Archive

We have refreshed PostSharp 2.0 CTP with a bunch of bug fixes and, most importantly, support for Visual Studio 2010 Beta 2 and .NET 4.0 Beta 2.

The PostSharp Add-In for Visual Studio currently don't work with Visual Studio 2010, but you should be able to build projects targetting all versions of the .NET Framework.

Note that the pipe server currently does not work with .NET 4.0.

Happy PostSharping!

-gael

Comments (5) -

Clement
Clement
11/4/2009 8:31:51 AM #

That's excellent news.
Is there any dates for Silverlight CTP yet ?

Cheers

Gael Fraiteur
Gael Fraiteur
11/7/2009 4:06:41 PM #

It will be probably in CTP 3 (after full support for VS 2010 and .NET 4.0), probably in December.

Alex Yakunin
Alex Yakunin
2/23/2010 11:43:45 PM #

Great news - we're going to migrate to .NET 4 as well.

Dan
Dan
4/23/2010 10:20:32 AM #

Is there a release that works with VS2010 RTM?

Gael Fraiteur
Gael Fraiteur
4/23/2010 10:23:43 AM #

AFAIK, build-time components already work with .NET 4.0 RTM, but the VS extension does not work completely with VS 2010 RTM. I'll publish the next and CTP next week.

Comments are closed