PostSharp 2.0 Documentation
Send Feedback

PostSharp helps software developers write clean, stable, efficient code. Thanks to PostSharp, you can achieve more with less lines of code, therefore less time, and less bugs. What is more, PostSharp makes your code more agile; your design will be more resilient to changes in requirements.

PostSharp empowers you to deliver better architecture, better code, better quality. Something a software craftsman can be proud of.

What's an Aspect?

Every developer knows how painful it is to implement non-functional requirements like transaction handling, tracing, caching, security, monitoring, or exception handling. Typically, the same implementation pattern has to be applied to hundreds of methods. And since the new code has to be intimately mixed with the existing one, traditional code generation frameworks are helpless.

That's where PostSharp comes to rescue.

PostSharp is an aspect-oriented framework: it makes it easy to develop custom attributes that really add new behaviors to the methods, fields, or types to which they are applied.

For instance, you can develop a custom attribute TraceAttribute calling System.Diagnostics.Trace. When you apply it to a method, the method really starts tracing! And if you apply it on a type, all methods of this type start trace!

So, what's an aspect? Basically, an aspect is a piece of code implementing behavior that can be applied to other pieces of codes. The aspect framework is responsible for injecting aspects into target code.

Read more about PostSharp Aspects.

How does it work?

PostSharp is a post-compiler. PostSharp enhances .NET assemblies just after the C# or VB compiler did its job, and add whatever functionality you tell it to add!

When you install PostSharp using the setup program, it is typically inserted in the build process of MSBuild. No other configuration is needed. If don't want to use to install PostSharp on your local problem, no problem: it's all explained in Deploying PostSharp.

In this documentation

Getting Started

So you decided to give it 15 more minutes. Here's a step-by-step guide to your first aspect.

What's New in PostSharp 2.0

PostSharp 1.5 made aspects popular in the .NET community. PostSharp 2.0 brings rock-solid foundations for professional aspect-oriented development. Learn about the features that make PostSharp the number-one choice for aspects in .NET.

Deploying PostSharp 2.0

It can be as easy as running the setup program, but there are a lot of options available to cope with complex situations: installation in source control, deployment of the license key for a large team... There's certainly a way to handle your development environment.

Using PostSharp Aspects

Now it's time for serious work. Learn the concepts and techniques to get productive with aspects and start building better code.

Examples

Thousands of pages of documentation would be worthless without a couple of commented examples.

Send comments on this topic to SharpCrafters

Copyright © SharpCrafters s.r.o., 2010. All rights reserved.


What's New in PostSharp 2.0?
Send Feedback

At SharpCrafters, we started to work on PostSharp even before SharpCrafters existed: in 2004. PostSharp 2.0 is the third major release of PostSharp (after 1.0 and 1.5) and makes PostSharp the most popular and by far the most advanced framework for aspect-oriented programming in .NET.

What's New In PostSharp 2.0?

PostSharp 1.0 and 1.5 made aspect-oriented programming (AOP) popular in the .NET community. PostSharp 2.0 makes it mainstream by enhancing convenience (Visual Studio Extension), reliability (dependency enforcement), run-time performance (optimizer), and features (composite aspects, property- and event-level aspects).

Visual Studio Extension

As developers start being comfortable with PostSharp and add more and more aspects to their code, two questions become manifest: How can I know to which elements of code my aspect has been applied? How can I know which aspects have been applied to the element of code I am looking at? Answering these two questions is precisely what the PostSharp Extension for Visual Studio 2008 and 2010 has been designed for. It provides two new features to the IDE: an Aspect Browser tool window, and new adornments of enhanced elements of code with clickable tooltip.

Composite Aspects (Advices and Pointcuts)

Part of the success of PostSharp 1.5 was due to its ability to introduce aspects without appealing to barbaric terms such as advices and pointcuts. So why to introduce them now? Because they make it easier to develop complex aspects. Thanks to advices and pointcuts, you can implement complex patterns such as observability awareness (INotifyPropertyChanged) with just a few lines of code. And just with PostSharp 1.5, you can still write your own aspects without knowing about advices and pointcuts.

Adaptive Code Generation

PostSharp 2.0 generates much smarter, faster, and smaller code than before. Let's face it: PostSharp 1.5 was quite dumb. It generated a lot of instructions that your aspects did not even need. PostSharp 2.0 analyzes your aspect to see which features are actually being used at runtime, and generates only instructions that support these features. Result: you could probably not write much faster code by hand.

Interception Aspect for Fields and Properties

PostSharp 2.0 comes with a new kind of aspect that handles fields and properties: LocationInterceptionAspect (in replacement of OnFieldAccessAspect). The aspect is much more usable than its predecessor; for instance, it is possible to call the field or property getter from the setter.

Interception Aspect for Events

The new aspect kind EventInterceptionAspect allows an aspect to intercept all event semantics: add, remove, and fire.

Aspect Dependencies

By enforcing aspect dependency rules, PostSharp ensures that aspects behave in a predictable and robust way, even when multiple aspects are applied to the same element of code. This feature is important for large and complex projects, where aspects may be written by different teams, or provided by numerous third-party vendors who don't know about each other.

Instance-Scoped Aspects

In PostSharp 1.5, all aspects had static scope, i.e. there was a single instance of the aspect for every element of code to which they apply. It is now possible to define aspects that have instance lifetime. For instance, if the aspect is applied to an instance field, a new instance of the aspect will be created for every instance of the type declaring the field. This is named an instance-scoped aspect.

Support for New Platforms

  • Microsoft .NET Framework 4.0
  • Microsoft Silverlight 3.0
  • Microsoft Silverlight 4.0
  • Microsoft Windows Phone 7 (Applications and Games)
  • Microsoft .NET Compact Framework 3.5
  • Novell Mono 2.6

Build Time Improvements

Just starting the CLR and loading system assemblies takes considerable time, too much for an application (such as PostSharp) that is typically started very frequently and whose running time is just a couple of seconds. To cope with this issue, PostSharp now preferably runs as a background application

What's New In PostSharp 1.5?

PostSharp 1.5 was published 3 years after the start of the project, and was the first release to be really production-ready.

Aspect Inheritance

It is now possible to put an aspect on an interface and have it implicitly applied to all classes implementing that interface. The same works with classes, virtual or interface methods, and parameters of virtual or interface methods. Read more...

Reading assemblies without loading them in the CLR

In version 1.0, PostSharp required assemblies to be loaded in the CLR (i.e. in the application domain) to be able to read them. This limitation belongs to the past. When PostSharp processes a Silverlight or a Compact Framework assembly, it is never loaded by the CLR.

Lazy loading of assemblies

When PostSharp has to load a dependency assembly, it now reads only the metadata objects it really needs, resulting in a huge performance improvement and much lower memory consumption.

Build-Time Performance Enhancement

The code has been carefully profiled and optimized for maximal performance.

Support for Novell Mono

PostSharp is now truly cross-platform. Binaries compiled on the Microsoft platform can be executed under Novell Mono. Both Windows and Linux are tested and supported. A NAnt task makes it easier to use PostSharp in these environments.

Support for Silverlight 2.0 and the Compact Framework 2.0

You can add aspects to your projects targeting Silverlight 2.0 or the Compact Framework 2.0. Read more...

Pluggable Aspect Serializer & Partial Trust

>Previously, all aspects were serializer using the standard .NET binary formatter. It is now possible to choose another serializer or implement your own, and enhance assemblies that be executed with partial trust. Read more...


Getting Started with PostSharp
See Also Send Feedback

PostSharp makes aspect-oriented programming easy. You can start writing your own aspect in a matter of minutes. Just follow the guide.

Prerequisites

  • Windows XP or higher.

  • Microsoft Visual Studio 2008 or 2010.

  • Administrative privileges.

  • 10 minutes of your time.

Getting Started with PostSharp

  1. Download the PostSharp setup program and execute it on your development machine.

    Note

    If you don't want to or cannot install software on your machine, you can download the zip package instead of the setup program, but then you have to enable PostSharp manually for your projects (see Deploying PostSharp into a Source Repository). We suggest that for your first experience with PostSharp, you use the setup program.

  2. Load one of your projects into Visual Studio 2008 or higher. Any project type will work, but for this example it's best to choose a console application. It doesn't matter whether you use C#, VB.NET, or another language: it will just work.

  3. Add a reference to PostSharp.dll to your project.

  4. Create a class and name it TraceAttribute; design the class just as if it were a custom attribute.

    CopyA plain old custom attribute
    public sealed class TraceAttribute : Attribute
{
  private readonly string category;

  public TraceAttribute(string category)
  {
    this.category = category;
  }

  public string Category { get { return category; }  }
}

  5. Since you are not developing an ordinary custom attribute but an aspect, include the namespace PostSharp.Aspects and make the class inherit OnMethodBoundaryAspect (which, itself, derives Attribute).

    CopyA PostSharp aspect adding no behavior
    using PostSharp.Aspects;

[Serializable]
public sealed class TraceAttribute : OnMethodBoundaryAspect
{
  private readonly string category;

  public TraceAttribute(string category)
  {
     this.category = category;
  }

  public string Category { get { return category; }  }
}

  6. Add the advices, i.e. the code that will be executed before and after the target method:

    CopyA PostSharp aspect adding new behaviors (advices)
    using PostSharp.Aspects;

[Serializable]
public sealed class TraceAttribute : OnMethodBoundaryAspect
{
  private readonly string category;

  public TraceAttribute(string category)
  {
    this.category = category;
  }

  public string Category { get { return category; }  }

  public override void OnEntry(MethodExecutionArgs args)
  {
    Trace.WriteLine(string.Format("Entering {0}.{1}.",
      args.Method.DeclaringType.Name, args.Method.Name), this.category);
  }

  public override void OnExit(MethodExecutionArgs args)
  {
    Trace.WriteLine(string.Format("Leaving {0}.{1}.",
      args.Method.DeclaringType.Name, args.Method.Name), this.category);
  }
}

  7. In your project, choose an existing method you want to log and decorate it with our aspect – remember it is a custom attribute.

    CopyAdding an aspect to existing code using a plain old custom attribute
    internal static class Program
{
  private static void Main()
  {
    Trace.Listeners.Add(new TextWriterTraceListener(Console.Out));

    SayHello();
    SayGoodBye();
  }

  [Trace("MyCategory")]
  private static void SayHello()
  {
    Console.WriteLine("Hello, world.");
  }

  [Trace("MyCategory")]
  private static void SayGoodBye()
  {
    Console.WriteLine("Good bye, world.");
  }
}

    If you want to trace the execution of every method in a namespace, you can use the following code:

    CopyAdding an aspect to several elements of code using attribute multicasting
    [assembly: Trace("MyCategory", AttributeTargetTypes = "My.BusinessLayer.*")]

  8. We are done. Compile and execute the project.

Next Steps

  • Run the program with the debugger and step into the execution of methods that have been enhanced by an aspect.

  • Open the program binary file using Reflector and look how it has been transformed by PostSharp.

See Also

Reference

OnMethodBoundaryAspect

Other Resources

Installing PostSharp on Development Machines
Deploying PostSharp into a Source Repository


Deploying PostSharp

Deploying PostSharp
Send Feedback

This chapter describes how to deploy PostSharp in a variety of situations.

Deploying programming tools in a large team of software developers is always difficult. PostSharp makes no exception. Because PostSharp is not a simple library, but an extension to MSBuild and Visual Studio, it has more complex installation requirements.

The easiest way to deploy PostSharp in a small team is simply to install it on every development machine using the setup program. However, this deployment strategy may not meet all requirements of larger teams. That's why PostSharp offers different deployment options.

Typical Requirements of Development Teams

Development teams typically have the following concerns while integrating third-party tools in their development process:

  • Deployment. How to deploy PostSharp to the computer of all developers? How to deploy upgrades? How to ensure that all developers use up-to-date version of the software?

  • Versioning. Since source code is versioned and is tightly coupled to PostSharp, how to ensure that an older branch of the source code will still build if a newer version of PostSharp has been deployed in the mean time?

  • Licensing. How to distribute license keys to all developers?

Deployment Strategies for PostSharp

There are, schematically, two deployment strategies for PostSharp:

  1. You install PostSharp on each computer. You can automate installation using solutions such as Microsoft System Center Configuration Manager or third-party software. This strategy is easy to execute, but does not meet the versioning requirements. For details, see Installing PostSharp on Development Machines.

  2. You copy PostSharp in your source repository. This strategy is more difficult to execute; it requires to modify every project file (*.csproj;*.vbproj) using a text editor. However, once this is done, all requirements (deployment, versioning and licensing) are completed. Note that it is not possible to deploy the Visual Studio Extension using this approach. For details, see Deploying PostSharp into a Source Repository.

Finally, there is a third strategy: you can deploy PostSharp to the source repository and install the Visual Studio on every computer. This approach fulfills all requirements, including versioning, since the Visual Studio Extension is not tightly coupled with build components.

In this section

  • Installing PostSharp on Development Machines

  • Disabling PostSharp for a Specific Project or Project Configuration

  • Deploying PostSharp into a Source Repository

  • Using PostSharp on a Build Server

  • Deploying License Keys for a Team

  • Installing Third-Party Add-Ins

  • ASP.NET


Installing PostSharp on Development Machines

Installing PostSharp on Development Machines
See Also Send Feedback

The setup program offers the smoothest installation experience and is the recommended way to get started. The current section addresses advanced issues related to the use of the setup program.

Understanding the Installation Process

The PostSharp setup program (a file typically named PostSharp-2.0.x.x.exe) is actually a self-extractable (SFX) archive containing a bootstrapper and a standard, fully compliant, Windows Installer package (MSI).

When you execute the setup program on your machine, the following actions occur:

  1. The self-extractable archive is uncompressed to a temporary directory.

  2. The bootstrapper program (setup.exe) is executed.

  3. The bootstrapper program determines which MSI package (PostSharp-x86.msi or PostSharp-x64.mxi) should be executed on the current computer.

  4. The bootstrapper program checks whether PostSharp is already installed, and if yes which version, and determines whether a small update can be executed. If yes, it launches Windows Installer with the command line msiexec.exe /fvomus PostSharp-Platform.msi. If not, it launches the command line msiexec.exe /i PostSharp-Platform.msi where Platform is x86 or x64.

  5. The MSI package installs files, registry settings, and schedules the creation of native (NGen) images for PostSharp assemblies.

  6. The MSI package creates or edits the following files (if applicable) to insert PostSharp in the standard MSBuild process:

    • C:\Program Files\MSBuild\v2.0\Custom.After.Microsoft.Common.targets

    • C:\Program Files\MSBuild\v3.5\Custom.After.Microsoft.Common.targets

    • C:\Program Files\MSBuild\v4.0\Custom.After.Microsoft.Common.targets

    • C:\Program Files (x86)\MSBuild\v2.0\Custom.After.Microsoft.Common.targets

    • C:\Program Files (x86)\MSBuild\v3.5\Custom.After.Microsoft.Common.targets

    • C:\Program Files (x86)\MSBuild\v4.0\Custom.After.Microsoft.Common.targets

    Tip

    If these files get overwritten by another installation program, you can regenerate them by using the utility PostSharp.Setup.exe included with PostSharp.

Note that the setup program creates two files that may help troubleshooting the installation process: %TEMP%\PostSharp 2.0 Setup.log and %TEMP%\PostSharp 2.0 Setup Custom Actions.log

Automating PostSharp Installation

PostSharp installation can be automated by the use of custom scripts or solutions such as Microsoft System Center Configuration Manager. Since PostSharp is packaged in a Windows-compliant MSI package, its automated installation can be customized easily.

To extract the MSI package into a temporary folder, execute the self-extractable program with the following command line:

PostSharp-2.0.0.0 /x

This command will open a new Windows Explorer window at the directory containing the installation files.

You can then use the utility msiexec.exe to install PostSharp silently, or can use any other deployment tool supporting MSI.

Note

PostSharp does not support deployment through Windows Server Group Policies, as it cannot be advertised as an icon. Advertising allows an application to be installed on demand when the user first clicks on its icon.

Understanding the Build-Time Discovery Mechanism

Once installed on your computer, PostSharp will automatically transform assemblies that contain aspects.

However, post-processing an assembly is expensive in CPU and memory resources. In a typical configuration, PostSharp may take the half of your whole build time (i.e., double the build time). Therefore, the operation should be performed only when it is needed.

How does PostSharp decide whether or not to process an assembly? This decision is actually taken inside MSBuild, even before PostSharp is started, based on the list of references of the current project. The first-line rule is simple: if an assembly has references, even indirectly, to PostSharp.dll, MSBuild will invoke PostSharp.

This discovery mechanism is really fast; actually, MSBuild already inspects the list of references in the normal C#/VB build process, so our detection has nearly no overhead. Therefore, performance is not a reason not to install PostSharp in the standard MSBuild process.

This strategy never misses an assembly that needs to be transformed, but can produce false positives. If PostSharp was asked to process an assembly, and found no relevant aspect in it, it will print a warning into Visual Studio recommending to disable PostSharp for this specific project.

You can learn about disabling PostSharp for a specific project in section Disabling PostSharp for a Specific Project or Project Configuration.

See Also

Other Resources

Disabling PostSharp for a Specific Project or Project Configuration


Disabling PostSharp for a Specific Project or Project Configuration

Disabling PostSharp for a Specific Project or Project Configuration
Send Feedback

As explained in Installing PostSharp on Development Machines, when PostSharp is installed on a computer, it will attempt to process any assembly referencing PostSharp.dll directly or indirectly.

However, it can happen that you have an assembly referencing PostSharp.dll, but that does not need to be processed by PostSharp.

The easiest way to disable PostSharp in a project is to define the compilation symbol (or constant) SkipPostSharp.

Alternatively, you can define an MSBuild property SkipPostSharp=True.

Therefore, it is possible to have a project with many build configurations and enable PostSharp in only some of these.


Deploying PostSharp into a Source Repository

Deploying PostSharp into a Source Repository
Send Feedback

PostSharp has been designed to provide out-of-the-box experience to end-users. If you install PostSharp using the setup program and if you follow the default options, you can start using PostSharp in your projects immediately. However, many companies chose to deploy PostSharp in the source repository. If this your case, you have to enable PostSharp manually by editing every project that requires PostSharp.

Copying PostSharp to a Source Repository and Modifying Project Files

  1. Download the zip distribution, uncompress it, and copy the files in the source repository. We recommend you put include all distributed files in the source repository, expect the directories Documentation and Samples.

    For the ease of later upgrades of PostSharp, avoid including the full version number of PostSharp in the name of the directory.

    The next steps have to be repeated for every project that needs to be enhanced by PostSharp.

  2. Open the project file (csproj, vbproj, ...) using a text editor. If your project is loaded in Visual Studio, open the Solution Explorer, right-click on the project name, click on Unload project, then right-click again on the same project and click on Edit.

  3. Locate the <Import .../> elements near to the end of the file. For instance, a C# 2.0 project should end with an element similar to this:

    Copy
    <Import Project="$(MSBuildBinPath)\Microsoft.CSharp.targets" />

  4. Before the import line, insert the following text:

    Copy
    <PropertyGroup>
   <DontImportPostSharp>True</DontImportPostSharp>
</PropertyGroup>

    This property is important in case that PostSharp is enabled globally on a machine. It prevents PostSharp global targets to be included in the project when C# or VB targets will be included. Since you can never be sure that PostSharp is not installed globally the machine of another developer working on the same project, it is a good practice to define the DontImportPostSharp before importing main C# / VB targets. Note that it is illegal to import PostSharp targets twice in a project; you will therefore get a build error if you accidently try to do so.

  5. After the C# / VB import line, insert the following text:

    Copy
    <Import Project="..\..\Third Party\PostSharp 2.0\PostSharp.targets" />

  6. Save the file. If the project was open in Visual Studio, go to the Solution Explorer, right-click on the project name, then click on Reload project.

After modification, the tail of your project files should look like this:

Copy
  <PropertyGroup>
    <DontImportPostSharp>True</DontImportPostSharp>
  </PropertyGroup>
  <Import Project="$(MSBuildBinPath)\Microsoft.CSharp.targets" />
  <Import Project="..\..\Third Party\PostSharp 2.0\PostSharp.targets" />
</Project>

Adding References to PostSharp.dll

Since PostSharp is not installed on your computer, it will not appear in the .NET tab of the Add Reference dialog box. Instead, you have to open the Browse tab and select PostSharp.dll from the relevant directory in source control.

Tip

It is recommended to select the file Reference Assemblies\.NET Framework 2.0\PostSharp.dll (instead of the same file from the Release directory) so that Intellisense finds the XML documentation related to this library.

Drawbacks of Running PostSharp from a Source Repository

When you run PostSharp from a Source Repository without installing it in your computer:

  1. The Visual Studio Extension, adding aspect-oriented GUI features to Visual Studio, will not work. As a result, developers' productivity may be suboptimal, especially in complex projects. See next section to learn how to install the Visual Studio Extension separately on developers' machines.

  2. Build-time performance of PostSharp may be lightly worse than when PostSharp is installed, because no native image (NGen) is created for PostSharp build-time components. This drawback is greatly mitigated by the use of the pipe server, a new feature of PostSharp 2.0.

Installing the Visual Studio Extension to Developers' Machines

PostSharp Extension for Visual Studio needs to be installed using the setup program. However, the Visual Studio Extension is completely decoupled from PostSharp build components. If you want to use the Visual Studio Extension but want to install PostSharp in the code repository, you may want to install just the extension on your computer.


Configuring PostSharp

Configuring PostSharp
Send Feedback

PostSharp accepts several configuration settings such as the version and processor architecture of the target CLR, the search path of dependencies, or simply the license key. Although the default value of settings are appropriate for most situations, you may have to fine-tune some of them to cope with particular cases.

Setting MSBuild Properties

Most configuration parameters of PostSharp can be changed by setting an MSBuild property. There are multiple ways to define an MSBuild property.

Using a command-line parameter of MSBuild

When an MSBuild property does not need to be set permanently, it is convenient to set is from the command prompt by appending the flag /p:PropertyName=PropertyValue to the command line of msbuild.exe, for instance:

Copy
msbuild.exe /v:detailed /p:PostSharpAttachDebugger=true /p:PostSharpBuild=Diag /p:PostSharpTrace=AspectWeaver

Editing the project file

To set a property that persistently applies to a specific project, but not to the whole solution, the best solution is to define it directly inside the C# or Visual Basic project file (*.csproj or *.vbproj, respectively) using a text editor.

Adding a project-level MSBuild property using Visual Studio

  1. Open the Solution Explorer, right-click on the project name, click on Unload project, then right-click again on the same project and click on Edit.

  2. Insert the following XML fragment just before the <Import /> elements:

    CopyXML
    <PropertyGroup>
   <PropertyName>PropertyValue</PropertyName>
</PropertyGroup>
    Note

    Since you are defining a standard MSBuild property, you are free to use all MSBuild features. For instance, you can use conditional elements to define properties specific to a given build configuration. See MSBuild configuration for details.

  3. Save the file. If the project was open in Visual Studio, go to the Solution Explorer, right-click on the project name, then click on Reload project.

Creating a file PostSharp.Custom.targets

Instead of editing every project file, you can define shared settings in a file named PostSharp.Custom.targets and store in the same directory as the project file or in any parent directory of the parent file (up to 7 levels from the project directory).

Files PostSharp.Custom.targets are loaded from the root directory to the project directory, so that files that are closer to the project directory are loaded after and override files in parent directories.

Thanks to this mechanism, it is possible to define settings that apply to a large set of projects and control the grain of settings.

Files PostSharp.Custom.targets are normal MSBuild project or targets files; they should have the following content:

CopyA sample PostSharp.Custom.targets file
<?xml version="1.0" encoding="utf-8" ?>
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
        <PostSharpLicenseKey>xxx</PostSharpLicenseKey>
   </PropertyGroup>
</Project>
Note

Since you are defining a standard MSBuild property, you are free to use all MSBuild features. For instance, you can use conditional elements to define properties specific to a given build configuration. See MSBuild configuration for details.

Setting an environment variable

All environment variables are imported as MSBuild properties. Therefore, if you define an environment variable named after an MSBuild property recognized by PostSharp, this property will be set for all projects executed on this machine (if it is a system-wide environment variable) or by this user (if it is a user-wide environment variable). You can define environment variables locally using the Windows control panel, or globally using Windows Server Group Policies.

Important

If you are not sure which processes to restart (typically Visual Studio, command prompts, PostSharp pipe servers, build services), you need to log off and log on again after setting or changing an environment variable.

List of MSBuild Properties Used by PostSharp

Most configuration settings of PostSharp can be set as MSBuild properties. The following table lists the MSBuild properties used by PostSharp.

MSBuild properties influencing the choice of the host process

Because PostSharp not only reads, but also execute the assemblies it transform, it must run under the proper version and processor architecture of the CLR. Additionally, for each version and processor architecture. The following properties allow to influence the choice of the PostSharp host process.

Property Name

Description

PostSharpTargetFrameworkVersion

Version of the hosting CLR. Valid values are 2.0 and 4.0. By default, the value of this property is chosen according to the target framework version of the project.

PostSharpTargetProcessor

Processor architecture of the hosting process. Valid values are x86 and x64. By default, the value of this property is chosen according to the target platform of the project. If the target platform is AnyCPU, the architecture of the current machine will be chosen.

PostSharpTargetPlatform

A combination of properties PostSharpTargetFrameworkVersion and PostSharpTargetPlatform, for instance 2.0-x86. If set manually, this property has precedence over PostSharpTargetFrameworkVersion and PostSharpTargetPlatform.

PostSharpHost

Kind of process hosting PostSharp. The following values are supported:

  • PipeServer means that PostSharp will run as a background process invoked synchronously from MSBuild. Using the pipe server results in lower build time, since PostSharp would otherwise have to be started every time a project is built. The pipe server uses native code and the CLR Hosting API to control the way assemblies are loaded in application domains; the assembly loading algorithm is generally more accurate and predictable than with the managed host.

  • Native uses than the same native code as the pipe server, but the process runs synchronously and terminates immediately after an assembly has been processed. For this reason, it does not have the same build-time performance as the pipe server, but it has exactly the same assembly loading algorithm and is useful for diagnostics.

  • Managed is a purely managed application. The assembly loading algorithm may be less reliable in some situations because PostSharp has less control over it. However, it is the same algorithm as the one of PostSharp 1.5. The managed host is the only one that runs on Mono.

PostSharpBuild

Build configuration of PostSharp. Valid values are Release, Diag and Debug (the latest is not publicly distributed; only owners of a source code subscription can produce a debug build). For details, see Using PostSharp Diagnostic Build.

PostSharpDisableReflection

If this property is set to True, PostSharp will not load user assemblies in the CLR. Instead, it will read them directly from disk. Some features of PostSharp are not available when user assemblies are not loaded in the CLR. By default, this property is set to False for projects targeting the .NET Framework or Mono, and True for non-native platforms (Silverlight, Compact Framework, Windows Phone).

PostSharpAssemblyBindingPolicySet

Name of the set of assembly binding policies used to map reflection elements of the native platform to metadata elements of the target platform, or an empty string if no assembly binding policy should be used (which is typically the case if the target platform is identical to the native platform). Valid values are CompactFramework20, CompactFramework35 and Silverlight20 according to the target platform (the later set is used for all versions of Silverlight, including Windows Phone). Other sets may be defined in PostSharp-Platform.config or in a PostSharp project file (*.psproj).

MSBuild properties for PostSharp diagnostics

Property Name | Description
PostSharpAttachDebugger | If this property is set to True, PostSharp will break before starting execution, allowing you to attach a debugger to the PostSharp process. The default value is False. For details, see Debugging Compile-Time Logic.
PostSharpTrace | A semicolon-separated list of trace categories to be enabled. The property is effective only when PostSharp runs in diagnostic mode (see property PostSharpBuild here above). Additionally, the MSBuild verbosity should be set to detailed at least. For details, see Debugging Compile-Time Logic.
PostSharpUpdateCheckDisabled | True if the periodic update check mechanism should be disabled, False otherwise.
PostSharpExpectedMessages | A semicolon-separated list of codes of expected messages. PostSharp will return a failure code if any expected message was not emitted. This property is used in unit tests of aspects, to ensure that the application of an aspect results in the expected error message.
PostSharpIgnoreError | If this property is set to True, the PostSharp20 MSBuild task will succeed even if PostSharp returns an error code, allowing the build process to continue. The project or targets file can check the value of the ExitCode output property of the PostSharp20 to take action.
PostSharpFailOnUnexpectedMessage | This property should be used jointly with PostSharpExpectedMessages. If it set to True, PostSharp will fail if any unexpected message was emitted, even if this message was not an error. This property is used in unit tests of aspects, to ensure that the application of an aspect did not result in other messages than expected.

Other MSBuild properties recognized by PostSharp

Property Name | Description
PostSharpSearchPath | A semicolon-separated list of directories added to the PostSharp search path. PostSharp will probe these directories when looking for an assembly or an add-in. Note that several directories are automatically added to the search path: the .NET Framework reference directory, the directories containing the dependencies of your project and the directories added to the reference path of your project (tab Reference Path in the Visual Studio project properties dialog box).
PostSharpProject | Location of the PostSharp project (*.psproj) to be executed by PostSharp, or the string None to specify that PostSharp should not be invoked. If this property is defined, the standard detection mechanism based on references to the PostSharp.dll is disabled. If this
PostSharpLicenseKey | License key. See Deploying License Keys for a Team.
PostSharpLicenseFile | Path of a text file containing the license key. Ignored if the PostSharpLicenseKey property is defined. By default, set to $(APPDATA)\PostSharp 2.0\PostSharp.license. See Deploying License Keys for a Team
PostSharpProperties | Additional properties passed to the PostSharp project, in format Name1=Value1;Name2=Value2. See below.

PostSharp Properties

The previous section listed properties that are understood by PostSharp but must be defined as MSBuild properties. Additionally, PostSharp has its own system of properties. A project can pass properties to PostSharp by setting the MSBuild property PostSharpProperties.

For instance, the following MSBuild project fragment defines the PostSharp property IgnoredAssemblies:

CopyDefining a PostSharp properties in MSBuild
<PropertyGroup>
  <PostSharpProperties>
    $(PostSharpProperties);
    IgnoredAssemblies=ObfuscatedThirdPartyLib1,ObfuscatedThirdPartyLib2
  </PostSharpProperties>
</PropertyGroup>

The following table lists the PostSharp property that may be set from the MSBuild project:

Property Name | Description
IgnoredAssemblies | Comma-separated list of assembly short names (without extension) that should be ignored by the dependency scanning algorithm. Add an assembly to this list if it is obfuscated, or contains native code, and causes PostSharp to fail.

Reading PostSharp properties from aspect code

You can read the value of any PostSharp property thanks to the following piece of code:

Copy
string value = PostSharpEnvironment.Current.CurrentProject.EvaluateExpression("$(PropertyName)")

Additionally to the PostSharp properties listed above, you can read the value of the following properties:

Property Name | Description
MSBuildProjectFullPath | Full path of the MSBuild project (typically with extension *.csproj or *.vbproj) being built.
Configuration | Configuration being built (typically Debug or Release).
Platform | Platform being built (typically AnyCPU, x86 or x64).
Tip

To pass information from the C# or Visual Basic project to your aspect, you can define a custom PostSharp property and read its value from the aspect.


Deploying License Keys for a Team

Deploying License Keys for a Team
Send Feedback

Many software publishers seem to love cumbersome licensing systems. In an attempt to prevent illegal use of their software, they make it extremely difficult for truly legitimate customers to use their product. SharpCrafters is different. We know how hard it is of maintaining a development environment, we are aware that PostSharp adds complexity, and we don't think the licensing system should be allowed to make things worse.

If you don't want every user to enter the license key manually, you can deploy a PostSharp license into your source repository, or you can do it using Active Directory (group policies).

Deploying the License Key to the Source Repository

You can configure the license key as any other configuration parameter in PostSharp: by setting an MSBuild property. So all you have to do is to set an MSBuild property named PostSharpLicenseKey and containing the license key.

For details about setting MSBuild properties, see Configuring PostSharp.

The easiest way to deploy the license key to your source repository is to create a file named PostSharp.Custom.targets (in a directory that is a common parent of all projects using C#), with the following content:

CopySetting the license key in PostSharp.Custom.targets
<?xml version="1.0" encoding="utf-8" ?>
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
        <LicenseKey>
          42586-AUKU2QDSKJF49TU90GUDF9JGD9GJ09E4JDOPGJDFOPGK034I5T90TUEJGP
          OSKFKSAFPFK09T50E4T90EOTGAERO0ERIG0DDVDKGPODFKGPODKGPAQUPASKJAQQ
        </LicenseKey>
   </PropertyGroup>
</Project>

Then check this file into your source repository.

Deploying the License Key to the Registry

If for any reason you don't want to deploy the license key to the source repository, you can write it to the Windows registry. The benefit of this approach is that it can easily be automated using Active Directory (group policies). The characteristics of this registry value are the following:

  • Registry key name: HKEY_LOCAL_MACHINE\SOFTWARE\SharpCrafters\PostSharp 2.0 of the 32-bit registry hive (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SharpCrafters\PostSharp 2.0 on a 64-bit OS).

  • Registry value name: LicenseKey (String).

  • Value: the license key without spaces and line breaks.


Using PostSharp on a Build Server

Using PostSharp on a Build Server
See Also Send Feedback

Since PostSharp is a part of the build process, it should be installed on any build server. Some registry tweaks force PostSharp to disable its minimalistic user interface and run in unattended mode.

Integrating PostSharp with a Build Server

PostSharp can be installed on a build server using the same approaches as on other development machines. See Installing PostSharp on Development Machines and Deploying PostSharp into a Source Repository for details.

Most build servers for Microsoft .NET rely on MSBuild to compile projects. Since PostSharp is itself an extension to MSBuild, no other integration is necessary.

Preventing the PostSharp GUI to be Shown

PostSharp has a minimal user interface for license warnings, CEIP, and exception handling. Normally, PostSharp will not open the user interface if it detects that it is running in unattended mode.

PostSharp uses the property Environment..::.UserInteractive to determine whether the process is attended or not. If, for some reason, this detection gives unsuccessful, you can forbid the pipe server to open the tray icon by setting the following machine-level registry setting:

  • Registry key name: HKEY_LOCAL_MACHINE\SOFTWARE\SharpCrafters\PostSharp 2.0 in the 32-bit registry hive (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SharpCrafters\PostSharp 2.0 on a 64-bit OS).

  • Value name: TrayIconDisabled (DWORD).

  • Value: 1.

Installing a License on the Build Server

Build servers don’t need their own license. PostSharp will not attempt to enforce licensing if it detects that it runs in unattended mode. PostSharp uses the property Environment..::.UserInteractive to detect whether the process is attended. The TrayIconDisabled registry setting has no effect on license check.

If this check does not work for any reason, you may use the license key of any licensed user for the build server. This will not be consider a license infringement.

When you install the license with the PostSharp user interface, the license key is actually written in the roaming profile of the current user. Therefore, you have to install the license key when logged as the user under which the build service is executed.

If the build service runs under the identity of a non-interactive account (such as the system account or a service account), you have to install the license key in another way, as described in section Deploying License Keys for a Team.

See Also

Other Resources

Installing PostSharp on Development Machines
Deploying PostSharp into a Source Repository
Deploying License Keys for a Team


Installing Third-Party Add-Ins

Installing Third-Party Add-Ins
Send Feedback

Plug-ins are typically composed of one manifest file (an XML file with extension .psplugin), one or more assemblies containing the public interface of the feature, and one or more assemblies containing the features implementation.

For most scenarios, PostSharp supports the so-called xcopy deployment. It is often enough to copy or uncompress the plug-in to a well-known directory.

The plug-in should be contained in a subdirectory whose name equals the name of the manifest file. For instance, if the name of the manifest file is MyPlugIn.psplugin, the name of the subdirectory should be MyPlugin, and the full path of this directory may be, for instance, C:\Program Files\PostSharp 2.0\PlugIns\MyPlugIn. See below for other possible target directories.

Installation into Well-Known Directories

When searching for a plug-in, PostSharp probes the following directories. If you install a plug-in in one of these directories, it will be automatically found by PostSharp.

  • The PlugIns subdirectory of the PostSharp directory, for instance C:\Program files\PostSharp 2.0\PlugIns if PostSharp is installed on your computer).

  • The subdirectory PostSharp 2.0\PlugIns of your user local application data (%LOCALAPPDATA%\PostSharp 2.0\PlugIns on Windows Vista and superior).

Installation into Custom Directories

You can install the plug-ins into any other directory, but you need to include this directory in the search path. There are two ways to include a directory in PostSharp's search path:

  • Add the path to the MSBuild property PostSharpSearchPath. See Configuring PostSharp to learn how to configure MSBuild properties.

  • Add the path to the Reference Path tab of Visual Studio project properties. Note that this setting is stored in the user-specific configuration file (*.csproj.user) and is typically not stored in source control.


Developing with PostSharp Aspects

Developing with PostSharp Aspects
Send Feedback

PostSharp makes aspect-oriented programming easy.

All you have to do is to derive a custom attribute and to apply it to methods using wildcards. PostSharp Aspects users only need a superficial knowledge of System.Reflection.

The objective of PostSharp is to bring aspects to people who do not even know what an aspect is. Everyone in .NET knows that a custom attribute is "something that modifies a behavior" and PostSharp allows to modify add behaviors to code in a natural way.

But raising appetite is not enough. As developers become more familiar with aspects, PostSharp smoothly grows in complexity by providing advanced features and a robust approach and disciplined approach to aspect-oriented programming.

In this Chapter

This chapter gives a conceptual overview of the PostSharp aspect framework. It starts by explaining how to develop simple aspects and progressively introduces new concepts and features.

  • Developing Simple Aspects

  • Understanding Aspect Lifetime and Scope

  • Validating Aspects

  • Initializing Aspects

  • Developing Complex Aspects

  • Coping with Several Aspects on the Same Target

  • Interception Aspects


Developing Simple Aspects

Developing Simple Aspects
Send Feedback

In PostSharp, developing an aspect is as simple as deriving a primitive aspect class and overriding some special methods named advice. Aspects encapsulate a transformation of an element of code (such as a method or a property), and advices are the methods that are executed at runtime.

For instance, the effect of the aspect OnMethodBoundaryAspect is to wrap the target method into a try/catch/finally construct, and the advices of this aspect are OnEntry(MethodExecutionArgs), OnSuccess(MethodExecutionArgs), OnException(MethodExecutionArgs) and OnExit(MethodExecutionArgs)

By default, advices of primitive aspect types have an empty implementation, so the aspect has no effect until you override at least one advice.

Procedure: Developing a Simple Aspect

  1. Make sure your project has a reference to PostSharp.dll.

  2. Create a new class and make it derive from one of the primitive aspect classes (see below).

  3. Annotate the class with the custom attribute SerializableAttribute. See Understanding Aspect Lifetime and Scope to understand why,

  4. Override one of the aspect advices.

Aspect Classes

The following table gives a list of available primitive aspect classes. Every aspect class is described in greater detailed in the class reference documentation.

Aspect Type | Targets | Description
OnMethodBoundaryAspect | Methods | Methods enhanced with an OnMethodBoundaryAspect are wrapped by a try/catch/finally construct. This aspect provides the advices OnEntry(MethodExecutionArgs), OnSuccess(MethodExecutionArgs), OnException(MethodExecutionArgs) and OnExit(MethodExecutionArgs); these advices are invoked directly from the transformed method. the return value, and the exception (if applicable). This aspect is useful to implement tracing or transaction handling, for instance.
OnExceptionAspect | Methods | Methods enhanced with an OnExceptionAspect are wrapped by a try/catch construct. This aspect provides the advice OnException(MethodExecutionArgs); this advice is invoked from the catch block. This aspect is useful to implement exception handling policies. Contrarily to OnMethodBoundaryAspect, this aspect lets you define the type of caught exceptions by overriding the method GetExceptionType(MethodBase)
MethodInterceptionAspect | Methods | When a method is enhanced by a MethodInterceptionAspect, all calls to this method are replaced by calls to OnInvoke(MethodInterceptionArgs), the only advice of this aspect type. This aspect is useful when the execution of target method can be deferred (asynchronous calls), must be dispatched on a different thread.
LocationInterceptionAspect | Fields, Properties | When a field or property is enhanced by a LocationInterceptionAspect, all calls to its accessors are replaced by calls to advices OnGetValue(LocationInterceptionArgs) and OnSetValue(LocationInterceptionArgs). Fields are transparently replaced by properties. This aspect is useful to implement functionalities that need to get or set the location value, such as the observability design pattern (INotifyPropertyChanged).
EventInterceptionAspect | Events | When an event is enhanced by an EventInterceptionAspect, all calls to its add and remove semantics are replaced by calls to advices OnAddHandler(EventInterceptionArgs) and OnRemoveHandler(EventInterceptionArgs). Additionally, when the event is fired, even of invoking directly the handlers that were added to the event, the advice OnInvokeHandler(EventInterceptionArgs) is called instead. This aspect is useful to add functionalities to events, such as implementing asynchronous events or materialized list of subscribers.
CompositionAspect | Types | This aspect introduces an interface into a type by composition. The interface is introduced statically; the aspect method GetPublicInterfaces(Type) should return the type of introduced interfaces. However, the object implementing the interface is created dynamically at runtime by the implementation of the method CreateImplementationObject(AdviceArgs).
CustomAttributeIntroductionAspect | Any | This aspect introduces a custom attribute on any element of code. A custom attribute can be represented as a CustomAttributeData or a ObjectConstruction.
ManagedResourceIntroductionAspect | Assemblies | This aspect introduces a managed resource into the current assembly.
Tip

The implementation of aspects OnMethodBoundaryAspect and OnExceptionAspect is very efficient; they should be preferred over other aspects whenever it makes sense.

Using Aspect Interfaces

The primitive aspect classes listed above only exist for convenience. In reality, PostSharp only understands interfaces. Every of these aspect classes implement a pair of interfaces. For instance, the class OnMethodBoundaryAspect implements the interfaces IOnMethodBoundaryAspect and IMethodLevelAspectBuildSemantics.

The aspect classes are more convenient because they derive from MulticastAttribute, which extends System..::.Attribute with multicasting capability. See [5a11218e-fba7-427f-adc2-e656e0758848] for details.

If you do not need or want the capabilities of MulticastAttribute (for instance because the aspect is not used as a custom attribute, see IAspectProvider), you can implement the aspect interface manually. An aspect class must implement an interface derived from IAspect, and may implement an interface derived from IAspectBuildSemantics. Please refer to the documentation of the aspect class to get information about the corresponding aspect interface.

Additionally to the aspect interface corresponding to an aspect class, you can define the following interfaces on aspect classes:

Aspect Interface | Description
IAspectProvider | This interface defines a single method ProvideAspects(Object), returning a collection of AspectInstance. The method allows an aspect to dynamically provide other aspects to the weaver.
IInstanceScopedAspect | By default, aspects have static scope: there is one instance of the aspect per target class. Implementing the IInstanceScopedAspect makes the aspect instance-scoped: there will be one instance of this aspect per instance of the target class.


Applying Aspects to Code

Applying Aspects to Code
Send Feedback

An aspect has no effect until it is applied to some element of code. PostSharp provides multiple ways to add aspects to your code.

Applying Aspects to a Single Element of Code

Aspects in PostSharp are plain custom attributes. You can apply them to any element of code as usually.

In the following example, the Trace aspect is applied to two methods.

CopyApplying an aspect using a custom attribute
public class CustomerService
{
    [Trace]
    public Custom GetCustomer( int customerId )
    {
        // Details skipped.
    }

    [Trace]
    public void MergeCustomers( Customer customer1, Customer customer2 );
    {
        // Details skipped.
    }
}

Applying Aspects to Multiple Elements of Code Declaratively

In many situations, you want to apply the same aspect to many elements of code. For instance, you may need to add tracing or performance monitoring to all public methods of a namespace. Since there may be hundreds of affected methods, you don't want to add a custom attribute to all of them.

Thanks to an extension of semantics of custom attributes named multicast custom attribute (MulticastAttribute), it is easy to apply an aspect to multiple elements of code using a single line of code.

For details, see Applying Aspects to Multiple Code Elements and Applying Aspects to Derived Code Elements.

Applying Aspects to Multiple Elements of Code Imperatively

If declarative features of MulticastAttribute are not sufficient for your case, you can select elements of code imperatively. For instance, you can develop complex filters based on System.Reflection or read information from an XML file.

There are two ways you can implement imperative selection aspect targets:

Filtering Out Using CompileTimeValidate

To filter out elements of codes that have been selected by MulticastAttribute, you can implement the method CompileTimeValidate()()() of your aspect and silently return false if the candidate target is not appropriate. .

For instance, the following aspect will apply only on security-critical methods.

CopyFiltering out aspect targets using CompileTimeValidate
using System;
using System.Reflection;
using PostSharp.Aspects;

namespace Samples2
{
    [Serializable]
    public sealed class TraceSecurityCriticalAttribute : OnMethodBoundaryAspect
    {
        // Select only security-critical methods.
        public override bool CompileTimeValidate( MethodBase method )
        {
            return method.IsSecurityCritical;
        }

        public override void OnEntry( MethodExecutionArgs args )
        {
            Console.WriteLine( "On Entry" );
        }
    }
}

See Validating Aspects for details

Adding Aspect Instances Using IAspectProvider

If you have to implement more complex rules to select the target of aspects, you can create another aspect that will do nothing else than adding aspect instances to your code. This aspect must implement the interface IAspectProvider and will typically derive from AssemblyLevelAspect or TypeLevelAspect.


Applying Aspects to Multiple Code Elements

Applying Aspects to Multiple Code Elements
See Also Send Feedback

In .NET, you normally need to write one line of code for any application of a target attributes. If a custom attribute applies to all types of a namespace, you have to manually add the custom attribute to every single type.

By contrast, multicast custom attributes allow you to apply a custom attributes on multiple declarations from a single line of code by using wildcard or regular expressions, or by filtering on some attributes. It makes it easy to apply an aspect to, say, all public static methods of a namespace, with a single line of code.

Multicast attributes can be inherited: you can put it on an interface and ask it to apply to all classes implementing this interface. Attribute inheritance also works for classes, virtual or interface methods, and parameters of virtual or interface methods.

Custom attributes supporting multicasting needs to be derived from MulticastAttribute All PostSharp aspects are derived from this class.

Note

Multicasting of custom attribute is a feature of PostSharp. If you do not transform your assembly using PostSharp, multicast attributes will behave as plain old custom attributes.

Default Multicasting Algorithm

Multicast custom attributes have a set of valid targets: types, methods, fields, properties, or events. For instance, a caching aspect targets methods. A field validation aspect targets fields.

When a field-level multicast attribute is applied to a type, the attribute is implicitly applied to all fields of that type. When it is applied on an assembly, it is implicitly applied to all fields of that assembly.

The general rule is: when a multicast attribute is applied on a container, it is implicitly (and recursively) applied to all elements of that container.

The next table illustrates how this rule translates for different kinds of targets.

Directly applied to | Implicitly applied to
Assembly or Module | Types, methods, fields, properties, and events contained in this assembly or module.
Type | Methods, fields, properties, and events contained in this type.
Property or Event | Accessors of this property or event.
Method | This method and the parameters of this method.
Field | This field.
Parameter | This parameter.

Filtering Target Elements of Code

Note that the default behavior is maximalist: we apply the attribute to all contained elements. However, PostSharp provides a way to restrict the set of elements to which the attribute is multicast: filtering.

Both the attribute developer and the user of the aspect can specify filters.

Developer-Specified Filtering

Just like normal custom attributes should be decorated with the [AttributeUsage] custom attribute, multicast custom attributes must be decorated by the [MulticastAttributeUsage] attribute (see MulticastAttributeUsageAttribute). It specifies which are the valid targets of the multicast attributes.

For instance, the following piece of code specifies that the attribute GuiThreadAttributecan be applied on instance methods. Aspect users experience a build-time error when trying to use this aspect on a constructor or static method.

CopyRestricting an aspect to be applied on instance methods
[MulticastAttributeUsage(MulticastTargets.Method, TargetMemberAttributes = MulticastAttributes.Instance)]
[AttributeUsage(AttributeTargets.Assembly|AttributeTargets.Class|AttributeTargets.Method, AllowMultiple = true)]
[Serializable]
public class GuiThreadAttribute : MethodInterceptionAspect
{
// Details skipped.
}

Note the presence of the AttributeUsageAttribute attribute in the sample above. It tells the C# or Visual Basic compiler that the attribute can be directly applied to assemblies, classes, constructors, or methods. But this aspect will never be eventually applied to an assembly or a class. Indeed, the MulticastAttributeUsageAttribute attribute specifies that the sole valid targets are methods. Furthermore, the TargetMemberAttributes property establishes a filter that includes only instance methods.

Therefore, if the aspect is applied on a type containing an abstract method, the aspect will not be multicast to this method, neither to its constructors.

Tip

Additionally to multicast filtering, consider using programmatic validation of aspect usage. Any custom attribute can implement IValidableAnnotation to implement build-time validation of targets. Aspects that derive from Aspect already implement these interfaces: your aspect can override the method CompileTimeValidate(Object).

Tip

As an aspect developer, you should enforce as many restrictions as necessary to ensure that your aspect is only used in the way you intended, and raise errors in other cases. Using an aspect is used in an unexpected way may result in runtime errors that are difficult to debug.

User-Specified Filtering

The attribute user can specify multicasting filters using specific properties of the MulticastAttribute class. To make it clear that these properties only impact the multicasting process, they have the prefix Attribute.

As an aspect user, it is important to understand that you can only apply aspects to elements of codes that have been allowed by the developer of the aspect.

For instance, the following element of code adds a tracing aspect to all public methods of a namespace:

CopyApplying an aspect to several types methods in a single line of code
[assembly: Trace( AttributeTargetTypes="AdventureWorks.BusinessLayer.*", AttributeTargetMemberAttributes = MulticastAttributes.Public )]

Filtering Properties

The following table lists the filters available to users and developers of aspects:

MulticastAttributeUsageAttribute Property | MulticastAttribute Property | Description
AttributeTargetElements | ValidOn | Restricts the kinds of targets (assemblies, classes, value types, delegates, interfaces, properties, events, properties, methods, constructors, parameters) to which the attribute can be indirectly applied.
AttributeTargetAssemblies |  | Wildcard expression or regular expression specifying to which assemblies the attribute is multicast.
 | AllowExternalAssemblies | Determines whether the aspect can be applied to elements defined in a different assembly than the current one.
AttributeTargetTypes |  | Wildcard expression or regular expression filtering by name the type to which the attribute is applied, or the declaring type of the member to which the attribute is applied.
AttributeTargetTypeAttributes | TargetTypeAttributes | Restricts the visibility of the type to which the aspect is applied, or of the type declaring the member to which the aspect is applied.
AttributeTargetMembers |  | Wildcard expression or regular expression filtering by name the member to which the attribute is applied.
AttributeTargetMemberAttributes | TargetMemberAttributes | Restricts the attributes (visibility, virtuality, abstraction, literality, ...) of the member to which the aspect is applied.
AttributeTargetParameters |  | Wildcard expression or regular expression specifying to which parameter the attribute is multicast.
AttributeTargetParameterAttributes | TargetParameterAttributes | Restricts the attributes (in/out/ref) of the parameter to which the aspect is applied.
AttributeInheritance | Inheritance | Specifies whether the aspect is propagated along the lines of inheritance of the target interface, class, method, or parameter (see Applying Aspects to Derived Code Elements).
Caution

Whenever possible, do not rely on naming conventions to apply aspects (properties AttributeTargetTypes, AttributeTargetMembers and AttributeTargetParameters). This may work perfectly today, and break tomorrow if someone renames an element of code without being aware of the aspect.

Overriding Filtering Attributes

Suppose we have two classes A and B, B being derived from A. Both A and B can be decorated with MulticastAttributeUsageAttribute. However, since B is derived from A, filters on B cannot be more permissive than filters on A.

In other words, the MulticastAttributeUsageAttribute> custom attribute is inherited. It can be overwritten in derived classes, but derived class cannot enlarge the set of possible targets. They can only restrict it.

Similarly (and hopefully predictably), the aspect user is subject to the same rule: she can restrict the set of possible targets supported by the aspect, but cannot enlarge it.

See Also

Reference

MulticastAttribute
MulticastAttributeUsageAttribute
IAspectProvider

Other Resources

Overriding and Removing Aspect Instances
Reflecting Aspect Instances at Runtime


Applying Aspects to Derived Code Elements

Applying Aspects to Derived Code Elements
See Also Send Feedback

Thanks to aspect inheritance, you can put a aspect on an interface and have it implicitly applied on all classes implementing that interface. The same work with classes, virtual or interface methods, and parameters of virtual or interface methods.

Aspect inheritance is especially useful for validation: it is possible to annotate interfaces or abstract classes with constraints, and have their implementations automatically checking the constraint. The following code snippet illustrate how validation aspects can be used on interfaces (supposing that the NotNull and NotEmpty aspects both derive from MulticastAttribute and have inheritance enabled:

CopyAn interface defines NotNull and NotEmpty constraints with inherited aspects.
public interface IDiary
{
  Contact TryFindContact([NonEmpty] string name);

  [return: NonNull]
  Contact FindContact([NonEmpty] string name);

  void Update([NotNull] Contact contact);
}

Lines of Inheritance

Aspect inheritance is supported on the following elements.

Aspect Applied On | Aspect Propagated To
Interface | Any class implementing this interface or any other interface deriving this interface.
Class | Any class derived from this class.
Virtual or Abstract Methods | Any method implementing or overriding this method.
Interface Methods | Any method implementing that interface semantic.
Parameter or Return Value of an abstract, virtual or interface method | The corresponding parameter or to the return value of derived methods using the method-level rules described above.
Assembly | All assemblies referencing (directly or not) this assembly.
Note

Aspect inheritance is not supported on events and properties, but it is supported on event and property accessors. The reason of this limitation is that there is actually nothing like “event inheritance” or “property inheritance” in MSIL (events and properties have nearly no existence for the CLR: these are pure metadata intended for compilers). Obviously, aspect inheritance is not supported on fields.

Enabling Aspect Inheritance

Custom attribute inheritance can be enabled:

  • By the aspect developer using the property MulticastAttributeUsageAttribute..::.Inheritance.

  • By the aspect user using the property MulticastAttribute..::.AttributeInheritance.

The MulticastAttributeUsageAttribute..::.Inheritance property follows the same overriding rule as other properties of the MulticastAttribute: if it has been defined at an upper level, it cannot be overridden.

Strict and Multicast Inheritance

To understand the difference between strict and multicast inheritance, remember the original role of MulticastAttribute: to propagate custom attributes along the lines of containment. So, if you apply a method-level attribute to a type, the attribute will be propagated to all the methods of this types (some methods can be filtered out using specific properties of MulticastAttribute, or MulticastAttributeUsageAttribute; see Applying Aspects to Multiple Code Elements for details).

The difference between strict and multicasting inheritance is that, with multicasting inheritance (but not with strict inheritance), even inherited attributes are propagated along the lines of containment.

Consider the following piece of code, where A and B are both method-level aspects.

CopyComparing strict and multicast aspect inheritance
[A(AttributeInheritance = MulticastInheritance.Strict)]
[B(AttributeInheritance = MulticastInheritance.Multicast)]
public class BaseClass
{
  // Aspect A, B.
  public virtual void Method1();
}

public class DerivedClass : BaseClass
{
  // Aspects A, B.
  public override void Method1() {}

  // Aspect B.
  public void Method2();
}

If you just look at BaseClass, there is no difference between strict and multicasting inheritance. However, if you look at DerivedClass, you see the difference: only aspect B is applied to MethodB.

The multicasting mechanism for aspect A is the following:

  1. Propagation along the lines of containment from BaseClass to BaseClass.Method1.

  2. Propagation along the lines of inheritance from BaseClass.Method1 to DerivedClass.Method.

For aspect B, the mechanism is the following:

  1. Propagation along the lines of containment from BaseClass to BaseClass.Method1.

  2. Propagation along the lines of inheritance from BaseClass::Method1 to DerivedClass.Method2.

  3. Propagation along the lines of inheritance from BaseClass to DerivedClass.

  4. Propagation along the lines of containment from DerivedClass to DerivedClass.Method1and DerivedClass.Method2.

In other words, the difference between strict and multicasting inheritance is that multicasting inheritance applies containment propagation rules to inherited aspects; strict inheritance does not.

Avoiding Duplicate Aspects

If you read again the multicasting mechanism for aspect B, you will notice that the aspect B is actually applied twice codeInline DerivedClass.Method1: one instance comes from the inheritance propagation from BaseClass.Method1, the other instance comes from containment propagation from DerivedClass.

To avoid surprises, PostSharp implements a mechanism to avoid duplicate aspect instances. The rule: if many paths lead from the same custom attribute usage to the same target element, only one instance of this custom attribute is applied to the target element.

Attention: you can still have many instances of the same custom attribute on the same target element if they have different origins (i.e. they originate from different lines of code, typically). You can enforce uniqueness of custom attribute instances by using AllowMultiple. See Overriding and Removing Aspect Instances for details.

See Also

Reference

MulticastAttribute
MulticastAttributeUsageAttribute


Overriding and Removing Aspect Instances

Overriding and Removing Aspect Instances
Send Feedback

Having multiple instances of the same aspect on the same element of code is sometimes a desired behavior. With multicasting custom attributes (MulticastAttribute), it is easy to end up with that situation. Indeed, many multicasting paths can lead to the same target.

However, most of the time, a different behavior is preferred. We could define a method-level aspect on the type (this aspect would apply to all methods) and override (or even exclude) the aspect on a specific method.

The multicasting engine has both the ability to apply multiple aspect instances on the same target, and the ability to replace or remove custom attributes.

Understanding the Multicasting Algorithm

Before going ahead, it is important to understand the multicasting algorithm. The algorithm relies on a notion of order of processing of aspect instances.

Important

This section covers how PostSharp handles multiple instances of the same aspect type for the sole purpose of computing how aspect instances should be overridden or removed. See Coping with Several Aspects on the Same Target to understand how to cope with multiple instances of different aspects.

The following rules apply:

  1. Aspect instances defined on a container (for instance a type) have always precedence over instances defined on an item of that container (for instance a method). Elements of code are processed in the following order: assembly, module, type, field, property, event, method, parameter.

  2. When multiple aspect instances are defined on the same level, they are sorted by increasing of value of the AttributePriority

The algorithm builds a list of aspect instances applied (directly and indirectly) on an element of code, sorts these instances, and processes overrides or removals as described below.

Applying Multiple Instances of the Same Aspect

The property MulticastAttributeUsageAttribute..::.AllowMultiple determines whether multiple instance of the same aspect are allowed on an element of code. By default, this property is set to true for all aspects.

In the following example, the methods in type MyClass are enhanced by one, two and three instances of the Trace aspect (see code comments).

CopyApplying multiple instances of the same aspect
using System;
using System.Diagnostics;
using PostSharp.Aspects;
using PostSharp.Extensibility;
using Samples3;

[assembly: Trace( AttributeTargetTypes  = "Samples3.My*", Category = "A" )]
[assembly: Trace( AttributeTargetTypes  = "Samples3.My*",
                  AttributeTargetMemberAttributes = MulticastAttributes.Public, Category = "B" )]

namespace Samples3
{
    [Serializable]
    public sealed class TraceAttribute : OnMethodBoundaryAspect
    {
        public string Category { get; set; }

        public override void OnEntry( MethodExecutionArgs args )
        {
            Trace.WriteLine( "Entering " +
                args.Method.DeclaringType.FullName + "." + args.Method.Name, this.Category );
        }
    }

    public class MyClass
    {

        // This method will have 1 Trace aspect with Category set to A.
        private void Method1() { }

        // This method will have 2 Trace aspects with Category set to A, B
        public void Method2() { }

        // This method will have 3 Trace aspects with Category set to A, B, C.
        [Trace(Category = "C")]
        public void Method3() { }
    }
}

Overriding an Aspect Instance Manually

You can require an aspect instance to override any previous one by setting the aspect property AttributeReplace. This is equivalent to a deletion followed by an insertion (see below).

In the following examples, the first two methods of type MyClass are enhanced by aspects applied on assembly level, but these aspects are replaced by a different one on Method3.

CopyOverriding an aspect instance manually
using System;
using System.Diagnostics;
using PostSharp.Aspects;
using PostSharp.Extensibility;
using Samples5;

[assembly: Trace(AttributeTargetTypes = "Samples5.My*",  Category = "A")]
[assembly: Trace(AttributeTargetTypes = "Samples5.My*",
                 AttributeTargetMemberAttributes = MulticastAttributes.Public, Category = "B")]

namespace Samples5
{
    [Serializable]
    public sealed class TraceAttribute : OnMethodBoundaryAspect
    {
        public string Category { get; set; }

        public override void OnEntry(MethodExecutionArgs args)
        {
            Trace.WriteLine("Entering " +
                args.Method.DeclaringType.FullName + "." + args.Method.Name, this.Category);
        }
    }

    public class MyClass
    {

        // This method will have 1 Trace aspect with Category set to A.
        private void Method1() { }

        // This method will have 2 Trace aspect with Category set to A, B.
        public void Method2() { }

        // This method will have 1 Trace aspects with Category set to C.
        [Trace(Category = "C", AttributeReplace = true)]
        public void Method3() { }
    }
}

Overriding an Aspect Instance Automatically

To cause a new aspect instance to automatically override any previous one, the aspect developer must disallow multiple instances by annotating the aspect class with the custom attribute MulticastAttributeUsageAttribute and setting the property AllowMultiple to false.

In the following example, the methods in type MyClass are enhanced by a single Trace aspect

CopyOverriding an aspect instance automatically
using System;
using System.Diagnostics;
using PostSharp.Aspects;
using PostSharp.Extensibility;
using Samples4;

[assembly: Trace( AttributeTargetTypes = "Samples4.My*", AttributePriority = 1, Category = "A" )]
[assembly: Trace( AttributeTargetTypes = "Samples4.My*",
                  AttributeTargetMemberAttributes = MulticastAttributes.Public, AttributePriority = 2, Category = "B")]

namespace Samples4
{
    [MulticastAttributeUsage(MulticastTargets.Method, AllowMultiple = false)]
    [Serializable]
    public sealed class TraceAttribute : OnMethodBoundaryAspect
    {
        public string Category { get; set; }

        public override void OnEntry( MethodExecutionArgs args )
        {
            Trace.WriteLine( "Entering " +
                args.Method.DeclaringType.FullName + "." + args.Method.Name, this.Category );
        }
    }

    public class MyClass
    {

        // This method will have 1 Trace aspect with Category set to A.
        private void Method1() { }

        // This method will have 1 Trace aspects with Category set to B.
        public void Method2() { }

        // This method will have 1 Trace aspects with Category set to C.
        [Trace(Category = "C")]
        public void Method3() { }
    }
}

Deleting an Aspect Instance

The MulticastAttribute..::.AttributeExclude property removes any previous instance of the same aspect on a target.

This is useful, for instance, when you need to exclude a target from the matching set of a wildcard expression. For instance:

CopyDeleting an aspect instance
[assembly: Configurable( AttributeTypes = "BusinessLayer.*" )]

namespace BusinessLayer
{
  [Configurable( AttributeExclude = true )]
  public static class Helpers
  {

  }
}


Reflecting Aspect Instances at Runtime

Reflecting Aspect Instances at Runtime
Send Feedback

Attribute multicasting has been primarily designed as a mechanism to add aspects to a program. Most of the time, the custom attribute representing an aspect can be removed after the aspect has been applied.

By default, if you add an aspect to a program and look at the resulting program using a disassembler or System.Reflection, you will not find these corresponding custom attributes.

If you need your aspect (or any other multicast attribute) to be reflected by System.Reflection or any other tool, you have to set the MulticastAttributeUsageAttribute..::.PersistMetaData property to true.

For instance:

CopyMulticast attribute visible from System.Reflection
[MulticastAttributeUsage( MulticastTargets.Class, PersistMetaData = true )]
public class TagAttribute : MulticastAttribute
{
  public string Tag;
}


Aspect Multicasting: An Implementation Note

Aspect Multicasting: An Implementation Note
Send Feedback

This documentation refers to the feature behind MulticastAttribute as aspect multicasting and inheritance. This is not totally accurate. Although this feature has been developed to support aspects, you can use it for your own custom attributes, even if they are not aspects.

The notion of MulticastAttribute is independent from the notion of aspect.


Understanding Aspect Lifetime and Scope

Understanding Aspect Lifetime and Scope
See Also Send Feedback

An original feature of PostSharp is that aspects are instantiated at compile time. Most other frameworks instantiate aspects at run time.

Persistence of aspects between compile time and run time is achieved by serializing aspect instances into a binary resource stored in the transformed assembly. Therefore, you should carefully mark all aspect classes with the SerializableAttribute custom attribute, and distinguish between serialized fields (typically initialized at compile-time and used at run-time) and non-serialized fields (typically used at run-time only or at compile-time only).

Note

If your project targets Silverlight, Windows Phone, or the Compact Framework, aspects are initialized at run-time and all compile-time steps are skipped.

Scope of Aspects

PostSharp offers two kinds of aspect scopes: static (per-class) and per-instance.

Statically Scoped Aspects

With statically-scoped aspects, PostSharp creates one aspect instance for each element of code to which the aspect applies. The aspect instance is stored in a static field and is shared among all instances of the target class.

In generic types, the aspect instance has not exactly the same scope as static fields. Consider the following piece of code:

CopyComparing the scope of an aspect instance with the scope of a static variable
public class GenericClass<T>
{
  static T f;

  [Trace]
  public void void SetField(T value) { f = value; }
}

public class Program
{
   public static void Main()
   {
      GenericClass<int>.SetField(1);
      GenericClass<long>.SetField(2);
   }
}

In this program, there are two instances of the static field f (one for GenericClass<int>, the second for GenericClass<long>) but only a single instance of the aspect Trace.

Instance-Scoped Aspects

Instance-scoped aspect have the same scope (instance or static) as the element of code to which they are applied. If an instance-scoped aspect is applied to a static member, it will have static scope. However, if it is applied to an instance member or to a class, it will have the same lifetime as the class instance: an aspect instance will be created whenever the class is instantiated, and the aspect instance will be garbage-collectable at the same time as the class instance.

Instance-scoped aspects are implemented according to the prototype pattern: the aspect instance created at compile time serves as a prototype, and is cloned at run-time whenever the target class is instantiated.

Instance-scoped aspects must implement the interface IInstanceScopedAspect. Any aspect may be made instance-scoped. The following code is a typical implementation of the interface IInstanceScopedAspect:

CopyTypical implementation of IInstanceScopedAspect
object IInstanceScopedAspect.CreateInstance( AdviceArgs adviceArgs )
{
  return this.MemberwiseClone();
}

object IInstanceScopedAspect.RuntimeInitializeInstance()
{
}

Steps in the Lifetime of an Aspect Instance

The following table summarizes the different steps of

Phase

Step

Description

Compile-Time

Instantiation

PostSharp creates a new instance of the aspect for every target to which it applies. If the aspect has been applied using a multicast custom attribute (MulticastAttribute), there will be one aspect instance for each matching element of code.

When the aspect is given as a custom attribute or a multicast custom attribute, each custom attribute instance is instantiated using the same mechanism as the Common Language Runtime (CLR) does: PostSharp calls the appropriate constructor and sets the properties and/or fields with the appropriate values. For instance, when you use the construction [Trace(Category="FileManager")], PostSharp calls the default constructor and the Category property setter.

Validation

PostSharp validates the aspect by calling the CompileTimeValidate aspect method. See Validating Aspects for details.

Compile-Time Initialization

PostSharp invokes the CompileTimeInitialize aspect method. This method may, but must not, be overridden by concrete aspect classes in order to perform some expensive computations that do not depend on runtime conditions. The name of the element to which the custom attribute instance is applied is always passed to this method.

Serialization

After the aspect instances have all been created and initialized, PostSharp serializes them into a binary stream. This stream is stored inside the new assembly as a managed resource.

Run-Time

Deserialization

Before the first aspect must be executed, the aspect framework deserializes the binary stream that has been stored in a managed resource during post-compilation.

At this point, there is still one aspect instance per target class.

Per-Class Runtime Initialization

Once all custom attribute instances are deserialized, we call for each of them the RuntimeInitialize method. But this time we pass as an argument the real System.Reflection object to which it is applied.

Per-Instance Runtime Initialization

This step applies only to instance-scoped aspects when they have been applied to an instance member.

When a class is instantiated, the aspect framework creates an aspect instance by invoking the method CreateInstance(AdviceArgs) of the prototype aspect instance. After the new aspect instance has been set up, the aspect framework invokes the RuntimeInitializeInstance()()().

Advice Execution

Finally, advices (methods such as OnEntry(MethodExecutionArgs)) are executed.

Examples

[aa4b579-a7ea-420c-8903-3f2d6afe02a2]

See Also

Other Resources

Validating Aspects
Initializing Aspects
[5fafef23-0313-4eb9-9e4f-2ef80c616908]
Aspect Serialization
Coping with Custom Serializers


Validating Aspects

Validating Aspects
See Also Send Feedback

PostSharp allows aspect developers to validate that their aspect is being applied on the proper types, methods or fields.

Indeed, all aspects define a method named CompileTimeValidate. The parameter of this method is the type, method or field to which the aspect is being applied. By overriding this method, aspect developers can check that the target of the current aspect instance has expected characteristics, and emitting a compile-time error if not.

The CompileTimeValidate method should return true if the aspect has been applied on a valid target, and false otherwise. If this method returned false and no error was raised, the aspect will be silently ignored.

Emitting a Compile-Time Error

The easiest way to emit a compile-time error is to use the method Message..::.Write()()()

Note

Emitting a message does not affect the fact that the aspect is applied or not. Only the return value of the CompileTimeValidate method is relevant to this regard.

The following code checks that the aspect is applied to a type derived from DispatcherObject. If not, it emits an error message and returns false, causing PostSharp to ignore the aspect and then make the build process fail.

CopyValidating an aspect target using CompileTimeValidate and raising a compile-time error
// Method invoked at build time. It validates that the aspect has been applied to an acceptable method.
public override bool CompileTimeValidate( MethodBase method )
{
    // The method must be in a type derived from DispatcherObject.
    if ( !typeof(DispatcherObject).IsAssignableFrom( method.DeclaringType ) )
    {
        Message.Write( SeverityType.Error, "CUSTOM02",
                       "Cannot apply [GuiThread] to method {0} because it is not a member of a type " +
                       "derived from DispatcherObject.", method );
        return false;
    }

    return true;
}

If you plan to raise many messages, you may prefer to define your own MessageSource. A MessageSource is backed by a managed resource mapping error codes to error messages.

In order to create your own MessageSource, you should:

  1. Create a new managed resource. To each message will correspond a string item in the resource; the item name will be the message code, and the item value will be the formatting string of the error message.

  2. Create a static instance of the MessageSource class for your message source:

    CopyDefining a custom message source
    internal static class MyMessageSource
{
      public static readonly MessageSource Instance =
        new MessageSource( "MyWeaver",
                           new ResourceManager( "MyWeaver.Messages",
                                             typeof(MyMessageSource).Assembly ) );
}

  3. Then you can use a convenient set of methods on your MessageSource object:

    CopyUsing a custom message source
    MyMessageSource.Instance.Write( SeverityType.Error, "CU001", new object[] { type.FullName } );
Note

You can also emit information and warning messages.

Validating Attributes That Are Not Aspects

You can validate any attribute derived from Attribute by implementing the interface IValidableAnnotation.

Examples

Example: Dispatching a Method Execution to the GUI Thread

See Also

Reference

MethodLevelAspectCompileTimeValidate(MethodBase)
TypeLevelAspectCompileTimeValidate(Type)
FieldLevelAspectCompileTimeValidate(FieldInfo)
LocationLevelAspectCompileTimeValidate(LocationInfo)
EventLevelAspectCompileTimeValidate(EventInfo)
AssemblyLevelAspectCompileTimeValidate(_Assembly)
IValidableAnnotation
MessageSource
Message
Message..::.Write()()()


Initializing Aspects

Initializing Aspects
See Also Send Feedback

As explained in section Understanding Aspect Lifetime and Scope, a different aspect instance is associated with every element of code it is applied to. Aspect instances are created at compile time, serialized into the assembly as a managed resource, and deserialized at runtime. If the aspect is instance-scoped, instances are duplicated from the prototype and initialized.

Therefore, you can override one of the following three methods to handle aspect initializations:

  1. The method CompileTimeInitialize is invoked at compile time, and should initialize only serializable fields of the aspect, so that the value of these fields will be available at run time. The argument of this method is the System.Reflection object representing the element of code to which this aspect instance has been applied. Therefore, this method can already perform expensive computations that depend only on metadata.

  2. The method RuntimeInitialize is invoked at run time. Note that the aspect constructor itself is not invoked at run time. Therefore, overriding RuntimeInitialize is the only way to perform initialization tasks at run time. If the aspect is instance-scoped, this method is executed on the prototype instance.

  3. The methods IInstanceScopedAspect..::.CreateInstance(AdviceArgs) and IInstanceScopedAspect..::.RuntimeInitializeInstance()()() is invoked only for instance-scoped aspects. They initialize the aspect instance itself, as RuntimeInitialize was invoked on the prototype.

Tip

Initializing an aspect at compile time is useful when you need to compute a difficult result that depends only on metadata -- that is, it does not depend on any runtime information. An example is to build the strings that need to be printed by a tracing aspect. It is rather expensive to build strings that contain the full type name, the method name, and eventually placeholders for generic parameters and parameters. However, all required pieces of information are available at runtime. So compile time is the best moment to compute these strings.

See Also

Other Resources

Understanding Aspect Lifetime and Scope


Developing Complex Aspects

Developing Complex Aspects
Send Feedback

PostSharp offers two approaches to aspect-oriented development. The first, as explained in section Developing Simple Aspects, is very similar to object-oriented programming. It requires the aspect developer to override virtual methods or implement interfaces. This approach is very efficient for simple problems.

One way to grow in complexity with the first approach is to use the interface IAspectProvider (see Adding Aspects Dynamically). However, even this technique has its limitations.

This chapter documents the second approach, closer to the classic paradigm of aspect-oriented programming introduced by AspectJ. This approach allows developers to implement more complex design patterns using aspects. We call aspects developed with this approach composite aspects, because they are freely composed of different elements named advices and pointcuts. An advice is anything that adds a behaviour or a structural element to an element of code. For instance, introducing a method into a class, intercepting a property setter, or catching exceptions, are advices. A pointcut is a function returning a set of elements of code to which advices apply. For instance, a function returning the set of properties annotated with the custom attribute DataMember is a pointcut. Classes supporting advices and pointcuts are available in the namespace PostSharp.Aspects.Advices.

A composite aspect generally generally derives from a class that does not define its own advices: AssemblyLevelAspect, TypeLevelAspect, InstanceLevelAspect, MethodLevelAspect, LocationLevelAspect or EventLevelAspect. As such, these aspects have no functionality. You can add functionalities by adding advices to the aspect.

Advices are covered in the following sections:

Section | Description
Adding Behaviors to Members | Advices with equivalent functionality as OnMethodBoundaryAspect, MethodInterceptionAspect, LocationInterceptionAspect, and EventInterceptionAspect.
Introducing Interfaces | Make the aspect introduce an interface into the target class. The interface is implemented by the aspect itself.
Introducing, Overriding and Importing Members | Make the aspect introduce a new method, property or event into the target class. The new member is implemented by the aspect itself. Conversely, the aspect can import a member of the target so that it can invoke it through a delegate.


Adding Behaviors to Members

Adding Behaviors to Members
See Also Send Feedback

In order to add new behaviours to (i.e. modify) existing members (methods, fields, properties, or events), two questions must be addressed:

  • What transformation should be performed? The answer lays in the advice. This advice is a method of your advice, annotated with a custom attribute determining in which situation the method should be invoked. You can freely choose the name of the method, but its signature must match the one expected by the advice type.

  • Where should it be performed, i.e. on which elements on code? The answer lays in the pointcut, another custom attribute expected on the method providing the transformation.

How to Add a Behavior to an Existing Member

  1. Start with an empty aspect class deriving AssemblyLevelAspect, TypeLevelAspect, InstanceLevelAspect, MethodLevelAspect, LocationLevelAspect or EventLevelAspect. Mark it as serializable.

  2. Choose an advice type in the list below. For instance: OnMethodEntryAdvice.

  3. Create a method. The signature of this method should match exactly the signature matched by this advice type.

  4. Annotate this method with a custom attribute of the advice type you chose. For instance: [OnMethodEntryAdvice].

  5. Choose a pointcut type in the list below. For instance: SelfPointcut. Annotate the advice method with that custom attribute. For instance: [SelfPointcut].

Example

The following code shows a simple tracing aspect implemented with an advice and a pointcut. This aspect is exactly equivalent to a class derived from OnMethodBoundaryAspect where only the method OnEntry(MethodExecutionArgs) has been overwritten. The example is a method-level aspect and SelfPointcut means that the advice applies to the same target as the method itself.

CopyA simple composite aspect using an advice and a pointcut
using System;
using PostSharp.Aspects;
using PostSharp.Aspects.Advices;

namespace Samples6
{
    [Serializable]
    public sealed class TraceAttribute : MethodLevelAspect
    {
        [OnMethodEntryAdvice, SelfPointcut]
        public void OnEntry( MethodExecutionArgs args )
        {
            Console.WriteLine( "Entering {0}.{1}", args.Method.DeclaringType.Name, args.Method.Name );
        }
    }
}

Available Advices

The following table lists all types of advices that can transform existing members. Note that all these advices are available as a part of a simple aspect (for instance OnMethodEntryAdvice corresponds to OnMethodBoundaryAspect..::.OnEntry(MethodExecutionArgs). For a complete documentation of the advice, see the documentation of the corresponding simple aspect.

Advice Type | Targets | Description
OnMethodEntryAdvice OnMethodSuccessAdvice OnMethodExceptionAdvice OnMethodExitAdvice | Methods | These advices are equivalent to the advices of the aspect OnMethodBoundaryAspect. The target method to be wrapped by a try/catch/finally construct.
OnMethodInvokeAdvice | Methods | This advice is equivalent to the aspect MethodInterceptionAspect. Calls to the target methods are replaced to calls to the advice.
OnLocationGetValueAdvice OnLocationSetValueAdvice | Fields, Property | These advices are equivalent to the advices of the aspect LocationInterceptionAspect. Fields are changed into properties, and calls to the accessors are replaced to calls to the proper advice.
OnEventAddHandlerAdvice OnEventRemoveHandlerAdvice OnEventInvokeHandlerAdvice | Events | These advices are equivalent to the advices of the aspect EventInterceptionAspect. Calls to add and remove semantics are replaced by calls to advices. When the event is fired, the OnEventInvokeHandler is invoked for each handler, instead of the handler itself.

Available Pointcuts

Pointcuts determine where the transformation provided by the advice should be applied.

From a logical point of view, pointcuts are functions that return a set of code elements. A pointcut can only select elements of code that are inside the target of the aspect itself. For instance, if an aspect has been applied to a class A, the pointcut can select the class A itself, members of A, but different classes or members of different classes.

Multicast Pointcut

The pointcut type MulticastPointcut allows to express a pointcut in a purely declarative way, using a single custom attribute. It works in a very similar way as MulticastAttribute (see Applying Aspects to Multiple Code Elements) the kind of code elements being selected, their name and attributes can be filtered using properties of this custom attribute.

For instance, the following code applies the OnPropertySet advice to all non-abstract properties of the class to which the aspect has been applied.

CopyAdvice with a MulticastPointcut
[OnLocationSetValueAdvice,
 MulticastPointcut( Targets = MulticastTargets.Property,
                    Attributes = MulticastAttributes.Instance | MulticastAttributes.NonAbstract)]
public void OnPropertySet( LocationInterceptionArgs args )
{
  // Details skipped.
}

Method Pointcut

The pointcut type MethodPointcut allows to express a pointcut imperatively, using a C# or Visual Basic method. The argument of the custom attribute should contain the name of the method implementing the pointcut.

The only parameter of this method should be type-compatible with the kind of elements of code to which the aspect applies. The return value of the pointcut method should be a collection (IEnumerable<(Of <(T>)>)) of objects that are type-compatible with the kind of elements of code to which the advice applies.

For instance, the following code applies the OnPropertySet advice to all writable properties that are not annotated with the IgnorePropertyChanged custom attribute.

CopyAdvice with a MethodPointcut
private IEnumerable<PropertyInfo> SelectProperties( Type type )
{
    const BindingFlags bindingFlags = BindingFlags.Instance |
        BindingFlags.DeclaredOnly | BindingFlags.Public;

    return from property
               in type.GetProperties( bindingFlags )
           where property.CanWrite && !property.IsDefined(typeof(IgnorePropertyChanged))
           select property;
}

[OnLocationSetValueAdvice, MethodPointcut( "SelectProperties" )]
public void OnPropertySet( LocationInterceptionArgs args )
{
    // Details skipped.
}

As you can see in this example, pointcut methods can use the power of LINQ to query System.Reflection.

Self Pointcut

The pointcut type SelfPointcut simply selects the target of the aspect.

Grouping Advices

The table of above shows advice types grouped in families. Advices of different type but of the same family can be grouped into a single logical filter, so they are considered as single transformation.

Why Grouping Advices

Consider for instance three advices of the family OnMethodBoundaryAspect: OnMethodEntryAdvice, OnMethodSuccessAdvice and OnMethodExceptionAdvice. The way how they are ordered is important, as it results in different generation of try/catch/finally block.

The following table compares advice ordering strategies. In the left column, advices are executed in the order: OnEntry, OnExit, OnException. In the right column, advices are grouped together.

CopyCode generated by ordered advices
void Method()
{
  try
  {
    OnEntry();

    try
    {
      // Original method body.
    }
    finally
    {
      OnExit();
    }
  }
  catch
  {
     OnException();
     throw;
  }
}
CopyCode generated by grouped advices
void Method()
{
  OnEntry();

  try
  {
      // Original method body.
  }
  catch
  {
     OnException();
     throw;
  }
  finally
  {
      OnExit();
  }
}

The code in the left column may make sense in some situations, but it is not consistent with the code generated by OnMethodBoundaryAspect. Note that the advices may have been ordered differently: the order OnEntry, OnException, OnExit would have generated the same code as in the right column. However, you would have had to use custom attributes to specify order relationships between advices (see Ordering Advices). Grouping advices is a much easier way to ensure consistency.

Additionally, when advices of the OnMethodBoundaryAspect family are grouped together, it will be possible to share information among them using MethodExecutionTag.

The reasons to group advices of the family LocationInterceptionAspect and EventInterceptionAspect are similar: advices grouped together behave consistently as a single filter (see Interception Aspects).

How to Group Advices

To group several advices into a single filter:

  1. Choose a master advice. The choice of the master advice is arbitrary. All other advices of the group are called slave advices.

  2. Annotate the master advice method with one advice custom attribute (see Available Advices and one pointcut custom attribute (see Available Pointcuts), as usually.

  3. Annotate all slave advices with one advice custom attribute. Set the property Master of the custom attribute to the name of the master advice method.

  4. Do not specify any pointcut on slave advice methods.

The following code shows how two advices of type OnMethodEntryAdvice and OnMethodExitAdvice can be grouped into a single filter:

CopyGrouped advices
[OnMethodEntryAdvice, MulticastPointcut]
public void OnEntry(MethodExecutionArgs args)
{
}

[OnMethodExitAdvice(Master="OnEntry")]
public void OnExit(MethodExecutionArgs args)
{
}

See Also

Reference

PostSharp.Aspects.Advices

Other Resources

Ordering Advices
Interception Aspects


Introducing Interfaces

Introducing Interfaces
See Also Send Feedback

An aspect can easily introduce an interface into types to which the aspect is applied. After processing by PostSharp, these types will expose the introduced interface, but it will be implemented by the aspect.

Introducing an Interface

To make an aspect introduce an interface into a type:

  1. Create an aspect class derived from InstanceLevelAspect.

    Note

    Alternatively, your aspect class can be derived from TypeLevelAspect or AssemblyLevelAspect, but then the interface implementation will be shared by all instances of the target type or all instances of any class of the target assembly. This is probably not the desired behavior. For details, see Understanding Aspect Lifetime and Scope

  2. Add the interface to the aspect class and implement it.

  3. Annotate the aspect class with the custom attribute IntroduceInterfaceAttribute and set the constructor parameter to the type of the introduced interface.

Note

The advice type IntroduceInterfaceAttribute generates in an explicit implementation of the introduced interface in the target class. All interface members will be introduced as private. To make interface members public, you need to introduce individual members using the advice type IntroduceMemberAttribute. See Introducing, Overriding and Importing Members for details.

Accessing an Introduced Interface

One of the most serious drawbacks of post-compile aspect weaving is that artefacts introduces by aspects are not present in the source code. Therefore, they are visible neither from the compiler, neither from Intellisense.

PostSharp provides a special static method, [PostSharp.Post.Cast`2(TClass)(] to cast objects to interfaces introduced by aspects. Calls to this static method are checked after all aspects have been executed, so you would get a compile-time error if you try to cast a class to an interface that has not been introduced.

Example

The following aspect introduces the aspect ITaggable, which augments any class with a dictionary of tags.

CopyImplementing a simple interface using an IntroduceInterface advice
using System;
using System.Collections.Generic;
using PostSharp;
using PostSharp.Aspects;
using PostSharp.Aspects.Advices;

namespace Samples7
{
    public interface ITaggable
    {
        Dictionary<Guid, object> Tags { get; }
    }

    [Serializable]
    [IntroduceInterface( typeof(ITaggable) )]
    public sealed class TaggableAttribute : InstanceLevelAspect, ITaggable
    {
        public override void RuntimeInitializeInstance()
        {
            this.Tags = new Dictionary<Guid, object>();
        }

        public Dictionary<Guid, object> Tags { get; private set; }
    }

    [Taggable]
    public class MyObject
    {
    }

    public class Program
    {
        private static void Main()
        {
            ITaggable taggable = Post.Cast<MyObject, ITaggable>( new MyObject() );
            taggable.Tags[new Guid( "8F02365E-D66A-4330-93F6-A2F9AAD7FFEC" )] = "Hello, world";
        }
    }
}

See Also

Reference

IntroduceInterfaceAttribute


Introducing, Overriding and Importing Members

Introducing, Overriding and Importing Members
See Also Send Feedback

PostSharp allows aspect not only to add interfaces to class, but also to add new methods, properties, and events. PostSharp provides a mechanism to handle situations where these members already exist in the target class. Additionally, PostSharp makes it possible to import a delegate of a target class into the aspect class, so that the aspect can invoke this member.

These mechanisms allow developers to encapsulate more design patterns using aspects.

Introducing Members

To introduce a member of the aspect class into the target type:

  1. Define the method, property, or event into the aspect class as usually.

  2. Ensure the member to introduce has public visibility.

  3. Add the custom attribute IntroduceMemberAttribute to the member.

  4. If necessary, set the following properties of the custom attribute: use Visibility to make the member private, protected, internal, or public (default value); use IsVirtual to make the member virtual (false by default).

Note

Introduced members must be declared as public in the aspect class, because they will be accessed from the target class. The visibility in the target class is determined by the property Visibility. Introduced members declared can be static or non-static in the aspect class, but they are always introduced as non-static in the target class.

The following code introduces an event into the target type of the aspect. The even must be raised from the aspect.

CopyIntroducing an event into a type
[IntroduceMember]
public event EventHandler Changed;

Overriding Members

It may happen that the member that an aspect is trying to introduce already exists in the target class or in a parent of the target class. By default, PostSharp will emit a compile-time error if this situation happens. This behavior can be changed by setting the property OverrideAction. Valid values are Fail, OverrideOrFail or OverrideOrIgnore. The two last values means that PostSharp will try to override the member. But it is not always possible: PostSharp can only override two kinds of members: members of the target type, or virtual members of a parent of the target type. PostSharp cannot override a sealed member of a parent of the target class. In this case, OverrideAction specifies if the member introduction should fail or be silently ignored.

Importing Members

Importing a member into an aspect allows this aspect to invoke the member. An aspect can import methods, properties, or fields.

To import a member of the target type into the aspect class:

  1. Define a field into the aspect class, of the following type:

    Member Kind

    Field Type

    Method

    A typed Delegate, typically one of the variants of Action or Func<(Of <(TResult>)>). The delegate signature should exactly match the signature of the imported method.

    Property

    Property<(Of <(TValue>)>), where the generic argument is the type of the property.

    Collection Indexer

    Property<(Of <(TValue, TIndex>)>), where the first generic argument is the type of the property value and the second is the type of the index parameter. Indexers with more than one parameter are not supported.

    Event

    Event<(Of <(TDelegate>)>), where the generic argument is the type of the event delegate (for instance EventHandler).

  2. Make this field public. The field cannot be static.

  3. Add the custom attribute ImportMemberAttribute to the field. As the constructor argument, pass the name of the member to be imported.

At runtime, the field is set to a delegate of the imported member. Properties and events are imported as set of delegates
(Property<(Of <(TValue>)>)..::.Get,
Property<(Of <(TValue>)>)..::.Set;
Event<(Of <(TDelegate>)>)..::.Add,
Event<(Of <(TDelegate>)>)..::.Remove).
These delegates can be invoked by the aspect as any delegate.

The property ImportMemberAttribute..::.IsRequired determines what happens if the member could not be found in the target class or in its parent. By default, the field will simply have the null value if it could not be bound to a member. If the property IsRequired is set to true, a compile-time error will be emitted.

Interactions Between Several Member Introductions and Imports

Although member introduction and import may seem simple advices at first sight, things become more complex when the several advices try to introduce or import the same member. PostSharp handles these situations in a robust and predictable way. For this purpose, it is primordial to process classes, aspects and advices in a consistent order.

PostSharp enforces the following order:

  1. Base classes are processed first, derived classes after. Therefore, when a class is being processed, all parent classes have already been fully processed.

  2. Aspects targetting the same class are sorted (see Coping with Several Aspects on the Same Target) and executed.

  3. Advices of the same aspect are sorted and executed in the following order:

    1. Member imports which have the property ImportMemberAttribute..::.Order set to BeforeIntroductions.

    2. Member introductions.

    3. Members imports which have the property ImportMemberAttribute..::.Order set to AfterIntroductions (this is the default value).

Based on this well-defined order, the advices behave as follow:

Advice

Precondition

Behavior

ImportMemberAttribute

No member, or private member defined in a parent class.

Error if ImportMemberAttribute..::.IsRequired is true, ignored otherwise (by default).

Non-virtual member defined.

Member imported.

Virtual member defined.

If ImportMemberAttribute..::.Order is BeforeIntroductions, the overridden member is imported. This similar to calling a method with the base prefix in C#. Otherwise (and by default), the member is dynamically resolved using the virtual table of the target object.

IntroduceMemberAttribute

No member, or private member defined in a parent class.

Member introduced.

Non-virtual member defined in a parent class

Ignored if the property IntroduceMemberAttribute..::.OverrideAction is Ignore or OverrideOrIgnore, otherwise fail (by default).

Virtual member defined in a parent class

Introduce a new override method if the property IntroduceMemberAttribute..::.OverrideAction is OverrideOrFail or OverrideOrIgnore, ignore if the property is Ignore, otherwise fail (by default).

Member defined in the target class (virtual or not)

Fail by default or if the property IntroduceMemberAttribute..::.OverrideAction is Fail.

Otherwise:

  1. Move the previous method body to a new method so that the previous implementation can be imported by advices ImportMemberAttribute with the property Order set to BeforeIntroductions.

  2. Override the method with the imported method.

Examples

Example: Raising an Event When the Object is Finalized

See Also

Reference

IntroduceMemberAttribute
ImportMemberAttribute

Other Resources

Coping with Several Aspects on the Same Target


Adding Aspects Dynamically

Adding Aspects Dynamically
See Also Send Feedback

Additionally to providing advices, an aspect can provide other aspects dynamically. This allows aspect developers to address situations where it is not possible to add aspects declaratively (using custom attributes) to the source code; aspects can be provided on the basis of a complex analysis of the target assembly using System.Reflection, or by reading an XML file, for instance.

Developing an Aspect Provider

  1. Create a new aspect class. You will most probably want to derive the class from one of the abstract classes AssemblyLevelAspect, TypeLevelAspect, MethodLevelAspect LocationLevelAspect or EventLevelAspect. However, any class implementing the interface IAspect can become a valid aspect provider.

  2. Add the interface IAspectProvider to the class.

  3. Add the method ProvideAspects(Object) to the class. This method should return a collection of AspectInstance. We suggest you use the C# construct yield return new AspectInstance(...) for its simplicity.

Example

The following example is an aspect adding the custom attribute XmlIgnoreAttribute to the field or method to which the aspect was applied, unless it is marked with XmlElementAttribute or XmlAttributeAttribute. The benefit of this aspect is that it derives from MulticastAttribute, so it can be applied to multiple fields or properties with a single line of code.

CopyAn aspect that introduces a custom attribute
using System;
using System.Collections.Generic;
using System.Reflection;
using System.Xml.Serialization;
using PostSharp.Aspects;
using PostSharp.Extensibility;
using PostSharp.Reflection;

namespace Samples
{
    [MulticastAttributeUsage(MulticastTargets.Field|MulticastTargets.Property,
                             TargetMemberAttributes = MulticastAttributes.Public | MulticastAttributes.Instance)]
    public sealed class AddXmlIgnoreAttribute : MethodLevelAspect, IAspectProvider
    {
        private static readonly CustomAttributeIntroductionAspect customAttributeIntroductionAspect =
            new CustomAttributeIntroductionAspect(
                new ObjectConstruction( typeof(XmlIgnoreAttribute).GetConstructor( Type.EmptyTypes ) ) );

        public IEnumerable<AspectInstance> ProvideAspects( object targetElement )
        {
            MemberInfo memberInfo = (MemberInfo) targetElement;

            if (memberInfo.IsDefined(typeof(XmlElementAttribute), false) ||
                memberInfo.IsDefined(typeof(XmlAttributeAttribute), false))
                yield break;

            yield return new AspectInstance( targetElement, customAttributeIntroductionAspect);
        }
    }
}

Remarks

Initialization of Aspects

PostSharp does not automatically initialize the aspects provided by IAspectProvider, even if the method CompileTimeInitialize is defined.. Any initialization, if necessary, should be done in the ProvideAspects method or in the constructor of provided aspects.

However, these aspects are initialized at runtime just like normal aspects using the RunTimeInitialize method.

Graphs of Aspects

It is common that aspects provided by IAspectProvider (children aspects) form an object graph. For instance, children aspects may contain a reference to the parent aspect.

An interesting feature of PostSharp is that object graphs instantiated at compile-time are serialized, and can be used at run-time. In other words, if you store in a child aspect a reference to another aspect, you will be able to use this reference at runtime.

See Also

Reference

IAspectProvider

Other Resources

Example: Automatically Adding DataContract and DataMember Attributes


Coping with Several Aspects on the Same Target

Coping with Several Aspects on the Same Target
See Also Send Feedback

As the team learns aspect-oriented programming and start adding more aspect to projects, chances raise that several aspects are added to the same element of code. This could be a major source of troubles if PostSharp did not provide a robust framework to detect and prevent conflicts between aspects:

  • Most aspects need to be ordered. For instance, an authorization aspect must be executed before a caching aspect.

  • Even if some aspects don't care to be ordered, it's good to have them applied in predictable order. Otherwise, some code that works today may be broken tomorrow -- just because aspects were applied in a different order.

  • Some aspects conflict; they cannot be together on the same aspect, or not in a given order. For instance, it does not make sense to persist an object using two different aspects: one would persist to the database, the other to the registry.

  • Some aspects require other aspects to be applied. For instance, an aspect changing the mouse pointer to a hourglass requires the method to execute asynchronously, otherwise the pointer shape will never be updated.

PostSharp addresses these issues by make it possible to add dependencies between aspects. The aspect dependency framework is implemented in the namespace PostSharp.Aspects.Dependencies.

Note

The aspect dependency framework is not related to the notion of dependency injection.

Aspect Dependency Custom Attributes

You can express dependencies of an aspect by annotating the aspect class with custom attributes derived from the type AspectDependencyAttribute. Several derived types are available; every type matches other aspects according to different criteria.

Types of Aspect Dependency Custom Attributes
Attribute Type | Description
AspectTypeDependencyAttribute | This custom attribute expresses a dependency with a well-known aspect class.
AspectRoleDependencyAttribute | This custom attribute expresses a dependency with any aspect classes enrolled in a given role. Its dual is ProvideAspectRoleAttribute: this custom attribute enrolls an aspect class into a role. A role is simply a string. Whenever possible, consider using one of the roles defined in the class StandardRoles.
AspectEffectDependencyAttribute | This custom attribute expresses a dependency with any aspect that has a specific effect on the source code or the control flow. Effects are represented as a string, whose valid values are listed in the type ProvideAspectRoleAttribute. Effects are provisioned by the aspect weaver on the basis of a rough analysis of what the aspect may do; aspect developers cannot assign new effects to aspects. However, they can waive effects by using the custom attribute WaiveAspectEffectAttribute. For instance, an aspect developer can specify that a trace attribute has no effect at all; this aspect will commute with any other aspect (see below).

Every of these custom attributes have similar structure and members. The first parameter of their constructor, of type AspectDependencyAction, determines the kind of dependency relationship added between the current aspect and the aspects matched by the custom attribute.

PostSharp supports the following kinds of relationships:

Kinds of Aspect Dependency Relationships
Action | Description
Order | The dependency expresses an order relationship. The second constructor of the custom attribute, of type AspectDependencyPosition (with values Before or After), must be specified. The custom attributes determine the position of the current aspect with respect to matched aspects.
Require | The dependency expresses a requirement. PostSharp will issue a compile-time error if the requirement is not satisfied for any target of the current aspect. The second constructor of the custom attribute, of type AspectDependencyPosition, is optional. If specified, an aspect matching the dependency should be present before or after the current aspect.
Conflict | The dependency expresses a conflict. PostSharp will issue a compile-time error if any aspect matching the dependency rule is present on any target of the current aspect. The second constructor of the custom attribute, of type AspectDependencyPosition, is optional. If specified, an error is issued only if a matching aspect is present before or after the current aspect.
Commute | The dependency specifies that the current aspect is commutable with any matching aspect. When aspects are commutable, PostSharp does not issue any warning if they are not strongly ordered.

Custom attribute types and values of the enumeration AspectDependencyAction are orthogonal; they can be freely combined.

Examples

Using role-based dependencies

The following code shows how three aspects can be ordered without having explicit knowledge of each other. Each aspect provides a different role, and defines dependencies with respect to other roles.

CopyExample: role-based dependencies
[ProvideAspectRole( StandardRoles.Threading )]
[AspectRoleDependency(AspectDependencyAction.Order, AspectDependencyPosition.Before, "UI")]
public sealed class AsyncAttribute : MethodInterceptionAspect
{
  // Details skipped
}

[ProvideAspectRole( StandardRoles.ExceptionHandling )]
[AspectRoleDependency( AspectDependencyAction.Order, AspectDependencyPosition.After, StandardRoles.Threading )]
[AspectRoleDependency(AspectDependencyAction.Order, AspectDependencyPosition.After, "UI")]
public sealed class ExceptionDialogAttribute : OnExceptionAspect
{
  // Details skipped
}

[ProvideAspectRole("UI")]
public sealed class StatusTextAttribute : OnMethodBoundaryAspect
{
  // Details skipped
}

Using effect-based dependencies

The following code shows how to protect an authorization aspect to be executed after an aspect which may change the control flow and skipping the execution of the method, such as a caching aspect. Then, it shows how the aspectAsyncAttribute can opt out from this effect, because the aspect developer knows that does aspect does not skip the execution of the method, but only defers it.

CopyExample: effect-based dependencies
[AspectEffectDependency( AspectDependencyAction.Conflict, AspectDependencyPosition.Before,
                         StandardEffects.ChangeControlFlow )]
public sealed class AuthorizationAttribute : OnMethodBoundaryAspect
{
  // Details skipped.
}

 [WaiveAspectEffect(StandardEffects.ChangeControlFlow)]
 public sealed class AsyncAttribute : MethodInterceptionAspect
 {
   // Details skipped
 }

Deferring Ordering to Aspect Users

By adding dependencies to the aspect class, the aspect developer specifies the order of execution of aspects in a fully static way. The same order is used for every element of code to which aspects apply. While this behavior is most of time desirable, there may be situations where we want to defer ordering to users of our aspects.

Aspect users can influence the order of execution of an aspect by setting the aspect property AspectPriority, typically when using the aspect custom attribute (the same property is available in the configuration object as AspectConfiguration..::.AspectPriority, see Configuring Aspects).

Setting the AspectPriority results to an aspect in adding an ordering dependency between this aspect and all other aspects where the same property has been set. Therefore, aspect priorities complement, and do not replace, other ordering dependencies. The aspect developer may specify vital aspect dependencies (that is, under-specify aspect ordering), and let it to the aspect user to complete the ordering with priorities.

Caution

Do not confuse the property AspectPriority with AttributePriority. The latter determines in which several custom attributes of the same time are processed by the MulticastAttribute engine. The first determines in which order the aspects are executed at run time.

Adding Dependencies to Third-Party Aspects

If you are using aspects provided by several third-party vendors who don't know about each other, you may need to solve conflicts on your own.

You can do that by adding any custom attribute derived from AspectDependencyAttribute at assembly level, and use the property TargetType to specify to which aspect class the dependency applies.

Here is an example:

CopyAdding dependendencies to a third-party aspect
[assembly: AspectTypeDependency( AspectDependencyAction.Order, AspectDependencyPosition.Before,
                                 typeof(Vendor1.TraceAspect), TargetType = typeof(Vendor2.ExceptionHandlingAspect) ]

See Also

Reference

PostSharp.Aspects.Dependencies


Ordering Advices

Ordering Advices
See Also Send Feedback

Section Coping with Several Aspects on the Same Target talks in terms of aspect dependencies and aspect ordering. Most of what has been said there is also valid to advices. When we talk of the order of execution of aspects, we actually mean the execution of advices ("aspects" themselves, stricto sensu, are never executed).

Dependencies defined at aspect level implicitly apply to all advices. When developing a composite aspect (see Developing Complex Aspects), it is possible to add dependencies directly to advice methods by annotating them with custom attributes of the namespace PostSharp.Aspects.Dependencies.

Note that all advices provided by an aspect are ordered in a single block. Suppose that a method is the target of advices Aspect1.MethodA, Aspect1.MethodB and Aspect2.MethodC. The next table shows valid and invalid orders:

Valid Orders | Invalid Orders
Aspect1.MethodA, Aspect1.MethodB, Aspect2.MethodC | Aspect1.MethodA, Aspect2.MethodC, Aspect1.MethodB
Aspect1.MethodB, Aspect1.MethodA, Aspect2.MethodC | Aspect1.MethodB, Aspect2.MethodC, Aspect1.MethodA
Aspect2.MethodC, Aspect1.MethodA, Aspect1.MethodB |
Aspect2.MethodC, Aspect1.MethodB, Aspect1.MethodA |

Ordering Advices of the Same Aspect

Advices of the same aspect can be used using any custom attribute derived from AspectDependencyAttribute.

Because advices of the same aspect instance are necessarily ordered in block, it is appropriate to specify dependencies between aspect classes extensively, and specify ordering of advices only in the scope of the current aspect instance. The most appropriate dependency custom attribute for this purpose is AdviceDependencyAttribute, which accepts the name of the advice method as a parameter.

See Also

Reference

AdviceDependencyAttribute


Interception Aspects

Interception Aspects
See Also Send Feedback

Aspects types MethodInterceptionAspect, LocationInterceptionAspect and EventInterceptionAspect are all based on the same principle: the aspect is invoked instead of the enhanced semantic. The aspect gets access to the intercepted semantic through methods prefixed by Proceed, or by other methods.

Things become more complex when several interception aspects are applied to the same element of code. Consider a method enhanced by three aspects A, B and C. When aspect A calls the method Proceed()()(), it will actually invoke the method OnInvoke(MethodInterceptionArgs) of aspect B. Similarly, aspect B will invoke aspect C, and aspect C will eventually invoke the original method.

Chains of Invocation

Interception aspects form a chain on invocation where every aspect instance is a node in the chain, and the intercepted member is the last node.

An interception aspect can only invoke the next node in the chain. There is no way an aspect can invoke another node, or can access directly the intercepted member. This design ensures that aspects behave in a robust and consistent way in all situations.

Aspects types LocationInterceptionAspect and EventInterceptionAspect have several semantics (Get and Set for LocationInterceptionAspect; Add, Remove and Invoke for EventInterceptionAspect). All advices of the same aspect instance (one advice per semantic) logically belong to the same node in the chain of invocation. Therefore, when the implementation of the advice LocationInterceptionAspect..::.OnSetValue(LocationInterceptionArgs) invokes the method LocationInterceptionArgs..::.GetCurrentValue()()(), it actually invokes the Get semantic of the next node in the chain. If the aspect had used PropertyInfoGetValue(Object) to get the value (as was usual in PostSharp 1.0), it would have invoked the first node in the chain!

Aspects as Filters: a Disciplined Approach to Aspect-Oriented Programming

In its early days, aspect-oriented programming (AOP) has been perceived as a dangerous technology. Aspects allowed to do anything with a program. Although AOP has been designed to improve the readability and maintainability of source code, it could actually have the opposite effect.

As goes the saying, with a sharp tool, one must pay greater attention.

PostSharp was designed to respect one of the most fundamental principles of software engineering: encapsulation. Encapsulation means the condition of being enclosed, as in a capsule. In object-oriented programming, the primary capsule is the class itself. Outside code communicates with the capsule through well-defined ports: public members. Outside code cannot modify what's inside the capsule. A well-designed capsule should check the validity of messages it receives or it sends - something called precondition and postcondition checking. The second level of encapsulation is the method: even inside a class, code should be designed so that the implementation of a method does not need to care about the implementation of another method.

Of course, it is possible to ignore the rules of encapsulation. But it would most probably result in poorly readable and maintainable code.

PostSharp actually allows you break the first capsule: you can add advices to private members of a class. But it stops there: you cannot break the capsule of a method. Instead, you can enclose a method into a new capsule analog to a filter: the advice. When a method is enhanced by an advice, outside code seeking access to this method must go through its advice.

When a method is enhanced by several advices, every advice constitutes a filter that encloses not only the method, but all advices with lower priority.

Methods have a single semantic: Invoke. Properties, fields and events have many multiple semantics. These members can be considered as a single capsule, and their semantics as different ports in the capsule.

Note

Things can become more complex. Consider a property with a getter and a setter. The property is enhanced by an aspect of type LocationInterceptionAspect. The property setter is enhanced by a MethodInterceptionAspect with lower priority. From a logical point of view, the property is considered as a single capsule with two ports. The capsule is enclosed by two filters, one for each aspect. The aspect LocationInterceptionAspect filters both ports. However, MethodInterceptionAspect only filters the Set port. If the LocationInterceptionAspect invokes the Get semantic, it will be directed to the property getter, because there is no filter between the advice and the semantic. However, when the same aspect invokes the Set semantic, it will be directed to LocationInterceptionAspect as this filters lays in the way.

Note

The Invoke semantic of EventInterceptionAspect is executed in invert order. Indeed, the message originates inside the capsule is emitted outside. For all other semantics, the message always comes from outside and is directed to the capsule.

Aspect Bindings

When an advice it invoked, it receives an interface to the next node in the chain of invocation: an aspect binding. Every aspect type has its corresponding binding interface, exposed on a property of the advice argument object.

Aspect Type | Binding Interface | Exposed On
MethodInterceptionAspect | IMethodBinding | MethodInterceptionArgs..::.Binding
LocationInterceptionAspect | ILocationBinding | LocationInterceptionArgs..::.Binding
EventInterceptionAspect | IEventBinding | EventInterceptionArgs..::.Binding

Binding objects are singletons. They are fully thread-safe and reentrant. They can be invoked in any situation. This contrasts with advice arguments, which may be shared among different advices and should not be used once the advice gave over control to the next node in the chain invocation.

Note

As objects of type Arguments may be shared among different advices, some of which may modify the arguments, it may be safe to clone the object before the advice gives over control.

Note

For run-time performance reasons, PostSharp does not access binding classes through their interface, but directly invokes their implementation. Implementation classes of binding interfaces are considered an implementation detail and should not be referred to from user code.

See Also

Reference

LocationInterceptionAspect
MethodInterceptionAspect
EventInterceptionAspect


Coping with Custom Serializers

Coping with Custom Serializers
Send Feedback

Some aspects need to be initialized when a new instance of the class to which they are applied is created. For instance, instance-scoped aspect must be cloned from the prototype; members imported into the through ImportMemberAttribute must be bound to aspect fields.

PostSharp enhances every constructor of every enhanced class so that aspects are properly initialized.

However, it is possible to create new instances of classes by bypassing the constructor. This happens, for instance, when classes are deserialized by the BinaryFormatter or the DataContractSerializer. These formatters use the method FormatterServicesGetUnitializedObject(Type) to create new instances, but this method bypasses all constructors.

PostSharp implements a workaround for the deserializers BinaryFormatter and DataContractSerializer: it creates or modifies a method annotated by the custom attribute OnDeserializingAttribute, so that aspects are initialized properly.

However, if you are using a custom deserializer, or for any reason create instances using the method the method FormatterServicesGetUnitializedObject(Type), you will have to initialize aspects manually.

Initializing Aspects Manually

There are many possible ways to initialize an aspect from user code.

By Defining a Method InitializeAspects

You can define in your classes (typically in one of the root classes of your class hierarchy) a method with the following name and signature:

Copy
protected virtual void InitializeAspects();

When PostSharp discovers this method, it will insert its own initialization logic at the beginning of the InitializeAspects method. The original logic is not deleted. This method can safely have an empty implementation.

The following constraints apply:

  • The method should be virtual unless the class is sealed.

  • The method should be protected or public, unless the class is internal.

For instance, the following class would enable aspects (applied on this class or on derived classes) to be initialized after deserialization (note that PostSharp automatically generates this code for BinaryFormatter and DataContractSerializer; you only need to do it manually for a custom serializer).

Copy
[DataContract]
public abstract class BaseClass
{
  protected virtual void InitializeAspects()
  {
  }

  [OnDeserializing]
  private void OnDeserializingInitializeAspects()
  {
    this.InitializeAspects();
  }
}

By Invoking AspectUtilities.InitializeCurrentAspects

Instead of providing an empty method InitializeAspects, it is possible to invoke the method AspectUtilities..::.InitializeCurrentAspects()()(). A call to this method will be translated into a call to InitializeAspects. It has to be invoked from a non-static method of an enhanced class.

If the class from which InitializeCurrentAspects()()() is invoked has not been enhanced by an aspect requiring initialization, the call to this method is simply ignored.

Note

Using this approach may be brittle in some situations: calls to InitializeCurrentAspects()()() will have no effect if aspects are applied to derived classes, but not to the calling class. In this scenario, it is preferable to define the method InitializeAspects.


Aspect Serialization

Aspect Serialization
See Also Send Feedback

As explained in section Understanding Aspect Lifetime and Scope, aspect are first instantiated at build time by the weaver, are then initialized by the CompileTimeInitialize method, and serialized and stored in the assembly as a managed resource.

By default, aspects are serialized using the standard BinaryFormatter of the .NET Framework. This serializer is suitable for most scenarios. However, there are one case in which the default serializer will not work: if the enhanced assembly will be called with partial trust (BinaryFormatter requires full trust).

It is possible to override the default behavior and to specify a different serializer.

Note

This section does not apply to Silverlight and the Compact Framework, which by default use, and must use, MsilAspectSerializer.

Available Serializers

An aspect serializer is any class implementing AspectSerializer.

PostSharp comes with the following implementations:

Serializer Type | Description
BinaryAspectSerializer | The default serializer, backed by BinaryFormatter.
XmlAspectSerializer | This serializer is backed by XmlSerializer.
StateBagAspectSerializer | A custom but lightweight serializer requiring aspect classes to implement the interface IStateBagSerializable.
MsilAspectSerializer | This is actually not a serializer. When you use this implementation instead of a real serializer, the aspect is not serialized, but the weaver generates MSIL instructions to build the aspect instance at runtime, by calling the aspect class constructor and by setting its fields and properties.

You can define your own serializer by implementing the abstract class AspectSerializer.

Tip

For optimal runtime performance and assembly size, use the MsilAspectSerializer whenever an aspect do not need to persist information betweeb compile- and run-time, i.e. when the method CompileTimeInitialize is not used.

Specifying Which Serializer Should Be Used

You can specify which serializer should be used for a specific aspect class by setting the property AspectConfiguration..::.SerializerType of the configuration of this aspect class or instance.

See section Configuring Aspects for details.

The following code shows how to choose the serializer type for an OnMethodBoundaryAspect:

CopyChoosing the aspect serializer
[Serializable]
[OnMethodBoundaryAspectConfiguration(SerializerType=typeof(MsilAspectSerializer))]
public sealed MyAspect : OnMethodBoundaryAspect

See Also

Reference

AspectSerializer
BinaryAspectSerializer
XmlAspectSerializer
StateBagAspectSerializer
MsilAspectSerializer
AspectConfiguration..::.SerializerType

Other Resources

Configuring Aspects


Configuring Aspects

Configuring Aspects
Send Feedback

Configuration settings of aspects determine how they should be processed by their weaver. Configuration settings are always evaluated at built time. Most aspects have one or many of them. For instance, the aspect type OnExceptionAspect has a configuration setting determining the type of exceptions handled with this aspect.

There are two ways to configure an aspect: declarative and imperative.

Declarative Configuration

You can configure an aspect declaratively by applying the appropriate custom attribute on the aspect class. Aspect configuration attributes are in the namespace PostSharp.Aspects.Configuration. Every aspect type has its corresponding type of configuration attribute: The name of the custom attribute starts with the name of the aspect and has the suffix ConfigurationAttribute. For instance, the configuration attribute of the aspect class OnExceptionAspect is OnExceptionAspectConfigurationAttribute.

Declarative configuration has always precedence over imperative configuration: if some property of the configuration custom attribute is set on the aspect class, or on any parent, the corresponding imperative semantic will not be evaluated.

Once a configuration property has been set in a parent class, it cannot be overwritten in a child class.

Note that these restrictions are enforced at the level of properties. If a property of a configuration custom attribute is not set in a parent class, it can still be overwritten in a child class or by an imperative semantic.

Imperative Configuration

A second way to configure an aspect class is to override its configuration methods or set its configuration property.

Note

Imperative configuration is only available when you target the full .NET Framework. It is not available for Silverlight or the Compact Framework.

Benefits of Imperative Configuration

The advantage of imperative configuration is that it can be arbitrarily complex (since the code of the configuration method is executed inside the weaver). Specifically, it allows the configuration to be dependent on how the aspect is actually used, for instance the configuration can depend on the value of a property of the aspect custom attribute.

Implementation Note

Under the hood, aspects implement the method IAspectBuildSemantics..::.GetAspectConfiguration(Object). This method should return a configuration object, derived from the class AspectConfiguration. Every aspect class has its own aspect configuration class. For instance, the configuration attribute of the aspect class OnExceptionAspect is OnExceptionAspectConfiguration. The aspect type OnExceptionAspect implements IAspectBuildSemantics..::.GetAspectConfiguration(Object) by creating an instance of OnExceptionAspectConfiguration, then it invokes the method OnExceptionAspect..::.GetExceptionType(MethodBase) and copies the return value of this method to the property OnExceptionAspectConfiguration..::.ExceptionType. Therefore, there are two ways to configure an aspect: either by overriding configuration methods and setting configuration properties (these methods and properties are provided by the framework for convenience only), either by implementing the method IAspectBuildSemantics..::.GetAspectConfiguration(Object). If your aspect does not derive from the aspect class OnExceptionAspect, but directly implements the aspect interface IOnExceptionAspect, you can use only the later method.


Extending PostSharp

Extending PostSharp
Send Feedback

PostSharp can be extended by programming directly to the library PostSharp.Sdk.dll. This is however no easy task: it requires an advanced knowledge of both MSIL and PostSharp SDK.

The SDK documentation is not available at the moment. SharpCrafters apologizes for inconvenience.


Using PostSharp with ASP.NET

Using PostSharp with ASP.NET
See Also Send Feedback

There are two ways to develop web applications using Microsoft .NET:

  • ASP.NET Application projects are very similar to other projects; they need to be built before they can be executed. Since they are built using MSBuild, you can use PostSharp as with any other kind of project.
  • ASP.NET Site projects are very specific: there is no project file (a site is actually a directory), and these projects must not be built. Although they don't use MSBuild, you can theoretically still use PostSharp with ASP.NET site projects thanks to the project PostSharp4AspNet. As explained on the home page of this project, using PostSharp with ASP.NET Site projects is not recommended and not officially supported.

See Also

Other Resources

PostSharp4AspNet


Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework

Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework
Send Feedback

You can use PostSharp to your projects targeting Silverlight, or the .NET Compact Framework, or Windows Phone 7.

Instead of adding a reference to PostSharp.dll, you should add a reference to PostSharp.SL.dll (for Silverlight and Windows Phone) or PostSharp.CF.dll (for .NET Compact Framework).

Limitations

Because Silverlight or Compact Framework projects are not linked to the normal .NET Frameworks (the public key of mscorlib and even the name of other system assemblies differ), assemblies generated from these projects cannot be loaded into the CLR.

This has a number of direct consequences:

  • Aspects are not instantiated at build time by PostSharp.

  • Therefore, aspects are not serialized.

  • Compile-time semantics like CompileTimeValidate, CompileTimeInitialize, IAspectBuildSemantics or IAspectProvider, are not supported.

Working with Simple Aspects

Instantiation of Aspects

Since aspects cannot be instantiated and initialized at build time, they are instantiated at run-time. Ad-hoc MSIL instructions are generated (calling the proper constructor and initializing fields and properties) are emitted in static constructors.

You can require PostSharp to use the same strategy for aspect instantiation by setting the aspect serializer to MsilAspectSerializer. See Aspect Serialization for details.

Note that there is no equivalent to CompileTimeValidate and CompileTimeInitialize for small frameworks.

Configuring Aspects

Some aspects need to be configured at build time. For instance, the method OnExceptionAspect..::.GetExceptionType(MethodBase) determines the type of exceptions to be caught. This method is called at build time, because the type should be known to inject the exception handler.

Since PostSharp for small frameworks does not support compile-time semantics, this method is simply not available.

Fortunately, there is another mean of configuring aspects: custom attributes. Every aspect has a custom attribute class configuring it. See Configuring Aspects for details. The custom attribute configuring OnExceptionAspect is OnExceptionAspectConfigurationAttribute.

CopyConfiguring an aspect without compile-time imperative semantics
[OnExceptionAspectConfiguration(ExceptionType = "System.SystemException, mscorlib")]
public class ExceptionHandlerAttribute : OnExceptionAspect
{
  public override void OnException(MethodExecutionEventArgs eventArgs)
  {
    // Show a dialog box.
  }
}

Developing Complex Aspects

The limitations caused by the inability to load aspects in the CLR are severe.

If you have more complex requirements, PostSharp Laos provides you the possibility to execute code inside PostSharp to validate and initialize aspects, or to develop aspects composed of many advices (or sub-aspects).

The approach is however more cumbersome than with the full framework. Indeed, the compile-time logic should be in a separate assembly, because this one should be linked to the full framework.

In order to develop a complex aspect for a small framework, you have to go through the following steps.

Developing external aspects

  1. Create a new aspect class. Derive it from ExternalAspect. Define the semantics (uniquely constructors and properties) of your aspect. This class is called the aspect semantic. Indeed, it has no implementation logic (methods, even implementation of property setters, are never executed).

  2. Create another class library project linked to the full .NET Framework.

  3. Create a class implementing IExternalAspectImplementation. This interface is similar to IAspectProvider. It has a single method ProvideImplementationAspects(Object, ObjectConstruction). The argument ObjectConstruction gives the type of the aspect semantic, constructor arguments, and named arguments. This method must return a set of aspect instances. The aspect types must reside in an assembly linked to Silverlight or the .NET Compact Framework. Aspect instance may contain an AspectConfiguration.

  4. Annotate the aspect semantic class with the custom attribute ExternalAspectConfigurationAttribute and specify the assembly-qualified name of the aspect implementation type.


Combining PostSharp with ILMerge

Combining PostSharp with ILMerge
Send Feedback

You can use ILMerge to combine PostSharp.dll, or assemblies processed by PostSharp, into a large assembly. However, all assemblies enhanced by aspects must be made aware of this.

As explained in Understanding Aspect Lifetime and Scope, aspects are serialized at build time and deserialized at run time. Serialization data include the type name of aspects. If aspect classes are moved to a different assembly, the deserializer will complain that the aspect type does not exist any more.

Therefore, you have to make the serializer aware of the new name of assemblies. This can be achieved by tweaking the BinaryAspectSerializationBinder object.

CopyMaking the aspect serializer aspect of an assembly name change
((BinaryAspectSerializationBinder) BinaryAspectSerializer.Binder).Retarget("OldAssemblyName", "MergedAssemblyName");

The aspect serializer must be configured before aspects are deserialized, i.e. before the first class affected by an aspect is accessed by the program.

Note

You can also provide your own implementation of SerializationBinder by setting the property BinaryAspectSerializer..::.Binder.


Combining PostSharp with an Obfucation Tool

Combining PostSharp with an Obfucation Tool
Send Feedback

Obfuscating an assembly enhanced by PostSharp is possible but may be problematic. Indeed, obfuscation is likely to break the serialization data of aspects (see Understanding Aspect Lifetime and Scope).

If you want to obfuscate an assembly enhanced by PostSharp:

  • Do not obfuscate the name of aspect types and fields of aspect types, or of any object serialized in aspects.

  • Do not store reflection objects (such as a Type or a MethodBase) in serialized aspect fields.

  • Do not use the parameter of the method RuntimeInitialize if the aspect is to be used on a generic method. Because of a bug in the CLR, PostSharp must store the signature of generic methods as a string.


Code Analysis (FxCop)

Code Analysis (FxCop)
Send Feedback

Code Analysis for managed code analyzes managed assemblies and reports information about the assemblies, such as violations of the programming and design rules set forth in the Microsoft .NET Framework Design Guidelines.

The analysis tool represents the checks it performs during an analysis as warning messages. Warning messages identify any relevant programming and design issues and, when it is possible, supply information about how to fix the problem.

Code Analysis in integrated into Visual Studio Premium or Visual Studio Ultimate. The same product is available for free and is known as FxCop; FxCop requires manual integration with your build scripts.

Code Analysis must process assemblies before they have been processed by PostSharp. Indeed, PostSharp may add internal and private members, or generate instructions, that do not comply to Code Analysis rules. However, the warnings you would get from analyzing post-processed assemblies are not likely to be relevant.

PostSharp reconfigures the build process so that Code Analysis is executed on the assemblies as they were before being enhanced by PostSharp. If you are using Code Analysis as an integrated part of Visual, no change of configuration is required.

If you are executing FxCop manually or by using custom MSBuild integration, you should process assemblies from directories obj\CodeAnalysis\Before-PostSharp instead of bin\CodeAnalysis.


Using PostSharp Diagnostic Build

Using PostSharp Diagnostic Build
Send Feedback

Every distribution of PostSharp contains two builds: release and diagnostic. The release build is used by default and should be used in normal situations. The diagnostic build should be used for troubleshooting.

There are two ways to execute PostSharp is diagnostic mode:

  • Start PostSharp Diagnostic Console and check the option Diagnostic Mode, or

  • Set the MSBuild property PostSharpBuild to Diag as described in Configuring PostSharp.

Differences Between the Release and Diagnostic Builds

The release and diagnostic builds of PostSharp are significantly different. The release build is intended to be used by most users; it is optimized for performance. The diagnostic build is intended to be used by developers who work directly with PostSharp SDK. It is optimized for ease of development.

The differences between both builds are the following:

  • The diagnostic builds emit declarations of the module in the same order as the input module; it is therefore possible to compare input assemblies using a text comparison tool. Some of the collection classes have different implementation and class hierarchy in the debug than in the release build.

  • In the diagnostic build, PostSharp libraries are defended by many assertion and precondition checks. It makes it much easier to understand errors in user code.

  • The diagnostic build writes nice and human-readable MSIL.

  • The diagnostic build allows you to put comments in MSIL code so that you can more easily diagnose the problems.

  • The diagnostic build is therefore significantly (about 10%) slower than the release build.

Important

If you program directly to PostSharp SDK, you should always use a diagnostic build for development and run tests against a release build.


Tracing Compile-Time Logic

Tracing Compile-Time Logic
Send Feedback

Tracing often makes it easier to understand what happens in your program. This is also true with compile-time logic.

Enabling Tracing

The tracing facility is totally disabled in the release build; you have to run the diagnostic build. Every distribution of PostSharp contains both builds.

The easiest way to run PostSharp in diagnostic mode is to run the PostSharp Diagnostic Console (postsharp-diag.exe); if you installed PostSharp with the setup program, you should find a link in your Start menu. Check the box Diagnostic Mode and select the tracing categories you are interested in. Then click the Start button, and when the build is done click the View Details button.

This utility does actually nothing else than building an MSBuild command line. Two MSBuild properties control tracing: PostSharpBuild should be set to Diag and PostSharpTrace should be a semicolon-separated list of trace categories.

msbuild MyProject.csproj /p:PostSharpBuild=Diag /p:PostSharpTrace="AssemblyBinding;Project" /v:detailed

Emitting Custom Tracing Information

If you want to write your own tracing information, you have to use the PostSharp tracing facility.

The design pattern to create a tracing category is to define a static class, for instance MyTrace with a singleton instance initialized to a new instance of the Traceclass.

Copy
internal static class MyTrace
{
  public static readonly PostSharpTrace MyCategory = new PostSharpTrace("MyCategory");
}

MyTrace.MyCategory.WriteLine("Hello, world.").


Debugging Compile-Time Logic

Debugging Compile-Time Logic
Send Feedback

It may seem unusual to debug compile-time logic, but like any process, it is perfectly legal and even simple to debug the build process!

Basically, what you will do is to attach a debugger to the PostSharp process. If you use the standard MSBuild targets for PostSharp, define the constant PostSharpAttachDebugger=True.

The trick is easier to explain when you have compile-time logic (your aspect, for instance) and the transformed assembly in different Visual Studio projects.

Suppose you have a your aspects logic MyAspects.csproj and unit tests (i.e. the code to be transformed) in MyAspects.Test.csproj. The easiest way to debug MyAspects.csproj is to:

  1. Open MyAspects.csproj and MyAspects.Test.csproj in two different instances of Visual Studio.

  2. Open the Visual Studio Command Prompt and go to the directory containing MyAspects.Test.csproj.

  3. Build MyAspects.csproj using Visual Studio as usually .

  4. From the command prompt, type:

    msbuild MyAspects.Test.csproj /T:Rebuild /P:PostSharpAttachDebugger=True

  5. The build process will hit a break point. When it happens, attach the instance of MyAspects.csproj Visual Studio. Set up break points in your code and continue the program execution.


Troubleshoot: PostSharp is not executed

Troubleshoot: PostSharp is not executed
Send Feedback

If PostSharp has been installed on your computer using the setup program but does not get executed, check that PostSharp is still inserted in MSBuild extension points.

Manual Procedure

You need to do something in every directory that you find on your system in the following list:

  • C:\Program Files (x86)\MSBuild\v2.0

  • C:\Program Files (x86)\MSBuild\v3.5

  • C:\Program Files (x86)\MSBuild\v4.0

  • C:\Program Files\MSBuild\v2.0

  • C:\Program Files\MSBuild\v3.5

  • C:\Program Files\MSBuild\v4.0

In these directories, locate the file Custom.After.Microsoft.Common.targets.

  • If the file Custom.After.Microsoft.Common.targets does notexist, create it:

    CopyIntroducing PostSharp in the standard MSBuild process
    <Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <Import Project="C:\Program Files\PostSharp 2.0\PostSharp.targets"
          Condition=" '$(DontImportPostSharp)' != 'True' "/>
</Project>

  • If the file Custom.After.Microsoft.Common.targets exists, just insert the <Import ... /> line in the <Project/> element.

Automatic Procedure

Execute the program PostSharp.Setup.exe with the following command line:

Copy
PostSharp.Setup.exe install


Example: Tracing Method Execution

Example: Tracing Method Execution
Example Send Feedback

This code implements an aspect that writes a trace message before and after the execution of the methods to which the aspect is applied.

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

The example demonstrates the use of OnMethodBoundaryAspect, and shows how to use RuntimeInitialize(MethodBase) to improve runtime performance.

Example

CopyC#
using System;
using System.Diagnostics;
using System.Reflection;
using PostSharp.Aspects;

namespace Samples
{
    [Serializable]
    public sealed class TraceAttribute : OnMethodBoundaryAspect
    {
        // This field is initialized and serialized at build time, then deserialized at runtime.
        private readonly string category;

        // These fields are initialized at runtime. They do not need to be serialized.
        [NonSerialized] private string enteringMessage;
        [NonSerialized] private string exitingMessage;

        // Default constructor, invoked at build time.
        public TraceAttribute()
        {
        }

        // Constructor specifying the tracing category, invoked at build time.
        public TraceAttribute( string category )
        {
            this.category = category;
        }

        // Invoked only once at runtime from the static constructor of type declaring the target method.
        public override void RuntimeInitialize( MethodBase method )
        {
            string methodName = method.DeclaringType.FullName + method.Name;
            this.enteringMessage = "Entering " + methodName;
            this.exitingMessage = "Exiting " + methodName;
        }

        // Invoked at runtime before that target method is invoked.
        public override void OnEntry( MethodExecutionArgs args )
        {
            Trace.WriteLine( this.enteringMessage, this.category );
        }

        // Invoked at runtime after the target method is invoked (in a finally block).
        public override void OnExit( MethodExecutionArgs args )
        {
            Trace.WriteLine( this.exitingMessage, this.category );
        }
    }
}

Remarks

Note that fields enteringMessage and exitingMessage are initialized from method RuntimeInitialize. This method is invoked only once, before the aspect instance is used for the first time. It may have been possible to format the trace message from methods OnEntry and OnExit, but doing so would hurt performance for two reasons:

  1. Getting the reflection object (MethodBase) is rather expensive.

  2. Concatenating a string creates a new string instance, which causes an overhead to memory allocation and garbage collection.

The aspect results in instructions that can be inlined by the JIT/NGen compiler, which makes the aspect almost as fast as hand-written code.


Example: Handling Exceptions

Example: Handling Exceptions
Example Send Feedback

This code is an aspect that handles exceptions by opening a message box. It is useful in WPF applications to handle specific exceptions, for instance of type IOException

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

This example demonstrates the aspect type OnExceptionAspect.

Example

CopyC#
using System;
using System.Reflection;
using System.Windows;
using PostSharp.Aspects;

namespace Samples
{
    [Serializable]
    public sealed class ExceptionDialogAttribute : OnExceptionAspect
    {
        // We don't need this field at runtime, so we don't serialize it.
        [NonSerialized] private readonly Type exceptionType;

        public ExceptionDialogAttribute() : this( null )
        {
        }

        public ExceptionDialogAttribute( Type exceptionType )
        {
            this.exceptionType = exceptionType;

            // Set the default value for the dialog box.
            this.Message = "{0}";
            this.Caption = "Error";
        }

        public string Message { get; set; }
        public string Caption { get; set; }

        // Method invoked at build time. Should return the type of exceptions to be handled.
        public override Type GetExceptionType( MethodBase method )
        {
            return this.exceptionType;
        }

        // Method invoked at run time.
        public override void OnException( MethodExecutionArgs args )
        {
            // Format the exception message.
            string message = string.Format( this.Message, args.Exception.Message );

            // Finds the parent window of the dialog box.
            DependencyObject dependencyObject = args.Instance as DependencyObject;
            Window window = null;
            if (dependencyObject != null)
            {
                window = Window.GetWindow(dependencyObject);
            }

            if ( window != null )
            {
                // Display the error dialog with a parent window.
                MessageBox.Show( window, message, this.Caption, MessageBoxButton.OK, MessageBoxImage.Error );
            }
            else
            {
                // Display the error dialog without a parent window.
                MessageBox.Show( message, this.Caption, MessageBoxButton.OK, MessageBoxImage.Error );
            }

            // Do not rethrow the exception.
            args.FlowBehavior = FlowBehavior.Return;
        }
    }
}


Example: Caching the Result of a Method

Example: Caching the Result of a Method
Example See Also Send Feedback

The following class implements an aspect that caches the return value of methods to which it is applied.

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

The example demonstrates the use of OnMethodBoundaryAspect, and shows how to use FlowBehavior to skip the execution of a method when its value is found in cache. The property MethodExecutionTag is used to store the cache key between the OnEntry()()() and OnSuccess()()() advices.

Example

Copy
using System;
using System.Reflection;
using System.Text;
using System.Web;
using PostSharp.Aspects;

namespace Samples
{
    [Serializable]
    public sealed class CacheAttribute : OnMethodBoundaryAspect
    {
        // This field will be set by CompileTimeInitialize and serialized at build time,
        // then deserialized at runtime.
        private string methodName;

        // Method executed at build time.
        public override void CompileTimeInitialize( MethodBase method, AspectInfo aspectInfo )
        {
            this.methodName = method.DeclaringType.FullName + "." + method.Name;
        }

        private string GetCacheKey( object instance, Arguments arguments )
        {
            // If we have no argument, return just the method name so we don't uselessly allocate memory.
            if ( instance == null && arguments.Count == 0 )
                return this.methodName;

            // Add all arguments to the cache key. Note that generic arguments are not part of the cache
            // key, so method calls that differ only by generic arguments will have conflicting cache keys.
            StringBuilder stringBuilder = new StringBuilder( this.methodName );
            stringBuilder.Append( '(' );
            if ( instance != null )
            {
                stringBuilder.Append( instance );
                stringBuilder.Append( "; " );
            }

            for ( int i = 0; i < arguments.Count; i++ )
            {
                stringBuilder.Append( arguments.GetArgument( i ) ?? "null" );
                stringBuilder.Append( ", " );
            }

            return stringBuilder.ToString();
        }

        // This method is executed before the execution of target methods of this aspect.
        public override void OnEntry( MethodExecutionArgs args )
        {
            // Compute the cache key.
            string cacheKey = GetCacheKey( args.Instance, args.Arguments );

            // Fetch the value from the cache.
            object value = HttpRuntime.Cache[cacheKey];

            if ( value != null )
            {
                // The value was found in cache. Don't execute the method. Return immediately.
                args.ReturnValue = value;
                args.FlowBehavior = FlowBehavior.Return;
            }
            else
            {
                // The value was NOT found in cache. Continue with method execution, but store
                // the cache key so that we don't have to compute it in OnSuccess.
                args.MethodExecutionTag = cacheKey;
            }
        }

        // This method is executed upon successful completion of target methods of this aspect.
        public override void OnSuccess( MethodExecutionArgs args )
        {
            string cacheKey = (string) args.MethodExecutionTag;
            HttpRuntime.Cache[cacheKey] = args.ReturnValue;
        }
    }
}

Remarks

Note that the field methodName is initialized from method CompileTimeInitialize(MethodBase, AspectInfo). This method is invoked at build time, then the value of the field is serialized into the assembly. Thanks to this mechanism, no reflection is needed at runtime.

See Also

Reference

OnMethodBoundaryAspect
MethodExecutionArgs..::.FlowBehavior
MethodLevelAspect..::.CompileTimeInitialize(MethodBase, AspectInfo)


Example: Dispatching a Method Execution to the GUI Thread

Example: Dispatching a Method Execution to the GUI Thread
Example See Also Send Feedback

This code implements an aspect that causes methods to which it is applied to be invoked on the GUI thread. Indeed, properties and methods of WPF objects can be accessed only from the thread from which the object was created. Other threads must use the Dispatcher of this object to dispatch the invocation of the method to the GUI thread. The Asynchronous property of this aspect allows the developer to specify that the method should be invoked asynchronously; in this case, the current thread will not wait until completion of the intercepted method.

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

This example demonstrates the use of MethodInterceptionAspect to intercept invocations of method. Additionally, it shows bow to use CompileTimeValidate(MethodBase) to check that the aspect has been applied on a valid method.

Example

Copy
using System;
using System.Linq;
using System.Reflection;
using System.Windows.Threading;
using PostSharp.Aspects;
using PostSharp.Extensibility;

namespace Samples
{
    [Serializable]
    [MulticastAttributeUsage(MulticastTargets.Method, TargetMemberAttributes = MulticastAttributes.Instance)]
    [AttributeUsage(AttributeTargets.Assembly|AttributeTargets.Class|AttributeTargets.Method, AllowMultiple = true)]
    public class GuiThreadAttribute : MethodInterceptionAspect
    {
        public bool Asynchronous { get; set; }

        // Method invoked at build time. It validates that the aspect has been applied to an acceptable method.
        public override bool CompileTimeValidate( MethodBase method )
        {
            // The method must be in a type derived from DispatcherObject.
            if ( !typeof(DispatcherObject).IsAssignableFrom( method.DeclaringType ) )
            {
                Message.Write( SeverityType.Error, "CUSTOM02",
                               "Cannot apply [GuiThread] to method {0} because it is not a member of a type " +
                               "derived from DispatcherObject.", method );
                return false;
            }

            // If the call is asynchronous, there should not be any return value or ByRef parameter.
            if ( this.Asynchronous )
            {
                if ( ((MethodInfo) method).ReturnType == typeof(void) ||
                    method.GetParameters().Any( parameter => parameter.ParameterType.IsByRef ) )
                {
                    Message.Write( SeverityType.Error, "CUSTOM02",
                                  "Cannot apply [GuiThread(Asynchronous=true)] to method {0} because it is not a member " +
                                  "of a type derived from DispatcherObject.", method );
                    return false;
                }
            }

            return true;
        }

        // Method invoked at run time _instead_ of the intercepted method.
        public override void OnInvoke( MethodInterceptionArgs args )
        {
            // Get the graphic object.
            DispatcherObject dispatcherObject = (DispatcherObject) args.Instance;

            // Check whether the current thread has access to this object.
            if ( dispatcherObject.CheckAccess() )
            {
                // We have access. Proceed with invocation.
                args.Proceed();
            }
            else
            {
                // We don't have access. Invoke the method synchronously.
                if ( this.Asynchronous )
                {
                    dispatcherObject.Dispatcher.BeginInvoke( DispatcherPriority.Normal, new Action( args.Proceed ) );
                }
                else
                {
                    dispatcherObject.Dispatcher.Invoke( DispatcherPriority.Normal, new Action( args.Proceed ) );
                }
            }
        }
    }
}

See Also

Reference

MethodInterceptionAspect
CompileTimeValidate(MethodBase)


Example: Backing a Property with a Registry Value

Example: Backing a Property with a Registry Value
Example See Also Send Feedback

This code is an aspect that binds a field or a property with a registry value. The first time the field or property is read, its value is retrieved from registry. Whenever the field or property is written, its value is written to registry.

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

This example illustrates the use of the aspect type LocationInterceptionAspect in a situation where the location getter invokes the setter. It shows how the aspect can implement IInstanceScopedAspect to get the same scope (static or instance) than the location to which it is applied; thanks to this, we can use an aspect field (fetchedFromRegistry) to store the information whether the value has already been fetched from registry.

Example

Copy
using System;
using Microsoft.Win32;
using PostSharp.Aspects;

namespace Samples
{
    public sealed class RegistryValueAttribute : LocationInterceptionAspect, IInstanceScopedAspect
    {
        // True if the the value has already been fetched from registry and stored in the field or property.
        // It is not serialize since we don't need it at build time.
        [NonSerialized] private bool fetchedFromRegistry;

        public RegistryValueAttribute(string keyName, string valueName)
        {
            this.KeyName = keyName;
            this.ValueName = valueName;
        }

        public string KeyName { get; private set; }
        public string ValueName { get; private set; }
        public object DefaultValue { get; set; }

        // Invoked at runtime whenever someone gets the value of the field or property.
        public override void OnGetValue(LocationInterceptionArgs args)
        {
            if (!this.fetchedFromRegistry)
            {
                // We have not fetched the value from registry. Do it now.
                object value = Registry.GetValue(this.KeyName, this.ValueName, this.DefaultValue);

                // Store this value in the target field/property.
                args.SetNewValue(value);

                // Return this value (we don't even need to call the underlying getter).
                args.Value = value;
            }
            else
            {
                // The value is already stored in the field/property, so just call the
                // underlying getter.
                args.ProceedGetValue();
            }
        }

        // Invoked at runtime whenever someone gets the value of the field or property.
        public override void OnSetValue(LocationInterceptionArgs args)
        {
            // Store the new value in registry if it has changed.
            if (object.Equals(args.Value, args.GetCurrentValue()))
            {
                Registry.SetValue(this.KeyName, this.ValueName, args.Value);
            }

            // Call the underlying setter.
            base.OnSetValue(args);

            // Sets that the underlying field/property already stores the field.
            this.fetchedFromRegistry = true;
        }

        #region Implementation of IInstanceScopedAspect
        object IInstanceScopedAspect.CreateInstance(AdviceArgs adviceArgs)
        {
            return this.MemberwiseClone();
        }

        void IInstanceScopedAspect.RuntimeInitializeInstance()
        {
        }
        #endregion
    }
}

See Also

Reference

LocationInterceptionAspect
IInstanceScopedAspect


Example: Making an Event Asynchronous

Example: Making an Event Asynchronous
Example See Also Send Feedback

This code is an aspect making an event asynchronous. When an event enhanced with this aspect is fired, subscribed handlers are invoked asynchronously. Whenever a subscribed handler fails with an exception, it is removed from the list of subscribers of this event.

Requirements

PostSharp 2.0 Professional Edition or higher

Demonstrates

This example illustrates the use of the aspect type EventInterceptionAspect.

Example

CopyC#
using System;
using System.Diagnostics;
using System.Threading.Tasks;
using PostSharp.Aspects;

namespace Samples
{
    [Serializable]
    public sealed class AsyncEventAttribute : EventInterceptionAspect
    {
        public override void OnInvokeHandler( EventInterceptionArgs args )
        {
            // Invoke the event handler asynchronously.
            Task.Factory.StartNew( () => Invoke( args ) ).Start();
        }

        private static void Invoke( EventInterceptionArgs args )
        {
            try
            {
                // Invoke the event handler.
                args.ProceedInvokeHandler();
            }
            catch ( Exception e )
            {
                // Remove the event handler if it failed.
                Trace.TraceError( e.ToString() );
                args.ProceedRemoveHandler();
            }
        }
    }
}

See Also

Reference

EventInterceptionAspect


Example: Dynamically Introducing an Interface

Example: Dynamically Introducing an Interface
Example See Also Send Feedback

This aspect implement a very general way to compose types using a custom attribute. The custom attribute has two parameters: the type of the interface to be introduced, and the type of the class implementing the interface. This class should have a default constructor.

Requirements

PostSharp 2.0 Community Edition or higher

Demonstrates

This example demonstrates the use of CompositionAspect.

Example

CopyC#
using System;
using System.Collections;
using PostSharp;
using PostSharp.Aspects;

namespace Samples
{
    [Serializable]
    public sealed class GeneralComposeAttribute : CompositionAspect
    {
        // We don't need this field at runtime, so we mark it as non-serialized.
        [NonSerialized]
        private readonly Type interfaceType;

        private readonly Type implementationType;

        public GeneralComposeAttribute(Type interfaceType, Type implementationType)
        {
            this.interfaceType = interfaceType;
            this.implementationType = implementationType;
        }

        // Invoked at build time. We return the interface we want to implement.
        protected override Type[] GetPublicInterfaces(Type targetType)
        {
            return new[] { this.interfaceType };
        }

        // Invoked at run time.
        public override object CreateImplementationObject(AdviceArgs args)
        {
            return Activator.CreateInstance(this.implementationType);
        }
    }

    [GeneralCompose(typeof(IList), typeof(ArrayList))]
    internal class TestCompose
    {
        public TestCompose()
        {
            // Note the use of the Post.Cast method to get the implemented interface.
            IList list = Post.Cast<TestCompose, IList>(this);
            list.Add("apple");
            list.Add("orange");
            list.Add("banana");

        }
    }
}

See Also

Reference

CompositionAspect


Example: Automatically Adding DataContract and DataMember Attributes

Example: Automatically Adding DataContract and DataMember Attributes
Example See Also Send Feedback

This aspect automatically adds custom attributes DataContract and DataMember to classes so they can be serialized by the WCF formatter. Properties that must not be serialized must be annotated with the custom attribute NotDataMemberAttribute.

Requirements

PostSharp 2.0 Professional Edition or higher

Demonstrates

This example demonstrates how CustomAttributeIntroductionAspect can be used together with IAspectProvider.

Example

CopyC#
using System;
using System.Collections.Generic;
using System.Reflection;
using System.Runtime.Serialization;
using PostSharp.Aspects;
using PostSharp.Extensibility;
using PostSharp.Reflection;

namespace Samples
{
    // We set up multicast inheritance so  the aspect is automatically added to children types.
    [MulticastAttributeUsage( MulticastTargets.Class, Inheritance = MulticastInheritance.Strict )]
    [Serializable]
    public sealed class AutoDataContractAttribute : TypeLevelAspect, IAspectProvider
    {
        // This method is called at build time and should just provide other aspects.
        public IEnumerable<AspectInstance> ProvideAspects( object targetElement )
        {
            Type targetType = (Type) targetElement;

            CustomAttributeIntroductionAspect introduceDataContractAspect =
                new CustomAttributeIntroductionAspect(
                    new ObjectConstruction( typeof(DataContractAttribute).GetConstructor( Type.EmptyTypes ) ) );
            CustomAttributeIntroductionAspect introduceDataMemberAspect =
                new CustomAttributeIntroductionAspect(
                    new ObjectConstruction( typeof(DataMemberAttribute).GetConstructor( Type.EmptyTypes ) ) );

            // Add the DataContract attribute to the type.
            yield return new AspectInstance( targetType, introduceDataContractAspect );

            // Add a DataMember attribute to every relevant property.
            foreach ( PropertyInfo property in
                targetType.GetProperties( BindingFlags.Public | BindingFlags.DeclaredOnly | BindingFlags.Instance ) )
            {
                if ( property.CanWrite && !property.IsDefined( typeof(NotDataMemberAttribute), false))
                    yield return new AspectInstance( property, introduceDataMemberAspect );
            }
        }
    }

    [AttributeUsage(AttributeTargets.Property)]
    public sealed class NotDataMemberAttribute : Attribute
    {

    }
}

See Also

Reference

CustomAttributeIntroductionAspect
IAspectProvider


Example: Raising an Event When the Object is Finalized

Example: Raising an Event When the Object is Finalized
Example See Also Send Feedback

This example shows an aspect that raises an event when instances of the target class is finalized (during garbage collection).

Requirements

PostSharp 2.0 Professional Edition or higher

Demonstrates

This example demonstrates how a composite aspect can be used to integrate an aspect with another implementation pattern, here IDisposable. It demonstrates that the lifetime of an instance-scoped aspect is bound to the lifetime of its target class.

Example

CopyC#
using System;
using PostSharp;
using PostSharp.Aspects;
using PostSharp.Aspects.Advices;
using PostSharp.CodeModel;

namespace Samples
{
    // The aspect will introduce and implement this interface.
    public interface IObservableLifetime
    {
        // Event raised when the object is disposed.
        event EventHandler Disposed;

        // Event raised when the object is finialized.
        event EventHandler Finalized;
    }

    // The annotation IntroduceInterface specifies that the aspect introduces this interface.
    [Serializable]
    [IntroduceInterface( typeof(IObservableLifetime), OverrideAction = InterfaceOverrideAction.Fail )]
    public class ObservableLifetimeAttribute : InstanceLevelAspect, IObservableLifetime
    {
        // True if the aspect instance is a 'real' instance, false if it is the prototype instance.
        // We do not want to raise the Finalize event on prototype instances.
        [NonSerialized] private bool notPrototype;

        // True if the aspect has already been invoked.
        [NonSerialized] private bool disposed;

        // Initializes the aspect instance.
        public override void RuntimeInitializeInstance()
        {
            this.notPrototype = true;
        }

        // At runtime, this field is set to a delegate of the method Dispose(bool) before we override it.
        [ImportMember( "Dispose", IsRequired = true, Order = ImportMemberOrder.BeforeIntroductions )]
        public Action<bool> BaseDisposeMethod;

        // Overrides the method Dispose(bool) of the target type.
        [IntroduceMember( IsVirtual = true, OverrideAction = MemberOverrideAction.OverrideOrFail, Visibility = Visibility.Family )]
        public void Dispose( bool disposing )
        {
            // Ignore subsequent calls of this method.
            if ( this.disposed )
                return;

            this.disposed = true;

            // Invoke the Dispose(bool) method of the base type.
            this.BaseDisposeMethod( disposing );

            // Raise the Disposed event.
            if ( this.Disposed != null )
                this.Disposed( this.Instance, EventArgs.Empty );

            // Unlist this object from finalization.
            if ( disposing )
            {
                GC.SuppressFinalize( this );
            }
        }

        // Introduces the event Disposed in the target type.
        [IntroduceMember( OverrideAction = MemberOverrideAction.Fail )]
        public event EventHandler Disposed;

        // Introduces the event Finalized in the target type.
        [IntroduceMember( OverrideAction = MemberOverrideAction.Fail )]
        public event EventHandler Finalized;

        // Finalizer.
        ~ObservableLifetimeAttribute()
        {
            // Ignore the finalizer if we are a prototype instance.
            if ( !this.notPrototype )
                return;

            // Call the Dispose method of the target type.
            this.BaseDisposeMethod( false );

            // Raise the Finalized event.
            if ( this.Finalized != null )
            {
                this.Finalized( this.Instance, EventArgs.Empty );
            }
        }
    }

    // A sample object.
    [ObservableLifetime]
    internal class DomainObject : IDisposable
    {
        private readonly string tag;

        public DomainObject( string tag )
        {
            this.tag = tag;
        }

        protected virtual void Dispose( bool disposing )
        {
            Console.WriteLine( "Dispose({0})", disposing );
        }

        public void Dispose()
        {
            this.Dispose( true );
        }

        public override string ToString()
        {
            return "{" + tag + "}";
        }
    }

    internal class Program
    {
        private static void Main( string[] args )
        {
            DomainObject f1 = new DomainObject( "f1" );
            IObservableLifetime fe1 = Post.Cast<DomainObject, IObservableLifetime>( f1 );
            fe1.Finalized += OnFinalized;
            f1.Dispose();

            DomainObject f2 = new DomainObject( "f2" );
            IObservableLifetime fe2 = Post.Cast<DomainObject, IObservableLifetime>( f2 );
            fe2.Finalized += OnFinalized;
            f2 = null;
            fe2 = null;
            GC.Collect();
            GC.WaitForPendingFinalizers();
        }

        private static void OnFinalized( object sender, EventArgs e )
        {
            Console.WriteLine( "OnFinalized: " + sender );
        }
    }
}

The output of this program is:

Copy
Dispose(True)
Dispose(False)
OnFinalized: {f2}

Remarks

This example is made more complex by the fact that it understands the disposable pattern. The aspect requires the target class to implement the disposable pattern properly, i.e. to define the method protected virtual void Dispose(bool). PostSharp will fail if the user tries to apply this aspect to a class that implements the pattern incorrectly.

The aspect overrides the Dispose(bool) method by defining a method of the same name and signature, and annotating it with the custom attribute IntroduceMemberAttribute.

In order to be able to invoke the original implementation of Dispose(bool), the aspect defines the field BaseDisposeMethod, whose type Action<bool> is a delegate compatible with the signature of the method Dispose(bool). The custom attribute ImportMemberAttribute tells PostSharp to bind this field to the Dispose method.

Because the aspect class derives from InstanceLevelAspect, which implements IInstanceScopedAspect, aspect instances have the same lifetime as instances of the target class: both instances are garbage collected at the same time. Thanks to this, the aspect can reliably raise the Finalized event on the class instance when the aspect instance itself is collected.

See Also

Reference

InstanceLevelAspect
ImportMemberAttribute
IntroduceMemberAttribute
IntroduceInterfaceAttribute

Other Resources

Understanding Aspect Lifetime and Scope
[e4599448-160c-4d56-8a75-f255195fcd17]


More Examples

More Examples
Send Feedback

You can find more examples:

  • Online, on SharpCrafters web site.

  • In the subdirectory Samples of the PostSharp installation or package.


PostSharp Namespace

PostSharp Namespace
Send Feedback
The PostSharp namespace is the root namespace of PostSharp.

Classes

 | Class | Description
Public class | Post | Provides some methods that are transformed during post-compilation.


Post Class

Post Class
Members See Also Send Feedback
Provides some methods that are transformed during post-compilation.

Namespace: PostSharp
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class Post

Inheritance Hierarchy

System..::.Object
PostSharp..::.Post

See Also

Post Members
PostSharp Namespace


Post Members

[image]

PostSharp 2.0 Documentation
Post Members
Post Class Methods Properties See Also Send Feedback

The Post type exposes the following members.

Methods

Name | Description
Cast<(Of <(SourceType, TargetType>)>) | At post-compile time, casts an instance of a type into another. A post-compile time error is reported if the source type cannot be assigned to the target type.
GetValue<(Of <(T>)>) | When used to retrieve the value of a field, forces the compiler to retrieve a copy of the field value instead of an address to this field. This allows to call instance methods of value-type fields without loading the field address.

Properties

Name | Description
IsTransformed | Determines whether the calling program has been transformed by PostSharp.

See Also

Post Class
PostSharp Namespace


Post Methods

[image]

PostSharp 2.0 Documentation
Post Methods
Post Class See Also Send Feedback

The Post type exposes the following members.

Methods

Name | Description
Cast<(Of <(SourceType, TargetType>)>) | At post-compile time, casts an instance of a type into another. A post-compile time error is reported if the source type cannot be assigned to the target type.
GetValue<(Of <(T>)>) | When used to retrieve the value of a field, forces the compiler to retrieve a copy of the field value instead of an address to this field. This allows to call instance methods of value-type fields without loading the field address.

See Also

Post Class
PostSharp Namespace


Cast(SourceType, TargetType) Method

Post..::..Cast<(Of <(<'SourceType, TargetType>)>)> Method
Post Class See Also Send Feedback
At post-compile time, casts an instance of a type into another. A post-compile time error is reported if the source type cannot be assigned to the target type.

Namespace: PostSharp
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TargetType Cast<SourceType, TargetType>(
    SourceType o
)
where SourceType : class
where TargetType : class

Parameters

o
Type: SourceType
Instance to be casted.

Type Parameters

SourceType
Source type.
TargetType
Target type.

Return Value

The object o casted as TargetType.

Remarks

The purpose of this method is to make a source code compilable even when an interface will be implemented at post-compile time. PostSharp ensures that TargetType is assignable from SourceType. If yes, the call to this method is simply suppressed. If types are not assignable, a build error is issued.

See Also

Post Class
PostSharp Namespace


GetValue(T) Method

Post..::..GetValue<(Of <(<'T>)>)> Method
Post Class See Also Send Feedback
When used to retrieve the value of a field, forces the compiler to retrieve a copy of the field value instead of an address to this field. This allows to call instance methods of value-type fields without loading the field address.

Namespace: PostSharp
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static T GetValue<T>(
    T value
)
where T : struct, new()

Parameters

value
Type: T
Value.

Type Parameters

T
Type of the value to retrieve (this type parameter can generally be omitted).

Return Value

value, exactly.

See Also

Post Class
PostSharp Namespace


Post Properties

[image]

PostSharp 2.0 Documentation
Post Properties
Post Class See Also Send Feedback

The Post type exposes the following members.

Properties

Name | Description
IsTransformed | Determines whether the calling program has been transformed by PostSharp.

See Also

Post Class
PostSharp Namespace


IsTransformed Property

Post..::..IsTransformed Property
Post Class See Also Send Feedback
Determines whether the calling program has been transformed by PostSharp.

Namespace: PostSharp
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsTransformed { get; }

Field Value

true if the calling program has been transformed by PostSharp, otherwise false.

See Also

Post Class
PostSharp Namespace


PostSharp.Aspects Namespace

PostSharp.Aspects Namespace
Send Feedback
The PostSharp.Aspects namespace provides the primitives of the PostSharp aspect-oriented framework, such as abstract aspect classes, aspect interfaces, and advise argument classes.

Classes

 | Class | Description
Public class | AdviceArgs | Base class for arguments of all advices.
Public class | Arguments | Encapsulation of method arguments.
Public class | Aspect | Base class for all aspects that are declared using multicast custom attributes (MulticastAttribute).
Public class | AspectInfo | Reserved for future usage.
Public class | AspectInstance | Completely specifies an aspect instance, including its target code element. An AspectInstance contains either the aspect instance itself (Aspect property), either information allowing to construct the aspect (AspectConstruction) and configure the weaver (AspectConfiguration).
Public class | AspectSpecification | Completely specifies an aspect instance (but not its target). An AspectSpecification either the aspect instance itself (Aspect property), either information allowing to construct the aspect (AspectConstruction) and configure the weaver (AspectConfiguration).
Public class | AspectUtilities | Utility methods for PostSharp.Aspects.
Public class | AssemblyLevelAspect | Base class for all aspects applied on assemblies.
Public class | CompositionAspect | Aspect that, when applied on a type, introduces one or many new interfaces into that type.
Public class | CustomAttributeIntroductionAspect | Aspect that, when applied to a target, adds a custom attribute to this target.
Public class | EventInterceptionArgs | Arguments of handlers of aspects of the type EventInterceptionAspect.
Public class | EventInterceptionAspect | Aspect that, when applied on an event, intercepts invocations of its semantics Add (OnAddHandler(EventInterceptionArgs)), Remove (OnRemoveHandler(EventInterceptionArgs)) and Invoke (OnInvokeHandler(EventInterceptionArgs)).
Public class | EventLevelAspect | Base class for all aspects applied on events.
Public class | ExternalAspect | Aspect implemented in a different type (implementing the IExternalAspectImplementation interface), typically contained in an external assembly. Classes derived from ExternalAspect must be annotated by the custom attribute ExternalAspectConfigurationAttribute.
Public class | FieldLevelAspect | Base class for all aspects applied on fields.
Public class | InstanceLevelAspect | Base class for aspects applied on types, but having the same lifetime as instances of the type to which they are applied.
Public class | LocationInterceptionArgs | Arguments of advices of aspect type LocationInterceptionAspect.
Public class | LocationInterceptionAspect | Aspect that, when applied on a location (field or property), intercepts invocations of the Get (OnGetValue(LocationInterceptionArgs)) and Set (OnSetValue(LocationInterceptionArgs)) semantics.
Public class | LocationLevelAspect | Base class for aspects defined in fields, properties, or parameters.
Public class | ManagedResourceIntroductionAspect | Aspect that, when applied to an assembly, adds a custom attribute to this assembly.
Public class | MethodExecutionArgs | Arguments of advices of aspects of type OnMethodBoundaryAspect and OnExceptionAspect
Public class | MethodInterceptionArgs | Arguments of advices of aspect type MethodInterceptionAspect.
Public class | MethodInterceptionAspect | Aspect that, when applied on a method, intercepts invocations of this method.
Public class | MethodLevelAspect | Base class for all aspects applied on methods.
Public class | OnExceptionAspect | Aspect that, when applied to a method, defines an exception handler around the whole method and calls a custom method in this exception handler.
Public class | OnMethodBoundaryAspect | Aspect that, when applied to a method defined in the current assembly, inserts a piece of code before and after the body of these methods.
Public class | TypeIdentity | Wraps a Type or a type name.
Public class | TypeLevelAspect | Base class for all aspects applied on types.

Structures

 | Structure | Description
Public structure | InstanceCredentials | Credentials that give access to 'protected' semantics.

Interfaces

 | Interface | Description
Public interface | IAspect | Base interface for run-time semantics of all aspects.
Public interface | IAspectBuildSemantics | Compile-time semantics of IAspect.
Public interface | IAspectProvider | Interface that, when implemented by an aspect class, allows aspect instances to provide other aspects to the weaver.
Public interface | IAssemblyLevelAspect | Runtime semantics of aspects applied at assembly level.
Public interface | IAssemblyLevelAspectBuildSemantics | Build-time semantics of aspects applied at assembly level.
Public interface | IComposed<(Of <(T>)>) | Interface exposing the implementation of another interface introduced by a CompositionAspect.
Public interface | ICompositionAspect | Defines the semantics of an aspect that, when applied on a type, introduce one or many new interfaces into that type, and let these interfaces be implemented by an object created at runtime.
Public interface | ICustomAttributeIntroductionAspect | Semantics of an aspect that, when applied to a target, adds a custom attribute to this target.
Public interface | IEventBinding | Interface through which an event-level aspect or advice can invoke the next node in the chain of invocation.
Public interface | IEventInterceptionAspect | Runtime semantics of an aspect that, when applied on an event, intercepts invocations of its semantics Add (OnAddHandler(EventInterceptionArgs)), Remove (OnRemoveHandler(EventInterceptionArgs)) and Invoke (OnInvokeHandler(EventInterceptionArgs)) semantics.
Public interface | IEventLevelAspect | Runtime semantics of aspects that can be applied on events.
Public interface | IEventLevelAspectBuildSemantics | Build-time semantics of aspects that can be applied on events.
Public interface | IExternalAspect | Allows to turn an arbitrary custom attribute into an aspect, while implementing the aspect in a different class. Classes implementing this interface must be annotated with the ExternalAspectConfigurationAttribute custom attribute.
Public interface | IExternalAspectImplementation | Implementation of an IExternalAspect.
Public interface | IFieldLevelAspect | Run-time semantics of aspects applied to fields.
Public interface | IFieldLevelAspectBuildSemantics | Compile-time semantics of IFieldLevelAspect.
Public interface | IInstanceScopedAspect | Runtime semantics of aspects that have the same lifetime as instance of types to which their are applied (or instance of the declaring type of members to which they are applied).
Public interface | ILocationBinding | Interface through which a field- or property-level aspect or advice can invoke the next node in the chain of invocation.
Public interface | ILocationInterceptionAspect | Runtime semantics of an aspect that, when applied on a location (field or property), intercepts invocations of the Get (OnGetValue(LocationInterceptionArgs)) and Set (OnSetValue(LocationInterceptionArgs)) semantics.
Public interface | ILocationLevelAspect | Runtime semantics of aspects defined on a field, property, or parameter.
Public interface | ILocationLevelAspectBuildSemantics | Compile-time semantics of IMethodLevelAspect.
Public interface | IManagedResourceIntroductionAspect | Semantics of an aspect that, when applied to an assembly, adds a managed resource to this assembly.
Public interface | IMethodBinding | Interface through which a method-level aspect or advice can invoke the next node in the chain of invocation.
Public interface | IMethodInterceptionAspect | Runtime semantics of an aspect that, when applied on a method, intercepts invocations of this method.
Public interface | IMethodLevelAspect | Runtime semantics of aspects applied to methods.
Public interface | IMethodLevelAspectBuildSemantics | Compile-time semantics of IMethodLevelAspect.
Public interface | IOnExceptionAspect | Runtime semantics of an aspect that, when applied on a method, defines an exception handler around the whole method body and let the implementation of this interface handle the exception.
Public interface | IOnMethodBoundaryAspect | Runtime semantics of OnMethodBoundaryAspect.
Public interface | IProtectedInterface<(Of <(T>)>) | Gives access to a 'protected' interface, typically introduced by a CompositionAspect or a IntroduceInterfaceAttribute
Public interface | ITypeLevelAspect | Run-time semantics of aspects applied to types.
Public interface | ITypeLevelAspectBuildSemantics | Compile-time semantics of ITypeLevelAspect.

Enumerations

 | Enumeration | Description
Public enumeration | FlowBehavior | Enumerates the possible behaviors of the calling method after the calling method has returned.


AdviceArgs Class

AdviceArgs Class
Members See Also Send Feedback
Base class for arguments of all advices.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AdviceArgs

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AdviceArgs
PostSharp.Aspects..::.EventInterceptionArgs
PostSharp.Aspects..::.LocationInterceptionArgs
PostSharp.Aspects..::.MethodExecutionArgs
PostSharp.Aspects..::.MethodInterceptionArgs

See Also

AdviceArgs Members
PostSharp.Aspects Namespace


AdviceArgs Members

[image]

PostSharp 2.0 Documentation
AdviceArgs Members
AdviceArgs Class Constructors Properties See Also Send Feedback

The AdviceArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AdviceArgs | Initializes a new AdviceArgs.

Properties

 | Name | Description
Public property | Instance | Gets or sets the object instance on which the method is being executed.
Public property | InstanceCredentials | Gets the credentials of the current instance.

See Also

AdviceArgs Class
PostSharp.Aspects Namespace


AdviceArgs Constructor

AdviceArgs Constructor
AdviceArgs Class See Also Send Feedback
Initializes a new AdviceArgs.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceArgs(
    Object instance
)

Parameters

instance
Type: System..::.Object
The instance related to the advice invocation, or null if the advice is associated to a static element of code.

See Also

AdviceArgs Class
PostSharp.Aspects Namespace


AdviceArgs Properties

[image]

PostSharp 2.0 Documentation
AdviceArgs Properties
AdviceArgs Class See Also Send Feedback

The AdviceArgs type exposes the following members.

Properties

 | Name | Description
Public property | Instance | Gets or sets the object instance on which the method is being executed.
Public property | InstanceCredentials | Gets the credentials of the current instance.

See Also

AdviceArgs Class
PostSharp.Aspects Namespace


Instance Property

AdviceArgs..::..Instance Property
AdviceArgs Class See Also Send Feedback
Gets or sets the object instance on which the method is being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object Instance { get; set; }

Remarks

This set may be set by user code only when the instance is a value type. As usually, user code is responsible for setting an object of the right type.

See Also

AdviceArgs Class
PostSharp.Aspects Namespace


InstanceCredentials Property

AdviceArgs..::..InstanceCredentials Property
AdviceArgs Class See Also Send Feedback
Gets the credentials of the current instance.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstanceCredentials InstanceCredentials { get; set; }

Remarks

Credentials allow to use protected interfaces like IComposed<(Of <(T>)>).

See Also

AdviceArgs Class
PostSharp.Aspects Namespace


Arguments Class

Arguments Class
Members See Also Send Feedback
Encapsulation of method arguments.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class Arguments : ICloneable

Remarks

Note
As a result of optimizations, an Arguments object may be shared between different advices. If an advice implementation needs to access an Arguments object after it has given over control, it should take a reference to a clone instead of the initial object itself.
Note
Implementations of this type should be considered an implementation detail and should not be accessed by user code.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.Arguments

See Also

Arguments Members
PostSharp.Aspects Namespace


Arguments Members

[image]

PostSharp 2.0 Documentation
Arguments Members
Arguments Class Methods Fields Properties See Also Send Feedback

The Arguments type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a shallow copy of the current object.
Public method | CopyFrom | Copies all the argument values from the elements of Array.
Public method | CopyTo | Copies all arguments values to the specified Array starting at the specified destination Array index.
Public method | GetArgument | Gets the value of the argument at a given index.
Public method | SetArgument | Sets the value of the argument at a given index.
Public method | ToArray | Converts the current argument list into an Array.

Fields

Name | Description
Empty | Empty list of Arguments.

Properties

 | Name | Description
Public property | Count | Gets the number of arguments encapsulated by the current object.
Public property | Item | Gets or sets the value of an argument.

See Also

Arguments Class
PostSharp.Aspects Namespace


Arguments Fields

[image]

PostSharp 2.0 Documentation
Arguments Fields
Arguments Class See Also Send Feedback

The Arguments type exposes the following members.

Fields

Name | Description
Empty | Empty list of Arguments.

See Also

Arguments Class
PostSharp.Aspects Namespace


Empty Field

Arguments..::..Empty Field
Arguments Class See Also Send Feedback
Empty list of Arguments.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly Arguments Empty

See Also

Arguments Class
PostSharp.Aspects Namespace


Arguments Methods

[image]

PostSharp 2.0 Documentation
Arguments Methods
Arguments Class See Also Send Feedback

The Arguments type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a shallow copy of the current object.
Public method | CopyFrom | Copies all the argument values from the elements of Array.
Public method | CopyTo | Copies all arguments values to the specified Array starting at the specified destination Array index.
Public method | GetArgument | Gets the value of the argument at a given index.
Public method | SetArgument | Sets the value of the argument at a given index.
Public method | ToArray | Converts the current argument list into an Array.

See Also

Arguments Class
PostSharp.Aspects Namespace


Clone Method

Arguments..::..Clone Method
Arguments Class See Also Send Feedback
Returns a shallow copy of the current object.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Arguments Clone()

Return Value

A shallow copy of the current object.

See Also

Arguments Class
PostSharp.Aspects Namespace


CopyFrom Method

Arguments..::..CopyFrom Method
Arguments Class See Also Send Feedback
Copies all the argument values from the elements of Array.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CopyFrom(
    Object[] array,
    int index
)

Parameters

array
Type: array< System..::.Object >[]()[][]
The array that is the source of the argument values copied into the current Arguments.
index
Type: System..::.Int32
An integer that represents the index in array at which copying begins.

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | index is lower than zero.

See Also

Arguments Class
PostSharp.Aspects Namespace
Arguments..::.CopyTo(array<Object>[]()[], Int32)


CopyTo Method

Arguments..::..CopyTo Method
Arguments Class See Also Send Feedback
Copies all arguments values to the specified Array starting at the specified destination Array index.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CopyTo(
    Object[] array,
    int index
)

Parameters

array
Type: array< System..::.Object >[]()[][]
The array that is the destination of argument values copied from the current Arguments.
index
Type: System..::.Int32
An integer that represents the index in array at which copying begins

See Also

Arguments Class
PostSharp.Aspects Namespace
Arguments..::.CopyFrom(array<Object>[]()[], Int32)


GetArgument Method

Arguments..::..GetArgument Method
Arguments Class See Also Send Feedback
Gets the value of the argument at a given index.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Object GetArgument(
    int index
)

Parameters

index
Type: System..::.Int32
Argument index.

Return Value

The value of the argument at position index.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is lower than zero or greater or equal than Count.

See Also

Arguments Class
PostSharp.Aspects Namespace


SetArgument Method

Arguments..::..SetArgument Method
Arguments Class See Also Send Feedback
Sets the value of the argument at a given index.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void SetArgument(
    int index,
    Object value
)

Parameters

index
Type: System..::.Int32
Argument index.
value
Type: System..::.Object
New value of the argument at position index.

Exceptions

Exception | Condition
System..::.InvalidCastException | value is not assignable to parameter at position index.
System..::.ArgumentOutOfRangeException | index is lower than zero or greater or equal than Count.

See Also

Arguments Class
PostSharp.Aspects Namespace


ToArray Method

Arguments..::..ToArray Method
Arguments Class See Also Send Feedback
Converts the current argument list into an Array.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object[] ToArray()

Return Value

An Array whose elements are equal to the values encapsulated by the current Arguments.

See Also

Arguments Class
PostSharp.Aspects Namespace


Arguments Properties

[image]

PostSharp 2.0 Documentation
Arguments Properties
Arguments Class See Also Send Feedback

The Arguments type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of arguments encapsulated by the current object.
Public property | Item | Gets or sets the value of an argument.

See Also

Arguments Class
PostSharp.Aspects Namespace


Count Property

Arguments..::..Count Property
Arguments Class See Also Send Feedback
Gets the number of arguments encapsulated by the current object.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

See Also

Arguments Class
PostSharp.Aspects Namespace


Item Property

Arguments..::..Item Property
Arguments Class See Also Send Feedback
Gets or sets the value of an argument.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object Item[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32
Argument index.

Return Value

The argument value.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is lower than zero or greater or equal than Count.

See Also

Arguments Class
PostSharp.Aspects Namespace


Aspect Class

Aspect Class
Members See Also Send Feedback
Base class for all aspects that are declared using multicast custom attributes (MulticastAttribute).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class Aspect : MulticastAttribute,
    IAspect, IAspectBuildSemantics, IValidableAnnotation

Remarks

This class is not specific to any kind of declaration (method, field, type, ...). Considering deriving your aspect from TypeLevelAspect, MethodLevelAspect, LocationLevelAspect, or EventLevelAspect if it should be applied to a specifc kind of declarations.

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.AssemblyLevelAspect
PostSharp.Aspects..::.EventLevelAspect
PostSharp.Aspects..::.ExternalAspect
PostSharp.Aspects..::.FieldLevelAspect
PostSharp.Aspects..::.LocationLevelAspect
PostSharp.Aspects..::.MethodLevelAspect
PostSharp.Aspects..::.TypeLevelAspect

See Also

Aspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization


Aspect Members

[image]

PostSharp 2.0 Documentation
Aspect Members
Aspect Class Constructors Methods Properties See Also Send Feedback

The Aspect type exposes the following members.

Constructors

 | Name | Description
Protected method | Aspect | Initializes a new instance of the Aspect class

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target.
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect.
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime.

See Also

Aspect Class
PostSharp.Aspects Namespace


Aspect Constructor

Aspect Constructor
Aspect Class See Also Send Feedback
Initializes a new instance of the Aspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Aspect()

See Also

Aspect Class
PostSharp.Aspects Namespace


Aspect Methods

[image]

PostSharp 2.0 Documentation
Aspect Methods
Aspect Class See Also Send Feedback

The Aspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target.
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect.

See Also

Aspect Class
PostSharp.Aspects Namespace


CompileTimeValidate Method

Aspect..::..CompileTimeValidate Method
Aspect Class See Also Send Feedback
Method invoked at build time to ensure that the aspect has been applied to the right target.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool CompileTimeValidate(
    Object target
)

Parameters

target
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the aspect has been applied.

Return Value

true if the aspect was applied to an acceptable target, otherwise false.

Remarks

The implementation of this method is expected to emit an error message (see MessageSource) or an exception in case of error. Returning false without emitting an error message or exception causes the aspect to be silently ignored.

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Validating Aspects


CreateAspectConfiguration Method

Aspect..::..CreateAspectConfiguration Method
Aspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


GetAspectConfiguration Method

Aspect..::..GetAspectConfiguration Method
Aspect Class See Also Send Feedback
Method invoked at build tome to get the imperative configuration of the current Aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration GetAspectConfiguration(
    Object targetElement
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current Aspect has been applied.

Return Value

An AspectConfiguration representing the imperative configuration of the current Aspect.

Implements

IAspectBuildSemantics..::.GetAspectConfiguration(Object)

Remarks

This method can be customized by overriding CreateAspectConfiguration()()() and/or SetAspectConfiguration(AspectConfiguration, Object)

.

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


SetAspectConfiguration Method

Aspect..::..SetAspectConfiguration Method
Aspect Class See Also Send Feedback
Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void SetAspectConfiguration(
    AspectConfiguration aspectConfiguration,
    Object targetElement
)

Parameters

aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
The AspectConfiguration instance previously returned by the CreateAspectConfiguration()()() method.
targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current Aspect has been applied.

Remarks

Classes overriding this method must always invoke the base implementation before performing their own changes to the AspectConfiguration.

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


Aspect Properties

[image]

PostSharp 2.0 Documentation
Aspect Properties
Aspect Class See Also Send Feedback

The Aspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect.
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime.

See Also

Aspect Class
PostSharp.Aspects Namespace


AspectPriority Property

Aspect..::..AspectPriority Property
Aspect Class See Also Send Feedback
Gets or sets the weaving priority of the aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int AspectPriority { get; set; }

Field Value

The aspect priority, or null if the aspect priority is not specified.

Remarks

Advices with lower priority are executed before in case of 'entry' semantics (entering or invoking a method, setting a field value), but this order is inverted for advices of 'exit' semantics (leaving a method, getting a field value).

This property must not be confused with AttributePriority, which solely influences the multicasting process.

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Coping with Several Aspects on the Same Target


SerializerType Property

Aspect..::..SerializerType Property
Aspect Class See Also Send Feedback
Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Type SerializerType { get; set; }

See Also

Aspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Serialization


AspectInfo Class

AspectInfo Class
Members See Also Send Feedback
Reserved for future usage.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectInfo

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AspectInfo

See Also

AspectInfo Members
PostSharp.Aspects Namespace


AspectInfo Members

[image]

PostSharp 2.0 Documentation
AspectInfo Members
AspectInfo Class Constructors See Also Send Feedback

The AspectInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AspectInfo | Initializes a new instance of the AspectInfo class

See Also

AspectInfo Class
PostSharp.Aspects Namespace


AspectInfo Constructor

AspectInfo Constructor
AspectInfo Class See Also Send Feedback
Initializes a new instance of the AspectInfo class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfo()

See Also

AspectInfo Class
PostSharp.Aspects Namespace


AspectInstance Class

AspectInstance Class
Members See Also Send Feedback
Completely specifies an aspect instance, including its target code element. An AspectInstance contains either the aspect instance itself (Aspect property), either information allowing to construct the aspect (AspectConstruction) and configure the weaver (AspectConfiguration).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectInstance : AspectSpecification

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AspectSpecification
PostSharp.Aspects..::.AspectInstance

See Also

AspectInstance Members
PostSharp.Aspects Namespace
Conceptual Documentation: Adding Aspects Dynamically


AspectInstance Members

[image]

PostSharp 2.0 Documentation
AspectInstance Members
AspectInstance Class Constructors Properties See Also Send Feedback

The AspectInstance type exposes the following members.

Constructors

 | Name | Description
Public method | AspectInstance | Overloaded.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect instance. (Inherited from AspectSpecification.)
Public property | AspectAssemblyQualifiedTypeName | Gets the assembly-qualified type name of the aspect. (Inherited from AspectSpecification.)
Public property | AspectConfiguration | Gets the aspect configuration. (Inherited from AspectSpecification.)
Public property | AspectConstruction | Gets the aspect construction. (Inherited from AspectSpecification.)
Public property | AspectTypeName | Gets the type name of the aspect. (Inherited from AspectSpecification.)
Public property | TargetElement | Gets the code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.

See Also

AspectInstance Class
PostSharp.Aspects Namespace


AspectInstance Constructor

[image]

PostSharp 2.0 Documentation
AspectInstance Constructor
AspectInstance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectInstance(Object, IAspect) | Initializes a new AspectInstance from a runtime aspect instance (IAspect).
Public method | AspectInstance(Object, IAspect, AspectConfiguration) | Initializes a new AspectInstance from a runtime aspect instance (IAspect) and its AspectConfiguration.
Public method | AspectInstance(Object, ObjectConstruction, AspectConfiguration) | Initializes a new AspectInstance from

See Also

AspectInstance Class
AspectInstance Members
PostSharp.Aspects Namespace


AspectInstance Constructor (Object, IAspect)

AspectInstance Constructor (Object, IAspect)
AspectInstance Class See Also Send Feedback
Initializes a new AspectInstance from a runtime aspect instance (IAspect).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInstance(
    Object targetElement,
    IAspect aspect
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.
aspect
Type: PostSharp.Aspects..::.IAspect
The aspect runtime instance.

See Also

AspectInstance Class
AspectInstance Overload
PostSharp.Aspects Namespace


AspectInstance Constructor (Object, IAspect, AspectConfiguration)

AspectInstance Constructor (Object, IAspect, AspectConfiguration)
AspectInstance Class See Also Send Feedback
Initializes a new AspectInstance from a runtime aspect instance (IAspect) and its AspectConfiguration.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInstance(
    Object targetElement,
    IAspect aspect,
    AspectConfiguration aspectConfiguration
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.
aspect
Type: PostSharp.Aspects..::.IAspect
The aspect runtime instance.
aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
The aspect configuration (the type of this parameter should be equal to the type configuration objects expected by the concrete aspect).

See Also

AspectInstance Class
AspectInstance Overload
PostSharp.Aspects Namespace


AspectInstance Constructor (Object, ObjectConstruction, AspectConfiguration)

AspectInstance Constructor (Object, ObjectConstruction, AspectConfiguration)
AspectInstance Class See Also Send Feedback
Initializes a new AspectInstance from

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInstance(
    Object targetElement,
    ObjectConstruction aspectConstruction,
    AspectConfiguration aspectConfiguration
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.
aspectConstruction
Type: PostSharp.Reflection..::.ObjectConstruction
An ObjectConstruction instructing how the aspect instance should be constructed.
aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
An optional configuration object whose type corresponds to the the aspect type.

See Also

AspectInstance Class
AspectInstance Overload
PostSharp.Aspects Namespace


AspectInstance Properties

[image]

PostSharp 2.0 Documentation
AspectInstance Properties
AspectInstance Class See Also Send Feedback

The AspectInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect instance. (Inherited from AspectSpecification.)
Public property | AspectAssemblyQualifiedTypeName | Gets the assembly-qualified type name of the aspect. (Inherited from AspectSpecification.)
Public property | AspectConfiguration | Gets the aspect configuration. (Inherited from AspectSpecification.)
Public property | AspectConstruction | Gets the aspect construction. (Inherited from AspectSpecification.)
Public property | AspectTypeName | Gets the type name of the aspect. (Inherited from AspectSpecification.)
Public property | TargetElement | Gets the code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.

See Also

AspectInstance Class
PostSharp.Aspects Namespace


TargetElement Property

AspectInstance..::..TargetElement Property
AspectInstance Class See Also Send Feedback
Gets the code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current AspectInstance is applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object TargetElement { get; private set; }

See Also

AspectInstance Class
PostSharp.Aspects Namespace


AspectSpecification Class

AspectSpecification Class
Members See Also Send Feedback
Completely specifies an aspect instance (but not its target). An AspectSpecification either the aspect instance itself (Aspect property), either information allowing to construct the aspect (AspectConstruction) and configure the weaver (AspectConfiguration).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AspectSpecification

Remarks

User code cannot create an instance of the AspectSpecification class. Always create an instance of AspectInstance instead.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AspectSpecification
PostSharp.Aspects..::.AspectInstance

See Also

AspectSpecification Members
PostSharp.Aspects Namespace


AspectSpecification Members

[image]

PostSharp 2.0 Documentation
AspectSpecification Members
AspectSpecification Class Constructors Properties See Also Send Feedback

The AspectSpecification type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectSpecification | Initializes a new AspectSpecification when one cannot provide an aspect instance, i.e. from an ObjectConstruction and a AspectConfiguration.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect instance.
Public property | AspectAssemblyQualifiedTypeName | Gets the assembly-qualified type name of the aspect.
Public property | AspectConfiguration | Gets the aspect configuration.
Public property | AspectConstruction | Gets the aspect construction.
Public property | AspectTypeName | Gets the type name of the aspect.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectSpecification Constructor

AspectSpecification Constructor
AspectSpecification Class See Also Send Feedback
Initializes a new AspectSpecification when one cannot provide an aspect instance, i.e. from an ObjectConstruction and a AspectConfiguration.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectSpecification(
    ObjectConstruction aspectConstruction,
    AspectConfiguration aspectConfiguration
)

Parameters

aspectConstruction
Type: PostSharp.Reflection..::.ObjectConstruction
Aspect construction.
aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
Aspect configuration.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectSpecification Properties

[image]

PostSharp 2.0 Documentation
AspectSpecification Properties
AspectSpecification Class See Also Send Feedback

The AspectSpecification type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect instance.
Public property | AspectAssemblyQualifiedTypeName | Gets the assembly-qualified type name of the aspect.
Public property | AspectConfiguration | Gets the aspect configuration.
Public property | AspectConstruction | Gets the aspect construction.
Public property | AspectTypeName | Gets the type name of the aspect.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


Aspect Property

AspectSpecification..::..Aspect Property
AspectSpecification Class See Also Send Feedback
Gets the aspect instance.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAspect Aspect { get; }

Field Value

The aspect instance, or null if the AspectConfiguration was provided instead.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectAssemblyQualifiedTypeName Property

AspectSpecification..::..AspectAssemblyQualifiedTypeName Property
AspectSpecification Class See Also Send Feedback
Gets the assembly-qualified type name of the aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AspectAssemblyQualifiedTypeName { get; }

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectConfiguration Property

AspectSpecification..::..AspectConfiguration Property
AspectSpecification Class See Also Send Feedback
Gets the aspect configuration.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration AspectConfiguration { get; }

Field Value

The aspect configuration, or null if none was provided.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectConstruction Property

AspectSpecification..::..AspectConstruction Property
AspectSpecification Class See Also Send Feedback
Gets the aspect construction.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction AspectConstruction { get; }

Field Value

The aspect construction, or null if the aspect instance was provided instead.

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectTypeName Property

AspectSpecification..::..AspectTypeName Property
AspectSpecification Class See Also Send Feedback
Gets the type name of the aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AspectTypeName { get; }

See Also

AspectSpecification Class
PostSharp.Aspects Namespace


AspectUtilities Class

AspectUtilities Class
Members See Also Send Feedback
Utility methods for PostSharp.Aspects.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectUtilities

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AspectUtilities

See Also

AspectUtilities Members
PostSharp.Aspects Namespace


AspectUtilities Members

[image]

PostSharp 2.0 Documentation
AspectUtilities Members
AspectUtilities Class Constructors Methods See Also Send Feedback

The AspectUtilities type exposes the following members.

Constructors

 | Name | Description
Public method | AspectUtilities | Initializes a new instance of the AspectUtilities class

Methods

Name | Description
GetCurrentInstanceCredentials | Gets the InstanceCredentials of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.
InitializeCurrentAspects | Initializes the all the aspects of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.

See Also

AspectUtilities Class
PostSharp.Aspects Namespace


AspectUtilities Constructor

AspectUtilities Constructor
AspectUtilities Class See Also Send Feedback
Initializes a new instance of the AspectUtilities class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectUtilities()

See Also

AspectUtilities Class
PostSharp.Aspects Namespace


AspectUtilities Methods

[image]

PostSharp 2.0 Documentation
AspectUtilities Methods
AspectUtilities Class See Also Send Feedback

The AspectUtilities type exposes the following members.

Methods

Name | Description
GetCurrentInstanceCredentials | Gets the InstanceCredentials of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.
InitializeCurrentAspects | Initializes the all the aspects of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.

See Also

AspectUtilities Class
PostSharp.Aspects Namespace


GetCurrentInstanceCredentials Method

AspectUtilities..::..GetCurrentInstanceCredentials Method
AspectUtilities Class See Also Send Feedback
Gets the InstanceCredentials of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static InstanceCredentials GetCurrentInstanceCredentials()

Return Value

The InstanceCredentials of the calling instance.

Remarks

Calls to this method are transformed, at build time, to calls to this.GetInstanceCredentials, a method that is typically generated by PostSharp. This is why the current method has actually no implementation.

Note
Aspect credentials are considered obsolete and their use should be avoided.

See Also

AspectUtilities Class
PostSharp.Aspects Namespace


InitializeCurrentAspects Method

AspectUtilities..::..InitializeCurrentAspects Method
AspectUtilities Class See Also Send Feedback
Initializes the all the aspects of the calling instance. This method must be invoked from an instance method (not a static method) of a type that has been enhanced by an aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void InitializeCurrentAspects()

Remarks

Calls to this method are transformed, at build time, to calls to this.InitializeAspects, a method that is typically generated by PostSharp. This is why the current method has actually no implementation.

The constructors of enhanced classes always initialize aspects. The only scenario where this method needs to be invoked manually is when instances are not built using the constructor, but for instance with the method GetUninitializedObject(Type).

See Also

AspectUtilities Class
PostSharp.Aspects Namespace
Conceptual Documentation: Coping with Custom Serializers


AssemblyLevelAspect Class

AssemblyLevelAspect Class
Members See Also Send Feedback
Base class for all aspects applied on assemblies.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class AssemblyLevelAspect : Aspect,
    IAssemblyLevelAspect, IAssemblyLevelAspectBuildSemantics, IAspect

Remarks

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.AssemblyLevelAspect

See Also

AssemblyLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IAssemblyLevelAspect
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization


AssemblyLevelAspect Members

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspect Members
AssemblyLevelAspect Class Constructors Methods Properties See Also Send Feedback

The AssemblyLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | AssemblyLevelAspect | Initializes a new instance of the AssemblyLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

AssemblyLevelAspect Class
PostSharp.Aspects Namespace


AssemblyLevelAspect Constructor

AssemblyLevelAspect Constructor
AssemblyLevelAspect Class See Also Send Feedback
Initializes a new instance of the AssemblyLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AssemblyLevelAspect()

See Also

AssemblyLevelAspect Class
PostSharp.Aspects Namespace


AssemblyLevelAspect Methods

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspect Methods
AssemblyLevelAspect Class See Also Send Feedback

The AssemblyLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

AssemblyLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

AssemblyLevelAspect..::..CompileTimeInitialize Method
AssemblyLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    _Assembly assembly,
    AspectInfo aspectInfo
)

Parameters

assembly
Type: System.Runtime.InteropServices..::._Assembly
Assembly to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

IAssemblyLevelAspectBuildSemantics..::.CompileTimeInitialize(_Assembly, AspectInfo)

See Also

AssemblyLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


AssemblyLevelAspect Properties

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspect Properties
AssemblyLevelAspect Class See Also Send Feedback

The AssemblyLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

AssemblyLevelAspect Class
PostSharp.Aspects Namespace


CompositionAspect Class

CompositionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied on a type, introduces one or many new interfaces into that type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class CompositionAspect : TypeLevelAspect,
    ICompositionAspect, ITypeLevelAspect, IAspect

Remarks

Note
Consider using a composite aspect introducing an interface instead of using a CompositionAspect. For details, see Introducing Interfaces.

Methods GetPublicInterfaces(Type) and GetProtectedInterfaces(Type) are invoked at build time. At runtime, the method CreateImplementationObject(AdviceArgs) should return an object implementing all interfaces.

Use the Post.Cast<(Of <(SourceType, TargetType>)>)(SourceType) method to cast the enhanced type to the newly implemented interface. This cast is verified during post-compilation.

Properties OverrideAction and AncestorOverrideAction determine what should happen if the target type already implements the interface directly or indirectly.

By default, the object implementing the interface is stored as a serializable field. If the property NonSerializedImplementation is set to true, this field will be marked as NonSerializedAttribute.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Dynamically Introducing an Interface

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.TypeLevelAspect
PostSharp.Aspects..::.CompositionAspect

See Also

CompositionAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Serialization
PostSharp.Aspects.Advices..::.IntroduceInterfaceAttribute
Conceptual Documentation: Introducing Interfaces


CompositionAspect Members

[image]

PostSharp 2.0 Documentation
CompositionAspect Members
CompositionAspect Class Constructors Methods Properties See Also Send Feedback

The CompositionAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | CompositionAspect | Initializes a new instance of the CompositionAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from TypeLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | CreateImplementationObject | Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | GetProtectedInterfaces | Gets the array of interfaces to be introduced indirectly into the target type of the current aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Protected method | GetPublicInterfaces | Gets the array of interfaces that should be introduced publicly into the target type of the current aspect.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from TypeLevelAspect.)
Protected method | SetAspectConfiguration | Overloaded.

Properties

 | Name | Description
Protected property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces returned by GetPublicInterfaces(Type) is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface returned by the GetPublicInterfaces(Type) method.
Protected property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Protected property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces returned by GetPublicInterfaces(Type) or GetProtectedInterfaces(Type) is already implemented by the type to which the current aspect is applied.
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


CompositionAspect Constructor

CompositionAspect Constructor
CompositionAspect Class See Also Send Feedback
Initializes a new instance of the CompositionAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected CompositionAspect()

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


CompositionAspect Methods

[image]

PostSharp 2.0 Documentation
CompositionAspect Methods
CompositionAspect Class See Also Send Feedback

The CompositionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from TypeLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | CreateImplementationObject | Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | GetProtectedInterfaces | Gets the array of interfaces to be introduced indirectly into the target type of the current aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Protected method | GetPublicInterfaces | Gets the array of interfaces that should be introduced publicly into the target type of the current aspect.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from TypeLevelAspect.)
Protected method | SetAspectConfiguration | Overloaded.

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

CompositionAspect..::..CreateAspectConfiguration Method
CompositionAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override sealed AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

CompositionAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


CreateImplementationObject Method

CompositionAspect..::..CreateImplementationObject Method
CompositionAspect Class See Also Send Feedback
Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object CreateImplementationObject(
    AdviceArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.AdviceArgs

[Missing <param name="args"/> documentation for "M:PostSharp.Aspects.CompositionAspect.CreateImplementationObject(PostSharp.Aspects.AdviceArgs)"]

Return Value

The composed object. This interface should implement the interfaces specified by the GetPublicInterfaces(Type) and GetProtectedInterfaces(Type) methods.

Implements

ICompositionAspect..::.CreateImplementationObject(AdviceArgs)

Remarks

This method is invoked during at runtime after the base constructor has executed, and before the constructor of the current type is executed.

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


GetProtectedInterfaces Method

CompositionAspect..::..GetProtectedInterfaces Method
CompositionAspect Class See Also Send Feedback
Gets the array of interfaces to be introduced indirectly into the target type of the current aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual Type[] GetProtectedInterfaces(
    Type targetType
)

Parameters

targetType
Type: System..::.Type
Type to which the current aspect is applied.

Return Value

The array of interfaces that should be introduced indirectly into Type targetType, or null if no interface should be introduced indirectly.

Remarks

Note
Protected interfaces are provided for legacy support. It is recommended to use a different pattern, such as a composite aspect,

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


GetPublicInterfaces Method

CompositionAspect..::..GetPublicInterfaces Method
CompositionAspect Class See Also Send Feedback
Gets the array of interfaces that should be introduced publicly into the target type of the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual Type[] GetPublicInterfaces(
    Type targetType
)

Parameters

targetType
Type: System..::.Type
Type to which the current aspect is applied.

Return Value

The array of interfaces that should be introduced publicly into Type targetType, or null if no interface should be introduced publicly.

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


SetAspectConfiguration Method

[image]

PostSharp 2.0 Documentation
CompositionAspect..::..SetAspectConfiguration Method
CompositionAspect Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetAspectConfiguration(AspectConfiguration, Object) | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration(AspectConfiguration, Type) | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Overrides TypeLevelAspectSetAspectConfiguration(AspectConfiguration, Type).)

See Also

CompositionAspect Class
CompositionAspect Members
PostSharp.Aspects Namespace


SetAspectConfiguration Method (AspectConfiguration, Type)

CompositionAspect..::..SetAspectConfiguration Method (AspectConfiguration, Type)
CompositionAspect Class See Also Send Feedback
Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void SetAspectConfiguration(
    AspectConfiguration aspectConfiguration,
    Type targetType
)

Parameters

aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
The AspectConfiguration instance previously returned by the CreateAspectConfiguration()()() method.
targetType
Type: System..::.Type
Type to which the current aspect has been applied.

Remarks

Classes overriding this method must always invoke the base implementation before performing their own changes to the AspectConfiguration.

See Also

CompositionAspect Class
SetAspectConfiguration Overload
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


CompositionAspect Properties

[image]

PostSharp 2.0 Documentation
CompositionAspect Properties
CompositionAspect Class See Also Send Feedback

The CompositionAspect type exposes the following members.

Properties

 | Name | Description
Protected property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces returned by GetPublicInterfaces(Type) is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface returned by the GetPublicInterfaces(Type) method.
Protected property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Protected property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces returned by GetPublicInterfaces(Type) or GetProtectedInterfaces(Type) is already implemented by the type to which the current aspect is applied.
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


AncestorOverrideAction Property

CompositionAspect..::..AncestorOverrideAction Property
CompositionAspect Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces returned by GetPublicInterfaces(Type) is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InterfaceOverrideAction AncestorOverrideAction { get; set; }

See Also

CompositionAspect Class
PostSharp.Aspects Namespace
CompositionAspect..::.OverrideAction


GenerateImplementationAccessor Property

CompositionAspect..::..GenerateImplementationAccessor Property
CompositionAspect Class See Also Send Feedback
Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface returned by the GetPublicInterfaces(Type) method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected bool GenerateImplementationAccessor { get; set; }

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


NonSerializedImplementation Property

CompositionAspect..::..NonSerializedImplementation Property
CompositionAspect Class See Also Send Feedback
Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected bool NonSerializedImplementation { get; set; }

See Also

CompositionAspect Class
PostSharp.Aspects Namespace


OverrideAction Property

CompositionAspect..::..OverrideAction Property
CompositionAspect Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces returned by GetPublicInterfaces(Type) or GetProtectedInterfaces(Type) is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InterfaceOverrideAction OverrideAction { get; set; }

See Also

CompositionAspect Class
PostSharp.Aspects Namespace
CompositionAspect..::.AncestorOverrideAction


CustomAttributeIntroductionAspect Class

CustomAttributeIntroductionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied to a target, adds a custom attribute to this target.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomAttributeIntroductionAspect : ICustomAttributeIntroductionAspect,
    IAspect, IAspectBuildSemantics, IValidableAnnotation

Remarks

There are two ways to specify a custom attribute: either using an ObjectConstruction (to construct a new custom attribute), either a CustomAttributeData (to copy a custom attribute reflected using one of the overload of the method GetCustomAttributes(Assembly)/

Note
This aspect is not a custom attribute. You have to create another aspect implementing IAspectProvider and have the method ProvideAspects(Object) return instances of this aspect.

Examples

Example: Automatically Adding DataContract and DataMember Attributes

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.CustomAttributeIntroductionAspect

See Also

CustomAttributeIntroductionAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Adding Aspects Dynamically


CustomAttributeIntroductionAspect Members

[image]

PostSharp 2.0 Documentation
CustomAttributeIntroductionAspect Members
CustomAttributeIntroductionAspect Class Constructors Properties See Also Send Feedback

The CustomAttributeIntroductionAspect type exposes the following members.

Constructors

 | Name | Description
Public method | CustomAttributeIntroductionAspect | Overloaded.

Properties

 | Name | Description
Public property | CustomAttribute | Gets the construction of the custom attribute that must be applied to the target of this aspect.

See Also

CustomAttributeIntroductionAspect Class
PostSharp.Aspects Namespace


CustomAttributeIntroductionAspect Constructor

[image]

PostSharp 2.0 Documentation
CustomAttributeIntroductionAspect Constructor
CustomAttributeIntroductionAspect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomAttributeIntroductionAspect(CustomAttributeData) | Initializes a new CustomAttributeIntroductionAspect by specifying a CustomAttributeData.
Public method | CustomAttributeIntroductionAspect(ObjectConstruction) | Initializes a new CustomAttributeIntroductionAspect by specifying an ObjectConstruction.

See Also

CustomAttributeIntroductionAspect Class
CustomAttributeIntroductionAspect Members
PostSharp.Aspects Namespace


CustomAttributeIntroductionAspect Constructor (CustomAttributeData)

CustomAttributeIntroductionAspect Constructor (CustomAttributeData)
CustomAttributeIntroductionAspect Class See Also Send Feedback
Initializes a new CustomAttributeIntroductionAspect by specifying a CustomAttributeData.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeIntroductionAspect(
    CustomAttributeData customAttributeData
)

Parameters

customAttributeData
Type: System.Reflection..::.CustomAttributeData
Construction of the custom attribute to be added to the target.

See Also

CustomAttributeIntroductionAspect Class
CustomAttributeIntroductionAspect Overload
PostSharp.Aspects Namespace


CustomAttributeIntroductionAspect Constructor (ObjectConstruction)

CustomAttributeIntroductionAspect Constructor (ObjectConstruction)
CustomAttributeIntroductionAspect Class See Also Send Feedback
Initializes a new CustomAttributeIntroductionAspect by specifying an ObjectConstruction.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeIntroductionAspect(
    ObjectConstruction attribute
)

Parameters

attribute
Type: PostSharp.Reflection..::.ObjectConstruction
Construction of the custom attribute to be added to the target.

See Also

CustomAttributeIntroductionAspect Class
CustomAttributeIntroductionAspect Overload
PostSharp.Aspects Namespace


CustomAttributeIntroductionAspect Properties

[image]

PostSharp 2.0 Documentation
CustomAttributeIntroductionAspect Properties
CustomAttributeIntroductionAspect Class See Also Send Feedback

The CustomAttributeIntroductionAspect type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttribute | Gets the construction of the custom attribute that must be applied to the target of this aspect.

See Also

CustomAttributeIntroductionAspect Class
PostSharp.Aspects Namespace


CustomAttribute Property

CustomAttributeIntroductionAspect..::..CustomAttribute Property
CustomAttributeIntroductionAspect Class See Also Send Feedback
Gets the construction of the custom attribute that must be applied to the target of this aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction CustomAttribute { get; }

See Also

CustomAttributeIntroductionAspect Class
PostSharp.Aspects Namespace


EventInterceptionArgs Class

EventInterceptionArgs Class
Members See Also Send Feedback
Arguments of handlers of aspects of the type EventInterceptionAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class EventInterceptionArgs : AdviceArgs

Remarks

Note
As a result of weaving optimizations, instances of classes derived from AdviceArgs may be shared among different aspects. Therefore, aspect code should not attempt to access this object once the control has been given over to the next node in the chain of invocation. Consider working with aspect bindings if you need such deferred execution.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AdviceArgs
PostSharp.Aspects..::.EventInterceptionArgs

See Also

EventInterceptionArgs Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.EventInterceptionAspect
Conceptual Documentation: Aspect Bindings
PostSharp.Aspects..::.EventInterceptionAspect


EventInterceptionArgs Members

[image]

PostSharp 2.0 Documentation
EventInterceptionArgs Members
EventInterceptionArgs Class Methods Properties See Also Send Feedback

The EventInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a handler to the event by invoking the Add semantic of the next node in the chain of invocation.
Public method | InvokeHandler | Invokes a handler by calling the Invoke semantic of the next node in the chain of invocation.
Public method | ProceedAddHandler | Proceeds with adding the Delegate to the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnAddHandler(EventInterceptionArgs).
Public method | ProceedInvokeHandler | Proceeds with invoking the Delegate with the arguments specified in the Arguments property. The delegate may change the Arguments and set the ReturnValue. This method invokes the next handler in chain. It is typically invoked from the implementation of OnInvokeHandler(EventInterceptionArgs).
Public method | ProceedRemoveHandler | Proceeds with removing the Delegate from the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnRemoveHandler(EventInterceptionArgs).
Public method | RemoveHandler | Removes a handler from the event by invoking the Remove semantic of the next node in the chain of invocation.

Properties

 | Name | Description
Public property | Arguments | Gets the delegate arguments.
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Event | Gets the event to which the current aspect has been applied.
Public property | Handler | Gets the delegate being added, removed, or invoked.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | ReturnValue | Gets the return value of the delegate.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


EventInterceptionArgs Methods

[image]

PostSharp 2.0 Documentation
EventInterceptionArgs Methods
EventInterceptionArgs Class See Also Send Feedback

The EventInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a handler to the event by invoking the Add semantic of the next node in the chain of invocation.
Public method | InvokeHandler | Invokes a handler by calling the Invoke semantic of the next node in the chain of invocation.
Public method | ProceedAddHandler | Proceeds with adding the Delegate to the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnAddHandler(EventInterceptionArgs).
Public method | ProceedInvokeHandler | Proceeds with invoking the Delegate with the arguments specified in the Arguments property. The delegate may change the Arguments and set the ReturnValue. This method invokes the next handler in chain. It is typically invoked from the implementation of OnInvokeHandler(EventInterceptionArgs).
Public method | ProceedRemoveHandler | Proceeds with removing the Delegate from the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnRemoveHandler(EventInterceptionArgs).
Public method | RemoveHandler | Removes a handler from the event by invoking the Remove semantic of the next node in the chain of invocation.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


AddHandler Method

EventInterceptionArgs..::..AddHandler Method
EventInterceptionArgs Class See Also Send Feedback
Adds a handler to the event by invoking the Add semantic of the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void AddHandler(
    Delegate handler
)

Parameters

handler
Type: System..::.Delegate
The handler to add to the event.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


InvokeHandler Method

EventInterceptionArgs..::..InvokeHandler Method
EventInterceptionArgs Class See Also Send Feedback
Invokes a handler by calling the Invoke semantic of the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object InvokeHandler(
    Delegate handler,
    Arguments arguments
)

Parameters

handler
Type: System..::.Delegate
Handler to be invoked.
arguments
Type: PostSharp.Aspects..::.Arguments
Arguments passed to the handler.

Return Value

Return value of the handler.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


ProceedAddHandler Method

EventInterceptionArgs..::..ProceedAddHandler Method
EventInterceptionArgs Class See Also Send Feedback
Proceeds with adding the Delegate to the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnAddHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProceedAddHandler()

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


ProceedInvokeHandler Method

EventInterceptionArgs..::..ProceedInvokeHandler Method
EventInterceptionArgs Class See Also Send Feedback
Proceeds with invoking the Delegate with the arguments specified in the Arguments property. The delegate may change the Arguments and set the ReturnValue. This method invokes the next handler in chain. It is typically invoked from the implementation of OnInvokeHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProceedInvokeHandler()

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


ProceedRemoveHandler Method

EventInterceptionArgs..::..ProceedRemoveHandler Method
EventInterceptionArgs Class See Also Send Feedback
Proceeds with removing the Delegate from the event to which the current aspect. This method invokes the next handler in chain. It is typically invoked from the implementation of OnRemoveHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProceedRemoveHandler()

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


RemoveHandler Method

EventInterceptionArgs..::..RemoveHandler Method
EventInterceptionArgs Class See Also Send Feedback
Removes a handler from the event by invoking the Remove semantic of the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void RemoveHandler(
    Delegate handler
)

Parameters

handler
Type: System..::.Delegate
Handler to be removed.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


EventInterceptionArgs Properties

[image]

PostSharp 2.0 Documentation
EventInterceptionArgs Properties
EventInterceptionArgs Class See Also Send Feedback

The EventInterceptionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Gets the delegate arguments.
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Event | Gets the event to which the current aspect has been applied.
Public property | Handler | Gets the delegate being added, removed, or invoked.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | ReturnValue | Gets the return value of the delegate.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


Arguments Property

EventInterceptionArgs..::..Arguments Property
EventInterceptionArgs Class See Also Send Feedback
Gets the delegate arguments.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Arguments Arguments { get; private set; }

Remarks

This property is meaningful only during a delegate invocation (not during an addition or removal).

This property is typically accessed by the ProceedInvokeHandler()()() method. Implementations of OnInvokeHandler(EventInterceptionArgs) can also get or change the value of this property.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


Binding Property

EventInterceptionArgs..::..Binding Property
EventInterceptionArgs Class See Also Send Feedback
Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IEventBinding Binding { get; }

Remarks

Bindings are thread-safe and context-free singleton instances exposing the next node in the chain of invocation.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings


Event Property

EventInterceptionArgs..::..Event Property
EventInterceptionArgs Class See Also Send Feedback
Gets the event to which the current aspect has been applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInfo Event { get; set; }

Remarks

Note
Using this property causes the aspect weaver to generate code that has non-trivial runtime overhead. Avoid using this property whenever possible. One of the possible solution is to use compile-time initialization of aspect instances and to make use of reflection only at build time.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


Handler Property

EventInterceptionArgs..::..Handler Property
EventInterceptionArgs Class See Also Send Feedback
Gets the delegate being added, removed, or invoked.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Delegate Handler { get; private set; }

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


ReturnValue Property

EventInterceptionArgs..::..ReturnValue Property
EventInterceptionArgs Class See Also Send Feedback
Gets the return value of the delegate.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object ReturnValue { get; set; }

Remarks

This property is meaningful only during a delegate invocation (not during an addition or removal).

This property is typically set by the ProceedInvokeHandler()()() method. It is also legal for an implementation of OnInvokeHandler(EventInterceptionArgs) to change the value of this property.

See Also

EventInterceptionArgs Class
PostSharp.Aspects Namespace


EventInterceptionAspect Class

EventInterceptionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied on an event, intercepts invocations of its semantics Add (OnAddHandler(EventInterceptionArgs)), Remove (OnRemoveHandler(EventInterceptionArgs)) and Invoke (OnInvokeHandler(EventInterceptionArgs)).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class EventInterceptionAspect : EventLevelAspect,
    IEventInterceptionAspect, IEventLevelAspect, IAspect

Remarks

Applying an aspect of type EventInterceptionAspect to an event results in the add and remove methods of the event to be replaced by a call to OnAddHandler(EventInterceptionArgs) and OnRemoveHandler(EventInterceptionArgs), respectively. The original accessor body is moved into new methods, which the aspect code can call by invoking ProceedAddHandler()()() or ProceedRemoveHandler()()().

The method OnInvokeHandler(EventInterceptionArgs), if defined, is called instead when the event is raised, once for every handler that has been added to the list. When you define OnInvokeHandler(EventInterceptionArgs) method, PostSharp will use a broker object to control access to the event; this broker object will be the unique subscriber of the event, and maintains its own list of subscribers.

For details about the implementation of this aspect, see Interception Aspects.

Note
The aspect works only when caller code access the event through its add/remove semantics. It does not work when the caller code bypasses the event semantics and accesses directly its implementation (the underlying field of the event, typically). The C# compiler is known to bypass the semantics when the event is accessed directly from the class declaring it (it accesses directly the private field whenever it can).

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Making an Event Asynchronous

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.EventLevelAspect
PostSharp.Aspects..::.EventInterceptionAspect

See Also

EventInterceptionAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Serialization
Conceptual Documentation: Interception Aspects


EventInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
EventInterceptionAspect Members
EventInterceptionAspect Class Constructors Methods Properties See Also Send Feedback

The EventInterceptionAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | EventInterceptionAspect | Initializes a new instance of the EventInterceptionAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from EventLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnAddHandler | Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.
Public method | OnInvokeHandler | Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.
Public method | OnRemoveHandler | Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from EventLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


EventInterceptionAspect Constructor

EventInterceptionAspect Constructor
EventInterceptionAspect Class See Also Send Feedback
Initializes a new instance of the EventInterceptionAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected EventInterceptionAspect()

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


EventInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
EventInterceptionAspect Methods
EventInterceptionAspect Class See Also Send Feedback

The EventInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from EventLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnAddHandler | Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.
Public method | OnInvokeHandler | Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.
Public method | OnRemoveHandler | Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from EventLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

EventInterceptionAspect..::..CreateAspectConfiguration Method
EventInterceptionAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


OnAddHandler Method

EventInterceptionAspect..::..OnAddHandler Method
EventInterceptionAspect Class See Also Send Feedback
Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnAddHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Implements

IEventInterceptionAspect..::.OnAddHandler(EventInterceptionArgs)

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


OnInvokeHandler Method

EventInterceptionAspect..::..OnInvokeHandler Method
EventInterceptionAspect Class See Also Send Feedback
Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnInvokeHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Implements

IEventInterceptionAspect..::.OnInvokeHandler(EventInterceptionArgs)

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

Note
The Invoke Event Handler semantic is different from normal event firing. Indeed, when you fire an event, all handlers that were added to this event are fired. However, the current method invokes only a single handler: the one passed to the handler parameter.

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


OnRemoveHandler Method

EventInterceptionAspect..::..OnRemoveHandler Method
EventInterceptionAspect Class See Also Send Feedback
Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnRemoveHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Implements

IEventInterceptionAspect..::.OnRemoveHandler(EventInterceptionArgs)

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


EventInterceptionAspect Properties

[image]

PostSharp 2.0 Documentation
EventInterceptionAspect Properties
EventInterceptionAspect Class See Also Send Feedback

The EventInterceptionAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

EventInterceptionAspect Class
PostSharp.Aspects Namespace


EventLevelAspect Class

EventLevelAspect Class
Members See Also Send Feedback
Base class for all aspects applied on events.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class EventLevelAspect : Aspect,
    IEventLevelAspect, IAspect, IEventLevelAspectBuildSemantics, IAspectBuildSemantics, IValidableAnnotation

Remarks

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.EventLevelAspect
PostSharp.Aspects..::.EventInterceptionAspect

See Also

EventLevelAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization
PostSharp.Aspects..::.IEventLevelAspect


EventLevelAspect Members

[image]

PostSharp 2.0 Documentation
EventLevelAspect Members
EventLevelAspect Class Constructors Methods Properties See Also Send Feedback

The EventLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | EventLevelAspect | Initializes a new instance of the EventLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace


EventLevelAspect Constructor

EventLevelAspect Constructor
EventLevelAspect Class See Also Send Feedback
Initializes a new instance of the EventLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected EventLevelAspect()

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace


EventLevelAspect Methods

[image]

PostSharp 2.0 Documentation
EventLevelAspect Methods
EventLevelAspect Class See Also Send Feedback

The EventLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

EventLevelAspect..::..CompileTimeInitialize Method
EventLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    EventInfo targetEvent,
    AspectInfo aspectInfo
)

Parameters

targetEvent
Type: System.Reflection..::.EventInfo
Event to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

IEventLevelAspectBuildSemantics..::.CompileTimeInitialize(EventInfo, AspectInfo)

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


RuntimeInitialize Method

EventLevelAspect..::..RuntimeInitialize Method
EventLevelAspect Class See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitialize(
    EventInfo eventInfo
)

Parameters

eventInfo
Type: System.Reflection..::.EventInfo
Event to which the current aspect is applied.

Implements

IEventLevelAspect..::.RuntimeInitialize(EventInfo)

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


EventLevelAspect Properties

[image]

PostSharp 2.0 Documentation
EventLevelAspect Properties
EventLevelAspect Class See Also Send Feedback

The EventLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

EventLevelAspect Class
PostSharp.Aspects Namespace


ExternalAspect Class

ExternalAspect Class
Members See Also Send Feedback
Aspect implemented in a different type (implementing the IExternalAspectImplementation interface), typically contained in an external assembly. Classes derived from ExternalAspect must be annotated by the custom attribute ExternalAspectConfigurationAttribute.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class ExternalAspect : Aspect,
    IExternalAspect, IAspect

Remarks

External aspects are useful when you develop for Silverlight or the .NET Compact Framework. Indeed, aspects cannot have build-time semantics on these platforms. If you need to execute logic at build time on these platforms, you need to implement this logic in an assembly linked with the normal .NET Framework (so not Silverlight or Compact Framework). You must relate an aspect with its implementation using the custom attribute ExternalAspectConfigurationAttribute.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.ExternalAspect

See Also

ExternalAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework


ExternalAspect Members

[image]

PostSharp 2.0 Documentation
ExternalAspect Members
ExternalAspect Class Constructors Methods Properties See Also Send Feedback

The ExternalAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | ExternalAspect | Initializes a new instance of the ExternalAspect class

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

ExternalAspect Class
PostSharp.Aspects Namespace


ExternalAspect Constructor

ExternalAspect Constructor
ExternalAspect Class See Also Send Feedback
Initializes a new instance of the ExternalAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected ExternalAspect()

See Also

ExternalAspect Class
PostSharp.Aspects Namespace


ExternalAspect Methods

[image]

PostSharp 2.0 Documentation
ExternalAspect Methods
ExternalAspect Class See Also Send Feedback

The ExternalAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

ExternalAspect Class
PostSharp.Aspects Namespace


ExternalAspect Properties

[image]

PostSharp 2.0 Documentation
ExternalAspect Properties
ExternalAspect Class See Also Send Feedback

The ExternalAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

ExternalAspect Class
PostSharp.Aspects Namespace


FieldLevelAspect Class

FieldLevelAspect Class
Members See Also Send Feedback
Base class for all aspects applied on fields.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class FieldLevelAspect : Aspect,
    IFieldLevelAspect, IAspect, IFieldLevelAspectBuildSemantics, IAspectBuildSemantics, IValidableAnnotation

Remarks

Note
Consider deriving your aspects from LocationLevelAspect; locations can abstract both fields and properties, making it possible to apply the same aspect to both.
Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.FieldLevelAspect

See Also

FieldLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IFieldLevelAspect
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization
PostSharp.Aspects..::.LocationLevelAspect


FieldLevelAspect Members

[image]

PostSharp 2.0 Documentation
FieldLevelAspect Members
FieldLevelAspect Class Constructors Methods Properties See Also Send Feedback

The FieldLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldLevelAspect | Initializes a new instance of the FieldLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Method invoked at runtime before any other method of the aspect is invoked.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace


FieldLevelAspect Constructor

FieldLevelAspect Constructor
FieldLevelAspect Class See Also Send Feedback
Initializes a new instance of the FieldLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected FieldLevelAspect()

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace


FieldLevelAspect Methods

[image]

PostSharp 2.0 Documentation
FieldLevelAspect Methods
FieldLevelAspect Class See Also Send Feedback

The FieldLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Method invoked at runtime before any other method of the aspect is invoked.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

FieldLevelAspect..::..CompileTimeInitialize Method
FieldLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    FieldInfo field,
    AspectInfo aspectInfo
)

Parameters

field
Type: System.Reflection..::.FieldInfo
Field to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

IFieldLevelAspectBuildSemantics..::.CompileTimeInitialize(FieldInfo, AspectInfo)

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


RuntimeInitialize Method

FieldLevelAspect..::..RuntimeInitialize Method
FieldLevelAspect Class See Also Send Feedback
Method invoked at runtime before any other method of the aspect is invoked.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitialize(
    FieldInfo field
)

Parameters

field
Type: System.Reflection..::.FieldInfo
Field on which this instance is applied.

Implements

IFieldLevelAspect..::.RuntimeInitialize(FieldInfo)

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


FieldLevelAspect Properties

[image]

PostSharp 2.0 Documentation
FieldLevelAspect Properties
FieldLevelAspect Class See Also Send Feedback

The FieldLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

FieldLevelAspect Class
PostSharp.Aspects Namespace


FlowBehavior Enumeration

FlowBehavior Enumeration
See Also Send Feedback
Enumerates the possible behaviors of the calling method after the calling method has returned.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum FlowBehavior

Members

Member name | Value | Description
Default | 0 | Default flow behavior for the current method. For OnEntry or OnExit, the fault flow is Continue, for OnException it is RethrowException.
Continue | 1 | Continue normally (in an OnException advice, does not rethrow the exception).
RethrowException | 2 | The current exception will be rethrown. Available only for OnException.
Return | 3 | Return immediately from the current method. Available only for OnEntry and OnException. Note that you may want to set the ReturnValue property, otherwise you may get a NullReferenceException.

Remarks

This enumeration is used by the MethodExecutionArgs class.

See Also

PostSharp.Aspects Namespace


IAspect Interface

IAspect Interface
See Also Send Feedback
Base interface for run-time semantics of all aspects.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspect

See Also

PostSharp.Aspects Namespace
PostSharp.Aspects..::.IAspectBuildSemantics
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects..::.Aspect


IAspectBuildSemantics Interface

IAspectBuildSemantics Interface
Members See Also Send Feedback
Compile-time semantics of IAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspectBuildSemantics : IValidableAnnotation

See Also

IAspectBuildSemantics Members
PostSharp.Aspects Namespace


IAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
IAspectBuildSemantics Members
IAspectBuildSemantics Interface Methods See Also Send Feedback

The IAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect.

See Also

IAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
IAspectBuildSemantics Methods
IAspectBuildSemantics Interface See Also Send Feedback

The IAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect.

See Also

IAspectBuildSemantics Interface
PostSharp.Aspects Namespace


GetAspectConfiguration Method

IAspectBuildSemantics..::..GetAspectConfiguration Method
IAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to get the imperative configuration of the current Aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
AspectConfiguration GetAspectConfiguration(
    Object targetElement
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current aspect has been applied.

Return Value

An AspectConfiguration representing the imperative configuration of the current Aspect.

See Also

IAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IAspectProvider Interface

IAspectProvider Interface
Members Example See Also Send Feedback
Interface that, when implemented by an aspect class, allows aspect instances to provide other aspects to the weaver.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspectProvider

Examples

Example: Automatically Adding DataContract and DataMember Attributes

See Also

IAspectProvider Members
PostSharp.Aspects Namespace


IAspectProvider Members

[image]

PostSharp 2.0 Documentation
IAspectProvider Members
IAspectProvider Interface Methods See Also Send Feedback

The IAspectProvider type exposes the following members.

Methods

 | Name | Description
Public method | ProvideAspects | Provides new aspects.

See Also

IAspectProvider Interface
PostSharp.Aspects Namespace


IAspectProvider Methods

[image]

PostSharp 2.0 Documentation
IAspectProvider Methods
IAspectProvider Interface See Also Send Feedback

The IAspectProvider type exposes the following members.

Methods

 | Name | Description
Public method | ProvideAspects | Provides new aspects.

See Also

IAspectProvider Interface
PostSharp.Aspects Namespace


ProvideAspects Method

IAspectProvider..::..ProvideAspects Method
IAspectProvider Interface See Also Send Feedback
Provides new aspects.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<AspectInstance> ProvideAspects(
    Object targetElement
)

Parameters

targetElement
Type: System..::.Object
Code element (_Assembly, Type, FieldInfo, MethodBase, PropertyInfo, EventInfo, ParameterInfo, or LocationInfo) to which the current aspect has been applied.

Return Value

A set of aspect instances.

Remarks

Implementations of this method are only allowed to return aspect instances applied on elements of code located under the target element of code (targetElement). For instance, a type-level IAspectProvider can provide aspects on methods of the current type, but not of other types.

See Also

IAspectProvider Interface
PostSharp.Aspects Namespace


IAssemblyLevelAspect Interface

IAssemblyLevelAspect Interface
See Also Send Feedback
Runtime semantics of aspects applied at assembly level.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssemblyLevelAspect : IAspect

Remarks

An assembly-level aspect has no equivalent to RuntimeInitialize since assemblies are never initialized.

See Also

PostSharp.Aspects Namespace
PostSharp.Aspects..::.IAssemblyLevelAspectBuildSemantics
PostSharp.Aspects..::.AssemblyLevelAspect


IAssemblyLevelAspectBuildSemantics Interface

IAssemblyLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Build-time semantics of aspects applied at assembly level.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssemblyLevelAspectBuildSemantics : IAspect

See Also

IAssemblyLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.AssemblyLevelAspect


IAssemblyLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
IAssemblyLevelAspectBuildSemantics Members
IAssemblyLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The IAssemblyLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

See Also

IAssemblyLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IAssemblyLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
IAssemblyLevelAspectBuildSemantics Methods
IAssemblyLevelAspectBuildSemantics Interface See Also Send Feedback

The IAssemblyLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

See Also

IAssemblyLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

IAssemblyLevelAspectBuildSemantics..::..CompileTimeInitialize Method
IAssemblyLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    _Assembly assembly,
    AspectInfo aspectInfo
)

Parameters

assembly
Type: System.Runtime.InteropServices..::._Assembly
Assembly to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

IAssemblyLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects
Conceptual Documentation: Initializing Aspects


IComposed(T) Interface

IComposed<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
Interface exposing the implementation of another interface introduced by a CompositionAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IComposed<T>

Type Parameters

T
Interface whose implementation is expose.

See Also

IComposed<(Of <(T>)>) Members
PostSharp.Aspects Namespace


IComposed(T) Members

[image]

PostSharp 2.0 Documentation
IComposed<(Of <(<'T>)>)> Members
IComposed<(Of <(T>)>) Interface Methods See Also Send Feedback

The IComposed<(Of <(T>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetImplementation | Gets the object implementing the interface T on behalf of the current instance.

See Also

IComposed<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


IComposed(T) Methods

[image]

PostSharp 2.0 Documentation
IComposed<(Of <(<'T>)>)> Methods
IComposed<(Of <(T>)>) Interface See Also Send Feedback

The IComposed<(Of <(T>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetImplementation | Gets the object implementing the interface T on behalf of the current instance.

See Also

IComposed<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


GetImplementation Method

IComposed<(Of <(<'T>)>)>..::..GetImplementation Method
IComposed<(Of <(T>)>) Interface See Also Send Feedback
Gets the object implementing the interface T on behalf of the current instance.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
T GetImplementation(
    InstanceCredentials credentials
)

Parameters

credentials
Type: PostSharp.Aspects..::.InstanceCredentials
Credentials provided by the current instance.

Return Value

The object implementing the interface T on behalf of the current instance.

See Also

IComposed<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


ICompositionAspect Interface

ICompositionAspect Interface
Members See Also Send Feedback
Defines the semantics of an aspect that, when applied on a type, introduce one or many new interfaces into that type, and let these interfaces be implemented by an object created at runtime.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ICompositionAspect : ITypeLevelAspect,
    IAspect

Remarks

See CompositionAspect for details.

See Also

ICompositionAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.CompositionAspect


ICompositionAspect Members

[image]

PostSharp 2.0 Documentation
ICompositionAspect Members
ICompositionAspect Interface Methods See Also Send Feedback

The ICompositionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CreateImplementationObject | Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from ITypeLevelAspect.)

See Also

ICompositionAspect Interface
PostSharp.Aspects Namespace


ICompositionAspect Methods

[image]

PostSharp 2.0 Documentation
ICompositionAspect Methods
ICompositionAspect Interface See Also Send Feedback

The ICompositionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CreateImplementationObject | Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from ITypeLevelAspect.)

See Also

ICompositionAspect Interface
PostSharp.Aspects Namespace


CreateImplementationObject Method

ICompositionAspect..::..CreateImplementationObject Method
ICompositionAspect Interface See Also Send Feedback
Method invoked at runtime, during the initialization of instances of the target type, to create the composed object.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object CreateImplementationObject(
    AdviceArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.AdviceArgs

[Missing <param name="args"/> documentation for "M:PostSharp.Aspects.ICompositionAspect.CreateImplementationObject(PostSharp.Aspects.AdviceArgs)"]

Return Value

The composed object. This interface should implement the interfaces specified by the PublicInterfaces and ProtectedInterfaces collections.

Remarks

This method is invoked during at runtime after the base constructor has executed, and before the constructor of the current type is executed.

See Also

ICompositionAspect Interface
PostSharp.Aspects Namespace


ICustomAttributeIntroductionAspect Interface

ICustomAttributeIntroductionAspect Interface
See Also Send Feedback
Semantics of an aspect that, when applied to a target, adds a custom attribute to this target.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ICustomAttributeIntroductionAspect : IAspect

Remarks

See CustomAttributeIntroductionAspect for details.

See Also

PostSharp.Aspects Namespace
PostSharp.Aspects..::.CustomAttributeIntroductionAspect
PostSharp.Aspects.Configuration..::.CustomAttributeIntroductionAspectConfiguration


IEventBinding Interface

IEventBinding Interface
Members See Also Send Feedback
Interface through which an event-level aspect or advice can invoke the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IEventBinding

See Also

IEventBinding Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Advices..::.ImportMemberAttribute
Conceptual Documentation: Aspect Bindings


IEventBinding Members

[image]

PostSharp 2.0 Documentation
IEventBinding Members
IEventBinding Interface Methods See Also Send Feedback

The IEventBinding type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Invoke the Add semantic on the next node in the chain of invocation.
Public method | InvokeHandler | Invoke the Invoke semantic on the next node in the chain of invocation.
Public method | RemoveHandler | Invoke the Remove semantic on the next node in the chain of invocation.

See Also

IEventBinding Interface
PostSharp.Aspects Namespace


IEventBinding Methods

[image]

PostSharp 2.0 Documentation
IEventBinding Methods
IEventBinding Interface See Also Send Feedback

The IEventBinding type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Invoke the Add semantic on the next node in the chain of invocation.
Public method | InvokeHandler | Invoke the Invoke semantic on the next node in the chain of invocation.
Public method | RemoveHandler | Invoke the Remove semantic on the next node in the chain of invocation.

See Also

IEventBinding Interface
PostSharp.Aspects Namespace


AddHandler Method

IEventBinding..::..AddHandler Method
IEventBinding Interface See Also Send Feedback
Invoke the Add semantic on the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void AddHandler(
    ref Object instance,
    Delegate handler
)

Parameters

instance
Type: System..::.Object %
Target instance on which the event is defined (null if the event is static).
handler
Type: System..::.Delegate
Handler to be added to the event.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

See Also

IEventBinding Interface
PostSharp.Aspects Namespace


InvokeHandler Method

IEventBinding..::..InvokeHandler Method
IEventBinding Interface See Also Send Feedback
Invoke the Invoke semantic on the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object InvokeHandler(
    ref Object instance,
    Delegate handler,
    Arguments arguments
)

Parameters

instance
Type: System..::.Object %
Target instance on which the event is defined (null if the event is static).
handler
Type: System..::.Delegate
Handler to be removed from the event.
arguments
Type: PostSharp.Aspects..::.Arguments
Arguments with which the handler should be invoked.

Return Value

The value returned by the handler.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

Note
The Invoke Event Handler semantic is different from normal event firing. Indeed, when you fire an event, all handlers that were added to this event are fired. However, the current method invokes only a single handler: the one passed to the handler parameter.

See Also

IEventBinding Interface
PostSharp.Aspects Namespace


RemoveHandler Method

IEventBinding..::..RemoveHandler Method
IEventBinding Interface See Also Send Feedback
Invoke the Remove semantic on the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RemoveHandler(
    ref Object instance,
    Delegate handler
)

Parameters

instance
Type: System..::.Object %
Target instance on which the event is defined (null if the event is static).
handler
Type: System..::.Delegate
Handler to be removed from the event.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

See Also

IEventBinding Interface
PostSharp.Aspects Namespace


IEventInterceptionAspect Interface

IEventInterceptionAspect Interface
Members See Also Send Feedback
Runtime semantics of an aspect that, when applied on an event, intercepts invocations of its semantics Add (OnAddHandler(EventInterceptionArgs)), Remove (OnRemoveHandler(EventInterceptionArgs)) and Invoke (OnInvokeHandler(EventInterceptionArgs)) semantics.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IEventInterceptionAspect : IEventLevelAspect,
    IAspect

Remarks

For details, see EventInterceptionAspect

See Also

IEventInterceptionAspect Members
PostSharp.Aspects Namespace


IEventInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
IEventInterceptionAspect Members
IEventInterceptionAspect Interface Methods See Also Send Feedback

The IEventInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnAddHandler | Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.
Public method | OnInvokeHandler | Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.
Public method | OnRemoveHandler | Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IEventLevelAspect.)

See Also

IEventInterceptionAspect Interface
PostSharp.Aspects Namespace


IEventInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
IEventInterceptionAspect Methods
IEventInterceptionAspect Interface See Also Send Feedback

The IEventInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnAddHandler | Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.
Public method | OnInvokeHandler | Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.
Public method | OnRemoveHandler | Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IEventLevelAspect.)

See Also

IEventInterceptionAspect Interface
PostSharp.Aspects Namespace


OnAddHandler Method

IEventInterceptionAspect..::..OnAddHandler Method
IEventInterceptionAspect Interface See Also Send Feedback
Method invoked instead of the Add semantic of the event to which the current aspect is applied, i.e. when a new delegate is added to this event.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnAddHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

See Also

IEventInterceptionAspect Interface
PostSharp.Aspects Namespace


OnInvokeHandler Method

IEventInterceptionAspect..::..OnInvokeHandler Method
IEventInterceptionAspect Interface See Also Send Feedback
Method invoked when the event to which the current aspect is applied is fired, for each delegate of this event, and instead of invoking this delegate.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnInvokeHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

Note
The Invoke Event Handler semantic is different from normal event firing. Indeed, when you fire an event, all handlers that were added to this event are fired. However, the current method invokes only a single handler: the one passed to the handler parameter.

See Also

IEventInterceptionAspect Interface
PostSharp.Aspects Namespace


OnRemoveHandler Method

IEventInterceptionAspect..::..OnRemoveHandler Method
IEventInterceptionAspect Interface See Also Send Feedback
Method invoked instead of the Remove semantic of the event to which the current aspect is applied, i.e. when a delegate is removed from this event.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnRemoveHandler(
    EventInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.EventInterceptionArgs
Handler arguments.

Remarks

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

See Also

IEventInterceptionAspect Interface
PostSharp.Aspects Namespace


IEventLevelAspect Interface

IEventLevelAspect Interface
Members See Also Send Feedback
Runtime semantics of aspects that can be applied on events.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IEventLevelAspect : IAspect

See Also

IEventLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.EventLevelAspect
PostSharp.Aspects..::.IEventLevelAspectBuildSemantics


IEventLevelAspect Members

[image]

PostSharp 2.0 Documentation
IEventLevelAspect Members
IEventLevelAspect Interface Methods See Also Send Feedback

The IEventLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

IEventLevelAspect Interface
PostSharp.Aspects Namespace


IEventLevelAspect Methods

[image]

PostSharp 2.0 Documentation
IEventLevelAspect Methods
IEventLevelAspect Interface See Also Send Feedback

The IEventLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

IEventLevelAspect Interface
PostSharp.Aspects Namespace


RuntimeInitialize Method

IEventLevelAspect..::..RuntimeInitialize Method
IEventLevelAspect Interface See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitialize(
    EventInfo eventInfo
)

Parameters

eventInfo
Type: System.Reflection..::.EventInfo
Event to which the current aspect is applied.

See Also

IEventLevelAspect Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IEventLevelAspectBuildSemantics Interface

IEventLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Build-time semantics of aspects that can be applied on events.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IEventLevelAspectBuildSemantics : IAspectBuildSemantics,
    IValidableAnnotation

See Also

IEventLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.EventLevelAspect
PostSharp.Aspects..::.IEventLevelAspect


IEventLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
IEventLevelAspectBuildSemantics Members
IEventLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The IEventLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IEventLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IEventLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
IEventLevelAspectBuildSemantics Methods
IEventLevelAspectBuildSemantics Interface See Also Send Feedback

The IEventLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IEventLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

IEventLevelAspectBuildSemantics..::..CompileTimeInitialize Method
IEventLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    EventInfo targetEvent,
    AspectInfo aspectInfo
)

Parameters

targetEvent
Type: System.Reflection..::.EventInfo
Event to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

IEventLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IExternalAspect Interface

IExternalAspect Interface
See Also Send Feedback
Allows to turn an arbitrary custom attribute into an aspect, while implementing the aspect in a different class. Classes implementing this interface must be annotated with the ExternalAspectConfigurationAttribute custom attribute.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IExternalAspect : IAspect

Remarks

For details, see ExternalAspect.

See Also

PostSharp.Aspects Namespace
PostSharp.Aspects..::.ExternalAspect
PostSharp.Aspects..::.IExternalAspectImplementation
Conceptual Documentation: Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework


IExternalAspectImplementation Interface

IExternalAspectImplementation Interface
Members See Also Send Feedback
Implementation of an IExternalAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IExternalAspectImplementation

Remarks

Classes implementing this interface are instantiated in the post-compiler and are executed against the full .NET Framework. However, when processing a Silverlight or Compact Framework project, classes of this project cannot be instantiated in the post-compiler, neither can code be executed. Therefore, all aspects should be represented as object constructions (ObjectConstruction), and not aspect instances themselves.

See Also

IExternalAspectImplementation Members
PostSharp.Aspects Namespace
Conceptual Documentation: Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework


IExternalAspectImplementation Members

[image]

PostSharp 2.0 Documentation
IExternalAspectImplementation Members
IExternalAspectImplementation Interface Methods See Also Send Feedback

The IExternalAspectImplementation type exposes the following members.

Methods

 | Name | Description
Public method | ProvideImplementationAspects | Returns a set of aspect instances to be added to the project.

See Also

IExternalAspectImplementation Interface
PostSharp.Aspects Namespace


IExternalAspectImplementation Methods

[image]

PostSharp 2.0 Documentation
IExternalAspectImplementation Methods
IExternalAspectImplementation Interface See Also Send Feedback

The IExternalAspectImplementation type exposes the following members.

Methods

 | Name | Description
Public method | ProvideImplementationAspects | Returns a set of aspect instances to be added to the project.

See Also

IExternalAspectImplementation Interface
PostSharp.Aspects Namespace


ProvideImplementationAspects Method

IExternalAspectImplementation..::..ProvideImplementationAspects Method
IExternalAspectImplementation Interface See Also Send Feedback
Returns a set of aspect instances to be added to the project.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<AspectInstance> ProvideImplementationAspects(
    Object target,
    ObjectConstruction aspectConstruction
)

Parameters

target
Type: System..::.Object
Code element (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) on which the aspect is applied.
aspectConstruction
Type: PostSharp.Reflection..::.ObjectConstruction
Representation of the aspect instance (implementing IExternalAspect) requiring external implementation.

Return Value

A set of aspect instances to be added to the project. Objects AspectInstance are expected to be initialized using a constructor taking a required argument of type ObjectConstruction and an optional parameter of type AspectConfiguration.

See Also

IExternalAspectImplementation Interface
PostSharp.Aspects Namespace


IFieldLevelAspect Interface

IFieldLevelAspect Interface
Members See Also Send Feedback
Run-time semantics of aspects applied to fields.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IFieldLevelAspect : IAspect

See Also

IFieldLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IFieldLevelAspectBuildSemantics
PostSharp.Aspects..::.FieldLevelAspect


IFieldLevelAspect Members

[image]

PostSharp 2.0 Documentation
IFieldLevelAspect Members
IFieldLevelAspect Interface Methods See Also Send Feedback

The IFieldLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Method invoked at runtime before any other method of the aspect is invoked.

See Also

IFieldLevelAspect Interface
PostSharp.Aspects Namespace


IFieldLevelAspect Methods

[image]

PostSharp 2.0 Documentation
IFieldLevelAspect Methods
IFieldLevelAspect Interface See Also Send Feedback

The IFieldLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Method invoked at runtime before any other method of the aspect is invoked.

See Also

IFieldLevelAspect Interface
PostSharp.Aspects Namespace


RuntimeInitialize Method

IFieldLevelAspect..::..RuntimeInitialize Method
IFieldLevelAspect Interface See Also Send Feedback
Method invoked at runtime before any other method of the aspect is invoked.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitialize(
    FieldInfo field
)

Parameters

field
Type: System.Reflection..::.FieldInfo
Field on which this instance is applied.

See Also

IFieldLevelAspect Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IFieldLevelAspectBuildSemantics Interface

IFieldLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Compile-time semantics of IFieldLevelAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IFieldLevelAspectBuildSemantics : IAspectBuildSemantics,
    IValidableAnnotation

See Also

IFieldLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IFieldLevelAspect
PostSharp.Aspects..::.FieldLevelAspect


IFieldLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
IFieldLevelAspectBuildSemantics Members
IFieldLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The IFieldLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IFieldLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IFieldLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
IFieldLevelAspectBuildSemantics Methods
IFieldLevelAspectBuildSemantics Interface See Also Send Feedback

The IFieldLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IFieldLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

IFieldLevelAspectBuildSemantics..::..CompileTimeInitialize Method
IFieldLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    FieldInfo field,
    AspectInfo aspectInfo
)

Parameters

field
Type: System.Reflection..::.FieldInfo
Field to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

IFieldLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IInstanceScopedAspect Interface

IInstanceScopedAspect Interface
Members See Also Send Feedback
Runtime semantics of aspects that have the same lifetime as instance of types to which their are applied (or instance of the declaring type of members to which they are applied).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IInstanceScopedAspect : IAspect

Remarks

When an aspect is instance-scoped, a new instance of this aspect is created whenever an instance of the type to which it has been applied is created (concretely, before the call to the base constructor and the own constructor of this type).

New aspect instances are obtained using the prototype design pattern. As any other aspect, an instance-scope aspect has a static instance initialized at build time, then serialized, deserialized at runtime, and initialized by RuntimeInitialize. This static instance then serves as a prototype. When a new instance of the target type is created, the prototype is cloned by the method CreateInstance(AdviceArgs) (typically implemented by a call to MemberwiseClone()()()). Then some system initializations (for instance member import) are performed on the aspect instance, and finally the RuntimeInitializeInstance()()() method is invoked.

When an aspect implementing the IInstanceScopedAspect interface is applied on a static method, field, property, or event, the aspect will be statically scoped and the interface will be ignored.

See Also

IInstanceScopedAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Understanding Aspect Lifetime and Scope


IInstanceScopedAspect Members

[image]

PostSharp 2.0 Documentation
IInstanceScopedAspect Members
IInstanceScopedAspect Interface Methods See Also Send Feedback

The IInstanceScopedAspect type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Creates a new instance of the aspect based on the current instance, serving as a prototype.
Public method | RuntimeInitializeInstance | Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.

See Also

IInstanceScopedAspect Interface
PostSharp.Aspects Namespace


IInstanceScopedAspect Methods

[image]

PostSharp 2.0 Documentation
IInstanceScopedAspect Methods
IInstanceScopedAspect Interface See Also Send Feedback

The IInstanceScopedAspect type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Creates a new instance of the aspect based on the current instance, serving as a prototype.
Public method | RuntimeInitializeInstance | Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.

See Also

IInstanceScopedAspect Interface
PostSharp.Aspects Namespace


CreateInstance Method

IInstanceScopedAspect..::..CreateInstance Method
IInstanceScopedAspect Interface See Also Send Feedback
Creates a new instance of the aspect based on the current instance, serving as a prototype.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object CreateInstance(
    AdviceArgs adviceArgs
)

Parameters

adviceArgs
Type: PostSharp.Aspects..::.AdviceArgs
Aspect arguments.

Return Value

A new instance of the aspect, typically a clone of the current prototype instance.

Remarks

This method is typically implemented by invoking MemberwiseClone()()().

See Also

IInstanceScopedAspect Interface
PostSharp.Aspects Namespace


RuntimeInitializeInstance Method

IInstanceScopedAspect..::..RuntimeInitializeInstance Method
IInstanceScopedAspect Interface See Also Send Feedback
Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitializeInstance()

See Also

IInstanceScopedAspect Interface
PostSharp.Aspects Namespace


ILocationBinding Interface

ILocationBinding Interface
Members See Also Send Feedback
Interface through which a field- or property-level aspect or advice can invoke the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ILocationBinding

See Also

ILocationBinding Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Advices..::.ImportMemberAttribute
Conceptual Documentation: Aspect Bindings


ILocationBinding Members

[image]

PostSharp 2.0 Documentation
ILocationBinding Members
ILocationBinding Interface Methods See Also Send Feedback

The ILocationBinding type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Invokes the Get semantic on the next node in the chain of invocation.
Public method | SetValue | Invokes the Set semantic on the next node in the chain of invocation.

See Also

ILocationBinding Interface
PostSharp.Aspects Namespace


ILocationBinding Methods

[image]

PostSharp 2.0 Documentation
ILocationBinding Methods
ILocationBinding Interface See Also Send Feedback

The ILocationBinding type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Invokes the Get semantic on the next node in the chain of invocation.
Public method | SetValue | Invokes the Set semantic on the next node in the chain of invocation.

See Also

ILocationBinding Interface
PostSharp.Aspects Namespace


GetValue Method

ILocationBinding..::..GetValue Method
ILocationBinding Interface See Also Send Feedback
Invokes the Get semantic on the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object GetValue(
    ref Object instance,
    Arguments index
)

Parameters

instance
Type: System..::.Object %
Target instance from which the field or property should be retrieved (null if the field or property is static).
index
Type: PostSharp.Aspects..::.Arguments
Index arguments, if the location is an indexer property.

Return Value

The value stored at the location.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

See Also

ILocationBinding Interface
PostSharp.Aspects Namespace


SetValue Method

ILocationBinding..::..SetValue Method
ILocationBinding Interface See Also Send Feedback
Invokes the Set semantic on the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void SetValue(
    ref Object instance,
    Arguments index,
    Object value
)

Parameters

instance
Type: System..::.Object %
Target instance from which the field or property should be retrieved (null if the field or property is static).
index
Type: PostSharp.Aspects..::.Arguments
Index arguments, if the location is an indexer property.
value
Type: System..::.Object
New value to be stored at the location.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

See Also

ILocationBinding Interface
PostSharp.Aspects Namespace


ILocationInterceptionAspect Interface

ILocationInterceptionAspect Interface
Members See Also Send Feedback
Runtime semantics of an aspect that, when applied on a location (field or property), intercepts invocations of the Get (OnGetValue(LocationInterceptionArgs)) and Set (OnSetValue(LocationInterceptionArgs)) semantics.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ILocationInterceptionAspect : ILocationLevelAspect,
    IAspect

Remarks

See LocationInterceptionAspect for details.

See Also

ILocationInterceptionAspect Members
PostSharp.Aspects Namespace


ILocationInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
ILocationInterceptionAspect Members
ILocationInterceptionAspect Interface Methods See Also Send Feedback

The ILocationInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnGetValue | Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.
Public method | OnSetValue | Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from ILocationLevelAspect.)

See Also

ILocationInterceptionAspect Interface
PostSharp.Aspects Namespace


ILocationInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
ILocationInterceptionAspect Methods
ILocationInterceptionAspect Interface See Also Send Feedback

The ILocationInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnGetValue | Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.
Public method | OnSetValue | Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from ILocationLevelAspect.)

See Also

ILocationInterceptionAspect Interface
PostSharp.Aspects Namespace


OnGetValue Method

ILocationInterceptionAspect..::..OnGetValue Method
ILocationInterceptionAspect Interface See Also Send Feedback
Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnGetValue(
    LocationInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.LocationInterceptionArgs
Advice arguments.

See Also

ILocationInterceptionAspect Interface
PostSharp.Aspects Namespace
PostSharp.Aspects..::.LocationInterceptionArgs


OnSetValue Method

ILocationInterceptionAspect..::..OnSetValue Method
ILocationInterceptionAspect Interface See Also Send Feedback
Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnSetValue(
    LocationInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.LocationInterceptionArgs
Advice arguments.

See Also

ILocationInterceptionAspect Interface
PostSharp.Aspects Namespace
PostSharp.Aspects..::.LocationInterceptionArgs


ILocationLevelAspect Interface

ILocationLevelAspect Interface
Members See Also Send Feedback
Runtime semantics of aspects defined on a field, property, or parameter.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ILocationLevelAspect : IAspect

See Also

ILocationLevelAspect Members
PostSharp.Aspects Namespace


ILocationLevelAspect Members

[image]

PostSharp 2.0 Documentation
ILocationLevelAspect Members
ILocationLevelAspect Interface Methods See Also Send Feedback

The ILocationLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

ILocationLevelAspect Interface
PostSharp.Aspects Namespace


ILocationLevelAspect Methods

[image]

PostSharp 2.0 Documentation
ILocationLevelAspect Methods
ILocationLevelAspect Interface See Also Send Feedback

The ILocationLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

ILocationLevelAspect Interface
PostSharp.Aspects Namespace


RuntimeInitialize Method

ILocationLevelAspect..::..RuntimeInitialize Method
ILocationLevelAspect Interface See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitialize(
    LocationInfo locationInfo
)

Parameters

locationInfo
Type: PostSharp.Reflection..::.LocationInfo
Location to which the current aspect is applied.

See Also

ILocationLevelAspect Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


ILocationLevelAspectBuildSemantics Interface

ILocationLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Compile-time semantics of IMethodLevelAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ILocationLevelAspectBuildSemantics : IAspectBuildSemantics,
    IValidableAnnotation

See Also

ILocationLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace


ILocationLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
ILocationLevelAspectBuildSemantics Members
ILocationLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The ILocationLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

ILocationLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


ILocationLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
ILocationLevelAspectBuildSemantics Methods
ILocationLevelAspectBuildSemantics Interface See Also Send Feedback

The ILocationLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

ILocationLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

ILocationLevelAspectBuildSemantics..::..CompileTimeInitialize Method
ILocationLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    LocationInfo targetLocation,
    AspectInfo aspectInfo
)

Parameters

targetLocation
Type: PostSharp.Reflection..::.LocationInfo
Location to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

ILocationLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IManagedResourceIntroductionAspect Interface

IManagedResourceIntroductionAspect Interface
See Also Send Feedback
Semantics of an aspect that, when applied to an assembly, adds a managed resource to this assembly.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IManagedResourceIntroductionAspect : IAspect

Remarks

See ManagedResourceIntroductionAspect for details.

See Also

PostSharp.Aspects Namespace
PostSharp.Aspects..::.ManagedResourceIntroductionAspect
PostSharp.Aspects.Configuration..::.ManagedResourceIntroductionAspectConfiguration


IMethodBinding Interface

IMethodBinding Interface
Members See Also Send Feedback
Interface through which a method-level aspect or advice can invoke the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodBinding

See Also

IMethodBinding Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Advices..::.ImportMemberAttribute
Conceptual Documentation: Aspect Bindings


IMethodBinding Members

[image]

PostSharp 2.0 Documentation
IMethodBinding Members
IMethodBinding Interface Methods See Also Send Feedback

The IMethodBinding type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Invokes the next node in the chain of invocation.

See Also

IMethodBinding Interface
PostSharp.Aspects Namespace


IMethodBinding Methods

[image]

PostSharp 2.0 Documentation
IMethodBinding Methods
IMethodBinding Interface See Also Send Feedback

The IMethodBinding type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Invokes the next node in the chain of invocation.

See Also

IMethodBinding Interface
PostSharp.Aspects Namespace


Invoke Method

IMethodBinding..::..Invoke Method
IMethodBinding Interface See Also Send Feedback
Invokes the next node in the chain of invocation.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object Invoke(
    ref Object instance,
    Arguments arguments
)

Parameters

instance
Type: System..::.Object %
Target instance on which the method should be invoked (null if the method is static).
arguments
Type: PostSharp.Aspects..::.Arguments
Method arguments.

Return Value

Return value of the method.

Remarks

The instance parameter is passed by reference so that instance methods of value types ( struct in C#) are allowed to change the value of the instance.

See Also

IMethodBinding Interface
PostSharp.Aspects Namespace


IMethodInterceptionAspect Interface

IMethodInterceptionAspect Interface
Members See Also Send Feedback
Runtime semantics of an aspect that, when applied on a method, intercepts invocations of this method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodInterceptionAspect : IMethodLevelAspect,
    IAspect

Remarks

See MethodInterceptionAspect for details.

See Also

IMethodInterceptionAspect Members
PostSharp.Aspects Namespace


IMethodInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
IMethodInterceptionAspect Members
IMethodInterceptionAspect Interface Methods See Also Send Feedback

The IMethodInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnInvoke | Method invoked instead of the method to which the aspect has been applied.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IMethodInterceptionAspect Interface
PostSharp.Aspects Namespace


IMethodInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
IMethodInterceptionAspect Methods
IMethodInterceptionAspect Interface See Also Send Feedback

The IMethodInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnInvoke | Method invoked instead of the method to which the aspect has been applied.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IMethodInterceptionAspect Interface
PostSharp.Aspects Namespace


OnInvoke Method

IMethodInterceptionAspect..::..OnInvoke Method
IMethodInterceptionAspect Interface See Also Send Feedback
Method invoked instead of the method to which the aspect has been applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnInvoke(
    MethodInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodInterceptionArgs
Advice arguments.

Remarks

The implementation of OnInvoke(MethodInterceptionArgs) may invoke Proceed()()(), may schedule it for invocation from another thread, or may completely skip its invocation. Alternatively, it may use Binding. Before returning to the caller, the OnInvoke(MethodInterceptionArgs) method must set the return value (property ReturnValue) and all output arguments (property Arguments), otherwise the target method may fail with a NullReferenceException. These are normally set by calling Proceed()()().

See Also

IMethodInterceptionAspect Interface
PostSharp.Aspects Namespace
PostSharp.Aspects..::.MethodInterceptionArgs


IMethodLevelAspect Interface

IMethodLevelAspect Interface
Members See Also Send Feedback
Runtime semantics of aspects applied to methods.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodLevelAspect : IAspect

See Also

IMethodLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IMethodLevelAspectBuildSemantics
PostSharp.Aspects..::.MethodLevelAspect


IMethodLevelAspect Members

[image]

PostSharp 2.0 Documentation
IMethodLevelAspect Members
IMethodLevelAspect Interface Methods See Also Send Feedback

The IMethodLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

IMethodLevelAspect Interface
PostSharp.Aspects Namespace


IMethodLevelAspect Methods

[image]

PostSharp 2.0 Documentation
IMethodLevelAspect Methods
IMethodLevelAspect Interface See Also Send Feedback

The IMethodLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

IMethodLevelAspect Interface
PostSharp.Aspects Namespace


RuntimeInitialize Method

IMethodLevelAspect..::..RuntimeInitialize Method
IMethodLevelAspect Interface See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitialize(
    MethodBase method
)

Parameters

method
Type: System.Reflection..::.MethodBase
Method to which the current aspect is applied.

See Also

IMethodLevelAspect Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


IMethodLevelAspectBuildSemantics Interface

IMethodLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Compile-time semantics of IMethodLevelAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodLevelAspectBuildSemantics : IAspectBuildSemantics,
    IValidableAnnotation

See Also

IMethodLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace


IMethodLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
IMethodLevelAspectBuildSemantics Members
IMethodLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The IMethodLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IMethodLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


IMethodLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
IMethodLevelAspectBuildSemantics Methods
IMethodLevelAspectBuildSemantics Interface See Also Send Feedback

The IMethodLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

IMethodLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

IMethodLevelAspectBuildSemantics..::..CompileTimeInitialize Method
IMethodLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    MethodBase method,
    AspectInfo aspectInfo
)

Parameters

method
Type: System.Reflection..::.MethodBase
Method to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

IMethodLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


InstanceCredentials Structure

InstanceCredentials Structure
Members See Also Send Feedback
Credentials that give access to 'protected' semantics.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public struct InstanceCredentials : IEquatable<InstanceCredentials>

Remarks

A protected semantic is specified by an interface with public visibility, but code can only get this interface when it provides the semantics represented by the current type. Instance semantics are typically retrieved by an instance method GetInstanceCredentials, which has protected visibility. This method is implemented by PostSharp automatically.

Note
Instance credentials are considered obsolete. It is suggested to use techniques that do not require instance credentials.

See Also

InstanceCredentials Members
PostSharp.Aspects Namespace


InstanceCredentials Members

[image]

PostSharp 2.0 Documentation
InstanceCredentials Members
InstanceCredentials Structure Methods Operators Fields See Also Send Feedback

The InstanceCredentials type exposes the following members.

Methods

 | Name | Description
Public method | AssertEquals | Throws an exception if given credentials are not equal to the current one.
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
 | MakeNew | Creates a new InstanceCredentials.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two InstanceCredentials are equal.
Inequality | Determines whether two InstanceCredentials are different.

Fields

Name | Description
Null | Gets a null (or empty) InstanceCredentials/

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


InstanceCredentials Fields

[image]

PostSharp 2.0 Documentation
InstanceCredentials Fields
InstanceCredentials Structure See Also Send Feedback

The InstanceCredentials type exposes the following members.

Fields

Name | Description
Null | Gets a null (or empty) InstanceCredentials/

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


Null Field

InstanceCredentials..::..Null Field
InstanceCredentials Structure See Also Send Feedback
Gets a null (or empty) InstanceCredentials/

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly InstanceCredentials Null

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


InstanceCredentials Methods

[image]

PostSharp 2.0 Documentation
InstanceCredentials Methods
InstanceCredentials Structure See Also Send Feedback

The InstanceCredentials type exposes the following members.

Methods

 | Name | Description
Public method | AssertEquals | Throws an exception if given credentials are not equal to the current one.
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
 | MakeNew | Creates a new InstanceCredentials.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


AssertEquals Method

InstanceCredentials..::..AssertEquals Method
InstanceCredentials Structure See Also Send Feedback
Throws an exception if given credentials are not equal to the current one.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AssertEquals(
    InstanceCredentials others
)

Parameters

others
Type: PostSharp.Aspects..::.InstanceCredentials
Other credentials.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
InstanceCredentials..::..Equals Method
InstanceCredentials Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(InstanceCredentials) | Indicates whether the current object is equal to another object of the same type.

See Also

InstanceCredentials Structure
InstanceCredentials Members
PostSharp.Aspects Namespace


Equals Method (Object)

InstanceCredentials..::..Equals Method (Object)
InstanceCredentials Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

InstanceCredentials Structure
Equals Overload
PostSharp.Aspects Namespace


Equals Method (InstanceCredentials)

InstanceCredentials..::..Equals Method (InstanceCredentials)
InstanceCredentials Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    InstanceCredentials other
)

Parameters

other
Type: PostSharp.Aspects..::.InstanceCredentials
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

InstanceCredentials Structure
Equals Overload
PostSharp.Aspects Namespace


GetHashCode Method

InstanceCredentials..::..GetHashCode Method
InstanceCredentials Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


MakeNew Method

InstanceCredentials..::..MakeNew Method
InstanceCredentials Structure See Also Send Feedback
Creates a new InstanceCredentials.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static InstanceCredentials MakeNew()

Return Value

A new InstanceCredentials.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


ToString Method

InstanceCredentials..::..ToString Method
InstanceCredentials Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


InstanceCredentials Operators

[image]

PostSharp 2.0 Documentation
InstanceCredentials Operators
InstanceCredentials Structure See Also Send Feedback

The InstanceCredentials type exposes the following members.

Operators

Name | Description
Equality | Determines whether two InstanceCredentials are equal.
Inequality | Determines whether two InstanceCredentials are different.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


Equality Operator

InstanceCredentials..::..Equality Operator
InstanceCredentials Structure See Also Send Feedback
Determines whether two InstanceCredentials are equal.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    InstanceCredentials left,
    InstanceCredentials right
)

Parameters

left
Type: PostSharp.Aspects..::.InstanceCredentials
An InstanceCredentials object.
right
Type: PostSharp.Aspects..::.InstanceCredentials
An InstanceCredentials object.

Return Value

true if left equals right, otherwise false.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


Inequality Operator

InstanceCredentials..::..Inequality Operator
InstanceCredentials Structure See Also Send Feedback
Determines whether two InstanceCredentials are different.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    InstanceCredentials left,
    InstanceCredentials right
)

Parameters

left
Type: PostSharp.Aspects..::.InstanceCredentials
An InstanceCredentials object.
right
Type: PostSharp.Aspects..::.InstanceCredentials
An InstanceCredentials object.

Return Value

true if left is different than right, otherwise false.

See Also

InstanceCredentials Structure
PostSharp.Aspects Namespace


InstanceLevelAspect Class

InstanceLevelAspect Class
Members See Also Send Feedback
Base class for aspects applied on types, but having the same lifetime as instances of the type to which they are applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class InstanceLevelAspect : TypeLevelAspect,
    IInstanceScopedAspect, IAspect

Remarks

This class is provided for convenience. You get the same functionality by deriving your aspect class directly from TypeLevelAspect and implementing the interface IInstanceScopedAspect

See IInstanceScopedAspect for a discussion of instance-scoped aspects.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.TypeLevelAspect
PostSharp.Aspects..::.InstanceLevelAspect

See Also

InstanceLevelAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Serialization
PostSharp.Aspects..::.IInstanceScopedAspect
Conceptual Documentation: Understanding Aspect Lifetime and Scope


InstanceLevelAspect Members

[image]

PostSharp 2.0 Documentation
InstanceLevelAspect Members
InstanceLevelAspect Class Constructors Methods Properties See Also Send Feedback

The InstanceLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | InstanceLevelAspect | Initializes a new instance of the InstanceLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from TypeLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | CreateInstance | Creates a new instance of the aspect based on the current instance, serving as a prototype.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from TypeLevelAspect.)
Public method | RuntimeInitializeInstance | Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Public property | Instance | Gets the object to which the current aspect has been applied.
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


InstanceLevelAspect Constructor

InstanceLevelAspect Constructor
InstanceLevelAspect Class See Also Send Feedback
Initializes a new instance of the InstanceLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InstanceLevelAspect()

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


InstanceLevelAspect Methods

[image]

PostSharp 2.0 Documentation
InstanceLevelAspect Methods
InstanceLevelAspect Class See Also Send Feedback

The InstanceLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from TypeLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | CreateInstance | Creates a new instance of the aspect based on the current instance, serving as a prototype.
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from TypeLevelAspect.)
Public method | RuntimeInitializeInstance | Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

InstanceLevelAspect..::..CreateAspectConfiguration Method
InstanceLevelAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


CreateInstance Method

InstanceLevelAspect..::..CreateInstance Method
InstanceLevelAspect Class See Also Send Feedback
Creates a new instance of the aspect based on the current instance, serving as a prototype.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Object CreateInstance(
    AdviceArgs adviceArgs
)

Parameters

adviceArgs
Type: PostSharp.Aspects..::.AdviceArgs
Aspect arguments.

Return Value

A new instance of the aspect, typically a clone of the current prototype instance.

Implements

IInstanceScopedAspect..::.CreateInstance(AdviceArgs)

Remarks

This method is typically implemented by invoking MemberwiseClone()()().

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


RuntimeInitializeInstance Method

InstanceLevelAspect..::..RuntimeInitializeInstance Method
InstanceLevelAspect Class See Also Send Feedback
Initializes the aspect instance. This method is invoked when all system elements of the aspect (like member imports) have completed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitializeInstance()

Implements

IInstanceScopedAspect..::.RuntimeInitializeInstance()()()

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


InstanceLevelAspect Properties

[image]

PostSharp 2.0 Documentation
InstanceLevelAspect Properties
InstanceLevelAspect Class See Also Send Feedback

The InstanceLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Public property | Instance | Gets the object to which the current aspect has been applied.
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


Instance Property

InstanceLevelAspect..::..Instance Property
InstanceLevelAspect Class See Also Send Feedback
Gets the object to which the current aspect has been applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object Instance { get; }

See Also

InstanceLevelAspect Class
PostSharp.Aspects Namespace


IOnExceptionAspect Interface

IOnExceptionAspect Interface
Members See Also Send Feedback
Runtime semantics of an aspect that, when applied on a method, defines an exception handler around the whole method body and let the implementation of this interface handle the exception.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IOnExceptionAspect : IMethodLevelAspect,
    IAspect

Remarks

See OnExceptionAspect for details.

See Also

IOnExceptionAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.OnExceptionAspect
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfiguration
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfigurationAttribute


IOnExceptionAspect Members

[image]

PostSharp 2.0 Documentation
IOnExceptionAspect Members
IOnExceptionAspect Interface Methods See Also Send Feedback

The IOnExceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IOnExceptionAspect Interface
PostSharp.Aspects Namespace


IOnExceptionAspect Methods

[image]

PostSharp 2.0 Documentation
IOnExceptionAspect Methods
IOnExceptionAspect Interface See Also Send Feedback

The IOnExceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IOnExceptionAspect Interface
PostSharp.Aspects Namespace


OnException Method

IOnExceptionAspect..::..OnException Method
IOnExceptionAspect Interface See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnException(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Advice arguments.

See Also

IOnExceptionAspect Interface
PostSharp.Aspects Namespace


IOnMethodBoundaryAspect Interface

IOnMethodBoundaryAspect Interface
Members See Also Send Feedback
Runtime semantics of OnMethodBoundaryAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IOnMethodBoundaryAspect : IMethodLevelAspect,
    IAspect

Remarks

See OnMethodBoundaryAspect for details.

See Also

IOnMethodBoundaryAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.OnMethodBoundaryAspect
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfiguration
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfigurationAttribute


IOnMethodBoundaryAspect Members

[image]

PostSharp 2.0 Documentation
IOnMethodBoundaryAspect Members
IOnMethodBoundaryAspect Interface Methods See Also Send Feedback

The IOnMethodBoundaryAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnEntry | Method executed before the body of methods to which this aspect is applied.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.
Public method | OnExit | Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).
Public method | OnSuccess | Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


IOnMethodBoundaryAspect Methods

[image]

PostSharp 2.0 Documentation
IOnMethodBoundaryAspect Methods
IOnMethodBoundaryAspect Interface See Also Send Feedback

The IOnMethodBoundaryAspect type exposes the following members.

Methods

 | Name | Description
Public method | OnEntry | Method executed before the body of methods to which this aspect is applied.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.
Public method | OnExit | Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).
Public method | OnSuccess | Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from IMethodLevelAspect.)

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


OnEntry Method

IOnMethodBoundaryAspect..::..OnEntry Method
IOnMethodBoundaryAspect Interface See Also Send Feedback
Method executed before the body of methods to which this aspect is applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnEntry(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed, which are its arguments, and how should the execution continue after the execution of OnEntry(MethodExecutionArgs).

Remarks

If the aspect is applied to a constructor, the current method is invoked after the this pointer has been initialized, that is, after the base constructor has been called.

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


OnException Method

IOnMethodBoundaryAspect..::..OnException Method
IOnMethodBoundaryAspect Interface See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnException(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


OnExit Method

IOnMethodBoundaryAspect..::..OnExit Method
IOnMethodBoundaryAspect Interface See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnExit(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


OnSuccess Method

IOnMethodBoundaryAspect..::..OnSuccess Method
IOnMethodBoundaryAspect Interface See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void OnSuccess(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

See Also

IOnMethodBoundaryAspect Interface
PostSharp.Aspects Namespace


IProtectedInterface(T) Interface

IProtectedInterface<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
Gives access to a 'protected' interface, typically introduced by a CompositionAspect or a IntroduceInterfaceAttribute

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IProtectedInterface<T>

Type Parameters

T
Exposed interface.

Remarks

A 'protected' interface is not directly implemented by the type. Instead, the type exposes it through the IProtectedInterface<(Of <(T>)>) interface. When an object wants access to a protected interface, it must provide valid InstanceCredentials. Since the method providing InstanceCredentials is protected, it allows an instance to control which code can have access to protected semantics.

Note
Protected interfaces are considered obsolete. It is suggested to use techniques that do not require instance credentials.

See Also

IProtectedInterface<(Of <(T>)>) Members
PostSharp.Aspects Namespace


IProtectedInterface(T) Members

[image]

PostSharp 2.0 Documentation
IProtectedInterface<(Of <(<'T>)>)> Members
IProtectedInterface<(Of <(T>)>) Interface Methods See Also Send Feedback

The IProtectedInterface<(Of <(T>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetInterface | Gets a protected interface.

See Also

IProtectedInterface<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


IProtectedInterface(T) Methods

[image]

PostSharp 2.0 Documentation
IProtectedInterface<(Of <(<'T>)>)> Methods
IProtectedInterface<(Of <(T>)>) Interface See Also Send Feedback

The IProtectedInterface<(Of <(T>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetInterface | Gets a protected interface.

See Also

IProtectedInterface<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


GetInterface Method

IProtectedInterface<(Of <(<'T>)>)>..::..GetInterface Method
IProtectedInterface<(Of <(T>)>) Interface See Also Send Feedback
Gets a protected interface.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
T GetInterface(
    InstanceCredentials credentials
)

Parameters

credentials
Type: PostSharp.Aspects..::.InstanceCredentials
Credentials of the current instance.

Return Value

The implementation of the interface T.

See Also

IProtectedInterface<(Of <(T>)>) Interface
PostSharp.Aspects Namespace


ITypeLevelAspect Interface

ITypeLevelAspect Interface
Members See Also Send Feedback
Run-time semantics of aspects applied to types.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeLevelAspect : IAspect

See Also

ITypeLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.ITypeLevelAspectBuildSemantics


ITypeLevelAspect Members

[image]

PostSharp 2.0 Documentation
ITypeLevelAspect Members
ITypeLevelAspect Interface Methods See Also Send Feedback

The ITypeLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

ITypeLevelAspect Interface
PostSharp.Aspects Namespace


ITypeLevelAspect Methods

[image]

PostSharp 2.0 Documentation
ITypeLevelAspect Methods
ITypeLevelAspect Interface See Also Send Feedback

The ITypeLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | RuntimeInitialize | Initializes the current aspect.

See Also

ITypeLevelAspect Interface
PostSharp.Aspects Namespace


RuntimeInitialize Method

ITypeLevelAspect..::..RuntimeInitialize Method
ITypeLevelAspect Interface See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void RuntimeInitialize(
    Type type
)

Parameters

type
Type: System..::.Type
Type to which the current aspect is applied.

See Also

ITypeLevelAspect Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


ITypeLevelAspectBuildSemantics Interface

ITypeLevelAspectBuildSemantics Interface
Members See Also Send Feedback
Compile-time semantics of ITypeLevelAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeLevelAspectBuildSemantics : IAspectBuildSemantics,
    IValidableAnnotation

See Also

ITypeLevelAspectBuildSemantics Members
PostSharp.Aspects Namespace


ITypeLevelAspectBuildSemantics Members

[image]

PostSharp 2.0 Documentation
ITypeLevelAspectBuildSemantics Members
ITypeLevelAspectBuildSemantics Interface Methods See Also Send Feedback

The ITypeLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

ITypeLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


ITypeLevelAspectBuildSemantics Methods

[image]

PostSharp 2.0 Documentation
ITypeLevelAspectBuildSemantics Methods
ITypeLevelAspectBuildSemantics Interface See Also Send Feedback

The ITypeLevelAspectBuildSemantics type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from IValidableAnnotation.)
Public method | GetAspectConfiguration | Method invoked at build time to get the imperative configuration of the current Aspect. (Inherited from IAspectBuildSemantics.)

See Also

ITypeLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace


CompileTimeInitialize Method

ITypeLevelAspectBuildSemantics..::..CompileTimeInitialize Method
ITypeLevelAspectBuildSemantics Interface See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void CompileTimeInitialize(
    Type type,
    AspectInfo aspectInfo
)

Parameters

type
Type: System..::.Type
Type to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

See Also

ITypeLevelAspectBuildSemantics Interface
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


LocationInterceptionArgs Class

LocationInterceptionArgs Class
Members See Also Send Feedback
Arguments of advices of aspect type LocationInterceptionAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class LocationInterceptionArgs : AdviceArgs

Remarks

Note
As a result of weaving optimizations, instances of classes derived from AdviceArgs may be shared among different aspects. Therefore, aspect code should not attempt to access this object once the control has been given over to the next node in the chain of invocation. Consider working with aspect bindings if you need such deferred execution.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AdviceArgs
PostSharp.Aspects..::.LocationInterceptionArgs

See Also

LocationInterceptionArgs Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings
PostSharp.Aspects..::.LocationInterceptionAspect


LocationInterceptionArgs Members

[image]

PostSharp 2.0 Documentation
LocationInterceptionArgs Members
LocationInterceptionArgs Class Methods Properties See Also Send Feedback

The LocationInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | GetCurrentValue | Retrieves the current value of the location without overwriting the Value property.
Public method | ProceedGetValue | Invokes the Get Location Value semantic on the next node in the chain of invocation and stores the location value in the Value property.
Public method | ProceedSetValue | Invokes the Set Location Value semantic on the next node in the chain of invocation and stores the value of the Value property into the location.
Public method | SetNewValue | Sets the value of the location without overwriting the Value property.

Properties

 | Name | Description
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Index | Gets the current index arguments (in case of a property with parameters).
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Location | Gets the location (field, property or parameter) related to the aspect or advice being executed.
Public property | LocationFullName | Gets the full name (including the full name of the declaring type) of the location (field, property or parameter) related to the aspect or advice being executed.
Public property | LocationName | Gets the name of the location (field, property or parameter) related to the aspect or advice being executed.
Public property | Value | Gets or sets the location value.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


LocationInterceptionArgs Methods

[image]

PostSharp 2.0 Documentation
LocationInterceptionArgs Methods
LocationInterceptionArgs Class See Also Send Feedback

The LocationInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | GetCurrentValue | Retrieves the current value of the location without overwriting the Value property.
Public method | ProceedGetValue | Invokes the Get Location Value semantic on the next node in the chain of invocation and stores the location value in the Value property.
Public method | ProceedSetValue | Invokes the Set Location Value semantic on the next node in the chain of invocation and stores the value of the Value property into the location.
Public method | SetNewValue | Sets the value of the location without overwriting the Value property.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


GetCurrentValue Method

LocationInterceptionArgs..::..GetCurrentValue Method
LocationInterceptionArgs Class See Also Send Feedback
Retrieves the current value of the location without overwriting the Value property.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object GetCurrentValue()

Return Value

The current value of the location, as returned by the next node in the chain of invocation (see Binding).

Remarks

Note
This method is designed to be invoked during the execution of the advice. If you need to retrieve or store the value of the location at a different time, it is recommended to use the Binding . Indeed, a binding is stateless, while LocationInterceptionArgs instances may be shared among different aspects.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


ProceedGetValue Method

LocationInterceptionArgs..::..ProceedGetValue Method
LocationInterceptionArgs Class See Also Send Feedback
Invokes the Get Location Value semantic on the next node in the chain of invocation and stores the location value in the Value property.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProceedGetValue()

Remarks

Note that this method overwrites the content of the Value property. Therefore, you should not call this invoke from a OnSetValue(LocationInterceptionArgs) advice unless you store the value before. If you need to retrieve the current value of the location from a OnSetValue(LocationInterceptionArgs) advice, it is recommended you use the GetCurrentValue()()() method.

Note
This method is designed to be invoked during the execution of the advice. If you need to retrieve or store the value of the location at a different time, it is recommended to use the Binding . Indeed, a binding is stateless, while LocationInterceptionArgs instances may be shared among different aspects.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


ProceedSetValue Method

LocationInterceptionArgs..::..ProceedSetValue Method
LocationInterceptionArgs Class See Also Send Feedback
Invokes the Set Location Value semantic on the next node in the chain of invocation and stores the value of the Value property into the location.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProceedSetValue()

Remarks

Note that this method requires the value to be stored in the Value property. If you need to retrieve the current value of the location from a OnSetValue(LocationInterceptionArgs) advice, it is recommended you use the GetCurrentValue()()() method.

Note
This method is designed to be invoked during the execution of the advice. If you need to retrieve or store the value of the location at a different time, it is recommended to use the Binding . Indeed, a binding is stateless, while LocationInterceptionArgs instances may be shared among different aspects.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


SetNewValue Method

LocationInterceptionArgs..::..SetNewValue Method
LocationInterceptionArgs Class See Also Send Feedback
Sets the value of the location without overwriting the Value property.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void SetNewValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to be passed to the next node in the chain of invocation (see Binding).

Remarks

Note
This method is designed to be invoked during the execution of the advice. If you need to retrieve or store the value of the location at a different time, it is recommended to use the Binding . Indeed, a binding is stateless, while LocationInterceptionArgs instances may be shared among different aspects.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


LocationInterceptionArgs Properties

[image]

PostSharp 2.0 Documentation
LocationInterceptionArgs Properties
LocationInterceptionArgs Class See Also Send Feedback

The LocationInterceptionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Index | Gets the current index arguments (in case of a property with parameters).
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Location | Gets the location (field, property or parameter) related to the aspect or advice being executed.
Public property | LocationFullName | Gets the full name (including the full name of the declaring type) of the location (field, property or parameter) related to the aspect or advice being executed.
Public property | LocationName | Gets the name of the location (field, property or parameter) related to the aspect or advice being executed.
Public property | Value | Gets or sets the location value.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


Binding Property

LocationInterceptionArgs..::..Binding Property
LocationInterceptionArgs Class See Also Send Feedback
Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ILocationBinding Binding { get; }

Remarks

Bindings are thread-safe and context-free singleton instances exposing the next node in the chain of invocation.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings


Index Property

LocationInterceptionArgs..::..Index Property
LocationInterceptionArgs Class See Also Send Feedback
Gets the current index arguments (in case of a property with parameters).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Arguments Index { get; private set; }

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


Location Property

LocationInterceptionArgs..::..Location Property
LocationInterceptionArgs Class See Also Send Feedback
Gets the location (field, property or parameter) related to the aspect or advice being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInfo Location { get; set; }

Remarks

Note
Using this property causes the aspect weaver to generate code that has non-trivial runtime overhead. Avoid using this property whenever possible. One of the possible solution is to use compile-time initialization of aspect instances and to make use of reflection only at build time.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


LocationFullName Property

LocationInterceptionArgs..::..LocationFullName Property
LocationInterceptionArgs Class See Also Send Feedback
Gets the full name (including the full name of the declaring type) of the location (field, property or parameter) related to the aspect or advice being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string LocationFullName { get; set; }

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


LocationName Property

LocationInterceptionArgs..::..LocationName Property
LocationInterceptionArgs Class See Also Send Feedback
Gets the name of the location (field, property or parameter) related to the aspect or advice being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string LocationName { get; set; }

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


Value Property

LocationInterceptionArgs..::..Value Property
LocationInterceptionArgs Class See Also Send Feedback
Gets or sets the location value.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object Value { get; set; }

Remarks

Inside an OnGetValue(LocationInterceptionArgs) advice, this property is available after the next advice in chain has been invoked using ProceedGetValue()()(). However, inside an OnSetValue(LocationInterceptionArgs) advice, the value is available immediately, and is used as input by ProceedSetValue()()().

See GetCurrentValue()()() and SetNewValue(Object) to get or set the value of the location without affecting the value of this property.

See Also

LocationInterceptionArgs Class
PostSharp.Aspects Namespace


LocationInterceptionAspect Class

LocationInterceptionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied on a location (field or property), intercepts invocations of the Get (OnGetValue(LocationInterceptionArgs)) and Set (OnSetValue(LocationInterceptionArgs)) semantics.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class LocationInterceptionAspect : LocationLevelAspect,
    ILocationInterceptionAspect, ILocationLevelAspect, IAspect

Remarks

This aspect can be applied indifferently to fields and properties, called locations because they both have the semantics of a slot where a value can be stored and retrieved.

Applying the Aspect on Properties

Applying an aspect of type LocationInterceptionAspect to a property results in the accessors of this property to be replaced by a call to the method OnGetValue(LocationInterceptionArgs) or OnSetValue(LocationInterceptionArgs) of the current class. The original body of the accessor is moved into a new method, which can be called by the aspect by invoking one of the methods ProceedGetValue()()(), ProceedSetValue()()(), GetCurrentValue()()() or SetNewValue(Object), or by using the Binding object.

For details about the implementation of this aspect, see Interception Aspects.

Applying the Aspect on Fields

Applying this aspect on a field transforms the field into a property of the same name, scope and visibility as the original field. The original field is removed. Aspect code can get or set the value of the fied by calling the methods ProceedGetValue()()(), ProceedSetValue()()(), GetCurrentValue()()() or SetNewValue(Object), or by using the Binding object.

For details about the implementation of this aspect, see Interception Aspects.

Note
Remember to use PropertyInfo instead of FieldInfo at runtime to reflect the original field. For this reason, you cannot store a FieldInfo in the aspect. Store a LocationInfo instead; even if a LocationInfo represents a field at build time, it will represent the corresponding PropertyInfo at runtime.

Note
When you apply an aspect derived from LocationInterceptionAspect to a value-type field, you should not pass the value of this field by reference (as an argument to out and ref parameters in C#). Indeed, PostSharp is unable to detect read and write accesses through references.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Backing a Property with a Registry Value

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.LocationLevelAspect
PostSharp.Aspects..::.LocationInterceptionAspect

See Also

LocationInterceptionAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfigurationAttribute
Conceptual Documentation: Aspect Serialization
Conceptual Documentation: Interception Aspects


LocationInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspect Members
LocationInterceptionAspect Class Constructors Methods Properties See Also Send Feedback

The LocationInterceptionAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | LocationInterceptionAspect | Initializes a new instance of the LocationInterceptionAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from LocationLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnGetValue | Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.
Public method | OnSetValue | Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from LocationLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace


LocationInterceptionAspect Constructor

LocationInterceptionAspect Constructor
LocationInterceptionAspect Class See Also Send Feedback
Initializes a new instance of the LocationInterceptionAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected LocationInterceptionAspect()

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace


LocationInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspect Methods
LocationInterceptionAspect Class See Also Send Feedback

The LocationInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from LocationLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnGetValue | Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.
Public method | OnSetValue | Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from LocationLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

LocationInterceptionAspect..::..CreateAspectConfiguration Method
LocationInterceptionAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override sealed AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


OnGetValue Method

LocationInterceptionAspect..::..OnGetValue Method
LocationInterceptionAspect Class See Also Send Feedback
Method invoked instead of the Get semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is retrieved.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnGetValue(
    LocationInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.LocationInterceptionArgs
Advice arguments.

Implements

ILocationInterceptionAspect..::.OnGetValue(LocationInterceptionArgs)

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace
PostSharp.Aspects..::.LocationInterceptionArgs


OnSetValue Method

LocationInterceptionAspect..::..OnSetValue Method
LocationInterceptionAspect Class See Also Send Feedback
Method invoked instead of the Set semantic of the field or property to which the current aspect is applied, i.e. when the value of this field or property is changed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnSetValue(
    LocationInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.LocationInterceptionArgs
Advice arguments.

Implements

ILocationInterceptionAspect..::.OnSetValue(LocationInterceptionArgs)

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace
PostSharp.Aspects..::.LocationInterceptionArgs


LocationInterceptionAspect Properties

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspect Properties
LocationInterceptionAspect Class See Also Send Feedback

The LocationInterceptionAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

LocationInterceptionAspect Class
PostSharp.Aspects Namespace


LocationLevelAspect Class

LocationLevelAspect Class
Members See Also Send Feedback
Base class for aspects defined in fields, properties, or parameters.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class LocationLevelAspect : Aspect,
    ILocationLevelAspect, IAspect, ILocationLevelAspectBuildSemantics, IAspectBuildSemantics, IValidableAnnotation

Remarks

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.LocationLevelAspect
PostSharp.Aspects..::.LocationInterceptionAspect

See Also

LocationLevelAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization
PostSharp.Aspects..::.ILocationLevelAspect


LocationLevelAspect Members

[image]

PostSharp 2.0 Documentation
LocationLevelAspect Members
LocationLevelAspect Class Constructors Methods Properties See Also Send Feedback

The LocationLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | LocationLevelAspect | Initializes a new instance of the LocationLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace


LocationLevelAspect Constructor

LocationLevelAspect Constructor
LocationLevelAspect Class See Also Send Feedback
Initializes a new instance of the LocationLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected LocationLevelAspect()

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace


LocationLevelAspect Methods

[image]

PostSharp 2.0 Documentation
LocationLevelAspect Methods
LocationLevelAspect Class See Also Send Feedback

The LocationLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

LocationLevelAspect..::..CompileTimeInitialize Method
LocationLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    LocationInfo targetLocation,
    AspectInfo aspectInfo
)

Parameters

targetLocation
Type: PostSharp.Reflection..::.LocationInfo
Location to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

ILocationLevelAspectBuildSemantics..::.CompileTimeInitialize(LocationInfo, AspectInfo)

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


RuntimeInitialize Method

LocationLevelAspect..::..RuntimeInitialize Method
LocationLevelAspect Class See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitialize(
    LocationInfo locationInfo
)

Parameters

locationInfo
Type: PostSharp.Reflection..::.LocationInfo
Location to which the current aspect is applied.

Implements

ILocationLevelAspect..::.RuntimeInitialize(LocationInfo)

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


LocationLevelAspect Properties

[image]

PostSharp 2.0 Documentation
LocationLevelAspect Properties
LocationLevelAspect Class See Also Send Feedback

The LocationLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

LocationLevelAspect Class
PostSharp.Aspects Namespace


ManagedResourceIntroductionAspect Class

ManagedResourceIntroductionAspect Class
Members See Also Send Feedback
Aspect that, when applied to an assembly, adds a custom attribute to this assembly.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManagedResourceIntroductionAspect : IManagedResourceIntroductionAspect,
    IAspect, IAspectBuildSemantics, IValidableAnnotation

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.ManagedResourceIntroductionAspect

See Also

ManagedResourceIntroductionAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Adding Aspects Dynamically


ManagedResourceIntroductionAspect Members

[image]

PostSharp 2.0 Documentation
ManagedResourceIntroductionAspect Members
ManagedResourceIntroductionAspect Class Constructors Properties See Also Send Feedback

The ManagedResourceIntroductionAspect type exposes the following members.

Constructors

 | Name | Description
Public method | ManagedResourceIntroductionAspect | Initializes a new ManagedResourceIntroductionAspect.

Properties

 | Name | Description
Public property | Data | Gets the content of the managed resource.
Public property | Name | Gets the name of the managed resource.

See Also

ManagedResourceIntroductionAspect Class
PostSharp.Aspects Namespace


ManagedResourceIntroductionAspect Constructor

ManagedResourceIntroductionAspect Constructor
ManagedResourceIntroductionAspect Class See Also Send Feedback
Initializes a new ManagedResourceIntroductionAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManagedResourceIntroductionAspect(
    string name,
    byte[] data
)

Parameters

name
Type: System..::.String
Name of the managed resource.
data
Type: array< System..::.Byte >[]()[][]
Content of the managed resource.

See Also

ManagedResourceIntroductionAspect Class
PostSharp.Aspects Namespace


ManagedResourceIntroductionAspect Properties

[image]

PostSharp 2.0 Documentation
ManagedResourceIntroductionAspect Properties
ManagedResourceIntroductionAspect Class See Also Send Feedback

The ManagedResourceIntroductionAspect type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets the content of the managed resource.
Public property | Name | Gets the name of the managed resource.

See Also

ManagedResourceIntroductionAspect Class
PostSharp.Aspects Namespace


Data Property

ManagedResourceIntroductionAspect..::..Data Property
ManagedResourceIntroductionAspect Class See Also Send Feedback
Gets the content of the managed resource.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] Data { get; private set; }

See Also

ManagedResourceIntroductionAspect Class
PostSharp.Aspects Namespace


Name Property

ManagedResourceIntroductionAspect..::..Name Property
ManagedResourceIntroductionAspect Class See Also Send Feedback
Gets the name of the managed resource.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; private set; }

See Also

ManagedResourceIntroductionAspect Class
PostSharp.Aspects Namespace


MethodExecutionArgs Class

MethodExecutionArgs Class
Members See Also Send Feedback
Arguments of advices of aspects of type OnMethodBoundaryAspect and OnExceptionAspect

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodExecutionArgs : AdviceArgs

Remarks

Note
As a result of weaving optimizations, instances of classes derived from AdviceArgs may be shared among different aspects. Therefore, aspect code should not attempt to access this object once the control has been given over to the next node in the chain of invocation. Consider working with aspect bindings if you need such deferred execution.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AdviceArgs
PostSharp.Aspects..::.MethodExecutionArgs

See Also

MethodExecutionArgs Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings


MethodExecutionArgs Members

[image]

PostSharp 2.0 Documentation
MethodExecutionArgs Members
MethodExecutionArgs Class Properties See Also Send Feedback

The MethodExecutionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Gets the arguments with which the method has been invoked.
Public property | Exception | Gets the exception currently flying.
Public property | FlowBehavior | Determines the control flow of the target method once the advice is exited.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Method | Gets the method being executed.
Public property | MethodExecutionTag | User-defined state information whose lifetime is linked to the current method execution. Aspects derived from IOnMethodBoundaryAspect should use this property to save state information between different events (OnEntry(MethodExecutionArgs), OnExit(MethodExecutionArgs) and OnException(MethodExecutionArgs)).
Public property | ReturnValue | Gets or sets the method return value.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


MethodExecutionArgs Properties

[image]

PostSharp 2.0 Documentation
MethodExecutionArgs Properties
MethodExecutionArgs Class See Also Send Feedback

The MethodExecutionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Gets the arguments with which the method has been invoked.
Public property | Exception | Gets the exception currently flying.
Public property | FlowBehavior | Determines the control flow of the target method once the advice is exited.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Method | Gets the method being executed.
Public property | MethodExecutionTag | User-defined state information whose lifetime is linked to the current method execution. Aspects derived from IOnMethodBoundaryAspect should use this property to save state information between different events (OnEntry(MethodExecutionArgs), OnExit(MethodExecutionArgs) and OnException(MethodExecutionArgs)).
Public property | ReturnValue | Gets or sets the method return value.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


Arguments Property

MethodExecutionArgs..::..Arguments Property
MethodExecutionArgs Class See Also Send Feedback
Gets the arguments with which the method has been invoked.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Arguments Arguments { get; set; }

Remarks

Note
The property setter should never be used in user code.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


Exception Property

MethodExecutionArgs..::..Exception Property
MethodExecutionArgs Class See Also Send Feedback
Gets the exception currently flying.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception Exception { get; set; }

Field Value

An Exception, or null if the method is exiting normally.

Remarks

You cannot replace the exception by setting this property. Throw a new exception from the aspect if you need to replace the current exception.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


FlowBehavior Property

MethodExecutionArgs..::..FlowBehavior Property
MethodExecutionArgs Class See Also Send Feedback
Determines the control flow of the target method once the advice is exited.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FlowBehavior FlowBehavior { get; set; }

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


Method Property

MethodExecutionArgs..::..Method Property
MethodExecutionArgs Class See Also Send Feedback
Gets the method being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase Method { get; set; }

Remarks

If the executed method is generic or if its declaring type is generic, the current property contains the generic instance being executed.

Note
Using this property causes the aspect weaver to generate code that has non-trivial runtime overhead. Avoid using this property whenever possible. One of the possible solution is to use compile-time initialization of aspect instances and to make use of reflection only at build time. See CompileTimeInitialize(MethodBase, AspectInfo) for details.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace
MethodLevelAspect..::.CompileTimeInitialize(MethodBase, AspectInfo)


MethodExecutionTag Property

MethodExecutionArgs..::..MethodExecutionTag Property
MethodExecutionArgs Class See Also Send Feedback
User-defined state information whose lifetime is linked to the current method execution. Aspects derived from IOnMethodBoundaryAspect should use this property to save state information between different events (OnEntry(MethodExecutionArgs), OnExit(MethodExecutionArgs) and OnException(MethodExecutionArgs)).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object MethodExecutionTag { get; set; }

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


ReturnValue Property

MethodExecutionArgs..::..ReturnValue Property
MethodExecutionArgs Class See Also Send Feedback
Gets or sets the method return value.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object ReturnValue { get; set; }

Remarks

You can modify the return value only when the join point is located after a method execution (OnSuccess(MethodExecutionArgs), OnException(MethodExecutionArgs) or OnExit(MethodExecutionArgs), or in case you force the method to exit using the FlowBehavior property.

See Also

MethodExecutionArgs Class
PostSharp.Aspects Namespace


MethodInterceptionArgs Class

MethodInterceptionArgs Class
Members See Also Send Feedback
Arguments of advices of aspect type MethodInterceptionAspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodInterceptionArgs : AdviceArgs

Remarks

Note
As a result of weaving optimizations, instances of classes derived from AdviceArgs may be shared among different aspects. Therefore, aspect code should not attempt to access this object once the control has been given over to the next node in the chain of invocation. Consider working with aspect bindings if you need such deferred execution.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.AdviceArgs
PostSharp.Aspects..::.MethodInterceptionArgs

See Also

MethodInterceptionArgs Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings
PostSharp.Aspects..::.MethodInterceptionAspect


MethodInterceptionArgs Members

[image]

PostSharp 2.0 Documentation
MethodInterceptionArgs Members
MethodInterceptionArgs Class Methods Properties See Also Send Feedback

The MethodInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Invokes the method that has been intercepted by calling the next node in the chain of invocation with given arguments, without affecting the property ReturnValue.
Public method | Proceed | Proceeds with invocation of the method that has been intercepted by calling the next node in the chain of invocation, passing the current Arguments to that method and storing its return value into the property ReturnValue.

Properties

 | Name | Description
Public property | Arguments | Gets the list of arguments with which the method has been invoked.
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Method | Gets the method being executed.
Public property | ReturnValue | Gets or sets the return value of the method.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


MethodInterceptionArgs Methods

[image]

PostSharp 2.0 Documentation
MethodInterceptionArgs Methods
MethodInterceptionArgs Class See Also Send Feedback

The MethodInterceptionArgs type exposes the following members.

Methods

 | Name | Description
Public method | Invoke | Invokes the method that has been intercepted by calling the next node in the chain of invocation with given arguments, without affecting the property ReturnValue.
Public method | Proceed | Proceeds with invocation of the method that has been intercepted by calling the next node in the chain of invocation, passing the current Arguments to that method and storing its return value into the property ReturnValue.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


Invoke Method

MethodInterceptionArgs..::..Invoke Method
MethodInterceptionArgs Class See Also Send Feedback
Invokes the method that has been intercepted by calling the next node in the chain of invocation with given arguments, without affecting the property ReturnValue.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object Invoke(
    Arguments arguments
)

Parameters

arguments
Type: PostSharp.Aspects..::.Arguments
Arguments passed to the intercepted method.

Return Value

Value returned by the intercepted method.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


Proceed Method

MethodInterceptionArgs..::..Proceed Method
MethodInterceptionArgs Class See Also Send Feedback
Proceeds with invocation of the method that has been intercepted by calling the next node in the chain of invocation, passing the current Arguments to that method and storing its return value into the property ReturnValue.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void Proceed()

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


MethodInterceptionArgs Properties

[image]

PostSharp 2.0 Documentation
MethodInterceptionArgs Properties
MethodInterceptionArgs Class See Also Send Feedback

The MethodInterceptionArgs type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Gets the list of arguments with which the method has been invoked.
Public property | Binding | Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.
Public property | Instance | Gets or sets the object instance on which the method is being executed. (Inherited from AdviceArgs.)
Public property | InstanceCredentials | Gets the credentials of the current instance. (Inherited from AdviceArgs.)
Public property | Method | Gets the method being executed.
Public property | ReturnValue | Gets or sets the return value of the method.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


Arguments Property

MethodInterceptionArgs..::..Arguments Property
MethodInterceptionArgs Class See Also Send Feedback
Gets the list of arguments with which the method has been invoked.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Arguments Arguments { get; protected set; }

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


Binding Property

MethodInterceptionArgs..::..Binding Property
MethodInterceptionArgs Class See Also Send Feedback
Gets an interface that allows to invoke the next node in the chain of invocation of the intercepted method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IMethodBinding Binding { get; }

Remarks

Bindings are thread-safe and context-free singleton instances exposing the next node in the chain of invocation.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Bindings


Method Property

MethodInterceptionArgs..::..Method Property
MethodInterceptionArgs Class See Also Send Feedback
Gets the method being executed.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase Method { get; set; }

Remarks

If the executed method is generic or if its declaring type is generic, the current property contains the generic instance being executed.

Note
Using this property causes the aspect weaver to generate code that has non-trivial runtime overhead. Avoid using this property whenever possible. One of the possible solution is to use compile-time initialization of aspect instances and to make use of reflection only at build time. See CompileTimeInitialize(MethodBase, AspectInfo) for details.

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace
MethodLevelAspect..::.CompileTimeInitialize(MethodBase, AspectInfo)


ReturnValue Property

MethodInterceptionArgs..::..ReturnValue Property
MethodInterceptionArgs Class See Also Send Feedback
Gets or sets the return value of the method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Object ReturnValue { get; set; }

See Also

MethodInterceptionArgs Class
PostSharp.Aspects Namespace


MethodInterceptionAspect Class

MethodInterceptionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied on a method, intercepts invocations of this method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class MethodInterceptionAspect : MethodLevelAspect,
    IMethodInterceptionAspect, IMethodLevelAspect, IAspect

Remarks

Applying a MethodInterceptionAspect to a method results in the body of this method to be replaced by a call to the aspect OnInvoke(MethodInterceptionArgs) method of the current class. The original method body is moved into a new method, which can be called by the aspect by invoking the Proceed()()() method, or by using the object Binding.

For details about the implementation of this aspect, see Interception Aspects.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Dispatching a Method Execution to the GUI Thread

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.MethodLevelAspect
PostSharp.Aspects..::.MethodInterceptionAspect

See Also

MethodInterceptionAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfigurationAttribute
Conceptual Documentation: Aspect Serialization
Conceptual Documentation: Interception Aspects


MethodInterceptionAspect Members

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspect Members
MethodInterceptionAspect Class Constructors Methods Properties See Also Send Feedback

The MethodInterceptionAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodInterceptionAspect | Initializes a new instance of the MethodInterceptionAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnInvoke | Method invoked instead of the method to which the aspect has been applied.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace


MethodInterceptionAspect Constructor

MethodInterceptionAspect Constructor
MethodInterceptionAspect Class See Also Send Feedback
Initializes a new instance of the MethodInterceptionAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodInterceptionAspect()

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace


MethodInterceptionAspect Methods

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspect Methods
MethodInterceptionAspect Class See Also Send Feedback

The MethodInterceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnInvoke | Method invoked instead of the method to which the aspect has been applied.
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

MethodInterceptionAspect..::..CreateAspectConfiguration Method
MethodInterceptionAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


OnInvoke Method

MethodInterceptionAspect..::..OnInvoke Method
MethodInterceptionAspect Class See Also Send Feedback
Method invoked instead of the method to which the aspect has been applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnInvoke(
    MethodInterceptionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodInterceptionArgs
Advice arguments.

Implements

IMethodInterceptionAspect..::.OnInvoke(MethodInterceptionArgs)

Remarks

The implementation of OnInvoke(MethodInterceptionArgs) may invoke Proceed()()(), may schedule it for invocation from another thread, or may completely skip its invocation. Alternatively, it may use Binding. Before returning to the caller, the OnInvoke(MethodInterceptionArgs) method must set the return value (property ReturnValue) and all output arguments (property Arguments), otherwise the target method may fail with a NullReferenceException. These are normally set by calling Proceed()()().

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace
PostSharp.Aspects..::.MethodInterceptionArgs


MethodInterceptionAspect Properties

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspect Properties
MethodInterceptionAspect Class See Also Send Feedback

The MethodInterceptionAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

MethodInterceptionAspect Class
PostSharp.Aspects Namespace


MethodLevelAspect Class

MethodLevelAspect Class
Members See Also Send Feedback
Base class for all aspects applied on methods.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class MethodLevelAspect : Aspect,
    IMethodLevelAspect, IAspect, IMethodLevelAspectBuildSemantics, IAspectBuildSemantics, IValidableAnnotation

Remarks

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.MethodLevelAspect
PostSharp.Aspects..::.MethodInterceptionAspect
PostSharp.Aspects..::.OnExceptionAspect
PostSharp.Aspects..::.OnMethodBoundaryAspect

See Also

MethodLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.IMethodLevelAspect
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization


MethodLevelAspect Members

[image]

PostSharp 2.0 Documentation
MethodLevelAspect Members
MethodLevelAspect Class Constructors Methods Properties See Also Send Feedback

The MethodLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodLevelAspect | Initializes a new instance of the MethodLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace


MethodLevelAspect Constructor

MethodLevelAspect Constructor
MethodLevelAspect Class See Also Send Feedback
Initializes a new instance of the MethodLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodLevelAspect()

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace


MethodLevelAspect Methods

[image]

PostSharp 2.0 Documentation
MethodLevelAspect Methods
MethodLevelAspect Class See Also Send Feedback

The MethodLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

MethodLevelAspect..::..CompileTimeInitialize Method
MethodLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    MethodBase method,
    AspectInfo aspectInfo
)

Parameters

method
Type: System.Reflection..::.MethodBase
Method to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

IMethodLevelAspectBuildSemantics..::.CompileTimeInitialize(MethodBase, AspectInfo)

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


RuntimeInitialize Method

MethodLevelAspect..::..RuntimeInitialize Method
MethodLevelAspect Class See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitialize(
    MethodBase method
)

Parameters

method
Type: System.Reflection..::.MethodBase
Method to which the current aspect is applied.

Implements

IMethodLevelAspect..::.RuntimeInitialize(MethodBase)

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


MethodLevelAspect Properties

[image]

PostSharp 2.0 Documentation
MethodLevelAspect Properties
MethodLevelAspect Class See Also Send Feedback

The MethodLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

MethodLevelAspect Class
PostSharp.Aspects Namespace


OnExceptionAspect Class

OnExceptionAspect Class
Members Example See Also Send Feedback
Aspect that, when applied to a method, defines an exception handler around the whole method and calls a custom method in this exception handler.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class OnExceptionAspect : MethodLevelAspect,
    IOnExceptionAspect, IMethodLevelAspect, IAspect

Remarks

The OnMethodBoundaryAspect aspect adds an exception handler to the method to which it is applied. It allows you to easily encapsulate exception handling policies as a custom attribute.

The most important method is OnException(MethodExecutionArgs). It is the exception handler in itself.

The current exception is available from the Exception property of the MethodExecutionArgs> object. This property is read-only. If you need to replace the current exception by another one, you should throw a new exception from the handler. If you need to ignore the exception, set the FlowBehavior property to Continue.

An object of type MethodExecutionArgs is passed to every advice of this aspect. This object allows you to:

  • Get or set arguments. Input and output arguments are available on the property Arguments. You can change output (out) and by-reference (ref) arguments, but not input arguments. If you need to modify arguments passed by value, consider using a MethodInterceptionAspect. (see property );
  • Get the current exception. The current exception is available on property Exception, but from the OnException(MethodExecutionArgs) advice. You cannot replace the exception by setting this property. Throw a new exception from the aspect if you need to replace the current exception.
  • Get or set the return value. The return value is available on the ReturnValue property.
  • Change the method control flow. You can change the value of the FlowBehavior property to specify whether the target method should execute after the execution of the current advice. This may be useful to implement a caching aspect or an exception handler.
  • Share state between advices. You can use the MethodExecutionTag property to store state between the execution of different advices related to the same execution of a method. For instance, you can store a cache key in OnEntry(MethodExecutionArgs) and find it back on OnSuccess(MethodExecutionArgs). Using MethodExecutionTag is the only way to share state that is both thread-safe and reentrant. All other implementations are buggy.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Handling Exceptions

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.MethodLevelAspect
PostSharp.Aspects..::.OnExceptionAspect

See Also

OnExceptionAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfigurationAttribute
Conceptual Documentation: Aspect Serialization


OnExceptionAspect Members

[image]

PostSharp 2.0 Documentation
OnExceptionAspect Members
OnExceptionAspect Class Constructors Methods Properties See Also Send Feedback

The OnExceptionAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | OnExceptionAspect | Initializes a new instance of the OnExceptionAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | GetExceptionType | Gets the type of exception handled by this aspect.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Overloaded.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


OnExceptionAspect Constructor

OnExceptionAspect Constructor
OnExceptionAspect Class See Also Send Feedback
Initializes a new instance of the OnExceptionAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected OnExceptionAspect()

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


OnExceptionAspect Methods

[image]

PostSharp 2.0 Documentation
OnExceptionAspect Methods
OnExceptionAspect Class See Also Send Feedback

The OnExceptionAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | GetExceptionType | Gets the type of exception handled by this aspect.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Overloaded.

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

OnExceptionAspect..::..CreateAspectConfiguration Method
OnExceptionAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override sealed AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


GetExceptionType Method

OnExceptionAspect..::..GetExceptionType Method
OnExceptionAspect Class See Also Send Feedback
Gets the type of exception handled by this aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Type GetExceptionType(
    MethodBase targetMethod
)

Parameters

targetMethod
Type: System.Reflection..::.MethodBase
Method to which the current aspect is applied.

Return Value

The type (derived from Exception) of exceptions handled by this aspect.

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


OnException Method

OnExceptionAspect..::..OnException Method
OnExceptionAspect Class See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception (i.e., in a catch block).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnException(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Advice arguments.

Implements

IOnExceptionAspect..::.OnException(MethodExecutionArgs)

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


SetAspectConfiguration Method

[image]

PostSharp 2.0 Documentation
OnExceptionAspect..::..SetAspectConfiguration Method
OnExceptionAspect Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetAspectConfiguration(AspectConfiguration, Object) | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)
Protected method | SetAspectConfiguration(AspectConfiguration, MethodBase) | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Overrides MethodLevelAspectSetAspectConfiguration(AspectConfiguration, MethodBase).)

See Also

OnExceptionAspect Class
OnExceptionAspect Members
PostSharp.Aspects Namespace


SetAspectConfiguration Method (AspectConfiguration, MethodBase)

OnExceptionAspect..::..SetAspectConfiguration Method (AspectConfiguration, MethodBase)
OnExceptionAspect Class See Also Send Feedback
Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void SetAspectConfiguration(
    AspectConfiguration aspectConfiguration,
    MethodBase targetMethod
)

Parameters

aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
The AspectConfiguration instance previously returned by the CreateAspectConfiguration()()() method.
targetMethod
Type: System.Reflection..::.MethodBase
Method to which the current aspect has been applied.

Remarks

Classes overriding this method must always invoke the base implementation before performing their own changes to the AspectConfiguration.

See Also

OnExceptionAspect Class
SetAspectConfiguration Overload
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


OnExceptionAspect Properties

[image]

PostSharp 2.0 Documentation
OnExceptionAspect Properties
OnExceptionAspect Class See Also Send Feedback

The OnExceptionAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

OnExceptionAspect Class
PostSharp.Aspects Namespace


OnMethodBoundaryAspect Class

OnMethodBoundaryAspect Class
Members Example See Also Send Feedback
Aspect that, when applied to a method defined in the current assembly, inserts a piece of code before and after the body of these methods.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class OnMethodBoundaryAspect : MethodLevelAspect,
    IOnMethodBoundaryAspect, IMethodLevelAspect, IAspect

Remarks

The OnMethodBoundaryAspect aspect results in the target method to be wrapped into a try ... catch ... finally block. You can implement four advices: OnEntry(MethodExecutionArgs), executed at the beginning of the block; OnSuccess(MethodExecutionArgs), executed only when the method is successful (i.e. does not result in an exception); OnException(MethodExecutionArgs), invoked when the method results in an exception; and OnExit(MethodExecutionArgs), always executed after method execution (whether the method resulted in an exception or not).

Schematically, the aspect transforms the original method as follows:

CopyC#
int MyMethod(object arg0, int arg1)
{
  OnEntry();
  try
  {
    // Original method body.
    OnSuccess();
    return returnValue;
  }
  catch ( Exception e )
  {
    OnException();
  }
  finally
  {
    OnExit();
  }
}

Note that this code is only schematic; actually generated instructions are more complex because they have to cope with parameter boxing and control flow modification, among others.

An object of type MethodExecutionArgs is passed to every advice of this aspect. This object allows you to:

  • Get or set arguments. Input and output arguments are available on the property Arguments. You can change output (out) and by-reference (ref) arguments, but not input arguments. If you need to modify arguments passed by value, consider using a MethodInterceptionAspect. (see property );
  • Get the current exception. The current exception is available on property Exception, but from the OnException(MethodExecutionArgs) advice. You cannot replace the exception by setting this property. Throw a new exception from the aspect if you need to replace the current exception.
  • Get or set the return value. The return value is available on the ReturnValue property.
  • Change the method control flow. You can change the value of the FlowBehavior property to specify whether the target method should execute after the execution of the current advice. This may be useful to implement a caching aspect or an exception handler.
  • Share state between advices. You can use the MethodExecutionTag property to store state between the execution of different advices related to the same execution of a method. For instance, you can store a cache key in OnEntry(MethodExecutionArgs) and find it back on OnSuccess(MethodExecutionArgs). Using MethodExecutionTag is the only way to share state that is both thread-safe and reentrant. All other implementations are buggy.

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Examples

Example: Tracing Method Execution

Example: Caching the Result of a Method

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.MethodLevelAspect
PostSharp.Aspects..::.OnMethodBoundaryAspect

See Also

OnMethodBoundaryAspect Members
PostSharp.Aspects Namespace
Conceptual Documentation: Aspect Serialization


OnMethodBoundaryAspect Members

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspect Members
OnMethodBoundaryAspect Class Constructors Methods Properties See Also Send Feedback

The OnMethodBoundaryAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | OnMethodBoundaryAspect | Initializes a new instance of the OnMethodBoundaryAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnEntry | Method executed before the body of methods to which this aspect is applied.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.
Public method | OnExit | Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).
Public method | OnSuccess | Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnMethodBoundaryAspect Constructor

OnMethodBoundaryAspect Constructor
OnMethodBoundaryAspect Class See Also Send Feedback
Initializes a new instance of the OnMethodBoundaryAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected OnMethodBoundaryAspect()

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnMethodBoundaryAspect Methods

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspect Methods
OnMethodBoundaryAspect Class See Also Send Feedback

The OnMethodBoundaryAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method. (Inherited from MethodLevelAspect.)
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Overrides Aspect..::.CreateAspectConfiguration()()().)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | OnEntry | Method executed before the body of methods to which this aspect is applied.
Public method | OnException | Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.
Public method | OnExit | Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).
Public method | OnSuccess | Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).
Public method | RuntimeInitialize | Initializes the current aspect. (Inherited from MethodLevelAspect.)
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


CreateAspectConfiguration Method

OnMethodBoundaryAspect..::..CreateAspectConfiguration Method
OnMethodBoundaryAspect Class See Also Send Feedback
Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override sealed AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the Aspect.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration, Object) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Configuring Aspects


OnEntry Method

OnMethodBoundaryAspect..::..OnEntry Method
OnMethodBoundaryAspect Class See Also Send Feedback
Method executed before the body of methods to which this aspect is applied.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnEntry(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed, which are its arguments, and how should the execution continue after the execution of OnEntry(MethodExecutionArgs).

Implements

IOnMethodBoundaryAspect..::.OnEntry(MethodExecutionArgs)

Remarks

If the aspect is applied to a constructor, the current method is invoked after the this pointer has been initialized, that is, after the base constructor has been called.

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnException Method

OnMethodBoundaryAspect..::..OnException Method
OnMethodBoundaryAspect Class See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, in case that the method resulted with an exception.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnException(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

Implements

IOnMethodBoundaryAspect..::.OnException(MethodExecutionArgs)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnExit Method

OnMethodBoundaryAspect..::..OnExit Method
OnMethodBoundaryAspect Class See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, even when the method exists with an exception (this method is invoked from the finally block).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnExit(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

Implements

IOnMethodBoundaryAspect..::.OnExit(MethodExecutionArgs)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnSuccess Method

OnMethodBoundaryAspect..::..OnSuccess Method
OnMethodBoundaryAspect Class See Also Send Feedback
Method executed after the body of methods to which this aspect is applied, but only when the method successfully returns (i.e. when no exception flies out the method.).

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void OnSuccess(
    MethodExecutionArgs args
)

Parameters

args
Type: PostSharp.Aspects..::.MethodExecutionArgs
Event arguments specifying which method is being executed and which are its arguments.

Implements

IOnMethodBoundaryAspect..::.OnSuccess(MethodExecutionArgs)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


OnMethodBoundaryAspect Properties

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspect Properties
OnMethodBoundaryAspect Class See Also Send Feedback

The OnMethodBoundaryAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

OnMethodBoundaryAspect Class
PostSharp.Aspects Namespace


TypeIdentity Class

TypeIdentity Class
Members See Also Send Feedback
Wraps a Type or a type name.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class TypeIdentity

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects..::.TypeIdentity

See Also

TypeIdentity Members
PostSharp.Aspects Namespace


TypeIdentity Members

[image]

PostSharp 2.0 Documentation
TypeIdentity Members
TypeIdentity Class Methods Properties See Also Send Feedback

The TypeIdentity type exposes the following members.

Methods

 | Name | Description
 | FromType | Wraps a Type into a TypeIdentity.
 | FromTypeName | Wraps a type name into a TypeIdentity.
 | FromTypeNames | Wraps an array of type names into an array of TypeIdentity.
 | FromTypes | Wraps an array of Type into an array of TypeIdentity.
Public method | ToType | Converts a TypeIdentity into a Type.

Properties

 | Name | Description
Public property | Type | Gets the wrapped Type, or null it the TypeName property is set.
Public property | TypeName | Gets the wrapped type name, or null it the Type property is set.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


TypeIdentity Methods

[image]

PostSharp 2.0 Documentation
TypeIdentity Methods
TypeIdentity Class See Also Send Feedback

The TypeIdentity type exposes the following members.

Methods

 | Name | Description
 | FromType | Wraps a Type into a TypeIdentity.
 | FromTypeName | Wraps a type name into a TypeIdentity.
 | FromTypeNames | Wraps an array of type names into an array of TypeIdentity.
 | FromTypes | Wraps an array of Type into an array of TypeIdentity.
Public method | ToType | Converts a TypeIdentity into a Type.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


FromType Method

TypeIdentity..::..FromType Method
TypeIdentity Class See Also Send Feedback
Wraps a Type into a TypeIdentity.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeIdentity FromType(
    Type type
)

Parameters

type
Type: System..::.Type
A Type.

Return Value

A TypeIdentity wrapping .

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


FromTypeName Method

TypeIdentity..::..FromTypeName Method
TypeIdentity Class See Also Send Feedback
Wraps a type name into a TypeIdentity.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeIdentity FromTypeName(
    string typeName
)

Parameters

typeName
Type: System..::.String
The type name.

Return Value

A TypeIdentity wrapping the type name.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


FromTypeNames Method

TypeIdentity..::..FromTypeNames Method
TypeIdentity Class See Also Send Feedback
Wraps an array of type names into an array of TypeIdentity.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeIdentity[] FromTypeNames(
    string[] typeNames
)

Parameters

typeNames
Type: array< System..::.String >[]()[][]
An array of type names.

Return Value

An array of TypeIdentity wrapping typeNames.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


FromTypes Method

TypeIdentity..::..FromTypes Method
TypeIdentity Class See Also Send Feedback
Wraps an array of Type into an array of TypeIdentity.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeIdentity[] FromTypes(
    Type[] types
)

Parameters

types
Type: array< System..::.Type >[]()[][]
An array of Type.

Return Value

An array of TypeIdentity wrapping types.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


ToType Method

TypeIdentity..::..ToType Method
TypeIdentity Class See Also Send Feedback
Converts a TypeIdentity into a Type.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type ToType()

Return Value

[Missing <returns> documentation for "M:PostSharp.Aspects.TypeIdentity.ToType"]

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


TypeIdentity Properties

[image]

PostSharp 2.0 Documentation
TypeIdentity Properties
TypeIdentity Class See Also Send Feedback

The TypeIdentity type exposes the following members.

Properties

 | Name | Description
Public property | Type | Gets the wrapped Type, or null it the TypeName property is set.
Public property | TypeName | Gets the wrapped type name, or null it the Type property is set.

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


Type Property

TypeIdentity..::..Type Property
TypeIdentity Class See Also Send Feedback
Gets the wrapped Type, or null it the TypeName property is set.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type Type { get; }

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


TypeName Property

TypeIdentity..::..TypeName Property
TypeIdentity Class See Also Send Feedback
Gets the wrapped type name, or null it the Type property is set.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TypeName { get; }

See Also

TypeIdentity Class
PostSharp.Aspects Namespace


TypeLevelAspect Class

TypeLevelAspect Class
Members See Also Send Feedback
Base class for all aspects applied on types.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class TypeLevelAspect : Aspect,
    ITypeLevelAspect, IAspect, ITypeLevelAspectBuildSemantics, IAspectBuildSemantics, IValidableAnnotation

Remarks

Note
This class does not provide any advice. You may derive your aspect class from a class providing predefined advice , or build a composite aspect .

Note
All classes implementing IAspect should typically be marked as serializable using the custom attribute SerializableAttribute. Fields that are only used at runtime (and unknown at compile-time) should be carefully marked with the custom attribute NonSerializedAttribute. When PostSharp is used on a platform that does not support aspect serialization (such as .NET Compact Framework, Silverlight, or Windows Phone), or when another aspect serializer is used, it is not necessary to mark the aspect class as serializable. For more information, see Aspect Serialization .

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect
PostSharp.Aspects..::.TypeLevelAspect
PostSharp.Aspects..::.CompositionAspect
PostSharp.Aspects..::.InstanceLevelAspect

See Also

TypeLevelAspect Members
PostSharp.Aspects Namespace
PostSharp.Aspects..::.ITypeLevelAspect
Conceptual Documentation: Aspect Classes
Conceptual Documentation: Developing Complex Aspects
Conceptual Documentation: Aspect Serialization


TypeLevelAspect Members

[image]

PostSharp 2.0 Documentation
TypeLevelAspect Members
TypeLevelAspect Class Constructors Methods Properties See Also Send Feedback

The TypeLevelAspect type exposes the following members.

Constructors

 | Name | Description
Protected method | TypeLevelAspect | Initializes a new instance of the TypeLevelAspect class

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace


TypeLevelAspect Constructor

TypeLevelAspect Constructor
TypeLevelAspect Class See Also Send Feedback
Initializes a new instance of the TypeLevelAspect class

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected TypeLevelAspect()

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace


TypeLevelAspect Methods

[image]

PostSharp 2.0 Documentation
TypeLevelAspect Methods
TypeLevelAspect Class See Also Send Feedback

The TypeLevelAspect type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeInitialize | Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target. (Inherited from Aspect.)
Protected method | CreateAspectConfiguration | Method invoked at build time to create a concrete AspectConfiguration instance specifically for the current Aspect type. (Inherited from Aspect.)
Public method | GetAspectConfiguration | Method invoked at build tome to get the imperative configuration of the current Aspect. (Inherited from Aspect.)
Public method | RuntimeInitialize | Initializes the current aspect.
Protected method | SetAspectConfiguration | Method invoked at build time to set up an AspectConfiguration object according to the current Aspect instance and a specified target element of the current aspect. (Inherited from Aspect.)

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace


CompileTimeInitialize Method

TypeLevelAspect..::..CompileTimeInitialize Method
TypeLevelAspect Class See Also Send Feedback
Method invoked at build time to initialize the instance fields of the current aspect. This method is invoked before any other build-time method.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void CompileTimeInitialize(
    Type type,
    AspectInfo aspectInfo
)

Parameters

type
Type: System..::.Type
Type to which the current aspect is applied
aspectInfo
Type: PostSharp.Aspects..::.AspectInfo
Reserved for future usage.

Implements

ITypeLevelAspectBuildSemantics..::.CompileTimeInitialize(Type, AspectInfo)

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


RuntimeInitialize Method

TypeLevelAspect..::..RuntimeInitialize Method
TypeLevelAspect Class See Also Send Feedback
Initializes the current aspect.

Namespace: PostSharp.Aspects
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void RuntimeInitialize(
    Type type
)

Parameters

type
Type: System..::.Type
Type to which the current aspect is applied.

Implements

ITypeLevelAspect..::.RuntimeInitialize(Type)

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace
Conceptual Documentation: Initializing Aspects


TypeLevelAspect Properties

[image]

PostSharp 2.0 Documentation
TypeLevelAspect Properties
TypeLevelAspect Class See Also Send Feedback

The TypeLevelAspect type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from Aspect.)
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance. (Inherited from MulticastAttribute.)
Public property | AttributeInheritance | Determines whether this attribute is inherited (Inherited from MulticastAttribute.)
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before). (Inherited from MulticastAttribute.)
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations. (Inherited from MulticastAttribute.)
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply. (Inherited from MulticastAttribute.)
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies. (Inherited from MulticastAttribute.)
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies. (Inherited from MulticastAttribute.)
Protected property | SerializerType | Gets or sets the Type of the serializer (a type derived from AspectSerializer) used to serialize the aspect instance at build time and deserialize it at runtime. (Inherited from Aspect.)

See Also

TypeLevelAspect Class
PostSharp.Aspects Namespace


PostSharp.Aspects.Advices Namespace

PostSharp.Aspects.Advices Namespace
Send Feedback
The PostSharp.Aspects.Advices provides custom attributes that allow developing composite aspects with advices and pointcuts.

Classes

 | Class | Description
Public class | Advice | Base class for all custom attributes representing an advice.
Public class | CopyCustomAttributesAttribute | Custom attribute that, when applied on an aspect class, requires custom attributes present on the aspect class to be copied to the target of this class. When applied on an introduced member (see IntroduceMemberAttribute), this custom attribute requires custom attributes present on the aspect member to be copied to the introduced member.
Public class | Event<(Of <(TDelegate>)>) | Exposes the semantics of an event for use with the ImportMemberAttribute aspect extension.
Public class | GroupingAdvice | Base class for all advices that are possibly composed of multiple advices that can be grouped together using the Master property.
Public class | ImportMemberAttribute | Custom attribute that, when applied to an instance field of an aspect class, determines that this field should be bound to a method, event or property, of the target class of this aspect. Valid types for fields are a concrete Delegate (to bind to a method), Property<(Of <(TValue>)>) or Property<(Of <(TValue, TIndex>)>) (to bind to a property), or Event<(Of <(TDelegate>)>) (to bind to an event).
Public class | IntroduceInterfaceAttribute | Custom attribute that, when applied to an aspect class, specifies that the aspect should introduce a given interface into the type to which the aspect is applied.
Public class | IntroduceMemberAttribute | Custom attribute that, when applied on a method, event or property of an aspect class, specifies that this method, event or property should be introduced into the types to which the aspect is applied.
Public class | MethodPointcut | Custom attribute that, when applied on an advice method, specifies the name of the method that will be invoked at build-time to return the set of elements of code to which the advice applies.
Public class | MulticastPointcut | Custom attribute that, when applied on an advice method, specifies to which elements of code this advice applies, based on the kind, name and attributes of code elements. Works similarly as MulticastAttribute.
Public class | OnEventAddHandlerAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnAddHandler(EventInterceptionArgs).
Public class | OnEventInvokeHandlerAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnInvokeHandler(EventInterceptionArgs).
Public class | OnEventRemoveHandlerAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnRemoveHandler(EventInterceptionArgs).
Public class | OnLocationGetValueAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnGetValue(LocationInterceptionArgs).
Public class | OnLocationSetValueAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnSetValue(LocationInterceptionArgs).
Public class | OnMethodEntryAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnEntry(MethodExecutionArgs).
Public class | OnMethodExceptionAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnException(MethodExecutionArgs).
Public class | OnMethodExitAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnExit(MethodExecutionArgs).
Public class | OnMethodInvokeAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnInvoke(MethodInterceptionArgs).
Public class | OnMethodSuccessAdvice | Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnSuccess(MethodExecutionArgs).
Public class | Pointcut | Custom attribute, typically accompanying an advice, specifying to which code elements the advice applies.
Public class | Property<(Of <(TValue>)>) | Exposes the semantics of a parameterless property for use with the ImportMemberAttribute aspect extension.
Public class | Property<(Of <(TValue, TIndex>)>) | Mimics the semantics of a property accepting a single index parameter, for use with the ImportMemberAttribute aspect extension.
Public class | SelfPointcut | Pointcut that selects exactly the aspect target.

Delegates

 | Delegate | Description
Public delegate | EventAccessor<(Of <(TDelegate>)>) | Defines the signature of methods implementing the Add and Remove semantics of an event.
Public delegate | PropertyGetter<(Of <(TValue>)>) | Defines the signature of methods implementing the Get semantic of a parameterless property.
Public delegate | PropertyGetter<(Of <(TValue, TIndex>)>) | Defines the signature of methods implementing the Get semantic of a property with a single index parameter.
Public delegate | PropertySetter<(Of <(TValue>)>) | Defines the signature of methods implementing the Set semantic of a parameterless property.
Public delegate | PropertySetter<(Of <(TValue, TIndex>)>) | Defines the signature of methods implementing the Set semantic of a property with a single index parameter.

Enumerations

 | Enumeration | Description
Public enumeration | CustomAttributeOverrideAction | Behavior of CopyCustomAttributesAttribute when a custom attribute of the same type already exists on the target declaration.
Public enumeration | ImportMemberOrder | Enumeration of moments when members should be imported into an aspect.
Public enumeration | InterfaceOverrideAction | Enumeration of actions to be overtaken when an interface that should be introduced into a type is already implemented by that type.
Public enumeration | MemberOverrideAction | Enumeration of actions to be overtaken by the IntroduceMemberAttribute aspect extension when the member to be introduced already exists in the aspect target type or its base type.


Advice Class

Advice Class
Members See Also Send Feedback
Base class for all custom attributes representing an advice.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Advice : Attribute

Remarks

Advices are behaviors added to aspects by the way of custom attributes. Other ways to add behaviors is to implement interface methods.

Advice custom attributes are typically used on aspect classes, or on members of aspect classes.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.CopyCustomAttributesAttribute
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.ImportMemberAttribute
PostSharp.Aspects.Advices..::.IntroduceInterfaceAttribute
PostSharp.Aspects.Advices..::.IntroduceMemberAttribute
PostSharp.Aspects.Advices..::.OnMethodInvokeAdvice

See Also

Advice Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Developing Complex Aspects


Advice Members

[image]

PostSharp 2.0 Documentation
Advice Members
Advice Class Constructors See Also Send Feedback

The Advice type exposes the following members.

Constructors

 | Name | Description
Protected method | Advice | Initializes a new instance of the Advice class

See Also

Advice Class
PostSharp.Aspects.Advices Namespace


Advice Constructor

Advice Constructor
Advice Class See Also Send Feedback
Initializes a new instance of the Advice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Advice()

See Also

Advice Class
PostSharp.Aspects.Advices Namespace


CopyCustomAttributesAttribute Class

CopyCustomAttributesAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on an aspect class, requires custom attributes present on the aspect class to be copied to the target of this class. When applied on an introduced member (see IntroduceMemberAttribute), this custom attribute requires custom attributes present on the aspect member to be copied to the introduced member.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CopyCustomAttributesAttribute : Advice

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.CopyCustomAttributesAttribute

See Also

CopyCustomAttributesAttribute Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.IntroduceMemberAttribute
Conceptual Documentation: Introducing, Overriding and Importing Members


CopyCustomAttributesAttribute Members

[image]

PostSharp 2.0 Documentation
CopyCustomAttributesAttribute Members
CopyCustomAttributesAttribute Class Constructors Properties See Also Send Feedback

The CopyCustomAttributesAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CopyCustomAttributesAttribute | Overloaded.

Properties

 | Name | Description
Public property | OverrideAction | Determines what should happen when a custom attribute of the same type is already present on the target declaration.
Public property | Types | Gets the list of custom attribute types to be copied.

See Also

CopyCustomAttributesAttribute Class
PostSharp.Aspects.Advices Namespace


CopyCustomAttributesAttribute Constructor

[image]

PostSharp 2.0 Documentation
CopyCustomAttributesAttribute Constructor
CopyCustomAttributesAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyCustomAttributesAttribute(Type) | Requires custom attributes present on the aspect class or aspect class member to be copied to the aspect target or to the introduced member, respectively.
Public method | CopyCustomAttributesAttribute(array<Type>[]()[]) | Requires custom attributes present on the aspect class or aspect class member to be copied to the aspect target or to the introduced member, respectively.

See Also

CopyCustomAttributesAttribute Class
CopyCustomAttributesAttribute Members
PostSharp.Aspects.Advices Namespace


CopyCustomAttributesAttribute Constructor (Type)

CopyCustomAttributesAttribute Constructor (Type)
CopyCustomAttributesAttribute Class See Also Send Feedback
Requires custom attributes present on the aspect class or aspect class member to be copied to the aspect target or to the introduced member, respectively.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CopyCustomAttributesAttribute(
    Type type
)

Parameters

type
Type: System..::.Type
Base type of custom attributes to be copied.

See Also

CopyCustomAttributesAttribute Class
CopyCustomAttributesAttribute Overload
PostSharp.Aspects.Advices Namespace


CopyCustomAttributesAttribute Constructor (Type[])

CopyCustomAttributesAttribute Constructor (array<Type>[]()[][])
CopyCustomAttributesAttribute Class See Also Send Feedback
Requires custom attributes present on the aspect class or aspect class member to be copied to the aspect target or to the introduced member, respectively.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CopyCustomAttributesAttribute(
    params Type[] types
)

Parameters

types
Type: array< System..::.Type >[]()[][]
Base types of custom attributes to be copied.

See Also

CopyCustomAttributesAttribute Class
CopyCustomAttributesAttribute Overload
PostSharp.Aspects.Advices Namespace


CopyCustomAttributesAttribute Properties

[image]

PostSharp 2.0 Documentation
CopyCustomAttributesAttribute Properties
CopyCustomAttributesAttribute Class See Also Send Feedback

The CopyCustomAttributesAttribute type exposes the following members.

Properties

 | Name | Description
Public property | OverrideAction | Determines what should happen when a custom attribute of the same type is already present on the target declaration.
Public property | Types | Gets the list of custom attribute types to be copied.

See Also

CopyCustomAttributesAttribute Class
PostSharp.Aspects.Advices Namespace


OverrideAction Property

CopyCustomAttributesAttribute..::..OverrideAction Property
CopyCustomAttributesAttribute Class See Also Send Feedback
Determines what should happen when a custom attribute of the same type is already present on the target declaration.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeOverrideAction OverrideAction { get; set; }

See Also

CopyCustomAttributesAttribute Class
PostSharp.Aspects.Advices Namespace


Types Property

CopyCustomAttributesAttribute..::..Types Property
CopyCustomAttributesAttribute Class See Also Send Feedback
Gets the list of custom attribute types to be copied.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type[] Types { get; private set; }

See Also

CopyCustomAttributesAttribute Class
PostSharp.Aspects.Advices Namespace


CustomAttributeOverrideAction Enumeration

CustomAttributeOverrideAction Enumeration
See Also Send Feedback
Behavior of CopyCustomAttributesAttribute when a custom attribute of the same type already exists on the target declaration.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum CustomAttributeOverrideAction

Members

Member name | Value | Description
Default | 0 | Default (Fail).
Fail | 0 | Emits an error message.
Ignore | 1 | Silently ignore this custom attribute (does not copy it, without error message).
Add | 2 | Adds a new copy (possibly duplicate) of the custom attribute.
MergeAddProperty | 3 | Merges the existing custom attribute with the template custom attribute by adding properties and fields. If the existing custom attribute defines the same properties and fields as the template custom attribute, they are not overridden.
MergeReplaceProperty | 4 | Merges the exising custom attribute with the template custom attribute by adding and replacing properties and fields. If the existing custom attribute defines the same properties and fields as the template custom attribute, they are replaced by the values defined in the template custom attribute.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.CopyCustomAttributesAttribute


Event(TDelegate) Class

Event<(Of <(<'TDelegate>)>)> Class
Members See Also Send Feedback
Exposes the semantics of an event for use with the ImportMemberAttribute aspect extension.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Event<TDelegate>

Type Parameters

TDelegate
Handler type (derived from Delegate).

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Advices..::.Event<(Of <(TDelegate>)>)

See Also

Event<(Of <(TDelegate>)>) Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.ImportMemberAttribute
Conceptual Documentation: Introducing, Overriding and Importing Members


Event(TDelegate) Members

[image]

PostSharp 2.0 Documentation
Event<(Of <(<'TDelegate>)>)> Members
Event<(Of <(TDelegate>)>) Class Properties See Also Send Feedback

The Event<(Of <(TDelegate>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Add | Gets a delegate enabling to invoke the add accessor of the imported event.
Public property | Remove | Gets a delegate enabling to invoke the remove accessor of the imported event.

See Also

Event<(Of <(TDelegate>)>) Class
PostSharp.Aspects.Advices Namespace


Event(TDelegate) Properties

[image]

PostSharp 2.0 Documentation
Event<(Of <(<'TDelegate>)>)> Properties
Event<(Of <(TDelegate>)>) Class See Also Send Feedback

The Event<(Of <(TDelegate>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Add | Gets a delegate enabling to invoke the add accessor of the imported event.
Public property | Remove | Gets a delegate enabling to invoke the remove accessor of the imported event.

See Also

Event<(Of <(TDelegate>)>) Class
PostSharp.Aspects.Advices Namespace


Add Property

Event<(Of <(<'TDelegate>)>)>..::..Add Property
Event<(Of <(TDelegate>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the add accessor of the imported event.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventAccessor<TDelegate> Add { get; private set; }

See Also

Event<(Of <(TDelegate>)>) Class
PostSharp.Aspects.Advices Namespace


Remove Property

Event<(Of <(<'TDelegate>)>)>..::..Remove Property
Event<(Of <(TDelegate>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the remove accessor of the imported event.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventAccessor<TDelegate> Remove { get; private set; }

See Also

Event<(Of <(TDelegate>)>) Class
PostSharp.Aspects.Advices Namespace


EventAccessor(TDelegate) Delegate

EventAccessor<(Of <(<'TDelegate>)>)> Delegate
See Also Send Feedback
Defines the signature of methods implementing the Add and Remove semantics of an event.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate void EventAccessor<TDelegate>(
    TDelegate delegate
)

Parameters

delegate
Type: TDelegate
Handler.

Type Parameters

TDelegate
Handler type (derived from Delegate).

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Event<(Of <(TDelegate>)>)


GroupingAdvice Class

GroupingAdvice Class
Members See Also Send Feedback
Base class for all advices that are possibly composed of multiple advices that can be grouped together using the Master property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class GroupingAdvice : Advice

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventRemoveHandlerAdvice
PostSharp.Aspects.Advices..::.OnLocationGetValueAdvice
PostSharp.Aspects.Advices..::.OnLocationSetValueAdvice
PostSharp.Aspects.Advices..::.OnMethodEntryAdvice
PostSharp.Aspects.Advices..::.OnMethodExceptionAdvice
PostSharp.Aspects.Advices..::.OnMethodExitAdvice
PostSharp.Aspects.Advices..::.OnMethodSuccessAdvice

See Also

GroupingAdvice Members
PostSharp.Aspects.Advices Namespace


GroupingAdvice Members

[image]

PostSharp 2.0 Documentation
GroupingAdvice Members
GroupingAdvice Class Constructors Properties See Also Send Feedback

The GroupingAdvice type exposes the following members.

Constructors

 | Name | Description
Protected method | GroupingAdvice | Initializes a new instance of the GroupingAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute).

See Also

GroupingAdvice Class
PostSharp.Aspects.Advices Namespace


GroupingAdvice Constructor

GroupingAdvice Constructor
GroupingAdvice Class See Also Send Feedback
Initializes a new instance of the GroupingAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected GroupingAdvice()

See Also

GroupingAdvice Class
PostSharp.Aspects.Advices Namespace


GroupingAdvice Properties

[image]

PostSharp 2.0 Documentation
GroupingAdvice Properties
GroupingAdvice Class See Also Send Feedback

The GroupingAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute).

See Also

GroupingAdvice Class
PostSharp.Aspects.Advices Namespace


Master Property

GroupingAdvice..::..Master Property
GroupingAdvice Class See Also Send Feedback
Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Master { get; set; }

See Also

GroupingAdvice Class
PostSharp.Aspects.Advices Namespace


ImportMemberAttribute Class

ImportMemberAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied to an instance field of an aspect class, determines that this field should be bound to a method, event or property, of the target class of this aspect. Valid types for fields are a concrete Delegate (to bind to a method), Property<(Of <(TValue>)>) or Property<(Of <(TValue, TIndex>)>) (to bind to a property), or Event<(Of <(TDelegate>)>) (to bind to an event).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ImportMemberAttribute : Advice

Remarks

Fields annotated with the ImportMemberAttribute custom attribute must be public and must not be read only.

At runtime, these fields are assigned to a delegate (in case of method binding) or a pair of delegates (in case of event or property binding) allowing to invoke the imported member.

When the target type does not contain a member of the required name and signature

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.ImportMemberAttribute

See Also

ImportMemberAttribute Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Introducing, Overriding and Importing Members


ImportMemberAttribute Members

[image]

PostSharp 2.0 Documentation
ImportMemberAttribute Members
ImportMemberAttribute Class Constructors Properties See Also Send Feedback

The ImportMemberAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ImportMemberAttribute | Initializes a new ImportMemberAttribute.

Properties

 | Name | Description
Public property | IsRequired | Determines whether a build time error must be issued if the member to be imported is absent. If false, the binding field will be null in case the imported member is absent.
Public property | MemberName | Name of the imported member.
Public property | Order | Determines when the member should be imported: either before (BeforeIntroductions) or after (AfterIntroductions) members have been introduced by the current aspect. Default is BeforeIntroductions.

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


ImportMemberAttribute Constructor

ImportMemberAttribute Constructor
ImportMemberAttribute Class See Also Send Feedback
Initializes a new ImportMemberAttribute.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImportMemberAttribute(
    string memberName
)

Parameters

memberName
Type: System..::.String
Name of the member to import.

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


ImportMemberAttribute Properties

[image]

PostSharp 2.0 Documentation
ImportMemberAttribute Properties
ImportMemberAttribute Class See Also Send Feedback

The ImportMemberAttribute type exposes the following members.

Properties

 | Name | Description
Public property | IsRequired | Determines whether a build time error must be issued if the member to be imported is absent. If false, the binding field will be null in case the imported member is absent.
Public property | MemberName | Name of the imported member.
Public property | Order | Determines when the member should be imported: either before (BeforeIntroductions) or after (AfterIntroductions) members have been introduced by the current aspect. Default is BeforeIntroductions.

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


IsRequired Property

ImportMemberAttribute..::..IsRequired Property
ImportMemberAttribute Class See Also Send Feedback
Determines whether a build time error must be issued if the member to be imported is absent. If false, the binding field will be null in case the imported member is absent.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsRequired { get; set; }

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


MemberName Property

ImportMemberAttribute..::..MemberName Property
ImportMemberAttribute Class See Also Send Feedback
Name of the imported member.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MemberName { get; private set; }

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


Order Property

ImportMemberAttribute..::..Order Property
ImportMemberAttribute Class See Also Send Feedback
Determines when the member should be imported: either before (BeforeIntroductions) or after (AfterIntroductions) members have been introduced by the current aspect. Default is BeforeIntroductions.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImportMemberOrder Order { get; set; }

Remarks

Sometimes it makes sense for an aspect to import a member after the same aspect has introduced member. This allows the aspect to invoke a member that could be overridden by later aspects.

See Also

ImportMemberAttribute Class
PostSharp.Aspects.Advices Namespace


ImportMemberOrder Enumeration

ImportMemberOrder Enumeration
See Also Send Feedback
Enumeration of moments when members should be imported into an aspect.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum ImportMemberOrder

Members

Member name | Value | Description
Default | 0 | AfterIntroductions
BeforeIntroductions | 1 | Before the aspect introduces its own members. This is similar to calling the overridden method using the base keyword in C#. The overridden method implementation is always selected, even if the method is virtual.
AfterIntroductions | 0 | After the aspect introduces its own members. Note that importing a member introduced by the current aspect makes sense only if the member has been introduced as virtual; in this case, the the imported member is dynamically resolved using the virtual table of the target object.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.ImportMemberAttribute


InterfaceOverrideAction Enumeration

InterfaceOverrideAction Enumeration
See Also Send Feedback
Enumeration of actions to be overtaken when an interface that should be introduced into a type is already implemented by that type.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum InterfaceOverrideAction

Members

Member name | Value | Description
Default | 0 | Fail.
Fail | 0 | Fails and emits an error message.
Ignore | 1 | Silently ignore this interface (does not introduct it).

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.IntroduceInterfaceAttribute


IntroduceInterfaceAttribute Class

IntroduceInterfaceAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied to an aspect class, specifies that the aspect should introduce a given interface into the type to which the aspect is applied.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IntroduceInterfaceAttribute : Advice

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.IntroduceInterfaceAttribute

See Also

IntroduceInterfaceAttribute Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Introducing Interfaces


IntroduceInterfaceAttribute Members

[image]

PostSharp 2.0 Documentation
IntroduceInterfaceAttribute Members
IntroduceInterfaceAttribute Class Constructors Properties See Also Send Feedback

The IntroduceInterfaceAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | IntroduceInterfaceAttribute | Initializes a new IntroduceInterfaceAttribute.

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.
Public property | IsProtected | Determines whether the interface should be exposed indirectly through the IProtectedInterface<(Of <(T>)>) interface. If false, the interface will be implemented directly by the type.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace


IntroduceInterfaceAttribute Constructor

IntroduceInterfaceAttribute Constructor
IntroduceInterfaceAttribute Class See Also Send Feedback
Initializes a new IntroduceInterfaceAttribute.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntroduceInterfaceAttribute(
    Type interfaceType
)

Parameters

interfaceType
Type: System..::.Type
Interface that should be introduced into the types to which the aspect is applied.

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace


IntroduceInterfaceAttribute Properties

[image]

PostSharp 2.0 Documentation
IntroduceInterfaceAttribute Properties
IntroduceInterfaceAttribute Class See Also Send Feedback

The IntroduceInterfaceAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.
Public property | IsProtected | Determines whether the interface should be exposed indirectly through the IProtectedInterface<(Of <(T>)>) interface. If false, the interface will be implemented directly by the type.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace


AncestorOverrideAction Property

IntroduceInterfaceAttribute..::..AncestorOverrideAction Property
IntroduceInterfaceAttribute Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when an ancestor of the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceOverrideAction AncestorOverrideAction { get; set; }

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace
IntroduceInterfaceAttribute..::.OverrideAction


IsProtected Property

IntroduceInterfaceAttribute..::..IsProtected Property
IntroduceInterfaceAttribute Class See Also Send Feedback
Determines whether the interface should be exposed indirectly through the IProtectedInterface<(Of <(T>)>) interface. If false, the interface will be implemented directly by the type.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsProtected { get; set; }

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace


OverrideAction Property

IntroduceInterfaceAttribute..::..OverrideAction Property
IntroduceInterfaceAttribute Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when the interface specified in the constructor of this custom attribute is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceOverrideAction OverrideAction { get; set; }

See Also

IntroduceInterfaceAttribute Class
PostSharp.Aspects.Advices Namespace
IntroduceInterfaceAttribute..::.AncestorOverrideAction


IntroduceMemberAttribute Class

IntroduceMemberAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a method, event or property of an aspect class, specifies that this method, event or property should be introduced into the types to which the aspect is applied.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IntroduceMemberAttribute : Advice

Remarks

Methods, properties and events annotated with IntroduceMemberAttribute must be public.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.IntroduceMemberAttribute

See Also

IntroduceMemberAttribute Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.CopyCustomAttributesAttribute
Conceptual Documentation: Introducing, Overriding and Importing Members


IntroduceMemberAttribute Members

[image]

PostSharp 2.0 Documentation
IntroduceMemberAttribute Members
IntroduceMemberAttribute Class Constructors Properties See Also Send Feedback

The IntroduceMemberAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | IntroduceMemberAttribute | Initializes a new instance of the IntroduceMemberAttribute class

Properties

 | Name | Description
Public property | IsIsVirtualSpecified | Determines whether the IsVirtual property has been specified.
Public property | IsVirtual | Determines whether the introduced member should be virtual.
Public property | OverrideAction | Determines the action to be overtaken when the member to be introduced already exists in the type to which the aspect is applied, or to a base type.
Public property | Visibility | Determines the visibility (Public, (Family, ...) of the introduced member.

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


IntroduceMemberAttribute Constructor

IntroduceMemberAttribute Constructor
IntroduceMemberAttribute Class See Also Send Feedback
Initializes a new instance of the IntroduceMemberAttribute class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntroduceMemberAttribute()

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


IntroduceMemberAttribute Properties

[image]

PostSharp 2.0 Documentation
IntroduceMemberAttribute Properties
IntroduceMemberAttribute Class See Also Send Feedback

The IntroduceMemberAttribute type exposes the following members.

Properties

 | Name | Description
Public property | IsIsVirtualSpecified | Determines whether the IsVirtual property has been specified.
Public property | IsVirtual | Determines whether the introduced member should be virtual.
Public property | OverrideAction | Determines the action to be overtaken when the member to be introduced already exists in the type to which the aspect is applied, or to a base type.
Public property | Visibility | Determines the visibility (Public, (Family, ...) of the introduced member.

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


IsIsVirtualSpecified Property

IntroduceMemberAttribute..::..IsIsVirtualSpecified Property
IntroduceMemberAttribute Class See Also Send Feedback
Determines whether the IsVirtual property has been specified.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsIsVirtualSpecified { get; }

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


IsVirtual Property

IntroduceMemberAttribute..::..IsVirtual Property
IntroduceMemberAttribute Class See Also Send Feedback
Determines whether the introduced member should be virtual.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsVirtual { get; set; }

Remarks

When this property is false and the member already exists in a base type and is virtual, the member is overridden and marked as sealed.

When this property is not set, the introduced member is virtual if it exists in a base type as a virtual member, otherwise non-virtual.

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


OverrideAction Property

IntroduceMemberAttribute..::..OverrideAction Property
IntroduceMemberAttribute Class See Also Send Feedback
Determines the action to be overtaken when the member to be introduced already exists in the type to which the aspect is applied, or to a base type.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberOverrideAction OverrideAction { get; set; }

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


Visibility Property

IntroduceMemberAttribute..::..Visibility Property
IntroduceMemberAttribute Class See Also Send Feedback
Determines the visibility (Public, (Family, ...) of the introduced member.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; set; }

See Also

IntroduceMemberAttribute Class
PostSharp.Aspects.Advices Namespace


MemberOverrideAction Enumeration

MemberOverrideAction Enumeration
See Also Send Feedback
Enumeration of actions to be overtaken by the IntroduceMemberAttribute aspect extension when the member to be introduced already exists in the aspect target type or its base type.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum MemberOverrideAction

Members

Member name | Value | Description
Default | 0 | Fail
Fail | 0 | Emits a build time error.
Ignore | 1 | Silently ignore the member introduction.
OverrideOrFail | 2 | Tries to override the member, and fails if it is impossible (i.e. if the existing member is defined in a base type and is sealed or non-virtual).
OverrideOrIgnore | 3 | Tries to override the member, and silently ignore if it is impossible (i.e. if the existing member is defined in a base type and is sealed or non-virtual).

See Also

PostSharp.Aspects.Advices Namespace


MethodPointcut Class

MethodPointcut Class
Members See Also Send Feedback
Custom attribute that, when applied on an advice method, specifies the name of the method that will be invoked at build-time to return the set of elements of code to which the advice applies.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodPointcut : Pointcut

Remarks

This method should have the signature IEnumerable<AdviceTargetType> SelectCodeElements(AspectTargetType target) , where AspectTargetType is either object either a reflection type corresponding to the kind of targets of the aspect (for instance System.Type for a type-level aspect), and AdviceTargetType is either object either a reflection type of the kind of targets of the advice (for instance System.MethodInfo for a method-level advice).

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Pointcut
PostSharp.Aspects.Advices..::.MethodPointcut

See Also

MethodPointcut Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Adding Behaviors to Members


MethodPointcut Members

[image]

PostSharp 2.0 Documentation
MethodPointcut Members
MethodPointcut Class Constructors Properties See Also Send Feedback

The MethodPointcut type exposes the following members.

Constructors

 | Name | Description
Public method | MethodPointcut | Initializes a new MethodPointcut.

Properties

 | Name | Description
Public property | MethodName | Gets the name of the method returning the set of code elements.

See Also

MethodPointcut Class
PostSharp.Aspects.Advices Namespace


MethodPointcut Constructor

MethodPointcut Constructor
MethodPointcut Class See Also Send Feedback
Initializes a new MethodPointcut.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodPointcut(
    string methodName
)

Parameters

methodName
Type: System..::.String
Name of the method returning the set of targets. This method should have a specific signature as discussed in the class documentation.

See Also

MethodPointcut Class
PostSharp.Aspects.Advices Namespace


MethodPointcut Properties

[image]

PostSharp 2.0 Documentation
MethodPointcut Properties
MethodPointcut Class See Also Send Feedback

The MethodPointcut type exposes the following members.

Properties

 | Name | Description
Public property | MethodName | Gets the name of the method returning the set of code elements.

See Also

MethodPointcut Class
PostSharp.Aspects.Advices Namespace


MethodName Property

MethodPointcut..::..MethodName Property
MethodPointcut Class See Also Send Feedback
Gets the name of the method returning the set of code elements.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MethodName { get; private set; }

See Also

MethodPointcut Class
PostSharp.Aspects.Advices Namespace


MulticastPointcut Class

MulticastPointcut Class
Members See Also Send Feedback
Custom attribute that, when applied on an advice method, specifies to which elements of code this advice applies, based on the kind, name and attributes of code elements. Works similarly as MulticastAttribute.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MulticastPointcut : Pointcut

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Pointcut
PostSharp.Aspects.Advices..::.MulticastPointcut

See Also

MulticastPointcut Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Adding Behaviors to Members


MulticastPointcut Members

[image]

PostSharp 2.0 Documentation
MulticastPointcut Members
MulticastPointcut Class Constructors Properties See Also Send Feedback

The MulticastPointcut type exposes the following members.

Constructors

 | Name | Description
Public method | MulticastPointcut | Initializes a new instance of the MulticastPointcut class

Properties

 | Name | Description
Public property | Attributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.
Public property | MemberName | Gets or sets the expression specifying to which members the aspect extension applies.
Public property | Targets | Gets or sets the kind of elements to which this aspect extension applies.

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


MulticastPointcut Constructor

MulticastPointcut Constructor
MulticastPointcut Class See Also Send Feedback
Initializes a new instance of the MulticastPointcut class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastPointcut()

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


MulticastPointcut Properties

[image]

PostSharp 2.0 Documentation
MulticastPointcut Properties
MulticastPointcut Class See Also Send Feedback

The MulticastPointcut type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.
Public property | MemberName | Gets or sets the expression specifying to which members the aspect extension applies.
Public property | Targets | Gets or sets the kind of elements to which this aspect extension applies.

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


Attributes Property

MulticastPointcut..::..Attributes Property
MulticastPointcut Class See Also Send Feedback
Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes Attributes { get; set; }

Remarks

The MulticastAttributes enumeration is a multi-part flag: there is one part for visibility, one for scope, one for virtuality, and one for implementation. If you specify one part, it will override the values defined on the custom attribute definition.

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


MemberName Property

MulticastPointcut..::..MemberName Property
MulticastPointcut Class See Also Send Feedback
Gets or sets the expression specifying to which members the aspect extension applies.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MemberName { get; set; }

Field Value

A wildcard or regular expression specifying to which members this instance applies, or null this instance applies either to all members whose kind is given in Targets. Regular expressions should start with the regex: prefix.

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


Targets Property

MulticastPointcut..::..Targets Property
MulticastPointcut Class See Also Send Feedback
Gets or sets the kind of elements to which this aspect extension applies.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastTargets Targets { get; set; }

See Also

MulticastPointcut Class
PostSharp.Aspects.Advices Namespace


OnEventAddHandlerAdvice Class

OnEventAddHandlerAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnAddHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnEventAddHandlerAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnAddHandler(EventInterceptionArgs). However, it can be static.

If an aspect defines many advices (among OnEventAddHandlerAdvice, OnEventRemoveHandlerAdvice and OnEventInvokeHandlerAdvice) that are meant to be applied to the same events with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice

See Also

OnEventAddHandlerAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.IEventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
PostSharp.Aspects..::.EventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventRemoveHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
Conceptual Documentation: Adding Behaviors to Members


OnEventAddHandlerAdvice Members

[image]

PostSharp 2.0 Documentation
OnEventAddHandlerAdvice Members
OnEventAddHandlerAdvice Class Constructors Properties See Also Send Feedback

The OnEventAddHandlerAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnEventAddHandlerAdvice | Initializes a new instance of the OnEventAddHandlerAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventAddHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventAddHandlerAdvice Constructor

OnEventAddHandlerAdvice Constructor
OnEventAddHandlerAdvice Class See Also Send Feedback
Initializes a new instance of the OnEventAddHandlerAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnEventAddHandlerAdvice()

See Also

OnEventAddHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventAddHandlerAdvice Properties

[image]

PostSharp 2.0 Documentation
OnEventAddHandlerAdvice Properties
OnEventAddHandlerAdvice Class See Also Send Feedback

The OnEventAddHandlerAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventAddHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventInvokeHandlerAdvice Class

OnEventInvokeHandlerAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnInvokeHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnEventInvokeHandlerAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnInvokeHandler(EventInterceptionArgs). However, it can be static.

If an aspect defines many advices (among OnEventAddHandlerAdvice, OnEventRemoveHandlerAdvice and OnEventInvokeHandlerAdvice) that are meant to be applied to the same events with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice

See Also

OnEventInvokeHandlerAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.IEventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
PostSharp.Aspects..::.EventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventRemoveHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
Conceptual Documentation: Adding Behaviors to Members


OnEventInvokeHandlerAdvice Members

[image]

PostSharp 2.0 Documentation
OnEventInvokeHandlerAdvice Members
OnEventInvokeHandlerAdvice Class Constructors Properties See Also Send Feedback

The OnEventInvokeHandlerAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnEventInvokeHandlerAdvice | Initializes a new instance of the OnEventInvokeHandlerAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventInvokeHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventInvokeHandlerAdvice Constructor

OnEventInvokeHandlerAdvice Constructor
OnEventInvokeHandlerAdvice Class See Also Send Feedback
Initializes a new instance of the OnEventInvokeHandlerAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnEventInvokeHandlerAdvice()

See Also

OnEventInvokeHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventInvokeHandlerAdvice Properties

[image]

PostSharp 2.0 Documentation
OnEventInvokeHandlerAdvice Properties
OnEventInvokeHandlerAdvice Class See Also Send Feedback

The OnEventInvokeHandlerAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventInvokeHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventRemoveHandlerAdvice Class

OnEventRemoveHandlerAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnRemoveHandler(EventInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnEventRemoveHandlerAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnRemoveHandler(EventInterceptionArgs). However, it can be static.

If an aspect defines many advices (among OnEventAddHandlerAdvice, OnEventRemoveHandlerAdvice and OnEventInvokeHandlerAdvice) that are meant to be applied to the same events with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Note
Because of the way how the C# compiler implements automatic events (i.e. events where you don't implement the Add and Remove semantics manually), the Invoke Event Handler semantic (OnInvokeHandler(EventInterceptionArgs) or equivalent) shall not be invoked for delegates that have been added from inside the class that declares this event.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnEventRemoveHandlerAdvice

See Also

OnEventRemoveHandlerAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.IEventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
PostSharp.Aspects..::.EventInterceptionAspect
PostSharp.Aspects.Advices..::.OnEventAddHandlerAdvice
PostSharp.Aspects.Advices..::.OnEventInvokeHandlerAdvice
Conceptual Documentation: Adding Behaviors to Members


OnEventRemoveHandlerAdvice Members

[image]

PostSharp 2.0 Documentation
OnEventRemoveHandlerAdvice Members
OnEventRemoveHandlerAdvice Class Constructors Properties See Also Send Feedback

The OnEventRemoveHandlerAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnEventRemoveHandlerAdvice | Initializes a new instance of the OnEventRemoveHandlerAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventRemoveHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventRemoveHandlerAdvice Constructor

OnEventRemoveHandlerAdvice Constructor
OnEventRemoveHandlerAdvice Class See Also Send Feedback
Initializes a new instance of the OnEventRemoveHandlerAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnEventRemoveHandlerAdvice()

See Also

OnEventRemoveHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnEventRemoveHandlerAdvice Properties

[image]

PostSharp 2.0 Documentation
OnEventRemoveHandlerAdvice Properties
OnEventRemoveHandlerAdvice Class See Also Send Feedback

The OnEventRemoveHandlerAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnEventRemoveHandlerAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationGetValueAdvice Class

OnLocationGetValueAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnGetValue(LocationInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnLocationGetValueAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnGetValue(LocationInterceptionArgs). However, it can be static.

If an aspect defines many advices (among OnLocationSetValueAdvice, OnLocationGetValueAdvice) and if these advices are meant to be applied to the same properties with consistent ordering, they should be grouped together (see Master property).

Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnLocationGetValueAdvice

See Also

OnLocationGetValueAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.LocationLevelAspect
PostSharp.Aspects.Advices..::.OnLocationSetValueAdvice
Conceptual Documentation: Adding Behaviors to Members


OnLocationGetValueAdvice Members

[image]

PostSharp 2.0 Documentation
OnLocationGetValueAdvice Members
OnLocationGetValueAdvice Class Constructors Properties See Also Send Feedback

The OnLocationGetValueAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnLocationGetValueAdvice | Initializes a new instance of the OnLocationGetValueAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnLocationGetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationGetValueAdvice Constructor

OnLocationGetValueAdvice Constructor
OnLocationGetValueAdvice Class See Also Send Feedback
Initializes a new instance of the OnLocationGetValueAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnLocationGetValueAdvice()

See Also

OnLocationGetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationGetValueAdvice Properties

[image]

PostSharp 2.0 Documentation
OnLocationGetValueAdvice Properties
OnLocationGetValueAdvice Class See Also Send Feedback

The OnLocationGetValueAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnLocationGetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationSetValueAdvice Class

OnLocationSetValueAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnSetValue(LocationInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnLocationSetValueAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnSetValue(LocationInterceptionArgs). However, it can be static.

If an aspect defines many advices (among OnLocationSetValueAdvice, OnLocationGetValueAdvice) and if these advices are meant to be applied to the same properties with consistent ordering, they should be grouped together (see Master property).

Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnLocationSetValueAdvice

See Also

OnLocationSetValueAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.LocationLevelAspect
PostSharp.Aspects.Advices..::.OnLocationGetValueAdvice
Conceptual Documentation: Adding Behaviors to Members


OnLocationSetValueAdvice Members

[image]

PostSharp 2.0 Documentation
OnLocationSetValueAdvice Members
OnLocationSetValueAdvice Class Constructors Properties See Also Send Feedback

The OnLocationSetValueAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnLocationSetValueAdvice | Initializes a new instance of the OnLocationSetValueAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnLocationSetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationSetValueAdvice Constructor

OnLocationSetValueAdvice Constructor
OnLocationSetValueAdvice Class See Also Send Feedback
Initializes a new instance of the OnLocationSetValueAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnLocationSetValueAdvice()

See Also

OnLocationSetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnLocationSetValueAdvice Properties

[image]

PostSharp 2.0 Documentation
OnLocationSetValueAdvice Properties
OnLocationSetValueAdvice Class See Also Send Feedback

The OnLocationSetValueAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnLocationSetValueAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodEntryAdvice Class

OnMethodEntryAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnEntry(MethodExecutionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodEntryAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnEntry(MethodExecutionArgs). However, it can be static.

If an aspect defines many advices (among OnMethodEntryAdvice, OnMethodExitAdvice, OnMethodSuccessAdvice and OnMethodExceptionAdvice) that are meant to be applied to the same methods with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnMethodEntryAdvice

See Also

OnMethodEntryAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.OnMethodBoundaryAspect
PostSharp.Aspects.Advices..::.OnMethodExitAdvice
PostSharp.Aspects.Advices..::.OnMethodSuccessAdvice
PostSharp.Aspects.Advices..::.OnMethodExceptionAdvice
Conceptual Documentation: Adding Behaviors to Members


OnMethodEntryAdvice Members

[image]

PostSharp 2.0 Documentation
OnMethodEntryAdvice Members
OnMethodEntryAdvice Class Constructors Properties See Also Send Feedback

The OnMethodEntryAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodEntryAdvice | Initializes a new instance of the OnMethodEntryAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodEntryAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodEntryAdvice Constructor

OnMethodEntryAdvice Constructor
OnMethodEntryAdvice Class See Also Send Feedback
Initializes a new instance of the OnMethodEntryAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodEntryAdvice()

See Also

OnMethodEntryAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodEntryAdvice Properties

[image]

PostSharp 2.0 Documentation
OnMethodEntryAdvice Properties
OnMethodEntryAdvice Class See Also Send Feedback

The OnMethodEntryAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodEntryAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExceptionAdvice Class

OnMethodExceptionAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnException(MethodExecutionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodExceptionAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnException(MethodExecutionArgs). However, it can be static.

If an aspect defines many advices (among OnMethodEntryAdvice, OnMethodExitAdvice, OnMethodSuccessAdvice and OnMethodExceptionAdvice) that are meant to be applied to the same methods with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnMethodExceptionAdvice

See Also

OnMethodExceptionAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.OnMethodBoundaryAspect
PostSharp.Aspects.Advices..::.OnMethodExitAdvice
PostSharp.Aspects.Advices..::.OnMethodSuccessAdvice
PostSharp.Aspects.Advices..::.OnMethodEntryAdvice
Conceptual Documentation: Adding Behaviors to Members


OnMethodExceptionAdvice Members

[image]

PostSharp 2.0 Documentation
OnMethodExceptionAdvice Members
OnMethodExceptionAdvice Class Constructors Properties See Also Send Feedback

The OnMethodExceptionAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodExceptionAdvice | Initializes a new instance of the OnMethodExceptionAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodExceptionAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExceptionAdvice Constructor

OnMethodExceptionAdvice Constructor
OnMethodExceptionAdvice Class See Also Send Feedback
Initializes a new instance of the OnMethodExceptionAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodExceptionAdvice()

See Also

OnMethodExceptionAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExceptionAdvice Properties

[image]

PostSharp 2.0 Documentation
OnMethodExceptionAdvice Properties
OnMethodExceptionAdvice Class See Also Send Feedback

The OnMethodExceptionAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodExceptionAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExitAdvice Class

OnMethodExitAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnExit(MethodExecutionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodExitAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnExit(MethodExecutionArgs). However, it can be static.

If an aspect defines many advices (among OnMethodEntryAdvice, OnMethodExitAdvice, OnMethodSuccessAdvice and OnMethodExceptionAdvice) that are meant to be applied to the same methods with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnMethodExitAdvice

See Also

OnMethodExitAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.OnMethodBoundaryAspect
PostSharp.Aspects.Advices..::.OnMethodExceptionAdvice
PostSharp.Aspects.Advices..::.OnMethodSuccessAdvice
PostSharp.Aspects.Advices..::.OnMethodEntryAdvice
Conceptual Documentation: Adding Behaviors to Members


OnMethodExitAdvice Members

[image]

PostSharp 2.0 Documentation
OnMethodExitAdvice Members
OnMethodExitAdvice Class Constructors Properties See Also Send Feedback

The OnMethodExitAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodExitAdvice | Initializes a new instance of the OnMethodExitAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodExitAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExitAdvice Constructor

OnMethodExitAdvice Constructor
OnMethodExitAdvice Class See Also Send Feedback
Initializes a new instance of the OnMethodExitAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodExitAdvice()

See Also

OnMethodExitAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodExitAdvice Properties

[image]

PostSharp 2.0 Documentation
OnMethodExitAdvice Properties
OnMethodExitAdvice Class See Also Send Feedback

The OnMethodExitAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodExitAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodInvokeAdvice Class

OnMethodInvokeAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnInvoke(MethodInterceptionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodInvokeAdvice : Advice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnInvoke(MethodInterceptionArgs). However, it can be static.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.OnMethodInvokeAdvice

See Also

OnMethodInvokeAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.MethodInterceptionAspect
Conceptual Documentation: Adding Behaviors to Members


OnMethodInvokeAdvice Members

[image]

PostSharp 2.0 Documentation
OnMethodInvokeAdvice Members
OnMethodInvokeAdvice Class Constructors See Also Send Feedback

The OnMethodInvokeAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodInvokeAdvice | Initializes a new instance of the OnMethodInvokeAdvice class

See Also

OnMethodInvokeAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodInvokeAdvice Constructor

OnMethodInvokeAdvice Constructor
OnMethodInvokeAdvice Class See Also Send Feedback
Initializes a new instance of the OnMethodInvokeAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodInvokeAdvice()

See Also

OnMethodInvokeAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodSuccessAdvice Class

OnMethodSuccessAdvice Class
Members See Also Send Feedback
Custom attribute that, when applied on a method of an aspect class, specifies that this method is an advice having the same semantics as OnSuccess(MethodExecutionArgs).

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodSuccessAdvice : GroupingAdvice

Remarks

The method to which this custom attribute is applied must be public and must have the same signature as OnSuccess(MethodExecutionArgs). However, it can be static.

If an aspect defines many advices (among OnMethodEntryAdvice, OnMethodExitAdvice, OnMethodSuccessAdvice and OnMethodExceptionAdvice) that are meant to be applied to the same methods with consistent ordering, these advices should be grouped together (see Master property).

Note
Standalone advices or group masters should also be annotated by a custom attribute derived from Pointcut.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Advice
PostSharp.Aspects.Advices..::.GroupingAdvice
PostSharp.Aspects.Advices..::.OnMethodSuccessAdvice

See Also

OnMethodSuccessAdvice Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects..::.OnMethodBoundaryAspect
PostSharp.Aspects.Advices..::.OnMethodExitAdvice
PostSharp.Aspects.Advices..::.OnMethodExceptionAdvice
PostSharp.Aspects.Advices..::.OnMethodEntryAdvice
Conceptual Documentation: Adding Behaviors to Members


OnMethodSuccessAdvice Members

[image]

PostSharp 2.0 Documentation
OnMethodSuccessAdvice Members
OnMethodSuccessAdvice Class Constructors Properties See Also Send Feedback

The OnMethodSuccessAdvice type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodSuccessAdvice | Initializes a new instance of the OnMethodSuccessAdvice class

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodSuccessAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodSuccessAdvice Constructor

OnMethodSuccessAdvice Constructor
OnMethodSuccessAdvice Class See Also Send Feedback
Initializes a new instance of the OnMethodSuccessAdvice class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodSuccessAdvice()

See Also

OnMethodSuccessAdvice Class
PostSharp.Aspects.Advices Namespace


OnMethodSuccessAdvice Properties

[image]

PostSharp 2.0 Documentation
OnMethodSuccessAdvice Properties
OnMethodSuccessAdvice Class See Also Send Feedback

The OnMethodSuccessAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Master | Name of the master advice method. If this property is not set, the current method is itself the master of the group. Only master methods can define selectors (Pointcut) and dependencies (AspectDependencyAttribute). (Inherited from GroupingAdvice.)

See Also

OnMethodSuccessAdvice Class
PostSharp.Aspects.Advices Namespace


Pointcut Class

Pointcut Class
Members See Also Send Feedback
Custom attribute, typically accompanying an advice, specifying to which code elements the advice applies.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Pointcut : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Pointcut
PostSharp.Aspects.Advices..::.MethodPointcut
PostSharp.Aspects.Advices..::.MulticastPointcut
PostSharp.Aspects.Advices..::.SelfPointcut

See Also

Pointcut Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Adding Behaviors to Members


Pointcut Members

[image]

PostSharp 2.0 Documentation
Pointcut Members
Pointcut Class Constructors See Also Send Feedback

The Pointcut type exposes the following members.

Constructors

 | Name | Description
Protected method | Pointcut | Initializes a new instance of the Pointcut class

See Also

Pointcut Class
PostSharp.Aspects.Advices Namespace


Pointcut Constructor

Pointcut Constructor
Pointcut Class See Also Send Feedback
Initializes a new instance of the Pointcut class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Pointcut()

See Also

Pointcut Class
PostSharp.Aspects.Advices Namespace


Property(TValue) Class

Property<(Of <(<'TValue>)>)> Class
Members See Also Send Feedback
Exposes the semantics of a parameterless property for use with the ImportMemberAttribute aspect extension.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Property<TValue>

Type Parameters

TValue
Property value type.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Advices..::.Property<(Of <(TValue>)>)

See Also

Property<(Of <(TValue>)>) Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue, TIndex>)>)
PostSharp.Aspects.Advices..::.PropertyGetter<(Of <(TValue>)>)
PostSharp.Aspects.Advices..::.PropertySetter<(Of <(TValue>)>)
PostSharp.Aspects.Advices..::.ImportMemberAttribute
Conceptual Documentation: Introducing, Overriding and Importing Members


Property(TValue) Members

[image]

PostSharp 2.0 Documentation
Property<(Of <(<'TValue>)>)> Members
Property<(Of <(TValue>)>) Class Properties See Also Send Feedback

The Property<(Of <(TValue>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Get | Gets a delegate enabling to invoke the get accessor of the imported property.
Public property | Set | Gets a delegate enabling to invoke the set accessor of the imported property.

See Also

Property<(Of <(TValue>)>) Class
PostSharp.Aspects.Advices Namespace


Property(TValue) Properties

[image]

PostSharp 2.0 Documentation
Property<(Of <(<'TValue>)>)> Properties
Property<(Of <(TValue>)>) Class See Also Send Feedback

The Property<(Of <(TValue>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Get | Gets a delegate enabling to invoke the get accessor of the imported property.
Public property | Set | Gets a delegate enabling to invoke the set accessor of the imported property.

See Also

Property<(Of <(TValue>)>) Class
PostSharp.Aspects.Advices Namespace


Get Property

Property<(Of <(<'TValue>)>)>..::..Get Property
Property<(Of <(TValue>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the get accessor of the imported property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyGetter<TValue> Get { get; private set; }

See Also

Property<(Of <(TValue>)>) Class
PostSharp.Aspects.Advices Namespace


Set Property

Property<(Of <(<'TValue>)>)>..::..Set Property
Property<(Of <(TValue>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the set accessor of the imported property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertySetter<TValue> Set { get; private set; }

See Also

Property<(Of <(TValue>)>) Class
PostSharp.Aspects.Advices Namespace


Property(TValue, TIndex) Class

Property<(Of <(<'TValue, TIndex>)>)> Class
Members See Also Send Feedback
Mimics the semantics of a property accepting a single index parameter, for use with the ImportMemberAttribute aspect extension.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Property<TValue, TIndex>

Type Parameters

TValue
Property value type.
TIndex
Property index type.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Advices..::.Property<(Of <(TValue, TIndex>)>)

See Also

Property<(Of <(TValue, TIndex>)>) Members
PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue>)>)
PostSharp.Aspects.Advices..::.PropertyGetter<(Of <(TValue, TIndex>)>)
PostSharp.Aspects.Advices..::.PropertySetter<(Of <(TValue, TIndex>)>)


Property(TValue, TIndex) Members

[image]

PostSharp 2.0 Documentation
Property<(Of <(<'TValue, TIndex>)>)> Members
Property<(Of <(TValue, TIndex>)>) Class Properties See Also Send Feedback

The Property<(Of <(TValue, TIndex>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Get | Gets a delegate enabling to invoke the get accessor of the imported property.
Public property | Set | Gets a delegate enabling to invoke the set accessor of the imported property.

See Also

Property<(Of <(TValue, TIndex>)>) Class
PostSharp.Aspects.Advices Namespace


Property(TValue, TIndex) Properties

[image]

PostSharp 2.0 Documentation
Property<(Of <(<'TValue, TIndex>)>)> Properties
Property<(Of <(TValue, TIndex>)>) Class See Also Send Feedback

The Property<(Of <(TValue, TIndex>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Get | Gets a delegate enabling to invoke the get accessor of the imported property.
Public property | Set | Gets a delegate enabling to invoke the set accessor of the imported property.

See Also

Property<(Of <(TValue, TIndex>)>) Class
PostSharp.Aspects.Advices Namespace


Get Property

Property<(Of <(<'TValue, TIndex>)>)>..::..Get Property
Property<(Of <(TValue, TIndex>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the get accessor of the imported property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyGetter<TValue, TIndex> Get { get; private set; }

See Also

Property<(Of <(TValue, TIndex>)>) Class
PostSharp.Aspects.Advices Namespace


Set Property

Property<(Of <(<'TValue, TIndex>)>)>..::..Set Property
Property<(Of <(TValue, TIndex>)>) Class See Also Send Feedback
Gets a delegate enabling to invoke the set accessor of the imported property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertySetter<TValue, TIndex> Set { get; private set; }

See Also

Property<(Of <(TValue, TIndex>)>) Class
PostSharp.Aspects.Advices Namespace


PropertyGetter(TValue) Delegate

PropertyGetter<(Of <(<'TValue>)>)> Delegate
See Also Send Feedback
Defines the signature of methods implementing the Get semantic of a parameterless property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate TValue PropertyGetter<TValue>()

Type Parameters

TValue
Property value type.

Return Value

The property value.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue>)>)


PropertyGetter(TValue, TIndex) Delegate

PropertyGetter<(Of <(<'TValue, TIndex>)>)> Delegate
See Also Send Feedback
Defines the signature of methods implementing the Get semantic of a property with a single index parameter.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate TValue PropertyGetter<TValue, TIndex>(
    TIndex index
)

Parameters

index
Type: TIndex
Index.

Type Parameters

TValue
Property value type.
TIndex
Property index type.

Return Value

The property value.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue, TIndex>)>)


PropertySetter(TValue) Delegate

PropertySetter<(Of <(<'TValue>)>)> Delegate
See Also Send Feedback
Defines the signature of methods implementing the Set semantic of a parameterless property.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate void PropertySetter<TValue>(
    TValue value
)

Parameters

value
Type: TValue
The property value.

Type Parameters

TValue
Property value type.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue>)>)


PropertySetter(TValue, TIndex) Delegate

PropertySetter<(Of <(<'TValue, TIndex>)>)> Delegate
See Also Send Feedback
Defines the signature of methods implementing the Set semantic of a property with a single index parameter.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate void PropertySetter<TValue, TIndex>(
    TIndex index,
    TValue value
)

Parameters

index
Type: TIndex
Index.
value
Type: TValue
The property value.

Type Parameters

TValue
Property value type.
TIndex
Property index type.

See Also

PostSharp.Aspects.Advices Namespace
PostSharp.Aspects.Advices..::.Property<(Of <(TValue, TIndex>)>)


SelfPointcut Class

SelfPointcut Class
Members See Also Send Feedback
Pointcut that selects exactly the aspect target.

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SelfPointcut : Pointcut

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Advices..::.Pointcut
PostSharp.Aspects.Advices..::.SelfPointcut

See Also

SelfPointcut Members
PostSharp.Aspects.Advices Namespace
Conceptual Documentation: Adding Behaviors to Members


SelfPointcut Members

[image]

PostSharp 2.0 Documentation
SelfPointcut Members
SelfPointcut Class Constructors See Also Send Feedback

The SelfPointcut type exposes the following members.

Constructors

 | Name | Description
Public method | SelfPointcut | Initializes a new instance of the SelfPointcut class

See Also

SelfPointcut Class
PostSharp.Aspects.Advices Namespace


SelfPointcut Constructor

SelfPointcut Constructor
SelfPointcut Class See Also Send Feedback
Initializes a new instance of the SelfPointcut class

Namespace: PostSharp.Aspects.Advices
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SelfPointcut()

See Also

SelfPointcut Class
PostSharp.Aspects.Advices Namespace


PostSharp.Aspects.Configuration Namespace

PostSharp.Aspects.Configuration Namespace
Send Feedback
The PostSharp.Aspects.Configuration namespace contains classes and custom attributes configuring the aspects of the PostSharp.Aspects namespace.

Classes

 | Class | Description
Public class | AspectConfiguration | Configuration of an IAspect.
Public class | AspectConfigurationAttribute | Configures an aspect of type IAspect.
Public class | CompositionAspectConfiguration | Configuration of aspects of type ICompositionAspect.
Public class | CompositionAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing ICompositionAspect, defines the declarative configuration of that aspect.
Public class | CustomAttributeIntroductionAspectConfiguration | Configuration of aspects of type CustomAttributeIntroductionAspect.
Public class | EventInterceptionAspectConfiguration | Configuration of aspects of type IEventInterceptionAspect.
Public class | EventInterceptionAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing IEventInterceptionAspect, defines the declarative configuration of that aspect.
Public class | ExternalAspectConfiguration | Configuration of aspects of type IExternalAspect.
Public class | ExternalAspectConfigurationAttribute | Specifies the type name of the implementation of external aspects (IExternalAspect).
Public class | LocationInterceptionAspectConfiguration | Configuration of aspects of type ILocationLevelAspect.
Public class | LocationInterceptionAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing ILocationInterceptionAspect, defines the declarative configuration of that aspect.
Public class | ManagedResourceIntroductionAspectConfiguration | Configuration of aspects of type ManagedResourceIntroductionAspect.
Public class | MethodInterceptionAspectConfiguration | Configuration of aspects of type IMethodInterceptionAspect.
Public class | MethodInterceptionAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing IMethodInterceptionAspect, defines the declarative configuration of that aspect.
Public class | OnExceptionAspectConfiguration | Configuration of the IOnExceptionAspect aspect.
Public class | OnExceptionAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing IOnExceptionAspect, defines the configuration of that aspect.
Public class | OnMethodBoundaryAspectConfiguration | Configuration of the IOnMethodBoundaryAspect aspect.
Public class | OnMethodBoundaryAspectConfigurationAttribute | Custom attribute that, when applied on a class implementing IOnMethodBoundaryAspect, defines the configuration of that aspect.


AspectConfiguration Class

AspectConfiguration Class
Members See Also Send Feedback
Configuration of an IAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AspectConfiguration

Remarks

Every concrete aspect class has a corresponding configuration class derived from AspectConfiguration.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.CompositionAspectConfiguration
PostSharp.Aspects.Configuration..::.CustomAttributeIntroductionAspectConfiguration
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfiguration
PostSharp.Aspects.Configuration..::.ExternalAspectConfiguration
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfiguration
PostSharp.Aspects.Configuration..::.ManagedResourceIntroductionAspectConfiguration
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfiguration
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfiguration
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfiguration

See Also

AspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects


AspectConfiguration Members

[image]

PostSharp 2.0 Documentation
AspectConfiguration Members
AspectConfiguration Class Constructors Properties See Also Send Feedback

The AspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | AspectConfiguration | Initializes a new instance of the AspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero.
Public property | Dependencies | Gets or sets the collection of dependencies.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect.

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


AspectConfiguration Constructor

AspectConfiguration Constructor
AspectConfiguration Class See Also Send Feedback
Initializes a new instance of the AspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration()

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


AspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
AspectConfiguration Properties
AspectConfiguration Class See Also Send Feedback

The AspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero.
Public property | Dependencies | Gets or sets the collection of dependencies.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect.

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


AspectPriority Property

AspectConfiguration..::..AspectPriority Property
AspectConfiguration Class See Also Send Feedback
Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<int> AspectPriority { get; set; }

Remarks

Whenever possible, use dependencies (Dependencies collection) to specify the ordering of aspects. Unlike priorities, dependencies scale up in complexity, which can be important in larger projects.

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


Dependencies Property

AspectConfiguration..::..Dependencies Property
AspectConfiguration Class See Also Send Feedback
Gets or sets the collection of dependencies.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyAttributeCollection Dependencies { get; set; }

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


SerializerType Property

AspectConfiguration..::..SerializerType Property
AspectConfiguration Class See Also Send Feedback
Gets or sets the type of the serializer that will be used to configure the current aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeIdentity SerializerType { get; set; }

Remarks

This type should have derive from AspectSerializer and have a default constructor. Use null to specify that the aspect will not be serialized, but will be constructed using MSIL instructions.

See Also

AspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


AspectConfigurationAttribute Class

AspectConfigurationAttribute Class
Members See Also Send Feedback
Configures an aspect of type IAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AspectConfigurationAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.CompositionAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.ExternalAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfigurationAttribute

See Also

AspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects


AspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
AspectConfigurationAttribute Members
AspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The AspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AspectConfigurationAttribute | Initializes a new instance of the AspectConfigurationAttribute class

Methods

 | Name | Description
Protected method | CreateAspectConfiguration | Creates a concrete AspectConfiguration instance specifically for the current AspectConfigurationAttribute type.
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute.
Protected method | SetAspectConfiguration | Sets up an AspectConfiguration object according to the current custom attribute instance.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


AspectConfigurationAttribute Constructor

AspectConfigurationAttribute Constructor
AspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the AspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfigurationAttribute()

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


AspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
AspectConfigurationAttribute Methods
AspectConfigurationAttribute Class See Also Send Feedback

The AspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Protected method | CreateAspectConfiguration | Creates a concrete AspectConfiguration instance specifically for the current AspectConfigurationAttribute type.
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute.
Protected method | SetAspectConfiguration | Sets up an AspectConfiguration object according to the current custom attribute instance.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CreateAspectConfiguration Method

AspectConfigurationAttribute..::..CreateAspectConfiguration Method
AspectConfigurationAttribute Class See Also Send Feedback
Creates a concrete AspectConfiguration instance specifically for the current AspectConfigurationAttribute type.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual AspectConfiguration CreateAspectConfiguration()

Return Value

A new and empty instance of AspectConfiguration, whose concrete type corresponds to the concrete type of the AspectConfigurationAttribute.

Remarks

This method should not set up the returned AspectConfiguration. After the current method has returned, the SetAspectConfiguration(AspectConfiguration) method will be invoked, and this method is responsible for setting up the AspectConfigurationobject.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


GetAspectConfiguration Method

AspectConfigurationAttribute..::..GetAspectConfiguration Method
AspectConfigurationAttribute Class See Also Send Feedback
Gets the AspectConfiguration corresponding to the current custom attribute.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration GetAspectConfiguration()

Return Value

An AspectConfiguration corresponding to the current custom attribute.

Remarks

This method can be customized by overriding CreateAspectConfiguration()()() and/or SetAspectConfiguration(AspectConfiguration)

.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


SetAspectConfiguration Method

AspectConfigurationAttribute..::..SetAspectConfiguration Method
AspectConfigurationAttribute Class See Also Send Feedback
Sets up an AspectConfiguration object according to the current custom attribute instance.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void SetAspectConfiguration(
    AspectConfiguration aspectConfiguration
)

Parameters

aspectConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfiguration
The AspectConfiguration instance previously returned by the CreateAspectConfiguration()()() method.

Remarks

Classes overriding this method must always invoke the base implementation before performing their own changes to the AspectConfiguration.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


AspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
AspectConfigurationAttribute Properties
AspectConfigurationAttribute Class See Also Send Feedback

The AspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


AspectPriority Property

AspectConfigurationAttribute..::..AspectPriority Property
AspectConfigurationAttribute Class See Also Send Feedback
Gets or sets the weaving priority of the aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int AspectPriority { get; set; }

Field Value

The aspect priority, or null if the aspect priority is not specified.

Remarks

Advices with lower priority are executed before in case of 'entry' semantics (entering or invoking a method, setting a field value), but this order is inverted for advices of 'exit' semantics (leaving a method, getting a field value).

This property must not be confused with AttributePriority, which solely influences the multicasting process.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


SerializerType Property

AspectConfigurationAttribute..::..SerializerType Property
AspectConfigurationAttribute Class See Also Send Feedback
Gets or sets the Type of the serializer that will be used to configure the current aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type SerializerType { get; set; }

Remarks

This type should have derive from AspectSerializer and have a default constructor. Use null to specify that the aspect will not be serialized, but will be constructed using MSIL instructions.

See Also

AspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfiguration Class

CompositionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type ICompositionAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CompositionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.CompositionAspectConfiguration

See Also

CompositionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.CompositionAspectConfigurationAttribute
Conceptual Documentation: Configuring Aspects


CompositionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
CompositionAspectConfiguration Members
CompositionAspectConfiguration Class Constructors Properties See Also Send Feedback

The CompositionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | CompositionAspectConfiguration | Initializes a new instance of the CompositionAspectConfiguration class

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.
Public property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.
Public property | ProtectedInterfaces | Gets or sets the array of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Public property | PublicInterfaces | Gets or sets the array of interfaces that should be introduced publicly into the target type of the aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfiguration Constructor

CompositionAspectConfiguration Constructor
CompositionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the CompositionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CompositionAspectConfiguration()

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
CompositionAspectConfiguration Properties
CompositionAspectConfiguration Class See Also Send Feedback

The CompositionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.
Public property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.
Public property | ProtectedInterfaces | Gets or sets the array of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Public property | PublicInterfaces | Gets or sets the array of interfaces that should be introduced publicly into the target type of the aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


AncestorOverrideAction Property

CompositionAspectConfiguration..::..AncestorOverrideAction Property
CompositionAspectConfiguration Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<InterfaceOverrideAction> AncestorOverrideAction { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace
CompositionAspectConfiguration..::.OverrideAction


GenerateImplementationAccessor Property

CompositionAspectConfiguration..::..GenerateImplementationAccessor Property
CompositionAspectConfiguration Class See Also Send Feedback
Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<bool> GenerateImplementationAccessor { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


NonSerializedImplementation Property

CompositionAspectConfiguration..::..NonSerializedImplementation Property
CompositionAspectConfiguration Class See Also Send Feedback
Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<bool> NonSerializedImplementation { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OverrideAction Property

CompositionAspectConfiguration..::..OverrideAction Property
CompositionAspectConfiguration Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<InterfaceOverrideAction> OverrideAction { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace
CompositionAspectConfiguration..::.AncestorOverrideAction


ProtectedInterfaces Property

CompositionAspectConfiguration..::..ProtectedInterfaces Property
CompositionAspectConfiguration Class See Also Send Feedback
Gets or sets the array of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeIdentity[] ProtectedInterfaces { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


PublicInterfaces Property

CompositionAspectConfiguration..::..PublicInterfaces Property
CompositionAspectConfiguration Class See Also Send Feedback
Gets or sets the array of interfaces that should be introduced publicly into the target type of the aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeIdentity[] PublicInterfaces { get; set; }

See Also

CompositionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfigurationAttribute Class

CompositionAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing ICompositionAspect, defines the declarative configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CompositionAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.CompositionAspectConfigurationAttribute

See Also

CompositionAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects..::.CompositionAspect
Conceptual Documentation: Configuring Aspects


CompositionAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
CompositionAspectConfigurationAttribute Members
CompositionAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The CompositionAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CompositionAspectConfigurationAttribute | Initializes a new instance of the CompositionAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.
Public property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.
Public property | ProtectedInterfaces | Gets or sets the array of type names of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Public property | PublicInterfaces | Gets or sets the array of type names of interfaces that should be introduced publicly into the target type of the aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfigurationAttribute Constructor

CompositionAspectConfigurationAttribute Constructor
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the CompositionAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CompositionAspectConfigurationAttribute()

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
CompositionAspectConfigurationAttribute Methods
CompositionAspectConfigurationAttribute Class See Also Send Feedback

The CompositionAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CompositionAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
CompositionAspectConfigurationAttribute Properties
CompositionAspectConfigurationAttribute Class See Also Send Feedback

The CompositionAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AncestorOverrideAction | Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | GenerateImplementationAccessor | Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.
Public property | NonSerializedImplementation | Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.
Public property | OverrideAction | Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.
Public property | ProtectedInterfaces | Gets or sets the array of type names of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.
Public property | PublicInterfaces | Gets or sets the array of type names of interfaces that should be introduced publicly into the target type of the aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


AncestorOverrideAction Property

CompositionAspectConfigurationAttribute..::..AncestorOverrideAction Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when an ancestor of one of the interfaces specified by PublicInterfaces is already implemented by the type to which the current aspect is applied.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceOverrideAction AncestorOverrideAction { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace
CompositionAspectConfigurationAttribute..::.OverrideAction


GenerateImplementationAccessor Property

CompositionAspectConfigurationAttribute..::..GenerateImplementationAccessor Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Determines whether the interface IComposed<(Of <(T>)>) should be introduced into the type to which the aspect is applied for each interface specified by the PublicInterfaces property.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool GenerateImplementationAccessor { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


NonSerializedImplementation Property

CompositionAspectConfigurationAttribute..::..NonSerializedImplementation Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Determines whether the field containing the interface implementation (and storing the object returned by CreateImplementationObject(AdviceArgs)) should be excluded from serialization by BinaryFormatter. The same effect is typically obtained by applying the NonSerializedAttribute custom attribute to the field.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool NonSerializedImplementation { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OverrideAction Property

CompositionAspectConfigurationAttribute..::..OverrideAction Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Specifies the action (Fail or Ignore) to be overtaken when one of the interfaces specified by PublicInterfaces or ProtectedInterfaces is already implemented by the type to which the aspect is applied.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceOverrideAction OverrideAction { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace
CompositionAspectConfigurationAttribute..::.AncestorOverrideAction


ProtectedInterfaces Property

CompositionAspectConfigurationAttribute..::..ProtectedInterfaces Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Gets or sets the array of type names of interfaces to be introduced indirectly into the target type of the aspect. These interfaces will become accessible through the IProtectedInterface<(Of <(T>)>) interface.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string[] ProtectedInterfaces { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


PublicInterfaces Property

CompositionAspectConfigurationAttribute..::..PublicInterfaces Property
CompositionAspectConfigurationAttribute Class See Also Send Feedback
Gets or sets the array of type names of interfaces that should be introduced publicly into the target type of the aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string[] PublicInterfaces { get; set; }

See Also

CompositionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


CustomAttributeIntroductionAspectConfiguration Class

CustomAttributeIntroductionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type CustomAttributeIntroductionAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomAttributeIntroductionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.CustomAttributeIntroductionAspectConfiguration

See Also

CustomAttributeIntroductionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects


CustomAttributeIntroductionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
CustomAttributeIntroductionAspectConfiguration Members
CustomAttributeIntroductionAspectConfiguration Class Constructors Properties See Also Send Feedback

The CustomAttributeIntroductionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | CustomAttributeIntroductionAspectConfiguration | Initializes a new instance of the CustomAttributeIntroductionAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ObjectConstruction | Gets or sets the construction of the custom attribute that must be applied to the target of this aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

CustomAttributeIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


CustomAttributeIntroductionAspectConfiguration Constructor

CustomAttributeIntroductionAspectConfiguration Constructor
CustomAttributeIntroductionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the CustomAttributeIntroductionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeIntroductionAspectConfiguration()

See Also

CustomAttributeIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


CustomAttributeIntroductionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
CustomAttributeIntroductionAspectConfiguration Properties
CustomAttributeIntroductionAspectConfiguration Class See Also Send Feedback

The CustomAttributeIntroductionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ObjectConstruction | Gets or sets the construction of the custom attribute that must be applied to the target of this aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

CustomAttributeIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ObjectConstruction Property

CustomAttributeIntroductionAspectConfiguration..::..ObjectConstruction Property
CustomAttributeIntroductionAspectConfiguration Class See Also Send Feedback
Gets or sets the construction of the custom attribute that must be applied to the target of this aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction ObjectConstruction { get; set; }

See Also

CustomAttributeIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfiguration Class

EventInterceptionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type IEventInterceptionAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EventInterceptionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfiguration

See Also

EventInterceptionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfigurationAttribute
Conceptual Documentation: Configuring Aspects


EventInterceptionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
EventInterceptionAspectConfiguration Members
EventInterceptionAspectConfiguration Class Constructors Properties See Also Send Feedback

The EventInterceptionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | EventInterceptionAspectConfiguration | Initializes a new instance of the EventInterceptionAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

EventInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfiguration Constructor

EventInterceptionAspectConfiguration Constructor
EventInterceptionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the EventInterceptionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInterceptionAspectConfiguration()

See Also

EventInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
EventInterceptionAspectConfiguration Properties
EventInterceptionAspectConfiguration Class See Also Send Feedback

The EventInterceptionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

EventInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfigurationAttribute Class

EventInterceptionAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing IEventInterceptionAspect, defines the declarative configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EventInterceptionAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfigurationAttribute

See Also

EventInterceptionAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.EventInterceptionAspectConfiguration
PostSharp.Aspects..::.EventInterceptionAspect
Conceptual Documentation: Configuring Aspects


EventInterceptionAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
EventInterceptionAspectConfigurationAttribute Members
EventInterceptionAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The EventInterceptionAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EventInterceptionAspectConfigurationAttribute | Initializes a new instance of the EventInterceptionAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

EventInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfigurationAttribute Constructor

EventInterceptionAspectConfigurationAttribute Constructor
EventInterceptionAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the EventInterceptionAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInterceptionAspectConfigurationAttribute()

See Also

EventInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
EventInterceptionAspectConfigurationAttribute Methods
EventInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The EventInterceptionAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

EventInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


EventInterceptionAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
EventInterceptionAspectConfigurationAttribute Properties
EventInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The EventInterceptionAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

EventInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfiguration Class

ExternalAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type IExternalAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExternalAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.ExternalAspectConfiguration

See Also

ExternalAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects
Conceptual Documentation: Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework


ExternalAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
ExternalAspectConfiguration Members
ExternalAspectConfiguration Class Constructors Properties See Also Send Feedback

The ExternalAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalAspectConfiguration | Initializes a new instance of the ExternalAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ImplementationTypeName | Gets or sets the type implementing the aspect. This type must implement the interface IExternalAspectImplementation.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

ExternalAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfiguration Constructor

ExternalAspectConfiguration Constructor
ExternalAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the ExternalAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExternalAspectConfiguration()

See Also

ExternalAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
ExternalAspectConfiguration Properties
ExternalAspectConfiguration Class See Also Send Feedback

The ExternalAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ImplementationTypeName | Gets or sets the type implementing the aspect. This type must implement the interface IExternalAspectImplementation.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

ExternalAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ImplementationTypeName Property

ExternalAspectConfiguration..::..ImplementationTypeName Property
ExternalAspectConfiguration Class See Also Send Feedback
Gets or sets the type implementing the aspect. This type must implement the interface IExternalAspectImplementation.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeIdentity ImplementationTypeName { get; set; }

See Also

ExternalAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Class

ExternalAspectConfigurationAttribute Class
Members See Also Send Feedback
Specifies the type name of the implementation of external aspects (IExternalAspect).

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExternalAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.ExternalAspectConfigurationAttribute

See Also

ExternalAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects
Conceptual Documentation: Using PostSharp with Silverlight, Windows Phone, and the Compact .NET Framework


ExternalAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
ExternalAspectConfigurationAttribute Members
ExternalAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The ExternalAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalAspectConfigurationAttribute | Overloaded.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | ImplementationTypeName | Gets the assembly-qualified name of the implementation type. This type must implement the IExternalAspectImplementation interface.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

ExternalAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Constructor

[image]

PostSharp 2.0 Documentation
ExternalAspectConfigurationAttribute Constructor
ExternalAspectConfigurationAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExternalAspectConfigurationAttribute()()() | Initializes a new ExternalAspectConfigurationAttribute. In user code, use the ExternalAspectConfigurationAttribute(String) constructor instead of this one.
Public method | ExternalAspectConfigurationAttribute(String) | Initializes a new ExternalAspectConfigurationAttribute.

See Also

ExternalAspectConfigurationAttribute Class
ExternalAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Constructor

ExternalAspectConfigurationAttribute Constructor
ExternalAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new ExternalAspectConfigurationAttribute. In user code, use the ExternalAspectConfigurationAttribute(String) constructor instead of this one.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExternalAspectConfigurationAttribute()

See Also

ExternalAspectConfigurationAttribute Class
ExternalAspectConfigurationAttribute Overload
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Constructor (String)

ExternalAspectConfigurationAttribute Constructor (String)
ExternalAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new ExternalAspectConfigurationAttribute.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExternalAspectConfigurationAttribute(
    string implementationTypeName
)

Parameters

implementationTypeName
Type: System..::.String
Assembly-qualified name of the implementation type. This type should implement the IExternalAspectImplementation interface.

See Also

ExternalAspectConfigurationAttribute Class
ExternalAspectConfigurationAttribute Overload
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
ExternalAspectConfigurationAttribute Methods
ExternalAspectConfigurationAttribute Class See Also Send Feedback

The ExternalAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

ExternalAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ExternalAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
ExternalAspectConfigurationAttribute Properties
ExternalAspectConfigurationAttribute Class See Also Send Feedback

The ExternalAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | ImplementationTypeName | Gets the assembly-qualified name of the implementation type. This type must implement the IExternalAspectImplementation interface.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

ExternalAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ImplementationTypeName Property

ExternalAspectConfigurationAttribute..::..ImplementationTypeName Property
ExternalAspectConfigurationAttribute Class See Also Send Feedback
Gets the assembly-qualified name of the implementation type. This type must implement the IExternalAspectImplementation interface.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string ImplementationTypeName { get; set; }

See Also

ExternalAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfiguration Class

LocationInterceptionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type ILocationLevelAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocationInterceptionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfiguration

See Also

LocationInterceptionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects


LocationInterceptionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspectConfiguration Members
LocationInterceptionAspectConfiguration Class Constructors Properties See Also Send Feedback

The LocationInterceptionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | LocationInterceptionAspectConfiguration | Initializes a new instance of the LocationInterceptionAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

LocationInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfiguration Constructor

LocationInterceptionAspectConfiguration Constructor
LocationInterceptionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the LocationInterceptionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInterceptionAspectConfiguration()

See Also

LocationInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspectConfiguration Properties
LocationInterceptionAspectConfiguration Class See Also Send Feedback

The LocationInterceptionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

LocationInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfigurationAttribute Class

LocationInterceptionAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing ILocationInterceptionAspect, defines the declarative configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocationInterceptionAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfigurationAttribute

See Also

LocationInterceptionAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.LocationInterceptionAspectConfiguration
PostSharp.Aspects..::.LocationLevelAspect
Conceptual Documentation: Configuring Aspects


LocationInterceptionAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspectConfigurationAttribute Members
LocationInterceptionAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The LocationInterceptionAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | LocationInterceptionAspectConfigurationAttribute | Initializes a new instance of the LocationInterceptionAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

LocationInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfigurationAttribute Constructor

LocationInterceptionAspectConfigurationAttribute Constructor
LocationInterceptionAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the LocationInterceptionAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInterceptionAspectConfigurationAttribute()

See Also

LocationInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspectConfigurationAttribute Methods
LocationInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The LocationInterceptionAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

LocationInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


LocationInterceptionAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
LocationInterceptionAspectConfigurationAttribute Properties
LocationInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The LocationInterceptionAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

LocationInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ManagedResourceIntroductionAspectConfiguration Class

ManagedResourceIntroductionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type ManagedResourceIntroductionAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManagedResourceIntroductionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.ManagedResourceIntroductionAspectConfiguration

See Also

ManagedResourceIntroductionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
Conceptual Documentation: Configuring Aspects


ManagedResourceIntroductionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
ManagedResourceIntroductionAspectConfiguration Members
ManagedResourceIntroductionAspectConfiguration Class Constructors Properties See Also Send Feedback

The ManagedResourceIntroductionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ManagedResourceIntroductionAspectConfiguration | Initializes a new ManagedResourceIntroductionAspectConfiguration.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Data | Gets the content of the managed resource.
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | Name | Gets the name of the managed resource.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

ManagedResourceIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ManagedResourceIntroductionAspectConfiguration Constructor

ManagedResourceIntroductionAspectConfiguration Constructor
ManagedResourceIntroductionAspectConfiguration Class See Also Send Feedback
Initializes a new ManagedResourceIntroductionAspectConfiguration.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManagedResourceIntroductionAspectConfiguration(
    string name,
    byte[] data
)

Parameters

name
Type: System..::.String
Name of the managed resource.
data
Type: array< System..::.Byte >[]()[][]
Content of the managed resource.

See Also

ManagedResourceIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ManagedResourceIntroductionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
ManagedResourceIntroductionAspectConfiguration Properties
ManagedResourceIntroductionAspectConfiguration Class See Also Send Feedback

The ManagedResourceIntroductionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Data | Gets the content of the managed resource.
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | Name | Gets the name of the managed resource.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

ManagedResourceIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


Data Property

ManagedResourceIntroductionAspectConfiguration..::..Data Property
ManagedResourceIntroductionAspectConfiguration Class See Also Send Feedback
Gets the content of the managed resource.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] Data { get; private set; }

See Also

ManagedResourceIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


Name Property

ManagedResourceIntroductionAspectConfiguration..::..Name Property
ManagedResourceIntroductionAspectConfiguration Class See Also Send Feedback
Gets the name of the managed resource.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; private set; }

See Also

ManagedResourceIntroductionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfiguration Class

MethodInterceptionAspectConfiguration Class
Members See Also Send Feedback
Configuration of aspects of type IMethodInterceptionAspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodInterceptionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfiguration

See Also

MethodInterceptionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfigurationAttribute
PostSharp.Aspects..::.MethodInterceptionAspect
Conceptual Documentation: Configuring Aspects


MethodInterceptionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspectConfiguration Members
MethodInterceptionAspectConfiguration Class Constructors Properties See Also Send Feedback

The MethodInterceptionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodInterceptionAspectConfiguration | Initializes a new instance of the MethodInterceptionAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

MethodInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfiguration Constructor

MethodInterceptionAspectConfiguration Constructor
MethodInterceptionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the MethodInterceptionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodInterceptionAspectConfiguration()

See Also

MethodInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspectConfiguration Properties
MethodInterceptionAspectConfiguration Class See Also Send Feedback

The MethodInterceptionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

MethodInterceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfigurationAttribute Class

MethodInterceptionAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing IMethodInterceptionAspect, defines the declarative configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodInterceptionAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfigurationAttribute

See Also

MethodInterceptionAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects..::.MethodInterceptionAspect
PostSharp.Aspects.Configuration..::.MethodInterceptionAspectConfiguration
Conceptual Documentation: Configuring Aspects


MethodInterceptionAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspectConfigurationAttribute Members
MethodInterceptionAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The MethodInterceptionAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | MethodInterceptionAspectConfigurationAttribute | Initializes a new instance of the MethodInterceptionAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

MethodInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfigurationAttribute Constructor

MethodInterceptionAspectConfigurationAttribute Constructor
MethodInterceptionAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the MethodInterceptionAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodInterceptionAspectConfigurationAttribute()

See Also

MethodInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspectConfigurationAttribute Methods
MethodInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The MethodInterceptionAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

MethodInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


MethodInterceptionAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
MethodInterceptionAspectConfigurationAttribute Properties
MethodInterceptionAspectConfigurationAttribute Class See Also Send Feedback

The MethodInterceptionAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

MethodInterceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfiguration Class

OnExceptionAspectConfiguration Class
Members See Also Send Feedback
Configuration of the IOnExceptionAspect aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnExceptionAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfiguration

See Also

OnExceptionAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects..::.OnExceptionAspect
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfigurationAttribute
Conceptual Documentation: Configuring Aspects


OnExceptionAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
OnExceptionAspectConfiguration Members
OnExceptionAspectConfiguration Class Constructors Properties See Also Send Feedback

The OnExceptionAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | OnExceptionAspectConfiguration | Initializes a new instance of the OnExceptionAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ExceptionType | Gets or sets the type of exceptions that are caught by this aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

OnExceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfiguration Constructor

OnExceptionAspectConfiguration Constructor
OnExceptionAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the OnExceptionAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnExceptionAspectConfiguration()

See Also

OnExceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
OnExceptionAspectConfiguration Properties
OnExceptionAspectConfiguration Class See Also Send Feedback

The OnExceptionAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | ExceptionType | Gets or sets the type of exceptions that are caught by this aspect.
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

OnExceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


ExceptionType Property

OnExceptionAspectConfiguration..::..ExceptionType Property
OnExceptionAspectConfiguration Class See Also Send Feedback
Gets or sets the type of exceptions that are caught by this aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeIdentity ExceptionType { get; set; }

Remarks

If this property is null, any Exception shall be caught.

See Also

OnExceptionAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfigurationAttribute Class

OnExceptionAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing IOnExceptionAspect, defines the configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnExceptionAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.OnExceptionAspectConfigurationAttribute

See Also

OnExceptionAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects..::.OnExceptionAspect
Conceptual Documentation: Configuring Aspects


OnExceptionAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
OnExceptionAspectConfigurationAttribute Members
OnExceptionAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The OnExceptionAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | OnExceptionAspectConfigurationAttribute | Initializes a new instance of the OnExceptionAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | ExceptionType | Gets or sets the type of exceptions that are caught by this aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

OnExceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfigurationAttribute Constructor

OnExceptionAspectConfigurationAttribute Constructor
OnExceptionAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the OnExceptionAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnExceptionAspectConfigurationAttribute()

See Also

OnExceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
OnExceptionAspectConfigurationAttribute Methods
OnExceptionAspectConfigurationAttribute Class See Also Send Feedback

The OnExceptionAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

OnExceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnExceptionAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
OnExceptionAspectConfigurationAttribute Properties
OnExceptionAspectConfigurationAttribute Class See Also Send Feedback

The OnExceptionAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | ExceptionType | Gets or sets the type of exceptions that are caught by this aspect.
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

OnExceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


ExceptionType Property

OnExceptionAspectConfigurationAttribute..::..ExceptionType Property
OnExceptionAspectConfigurationAttribute Class See Also Send Feedback
Gets or sets the type of exceptions that are caught by this aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type ExceptionType { get; set; }

Remarks

If this property is null, any Exception shall be caught.

See Also

OnExceptionAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfiguration Class

OnMethodBoundaryAspectConfiguration Class
Members See Also Send Feedback
Configuration of the IOnMethodBoundaryAspect aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodBoundaryAspectConfiguration : AspectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Configuration..::.AspectConfiguration
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfiguration

See Also

OnMethodBoundaryAspectConfiguration Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfigurationAttribute
PostSharp.Aspects..::.OnMethodBoundaryAspect
Conceptual Documentation: Configuring Aspects


OnMethodBoundaryAspectConfiguration Members

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspectConfiguration Members
OnMethodBoundaryAspectConfiguration Class Constructors Properties See Also Send Feedback

The OnMethodBoundaryAspectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodBoundaryAspectConfiguration | Initializes a new instance of the OnMethodBoundaryAspectConfiguration class

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

OnMethodBoundaryAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfiguration Constructor

OnMethodBoundaryAspectConfiguration Constructor
OnMethodBoundaryAspectConfiguration Class See Also Send Feedback
Initializes a new instance of the OnMethodBoundaryAspectConfiguration class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodBoundaryAspectConfiguration()

See Also

OnMethodBoundaryAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfiguration Properties

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspectConfiguration Properties
OnMethodBoundaryAspectConfiguration Class See Also Send Feedback

The OnMethodBoundaryAspectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the aspect priority. Aspects with smaller priority are processed first. The default priority is zero. (Inherited from AspectConfiguration.)
Public property | Dependencies | Gets or sets the collection of dependencies. (Inherited from AspectConfiguration.)
Public property | SerializerType | Gets or sets the type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfiguration.)

See Also

OnMethodBoundaryAspectConfiguration Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfigurationAttribute Class

OnMethodBoundaryAspectConfigurationAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a class implementing IOnMethodBoundaryAspect, defines the configuration of that aspect.

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OnMethodBoundaryAspectConfigurationAttribute : AspectConfigurationAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfigurationAttribute

See Also

OnMethodBoundaryAspectConfigurationAttribute Members
PostSharp.Aspects.Configuration Namespace
PostSharp.Aspects.Configuration..::.OnMethodBoundaryAspectConfiguration
PostSharp.Aspects..::.OnMethodBoundaryAspect
Conceptual Documentation: Configuring Aspects


OnMethodBoundaryAspectConfigurationAttribute Members

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspectConfigurationAttribute Members
OnMethodBoundaryAspectConfigurationAttribute Class Constructors Methods Properties See Also Send Feedback

The OnMethodBoundaryAspectConfigurationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | OnMethodBoundaryAspectConfigurationAttribute | Initializes a new instance of the OnMethodBoundaryAspectConfigurationAttribute class

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

OnMethodBoundaryAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfigurationAttribute Constructor

OnMethodBoundaryAspectConfigurationAttribute Constructor
OnMethodBoundaryAspectConfigurationAttribute Class See Also Send Feedback
Initializes a new instance of the OnMethodBoundaryAspectConfigurationAttribute class

Namespace: PostSharp.Aspects.Configuration
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OnMethodBoundaryAspectConfigurationAttribute()

See Also

OnMethodBoundaryAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfigurationAttribute Methods

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspectConfigurationAttribute Methods
OnMethodBoundaryAspectConfigurationAttribute Class See Also Send Feedback

The OnMethodBoundaryAspectConfigurationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | GetAspectConfiguration | Gets the AspectConfiguration corresponding to the current custom attribute. (Inherited from AspectConfigurationAttribute.)

See Also

OnMethodBoundaryAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


OnMethodBoundaryAspectConfigurationAttribute Properties

[image]

PostSharp 2.0 Documentation
OnMethodBoundaryAspectConfigurationAttribute Properties
OnMethodBoundaryAspectConfigurationAttribute Class See Also Send Feedback

The OnMethodBoundaryAspectConfigurationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AspectPriority | Gets or sets the weaving priority of the aspect. (Inherited from AspectConfigurationAttribute.)
Public property | SerializerType | Gets or sets the Type of the serializer that will be used to configure the current aspect. (Inherited from AspectConfigurationAttribute.)

See Also

OnMethodBoundaryAspectConfigurationAttribute Class
PostSharp.Aspects.Configuration Namespace


PostSharp.Aspects.Dependencies Namespace

PostSharp.Aspects.Dependencies Namespace
Send Feedback
The PostSharp.Aspects.Dependencies namespace contains types and custom attributes that allow to define dependencies between aspects and advices, so that the aspect weaver behaves determistically even if the same element of code is the target of several aspects provided by multiple vendors.

Classes

 | Class | Description
Public class | AdviceDependencyAttribute | Specifies an aspect dependency matching an advice of the same aspect instance.
Public class | AspectDependencyAttribute | Base class for all custom attributes defining aspect dependencies. An aspect dependency determines the behavior of aspects or advices when used in conjunction with other aspects and advices. Aspect dependencies determine ordering, requirements, conflicts, and commutativity of aspects and advices.
Public class | AspectDependencyAttributeCollection | Collection of AspectDependencyAttribute.
Public class | AspectEffectDependencyAttribute | Specifies an aspect dependency matching aspects or advices having a given effect.
Public class | AspectRoleDependencyAttribute | Specifies an aspect dependency matching aspects or advices that are a part of a given role.
Public class | AspectTypeDependencyAttribute | Specifies an aspect dependency matching aspects of a specified type, and all its advices.
Public class | ProvideAspectRoleAttribute | Specifies that the aspect or aspect advice to which this custom attribute is applied is a part of a given role. This aspect or advice can then be matched by AspectRoleDependencyAttribute/
Public class | StandardEffects | List of standard effects.
Public class | StandardRoles | List of standard roles.
Public class | WaiveAspectEffectAttribute | Declares that the aspect class or advice to which this custom attribute is applied is exempt of a given effect.

Enumerations

 | Enumeration | Description
Public enumeration | AspectDependencyAction | Enumeration of the different kinds of relationships of specified by aspect dependencies.
Public enumeration | AspectDependencyPosition | Enumeration of the direction of the relationship specified by an aspect dependency.
Public enumeration | AspectDependencyTarget | Enumeration of targets (Default or Type) to which the aspect dependency apply.


AdviceDependencyAttribute Class

AdviceDependencyAttribute Class
Members See Also Send Feedback
Specifies an aspect dependency matching an advice of the same aspect instance.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AdviceDependencyAttribute : AspectDependencyAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AdviceDependencyAttribute

See Also

AdviceDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace
Conceptual Documentation: Configuring Aspects


AdviceDependencyAttribute Members

[image]

PostSharp 2.0 Documentation
AdviceDependencyAttribute Members
AdviceDependencyAttribute Class Constructors Properties See Also Send Feedback

The AdviceDependencyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AdviceDependencyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | AdviceMethodName | Gets the name of the method implementing the advice.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AdviceDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AdviceDependencyAttribute Constructor

[image]

PostSharp 2.0 Documentation
AdviceDependencyAttribute Constructor
AdviceDependencyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AdviceDependencyAttribute(AspectDependencyAction, String) | Initializes a new AdviceDependencyAttribute without specifying the position, implicitly set to Any.
Public method | AdviceDependencyAttribute(AspectDependencyAction, AspectDependencyPosition, String) | Initializes a new AdviceDependencyAttribute and specifies a position.

See Also

AdviceDependencyAttribute Class
AdviceDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace


AdviceDependencyAttribute Constructor (AspectDependencyAction, String)

AdviceDependencyAttribute Constructor (AspectDependencyAction, String)
AdviceDependencyAttribute Class See Also Send Feedback
Initializes a new AdviceDependencyAttribute without specifying the position, implicitly set to Any.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceDependencyAttribute(
    AspectDependencyAction action,
    string adviceMethodName
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
adviceMethodName
Type: System..::.String
Name of the advice method.

See Also

AdviceDependencyAttribute Class
AdviceDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AdviceDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)

AdviceDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)
AdviceDependencyAttribute Class See Also Send Feedback
Initializes a new AdviceDependencyAttribute and specifies a position.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceDependencyAttribute(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    string adviceMethodName
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
Dependency position.
adviceMethodName
Type: System..::.String
Name of the advice method.

See Also

AdviceDependencyAttribute Class
AdviceDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AdviceDependencyAttribute Properties

[image]

PostSharp 2.0 Documentation
AdviceDependencyAttribute Properties
AdviceDependencyAttribute Class See Also Send Feedback

The AdviceDependencyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | AdviceMethodName | Gets the name of the method implementing the advice.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AdviceDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AdviceMethodName Property

AdviceDependencyAttribute..::..AdviceMethodName Property
AdviceDependencyAttribute Class See Also Send Feedback
Gets the name of the method implementing the advice.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AdviceMethodName { get; private set; }

See Also

AdviceDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAction Enumeration

AspectDependencyAction Enumeration
See Also Send Feedback
Enumeration of the different kinds of relationships of specified by aspect dependencies.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum AspectDependencyAction

Members

Member name | Value | Description
None | 0 | The dependency is ignored.
Order | 1 | The dependency specifies an order relationship.
Require | 2 | The depedency specifies that the current aspect or advice requires another aspect or advice.
Conflict | 3 | The dependency specifies that the current aspect or advice conflicts with another aspect or advice.
Commute | 4 | The dependency specifies that the current aspect or advice commutes with another aspect or advice.

Remarks

The combined values of AspectDependencyAction and AspectDependencyPosition is interpreted as follows:

Action | Position | Description
Order | After | The current aspect or advice should be positioned after the other aspect or advice matched by the custom attribute.
Order | Before | The current aspect or advice should be positioned before the other aspect or advice matched by the custom attribute.
Require | Any | The current aspect or advice requires another aspect or advice matched by the custom attribute, at any position.
Require | After | The current aspect or advice requires another aspect or advice matched by the custom attribute positioned after the current one.
Require | Before | The current aspect or advice requires another aspect or advice matched by the custom attribute positioned before the current one.
Conflict | Any | The current aspect or advice conflicts with any aspect or advice matched by the custom attribute, at any position.
Conflict | After | The current aspect or advice conflicts with any aspect or advice matched by the custom attribute, if positioned after the current one.
Conflict | Before | The current aspect or advice conflicts with any aspect or advice matched by the custom attribute, if positioned before the current one.
Commute |  | The current aspect or advice commute with any other aspect or advice matched by the custom attribute.

See Also

PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttribute Class

AspectDependencyAttribute Class
Members See Also Send Feedback
Base class for all custom attributes defining aspect dependencies. An aspect dependency determines the behavior of aspects or advices when used in conjunction with other aspects and advices. Aspect dependencies determine ordering, requirements, conflicts, and commutativity of aspects and advices.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectDependencyAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AdviceDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectEffectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectRoleDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectTypeDependencyAttribute
PostSharp.Aspects.Dependencies..::.ProvideAspectRoleAttribute

See Also

AspectDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace
Conceptual Documentation: Configuring Aspects


AspectDependencyAttribute Members

[image]

PostSharp 2.0 Documentation
AspectDependencyAttribute Members
AspectDependencyAttribute Class Constructors Properties See Also Send Feedback

The AspectDependencyAttribute type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectDependencyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute).
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected.
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply.
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level.

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttribute Constructor

[image]

PostSharp 2.0 Documentation
AspectDependencyAttribute Constructor
AspectDependencyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AspectDependencyAttribute(AspectDependencyAction) | Initializes a new AspectDependencyAttribute without specifying the position, implicitly set to Any.
Protected method | AspectDependencyAttribute(AspectDependencyAction, AspectDependencyPosition) | Initializes a new AspectDependencyAttribute and specifies a position.

See Also

AspectDependencyAttribute Class
AspectDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttribute Constructor (AspectDependencyAction)

AspectDependencyAttribute Constructor (AspectDependencyAction)
AspectDependencyAttribute Class See Also Send Feedback
Initializes a new AspectDependencyAttribute without specifying the position, implicitly set to Any.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectDependencyAttribute(
    AspectDependencyAction action
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.

See Also

AspectDependencyAttribute Class
AspectDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition)

AspectDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition)
AspectDependencyAttribute Class See Also Send Feedback
Initializes a new AspectDependencyAttribute and specifies a position.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectDependencyAttribute(
    AspectDependencyAction action,
    AspectDependencyPosition position
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
Dependency position.

See Also

AspectDependencyAttribute Class
AspectDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttribute Properties

[image]

PostSharp 2.0 Documentation
AspectDependencyAttribute Properties
AspectDependencyAttribute Class See Also Send Feedback

The AspectDependencyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute).
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected.
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply.
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level.

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


Action Property

AspectDependencyAttribute..::..Action Property
AspectDependencyAttribute Class See Also Send Feedback
Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyAction Action { get; private set; }

Remarks

See documentation of AspectDependencyAction for a description of the meaning of combined Action and Position properties.

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


IsWarning Property

AspectDependencyAttribute..::..IsWarning Property
AspectDependencyAttribute Class See Also Send Feedback
If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsWarning { get; set; }

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


Position Property

AspectDependencyAttribute..::..Position Property
AspectDependencyAttribute Class See Also Send Feedback
Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyPosition Position { get; private set; }

Remarks

See documentation of AspectDependencyAction for a description of the meaning of combined Action and Position properties.

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


Target Property

AspectDependencyAttribute..::..Target Property
AspectDependencyAttribute Class See Also Send Feedback
Determines the target (Default or Type) to which the aspect dependency apply.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyTarget Target { get; set; }

Remarks

See the documentation of AspectDependencyTarget for details.

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


TargetType Property

AspectDependencyAttribute..::..TargetType Property
AspectDependencyAttribute Class See Also Send Feedback
Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type TargetType { get; set; }

See Also

AspectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttributeCollection Class

AspectDependencyAttributeCollection Class
Members See Also Send Feedback
Collection of AspectDependencyAttribute.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectDependencyAttributeCollection : Collection<AspectDependencyAttribute>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' AspectDependencyAttribute >)>)>
PostSharp.Aspects.Dependencies..::.AspectDependencyAttributeCollection

See Also

AspectDependencyAttributeCollection Members
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttributeCollection Members

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeCollection Members
AspectDependencyAttributeCollection Class Constructors See Also Send Feedback

The AspectDependencyAttributeCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AspectDependencyAttributeCollection | Initializes a new instance of the AspectDependencyAttributeCollection class

See Also

AspectDependencyAttributeCollection Class
PostSharp.Aspects.Dependencies Namespace


AspectDependencyAttributeCollection Constructor

AspectDependencyAttributeCollection Constructor
AspectDependencyAttributeCollection Class See Also Send Feedback
Initializes a new instance of the AspectDependencyAttributeCollection class

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyAttributeCollection()

See Also

AspectDependencyAttributeCollection Class
PostSharp.Aspects.Dependencies Namespace


AspectDependencyPosition Enumeration

AspectDependencyPosition Enumeration
See Also Send Feedback
Enumeration of the direction of the relationship specified by an aspect dependency.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum AspectDependencyPosition

Members

Member name | Value | Description
Any | 0 | Any order possible (or order not relevant).
Before | -1 | The current aspect or advice is positioned before the other aspect or handler.
After | 1 | The current aspect or advice is positioned after the other aspect or handler.

See Also

PostSharp.Aspects.Dependencies Namespace


AspectDependencyTarget Enumeration

AspectDependencyTarget Enumeration
See Also Send Feedback
Enumeration of targets (Default or Type) to which the aspect dependency apply.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum AspectDependencyTarget

Members

Member name | Value | Description
Default | 0 | Natural target of the aspect.
Type | 1 | Declaring type of the natural target of the aspect.

Remarks

This property is meaningful only for aspects that apply to type members. For aspects that apply to types, type-level and default-level dependencies are the same thing.

Member-level aspects may have semantics that actually apply at type level (for instance member introductions and imports). By setting the dependency target to Type, you can specify that the aspect dependency applies to type-level semantics. Otherwise, it will apply to member-level semantics.

See Also

PostSharp.Aspects.Dependencies Namespace


AspectEffectDependencyAttribute Class

AspectEffectDependencyAttribute Class
Members See Also Send Feedback
Specifies an aspect dependency matching aspects or advices having a given effect.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectEffectDependencyAttribute : AspectDependencyAttribute

Remarks

All aspects (except the ones that have an empty implementation) have an effect on the program execution. The current custom attribute allows to express dependencies to aspects according to their effect.

The list of standard effects is given in class StandardEffects. All advices have implicitly the effect Custom. Most advices also have the effect ChangeControlFlow, because they are able to modify the control flow (for instance, skip the execution of the intercepted method or throwing an exception). An aspect or advice can declare it does not have a given effect by using the WaiveAspectEffectAttribute custom attribute.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectEffectDependencyAttribute

See Also

AspectEffectDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace
PostSharp.Aspects.Dependencies..::.StandardEffects
PostSharp.Aspects.Dependencies..::.WaiveAspectEffectAttribute
Conceptual Documentation: Configuring Aspects


AspectEffectDependencyAttribute Members

[image]

PostSharp 2.0 Documentation
AspectEffectDependencyAttribute Members
AspectEffectDependencyAttribute Class Constructors Properties See Also Send Feedback

The AspectEffectDependencyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AspectEffectDependencyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | Effect | Gets the effect that the aspects or advices must have in order to match the current dependency.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectEffectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectEffectDependencyAttribute Constructor

[image]

PostSharp 2.0 Documentation
AspectEffectDependencyAttribute Constructor
AspectEffectDependencyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectEffectDependencyAttribute(AspectDependencyAction, String) | Initializes a new AspectEffectDependencyAttribute without specifying the position, implicitly set to Any.
Public method | AspectEffectDependencyAttribute(AspectDependencyAction, AspectDependencyPosition, String) | Initializes a new AspectEffectDependencyAttribute and specifies a position.

See Also

AspectEffectDependencyAttribute Class
AspectEffectDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace


AspectEffectDependencyAttribute Constructor (AspectDependencyAction, String)

AspectEffectDependencyAttribute Constructor (AspectDependencyAction, String)
AspectEffectDependencyAttribute Class See Also Send Feedback
Initializes a new AspectEffectDependencyAttribute without specifying the position, implicitly set to Any.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectEffectDependencyAttribute(
    AspectDependencyAction action,
    string effect
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
effect
Type: System..::.String
Effect (see StandardEffects).

See Also

AspectEffectDependencyAttribute Class
AspectEffectDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectEffectDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)

AspectEffectDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)
AspectEffectDependencyAttribute Class See Also Send Feedback
Initializes a new AspectEffectDependencyAttribute and specifies a position.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectEffectDependencyAttribute(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    string effect
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
Dependency position.
effect
Type: System..::.String
Effect (see StandardEffects).

See Also

AspectEffectDependencyAttribute Class
AspectEffectDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectEffectDependencyAttribute Properties

[image]

PostSharp 2.0 Documentation
AspectEffectDependencyAttribute Properties
AspectEffectDependencyAttribute Class See Also Send Feedback

The AspectEffectDependencyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | Effect | Gets the effect that the aspects or advices must have in order to match the current dependency.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectEffectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


Effect Property

AspectEffectDependencyAttribute..::..Effect Property
AspectEffectDependencyAttribute Class See Also Send Feedback
Gets the effect that the aspects or advices must have in order to match the current dependency.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Effect { get; private set; }

See Also

AspectEffectDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectRoleDependencyAttribute Class

AspectRoleDependencyAttribute Class
Members See Also Send Feedback
Specifies an aspect dependency matching aspects or advices that are a part of a given role.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectRoleDependencyAttribute : AspectDependencyAttribute

Remarks

A role describes what the aspect actually does. A list of standard roles is available on the class StandardRoles. Aspect vendors are encouraged to enroll their aspects in one of these roles whenever it makes sense, and to document the other roles they have used.

An aspect or advice can be enrolled in a role by using the ProvideAspectRoleAttribute custom attribute.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectRoleDependencyAttribute

See Also

AspectRoleDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace
PostSharp.Aspects.Dependencies..::.ProvideAspectRoleAttribute
PostSharp.Aspects.Dependencies..::.StandardRoles
Conceptual Documentation: Configuring Aspects


AspectRoleDependencyAttribute Members

[image]

PostSharp 2.0 Documentation
AspectRoleDependencyAttribute Members
AspectRoleDependencyAttribute Class Constructors Properties See Also Send Feedback

The AspectRoleDependencyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AspectRoleDependencyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Role | Gets the role that the aspects or advices must be a part of in order to match the current dependency.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectRoleDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectRoleDependencyAttribute Constructor

[image]

PostSharp 2.0 Documentation
AspectRoleDependencyAttribute Constructor
AspectRoleDependencyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectRoleDependencyAttribute(AspectDependencyAction, String) | Initializes a new AspectEffectDependencyAttribute without specifying the position, implicitly set to Any.
Public method | AspectRoleDependencyAttribute(AspectDependencyAction, AspectDependencyPosition, String) | Initializes a new AspectRoleDependencyAttribute and specifies a position.

See Also

AspectRoleDependencyAttribute Class
AspectRoleDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace


AspectRoleDependencyAttribute Constructor (AspectDependencyAction, String)

AspectRoleDependencyAttribute Constructor (AspectDependencyAction, String)
AspectRoleDependencyAttribute Class See Also Send Feedback
Initializes a new AspectEffectDependencyAttribute without specifying the position, implicitly set to Any.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectRoleDependencyAttribute(
    AspectDependencyAction action,
    string role
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
role
Type: System..::.String
Role.

See Also

AspectRoleDependencyAttribute Class
AspectRoleDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectRoleDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)

AspectRoleDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, String)
AspectRoleDependencyAttribute Class See Also Send Feedback
Initializes a new AspectRoleDependencyAttribute and specifies a position.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectRoleDependencyAttribute(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    string role
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
Dependency position.
role
Type: System..::.String
Role.

See Also

AspectRoleDependencyAttribute Class
AspectRoleDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectRoleDependencyAttribute Properties

[image]

PostSharp 2.0 Documentation
AspectRoleDependencyAttribute Properties
AspectRoleDependencyAttribute Class See Also Send Feedback

The AspectRoleDependencyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Role | Gets the role that the aspects or advices must be a part of in order to match the current dependency.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectRoleDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


Role Property

AspectRoleDependencyAttribute..::..Role Property
AspectRoleDependencyAttribute Class See Also Send Feedback
Gets the role that the aspects or advices must be a part of in order to match the current dependency.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Role { get; private set; }

See Also

AspectRoleDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectTypeDependencyAttribute Class

AspectTypeDependencyAttribute Class
Members See Also Send Feedback
Specifies an aspect dependency matching aspects of a specified type, and all its advices.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectTypeDependencyAttribute : AspectDependencyAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.AspectTypeDependencyAttribute

See Also

AspectTypeDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace
Conceptual Documentation: Configuring Aspects


AspectTypeDependencyAttribute Members

[image]

PostSharp 2.0 Documentation
AspectTypeDependencyAttribute Members
AspectTypeDependencyAttribute Class Constructors Properties See Also Send Feedback

The AspectTypeDependencyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AspectTypeDependencyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | AspectType | Gets the type from which the aspects should be derived in order to match the current dependency.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectTypeDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectTypeDependencyAttribute Constructor

[image]

PostSharp 2.0 Documentation
AspectTypeDependencyAttribute Constructor
AspectTypeDependencyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectTypeDependencyAttribute(AspectDependencyAction, Type) | Initializes a new AspectTypeDependencyAttribute without specifying the position, implicitly set to Any.
Public method | AspectTypeDependencyAttribute(AspectDependencyAction, AspectDependencyPosition, Type) | Initializes a new AspectTypeDependencyAttribute and specifies a position.

See Also

AspectTypeDependencyAttribute Class
AspectTypeDependencyAttribute Members
PostSharp.Aspects.Dependencies Namespace


AspectTypeDependencyAttribute Constructor (AspectDependencyAction, Type)

AspectTypeDependencyAttribute Constructor (AspectDependencyAction, Type)
AspectTypeDependencyAttribute Class See Also Send Feedback
Initializes a new AspectTypeDependencyAttribute without specifying the position, implicitly set to Any.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectTypeDependencyAttribute(
    AspectDependencyAction action,
    Type aspectType
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
aspectType
Type: System..::.Type
Aspect type (derived from IAspect).

See Also

AspectTypeDependencyAttribute Class
AspectTypeDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectTypeDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, Type)

AspectTypeDependencyAttribute Constructor (AspectDependencyAction, AspectDependencyPosition, Type)
AspectTypeDependencyAttribute Class See Also Send Feedback
Initializes a new AspectTypeDependencyAttribute and specifies a position.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectTypeDependencyAttribute(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    Type aspectType
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
Dependency action.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
Dependency position.
aspectType
Type: System..::.Type
Aspect type (derived from IAspect).

See Also

AspectTypeDependencyAttribute Class
AspectTypeDependencyAttribute Overload
PostSharp.Aspects.Dependencies Namespace


AspectTypeDependencyAttribute Properties

[image]

PostSharp 2.0 Documentation
AspectTypeDependencyAttribute Properties
AspectTypeDependencyAttribute Class See Also Send Feedback

The AspectTypeDependencyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | AspectType | Gets the type from which the aspects should be derived in order to match the current dependency.
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

AspectTypeDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


AspectType Property

AspectTypeDependencyAttribute..::..AspectType Property
AspectTypeDependencyAttribute Class See Also Send Feedback
Gets the type from which the aspects should be derived in order to match the current dependency.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type AspectType { get; private set; }

See Also

AspectTypeDependencyAttribute Class
PostSharp.Aspects.Dependencies Namespace


ProvideAspectRoleAttribute Class

ProvideAspectRoleAttribute Class
Members See Also Send Feedback
Specifies that the aspect or aspect advice to which this custom attribute is applied is a part of a given role. This aspect or advice can then be matched by AspectRoleDependencyAttribute/

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ProvideAspectRoleAttribute : AspectDependencyAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
PostSharp.Aspects.Dependencies..::.ProvideAspectRoleAttribute

See Also

ProvideAspectRoleAttribute Members
PostSharp.Aspects.Dependencies Namespace
PostSharp.Aspects.Dependencies..::.AspectRoleDependencyAttribute
Conceptual Documentation: Configuring Aspects


ProvideAspectRoleAttribute Members

[image]

PostSharp 2.0 Documentation
ProvideAspectRoleAttribute Members
ProvideAspectRoleAttribute Class Constructors Properties See Also Send Feedback

The ProvideAspectRoleAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ProvideAspectRoleAttribute | Initializes a new ProvideAspectRoleAttribute.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Role | Gets the role into which the aspect or advice to which this custom attribute is applied will be enrolled.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

ProvideAspectRoleAttribute Class
PostSharp.Aspects.Dependencies Namespace


ProvideAspectRoleAttribute Constructor

ProvideAspectRoleAttribute Constructor
ProvideAspectRoleAttribute Class See Also Send Feedback
Initializes a new ProvideAspectRoleAttribute.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProvideAspectRoleAttribute(
    string role
)

Parameters

role
Type: System..::.String
Role.

See Also

ProvideAspectRoleAttribute Class
PostSharp.Aspects.Dependencies Namespace


ProvideAspectRoleAttribute Properties

[image]

PostSharp 2.0 Documentation
ProvideAspectRoleAttribute Properties
ProvideAspectRoleAttribute Class See Also Send Feedback

The ProvideAspectRoleAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the dependency action, i.e. the kind of relationship specified by the dependency (Order, Require, Conflict, or Commute). (Inherited from AspectDependencyAttribute.)
Public property | IsWarning | If true, specifies that the constraint (of type Require or Conflict) should emit a warning instead of an error if not respected. (Inherited from AspectDependencyAttribute.)
Public property | Position | Gets the position of the current dependency, i.e. actually the position of the other aspect or advices with respect to the one related to this dependency. (Inherited from AspectDependencyAttribute.)
Public property | Role | Gets the role into which the aspect or advice to which this custom attribute is applied will be enrolled.
Public property | Target | Determines the target (Default or Type) to which the aspect dependency apply. (Inherited from AspectDependencyAttribute.)
Public property | TargetType | Aspect type to which this dependency applies. This property is required when the custom attribute is applied at assembly level. It is ignored when applied on class or method level. (Inherited from AspectDependencyAttribute.)

See Also

ProvideAspectRoleAttribute Class
PostSharp.Aspects.Dependencies Namespace


Role Property

ProvideAspectRoleAttribute..::..Role Property
ProvideAspectRoleAttribute Class See Also Send Feedback
Gets the role into which the aspect or advice to which this custom attribute is applied will be enrolled.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Role { get; private set; }

See Also

ProvideAspectRoleAttribute Class
PostSharp.Aspects.Dependencies Namespace


StandardEffects Class

StandardEffects Class
Members See Also Send Feedback
List of standard effects.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class StandardEffects

Remarks

See AspectEffectDependencyAttribute for a discussion of effects.

This list is not meant to be extended by vendors providing concrete aspects (implementing some business functionality). Roles should be used to categorized the business effect of concrete aspects. However, if you implement a new kind of abstract aspect (for instance member suppression), you may need to define new effects.

In that case, we at PostSharp encourage you contact us to define a new role string. If you define a new role string, we recommend you clearly define it so that users of your aspect can express dependencies with their own aspects, or third-party aspects.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Dependencies..::.StandardEffects

See Also

StandardEffects Members
PostSharp.Aspects.Dependencies Namespace
PostSharp.Aspects.Dependencies..::.AspectEffectDependencyAttribute
PostSharp.Aspects.Dependencies..::.WaiveAspectEffectAttribute
PostSharp.Aspects.Dependencies..::.StandardRoles
Conceptual Documentation: Configuring Aspects


StandardEffects Members

[image]

PostSharp 2.0 Documentation
StandardEffects Members
StandardEffects Class Methods Fields See Also Send Feedback

The StandardEffects type exposes the following members.

Methods

Name | Description
GetInterfaceIntroductionEffect | Gets a string representing the effect of introducing an interface into a type.
GetMemberImportEffect | Gets a string representing the effect of importing a member into from the target type into the aspect.
GetMemberIntroductionEffect | Gets a string representing the effect of introducing a member into a type.

Fields

Name | Description
ChangeControlFlow | Change the flow control (for instance by having the possibility to skip execution of an intercepted method).
Custom | Custom effect (implemented in an aspect advice). All advices have this effect by default, unless they are annotated by WaiveAspectEffectAttribute.
CustomAttributeIntroduction | Introduction of a custom attribute.
InterfaceIntroduction | Introduction of an interface.
MemberImport | Import of a type member.
MemberIntroduction | Introduction of a type member.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


StandardEffects Fields

[image]

PostSharp 2.0 Documentation
StandardEffects Fields
StandardEffects Class See Also Send Feedback

The StandardEffects type exposes the following members.

Fields

Name | Description
ChangeControlFlow | Change the flow control (for instance by having the possibility to skip execution of an intercepted method).
Custom | Custom effect (implemented in an aspect advice). All advices have this effect by default, unless they are annotated by WaiveAspectEffectAttribute.
CustomAttributeIntroduction | Introduction of a custom attribute.
InterfaceIntroduction | Introduction of an interface.
MemberImport | Import of a type member.
MemberIntroduction | Introduction of a type member.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


ChangeControlFlow Field

StandardEffects..::..ChangeControlFlow Field
StandardEffects Class See Also Send Feedback
Change the flow control (for instance by having the possibility to skip execution of an intercepted method).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string ChangeControlFlow

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


Custom Field

StandardEffects..::..Custom Field
StandardEffects Class See Also Send Feedback
Custom effect (implemented in an aspect advice). All advices have this effect by default, unless they are annotated by WaiveAspectEffectAttribute.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Custom

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


CustomAttributeIntroduction Field

StandardEffects..::..CustomAttributeIntroduction Field
StandardEffects Class See Also Send Feedback
Introduction of a custom attribute.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string CustomAttributeIntroduction

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


InterfaceIntroduction Field

StandardEffects..::..InterfaceIntroduction Field
StandardEffects Class See Also Send Feedback
Introduction of an interface.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string InterfaceIntroduction

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


MemberImport Field

StandardEffects..::..MemberImport Field
StandardEffects Class See Also Send Feedback
Import of a type member.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string MemberImport

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


MemberIntroduction Field

StandardEffects..::..MemberIntroduction Field
StandardEffects Class See Also Send Feedback
Introduction of a type member.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string MemberIntroduction

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


StandardEffects Methods

[image]

PostSharp 2.0 Documentation
StandardEffects Methods
StandardEffects Class See Also Send Feedback

The StandardEffects type exposes the following members.

Methods

Name | Description
GetInterfaceIntroductionEffect | Gets a string representing the effect of introducing an interface into a type.
GetMemberImportEffect | Gets a string representing the effect of importing a member into from the target type into the aspect.
GetMemberIntroductionEffect | Gets a string representing the effect of introducing a member into a type.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


GetInterfaceIntroductionEffect Method

StandardEffects..::..GetInterfaceIntroductionEffect Method
StandardEffects Class See Also Send Feedback
Gets a string representing the effect of introducing an interface into a type.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetInterfaceIntroductionEffect(
    string typeName
)

Parameters

typeName
Type: System..::.String
Name of the introduced interface.

Return Value

A string that, by convention, represents the introduction of an interface named typeName into a type.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


GetMemberImportEffect Method

StandardEffects..::..GetMemberImportEffect Method
StandardEffects Class See Also Send Feedback
Gets a string representing the effect of importing a member into from the target type into the aspect.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetMemberImportEffect(
    string memberName
)

Parameters

memberName
Type: System..::.String
Name of the imported member.

Return Value

A string that, by convention, represents the import of a member named memberName from the target type into the aspect.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


GetMemberIntroductionEffect Method

StandardEffects..::..GetMemberIntroductionEffect Method
StandardEffects Class See Also Send Feedback
Gets a string representing the effect of introducing a member into a type.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetMemberIntroductionEffect(
    string memberName
)

Parameters

memberName
Type: System..::.String
Name of the introduced member.

Return Value

A string that, by convention, represents the introduction of a member named memberName into a type.

See Also

StandardEffects Class
PostSharp.Aspects.Dependencies Namespace


StandardRoles Class

StandardRoles Class
Members See Also Send Feedback
List of standard roles.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class StandardRoles

Remarks

See AspectRoleDependencyAttribute for a discussion of aspect roles.

Roles are used to categorize aspects according to their function. This class defines standard names for the most commonly used aspect roles. If you are an aspect vendor, you are encouraged to enroll your aspects (using ProvideAspectRoleAttribute) into one of these roles.

If this list is not sufficient, we at PostSharp encourage you contact us to define a new role string. In any case, if you define a new role string, we recommend you clearly define it so that users of your aspect can express dependencies with their own aspects, or third-party aspects.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Dependencies..::.StandardRoles

See Also

StandardRoles Members
PostSharp.Aspects.Dependencies Namespace
Conceptual Documentation: Configuring Aspects


StandardRoles Members

[image]

PostSharp 2.0 Documentation
StandardRoles Members
StandardRoles Class Fields See Also Send Feedback

The StandardRoles type exposes the following members.

Fields

Name | Description
Caching | Caching.
DataBinding | Data binding (for instance implementation of INotifyPropertyChanged).
EventBroker | Event broker (a system role used internally by PostSharp to realize the OnInvokeHandler(EventInterceptionArgs) handler).
ExceptionHandling | Exception handling.
PerformanceInstrumentation | Performance instrumentation (for instance performance counters).
Persistence | Object persistence (for instance Object-Relational Mapper).
Security | Security enforcing (typically authorization).
Threading | Threading (locking).
Tracing | Tracing and logging.
TransactionHandling | Transaction handling.
Validation | Validation of field, property, or parameter value.

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


StandardRoles Fields

[image]

PostSharp 2.0 Documentation
StandardRoles Fields
StandardRoles Class See Also Send Feedback

The StandardRoles type exposes the following members.

Fields

Name | Description
Caching | Caching.
DataBinding | Data binding (for instance implementation of INotifyPropertyChanged).
EventBroker | Event broker (a system role used internally by PostSharp to realize the OnInvokeHandler(EventInterceptionArgs) handler).
ExceptionHandling | Exception handling.
PerformanceInstrumentation | Performance instrumentation (for instance performance counters).
Persistence | Object persistence (for instance Object-Relational Mapper).
Security | Security enforcing (typically authorization).
Threading | Threading (locking).
Tracing | Tracing and logging.
TransactionHandling | Transaction handling.
Validation | Validation of field, property, or parameter value.

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Caching Field

StandardRoles..::..Caching Field
StandardRoles Class See Also Send Feedback
Caching.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Caching

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


DataBinding Field

StandardRoles..::..DataBinding Field
StandardRoles Class See Also Send Feedback
Data binding (for instance implementation of INotifyPropertyChanged).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string DataBinding

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


EventBroker Field

StandardRoles..::..EventBroker Field
StandardRoles Class See Also Send Feedback
Event broker (a system role used internally by PostSharp to realize the OnInvokeHandler(EventInterceptionArgs) handler).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string EventBroker

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


ExceptionHandling Field

StandardRoles..::..ExceptionHandling Field
StandardRoles Class See Also Send Feedback
Exception handling.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string ExceptionHandling

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


PerformanceInstrumentation Field

StandardRoles..::..PerformanceInstrumentation Field
StandardRoles Class See Also Send Feedback
Performance instrumentation (for instance performance counters).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string PerformanceInstrumentation

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Persistence Field

StandardRoles..::..Persistence Field
StandardRoles Class See Also Send Feedback
Object persistence (for instance Object-Relational Mapper).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Persistence

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Security Field

StandardRoles..::..Security Field
StandardRoles Class See Also Send Feedback
Security enforcing (typically authorization).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Security

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Threading Field

StandardRoles..::..Threading Field
StandardRoles Class See Also Send Feedback
Threading (locking).

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Threading

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Tracing Field

StandardRoles..::..Tracing Field
StandardRoles Class See Also Send Feedback
Tracing and logging.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Tracing

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


TransactionHandling Field

StandardRoles..::..TransactionHandling Field
StandardRoles Class See Also Send Feedback
Transaction handling.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string TransactionHandling

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


Validation Field

StandardRoles..::..Validation Field
StandardRoles Class See Also Send Feedback
Validation of field, property, or parameter value.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Validation

See Also

StandardRoles Class
PostSharp.Aspects.Dependencies Namespace


WaiveAspectEffectAttribute Class

WaiveAspectEffectAttribute Class
Members See Also Send Feedback
Declares that the aspect class or advice to which this custom attribute is applied is exempt of a given effect.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class WaiveAspectEffectAttribute : Attribute

Remarks

See AspectEffectDependencyAttribute for details about effects.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Aspects.Dependencies..::.WaiveAspectEffectAttribute

See Also

WaiveAspectEffectAttribute Members
PostSharp.Aspects.Dependencies Namespace
Conceptual Documentation: Configuring Aspects


WaiveAspectEffectAttribute Members

[image]

PostSharp 2.0 Documentation
WaiveAspectEffectAttribute Members
WaiveAspectEffectAttribute Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | WaiveAspectEffectAttribute | Overloaded.

See Also

WaiveAspectEffectAttribute Class
PostSharp.Aspects.Dependencies Namespace


WaiveAspectEffectAttribute Constructor

[image]

PostSharp 2.0 Documentation
WaiveAspectEffectAttribute Constructor
WaiveAspectEffectAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaiveAspectEffectAttribute()()() | Initializes a new WaiveAspectEffectAttribute declaring that the aspect class or advice to which this custom attribute is applied has no effect at all.
Public method | WaiveAspectEffectAttribute(array<String>[]()[]) | Initializes a new WaiveAspectEffectAttribute declaring that the aspect class or advice to which this custom attribute is applied is exempt of the specified effects.

See Also

WaiveAspectEffectAttribute Class
WaiveAspectEffectAttribute Members
PostSharp.Aspects.Dependencies Namespace


WaiveAspectEffectAttribute Constructor

WaiveAspectEffectAttribute Constructor
WaiveAspectEffectAttribute Class See Also Send Feedback
Initializes a new WaiveAspectEffectAttribute declaring that the aspect class or advice to which this custom attribute is applied has no effect at all.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WaiveAspectEffectAttribute()

See Also

WaiveAspectEffectAttribute Class
WaiveAspectEffectAttribute Overload
PostSharp.Aspects.Dependencies Namespace


WaiveAspectEffectAttribute Constructor (String[])

WaiveAspectEffectAttribute Constructor (array<String>[]()[][])
WaiveAspectEffectAttribute Class See Also Send Feedback
Initializes a new WaiveAspectEffectAttribute declaring that the aspect class or advice to which this custom attribute is applied is exempt of the specified effects.

Namespace: PostSharp.Aspects.Dependencies
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WaiveAspectEffectAttribute(
    params string[] effects
)

Parameters

effects
Type: array< System..::.String >[]()[][]
List of effects of which the aspect class or advice to which this custom attribute is applied is guaranteed to be exempt.

See Also

WaiveAspectEffectAttribute Class
WaiveAspectEffectAttribute Overload
PostSharp.Aspects.Dependencies Namespace


PostSharp.Aspects.Serialization Namespace

PostSharp.Aspects.Serialization Namespace
Send Feedback
The PostSharp.Aspects.Serialization namespace contains types taking care of the process of serializing aspects at build time and deserializing them at run time.

Classes

 | Class | Description
Public class | AspectSerializer | Base class for Laos serializers, whose role is to serialize aspect instances at compile-time and deserialize them at runtime.
Public class | BinaryAspectSerializationBinder | Implementation of SerializationBinder used at runtime when aspect instances are deserialized. By overriding the default binder, you can resolve assembly names differently. This can be useful if assemblies have been renamed or merged between PostSharp run and execution
Public class | BinaryAspectSerializer | Implementation of AspectSerializer based on the BinaryFormatter provided by the full version of the .NET Framework.
Public class | MsilAspectSerializer | When used as a value of AspectConfigurationAttribute.SerializerType property, specifies that the aspect should not be serialized but should instead be constructed at runtime using MSIL instructions.
Public class | StateBag | Simple recursive structure of name-value collections used by the StateBagAspectSerializer to implement portable serialization.
Public class | StateBagAspectSerializer | Trivial serializer for use with light editions of the .NET Framework (Compact Framework, Silverlight). Aspects should implement the IStateBagSerializable interface and should have a parameterless constructor. This constructor is used during deserialization.
Public class | StateBagAspectSerializerException | Exception thrown by the StateBagAspectSerializer.
Public class | XmlAspectSerializer | Implementation of AspectSerializer based on the XmlSerializer provided by the .NET Framework.

Interfaces

 | Interface | Description
Public interface | IStateBagSerializable | Interface to be implemented by classes that should be serializable using a StateBagAspectSerializer. These classes should also implement a default (parameterless) constructor.


AspectSerializer Class

AspectSerializer Class
Members See Also Send Feedback
Base class for Laos serializers, whose role is to serialize aspect instances at compile-time and deserialize them at runtime.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectSerializer

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.AspectSerializer
PostSharp.Aspects.Serialization..::.BinaryAspectSerializer
PostSharp.Aspects.Serialization..::.MsilAspectSerializer
PostSharp.Aspects.Serialization..::.StateBagAspectSerializer
PostSharp.Aspects.Serialization..::.XmlAspectSerializer

See Also

AspectSerializer Members
PostSharp.Aspects.Serialization Namespace


AspectSerializer Members

[image]

PostSharp 2.0 Documentation
AspectSerializer Members
AspectSerializer Class Constructors Methods See Also Send Feedback

The AspectSerializer type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectSerializer | Initializes a new instance of the AspectSerializer class

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream.

See Also

AspectSerializer Class
PostSharp.Aspects.Serialization Namespace


AspectSerializer Constructor

AspectSerializer Constructor
AspectSerializer Class See Also Send Feedback
Initializes a new instance of the AspectSerializer class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectSerializer()

See Also

AspectSerializer Class
PostSharp.Aspects.Serialization Namespace


AspectSerializer Methods

[image]

PostSharp 2.0 Documentation
AspectSerializer Methods
AspectSerializer Class See Also Send Feedback

The AspectSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream.

See Also

AspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

[image]

PostSharp 2.0 Documentation
AspectSerializer..::..Deserialize Method
AspectSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize(Stream) | Deserializes a stream into an array if aspects.
Public method | Deserialize(Assembly, String) | Deserializes aspects contained in a managed resource of an assembly.

See Also

AspectSerializer Class
AspectSerializer Members
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Stream)

AspectSerializer..::..Deserialize Method (Stream)
AspectSerializer Class See Also Send Feedback
Deserializes a stream into an array if aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IAspect[] Deserialize(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream containing serialized aspects.

Return Value

An array of aspects.

Remarks

The implementation is not allowed to change the order or array elements.

See Also

AspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Assembly, String)

AspectSerializer..::..Deserialize Method (Assembly, String)
AspectSerializer Class See Also Send Feedback
Deserializes aspects contained in a managed resource of an assembly.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAspect[] Deserialize(
    Assembly assembly,
    string resourceName
)

Parameters

assembly
Type: System.Reflection..::.Assembly
Assembly containing the serialized aspects.
resourceName
Type: System..::.String
Name of the managed resources into which aspects have been serialized.

Return Value

An array of aspects.

See Also

AspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Serialize Method

AspectSerializer..::..Serialize Method
AspectSerializer Class See Also Send Feedback
Serializes an array of aspects into a stream.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void Serialize(
    IAspect[] aspects,
    Stream stream
)

Parameters

aspects
Type: array< PostSharp.Aspects..::.IAspect >[]()[][]
Array of aspects to be serialized.
stream
Type: System.IO..::.Stream
Stream into which aspects have to be serialized.

See Also

AspectSerializer Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializationBinder Class

BinaryAspectSerializationBinder Class
Members See Also Send Feedback
Implementation of SerializationBinder used at runtime when aspect instances are deserialized. By overriding the default binder, you can resolve assembly names differently. This can be useful if assemblies have been renamed or merged between PostSharp run and execution

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class BinaryAspectSerializationBinder : SerializationBinder

Inheritance Hierarchy

System..::.Object
System.Runtime.Serialization..::.SerializationBinder
PostSharp.Aspects.Serialization..::.BinaryAspectSerializationBinder

See Also

BinaryAspectSerializationBinder Members
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializationBinder Members

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializationBinder Members
BinaryAspectSerializationBinder Class Constructors Methods See Also Send Feedback

The BinaryAspectSerializationBinder type exposes the following members.

Constructors

 | Name | Description
Public method | BinaryAspectSerializationBinder | Initializes a new instance of the BinaryAspectSerializationBinder class

Methods

 | Name | Description
Public method | BindToType | When overridden in a derived class, controls the binding of a serialized object to a type. (Overrides SerializationBinder..::.BindToType(String, String).)
Public method | Retarget | Retarget an assembly name to a new one.

See Also

BinaryAspectSerializationBinder Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializationBinder Constructor

BinaryAspectSerializationBinder Constructor
BinaryAspectSerializationBinder Class See Also Send Feedback
Initializes a new instance of the BinaryAspectSerializationBinder class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BinaryAspectSerializationBinder()

See Also

BinaryAspectSerializationBinder Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializationBinder Methods

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializationBinder Methods
BinaryAspectSerializationBinder Class See Also Send Feedback

The BinaryAspectSerializationBinder type exposes the following members.

Methods

 | Name | Description
Public method | BindToType | When overridden in a derived class, controls the binding of a serialized object to a type. (Overrides SerializationBinder..::.BindToType(String, String).)
Public method | Retarget | Retarget an assembly name to a new one.

See Also

BinaryAspectSerializationBinder Class
PostSharp.Aspects.Serialization Namespace


BindToType Method

BinaryAspectSerializationBinder..::..BindToType Method
BinaryAspectSerializationBinder Class See Also Send Feedback
When overridden in a derived class, controls the binding of a serialized object to a type.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type BindToType(
    string assemblyName,
    string typeName
)

Parameters

assemblyName
Type: System..::.String
Specifies the Assembly name of the serialized object.
typeName
Type: System..::.String
Specifies the Type name of the serialized object.

Return Value

The type of the object the formatter creates a new instance of.

See Also

BinaryAspectSerializationBinder Class
PostSharp.Aspects.Serialization Namespace


Retarget Method

BinaryAspectSerializationBinder..::..Retarget Method
BinaryAspectSerializationBinder Class See Also Send Feedback
Retarget an assembly name to a new one.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Retarget(
    string oldAssemblyName,
    string newAssemblyName
)

Parameters

oldAssemblyName
Type: System..::.String
Old assembly name (in short form only).
newAssemblyName
Type: System..::.String
New assembly name (in short or full form).

See Also

BinaryAspectSerializationBinder Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializer Class

BinaryAspectSerializer Class
Members See Also Send Feedback
Implementation of AspectSerializer based on the BinaryFormatter provided by the full version of the .NET Framework.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class BinaryAspectSerializer : AspectSerializer

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.AspectSerializer
PostSharp.Aspects.Serialization..::.BinaryAspectSerializer

See Also

BinaryAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializer Members

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializer Members
BinaryAspectSerializer Class Constructors Methods Properties See Also Send Feedback

The BinaryAspectSerializer type exposes the following members.

Constructors

 | Name | Description
Public method | BinaryAspectSerializer | Initializes a new instance of the BinaryAspectSerializer class

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

Properties

Name | Description
Binder | Gets or sets the SerializationBinder used to deserialize aspects.
SurrogateSelector | Gets or sets the SurrogateSelector used to deserialize aspects.

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializer Constructor

BinaryAspectSerializer Constructor
BinaryAspectSerializer Class See Also Send Feedback
Initializes a new instance of the BinaryAspectSerializer class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BinaryAspectSerializer()

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializer Methods

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializer Methods
BinaryAspectSerializer Class See Also Send Feedback

The BinaryAspectSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializer..::..Deserialize Method
BinaryAspectSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize(Stream) | Deserializes a stream into an array if aspects. (Overrides AspectSerializer..::.Deserialize(Stream).)
Public method | Deserialize(Assembly, String) | Deserializes aspects contained in a managed resource of an assembly. (Inherited from AspectSerializer.)

See Also

BinaryAspectSerializer Class
BinaryAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Stream)

BinaryAspectSerializer..::..Deserialize Method (Stream)
BinaryAspectSerializer Class See Also Send Feedback
Deserializes a stream into an array if aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAspect[] Deserialize(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream containing serialized aspects.

Return Value

An array of aspects.

Remarks

The implementation is not allowed to change the order or array elements.

See Also

BinaryAspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Serialize Method

BinaryAspectSerializer..::..Serialize Method
BinaryAspectSerializer Class See Also Send Feedback
Serializes an array of aspects into a stream.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Serialize(
    IAspect[] aspects,
    Stream stream
)

Parameters

aspects
Type: array< PostSharp.Aspects..::.IAspect >[]()[][]
Array of aspects to be serialized.
stream
Type: System.IO..::.Stream
Stream into which aspects have to be serialized.

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


BinaryAspectSerializer Properties

[image]

PostSharp 2.0 Documentation
BinaryAspectSerializer Properties
BinaryAspectSerializer Class See Also Send Feedback

The BinaryAspectSerializer type exposes the following members.

Properties

Name | Description
Binder | Gets or sets the SerializationBinder used to deserialize aspects.
SurrogateSelector | Gets or sets the SurrogateSelector used to deserialize aspects.

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Binder Property

BinaryAspectSerializer..::..Binder Property
BinaryAspectSerializer Class See Also Send Feedback
Gets or sets the SerializationBinder used to deserialize aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializationBinder Binder { get; set; }

Field Value

A SerializationBinder, or null to use the default one. By default, BinaryAspectSerializationBinder is used.

Remarks

You should set this property before the first aspect is deserialized; that is, before the static constructor of the first enhanced type is invoked.

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


SurrogateSelector Property

BinaryAspectSerializer..::..SurrogateSelector Property
BinaryAspectSerializer Class See Also Send Feedback
Gets or sets the SurrogateSelector used to deserialize aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SurrogateSelector SurrogateSelector { get; set; }

Remarks

Developers may provide their own SurrogateSelector, provided that they put the old selector in the chain.

See Also

BinaryAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


IStateBagSerializable Interface

IStateBagSerializable Interface
Members See Also Send Feedback
Interface to be implemented by classes that should be serializable using a StateBagAspectSerializer. These classes should also implement a default (parameterless) constructor.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IStateBagSerializable

See Also

IStateBagSerializable Members
PostSharp.Aspects.Serialization Namespace


IStateBagSerializable Members

[image]

PostSharp 2.0 Documentation
IStateBagSerializable Members
IStateBagSerializable Interface Methods See Also Send Feedback

The IStateBagSerializable type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserialized the current object from a StateBag.
Public method | Serialize | Serializes the current object into a StateBag/

See Also

IStateBagSerializable Interface
PostSharp.Aspects.Serialization Namespace


IStateBagSerializable Methods

[image]

PostSharp 2.0 Documentation
IStateBagSerializable Methods
IStateBagSerializable Interface See Also Send Feedback

The IStateBagSerializable type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserialized the current object from a StateBag.
Public method | Serialize | Serializes the current object into a StateBag/

See Also

IStateBagSerializable Interface
PostSharp.Aspects.Serialization Namespace


Deserialize Method

IStateBagSerializable..::..Deserialize Method
IStateBagSerializable Interface See Also Send Feedback
Deserialized the current object from a StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Deserialize(
    StateBag stateBag
)

Parameters

stateBag
Type: PostSharp.Aspects.Serialization..::.StateBag
The StateBag into which the object was previously serialized, and from which it should be deserialized.

Remarks

This method is called during deserialization just after the default (parameterless) constructor has been invoked.

See Also

IStateBagSerializable Interface
PostSharp.Aspects.Serialization Namespace


Serialize Method

IStateBagSerializable..::..Serialize Method
IStateBagSerializable Interface See Also Send Feedback
Serializes the current object into a StateBag/

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Serialize(
    StateBag stateBag
)

Parameters

stateBag
Type: PostSharp.Aspects.Serialization..::.StateBag
StateBag into which the current object has to be saved.

See Also

IStateBagSerializable Interface
PostSharp.Aspects.Serialization Namespace


MsilAspectSerializer Class

MsilAspectSerializer Class
Members See Also Send Feedback
When used as a value of AspectConfigurationAttribute.SerializerType property, specifies that the aspect should not be serialized but should instead be constructed at runtime using MSIL instructions.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MsilAspectSerializer : AspectSerializer

Remarks

This class is not a serializer. When you use MSIL aspect construction, the aspect is built at runtime just as normal custom attributes, and any change made at build time is lost.

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.AspectSerializer
PostSharp.Aspects.Serialization..::.MsilAspectSerializer

See Also

MsilAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


MsilAspectSerializer Members

[image]

PostSharp 2.0 Documentation
MsilAspectSerializer Members
MsilAspectSerializer Class Constructors Methods See Also Send Feedback

The MsilAspectSerializer type exposes the following members.

Constructors

 | Name | Description
Public method | MsilAspectSerializer | Initializes a new instance of the MsilAspectSerializer class

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

MsilAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


MsilAspectSerializer Constructor

MsilAspectSerializer Constructor
MsilAspectSerializer Class See Also Send Feedback
Initializes a new instance of the MsilAspectSerializer class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MsilAspectSerializer()

See Also

MsilAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


MsilAspectSerializer Methods

[image]

PostSharp 2.0 Documentation
MsilAspectSerializer Methods
MsilAspectSerializer Class See Also Send Feedback

The MsilAspectSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

MsilAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

[image]

PostSharp 2.0 Documentation
MsilAspectSerializer..::..Deserialize Method
MsilAspectSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize(Stream) | Deserializes a stream into an array if aspects. (Overrides AspectSerializer..::.Deserialize(Stream).)
Public method | Deserialize(Assembly, String) | Deserializes aspects contained in a managed resource of an assembly. (Inherited from AspectSerializer.)

See Also

MsilAspectSerializer Class
MsilAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Stream)

MsilAspectSerializer..::..Deserialize Method (Stream)
MsilAspectSerializer Class See Also Send Feedback
Deserializes a stream into an array if aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAspect[] Deserialize(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream containing serialized aspects.

Return Value

An array of aspects.

Remarks

The implementation is not allowed to change the order or array elements.

See Also

MsilAspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Serialize Method

MsilAspectSerializer..::..Serialize Method
MsilAspectSerializer Class See Also Send Feedback
Serializes an array of aspects into a stream.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Serialize(
    IAspect[] aspects,
    Stream stream
)

Parameters

aspects
Type: array< PostSharp.Aspects..::.IAspect >[]()[][]
Array of aspects to be serialized.
stream
Type: System.IO..::.Stream
Stream into which aspects have to be serialized.

See Also

MsilAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


StateBag Class

StateBag Class
Members See Also Send Feedback
Simple recursive structure of name-value collections used by the StateBagAspectSerializer to implement portable serialization.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class StateBag

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.StateBag

See Also

StateBag Members
PostSharp.Aspects.Serialization Namespace


StateBag Members

[image]

PostSharp 2.0 Documentation
StateBag Members
StateBag Class Constructors Methods Properties See Also Send Feedback

The StateBag type exposes the following members.

Constructors

 | Name | Description
Public method | StateBag | Initializes a new StateBag.

Methods

 | Name | Description
Public method | CreateBag | Create a child StateBag and assign it a name.
 | Deserialize | Deserializes a stream (given a BinaryReader) into a StateBag.
Public method | GetBag | Gets a child StateBag.
Public method | GetValue | Gets a value of the current StateBag.
Public method | Serialize | Serializes the current StateBag into a BinaryWriter.
Public method | SetBag | Sets a child StateBag to the StateBag obtained by deserializing an object.
Public method | SetValue | Sets a value in the current StateBag.

Properties

 | Name | Description
Public property | Item | Gets or sets a value in the current StateBag.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


StateBag Constructor

StateBag Constructor
StateBag Class See Also Send Feedback
Initializes a new StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBag()

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


StateBag Methods

[image]

PostSharp 2.0 Documentation
StateBag Methods
StateBag Class See Also Send Feedback

The StateBag type exposes the following members.

Methods

 | Name | Description
Public method | CreateBag | Create a child StateBag and assign it a name.
 | Deserialize | Deserializes a stream (given a BinaryReader) into a StateBag.
Public method | GetBag | Gets a child StateBag.
Public method | GetValue | Gets a value of the current StateBag.
Public method | Serialize | Serializes the current StateBag into a BinaryWriter.
Public method | SetBag | Sets a child StateBag to the StateBag obtained by deserializing an object.
Public method | SetValue | Sets a value in the current StateBag.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


CreateBag Method

StateBag..::..CreateBag Method
StateBag Class See Also Send Feedback
Create a child StateBag and assign it a name.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBag CreateBag(
    string name
)

Parameters

name
Type: System..::.String
Name of the child bag.

Return Value

The new StateBag.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

StateBag..::..Deserialize Method
StateBag Class See Also Send Feedback
Deserializes a stream (given a BinaryReader) into a StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static StateBag Deserialize(
    BinaryReader reader
)

Parameters

reader
Type: System.IO..::.BinaryReader
A BinaryReader.

Return Value

The StateBag built from reader.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


GetBag Method

StateBag..::..GetBag Method
StateBag Class See Also Send Feedback
Gets a child StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBag GetBag(
    string name
)

Parameters

name
Type: System..::.String
Name of the child StateBag.

Return Value

The child StateBag named name, or null if there is no child StateBag of this name.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


GetValue Method

StateBag..::..GetValue Method
StateBag Class See Also Send Feedback
Gets a value of the current StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetValue(
    string name
)

Parameters

name
Type: System..::.String
Name of the requested value.

Return Value

The value named name, or null if the StateBag does not contain this value.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


Serialize Method

StateBag..::..Serialize Method
StateBag Class See Also Send Feedback
Serializes the current StateBag into a BinaryWriter.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Serialize(
    BinaryWriter writer
)

Parameters

writer
Type: System.IO..::.BinaryWriter
A BinaryWriter.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


SetBag Method

StateBag..::..SetBag Method
StateBag Class See Also Send Feedback
Sets a child StateBag to the StateBag obtained by deserializing an object.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetBag(
    string name,
    IStateBagSerializable obj
)

Parameters

name
Type: System..::.String
Name of the child StateBag in the current StateBag.
obj
Type: PostSharp.Aspects.Serialization..::.IStateBagSerializable
Object to deserialize.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


SetValue Method

StateBag..::..SetValue Method
StateBag Class See Also Send Feedback
Sets a value in the current StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetValue(
    string name,
    string value
)

Parameters

name
Type: System..::.String
Item name.
value
Type: System..::.String
Item value.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


StateBag Properties

[image]

PostSharp 2.0 Documentation
StateBag Properties
StateBag Class See Also Send Feedback

The StateBag type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets a value in the current StateBag.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


Item Property

StateBag..::..Item Property
StateBag Class See Also Send Feedback
Gets or sets a value in the current StateBag.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Item[
    string name
] { get; set; }

Parameters

name
Type: System..::.String
Value name.

Return Value

The value named name, or null if the current StateBag does not contain any value named name.

See Also

StateBag Class
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializer Class

StateBagAspectSerializer Class
Members See Also Send Feedback
Trivial serializer for use with light editions of the .NET Framework (Compact Framework, Silverlight). Aspects should implement the IStateBagSerializable interface and should have a parameterless constructor. This constructor is used during deserialization.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class StateBagAspectSerializer : AspectSerializer

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.AspectSerializer
PostSharp.Aspects.Serialization..::.StateBagAspectSerializer

See Also

StateBagAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializer Members

[image]

PostSharp 2.0 Documentation
StateBagAspectSerializer Members
StateBagAspectSerializer Class Constructors Methods See Also Send Feedback

The StateBagAspectSerializer type exposes the following members.

Constructors

 | Name | Description
Public method | StateBagAspectSerializer | Initializes a new instance of the StateBagAspectSerializer class

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

StateBagAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializer Constructor

StateBagAspectSerializer Constructor
StateBagAspectSerializer Class See Also Send Feedback
Initializes a new instance of the StateBagAspectSerializer class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBagAspectSerializer()

See Also

StateBagAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializer Methods

[image]

PostSharp 2.0 Documentation
StateBagAspectSerializer Methods
StateBagAspectSerializer Class See Also Send Feedback

The StateBagAspectSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

StateBagAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

[image]

PostSharp 2.0 Documentation
StateBagAspectSerializer..::..Deserialize Method
StateBagAspectSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize(Stream) | Deserializes a stream into an array if aspects. (Overrides AspectSerializer..::.Deserialize(Stream).)
Public method | Deserialize(Assembly, String) | Deserializes aspects contained in a managed resource of an assembly. (Inherited from AspectSerializer.)

See Also

StateBagAspectSerializer Class
StateBagAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Stream)

StateBagAspectSerializer..::..Deserialize Method (Stream)
StateBagAspectSerializer Class See Also Send Feedback
Deserializes a stream into an array if aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAspect[] Deserialize(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream containing serialized aspects.

Return Value

An array of aspects.

Remarks

The implementation is not allowed to change the order or array elements.

See Also

StateBagAspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Serialize Method

StateBagAspectSerializer..::..Serialize Method
StateBagAspectSerializer Class See Also Send Feedback
Serializes an array of aspects into a stream.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Serialize(
    IAspect[] aspects,
    Stream stream
)

Parameters

aspects
Type: array< PostSharp.Aspects..::.IAspect >[]()[][]
Array of aspects to be serialized.
stream
Type: System.IO..::.Stream
Stream into which aspects have to be serialized.

See Also

StateBagAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Class

StateBagAspectSerializerException Class
Members See Also Send Feedback
Exception thrown by the StateBagAspectSerializer.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class StateBagAspectSerializerException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Aspects.Serialization..::.StateBagAspectSerializerException

See Also

StateBagAspectSerializerException Members
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Members

[image]

PostSharp 2.0 Documentation
StateBagAspectSerializerException Members
StateBagAspectSerializerException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | StateBagAspectSerializerException | Overloaded.

See Also

StateBagAspectSerializerException Class
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Constructor

[image]

PostSharp 2.0 Documentation
StateBagAspectSerializerException Constructor
StateBagAspectSerializerException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StateBagAspectSerializerException()()() | Initializes a new StateBagAspectSerializerException with the default message.
Public method | StateBagAspectSerializerException(String) | Initializes a new StateBagAspectSerializerException with a given message.
Protected method | StateBagAspectSerializerException(SerializationInfo, StreamingContext) | Deserializes a StateBagAspectSerializerException.
Public method | StateBagAspectSerializerException(String, Exception) | Initializes a new StateBagAspectSerializerException with a given message and an inner exception.

See Also

StateBagAspectSerializerException Class
StateBagAspectSerializerException Members
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Constructor

StateBagAspectSerializerException Constructor
StateBagAspectSerializerException Class See Also Send Feedback
Initializes a new StateBagAspectSerializerException with the default message.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBagAspectSerializerException()

See Also

StateBagAspectSerializerException Class
StateBagAspectSerializerException Overload
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Constructor (String)

StateBagAspectSerializerException Constructor (String)
StateBagAspectSerializerException Class See Also Send Feedback
Initializes a new StateBagAspectSerializerException with a given message.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBagAspectSerializerException(
    string message
)

Parameters

message
Type: System..::.String
Error message.

See Also

StateBagAspectSerializerException Class
StateBagAspectSerializerException Overload
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Constructor (SerializationInfo, StreamingContext)

StateBagAspectSerializerException Constructor (SerializationInfo, StreamingContext)
StateBagAspectSerializerException Class See Also Send Feedback
Deserializes a StateBagAspectSerializerException.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected StateBagAspectSerializerException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming context.

See Also

StateBagAspectSerializerException Class
StateBagAspectSerializerException Overload
PostSharp.Aspects.Serialization Namespace


StateBagAspectSerializerException Constructor (String, Exception)

StateBagAspectSerializerException Constructor (String, Exception)
StateBagAspectSerializerException Class See Also Send Feedback
Initializes a new StateBagAspectSerializerException with a given message and an inner exception.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StateBagAspectSerializerException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Error message.
inner
Type: System..::.Exception
Inner exception.

See Also

StateBagAspectSerializerException Class
StateBagAspectSerializerException Overload
PostSharp.Aspects.Serialization Namespace


XmlAspectSerializer Class

XmlAspectSerializer Class
Members See Also Send Feedback
Implementation of AspectSerializer based on the XmlSerializer provided by the .NET Framework.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class XmlAspectSerializer : AspectSerializer

Inheritance Hierarchy

System..::.Object
PostSharp.Aspects.Serialization..::.AspectSerializer
PostSharp.Aspects.Serialization..::.XmlAspectSerializer

See Also

XmlAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


XmlAspectSerializer Members

[image]

PostSharp 2.0 Documentation
XmlAspectSerializer Members
XmlAspectSerializer Class Constructors Methods See Also Send Feedback

The XmlAspectSerializer type exposes the following members.

Constructors

 | Name | Description
Public method | XmlAspectSerializer | Initializes a new instance of the XmlAspectSerializer class

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

XmlAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


XmlAspectSerializer Constructor

XmlAspectSerializer Constructor
XmlAspectSerializer Class See Also Send Feedback
Initializes a new instance of the XmlAspectSerializer class

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public XmlAspectSerializer()

See Also

XmlAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


XmlAspectSerializer Methods

[image]

PostSharp 2.0 Documentation
XmlAspectSerializer Methods
XmlAspectSerializer Class See Also Send Feedback

The XmlAspectSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Overloaded.
Public method | Serialize | Serializes an array of aspects into a stream. (Overrides AspectSerializer..::.Serialize(array<IAspect>[]()[], Stream).)

See Also

XmlAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


Deserialize Method

[image]

PostSharp 2.0 Documentation
XmlAspectSerializer..::..Deserialize Method
XmlAspectSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deserialize(Stream) | Deserializes a stream into an array if aspects. (Overrides AspectSerializer..::.Deserialize(Stream).)
Public method | Deserialize(Assembly, String) | Deserializes aspects contained in a managed resource of an assembly. (Inherited from AspectSerializer.)

See Also

XmlAspectSerializer Class
XmlAspectSerializer Members
PostSharp.Aspects.Serialization Namespace


Deserialize Method (Stream)

XmlAspectSerializer..::..Deserialize Method (Stream)
XmlAspectSerializer Class See Also Send Feedback
Deserializes a stream into an array if aspects.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAspect[] Deserialize(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream containing serialized aspects.

Return Value

An array of aspects.

Remarks

The implementation is not allowed to change the order or array elements.

See Also

XmlAspectSerializer Class
Deserialize Overload
PostSharp.Aspects.Serialization Namespace


Serialize Method

XmlAspectSerializer..::..Serialize Method
XmlAspectSerializer Class See Also Send Feedback
Serializes an array of aspects into a stream.

Namespace: PostSharp.Aspects.Serialization
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Serialize(
    IAspect[] aspects,
    Stream stream
)

Parameters

aspects
Type: array< PostSharp.Aspects..::.IAspect >[]()[][]
Array of aspects to be serialized.
stream
Type: System.IO..::.Stream
Stream into which aspects have to be serialized.

See Also

XmlAspectSerializer Class
PostSharp.Aspects.Serialization Namespace


PostSharp.Extensibility Namespace

PostSharp.Extensibility Namespace
Send Feedback
The PostSharp.Extensibility namespace defines the semantics of the attribute multicasting mechanism and exposes other types that allow user code to interact with the PostSharp,platform.

Classes

 | Class | Description
Public class | AssemblyIdAttribute | Assigns a unique identifier to an assembly. This assembly identifier is used to generate unique attribute identifiers.
Public class | DisablePostSharpMessageAttribute | Custom attribute that, when applied on an assembly, means that a given message should be disabled during the current PostSharp session.
Public class | EnhancedByPostSharpAttribute | Custom attribute added to the assembly manifest of modules processed by PostSharp.
Public class | EscalatePostSharpMessageAttribute | Custom attribute that, when applied on an assembly, means that a given message should be escalated to an error during the current PostSharp session.
Public class | FrameworkVariants | Defines constants identifying the different variants of the .NET Framework (Full, Compact, Silverlight).
Public class | HasInheritedAttributeAttribute | Internal Only. Custom attribute used internally by PostSharp to mark elements having inherited custom attributes. This custom attribute should not be used in custom code, otherwise PostSharp may not work properly.
Public class | ImplementationBoundAttributeAttribute | Custom attribute meaning that custom attributes of a given type are bound to the implementation, not to the semantics.
Public class | InvalidAnnotationException | Exception thrown at build time by implementation of CompileTimeValidate(Object) when an annotation is invalid.
Public class | Message | Encapsulates a message (error, warning, info, ...).
Public class | MessageException | Exception embedding a Message.
Public class | MessageSource | Provides commodity methods to work with an IMessageSink.
Public class | MulticastAttribute | Custom attribute that can be applied to multiple elements using wildcards.
Public class | MulticastAttributeUsageAttribute | Custom attribute that determines the usage of a MulticastAttribute.
Public class | PostSharpEnvironment | Provides access to the current PostSharp environment (IPostSharpEnvironment).
Public class | PostSharpTrace | Provides tracing functionality. An instance of the PostSharpTrace type implements a trace sink.
Public class | RequirePostSharpAttribute | Custom attribute that, when applied on another custom attribute (a class derived from Attribute), means that assemblies with elements annotated with that custom attribute should be processed by PostSharp.
Public class | RequireReflectionWrapperAttribute | Custom attribute that, when applied on a type, specifies that all build-time semantics of this type require reflection wrappers to be passed instead of real reflection objects.

Interfaces

 | Interface | Description
Public interface | IMessageSink | Receives messages.
Public interface | IPostSharpEnvironment | Provides information about the current PostSharp environment.
Public interface | IProject | Provides information about the currently executing project.
Public interface | IValidableAnnotation | Interface that, when implemented by a custom attribute (Attribute), causes PostSharp to invoke a validation method for every instance of that custom attribute.

Enumerations

 | Enumeration | Description
Public enumeration | MulticastAttributes | Attributes of elements to which multicast custom attributes (MulticastAttribute) apply.
Public enumeration | MulticastInheritance | Kind of inheritance of MulticastAttribute.
Public enumeration | MulticastTargets | Kinds of targets to which multicast custom attributes (MulticastAttribute) can apply.
Public enumeration | SeverityType | Types of message severities.


AssemblyIdAttribute Class

AssemblyIdAttribute Class
Members See Also Send Feedback
Assigns a unique identifier to an assembly. This assembly identifier is used to generate unique attribute identifiers.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyIdAttribute : Attribute

Remarks

By default, the assembly identifier is computed from the module name (by using the first 4 bytes of the MD5 sum of the module name).

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.AssemblyIdAttribute

See Also

AssemblyIdAttribute Members
PostSharp.Extensibility Namespace


AssemblyIdAttribute Members

[image]

PostSharp 2.0 Documentation
AssemblyIdAttribute Members
AssemblyIdAttribute Class Constructors See Also Send Feedback

The AssemblyIdAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyIdAttribute | Initializes a new AssemblyIdAttribute.

See Also

AssemblyIdAttribute Class
PostSharp.Extensibility Namespace


AssemblyIdAttribute Constructor

AssemblyIdAttribute Constructor
AssemblyIdAttribute Class See Also Send Feedback
Initializes a new AssemblyIdAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyIdAttribute(
    int id
)

Parameters

id
Type: System..::.Int32
Assembly identifier.

See Also

AssemblyIdAttribute Class
PostSharp.Extensibility Namespace


DisablePostSharpMessageAttribute Class

DisablePostSharpMessageAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on an assembly, means that a given message should be disabled during the current PostSharp session.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DisablePostSharpMessageAttribute : Attribute

Remarks

Errors and fatal errors cannot be disabled.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.DisablePostSharpMessageAttribute

See Also

DisablePostSharpMessageAttribute Members
PostSharp.Extensibility Namespace


DisablePostSharpMessageAttribute Members

[image]

PostSharp 2.0 Documentation
DisablePostSharpMessageAttribute Members
DisablePostSharpMessageAttribute Class Constructors Properties See Also Send Feedback

The DisablePostSharpMessageAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DisablePostSharpMessageAttribute | Initializes a new DisablePostSharpMessageAttribute.

Properties

 | Name | Description
Public property | MessageId | Gets the identifier of the message to be disabled.

See Also

DisablePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


DisablePostSharpMessageAttribute Constructor

DisablePostSharpMessageAttribute Constructor
DisablePostSharpMessageAttribute Class See Also Send Feedback
Initializes a new DisablePostSharpMessageAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DisablePostSharpMessageAttribute(
    string messageId
)

Parameters

messageId
Type: System..::.String
Identifier of the message to be disabled.

See Also

DisablePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


DisablePostSharpMessageAttribute Properties

[image]

PostSharp 2.0 Documentation
DisablePostSharpMessageAttribute Properties
DisablePostSharpMessageAttribute Class See Also Send Feedback

The DisablePostSharpMessageAttribute type exposes the following members.

Properties

 | Name | Description
Public property | MessageId | Gets the identifier of the message to be disabled.

See Also

DisablePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


MessageId Property

DisablePostSharpMessageAttribute..::..MessageId Property
DisablePostSharpMessageAttribute Class See Also Send Feedback
Gets the identifier of the message to be disabled.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MessageId { get; }

See Also

DisablePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


EnhancedByPostSharpAttribute Class

EnhancedByPostSharpAttribute Class
Members See Also Send Feedback
Custom attribute added to the assembly manifest of modules processed by PostSharp.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EnhancedByPostSharpAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.EnhancedByPostSharpAttribute

See Also

EnhancedByPostSharpAttribute Members
PostSharp.Extensibility Namespace


EnhancedByPostSharpAttribute Members

[image]

PostSharp 2.0 Documentation
EnhancedByPostSharpAttribute Members
EnhancedByPostSharpAttribute Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | EnhancedByPostSharpAttribute | Overloaded.

See Also

EnhancedByPostSharpAttribute Class
PostSharp.Extensibility Namespace


EnhancedByPostSharpAttribute Constructor

[image]

PostSharp 2.0 Documentation
EnhancedByPostSharpAttribute Constructor
EnhancedByPostSharpAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnhancedByPostSharpAttribute(Int32) | Instantiates a new EnhancedByPostSharpAttribute and specifies the license number (not the full license key).
Public method | EnhancedByPostSharpAttribute(String) | Instantiate a new EnhancedByPostSharpAttribute with a text message, typically used when PostSharp runs in evaluation mode.

See Also

EnhancedByPostSharpAttribute Class
EnhancedByPostSharpAttribute Members
PostSharp.Extensibility Namespace


EnhancedByPostSharpAttribute Constructor (Int32)

EnhancedByPostSharpAttribute Constructor (Int32)
EnhancedByPostSharpAttribute Class See Also Send Feedback
Instantiates a new EnhancedByPostSharpAttribute and specifies the license number (not the full license key).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EnhancedByPostSharpAttribute(
    int licenseId
)

Parameters

licenseId
Type: System..::.Int32
License number.

See Also

EnhancedByPostSharpAttribute Class
EnhancedByPostSharpAttribute Overload
PostSharp.Extensibility Namespace


EnhancedByPostSharpAttribute Constructor (String)

EnhancedByPostSharpAttribute Constructor (String)
EnhancedByPostSharpAttribute Class See Also Send Feedback
Instantiate a new EnhancedByPostSharpAttribute with a text message, typically used when PostSharp runs in evaluation mode.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EnhancedByPostSharpAttribute(
    string message
)

Parameters

message
Type: System..::.String
The watermark text.

See Also

EnhancedByPostSharpAttribute Class
EnhancedByPostSharpAttribute Overload
PostSharp.Extensibility Namespace


EscalatePostSharpMessageAttribute Class

EscalatePostSharpMessageAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on an assembly, means that a given message should be escalated to an error during the current PostSharp session.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EscalatePostSharpMessageAttribute : Attribute

Remarks

Errors and fatal errors cannot be disabled.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.EscalatePostSharpMessageAttribute

See Also

EscalatePostSharpMessageAttribute Members
PostSharp.Extensibility Namespace


EscalatePostSharpMessageAttribute Members

[image]

PostSharp 2.0 Documentation
EscalatePostSharpMessageAttribute Members
EscalatePostSharpMessageAttribute Class Constructors Properties See Also Send Feedback

The EscalatePostSharpMessageAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EscalatePostSharpMessageAttribute | Initializes a new EscalatePostSharpMessageAttribute.

Properties

 | Name | Description
Public property | MessageId | Gets the identifier of the message to be disabled.

See Also

EscalatePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


EscalatePostSharpMessageAttribute Constructor

EscalatePostSharpMessageAttribute Constructor
EscalatePostSharpMessageAttribute Class See Also Send Feedback
Initializes a new EscalatePostSharpMessageAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EscalatePostSharpMessageAttribute(
    string messageId
)

Parameters

messageId
Type: System..::.String
Identifier of the message to be disabled.

See Also

EscalatePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


EscalatePostSharpMessageAttribute Properties

[image]

PostSharp 2.0 Documentation
EscalatePostSharpMessageAttribute Properties
EscalatePostSharpMessageAttribute Class See Also Send Feedback

The EscalatePostSharpMessageAttribute type exposes the following members.

Properties

 | Name | Description
Public property | MessageId | Gets the identifier of the message to be disabled.

See Also

EscalatePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


MessageId Property

EscalatePostSharpMessageAttribute..::..MessageId Property
EscalatePostSharpMessageAttribute Class See Also Send Feedback
Gets the identifier of the message to be disabled.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MessageId { get; }

See Also

EscalatePostSharpMessageAttribute Class
PostSharp.Extensibility Namespace


FrameworkVariants Class

FrameworkVariants Class
Members See Also Send Feedback
Defines constants identifying the different variants of the .NET Framework (Full, Compact, Silverlight).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class FrameworkVariants

Inheritance Hierarchy

System..::.Object
PostSharp.Extensibility..::.FrameworkVariants

See Also

FrameworkVariants Members
PostSharp.Extensibility Namespace


FrameworkVariants Members

[image]

PostSharp 2.0 Documentation
FrameworkVariants Members
FrameworkVariants Class Methods Fields See Also Send Feedback

The FrameworkVariants type exposes the following members.

Methods

Name | Description
FromBytes | Convert a byte array (typically containing the public key token of mscorlib) into a string that can be compared to one of the constants defined in this class.

Fields

Name | Description
Compact | .NET Compact Framework.
Full | Normal, full .NET Framework.
Micro | Micro Framework.
Silverlight | Silverlight.

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


FrameworkVariants Fields

[image]

PostSharp 2.0 Documentation
FrameworkVariants Fields
FrameworkVariants Class See Also Send Feedback

The FrameworkVariants type exposes the following members.

Fields

Name | Description
Compact | .NET Compact Framework.
Full | Normal, full .NET Framework.
Micro | Micro Framework.
Silverlight | Silverlight.

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


Compact Field

FrameworkVariants..::..Compact Field
FrameworkVariants Class See Also Send Feedback
.NET Compact Framework.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Compact

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


Full Field

FrameworkVariants..::..Full Field
FrameworkVariants Class See Also Send Feedback
Normal, full .NET Framework.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Full

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


Micro Field

FrameworkVariants..::..Micro Field
FrameworkVariants Class See Also Send Feedback
Micro Framework.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Micro

Remarks

There is strong name in the Micro Framework.

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


Silverlight Field

FrameworkVariants..::..Silverlight Field
FrameworkVariants Class See Also Send Feedback
Silverlight.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string Silverlight

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


FrameworkVariants Methods

[image]

PostSharp 2.0 Documentation
FrameworkVariants Methods
FrameworkVariants Class See Also Send Feedback

The FrameworkVariants type exposes the following members.

Methods

Name | Description
FromBytes | Convert a byte array (typically containing the public key token of mscorlib) into a string that can be compared to one of the constants defined in this class.

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


FromBytes Method

FrameworkVariants..::..FromBytes Method
FrameworkVariants Class See Also Send Feedback
Convert a byte array (typically containing the public key token of mscorlib) into a string that can be compared to one of the constants defined in this class.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string FromBytes(
    byte[] bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[][]
A byte array (typically containing the public key token of mscorlib)

Return Value

A string that can be compared to one of the constants defined in this class

See Also

FrameworkVariants Class
PostSharp.Extensibility Namespace


HasInheritedAttributeAttribute Class

HasInheritedAttributeAttribute Class
Members See Also Send Feedback
Internal Only. Custom attribute used internally by PostSharp to mark elements having inherited custom attributes. This custom attribute should not be used in custom code, otherwise PostSharp may not work properly.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class HasInheritedAttributeAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.HasInheritedAttributeAttribute

See Also

HasInheritedAttributeAttribute Members
PostSharp.Extensibility Namespace


HasInheritedAttributeAttribute Members

[image]

PostSharp 2.0 Documentation
HasInheritedAttributeAttribute Members
HasInheritedAttributeAttribute Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | HasInheritedAttributeAttribute | Overloaded.

See Also

HasInheritedAttributeAttribute Class
PostSharp.Extensibility Namespace


HasInheritedAttributeAttribute Constructor

[image]

PostSharp 2.0 Documentation
HasInheritedAttributeAttribute Constructor
HasInheritedAttributeAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HasInheritedAttributeAttribute()()() | Initializes a new HasInheritedAttributeAttribute.
Public method | HasInheritedAttributeAttribute(array<Int64>[]()[]) | Obsolete. Initializes a new HasInheritedAttributeAttribute.

See Also

HasInheritedAttributeAttribute Class
HasInheritedAttributeAttribute Members
PostSharp.Extensibility Namespace


HasInheritedAttributeAttribute Constructor

HasInheritedAttributeAttribute Constructor
HasInheritedAttributeAttribute Class See Also Send Feedback
Initializes a new HasInheritedAttributeAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public HasInheritedAttributeAttribute()

See Also

HasInheritedAttributeAttribute Class
HasInheritedAttributeAttribute Overload
PostSharp.Extensibility Namespace


HasInheritedAttributeAttribute Constructor (Int64[])

HasInheritedAttributeAttribute Constructor (array<Int64>[]()[][])
HasInheritedAttributeAttribute Class See Also Send Feedback
Initializes a new HasInheritedAttributeAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Do not use this custom attribute in user code.",
    false)]
public HasInheritedAttributeAttribute(
    long[] ids
)

Parameters

ids
Type: array< System..::.Int64 >[]()[][]
List of pooled inherited instances present on the target element of the current HasInheritedAttributeAttribute instance.

See Also

HasInheritedAttributeAttribute Class
HasInheritedAttributeAttribute Overload
PostSharp.Extensibility Namespace


IMessageSink Interface

IMessageSink Interface
Members See Also Send Feedback
Receives messages.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMessageSink

Remarks

Use this interface instead of events for cross-domain communication.

See Also

IMessageSink Members
PostSharp.Extensibility Namespace


IMessageSink Members

[image]

PostSharp 2.0 Documentation
IMessageSink Members
IMessageSink Interface Methods See Also Send Feedback

The IMessageSink type exposes the following members.

Methods

 | Name | Description
Public method | Write | Writes a message to the sink.

See Also

IMessageSink Interface
PostSharp.Extensibility Namespace


IMessageSink Methods

[image]

PostSharp 2.0 Documentation
IMessageSink Methods
IMessageSink Interface See Also Send Feedback

The IMessageSink type exposes the following members.

Methods

 | Name | Description
Public method | Write | Writes a message to the sink.

See Also

IMessageSink Interface
PostSharp.Extensibility Namespace


Write Method

IMessageSink..::..Write Method
IMessageSink Interface See Also Send Feedback
Writes a message to the sink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Write(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A message.

See Also

IMessageSink Interface
PostSharp.Extensibility Namespace


ImplementationBoundAttributeAttribute Class

ImplementationBoundAttributeAttribute Class
Members See Also Send Feedback
Custom attribute meaning that custom attributes of a given type are bound to the implementation, not to the semantics.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ImplementationBoundAttributeAttribute : Attribute

Remarks

This custom attribute influences whether instances of a given other custom attribute should be moved from the semantic to the implementation, when the semantic is detached from the implementation. This happens for instance when a property is generated from a field; the property become the semantic (and is made public) and the field the implementation (and is made private). Most custom attributes apply to semantics, so they are moved from the field to the property. If a custom attribute must not be moved, it should be marked with the ImplementationBoundAttributeAttribute custom attribute.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.ImplementationBoundAttributeAttribute

See Also

ImplementationBoundAttributeAttribute Members
PostSharp.Extensibility Namespace


ImplementationBoundAttributeAttribute Members

[image]

PostSharp 2.0 Documentation
ImplementationBoundAttributeAttribute Members
ImplementationBoundAttributeAttribute Class Constructors Properties See Also Send Feedback

The ImplementationBoundAttributeAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ImplementationBoundAttributeAttribute | Initializes the new ImplementationBoundAttributeAttribute.

Properties

 | Name | Description
Public property | AttributeType | Gets the type of the custom attribute that should not be moved from implementation to semantic

See Also

ImplementationBoundAttributeAttribute Class
PostSharp.Extensibility Namespace


ImplementationBoundAttributeAttribute Constructor

ImplementationBoundAttributeAttribute Constructor
ImplementationBoundAttributeAttribute Class See Also Send Feedback
Initializes the new ImplementationBoundAttributeAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImplementationBoundAttributeAttribute(
    Type attributeType
)

Parameters

attributeType
Type: System..::.Type
Type of the custom attribute that should not be moved from implementation to semantic.

See Also

ImplementationBoundAttributeAttribute Class
PostSharp.Extensibility Namespace


ImplementationBoundAttributeAttribute Properties

[image]

PostSharp 2.0 Documentation
ImplementationBoundAttributeAttribute Properties
ImplementationBoundAttributeAttribute Class See Also Send Feedback

The ImplementationBoundAttributeAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeType | Gets the type of the custom attribute that should not be moved from implementation to semantic

See Also

ImplementationBoundAttributeAttribute Class
PostSharp.Extensibility Namespace


AttributeType Property

ImplementationBoundAttributeAttribute..::..AttributeType Property
ImplementationBoundAttributeAttribute Class See Also Send Feedback
Gets the type of the custom attribute that should not be moved from implementation to semantic

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type AttributeType { get; }

See Also

ImplementationBoundAttributeAttribute Class
PostSharp.Extensibility Namespace


InvalidAnnotationException Class

InvalidAnnotationException Class
Members See Also Send Feedback
Exception thrown at build time by implementation of CompileTimeValidate(Object) when an annotation is invalid.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class InvalidAnnotationException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Extensibility..::.InvalidAnnotationException

See Also

InvalidAnnotationException Members
PostSharp.Extensibility Namespace


InvalidAnnotationException Members

[image]

PostSharp 2.0 Documentation
InvalidAnnotationException Members
InvalidAnnotationException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | InvalidAnnotationException | Overloaded.

See Also

InvalidAnnotationException Class
PostSharp.Extensibility Namespace


InvalidAnnotationException Constructor

[image]

PostSharp 2.0 Documentation
InvalidAnnotationException Constructor
InvalidAnnotationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidAnnotationException()()() | Initializes a new InvalidAnnotationException with default message.
Public method | InvalidAnnotationException(String) | Initializes a new InvalidAnnotationException and with a specified exception message.
Protected method | InvalidAnnotationException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | InvalidAnnotationException(String, Exception) | Initializes a new InvalidAnnotationException with a specified exception message and inner Exception.

See Also

InvalidAnnotationException Class
InvalidAnnotationException Members
PostSharp.Extensibility Namespace


InvalidAnnotationException Constructor

InvalidAnnotationException Constructor
InvalidAnnotationException Class See Also Send Feedback
Initializes a new InvalidAnnotationException with default message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidAnnotationException()

See Also

InvalidAnnotationException Class
InvalidAnnotationException Overload
PostSharp.Extensibility Namespace


InvalidAnnotationException Constructor (String)

InvalidAnnotationException Constructor (String)
InvalidAnnotationException Class See Also Send Feedback
Initializes a new InvalidAnnotationException and with a specified exception message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidAnnotationException(
    string message
)

Parameters

message
Type: System..::.String
Exception message

See Also

InvalidAnnotationException Class
InvalidAnnotationException Overload
PostSharp.Extensibility Namespace


InvalidAnnotationException Constructor (SerializationInfo, StreamingContext)

InvalidAnnotationException Constructor (SerializationInfo, StreamingContext)
InvalidAnnotationException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InvalidAnnotationException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Info.
context
Type: System.Runtime.Serialization..::.StreamingContext
Context.

See Also

InvalidAnnotationException Class
InvalidAnnotationException Overload
PostSharp.Extensibility Namespace


InvalidAnnotationException Constructor (String, Exception)

InvalidAnnotationException Constructor (String, Exception)
InvalidAnnotationException Class See Also Send Feedback
Initializes a new InvalidAnnotationException with a specified exception message and inner Exception.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidAnnotationException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

InvalidAnnotationException Class
InvalidAnnotationException Overload
PostSharp.Extensibility Namespace


IPostSharpEnvironment Interface

IPostSharpEnvironment Interface
Members See Also Send Feedback
Provides information about the current PostSharp environment.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IPostSharpEnvironment

See Also

IPostSharpEnvironment Members
PostSharp.Extensibility Namespace


IPostSharpEnvironment Members

[image]

PostSharp 2.0 Documentation
IPostSharpEnvironment Members
IPostSharpEnvironment Interface Properties See Also Send Feedback

The IPostSharpEnvironment type exposes the following members.

Properties

 | Name | Description
Public property | CurrentProject | Gets the currently executing project.

See Also

IPostSharpEnvironment Interface
PostSharp.Extensibility Namespace


IPostSharpEnvironment Properties

[image]

PostSharp 2.0 Documentation
IPostSharpEnvironment Properties
IPostSharpEnvironment Interface See Also Send Feedback

The IPostSharpEnvironment type exposes the following members.

Properties

 | Name | Description
Public property | CurrentProject | Gets the currently executing project.

See Also

IPostSharpEnvironment Interface
PostSharp.Extensibility Namespace


CurrentProject Property

IPostSharpEnvironment..::..CurrentProject Property
IPostSharpEnvironment Interface See Also Send Feedback
Gets the currently executing project.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IProject CurrentProject { get; }

Field Value

The current project, or null if there is no current project.

See Also

IPostSharpEnvironment Interface
PostSharp.Extensibility Namespace


IProject Interface

IProject Interface
Members See Also Send Feedback
Provides information about the currently executing project.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IProject

See Also

IProject Members
PostSharp.Extensibility Namespace


IProject Members

[image]

PostSharp 2.0 Documentation
IProject Members
IProject Interface Methods See Also Send Feedback

The IProject type exposes the following members.

Methods

 | Name | Description
Public method | EvaluateExpression | Evaluates an expression (that is, replace parameters by their actual value).
Public method | GetFrameworkVariant | Gets the variant of the .NET Framework against which the .NET assembly currently processed is linked.
Public method | GetTargetAssembly | Gets the assembly that is being transformed by PostSharp.

See Also

IProject Interface
PostSharp.Extensibility Namespace


IProject Methods

[image]

PostSharp 2.0 Documentation
IProject Methods
IProject Interface See Also Send Feedback

The IProject type exposes the following members.

Methods

 | Name | Description
Public method | EvaluateExpression | Evaluates an expression (that is, replace parameters by their actual value).
Public method | GetFrameworkVariant | Gets the variant of the .NET Framework against which the .NET assembly currently processed is linked.
Public method | GetTargetAssembly | Gets the assembly that is being transformed by PostSharp.

See Also

IProject Interface
PostSharp.Extensibility Namespace


EvaluateExpression Method

IProject..::..EvaluateExpression Method
IProject Interface See Also Send Feedback
Evaluates an expression (that is, replace parameters by their actual value).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string EvaluateExpression(
    string expression
)

Parameters

expression
Type: System..::.String
An expression.

Return Value

The evaluated expression, or null if one parameter could not be resolved.

See Also

IProject Interface
PostSharp.Extensibility Namespace


GetFrameworkVariant Method

IProject..::..GetFrameworkVariant Method
IProject Interface See Also Send Feedback
Gets the variant of the .NET Framework against which the .NET assembly currently processed is linked.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string GetFrameworkVariant()

Return Value

A string uniquely identifying the framework variant, to be compared to the constants defined in the FrameworkVariants class. Actually, the public key token of mscorlib is returned.

See Also

IProject Interface
PostSharp.Extensibility Namespace


GetTargetAssembly Method

IProject..::..GetTargetAssembly Method
IProject Interface See Also Send Feedback
Gets the assembly that is being transformed by PostSharp.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
_Assembly GetTargetAssembly(
    bool getWrapper
)

Parameters

getWrapper
Type: System..::.Boolean
false if the system Assembly has to be returned, true if a wrapper has to be returned.

Return Value

The assembly being processed. If getWrapper is true, this method returns an instance of a PostSharp internal type implementing the _Assembly interface. Otherwise, the reflection Assembly is returned.

See Also

IProject Interface
PostSharp.Extensibility Namespace


IValidableAnnotation Interface

IValidableAnnotation Interface
Members See Also Send Feedback
Interface that, when implemented by a custom attribute (Attribute), causes PostSharp to invoke a validation method for every instance of that custom attribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IValidableAnnotation

See Also

IValidableAnnotation Members
PostSharp.Extensibility Namespace


IValidableAnnotation Members

[image]

PostSharp 2.0 Documentation
IValidableAnnotation Members
IValidableAnnotation Interface Methods See Also Send Feedback

The IValidableAnnotation type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target.

See Also

IValidableAnnotation Interface
PostSharp.Extensibility Namespace


IValidableAnnotation Methods

[image]

PostSharp 2.0 Documentation
IValidableAnnotation Methods
IValidableAnnotation Interface See Also Send Feedback

The IValidableAnnotation type exposes the following members.

Methods

 | Name | Description
Public method | CompileTimeValidate | Method invoked at build time to ensure that the aspect has been applied to the right target.

See Also

IValidableAnnotation Interface
PostSharp.Extensibility Namespace


CompileTimeValidate Method

IValidableAnnotation..::..CompileTimeValidate Method
IValidableAnnotation Interface See Also Send Feedback
Method invoked at build time to ensure that the aspect has been applied to the right target.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool CompileTimeValidate(
    Object target
)

Parameters

target
Type: System..::.Object
Target element.

Return Value

true if the aspect was applied to an acceptable target, otherwise false.

Remarks

The implementation of this method is expected to emit an error message or an exception of type InvalidAnnotationException in case of error. Only returning false causes the aspect to be silently ignored.

See Also

IValidableAnnotation Interface
PostSharp.Extensibility Namespace


Message Class

Message Class
Members See Also Send Feedback
Encapsulates a message (error, warning, info, ...).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Message

Inheritance Hierarchy

System..::.Object
PostSharp.Extensibility..::.Message

See Also

Message Members
PostSharp.Extensibility Namespace


Message Members

[image]

PostSharp 2.0 Documentation
Message Members
Message Class Constructors Methods Fields Properties See Also Send Feedback

The Message type exposes the following members.

Constructors

 | Name | Description
Public method | Message | Overloaded.

Methods

Name | Description
GetExceptionStackMessage | Returns a string composed of the messages of all inner exceptions.
Write | Overloaded.

Fields

Name | Description
NotAvailable | When set to the LocationLine or the LocationColumn property, means that the value of this property is unknown.

Properties

 | Name | Description
Public property | HelpLink | Gets the help link.
Public property | InnerException | Gets the
Public property | LocationColumn | Gets the column in the file that caused the message.
Public property | LocationFile | Gets the name of the file that caused the message.
Public property | LocationLine | Gets the line in the file that caused the message.
Public property | MessageId | Gets the message type identifier.
Public property | MessageText | Gets the message formatted text.
Public property | Severity | Gets the message severity.
Public property | Source | Gets or sets the name of the source component.

See Also

Message Class
PostSharp.Extensibility Namespace


Message Constructor

[image]

PostSharp 2.0 Documentation
Message Constructor
Message Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Message(SeverityType, String, String, String) | Initializes a new Message and specifies only required parameters.
Public method | Message(SeverityType, String, String, String, String, String, Int32, Int32, Exception) | Initializes a new Message and specifies all its properties.

See Also

Message Class
Message Members
PostSharp.Extensibility Namespace


Message Constructor (SeverityType, String, String, String)

Message Constructor (SeverityType, String, String, String)
Message Class See Also Send Feedback
Initializes a new Message and specifies only required parameters.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Message(
    SeverityType severity,
    string messageId,
    string messageText,
    string source
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severify (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
messageText
Type: System..::.String
Fully formatted message text.
source
Type: System..::.String
Name of the component emitting the message.

See Also

Message Class
Message Overload
PostSharp.Extensibility Namespace


Message Constructor (SeverityType, String, String, String, String, String, Int32, Int32, Exception)

Message Constructor (SeverityType, String, String, String, String, String, Int32, Int32, Exception)
Message Class See Also Send Feedback
Initializes a new Message and specifies all its properties.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Message(
    SeverityType severity,
    string messageId,
    string messageText,
    string helpLink,
    string source,
    string locationFile,
    int locationLine,
    int locationColumn,
    Exception innerException
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severify (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
messageText
Type: System..::.String
Fully formatted message text.
helpLink
Type: System..::.String
Link to the help file page associated to this message.
source
Type: System..::.String
Name of the component emitting the message.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.
locationLine
Type: System..::.Int32
Position (line) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
locationColumn
Type: System..::.Int32
Position (column) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
innerException
Type: System..::.Exception
The Exception that caused this message, or null if this message was not caused by an exception.

See Also

Message Class
Message Overload
PostSharp.Extensibility Namespace


Message Fields

[image]

PostSharp 2.0 Documentation
Message Fields
Message Class See Also Send Feedback

The Message type exposes the following members.

Fields

Name | Description
NotAvailable | When set to the LocationLine or the LocationColumn property, means that the value of this property is unknown.

See Also

Message Class
PostSharp.Extensibility Namespace


NotAvailable Field

Message..::..NotAvailable Field
Message Class See Also Send Feedback
When set to the LocationLine or the LocationColumn property, means that the value of this property is unknown.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int NotAvailable

See Also

Message Class
PostSharp.Extensibility Namespace


Message Methods

[image]

PostSharp 2.0 Documentation
Message Methods
Message Class See Also Send Feedback

The Message type exposes the following members.

Methods

Name | Description
GetExceptionStackMessage | Returns a string composed of the messages of all inner exceptions.
Write | Overloaded.

See Also

Message Class
PostSharp.Extensibility Namespace


GetExceptionStackMessage Method

Message..::..GetExceptionStackMessage Method
Message Class See Also Send Feedback
Returns a string composed of the messages of all inner exceptions.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetExceptionStackMessage(
    Exception outerException
)

Parameters

outerException
Type: System..::.Exception
The outer exception.

Return Value

A string composed of the mesages of all outerException and all inner exceptions, concatenated by the string -->.

See Also

Message Class
PostSharp.Extensibility Namespace


Write Method

[image]

PostSharp 2.0 Documentation
Message..::..Write Method
Message Class See Also Send Feedback

Overload List

Name | Description
Write(Message) | Writes a message by providing a Message object.
Write(SeverityType, String, String) | Writes a message by providing a severity, an error code, and an error message.
Write(SeverityType, String, String, array<Object>[]()[]) | Writes a message by providing a severity, an error code, an error message formatting string, and arguments for this formatting string.

See Also

Message Class
Message Members
PostSharp.Extensibility Namespace


Write Method (Message)

Message..::..Write Method (Message)
Message Class See Also Send Feedback
Writes a message by providing a Message object.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Write(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A Message.

See Also

Message Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, String)

Message..::..Write Method (SeverityType, String, String)
Message Class See Also Send Feedback
Writes a message by providing a severity, an error code, and an error message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Write(
    SeverityType severity,
    string errorCode,
    string message
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Severity.
errorCode
Type: System..::.String
Error code.
message
Type: System..::.String
Error message.

See Also

Message Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, String, Object[])

Message..::..Write Method (SeverityType, String, String, array<Object>[]()[][])
Message Class See Also Send Feedback
Writes a message by providing a severity, an error code, an error message formatting string, and arguments for this formatting string.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Write(
    SeverityType severity,
    string errorCode,
    string format,
    params Object[] arguments
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Severity.
errorCode
Type: System..::.String
Error code.
format
Type: System..::.String
Error message formatting string.
arguments
Type: array< System..::.Object >[]()[][]
Formatting string arguments.

See Also

Message Class
Write Overload
PostSharp.Extensibility Namespace


Message Properties

[image]

PostSharp 2.0 Documentation
Message Properties
Message Class See Also Send Feedback

The Message type exposes the following members.

Properties

 | Name | Description
Public property | HelpLink | Gets the help link.
Public property | InnerException | Gets the
Public property | LocationColumn | Gets the column in the file that caused the message.
Public property | LocationFile | Gets the name of the file that caused the message.
Public property | LocationLine | Gets the line in the file that caused the message.
Public property | MessageId | Gets the message type identifier.
Public property | MessageText | Gets the message formatted text.
Public property | Severity | Gets the message severity.
Public property | Source | Gets or sets the name of the source component.

See Also

Message Class
PostSharp.Extensibility Namespace


HelpLink Property

Message..::..HelpLink Property
Message Class See Also Send Feedback
Gets the help link.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string HelpLink { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


InnerException Property

Message..::..InnerException Property
Message Class See Also Send Feedback
Gets the

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception InnerException { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


LocationColumn Property

Message..::..LocationColumn Property
Message Class See Also Send Feedback
Gets the column in the file that caused the message.
An integer greater or equal to 1, or NotAvailable if the column is unknown or does not apply.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int LocationColumn { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


LocationFile Property

Message..::..LocationFile Property
Message Class See Also Send Feedback
Gets the name of the file that caused the message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string LocationFile { get; }

Field Value

A full file name, or null if the file name is unknown or not applicable.

See Also

Message Class
PostSharp.Extensibility Namespace


LocationLine Property

Message..::..LocationLine Property
Message Class See Also Send Feedback
Gets the line in the file that caused the message.
An integer greater or equal to 1, or NotAvailable if the line is unknown or does not apply.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int LocationLine { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


MessageId Property

Message..::..MessageId Property
Message Class See Also Send Feedback
Gets the message type identifier.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MessageId { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


MessageText Property

Message..::..MessageText Property
Message Class See Also Send Feedback
Gets the message formatted text.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MessageText { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


Severity Property

Message..::..Severity Property
Message Class See Also Send Feedback
Gets the message severity.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SeverityType Severity { get; internal set; }

See Also

Message Class
PostSharp.Extensibility Namespace


Source Property

Message..::..Source Property
Message Class See Also Send Feedback
Gets or sets the name of the source component.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Source { get; }

See Also

Message Class
PostSharp.Extensibility Namespace


MessageException Class

MessageException Class
Members See Also Send Feedback
Exception embedding a Message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MessageException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Extensibility..::.MessageException

See Also

MessageException Members
PostSharp.Extensibility Namespace


MessageException Members

[image]

PostSharp 2.0 Documentation
MessageException Members
MessageException Class Constructors Methods Properties See Also Send Feedback

The MessageException type exposes the following members.

Constructors

 | Name | Description
Public method | MessageException | Initializes a new MessageException from an existing Message.

Methods

 | Name | Description
Public method | GetObjectData | Serializes the current object. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

 | Name | Description
Public property | MessageObject | Gets the Message em

See Also

MessageException Class
PostSharp.Extensibility Namespace


MessageException Constructor

MessageException Constructor
MessageException Class See Also Send Feedback
Initializes a new MessageException from an existing Message.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MessageException(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A Message.

See Also

MessageException Class
PostSharp.Extensibility Namespace


MessageException Methods

[image]

PostSharp 2.0 Documentation
MessageException Methods
MessageException Class See Also Send Feedback

The MessageException type exposes the following members.

Methods

 | Name | Description
Public method | GetObjectData | Serializes the current object. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)

See Also

MessageException Class
PostSharp.Extensibility Namespace


GetObjectData Method

MessageException..::..GetObjectData Method
MessageException Class See Also Send Feedback
Serializes the current object.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Serialization context.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MessageException Class
PostSharp.Extensibility Namespace


MessageException Properties

[image]

PostSharp 2.0 Documentation
MessageException Properties
MessageException Class See Also Send Feedback

The MessageException type exposes the following members.

Properties

 | Name | Description
Public property | MessageObject | Gets the Message em

See Also

MessageException Class
PostSharp.Extensibility Namespace


MessageObject Property

MessageException..::..MessageObject Property
MessageException Class See Also Send Feedback
Gets the Message em

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Message MessageObject { get; }

See Also

MessageException Class
PostSharp.Extensibility Namespace


MessageSource Class

MessageSource Class
Members See Also Send Feedback
Provides commodity methods to work with an IMessageSink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MessageSource : MarshalByRefObject,
    IMessageSink

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Extensibility..::.MessageSource

See Also

MessageSource Members
PostSharp.Extensibility Namespace


MessageSource Members

[image]

PostSharp 2.0 Documentation
MessageSource Members
MessageSource Class Constructors Methods Properties See Also Send Feedback

The MessageSource type exposes the following members.

Constructors

 | Name | Description
Public method | MessageSource | Initializes a new MessageSource.

Methods

 | Name | Description
Public method | CreateMessage | Creates a Message object and specifies the HelpLink.
Public method | Write | Overloaded.

Properties

Name | Description
MessageSink | Gets the current message sink.

See Also

MessageSource Class
PostSharp.Extensibility Namespace


MessageSource Constructor

MessageSource Constructor
MessageSource Class See Also Send Feedback
Initializes a new MessageSource.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MessageSource(
    string source,
    ResourceManager resourceManager
)

Parameters

source
Type: System..::.String
Name of the component emitting. the messages.
resourceManager
Type: System.Resources..::.ResourceManager
The ResourceManager that will be used to retrieve message texts.

See Also

MessageSource Class
PostSharp.Extensibility Namespace


MessageSource Methods

[image]

PostSharp 2.0 Documentation
MessageSource Methods
MessageSource Class See Also Send Feedback

The MessageSource type exposes the following members.

Methods

 | Name | Description
Public method | CreateMessage | Creates a Message object and specifies the HelpLink.
Public method | Write | Overloaded.

See Also

MessageSource Class
PostSharp.Extensibility Namespace


CreateMessage Method

MessageSource..::..CreateMessage Method
MessageSource Class See Also Send Feedback
Creates a Message object and specifies the HelpLink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Message CreateMessage(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    string locationFile,
    int locationLine,
    int locationColumn,
    Exception innerException
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.
locationLine
Type: System..::.Int32
Position (line) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
locationColumn
Type: System..::.Int32
Position (column) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
innerException
Type: System..::.Exception
The Exception that caused this message, or null if this message was not caused by an exception.

Return Value

A Message object.

See Also

MessageSource Class
PostSharp.Extensibility Namespace


Write Method

[image]

PostSharp 2.0 Documentation
MessageSource..::..Write Method
MessageSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(Message) | Writes a message to the sink.
Public method | Write(SeverityType, String, array<Object>[]()[]) | Emits a Message without specifying the location of the error.
Public method | Write(SeverityType, String, array<Object>[]()[], SymbolSequencePoint) | Emits a Message and specifies the error location using a SymbolSequencePoint.
Public method | Write(SeverityType, String, array<Object>[]()[], String) | Emits a Message and specifies the source file name..
Public method | Write(SeverityType, String, array<Object>[]()[], String, Int32) | Emits a Message and specifies the source file name and line.
Public method | Write(SeverityType, String, array<Object>[]()[], String, Int32, Int32) | Emits a Message and specifies the source file name, line and column.
Public method | Write(SeverityType, String, array<Object>[]()[], String, Int32, Int32, Exception) | Emits a Message and specifies all its properties.

See Also

MessageSource Class
MessageSource Members
PostSharp.Extensibility Namespace


Write Method (Message)

MessageSource..::..Write Method (Message)
MessageSource Class See Also Send Feedback
Writes a message to the sink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A message.

Implements

IMessageSink..::.Write(Message)

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[])

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][])
MessageSource Class See Also Send Feedback
Emits a Message without specifying the location of the error.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[], SymbolSequencePoint)

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][], SymbolSequencePoint)
MessageSource Class See Also Send Feedback
Emits a Message and specifies the error location using a SymbolSequencePoint.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    SymbolSequencePoint symbolSequencePoint
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.
symbolSequencePoint
Type: PostSharp.Reflection..::.SymbolSequencePoint
Location of the problem in source code..

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[], String)

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][], String)
MessageSource Class See Also Send Feedback
Emits a Message and specifies the source file name..

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    string locationFile
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[], String, Int32)

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][], String, Int32)
MessageSource Class See Also Send Feedback
Emits a Message and specifies the source file name and line.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    string locationFile,
    int locationLine
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.
locationLine
Type: System..::.Int32
Position (line) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[], String, Int32, Int32)

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][], String, Int32, Int32)
MessageSource Class See Also Send Feedback
Emits a Message and specifies the source file name, line and column.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    string locationFile,
    int locationLine,
    int locationColumn
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Message arguments.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.
locationLine
Type: System..::.Int32
Position (line) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
locationColumn
Type: System..::.Int32
Position (column) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (SeverityType, String, Object[], String, Int32, Int32, Exception)

MessageSource..::..Write Method (SeverityType, String, array<Object>[]()[][], String, Int32, Int32, Exception)
MessageSource Class See Also Send Feedback
Emits a Message and specifies all its properties.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    SeverityType severity,
    string messageId,
    Object[] arguments,
    string locationFile,
    int locationLine,
    int locationColumn,
    Exception innerException
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Message severity (fatal error, error, info, debug).
messageId
Type: System..::.String
Identifier of the message type.
arguments
Type: array< System..::.Object >[]()[][]
Array of arguments used to format the message text, or null if this message has no argument.
locationFile
Type: System..::.String
File that caused the error, or null if the file is unknown or does not apply.
locationLine
Type: System..::.Int32
Position (line) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
locationColumn
Type: System..::.Int32
Position (column) in the file that caused the error, or NotAvailable if the line is unknown or does not apply.
innerException
Type: System..::.Exception
The Exception that caused this message, or null if this message was not caused by an exception.

See Also

MessageSource Class
Write Overload
PostSharp.Extensibility Namespace


MessageSource Properties

[image]

PostSharp 2.0 Documentation
MessageSource Properties
MessageSource Class See Also Send Feedback

The MessageSource type exposes the following members.

Properties

Name | Description
MessageSink | Gets the current message sink.

See Also

MessageSource Class
PostSharp.Extensibility Namespace


MessageSink Property

MessageSource..::..MessageSink Property
MessageSource Class See Also Send Feedback
Gets the current message sink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IMessageSink MessageSink { get; }

See Also

MessageSource Class
PostSharp.Extensibility Namespace


MulticastAttribute Class

MulticastAttribute Class
Members See Also Send Feedback
Custom attribute that can be applied to multiple elements using wildcards.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class MulticastAttribute : Attribute

Remarks

Each class derived from MulticastAttribute should be decorated with an instance of MulticastAttributeUsageAttribute.

Multicasting is performed by the MulticastAttributeTask, which should be included in the project. After multicasting, custom attribute instances are available on the CustomAttributeDictionaryTask class.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttribute
PostSharp.Aspects..::.Aspect

See Also

MulticastAttribute Members
PostSharp.Extensibility Namespace


MulticastAttribute Members

[image]

PostSharp 2.0 Documentation
MulticastAttribute Members
MulticastAttribute Class Constructors Properties See Also Send Feedback

The MulticastAttribute type exposes the following members.

Constructors

 | Name | Description
Protected method | MulticastAttribute | Initializes a new instance of the MulticastAttribute class

Properties

 | Name | Description
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance.
Public property | AttributeInheritance | Determines whether this attribute is inherited
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before).
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations.
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply.
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies.
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies.
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies.
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies.
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies.
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


MulticastAttribute Constructor

MulticastAttribute Constructor
MulticastAttribute Class See Also Send Feedback
Initializes a new instance of the MulticastAttribute class

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MulticastAttribute()

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


MulticastAttribute Properties

[image]

PostSharp 2.0 Documentation
MulticastAttribute Properties
MulticastAttribute Class See Also Send Feedback

The MulticastAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeExclude | If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance.
Public property | AttributeInheritance | Determines whether this attribute is inherited
Public property | AttributePriority | Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before).
Public property | AttributeReplace | Determines whether this attribute replaces other attributes found on the target declarations.
Public property | AttributeTargetAssemblies | Gets or sets the assemblies to which the current attribute apply.
Public property | AttributeTargetElements | Gets or sets the kind of elements to which this custom attributes applies.
Public property | AttributeTargetMemberAttributes | Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.
Public property | AttributeTargetMembers | Gets or sets the expression specifying to which members this instance applies.
Public property | AttributeTargetParameterAttributes | Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies.
Public property | AttributeTargetParameters | Gets or sets the expression specifying to which parameters this instance applies.
Public property | AttributeTargetTypeAttributes | Gets or sets the visibilities of types to which this attribute applies.
Public property | AttributeTargetTypes | Gets or sets the expression specifying to which types this instance applies.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeExclude Property

MulticastAttribute..::..AttributeExclude Property
MulticastAttribute Class See Also Send Feedback
If true, indicates that this attribute removes all other instances of the same attribute type from the set of elements defined by the current instance.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AttributeExclude { get; set; }

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeInheritance Property

MulticastAttribute..::..AttributeInheritance Property
MulticastAttribute Class See Also Send Feedback
Determines whether this attribute is inherited

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastInheritance AttributeInheritance { get; set; }

Remarks

If this property is true, a copy of this attribute will be propagated along the lines of inheritance of the target element:

  • On classes: all classed derived from that class.
  • On interfaces: all classes implementing this interface.
  • On virtual, abstract or interface methods: all methods overriding or implementing this method.
  • On parameters or return value of virtual, abstract or interface methods: corresponding parameter or return value on all methods or overriding or implementing the parent method of the target parameter or return value.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributePriority Property

MulticastAttribute..::..AttributePriority Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the priority of the current attribute in case that multiple instances are defined on the same element (lower values are processed before).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int AttributePriority { get; set; }

Remarks

You should use only 16-bit values in user code. Top 16 bits are reserved for the system.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeReplace Property

MulticastAttribute..::..AttributeReplace Property
MulticastAttribute Class See Also Send Feedback
Determines whether this attribute replaces other attributes found on the target declarations.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AttributeReplace { get; set; }

Field Value

true if the current instance will replace previous ones, or false if it will be added to previous instances.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetAssemblies Property

MulticastAttribute..::..AttributeTargetAssemblies Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the assemblies to which the current attribute apply.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AttributeTargetAssemblies { get; set; }

Field Value

Wildcard or regular expression specifying to which assemblies this instance applies, or null if this instance applies only to elements of the current assembly. Wildcard expressions should start with the regex: prefix.

Remarks

When this property is not specified or is null, the current attribute is multicasted only in the current assembly. Otherwise, it is multicasted also to external assemblies, i.e. to declarations that are referenced by the current assembly.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetElements Property

MulticastAttribute..::..AttributeTargetElements Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the kind of elements to which this custom attributes applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastTargets AttributeTargetElements { get; set; }

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetMemberAttributes Property

MulticastAttribute..::..AttributeTargetMemberAttributes Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the visibilities, scopes, virtualities, and implementation of members to which this attribute applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes AttributeTargetMemberAttributes { get; set; }

Remarks

Ignored if the AttributeTargetElements are only the module, the assembly, and/or types.

The MulticastAttributes enumeration is a multi-part flag: there is one part for visibility, one for scope, one for virtuality, and one for implementation. If you specify one part, it will override the values defined on the custom attribute definition. If you do not specify it, the values defined on the custom attribute definition will be inherited. Note that custom attributes may apply restrictions on these attributes. For instance, a custom attribute may not be valid on abstract methods. You are obviously not allowed to 'enlarge' the set of possible targets.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetMembers Property

MulticastAttribute..::..AttributeTargetMembers Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the expression specifying to which members this instance applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AttributeTargetMembers { get; set; }

Field Value

A wildcard or regular expression specifying to which members this instance applies, or null this instance applies either to all members whose kind is given in AttributeTargetElements. Regular expressions should start with the regex: prefix.

Remarks

Ignored if the only AttributeTargetElements are only types.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetParameterAttributes Property

MulticastAttribute..::..AttributeTargetParameterAttributes Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the passing style (by value, out or ref) of parameters to which this attribute applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes AttributeTargetParameterAttributes { get; set; }

Remarks

Ignored if the AttributeTargetElements do not include parameters.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetParameters Property

MulticastAttribute..::..AttributeTargetParameters Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the expression specifying to which parameters this instance applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AttributeTargetParameters { get; set; }

Field Value

A wildcard or regular expression specifying to which parameters this instance applies, or null this instance applies either to all members whose kind is given in AttributeTargetElements. Wildcard expressions should start with the regex: prefix.

Remarks

Ignored if the only AttributeTargetElements are only types.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetTypeAttributes Property

MulticastAttribute..::..AttributeTargetTypeAttributes Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the visibilities of types to which this attribute applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes AttributeTargetTypeAttributes { get; set; }

Remarks

On type-level, the only meaningfull enumeration values are related to visibility.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


AttributeTargetTypes Property

MulticastAttribute..::..AttributeTargetTypes Property
MulticastAttribute Class See Also Send Feedback
Gets or sets the expression specifying to which types this instance applies.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AttributeTargetTypes { get; set; }

Field Value

A wildcard or regular expression specifying to which types this instance applies, or null this instance applies either to all types. Regular expressions should start with the regex: prefix.

Remarks

Ignored if the AttributeTargetElements are only the module and/or the assembly.

See Also

MulticastAttribute Class
PostSharp.Extensibility Namespace


MulticastAttributes Enumeration

MulticastAttributes Enumeration
See Also Send Feedback
Attributes of elements to which multicast custom attributes (MulticastAttribute) apply.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum MulticastAttributes

Members

Member name | Value | Description
Default | 0 | Specifies that the set of target attributes is inherited from the parent custom attribute.
Private | 2 | Private (visible inside the current type).
Protected | 4 | Protected (visible inside derived types).
Internal | 8 | Internal (visible inside the current assembly).
InternalAndProtected | 16 | Internal and protected (visible inside derived types that are defined in the current assembly).
InternalOrProtected | 32 | Internal or protected (visible inside all derived types and in the current assembly).
Public | 64 | Public (visible everywhere).
AnyVisibility | 126 | Any visibility.
Static | 128 | Static scope.
Instance | 256 | Instance scope.
AnyScope | 384 | Any scope (Static | Instance).
Abstract | 512 | Abstract methods.
NonAbstract | 1024 | Concrete (non-abstract) methods.
AnyAbstraction | 1536 | Any abstraction (Abstract | NonAbstract).
Virtual | 2048 | Virtual methods.
NonVirtual | 4096 | Non-virtual methods.
AnyVirtuality | 6144 | Any virtuality (Virtual | NonVirtual).
Managed | 8192 | Managed code implemetation.
NonManaged | 16384 | Non-managed code implementation (external or system).
AnyImplementation | 24576 | Any implementation (Managed | NonManaged).
Literal | 32768 | Literal fields.
NonLiteral | 65536 | Non-literal fields.
AnyLiterality | 98304 | Any field literality (Literal | NonLiteral).
InParameter | 131072 | Input parameters.
CompilerGenerated | 262144 | Compiler-generated code (for instance closure types of anonymous method, iterator type, ...).
UserGenerated | 524288 | User-generated code (anything expected CompilerGenerated).
AnyGeneration | 786432 | Any code generation (CompilerGenerated | UserGenerated)l
OutParameter | 262144 | Output (out in C#) parameters.
RefParameter | 524288 | Input/Output (ref in C#) parameters.
AnyParameter | 917504 | Any kind of parameter passing (InParameter | OutParameter | RefParameter).
All | 1048574 | All members.

Remarks

When specifying attributes of target members or types, do not forget to provide all categories of flags, not only the category on which you want to put a restriction. If you want to limit, for instance, a custom attribute to be applied on public members, a good practice is to set TargetMemberAttributes = MulticastAttributes.Public | ~MulticastAttributes.AnyVisibility, unless the parent is more restrictive, in which case you should specify attributes explicitly.

See Also

PostSharp.Extensibility Namespace


MulticastAttributeUsageAttribute Class

MulticastAttributeUsageAttribute Class
Members See Also Send Feedback
Custom attribute that determines the usage of a MulticastAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MulticastAttributeUsageAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.MulticastAttributeUsageAttribute

See Also

MulticastAttributeUsageAttribute Members
PostSharp.Extensibility Namespace


MulticastAttributeUsageAttribute Members

[image]

PostSharp 2.0 Documentation
MulticastAttributeUsageAttribute Members
MulticastAttributeUsageAttribute Class Constructors Properties See Also Send Feedback

The MulticastAttributeUsageAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | MulticastAttributeUsageAttribute | Initializes a new MulticastAttributeUsageAttribute.

Properties

 | Name | Description
Public property | AllowExternalAssemblies | Determines whether this attribute can be applied to declaration of external assemblies (i.e. to other assemblies than the one in which the custom attribute is instantiated).
Public property | AllowMultiple | Determines whether many instances of the custom attribute are allowed on a single declaration.
Public property | Inheritance | Determines whether the custom attribute in inherited along the lines of inheritance of the target element.
Public property | PersistMetaData | Determines whether the custom attribute should be persisted in metadata, so that it would be available for System.Reflection.
Public property | TargetMemberAttributes | Gets or sets the attributes of the members (fields or methods) to which the custom attribute can be applied.
Public property | TargetParameterAttributes | Gets or sets the attributes of the parameter to which the custom attribute can be applied.
Public property | TargetTypeAttributes | Gets or sets the attributes of the types to which the custom attribute can be applied. If the custom attribute relates to fields or methods, this property specifies which attributes of the declaring type are acceptable.
Public property | ValidOn | Gets the kinds of targets that instances of the related MulticastAttribute apply to.

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


MulticastAttributeUsageAttribute Constructor

MulticastAttributeUsageAttribute Constructor
MulticastAttributeUsageAttribute Class See Also Send Feedback
Initializes a new MulticastAttributeUsageAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributeUsageAttribute(
    MulticastTargets validOn
)

Parameters

validOn
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of targets that instances of the related MulticastAttribute apply to.

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


MulticastAttributeUsageAttribute Properties

[image]

PostSharp 2.0 Documentation
MulticastAttributeUsageAttribute Properties
MulticastAttributeUsageAttribute Class See Also Send Feedback

The MulticastAttributeUsageAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AllowExternalAssemblies | Determines whether this attribute can be applied to declaration of external assemblies (i.e. to other assemblies than the one in which the custom attribute is instantiated).
Public property | AllowMultiple | Determines whether many instances of the custom attribute are allowed on a single declaration.
Public property | Inheritance | Determines whether the custom attribute in inherited along the lines of inheritance of the target element.
Public property | PersistMetaData | Determines whether the custom attribute should be persisted in metadata, so that it would be available for System.Reflection.
Public property | TargetMemberAttributes | Gets or sets the attributes of the members (fields or methods) to which the custom attribute can be applied.
Public property | TargetParameterAttributes | Gets or sets the attributes of the parameter to which the custom attribute can be applied.
Public property | TargetTypeAttributes | Gets or sets the attributes of the types to which the custom attribute can be applied. If the custom attribute relates to fields or methods, this property specifies which attributes of the declaring type are acceptable.
Public property | ValidOn | Gets the kinds of targets that instances of the related MulticastAttribute apply to.

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


AllowExternalAssemblies Property

MulticastAttributeUsageAttribute..::..AllowExternalAssemblies Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Determines whether this attribute can be applied to declaration of external assemblies (i.e. to other assemblies than the one in which the custom attribute is instantiated).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AllowExternalAssemblies { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


AllowMultiple Property

MulticastAttributeUsageAttribute..::..AllowMultiple Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Determines whether many instances of the custom attribute are allowed on a single declaration.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AllowMultiple { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


Inheritance Property

MulticastAttributeUsageAttribute..::..Inheritance Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Determines whether the custom attribute in inherited along the lines of inheritance of the target element.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastInheritance Inheritance { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace
MulticastAttribute..::.AttributeInheritance


PersistMetaData Property

MulticastAttributeUsageAttribute..::..PersistMetaData Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Determines whether the custom attribute should be persisted in metadata, so that it would be available for System.Reflection.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool PersistMetaData { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


TargetMemberAttributes Property

MulticastAttributeUsageAttribute..::..TargetMemberAttributes Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Gets or sets the attributes of the members (fields or methods) to which the custom attribute can be applied.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes TargetMemberAttributes { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


TargetParameterAttributes Property

MulticastAttributeUsageAttribute..::..TargetParameterAttributes Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Gets or sets the attributes of the parameter to which the custom attribute can be applied.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes TargetParameterAttributes { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


TargetTypeAttributes Property

MulticastAttributeUsageAttribute..::..TargetTypeAttributes Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Gets or sets the attributes of the types to which the custom attribute can be applied. If the custom attribute relates to fields or methods, this property specifies which attributes of the declaring type are acceptable.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributes TargetTypeAttributes { get; set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


ValidOn Property

MulticastAttributeUsageAttribute..::..ValidOn Property
MulticastAttributeUsageAttribute Class See Also Send Feedback
Gets the kinds of targets that instances of the related MulticastAttribute apply to.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastTargets ValidOn { get; internal set; }

See Also

MulticastAttributeUsageAttribute Class
PostSharp.Extensibility Namespace


MulticastInheritance Enumeration

MulticastInheritance Enumeration
See Also Send Feedback
Kind of inheritance of MulticastAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum MulticastInheritance

Members

Member name | Value | Description
None | 0 | No inheritance.
Strict | 1 | The instance is inherited to children of the original element, but multicasting is not applied to members of children.
Multicast | 2 | The instance is inherited to children of the original element and multicasting is applied to members of children.

See Also

PostSharp.Extensibility Namespace


MulticastTargets Enumeration

MulticastTargets Enumeration
See Also Send Feedback
Kinds of targets to which multicast custom attributes (MulticastAttribute) can apply.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum MulticastTargets

Members

Member name | Value | Description
Default | 0 | Specifies that the set of target elements is inherited from the parent custom attribute.
Class | 1 | Class.
Struct | 2 | Structure.
Enum | 4 | Enumeration.
Delegate | 8 | Delegate.
Interface | 16 | Interface.
AnyType | 31 | Any type (Class, Struct, Enum, Delegate or Interface).
Field | 32 | Field.
Method | 64 | Method (but not constructor).
Constructor | 384 | Obsolete. Constructor.
InstanceConstructor | 128 | Instance constructor.
StaticConstructor | 256 | Static constructor.
Property | 512 | Property (but not methods inside the property).
Event | 1024 | Event (but not methods inside the event).
AnyMember | 2016 | Any member (Field, Method, InstanceConstructor, StaticConstructor, Property, Event).
Assembly | 2048 | Assembly.
Parameter | 4096 | Method or property parameter.
ReturnValue | 8192 | Method or property return value.
All | 16383 | All element kinds.

See Also

PostSharp.Extensibility Namespace


PostSharpEnvironment Class

PostSharpEnvironment Class
Members See Also Send Feedback
Provides access to the current PostSharp environment (IPostSharpEnvironment).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class PostSharpEnvironment

Inheritance Hierarchy

System..::.Object
PostSharp.Extensibility..::.PostSharpEnvironment

See Also

PostSharpEnvironment Members
PostSharp.Extensibility Namespace


PostSharpEnvironment Members

[image]

PostSharp 2.0 Documentation
PostSharpEnvironment Members
PostSharpEnvironment Class Properties See Also Send Feedback

The PostSharpEnvironment type exposes the following members.

Properties

Name | Description
Current | Gets the current PostSharp environment, or null if the PostSharp Platform is not loaded in the current context.
IsPostSharpRunning | Determines whether the PostSharp Platform is currently loaded.

See Also

PostSharpEnvironment Class
PostSharp.Extensibility Namespace


PostSharpEnvironment Properties

[image]

PostSharp 2.0 Documentation
PostSharpEnvironment Properties
PostSharpEnvironment Class See Also Send Feedback

The PostSharpEnvironment type exposes the following members.

Properties

Name | Description
Current | Gets the current PostSharp environment, or null if the PostSharp Platform is not loaded in the current context.
IsPostSharpRunning | Determines whether the PostSharp Platform is currently loaded.

See Also

PostSharpEnvironment Class
PostSharp.Extensibility Namespace


Current Property

PostSharpEnvironment..::..Current Property
PostSharpEnvironment Class See Also Send Feedback
Gets the current PostSharp environment, or null if the PostSharp Platform is not loaded in the current context.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IPostSharpEnvironment Current { get; internal set; }

See Also

PostSharpEnvironment Class
PostSharp.Extensibility Namespace


IsPostSharpRunning Property

PostSharpEnvironment..::..IsPostSharpRunning Property
PostSharpEnvironment Class See Also Send Feedback
Determines whether the PostSharp Platform is currently loaded.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsPostSharpRunning { get; }

See Also

PostSharpEnvironment Class
PostSharp.Extensibility Namespace


PostSharpTrace Class

PostSharpTrace Class
Members See Also Send Feedback
Provides tracing functionality. An instance of the PostSharpTrace type implements a trace sink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PostSharpTrace

Inheritance Hierarchy

System..::.Object
PostSharp.Extensibility..::.PostSharpTrace

See Also

PostSharpTrace Members
PostSharp.Extensibility Namespace


PostSharpTrace Members

[image]

PostSharp 2.0 Documentation
PostSharpTrace Members
PostSharpTrace Class Constructors Methods Properties See Also Send Feedback

The PostSharpTrace type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharpTrace | Initialize a new PostSharpTrace sink.

Methods

 | Name | Description
 | EnableCategory | Overloaded.
Public method | Write | Overloaded.
Public method | WriteLine | Overloaded.

Properties

 | Name | Description
Public property | Enabled | Determines whether the current trace sink is enabled.

See Also

PostSharpTrace Class
PostSharp.Extensibility Namespace


PostSharpTrace Constructor

PostSharpTrace Constructor
PostSharpTrace Class See Also Send Feedback
Initialize a new PostSharpTrace sink.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PostSharpTrace(
    string category
)

Parameters

category
Type: System..::.String
Category of messages.

See Also

PostSharpTrace Class
PostSharp.Extensibility Namespace


PostSharpTrace Methods

[image]

PostSharp 2.0 Documentation
PostSharpTrace Methods
PostSharpTrace Class See Also Send Feedback

Methods

 | Name | Description
 | EnableCategory | Overloaded.
Public method | Write | Overloaded.
Public method | WriteLine | Overloaded.

See Also

PostSharpTrace Class
PostSharp.Extensibility Namespace


EnableCategory Method

[image]

PostSharp 2.0 Documentation
PostSharpTrace..::..EnableCategory Method
PostSharpTrace Class See Also Send Feedback

Overload List

Name | Description
EnableCategory(String) | Enables a trace category known by its name.
EnableCategory(PostSharpTrace) | Enables a trace category known by its object.

See Also

PostSharpTrace Class
PostSharpTrace Members
PostSharp.Extensibility Namespace


EnableCategory Method (String)

PostSharpTrace..::..EnableCategory Method (String)
PostSharpTrace Class See Also Send Feedback
Enables a trace category known by its name.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void EnableCategory(
    string category
)

Parameters

category
Type: System..::.String
The category name.

See Also

PostSharpTrace Class
EnableCategory Overload
PostSharp.Extensibility Namespace


EnableCategory Method (PostSharpTrace)

PostSharpTrace..::..EnableCategory Method (PostSharpTrace)
PostSharpTrace Class See Also Send Feedback
Enables a trace category known by its object.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void EnableCategory(
    PostSharpTrace category
)

Parameters

category
Type: PostSharp.Extensibility..::.PostSharpTrace
A PostSharpTrace object.

See Also

PostSharpTrace Class
EnableCategory Overload
PostSharp.Extensibility Namespace


Write Method

[image]

PostSharp 2.0 Documentation
PostSharpTrace..::..Write Method
PostSharpTrace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(String) | Writes a message to the current sink without formatting parameter.
Public method | Write(String, Object) | Writes a message to the current sink with a single formatting parameter.
Public method | Write(String, array<Object>[]()[]) | Writes a message to the current sink with many formatting parameters.
Public method | Write(String, Object, Object) | Writes a message to the current sink with two formatting parameters.
Public method | Write(String, Object, Object, Object) | Writes a message to the current sink with three formatting parameters.

See Also

PostSharpTrace Class
PostSharpTrace Members
PostSharp.Extensibility Namespace


Write Method (String)

PostSharpTrace..::..Write Method (String)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink without formatting parameter.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    string message
)

Parameters

message
Type: System..::.String
Message.

See Also

PostSharpTrace Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (String, Object)

PostSharpTrace..::..Write Method (String, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with a single formatting parameter.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    string format,
    Object arg0
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.

See Also

PostSharpTrace Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (String, Object[])

PostSharpTrace..::..Write Method (String, array<Object>[]()[][])
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with many formatting parameters.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    string format,
    params Object[] parameters
)

Parameters

format
Type: System..::.String
Message formatting string.
parameters
Type: array< System..::.Object >[]()[][]
Formatting parameters.

See Also

PostSharpTrace Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (String, Object, Object)

PostSharpTrace..::..Write Method (String, Object, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with two formatting parameters.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    string format,
    Object arg0,
    Object arg1
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.
arg1
Type: System..::.Object
The second formatting parameter.

See Also

PostSharpTrace Class
Write Overload
PostSharp.Extensibility Namespace


Write Method (String, Object, Object, Object)

PostSharpTrace..::..Write Method (String, Object, Object, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with three formatting parameters.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.
arg1
Type: System..::.Object
The second formatting parameter.
arg2
Type: System..::.Object
The thirs formatting parameter.

See Also

PostSharpTrace Class
Write Overload
PostSharp.Extensibility Namespace


WriteLine Method

[image]

PostSharp 2.0 Documentation
PostSharpTrace..::..WriteLine Method
PostSharpTrace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(String) | Writes a message to the current sink without parameter, and issues a line break.
Public method | WriteLine(String, Object) | Writes a message to the current sink with a single formatting parameter, and issues a line break.
Public method | WriteLine(String, array<Object>[]()[]) | Writes a message to the current sink with many formatting parameters, and issues a line break.
Public method | WriteLine(String, Object, Object) | Writes a message to the current sink with two formatting parameters, and issues a line break.
Public method | WriteLine(String, Object, Object, Object) | Writes a message to the current sink with three formatting parameters, and issues a line break.

See Also

PostSharpTrace Class
PostSharpTrace Members
PostSharp.Extensibility Namespace


WriteLine Method (String)

PostSharpTrace..::..WriteLine Method (String)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink without parameter, and issues a line break.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format
)

Parameters

format
Type: System..::.String
Message formatting string.

See Also

PostSharpTrace Class
WriteLine Overload
PostSharp.Extensibility Namespace


WriteLine Method (String, Object)

PostSharpTrace..::..WriteLine Method (String, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with a single formatting parameter, and issues a line break.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format,
    Object arg0
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.

See Also

PostSharpTrace Class
WriteLine Overload
PostSharp.Extensibility Namespace


WriteLine Method (String, Object[])

PostSharpTrace..::..WriteLine Method (String, array<Object>[]()[][])
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with many formatting parameters, and issues a line break.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format,
    params Object[] parameters
)

Parameters

format
Type: System..::.String
Message formatting string.
parameters
Type: array< System..::.Object >[]()[][]
Formatting parameters.

See Also

PostSharpTrace Class
WriteLine Overload
PostSharp.Extensibility Namespace


WriteLine Method (String, Object, Object)

PostSharpTrace..::..WriteLine Method (String, Object, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with two formatting parameters, and issues a line break.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format,
    Object arg0,
    Object arg1
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.
arg1
Type: System..::.Object
The second formatting parameter.

See Also

PostSharpTrace Class
WriteLine Overload
PostSharp.Extensibility Namespace


WriteLine Method (String, Object, Object, Object)

PostSharpTrace..::..WriteLine Method (String, Object, Object, Object)
PostSharpTrace Class See Also Send Feedback
Writes a message to the current sink with three formatting parameters, and issues a line break.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)

Parameters

format
Type: System..::.String
Message formatting string.
arg0
Type: System..::.Object
The first formatting parameter.
arg1
Type: System..::.Object
The second formatting parameter.
arg2
Type: System..::.Object
The thirs formatting parameter.

See Also

PostSharpTrace Class
WriteLine Overload
PostSharp.Extensibility Namespace


PostSharpTrace Properties

[image]

PostSharp 2.0 Documentation
PostSharpTrace Properties
PostSharpTrace Class See Also Send Feedback

The PostSharpTrace type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Determines whether the current trace sink is enabled.

See Also

PostSharpTrace Class
PostSharp.Extensibility Namespace


Enabled Property

PostSharpTrace..::..Enabled Property
PostSharpTrace Class See Also Send Feedback
Determines whether the current trace sink is enabled.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Enabled { get; }

See Also

PostSharpTrace Class
PostSharp.Extensibility Namespace


RequirePostSharpAttribute Class

RequirePostSharpAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on another custom attribute (a class derived from Attribute), means that assemblies with elements annotated with that custom attribute should be processed by PostSharp.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class RequirePostSharpAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.RequirePostSharpAttribute

See Also

RequirePostSharpAttribute Members
PostSharp.Extensibility Namespace


RequirePostSharpAttribute Members

[image]

PostSharp 2.0 Documentation
RequirePostSharpAttribute Members
RequirePostSharpAttribute Class Constructors Properties See Also Send Feedback

The RequirePostSharpAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | RequirePostSharpAttribute | Initializes a new RequirePostSharpAttribute.

Properties

 | Name | Description
Public property | PlugIn | Gets the name of the required plug-in (file name without the extension).
Public property | Task | Gets the name of the required task (should be defined in PlugIn).

See Also

RequirePostSharpAttribute Class
PostSharp.Extensibility Namespace


RequirePostSharpAttribute Constructor

RequirePostSharpAttribute Constructor
RequirePostSharpAttribute Class See Also Send Feedback
Initializes a new RequirePostSharpAttribute.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public RequirePostSharpAttribute(
    string plugIn,
    string task
)

Parameters

plugIn
Type: System..::.String
Name of the required plug-in (file name without extension).
task
Type: System..::.String
Name of the required task (should be defined in plugIn).

See Also

RequirePostSharpAttribute Class
PostSharp.Extensibility Namespace


RequirePostSharpAttribute Properties

[image]

PostSharp 2.0 Documentation
RequirePostSharpAttribute Properties
RequirePostSharpAttribute Class See Also Send Feedback

The RequirePostSharpAttribute type exposes the following members.

Properties

 | Name | Description
Public property | PlugIn | Gets the name of the required plug-in (file name without the extension).
Public property | Task | Gets the name of the required task (should be defined in PlugIn).

See Also

RequirePostSharpAttribute Class
PostSharp.Extensibility Namespace


PlugIn Property

RequirePostSharpAttribute..::..PlugIn Property
RequirePostSharpAttribute Class See Also Send Feedback
Gets the name of the required plug-in (file name without the extension).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PlugIn { get; }

See Also

RequirePostSharpAttribute Class
PostSharp.Extensibility Namespace


Task Property

RequirePostSharpAttribute..::..Task Property
RequirePostSharpAttribute Class See Also Send Feedback
Gets the name of the required task (should be defined in PlugIn).

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Task { get; }

See Also

RequirePostSharpAttribute Class
PostSharp.Extensibility Namespace


RequireReflectionWrapperAttribute Class

RequireReflectionWrapperAttribute Class
Members See Also Send Feedback
Custom attribute that, when applied on a type, specifies that all build-time semantics of this type require reflection wrappers to be passed instead of real reflection objects.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class RequireReflectionWrapperAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Extensibility..::.RequireReflectionWrapperAttribute

See Also

RequireReflectionWrapperAttribute Members
PostSharp.Extensibility Namespace


RequireReflectionWrapperAttribute Members

[image]

PostSharp 2.0 Documentation
RequireReflectionWrapperAttribute Members
RequireReflectionWrapperAttribute Class Constructors See Also Send Feedback

The RequireReflectionWrapperAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | RequireReflectionWrapperAttribute | Initializes a new instance of the RequireReflectionWrapperAttribute class

See Also

RequireReflectionWrapperAttribute Class
PostSharp.Extensibility Namespace


RequireReflectionWrapperAttribute Constructor

RequireReflectionWrapperAttribute Constructor
RequireReflectionWrapperAttribute Class See Also Send Feedback
Initializes a new instance of the RequireReflectionWrapperAttribute class

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public RequireReflectionWrapperAttribute()

See Also

RequireReflectionWrapperAttribute Class
PostSharp.Extensibility Namespace


SeverityType Enumeration

SeverityType Enumeration
See Also Send Feedback
Types of message severities.

Namespace: PostSharp.Extensibility
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum SeverityType

Members

Member name | Value | Description
Debug | 0 | Debugging information (typically trace).
Verbose | 1 | Verbose (lowly important information).
Info | 2 | Information.
ImportantInfo | 3 | Important information.
CommandLine | 4 | Command line.
Warning | 5 | Warning.
Error | 6 | Error.
Fatal | 7 | Fatal error.

See Also

PostSharp.Extensibility Namespace


PostSharp.Reflection Namespace

PostSharp.Reflection Namespace
Send Feedback
The PostSharp.Reflection namespace complements the System.Reflection namespace.

Classes

 | Class | Description
Public class | CustomReflectionBinder | Custom implementation of a reflection Binder that select methods based on exact matches using the ReflectionTypeComparer.
Public class | LocationInfo | Represents a FieldInfo, PropertyInfo or ParameterInfo, which all have the semantics of a location (get value, set value).
Public class | ObjectConstruction | Specifies how an object should be constructed, i.e. specifies the constructor to be used, the arguments to be passed to this constructor, and the fields or properties to be set.
Public class | ReflectionHelper | Provides helper methods for work with System.Reflection.
Public class | ReflectionTypeComparer | Comparer of reflection types (Type) based on content, not reference. Supports the unbound generic parameters derived from the GenericArg class.
Public class | SymbolSequencePoint | Maps a point in IL instructions to location in source code.

Interfaces

 | Interface | Description
Public interface | IAssemblyName | Defines the semantics of an assembly name.
Public interface | IAssemblyWrapper | Represents an Assembly without giving directly the Assembly object. The object allows browsing of contained types and of custom attributes.
Public interface | IReflectionWrapper | Interface implemented by all reflection wrappers.

Enumerations

 | Enumeration | Description
Public enumeration | LocationKind | Enumerates the kinds of code elements that can be encapsulated by a LocationInfo.
Public enumeration | Visibility | Visibility of types and type members.


CustomReflectionBinder Class

CustomReflectionBinder Class
Members See Also Send Feedback
Custom implementation of a reflection Binder that select methods based on exact matches using the ReflectionTypeComparer.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomReflectionBinder : Binder

Inheritance Hierarchy

System..::.Object
System.Reflection..::.Binder
PostSharp.Reflection..::.CustomReflectionBinder

See Also

CustomReflectionBinder Members
PostSharp.Reflection Namespace


CustomReflectionBinder Members

[image]

PostSharp 2.0 Documentation
CustomReflectionBinder Members
CustomReflectionBinder Class Methods Fields See Also Send Feedback

The CustomReflectionBinder type exposes the following members.

Methods

 | Name | Description
Public method | BindToField | Selects a field from the given set of fields, based on the specified criteria. (Overrides Binder..::.BindToField(BindingFlags, array<FieldInfo>[]()[], Object, CultureInfo).)
Public method | BindToMethod | Selects a method to invoke from the given set of methods, based on the supplied arguments. (Overrides Binder..::.BindToMethod(BindingFlags, array<MethodBase>[]()[], array<Object>[]()[]%, array<ParameterModifier>[]()[], CultureInfo, array<String>[]()[], Object%).)
Public method | ChangeType | Changes the type of the given Object to the given Type. (Overrides Binder..::.ChangeType(Object, Type, CultureInfo).)
Public method | ReorderArgumentArray | Upon returning from BindToMethod(BindingFlags, array<MethodBase>[]()[], array<Object>[]()[]%, array<ParameterModifier>[]()[], CultureInfo, array<String>[]()[], Object%), restores the args argument to what it was when it came from BindToMethod. (Overrides Binder..::.ReorderArgumentArray(array<Object>[]()[]%, Object).)
Public method | SelectMethod | Selects a method from the given set of methods, based on the argument type. (Overrides Binder..::.SelectMethod(BindingFlags, array<MethodBase>[]()[], array<Type>[]()[], array<ParameterModifier>[]()[]).)
Public method | SelectProperty | Selects a property from the given set of properties, based on the specified criteria. (Overrides Binder..::.SelectProperty(BindingFlags, array<PropertyInfo>[]()[], Type, array<Type>[]()[], array<ParameterModifier>[]()[]).)

Fields

Name | Description
Instance | Singleton instance.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


CustomReflectionBinder Fields

[image]

PostSharp 2.0 Documentation
CustomReflectionBinder Fields
CustomReflectionBinder Class See Also Send Feedback

The CustomReflectionBinder type exposes the following members.

Fields

Name | Description
Instance | Singleton instance.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


Instance Field

CustomReflectionBinder..::..Instance Field
CustomReflectionBinder Class See Also Send Feedback
Singleton instance.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly CustomReflectionBinder Instance

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


CustomReflectionBinder Methods

[image]

PostSharp 2.0 Documentation
CustomReflectionBinder Methods
CustomReflectionBinder Class See Also Send Feedback

The CustomReflectionBinder type exposes the following members.

Methods

 | Name | Description
Public method | BindToField | Selects a field from the given set of fields, based on the specified criteria. (Overrides Binder..::.BindToField(BindingFlags, array<FieldInfo>[]()[], Object, CultureInfo).)
Public method | BindToMethod | Selects a method to invoke from the given set of methods, based on the supplied arguments. (Overrides Binder..::.BindToMethod(BindingFlags, array<MethodBase>[]()[], array<Object>[]()[]%, array<ParameterModifier>[]()[], CultureInfo, array<String>[]()[], Object%).)
Public method | ChangeType | Changes the type of the given Object to the given Type. (Overrides Binder..::.ChangeType(Object, Type, CultureInfo).)
Public method | ReorderArgumentArray | Upon returning from BindToMethod(BindingFlags, array<MethodBase>[]()[], array<Object>[]()[]%, array<ParameterModifier>[]()[], CultureInfo, array<String>[]()[], Object%), restores the args argument to what it was when it came from BindToMethod. (Overrides Binder..::.ReorderArgumentArray(array<Object>[]()[]%, Object).)
Public method | SelectMethod | Selects a method from the given set of methods, based on the argument type. (Overrides Binder..::.SelectMethod(BindingFlags, array<MethodBase>[]()[], array<Type>[]()[], array<ParameterModifier>[]()[]).)
Public method | SelectProperty | Selects a property from the given set of properties, based on the specified criteria. (Overrides Binder..::.SelectProperty(BindingFlags, array<PropertyInfo>[]()[], Type, array<Type>[]()[], array<ParameterModifier>[]()[]).)

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


BindToField Method

CustomReflectionBinder..::..BindToField Method
CustomReflectionBinder Class See Also Send Feedback
Selects a field from the given set of fields, based on the specified criteria.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override FieldInfo BindToField(
    BindingFlags bindingFlags,
    FieldInfo[] match,
    Object value,
    CultureInfo culture
)

Parameters

bindingFlags
Type: System.Reflection..::.BindingFlags

[Missing <param name="bindingFlags"/> documentation for "M:PostSharp.Reflection.CustomReflectionBinder.BindToField(System.Reflection.BindingFlags,System.Reflection.FieldInfo[],System.Object,System.Globalization.CultureInfo)"]

match
Type: array< System.Reflection..::.FieldInfo >[]()[][]
The set of fields that are candidates for matching. For example, when a Binder object is used by InvokeMember()()(), this parameter specifies the set of fields that reflection has determined to be possible matches, typically because they have the correct member name. The default implementation provided by DefaultBinder changes the order of this array.
value
Type: System..::.Object
The field value used to locate a matching field.
culture
Type: System.Globalization..::.CultureInfo
An instance of CultureInfo that is used to control the coercion of data types, in binder implementations that coerce types. If culture is null, the CultureInfo for the current thread is used. Note: For example, if a binder implementation allows coercion of string values to numeric types, this parameter is necessary to convert a String that represents 1000 to a Double value, because 1000 is represented differently by different cultures. The default binder does not do such string coercions.

Return Value

The matching field.

Exceptions

Exception | Condition
System.Reflection..::.AmbiguousMatchException | For the default binder, bindingAttr includes SetField, and match contains multiple fields that are equally good matches for value. For example, value contains a MyClass object that implements the IMyClass interface, and match contains a field of type MyClass and a field of type IMyClass.
System..::.MissingFieldException | For the default binder, bindingAttr includes SetField, and match contains no fields that can accept value.
System..::.NullReferenceException | For the default binder, bindingAttr includes SetField, and match is null or an empty array. -or- bindingAttr includes SetField, and value is null.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


BindToMethod Method

CustomReflectionBinder..::..BindToMethod Method
CustomReflectionBinder Class See Also Send Feedback
Selects a method to invoke from the given set of methods, based on the supplied arguments.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override MethodBase BindToMethod(
    BindingFlags bindingFlags,
    MethodBase[] match,
    ref Object[] args,
    ParameterModifier[] modifiers,
    CultureInfo culture,
    string[] names,
    out Object state
)

Parameters

bindingFlags
Type: System.Reflection..::.BindingFlags

[Missing <param name="bindingFlags"/> documentation for "M:PostSharp.Reflection.CustomReflectionBinder.BindToMethod(System.Reflection.BindingFlags,System.Reflection.MethodBase[],System.Object[]@,System.Reflection.ParameterModifier[],System.Globalization.CultureInfo,System.String[],System.Object@)"]

match
Type: array< System.Reflection..::.MethodBase >[]()[][]
The set of methods that are candidates for matching. For example, when a Binder object is used by InvokeMember()()(), this parameter specifies the set of methods that reflection has determined to be possible matches, typically because they have the correct member name. The default implementation provided by DefaultBinder changes the order of this array.
args
Type: array< System..::.Object >[]()[][] %
The arguments that are passed in. The binder can change the order of the arguments in this array; for example, the default binder changes the order of arguments if the names parameter is used to specify an order other than positional order. If a binder implementation coerces argument types, the types and values of the arguments can be changed as well.
modifiers
Type: array< System.Reflection..::.ParameterModifier >[]()[][]
An array of parameter modifiers that enable binding to work with parameter signatures in which the types have been modified. The default binder implementation does not use this parameter.
culture
Type: System.Globalization..::.CultureInfo
An instance of CultureInfo that is used to control the coercion of data types, in binder implementations that coerce types. If culture is null, the CultureInfo for the current thread is used. Note: For example, if a binder implementation allows coercion of string values to numeric types, this parameter is necessary to convert a String that represents 1000 to a Double value, because 1000 is represented differently by different cultures. The default binder does not do such string coercions.
names
Type: array< System..::.String >[]()[][]
The parameter names, if parameter names are to be considered when matching, or null if arguments are to be treated as purely positional. For example, parameter names must be used if arguments are not supplied in positional order.
state
Type: System..::.Object %
After the method returns, state contains a binder-provided object that keeps track of argument reordering. The binder creates this object, and the binder is the sole consumer of this object. If state is not null when BindToMethod returns, you must pass state to the ReorderArgumentArray(array<Object>[]()[]%, Object) method if you want to restore args to its original order, for example, so that you can retrieve the values of ref parameters (ByRef parameters in Visual Basic).

Return Value

The matching method.

Exceptions

Exception | Condition
System.Reflection..::.AmbiguousMatchException | For the default binder, match contains multiple methods that are equally good matches for args. For example, args contains a MyClass object that implements the IMyClass interface, and match contains a method that takes MyClass and a method that takes IMyClass.
System..::.MissingMethodException | For the default binder, match contains no methods that can accept the arguments supplied in args.
System..::.ArgumentException | For the default binder, match is null or an empty array.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


ChangeType Method

CustomReflectionBinder..::..ChangeType Method
CustomReflectionBinder Class See Also Send Feedback
Changes the type of the given Object to the given Type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Object ChangeType(
    Object value,
    Type type,
    CultureInfo culture
)

Parameters

value
Type: System..::.Object
The object to change into a new Type.
type
Type: System..::.Type
The new Type that value will become.
culture
Type: System.Globalization..::.CultureInfo
An instance of CultureInfo that is used to control the coercion of data types. If culture is null, the CultureInfo for the current thread is used. Note: For example, this parameter is necessary to convert a String that represents 1000 to a Double value, because 1000 is represented differently by different cultures.

Return Value

An object that contains the given value as the new type.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


ReorderArgumentArray Method

CustomReflectionBinder..::..ReorderArgumentArray Method
CustomReflectionBinder Class See Also Send Feedback
Upon returning from BindToMethod(BindingFlags, array<MethodBase>[]()[], array<Object>[]()[]%, array<ParameterModifier>[]()[], CultureInfo, array<String>[]()[], Object%), restores the args argument to what it was when it came from BindToMethod.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ReorderArgumentArray(
    ref Object[] args,
    Object state
)

Parameters

args
Type: array< System..::.Object >[]()[][] %
The actual arguments that are passed in. Both the types and values of the arguments can be changed.
state
Type: System..::.Object
A binder-provided object that keeps track of argument reordering.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


SelectMethod Method

CustomReflectionBinder..::..SelectMethod Method
CustomReflectionBinder Class See Also Send Feedback
Selects a method from the given set of methods, based on the argument type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override MethodBase SelectMethod(
    BindingFlags bindingFlags,
    MethodBase[] match,
    Type[] types,
    ParameterModifier[] modifiers
)

Parameters

bindingFlags
Type: System.Reflection..::.BindingFlags

[Missing <param name="bindingFlags"/> documentation for "M:PostSharp.Reflection.CustomReflectionBinder.SelectMethod(System.Reflection.BindingFlags,System.Reflection.MethodBase[],System.Type[],System.Reflection.ParameterModifier[])"]

match
Type: array< System.Reflection..::.MethodBase >[]()[][]
The set of methods that are candidates for matching. For example, when a Binder object is used by InvokeMember()()(), this parameter specifies the set of methods that reflection has determined to be possible matches, typically because they have the correct member name. The default implementation provided by DefaultBinder changes the order of this array.
types
Type: array< System..::.Type >[]()[][]
The parameter types used to locate a matching method.
modifiers
Type: array< System.Reflection..::.ParameterModifier >[]()[][]
An array of parameter modifiers that enable binding to work with parameter signatures in which the types have been modified.

Return Value

The matching method, if found; otherwise, null.

Exceptions

Exception | Condition
System.Reflection..::.AmbiguousMatchException | For the default binder, match contains multiple methods that are equally good matches for the parameter types described by types. For example, the array in types contains a Type object for MyClass and the array in match contains a method that takes a base class of MyClass and a method that takes an interface that MyClass implements.
System..::.ArgumentException | For the default binder, match is null or an empty array. -or- An element of types derives from Type, but is not of type RuntimeType.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


SelectProperty Method

CustomReflectionBinder..::..SelectProperty Method
CustomReflectionBinder Class See Also Send Feedback
Selects a property from the given set of properties, based on the specified criteria.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override PropertyInfo SelectProperty(
    BindingFlags bindingFlags,
    PropertyInfo[] match,
    Type returnType,
    Type[] indexes,
    ParameterModifier[] modifiers
)

Parameters

bindingFlags
Type: System.Reflection..::.BindingFlags

[Missing <param name="bindingFlags"/> documentation for "M:PostSharp.Reflection.CustomReflectionBinder.SelectProperty(System.Reflection.BindingFlags,System.Reflection.PropertyInfo[],System.Type,System.Type[],System.Reflection.ParameterModifier[])"]

match
Type: array< System.Reflection..::.PropertyInfo >[]()[][]
The set of properties that are candidates for matching. For example, when a Binder object is used by InvokeMember()()(), this parameter specifies the set of properties that reflection has determined to be possible matches, typically because they have the correct member name. The default implementation provided by DefaultBinder changes the order of this array.
returnType
Type: System..::.Type
The return value the matching property must have.
indexes
Type: array< System..::.Type >[]()[][]
The index types of the property being searched for. Used for index properties such as the indexer for a class.
modifiers
Type: array< System.Reflection..::.ParameterModifier >[]()[][]
An array of parameter modifiers that enable binding to work with parameter signatures in which the types have been modified.

Return Value

The matching property.

Exceptions

Exception | Condition
System.Reflection..::.AmbiguousMatchException | For the default binder, match contains multiple properties that are equally good matches for returnType and indexes.
System..::.ArgumentException | For the default binder, match is null or an empty array.

See Also

CustomReflectionBinder Class
PostSharp.Reflection Namespace


IAssemblyName Interface

IAssemblyName Interface
Members See Also Send Feedback
Defines the semantics of an assembly name.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssemblyName

See Also

IAssemblyName Members
PostSharp.Reflection Namespace


IAssemblyName Members

[image]

PostSharp 2.0 Documentation
IAssemblyName Members
IAssemblyName Interface Methods Properties See Also Send Feedback

The IAssemblyName type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Version | Gets the assembly version.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


IAssemblyName Methods

[image]

PostSharp 2.0 Documentation
IAssemblyName Methods
IAssemblyName Interface See Also Send Feedback

The IAssemblyName type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


GetPublicKey Method

IAssemblyName..::..GetPublicKey Method
IAssemblyName Interface See Also Send Feedback
Gets the assembly public key.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
byte[] GetPublicKey()

Field Value

An array of bytes containing the public key, or null if no public key is specified (for instance if only the public key token is given).

Return Value

An array of bytes containing the public key, or null if no public key is specified.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


GetPublicKeyToken Method

IAssemblyName..::..GetPublicKeyToken Method
IAssemblyName Interface See Also Send Feedback
Gets the assembly public key token.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
byte[] GetPublicKeyToken()

Return Value

An array of bytes containing the public key token, or null if no public key is specified.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


IAssemblyName Properties

[image]

PostSharp 2.0 Documentation
IAssemblyName Properties
IAssemblyName Interface See Also Send Feedback

The IAssemblyName type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Version | Gets the assembly version.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


Culture Property

IAssemblyName..::..Culture Property
IAssemblyName Interface See Also Send Feedback
Gets the assembly culture name.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string Culture { get; }

Field Value

The standard assembly culture name, or null if the assembly is culture-neutral.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


IsMscorlib Property

IAssemblyName..::..IsMscorlib Property
IAssemblyName Interface See Also Send Feedback
Determines whether the current assembly (or assembly reference) is mscorlib.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsMscorlib { get; }

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


IsStronglyNamed Property

IAssemblyName..::..IsStronglyNamed Property
IAssemblyName Interface See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsStronglyNamed { get; }

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


Name Property

IAssemblyName..::..Name Property
IAssemblyName Interface See Also Send Feedback
Gets the assembly friendly name.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string Name { get; }

Field Value

The assembly friendly name.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


ProcessorArchitecture Property

IAssemblyName..::..ProcessorArchitecture Property
IAssemblyName Interface See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ProcessorArchitecture ProcessorArchitecture { get; }

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


Version Property

IAssemblyName..::..Version Property
IAssemblyName Interface See Also Send Feedback
Gets the assembly version.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Version Version { get; }

Field Value

A Version.

See Also

IAssemblyName Interface
PostSharp.Reflection Namespace


IAssemblyWrapper Interface

IAssemblyWrapper Interface
Members See Also Send Feedback
Represents an Assembly without giving directly the Assembly object. The object allows browsing of contained types and of custom attributes.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssemblyWrapper : IAssemblyName,
    IReflectionWrapper, ICustomAttributeProvider

See Also

IAssemblyWrapper Members
PostSharp.Reflection Namespace


IAssemblyWrapper Members

[image]

PostSharp 2.0 Documentation
IAssemblyWrapper Members
IAssemblyWrapper Interface Methods Properties See Also Send Feedback

The IAssemblyWrapper type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetTypes | Gets the list of types defined in this assembly.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element. (Inherited from IReflectionWrapper.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | UnderlyingSystemAssembly | Gets the system Assembly corresponding to the current object.
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper. (Inherited from IReflectionWrapper.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssemblyWrapper Interface
PostSharp.Reflection Namespace


IAssemblyWrapper Methods

[image]

PostSharp 2.0 Documentation
IAssemblyWrapper Methods
IAssemblyWrapper Interface See Also Send Feedback

The IAssemblyWrapper type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetTypes | Gets the list of types defined in this assembly.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

IAssemblyWrapper Interface
PostSharp.Reflection Namespace


GetTypes Method

IAssemblyWrapper..::..GetTypes Method
IAssemblyWrapper Interface See Also Send Feedback
Gets the list of types defined in this assembly.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Type[] GetTypes()

Return Value

The list of types defined in this assembly.

Remarks

This method does not return nested types.

See Also

IAssemblyWrapper Interface
PostSharp.Reflection Namespace


IAssemblyWrapper Properties

[image]

PostSharp 2.0 Documentation
IAssemblyWrapper Properties
IAssemblyWrapper Interface See Also Send Feedback

The IAssemblyWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element. (Inherited from IReflectionWrapper.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | UnderlyingSystemAssembly | Gets the system Assembly corresponding to the current object.
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper. (Inherited from IReflectionWrapper.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssemblyWrapper Interface
PostSharp.Reflection Namespace


UnderlyingSystemAssembly Property

IAssemblyWrapper..::..UnderlyingSystemAssembly Property
IAssemblyWrapper Interface See Also Send Feedback
Gets the system Assembly corresponding to the current object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Assembly UnderlyingSystemAssembly { get; }

See Also

IAssemblyWrapper Interface
PostSharp.Reflection Namespace


IReflectionWrapper Interface

IReflectionWrapper Interface
Members See Also Send Feedback
Interface implemented by all reflection wrappers.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IReflectionWrapper

See Also

IReflectionWrapper Members
PostSharp.Reflection Namespace


IReflectionWrapper Members

[image]

PostSharp 2.0 Documentation
IReflectionWrapper Members
IReflectionWrapper Interface Properties See Also Send Feedback

The IReflectionWrapper type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element.
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper.

See Also

IReflectionWrapper Interface
PostSharp.Reflection Namespace


IReflectionWrapper Properties

[image]

PostSharp 2.0 Documentation
IReflectionWrapper Properties
IReflectionWrapper Interface See Also Send Feedback

The IReflectionWrapper type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element.
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper.

See Also

IReflectionWrapper Interface
PostSharp.Reflection Namespace


DeclaringAssemblyName Property

IReflectionWrapper..::..DeclaringAssemblyName Property
IReflectionWrapper Interface See Also Send Feedback
Gets the name of the assembly declaring the current element.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAssemblyName DeclaringAssemblyName { get; }

See Also

IReflectionWrapper Interface
PostSharp.Reflection Namespace


UnderlyingSystemObject Property

IReflectionWrapper..::..UnderlyingSystemObject Property
IReflectionWrapper Interface See Also Send Feedback
Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object UnderlyingSystemObject { get; }

See Also

IReflectionWrapper Interface
PostSharp.Reflection Namespace


LocationInfo Class

LocationInfo Class
Members See Also Send Feedback
Represents a FieldInfo, PropertyInfo or ParameterInfo, which all have the semantics of a location (get value, set value).

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class LocationInfo : ISerializable,
    IEquatable<LocationInfo>

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection..::.LocationInfo

See Also

LocationInfo Members
PostSharp.Reflection Namespace


LocationInfo Members

[image]

PostSharp 2.0 Documentation
LocationInfo Members
LocationInfo Class Constructors Methods Operators Properties See Also Send Feedback

The LocationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LocationInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetValue | Overloaded.
Public method | SetValue | Overloaded.
 | ToLocationInfo | Initializes a new LocationInfo from a FieldInfo, PropertyInfo, or ParameterInfo.
 | ToLocationInfoArray | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two instances of LocationInfo represent the same element of code.
Inequality | Determines whether two instances of LocationInfo represent different elements of code.

Properties

 | Name | Description
Public property | DeclaringType | Gets the declaring type of the underlying field, property, parameter, or return value.
Public property | FieldInfo | Gets the underlying FieldInfo, or null if the underlying code element is not a property.
Public property | IsStatic | Determines whether the underlying field or property is static.
Public property | LocationKind | Gets the location kind (Field, Property, Parameter or ReturnValue).
Public property | LocationType | Gets the type of values that can be stored in the location.
Public property | Name | Gets the name of the underlying field, property, parameter, or return value.
Public property | ParameterInfo | Gets the underlying ParameterInfo, or null if the underlying code element is not a property.
Public property | PropertyInfo | Gets the underlying PropertyInfo, or null if the underlying code element is not a property.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationInfo Constructor

[image]

PostSharp 2.0 Documentation
LocationInfo Constructor
LocationInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LocationInfo(FieldInfo) | Initializes a new LocationInfo from a FieldInfo.
Public method | LocationInfo(ParameterInfo) | Initializes a new LocationInfo from a ParameterInfo.
Public method | LocationInfo(PropertyInfo) | Initializes a new LocationInfo from a PropertyInfo.

See Also

LocationInfo Class
LocationInfo Members
PostSharp.Reflection Namespace


LocationInfo Constructor (FieldInfo)

LocationInfo Constructor (FieldInfo)
LocationInfo Class See Also Send Feedback
Initializes a new LocationInfo from a FieldInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInfo(
    FieldInfo fieldInfo
)

Parameters

fieldInfo
Type: System.Reflection..::.FieldInfo
The field represented by the LocationInfo.

See Also

LocationInfo Class
LocationInfo Overload
PostSharp.Reflection Namespace


LocationInfo Constructor (ParameterInfo)

LocationInfo Constructor (ParameterInfo)
LocationInfo Class See Also Send Feedback
Initializes a new LocationInfo from a ParameterInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInfo(
    ParameterInfo parameterInfo
)

Parameters

parameterInfo
Type: System.Reflection..::.ParameterInfo
The parameter represented by the LocationInfo.

See Also

LocationInfo Class
LocationInfo Overload
PostSharp.Reflection Namespace


LocationInfo Constructor (PropertyInfo)

LocationInfo Constructor (PropertyInfo)
LocationInfo Class See Also Send Feedback
Initializes a new LocationInfo from a PropertyInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInfo(
    PropertyInfo propertyInfo
)

Parameters

propertyInfo
Type: System.Reflection..::.PropertyInfo
The property represented by the LocationInfo.

See Also

LocationInfo Class
LocationInfo Overload
PostSharp.Reflection Namespace


LocationInfo Methods

[image]

PostSharp 2.0 Documentation
LocationInfo Methods
LocationInfo Class See Also Send Feedback

The LocationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetValue | Overloaded.
Public method | SetValue | Overloaded.
 | ToLocationInfo | Initializes a new LocationInfo from a FieldInfo, PropertyInfo, or ParameterInfo.
 | ToLocationInfoArray | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

LocationInfo Class
PostSharp.Reflection Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
LocationInfo..::..Equals Method
LocationInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Public method | Equals(LocationInfo) | Indicates whether the current object is equal to another object of the same type.

See Also

LocationInfo Class
LocationInfo Members
PostSharp.Reflection Namespace


Equals Method (Object)

LocationInfo..::..Equals Method (Object)
LocationInfo Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

LocationInfo Class
Equals Overload
PostSharp.Reflection Namespace


Equals Method (LocationInfo)

LocationInfo..::..Equals Method (LocationInfo)
LocationInfo Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    LocationInfo other
)

Parameters

other
Type: PostSharp.Reflection..::.LocationInfo
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

LocationInfo Class
Equals Overload
PostSharp.Reflection Namespace


GetHashCode Method

LocationInfo..::..GetHashCode Method
LocationInfo Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A hash code for the current Object.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


GetObjectData Method

LocationInfo..::..GetObjectData Method
LocationInfo Class See Also Send Feedback
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System.Security..::.SecurityException | The caller does not have the required permission.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


GetValue Method

[image]

PostSharp 2.0 Documentation
LocationInfo..::..GetValue Method
LocationInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(Object) | Returns the value of the field or property represented by the current object.
Public method | GetValue(Object, array<Object>[]()[]) | Returns the value of the field or property represented by the current object with optional index values for indexed properties.

See Also

LocationInfo Class
LocationInfo Members
PostSharp.Reflection Namespace


GetValue Method (Object)

LocationInfo..::..GetValue Method (Object)
LocationInfo Class See Also Send Feedback
Returns the value of the field or property represented by the current object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetValue(
    Object instance
)

Parameters

instance
Type: System..::.Object
The object whose field or property value will be returned (null if the field or property is static).

Return Value

The value of the field or property.

See Also

LocationInfo Class
GetValue Overload
PostSharp.Reflection Namespace


GetValue Method (Object, Object[])

LocationInfo..::..GetValue Method (Object, array<Object>[]()[][])
LocationInfo Class See Also Send Feedback
Returns the value of the field or property represented by the current object with optional index values for indexed properties.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetValue(
    Object instance,
    Object[] index
)

Parameters

instance
Type: System..::.Object
The object whose field or property value will be returned (null if the field or property is static).
index
Type: array< System..::.Object >[]()[][]
Optional index values for indexed properties. null for fields or non-index properties.

Return Value

The value of the field or property.

See Also

LocationInfo Class
GetValue Overload
PostSharp.Reflection Namespace


SetValue Method

[image]

PostSharp 2.0 Documentation
LocationInfo..::..SetValue Method
LocationInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Object, Object) | Sets the value of the field or property represented by the current object to a given value.
Public method | SetValue(Object, Object, array<Object>[]()[]) | Sets the value of the field or property represented by the current object to a given value with optional index values for indexed properties.

See Also

LocationInfo Class
LocationInfo Members
PostSharp.Reflection Namespace


SetValue Method (Object, Object)

LocationInfo..::..SetValue Method (Object, Object)
LocationInfo Class See Also Send Feedback
Sets the value of the field or property represented by the current object to a given value.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetValue(
    Object instance,
    Object value
)

Parameters

instance
Type: System..::.Object
The object whose field or property value will be changed (null if the field or property is static).
value
Type: System..::.Object
New value.

See Also

LocationInfo Class
SetValue Overload
PostSharp.Reflection Namespace


SetValue Method (Object, Object, Object[])

LocationInfo..::..SetValue Method (Object, Object, array<Object>[]()[][])
LocationInfo Class See Also Send Feedback
Sets the value of the field or property represented by the current object to a given value with optional index values for indexed properties.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetValue(
    Object instance,
    Object value,
    Object[] index
)

Parameters

instance
Type: System..::.Object
The object whose field or property value will be changed (null if the field or property is static).
value
Type: System..::.Object
New value.
index
Type: array< System..::.Object >[]()[][]
Optional index values for indexed properties. null for fields or non-index properties.

See Also

LocationInfo Class
SetValue Overload
PostSharp.Reflection Namespace


ToLocationInfo Method

LocationInfo..::..ToLocationInfo Method
LocationInfo Class See Also Send Feedback
Initializes a new LocationInfo from a FieldInfo, PropertyInfo, or ParameterInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static LocationInfo ToLocationInfo(
    Object reflectionInfo
)

Parameters

reflectionInfo
Type: System..::.Object

[Missing <param name="reflectionInfo"/> documentation for "M:PostSharp.Reflection.LocationInfo.ToLocationInfo(System.Object)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Reflection.LocationInfo.ToLocationInfo(System.Object)"]

See Also

LocationInfo Class
PostSharp.Reflection Namespace


ToLocationInfoArray Method

[image]

PostSharp 2.0 Documentation
LocationInfo..::..ToLocationInfoArray Method
LocationInfo Class See Also Send Feedback

Overload List

Name | Description
ToLocationInfoArray(ICollection<(Of <(FieldInfo>)>)) | Converts a collection of FieldInfo into an array of LocationInfo.
ToLocationInfoArray(ICollection<(Of <(ParameterInfo>)>)) | Converts a collection of ParameterInfo into an array of LocationInfo.
ToLocationInfoArray(ICollection<(Of <(PropertyInfo>)>)) | Converts a collection of PropertyInfo into an array of LocationInfo.

See Also

LocationInfo Class
LocationInfo Members
PostSharp.Reflection Namespace


ToLocationInfoArray Method (ICollection(FieldInfo))

LocationInfo..::..ToLocationInfoArray Method (ICollection<(Of <(<'FieldInfo>)>)>)
LocationInfo Class See Also Send Feedback
Converts a collection of FieldInfo into an array of LocationInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static LocationInfo[] ToLocationInfoArray(
    ICollection<FieldInfo> fields
)

Parameters

fields
Type: System.Collections.Generic..::.ICollection <(Of <(<' FieldInfo >)>)>
A collection of FieldInfo.

Return Value

An array of LocationInfo.

See Also

LocationInfo Class
ToLocationInfoArray Overload
PostSharp.Reflection Namespace


ToLocationInfoArray Method (ICollection(ParameterInfo))

LocationInfo..::..ToLocationInfoArray Method (ICollection<(Of <(<'ParameterInfo>)>)>)
LocationInfo Class See Also Send Feedback
Converts a collection of ParameterInfo into an array of LocationInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static LocationInfo[] ToLocationInfoArray(
    ICollection<ParameterInfo> parameters
)

Parameters

parameters
Type: System.Collections.Generic..::.ICollection <(Of <(<' ParameterInfo >)>)>
A collection of ParameterInfo.

Return Value

An array of LocationInfo.

See Also

LocationInfo Class
ToLocationInfoArray Overload
PostSharp.Reflection Namespace


ToLocationInfoArray Method (ICollection(PropertyInfo))

LocationInfo..::..ToLocationInfoArray Method (ICollection<(Of <(<'PropertyInfo>)>)>)
LocationInfo Class See Also Send Feedback
Converts a collection of PropertyInfo into an array of LocationInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static LocationInfo[] ToLocationInfoArray(
    ICollection<PropertyInfo> properties
)

Parameters

properties
Type: System.Collections.Generic..::.ICollection <(Of <(<' PropertyInfo >)>)>
A collection of PropertyInfo.

Return Value

An array of LocationInfo.

See Also

LocationInfo Class
ToLocationInfoArray Overload
PostSharp.Reflection Namespace


ToString Method

LocationInfo..::..ToString Method
LocationInfo Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationInfo Operators

[image]

PostSharp 2.0 Documentation
LocationInfo Operators
LocationInfo Class See Also Send Feedback

The LocationInfo type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of LocationInfo represent the same element of code.
Inequality | Determines whether two instances of LocationInfo represent different elements of code.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


Equality Operator

LocationInfo..::..Equality Operator
LocationInfo Class See Also Send Feedback
Determines whether two instances of LocationInfo represent the same element of code.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    LocationInfo left,
    LocationInfo right
)

Parameters

left
Type: PostSharp.Reflection..::.LocationInfo
A LocationInfo.
right
Type: PostSharp.Reflection..::.LocationInfo
A LocationInfo.

Return Value

true if left and right are equal, otherwise false.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


Inequality Operator

LocationInfo..::..Inequality Operator
LocationInfo Class See Also Send Feedback
Determines whether two instances of LocationInfo represent different elements of code.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    LocationInfo left,
    LocationInfo right
)

Parameters

left
Type: PostSharp.Reflection..::.LocationInfo
A LocationInfo.
right
Type: PostSharp.Reflection..::.LocationInfo
A LocationInfo.

Return Value

true if left and right are different, otherwise false.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationInfo Properties

[image]

PostSharp 2.0 Documentation
LocationInfo Properties
LocationInfo Class See Also Send Feedback

The LocationInfo type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringType | Gets the declaring type of the underlying field, property, parameter, or return value.
Public property | FieldInfo | Gets the underlying FieldInfo, or null if the underlying code element is not a property.
Public property | IsStatic | Determines whether the underlying field or property is static.
Public property | LocationKind | Gets the location kind (Field, Property, Parameter or ReturnValue).
Public property | LocationType | Gets the type of values that can be stored in the location.
Public property | Name | Gets the name of the underlying field, property, parameter, or return value.
Public property | ParameterInfo | Gets the underlying ParameterInfo, or null if the underlying code element is not a property.
Public property | PropertyInfo | Gets the underlying PropertyInfo, or null if the underlying code element is not a property.

See Also

LocationInfo Class
PostSharp.Reflection Namespace


DeclaringType Property

LocationInfo..::..DeclaringType Property
LocationInfo Class See Also Send Feedback
Gets the declaring type of the underlying field, property, parameter, or return value.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type DeclaringType { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


FieldInfo Property

LocationInfo..::..FieldInfo Property
LocationInfo Class See Also Send Feedback
Gets the underlying FieldInfo, or null if the underlying code element is not a property.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo FieldInfo { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


IsStatic Property

LocationInfo..::..IsStatic Property
LocationInfo Class See Also Send Feedback
Determines whether the underlying field or property is static.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationKind Property

LocationInfo..::..LocationKind Property
LocationInfo Class See Also Send Feedback
Gets the location kind (Field, Property, Parameter or ReturnValue).

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationKind LocationKind { get; private set; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationType Property

LocationInfo..::..LocationType Property
LocationInfo Class See Also Send Feedback
Gets the type of values that can be stored in the location.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type LocationType { get; private set; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


Name Property

LocationInfo..::..Name Property
LocationInfo Class See Also Send Feedback
Gets the name of the underlying field, property, parameter, or return value.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


ParameterInfo Property

LocationInfo..::..ParameterInfo Property
LocationInfo Class See Also Send Feedback
Gets the underlying ParameterInfo, or null if the underlying code element is not a property.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterInfo ParameterInfo { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


PropertyInfo Property

LocationInfo..::..PropertyInfo Property
LocationInfo Class See Also Send Feedback
Gets the underlying PropertyInfo, or null if the underlying code element is not a property.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyInfo PropertyInfo { get; }

See Also

LocationInfo Class
PostSharp.Reflection Namespace


LocationKind Enumeration

LocationKind Enumeration
See Also Send Feedback
Enumerates the kinds of code elements that can be encapsulated by a LocationInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum LocationKind

Members

Member name | Value | Description
Field | 0 | FieldInfo.
Property | 1 | PropertyInfo.
Parameter | 2 | A ParameterInfo representing a parameter (not a ReturnValue).
ReturnValue | 3 | A ParameterInfo representing a return value.

See Also

PostSharp.Reflection Namespace


ObjectConstruction Class

ObjectConstruction Class
Members See Also Send Feedback
Specifies how an object should be constructed, i.e. specifies the constructor to be used, the arguments to be passed to this constructor, and the fields or properties to be set.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ObjectConstruction

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection..::.ObjectConstruction

See Also

ObjectConstruction Members
PostSharp.Reflection Namespace


ObjectConstruction Members

[image]

PostSharp 2.0 Documentation
ObjectConstruction Members
ObjectConstruction Class Constructors Properties See Also Send Feedback

The ObjectConstruction type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectConstruction | Overloaded.

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the arguments passed to the custom attribute constructor.
Public property | NamedArguments | Gets the collection of named arguments.
Public property | TypeName | Gets the assembly-qualified type name of the object.

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


ObjectConstruction Constructor

[image]

PostSharp 2.0 Documentation
ObjectConstruction Constructor
ObjectConstruction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ObjectConstruction(CustomAttributeData) | Initializes a new type-safe ObjectConstruction from a CustomAttributeData
Public method | ObjectConstruction(ConstructorInfo, array<Object>[]()[]) | Initializes a new type-safe ObjectConstruction from a ConstructorInfo.
Public method | ObjectConstruction(String, array<Object>[]()[]) | Initializes a new ObjectConstruction by specifying a type name and a list of constructor arguments.
Public method | ObjectConstruction(Type, array<Object>[]()[]) | Initializes a new ObjectConstruction by specifying a type name and a list of constructor arguments.

See Also

ObjectConstruction Class
ObjectConstruction Members
PostSharp.Reflection Namespace


ObjectConstruction Constructor (CustomAttributeData)

ObjectConstruction Constructor (CustomAttributeData)
ObjectConstruction Class See Also Send Feedback
Initializes a new type-safe ObjectConstruction from a CustomAttributeData

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction(
    CustomAttributeData customAttributeData
)

Parameters

customAttributeData
Type: System.Reflection..::.CustomAttributeData
A CustomAttributeData

See Also

ObjectConstruction Class
ObjectConstruction Overload
PostSharp.Reflection Namespace


ObjectConstruction Constructor (ConstructorInfo, Object[])

ObjectConstruction Constructor (ConstructorInfo, array<Object>[]()[][])
ObjectConstruction Class See Also Send Feedback
Initializes a new type-safe ObjectConstruction from a ConstructorInfo.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction(
    ConstructorInfo constructor,
    params Object[] constructorArguments
)

Parameters

constructor
Type: System.Reflection..::.ConstructorInfo
Constructor.
constructorArguments
Type: array< System..::.Object >[]()[][]
Arguments passed to the constructor.

See Also

ObjectConstruction Class
ObjectConstruction Overload
PostSharp.Reflection Namespace


ObjectConstruction Constructor (String, Object[])

ObjectConstruction Constructor (String, array<Object>[]()[][])
ObjectConstruction Class See Also Send Feedback
Initializes a new ObjectConstruction by specifying a type name and a list of constructor arguments.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction(
    string typeName,
    params Object[] constructorArguments
)

Parameters

typeName
Type: System..::.String
Name of the object type.
constructorArguments
Type: array< System..::.Object >[]()[][]
Arguments passed to the constructor.

See Also

ObjectConstruction Class
ObjectConstruction Overload
PostSharp.Reflection Namespace


ObjectConstruction Constructor (Type, Object[])

ObjectConstruction Constructor (Type, array<Object>[]()[][])
ObjectConstruction Class See Also Send Feedback
Initializes a new ObjectConstruction by specifying a type name and a list of constructor arguments.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ObjectConstruction(
    Type type,
    params Object[] constructorArguments
)

Parameters

type
Type: System..::.Type
Object type.
constructorArguments
Type: array< System..::.Object >[]()[][]
Arguments passed to the constructor.

See Also

ObjectConstruction Class
ObjectConstruction Overload
PostSharp.Reflection Namespace


ObjectConstruction Properties

[image]

PostSharp 2.0 Documentation
ObjectConstruction Properties
ObjectConstruction Class See Also Send Feedback

The ObjectConstruction type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the arguments passed to the custom attribute constructor.
Public property | NamedArguments | Gets the collection of named arguments.
Public property | TypeName | Gets the assembly-qualified type name of the object.

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


Constructor Property

ObjectConstruction..::..Constructor Property
ObjectConstruction Class See Also Send Feedback
Gets the custom attribute constructor.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ConstructorInfo Constructor { get; }

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


ConstructorArguments Property

ObjectConstruction..::..ConstructorArguments Property
ObjectConstruction Class See Also Send Feedback
Gets the arguments passed to the custom attribute constructor.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<Object> ConstructorArguments { get; }

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


NamedArguments Property

ObjectConstruction..::..NamedArguments Property
ObjectConstruction Class See Also Send Feedback
Gets the collection of named arguments.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<string, Object> NamedArguments { get; }

Remarks

This collection is a dictionary associating the name of public a field or property of the custom attributes to the value that should be assigned to it.

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


TypeName Property

ObjectConstruction..::..TypeName Property
ObjectConstruction Class See Also Send Feedback
Gets the assembly-qualified type name of the object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TypeName { get; }

See Also

ObjectConstruction Class
PostSharp.Reflection Namespace


ReflectionHelper Class

ReflectionHelper Class
Members See Also Send Feedback
Provides helper methods for work with System.Reflection.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class ReflectionHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection..::.ReflectionHelper

See Also

ReflectionHelper Members
PostSharp.Reflection Namespace


ReflectionHelper Members

[image]

PostSharp 2.0 Documentation
ReflectionHelper Members
ReflectionHelper Class Methods See Also Send Feedback

The ReflectionHelper type exposes the following members.

Methods

Name | Description
GetMethod | Identifies and gets a method in a type given its complete string-serialized signature.
GetProperty | Identifies and gets a property in a type given its complete string-serialized signature.

See Also

ReflectionHelper Class
PostSharp.Reflection Namespace


ReflectionHelper Methods

[image]

PostSharp 2.0 Documentation
ReflectionHelper Methods
ReflectionHelper Class See Also Send Feedback

The ReflectionHelper type exposes the following members.

Methods

Name | Description
GetMethod | Identifies and gets a method in a type given its complete string-serialized signature.
GetProperty | Identifies and gets a property in a type given its complete string-serialized signature.

See Also

ReflectionHelper Class
PostSharp.Reflection Namespace


GetMethod Method

ReflectionHelper..::..GetMethod Method
ReflectionHelper Class See Also Send Feedback
Identifies and gets a method in a type given its complete string-serialized signature.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static MethodBase GetMethod(
    Type type,
    string methodName,
    string methodSignature
)

Parameters

type
Type: System..::.Type
Type declaring the method.
methodName
Type: System..::.String
Method name.
methodSignature
Type: System..::.String
Method signature (from MethodBase.ToString()).

Return Value

The method (or constructor) with signature methodSignature in type, or null if such method was not found.

See Also

ReflectionHelper Class
PostSharp.Reflection Namespace


GetProperty Method

ReflectionHelper..::..GetProperty Method
ReflectionHelper Class See Also Send Feedback
Identifies and gets a property in a type given its complete string-serialized signature.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static PropertyInfo GetProperty(
    Type type,
    string propertyName,
    string propertySignature
)

Parameters

type
Type: System..::.Type
Type declaring the property.
propertyName
Type: System..::.String
Property name.
propertySignature
Type: System..::.String
Property signature (from PropertyInfo.ToString).

Return Value

The property, or null if the property was not found.

See Also

ReflectionHelper Class
PostSharp.Reflection Namespace


ReflectionTypeComparer Class

ReflectionTypeComparer Class
Members See Also Send Feedback
Comparer of reflection types (Type) based on content, not reference. Supports the unbound generic parameters derived from the GenericArg class.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ReflectionTypeComparer : IEqualityComparer<Type>,
    IEqualityComparer<Type[]>

Remarks

Used by the CustomReflectionBinder class.

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection..::.ReflectionTypeComparer

See Also

ReflectionTypeComparer Members
PostSharp.Reflection Namespace


ReflectionTypeComparer Members

[image]

PostSharp 2.0 Documentation
ReflectionTypeComparer Members
ReflectionTypeComparer Class Methods See Also Send Feedback

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Overloaded.

See Also

ReflectionTypeComparer Class
PostSharp.Reflection Namespace


ReflectionTypeComparer Methods

[image]

PostSharp 2.0 Documentation
ReflectionTypeComparer Methods
ReflectionTypeComparer Class See Also Send Feedback

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Overloaded.

See Also

ReflectionTypeComparer Class
PostSharp.Reflection Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
ReflectionTypeComparer..::..Equals Method
ReflectionTypeComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Type, Type) | Determines whether the specified objects are equal.
Public method | Equals(array<Type>[]()[], array<Type>[]()[]) | Determines whether the specified objects are equal.

See Also

ReflectionTypeComparer Class
ReflectionTypeComparer Members
PostSharp.Reflection Namespace


Equals Method (Type, Type)

ReflectionTypeComparer..::..Equals Method (Type, Type)
ReflectionTypeComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    Type x,
    Type y
)

Parameters

x
Type: System..::.Type
The first object of type T to compare.
y
Type: System..::.Type
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

ReflectionTypeComparer Class
Equals Overload
PostSharp.Reflection Namespace


Equals Method (Type[], Type[])

ReflectionTypeComparer..::..Equals Method (array<Type>[]()[][], array<Type>[]()[][])
ReflectionTypeComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    Type[] x,
    Type[] y
)

Parameters

x
Type: array< System..::.Type >[]()[][]
The first object of type T to compare.
y
Type: array< System..::.Type >[]()[][]
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

ReflectionTypeComparer Class
Equals Overload
PostSharp.Reflection Namespace


GetHashCode Method

[image]

PostSharp 2.0 Documentation
ReflectionTypeComparer..::..GetHashCode Method
ReflectionTypeComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode(Type) | Returns a hash code for the specified object.
Public method | GetHashCode(array<Type>[]()[]) | Returns a hash code for the specified object.

See Also

ReflectionTypeComparer Class
ReflectionTypeComparer Members
PostSharp.Reflection Namespace


GetHashCode Method (Type)

ReflectionTypeComparer..::..GetHashCode Method (Type)
ReflectionTypeComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    Type obj
)

Parameters

obj
Type: System..::.Type
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

ReflectionTypeComparer Class
GetHashCode Overload
PostSharp.Reflection Namespace


GetHashCode Method (Type[])

ReflectionTypeComparer..::..GetHashCode Method (array<Type>[]()[][])
ReflectionTypeComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    Type[] obj
)

Parameters

obj
Type: array< System..::.Type >[]()[][]
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

ReflectionTypeComparer Class
GetHashCode Overload
PostSharp.Reflection Namespace


GetInstance Method

[image]

PostSharp 2.0 Documentation
ReflectionTypeComparer..::..GetInstance Method
ReflectionTypeComparer Class See Also Send Feedback

Overload List

Name | Description
GetInstance()()() | Gets an instance of ReflectionTypeComparer that does not perform substitution of generic parameters.
GetInstance(array<Type>[]()[], array<Type>[]()[], array<Type>[]()[], array<Type>[]()[]) | Gets an instance of ReflectionTypeComparer that performs substitution of generic parameters.

See Also

ReflectionTypeComparer Class
ReflectionTypeComparer Members
PostSharp.Reflection Namespace


GetInstance Method

ReflectionTypeComparer..::..GetInstance Method
ReflectionTypeComparer Class See Also Send Feedback
Gets an instance of ReflectionTypeComparer that does not perform substitution of generic parameters.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ReflectionTypeComparer GetInstance()

Return Value

An instance of ReflectionTypeComparer.

See Also

ReflectionTypeComparer Class
GetInstance Overload
PostSharp.Reflection Namespace


GetInstance Method (Type[], Type[], Type[], Type[])

ReflectionTypeComparer..::..GetInstance Method (array<Type>[]()[][], array<Type>[]()[][], array<Type>[]()[][], array<Type>[]()[][])
ReflectionTypeComparer Class See Also Send Feedback
Gets an instance of ReflectionTypeComparer that performs substitution of generic parameters.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ReflectionTypeComparer GetInstance(
    Type[] leftGenericTypeParameters,
    Type[] leftGenericMethodParameters,
    Type[] rightGenericTypeParameters,
    Type[] rightGenericMethodParameters
)

Parameters

leftGenericTypeParameters
Type: array< System..::.Type >[]()[][]
Array of types to be substituted to the generic type parameters of the left member.
leftGenericMethodParameters
Type: array< System..::.Type >[]()[][]
Array of types to be substituted to the generic method parameters of the left member.
rightGenericTypeParameters
Type: array< System..::.Type >[]()[][]
Array of types to be substituted to the generic type parameters of the right member.
rightGenericMethodParameters
Type: array< System..::.Type >[]()[][]
Array of types to be substituted to the generic method parameters of the right member.

Return Value

An instance of ReflectionTypeComparer.

See Also

ReflectionTypeComparer Class
GetInstance Overload
PostSharp.Reflection Namespace


SymbolSequencePoint Class

SymbolSequencePoint Class
Members See Also Send Feedback
Maps a point in IL instructions to location in source code.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymbolSequencePoint : IComparable<SymbolSequencePoint>,
    IEquatable<SymbolSequencePoint>

Remarks

This class implements the IComparable<(Of <(T>)>) interface. This allows sorting sequence points according to their IL offsets and performing binary searches in sorted arrays.

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection..::.SymbolSequencePoint

See Also

SymbolSequencePoint Members
PostSharp.Reflection Namespace


SymbolSequencePoint Members

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint Members
SymbolSequencePoint Class Constructors Methods Operators Fields Properties See Also Send Feedback

The SymbolSequencePoint type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolSequencePoint | Initializes a new SymbolSequencePoint.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two sequence points are equal.
Inequality | Determines whether two sequence points are different.

Fields

Name | Description
Hidden | Gets a symbol meaning that the associated instructions have no source code.

Properties

 | Name | Description
Public property | Document | Gets the document defining the next instructions.
Public property | EndColumn | Gets the end column in the source file.
Public property | EndLine | Gets the end line in the source file.
Public property | IsHidden | Determines whether the current symbol means that the associated instructions have no source code..
Public property | StartColumn | Gets the start column in the source file.
Public property | StartLine | Gets the start line in the source file.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


SymbolSequencePoint Constructor

SymbolSequencePoint Constructor
SymbolSequencePoint Class See Also Send Feedback
Initializes a new SymbolSequencePoint.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymbolSequencePoint(
    int startLine,
    int startColumn,
    int endLine,
    int endColumn,
    ISymbolDocument document
)

Parameters

startLine
Type: System..::.Int32
The start line in the source file.
startColumn
Type: System..::.Int32
The start column in the source file.
endLine
Type: System..::.Int32
The end line in the source file.
endColumn
Type: System..::.Int32
The end column in the source file.
document
Type: System.Diagnostics.SymbolStore..::.ISymbolDocument
Source file

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


SymbolSequencePoint Fields

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint Fields
SymbolSequencePoint Class See Also Send Feedback

The SymbolSequencePoint type exposes the following members.

Fields

Name | Description
Hidden | Gets a symbol meaning that the associated instructions have no source code.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Hidden Field

SymbolSequencePoint..::..Hidden Field
SymbolSequencePoint Class See Also Send Feedback
Gets a symbol meaning that the associated instructions have no source code.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly SymbolSequencePoint Hidden

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


SymbolSequencePoint Methods

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint Methods
SymbolSequencePoint Class See Also Send Feedback

The SymbolSequencePoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint..::..Equals Method
SymbolSequencePoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Public method | Equals(SymbolSequencePoint) | Indicates whether the current object is equal to another object of the same type.

See Also

SymbolSequencePoint Class
SymbolSequencePoint Members
PostSharp.Reflection Namespace


Equals Method (Object)

SymbolSequencePoint..::..Equals Method (Object)
SymbolSequencePoint Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

SymbolSequencePoint Class
Equals Overload
PostSharp.Reflection Namespace


Equals Method (SymbolSequencePoint)

SymbolSequencePoint..::..Equals Method (SymbolSequencePoint)
SymbolSequencePoint Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    SymbolSequencePoint other
)

Parameters

other
Type: PostSharp.Reflection..::.SymbolSequencePoint
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

SymbolSequencePoint Class
Equals Overload
PostSharp.Reflection Namespace


GetHashCode Method

SymbolSequencePoint..::..GetHashCode Method
SymbolSequencePoint Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A hash code for the current Object.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


ToString Method

SymbolSequencePoint..::..ToString Method
SymbolSequencePoint Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


SymbolSequencePoint Operators

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint Operators
SymbolSequencePoint Class See Also Send Feedback

The SymbolSequencePoint type exposes the following members.

Operators

Name | Description
Equality | Determines whether two sequence points are equal.
Inequality | Determines whether two sequence points are different.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Equality Operator

SymbolSequencePoint..::..Equality Operator
SymbolSequencePoint Class See Also Send Feedback
Determines whether two sequence points are equal.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    SymbolSequencePoint left,
    SymbolSequencePoint right
)

Parameters

left
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint.
right
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint.

Return Value

true if both sequence points are equal, otherwise false.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Inequality Operator

SymbolSequencePoint..::..Inequality Operator
SymbolSequencePoint Class See Also Send Feedback
Determines whether two sequence points are different.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    SymbolSequencePoint left,
    SymbolSequencePoint right
)

Parameters

left
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint.
right
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint.

Return Value

true if both sequence points are different, otherwise false.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


SymbolSequencePoint Properties

[image]

PostSharp 2.0 Documentation
SymbolSequencePoint Properties
SymbolSequencePoint Class See Also Send Feedback

The SymbolSequencePoint type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document defining the next instructions.
Public property | EndColumn | Gets the end column in the source file.
Public property | EndLine | Gets the end line in the source file.
Public property | IsHidden | Determines whether the current symbol means that the associated instructions have no source code..
Public property | StartColumn | Gets the start column in the source file.
Public property | StartLine | Gets the start line in the source file.

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Document Property

SymbolSequencePoint..::..Document Property
SymbolSequencePoint Class See Also Send Feedback
Gets the document defining the next instructions.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ISymbolDocument Document { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


EndColumn Property

SymbolSequencePoint..::..EndColumn Property
SymbolSequencePoint Class See Also Send Feedback
Gets the end column in the source file.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int EndColumn { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


EndLine Property

SymbolSequencePoint..::..EndLine Property
SymbolSequencePoint Class See Also Send Feedback
Gets the end line in the source file.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int EndLine { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


IsHidden Property

SymbolSequencePoint..::..IsHidden Property
SymbolSequencePoint Class See Also Send Feedback
Determines whether the current symbol means that the associated instructions have no source code..

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsHidden { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


StartColumn Property

SymbolSequencePoint..::..StartColumn Property
SymbolSequencePoint Class See Also Send Feedback
Gets the start column in the source file.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int StartColumn { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


StartLine Property

SymbolSequencePoint..::..StartLine Property
SymbolSequencePoint Class See Also Send Feedback
Gets the start line in the source file.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int StartLine { get; }

See Also

SymbolSequencePoint Class
PostSharp.Reflection Namespace


Visibility Enumeration

Visibility Enumeration
See Also Send Feedback
Visibility of types and type members.

Namespace: PostSharp.Reflection
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum Visibility

Members

Member name | Value | Description
Public | 0 | Public.
Family | 1 | Family (protected).
Assembly | 2 | Assembly (internal).
FamilyOrAssembly | 3 | Family or assembly (protected internal).
FamilyAndAssembly | 4 | Family and assembly (no C# equivalent: protected types inside the current assembly).
Private | 5 | Private.

See Also

PostSharp.Reflection Namespace


PostSharp.Reflection.GenericArgs Namespace

PostSharp.Reflection.GenericArgs Namespace
Send Feedback
The PostSharp.Reflection.GenericArgs namespace contains classes that can be used instead of unbound generic type arguments.

Classes

 | Class | Description
Public class | GenericArg | Classes derived from GenericArg represent unbound generic arguments. It is a 'trick' to create unbound generic instances, because C# and System.Reflection does not make it possible. Use the Map(Type, array<Type>[]()[], array<Type>[]()[]) method to bind the unbound generic arguments to concrete types.
Public class | GenericMethodArg | Classes derived from GenericMethodArg represent unbound generic method parameters.
Public class | GenericMethodArg0 | Unbound generic method argument. Reference to the 0-th generic method argument.
Public class | GenericMethodArg1 | Unbound generic method argument. Reference to the 1-th generic method argument.
Public class | GenericMethodArg2 | Unbound generic method argument. Reference to the 2-th generic method argument.
Public class | GenericMethodArg3 | Unbound generic method argument. Reference to the 3-th generic method argument.
Public class | GenericMethodArg4 | Unbound generic method argument. Reference to the 4-th generic method argument.
Public class | GenericMethodArg5 | Unbound generic method argument. Reference to the 5-th generic method argument.
Public class | GenericMethodArg6 | Unbound generic method argument. Reference to the 6-th generic method argument.
Public class | GenericMethodArg7 | Unbound generic method argument. Reference to the 7-th generic method argument.
Public class | GenericMethodArg8 | Unbound generic method argument. Reference to the 8-th generic method argument.
Public class | GenericMethodArg9 | Unbound generic method argument. Reference to the 9-th generic method argument.
Public class | GenericTypeArg | Classes derived from GenericTypeArg represent unbound generic type parameters.
Public class | GenericTypeArg0 | Unbound generic type argument. Reference to the 0-th generic type argument.
Public class | GenericTypeArg1 | Unbound generic type argument. Reference to the 1-th generic type argument.
Public class | GenericTypeArg2 | Unbound generic type argument. Reference to the 2-th generic type argument.
Public class | GenericTypeArg3 | Unbound generic type argument. Reference to the 3-th generic type argument.
Public class | GenericTypeArg4 | Unbound generic type argument. Reference to the 4-th generic type argument.
Public class | GenericTypeArg5 | Unbound generic type argument. Reference to the 5-th generic type argument.
Public class | GenericTypeArg6 | Unbound generic type argument. Reference to the 6-th generic type argument.
Public class | GenericTypeArg7 | Unbound generic type argument. Reference to the 7-th generic type argument.
Public class | GenericTypeArg8 | Unbound generic type argument. Reference to the 8-th generic type argument.
Public class | GenericTypeArg9 | Unbound generic type argument. Reference to the 9-th generic type argument.


GenericArg Class

GenericArg Class
Members See Also Send Feedback
Classes derived from GenericArg represent unbound generic arguments. It is a 'trick' to create unbound generic instances, because C# and System.Reflection does not make it possible. Use the Map(Type, array<Type>[]()[], array<Type>[]()[]) method to bind the unbound generic arguments to concrete types.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class GenericArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg

See Also

GenericArg Members
PostSharp.Reflection.GenericArgs Namespace


GenericArg Members

[image]

PostSharp 2.0 Documentation
GenericArg Members
GenericArg Class Constructors Methods See Also Send Feedback

The GenericArg type exposes the following members.

Constructors

 | Name | Description
Protected method | GenericArg | Initializes a new instance of the GenericArg class

Methods

Name | Description
Map | Binds unbound generic arguments to concrete types.

See Also

GenericArg Class
PostSharp.Reflection.GenericArgs Namespace


GenericArg Constructor

GenericArg Constructor
GenericArg Class See Also Send Feedback
Initializes a new instance of the GenericArg class

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected GenericArg()

See Also

GenericArg Class
PostSharp.Reflection.GenericArgs Namespace


GenericArg Methods

[image]

PostSharp 2.0 Documentation
GenericArg Methods
GenericArg Class See Also Send Feedback

The GenericArg type exposes the following members.

Methods

Name | Description
Map | Binds unbound generic arguments to concrete types.

See Also

GenericArg Class
PostSharp.Reflection.GenericArgs Namespace


Map Method

GenericArg..::..Map Method
GenericArg Class See Also Send Feedback
Binds unbound generic arguments to concrete types.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Type Map(
    Type type,
    Type[] genericTypeParameters,
    Type[] genericMethodParameters
)

Parameters

type
Type: System..::.Type
A Type containing unbound generic arguments (derived from GenericArg).
genericTypeParameters
Type: array< System..::.Type >[]()[][]
Array of types to which the unbound generic type arguments should be bound.
genericMethodParameters
Type: array< System..::.Type >[]()[][]
Array of types to which the unbound generic method parameters should be bound.

Return Value

A Type where unbound generic arguments have been replaced by genericTypeParameters and genericMethodParameters.

See Also

GenericArg Class
PostSharp.Reflection.GenericArgs Namespace


GenericMethodArg Class

GenericMethodArg Class
See Also Send Feedback
Classes derived from GenericMethodArg represent unbound generic method parameters.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class GenericMethodArg : GenericArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg0
PostSharp.Reflection.GenericArgs..::.GenericMethodArg1
PostSharp.Reflection.GenericArgs..::.GenericMethodArg2
PostSharp.Reflection.GenericArgs..::.GenericMethodArg3
PostSharp.Reflection.GenericArgs..::.GenericMethodArg4
PostSharp.Reflection.GenericArgs..::.GenericMethodArg5
PostSharp.Reflection.GenericArgs..::.GenericMethodArg6
PostSharp.Reflection.GenericArgs..::.GenericMethodArg7
PostSharp.Reflection.GenericArgs..::.GenericMethodArg8
PostSharp.Reflection.GenericArgs..::.GenericMethodArg9

See Also

PostSharp.Reflection.GenericArgs Namespace
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg0 Class

GenericMethodArg0 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 0-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg0 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg0

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg1 Class

GenericMethodArg1 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 1-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg1 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg1

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg2 Class

GenericMethodArg2 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 2-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg2 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg2

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg3 Class

GenericMethodArg3 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 3-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg3 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg3

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg4 Class

GenericMethodArg4 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 4-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg4 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg4

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg5 Class

GenericMethodArg5 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 5-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg5 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg5

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg6 Class

GenericMethodArg6 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 6-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg6 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg6

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg7 Class

GenericMethodArg7 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 7-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg7 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg7

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg8 Class

GenericMethodArg8 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 8-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg8 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg8

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericMethodArg9 Class

GenericMethodArg9 Class
See Also Send Feedback
Unbound generic method argument. Reference to the 9-th generic method argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodArg9 : GenericMethodArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg
PostSharp.Reflection.GenericArgs..::.GenericMethodArg9

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg Class

GenericTypeArg Class
See Also Send Feedback
Classes derived from GenericTypeArg represent unbound generic type parameters.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class GenericTypeArg : GenericArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg0
PostSharp.Reflection.GenericArgs..::.GenericTypeArg1
PostSharp.Reflection.GenericArgs..::.GenericTypeArg2
PostSharp.Reflection.GenericArgs..::.GenericTypeArg3
PostSharp.Reflection.GenericArgs..::.GenericTypeArg4
PostSharp.Reflection.GenericArgs..::.GenericTypeArg5
PostSharp.Reflection.GenericArgs..::.GenericTypeArg6
PostSharp.Reflection.GenericArgs..::.GenericTypeArg7
PostSharp.Reflection.GenericArgs..::.GenericTypeArg8
PostSharp.Reflection.GenericArgs..::.GenericTypeArg9

See Also

PostSharp.Reflection.GenericArgs Namespace
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg0 Class

GenericTypeArg0 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 0-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg0 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg0

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg1 Class

GenericTypeArg1 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 1-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg1 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg1

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg2 Class

GenericTypeArg2 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 2-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg2 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg2

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg3 Class

GenericTypeArg3 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 3-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg3 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg3

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg4 Class

GenericTypeArg4 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 4-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg4 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg4

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg5 Class

GenericTypeArg5 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 5-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg5 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg5

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg6 Class

GenericTypeArg6 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 6-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg6 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg6

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg7 Class

GenericTypeArg7 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 7-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg7 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg7

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg8 Class

GenericTypeArg8 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 8-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg8 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg8

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


GenericTypeArg9 Class

GenericTypeArg9 Class
See Also Send Feedback
Unbound generic type argument. Reference to the 9-th generic type argument.

Namespace: PostSharp.Reflection.GenericArgs
Assembly: PostSharp (in PostSharp.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeArg9 : GenericTypeArg

Inheritance Hierarchy

System..::.Object
PostSharp.Reflection.GenericArgs..::.GenericArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg
PostSharp.Reflection.GenericArgs..::.GenericTypeArg9

See Also

PostSharp.Reflection.GenericArgs Namespace
GenericArg..::.Map(Type, array<Type>[]()[], array<Type>[]()[])
PostSharp.Reflection.GenericArgs..::.GenericArg


PostSharp.Hosting Namespace

PostSharp.Hosting Namespace
Send Feedback
The PostSharp.Hosting namespace contains the types that allow third-party code to host PostSharp, i.e. to initiate a post-compilation process.

Classes

 | Class | Description
Public class | ConsoleProgram | Entry-point of the PostSharp command-line utility.
Public class | DefaultPostSharpHost | Default implementation of IPostSharpHost for the runtime usage scenario.
Public class | PhaseExecutedEventArgs | Arguments of the events PhaseExecuting and PhaseExecuted.
Public class | Platform | Abstraction of the platform (.NET, Mono) on which PostSharp currently run.
Public class | PostSharpLocalHost | Object that stands between the PostSharpObject and the remote host (IPostSharpHost). Lays in the PostSharp AppDomain. Typically derived by a host when some operations have to be done in the PostSharp AppDomain instead of the host AppDomain.
Public class | PostSharpObject | Implementation of IPostSharpObject. The principal entry point of the PostSharp Platform.
Public class | PostSharpObjectSettings | Specifies how the PostSharp Object (IPostSharpObject) should be instantiated and should behave.
Public class | Program | Entry point of PostSharp.
Public class | ProjectInvocation | Request to execute a Project.
Public class | ProjectInvocationParameters | Determines how an already-given module should be processed. Encapsulates a project identity and the properties with which it should be executed.

Interfaces

 | Interface | Description
Public interface | IPostSharpHost | Describes the semantics of a PostSharp Host. The host is conceptually the component that instantiates and uses IPostSharpObject, the principal entry point for the Platform Infrastructure. The IPostSharpObject implementation uses this interface when it needs to get information from the host.
Public interface | IPostSharpObject | Defines the semantics of the PostSharp Object, the entry point of the Platform Infrastructure. Use the CreateInstance(PostSharpObjectSettings) method to create an instance of the PostSharp Object.

Enumerations

 | Enumeration | Description
Public enumeration | ProgramReturnCode | Return codes of Program.
Public enumeration | ProjectExecutionOrder | Determines in which order tasks of projects should be executed. This is relevant only when the InvokeProjects(array<ProjectInvocation>[]()[]) method is called with many projects or if many projects are executed together due to recursive processing.


ConsoleProgram Class

ConsoleProgram Class
Members See Also Send Feedback
Entry-point of the PostSharp command-line utility.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public sealed class ConsoleProgram : Program

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.Program
PostSharp.Hosting..::.ConsoleProgram

See Also

ConsoleProgram Members
PostSharp.Hosting Namespace


ConsoleProgram Members

[image]

PostSharp 2.0 Documentation
ConsoleProgram Members
ConsoleProgram Class Constructors Methods See Also Send Feedback

The ConsoleProgram type exposes the following members.

Constructors

 | Name | Description
Public method | ConsoleProgram | Initializes a new ConsoleProgram.

Methods

 | Name | Description
Public method | Execute | Executes the program. (Inherited from Program.)

See Also

ConsoleProgram Class
PostSharp.Hosting Namespace


ConsoleProgram Constructor

ConsoleProgram Constructor
ConsoleProgram Class See Also Send Feedback
Initializes a new ConsoleProgram.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ConsoleProgram(
    string[] arguments
)

Parameters

arguments
Type: array< System..::.String >[]()[][]
Command-line arguments.

See Also

ConsoleProgram Class
PostSharp.Hosting Namespace


ConsoleProgram Methods

[image]

PostSharp 2.0 Documentation
ConsoleProgram Methods
ConsoleProgram Class See Also Send Feedback

The ConsoleProgram type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes the program. (Inherited from Program.)

See Also

ConsoleProgram Class
PostSharp.Hosting Namespace


DefaultPostSharpHost Class

DefaultPostSharpHost Class
Members See Also Send Feedback
Default implementation of IPostSharpHost for the runtime usage scenario.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public class DefaultPostSharpHost : MarshalByRefObject,
    IPostSharpHost

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Hosting..::.DefaultPostSharpHost

See Also

DefaultPostSharpHost Members
PostSharp.Hosting Namespace


DefaultPostSharpHost Members

[image]

PostSharp 2.0 Documentation
DefaultPostSharpHost Members
DefaultPostSharpHost Class Constructors Methods Fields See Also Send Feedback

The DefaultPostSharpHost type exposes the following members.

Constructors

 | Name | Description
Protected method | DefaultPostSharpHost | Protected constructor.

Methods

 | Name | Description
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

Fields

Name | Description
Instance | Singleton instance.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


DefaultPostSharpHost Constructor

DefaultPostSharpHost Constructor
DefaultPostSharpHost Class See Also Send Feedback
Protected constructor.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected DefaultPostSharpHost()

Remarks

It makes no sense to have many instances of the DefaultPostSharpHost, but we want to make it possible to inherit this class.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


DefaultPostSharpHost Fields

[image]

PostSharp 2.0 Documentation
DefaultPostSharpHost Fields
DefaultPostSharpHost Class See Also Send Feedback

The DefaultPostSharpHost type exposes the following members.

Fields

Name | Description
Instance | Singleton instance.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


Instance Field

DefaultPostSharpHost..::..Instance Field
DefaultPostSharpHost Class See Also Send Feedback
Singleton instance.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public static readonly DefaultPostSharpHost Instance

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


DefaultPostSharpHost Methods

[image]

PostSharp 2.0 Documentation
DefaultPostSharpHost Methods
DefaultPostSharpHost Class See Also Send Feedback

The DefaultPostSharpHost type exposes the following members.

Methods

 | Name | Description
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


GetProjectInvocationParameters Method

DefaultPostSharpHost..::..GetProjectInvocationParameters Method
DefaultPostSharpHost Class See Also Send Feedback
Determines whether and how a module should be processed by PostSharp.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProjectInvocationParameters GetProjectInvocationParameters(
    string assemblyFileName,
    string moduleName,
    AssemblyName assemblyName
)

Parameters

assemblyFileName
Type: System..::.String
Location of the considered assembly. This is merely the location returned by the ResolveAssemblyReference(AssemblyName) method.
moduleName
Type: System..::.String
Name of the considered module.
assemblyName
Type: System.Reflection..::.AssemblyName
Complete name of the assembly.

Return Value

A ProjectInvocationParameters object if this module has to be processed, or null if the module should not be processed.

Implements

IPostSharpHost..::.GetProjectInvocationParameters(String, String, AssemblyName)

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


RenameAssembly Method

DefaultPostSharpHost..::..RenameAssembly Method
DefaultPostSharpHost Class See Also Send Feedback
Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void RenameAssembly(
    AssemblyName oldAssemblyName,
    AssemblyName newAssemblyName
)

Parameters

oldAssemblyName
Type: System.Reflection..::.AssemblyName
Original assembly name.
newAssemblyName
Type: System.Reflection..::.AssemblyName
New assembly name.

Implements

IPostSharpHost..::.RenameAssembly(AssemblyName, AssemblyName)

Remarks

The assembly renaming is used in the runtime usage scenario in order to (1) remove strong names and (2) make sure that the unprocessed assembly is not loaded 'accidentally' by the default system binder (for instance because the transformed assembly lays in the GAC). See OverwriteAssemblyNames for details.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


ResolveAssemblyReference Method

DefaultPostSharpHost..::..ResolveAssemblyReference Method
DefaultPostSharpHost Class See Also Send Feedback
Returns the location and the load arguments of an assembly known by name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public string ResolveAssemblyReference(
    AssemblyName assemblyName
)

Parameters

assemblyName
Type: System.Reflection..::.AssemblyName
Assembly name.

Return Value

The full path of the assembly, or null if the host does not want to intervene in the default binding mechanism of the PostSharp Platform.

Implements

IPostSharpHost..::.ResolveAssemblyReference(AssemblyName)

Remarks

This method is called whenever an assembly reference has to be resolved inside the PostSharp Code Object Model, and this assembly has neither been resolved yet neither been passed to the InvokeProjects(array<ProjectInvocation>[]()[]) method.

See Also

DefaultPostSharpHost Class
PostSharp.Hosting Namespace


IPostSharpHost Interface

IPostSharpHost Interface
Members See Also Send Feedback
Describes the semantics of a PostSharp Host. The host is conceptually the component that instantiates and uses IPostSharpObject, the principal entry point for the Platform Infrastructure. The IPostSharpObject implementation uses this interface when it needs to get information from the host.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public interface IPostSharpHost

Remarks

Classes implementing IPostSharpHost should be derived from MarshalByRefObject if the IPostSharpObject is set up to use its own application domain.

If a host has default behavior, it is not required to implement its own IPostSharpHost. The default behavior is typically the compile-time use case, when all modules to be transformed are passed to the InvokeProjects(array<ProjectInvocation>[]()[]) method. Modules that are discovered at runtime (like dependencies) are not processed.

See Also

IPostSharpHost Members
PostSharp.Hosting Namespace


IPostSharpHost Members

[image]

PostSharp 2.0 Documentation
IPostSharpHost Members
IPostSharpHost Interface Methods See Also Send Feedback

The IPostSharpHost type exposes the following members.

Methods

 | Name | Description
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

See Also

IPostSharpHost Interface
PostSharp.Hosting Namespace


IPostSharpHost Methods

[image]

PostSharp 2.0 Documentation
IPostSharpHost Methods
IPostSharpHost Interface See Also Send Feedback

The IPostSharpHost type exposes the following members.

Methods

 | Name | Description
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

See Also

IPostSharpHost Interface
PostSharp.Hosting Namespace


GetProjectInvocationParameters Method

IPostSharpHost..::..GetProjectInvocationParameters Method
IPostSharpHost Interface See Also Send Feedback
Determines whether and how a module should be processed by PostSharp.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
ProjectInvocationParameters GetProjectInvocationParameters(
    string assemblyFileName,
    string moduleName,
    AssemblyName assemblyName
)

Parameters

assemblyFileName
Type: System..::.String
Location of the considered assembly. This is merely the location returned by the ResolveAssemblyReference(AssemblyName) method.
moduleName
Type: System..::.String
Name of the considered module.
assemblyName
Type: System.Reflection..::.AssemblyName
Complete name of the assembly.

Return Value

A ProjectInvocationParameters object if this module has to be processed, or null if the module should not be processed.

See Also

IPostSharpHost Interface
PostSharp.Hosting Namespace


RenameAssembly Method

IPostSharpHost..::..RenameAssembly Method
IPostSharpHost Interface See Also Send Feedback
Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
void RenameAssembly(
    AssemblyName oldAssemblyName,
    AssemblyName newAssemblyName
)

Parameters

oldAssemblyName
Type: System.Reflection..::.AssemblyName
Original assembly name.
newAssemblyName
Type: System.Reflection..::.AssemblyName
New assembly name.

Remarks

The assembly renaming is used in the runtime usage scenario in order to (1) remove strong names and (2) make sure that the unprocessed assembly is not loaded 'accidentally' by the default system binder (for instance because the transformed assembly lays in the GAC). See OverwriteAssemblyNames for details.

See Also

IPostSharpHost Interface
PostSharp.Hosting Namespace


ResolveAssemblyReference Method

IPostSharpHost..::..ResolveAssemblyReference Method
IPostSharpHost Interface See Also Send Feedback
Returns the location and the load arguments of an assembly known by name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
string ResolveAssemblyReference(
    AssemblyName assemblyName
)

Parameters

assemblyName
Type: System.Reflection..::.AssemblyName
Assembly name.

Return Value

The full path of the assembly, or null if the host does not want to intervene in the default binding mechanism of the PostSharp Platform.

Remarks

This method is called whenever an assembly reference has to be resolved inside the PostSharp Code Object Model, and this assembly has neither been resolved yet neither been passed to the InvokeProjects(array<ProjectInvocation>[]()[]) method.

See Also

IPostSharpHost Interface
PostSharp.Hosting Namespace


IPostSharpObject Interface

IPostSharpObject Interface
Members See Also Send Feedback
Defines the semantics of the PostSharp Object, the entry point of the Platform Infrastructure. Use the CreateInstance(PostSharpObjectSettings) method to create an instance of the PostSharp Object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public interface IPostSharpObject : IDisposable

Remarks

This object is disposable. Seriously! Be sure to call the Dispose()()() method when you do not need PostSharp any more, otherwise the private application domain won't be unloaded.

All assemblies loaded in the scope of one instance of IPostSharpObject and all projects will share a unique instance of the Domain class. If this behavior is not wished, you should use many instances of IPostSharpObject.

See Also

IPostSharpObject Members
PostSharp.Hosting Namespace


IPostSharpObject Members

[image]

PostSharp 2.0 Documentation
IPostSharpObject Members
IPostSharpObject Interface Methods Properties See Also Send Feedback

The IPostSharpObject type exposes the following members.

Methods

 | Name | Description
Public method | GetMetrics | Gets the metrics collected during the process.
Public method | InvokeProject | Requests the processing of a single PostSharp project.
Public method | InvokeProjects | Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.
Public method | ProcessAssemblies | Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

Properties

 | Name | Description
Public property | AppDomain | Gets the AppDomain in which the PostSharp Object lives.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


IPostSharpObject Methods

[image]

PostSharp 2.0 Documentation
IPostSharpObject Methods
IPostSharpObject Interface See Also Send Feedback

The IPostSharpObject type exposes the following members.

Methods

 | Name | Description
Public method | GetMetrics | Gets the metrics collected during the process.
Public method | InvokeProject | Requests the processing of a single PostSharp project.
Public method | InvokeProjects | Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.
Public method | ProcessAssemblies | Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


GetMetrics Method

IPostSharpObject..::..GetMetrics Method
IPostSharpObject Interface See Also Send Feedback
Gets the metrics collected during the process.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
MetricCollection GetMetrics()

Return Value

A MetricCollection.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


InvokeProject Method

IPostSharpObject..::..InvokeProject Method
IPostSharpObject Interface See Also Send Feedback
Requests the processing of a single PostSharp project.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
void InvokeProject(
    ProjectInvocation projectInvocation
)

Parameters

projectInvocation
Type: PostSharp.Hosting..::.ProjectInvocation
Parameters for the PostSharp invocation.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


InvokeProjects Method

IPostSharpObject..::..InvokeProjects Method
IPostSharpObject Interface See Also Send Feedback
Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
void InvokeProjects(
    ProjectInvocation[] projectInvocations
)

Parameters

projectInvocations
Type: array< PostSharp.Hosting..::.ProjectInvocation >[]()[][]
An array in which each element is a request to execute a PostSharp project.

Remarks

One source assembly may be processed only once in the lifetime of a IPostSharpObject.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


ProcessAssemblies Method

IPostSharpObject..::..ProcessAssemblies Method
IPostSharpObject Interface See Also Send Feedback
Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
void ProcessAssemblies(
    ModuleLoadStrategy[] modules
)

Parameters

modules
Type: array< PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy >[]()[][]
Array of assemblies to be processed.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


IPostSharpObject Properties

[image]

PostSharp 2.0 Documentation
IPostSharpObject Properties
IPostSharpObject Interface See Also Send Feedback

The IPostSharpObject type exposes the following members.

Properties

 | Name | Description
Public property | AppDomain | Gets the AppDomain in which the PostSharp Object lives.

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


AppDomain Property

IPostSharpObject..::..AppDomain Property
IPostSharpObject Interface See Also Send Feedback
Gets the AppDomain in which the PostSharp Object lives.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
AppDomain AppDomain { get; }

See Also

IPostSharpObject Interface
PostSharp.Hosting Namespace


PhaseExecutedEventArgs Class

PhaseExecutedEventArgs Class
Members See Also Send Feedback
Arguments of the events PhaseExecuting and PhaseExecuted.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public sealed class PhaseExecutedEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PostSharp.Hosting..::.PhaseExecutedEventArgs

See Also

PhaseExecutedEventArgs Members
PostSharp.Hosting Namespace


PhaseExecutedEventArgs Members

[image]

PostSharp 2.0 Documentation
PhaseExecutedEventArgs Members
PhaseExecutedEventArgs Class Properties See Also Send Feedback

The PhaseExecutedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Phase | Name of the phase.
Public property | Projects | List of projects in the group being now executed, in deep-first order of dependency relationships.

See Also

PhaseExecutedEventArgs Class
PostSharp.Hosting Namespace


PhaseExecutedEventArgs Properties

[image]

PostSharp 2.0 Documentation
PhaseExecutedEventArgs Properties
PhaseExecutedEventArgs Class See Also Send Feedback

The PhaseExecutedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Phase | Name of the phase.
Public property | Projects | List of projects in the group being now executed, in deep-first order of dependency relationships.

See Also

PhaseExecutedEventArgs Class
PostSharp.Hosting Namespace


Phase Property

PhaseExecutedEventArgs..::..Phase Property
PhaseExecutedEventArgs Class See Also Send Feedback
Name of the phase.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public string Phase { get; internal set; }

See Also

PhaseExecutedEventArgs Class
PostSharp.Hosting Namespace


Projects Property

PhaseExecutedEventArgs..::..Projects Property
PhaseExecutedEventArgs Class See Also Send Feedback
List of projects in the group being now executed, in deep-first order of dependency relationships.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public IList<Project> Projects { get; }

See Also

PhaseExecutedEventArgs Class
PostSharp.Hosting Namespace


Platform Class

Platform Class
Members See Also Send Feedback
Abstraction of the platform (.NET, Mono) on which PostSharp currently run.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Platform

Remarks

This class is not to be confused with TargetPlatformAdapter, which is an abstraction of the platform to which PostSharp should compile. It is theoretically possible to build transformed assemblies for a different platform than the current one (for instance .NET 1.1 on .NET 2.0), although this feature is not used and not supported.

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.Platform

See Also

Platform Members
PostSharp.Hosting Namespace
ManagedDotNet20Platform
Mono20Platform


Platform Members

[image]

PostSharp 2.0 Documentation
Platform Members
Platform Class Methods Properties See Also Send Feedback

The Platform type exposes the following members.

Methods

 | Name | Description
Public method | CreateAppDomain | Creates an AppDomain.
Public method | CreateAssemblyLocator | Creates a AssemblyLocator for a given Domain.
Public method | EvaluateBindingPolicy | Evaluates a system binding policy.
Public method | FindAssemblyInCache | Finds an assembly in GAC.
Public method | GetAssemblyBindingIdentity | Gets the binding identity of an assembly given its file name.
Public method | GetAssemblyLocation | Gets the location (path) of an assembly.
Public method | IsMemoryMapped | Determines whether a given Module is mapped in memory.
Public method | LoadAssemblyFromFile | Loads an Assembly in the current AppDomain given its file name.
Public method | LoadAssemblyFromName | Loads an Assembly in the current AppDomain given its assembly name.
Public method | NormalizeCilIdentifier | Normalizes a CIL identifier so that it is accepted by ILASM without quoting.
Public method | SetDomain | Sets the Domain property and configures the Platform for this domain.
Public method | Uninitialize | Disposes the current Platform.

Properties

 | Name | Description
 | Current | Gets the current Platform.
Public property | DefaultTargetPlatformName | Gets the default TargetPlatformAdapter
Public property | Domain | Gets the Domain associated with the current Platform.
Public property | IntrinsicOfOppositeSignAssignable | Determines whether intrinsics of opposite sign (for instance Int32 and UInt32) are assignable.
Public property | Name | Gets the name of the current Platform.
Public property | ReadModuleStrategy | Gets the strategy used to read a module (from disk or from memory).

See Also

Platform Class
PostSharp.Hosting Namespace


Platform Methods

[image]

PostSharp 2.0 Documentation
Platform Methods
Platform Class See Also Send Feedback

The Platform type exposes the following members.

Methods

 | Name | Description
Public method | CreateAppDomain | Creates an AppDomain.
Public method | CreateAssemblyLocator | Creates a AssemblyLocator for a given Domain.
Public method | EvaluateBindingPolicy | Evaluates a system binding policy.
Public method | FindAssemblyInCache | Finds an assembly in GAC.
Public method | GetAssemblyBindingIdentity | Gets the binding identity of an assembly given its file name.
Public method | GetAssemblyLocation | Gets the location (path) of an assembly.
Public method | IsMemoryMapped | Determines whether a given Module is mapped in memory.
Public method | LoadAssemblyFromFile | Loads an Assembly in the current AppDomain given its file name.
Public method | LoadAssemblyFromName | Loads an Assembly in the current AppDomain given its assembly name.
Public method | NormalizeCilIdentifier | Normalizes a CIL identifier so that it is accepted by ILASM without quoting.
Public method | SetDomain | Sets the Domain property and configures the Platform for this domain.
Public method | Uninitialize | Disposes the current Platform.

See Also

Platform Class
PostSharp.Hosting Namespace


CreateAppDomain Method

Platform..::..CreateAppDomain Method
Platform Class See Also Send Feedback
Creates an AppDomain.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract AppDomain CreateAppDomain(
    string name,
    Evidence evidence,
    AppDomainSetup setup,
    PermissionSet permissions
)

Parameters

name
Type: System..::.String
Name.
evidence
Type: System.Security.Policy..::.Evidence
Evidence.
setup
Type: System..::.AppDomainSetup
Setup information.
permissions
Type: System.Security..::.PermissionSet
Permission.

Return Value

A new AppDomain.

See Also

Platform Class
PostSharp.Hosting Namespace


CreateAssemblyLocator Method

Platform..::..CreateAssemblyLocator Method
Platform Class See Also Send Feedback
Creates a AssemblyLocator for a given Domain.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract AssemblyLocator CreateAssemblyLocator(
    Domain domain
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
The domain.

Return Value

An AssemblyLocator configured for domain.

See Also

Platform Class
PostSharp.Hosting Namespace


EvaluateBindingPolicy Method

Platform..::..EvaluateBindingPolicy Method
Platform Class See Also Send Feedback
Evaluates a system binding policy.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual IAssemblyName EvaluateBindingPolicy(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
The pre-policy assembly name.

Return Value

The post-policy assembly name.

See Also

Platform Class
PostSharp.Hosting Namespace


FindAssemblyInCache Method

Platform..::..FindAssemblyInCache Method
Platform Class See Also Send Feedback
Finds an assembly in GAC.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract string FindAssemblyInCache(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name.

Return Value

The full path of the assembly in GAC (i.e., on file system), or null if the assembly was not found.

See Also

Platform Class
PostSharp.Hosting Namespace


GetAssemblyBindingIdentity Method

Platform..::..GetAssemblyBindingIdentity Method
Platform Class See Also Send Feedback
Gets the binding identity of an assembly given its file name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string GetAssemblyBindingIdentity(
    string fileName
)

Parameters

fileName
Type: System..::.String
File name of the assembly.

Return Value

[Missing <returns> documentation for "M:PostSharp.Hosting.Platform.GetAssemblyBindingIdentity(System.String)"]

See Also

Platform Class
PostSharp.Hosting Namespace


GetAssemblyLocation Method

Platform..::..GetAssemblyLocation Method
Platform Class See Also Send Feedback
Gets the location (path) of an assembly.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string GetAssemblyLocation(
    Assembly assembly
)

Parameters

assembly
Type: System.Reflection..::.Assembly
An assembly.

Return Value

The location of this assembly.

See Also

Platform Class
PostSharp.Hosting Namespace


IsMemoryMapped Method

Platform..::..IsMemoryMapped Method
Platform Class See Also Send Feedback
Determines whether a given Module is mapped in memory.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool IsMemoryMapped(
    Module module
)

Parameters

module
Type: System.Reflection..::.Module
A module.

Return Value

true if module is mapped in memory, false if it is loaded in memory just as from disk.

See Also

Platform Class
PostSharp.Hosting Namespace


LoadAssemblyFromFile Method

Platform..::..LoadAssemblyFromFile Method
Platform Class See Also Send Feedback
Loads an Assembly in the current AppDomain given its file name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Assembly LoadAssemblyFromFile(
    string fileName
)

Parameters

fileName
Type: System..::.String
Path of the assembly.

Return Value

The loaded Assembly.

See Also

Platform Class
PostSharp.Hosting Namespace


LoadAssemblyFromName Method

Platform..::..LoadAssemblyFromName Method
Platform Class See Also Send Feedback
Loads an Assembly in the current AppDomain given its assembly name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Assembly LoadAssemblyFromName(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name.

Return Value

The loaded Assembly.

See Also

Platform Class
PostSharp.Hosting Namespace


NormalizeCilIdentifier Method

Platform..::..NormalizeCilIdentifier Method
Platform Class See Also Send Feedback
Normalizes a CIL identifier so that it is accepted by ILASM without quoting.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract string NormalizeCilIdentifier(
    string name
)

Parameters

name
Type: System..::.String
The identifier name.

Return Value

The normalized identifier name.

See Also

Platform Class
PostSharp.Hosting Namespace


SetDomain Method

Platform..::..SetDomain Method
Platform Class See Also Send Feedback
Sets the Domain property and configures the Platform for this domain.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void SetDomain(
    Domain domain
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
The domain.

See Also

Platform Class
PostSharp.Hosting Namespace


Uninitialize Method

Platform..::..Uninitialize Method
Platform Class See Also Send Feedback
Disposes the current Platform.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void Uninitialize()

See Also

Platform Class
PostSharp.Hosting Namespace


Platform Properties

[image]

PostSharp 2.0 Documentation
Platform Properties
Platform Class See Also Send Feedback

The Platform type exposes the following members.

Properties

 | Name | Description
 | Current | Gets the current Platform.
Public property | DefaultTargetPlatformName | Gets the default TargetPlatformAdapter
Public property | Domain | Gets the Domain associated with the current Platform.
Public property | IntrinsicOfOppositeSignAssignable | Determines whether intrinsics of opposite sign (for instance Int32 and UInt32) are assignable.
Public property | Name | Gets the name of the current Platform.
Public property | ReadModuleStrategy | Gets the strategy used to read a module (from disk or from memory).

See Also

Platform Class
PostSharp.Hosting Namespace


Current Property

Platform..::..Current Property
Platform Class See Also Send Feedback
Gets the current Platform.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Platform Current { get; }

See Also

Platform Class
PostSharp.Hosting Namespace


DefaultTargetPlatformName Property

Platform..::..DefaultTargetPlatformName Property
Platform Class See Also Send Feedback
Gets the default TargetPlatformAdapter

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string DefaultTargetPlatformName { get; protected set; }

Field Value

The name of the default TargetPlatformAdapter in PostSharp-Platform.config.

See Also

Platform Class
PostSharp.Hosting Namespace


Domain Property

Platform..::..Domain Property
Platform Class See Also Send Feedback
Gets the Domain associated with the current Platform.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Domain Domain { get; private set; }

See Also

Platform Class
PostSharp.Hosting Namespace


IntrinsicOfOppositeSignAssignable Property

Platform..::..IntrinsicOfOppositeSignAssignable Property
Platform Class See Also Send Feedback
Determines whether intrinsics of opposite sign (for instance Int32 and UInt32) are assignable.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IntrinsicOfOppositeSignAssignable { get; protected set; }

See Also

Platform Class
PostSharp.Hosting Namespace


Name Property

Platform..::..Name Property
Platform Class See Also Send Feedback
Gets the name of the current Platform.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract string Name { get; }

See Also

Platform Class
PostSharp.Hosting Namespace


ReadModuleStrategy Property

Platform..::..ReadModuleStrategy Property
Platform Class See Also Send Feedback
Gets the strategy used to read a module (from disk or from memory).

Namespace: PostSharp.Hosting
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ReadModuleStrategy ReadModuleStrategy { get; protected set; }

See Also

Platform Class
PostSharp.Hosting Namespace


PostSharpLocalHost Class

PostSharpLocalHost Class
Members See Also Send Feedback
Object that stands between the PostSharpObject and the remote host (IPostSharpHost). Lays in the PostSharp AppDomain. Typically derived by a host when some operations have to be done in the PostSharp AppDomain instead of the host AppDomain.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public class PostSharpLocalHost : MarshalByRefObject,
    IDisposable

Remarks

The default implementation of all methods just calls the remote host.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Hosting..::.PostSharpLocalHost

See Also

PostSharpLocalHost Members
PostSharp.Hosting Namespace


PostSharpLocalHost Members

[image]

PostSharp 2.0 Documentation
PostSharpLocalHost Members
PostSharpLocalHost Class Constructors Methods Properties See Also Send Feedback

The PostSharpLocalHost type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharpLocalHost | Initializes a new instance of the PostSharpLocalHost class

Methods

 | Name | Description
Public method | Dispose | Overloaded.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | Initialize | Initializes the current instance.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | PostSharpObject | Gets the PostSharpObject associated to the current instance.
Public property | RemoteHost | Gets the remote host (i.e. the IPostSharpHost located in the host AppDomain) associated to to the current instance.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


PostSharpLocalHost Constructor

PostSharpLocalHost Constructor
PostSharpLocalHost Class See Also Send Feedback
Initializes a new instance of the PostSharpLocalHost class

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public PostSharpLocalHost()

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


PostSharpLocalHost Methods

[image]

PostSharp 2.0 Documentation
PostSharpLocalHost Methods
PostSharpLocalHost Class See Also Send Feedback

The PostSharpLocalHost type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Overloaded.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetProjectInvocationParameters | Determines whether and how a module should be processed by PostSharp.
Public method | Initialize | Initializes the current instance.
Public method | RenameAssembly | Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.
Public method | ResolveAssemblyReference | Returns the location and the load arguments of an assembly known by name.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
PostSharpLocalHost..::..Dispose Method
PostSharpLocalHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Frees the resources consumed by the current object.
Protected method | Dispose(Boolean) | Disposes the current object.

See Also

PostSharpLocalHost Class
PostSharpLocalHost Members
PostSharp.Hosting Namespace


Dispose Method

PostSharpLocalHost..::..Dispose Method
PostSharpLocalHost Class See Also Send Feedback
Frees the resources consumed by the current object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

PostSharpLocalHost Class
Dispose Overload
PostSharp.Hosting Namespace


Dispose Method (Boolean)

PostSharpLocalHost..::..Dispose Method (Boolean)
PostSharpLocalHost Class See Also Send Feedback
Disposes the current object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if the current method is called because the object is being disposed explicitly, false if it is called because of the destructor.

See Also

PostSharpLocalHost Class
Dispose Overload
PostSharp.Hosting Namespace


Finalize Method

PostSharpLocalHost..::..Finalize Method
PostSharpLocalHost Class See Also Send Feedback
Destructor.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected override void Finalize()

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


GetProjectInvocationParameters Method

PostSharpLocalHost..::..GetProjectInvocationParameters Method
PostSharpLocalHost Class See Also Send Feedback
Determines whether and how a module should be processed by PostSharp.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public virtual ProjectInvocationParameters GetProjectInvocationParameters(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module that is being considered.

Return Value

A ProjectInvocationParameters object if this module has to be processed, or null if the module should not be processed.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


Initialize Method

PostSharpLocalHost..::..Initialize Method
PostSharpLocalHost Class See Also Send Feedback
Initializes the current instance.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public virtual void Initialize()

Remarks

This method is called just after the object is instantiated and the properties RemoteHost and PostSharpObject have been initialized.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


RenameAssembly Method

PostSharpLocalHost..::..RenameAssembly Method
PostSharpLocalHost Class See Also Send Feedback
Notifies the host that an assembly has been renamed. This happens if the PostSharpObjectSettings.OverwriteAssemblyNames flag has been set.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public virtual void RenameAssembly(
    AssemblyManifestDeclaration assemblyManifest
)

Parameters

assemblyManifest
Type: PostSharp.Sdk.CodeModel..::.AssemblyManifestDeclaration
The assembly manifest where the OverwrittenName is different than the Name property.

Remarks

The assembly renaming is used in the runtime usage scenario in order to (1) remove strong names and (2) make sure that the unprocessed assembly is not loaded 'accidentally' by the default system binder (for instance because the transformed assembly lays in the GAC). See OverwriteAssemblyNames for details.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


ResolveAssemblyReference Method

PostSharpLocalHost..::..ResolveAssemblyReference Method
PostSharpLocalHost Class See Also Send Feedback
Returns the location and the load arguments of an assembly known by name.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public virtual string ResolveAssemblyReference(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name.

Return Value

An ModuleLoadStrategy object containing principally the location of the assembly to load, or null if the host does not want to intervene in the default binding mechanism of the PostSharp Platform.

Remarks

This method is called whenever an assembly reference has to be resolved inside the PostSharp Code Object Model, and this assembly has neither been resolved yet neither been passed to the InvokeProjects(array<ProjectInvocation>[]()[]) method.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


PostSharpLocalHost Properties

[image]

PostSharp 2.0 Documentation
PostSharpLocalHost Properties
PostSharpLocalHost Class See Also Send Feedback

The PostSharpLocalHost type exposes the following members.

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | PostSharpObject | Gets the PostSharpObject associated to the current instance.
Public property | RemoteHost | Gets the remote host (i.e. the IPostSharpHost located in the host AppDomain) associated to to the current instance.

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


IsDisposed Property

PostSharpLocalHost..::..IsDisposed Property
PostSharpLocalHost Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool IsDisposed { get; }

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


PostSharpObject Property

PostSharpLocalHost..::..PostSharpObject Property
PostSharpLocalHost Class See Also Send Feedback
Gets the PostSharpObject associated to the current instance.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public PostSharpObject PostSharpObject { get; }

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


RemoteHost Property

PostSharpLocalHost..::..RemoteHost Property
PostSharpLocalHost Class See Also Send Feedback
Gets the remote host (i.e. the IPostSharpHost located in the host AppDomain) associated to to the current instance.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public IPostSharpHost RemoteHost { get; }

See Also

PostSharpLocalHost Class
PostSharp.Hosting Namespace


PostSharpObject Class

PostSharpObject Class
Members See Also Send Feedback
Implementation of IPostSharpObject. The principal entry point of the PostSharp Platform.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public sealed class PostSharpObject : MarshalByRefObject,
    IPostSharpObject, IDisposable, IPostSharpEnvironment

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Hosting..::.PostSharpObject

See Also

PostSharpObject Members
PostSharp.Hosting Namespace


PostSharpObject Members

[image]

PostSharp 2.0 Documentation
PostSharpObject Members
PostSharpObject Class Methods Properties Events See Also Send Feedback

The PostSharpObject type exposes the following members.

Methods

 | Name | Description
 | CreateInstance | Overloaded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetMetrics | Gets the metrics collected during the process.
Public method | InvokeProject | Requests the processing of a single PostSharp project.
Public method | InvokeProjects | Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.
Public method | ProcessAssemblies | Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

Properties

 | Name | Description
Public property | AppDomain | Gets the AppDomain in which the PostSharp Object lives.
Public property | CurrentProject | Gets the currently executing project.
Public property | Domain | Gets the Domain in which all modules are loaded and processed.

Events

 | Name | Description
Public event | PhaseExecuted | Event raised after a phase has been executed on a group of projects, if the project execution mode is Phased.
Public event | PhaseExecuting | Event raised before a phase is executed on a group of projects, if the project execution mode is Phased.

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PostSharpObject Methods

[image]

PostSharp 2.0 Documentation
PostSharpObject Methods
PostSharpObject Class See Also Send Feedback

The PostSharpObject type exposes the following members.

Methods

 | Name | Description
 | CreateInstance | Overloaded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetMetrics | Gets the metrics collected during the process.
Public method | InvokeProject | Requests the processing of a single PostSharp project.
Public method | InvokeProjects | Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.
Public method | ProcessAssemblies | Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


CreateInstance Method

[image]

PostSharp 2.0 Documentation
PostSharpObject..::..CreateInstance Method
PostSharpObject Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(PostSharpObjectSettings) | Creates a PostSharp Object using the default host implementation.
CreateInstance(PostSharpObjectSettings, IPostSharpHost) | Creates a PostSharp Object and specifies the host implementation.

See Also

PostSharpObject Class
PostSharpObject Members
PostSharp.Hosting Namespace


CreateInstance Method (PostSharpObjectSettings)

PostSharpObject..::..CreateInstance Method (PostSharpObjectSettings)
PostSharpObject Class See Also Send Feedback
Creates a PostSharp Object using the default host implementation.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public static IPostSharpObject CreateInstance(
    PostSharpObjectSettings settings
)

Parameters

settings
Type: PostSharp.Hosting..::.PostSharpObjectSettings
Settings of the PostSharp Object.

Return Value

A PostSharp Object, the entry point of the PostSharp Platform Infrastructure.

Remarks

The default host implementation covers the compile-time usage scenario: projects are executed only when explicitly invoked by the InvokeProjects(array<ProjectInvocation>[]()[]) methods, never when they are 'discovered' at runtime.

Note that, in every case, the host should register to the Message event of the Messenger object, in the current AppDomain.

See Also

PostSharpObject Class
CreateInstance Overload
PostSharp.Hosting Namespace


CreateInstance Method (PostSharpObjectSettings, IPostSharpHost)

PostSharpObject..::..CreateInstance Method (PostSharpObjectSettings, IPostSharpHost)
PostSharpObject Class See Also Send Feedback
Creates a PostSharp Object and specifies the host implementation.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public static IPostSharpObject CreateInstance(
    PostSharpObjectSettings settings,
    IPostSharpHost host
)

Parameters

settings
Type: PostSharp.Hosting..::.PostSharpObjectSettings
Settings of the PostSharp Object.
host
Type: PostSharp.Hosting..::.IPostSharpHost
An implementation of IPostSharpHost derived from MarshalByRefObject, or null to use the default host implementation.

Return Value

A PostSharp Object, the entry point of the PostSharp Platform Infrastructure.

Remarks

The default host implementation covers the compile-time usage scenario: projects are executed only when explicitly invoked by the InvokeProjects(array<ProjectInvocation>[]()[]) methods, never when they are 'discovered' at runtime.

Note that, in every case, the host should register to the Message event of the Messenger object, in the current AppDomain.

See Also

PostSharpObject Class
CreateInstance Overload
PostSharp.Hosting Namespace


Dispose Method

PostSharpObject..::..Dispose Method
PostSharpObject Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


GetMetrics Method

PostSharpObject..::..GetMetrics Method
PostSharpObject Class See Also Send Feedback
Gets the metrics collected during the process.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public MetricCollection GetMetrics()

Return Value

A MetricCollection.

Implements

IPostSharpObject..::.GetMetrics()()()

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


InvokeProject Method

PostSharpObject..::..InvokeProject Method
PostSharpObject Class See Also Send Feedback
Requests the processing of a single PostSharp project.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void InvokeProject(
    ProjectInvocation projectInvocation
)

Parameters

projectInvocation
Type: PostSharp.Hosting..::.ProjectInvocation
Parameters for the PostSharp invocation.

Implements

IPostSharpObject..::.InvokeProject(ProjectInvocation)

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


InvokeProjects Method

PostSharpObject..::..InvokeProjects Method
PostSharpObject Class See Also Send Feedback
Requests the processing of PostSharp projects. Each project and its parameters are described in a ProjectInvocation object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void InvokeProjects(
    ProjectInvocation[] projectInvocations
)

Parameters

projectInvocations
Type: array< PostSharp.Hosting..::.ProjectInvocation >[]()[][]
An array in which each element is a request to execute a PostSharp project.

Implements

IPostSharpObject..::.InvokeProjects(array<ProjectInvocation>[]()[])

Remarks

One source assembly may be processed only once in the lifetime of a IPostSharpObject.

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


ProcessAssemblies Method

PostSharpObject..::..ProcessAssemblies Method
PostSharpObject Class See Also Send Feedback
Requests the processing of assemblies by PostSharp. The projects to be executed and their parameters are not yet known. They will be requested through the GetProjectInvocationParameters(String, String, AssemblyName) method of the IPostSharpHost interface.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public void ProcessAssemblies(
    ModuleLoadStrategy[] modules
)

Parameters

modules
Type: array< PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy >[]()[][]
Array of assemblies to be processed.

Implements

IPostSharpObject..::.ProcessAssemblies(array<ModuleLoadStrategy>[]()[])

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PostSharpObject Properties

[image]

PostSharp 2.0 Documentation
PostSharpObject Properties
PostSharpObject Class See Also Send Feedback

The PostSharpObject type exposes the following members.

Properties

 | Name | Description
Public property | AppDomain | Gets the AppDomain in which the PostSharp Object lives.
Public property | CurrentProject | Gets the currently executing project.
Public property | Domain | Gets the Domain in which all modules are loaded and processed.

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


AppDomain Property

PostSharpObject..::..AppDomain Property
PostSharpObject Class See Also Send Feedback
Gets the AppDomain in which the PostSharp Object lives.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public AppDomain AppDomain { get; }

Implements

IPostSharpObject..::.AppDomain

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


CurrentProject Property

PostSharpObject..::..CurrentProject Property
PostSharpObject Class See Also Send Feedback
Gets the currently executing project.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Project CurrentProject { get; }

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


Domain Property

PostSharpObject..::..Domain Property
PostSharpObject Class See Also Send Feedback
Gets the Domain in which all modules are loaded and processed.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Domain Domain { get; }

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PostSharpObject Events

[image]

PostSharp 2.0 Documentation
PostSharpObject Events
PostSharpObject Class See Also Send Feedback

The PostSharpObject type exposes the following members.

Events

 | Name | Description
Public event | PhaseExecuted | Event raised after a phase has been executed on a group of projects, if the project execution mode is Phased.
Public event | PhaseExecuting | Event raised before a phase is executed on a group of projects, if the project execution mode is Phased.

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PhaseExecuted Event

PostSharpObject..::..PhaseExecuted Event
PostSharpObject Class See Also Send Feedback
Event raised after a phase has been executed on a group of projects, if the project execution mode is Phased.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public event EventHandler<PhaseExecutedEventArgs> PhaseExecuted

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PhaseExecuting Event

PostSharpObject..::..PhaseExecuting Event
PostSharpObject Class See Also Send Feedback
Event raised before a phase is executed on a group of projects, if the project execution mode is Phased.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public event EventHandler<PhaseExecutedEventArgs> PhaseExecuting

See Also

PostSharpObject Class
PostSharp.Hosting Namespace


PostSharpObjectSettings Class

PostSharpObjectSettings Class
Members See Also Send Feedback
Specifies how the PostSharp Object (IPostSharpObject) should be instantiated and should behave.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
[SerializableAttribute]
public sealed class PostSharpObjectSettings

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.PostSharpObjectSettings

See Also

PostSharpObjectSettings Members
PostSharp.Hosting Namespace


PostSharpObjectSettings Members

[image]

PostSharp 2.0 Documentation
PostSharpObjectSettings Members
PostSharpObjectSettings Class Constructors Properties See Also Send Feedback

The PostSharpObjectSettings type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharpObjectSettings | Initializes a new PostSharpObjectSettings and set default values.

Properties

 | Name | Description
Public property | AppDomainSetup | The AppDomainSetup object used to create the private AppDomain. Ignored if the property CreatePrivateAppDomain is false.
Public property | CollectMetrics | Determines whether PostSharp should collect metrics
Public property | CreatePrivateAppDomain | Determines whether the PostSharp Object should be created in a new AppDomain.
Public property | DisabledMessages | Gets the set of messages that should be disabled.
Public property | DisableReflection | Determines whether user code is allowed to be loaded in the CLR.
Public property | DomainTags | Gets the collection of domainTags set on the PostSharp Object.
Public property | EnabledTraceCategories | Set of enabled trace categories.
Public property | Evidence | Evidence mapped through the security policy to establish a top-of-stack permission set of the new AppDomain. Ignored if the property CreatePrivateAppDomain is false.
Public property | LicenseManager | Gets or sets the LicenseManager.
Public property | LocalHostImplementation | Gets or sets the assembly-qualified name of the implementation of the local host. This type should be derived from PostSharpLocalHost and have a default constructor.
Public property | Messenger | Gets the Messenger.
Public property | OverwriteAssemblyNames | Determines whether the name of processed assemblies should be automatically modified.
Public property | PermissionSet | A default permission set that is granted to all assemblies loaded into the new application domain that do not have specific grants. Ignored if the property CreatePrivateAppDomain is false.
Public property | PlatformTypeName | Gets or sets the type of the Platform implementation.
Public property | ProjectExecutionOrder | Gets or sets the project execution order. Determines whether projects should be executed sequentially or per phase.
Public property | ReportExceptions | Determines whether PostSharp should report unhandled exceptions to SharpCrafters.
Public property | SearchDirectories | Gets the set of directories in which assemblies have to be searched.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


PostSharpObjectSettings Constructor

PostSharpObjectSettings Constructor
PostSharpObjectSettings Class See Also Send Feedback
Initializes a new PostSharpObjectSettings and set default values.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public PostSharpObjectSettings(
    Messenger messenger
)

Parameters

messenger
Type: PostSharp.Sdk.Extensibility..::.Messenger

[Missing <param name="messenger"/> documentation for "M:PostSharp.Hosting.PostSharpObjectSettings.#ctor(PostSharp.Sdk.Extensibility.Messenger)"]

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


PostSharpObjectSettings Properties

[image]

PostSharp 2.0 Documentation
PostSharpObjectSettings Properties
PostSharpObjectSettings Class See Also Send Feedback

The PostSharpObjectSettings type exposes the following members.

Properties

 | Name | Description
Public property | AppDomainSetup | The AppDomainSetup object used to create the private AppDomain. Ignored if the property CreatePrivateAppDomain is false.
Public property | CollectMetrics | Determines whether PostSharp should collect metrics
Public property | CreatePrivateAppDomain | Determines whether the PostSharp Object should be created in a new AppDomain.
Public property | DisabledMessages | Gets the set of messages that should be disabled.
Public property | DisableReflection | Determines whether user code is allowed to be loaded in the CLR.
Public property | DomainTags | Gets the collection of domainTags set on the PostSharp Object.
Public property | EnabledTraceCategories | Set of enabled trace categories.
Public property | Evidence | Evidence mapped through the security policy to establish a top-of-stack permission set of the new AppDomain. Ignored if the property CreatePrivateAppDomain is false.
Public property | LicenseManager | Gets or sets the LicenseManager.
Public property | LocalHostImplementation | Gets or sets the assembly-qualified name of the implementation of the local host. This type should be derived from PostSharpLocalHost and have a default constructor.
Public property | Messenger | Gets the Messenger.
Public property | OverwriteAssemblyNames | Determines whether the name of processed assemblies should be automatically modified.
Public property | PermissionSet | A default permission set that is granted to all assemblies loaded into the new application domain that do not have specific grants. Ignored if the property CreatePrivateAppDomain is false.
Public property | PlatformTypeName | Gets or sets the type of the Platform implementation.
Public property | ProjectExecutionOrder | Gets or sets the project execution order. Determines whether projects should be executed sequentially or per phase.
Public property | ReportExceptions | Determines whether PostSharp should report unhandled exceptions to SharpCrafters.
Public property | SearchDirectories | Gets the set of directories in which assemblies have to be searched.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


AppDomainSetup Property

PostSharpObjectSettings..::..AppDomainSetup Property
PostSharpObjectSettings Class See Also Send Feedback
The AppDomainSetup object used to create the private AppDomain. Ignored if the property CreatePrivateAppDomain is false.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public AppDomainSetup AppDomainSetup { get; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


CollectMetrics Property

PostSharpObjectSettings..::..CollectMetrics Property
PostSharpObjectSettings Class See Also Send Feedback
Determines whether PostSharp should collect metrics

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool CollectMetrics { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


CreatePrivateAppDomain Property

PostSharpObjectSettings..::..CreatePrivateAppDomain Property
PostSharpObjectSettings Class See Also Send Feedback
Determines whether the PostSharp Object should be created in a new AppDomain.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool CreatePrivateAppDomain { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


DisabledMessages Property

PostSharpObjectSettings..::..DisabledMessages Property
PostSharpObjectSettings Class See Also Send Feedback
Gets the set of messages that should be disabled.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Set<string> DisabledMessages { get; }

Remarks

Populate the set with the identifier of messages to be disabled. You cannot disable errors or fatal errors.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


DisableReflection Property

PostSharpObjectSettings..::..DisableReflection Property
PostSharpObjectSettings Class See Also Send Feedback
Determines whether user code is allowed to be loaded in the CLR.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool DisableReflection { get; set; }

Remarks

The value should typically be true for assemblies linked against the full .NET Framework, and false for assemblies linked against the Compact Framework or Silverlight.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


DomainTags Property

PostSharpObjectSettings..::..DomainTags Property
PostSharpObjectSettings Class See Also Send Feedback
Gets the collection of domainTags set on the PostSharp Object.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public TagCollection DomainTags { get; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


EnabledTraceCategories Property

PostSharpObjectSettings..::..EnabledTraceCategories Property
PostSharpObjectSettings Class See Also Send Feedback
Set of enabled trace categories.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Set<string> EnabledTraceCategories { get; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


Evidence Property

PostSharpObjectSettings..::..Evidence Property
PostSharpObjectSettings Class See Also Send Feedback
Evidence mapped through the security policy to establish a top-of-stack permission set of the new AppDomain. Ignored if the property CreatePrivateAppDomain is false.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Evidence Evidence { get; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


LicenseManager Property

PostSharpObjectSettings..::..LicenseManager Property
PostSharpObjectSettings Class See Also Send Feedback
Gets or sets the LicenseManager.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public LicenseManager LicenseManager { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


LocalHostImplementation Property

PostSharpObjectSettings..::..LocalHostImplementation Property
PostSharpObjectSettings Class See Also Send Feedback
Gets or sets the assembly-qualified name of the implementation of the local host. This type should be derived from PostSharpLocalHost and have a default constructor.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public string LocalHostImplementation { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


Messenger Property

PostSharpObjectSettings..::..Messenger Property
PostSharpObjectSettings Class See Also Send Feedback
Gets the Messenger.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Messenger Messenger { get; private set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


OverwriteAssemblyNames Property

PostSharpObjectSettings..::..OverwriteAssemblyNames Property
PostSharpObjectSettings Class See Also Send Feedback
Determines whether the name of processed assemblies should be automatically modified.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool OverwriteAssemblyNames { get; set; }

Remarks

You will typically use false in the compile-time scenario and true in the runtime scenario.

A true value instructs the PostSharp Object to suppress public keys from and to append a tilde to names of transformed assemblies. Removing public keys is required (unless you can resign assemblies after processing), otherwise the VRE will refuse to load transformed assemblies. Changing assembly names make sure that the system Assembly Binder does not load the original assembly and call 'our' custom binder.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


PermissionSet Property

PostSharpObjectSettings..::..PermissionSet Property
PostSharpObjectSettings Class See Also Send Feedback
A default permission set that is granted to all assemblies loaded into the new application domain that do not have specific grants. Ignored if the property CreatePrivateAppDomain is false.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public PermissionSet PermissionSet { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


PlatformTypeName Property

PostSharpObjectSettings..::..PlatformTypeName Property
PostSharpObjectSettings Class See Also Send Feedback
Gets or sets the type of the Platform implementation.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public string PlatformTypeName { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


ProjectExecutionOrder Property

PostSharpObjectSettings..::..ProjectExecutionOrder Property
PostSharpObjectSettings Class See Also Send Feedback
Gets or sets the project execution order. Determines whether projects should be executed sequentially or per phase.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProjectExecutionOrder ProjectExecutionOrder { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace
PostSharp.Hosting..::.ProjectExecutionOrder


ReportExceptions Property

PostSharpObjectSettings..::..ReportExceptions Property
PostSharpObjectSettings Class See Also Send Feedback
Determines whether PostSharp should report unhandled exceptions to SharpCrafters.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool ReportExceptions { get; set; }

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


SearchDirectories Property

PostSharpObjectSettings..::..SearchDirectories Property
PostSharpObjectSettings Class See Also Send Feedback
Gets the set of directories in which assemblies have to be searched.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public Set<string> SearchDirectories { get; }

Remarks

This search path is useful when assemblies and their dependencies are loaded, before projects are executed. In order to specify the path of PostSharp plug-ins, it is preferable to use the standard search path facility of projects.

See Also

PostSharpObjectSettings Class
PostSharp.Hosting Namespace


Program Class

Program Class
Members See Also Send Feedback
Entry point of PostSharp.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public abstract class Program

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.Program
PostSharp.Hosting..::.ConsoleProgram

See Also

Program Members
PostSharp.Hosting Namespace


Program Members

[image]

PostSharp 2.0 Documentation
Program Members
Program Class Constructors Methods Properties See Also Send Feedback

The Program type exposes the following members.

Constructors

 | Name | Description
Protected method | Program | Initializes a new Program.

Methods

 | Name | Description
Protected method | BeginCheckUpdates | Begin to check updates.
Public method | Execute | Executes the program.
Protected method | Pause | Pause and wait for user input before continuing.
Protected method | PrintLogo | Prints the banner line.
Protected method | PrintMessage | Overloaded.
Protected method | PrintUsage | Prints usage help.
Protected method | WriteMetrics | Writes a collection of metric.
 | WriteMetricsImpl | Implementation of WriteMetrics(MetricCollection).

Properties

 | Name | Description
Protected property | Arguments | Gets the array of command-line arguments.
Protected property | CreateAppDomain | Determines whether a new AppDomain should be created for this program instance.
 | Current | Gets the current Program.
Protected property | NoColor | Determines if message should be written without color.
Protected property | WorkingDirectory | Gets or sets the working directory.

See Also

Program Class
PostSharp.Hosting Namespace


Program Constructor

Program Constructor
Program Class See Also Send Feedback
Initializes a new Program.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected Program(
    string[] arguments
)

Parameters

arguments
Type: array< System..::.String >[]()[][]
Command-line arguments.

See Also

Program Class
PostSharp.Hosting Namespace


Program Methods

[image]

PostSharp 2.0 Documentation
Program Methods
Program Class See Also Send Feedback

The Program type exposes the following members.

Methods

 | Name | Description
Protected method | BeginCheckUpdates | Begin to check updates.
Public method | Execute | Executes the program.
Protected method | Pause | Pause and wait for user input before continuing.
Protected method | PrintLogo | Prints the banner line.
Protected method | PrintMessage | Overloaded.
Protected method | PrintUsage | Prints usage help.
Protected method | WriteMetrics | Writes a collection of metric.
 | WriteMetricsImpl | Implementation of WriteMetrics(MetricCollection).

See Also

Program Class
PostSharp.Hosting Namespace


BeginCheckUpdates Method

Program..::..BeginCheckUpdates Method
Program Class See Also Send Feedback
Begin to check updates.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void BeginCheckUpdates()

See Also

Program Class
PostSharp.Hosting Namespace


Execute Method

Program..::..Execute Method
Program Class See Also Send Feedback
Executes the program.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProgramReturnCode Execute()

Return Value

Return code.

See Also

Program Class
PostSharp.Hosting Namespace


Pause Method

Program..::..Pause Method
Program Class See Also Send Feedback
Pause and wait for user input before continuing.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void Pause()

See Also

Program Class
PostSharp.Hosting Namespace


PrintLogo Method

Program..::..PrintLogo Method
Program Class See Also Send Feedback
Prints the banner line.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void PrintLogo()

See Also

Program Class
PostSharp.Hosting Namespace


PrintMessage Method

[image]

PostSharp 2.0 Documentation
Program..::..PrintMessage Method
Program Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | PrintMessage(Message) | Prints a Message.
Protected method | PrintMessage(SeverityType, String, String) | Prints a message.

See Also

Program Class
Program Members
PostSharp.Hosting Namespace


PrintMessage Method (Message)

Program..::..PrintMessage Method (Message)
Program Class See Also Send Feedback
Prints a Message.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void PrintMessage(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message

[Missing <param name="message"/> documentation for "M:PostSharp.Hosting.Program.PrintMessage(PostSharp.Extensibility.Message)"]

See Also

Program Class
PrintMessage Overload
PostSharp.Hosting Namespace


PrintMessage Method (SeverityType, String, String)

Program..::..PrintMessage Method (SeverityType, String, String)
Program Class See Also Send Feedback
Prints a message.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void PrintMessage(
    SeverityType severity,
    string messageId,
    string message
)

Parameters

severity
Type: PostSharp.Extensibility..::.SeverityType
Severity.
messageId
Type: System..::.String
Message identifier.
message
Type: System..::.String
Message text.

See Also

Program Class
PrintMessage Overload
PostSharp.Hosting Namespace


PrintUsage Method

Program..::..PrintUsage Method
Program Class See Also Send Feedback
Prints usage help.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void PrintUsage()

See Also

Program Class
PostSharp.Hosting Namespace


WriteMetrics Method

Program..::..WriteMetrics Method
Program Class See Also Send Feedback
Writes a collection of metric.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected abstract void WriteMetrics(
    MetricCollection metrics
)

Parameters

metrics
Type: PostSharp.Sdk.User..::.MetricCollection
Collection of metrics.

See Also

Program Class
PostSharp.Hosting Namespace


WriteMetricsImpl Method

Program..::..WriteMetricsImpl Method
Program Class See Also Send Feedback
Implementation of WriteMetrics(MetricCollection).

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected static void WriteMetricsImpl(
    MetricCollection metrics
)

Parameters

metrics
Type: PostSharp.Sdk.User..::.MetricCollection
Collection of metrics.

See Also

Program Class
PostSharp.Hosting Namespace


Program Properties

[image]

PostSharp 2.0 Documentation
Program Properties
Program Class See Also Send Feedback

The Program type exposes the following members.

Properties

 | Name | Description
Protected property | Arguments | Gets the array of command-line arguments.
Protected property | CreateAppDomain | Determines whether a new AppDomain should be created for this program instance.
 | Current | Gets the current Program.
Protected property | NoColor | Determines if message should be written without color.
Protected property | WorkingDirectory | Gets or sets the working directory.

See Also

Program Class
PostSharp.Hosting Namespace


Arguments Property

Program..::..Arguments Property
Program Class See Also Send Feedback
Gets the array of command-line arguments.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected string[] Arguments { get; }

See Also

Program Class
PostSharp.Hosting Namespace


CreateAppDomain Property

Program..::..CreateAppDomain Property
Program Class See Also Send Feedback
Determines whether a new AppDomain should be created for this program instance.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected bool CreateAppDomain { get; set; }

See Also

Program Class
PostSharp.Hosting Namespace


Current Property

Program..::..Current Property
Program Class See Also Send Feedback
Gets the current Program.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public static Program Current { get; private set; }

See Also

Program Class
PostSharp.Hosting Namespace


NoColor Property

Program..::..NoColor Property
Program Class See Also Send Feedback
Determines if message should be written without color.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected bool NoColor { get; private set; }

See Also

Program Class
PostSharp.Hosting Namespace


WorkingDirectory Property

Program..::..WorkingDirectory Property
Program Class See Also Send Feedback
Gets or sets the working directory.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
protected string WorkingDirectory { get; set; }

See Also

Program Class
PostSharp.Hosting Namespace


ProgramReturnCode Enumeration

ProgramReturnCode Enumeration
See Also Send Feedback
Return codes of Program.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public enum ProgramReturnCode

Members

Member name | Value | Description
Success | 0 | Success.
InvalidCommandLine | 10 | Invalid command line.
Error | 11 | Error (emitted as a Message).
Exception | 12 | Unhandled exception.
UnexpectedMessages | 13 | An expected message was not emitted.
ExpectedError | 14 | An expected error was emitted.

See Also

PostSharp.Hosting Namespace


ProjectExecutionOrder Enumeration

ProjectExecutionOrder Enumeration
See Also Send Feedback
Determines in which order tasks of projects should be executed. This is relevant only when the InvokeProjects(array<ProjectInvocation>[]()[]) method is called with many projects or if many projects are executed together due to recursive processing.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public enum ProjectExecutionOrder

Members

Member name | Value | Description
Default | 0 | Default execution order: Sequential.
Sequential | 0 | Projects are executed atomically. All tasks of all phases of one project are executed, then the next projects are executed.
Phased | 1 | Groups of projects are executed per phase. Tasks of one phases of all projects are executed, then the next phases are are executed for all projects.

See Also

PostSharp.Hosting Namespace


ProjectInvocation Class

ProjectInvocation Class
Members See Also Send Feedback
Request to execute a Project.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
[SerializableAttribute]
public sealed class ProjectInvocation

Remarks

When invoking a project, one should give (1) the project to execute, (2) the module that should be processed and (3) some user-defined properties. The two last elements are encapsulates by the ProjectInvocationParameters class. The ProjectInvocation class encapsulates both the module identity and a ProjectInvocationParameters object.

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.ProjectInvocation

See Also

ProjectInvocation Members
PostSharp.Hosting Namespace


ProjectInvocation Members

[image]

PostSharp 2.0 Documentation
ProjectInvocation Members
ProjectInvocation Class Constructors Properties See Also Send Feedback

The ProjectInvocation type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectInvocation | Initializes a new ProjectInvocation and informs to process the default module (manifest module) of the given assembly.

Properties

 | Name | Description
Public property | InvocationParameters | Gets the identity of the project and the parameters with which it should be executed.
Public property | ModuleLoadStrategy | Gets the identity of the assembly and the arguments with which it should be loaded.

See Also

ProjectInvocation Class
PostSharp.Hosting Namespace


ProjectInvocation Constructor

ProjectInvocation Constructor
ProjectInvocation Class See Also Send Feedback
Initializes a new ProjectInvocation and informs to process the default module (manifest module) of the given assembly.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProjectInvocation(
    ProjectInvocationParameters invocationParameters,
    ModuleLoadStrategy moduleLoadStrategy
)

Parameters

invocationParameters
Type: PostSharp.Hosting..::.ProjectInvocationParameters
Identity of the project to be executed and their parameters.
moduleLoadStrategy
Type: PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
Identity of the assembly to be loaded.

See Also

ProjectInvocation Class
PostSharp.Hosting Namespace


ProjectInvocation Properties

[image]

PostSharp 2.0 Documentation
ProjectInvocation Properties
ProjectInvocation Class See Also Send Feedback

The ProjectInvocation type exposes the following members.

Properties

 | Name | Description
Public property | InvocationParameters | Gets the identity of the project and the parameters with which it should be executed.
Public property | ModuleLoadStrategy | Gets the identity of the assembly and the arguments with which it should be loaded.

See Also

ProjectInvocation Class
PostSharp.Hosting Namespace


InvocationParameters Property

ProjectInvocation..::..InvocationParameters Property
ProjectInvocation Class See Also Send Feedback
Gets the identity of the project and the parameters with which it should be executed.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProjectInvocationParameters InvocationParameters { get; }

See Also

ProjectInvocation Class
PostSharp.Hosting Namespace


ModuleLoadStrategy Property

ProjectInvocation..::..ModuleLoadStrategy Property
ProjectInvocation Class See Also Send Feedback
Gets the identity of the assembly and the arguments with which it should be loaded.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ModuleLoadStrategy ModuleLoadStrategy { get; }

See Also

ProjectInvocation Class
PostSharp.Hosting Namespace


ProjectInvocationParameters Class

ProjectInvocationParameters Class
Members See Also Send Feedback
Determines how an already-given module should be processed. Encapsulates a project identity and the properties with which it should be executed.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
[SerializableAttribute]
public sealed class ProjectInvocationParameters

Inheritance Hierarchy

System..::.Object
PostSharp.Hosting..::.ProjectInvocationParameters

See Also

ProjectInvocationParameters Members
PostSharp.Hosting Namespace


ProjectInvocationParameters Members

[image]

PostSharp 2.0 Documentation
ProjectInvocationParameters Members
ProjectInvocationParameters Class Constructors Properties See Also Send Feedback

The ProjectInvocationParameters type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectInvocationParameters | Initializes a new ProjectInvocationParameters.

Properties

 | Name | Description
Public property | PreventOverwriteAssemblyNames | If true, the name of this assembly won't be overwritten.
Public property | ProcessDependenciesFirst | Determines whether the dependencies of this module should be processed before.
Public property | ProjectConfigurationFile | Gets the location of the project configuration file.
Public property | Properties | Gets the collection of properties with which the project should be executed.
Public property | Tags | Gets the collection of tags that needs to be passed to the Project.

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


ProjectInvocationParameters Constructor

ProjectInvocationParameters Constructor
ProjectInvocationParameters Class See Also Send Feedback
Initializes a new ProjectInvocationParameters.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public ProjectInvocationParameters(
    string projectConfigurationFile
)

Parameters

projectConfigurationFile
Type: System..::.String
Location of the project file.

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


ProjectInvocationParameters Properties

[image]

PostSharp 2.0 Documentation
ProjectInvocationParameters Properties
ProjectInvocationParameters Class See Also Send Feedback

The ProjectInvocationParameters type exposes the following members.

Properties

 | Name | Description
Public property | PreventOverwriteAssemblyNames | If true, the name of this assembly won't be overwritten.
Public property | ProcessDependenciesFirst | Determines whether the dependencies of this module should be processed before.
Public property | ProjectConfigurationFile | Gets the location of the project configuration file.
Public property | Properties | Gets the collection of properties with which the project should be executed.
Public property | Tags | Gets the collection of tags that needs to be passed to the Project.

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


PreventOverwriteAssemblyNames Property

ProjectInvocationParameters..::..PreventOverwriteAssemblyNames Property
ProjectInvocationParameters Class See Also Send Feedback
If true, the name of this assembly won't be overwritten.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool PreventOverwriteAssemblyNames { get; set; }

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


ProcessDependenciesFirst Property

ProjectInvocationParameters..::..ProcessDependenciesFirst Property
ProjectInvocationParameters Class See Also Send Feedback
Determines whether the dependencies of this module should be processed before.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public bool ProcessDependenciesFirst { get; set; }

Remarks

If this property is true, the PostSharp Object will call the GetProjectInvocationParameters(String, String, AssemblyName) for each dependency.

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


ProjectConfigurationFile Property

ProjectInvocationParameters..::..ProjectConfigurationFile Property
ProjectInvocationParameters Class See Also Send Feedback
Gets the location of the project configuration file.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public string ProjectConfigurationFile { get; }

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


Properties Property

ProjectInvocationParameters..::..Properties Property
ProjectInvocationParameters Class See Also Send Feedback
Gets the collection of properties with which the project should be executed.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public PropertyCollection Properties { get; }

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


Tags Property

ProjectInvocationParameters..::..Tags Property
ProjectInvocationParameters Class See Also Send Feedback
Gets the collection of tags that needs to be passed to the Project.

Namespace: PostSharp.Hosting
Assembly: PostSharp.Hosting (in PostSharp.Hosting.dll) Version: 2.0.0.0 (2.0.7.1249)

Syntax

C#
public TagCollection Tags { get; }

See Also

ProjectInvocationParameters Class
PostSharp.Hosting Namespace


PostSharp.MSBuild Namespace

PostSharp.MSBuild Namespace
Send Feedback
The PostSharp.MSBuild namespace contains the MSBuild tasks for PostSharp.

Classes

 | Class | Description
Public class | PostSharp20 | [MSBuild Task] Execute PostSharp.
Public class | PostSharp20CheckPfx | [MSBuild Task] Checks the kind of key being used to sign an assembly. If the key is a PFX, exports the SNK from it, sets the PublicKeyFile to the path of this key and sets the SignAfterPostSharp property to true
Public class | PostSharp20GetCurrentProjectDirectory | [MSBuild Task] Gets the directory containing the current project or targets file.
Public class | PostSharp20MoveWithRetry | [MSBuild Task] Move or rename a file and retries the operation during a defined amount of time in case that a sharing violation exception occurs.
Public class | PostSharp20Sign | [MSBuild Task] Signs an assembly using the sn utility.
Public class | PostSharp20TouchWithDelay | [MSBuild Task] Touches a file according to the modification time of another file.


PostSharp20 Class

PostSharp20 Class
Members See Also Send Feedback
[MSBuild Task] Execute PostSharp.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public sealed class PostSharp20 : ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
PostSharp.MSBuild..::.PostSharp20

See Also

PostSharp20 Members
PostSharp.MSBuild Namespace


PostSharp20 Members

[image]

PostSharp 2.0 Documentation
PostSharp20 Members
PostSharp20 Class Constructors Methods Properties See Also Send Feedback

The PostSharp20 type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20 | Initializes a new instance of the PostSharp20 task.

Methods

 | Name | Description
Public method | Execute | Executes the task. (Overrides ToolTask..::.Execute()()().)

Properties

 | Name | Description
Public property | AttachDebugger | If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.
Public property | ClientAttachDebugger | If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.
Public property | DisableReflection | If true, user assemblies will not be loaded into the CLR. This behavior is typically desired when user assemblies are linked against the Compact Framework or Silverlight.
Public property | ExitCode | Gets or sets the exit code of PostSharp.
Public property | ExpectedMessages | A list of semicolon-separated message codes that are expected during the execution of PostSharp. The task will fail if some expected message was not emitted.
Public property | FailOnUnexpectedMessage | If true, this MSBuild task will fail if the task emits some message that was not listed in ExpectedMessages, even if this message is not an error.
Public property | Host | Gets or sets the kind of process that will host PostSharp. Valid values are Native, Managed, and PipeServer.
Public property | IgnoreError | If true, this MSBuild task will return successfully even in case of error.
Public property | Input | Gets or sets the location of the assembly to be processed.
Public property | InputReferenceDirectory | Directory according to which the Input property should be resolved, if a relative filename is given in Input.
Public property | LicenseKey | Gets or sets the user license key.
Public property | NoLogo | Indicates that the PostSharp tag line should not be printed.
Public property | PipeTimeout | Gets or sets the timeout, in millisecond, of communication between the MSBuild task and the pipe server. The default value is -1 (infinite).
Public property | Project | Gets or sets the PostSharp project to be executed. Required.
Public property | Properties | Gets or sets the proerties passed to the PostSharp project.
Public property | TargetPlatform | Gets or sets the platform (a combination of CLR version and processor architecture) under which PostSharp should be started. Valid values are 2.0-x86, 2.0-x64, 4.0-x86, and 4.0-x64.
Public property | TraceCategories | A semicolon-separated list of trace categories that should be enabled.

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


PostSharp20 Constructor

PostSharp20 Constructor
PostSharp20 Class See Also Send Feedback
Initializes a new instance of the PostSharp20 task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20()

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


PostSharp20 Methods

[image]

PostSharp 2.0 Documentation
PostSharp20 Methods
PostSharp20 Class See Also Send Feedback

The PostSharp20 type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Executes the task. (Overrides ToolTask..::.Execute()()().)

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


Execute Method

PostSharp20..::..Execute Method
PostSharp20 Class See Also Send Feedback
Executes the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public override bool Execute()

Return Value

true if the task was successful, otherwise false.

Implements

ITask..::.Execute()()()

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


PostSharp20 Properties

[image]

PostSharp 2.0 Documentation
PostSharp20 Properties
PostSharp20 Class See Also Send Feedback

The PostSharp20 type exposes the following members.

Properties

 | Name | Description
Public property | AttachDebugger | If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.
Public property | ClientAttachDebugger | If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.
Public property | DisableReflection | If true, user assemblies will not be loaded into the CLR. This behavior is typically desired when user assemblies are linked against the Compact Framework or Silverlight.
Public property | ExitCode | Gets or sets the exit code of PostSharp.
Public property | ExpectedMessages | A list of semicolon-separated message codes that are expected during the execution of PostSharp. The task will fail if some expected message was not emitted.
Public property | FailOnUnexpectedMessage | If true, this MSBuild task will fail if the task emits some message that was not listed in ExpectedMessages, even if this message is not an error.
Public property | Host | Gets or sets the kind of process that will host PostSharp. Valid values are Native, Managed, and PipeServer.
Public property | IgnoreError | If true, this MSBuild task will return successfully even in case of error.
Public property | Input | Gets or sets the location of the assembly to be processed.
Public property | InputReferenceDirectory | Directory according to which the Input property should be resolved, if a relative filename is given in Input.
Public property | LicenseKey | Gets or sets the user license key.
Public property | NoLogo | Indicates that the PostSharp tag line should not be printed.
Public property | PipeTimeout | Gets or sets the timeout, in millisecond, of communication between the MSBuild task and the pipe server. The default value is -1 (infinite).
Public property | Project | Gets or sets the PostSharp project to be executed. Required.
Public property | Properties | Gets or sets the proerties passed to the PostSharp project.
Public property | TargetPlatform | Gets or sets the platform (a combination of CLR version and processor architecture) under which PostSharp should be started. Valid values are 2.0-x86, 2.0-x64, 4.0-x86, and 4.0-x64.
Public property | TraceCategories | A semicolon-separated list of trace categories that should be enabled.

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


AttachDebugger Property

PostSharp20..::..AttachDebugger Property
PostSharp20 Class See Also Send Feedback
If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool AttachDebugger { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


ClientAttachDebugger Property

PostSharp20..::..ClientAttachDebugger Property
PostSharp20 Class See Also Send Feedback
If true, the method Debugger.Launch()()() will be invoked before the execution of PostSharp, given the opportunity to attach a debugger to the building process.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool ClientAttachDebugger { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


DisableReflection Property

PostSharp20..::..DisableReflection Property
PostSharp20 Class See Also Send Feedback
If true, user assemblies will not be loaded into the CLR. This behavior is typically desired when user assemblies are linked against the Compact Framework or Silverlight.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool DisableReflection { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


ExitCode Property

PostSharp20..::..ExitCode Property
PostSharp20 Class See Also Send Feedback
Gets or sets the exit code of PostSharp.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public int ExitCode { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


ExpectedMessages Property

PostSharp20..::..ExpectedMessages Property
PostSharp20 Class See Also Send Feedback
A list of semicolon-separated message codes that are expected during the execution of PostSharp. The task will fail if some expected message was not emitted.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string ExpectedMessages { get; set; }

Remarks

This feature is useful for testing of aspects and compile-time validation logic.

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace
PostSharp20..::.FailOnUnexpectedMessage


FailOnUnexpectedMessage Property

PostSharp20..::..FailOnUnexpectedMessage Property
PostSharp20 Class See Also Send Feedback
If true, this MSBuild task will fail if the task emits some message that was not listed in ExpectedMessages, even if this message is not an error.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool FailOnUnexpectedMessage { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


Host Property

PostSharp20..::..Host Property
PostSharp20 Class See Also Send Feedback
Gets or sets the kind of process that will host PostSharp. Valid values are Native, Managed, and PipeServer.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Host { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


IgnoreError Property

PostSharp20..::..IgnoreError Property
PostSharp20 Class See Also Send Feedback
If true, this MSBuild task will return successfully even in case of error.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool IgnoreError { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


Input Property

PostSharp20..::..Input Property
PostSharp20 Class See Also Send Feedback
Gets or sets the location of the assembly to be processed.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Input { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace
PostSharp20..::.InputReferenceDirectory


InputReferenceDirectory Property

PostSharp20..::..InputReferenceDirectory Property
PostSharp20 Class See Also Send Feedback
Directory according to which the Input property should be resolved, if a relative filename is given in Input.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string InputReferenceDirectory { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


LicenseKey Property

PostSharp20..::..LicenseKey Property
PostSharp20 Class See Also Send Feedback
Gets or sets the user license key.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string LicenseKey { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


NoLogo Property

PostSharp20..::..NoLogo Property
PostSharp20 Class See Also Send Feedback
Indicates that the PostSharp tag line should not be printed.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool NoLogo { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


PipeTimeout Property

PostSharp20..::..PipeTimeout Property
PostSharp20 Class See Also Send Feedback
Gets or sets the timeout, in millisecond, of communication between the MSBuild task and the pipe server. The default value is -1 (infinite).

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public int PipeTimeout { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


Project Property

PostSharp20..::..Project Property
PostSharp20 Class See Also Send Feedback
Gets or sets the PostSharp project to be executed. Required.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Project { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


Properties Property

PostSharp20..::..Properties Property
PostSharp20 Class See Also Send Feedback
Gets or sets the proerties passed to the PostSharp project.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Properties { get; set; }

Field Value

A string whose format is "Name1=Value1;Name2=Value2".

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


TargetPlatform Property

PostSharp20..::..TargetPlatform Property
PostSharp20 Class See Also Send Feedback
Gets or sets the platform (a combination of CLR version and processor architecture) under which PostSharp should be started. Valid values are 2.0-x86, 2.0-x64, 4.0-x86, and 4.0-x64.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string TargetPlatform { get; set; }

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


TraceCategories Property

PostSharp20..::..TraceCategories Property
PostSharp20 Class See Also Send Feedback
A semicolon-separated list of trace categories that should be enabled.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string TraceCategories { get; set; }

Remarks

Setting this property has no effect for the release build of PostSharp. Use this property only with the diagnostic build or the debug build.

See Also

PostSharp20 Class
PostSharp.MSBuild Namespace


PostSharp20CheckPfx Class

PostSharp20CheckPfx Class
Members See Also Send Feedback
[MSBuild Task] Checks the kind of key being used to sign an assembly. If the key is a PFX, exports the SNK from it, sets the PublicKeyFile to the path of this key and sets the SignAfterPostSharp property to true

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public sealed class PostSharp20CheckPfx : Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
PostSharp.MSBuild..::.PostSharp20CheckPfx

See Also

PostSharp20CheckPfx Members
PostSharp.MSBuild Namespace


PostSharp20CheckPfx Members

[image]

PostSharp 2.0 Documentation
PostSharp20CheckPfx Members
PostSharp20CheckPfx Class Constructors Methods Properties See Also Send Feedback

The PostSharp20CheckPfx type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20CheckPfx | Initializes a new instance of the PostSharp20CheckPfx class

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

Properties

 | Name | Description
Public property | KeyFile | Full path to the key file.
Public property | PostSharpKeyFile | After task execution, gets the full path of the key that should be used to sign the assembly after PostSharp.
Public property | PublicKeyFile | After task execution, gets the full path to the public key.
Public property | SignAfterPostSharp | After task exection, determines whether the assembly should be signed after PostSharp execution.

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PostSharp20CheckPfx Constructor

PostSharp20CheckPfx Constructor
PostSharp20CheckPfx Class See Also Send Feedback
Initializes a new instance of the PostSharp20CheckPfx class

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20CheckPfx()

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PostSharp20CheckPfx Methods

[image]

PostSharp 2.0 Documentation
PostSharp20CheckPfx Methods
PostSharp20CheckPfx Class See Also Send Feedback

The PostSharp20CheckPfx type exposes the following members.

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


Execute Method

PostSharp20CheckPfx..::..Execute Method
PostSharp20CheckPfx Class See Also Send Feedback
When overridden in a derived class, executes the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public override bool Execute()

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PostSharp20CheckPfx Properties

[image]

PostSharp 2.0 Documentation
PostSharp20CheckPfx Properties
PostSharp20CheckPfx Class See Also Send Feedback

The PostSharp20CheckPfx type exposes the following members.

Properties

 | Name | Description
Public property | KeyFile | Full path to the key file.
Public property | PostSharpKeyFile | After task execution, gets the full path of the key that should be used to sign the assembly after PostSharp.
Public property | PublicKeyFile | After task execution, gets the full path to the public key.
Public property | SignAfterPostSharp | After task exection, determines whether the assembly should be signed after PostSharp execution.

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


KeyFile Property

PostSharp20CheckPfx..::..KeyFile Property
PostSharp20CheckPfx Class See Also Send Feedback
Full path to the key file.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string KeyFile { get; set; }

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PostSharpKeyFile Property

PostSharp20CheckPfx..::..PostSharpKeyFile Property
PostSharp20CheckPfx Class See Also Send Feedback
After task execution, gets the full path of the key that should be used to sign the assembly after PostSharp.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string PostSharpKeyFile { get; set; }

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PublicKeyFile Property

PostSharp20CheckPfx..::..PublicKeyFile Property
PostSharp20CheckPfx Class See Also Send Feedback
After task execution, gets the full path to the public key.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string PublicKeyFile { get; set; }

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


SignAfterPostSharp Property

PostSharp20CheckPfx..::..SignAfterPostSharp Property
PostSharp20CheckPfx Class See Also Send Feedback
After task exection, determines whether the assembly should be signed after PostSharp execution.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public bool SignAfterPostSharp { get; set; }

See Also

PostSharp20CheckPfx Class
PostSharp.MSBuild Namespace


PostSharp20GetCurrentProjectDirectory Class

PostSharp20GetCurrentProjectDirectory Class
Members See Also Send Feedback
[MSBuild Task] Gets the directory containing the current project or targets file.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public sealed class PostSharp20GetCurrentProjectDirectory : Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
PostSharp.MSBuild..::.PostSharp20GetCurrentProjectDirectory

See Also

PostSharp20GetCurrentProjectDirectory Members
PostSharp.MSBuild Namespace


PostSharp20GetCurrentProjectDirectory Members

[image]

PostSharp 2.0 Documentation
PostSharp20GetCurrentProjectDirectory Members
PostSharp20GetCurrentProjectDirectory Class Constructors Methods Properties See Also Send Feedback

The PostSharp20GetCurrentProjectDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20GetCurrentProjectDirectory | Initializes a new instance of the PostSharp20GetCurrentProjectDirectory class

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

Properties

 | Name | Description
Public property | Directory | After task execution, gets the directory containing the project or target file that invoked the task.

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


PostSharp20GetCurrentProjectDirectory Constructor

PostSharp20GetCurrentProjectDirectory Constructor
PostSharp20GetCurrentProjectDirectory Class See Also Send Feedback
Initializes a new instance of the PostSharp20GetCurrentProjectDirectory class

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20GetCurrentProjectDirectory()

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


PostSharp20GetCurrentProjectDirectory Methods

[image]

PostSharp 2.0 Documentation
PostSharp20GetCurrentProjectDirectory Methods
PostSharp20GetCurrentProjectDirectory Class See Also Send Feedback

The PostSharp20GetCurrentProjectDirectory type exposes the following members.

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


Execute Method

PostSharp20GetCurrentProjectDirectory..::..Execute Method
PostSharp20GetCurrentProjectDirectory Class See Also Send Feedback
When overridden in a derived class, executes the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public override bool Execute()

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


PostSharp20GetCurrentProjectDirectory Properties

[image]

PostSharp 2.0 Documentation
PostSharp20GetCurrentProjectDirectory Properties
PostSharp20GetCurrentProjectDirectory Class See Also Send Feedback

The PostSharp20GetCurrentProjectDirectory type exposes the following members.

Properties

 | Name | Description
Public property | Directory | After task execution, gets the directory containing the project or target file that invoked the task.

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


Directory Property

PostSharp20GetCurrentProjectDirectory..::..Directory Property
PostSharp20GetCurrentProjectDirectory Class See Also Send Feedback
After task execution, gets the directory containing the project or target file that invoked the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public ITaskItem Directory { get; set; }

See Also

PostSharp20GetCurrentProjectDirectory Class
PostSharp.MSBuild Namespace


PostSharp20MoveWithRetry Class

PostSharp20MoveWithRetry Class
Members See Also Send Feedback
[MSBuild Task] Move or rename a file and retries the operation during a defined amount of time in case that a sharing violation exception occurs.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public class PostSharp20MoveWithRetry : Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
PostSharp.MSBuild..::.PostSharp20MoveWithRetry

See Also

PostSharp20MoveWithRetry Members
PostSharp.MSBuild Namespace


PostSharp20MoveWithRetry Members

[image]

PostSharp 2.0 Documentation
PostSharp20MoveWithRetry Members
PostSharp20MoveWithRetry Class Constructors Methods Properties See Also Send Feedback

The PostSharp20MoveWithRetry type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20MoveWithRetry | Initializes a new instance of the PostSharp20MoveWithRetry class

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

Properties

 | Name | Description
Public property | Destination | Gets or sets the target file path.
Public property | Source | Gets or sets the source file path.
Public property | Timeout | Gets or sets the timeout, in milliseconds, for the whole operation.
Public property | WarningTimeout | Gets or sets the timeout before a warning is emitted.

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


PostSharp20MoveWithRetry Constructor

PostSharp20MoveWithRetry Constructor
PostSharp20MoveWithRetry Class See Also Send Feedback
Initializes a new instance of the PostSharp20MoveWithRetry class

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20MoveWithRetry()

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


PostSharp20MoveWithRetry Methods

[image]

PostSharp 2.0 Documentation
PostSharp20MoveWithRetry Methods
PostSharp20MoveWithRetry Class See Also Send Feedback

The PostSharp20MoveWithRetry type exposes the following members.

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


Execute Method

PostSharp20MoveWithRetry..::..Execute Method
PostSharp20MoveWithRetry Class See Also Send Feedback
When overridden in a derived class, executes the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public override bool Execute()

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


PostSharp20MoveWithRetry Properties

[image]

PostSharp 2.0 Documentation
PostSharp20MoveWithRetry Properties
PostSharp20MoveWithRetry Class See Also Send Feedback

The PostSharp20MoveWithRetry type exposes the following members.

Properties

 | Name | Description
Public property | Destination | Gets or sets the target file path.
Public property | Source | Gets or sets the source file path.
Public property | Timeout | Gets or sets the timeout, in milliseconds, for the whole operation.
Public property | WarningTimeout | Gets or sets the timeout before a warning is emitted.

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


Destination Property

PostSharp20MoveWithRetry..::..Destination Property
PostSharp20MoveWithRetry Class See Also Send Feedback
Gets or sets the target file path.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Destination { get; set; }

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


Source Property

PostSharp20MoveWithRetry..::..Source Property
PostSharp20MoveWithRetry Class See Also Send Feedback
Gets or sets the source file path.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Source { get; set; }

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


Timeout Property

PostSharp20MoveWithRetry..::..Timeout Property
PostSharp20MoveWithRetry Class See Also Send Feedback
Gets or sets the timeout, in milliseconds, for the whole operation.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public int Timeout { get; set; }

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


WarningTimeout Property

PostSharp20MoveWithRetry..::..WarningTimeout Property
PostSharp20MoveWithRetry Class See Also Send Feedback
Gets or sets the timeout before a warning is emitted.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public int WarningTimeout { get; set; }

See Also

PostSharp20MoveWithRetry Class
PostSharp.MSBuild Namespace


PostSharp20Sign Class

PostSharp20Sign Class
Members See Also Send Feedback
[MSBuild Task] Signs an assembly using the sn utility.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public sealed class PostSharp20Sign : ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
PostSharp.MSBuild..::.PostSharp20Sign

See Also

PostSharp20Sign Members
PostSharp.MSBuild Namespace


PostSharp20Sign Members

[image]

PostSharp 2.0 Documentation
PostSharp20Sign Members
PostSharp20Sign Class Constructors Properties See Also Send Feedback

The PostSharp20Sign type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20Sign | Initializes a new instance of the PostSharp20Sign class

Properties

 | Name | Description
Public property | Assembly | Full path of the assembly to be signed.
Public property | KeyFile | Full path of the file containing the strong name key.

See Also

PostSharp20Sign Class
PostSharp.MSBuild Namespace


PostSharp20Sign Constructor

PostSharp20Sign Constructor
PostSharp20Sign Class See Also Send Feedback
Initializes a new instance of the PostSharp20Sign class

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20Sign()

See Also

PostSharp20Sign Class
PostSharp.MSBuild Namespace


PostSharp20Sign Properties

[image]

PostSharp 2.0 Documentation
PostSharp20Sign Properties
PostSharp20Sign Class See Also Send Feedback

The PostSharp20Sign type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Full path of the assembly to be signed.
Public property | KeyFile | Full path of the file containing the strong name key.

See Also

PostSharp20Sign Class
PostSharp.MSBuild Namespace


Assembly Property

PostSharp20Sign..::..Assembly Property
PostSharp20Sign Class See Also Send Feedback
Full path of the assembly to be signed.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string Assembly { get; set; }

See Also

PostSharp20Sign Class
PostSharp.MSBuild Namespace


KeyFile Property

PostSharp20Sign..::..KeyFile Property
PostSharp20Sign Class See Also Send Feedback
Full path of the file containing the strong name key.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public string KeyFile { get; set; }

See Also

PostSharp20Sign Class
PostSharp.MSBuild Namespace


PostSharp20TouchWithDelay Class

PostSharp20TouchWithDelay Class
Members See Also Send Feedback
[MSBuild Task] Touches a file according to the modification time of another file.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public sealed class PostSharp20TouchWithDelay : Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
PostSharp.MSBuild..::.PostSharp20TouchWithDelay

See Also

PostSharp20TouchWithDelay Members
PostSharp.MSBuild Namespace


PostSharp20TouchWithDelay Members

[image]

PostSharp 2.0 Documentation
PostSharp20TouchWithDelay Members
PostSharp20TouchWithDelay Class Constructors Methods Properties See Also Send Feedback

The PostSharp20TouchWithDelay type exposes the following members.

Constructors

 | Name | Description
Public method | PostSharp20TouchWithDelay | Initializes a new instance of the PostSharp20TouchWithDelay class

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

Properties

 | Name | Description
Public property | Delay | Gets or sets the delay w.r.t. ReferenceFile.
Public property | Files | Gets or sets the files to be touched. Required.
Public property | ReferenceFile | Gets or sets the file giving the reference time.

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


PostSharp20TouchWithDelay Constructor

PostSharp20TouchWithDelay Constructor
PostSharp20TouchWithDelay Class See Also Send Feedback
Initializes a new instance of the PostSharp20TouchWithDelay class

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public PostSharp20TouchWithDelay()

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


PostSharp20TouchWithDelay Methods

[image]

PostSharp 2.0 Documentation
PostSharp20TouchWithDelay Methods
PostSharp20TouchWithDelay Class See Also Send Feedback

The PostSharp20TouchWithDelay type exposes the following members.

Methods

 | Name | Description
Public method | Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


Execute Method

PostSharp20TouchWithDelay..::..Execute Method
PostSharp20TouchWithDelay Class See Also Send Feedback
When overridden in a derived class, executes the task.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public override bool Execute()

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


PostSharp20TouchWithDelay Properties

[image]

PostSharp 2.0 Documentation
PostSharp20TouchWithDelay Properties
PostSharp20TouchWithDelay Class See Also Send Feedback

The PostSharp20TouchWithDelay type exposes the following members.

Properties

 | Name | Description
Public property | Delay | Gets or sets the delay w.r.t. ReferenceFile.
Public property | Files | Gets or sets the files to be touched. Required.
Public property | ReferenceFile | Gets or sets the file giving the reference time.

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


Delay Property

PostSharp20TouchWithDelay..::..Delay Property
PostSharp20TouchWithDelay Class See Also Send Feedback
Gets or sets the delay w.r.t. ReferenceFile.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public long Delay { get; set; }

Field Value

The number of milliseconds. Default is 1000.

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


Files Property

PostSharp20TouchWithDelay..::..Files Property
PostSharp20TouchWithDelay Class See Also Send Feedback
Gets or sets the files to be touched. Required.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public ITaskItem[] Files { get; set; }

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


ReferenceFile Property

PostSharp20TouchWithDelay..::..ReferenceFile Property
PostSharp20TouchWithDelay Class See Also Send Feedback
Gets or sets the file giving the reference time.

Namespace: PostSharp.MSBuild
Assembly: PostSharp.MSBuild (in PostSharp.MSBuild.dll) Version: 2.0.0.0 (2.0.7.1248)

Syntax

C#
public ITaskItem ReferenceFile { get; set; }

See Also

PostSharp20TouchWithDelay Class
PostSharp.MSBuild Namespace


PostSharp.Sdk Namespace

PostSharp.Sdk Namespace
Send Feedback
The PostSharp.Sdk namespace contains types that allow to extend PostSharp using low-level APIes.

Classes

 | Class | Description
Public class | ApplicationInfo | Provides information about PostSharp.
Public class | AssertionFailedException | This exception is thrown when an internal assertion failed.
Public class | BufferOverflowException | Exception thrown by the BufferReader class when one tries to read more bytes than the buffer actually has.
Public class | UnreachableException | Formal exception thrown after calling a method that always results in an exception, so that static analyzers do not complain.
Public class | UserException | Exception thrown because of a cause controlled by the user or the environment. User exceptions should not be reported to SharpCrafters.


ApplicationInfo Class

ApplicationInfo Class
Members See Also Send Feedback
Provides information about PostSharp.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class ApplicationInfo

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk..::.ApplicationInfo

See Also

ApplicationInfo Members
PostSharp.Sdk Namespace


ApplicationInfo Members

[image]

PostSharp 2.0 Documentation
ApplicationInfo Members
ApplicationInfo Class Properties See Also Send Feedback

The ApplicationInfo type exposes the following members.

Properties

Name | Description
BannerName | Gets the name of the application to be displayed in the banner.
BaseDirectory | Gets the application base installation directory.
Build | Gets the build of PostSharp (Release, Diag or Debug).
CopyrightLine | Gets the copyright line.
HostVersion | Gets a string containing the full information about the host.
Version | Gets the version of the PostSharp.Sdk assembly.

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


ApplicationInfo Properties

[image]

PostSharp 2.0 Documentation
ApplicationInfo Properties
ApplicationInfo Class See Also Send Feedback

The ApplicationInfo type exposes the following members.

Properties

Name | Description
BannerName | Gets the name of the application to be displayed in the banner.
BaseDirectory | Gets the application base installation directory.
Build | Gets the build of PostSharp (Release, Diag or Debug).
CopyrightLine | Gets the copyright line.
HostVersion | Gets a string containing the full information about the host.
Version | Gets the version of the PostSharp.Sdk assembly.

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


BannerName Property

ApplicationInfo..::..BannerName Property
ApplicationInfo Class See Also Send Feedback
Gets the name of the application to be displayed in the banner.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string BannerName { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


BaseDirectory Property

ApplicationInfo..::..BaseDirectory Property
ApplicationInfo Class See Also Send Feedback
Gets the application base installation directory.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string BaseDirectory { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


Build Property

ApplicationInfo..::..Build Property
ApplicationInfo Class See Also Send Feedback
Gets the build of PostSharp (Release, Diag or Debug).

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string Build { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


CopyrightLine Property

ApplicationInfo..::..CopyrightLine Property
ApplicationInfo Class See Also Send Feedback
Gets the copyright line.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string CopyrightLine { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


HostVersion Property

ApplicationInfo..::..HostVersion Property
ApplicationInfo Class See Also Send Feedback
Gets a string containing the full information about the host.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string HostVersion { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


Version Property

ApplicationInfo..::..Version Property
ApplicationInfo Class See Also Send Feedback
Gets the version of the PostSharp.Sdk assembly.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Version Version { get; }

See Also

ApplicationInfo Class
PostSharp.Sdk Namespace


AssertionFailedException Class

AssertionFailedException Class
Members See Also Send Feedback
This exception is thrown when an internal assertion failed.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class AssertionFailedException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Sdk..::.AssertionFailedException

See Also

AssertionFailedException Members
PostSharp.Sdk Namespace


AssertionFailedException Members

[image]

PostSharp 2.0 Documentation
AssertionFailedException Members
AssertionFailedException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | AssertionFailedException | Overloaded.

See Also

AssertionFailedException Class
PostSharp.Sdk Namespace


AssertionFailedException Constructor

[image]

PostSharp 2.0 Documentation
AssertionFailedException Constructor
AssertionFailedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertionFailedException()()() | Initializes a new AssertionFailedException with no message.
Public method | AssertionFailedException(String) | Initializes a new AssertionFailedException exception with a message.
Protected method | AssertionFailedException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | AssertionFailedException(String, Exception) | Initializes a new AssertionFailedException exception with a message and an inner exception.

See Also

AssertionFailedException Class
AssertionFailedException Members
PostSharp.Sdk Namespace


AssertionFailedException Constructor

AssertionFailedException Constructor
AssertionFailedException Class See Also Send Feedback
Initializes a new AssertionFailedException with no message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssertionFailedException()

See Also

AssertionFailedException Class
AssertionFailedException Overload
PostSharp.Sdk Namespace


AssertionFailedException Constructor (String)

AssertionFailedException Constructor (String)
AssertionFailedException Class See Also Send Feedback
Initializes a new AssertionFailedException exception with a message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssertionFailedException(
    string message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

AssertionFailedException Class
AssertionFailedException Overload
PostSharp.Sdk Namespace


AssertionFailedException Constructor (SerializationInfo, StreamingContext)

AssertionFailedException Constructor (SerializationInfo, StreamingContext)
AssertionFailedException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AssertionFailedException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Context.

See Also

AssertionFailedException Class
AssertionFailedException Overload
PostSharp.Sdk Namespace


AssertionFailedException Constructor (String, Exception)

AssertionFailedException Constructor (String, Exception)
AssertionFailedException Class See Also Send Feedback
Initializes a new AssertionFailedException exception with a message and an inner exception.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssertionFailedException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

AssertionFailedException Class
AssertionFailedException Overload
PostSharp.Sdk Namespace


BufferOverflowException Class

BufferOverflowException Class
Members See Also Send Feedback
Exception thrown by the BufferReader class when one tries to read more bytes than the buffer actually has.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class BufferOverflowException : ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
PostSharp.Sdk..::.BufferOverflowException

See Also

BufferOverflowException Members
PostSharp.Sdk Namespace


BufferOverflowException Members

[image]

PostSharp 2.0 Documentation
BufferOverflowException Members
BufferOverflowException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | BufferOverflowException | Overloaded.

See Also

BufferOverflowException Class
PostSharp.Sdk Namespace


BufferOverflowException Constructor

[image]

PostSharp 2.0 Documentation
BufferOverflowException Constructor
BufferOverflowException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BufferOverflowException()()() | Initializes a new BufferOverflowException with the default message.
Public method | BufferOverflowException(String) | Initializes a new BufferOverflowException and specifies a message.
Protected method | BufferOverflowException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | BufferOverflowException(String, Exception) | Initializes a new BufferOverflowException and specifies a message and an inner Exception.

See Also

BufferOverflowException Class
BufferOverflowException Members
PostSharp.Sdk Namespace


BufferOverflowException Constructor

BufferOverflowException Constructor
BufferOverflowException Class See Also Send Feedback
Initializes a new BufferOverflowException with the default message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BufferOverflowException()

See Also

BufferOverflowException Class
BufferOverflowException Overload
PostSharp.Sdk Namespace


BufferOverflowException Constructor (String)

BufferOverflowException Constructor (String)
BufferOverflowException Class See Also Send Feedback
Initializes a new BufferOverflowException and specifies a message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BufferOverflowException(
    string message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

BufferOverflowException Class
BufferOverflowException Overload
PostSharp.Sdk Namespace


BufferOverflowException Constructor (SerializationInfo, StreamingContext)

BufferOverflowException Constructor (SerializationInfo, StreamingContext)
BufferOverflowException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected BufferOverflowException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming context.

See Also

BufferOverflowException Class
BufferOverflowException Overload
PostSharp.Sdk Namespace


BufferOverflowException Constructor (String, Exception)

BufferOverflowException Constructor (String, Exception)
BufferOverflowException Class See Also Send Feedback
Initializes a new BufferOverflowException and specifies a message and an inner Exception.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BufferOverflowException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

BufferOverflowException Class
BufferOverflowException Overload
PostSharp.Sdk Namespace


UnreachableException Class

UnreachableException Class
Members See Also Send Feedback
Formal exception thrown after calling a method that always results in an exception, so that static analyzers do not complain.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class UnreachableException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Sdk..::.UnreachableException

See Also

UnreachableException Members
PostSharp.Sdk Namespace


UnreachableException Members

[image]

PostSharp 2.0 Documentation
UnreachableException Members
UnreachableException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | UnreachableException | Overloaded.

See Also

UnreachableException Class
PostSharp.Sdk Namespace


UnreachableException Constructor

[image]

PostSharp 2.0 Documentation
UnreachableException Constructor
UnreachableException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnreachableException()()() | Initializes an UnreachableException with default message.
Public method | UnreachableException(String) | Initializes an UnreachableException with a given message.
Protected method | UnreachableException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | UnreachableException(String, Exception) | Initializes an UnreachableException with a given message and inner Exception.

See Also

UnreachableException Class
UnreachableException Members
PostSharp.Sdk Namespace


UnreachableException Constructor

UnreachableException Constructor
UnreachableException Class See Also Send Feedback
Initializes an UnreachableException with default message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnreachableException()

See Also

UnreachableException Class
UnreachableException Overload
PostSharp.Sdk Namespace


UnreachableException Constructor (String)

UnreachableException Constructor (String)
UnreachableException Class See Also Send Feedback
Initializes an UnreachableException with a given message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnreachableException(
    string message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

UnreachableException Class
UnreachableException Overload
PostSharp.Sdk Namespace


UnreachableException Constructor (SerializationInfo, StreamingContext)

UnreachableException Constructor (SerializationInfo, StreamingContext)
UnreachableException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected UnreachableException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization info.
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming context.

See Also

UnreachableException Class
UnreachableException Overload
PostSharp.Sdk Namespace


UnreachableException Constructor (String, Exception)

UnreachableException Constructor (String, Exception)
UnreachableException Class See Also Send Feedback
Initializes an UnreachableException with a given message and inner Exception.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnreachableException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

UnreachableException Class
UnreachableException Overload
PostSharp.Sdk Namespace


UserException Class

UserException Class
Members See Also Send Feedback
Exception thrown because of a cause controlled by the user or the environment. User exceptions should not be reported to SharpCrafters.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class UserException : ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
PostSharp.Sdk..::.UserException
PostSharp.Sdk.CodeModel..::.AssemblyLoadException

See Also

UserException Members
PostSharp.Sdk Namespace


UserException Members

[image]

PostSharp 2.0 Documentation
UserException Members
UserException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | UserException | Overloaded.

See Also

UserException Class
PostSharp.Sdk Namespace


UserException Constructor

[image]

PostSharp 2.0 Documentation
UserException Constructor
UserException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserException()()() | Initializes a new UserException.
Public method | UserException(String) | Initializes a new UserException and specifies the error message.
Protected method | UserException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | UserException(String, Exception) | Initializes a new UserException and specifies the error message and the inner Exception.

See Also

UserException Class
UserException Members
PostSharp.Sdk Namespace


UserException Constructor

UserException Constructor
UserException Class See Also Send Feedback
Initializes a new UserException.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UserException()

See Also

UserException Class
UserException Overload
PostSharp.Sdk Namespace


UserException Constructor (String)

UserException Constructor (String)
UserException Class See Also Send Feedback
Initializes a new UserException and specifies the error message.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UserException(
    string message
)

Parameters

message
Type: System..::.String
Error message.

See Also

UserException Class
UserException Overload
PostSharp.Sdk Namespace


UserException Constructor (SerializationInfo, StreamingContext)

UserException Constructor (SerializationInfo, StreamingContext)
UserException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected UserException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Info.
context
Type: System.Runtime.Serialization..::.StreamingContext
Context.

See Also

UserException Class
UserException Overload
PostSharp.Sdk Namespace


UserException Constructor (String, Exception)

UserException Constructor (String, Exception)
UserException Class See Also Send Feedback
Initializes a new UserException and specifies the error message and the inner Exception.

Namespace: PostSharp.Sdk
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UserException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Error message.
inner
Type: System..::.Exception
Inner Exception.

See Also

UserException Class
UserException Overload
PostSharp.Sdk Namespace


PostSharp.Sdk.AspectInfrastructure Namespace

PostSharp.Sdk.AspectInfrastructure Namespace
Send Feedback
The PostSharp.Sdk.AspectInfrastructure namespace defines and implements an infrastructure that can be shared by all aspect frameworks. It makes minimal assumptions on the semantics of aspect frameworks (such as PostSharp.Aspects) that can be built on the top of it. The aspect infrastructure does not itself have a notion of aspect, advice or point cut; instead, it has a notion of transformation, transformation pipeline, and defines a framework to resolve dependencies between transformations.

Classes

 | Class | Description
Public class | AspectDependency | Represent a dependency relationships between aspects, advices or more generally any object implementing IAspectDependencyObject.
Public class | AspectDependencyCollection | Collection of AspectDependency.
Public class | AspectDependencyCondition | Represents a condition (i.e., a boolean function) between two dependency objects (IAspectDependencyObject).
Public class | AspectDependencyResolver | Compares and sorts dependency objects.
Public class | AspectInfrastructureTask | The PostSharp task responsible for the aspect infrastructure.
Public class | CanonicalMethodMapping | An implementation of MethodMapping representing an identical mapping, where all parameters are mapped to themselves.
Public class | Factory<(Of <(?0, ?1>)>) | Generic implementation of IFactory<(Of <(?0>)>).
Public class | MethodBodyTransformationContext | Context information of a transformation of a method body, passed to the method Implement(MethodBodyTransformationContext).
Public class | MethodBodyTransformationRedirection | Encapsulates the information by which an IMethodBodyTransformationInstance specifies in which InstructionBlock the next transformation should emit its instructions, and related pieces of information.
Public class | MethodMapping | Represents the mapping of a method (generic parameters, this reference, parameters) to a different method.
Public class | MethodMappingInformation | The part of a MethodMapping that is constant over all transformations of a pipeline.
Public class | MethodMappingWriter | Emits instructions that load and store arguments and context items in the context of a MethodMapping.
Public class | NullTransformationInstance | A transformation instance performing no transformation.
Public class | PipelineTransversalState | Contains state shared by all branches and instances of a transformation pipeline. In properties and events, all accessors share the same PipelineTransversalState.
Public class | StructuredDeclarationDictionary<(Of <(?0>)>) | A dictionary whose keys are IMetadataDeclaration and that can be visited in a predictable order. Multiple values can be added to the same key. Visiting semantics are internal.
Public class | TransformationContext | Context information of a transformation pipeline.
Public class | TransformationInstanceCollection | Collection of transformation instances (IDependencyTransformationInstance).
Public class | TypeInitializationManager | Manages initialization of aspects, i.e. the generation aspect initialization methods and the enhancement of constructors so that these methods are invoked.
Public class | TypeInitializationManager..::.StandardRoles | Standard aspect-dependency roles for use with the TypeInitializationManager.

Structures

 | Structure | Description
Public structure | MethodMappingContextItem | Identifies a piece of run-time information available in the context of a MethodMapping. Sets of available context items are exposed on property AvailableContextItems. Implementations of MethodMappingWriter must a set of methods emitting instructions that get supported context items.

Interfaces

 | Interface | Description
Public interface | IAspectDependencyObject | Defines the semantics of objects whose dependency relationships can be revolved by the aspect dependency framework.
Public interface | IComparableAspectDependencyObject | Defines the semantics of an object that can be compared to another using the aspect dependency framework.
Public interface | IDependencyTransformationInstance | Defines the semantics of an instance of code transformation that is also an aspect dependency object.
Public interface | IFactory<(Of <(?0>)>) | Defines the semantics of a factory object. Has a single method Create()()().
Public interface | IMethodBodyTransformationInstance | Defines the semantics of an instance of a code transformation that modifies the body of a method (i.e. its flow of MSIL instructions).
Public interface | IStructuralTransformationInstance | Defines the semantics of a code transformation that modifies the structure of an element of code (such as: changing its attributes or adding members) but does not modify the body of an existing method.
Public interface | ITransformationInstance | The common interface for all instances of code transformations. This interface has no member.
Public interface | ITypeInitializationClient | Client of the InstanceCredentialsManager class. Emits aspect initialization instructions into enhanced classes.

Enumerations

 | Enumeration | Description
Public enumeration | MethodBodyTransformationOptions | Options returned by GetOptions(MetadataDeclaration, MethodSemantics).
Public enumeration | TypeInitializationClientScopes | Scopes (Instance or Static) in which ITypeInitializationClient are registered.


AspectDependency Class

AspectDependency Class
Members See Also Send Feedback
Represent a dependency relationships between aspects, advices or more generally any object implementing IAspectDependencyObject.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AspectDependency

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependency
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.ProvideAspectRoleDependency
PostSharp.Sdk.AspectWeaver.Dependencies..::.ProvidedByAdviceDependency

See Also

AspectDependency Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Members

[image]

PostSharp 2.0 Documentation
AspectDependency Members
AspectDependency Class Constructors Methods Properties See Also Send Feedback

The AspectDependency type exposes the following members.

Constructors

 | Name | Description
Public method | AspectDependency | Overloaded.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency.
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship.
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error.
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member.

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Constructor

[image]

PostSharp 2.0 Documentation
AspectDependency Constructor
AspectDependency Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectDependency(AspectDependencyAction, AspectDependencyCondition) | Initializes a new AspectDependency with default (Any) position.
Public method | AspectDependency(AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition) | Initializes a new AspectDependency with the given position.
Public method | AspectDependency(AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition, Boolean) | Initializes a new AspectDependency with the given position and specifies whether a violation of this dependency rule should result in a warning instead of an error.

See Also

AspectDependency Class
AspectDependency Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Constructor (AspectDependencyAction, AspectDependencyCondition)

AspectDependency Constructor (AspectDependencyAction, AspectDependencyCondition)
AspectDependency Class See Also Send Feedback
Initializes a new AspectDependency with default (Any) position.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependency(
    AspectDependencyAction action,
    AspectDependencyCondition condition
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
The kind of aspect dependency.
condition
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
An object evaluating whether a pair of objects is affected by the current AspectDependency.

See Also

AspectDependency Class
AspectDependency Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Constructor (AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition)

AspectDependency Constructor (AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition)
AspectDependency Class See Also Send Feedback
Initializes a new AspectDependency with the given position.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependency(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    AspectDependencyCondition condition
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
The kind of aspect dependency.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
The direction of the dependency (i.e. position of the right object with respect to the left object).
condition
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
An object evaluating whether a pair of objects is affected by the current AspectDependency.

See Also

AspectDependency Class
AspectDependency Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Constructor (AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition, Boolean)

AspectDependency Constructor (AspectDependencyAction, AspectDependencyPosition, AspectDependencyCondition, Boolean)
AspectDependency Class See Also Send Feedback
Initializes a new AspectDependency with the given position and specifies whether a violation of this dependency rule should result in a warning instead of an error.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependency(
    AspectDependencyAction action,
    AspectDependencyPosition position,
    AspectDependencyCondition condition,
    bool isWarning
)

Parameters

action
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAction
The kind of aspect dependency.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition
The direction of the dependency (i.e. position of the right object with respect to the left object).
condition
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
An object evaluating whether a pair of objects is affected by the current AspectDependency.
isWarning
Type: System..::.Boolean
true if a violation of this dependency rule should result in a warning, false if it should result in an error.

See Also

AspectDependency Class
AspectDependency Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Methods

[image]

PostSharp 2.0 Documentation
AspectDependency Methods
AspectDependency Class See Also Send Feedback

The AspectDependency type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


ToString Method

AspectDependency..::..ToString Method
AspectDependency Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependency Properties

[image]

PostSharp 2.0 Documentation
AspectDependency Properties
AspectDependency Class See Also Send Feedback

The AspectDependency type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency.
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship.
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error.
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member.

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


Action Property

AspectDependency..::..Action Property
AspectDependency Class See Also Send Feedback
Gets the kind of relationship represented by the current AspectDependency.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyAction Action { get; private set; }

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


Condition Property

AspectDependency..::..Condition Property
AspectDependency Class See Also Send Feedback
Gets the condition determining whether a pair of objects matches the current relationship.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCondition Condition { get; private set; }

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsWarning Property

AspectDependency..::..IsWarning Property
AspectDependency Class See Also Send Feedback
Determines whether a violation of the current dependency rule should result in a warning instead of an error.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsWarning { get; private set; }

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


Position Property

AspectDependency..::..Position Property
AspectDependency Class See Also Send Feedback
Gets the position of the right member of the current relationship with respect to the left member.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyPosition Position { get; private set; }

See Also

AspectDependency Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Class

AspectDependencyCollection Class
Members See Also Send Feedback
Collection of AspectDependency.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectDependencyCollection : Collection<AspectDependency>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' AspectDependency >)>)>
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCollection

See Also

AspectDependencyCollection Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Members

[image]

PostSharp 2.0 Documentation
AspectDependencyCollection Members
AspectDependencyCollection Class Constructors Methods See Also Send Feedback

The AspectDependencyCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AspectDependencyCollection | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds all elements of an AspectDependencyCollection into the current collection.

See Also

AspectDependencyCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Constructor

[image]

PostSharp 2.0 Documentation
AspectDependencyCollection Constructor
AspectDependencyCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspectDependencyCollection()()() | Initializes a new AspectDependencyCollection.
Public method | AspectDependencyCollection(Int32) | Initializes a new AspectDependencyCollection and specifies the collection capacity.

See Also

AspectDependencyCollection Class
AspectDependencyCollection Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Constructor

AspectDependencyCollection Constructor
AspectDependencyCollection Class See Also Send Feedback
Initializes a new AspectDependencyCollection.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection()

See Also

AspectDependencyCollection Class
AspectDependencyCollection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Constructor (Int32)

AspectDependencyCollection Constructor (Int32)
AspectDependencyCollection Class See Also Send Feedback
Initializes a new AspectDependencyCollection and specifies the collection capacity.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Collection capacity.

See Also

AspectDependencyCollection Class
AspectDependencyCollection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCollection Methods

[image]

PostSharp 2.0 Documentation
AspectDependencyCollection Methods
AspectDependencyCollection Class See Also Send Feedback

The AspectDependencyCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds all elements of an AspectDependencyCollection into the current collection.

See Also

AspectDependencyCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


Add Method

AspectDependencyCollection..::..Add Method
AspectDependencyCollection Class See Also Send Feedback
Adds all elements of an AspectDependencyCollection into the current collection.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    IEnumerable<AspectDependency> collection
)

Parameters

collection
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' AspectDependency >)>)>
An AspectDependencyCollection.

See Also

AspectDependencyCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCondition Class

AspectDependencyCondition Class
Members See Also Send Feedback
Represents a condition (i.e., a boolean function) between two dependency objects (IAspectDependencyObject).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AndDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AspectEffectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AspectRoleDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.NotDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.OrDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.TrueDependencyCondition
PostSharp.Sdk.AspectWeaver.Dependencies..::.AspectTypeDependencyCondition
PostSharp.Sdk.AspectWeaver.Dependencies..::.DependencyObjectTypeDependencyCondition<(Of <(?0>)>)
PostSharp.Sdk.AspectWeaver.Dependencies..::.SameAspectInstanceDependencyCondition

See Also

AspectDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCondition Members

[image]

PostSharp 2.0 Documentation
AspectDependencyCondition Members
AspectDependencyCondition Class Constructors Methods See Also Send Feedback

The AspectDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectDependencyCondition | Initializes a new instance of the AspectDependencyCondition class

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition.
Public method | Match | Determines whether a pair of objects match the current condition.

See Also

AspectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCondition Constructor

AspectDependencyCondition Constructor
AspectDependencyCondition Class See Also Send Feedback
Initializes a new instance of the AspectDependencyCondition class

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectDependencyCondition()

See Also

AspectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
AspectDependencyCondition Methods
AspectDependencyCondition Class See Also Send Feedback

The AspectDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition.
Public method | Match | Determines whether a pair of objects match the current condition.

See Also

AspectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure Namespace


FormatCondition Method

AspectDependencyCondition..::..FormatCondition Method
AspectDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

AspectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure Namespace


Match Method

AspectDependencyCondition..::..Match Method
AspectDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

AspectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyResolver Class

AspectDependencyResolver Class
Members See Also Send Feedback
Compares and sorts dependency objects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class AspectDependencyResolver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyResolver

See Also

AspectDependencyResolver Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyResolver Members

[image]

PostSharp 2.0 Documentation
AspectDependencyResolver Members
AspectDependencyResolver Class Methods See Also Send Feedback

The AspectDependencyResolver type exposes the following members.

Methods

Name | Description
Commute | Determines whether two dependency objects commute.
Compare | Determines the ordering of two dependency objects.

See Also

AspectDependencyResolver Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectDependencyResolver Methods

[image]

PostSharp 2.0 Documentation
AspectDependencyResolver Methods
AspectDependencyResolver Class See Also Send Feedback

The AspectDependencyResolver type exposes the following members.

Methods

Name | Description
Commute | Determines whether two dependency objects commute.
Compare | Determines the ordering of two dependency objects.

See Also

AspectDependencyResolver Class
PostSharp.Sdk.AspectInfrastructure Namespace


Commute Method

AspectDependencyResolver..::..Commute Method
AspectDependencyResolver Class See Also Send Feedback
Determines whether two dependency objects commute.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Commute(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object.

Return Value

true if left and right commute, otherwise false.

See Also

AspectDependencyResolver Class
PostSharp.Sdk.AspectInfrastructure Namespace


Compare Method

AspectDependencyResolver..::..Compare Method
AspectDependencyResolver Class See Also Send Feedback
Determines the ordering of two dependency objects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Compare(
    MetadataDeclaration targetElement,
    IAspectDependencyObject left,
    IAspectDependencyObject right,
    out AspectDependencyPosition result
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the dependency objects apply,
left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object.
result
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition %
The relative position of right with respect to left.

Return Value

true in case of success, otherwise false.

See Also

AspectDependencyResolver Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructureTask Class

AspectInfrastructureTask Class
Members See Also Send Feedback
The PostSharp task responsible for the aspect infrastructure.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectInfrastructureTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask

See Also

AspectInfrastructureTask Members
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructureTask Members

[image]

PostSharp 2.0 Documentation
AspectInfrastructureTask Members
AspectInfrastructureTask Class Constructors Methods Properties See Also Send Feedback

The AspectInfrastructureTask type exposes the following members.

Constructors

 | Name | Description
Public method | AspectInfrastructureTask | Initializes a new instance of the AspectInfrastructureTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetImplementationDetailsType | Gets the type where implementation details can be stored.
 | GetRedirectedDeclaration | Gets the declaration to which another declaration has been redirected by the aspect infrastructure (typically, fields are changed into properties).
 | GetTask | Gets the AspectInfrastructureTask in a given Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | CodeWeaver | Gets the Weaver used by the aspect infrastructure.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | Events | Gets the set of events exposed by the aspect infrastructure.
Public property | FrameworkVariant | Gets the current framework variant (GetFrameworkVariant()()()).
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | SymAspectModule | Gets the node of the symbol file representing the module being processed.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)
Public property | TransformationInstances | Gets the collection of transformations that must be executed by the current task.
Public property | TypeInitializationManager | Gets the TypeInitializationManager.
Public property | WeavingHelper | Gets a collection that can be used to add type-level advices of the PostSharp.Sdk.CodeWeaver namespace (i.e. advices of the low-level weaver).

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructureTask Constructor

AspectInfrastructureTask Constructor
AspectInfrastructureTask Class See Also Send Feedback
Initializes a new instance of the AspectInfrastructureTask class

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask()

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructureTask Methods

[image]

PostSharp 2.0 Documentation
AspectInfrastructureTask Methods
AspectInfrastructureTask Class See Also Send Feedback

The AspectInfrastructureTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetImplementationDetailsType | Gets the type where implementation details can be stored.
 | GetRedirectedDeclaration | Gets the declaration to which another declaration has been redirected by the aspect infrastructure (typically, fields are changed into properties).
 | GetTask | Gets the AspectInfrastructureTask in a given Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


Execute Method

AspectInfrastructureTask..::..Execute Method
AspectInfrastructureTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetImplementationDetailsType Method

AspectInfrastructureTask..::..GetImplementationDetailsType Method
AspectInfrastructureTask Class See Also Send Feedback
Gets the type where implementation details can be stored.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetImplementationDetailsType()

Return Value

The type where implementation details can be stored.

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetRedirectedDeclaration Method

AspectInfrastructureTask..::..GetRedirectedDeclaration Method
AspectInfrastructureTask Class See Also Send Feedback
Gets the declaration to which another declaration has been redirected by the aspect infrastructure (typically, fields are changed into properties).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IMetadataDeclaration GetRedirectedDeclaration(
    IMetadataDeclaration originalDeclaration,
    bool recursive
)

Parameters

originalDeclaration
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
The original declaration (typically, a field).
recursive
Type: System..::.Boolean
true if multiple levels of redirection should be considered, otherwise false.

Return Value

The declaration to which originalDeclaration has been redirected, or originalDeclaration itself.

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetTask Method

AspectInfrastructureTask..::..GetTask Method
AspectInfrastructureTask Class See Also Send Feedback
Gets the AspectInfrastructureTask in a given Project.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AspectInfrastructureTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
A Project.

Return Value

The AspectInfrastructureTask task in the project.

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructureTask Properties

[image]

PostSharp 2.0 Documentation
AspectInfrastructureTask Properties
AspectInfrastructureTask Class See Also Send Feedback

The AspectInfrastructureTask type exposes the following members.

Properties

 | Name | Description
Public property | CodeWeaver | Gets the Weaver used by the aspect infrastructure.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | Events | Gets the set of events exposed by the aspect infrastructure.
Public property | FrameworkVariant | Gets the current framework variant (GetFrameworkVariant()()()).
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | SymAspectModule | Gets the node of the symbol file representing the module being processed.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)
Public property | TransformationInstances | Gets the collection of transformations that must be executed by the current task.
Public property | TypeInitializationManager | Gets the TypeInitializationManager.
Public property | WeavingHelper | Gets a collection that can be used to add type-level advices of the PostSharp.Sdk.CodeWeaver namespace (i.e. advices of the low-level weaver).

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


CodeWeaver Property

AspectInfrastructureTask..::..CodeWeaver Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the Weaver used by the aspect infrastructure.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Weaver CodeWeaver { get; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


Events Property

AspectInfrastructureTask..::..Events Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the set of events exposed by the aspect infrastructure.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureEvents Events { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


FrameworkVariant Property

AspectInfrastructureTask..::..FrameworkVariant Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the current framework variant (GetFrameworkVariant()()()).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FrameworkVariant { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


SymAspectModule Property

AspectInfrastructureTask..::..SymAspectModule Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the node of the symbol file representing the module being processed.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectModule SymAspectModule { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstances Property

AspectInfrastructureTask..::..TransformationInstances Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the collection of transformations that must be executed by the current task.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TransformationInstanceCollection TransformationInstances { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager Property

AspectInfrastructureTask..::..TypeInitializationManager Property
AspectInfrastructureTask Class See Also Send Feedback
Gets the TypeInitializationManager.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeInitializationManager TypeInitializationManager { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


WeavingHelper Property

AspectInfrastructureTask..::..WeavingHelper Property
AspectInfrastructureTask Class See Also Send Feedback
Gets a collection that can be used to add type-level advices of the PostSharp.Sdk.CodeWeaver namespace (i.e. advices of the low-level weaver).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WeavingHelper WeavingHelper { get; private set; }

See Also

AspectInfrastructureTask Class
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Class

CanonicalMethodMapping Class
Members See Also Send Feedback
An implementation of MethodMapping representing an identical mapping, where all parameters are mapped to themselves.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class CanonicalMethodMapping : MethodMapping

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
PostSharp.Sdk.AspectInfrastructure..::.CanonicalMethodMapping

See Also

CanonicalMethodMapping Members
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Members

[image]

PostSharp 2.0 Documentation
CanonicalMethodMapping Members
CanonicalMethodMapping Class Constructors Methods Properties See Also Send Feedback

The CanonicalMethodMapping type exposes the following members.

Constructors

 | Name | Description
Public method | CanonicalMethodMapping | Overloaded.

Methods

 | Name | Description
Public method | CreateWriter | Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping. (Overrides MethodMapping..::.CreateWriter()()().)
Public method | GetInstanceTypeDefinition | Gets the TypeDefDeclaration of the this object. (Inherited from MethodMapping.)

Properties

 | Name | Description
Public property | AvailableContextItems | Set of context items (MethodMappingContextItem) that are available in the current context. (Inherited from MethodMapping.)
Public property | GenericMap | Gets the GenericMap mapping the current generic context to the original generic context. (Overrides MethodMapping..::.GenericMap.)
Public property | InstanceType | Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type. (Overrides MethodMapping..::.InstanceType.)
Public property | InstanceValueType | Gets the value type of the this reference, without the managed pointer. (Overrides MethodMapping..::.InstanceValueType.)
Public property | IsValueType | Determines whether the this object is a value type. (Overrides MethodMapping..::.IsValueType.)
Public property | MethodMappingInformation | Gets static information about the current MethodMapping. (Inherited from MethodMapping.)
Public property | MethodSignature | Gets the method signature mapped in the current generic context. (Overrides MethodMapping..::.MethodSignature.)
Public property | Module | Gets the current ModuleDeclaration. (Inherited from MethodMapping.)
Public property | Task | Gets the parent AspectInfrastructureTask. (Inherited from MethodMapping.)

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Constructor

[image]

PostSharp 2.0 Documentation
CanonicalMethodMapping Constructor
CanonicalMethodMapping Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanonicalMethodMapping(AspectInfrastructureTask, IMethod, GenericMap) | Initializes a new CanonicalMethodMapping from a method.
Public method | CanonicalMethodMapping(AspectInfrastructureTask, ITypeSignature, IMethodSignature, GenericMap, MethodDefDeclaration) | Initializes a new CanonicalMethodMapping by specifying it completely.

See Also

CanonicalMethodMapping Class
CanonicalMethodMapping Members
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Constructor (AspectInfrastructureTask, IMethod, GenericMap)

CanonicalMethodMapping Constructor (AspectInfrastructureTask, IMethod, GenericMap)
CanonicalMethodMapping Class See Also Send Feedback
Initializes a new CanonicalMethodMapping from a method.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CanonicalMethodMapping(
    AspectInfrastructureTask task,
    IMethod method,
    GenericMap genericMap
)

Parameters

task
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask
Parent AspectInfrastructureTask.
method
Type: PostSharp.Sdk.CodeModel..::.IMethod
Method for which the CanonicalMethodMapping is required.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
GenericMap with which the generic arguments of method are transformed.

See Also

CanonicalMethodMapping Class
CanonicalMethodMapping Overload
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Constructor (AspectInfrastructureTask, ITypeSignature, IMethodSignature, GenericMap, MethodDefDeclaration)

CanonicalMethodMapping Constructor (AspectInfrastructureTask, ITypeSignature, IMethodSignature, GenericMap, MethodDefDeclaration)
CanonicalMethodMapping Class See Also Send Feedback
Initializes a new CanonicalMethodMapping by specifying it completely.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CanonicalMethodMapping(
    AspectInfrastructureTask task,
    ITypeSignature declaringType,
    IMethodSignature methodSignature,
    GenericMap genericMap,
    MethodDefDeclaration prototypeMethodDef
)

Parameters

task
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask
Parent AspectInfrastructureTask.
declaringType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Declaring type of the method.
methodSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Signature of the method.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
GenericMap with which the generic arguments of declaringType and methodSignature are transformed.
prototypeMethodDef
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
Method from which the MethodMappingInformation is constructed.

See Also

CanonicalMethodMapping Class
CanonicalMethodMapping Overload
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Methods

[image]

PostSharp 2.0 Documentation
CanonicalMethodMapping Methods
CanonicalMethodMapping Class See Also Send Feedback

The CanonicalMethodMapping type exposes the following members.

Methods

 | Name | Description
Public method | CreateWriter | Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping. (Overrides MethodMapping..::.CreateWriter()()().)
Public method | GetInstanceTypeDefinition | Gets the TypeDefDeclaration of the this object. (Inherited from MethodMapping.)

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


CreateWriter Method

CanonicalMethodMapping..::..CreateWriter Method
CanonicalMethodMapping Class See Also Send Feedback
Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override MethodMappingWriter CreateWriter()

Return Value

A new MethodMappingWriter.

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


CanonicalMethodMapping Properties

[image]

PostSharp 2.0 Documentation
CanonicalMethodMapping Properties
CanonicalMethodMapping Class See Also Send Feedback

The CanonicalMethodMapping type exposes the following members.

Properties

 | Name | Description
Public property | AvailableContextItems | Set of context items (MethodMappingContextItem) that are available in the current context. (Inherited from MethodMapping.)
Public property | GenericMap | Gets the GenericMap mapping the current generic context to the original generic context. (Overrides MethodMapping..::.GenericMap.)
Public property | InstanceType | Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type. (Overrides MethodMapping..::.InstanceType.)
Public property | InstanceValueType | Gets the value type of the this reference, without the managed pointer. (Overrides MethodMapping..::.InstanceValueType.)
Public property | IsValueType | Determines whether the this object is a value type. (Overrides MethodMapping..::.IsValueType.)
Public property | MethodMappingInformation | Gets static information about the current MethodMapping. (Inherited from MethodMapping.)
Public property | MethodSignature | Gets the method signature mapped in the current generic context. (Overrides MethodMapping..::.MethodSignature.)
Public property | Module | Gets the current ModuleDeclaration. (Inherited from MethodMapping.)
Public property | Task | Gets the parent AspectInfrastructureTask. (Inherited from MethodMapping.)

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


GenericMap Property

CanonicalMethodMapping..::..GenericMap Property
CanonicalMethodMapping Class See Also Send Feedback
Gets the GenericMap mapping the current generic context to the original generic context.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override GenericMap GenericMap { get; }

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


InstanceType Property

CanonicalMethodMapping..::..InstanceType Property
CanonicalMethodMapping Class See Also Send Feedback
Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature InstanceType { get; }

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMapping..::.GetInstanceTypeDefinition()()()
MethodMapping..::.IsValueType
MethodMapping..::.InstanceValueType


InstanceValueType Property

CanonicalMethodMapping..::..InstanceValueType Property
CanonicalMethodMapping Class See Also Send Feedback
Gets the value type of the this reference, without the managed pointer.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature InstanceValueType { get; }

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMapping..::.IsValueType
MethodMapping..::.InstanceType


IsValueType Property

CanonicalMethodMapping..::..IsValueType Property
CanonicalMethodMapping Class See Also Send Feedback
Determines whether the this object is a value type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool IsValueType { get; }

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodSignature Property

CanonicalMethodMapping..::..MethodSignature Property
CanonicalMethodMapping Class See Also Send Feedback
Gets the method signature mapped in the current generic context.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMethodSignature MethodSignature { get; }

See Also

CanonicalMethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


Factory(?0, ?1) Class

Factory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Generic implementation of IFactory<(Of <(?0>)>).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class Factory<?0, ?1> : IFactory<?0>
where ?1 : new()

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.AspectInfrastructure.Factory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.AspectInfrastructure.Factory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.Factory<(Of <(?0, ?1>)>)

See Also

Factory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.AspectInfrastructure Namespace


Factory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
Factory<(Of <(<'?0, ?1>)>)> Members
Factory<(Of <(?0, ?1>)>) Class Constructors Methods See Also Send Feedback

The Factory<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | Factory<(Of <(?0, ?1>)>) | Initializes a new instance of the Factory<(Of <(?0, ?1>)>) class

Methods

 | Name | Description
Public method | Create | Returns a new object.

See Also

Factory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Factory(?0, ?1) Constructor

Factory<(Of <(<'?0, ?1>)>)> Constructor
Factory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new instance of the Factory<(Of <(?0, ?1>)>) class

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Factory()

See Also

Factory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Factory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
Factory<(Of <(<'?0, ?1>)>)> Methods
Factory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The Factory<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Create | Returns a new object.

See Also

Factory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Create Method

Factory<(Of <(<'?0, ?1>)>)>..::..Create Method
Factory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Returns a new object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Create()

Return Value

A new object of type T.

Implements

IFactory<(Of <(?0>)>)..::.Create()()()

See Also

Factory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


IAspectDependencyObject Interface

IAspectDependencyObject Interface
Members See Also Send Feedback
Defines the semantics of objects whose dependency relationships can be revolved by the aspect dependency framework.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspectDependencyObject

See Also

IAspectDependencyObject Members
PostSharp.Sdk.AspectInfrastructure Namespace


IAspectDependencyObject Members

[image]

PostSharp 2.0 Documentation
IAspectDependencyObject Members
IAspectDependencyObject Interface Methods Properties See Also Send Feedback

The IAspectDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object.
Public method | HasEffect | Determines whether the current object has a given effect.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IAspectDependencyObject Methods

[image]

PostSharp 2.0 Documentation
IAspectDependencyObject Methods
IAspectDependencyObject Interface See Also Send Feedback

The IAspectDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object.
Public method | HasEffect | Determines whether the current object has a given effect.

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


GetDisplayName Method

IAspectDependencyObject..::..GetDisplayName Method
IAspectDependencyObject Interface See Also Send Feedback
Gets a human-readable string representing the current object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string GetDisplayName()

Return Value

A human-readable string representing the current object.

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


HasEffect Method

IAspectDependencyObject..::..HasEffect Method
IAspectDependencyObject Interface See Also Send Feedback
Determines whether the current object has a given effect.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool HasEffect(
    string effect
)

Parameters

effect
Type: System..::.String
A case-sensitive string uniquely identifying the effect. See StandardEffects.

Return Value

true if the current object has the current effect, otherwise false.

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IAspectDependencyObject Properties

[image]

PostSharp 2.0 Documentation
IAspectDependencyObject Properties
IAspectDependencyObject Interface See Also Send Feedback

The IAspectDependencyObject type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


Dependencies Property

IAspectDependencyObject..::..Dependencies Property
IAspectDependencyObject Interface See Also Send Feedback
Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<AspectDependency> Dependencies { get; }

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IsCommutative Property

IAspectDependencyObject..::..IsCommutative Property
IAspectDependencyObject Interface See Also Send Feedback
Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsCommutative { get; }

See Also

IAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IComparableAspectDependencyObject Interface

IComparableAspectDependencyObject Interface
Members See Also Send Feedback
Defines the semantics of an object that can be compared to another using the aspect dependency framework.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IComparableAspectDependencyObject : IAspectDependencyObject

See Also

IComparableAspectDependencyObject Members
PostSharp.Sdk.AspectInfrastructure Namespace


IComparableAspectDependencyObject Members

[image]

PostSharp 2.0 Documentation
IComparableAspectDependencyObject Members
IComparableAspectDependencyObject Interface Methods Properties See Also Send Feedback

The IComparableAspectDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Determines the position of another object (considered the right member of the comparison) with respect to the current object (considered the left member of the comparison).
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

IComparableAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IComparableAspectDependencyObject Methods

[image]

PostSharp 2.0 Documentation
IComparableAspectDependencyObject Methods
IComparableAspectDependencyObject Interface See Also Send Feedback

The IComparableAspectDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Determines the position of another object (considered the right member of the comparison) with respect to the current object (considered the left member of the comparison).
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

See Also

IComparableAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


CompareTo Method

IComparableAspectDependencyObject..::..CompareTo Method
IComparableAspectDependencyObject Interface See Also Send Feedback
Determines the position of another object (considered the right member of the comparison) with respect to the current object (considered the left member of the comparison).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool CompareTo(
    MetadataDeclaration targetElement,
    IAspectDependencyObject right,
    out AspectDependencyPosition position
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the dependency objects are applied.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
The other dependency object, considered at the right end of the relationship.
position
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyPosition %
The position of right with respect to the current object.

Return Value

true in case of success, false if the dependency network cannot be resolved.

See Also

IComparableAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IComparableAspectDependencyObject Properties

[image]

PostSharp 2.0 Documentation
IComparableAspectDependencyObject Properties
IComparableAspectDependencyObject Interface See Also Send Feedback

The IComparableAspectDependencyObject type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

IComparableAspectDependencyObject Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IDependencyTransformationInstance Interface

IDependencyTransformationInstance Interface
Members See Also Send Feedback
Defines the semantics of an instance of code transformation that is also an aspect dependency object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IDependencyTransformationInstance : ITransformationInstance,
    IAspectDependencyObject

See Also

IDependencyTransformationInstance Members
PostSharp.Sdk.AspectInfrastructure Namespace


IDependencyTransformationInstance Members

[image]

PostSharp 2.0 Documentation
IDependencyTransformationInstance Members
IDependencyTransformationInstance Interface Methods Properties See Also Send Feedback

The IDependencyTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

IDependencyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IDependencyTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
IDependencyTransformationInstance Methods
IDependencyTransformationInstance Interface See Also Send Feedback

The IDependencyTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

See Also

IDependencyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IDependencyTransformationInstance Properties

[image]

PostSharp 2.0 Documentation
IDependencyTransformationInstance Properties
IDependencyTransformationInstance Interface See Also Send Feedback

The IDependencyTransformationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

IDependencyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IFactory(?0) Interface

IFactory<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
Defines the semantics of a factory object. Has a single method Create()()().

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IFactory<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.AspectInfrastructure.IFactory`1"]

See Also

IFactory<(Of <(?0>)>) Members
PostSharp.Sdk.AspectInfrastructure Namespace


IFactory(?0) Members

[image]

PostSharp 2.0 Documentation
IFactory<(Of <(<'?0>)>)> Members
IFactory<(Of <(?0>)>) Interface Methods See Also Send Feedback

The IFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Create | Returns a new object.

See Also

IFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IFactory(?0) Methods

[image]

PostSharp 2.0 Documentation
IFactory<(Of <(<'?0>)>)> Methods
IFactory<(Of <(?0>)>) Interface See Also Send Feedback

The IFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Create | Returns a new object.

See Also

IFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.AspectInfrastructure Namespace


Create Method

IFactory<(Of <(<'?0>)>)>..::..Create Method
IFactory<(Of <(?0>)>) Interface See Also Send Feedback
Returns a new object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
?0 Create()

Return Value

A new object of type T.

See Also

IFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IMethodBodyTransformationInstance Interface

IMethodBodyTransformationInstance Interface
Members See Also Send Feedback
Defines the semantics of an instance of a code transformation that modifies the body of a method (i.e. its flow of MSIL instructions).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodBodyTransformationInstance : ITransformationInstance

See Also

IMethodBodyTransformationInstance Members
PostSharp.Sdk.AspectInfrastructure Namespace


IMethodBodyTransformationInstance Members

[image]

PostSharp 2.0 Documentation
IMethodBodyTransformationInstance Members
IMethodBodyTransformationInstance Interface Methods See Also Send Feedback

The IMethodBodyTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetOptions | Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.
Public method | Implement | Implements the transformation.

See Also

IMethodBodyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IMethodBodyTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
IMethodBodyTransformationInstance Methods
IMethodBodyTransformationInstance Interface See Also Send Feedback

The IMethodBodyTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetOptions | Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.
Public method | Implement | Implements the transformation.

See Also

IMethodBodyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


GetOptions Method

IMethodBodyTransformationInstance..::..GetOptions Method
IMethodBodyTransformationInstance Interface See Also Send Feedback
Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodBodyTransformationOptions GetOptions(
    MetadataDeclaration originalTargetElement,
    MethodSemantics semantic
)

Parameters

originalTargetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the transformation will be applied.
semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic of the method (if the method is a member of a property or event).

Return Value

Options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method

See Also

IMethodBodyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


Implement Method

IMethodBodyTransformationInstance..::..Implement Method
IMethodBodyTransformationInstance Interface See Also Send Feedback
Implements the transformation.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Implement(
    MethodBodyTransformationContext context
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationContext
Context.

See Also

IMethodBodyTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IStructuralTransformationInstance Interface

IStructuralTransformationInstance Interface
Members See Also Send Feedback
Defines the semantics of a code transformation that modifies the structure of an element of code (such as: changing its attributes or adding members) but does not modify the body of an existing method.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IStructuralTransformationInstance : ITransformationInstance

See Also

IStructuralTransformationInstance Members
PostSharp.Sdk.AspectInfrastructure Namespace


IStructuralTransformationInstance Members

[image]

PostSharp 2.0 Documentation
IStructuralTransformationInstance Members
IStructuralTransformationInstance Interface Methods See Also Send Feedback

The IStructuralTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | Implement | Implements the transformation.

See Also

IStructuralTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IStructuralTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
IStructuralTransformationInstance Methods
IStructuralTransformationInstance Interface See Also Send Feedback

The IStructuralTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | Implement | Implements the transformation.

See Also

IStructuralTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


Implement Method

IStructuralTransformationInstance..::..Implement Method
IStructuralTransformationInstance Interface See Also Send Feedback
Implements the transformation.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Implement(
    TransformationContext context
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
Context.

See Also

IStructuralTransformationInstance Interface
PostSharp.Sdk.AspectInfrastructure Namespace


ITransformationInstance Interface

ITransformationInstance Interface
See Also Send Feedback
The common interface for all instances of code transformations. This interface has no member.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITransformationInstance

See Also

PostSharp.Sdk.AspectInfrastructure Namespace


ITypeInitializationClient Interface

ITypeInitializationClient Interface
Members See Also Send Feedback
Client of the InstanceCredentialsManager class. Emits aspect initialization instructions into enhanced classes.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeInitializationClient : IAspectDependencyObject

See Also

ITypeInitializationClient Members
PostSharp.Sdk.AspectInfrastructure Namespace


ITypeInitializationClient Members

[image]

PostSharp 2.0 Documentation
ITypeInitializationClient Members
ITypeInitializationClient Interface Methods Properties See Also Send Feedback

The ITypeInitializationClient type exposes the following members.

Methods

 | Name | Description
Public method | Emit | Emits aspect initialization instructions into enhanced classes.
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsBeforeFieldInitSupported | Determines whether the client is compatible with the BeforeFieldInit class-level specifier.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

ITypeInitializationClient Interface
PostSharp.Sdk.AspectInfrastructure Namespace


ITypeInitializationClient Methods

[image]

PostSharp 2.0 Documentation
ITypeInitializationClient Methods
ITypeInitializationClient Interface See Also Send Feedback

The ITypeInitializationClient type exposes the following members.

Methods

 | Name | Description
Public method | Emit | Emits aspect initialization instructions into enhanced classes.
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

See Also

ITypeInitializationClient Interface
PostSharp.Sdk.AspectInfrastructure Namespace


Emit Method

ITypeInitializationClient..::..Emit Method
ITypeInitializationClient Interface See Also Send Feedback
Emits aspect initialization instructions into enhanced classes.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Emit(
    InstructionWriter writer,
    InstructionBlock block,
    TypeInitializationClientScopes scope
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
The InstructionWriter to use.
block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock where instructions should be emitted.
scope
Type: PostSharp.Sdk.AspectInfrastructure..::.TypeInitializationClientScopes

[Missing <param name="scope"/> documentation for "M:PostSharp.Sdk.AspectInfrastructure.ITypeInitializationClient.Emit(PostSharp.Sdk.CodeModel.InstructionWriter,PostSharp.Sdk.CodeModel.InstructionBlock,PostSharp.Sdk.AspectInfrastructure.TypeInitializationClientScopes)"]

See Also

ITypeInitializationClient Interface
PostSharp.Sdk.AspectInfrastructure Namespace


ITypeInitializationClient Properties

[image]

PostSharp 2.0 Documentation
ITypeInitializationClient Properties
ITypeInitializationClient Interface See Also Send Feedback

The ITypeInitializationClient type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsBeforeFieldInitSupported | Determines whether the client is compatible with the BeforeFieldInit class-level specifier.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)

See Also

ITypeInitializationClient Interface
PostSharp.Sdk.AspectInfrastructure Namespace


IsBeforeFieldInitSupported Property

ITypeInitializationClient..::..IsBeforeFieldInitSupported Property
ITypeInitializationClient Interface See Also Send Feedback
Determines whether the client is compatible with the BeforeFieldInit class-level specifier.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsBeforeFieldInitSupported { get; }

See Also

ITypeInitializationClient Interface
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationContext Class

MethodBodyTransformationContext Class
Members See Also Send Feedback
Context information of a transformation of a method body, passed to the method Implement(MethodBodyTransformationContext).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodBodyTransformationContext : TransformationContext

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationContext

See Also

MethodBodyTransformationContext Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationContext Members

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationContext Members
MethodBodyTransformationContext Class Methods Properties See Also Send Feedback

The MethodBodyTransformationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddRedirection | Overloaded.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides TransformationContext..::.Clone()()().)
Public method | GetPipelineStateItem | Gets state information that has been previously stored with the method SetPipelineStateItem(Object, Object).
Public method | TerminatePipeline | Prevents further transformations of the pipeline to be executed.

Properties

 | Name | Description
Public property | BindingsContainerType | Gets the type in which binding classes should be created.
Public property | InstructionBlock | Gets the InstructionBlock in which the current transformation should emit instructions.
Public property | IsBranched | Determines if the current pipeline instance has been branched, i.e. if there are multiple branches if the same pipeline at this stage.
Public property | LeaveBranchTarget | Gets the InstructionSequence to which the current transformation should branch the instruction flow when exiting, instead of emitting the ret instruction.
Public property | MethodMapping | Gets the MethodMapping that maps the context of the current InstructionBlock to the original method body.
Public property | MethodSemantic | Gets the semantic of the method being transformed, if the method is a member of an event or a property. (Inherited from TransformationContext.)
Public property | MustAddSymJoinPoint | Determines whether the current transformation is expected to add a join point symbol. (Inherited from TransformationContext.)
Public property | Ordinal | Gets the ordinal of the current transformation in the transformation pipeline. (Inherited from TransformationContext.)
Public property | OriginalTargetElement | Gets the element of code to the transformation pipeline was originally applied. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the current property contains the original element of code, and the TargetElement property contains the replacement element of code. (Inherited from TransformationContext.)
Public property | ReturnValueVariable | Gets the local variable in which the current transformation should store the return value.
Public property | TargetElement | Gets the element of code being currently transformed by the transformation pipeline. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the OriginalTargetElement property contains the original element of code, and the current property contains the replacement element of code. (Inherited from TransformationContext.)
Public property | TransversalState | Gets an object allowing transformations to share state between pipelines targeting different methods of the same property or event. (Inherited from TransformationContext.)

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationContext Methods

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationContext Methods
MethodBodyTransformationContext Class See Also Send Feedback

The MethodBodyTransformationContext type exposes the following members.

Methods

 | Name | Description
Public method | AddRedirection | Overloaded.
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides TransformationContext..::.Clone()()().)
Public method | GetPipelineStateItem | Gets state information that has been previously stored with the method SetPipelineStateItem(Object, Object).
Public method | TerminatePipeline | Prevents further transformations of the pipeline to be executed.

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


AddRedirection Method

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationContext..::..AddRedirection Method
MethodBodyTransformationContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRedirection(MethodBodyTransformationRedirection) | Adds a MethodBodyTransformationRedirection.
Public method | AddRedirection(InstructionBlock, InstructionSequence) | Adds a MethodBodyTransformationRedirection by specifying an instruction block (inside the current method) in which the next transformation should add its implementation, but without changing the method mapping or the local variable storing the return value.
Public method | AddRedirection(InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol) | Adds a MethodBodyTransformationRedirection by specifying an instruction block (typically in a different method) in which the next transformation should add its implementation, a different method mapping and a local variable storing the return value.

See Also

MethodBodyTransformationContext Class
MethodBodyTransformationContext Members
PostSharp.Sdk.AspectInfrastructure Namespace


AddRedirection Method (MethodBodyTransformationRedirection)

MethodBodyTransformationContext..::..AddRedirection Method (MethodBodyTransformationRedirection)
MethodBodyTransformationContext Class See Also Send Feedback
Adds a MethodBodyTransformationRedirection.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRedirection(
    MethodBodyTransformationRedirection redirection
)

Parameters

redirection
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationRedirection
The new MethodBodyTransformationRedirection.

See Also

MethodBodyTransformationContext Class
AddRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AddRedirection Method (InstructionBlock, InstructionSequence)

MethodBodyTransformationContext..::..AddRedirection Method (InstructionBlock, InstructionSequence)
MethodBodyTransformationContext Class See Also Send Feedback
Adds a MethodBodyTransformationRedirection by specifying an instruction block (inside the current method) in which the next transformation should add its implementation, but without changing the method mapping or the local variable storing the return value.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyTransformationRedirection AddRedirection(
    InstructionBlock instructionBlock,
    InstructionSequence leaveBranchTarget
)

Parameters

instructionBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Instruction block in which the next transformation should be implemented, or null if the instruction block is not modified.
leaveBranchTarget
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
Instruction sequence to which the next transformation should go to when existing (instead of emitting the ret instruction), or null if the leave target is not modified.

Return Value

The MethodBodyTransformationRedirection that has been created.

See Also

MethodBodyTransformationContext Class
AddRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


AddRedirection Method (InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol)

MethodBodyTransformationContext..::..AddRedirection Method (InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol)
MethodBodyTransformationContext Class See Also Send Feedback
Adds a MethodBodyTransformationRedirection by specifying an instruction block (typically in a different method) in which the next transformation should add its implementation, a different method mapping and a local variable storing the return value.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyTransformationRedirection AddRedirection(
    InstructionBlock instructionBlock,
    InstructionSequence leaveBranchTarget,
    MethodMapping methodMapping,
    LocalVariableSymbol returnVariable
)

Parameters

instructionBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Instruction block in which the next transformation should be implemented, or null if the instruction block is not modified.
leaveBranchTarget
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
Instruction sequence to which the next transformation should go to when existing (instead of emitting the ret instruction), or null if the leave target is not modified.
methodMapping
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
The method mapping for the new instructionBlock, or null if the method mapping is not modified.
returnVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The variable in which the next transformation should store the return value, or null if the return variable is not modified.

Return Value

The MethodBodyTransformationRedirection that has been created.

See Also

MethodBodyTransformationContext Class
AddRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


Clone Method

MethodBodyTransformationContext..::..Clone Method
MethodBodyTransformationContext Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::.Clone()()()

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetPipelineStateItem Method

MethodBodyTransformationContext..::..GetPipelineStateItem Method
MethodBodyTransformationContext Class See Also Send Feedback
Gets state information that has been previously stored with the method SetPipelineStateItem(Object, Object).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetPipelineStateItem(
    Object key
)

Parameters

key
Type: System..::.Object
Shared identifier of the state item.

Return Value

The item corresponding to key if it was added by a previous transformation, otherwise null.

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace
TransformationContext..::.TransversalState


TerminatePipeline Method

MethodBodyTransformationContext..::..TerminatePipeline Method
MethodBodyTransformationContext Class See Also Send Feedback
Prevents further transformations of the pipeline to be executed.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void TerminatePipeline()

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationContext Properties

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationContext Properties
MethodBodyTransformationContext Class See Also Send Feedback

The MethodBodyTransformationContext type exposes the following members.

Properties

 | Name | Description
Public property | BindingsContainerType | Gets the type in which binding classes should be created.
Public property | InstructionBlock | Gets the InstructionBlock in which the current transformation should emit instructions.
Public property | IsBranched | Determines if the current pipeline instance has been branched, i.e. if there are multiple branches if the same pipeline at this stage.
Public property | LeaveBranchTarget | Gets the InstructionSequence to which the current transformation should branch the instruction flow when exiting, instead of emitting the ret instruction.
Public property | MethodMapping | Gets the MethodMapping that maps the context of the current InstructionBlock to the original method body.
Public property | MethodSemantic | Gets the semantic of the method being transformed, if the method is a member of an event or a property. (Inherited from TransformationContext.)
Public property | MustAddSymJoinPoint | Determines whether the current transformation is expected to add a join point symbol. (Inherited from TransformationContext.)
Public property | Ordinal | Gets the ordinal of the current transformation in the transformation pipeline. (Inherited from TransformationContext.)
Public property | OriginalTargetElement | Gets the element of code to the transformation pipeline was originally applied. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the current property contains the original element of code, and the TargetElement property contains the replacement element of code. (Inherited from TransformationContext.)
Public property | ReturnValueVariable | Gets the local variable in which the current transformation should store the return value.
Public property | TargetElement | Gets the element of code being currently transformed by the transformation pipeline. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the OriginalTargetElement property contains the original element of code, and the current property contains the replacement element of code. (Inherited from TransformationContext.)
Public property | TransversalState | Gets an object allowing transformations to share state between pipelines targeting different methods of the same property or event. (Inherited from TransformationContext.)

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


BindingsContainerType Property

MethodBodyTransformationContext..::..BindingsContainerType Property
MethodBodyTransformationContext Class See Also Send Feedback
Gets the type in which binding classes should be created.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration BindingsContainerType { get; private set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


InstructionBlock Property

MethodBodyTransformationContext..::..InstructionBlock Property
MethodBodyTransformationContext Class See Also Send Feedback
Gets the InstructionBlock in which the current transformation should emit instructions.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock InstructionBlock { get; private set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsBranched Property

MethodBodyTransformationContext..::..IsBranched Property
MethodBodyTransformationContext Class See Also Send Feedback
Determines if the current pipeline instance has been branched, i.e. if there are multiple branches if the same pipeline at this stage.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsBranched { get; internal set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


LeaveBranchTarget Property

MethodBodyTransformationContext..::..LeaveBranchTarget Property
MethodBodyTransformationContext Class See Also Send Feedback
Gets the InstructionSequence to which the current transformation should branch the instruction flow when exiting, instead of emitting the ret instruction.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence LeaveBranchTarget { get; private set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Property

MethodBodyTransformationContext..::..MethodMapping Property
MethodBodyTransformationContext Class See Also Send Feedback
Gets the MethodMapping that maps the context of the current InstructionBlock to the original method body.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMapping MethodMapping { get; private set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


ReturnValueVariable Property

MethodBodyTransformationContext..::..ReturnValueVariable Property
MethodBodyTransformationContext Class See Also Send Feedback
Gets the local variable in which the current transformation should store the return value.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol ReturnValueVariable { get; private set; }

See Also

MethodBodyTransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationOptions Enumeration

MethodBodyTransformationOptions Enumeration
See Also Send Feedback
Options returned by GetOptions(MetadataDeclaration, MethodSemantics).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum MethodBodyTransformationOptions

Members

Member name | Value | Description
None | 0 | None.
UseBindingType | 1 | Specifies that the transformation creates a binding type.
CreateBranch | 2 | Specifies that the transformation creates a branch in the transformation pipeline.
CreateMethodBody | 4 | Specifies that the transformation creates a method body if the method is abstract or extern.

See Also

PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Class

MethodBodyTransformationRedirection Class
Members See Also Send Feedback
Encapsulates the information by which an IMethodBodyTransformationInstance specifies in which InstructionBlock the next transformation should emit its instructions, and related pieces of information.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodBodyTransformationRedirection

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationRedirection

See Also

MethodBodyTransformationRedirection Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Members

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationRedirection Members
MethodBodyTransformationRedirection Class Constructors Methods Properties See Also Send Feedback

The MethodBodyTransformationRedirection type exposes the following members.

Constructors

 | Name | Description
Public method | MethodBodyTransformationRedirection | Overloaded.

Methods

 | Name | Description
Public method | SetPipelineStateItem | Sets a piece of information that will be made available to next transformations in the branch created by the current MethodBodyTransformationRedirection. This piece of information can be retrieved by GetPipelineStateItem(Object).

Properties

 | Name | Description
Public property | InstructionBlock | Gets or sets the InstructionBlock in which the next transformation should emit its instructions. nulll if the InstructionBlock is unchanged.
Public property | LeaveBranchTarget | Gets or sets the InstructionSequence to which the next transformation should redirect the instruction flow when exiting, instead of calling the ret instruction. null if the target is unchanged.
Public property | MethodMapping | Gets or sets the MethodMapping that maps the context of the new InstructionBlock to the original method. null if the method mapping is unchanged.
Public property | ReturnVariable | Gets or sets the local variable into which the next transformation should store the return value. null if the return value is unchanged.

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Constructor

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationRedirection Constructor
MethodBodyTransformationRedirection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MethodBodyTransformationRedirection()()() | Creates a new, empty instance of MethodBodyTransformationRedirection, representing no redirection.
Public method | MethodBodyTransformationRedirection(InstructionBlock, InstructionSequence) | Initializes a new MethodBodyTransformationRedirection by specifying an InstructionBlock, typically in the current method body.
Public method | MethodBodyTransformationRedirection(InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol) | Initializes a new MethodBodyTransformationRedirection by specifying an InstructionBlock, typically in a different method body, and the corresponding MethodMapping.

See Also

MethodBodyTransformationRedirection Class
MethodBodyTransformationRedirection Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Constructor

MethodBodyTransformationRedirection Constructor
MethodBodyTransformationRedirection Class See Also Send Feedback
Creates a new, empty instance of MethodBodyTransformationRedirection, representing no redirection.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyTransformationRedirection()

Remarks

An empty redirection is typically used when the current transformation did not do anything.

See Also

MethodBodyTransformationRedirection Class
MethodBodyTransformationRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Constructor (InstructionBlock, InstructionSequence)

MethodBodyTransformationRedirection Constructor (InstructionBlock, InstructionSequence)
MethodBodyTransformationRedirection Class See Also Send Feedback
Initializes a new MethodBodyTransformationRedirection by specifying an InstructionBlock, typically in the current method body.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyTransformationRedirection(
    InstructionBlock instructionBlock,
    InstructionSequence leaveBranchTarget
)

Parameters

instructionBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock in which the next transformation should emit its instruction, or null if the instruction block is unchanged.
leaveBranchTarget
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The InstructionSequence to which the next transformation should branch the instruction flow when exiting, instead of emitting the ret instruction.

See Also

MethodBodyTransformationRedirection Class
MethodBodyTransformationRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Constructor (InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol)

MethodBodyTransformationRedirection Constructor (InstructionBlock, InstructionSequence, MethodMapping, LocalVariableSymbol)
MethodBodyTransformationRedirection Class See Also Send Feedback
Initializes a new MethodBodyTransformationRedirection by specifying an InstructionBlock, typically in a different method body, and the corresponding MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyTransformationRedirection(
    InstructionBlock instructionBlock,
    InstructionSequence leaveBranchTarget,
    MethodMapping methodMapping,
    LocalVariableSymbol returnVariable
)

Parameters

instructionBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock in which the next transformation should emit its instruction, or null if the instruction block is unchanged.
leaveBranchTarget
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The InstructionSequence to which the next transformation should branch the instruction flow when exiting, instead of emitting the ret instruction.
methodMapping
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
The method mapping for the new instructionBlock, or null if the method mapping is not modified.
returnVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The variable in which the next transformation should store the return value, or null if the return variable is not modified.

See Also

MethodBodyTransformationRedirection Class
MethodBodyTransformationRedirection Overload
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Methods

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationRedirection Methods
MethodBodyTransformationRedirection Class See Also Send Feedback

The MethodBodyTransformationRedirection type exposes the following members.

Methods

 | Name | Description
Public method | SetPipelineStateItem | Sets a piece of information that will be made available to next transformations in the branch created by the current MethodBodyTransformationRedirection. This piece of information can be retrieved by GetPipelineStateItem(Object).

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


SetPipelineStateItem Method

MethodBodyTransformationRedirection..::..SetPipelineStateItem Method
MethodBodyTransformationRedirection Class See Also Send Feedback
Sets a piece of information that will be made available to next transformations in the branch created by the current MethodBodyTransformationRedirection. This piece of information can be retrieved by GetPipelineStateItem(Object).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetPipelineStateItem(
    Object key,
    Object value
)

Parameters

key
Type: System..::.Object
Item key.
value
Type: System..::.Object
Item value.

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBodyTransformationRedirection Properties

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationRedirection Properties
MethodBodyTransformationRedirection Class See Also Send Feedback

The MethodBodyTransformationRedirection type exposes the following members.

Properties

 | Name | Description
Public property | InstructionBlock | Gets or sets the InstructionBlock in which the next transformation should emit its instructions. nulll if the InstructionBlock is unchanged.
Public property | LeaveBranchTarget | Gets or sets the InstructionSequence to which the next transformation should redirect the instruction flow when exiting, instead of calling the ret instruction. null if the target is unchanged.
Public property | MethodMapping | Gets or sets the MethodMapping that maps the context of the new InstructionBlock to the original method. null if the method mapping is unchanged.
Public property | ReturnVariable | Gets or sets the local variable into which the next transformation should store the return value. null if the return value is unchanged.

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


InstructionBlock Property

MethodBodyTransformationRedirection..::..InstructionBlock Property
MethodBodyTransformationRedirection Class See Also Send Feedback
Gets or sets the InstructionBlock in which the next transformation should emit its instructions. nulll if the InstructionBlock is unchanged.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock InstructionBlock { get; set; }

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


LeaveBranchTarget Property

MethodBodyTransformationRedirection..::..LeaveBranchTarget Property
MethodBodyTransformationRedirection Class See Also Send Feedback
Gets or sets the InstructionSequence to which the next transformation should redirect the instruction flow when exiting, instead of calling the ret instruction. null if the target is unchanged.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence LeaveBranchTarget { get; set; }

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Property

MethodBodyTransformationRedirection..::..MethodMapping Property
MethodBodyTransformationRedirection Class See Also Send Feedback
Gets or sets the MethodMapping that maps the context of the new InstructionBlock to the original method. null if the method mapping is unchanged.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMapping MethodMapping { get; set; }

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


ReturnVariable Property

MethodBodyTransformationRedirection..::..ReturnVariable Property
MethodBodyTransformationRedirection Class See Also Send Feedback
Gets or sets the local variable into which the next transformation should store the return value. null if the return value is unchanged.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol ReturnVariable { get; set; }

See Also

MethodBodyTransformationRedirection Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Class

MethodMapping Class
Members See Also Send Feedback
Represents the mapping of a method (generic parameters, this reference, parameters) to a different method.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodMapping

Remarks

The objective of MethodMapping is to support method ousting: indeed, a transformation may move the method body to a different method and/or class; the this reference and parameters may be mapped to fields.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
PostSharp.Sdk.AspectInfrastructure..::.CanonicalMethodMapping

See Also

MethodMapping Members
PostSharp.Sdk.AspectInfrastructure Namespace
PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter


MethodMapping Members

[image]

PostSharp 2.0 Documentation
MethodMapping Members
MethodMapping Class Constructors Methods Properties See Also Send Feedback

The MethodMapping type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodMapping | Initializes a new MethodMapping.

Methods

 | Name | Description
Public method | CreateWriter | Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping.
Public method | GetInstanceTypeDefinition | Gets the TypeDefDeclaration of the this object.

Properties

 | Name | Description
Public property | AvailableContextItems | Set of context items (MethodMappingContextItem) that are available in the current context.
Public property | GenericMap | Gets the GenericMap mapping the current generic context to the original generic context.
Public property | InstanceType | Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type.
Public property | InstanceValueType | Gets the value type of the this reference, without the managed pointer.
Public property | IsValueType | Determines whether the this object is a value type.
Public property | MethodMappingInformation | Gets static information about the current MethodMapping.
Public property | MethodSignature | Gets the method signature mapped in the current generic context.
Public property | Module | Gets the current ModuleDeclaration.
Public property | Task | Gets the parent AspectInfrastructureTask.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Constructor

MethodMapping Constructor
MethodMapping Class See Also Send Feedback
Initializes a new MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodMapping(
    AspectInfrastructureTask aspectInfrastructureTask,
    MethodMappingInformation methodMappingInformation
)

Parameters

aspectInfrastructureTask
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask
The parent AspectInfrastructureTask.
methodMappingInformation
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingInformation
Static information about the MethodMapping.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Methods

[image]

PostSharp 2.0 Documentation
MethodMapping Methods
MethodMapping Class See Also Send Feedback

The MethodMapping type exposes the following members.

Methods

 | Name | Description
Public method | CreateWriter | Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping.
Public method | GetInstanceTypeDefinition | Gets the TypeDefDeclaration of the this object.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


CreateWriter Method

MethodMapping..::..CreateWriter Method
MethodMapping Class See Also Send Feedback
Creates a MethodMappingWriter able to emit MSIL instructions relevant for the current MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract MethodMappingWriter CreateWriter()

Return Value

A new MethodMappingWriter.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetInstanceTypeDefinition Method

MethodMapping..::..GetInstanceTypeDefinition Method
MethodMapping Class See Also Send Feedback
Gets the TypeDefDeclaration of the this object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetInstanceTypeDefinition()

Return Value

The TypeDefDeclaration corresponding to InstanceType.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMapping Properties

[image]

PostSharp 2.0 Documentation
MethodMapping Properties
MethodMapping Class See Also Send Feedback

The MethodMapping type exposes the following members.

Properties

 | Name | Description
Public property | AvailableContextItems | Set of context items (MethodMappingContextItem) that are available in the current context.
Public property | GenericMap | Gets the GenericMap mapping the current generic context to the original generic context.
Public property | InstanceType | Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type.
Public property | InstanceValueType | Gets the value type of the this reference, without the managed pointer.
Public property | IsValueType | Determines whether the this object is a value type.
Public property | MethodMappingInformation | Gets static information about the current MethodMapping.
Public property | MethodSignature | Gets the method signature mapped in the current generic context.
Public property | Module | Gets the current ModuleDeclaration.
Public property | Task | Gets the parent AspectInfrastructureTask.

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


AvailableContextItems Property

MethodMapping..::..AvailableContextItems Property
MethodMapping Class See Also Send Feedback
Set of context items (MethodMappingContextItem) that are available in the current context.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<MethodMappingContextItem> AvailableContextItems { get; private set; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


GenericMap Property

MethodMapping..::..GenericMap Property
MethodMapping Class See Also Send Feedback
Gets the GenericMap mapping the current generic context to the original generic context.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract GenericMap GenericMap { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


InstanceType Property

MethodMapping..::..InstanceType Property
MethodMapping Class See Also Send Feedback
Gets the type of values of the this reference mapped in the current generic context. If this is a value type (IsValueType is true), the current property is a managed pointer to the value type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature InstanceType { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMapping..::.GetInstanceTypeDefinition()()()
MethodMapping..::.IsValueType
MethodMapping..::.InstanceValueType


InstanceValueType Property

MethodMapping..::..InstanceValueType Property
MethodMapping Class See Also Send Feedback
Gets the value type of the this reference, without the managed pointer.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature InstanceValueType { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMapping..::.IsValueType
MethodMapping..::.InstanceType


IsValueType Property

MethodMapping..::..IsValueType Property
MethodMapping Class See Also Send Feedback
Determines whether the this object is a value type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool IsValueType { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Property

MethodMapping..::..MethodMappingInformation Property
MethodMapping Class See Also Send Feedback
Gets static information about the current MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMappingInformation MethodMappingInformation { get; private set; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodSignature Property

MethodMapping..::..MethodSignature Property
MethodMapping Class See Also Send Feedback
Gets the method signature mapped in the current generic context.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IMethodSignature MethodSignature { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


Module Property

MethodMapping..::..Module Property
MethodMapping Class See Also Send Feedback
Gets the current ModuleDeclaration.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


Task Property

MethodMapping..::..Task Property
MethodMapping Class See Also Send Feedback
Gets the parent AspectInfrastructureTask.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask Task { get; private set; }

See Also

MethodMapping Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Structure

MethodMappingContextItem Structure
Members See Also Send Feedback
Identifies a piece of run-time information available in the context of a MethodMapping. Sets of available context items are exposed on property AvailableContextItems. Implementations of MethodMappingWriter must a set of methods emitting instructions that get supported context items.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct MethodMappingContextItem : IEquatable<MethodMappingContextItem>

Remarks

A MethodMappingContextItem is uniquely identified by a string.

Context items are typically used to share information between transformations on the same pipeline, so that code generation can be optimized.

See Also

MethodMappingContextItem Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Members

[image]

PostSharp 2.0 Documentation
MethodMappingContextItem Members
MethodMappingContextItem Structure Constructors Methods Operators Fields See Also Send Feedback

The MethodMappingContextItem type exposes the following members.

Constructors

 | Name | Description
Public method | MethodMappingContextItem | Initializes a new MethodMappingContextItem.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two MethodMappingContextItem are equal.
Inequality | Determines whether two MethodMappingContextItem are different.

Fields

Name | Description
EventInfo | A MethodMappingContextItem representing the current EventInfo.
EventInterceptionAdviceArgs | A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.
FieldInfo | A MethodMappingContextItem representing the current FieldInfo.
Handler | A MethodMappingContextItem representing the current handler (a Delegate, typically in the context of an EventInterceptionAdviceArgs).
LocationInfo | A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.
LocationInterceptionAdviceArgs | A MethodMappingContextItem representing the current LocationInterceptionAdviceArgs.
MethodBase | A MethodMappingContextItem representing the current MethodBase.
MethodInterceptionAdviceArgs | A MethodMappingContextItem representing the current MethodInterceptionAdviceArgs.
PropertyInfo | A MethodMappingContextItem representing the current PropertyInfo.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Constructor

MethodMappingContextItem Constructor
MethodMappingContextItem Structure See Also Send Feedback
Initializes a new MethodMappingContextItem.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMappingContextItem(
    string name
)

Parameters

name
Type: System..::.String
A case-sensitive string uniquely identifying the context item.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Fields

[image]

PostSharp 2.0 Documentation
MethodMappingContextItem Fields
MethodMappingContextItem Structure See Also Send Feedback

The MethodMappingContextItem type exposes the following members.

Fields

Name | Description
EventInfo | A MethodMappingContextItem representing the current EventInfo.
EventInterceptionAdviceArgs | A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.
FieldInfo | A MethodMappingContextItem representing the current FieldInfo.
Handler | A MethodMappingContextItem representing the current handler (a Delegate, typically in the context of an EventInterceptionAdviceArgs).
LocationInfo | A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.
LocationInterceptionAdviceArgs | A MethodMappingContextItem representing the current LocationInterceptionAdviceArgs.
MethodBase | A MethodMappingContextItem representing the current MethodBase.
MethodInterceptionAdviceArgs | A MethodMappingContextItem representing the current MethodInterceptionAdviceArgs.
PropertyInfo | A MethodMappingContextItem representing the current PropertyInfo.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


EventInfo Field

MethodMappingContextItem..::..EventInfo Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current EventInfo.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem EventInfo

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


EventInterceptionAdviceArgs Field

MethodMappingContextItem..::..EventInterceptionAdviceArgs Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem EventInterceptionAdviceArgs

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


FieldInfo Field

MethodMappingContextItem..::..FieldInfo Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current FieldInfo.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem FieldInfo

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


Handler Field

MethodMappingContextItem..::..Handler Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current handler (a Delegate, typically in the context of an EventInterceptionAdviceArgs).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem Handler

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


LocationInfo Field

MethodMappingContextItem..::..LocationInfo Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current EventInterceptionAdviceArgs.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem LocationInfo

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


LocationInterceptionAdviceArgs Field

MethodMappingContextItem..::..LocationInterceptionAdviceArgs Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current LocationInterceptionAdviceArgs.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem LocationInterceptionAdviceArgs

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodBase Field

MethodMappingContextItem..::..MethodBase Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current MethodBase.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem MethodBase

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodInterceptionAdviceArgs Field

MethodMappingContextItem..::..MethodInterceptionAdviceArgs Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current MethodInterceptionAdviceArgs.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem MethodInterceptionAdviceArgs

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


PropertyInfo Field

MethodMappingContextItem..::..PropertyInfo Field
MethodMappingContextItem Structure See Also Send Feedback
A MethodMappingContextItem representing the current PropertyInfo.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MethodMappingContextItem PropertyInfo

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Methods

[image]

PostSharp 2.0 Documentation
MethodMappingContextItem Methods
MethodMappingContextItem Structure See Also Send Feedback

The MethodMappingContextItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
MethodMappingContextItem..::..Equals Method
MethodMappingContextItem Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(MethodMappingContextItem) | Indicates whether the current object is equal to another object of the same type.

See Also

MethodMappingContextItem Structure
MethodMappingContextItem Members
PostSharp.Sdk.AspectInfrastructure Namespace


Equals Method (Object)

MethodMappingContextItem..::..Equals Method (Object)
MethodMappingContextItem Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

MethodMappingContextItem Structure
Equals Overload
PostSharp.Sdk.AspectInfrastructure Namespace


Equals Method (MethodMappingContextItem)

MethodMappingContextItem..::..Equals Method (MethodMappingContextItem)
MethodMappingContextItem Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    MethodMappingContextItem other
)

Parameters

other
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodMappingContextItem Structure
Equals Overload
PostSharp.Sdk.AspectInfrastructure Namespace


GetHashCode Method

MethodMappingContextItem..::..GetHashCode Method
MethodMappingContextItem Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


ToString Method

MethodMappingContextItem..::..ToString Method
MethodMappingContextItem Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingContextItem Operators

[image]

PostSharp 2.0 Documentation
MethodMappingContextItem Operators
MethodMappingContextItem Structure See Also Send Feedback

The MethodMappingContextItem type exposes the following members.

Operators

Name | Description
Equality | Determines whether two MethodMappingContextItem are equal.
Inequality | Determines whether two MethodMappingContextItem are different.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


Equality Operator

MethodMappingContextItem..::..Equality Operator
MethodMappingContextItem Structure See Also Send Feedback
Determines whether two MethodMappingContextItem are equal.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    MethodMappingContextItem left,
    MethodMappingContextItem right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
A MethodMappingContextItem.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
A MethodMappingContextItem.

Return Value

true if left and right and equal, otherwise false.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


Inequality Operator

MethodMappingContextItem..::..Inequality Operator
MethodMappingContextItem Structure See Also Send Feedback
Determines whether two MethodMappingContextItem are different.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    MethodMappingContextItem left,
    MethodMappingContextItem right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
A MethodMappingContextItem.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
A MethodMappingContextItem.

Return Value

true if left and right and different, otherwise false.

See Also

MethodMappingContextItem Structure
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Class

MethodMappingInformation Class
Members See Also Send Feedback
The part of a MethodMapping that is constant over all transformations of a pipeline.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodMappingInformation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.MethodMappingInformation

See Also

MethodMappingInformation Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Members

[image]

PostSharp 2.0 Documentation
MethodMappingInformation Members
MethodMappingInformation Class Constructors Methods Properties See Also Send Feedback

The MethodMappingInformation type exposes the following members.

Constructors

 | Name | Description
Public method | MethodMappingInformation | Initializes a MethodMappingInformation based on a prototype MethodDefDeclaration.

Methods

 | Name | Description
Public method | GetParameterName | Gets the name of a parameter.
Public method | IsByRefParameter | Determines whether a parameter has the out or ref modifier.
Public method | IsOutParameter | Determines whether a parameter has the out modifier.

Properties

 | Name | Description
Public property | HasByRefParameter | Determines whether the method has at least one out or ref parameter.
Public property | IsStatic | Determines whether the method is static.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Constructor

MethodMappingInformation Constructor
MethodMappingInformation Class See Also Send Feedback
Initializes a MethodMappingInformation based on a prototype MethodDefDeclaration.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMappingInformation(
    MethodDefDeclaration prototypeMethodDef
)

Parameters

prototypeMethodDef
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The method from which the MethodMappingInformation should be constructed.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Methods

[image]

PostSharp 2.0 Documentation
MethodMappingInformation Methods
MethodMappingInformation Class See Also Send Feedback

The MethodMappingInformation type exposes the following members.

Methods

 | Name | Description
Public method | GetParameterName | Gets the name of a parameter.
Public method | IsByRefParameter | Determines whether a parameter has the out or ref modifier.
Public method | IsOutParameter | Determines whether a parameter has the out modifier.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetParameterName Method

MethodMappingInformation..::..GetParameterName Method
MethodMappingInformation Class See Also Send Feedback
Gets the name of a parameter.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetParameterName(
    int index
)

Parameters

index
Type: System..::.Int32
Parameter index.

Return Value

The name of the index-th parameter.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsByRefParameter Method

MethodMappingInformation..::..IsByRefParameter Method
MethodMappingInformation Class See Also Send Feedback
Determines whether a parameter has the out or ref modifier.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsByRefParameter(
    int index
)

Parameters

index
Type: System..::.Int32
Parameter

Return Value

true if the index-th parameter has the out modifier or ref, false if it has no modifier.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsOutParameter Method

MethodMappingInformation..::..IsOutParameter Method
MethodMappingInformation Class See Also Send Feedback
Determines whether a parameter has the out modifier.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsOutParameter(
    int index
)

Parameters

index
Type: System..::.Int32
Parameter

Return Value

true if the index-th parameter has the out modifier, false if it has no modifier or has the ref modifier.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingInformation Properties

[image]

PostSharp 2.0 Documentation
MethodMappingInformation Properties
MethodMappingInformation Class See Also Send Feedback

The MethodMappingInformation type exposes the following members.

Properties

 | Name | Description
Public property | HasByRefParameter | Determines whether the method has at least one out or ref parameter.
Public property | IsStatic | Determines whether the method is static.

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


HasByRefParameter Property

MethodMappingInformation..::..HasByRefParameter Property
MethodMappingInformation Class See Also Send Feedback
Determines whether the method has at least one out or ref parameter.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasByRefParameter { get; private set; }

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsStatic Property

MethodMappingInformation..::..IsStatic Property
MethodMappingInformation Class See Also Send Feedback
Determines whether the method is static.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; private set; }

See Also

MethodMappingInformation Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingWriter Class

MethodMappingWriter Class
Members See Also Send Feedback
Emits instructions that load and store arguments and context items in the context of a MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodMappingWriter

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter

See Also

MethodMappingWriter Members
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingWriter Members

[image]

PostSharp 2.0 Documentation
MethodMappingWriter Members
MethodMappingWriter Class Constructors Methods Properties See Also Send Feedback

The MethodMappingWriter type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodMappingWriter | Initializes a new MethodMappingWriter.

Methods

 | Name | Description
Public method | Clone | Clones the current MethodMappingWriter.
Public method | EmitLoadArgument | Emits instructions that load the value of an argument on the stack.
Public method | EmitLoadArgumentAddress | Emits instructions that load the address of an argument on the stack.
Public method | EmitLoadContextItem | Emits instructions that load the value of a context item on the stack. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.
Public method | EmitLoadInstance | Emits instructions that load the this value on the stack.
Public method | EmitStoreByRefArgument | Emits instructions that set the value of an out or ref argument.
Public method | EmitStoreContextItemIntoLocal | Overloaded.
Public method | EmitStoreContextItemIntoLocalConditional | Overloaded.
Public method | EmitStoreInstance | Emits instructions that set the value of the this object (typically a struct).

Properties

 | Name | Description
Public property | CanLoadArgumentAddress | Determines whether the current MethodMappingWriter has the ability to load the address of method arguments.
Public property | MethodMapping | Gets the parent MethodMapping.
Protected property | Task | Gets the parent AspectInfrastructureTask.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingWriter Constructor

MethodMappingWriter Constructor
MethodMappingWriter Class See Also Send Feedback
Initializes a new MethodMappingWriter.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodMappingWriter(
    MethodMapping parent
)

Parameters

parent
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
The parent MethodMapping.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingWriter Methods

[image]

PostSharp 2.0 Documentation
MethodMappingWriter Methods
MethodMappingWriter Class See Also Send Feedback

The MethodMappingWriter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the current MethodMappingWriter.
Public method | EmitLoadArgument | Emits instructions that load the value of an argument on the stack.
Public method | EmitLoadArgumentAddress | Emits instructions that load the address of an argument on the stack.
Public method | EmitLoadContextItem | Emits instructions that load the value of a context item on the stack. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.
Public method | EmitLoadInstance | Emits instructions that load the this value on the stack.
Public method | EmitStoreByRefArgument | Emits instructions that set the value of an out or ref argument.
Public method | EmitStoreContextItemIntoLocal | Overloaded.
Public method | EmitStoreContextItemIntoLocalConditional | Overloaded.
Public method | EmitStoreInstance | Emits instructions that set the value of the this object (typically a struct).

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


Clone Method

MethodMappingWriter..::..Clone Method
MethodMappingWriter Class See Also Send Feedback
Clones the current MethodMappingWriter.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual MethodMappingWriter Clone()

Return Value

A clone of the current MethodMappingWriter.

Remarks

Because of optimizations, instances of MethodMappingWriter are stateful. Therefore, the same instance cannot be shared among non-sequential InstructionSequence. A MethodMappingWriter should typically be cloned before using it to emit code in a InstructionSequence following a conditional branching instruction.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


EmitLoadArgument Method

MethodMappingWriter..::..EmitLoadArgument Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that load the value of an argument on the stack.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitLoadArgument(
    int index,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index (0 is always the first argument, even if the method is non-static).
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


EmitLoadArgumentAddress Method

MethodMappingWriter..::..EmitLoadArgumentAddress Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that load the address of an argument on the stack.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void EmitLoadArgumentAddress(
    int index,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index (0 is always the first argument, even if the method is non-static).
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMappingWriter..::.CanLoadArgumentAddress


EmitLoadContextItem Method

MethodMappingWriter..::..EmitLoadContextItem Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that load the value of a context item on the stack. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadContextItem(
    MethodMappingContextItem methodMappingContextItem,
    ITypeSignature type,
    InstructionWriter instructionWriter,
    Action<InstructionWriter> loadContextItemAction
)

Parameters

methodMappingContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
The context item.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the context item value.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
loadContextItemAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
A delegate that emits instructions that load the context item value on the stack. This delegate is invoked in case the item is not available in the current context.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


EmitLoadInstance Method

MethodMappingWriter..::..EmitLoadInstance Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that load the this value on the stack.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitLoadInstance(
    bool cast,
    InstructionWriter instructionWriter
)

Parameters

cast
Type: System..::.Boolean
true if the this value should be pushed to the stack as strongly-typed, false if it should be pushed as an Object.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreByRefArgument Method

MethodMappingWriter..::..EmitStoreByRefArgument Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that set the value of an out or ref argument.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitStoreByRefArgument(
    int index,
    Action<InstructionWriter> getValueAction,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index (0 is always the first argument, even if the method is non-static).
getValueAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
A delegate that emits instructions that load the new argument value on the stack.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocal Method

[image]

PostSharp 2.0 Documentation
MethodMappingWriter..::..EmitStoreContextItemIntoLocal Method
MethodMappingWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreContextItemIntoLocal(MethodMappingContextItem, InstructionWriter, LocalVariableSymbol) | Emits instructions that store a context item into an existing local variable.
Public method | EmitStoreContextItemIntoLocal(MethodMappingContextItem, InstructionWriter, LocalVariableSymbol%, Boolean%) | Emits instructions that store the value of a context item into a local variable, creates and returns the local variable if it has not been passed by the caller, and returns a value indicating whether the value stored may be null at run time.

See Also

MethodMappingWriter Class
MethodMappingWriter Members
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocal Method (MethodMappingContextItem, InstructionWriter, LocalVariableSymbol)

MethodMappingWriter..::..EmitStoreContextItemIntoLocal Method (MethodMappingContextItem, InstructionWriter, LocalVariableSymbol)
MethodMappingWriter Class See Also Send Feedback
Emits instructions that store a context item into an existing local variable.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreContextItemIntoLocal(
    MethodMappingContextItem methodMappingContextItem,
    InstructionWriter instructionWriter,
    LocalVariableSymbol local
)

Parameters

methodMappingContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
The context item.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
local
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The local variable into which the context item should be stored.

See Also

MethodMappingWriter Class
EmitStoreContextItemIntoLocal Overload
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocal Method (MethodMappingContextItem, InstructionWriter, LocalVariableSymbol, Boolean)

MethodMappingWriter..::..EmitStoreContextItemIntoLocal Method (MethodMappingContextItem, InstructionWriter, LocalVariableSymbol%, Boolean%)
MethodMappingWriter Class See Also Send Feedback
Emits instructions that store the value of a context item into a local variable, creates and returns the local variable if it has not been passed by the caller, and returns a value indicating whether the value stored may be null at run time.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitStoreContextItemIntoLocal(
    MethodMappingContextItem methodMappingContextItem,
    InstructionWriter instructionWriter,
    ref LocalVariableSymbol local,
    out bool mayBeNull
)

Parameters

methodMappingContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
The context item.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
local
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
The local variable into which the context item is stored. If the input value of this parameter is null, the local variable is created.
mayBeNull
Type: System..::.Boolean %
At output, true if the value of local can be null at run time, false if it guaranteed to contain the required context item.

See Also

MethodMappingWriter Class
EmitStoreContextItemIntoLocal Overload
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocalConditional Method

[image]

PostSharp 2.0 Documentation
MethodMappingWriter..::..EmitStoreContextItemIntoLocalConditional Method
MethodMappingWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreContextItemIntoLocalConditional(MethodMappingContextItem, LocalVariableSymbol%, ITypeSignature, InstructionWriter, Action<(Of <(InstructionWriter, LocalVariableSymbol>)>)) | Emits instructions that store the value of a context item to a local variable. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.
Public method | EmitStoreContextItemIntoLocalConditional(MethodMappingContextItem, LocalVariableSymbol%, ITypeSignature, InstructionWriter, Action<(Of <(InstructionWriter, LocalVariableSymbol>)>), Action<(Of <(InstructionWriter, LocalVariableSymbol>)>)) | Emits instructions that store the value of a context item to a local variable. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.

See Also

MethodMappingWriter Class
MethodMappingWriter Members
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocalConditional Method (MethodMappingContextItem, LocalVariableSymbol, ITypeSignature, InstructionWriter, Action(InstructionWriter, LocalVariableSymbol))

MethodMappingWriter..::..EmitStoreContextItemIntoLocalConditional Method (MethodMappingContextItem, LocalVariableSymbol%, ITypeSignature, InstructionWriter, Action<(Of <(<'InstructionWriter, LocalVariableSymbol>)>)>)
MethodMappingWriter Class See Also Send Feedback
Emits instructions that store the value of a context item to a local variable. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreContextItemIntoLocalConditional(
    MethodMappingContextItem methodMappingContextItem,
    ref LocalVariableSymbol contextItemLocal,
    ITypeSignature contextItemType,
    InstructionWriter instructionWriter,
    Action<InstructionWriter, LocalVariableSymbol> loadContextItemAction
)

Parameters

methodMappingContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
The context item.
contextItemLocal
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
The local variable where the value of the context item should be stored. If the input value of this parameter is null, a local variable of type contextItemType is created.
contextItemType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type of the context item, used to create the local variable if contextItemLocal is null.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
loadContextItemAction
Type: System..::.Action <(Of <(<' InstructionWriter, LocalVariableSymbol >)>)>
A delegate that emits instructions that load the context item value on the stack. This delegate is invoked in case the item is not available in the current context.

See Also

MethodMappingWriter Class
EmitStoreContextItemIntoLocalConditional Overload
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreContextItemIntoLocalConditional Method (MethodMappingContextItem, LocalVariableSymbol, ITypeSignature, InstructionWriter, Action(InstructionWriter, LocalVariableSymbol), Action(InstructionWriter, LocalVariableSymbol))

MethodMappingWriter..::..EmitStoreContextItemIntoLocalConditional Method (MethodMappingContextItem, LocalVariableSymbol%, ITypeSignature, InstructionWriter, Action<(Of <(<'InstructionWriter, LocalVariableSymbol>)>)>, Action<(Of <(<'InstructionWriter, LocalVariableSymbol>)>)>)
MethodMappingWriter Class See Also Send Feedback
Emits instructions that store the value of a context item to a local variable. If the item is not available in the current context, it is loaded using instructions emitted by a delegate.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreContextItemIntoLocalConditional(
    MethodMappingContextItem methodMappingContextItem,
    ref LocalVariableSymbol contextItemLocal,
    ITypeSignature contextItemType,
    InstructionWriter instructionWriter,
    Action<InstructionWriter, LocalVariableSymbol> loadContextItemAction,
    Action<InstructionWriter, LocalVariableSymbol> emitIfLoadedFromContextAction
)

Parameters

methodMappingContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
The context item.
contextItemLocal
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
The local variable where the value of the context item should be stored. If the input value of this parameter is null, a local variable of type contextItemType is created.
contextItemType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type of the context item, used to create the local variable if contextItemLocal is null.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
loadContextItemAction
Type: System..::.Action <(Of <(<' InstructionWriter, LocalVariableSymbol >)>)>
A delegate that emits instructions that load the context item value on the stack. This delegate is invoked in case the item is not available in the current context.
emitIfLoadedFromContextAction
Type: System..::.Action <(Of <(<' InstructionWriter, LocalVariableSymbol >)>)>
A delegate that emits instructions executed in case the item has been loaded from context, or null if nothing should be executed if the item is loaded from context.

See Also

MethodMappingWriter Class
EmitStoreContextItemIntoLocalConditional Overload
PostSharp.Sdk.AspectInfrastructure Namespace


EmitStoreInstance Method

MethodMappingWriter..::..EmitStoreInstance Method
MethodMappingWriter Class See Also Send Feedback
Emits instructions that set the value of the this object (typically a struct).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitStoreInstance(
    bool cast,
    InstructionWriter writer,
    Action<InstructionWriter> loadValueAction
)

Parameters

cast
Type: System..::.Boolean
true if the value loaded by loadValueAction is an Object and should be unboxed, false if the value is already in the right type.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
loadValueAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
A delegate that emits instructions that load the new value of the this object on the top of the stack.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodMappingWriter Properties

[image]

PostSharp 2.0 Documentation
MethodMappingWriter Properties
MethodMappingWriter Class See Also Send Feedback

The MethodMappingWriter type exposes the following members.

Properties

 | Name | Description
Public property | CanLoadArgumentAddress | Determines whether the current MethodMappingWriter has the ability to load the address of method arguments.
Public property | MethodMapping | Gets the parent MethodMapping.
Protected property | Task | Gets the parent AspectInfrastructureTask.

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


CanLoadArgumentAddress Property

MethodMappingWriter..::..CanLoadArgumentAddress Property
MethodMappingWriter Class See Also Send Feedback
Determines whether the current MethodMappingWriter has the ability to load the address of method arguments.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool CanLoadArgumentAddress { get; }

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace
MethodMappingWriter..::.EmitLoadArgumentAddress(Int32, InstructionWriter)


MethodMapping Property

MethodMappingWriter..::..MethodMapping Property
MethodMappingWriter Class See Also Send Feedback
Gets the parent MethodMapping.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodMapping MethodMapping { get; private set; }

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


Task Property

MethodMappingWriter..::..Task Property
MethodMappingWriter Class See Also Send Feedback
Gets the parent AspectInfrastructureTask.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectInfrastructureTask Task { get; }

See Also

MethodMappingWriter Class
PostSharp.Sdk.AspectInfrastructure Namespace


NullTransformationInstance Class

NullTransformationInstance Class
Members See Also Send Feedback
A transformation instance performing no transformation.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class NullTransformationInstance : IDependencyTransformationInstance,
    IAspectDependencyObject, IStructuralTransformationInstance, ITransformationInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.NullTransformationInstance

See Also

NullTransformationInstance Members
PostSharp.Sdk.AspectInfrastructure Namespace


NullTransformationInstance Members

[image]

PostSharp 2.0 Documentation
NullTransformationInstance Members
NullTransformationInstance Class Methods Fields Properties See Also Send Feedback

The NullTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object.
Public method | HasEffect | Determines whether the current object has a given effect.

Fields

Name | Description
Instance | Singleton instance of NullTransformationInstance.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


NullTransformationInstance Fields

[image]

PostSharp 2.0 Documentation
NullTransformationInstance Fields
NullTransformationInstance Class See Also Send Feedback

The NullTransformationInstance type exposes the following members.

Fields

Name | Description
Instance | Singleton instance of NullTransformationInstance.

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


Instance Field

NullTransformationInstance..::..Instance Field
NullTransformationInstance Class See Also Send Feedback
Singleton instance of NullTransformationInstance.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly IDependencyTransformationInstance Instance

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


NullTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
NullTransformationInstance Methods
NullTransformationInstance Class See Also Send Feedback

The NullTransformationInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object.
Public method | HasEffect | Determines whether the current object has a given effect.

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetDisplayName Method

NullTransformationInstance..::..GetDisplayName Method
NullTransformationInstance Class See Also Send Feedback
Gets a human-readable string representing the current object.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetDisplayName()

Return Value

A human-readable string representing the current object.

Implements

IAspectDependencyObject..::.GetDisplayName()()()

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


HasEffect Method

NullTransformationInstance..::..HasEffect Method
NullTransformationInstance Class See Also Send Feedback
Determines whether the current object has a given effect.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasEffect(
    string effect
)

Parameters

effect
Type: System..::.String
A case-sensitive string uniquely identifying the effect. See StandardEffects.

Return Value

true if the current object has the current effect, otherwise false.

Implements

IAspectDependencyObject..::.HasEffect(String)

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


NullTransformationInstance Properties

[image]

PostSharp 2.0 Documentation
NullTransformationInstance Properties
NullTransformationInstance Class See Also Send Feedback

The NullTransformationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


Dependencies Property

NullTransformationInstance..::..Dependencies Property
NullTransformationInstance Class See Also Send Feedback
Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerable<AspectDependency> Dependencies { get; private set; }

Implements

IAspectDependencyObject..::.Dependencies

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


IsCommutative Property

NullTransformationInstance..::..IsCommutative Property
NullTransformationInstance Class See Also Send Feedback
Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsCommutative { get; }

Implements

IAspectDependencyObject..::.IsCommutative

See Also

NullTransformationInstance Class
PostSharp.Sdk.AspectInfrastructure Namespace


PipelineTransversalState Class

PipelineTransversalState Class
Members See Also Send Feedback
Contains state shared by all branches and instances of a transformation pipeline. In properties and events, all accessors share the same PipelineTransversalState.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PipelineTransversalState

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.PipelineTransversalState

See Also

PipelineTransversalState Members
PostSharp.Sdk.AspectInfrastructure Namespace


PipelineTransversalState Members

[image]

PostSharp 2.0 Documentation
PipelineTransversalState Members
PipelineTransversalState Class Properties See Also Send Feedback

The PipelineTransversalState type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets a state item.

See Also

PipelineTransversalState Class
PostSharp.Sdk.AspectInfrastructure Namespace


PipelineTransversalState Properties

[image]

PostSharp 2.0 Documentation
PipelineTransversalState Properties
PipelineTransversalState Class See Also Send Feedback

The PipelineTransversalState type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets a state item.

See Also

PipelineTransversalState Class
PostSharp.Sdk.AspectInfrastructure Namespace


Item Property

PipelineTransversalState..::..Item Property
PipelineTransversalState Class See Also Send Feedback
Gets or sets a state item.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object Item[
    IDependencyTransformationInstance transformation
] { get; set; }

Parameters

transformation
Type: PostSharp.Sdk.AspectInfrastructure..::.IDependencyTransformationInstance
The transformation instance to which the transformation belong.

Return Value

The state object associated with this transformation, or null if no state item was associated with transformation.

See Also

PipelineTransversalState Class
PostSharp.Sdk.AspectInfrastructure Namespace


StructuredDeclarationDictionary(?0) Class

StructuredDeclarationDictionary<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
A dictionary whose keys are IMetadataDeclaration and that can be visited in a predictable order. Multiple values can be added to the same key. Visiting semantics are internal.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class StructuredDeclarationDictionary<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.AspectInfrastructure.StructuredDeclarationDictionary`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.StructuredDeclarationDictionary<(Of <(?0>)>)
PostSharp.Sdk.AspectInfrastructure..::.TransformationInstanceCollection

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Members
PostSharp.Sdk.AspectInfrastructure Namespace


StructuredDeclarationDictionary(?0) Members

[image]

PostSharp 2.0 Documentation
StructuredDeclarationDictionary<(Of <(<'?0>)>)> Members
StructuredDeclarationDictionary<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The StructuredDeclarationDictionary<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | StructuredDeclarationDictionary<(Of <(?0>)>) | Initializes a new StructuredDeclarationDictionary<(Of <(?0>)>).

Methods

 | Name | Description
Public method | Add | Adds an item to the current dictionary.
Public method | Remove | Removes all items associated to a given key from the current directory.

Properties

 | Name | Description
Public property | Count | Gets the number of values in the current dictionary.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


StructuredDeclarationDictionary(?0) Constructor

StructuredDeclarationDictionary<(Of <(<'?0>)>)> Constructor
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new StructuredDeclarationDictionary<(Of <(?0>)>).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StructuredDeclarationDictionary(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which declarations belong.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


StructuredDeclarationDictionary(?0) Methods

[image]

PostSharp 2.0 Documentation
StructuredDeclarationDictionary<(Of <(<'?0>)>)> Methods
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback

The StructuredDeclarationDictionary<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the current dictionary.
Public method | Remove | Removes all items associated to a given key from the current directory.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Add Method

StructuredDeclarationDictionary<(Of <(<'?0>)>)>..::..Add Method
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the current dictionary.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    IMetadataDeclaration key,
    ?0 value
)

Parameters

key
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Key.
value
Type: ?0
Value.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Remove Method

StructuredDeclarationDictionary<(Of <(<'?0>)>)>..::..Remove Method
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback
Removes all items associated to a given key from the current directory.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove(
    IMetadataDeclaration key
)

Parameters

key
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Key.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


StructuredDeclarationDictionary(?0) Properties

[image]

PostSharp 2.0 Documentation
StructuredDeclarationDictionary<(Of <(<'?0>)>)> Properties
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback

The StructuredDeclarationDictionary<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of values in the current dictionary.

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


Count Property

StructuredDeclarationDictionary<(Of <(<'?0>)>)>..::..Count Property
StructuredDeclarationDictionary<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of values in the current dictionary.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; private set; }

See Also

StructuredDeclarationDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationContext Class

TransformationContext Class
Members See Also Send Feedback
Context information of a transformation pipeline.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class TransformationContext : ICloneable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationContext

See Also

TransformationContext Members
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationContext Members

[image]

PostSharp 2.0 Documentation
TransformationContext Members
TransformationContext Class Methods Properties See Also Send Feedback

The TransformationContext type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.

Properties

 | Name | Description
Public property | MethodSemantic | Gets the semantic of the method being transformed, if the method is a member of an event or a property.
Public property | MustAddSymJoinPoint | Determines whether the current transformation is expected to add a join point symbol.
Public property | Ordinal | Gets the ordinal of the current transformation in the transformation pipeline.
Public property | OriginalTargetElement | Gets the element of code to the transformation pipeline was originally applied. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the current property contains the original element of code, and the TargetElement property contains the replacement element of code.
Public property | TargetElement | Gets the element of code being currently transformed by the transformation pipeline. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the OriginalTargetElement property contains the original element of code, and the current property contains the replacement element of code.
Public property | TransversalState | Gets an object allowing transformations to share state between pipelines targeting different methods of the same property or event.

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationContext Methods

[image]

PostSharp 2.0 Documentation
TransformationContext Methods
TransformationContext Class See Also Send Feedback

The TransformationContext type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


Clone Method

TransformationContext..::..Clone Method
TransformationContext Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Object Clone()

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::.Clone()()()

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationContext Properties

[image]

PostSharp 2.0 Documentation
TransformationContext Properties
TransformationContext Class See Also Send Feedback

The TransformationContext type exposes the following members.

Properties

 | Name | Description
Public property | MethodSemantic | Gets the semantic of the method being transformed, if the method is a member of an event or a property.
Public property | MustAddSymJoinPoint | Determines whether the current transformation is expected to add a join point symbol.
Public property | Ordinal | Gets the ordinal of the current transformation in the transformation pipeline.
Public property | OriginalTargetElement | Gets the element of code to the transformation pipeline was originally applied. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the current property contains the original element of code, and the TargetElement property contains the replacement element of code.
Public property | TargetElement | Gets the element of code being currently transformed by the transformation pipeline. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the OriginalTargetElement property contains the original element of code, and the current property contains the replacement element of code.
Public property | TransversalState | Gets an object allowing transformations to share state between pipelines targeting different methods of the same property or event.

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MethodSemantic Property

TransformationContext..::..MethodSemantic Property
TransformationContext Class See Also Send Feedback
Gets the semantic of the method being transformed, if the method is a member of an event or a property.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemantics MethodSemantic { get; private set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


MustAddSymJoinPoint Property

TransformationContext..::..MustAddSymJoinPoint Property
TransformationContext Class See Also Send Feedback
Determines whether the current transformation is expected to add a join point symbol.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MustAddSymJoinPoint { get; internal set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


Ordinal Property

TransformationContext..::..Ordinal Property
TransformationContext Class See Also Send Feedback
Gets the ordinal of the current transformation in the transformation pipeline.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; internal set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


OriginalTargetElement Property

TransformationContext..::..OriginalTargetElement Property
TransformationContext Class See Also Send Feedback
Gets the element of code to the transformation pipeline was originally applied. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the current property contains the original element of code, and the TargetElement property contains the replacement element of code.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration OriginalTargetElement { get; private set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace
TransformationContext..::.TargetElement


TargetElement Property

TransformationContext..::..TargetElement Property
TransformationContext Class See Also Send Feedback
Gets the element of code being currently transformed by the transformation pipeline. The pipeline may have redirected created a new element of code in replacement of the original one. In this case, the OriginalTargetElement property contains the original element of code, and the current property contains the replacement element of code.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; private set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace
TransformationContext..::.TargetElement


TransversalState Property

TransformationContext..::..TransversalState Property
TransformationContext Class See Also Send Feedback
Gets an object allowing transformations to share state between pipelines targeting different methods of the same property or event.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PipelineTransversalState TransversalState { get; private set; }

See Also

TransformationContext Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstanceCollection Class

TransformationInstanceCollection Class
Members See Also Send Feedback
Collection of transformation instances (IDependencyTransformationInstance).

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TransformationInstanceCollection : StructuredDeclarationDictionary<IDependencyTransformationInstance>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.StructuredDeclarationDictionary <(Of <(<' IDependencyTransformationInstance >)>)>
PostSharp.Sdk.AspectInfrastructure..::.TransformationInstanceCollection

See Also

TransformationInstanceCollection Members
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstanceCollection Members

[image]

PostSharp 2.0 Documentation
TransformationInstanceCollection Members
TransformationInstanceCollection Class Constructors Methods Properties See Also Send Feedback

The TransformationInstanceCollection type exposes the following members.

Constructors

 | Name | Description
Public method | TransformationInstanceCollection | Initializes a new TransformationInstanceCollection.

Methods

 | Name | Description
Public method | Add | Adds an item to the current dictionary. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)
Public method | Remove | Removes all items associated to a given key from the current directory. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of values in the current dictionary. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)

See Also

TransformationInstanceCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstanceCollection Constructor

TransformationInstanceCollection Constructor
TransformationInstanceCollection Class See Also Send Feedback
Initializes a new TransformationInstanceCollection.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TransformationInstanceCollection(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which transformations are added.

See Also

TransformationInstanceCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstanceCollection Methods

[image]

PostSharp 2.0 Documentation
TransformationInstanceCollection Methods
TransformationInstanceCollection Class See Also Send Feedback

The TransformationInstanceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the current dictionary. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)
Public method | Remove | Removes all items associated to a given key from the current directory. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)

See Also

TransformationInstanceCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


TransformationInstanceCollection Properties

[image]

PostSharp 2.0 Documentation
TransformationInstanceCollection Properties
TransformationInstanceCollection Class See Also Send Feedback

The TransformationInstanceCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of values in the current dictionary. (Inherited from StructuredDeclarationDictionary<(Of <(?0>)>).)

See Also

TransformationInstanceCollection Class
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationClientScopes Enumeration

TypeInitializationClientScopes Enumeration
See Also Send Feedback
Scopes (Instance or Static) in which ITypeInitializationClient are registered.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum TypeInitializationClientScopes

Members

Member name | Value | Description
None | 0 | No registration.
Instance | 1 | Registration for the instance initializer.
Static | 2 | Registration for the static (type) initializer.

See Also

PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager Class

TypeInitializationManager Class
Members See Also Send Feedback
Manages initialization of aspects, i.e. the generation aspect initialization methods and the enhancement of constructors so that these methods are invoked.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeInitializationManager

Remarks

Aspects that need to be initialized should register themselves using the RegisterClient(TypeDefDeclaration, ITypeInitializationClient, TypeInitializationClientScopes) method.

An instance of this class is available on the TypeInitializationManager property of the AspectInfrastructureTask class.

The TypeInitializationManager performs the following transformations:

  • For each type requiring initialization, it creates a private method (typically named ~InitializeAspects~1) and let all clients (register using RegisterClient(TypeDefDeclaration, ITypeInitializationClient, TypeInitializationClientScopes)) emit code in that method. Then, constructors are enhanced so that they invoke this method.
  • It creates a protected virtual method named InitializeAspects, calling the base method (if any), then calling the private method described above. This protected method can be retrieved using GetInitializeAspectsProtectedMethod(TypeDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.TypeInitializationManager

See Also

TypeInitializationManager Members
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager Members

[image]

PostSharp 2.0 Documentation
TypeInitializationManager Members
TypeInitializationManager Class Methods See Also Send Feedback

The TypeInitializationManager type exposes the following members.

Methods

 | Name | Description
Public method | GetInitializeAspectsPrivateMethod | Gets the generated InitializeAspects (exact name may vary) private method for a given type.
Public method | GetInitializeAspectsProtectedMethod | Gets the generated InitializeAspects protected method for a given type.
Public method | RegisterClient | Registers an ITypeInitializationClient for a given TypeDefDeclaration.

See Also

TypeInitializationManager Class
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager Methods

[image]

PostSharp 2.0 Documentation
TypeInitializationManager Methods
TypeInitializationManager Class See Also Send Feedback

The TypeInitializationManager type exposes the following members.

Methods

 | Name | Description
Public method | GetInitializeAspectsPrivateMethod | Gets the generated InitializeAspects (exact name may vary) private method for a given type.
Public method | GetInitializeAspectsProtectedMethod | Gets the generated InitializeAspects protected method for a given type.
Public method | RegisterClient | Registers an ITypeInitializationClient for a given TypeDefDeclaration.

See Also

TypeInitializationManager Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetInitializeAspectsPrivateMethod Method

TypeInitializationManager..::..GetInitializeAspectsPrivateMethod Method
TypeInitializationManager Class See Also Send Feedback
Gets the generated InitializeAspects (exact name may vary) private method for a given type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetInitializeAspectsPrivateMethod(
    TypeDefDeclaration typeDef
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The type for which the InitializeAspects method should be returned.

Return Value

The InitializeAspects protected method for type typeDef, or null if this method does not exist for this type (which would mean that this type required no aspect initialization).

See Also

TypeInitializationManager Class
PostSharp.Sdk.AspectInfrastructure Namespace


GetInitializeAspectsProtectedMethod Method

TypeInitializationManager..::..GetInitializeAspectsProtectedMethod Method
TypeInitializationManager Class See Also Send Feedback
Gets the generated InitializeAspects protected method for a given type.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetInitializeAspectsProtectedMethod(
    TypeDefDeclaration typeDef
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The type for which the InitializeAspects method should be returned.

Return Value

The InitializeAspects protected method for type typeDef, or null if this method does not exist for this type (which would mean that this type required no aspect initialization).

See Also

TypeInitializationManager Class
PostSharp.Sdk.AspectInfrastructure Namespace


RegisterClient Method

TypeInitializationManager..::..RegisterClient Method
TypeInitializationManager Class See Also Send Feedback
Registers an ITypeInitializationClient for a given TypeDefDeclaration.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RegisterClient(
    TypeDefDeclaration typeDef,
    ITypeInitializationClient client,
    TypeInitializationClientScopes scopes
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The type to be enhanced.
client
Type: PostSharp.Sdk.AspectInfrastructure..::.ITypeInitializationClient
The ITypeInitializationClient emitting initialization instructions.
scopes
Type: PostSharp.Sdk.AspectInfrastructure..::.TypeInitializationClientScopes
Scopes for which the client is registered.

See Also

TypeInitializationManager Class
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager.StandardRoles Class

TypeInitializationManager..::..StandardRoles Class
TypeInitializationManager Class Members See Also Send Feedback
Standard aspect-dependency roles for use with the TypeInitializationManager.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class StandardRoles

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.TypeInitializationManager..::.StandardRoles

See Also

TypeInitializationManager..::.StandardRoles Members
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager.StandardRoles Members

[image]

PostSharp 2.0 Documentation
TypeInitializationManager..::..StandardRoles Members
TypeInitializationManager..::.StandardRoles Class Fields See Also Send Feedback

Manages initialization of aspects, i.e. the generation aspect initialization methods and the enhancement of constructors so that these methods are invoked.

The TypeInitializationManager..::.StandardRoles type exposes the following members.

Fields

Name | Description
AspectInfrastructure | Initialization of the aspect infrastructure.
AspectInstantiation | Instantiation of aspects.
AspectSystemInitialization | Initialization of the aspect by the aspect framework.
AspectUserInitialization | Initialization of the aspect by the user.
InstanceCredentials | Initialization of InstanceCredentials.
ReflectionInitialization | Initialization of reflection objects.

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


TypeInitializationManager.StandardRoles Fields

[image]

PostSharp 2.0 Documentation
TypeInitializationManager..::..StandardRoles Fields
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback

The TypeInitializationManager..::.StandardRoles type exposes the following members.

Fields

Name | Description
AspectInfrastructure | Initialization of the aspect infrastructure.
AspectInstantiation | Instantiation of aspects.
AspectSystemInitialization | Initialization of the aspect by the aspect framework.
AspectUserInitialization | Initialization of the aspect by the user.
InstanceCredentials | Initialization of InstanceCredentials.
ReflectionInitialization | Initialization of reflection objects.

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInfrastructure Field

TypeInitializationManager..::..StandardRoles..::..AspectInfrastructure Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Initialization of the aspect infrastructure.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string AspectInfrastructure

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectInstantiation Field

TypeInitializationManager..::..StandardRoles..::..AspectInstantiation Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Instantiation of aspects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string AspectInstantiation

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectSystemInitialization Field

TypeInitializationManager..::..StandardRoles..::..AspectSystemInitialization Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Initialization of the aspect by the aspect framework.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string AspectSystemInitialization

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


AspectUserInitialization Field

TypeInitializationManager..::..StandardRoles..::..AspectUserInitialization Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Initialization of the aspect by the user.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string AspectUserInitialization

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


InstanceCredentials Field

TypeInitializationManager..::..StandardRoles..::..InstanceCredentials Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Initialization of InstanceCredentials.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string InstanceCredentials

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


ReflectionInitialization Field

TypeInitializationManager..::..StandardRoles..::..ReflectionInitialization Field
TypeInitializationManager..::.StandardRoles Class See Also Send Feedback
Initialization of reflection objects.

Namespace: PostSharp.Sdk.AspectInfrastructure
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string ReflectionInitialization

See Also

TypeInitializationManager..::.StandardRoles Class
PostSharp.Sdk.AspectInfrastructure Namespace


PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace

PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace
Send Feedback
The PostSharp.Sdk.AspectInfrastructure.Dependencies namespace contains specific implementations of aspect dependencies.

Classes

 | Class | Description
Public class | AndDependencyCondition | An AspectDependencyCondition aggregating several other child conditions and evaluating to true if all child conditions evaluate to true.
Public class | AspectEffectDependencyCondition | An AspectDependencyCondition that evaluates to true if the right member has a given effect.
Public class | AspectRoleDependencyCondition | An AspectDependencyCondition that evaluates to true if the right member is in a given role.
Public class | NotDependencyCondition | An AspectDependencyCondition that negates another condition.
Public class | OrDependencyCondition | An AspectDependencyCondition aggregating several other child conditions and evaluating to true if at least one child condition evaluates to true.
Public class | ProvideAspectRoleDependency | An AspectDependency representing the fact that a dependency object provides a role.
Public class | TrueDependencyCondition | An AspectDependencyCondition that always evaluates to true.


AndDependencyCondition Class

AndDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition aggregating several other child conditions and evaluating to true if all child conditions evaluate to true.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AndDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AndDependencyCondition

See Also

AndDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AndDependencyCondition Members

[image]

PostSharp 2.0 Documentation
AndDependencyCondition Members
AndDependencyCondition Class Constructors Methods See Also Send Feedback

The AndDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AndDependencyCondition | Initializes a new AndDependencyCondition

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AndDependencyCondition Constructor

AndDependencyCondition Constructor
AndDependencyCondition Class See Also Send Feedback
Initializes a new AndDependencyCondition

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AndDependencyCondition(
    params AspectDependencyCondition[] conditions
)

Parameters

conditions
Type: array< PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition >[]()[][]
An array of children conditions.

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AndDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
AndDependencyCondition Methods
AndDependencyCondition Class See Also Send Feedback

The AndDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

AndDependencyCondition..::..FormatCondition Method
AndDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

AndDependencyCondition..::..Match Method
AndDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

AndDependencyCondition..::..ToString Method
AndDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AndDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectEffectDependencyCondition Class

AspectEffectDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition that evaluates to true if the right member has a given effect.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectEffectDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AspectEffectDependencyCondition

See Also

AspectEffectDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectEffectDependencyCondition Members

[image]

PostSharp 2.0 Documentation
AspectEffectDependencyCondition Members
AspectEffectDependencyCondition Class Constructors Methods See Also Send Feedback

The AspectEffectDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AspectEffectDependencyCondition | Initializes a new AspectEffectDependencyCondition.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectEffectDependencyCondition Constructor

AspectEffectDependencyCondition Constructor
AspectEffectDependencyCondition Class See Also Send Feedback
Initializes a new AspectEffectDependencyCondition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectEffectDependencyCondition(
    string effect
)

Parameters

effect
Type: System..::.String
The effect that the right member of the condition must have in order for the condition to evaluate to true.

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectEffectDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
AspectEffectDependencyCondition Methods
AspectEffectDependencyCondition Class See Also Send Feedback

The AspectEffectDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

AspectEffectDependencyCondition..::..FormatCondition Method
AspectEffectDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

AspectEffectDependencyCondition..::..Match Method
AspectEffectDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

AspectEffectDependencyCondition..::..ToString Method
AspectEffectDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectEffectDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectRoleDependencyCondition Class

AspectRoleDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition that evaluates to true if the right member is in a given role.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectRoleDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.AspectRoleDependencyCondition

See Also

AspectRoleDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectRoleDependencyCondition Members

[image]

PostSharp 2.0 Documentation
AspectRoleDependencyCondition Members
AspectRoleDependencyCondition Class Constructors Methods See Also Send Feedback

The AspectRoleDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AspectRoleDependencyCondition | Initializes a new AspectRoleDependencyCondition.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectRoleDependencyCondition Constructor

AspectRoleDependencyCondition Constructor
AspectRoleDependencyCondition Class See Also Send Feedback
Initializes a new AspectRoleDependencyCondition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectRoleDependencyCondition(
    string role
)

Parameters

role
Type: System..::.String
The role that the right member of the condition must provide in order for the condition to evaluate to true.

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


AspectRoleDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
AspectRoleDependencyCondition Methods
AspectRoleDependencyCondition Class See Also Send Feedback

The AspectRoleDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

AspectRoleDependencyCondition..::..FormatCondition Method
AspectRoleDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

AspectRoleDependencyCondition..::..Match Method
AspectRoleDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

AspectRoleDependencyCondition..::..ToString Method
AspectRoleDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectRoleDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


NotDependencyCondition Class

NotDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition that negates another condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class NotDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.NotDependencyCondition

See Also

NotDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


NotDependencyCondition Members

[image]

PostSharp 2.0 Documentation
NotDependencyCondition Members
NotDependencyCondition Class Constructors Methods See Also Send Feedback

The NotDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | NotDependencyCondition | Initializes new NotDependencyCondition.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


NotDependencyCondition Constructor

NotDependencyCondition Constructor
NotDependencyCondition Class See Also Send Feedback
Initializes new NotDependencyCondition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NotDependencyCondition(
    AspectDependencyCondition condition
)

Parameters

condition
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
The negated AspectDependencyCondition.

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


NotDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
NotDependencyCondition Methods
NotDependencyCondition Class See Also Send Feedback

The NotDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

NotDependencyCondition..::..FormatCondition Method
NotDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

NotDependencyCondition..::..Match Method
NotDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

NotDependencyCondition..::..ToString Method
NotDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

NotDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


OrDependencyCondition Class

OrDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition aggregating several other child conditions and evaluating to true if at least one child condition evaluates to true.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OrDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.OrDependencyCondition

See Also

OrDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


OrDependencyCondition Members

[image]

PostSharp 2.0 Documentation
OrDependencyCondition Members
OrDependencyCondition Class Constructors Methods See Also Send Feedback

The OrDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | OrDependencyCondition | Initializes a new OrDependencyCondition.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


OrDependencyCondition Constructor

OrDependencyCondition Constructor
OrDependencyCondition Class See Also Send Feedback
Initializes a new OrDependencyCondition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OrDependencyCondition(
    params AspectDependencyCondition[] conditions
)

Parameters

conditions
Type: array< PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition >[]()[][]
An array of child conditions.

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


OrDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
OrDependencyCondition Methods
OrDependencyCondition Class See Also Send Feedback

The OrDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

OrDependencyCondition..::..FormatCondition Method
OrDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

OrDependencyCondition..::..Match Method
OrDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

OrDependencyCondition..::..ToString Method
OrDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

OrDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ProvideAspectRoleDependency Class

ProvideAspectRoleDependency Class
Members See Also Send Feedback
An AspectDependency representing the fact that a dependency object provides a role.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class ProvideAspectRoleDependency : AspectDependency

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependency
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.ProvideAspectRoleDependency

See Also

ProvideAspectRoleDependency Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ProvideAspectRoleDependency Members

[image]

PostSharp 2.0 Documentation
ProvideAspectRoleDependency Members
ProvideAspectRoleDependency Class Constructors Methods Properties See Also Send Feedback

The ProvideAspectRoleDependency type exposes the following members.

Constructors

 | Name | Description
Public method | ProvideAspectRoleDependency | Initializes a new ProvideAspectRoleDependency.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides AspectDependency..::.ToString()()().)

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency. (Inherited from AspectDependency.)
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship. (Inherited from AspectDependency.)
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error. (Inherited from AspectDependency.)
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member. (Inherited from AspectDependency.)
Public property | Role | Gets the role provided by the dependency object.

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ProvideAspectRoleDependency Constructor

ProvideAspectRoleDependency Constructor
ProvideAspectRoleDependency Class See Also Send Feedback
Initializes a new ProvideAspectRoleDependency.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProvideAspectRoleDependency(
    string role
)

Parameters

role
Type: System..::.String
Role provided by the dependency object.

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ProvideAspectRoleDependency Methods

[image]

PostSharp 2.0 Documentation
ProvideAspectRoleDependency Methods
ProvideAspectRoleDependency Class See Also Send Feedback

The ProvideAspectRoleDependency type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides AspectDependency..::.ToString()()().)

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ToString Method

ProvideAspectRoleDependency..::..ToString Method
ProvideAspectRoleDependency Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


ProvideAspectRoleDependency Properties

[image]

PostSharp 2.0 Documentation
ProvideAspectRoleDependency Properties
ProvideAspectRoleDependency Class See Also Send Feedback

The ProvideAspectRoleDependency type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency. (Inherited from AspectDependency.)
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship. (Inherited from AspectDependency.)
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error. (Inherited from AspectDependency.)
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member. (Inherited from AspectDependency.)
Public property | Role | Gets the role provided by the dependency object.

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Role Property

ProvideAspectRoleDependency..::..Role Property
ProvideAspectRoleDependency Class See Also Send Feedback
Gets the role provided by the dependency object.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Role { get; private set; }

See Also

ProvideAspectRoleDependency Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


TrueDependencyCondition Class

TrueDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition that always evaluates to true.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TrueDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectInfrastructure.Dependencies..::.TrueDependencyCondition

See Also

TrueDependencyCondition Members
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


TrueDependencyCondition Members

[image]

PostSharp 2.0 Documentation
TrueDependencyCondition Members
TrueDependencyCondition Class Constructors Methods See Also Send Feedback

The TrueDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TrueDependencyCondition | Initializes a new instance of the TrueDependencyCondition class

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)

See Also

TrueDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


TrueDependencyCondition Constructor

TrueDependencyCondition Constructor
TrueDependencyCondition Class See Also Send Feedback
Initializes a new instance of the TrueDependencyCondition class

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TrueDependencyCondition()

See Also

TrueDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


TrueDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
TrueDependencyCondition Methods
TrueDependencyCondition Class See Also Send Feedback

The TrueDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)

See Also

TrueDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


FormatCondition Method

TrueDependencyCondition..::..FormatCondition Method
TrueDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

TrueDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


Match Method

TrueDependencyCondition..::..Match Method
TrueDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectInfrastructure.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

TrueDependencyCondition Class
PostSharp.Sdk.AspectInfrastructure.Dependencies Namespace


PostSharp.Sdk.AspectInfrastructure.Events Namespace

PostSharp.Sdk.AspectInfrastructure.Events Namespace
Send Feedback
The PostSharp.Sdk.AspectInfrastructure.Events namespace exposes the events raised by the aspect infrastructure.

Classes

 | Class | Description
Public class | AspectInfrastructureEvents | Exposes events raised by the aspect infrastructure.
Public class | InstanceInitializationEventArgs | Arguments of the event AfterImplementingInstanceInitializer.
Public class | TransformationPipelineEventArgs | Arguments of the events BeforeExecutingTransformationPipeline and AfterExecutingTransformationPipeline/

Interfaces

 | Interface | Description
Public interface | IAspectInfrastructureEventsClient | Interface to be implemented by tasks that need to subscribe to events of AspectInfrastructureEvents. These tasks must be derived from Task and be inserted in the build process.


AspectInfrastructureEvents Class

AspectInfrastructureEvents Class
Members See Also Send Feedback
Exposes events raised by the aspect infrastructure.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectInfrastructureEvents

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure.Events..::.AspectInfrastructureEvents

See Also

AspectInfrastructureEvents Members
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AspectInfrastructureEvents Members

[image]

PostSharp 2.0 Documentation
AspectInfrastructureEvents Members
AspectInfrastructureEvents Class Properties Events See Also Send Feedback

The AspectInfrastructureEvents type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectInfrastructureTask.

Events

 | Name | Description
Public event | AfterExecutingTransformationPipeline | Event raised after a transformation pipeline on a specific element of code has been executed.
Public event | AfterImplementingInstanceInitializer | Event raised after TypeInitializationManager implements instance initializers on a specific type.
Public event | AfterImplementingTransformations | Event raised after all transformations on the module has been implemented.
Public event | AfterImplementingTypeInitializers | Event raised after TypeInitializationManager has implemented all type initializers.
Public event | AfterWeaving | Event raised after weaving by the Weaver has completed.
Public event | BeforeExecutingTransformationPipeline | Event raised before executing a transformation pipeline on a specific element of code.
Public event | BeforeImplementingTransformations | Event raised before implementing transformations on the module.
Public event | BeforeImplementingTypeInitializers | Event raised before TypeInitializationManager starts implementing type initializers.
Public event | BeforeWeaving | Event raised before weaving by the Weaver starts.
Public event | TaskCompleted | Event raised when the AspectInfrastructureTask task is completed.

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AspectInfrastructureEvents Properties

[image]

PostSharp 2.0 Documentation
AspectInfrastructureEvents Properties
AspectInfrastructureEvents Class See Also Send Feedback

The AspectInfrastructureEvents type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectInfrastructureTask.

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


Task Property

AspectInfrastructureEvents..::..Task Property
AspectInfrastructureEvents Class See Also Send Feedback
Gets the parent AspectInfrastructureTask.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask Task { get; private set; }

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AspectInfrastructureEvents Events

[image]

PostSharp 2.0 Documentation
AspectInfrastructureEvents Events
AspectInfrastructureEvents Class See Also Send Feedback

The AspectInfrastructureEvents type exposes the following members.

Events

 | Name | Description
Public event | AfterExecutingTransformationPipeline | Event raised after a transformation pipeline on a specific element of code has been executed.
Public event | AfterImplementingInstanceInitializer | Event raised after TypeInitializationManager implements instance initializers on a specific type.
Public event | AfterImplementingTransformations | Event raised after all transformations on the module has been implemented.
Public event | AfterImplementingTypeInitializers | Event raised after TypeInitializationManager has implemented all type initializers.
Public event | AfterWeaving | Event raised after weaving by the Weaver has completed.
Public event | BeforeExecutingTransformationPipeline | Event raised before executing a transformation pipeline on a specific element of code.
Public event | BeforeImplementingTransformations | Event raised before implementing transformations on the module.
Public event | BeforeImplementingTypeInitializers | Event raised before TypeInitializationManager starts implementing type initializers.
Public event | BeforeWeaving | Event raised before weaving by the Weaver starts.
Public event | TaskCompleted | Event raised when the AspectInfrastructureTask task is completed.

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AfterExecutingTransformationPipeline Event

AspectInfrastructureEvents..::..AfterExecutingTransformationPipeline Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised after a transformation pipeline on a specific element of code has been executed.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<TransformationPipelineEventArgs> AfterExecutingTransformationPipeline

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AfterImplementingInstanceInitializer Event

AspectInfrastructureEvents..::..AfterImplementingInstanceInitializer Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised after TypeInitializationManager implements instance initializers on a specific type.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<InstanceInitializationEventArgs> AfterImplementingInstanceInitializer

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AfterImplementingTransformations Event

AspectInfrastructureEvents..::..AfterImplementingTransformations Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised after all transformations on the module has been implemented.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler AfterImplementingTransformations

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AfterImplementingTypeInitializers Event

AspectInfrastructureEvents..::..AfterImplementingTypeInitializers Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised after TypeInitializationManager has implemented all type initializers.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler AfterImplementingTypeInitializers

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


AfterWeaving Event

AspectInfrastructureEvents..::..AfterWeaving Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised after weaving by the Weaver has completed.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler AfterWeaving

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


BeforeExecutingTransformationPipeline Event

AspectInfrastructureEvents..::..BeforeExecutingTransformationPipeline Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised before executing a transformation pipeline on a specific element of code.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<TransformationPipelineEventArgs> BeforeExecutingTransformationPipeline

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


BeforeImplementingTransformations Event

AspectInfrastructureEvents..::..BeforeImplementingTransformations Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised before implementing transformations on the module.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler BeforeImplementingTransformations

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


BeforeImplementingTypeInitializers Event

AspectInfrastructureEvents..::..BeforeImplementingTypeInitializers Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised before TypeInitializationManager starts implementing type initializers.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler BeforeImplementingTypeInitializers

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


BeforeWeaving Event

AspectInfrastructureEvents..::..BeforeWeaving Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised before weaving by the Weaver starts.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler BeforeWeaving

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


TaskCompleted Event

AspectInfrastructureEvents..::..TaskCompleted Event
AspectInfrastructureEvents Class See Also Send Feedback
Event raised when the AspectInfrastructureTask task is completed.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event CancelEventHandler TaskCompleted

See Also

AspectInfrastructureEvents Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


IAspectInfrastructureEventsClient Interface

IAspectInfrastructureEventsClient Interface
Members See Also Send Feedback
Interface to be implemented by tasks that need to subscribe to events of AspectInfrastructureEvents. These tasks must be derived from Task and be inserted in the build process.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspectInfrastructureEventsClient

See Also

IAspectInfrastructureEventsClient Members
PostSharp.Sdk.AspectInfrastructure.Events Namespace


IAspectInfrastructureEventsClient Members

[image]

PostSharp 2.0 Documentation
IAspectInfrastructureEventsClient Members
IAspectInfrastructureEventsClient Interface Methods See Also Send Feedback

The IAspectInfrastructureEventsClient type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes the current client.

See Also

IAspectInfrastructureEventsClient Interface
PostSharp.Sdk.AspectInfrastructure.Events Namespace


IAspectInfrastructureEventsClient Methods

[image]

PostSharp 2.0 Documentation
IAspectInfrastructureEventsClient Methods
IAspectInfrastructureEventsClient Interface See Also Send Feedback

The IAspectInfrastructureEventsClient type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Initializes the current client.

See Also

IAspectInfrastructureEventsClient Interface
PostSharp.Sdk.AspectInfrastructure.Events Namespace


Initialize Method

IAspectInfrastructureEventsClient..::..Initialize Method
IAspectInfrastructureEventsClient Interface See Also Send Feedback
Initializes the current client.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Initialize(
    AspectInfrastructureEvents events
)

Parameters

events
Type: PostSharp.Sdk.AspectInfrastructure.Events..::.AspectInfrastructureEvents
An object exposing the events that can be subscribed to.

See Also

IAspectInfrastructureEventsClient Interface
PostSharp.Sdk.AspectInfrastructure.Events Namespace


InstanceInitializationEventArgs Class

InstanceInitializationEventArgs Class
Members See Also Send Feedback
Arguments of the event AfterImplementingInstanceInitializer.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstanceInitializationEventArgs : CancelEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
PostSharp.Sdk.AspectInfrastructure.Events..::.InstanceInitializationEventArgs

See Also

InstanceInitializationEventArgs Members
PostSharp.Sdk.AspectInfrastructure.Events Namespace


InstanceInitializationEventArgs Members

[image]

PostSharp 2.0 Documentation
InstanceInitializationEventArgs Members
InstanceInitializationEventArgs Class Properties See Also Send Feedback

The InstanceInitializationEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | PrivateInitializationMethod | Gets the private Initialize method.
Public property | ProtectedInitializationMethod | Gets the protected Initialize method.
Public property | Type | Gets the type whose instance initializer has just been implemented by the TypeInitializationManager.

See Also

InstanceInitializationEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


InstanceInitializationEventArgs Properties

[image]

PostSharp 2.0 Documentation
InstanceInitializationEventArgs Properties
InstanceInitializationEventArgs Class See Also Send Feedback

The InstanceInitializationEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | PrivateInitializationMethod | Gets the private Initialize method.
Public property | ProtectedInitializationMethod | Gets the protected Initialize method.
Public property | Type | Gets the type whose instance initializer has just been implemented by the TypeInitializationManager.

See Also

InstanceInitializationEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


PrivateInitializationMethod Property

InstanceInitializationEventArgs..::..PrivateInitializationMethod Property
InstanceInitializationEventArgs Class See Also Send Feedback
Gets the private Initialize method.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration PrivateInitializationMethod { get; private set; }

See Also

InstanceInitializationEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


ProtectedInitializationMethod Property

InstanceInitializationEventArgs..::..ProtectedInitializationMethod Property
InstanceInitializationEventArgs Class See Also Send Feedback
Gets the protected Initialize method.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration ProtectedInitializationMethod { get; private set; }

See Also

InstanceInitializationEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


Type Property

InstanceInitializationEventArgs..::..Type Property
InstanceInitializationEventArgs Class See Also Send Feedback
Gets the type whose instance initializer has just been implemented by the TypeInitializationManager.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration Type { get; }

See Also

InstanceInitializationEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


TransformationPipelineEventArgs Class

TransformationPipelineEventArgs Class
Members See Also Send Feedback
Arguments of the events BeforeExecutingTransformationPipeline and AfterExecutingTransformationPipeline/

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TransformationPipelineEventArgs : CancelEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
PostSharp.Sdk.AspectInfrastructure.Events..::.TransformationPipelineEventArgs

See Also

TransformationPipelineEventArgs Members
PostSharp.Sdk.AspectInfrastructure.Events Namespace


TransformationPipelineEventArgs Members

[image]

PostSharp 2.0 Documentation
TransformationPipelineEventArgs Members
TransformationPipelineEventArgs Class Properties See Also Send Feedback

The TransformationPipelineEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | TargetElement | Gets the element of code on which the pipeline is executed.

See Also

TransformationPipelineEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


TransformationPipelineEventArgs Properties

[image]

PostSharp 2.0 Documentation
TransformationPipelineEventArgs Properties
TransformationPipelineEventArgs Class See Also Send Feedback

The TransformationPipelineEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | TargetElement | Gets the element of code on which the pipeline is executed.

See Also

TransformationPipelineEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


TargetElement Property

TransformationPipelineEventArgs..::..TargetElement Property
TransformationPipelineEventArgs Class See Also Send Feedback
Gets the element of code on which the pipeline is executed.

Namespace: PostSharp.Sdk.AspectInfrastructure.Events
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; private set; }

See Also

TransformationPipelineEventArgs Class
PostSharp.Sdk.AspectInfrastructure.Events Namespace


PostSharp.Sdk.AspectWeaver Namespace

PostSharp.Sdk.AspectWeaver Namespace
Send Feedback
The PostSharp.Sdk.AspectWeaver namespace is an abstract implementation of the aspect framework defined in PostSharp.Aspects. The aspect framework defines the concepts of aspect, advice, and pointcut.

Classes

 | Class | Description
Public class | AdviceAnalyzer | Default implementation of IAdviceAnalyzer.
Public class | AdviceAnalyzerFlags | Encapsulates static information about a specific type of AdviceAnalyzer, such as the value of flags.
Public class | AdviceArgsBuilder | Emits instructions that build objects derived from AdviceArgs.
Public class | AdviceGroup | Represents a group of advices. Information encapsulated in this class do not depend on how the aspect is being used. All advices, including those represented by custom attributes that do not derive from GroupingAdvice, exist in an AdviceGroup. In this case, the group contains a single advice.
Public class | AdviceGroupingKey | Determines how an advice annotation should be mapped to an AdviceGroup. Result of the method GetGroupingKey(IAnnotationInstance).
Public class | AdviceWeaver | An object that knows how to process a specific advice. Advice weavers must be associated to advice custom attributes using BindAdviceWeaver<(Of <(TAttribute, TImpl>)>)()()(). An AdviceWeaver is associated with a concrete advice type and is independent from advice usage, i.e. independent from the AspectWeaverInstance.
Public class | AspectDependencyAttributeInfo | Encapsulates a parsed AspectDependencyAttributeInfo.
Public class | AspectDependencyAttributeParser | Base implementation of IAspectDependencyAttributeParser.
Public class | AspectInstanceInfo | Stores an AspectSpecification and its target MetadataDeclaration.
Public class | AspectRuntimeInstanceField | Encapsulates the field storing the runtime aspect instance.
Public class | AspectWeaver | An object that knows how to process a specific aspect. Aspect weavers must be associated to aspect interfaces (derived from IAspect using BindAspectWeaver<(Of <(TAspect, TImpl>)>)()()(). An AspectWeaver is associated with an aspect type and is independent from aspect usage, which is encapsulated by AspectWeaverInstance.
Public class | AspectWeaverInstance | Extension of the AspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | AspectWeaverPlugIn | Base class for plug-ins of the aspect framework; exposes methods that allow plug-ins to bind interface types to implementation classes.
Protected class | AspectWeaverPlugIn..::.StandardPriorities | Standard priorities of plug-ins.
Public class | AspectWeaverTask | Principal Task implementing the aspect framework.
Public class | AspectWeaverTransformation | Static information about a transformation provided by an AspectWeaver or an AdviceWeaver, independent from the element of code to which the aspect has been applied.
Public class | AspectWeaverTransformationAdder | Object allowing to implementations of AspectWeaver or AdviceGroup to provide their transformations to the aspect framework.
Public class | AspectWeaverTransformationInstance | Extension of the AspectWeaverTransformation class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.
Public class | EventInterceptionAdviceArgsBuilder | Implementation of MethodExecutionAdviceArgsBuilder able to emit instructions that build objects of type EventInterceptionArgs.
Public class | GroupingAdviceWeaver | An AdviceWeaver for use with advice custom attributes derived from GroupingAdvice.
Public class | InterceptionAdviceArgsBuilder | Implementation of AdviceArgsBuilder that can emit instructions to create objects MethodInterceptionArgs, LocationInterceptionArgs or EventInterceptionArgs.
Public class | LocationInterceptionAdviceArgsBuilder | Implementation of AdviceArgsBuilder that can emit instructions to create objects of type LocationInterceptionArgs or EventInterceptionArgs.
Public class | MethodBodyWrappingImplementation | Makes it easier to implement transformations (IMethodBodyTransformationInstance) that wrap the method body with advices such as OnEntry, OnSuccess, OnExit and OnException.
Public class | MethodExecutionAdviceArgsBuilder | Implementation of AdviceArgsBuilder that can emit instructions to create objects of type MethodExecutionArgs.
Public class | MethodInterceptionAdviceArgsBuilder | Implementation of AdviceArgsBuilder that can emit instructions to create objects of type MethodInterceptionArgs.
Public class | PointcutAwareAdviceGroup | An AdviceGroup where the master advice must be annotated with a Pointcut.
Public class | ReflectionObjectBuilder | Base for classes able to emit instructions that load reflection objects (such as Type, MethodBase, FieldInfo, ... ).

Interfaces

 | Interface | Description
Public interface | IAdviceAnalyzer | Defines the semantics of an advice analyzer, which should analyze the implementation of advices and figure out which optimizations can be applied.
Public interface | IAspectDependencyAttributeParser | Defines the semantics of a parser of custom attributes representing custom attributes. The parser must create instances of AspectDependency based on custom attributes derived from AspectDependencyAttribute.
Public interface | IPointcutEngine | Defines the semantics of a pointcut engine. Pointcut engines evaluate pointcuts.

Delegates

 | Delegate | Description
Public delegate | ConfigurationGetter<(Of <(?0, ?1>)>) | Delegate definition for methods that retrieve the value of some property of a AspectConfiguration.


AdviceAnalyzer Class

AdviceAnalyzer Class
Members See Also Send Feedback
Default implementation of IAdviceAnalyzer.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AdviceAnalyzer : IAdviceAnalyzer

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceAnalyzer

See Also

AdviceAnalyzer Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzer Members

[image]

PostSharp 2.0 Documentation
AdviceAnalyzer Members
AdviceAnalyzer Class Constructors Methods Properties See Also Send Feedback

The AdviceAnalyzer type exposes the following members.

Constructors

 | Name | Description
Protected method | AdviceAnalyzer | Initializes a new AdviceAnalyzer.

Methods

 | Name | Description
Public method | Analyze | Analyzes an advice method and store the result in a custom attribute if the member is public.
 | CheckMethodSealed | Emits a warning if the advice method is not sealed.
 | GetCachedOptimizations | Gets optimization flags that have been previously cached, either because the method has previously been analyzed in the current session, either because optimization flags are stored in a custom attribute.
Public method | Initialize | Overloaded.

Properties

 | Name | Description
Protected property | MethodExecutionLookups | A dictionary mapping a method to an optimization flag. When a call to this method is detected in the advice, the corresponding optimization flag is set (i.e. the optimization is disabled).

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzer Constructor

AdviceAnalyzer Constructor
AdviceAnalyzer Class See Also Send Feedback
Initializes a new AdviceAnalyzer.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AdviceAnalyzer(
    AdviceAnalyzerFlags flags
)

Parameters

flags
Type: PostSharp.Sdk.AspectWeaver..::.AdviceAnalyzerFlags
Value of advice optimization flags.

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzer Methods

[image]

PostSharp 2.0 Documentation
AdviceAnalyzer Methods
AdviceAnalyzer Class See Also Send Feedback

The AdviceAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Analyze | Analyzes an advice method and store the result in a custom attribute if the member is public.
 | CheckMethodSealed | Emits a warning if the advice method is not sealed.
 | GetCachedOptimizations | Gets optimization flags that have been previously cached, either because the method has previously been analyzed in the current session, either because optimization flags are stored in a custom attribute.
Public method | Initialize | Overloaded.

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


Analyze Method

AdviceAnalyzer..::..Analyze Method
AdviceAnalyzer Class See Also Send Feedback
Analyzes an advice method and store the result in a custom attribute if the member is public.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void Analyze(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method to be analyzed.

Implements

IAdviceAnalyzer..::.Analyze(MethodDefDeclaration)

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


CheckMethodSealed Method

AdviceAnalyzer..::..CheckMethodSealed Method
AdviceAnalyzer Class See Also Send Feedback
Emits a warning if the advice method is not sealed.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected static void CheckMethodSealed(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method.

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


GetCachedOptimizations Method

AdviceAnalyzer..::..GetCachedOptimizations Method
AdviceAnalyzer Class See Also Send Feedback
Gets optimization flags that have been previously cached, either because the method has previously been analyzed in the current session, either because optimization flags are stored in a custom attribute.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Nullable<long> GetCachedOptimizations(
    MethodDefDeclaration method,
    Type customAttributeType,
    bool warning
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method.
customAttributeType
Type: System..::.Type
The type of the custom attribute that can store optimization flags.
warning
Type: System..::.Boolean
true if a warning should be emitted if optimization flags could not be found, otherwise true.

Return Value

Cached optimization flags, or null if no optimization flags were cached.

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

[image]

PostSharp 2.0 Documentation
AdviceAnalyzer..::..Initialize Method
AdviceAnalyzer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Initialize(ModuleDeclaration) | Initializes the current AdviceAnalyzer. Implementations of this method must call Initialize(ModuleDeclaration, IMethod, SerializationType). They typically populate the dictionary MethodExecutionLookups.
Protected method | Initialize(ModuleDeclaration, IMethod, SerializationType) | Initializes the current AdviceAnalyzer. This method must be invoked by implementations of Initialize(ModuleDeclaration).

See Also

AdviceAnalyzer Class
AdviceAnalyzer Members
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method (ModuleDeclaration)

AdviceAnalyzer..::..Initialize Method (ModuleDeclaration)
AdviceAnalyzer Class See Also Send Feedback
Initializes the current AdviceAnalyzer. Implementations of this method must call Initialize(ModuleDeclaration, IMethod, SerializationType). They typically populate the dictionary MethodExecutionLookups.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void Initialize(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which advices have to be initialized.

Implements

IAdviceAnalyzer..::.Initialize(ModuleDeclaration)

See Also

AdviceAnalyzer Class
Initialize Overload
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method (ModuleDeclaration, IMethod, SerializationType)

AdviceAnalyzer..::..Initialize Method (ModuleDeclaration, IMethod, SerializationType)
AdviceAnalyzer Class See Also Send Feedback
Initializes the current AdviceAnalyzer. This method must be invoked by implementations of Initialize(ModuleDeclaration).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void Initialize(
    ModuleDeclaration module,
    IMethod optimizationAttributeConstructor,
    SerializationType optimizationSerializationType
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which advices have to be initialized.
optimizationAttributeConstructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Constructor of the specific custom attribute derived from AdviceOptimizationAttribute.
optimizationSerializationType
Type: PostSharp.Sdk.CodeModel..::.SerializationType
Serialization type of the first parameter of optimizationAttributeConstructor.

See Also

AdviceAnalyzer Class
Initialize Overload
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzer Properties

[image]

PostSharp 2.0 Documentation
AdviceAnalyzer Properties
AdviceAnalyzer Class See Also Send Feedback

The AdviceAnalyzer type exposes the following members.

Properties

 | Name | Description
Protected property | MethodExecutionLookups | A dictionary mapping a method to an optimization flag. When a call to this method is detected in the advice, the corresponding optimization flag is set (i.e. the optimization is disabled).

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionLookups Property

AdviceAnalyzer..::..MethodExecutionLookups Property
AdviceAnalyzer Class See Also Send Feedback
A dictionary mapping a method to an optimization flag. When a call to this method is detected in the advice, the corresponding optimization flag is set (i.e. the optimization is disabled).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Dictionary<IMethod, long> MethodExecutionLookups { get; }

See Also

AdviceAnalyzer Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzerFlags Class

AdviceAnalyzerFlags Class
Members See Also Send Feedback
Encapsulates static information about a specific type of AdviceAnalyzer, such as the value of flags.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AdviceAnalyzerFlags

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceAnalyzerFlags

See Also

AdviceAnalyzerFlags Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzerFlags Members

[image]

PostSharp 2.0 Documentation
AdviceAnalyzerFlags Members
AdviceAnalyzerFlags Class Constructors Methods Properties See Also Send Feedback

The AdviceAnalyzerFlags type exposes the following members.

Constructors

 | Name | Description
Public method | AdviceAnalyzerFlags | Initializes a new AdviceAnalyzerFlags.

Methods

 | Name | Description
Public method | GetOptimizations | Overloaded.

Properties

 | Name | Description
Public property | CheckMethodSealed | Determines whether a warning should be emitted if the advice method is not sealed.
Public property | CustomAttributeType | Type of custom attribute (derived from AdviceOptimizationAttribute) storing optimization flags.
Public property | IgnoreAdviceArgsFlag | A value where a single bit is set, representing the fact that the AdviceArgs argument is used.
Public property | IgnoreAdviceFlag | A value where a single bit is set, representing the fact that the advice is empty and can safely be ignored.
Public property | IgnoreAllAdviceArgsMembersFlags | A bit mask where all bits representing access to members of AdviceArgs (or derived classes) are set.
Public property | IgnoreAllFlags | A bit mask where all meaningful bits are set.

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzerFlags Constructor

AdviceAnalyzerFlags Constructor
AdviceAnalyzerFlags Class See Also Send Feedback
Initializes a new AdviceAnalyzerFlags.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceAnalyzerFlags(
    long ignoreAllAdviceArgsMembersFlags,
    long ignoreAdviceArgsFlag,
    long ignoreAllFlags,
    long ignoreAdviceFlag,
    Type customAttributeType
)

Parameters

ignoreAllAdviceArgsMembersFlags
Type: System..::.Int64
A bit mask where all bits representing access to members of AdviceArgs (or derived classes) are set.
ignoreAdviceArgsFlag
Type: System..::.Int64
A value where a single bit is set, representing the fact that the AdviceArgs argument is used.
ignoreAllFlags
Type: System..::.Int64
A bit mask where all meaningful bits are set.
ignoreAdviceFlag
Type: System..::.Int64
A value where a single bit is set, representing the fact that the advice is empty and can safely be ignored.
customAttributeType
Type: System..::.Type
Type of custom attribute (derived from AdviceOptimizationAttribute) storing optimization flags.

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzerFlags Methods

[image]

PostSharp 2.0 Documentation
AdviceAnalyzerFlags Methods
AdviceAnalyzerFlags Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetOptimizations | Overloaded.

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


GetOptimizations Method

[image]

PostSharp 2.0 Documentation
AdviceAnalyzerFlags..::..GetOptimizations Method
AdviceAnalyzerFlags Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOptimizations(MethodDefDeclaration) | Gets optimization flags of a method, and emits a warning if optimizations flags for this method are not present or cannot be computed.
Public method | GetOptimizations(MethodDefDeclaration, Boolean) | Gets optimization flags of a method.

See Also

AdviceAnalyzerFlags Class
AdviceAnalyzerFlags Members
PostSharp.Sdk.AspectWeaver Namespace


GetOptimizations Method (MethodDefDeclaration)

AdviceAnalyzerFlags..::..GetOptimizations Method (MethodDefDeclaration)
AdviceAnalyzerFlags Class See Also Send Feedback
Gets optimization flags of a method, and emits a warning if optimizations flags for this method are not present or cannot be computed.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long GetOptimizations(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method.

Return Value

Optimization flags for method, or 0 if optimizations flags for this method are not present or cannot be computed.

See Also

AdviceAnalyzerFlags Class
GetOptimizations Overload
PostSharp.Sdk.AspectWeaver Namespace


GetOptimizations Method (MethodDefDeclaration, Boolean)

AdviceAnalyzerFlags..::..GetOptimizations Method (MethodDefDeclaration, Boolean)
AdviceAnalyzerFlags Class See Also Send Feedback
Gets optimization flags of a method.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<long> GetOptimizations(
    MethodDefDeclaration method,
    bool warning
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method.
warning
Type: System..::.Boolean
true to emit a warning if optimizations flags for this method are not present or cannot be computed, false otherwise.

Return Value

Optimization flags for method, or null if optimizations flags for this method are not present or cannot be computed.

See Also

AdviceAnalyzerFlags Class
GetOptimizations Overload
PostSharp.Sdk.AspectWeaver Namespace


AdviceAnalyzerFlags Properties

[image]

PostSharp 2.0 Documentation
AdviceAnalyzerFlags Properties
AdviceAnalyzerFlags Class See Also Send Feedback

The AdviceAnalyzerFlags type exposes the following members.

Properties

 | Name | Description
Public property | CheckMethodSealed | Determines whether a warning should be emitted if the advice method is not sealed.
Public property | CustomAttributeType | Type of custom attribute (derived from AdviceOptimizationAttribute) storing optimization flags.
Public property | IgnoreAdviceArgsFlag | A value where a single bit is set, representing the fact that the AdviceArgs argument is used.
Public property | IgnoreAdviceFlag | A value where a single bit is set, representing the fact that the advice is empty and can safely be ignored.
Public property | IgnoreAllAdviceArgsMembersFlags | A bit mask where all bits representing access to members of AdviceArgs (or derived classes) are set.
Public property | IgnoreAllFlags | A bit mask where all meaningful bits are set.

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


CheckMethodSealed Property

AdviceAnalyzerFlags..::..CheckMethodSealed Property
AdviceAnalyzerFlags Class See Also Send Feedback
Determines whether a warning should be emitted if the advice method is not sealed.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CheckMethodSealed { get; set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


CustomAttributeType Property

AdviceAnalyzerFlags..::..CustomAttributeType Property
AdviceAnalyzerFlags Class See Also Send Feedback
Type of custom attribute (derived from AdviceOptimizationAttribute) storing optimization flags.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type CustomAttributeType { get; private set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


IgnoreAdviceArgsFlag Property

AdviceAnalyzerFlags..::..IgnoreAdviceArgsFlag Property
AdviceAnalyzerFlags Class See Also Send Feedback
A value where a single bit is set, representing the fact that the AdviceArgs argument is used.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long IgnoreAdviceArgsFlag { get; private set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


IgnoreAdviceFlag Property

AdviceAnalyzerFlags..::..IgnoreAdviceFlag Property
AdviceAnalyzerFlags Class See Also Send Feedback
A value where a single bit is set, representing the fact that the advice is empty and can safely be ignored.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long IgnoreAdviceFlag { get; private set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


IgnoreAllAdviceArgsMembersFlags Property

AdviceAnalyzerFlags..::..IgnoreAllAdviceArgsMembersFlags Property
AdviceAnalyzerFlags Class See Also Send Feedback
A bit mask where all bits representing access to members of AdviceArgs (or derived classes) are set.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long IgnoreAllAdviceArgsMembersFlags { get; private set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


IgnoreAllFlags Property

AdviceAnalyzerFlags..::..IgnoreAllFlags Property
AdviceAnalyzerFlags Class See Also Send Feedback
A bit mask where all meaningful bits are set.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long IgnoreAllFlags { get; private set; }

See Also

AdviceAnalyzerFlags Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceArgsBuilder Class

AdviceArgsBuilder Class
Members See Also Send Feedback
Emits instructions that build objects derived from AdviceArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.InterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.MethodExecutionAdviceArgsBuilder

See Also

AdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
AdviceArgsBuilder Members
AdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The AdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | AdviceArgsBuilder | Initializes a new AdviceArgsBuilder.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs.
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceArgsBuilder Constructor

AdviceArgsBuilder Constructor
AdviceArgsBuilder Class See Also Send Feedback
Initializes a new AdviceArgsBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AdviceArgsBuilder(
    AspectWeaverTask task,
    ReflectionObjectBuilder reflectionObjectBuilder
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
Parent AspectWeaverTask.
reflectionObjectBuilder
Type: PostSharp.Sdk.AspectWeaver..::.ReflectionObjectBuilder
The ReflectionObjectBuilder that emits instructions to load the reflection object associated with the specific AdviceArgs.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
AdviceArgsBuilder Methods
AdviceArgsBuilder Class See Also Send Feedback

The AdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs.
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitLoadReflectionObject Method

AdviceArgsBuilder..::..EmitLoadReflectionObject Method
AdviceArgsBuilder Class See Also Send Feedback
Emits instructions that load the reflection object associated with the AdviceArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadReflectionObject(
    AspectWeaverInstance aspectWeaverInstance,
    MetadataDeclaration declaration,
    IType declaringType,
    InstructionWriter writer
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which the reflection object is loaded.
declaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The declaration whose reflection object should be loaded.
declaringType
Type: PostSharp.Sdk.CodeModel..::.IType
The declaring type of declaration. This parameter must always be specified if declaration is a type member. In case of a method or a field, the declaringType is trivial; however, there is no other way to refer to a property or event of a generic type instance than by specifying the declaring type explicitly.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitSetInstanceCredentials Method

AdviceArgsBuilder..::..EmitSetInstanceCredentials Method
AdviceArgsBuilder Class See Also Send Feedback
Emits instructions that set the InstanceCredentials property.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitSetInstanceCredentials(
    MethodMappingWriter methodMappingWriter,
    InstructionWriter instructionWriter,
    LocalVariableSymbol adviceArgsLocal
)

Parameters

methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
A MethodMappingWriter.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An MethodMappingWriter.
adviceArgsLocal
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
A local variable containing the AdviceArgs.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
AdviceArgsBuilder Properties
AdviceArgsBuilder Class See Also Send Feedback

The AdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask.

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


Task Property

AdviceArgsBuilder..::..Task Property
AdviceArgsBuilder Class See Also Send Feedback
Gets the parent AspectWeaverTask.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverTask Task { get; private set; }

See Also

AdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroup Class

AdviceGroup Class
Members See Also Send Feedback
Represents a group of advices. Information encapsulated in this class do not depend on how the aspect is being used. All advices, including those represented by custom attributes that do not derive from GroupingAdvice, exist in an AdviceGroup. In this case, the group contains a single advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AdviceGroup

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceGroup
PostSharp.Sdk.AspectWeaver..::.PointcutAwareAdviceGroup

See Also

AdviceGroup Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroup Members

[image]

PostSharp 2.0 Documentation
AdviceGroup Members
AdviceGroup Class Constructors Methods Properties See Also Send Feedback

The AdviceGroup type exposes the following members.

Constructors

 | Name | Description
Protected method | AdviceGroup | Initializes a new AdviceGroup.

Methods

 | Name | Description
Protected method | Initialize | Initializes the current AdviceGroup. This method is invoked after the object has been fully set up.
Protected method | PrepareTransformation | Prepares an AspectWeaverTransformation for use with the current AdviceGroup by adding relevant dependencies to the transformation.
Public method | ProvideTransformations | Provides the transformation instances necessary to implement the current AdviceGroup.

Properties

 | Name | Description
Public property | AdviceWeaver | Gets the parent AdviceWeaver.
Public property | Annotations | Gets the collection of annotations (custom attributes) in the current AdviceGroup.
Public property | Dependencies | Gets the collection of dependencies of the current AdviceGroup.
Public property | GroupKey | Gets the key of the current AdviceGroup.
Public property | MasterAnnotation | Gets the master annotation (custom attribute) of the current, i.e. the one where the Master property is set.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroup Constructor

AdviceGroup Constructor
AdviceGroup Class See Also Send Feedback
Initializes a new AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AdviceGroup(
    AdviceWeaver parent
)

Parameters

parent
Type: PostSharp.Sdk.AspectWeaver..::.AdviceWeaver
The parent AdviceWeaver.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroup Methods

[image]

PostSharp 2.0 Documentation
AdviceGroup Methods
AdviceGroup Class See Also Send Feedback

The AdviceGroup type exposes the following members.

Methods

 | Name | Description
Protected method | Initialize | Initializes the current AdviceGroup. This method is invoked after the object has been fully set up.
Protected method | PrepareTransformation | Prepares an AspectWeaverTransformation for use with the current AdviceGroup by adding relevant dependencies to the transformation.
Public method | ProvideTransformations | Provides the transformation instances necessary to implement the current AdviceGroup.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

AdviceGroup..::..Initialize Method
AdviceGroup Class See Also Send Feedback
Initializes the current AdviceGroup. This method is invoked after the object has been fully set up.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Initialize()

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


PrepareTransformation Method

AdviceGroup..::..PrepareTransformation Method
AdviceGroup Class See Also Send Feedback
Prepares an AspectWeaverTransformation for use with the current AdviceGroup by adding relevant dependencies to the transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void PrepareTransformation(
    AspectWeaverTransformation transformation
)

Parameters

transformation
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
The AspectWeaverTransformation to be prepared.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


ProvideTransformations Method

AdviceGroup..::..ProvideTransformations Method
AdviceGroup Class See Also Send Feedback
Provides the transformation instances necessary to implement the current AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProvideTransformations(
    AspectWeaverInstance aspectWeaverInstance,
    AspectWeaverTransformationAdder adder
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which transformations are collected.
adder
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder
The AspectWeaverTransformationAdder to used to add transformations.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroup Properties

[image]

PostSharp 2.0 Documentation
AdviceGroup Properties
AdviceGroup Class See Also Send Feedback

The AdviceGroup type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeaver | Gets the parent AdviceWeaver.
Public property | Annotations | Gets the collection of annotations (custom attributes) in the current AdviceGroup.
Public property | Dependencies | Gets the collection of dependencies of the current AdviceGroup.
Public property | GroupKey | Gets the key of the current AdviceGroup.
Public property | MasterAnnotation | Gets the master annotation (custom attribute) of the current, i.e. the one where the Master property is set.

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Property

AdviceGroup..::..AdviceWeaver Property
AdviceGroup Class See Also Send Feedback
Gets the parent AdviceWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceWeaver AdviceWeaver { get; private set; }

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


Annotations Property

AdviceGroup..::..Annotations Property
AdviceGroup Class See Also Send Feedback
Gets the collection of annotations (custom attributes) in the current AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<IAnnotationInstance> Annotations { get; }

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


Dependencies Property

AdviceGroup..::..Dependencies Property
AdviceGroup Class See Also Send Feedback
Gets the collection of dependencies of the current AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection Dependencies { get; }

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


GroupKey Property

AdviceGroup..::..GroupKey Property
AdviceGroup Class See Also Send Feedback
Gets the key of the current AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GroupKey { get; private set; }

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


MasterAnnotation Property

AdviceGroup..::..MasterAnnotation Property
AdviceGroup Class See Also Send Feedback
Gets the master annotation (custom attribute) of the current, i.e. the one where the Master property is set.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationInstance MasterAnnotation { get; internal set; }

See Also

AdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroupingKey Class

AdviceGroupingKey Class
Members See Also Send Feedback
Determines how an advice annotation should be mapped to an AdviceGroup. Result of the method GetGroupingKey(IAnnotationInstance).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AdviceGroupingKey

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceGroupingKey

See Also

AdviceGroupingKey Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroupingKey Members

[image]

PostSharp 2.0 Documentation
AdviceGroupingKey Members
AdviceGroupingKey Class Constructors Properties See Also Send Feedback

The AdviceGroupingKey type exposes the following members.

Constructors

 | Name | Description
Public method | AdviceGroupingKey | Initializes a new AdviceGroupingKey.

Properties

 | Name | Description
Public property | IsMaster | Determines whether the advice is the master of its AdviceGroup. There can be a single master per AdviceGroup.
Public property | Key | Gets the grouping key.

See Also

AdviceGroupingKey Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroupingKey Constructor

AdviceGroupingKey Constructor
AdviceGroupingKey Class See Also Send Feedback
Initializes a new AdviceGroupingKey.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AdviceGroupingKey(
    string key,
    bool isMaster
)

Parameters

key
Type: System..::.String
The grouping key. Advices with the same key are grouped into the same AdviceGroup. null is equivalent to an empty string.
isMaster
Type: System..::.Boolean
true if the advice is the master of its group, otherwise false. There can be a single master per group.

See Also

AdviceGroupingKey Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceGroupingKey Properties

[image]

PostSharp 2.0 Documentation
AdviceGroupingKey Properties
AdviceGroupingKey Class See Also Send Feedback

The AdviceGroupingKey type exposes the following members.

Properties

 | Name | Description
Public property | IsMaster | Determines whether the advice is the master of its AdviceGroup. There can be a single master per AdviceGroup.
Public property | Key | Gets the grouping key.

See Also

AdviceGroupingKey Class
PostSharp.Sdk.AspectWeaver Namespace


IsMaster Property

AdviceGroupingKey..::..IsMaster Property
AdviceGroupingKey Class See Also Send Feedback
Determines whether the advice is the master of its AdviceGroup. There can be a single master per AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMaster { get; private set; }

See Also

AdviceGroupingKey Class
PostSharp.Sdk.AspectWeaver Namespace


Key Property

AdviceGroupingKey..::..Key Property
AdviceGroupingKey Class See Also Send Feedback
Gets the grouping key.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Key { get; private set; }

Remarks

Advices with the same key are grouped into the same AdviceGroup. null is equivalent to an empty string.

See Also

AdviceGroupingKey Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Class

AdviceWeaver Class
Members See Also Send Feedback
An object that knows how to process a specific advice. Advice weavers must be associated to advice custom attributes using BindAdviceWeaver<(Of <(TAttribute, TImpl>)>)()()(). An AdviceWeaver is associated with a concrete advice type and is independent from advice usage, i.e. independent from the AspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AdviceWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceWeaver
PostSharp.Sdk.AspectWeaver..::.GroupingAdviceWeaver

See Also

AdviceWeaver Members
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Members

[image]

PostSharp 2.0 Documentation
AdviceWeaver Members
AdviceWeaver Class Constructors Methods Properties See Also Send Feedback

The AdviceWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | AdviceWeaver | Initializes a new instance of the AdviceWeaver class

Methods

 | Name | Description
Protected method | CreateAdviceGroup | Creates an empty AdviceGroup where advices handled by the current AdviceWeaver will be added.
Protected method | GetGroupingKey | Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup.
Protected method | Initialize | Initializes the current AdviceWeaver.
Public method | ValidateAdvice | Validates an advice annotation.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Constructor

AdviceWeaver Constructor
AdviceWeaver Class See Also Send Feedback
Initializes a new instance of the AdviceWeaver class

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AdviceWeaver()

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Methods

[image]

PostSharp 2.0 Documentation
AdviceWeaver Methods
AdviceWeaver Class See Also Send Feedback

The AdviceWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | CreateAdviceGroup | Creates an empty AdviceGroup where advices handled by the current AdviceWeaver will be added.
Protected method | GetGroupingKey | Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup.
Protected method | Initialize | Initializes the current AdviceWeaver.
Public method | ValidateAdvice | Validates an advice annotation.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


CreateAdviceGroup Method

AdviceWeaver..::..CreateAdviceGroup Method
AdviceWeaver Class See Also Send Feedback
Creates an empty AdviceGroup where advices handled by the current AdviceWeaver will be added.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract AdviceGroup CreateAdviceGroup()

Return Value

A new AdviceGroup.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GetGroupingKey Method

AdviceWeaver..::..GetGroupingKey Method
AdviceWeaver Class See Also Send Feedback
Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual AdviceGroupingKey GetGroupingKey(
    IAnnotationInstance adviseAnnotation
)

Parameters

adviseAnnotation
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
An annotation (typically, a custom attribute) representing an advise handled by the current AdviceWeaver.

Return Value

An AdviceGroupingKey used to assign adviseAnnotation to an AdviceGroup.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

AdviceWeaver..::..Initialize Method
AdviceWeaver Class See Also Send Feedback
Initializes the current AdviceWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Initialize()

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


ValidateAdvice Method

AdviceWeaver..::..ValidateAdvice Method
AdviceWeaver Class See Also Send Feedback
Validates an advice annotation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool ValidateAdvice(
    IAnnotationInstance adviseAnnotation
)

Parameters

adviseAnnotation
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
An annotation (typically, a custom attribute) representing an advise handled by the current AdviceWeaver.

Return Value

true if adviseAnnotation is valid, otherwise false.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeaver Properties

[image]

PostSharp 2.0 Documentation
AdviceWeaver Properties
AdviceWeaver Class See Also Send Feedback

The AdviceWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver.

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Property

AdviceWeaver..::..AspectWeaver Property
AdviceWeaver Class See Also Send Feedback
Gets the parent AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaver AspectWeaver { get; private set; }

See Also

AdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeInfo Class

AspectDependencyAttributeInfo Class
Members See Also Send Feedback
Encapsulates a parsed AspectDependencyAttributeInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectDependencyAttributeInfo

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectDependencyAttributeInfo

See Also

AspectDependencyAttributeInfo Members
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeInfo Members

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeInfo Members
AspectDependencyAttributeInfo Class Properties See Also Send Feedback

The AspectDependencyAttributeInfo type exposes the following members.

Properties

 | Name | Description
Public property | AspectDependency | Gets the AspectDependency.
Public property | Target | Gets the target of the aspect dependency.
Public property | TargetType | Gets the aspect type to which the aspect dependency applies.

See Also

AspectDependencyAttributeInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeInfo Properties

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeInfo Properties
AspectDependencyAttributeInfo Class See Also Send Feedback

The AspectDependencyAttributeInfo type exposes the following members.

Properties

 | Name | Description
Public property | AspectDependency | Gets the AspectDependency.
Public property | Target | Gets the target of the aspect dependency.
Public property | TargetType | Gets the aspect type to which the aspect dependency applies.

See Also

AspectDependencyAttributeInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependency Property

AspectDependencyAttributeInfo..::..AspectDependency Property
AspectDependencyAttributeInfo Class See Also Send Feedback
Gets the AspectDependency.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependency AspectDependency { get; private set; }

See Also

AspectDependencyAttributeInfo Class
PostSharp.Sdk.AspectWeaver Namespace


Target Property

AspectDependencyAttributeInfo..::..Target Property
AspectDependencyAttributeInfo Class See Also Send Feedback
Gets the target of the aspect dependency.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyTarget Target { get; private set; }

See Also

AspectDependencyAttributeInfo Class
PostSharp.Sdk.AspectWeaver Namespace


TargetType Property

AspectDependencyAttributeInfo..::..TargetType Property
AspectDependencyAttributeInfo Class See Also Send Feedback
Gets the aspect type to which the aspect dependency applies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature TargetType { get; private set; }

See Also

AspectDependencyAttributeInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeParser Class

AspectDependencyAttributeParser Class
Members See Also Send Feedback
Base implementation of IAspectDependencyAttributeParser.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectDependencyAttributeParser : IAspectDependencyAttributeParser

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectDependencyAttributeParser

See Also

AspectDependencyAttributeParser Members
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeParser Members

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeParser Members
AspectDependencyAttributeParser Class Constructors Methods See Also Send Feedback

The AspectDependencyAttributeParser type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectDependencyAttributeParser | Initializes a new instance of the AspectDependencyAttributeParser class

Methods

 | Name | Description
Public method | GetAttributeType | Gets the Type of custom attribute representing the aspect dependency supported by the current parser.
Public method | Parse | Overloaded.
Protected method | ParseCondition | Parses the AspectDependencyCondition represented by an aspect dependency custom attribute.

See Also

AspectDependencyAttributeParser Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeParser Constructor

AspectDependencyAttributeParser Constructor
AspectDependencyAttributeParser Class See Also Send Feedback
Initializes a new instance of the AspectDependencyAttributeParser class

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectDependencyAttributeParser()

See Also

AspectDependencyAttributeParser Class
PostSharp.Sdk.AspectWeaver Namespace


AspectDependencyAttributeParser Methods

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeParser Methods
AspectDependencyAttributeParser Class See Also Send Feedback

The AspectDependencyAttributeParser type exposes the following members.

Methods

 | Name | Description
Public method | GetAttributeType | Gets the Type of custom attribute representing the aspect dependency supported by the current parser.
Public method | Parse | Overloaded.
Protected method | ParseCondition | Parses the AspectDependencyCondition represented by an aspect dependency custom attribute.

See Also

AspectDependencyAttributeParser Class
PostSharp.Sdk.AspectWeaver Namespace


GetAttributeType Method

AspectDependencyAttributeParser..::..GetAttributeType Method
AspectDependencyAttributeParser Class See Also Send Feedback
Gets the Type of custom attribute representing the aspect dependency supported by the current parser.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Type GetAttributeType()

Return Value

Type of custom attribute representing the aspect dependency supported by the current parser

See Also

AspectDependencyAttributeParser Class
PostSharp.Sdk.AspectWeaver Namespace


Parse Method

[image]

PostSharp 2.0 Documentation
AspectDependencyAttributeParser..::..Parse Method
AspectDependencyAttributeParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parse(AspectDependencyAttribute, ModuleDeclaration) | Parses an aspect dependency represented by a constructed custom attribute (AspectDependencyAttribute).
Public method | Parse(IAnnotationValue, ModuleDeclaration) | Parses an aspect dependency represented by an annotation (IAnnotationValue).

See Also

AspectDependencyAttributeParser Class
AspectDependencyAttributeParser Members
PostSharp.Sdk.AspectWeaver Namespace


Parse Method (AspectDependencyAttribute, ModuleDeclaration)

AspectDependencyAttributeParser..::..Parse Method (AspectDependencyAttribute, ModuleDeclaration)
AspectDependencyAttributeParser Class See Also Send Feedback
Parses an aspect dependency represented by a constructed custom attribute (AspectDependencyAttribute).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependency Parse(
    AspectDependencyAttribute attribute,
    ModuleDeclaration module
)

Parameters

attribute
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
The custom attribute to be parsed.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration in which the condition should be expressed.

Return Value

he AspectDependencyAttributeInfo corresponding to attribute.

Implements

IAspectDependencyAttributeParser..::.Parse(AspectDependencyAttribute, ModuleDeclaration)

See Also

AspectDependencyAttributeParser Class
Parse Overload
PostSharp.Sdk.AspectWeaver Namespace


Parse Method (IAnnotationValue, ModuleDeclaration)

AspectDependencyAttributeParser..::..Parse Method (IAnnotationValue, ModuleDeclaration)
AspectDependencyAttributeParser Class See Also Send Feedback
Parses an aspect dependency represented by an annotation (IAnnotationValue).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual AspectDependencyAttributeInfo Parse(
    IAnnotationValue attribute,
    ModuleDeclaration module
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
The annotation (custom attribute) to be parsed.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration in which the condition should be expressed.

Return Value

he AspectDependencyAttributeInfo corresponding to attribute.

Implements

IAspectDependencyAttributeParser..::.Parse(IAnnotationValue, ModuleDeclaration)

See Also

AspectDependencyAttributeParser Class
Parse Overload
PostSharp.Sdk.AspectWeaver Namespace


ParseCondition Method

AspectDependencyAttributeParser..::..ParseCondition Method
AspectDependencyAttributeParser Class See Also Send Feedback
Parses the AspectDependencyCondition represented by an aspect dependency custom attribute.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract AspectDependencyCondition ParseCondition(
    AspectDependencyAttribute attribute,
    ModuleDeclaration module
)

Parameters

attribute
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
An aspect dependency custom attribute.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration in which the condition should be expressed.

Return Value

The AspectDependencyCondition corresponding to attribute.

See Also

AspectDependencyAttributeParser Class
PostSharp.Sdk.AspectWeaver Namespace


AspectInstanceInfo Class

AspectInstanceInfo Class
Members See Also Send Feedback
Stores an AspectSpecification and its target MetadataDeclaration.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectInstanceInfo

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo

See Also

AspectInstanceInfo Members
PostSharp.Sdk.AspectWeaver Namespace


AspectInstanceInfo Members

[image]

PostSharp 2.0 Documentation
AspectInstanceInfo Members
AspectInstanceInfo Class Properties See Also Send Feedback

The AspectInstanceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect object, if available.
Public property | AspectConfiguration | Gets the aspect configuration, if any.
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any.
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance.
Public property | TargetElement | Gets the element of code to which the aspect has been applied.

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectInstanceInfo Properties

[image]

PostSharp 2.0 Documentation
AspectInstanceInfo Properties
AspectInstanceInfo Class See Also Send Feedback

The AspectInstanceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the aspect object, if available.
Public property | AspectConfiguration | Gets the aspect configuration, if any.
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any.
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance.
Public property | TargetElement | Gets the element of code to which the aspect has been applied.

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


Aspect Property

AspectInstanceInfo..::..Aspect Property
AspectInstanceInfo Class See Also Send Feedback
Gets the aspect object, if available.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAspect Aspect { get; private set; }

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectConfiguration Property

AspectInstanceInfo..::..AspectConfiguration Property
AspectInstanceInfo Class See Also Send Feedback
Gets the aspect configuration, if any.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration AspectConfiguration { get; private set; }

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectConstruction Property

AspectInstanceInfo..::..AspectConstruction Property
AspectInstanceInfo Class See Also Send Feedback
Gets the annotation (custom attribute) constructing the aspect instance, if any.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationValue AspectConstruction { get; private set; }

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


SymAspectInstance Property

AspectInstanceInfo..::..SymAspectInstance Property
AspectInstanceInfo Class See Also Send Feedback
Gets the symbol representing the current aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectInstance SymAspectInstance { get; private set; }

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


TargetElement Property

AspectInstanceInfo..::..TargetElement Property
AspectInstanceInfo Class See Also Send Feedback
Gets the element of code to which the aspect has been applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; private set; }

See Also

AspectInstanceInfo Class
PostSharp.Sdk.AspectWeaver Namespace


AspectRuntimeInstanceField Class

AspectRuntimeInstanceField Class
Members See Also Send Feedback
Encapsulates the field storing the runtime aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectRuntimeInstanceField

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectRuntimeInstanceField

See Also

AspectRuntimeInstanceField Members
PostSharp.Sdk.AspectWeaver Namespace


AspectRuntimeInstanceField Members

[image]

PostSharp 2.0 Documentation
AspectRuntimeInstanceField Members
AspectRuntimeInstanceField Class Methods Properties See Also Send Feedback

The AspectRuntimeInstanceField type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadField | Emits instructions that load the value of the field, i.e. load the aspect instance.

Properties

 | Name | Description
Public property | InstanceField | Gets the field containing the instance aspect instance, i.e. the aspect instance with instance scope. This property is null if IsStatic is true.
Public property | InstanceFieldCanonicalGenericInstance | Gets the canonical generic instance of InstanceField.
Public property | IsStatic | Determines whether the aspect instance has static scope, and therefore does not have an InstanceField.
Public property | PrototypeField | Gets the field containing the prototype aspect instance, i.e. the aspect instance with static scope.

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


AspectRuntimeInstanceField Methods

[image]

PostSharp 2.0 Documentation
AspectRuntimeInstanceField Methods
AspectRuntimeInstanceField Class See Also Send Feedback

The AspectRuntimeInstanceField type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadField | Emits instructions that load the value of the field, i.e. load the aspect instance.

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


EmitLoadField Method

AspectRuntimeInstanceField..::..EmitLoadField Method
AspectRuntimeInstanceField Class See Also Send Feedback
Emits instructions that load the value of the field, i.e. load the aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadField(
    InstructionWriter instructionWriter,
    MethodMappingWriter methodMappingWriter
)

Parameters

instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
A MethodMappingWriter.

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


AspectRuntimeInstanceField Properties

[image]

PostSharp 2.0 Documentation
AspectRuntimeInstanceField Properties
AspectRuntimeInstanceField Class See Also Send Feedback

The AspectRuntimeInstanceField type exposes the following members.

Properties

 | Name | Description
Public property | InstanceField | Gets the field containing the instance aspect instance, i.e. the aspect instance with instance scope. This property is null if IsStatic is true.
Public property | InstanceFieldCanonicalGenericInstance | Gets the canonical generic instance of InstanceField.
Public property | IsStatic | Determines whether the aspect instance has static scope, and therefore does not have an InstanceField.
Public property | PrototypeField | Gets the field containing the prototype aspect instance, i.e. the aspect instance with static scope.

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


InstanceField Property

AspectRuntimeInstanceField..::..InstanceField Property
AspectRuntimeInstanceField Class See Also Send Feedback
Gets the field containing the instance aspect instance, i.e. the aspect instance with instance scope. This property is null if IsStatic is true.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration InstanceField { get; }

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


InstanceFieldCanonicalGenericInstance Property

AspectRuntimeInstanceField..::..InstanceFieldCanonicalGenericInstance Property
AspectRuntimeInstanceField Class See Also Send Feedback
Gets the canonical generic instance of InstanceField.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField InstanceFieldCanonicalGenericInstance { get; }

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


IsStatic Property

AspectRuntimeInstanceField..::..IsStatic Property
AspectRuntimeInstanceField Class See Also Send Feedback
Determines whether the aspect instance has static scope, and therefore does not have an InstanceField.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


PrototypeField Property

AspectRuntimeInstanceField..::..PrototypeField Property
AspectRuntimeInstanceField Class See Also Send Feedback
Gets the field containing the prototype aspect instance, i.e. the aspect instance with static scope.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration PrototypeField { get; }

See Also

AspectRuntimeInstanceField Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Class

AspectWeaver Class
Members See Also Send Feedback
An object that knows how to process a specific aspect. Aspect weavers must be associated to aspect interfaces (derived from IAspect using BindAspectWeaver<(Of <(TAspect, TImpl>)>)()()(). An AspectWeaver is associated with an aspect type and is independent from aspect usage, which is encapsulated by AspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.AssemblyLevelAspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.EventLevelAspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.FieldLevelAspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.LocationLevelAspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.MethodLevelAspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.TypeLevelAspectWeaver

See Also

AspectWeaver Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Members

[image]

PostSharp 2.0 Documentation
AspectWeaver Members
AspectWeaver Class Constructors Methods Properties See Also Send Feedback

The AspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectWeaver | Initializes a new AspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation.
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance.
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type.
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver.
Protected method | Initialize | Initialize the current weaver and its aspect.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type.
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask.
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver.
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask.
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped.
Public property | Module | Gets the ModuleDeclaration being processed.
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied.
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers.
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance.
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance.
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied.
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Constructor

AspectWeaver Constructor
AspectWeaver Class See Also Send Feedback
Initializes a new AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectWeaver(
    AspectConfigurationAttribute defaultConfiguration,
    ReflectionObjectBuilder reflectionObjectBuilder,
    MulticastTargets validTargets
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.
reflectionObjectBuilder
Type: PostSharp.Sdk.AspectWeaver..::.ReflectionObjectBuilder
A ReflectionObjectBuilder able to emit instructions to load reflection objects compatible with the current aspect type.
validTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of elements of code to which this aspect can be applied.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Methods

[image]

PostSharp 2.0 Documentation
AspectWeaver Methods
AspectWeaver Class See Also Send Feedback

The AspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation.
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance.
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type.
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver.
Protected method | Initialize | Initialize the current weaver and its aspect.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


ApplyWaivedEffects Method

AspectWeaver..::..ApplyWaivedEffects Method
AspectWeaver Class See Also Send Feedback
Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void ApplyWaivedEffects(
    AspectWeaverTransformation transformation
)

Parameters

transformation
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
The transformation from which effects should be waived.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


CreateAspectWeaverInstance Method

AspectWeaver..::..CreateAspectWeaverInstance Method
AspectWeaver Class See Also Send Feedback
Creates a new AspectWeaverInstance for a given aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract AspectWeaverInstance CreateAspectWeaverInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

A AspectWeaverInstance able to process the aspect instance in aspectInstanceInfo.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GetAspectDisplayName Method

AspectWeaver..::..GetAspectDisplayName Method
AspectWeaver Class See Also Send Feedback
Gets a human-readable name of the current aspect type.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetAspectDisplayName()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.AspectWeaver.AspectWeaver.GetAspectDisplayName"]

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GetRequiredLicensedFeatures Method

AspectWeaver..::..GetRequiredLicensedFeatures Method
AspectWeaver Class See Also Send Feedback
Gets the set of licensed features required by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual LicensedFeatures GetRequiredLicensedFeatures()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.AspectWeaver.AspectWeaver.GetRequiredLicensedFeatures"]

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

AspectWeaver..::..Initialize Method
AspectWeaver Class See Also Send Feedback
Initialize the current weaver and its aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Initialize()

Remarks

Implementations should always call the base method.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


ToString Method

AspectWeaver..::..ToString Method
AspectWeaver Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


ValidateAspectInstance Method

AspectWeaver..::..ValidateAspectInstance Method
AspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Properties

[image]

PostSharp 2.0 Documentation
AspectWeaver Properties
AspectWeaver Class See Also Send Feedback

The AspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type.
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask.
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver.
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask.
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped.
Public property | Module | Gets the ModuleDeclaration being processed.
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied.
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers.
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance.
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance.
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied.
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AdviceWeavers Property

AspectWeaver..::..AdviceWeavers Property
AspectWeaver Class See Also Send Feedback
Gets the collection of weavers of advices included in the current aspect type.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<AdviceWeaver> AdviceWeavers { get; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectInfrastructureTask Property

AspectWeaver..::..AspectInfrastructureTask Property
AspectWeaver Class See Also Send Feedback
Gets the parent AspectInfrastructureTask.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask AspectInfrastructureTask { get; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectType Property

AspectWeaver..::..AspectType Property
AspectWeaver Class See Also Send Feedback
Gets the aspect type processed by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration AspectType { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Property

AspectWeaver..::..AspectWeaverTask Property
AspectWeaver Class See Also Send Feedback
Gets the parent AspectWeaverTask.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverTask AspectWeaverTask { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


DeclarativeConfiguration Property

AspectWeaver..::..DeclarativeConfiguration Property
AspectWeaver Class See Also Send Feedback
Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectConfiguration DeclarativeConfiguration { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


Dependencies Property

AspectWeaver..::..Dependencies Property
AspectWeaver Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection Dependencies { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaver..::.TypeLevelDependencies


IsInstanceScoped Property

AspectWeaver..::..IsInstanceScoped Property
AspectWeaver Class See Also Send Feedback
Determines whether the current aspect type is instance-scoped.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsInstanceScoped { get; private set; }

Remarks

Even instance-scoped aspect types can result in statically scoped aspects if an aspect is applied to a static member.

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


Module Property

AspectWeaver..::..Module Property
AspectWeaver Class See Also Send Feedback
Gets the ModuleDeclaration being processed.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Property

AspectWeaver..::..ReflectionObjectBuilder Property
AspectWeaver Class See Also Send Feedback
Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ReflectionObjectBuilder ReflectionObjectBuilder { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


RequiresReflectionWrapper Property

AspectWeaver..::..RequiresReflectionWrapper Property
AspectWeaver Class See Also Send Feedback
Determines whether the compile-time semantics of the current aspect require reflection wrappers.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool RequiresReflectionWrapper { get; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


RequiresRuntimeInstance Property

AspectWeaver..::..RequiresRuntimeInstance Property
AspectWeaver Class See Also Send Feedback
Determines whether the current aspect requires a runtime instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RequiresRuntimeInstance { get; protected set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


RequiresRuntimeInstanceInitialization Property

AspectWeaver..::..RequiresRuntimeInstanceInitialization Property
AspectWeaver Class See Also Send Feedback
Determines whether the current aspect requires initialization of the runtime instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RequiresRuntimeInstanceInitialization { get; protected set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


RequiresRuntimeReflectionObject Property

AspectWeaver..::..RequiresRuntimeReflectionObject Property
AspectWeaver Class See Also Send Feedback
Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RequiresRuntimeReflectionObject { get; protected set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


TypeLevelDependencies Property

AspectWeaver..::..TypeLevelDependencies Property
AspectWeaver Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection TypeLevelDependencies { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaver..::.Dependencies


ValidTargets Property

AspectWeaver..::..ValidTargets Property
AspectWeaver Class See Also Send Feedback
Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastTargets ValidTargets { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


WaivedEffects Property

AspectWeaver..::..WaivedEffects Property
AspectWeaver Class See Also Send Feedback
Gets the set of effects that are waived (opted out) for the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<string> WaivedEffects { get; private set; }

See Also

AspectWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Class

AspectWeaverInstance Class
Members See Also Send Feedback
Extension of the AspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.AssemblyLevelAspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.EventLevelAspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.FieldLevelAspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.LocationLevelAspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.MethodLevelAspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.TypeLevelAspectWeaverInstance

See Also

AspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
AspectWeaverInstance Members
AspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The AspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectWeaverInstance | Initializes a new AspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo.
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized.
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration.
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration.
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect.
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers).
Public method | ProvideAspects | Allows aspect weavers to provide other aspects.
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices).
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect.
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any.
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect.
Public property | AspectType | Gets the type of the current aspect.
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped.
Public property | Priority | Gets the priority of the current aspect.
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied.
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance.
Public property | TargetElement | Gets the element to which the aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Constructor

AspectWeaverInstance Constructor
AspectWeaverInstance Class See Also Send Feedback
Initializes a new AspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectWeaverInstance(
    AspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverInstance Methods
AspectWeaverInstance Class See Also Send Feedback

The AspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo.
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized.
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration.
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration.
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect.
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers).
Public method | ProvideAspects | Allows aspect weavers to provide other aspects.
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices).
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


EmitAspectConstruction Method

AspectWeaverInstance..::..EmitAspectConstruction Method
AspectWeaverInstance Class See Also Send Feedback
Emits instructions that build the custom attribute from AspectInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void EmitAspectConstruction(
    InstructionWriter writer
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
The BaseInstructionWriter with which instructions have to be written.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


EmitRuntimeInitialization Method

AspectWeaverInstance..::..EmitRuntimeInitialization Method
AspectWeaverInstance Class See Also Send Feedback
Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void EmitRuntimeInitialization(
    InstructionWriter writer,
    InstructionBlock block
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock into which instructions have to be emitted.

Remarks

It is expected that implementations generate only simple streams of instructions, without branching instructions. If more complexity is required, they should generate auxiliary methods.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


GetConfigurationObject(TConfiguration, TValue) Method

AspectWeaverInstance..::..GetConfigurationObject<(Of <(<'TConfiguration, TValue>)>)> Method
AspectWeaverInstance Class See Also Send Feedback
Gets an object (i.e., reference type) from the aspect configuration.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TValue GetConfigurationObject<TConfiguration, TValue>(
    ConfigurationGetter<TConfiguration, TValue> getter
)
where TConfiguration : AspectConfiguration
where TValue : class

Parameters

getter
Type: PostSharp.Sdk.AspectWeaver..::.ConfigurationGetter <(Of <(<'TConfiguration, TValue>)>)>
Function (delegate) retrieving the value from a configuration element.

Type Parameters

TConfiguration
Type of the aspect configuration.
TValue
Type of the retrieved aspect.

Return Value

The configuration value, or null if no configuration element defined that property.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


GetConfigurationValue(TConfiguration, TValue) Method

AspectWeaverInstance..::..GetConfigurationValue<(Of <(<'TConfiguration, TValue>)>)> Method
AspectWeaverInstance Class See Also Send Feedback
Gets a value (i.e., value type) from the aspect configuration.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TValue GetConfigurationValue<TConfiguration, TValue>(
    ConfigurationGetter<TConfiguration, Nullable<TValue>> getter
)
where TConfiguration : AspectConfiguration
where TValue : struct, new()

Parameters

getter
Type: PostSharp.Sdk.AspectWeaver..::.ConfigurationGetter <(Of <(<'TConfiguration, Nullable <(Of <(<'TValue>)>)>>)>)>
Function (delegate) retrieving the value from a configuration element.

Type Parameters

TConfiguration
Type of the aspect configuration.
TValue
Type of the retrieved aspect.

Return Value

The configuration value, or the default value of TValue if no configuration element defined that property.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


GetSerializerType Method

AspectWeaverInstance..::..GetSerializerType Method
AspectWeaverInstance Class See Also Send Feedback
Gets the type of AspectSerializer used to serialize the current aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Type GetSerializerType()

Return Value

A Type derived from AspectSerializer

Remarks

The default implementation always returns BinaryAspectSerializer.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


InitializeAspect Method

AspectWeaverInstance..::..InitializeAspect Method
AspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void InitializeAspect()

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ProvideAdviceTransformations Method

AspectWeaverInstance..::..ProvideAdviceTransformations Method
AspectWeaverInstance Class See Also Send Feedback
Provides the transformations required by the advice weavers (AdviceWeavers).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void ProvideAdviceTransformations(
    AspectWeaverTransformationAdder adder
)

Parameters

adder
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder
Object through which transformations should be added.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ProvideAspects Method

AspectWeaverInstance..::..ProvideAspects Method
AspectWeaverInstance Class See Also Send Feedback
Allows aspect weavers to provide other aspects.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual IEnumerable<AspectInstance> ProvideAspects()

Return Value

The set of aspect instances to be added to the transformation process.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ProvideAspectTransformations Method

AspectWeaverInstance..::..ProvideAspectTransformations Method
AspectWeaverInstance Class See Also Send Feedback
Provides the transformations required by the current aspect (not those required by independent advices).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ProvideAspectTransformations(
    AspectWeaverTransformationAdder adder
)

Parameters

adder
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder
Object through which transformations should be added.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ToString Method

AspectWeaverInstance..::..ToString Method
AspectWeaverInstance Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


Validate Method

AspectWeaverInstance..::..Validate Method
AspectWeaverInstance Class See Also Send Feedback
Validates the aspect use in itself, without regard to other aspects.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool Validate()

Return Value

true if the aspect is used correctly, otherwise false.

Remarks

Implementations should write messages using aMessageSource, then return true. If false is returned, the aspect is not further processed (for instance, the IAspectProvider interface is not used).

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
AspectWeaverInstance Properties
AspectWeaverInstance Class See Also Send Feedback

The AspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect.
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any.
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect.
Public property | AspectType | Gets the type of the current aspect.
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped.
Public property | Priority | Gets the priority of the current aspect.
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied.
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance.
Public property | TargetElement | Gets the element to which the aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


Aspect Property

AspectWeaverInstance..::..Aspect Property
AspectWeaverInstance Class See Also Send Feedback
Gets the compile-time instance of the aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAspect Aspect { get; }

Field Value

May be null if no runtime instance of the aspect is available, typically if the target assembly is linked against the Compact Framework or Silverlight.

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectConstruction Property

AspectWeaverInstance..::..AspectConstruction Property
AspectWeaverInstance Class See Also Send Feedback
Gets the annotation (custom attribute) constructing the aspect instance, if any.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationValue AspectConstruction { get; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectRuntimeInstanceField Property

AspectWeaverInstance..::..AspectRuntimeInstanceField Property
AspectWeaverInstance Class See Also Send Feedback
Gets the field that contains, at runtime, the deserialized instance of the aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectRuntimeInstanceField AspectRuntimeInstanceField { get; internal set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectType Property

AspectWeaverInstance..::..AspectType Property
AspectWeaverInstance Class See Also Send Feedback
Gets the type of the current aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature AspectType { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Property

AspectWeaverInstance..::..AspectWeaver Property
AspectWeaverInstance Class See Also Send Feedback
Gets the parent AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaver AspectWeaver { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


Dependencies Property

AspectWeaverInstance..::..Dependencies Property
AspectWeaverInstance Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection Dependencies { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaverInstance..::.TypeLevelDependencies


IsInstanceScoped Property

AspectWeaverInstance..::..IsInstanceScoped Property
AspectWeaverInstance Class See Also Send Feedback
Determines whether the current aspect instance is instance-scoped.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsInstanceScoped { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


Priority Property

AspectWeaverInstance..::..Priority Property
AspectWeaverInstance Class See Also Send Feedback
Gets the priority of the current aspect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Priority { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


RuntimeReflectionObjectField Property

AspectWeaverInstance..::..RuntimeReflectionObjectField Property
AspectWeaverInstance Class See Also Send Feedback
Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration RuntimeReflectionObjectField { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


SymAspectInstance Property

AspectWeaverInstance..::..SymAspectInstance Property
AspectWeaverInstance Class See Also Send Feedback
Gets the symbol representing the current aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectInstance SymAspectInstance { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


TargetElement Property

AspectWeaverInstance..::..TargetElement Property
AspectWeaverInstance Class See Also Send Feedback
Gets the element to which the aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


TargetReflectionObject Property

AspectWeaverInstance..::..TargetReflectionObject Property
AspectWeaverInstance Class See Also Send Feedback
Gets the reflection object representing the element of code to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object TargetReflectionObject { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace


TypeLevelDependencies Property

AspectWeaverInstance..::..TypeLevelDependencies Property
AspectWeaverInstance Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection TypeLevelDependencies { get; private set; }

See Also

AspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaverInstance..::.Dependencies


AspectWeaverPlugIn Class

AspectWeaverPlugIn Class
Members See Also Send Feedback
Base class for plug-ins of the aspect framework; exposes methods that allow plug-ins to bind interface types to implementation classes.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectWeaverPlugIn : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.AspectWeaver..::.AspectWeaverPlugIn

See Also

AspectWeaverPlugIn Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn Members

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn Members
AspectWeaverPlugIn Class Constructors Methods Properties See Also Send Feedback

The AspectWeaverPlugIn type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectWeaverPlugIn | Initializes a new AspectWeaverPlugIn.

Methods

 | Name | Description
Protected method | BindAdviceAnalyzerFactory<(Of <(TAttribute, TImpl>)>) | Binds a dependency custom attribute type (RequiresAdviceAnalysisAttribute) to an analyzer (IAdviceAnalyzer).
Protected method | BindAdviceWeaver<(Of <(TAttribute, TImpl>)>) | Binds an advice custom attribute type (Advice) to an AdviceWeaver.
Protected method | BindAspectDependencyAttributeParser<(Of <(TAttribute, TImpl>)>) | Binds a dependency custom attribute type (Advice) to a parser (IAspectDependencyAttributeParser).
Protected method | BindAspectWeaver<(Of <(TAspect, TImpl>)>) | Binds an aspect interface (IAspect) to an AspectWeaver.
Protected method | BindPointcutEngine<(Of <(TAttribute, TImpl>)>) | Binds a pointcut custom attribute type (Pointcut) to a pointcut engine (IPointcutEngine).
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Inherited from Task.)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Inherited from Task.)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Priority | Gets the priority of the current plug-in.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn Constructor

AspectWeaverPlugIn Constructor
AspectWeaverPlugIn Class See Also Send Feedback
Initializes a new AspectWeaverPlugIn.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectWeaverPlugIn(
    int priority
)

Parameters

priority
Type: System..::.Int32
Priority.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn Methods
AspectWeaverPlugIn Class See Also Send Feedback

The AspectWeaverPlugIn type exposes the following members.

Methods

 | Name | Description
Protected method | BindAdviceAnalyzerFactory<(Of <(TAttribute, TImpl>)>) | Binds a dependency custom attribute type (RequiresAdviceAnalysisAttribute) to an analyzer (IAdviceAnalyzer).
Protected method | BindAdviceWeaver<(Of <(TAttribute, TImpl>)>) | Binds an advice custom attribute type (Advice) to an AdviceWeaver.
Protected method | BindAspectDependencyAttributeParser<(Of <(TAttribute, TImpl>)>) | Binds a dependency custom attribute type (Advice) to a parser (IAspectDependencyAttributeParser).
Protected method | BindAspectWeaver<(Of <(TAspect, TImpl>)>) | Binds an aspect interface (IAspect) to an AspectWeaver.
Protected method | BindPointcutEngine<(Of <(TAttribute, TImpl>)>) | Binds a pointcut custom attribute type (Pointcut) to a pointcut engine (IPointcutEngine).
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Inherited from Task.)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Inherited from Task.)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


BindAdviceAnalyzerFactory(TAttribute, TImpl) Method

AspectWeaverPlugIn..::..BindAdviceAnalyzerFactory<(Of <(<'TAttribute, TImpl>)>)> Method
AspectWeaverPlugIn Class See Also Send Feedback
Binds a dependency custom attribute type (RequiresAdviceAnalysisAttribute) to an analyzer (IAdviceAnalyzer).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void BindAdviceAnalyzerFactory<TAttribute, TImpl>()
where TAttribute : RequiresAdviceAnalysisAttribute
where TImpl : new(), IAdviceAnalyzer

Type Parameters

TAttribute
Dependency custom attribute type (derived from RequiresAdviceAnalysisAttribute).
TImpl
The analyzer able to process attributes of type TAttribute.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


BindAdviceWeaver(TAttribute, TImpl) Method

AspectWeaverPlugIn..::..BindAdviceWeaver<(Of <(<'TAttribute, TImpl>)>)> Method
AspectWeaverPlugIn Class See Also Send Feedback
Binds an advice custom attribute type (Advice) to an AdviceWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void BindAdviceWeaver<TAttribute, TImpl>()
where TAttribute : Advice
where TImpl : new(), AdviceWeaver

Type Parameters

TAttribute
Advice custom attribute type (derived from Advice).
TImpl
The AspectWeaver able to process advices of type TAttribute.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


BindAspectDependencyAttributeParser(TAttribute, TImpl) Method

AspectWeaverPlugIn..::..BindAspectDependencyAttributeParser<(Of <(<'TAttribute, TImpl>)>)> Method
AspectWeaverPlugIn Class See Also Send Feedback
Binds a dependency custom attribute type (Advice) to a parser (IAspectDependencyAttributeParser).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void BindAspectDependencyAttributeParser<TAttribute, TImpl>()
where TAttribute : AspectDependencyAttribute
where TImpl : new(), IAspectDependencyAttributeParser

Type Parameters

TAttribute
Dependency custom attribute type (derived from Advice).
TImpl
The parser able to process dependencies of type TAttribute.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


BindAspectWeaver(TAspect, TImpl) Method

AspectWeaverPlugIn..::..BindAspectWeaver<(Of <(<'TAspect, TImpl>)>)> Method
AspectWeaverPlugIn Class See Also Send Feedback
Binds an aspect interface (IAspect) to an AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void BindAspectWeaver<TAspect, TImpl>()
where TAspect : IAspect
where TImpl : new(), AspectWeaver

Type Parameters

TAspect
Aspect interface (derived from IAspect).
TImpl
The AspectWeaver able to process aspects of type TAspect.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


BindPointcutEngine(TAttribute, TImpl) Method

AspectWeaverPlugIn..::..BindPointcutEngine<(Of <(<'TAttribute, TImpl>)>)> Method
AspectWeaverPlugIn Class See Also Send Feedback
Binds a pointcut custom attribute type (Pointcut) to a pointcut engine (IPointcutEngine).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void BindPointcutEngine<TAttribute, TImpl>()
where TAttribute : Pointcut
where TImpl : new(), IPointcutEngine

Type Parameters

TAttribute
Pointcut custom attribute type (derived from Pointcut).
TImpl
The pointcut engine able to process pointcuts of type TAttribute.

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn..::..Dispose Method
AspectWeaverPlugIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance. (Inherited from Task.)

See Also

AspectWeaverPlugIn Class
AspectWeaverPlugIn Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn Properties

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn Properties
AspectWeaverPlugIn Class See Also Send Feedback

The AspectWeaverPlugIn type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Priority | Gets the priority of the current plug-in.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


Priority Property

AspectWeaverPlugIn..::..Priority Property
AspectWeaverPlugIn Class See Also Send Feedback
Gets the priority of the current plug-in.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Priority { get; private set; }

See Also

AspectWeaverPlugIn Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn.StandardPriorities Class

AspectWeaverPlugIn..::..StandardPriorities Class
AspectWeaverPlugIn Class Members See Also Send Feedback
Standard priorities of plug-ins.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected static class StandardPriorities

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverPlugIn..::.StandardPriorities

See Also

AspectWeaverPlugIn..::.StandardPriorities Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn.StandardPriorities Members

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn..::..StandardPriorities Members
AspectWeaverPlugIn..::.StandardPriorities Class Fields See Also Send Feedback

Base class for plug-ins of the aspect framework; exposes methods that allow plug-ins to bind interface types to implementation classes.

The AspectWeaverPlugIn..::.StandardPriorities type exposes the following members.

Fields

Name | Description
System | Priority of the system plug-in (100).
SystemFallback1 | Priority of the first fall-back plug-in (200).
SystemFallback2 | Priority of the second fall-back plug-in (201).
User | Priority of user plug-ins (0).

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverPlugIn.StandardPriorities Fields

[image]

PostSharp 2.0 Documentation
AspectWeaverPlugIn..::..StandardPriorities Fields
AspectWeaverPlugIn..::.StandardPriorities Class See Also Send Feedback

The AspectWeaverPlugIn..::.StandardPriorities type exposes the following members.

Fields

Name | Description
System | Priority of the system plug-in (100).
SystemFallback1 | Priority of the first fall-back plug-in (200).
SystemFallback2 | Priority of the second fall-back plug-in (201).
User | Priority of user plug-ins (0).

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


System Field

AspectWeaverPlugIn..::..StandardPriorities..::..System Field
AspectWeaverPlugIn..::.StandardPriorities Class See Also Send Feedback
Priority of the system plug-in (100).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int System

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


SystemFallback1 Field

AspectWeaverPlugIn..::..StandardPriorities..::..SystemFallback1 Field
AspectWeaverPlugIn..::.StandardPriorities Class See Also Send Feedback
Priority of the first fall-back plug-in (200).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int SystemFallback1

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


SystemFallback2 Field

AspectWeaverPlugIn..::..StandardPriorities..::..SystemFallback2 Field
AspectWeaverPlugIn..::.StandardPriorities Class See Also Send Feedback
Priority of the second fall-back plug-in (201).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int SystemFallback2

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


User Field

AspectWeaverPlugIn..::..StandardPriorities..::..User Field
AspectWeaverPlugIn..::.StandardPriorities Class See Also Send Feedback
Priority of user plug-ins (0).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int User

See Also

AspectWeaverPlugIn..::.StandardPriorities Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Class

AspectWeaverTask Class
Members See Also Send Feedback
Principal Task implementing the aspect framework.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AspectWeaverTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask

See Also

AspectWeaverTask Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Members

[image]

PostSharp 2.0 Documentation
AspectWeaverTask Members
AspectWeaverTask Class Constructors Methods Properties See Also Send Feedback

The AspectWeaverTask type exposes the following members.

Constructors

 | Name | Description
Public method | AspectWeaverTask | Initializes a new instance of the AspectWeaverTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Overrides Task..::.Initialize()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the AspectInfrastructureTask in the current project.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | InstanceCredentialsManager | Gets the InstanceCredentialsManager.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Constructor

AspectWeaverTask Constructor
AspectWeaverTask Class See Also Send Feedback
Initializes a new instance of the AspectWeaverTask class

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverTask()

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverTask Methods
AspectWeaverTask Class See Also Send Feedback

The AspectWeaverTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Overrides Task..::.Initialize()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
AspectWeaverTask..::..Dispose Method
AspectWeaverTask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance. (Inherited from Task.)

See Also

AspectWeaverTask Class
AspectWeaverTask Members
PostSharp.Sdk.AspectWeaver Namespace


Execute Method

AspectWeaverTask..::..Execute Method
AspectWeaverTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

AspectWeaverTask..::..Initialize Method
AspectWeaverTask Class See Also Send Feedback
Initializes the current task.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Initialize()

Remarks

In case that the task is deserialized from XML, this method is called after Deserialize(XmlElement).

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Properties

[image]

PostSharp 2.0 Documentation
AspectWeaverTask Properties
AspectWeaverTask Class See Also Send Feedback

The AspectWeaverTask type exposes the following members.

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the AspectInfrastructureTask in the current project.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | InstanceCredentialsManager | Gets the InstanceCredentialsManager.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


AspectInfrastructureTask Property

AspectWeaverTask..::..AspectInfrastructureTask Property
AspectWeaverTask Class See Also Send Feedback
Gets the AspectInfrastructureTask in the current project.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask AspectInfrastructureTask { get; private set; }

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


InstanceCredentialsManager Property

AspectWeaverTask..::..InstanceCredentialsManager Property
AspectWeaverTask Class See Also Send Feedback
Gets the InstanceCredentialsManager.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstanceCredentialsManager InstanceCredentialsManager { get; }

See Also

AspectWeaverTask Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformation Class

AspectWeaverTransformation Class
Members See Also Send Feedback
Static information about a transformation provided by an AspectWeaver or an AdviceWeaver, independent from the element of code to which the aspect has been applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectWeaverTransformation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
PostSharp.Sdk.AspectWeaver.Transformations..::.MethodBodyTransformation
PostSharp.Sdk.AspectWeaver.Transformations..::.StructuralTransformation

See Also

AspectWeaverTransformation Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformation Members

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformation Members
AspectWeaverTransformation Class Methods Properties See Also Send Feedback

The AspectWeaverTransformation type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation.

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask.
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | Effects | Gets the set of effects of the current transformation.
Public property | IsCommutative | Determines whether the current transformation is commutative.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformation Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformation Methods
AspectWeaverTransformation Class See Also Send Feedback

The AspectWeaverTransformation type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation.

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


GetDisplayName Method

AspectWeaverTransformation..::..GetDisplayName Method
AspectWeaverTransformation Class See Also Send Feedback
Gets the human-readable name of the current transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract string GetDisplayName(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic for which the name is requested.

Return Value

The human-readable name of the current transformation for the specified semantic.

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformation Properties

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformation Properties
AspectWeaverTransformation Class See Also Send Feedback

The AspectWeaverTransformation type exposes the following members.

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask.
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.
Public property | Effects | Gets the set of effects of the current transformation.
Public property | IsCommutative | Determines whether the current transformation is commutative.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


AspectInfrastructureTask Property

AspectWeaverTransformation..::..AspectInfrastructureTask Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the parent AspectInfrastructureTask.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectInfrastructureTask AspectInfrastructureTask { get; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Property

AspectWeaverTransformation..::..AspectWeaver Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the parent AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaver AspectWeaver { get; private set; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTask Property

AspectWeaverTransformation..::..AspectWeaverTask Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the parent AspectWeaverTask.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverTask AspectWeaverTask { get; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


Dependencies Property

AspectWeaverTransformation..::..Dependencies Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection Dependencies { get; private set; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaverTransformation..::.TypeLevelDependencies


Effects Property

AspectWeaverTransformation..::..Effects Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the set of effects of the current transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<string> Effects { get; private set; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


IsCommutative Property

AspectWeaverTransformation..::..IsCommutative Property
AspectWeaverTransformation Class See Also Send Feedback
Determines whether the current transformation is commutative.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool IsCommutative { get; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace


TypeLevelDependencies Property

AspectWeaverTransformation..::..TypeLevelDependencies Property
AspectWeaverTransformation Class See Also Send Feedback
Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectDependencyCollection TypeLevelDependencies { get; private set; }

See Also

AspectWeaverTransformation Class
PostSharp.Sdk.AspectWeaver Namespace
AspectWeaverTransformation..::.Dependencies


AspectWeaverTransformationAdder Class

AspectWeaverTransformationAdder Class
Members See Also Send Feedback
Object allowing to implementations of AspectWeaver or AdviceGroup to provide their transformations to the aspect framework.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectWeaverTransformationAdder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder

See Also

AspectWeaverTransformationAdder Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationAdder Members

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationAdder Members
AspectWeaverTransformationAdder Class Methods See Also Send Feedback

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddNullTransformation | Overloaded.

See Also

AspectWeaverTransformationAdder Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationAdder Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationAdder Methods
AspectWeaverTransformationAdder Class See Also Send Feedback

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddNullTransformation | Overloaded.

See Also

AspectWeaverTransformationAdder Class
PostSharp.Sdk.AspectWeaver Namespace


Add Method

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationAdder..::..Add Method
AspectWeaverTransformationAdder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(IMetadataDeclaration, AspectWeaverTransformationInstance) | Adds a transformation and associates it with the set of dependencies in Dependencies.
Public method | Add(IMetadataDeclaration, AspectWeaverTransformationInstance, AspectDependencyTarget) | Adds a transformation with the default AspectDependencyTarget and specifies whether the transformation should be associated with the set of dependencies in Dependencies or TypeLevelDependencies.

See Also

AspectWeaverTransformationAdder Class
AspectWeaverTransformationAdder Members
PostSharp.Sdk.AspectWeaver Namespace


Add Method (IMetadataDeclaration, AspectWeaverTransformationInstance)

AspectWeaverTransformationAdder..::..Add Method (IMetadataDeclaration, AspectWeaverTransformationInstance)
AspectWeaverTransformationAdder Class See Also Send Feedback
Adds a transformation and associates it with the set of dependencies in Dependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    IMetadataDeclaration targetElement,
    AspectWeaverTransformationInstance transformation
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration to which the transformation should be added.
transformation
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationInstance
Transformation to be added.

See Also

AspectWeaverTransformationAdder Class
Add Overload
PostSharp.Sdk.AspectWeaver Namespace


Add Method (IMetadataDeclaration, AspectWeaverTransformationInstance, AspectDependencyTarget)

AspectWeaverTransformationAdder..::..Add Method (IMetadataDeclaration, AspectWeaverTransformationInstance, AspectDependencyTarget)
AspectWeaverTransformationAdder Class See Also Send Feedback
Adds a transformation with the default AspectDependencyTarget and specifies whether the transformation should be associated with the set of dependencies in Dependencies or TypeLevelDependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    IMetadataDeclaration targetElement,
    AspectWeaverTransformationInstance transformation,
    AspectDependencyTarget aspectDependencyTarget
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration to which the transformation should be added.
transformation
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationInstance
Transformation to be added.
aspectDependencyTarget
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyTarget
Default to use the set of dependencies in Dependencies, Type to use TypeLevelDependencies.

See Also

AspectWeaverTransformationAdder Class
Add Overload
PostSharp.Sdk.AspectWeaver Namespace


AddNullTransformation Method

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationAdder..::..AddNullTransformation Method
AspectWeaverTransformationAdder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddNullTransformation(IMetadataDeclaration) | Adds a null transformation, i.e. a transformation doing nothing.
Public method | AddNullTransformation(IMetadataDeclaration, String, IEnumerable<(Of <(AspectDependency>)>)) | Adds a null transformation, i.e. a transformation doing nothing, and specifies its display name and a set of dependencies.

See Also

AspectWeaverTransformationAdder Class
AspectWeaverTransformationAdder Members
PostSharp.Sdk.AspectWeaver Namespace


AddNullTransformation Method (IMetadataDeclaration)

AspectWeaverTransformationAdder..::..AddNullTransformation Method (IMetadataDeclaration)
AspectWeaverTransformationAdder Class See Also Send Feedback
Adds a null transformation, i.e. a transformation doing nothing.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddNullTransformation(
    IMetadataDeclaration targetElement
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration to which the transformation should be added.

See Also

AspectWeaverTransformationAdder Class
AddNullTransformation Overload
PostSharp.Sdk.AspectWeaver Namespace


AddNullTransformation Method (IMetadataDeclaration, String, IEnumerable(AspectDependency))

AspectWeaverTransformationAdder..::..AddNullTransformation Method (IMetadataDeclaration, String, IEnumerable<(Of <(<'AspectDependency>)>)>)
AspectWeaverTransformationAdder Class See Also Send Feedback
Adds a null transformation, i.e. a transformation doing nothing, and specifies its display name and a set of dependencies.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddNullTransformation(
    IMetadataDeclaration targetElement,
    string displayName,
    IEnumerable<AspectDependency> dependencies
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration to which the transformation should be added.
displayName
Type: System..::.String
Human-readable name of the transformation.
dependencies
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' AspectDependency >)>)>
Set of dependencies applying to the transformation.

See Also

AspectWeaverTransformationAdder Class
AddNullTransformation Overload
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationInstance Class

AspectWeaverTransformationInstance Class
Members See Also Send Feedback
Extension of the AspectWeaverTransformation class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AspectWeaverTransformationInstance : IDependencyTransformationInstance,
    ITransformationInstance, IAspectDependencyObject

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationInstance
PostSharp.Sdk.AspectWeaver.Transformations..::.MethodBodyTransformationInstance
PostSharp.Sdk.AspectWeaver.Transformations..::.StructuralTransformationInstance

See Also

AspectWeaverTransformationInstance Members
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationInstance Members

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationInstance Members
AspectWeaverTransformationInstance Class Constructors Methods Properties See Also Send Feedback

The AspectWeaverTransformationInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | AspectWeaverTransformationInstance | Initializes a new AspectWeaverTransformationInstance.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation.
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation.
Public method | HasEffect | Determines whether the current transformation has a given effect.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.
Public property | Transformation | Gets the parent AspectWeaverTransformation.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationInstance Constructor

AspectWeaverTransformationInstance Constructor
AspectWeaverTransformationInstance Class See Also Send Feedback
Initializes a new AspectWeaverTransformationInstance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AspectWeaverTransformationInstance(
    AspectWeaverTransformation parent,
    AspectWeaverInstance aspectWeaverInstance
)

Parameters

parent
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
The parent AspectWeaverTransformation.
aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance to which the transformation instance applies.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationInstance Methods
AspectWeaverTransformationInstance Class See Also Send Feedback

The AspectWeaverTransformationInstance type exposes the following members.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation.
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation.
Public method | HasEffect | Determines whether the current transformation has a given effect.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AddDependency Method

AspectWeaverTransformationInstance..::..AddDependency Method
AspectWeaverTransformationInstance Class See Also Send Feedback
Adds a new AspectDependency to the current transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AddDependency(
    AspectDependency dependency
)

Parameters

dependency
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectDependency
The additional dependency.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AddSymJoinPoint Method

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationInstance..::..AddSymJoinPoint Method
AspectWeaverTransformationInstance Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddSymJoinPoint(TransformationContext) | Adds a join point to the symbol file for the current transformation given a TransformationContext.
Protected method | AddSymJoinPoint(TransformationContext, String) | Adds a join point to the symbol file for the current transformation given a TransformationContext, with the possibility to override the description of the join point.
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32) | Adds a join point to the symbol file for the current transformation, using GetDisplayName(MethodSemantics) to get the description of the join point.
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32, String) | Adds a join point to the symbol file for the current transformation, with the possibility to override the description of the join point.

See Also

AspectWeaverTransformationInstance Class
AspectWeaverTransformationInstance Members
PostSharp.Sdk.AspectWeaver Namespace


AddSymJoinPoint Method (TransformationContext)

AspectWeaverTransformationInstance..::..AddSymJoinPoint Method (TransformationContext)
AspectWeaverTransformationInstance Class See Also Send Feedback
Adds a join point to the symbol file for the current transformation given a TransformationContext.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AddSymJoinPoint(
    TransformationContext context
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
The TransformationContext for which the join point should be added.

See Also

AspectWeaverTransformationInstance Class
AddSymJoinPoint Overload
PostSharp.Sdk.AspectWeaver Namespace


AddSymJoinPoint Method (TransformationContext, String)

AspectWeaverTransformationInstance..::..AddSymJoinPoint Method (TransformationContext, String)
AspectWeaverTransformationInstance Class See Also Send Feedback
Adds a join point to the symbol file for the current transformation given a TransformationContext, with the possibility to override the description of the join point.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AddSymJoinPoint(
    TransformationContext context,
    string description
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
The TransformationContext for which the join point should be added.
description
Type: System..::.String
Join point description, or null if the description should be the result of the method GetDisplayName(MethodSemantics).

See Also

AspectWeaverTransformationInstance Class
AddSymJoinPoint Overload
PostSharp.Sdk.AspectWeaver Namespace


AddSymJoinPoint Method (MetadataDeclaration, MethodSemantics, Int32)

AspectWeaverTransformationInstance..::..AddSymJoinPoint Method (MetadataDeclaration, MethodSemantics, Int32)
AspectWeaverTransformationInstance Class See Also Send Feedback
Adds a join point to the symbol file for the current transformation, using GetDisplayName(MethodSemantics) to get the description of the join point.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AddSymJoinPoint(
    MetadataDeclaration targetElement,
    MethodSemantics semantic,
    int ordinal
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration on which the join point is added.
semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic for which the join point is added.
ordinal
Type: System..::.Int32
Ordinal of the join point.

See Also

AspectWeaverTransformationInstance Class
AddSymJoinPoint Overload
PostSharp.Sdk.AspectWeaver Namespace


AddSymJoinPoint Method (MetadataDeclaration, MethodSemantics, Int32, String)

AspectWeaverTransformationInstance..::..AddSymJoinPoint Method (MetadataDeclaration, MethodSemantics, Int32, String)
AspectWeaverTransformationInstance Class See Also Send Feedback
Adds a join point to the symbol file for the current transformation, with the possibility to override the description of the join point.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AddSymJoinPoint(
    MetadataDeclaration targetElement,
    MethodSemantics semantic,
    int ordinal,
    string description
)

Parameters

targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration on which the join point is added.
semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic for which the join point is added.
ordinal
Type: System..::.Int32
Ordinal of the join point.
description
Type: System..::.String
Join point description, or null if the description should be the result of the method GetDisplayName(MethodSemantics).

See Also

AspectWeaverTransformationInstance Class
AddSymJoinPoint Overload
PostSharp.Sdk.AspectWeaver Namespace


GetDisplayName Method

AspectWeaverTransformationInstance..::..GetDisplayName Method
AspectWeaverTransformationInstance Class See Also Send Feedback
Gets a human-readable description of the current transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string GetDisplayName(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic on which the transformation is applied.

Return Value

A human-readable description of the current transformation when applied on a semantic of type semantic.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


HasEffect Method

AspectWeaverTransformationInstance..::..HasEffect Method
AspectWeaverTransformationInstance Class See Also Send Feedback
Determines whether the current transformation has a given effect.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool HasEffect(
    string effect
)

Parameters

effect
Type: System..::.String
Effect.

Return Value

true if the current transformation has the specified effect, otherwise false.

Implements

IAspectDependencyObject..::.HasEffect(String)

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ToString Method

AspectWeaverTransformationInstance..::..ToString Method
AspectWeaverTransformationInstance Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverTransformationInstance Properties

[image]

PostSharp 2.0 Documentation
AspectWeaverTransformationInstance Properties
AspectWeaverTransformationInstance Class See Also Send Feedback

The AspectWeaverTransformationInstance type exposes the following members.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver.
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance.
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.
Public property | Transformation | Gets the parent AspectWeaverTransformation.

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaver Property

AspectWeaverTransformationInstance..::..AspectWeaver Property
AspectWeaverTransformationInstance Class See Also Send Feedback
Gets the parent AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaver AspectWeaver { get; }

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


AspectWeaverInstance Property

AspectWeaverTransformationInstance..::..AspectWeaverInstance Property
AspectWeaverTransformationInstance Class See Also Send Feedback
Gets the parent AspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverInstance AspectWeaverInstance { get; private set; }

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


IsCommutative Property

AspectWeaverTransformationInstance..::..IsCommutative Property
AspectWeaverTransformationInstance Class See Also Send Feedback
Determines whether the current object is commutative with any other object, irrespective of dependencies or effects.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool IsCommutative { get; }

Implements

IAspectDependencyObject..::.IsCommutative

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


Transformation Property

AspectWeaverTransformationInstance..::..Transformation Property
AspectWeaverTransformationInstance Class See Also Send Feedback
Gets the parent AspectWeaverTransformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectWeaverTransformation Transformation { get; private set; }

See Also

AspectWeaverTransformationInstance Class
PostSharp.Sdk.AspectWeaver Namespace


ConfigurationGetter(?0, ?1) Delegate

ConfigurationGetter<(Of <(<'?0, ?1>)>)> Delegate
See Also Send Feedback
Delegate definition for methods that retrieve the value of some property of a AspectConfiguration.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate ?1 ConfigurationGetter<?0, ?1>(
    ?0 configuration
)
where ?0 : AspectConfiguration

Parameters

configuration
Type: ?0
Aspect configuration.

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.AspectWeaver.ConfigurationGetter`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.AspectWeaver.ConfigurationGetter`2"]

Return Value

Typically an aspect configuration property.

See Also

PostSharp.Sdk.AspectWeaver Namespace


EventInterceptionAdviceArgsBuilder Class

EventInterceptionAdviceArgsBuilder Class
Members See Also Send Feedback
Implementation of MethodExecutionAdviceArgsBuilder able to emit instructions that build objects of type EventInterceptionArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class EventInterceptionAdviceArgsBuilder : InterceptionAdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.InterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.EventInterceptionAdviceArgsBuilder

See Also

EventInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


EventInterceptionAdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
EventInterceptionAdviceArgsBuilder Members
EventInterceptionAdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The EventInterceptionAdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | EventInterceptionAdviceArgsBuilder | Initializes a new EventInterceptionAdviceArgsBuilder.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

EventInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EventInterceptionAdviceArgsBuilder Constructor

EventInterceptionAdviceArgsBuilder Constructor
EventInterceptionAdviceArgsBuilder Class See Also Send Feedback
Initializes a new EventInterceptionAdviceArgsBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInterceptionAdviceArgsBuilder(
    AspectWeaverTask task
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
The parent AspectWeaverTask.

See Also

EventInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EventInterceptionAdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
EventInterceptionAdviceArgsBuilder Methods
EventInterceptionAdviceArgsBuilder Class See Also Send Feedback

The EventInterceptionAdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

See Also

EventInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method

[image]

PostSharp 2.0 Documentation
EventInterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method
EventInterceptionAdviceArgsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField, Action<(Of <(InstructionWriter>)>)) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)

See Also

EventInterceptionAdviceArgsBuilder Class
EventInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


EventInterceptionAdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
EventInterceptionAdviceArgsBuilder Properties
EventInterceptionAdviceArgsBuilder Class See Also Send Feedback

The EventInterceptionAdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

EventInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


GroupingAdviceWeaver Class

GroupingAdviceWeaver Class
Members See Also Send Feedback
An AdviceWeaver for use with advice custom attributes derived from GroupingAdvice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class GroupingAdviceWeaver : AdviceWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceWeaver
PostSharp.Sdk.AspectWeaver..::.GroupingAdviceWeaver

See Also

GroupingAdviceWeaver Members
PostSharp.Sdk.AspectWeaver Namespace


GroupingAdviceWeaver Members

[image]

PostSharp 2.0 Documentation
GroupingAdviceWeaver Members
GroupingAdviceWeaver Class Constructors Methods Properties See Also Send Feedback

The GroupingAdviceWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | GroupingAdviceWeaver | Initializes a new instance of the GroupingAdviceWeaver class

Methods

 | Name | Description
Protected method | CreateAdviceGroup | Creates an empty AdviceGroup where advices handled by the current AdviceWeaver will be added. (Inherited from AdviceWeaver.)
Protected method | GetGroupingKey | Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup. (Overrides AdviceWeaver..::.GetGroupingKey(IAnnotationInstance).)
Protected method | Initialize | Initializes the current AdviceWeaver. (Inherited from AdviceWeaver.)
Public method | ValidateAdvice | Validates an advice annotation. (Inherited from AdviceWeaver.)

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AdviceWeaver.)

See Also

GroupingAdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GroupingAdviceWeaver Constructor

GroupingAdviceWeaver Constructor
GroupingAdviceWeaver Class See Also Send Feedback
Initializes a new instance of the GroupingAdviceWeaver class

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected GroupingAdviceWeaver()

See Also

GroupingAdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GroupingAdviceWeaver Methods

[image]

PostSharp 2.0 Documentation
GroupingAdviceWeaver Methods
GroupingAdviceWeaver Class See Also Send Feedback

The GroupingAdviceWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | CreateAdviceGroup | Creates an empty AdviceGroup where advices handled by the current AdviceWeaver will be added. (Inherited from AdviceWeaver.)
Protected method | GetGroupingKey | Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup. (Overrides AdviceWeaver..::.GetGroupingKey(IAnnotationInstance).)
Protected method | Initialize | Initializes the current AdviceWeaver. (Inherited from AdviceWeaver.)
Public method | ValidateAdvice | Validates an advice annotation. (Inherited from AdviceWeaver.)

See Also

GroupingAdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GetGroupingKey Method

GroupingAdviceWeaver..::..GetGroupingKey Method
GroupingAdviceWeaver Class See Also Send Feedback
Gets the AdviceGroupingKey of an annotation representing an advice. This grouping key is used to group advices into instances of AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override AdviceGroupingKey GetGroupingKey(
    IAnnotationInstance adviseAnnotation
)

Parameters

adviseAnnotation
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
An annotation (typically, a custom attribute) representing an advise handled by the current AdviceWeaver.

Return Value

An AdviceGroupingKey used to assign adviseAnnotation to an AdviceGroup.

See Also

GroupingAdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


GroupingAdviceWeaver Properties

[image]

PostSharp 2.0 Documentation
GroupingAdviceWeaver Properties
GroupingAdviceWeaver Class See Also Send Feedback

The GroupingAdviceWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AdviceWeaver.)

See Also

GroupingAdviceWeaver Class
PostSharp.Sdk.AspectWeaver Namespace


IAdviceAnalyzer Interface

IAdviceAnalyzer Interface
Members See Also Send Feedback
Defines the semantics of an advice analyzer, which should analyze the implementation of advices and figure out which optimizations can be applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAdviceAnalyzer

See Also

IAdviceAnalyzer Members
PostSharp.Sdk.AspectWeaver Namespace
PostSharp.Sdk.AspectWeaver..::.AdviceAnalyzer


IAdviceAnalyzer Members

[image]

PostSharp 2.0 Documentation
IAdviceAnalyzer Members
IAdviceAnalyzer Interface Methods See Also Send Feedback

The IAdviceAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Analyze | Analyzes an advice.
Public method | Initialize | Initializes the current advice analyzer.

See Also

IAdviceAnalyzer Interface
PostSharp.Sdk.AspectWeaver Namespace


IAdviceAnalyzer Methods

[image]

PostSharp 2.0 Documentation
IAdviceAnalyzer Methods
IAdviceAnalyzer Interface See Also Send Feedback

The IAdviceAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Analyze | Analyzes an advice.
Public method | Initialize | Initializes the current advice analyzer.

See Also

IAdviceAnalyzer Interface
PostSharp.Sdk.AspectWeaver Namespace


Analyze Method

IAdviceAnalyzer..::..Analyze Method
IAdviceAnalyzer Interface See Also Send Feedback
Analyzes an advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Analyze(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The advice method.

Remarks

The implementation of this method will typically store optimization information as a tag on method for later retrieval using a custom method.

See Also

IAdviceAnalyzer Interface
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

IAdviceAnalyzer..::..Initialize Method
IAdviceAnalyzer Interface See Also Send Feedback
Initializes the current advice analyzer.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Initialize(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which advices will be analyzed.

See Also

IAdviceAnalyzer Interface
PostSharp.Sdk.AspectWeaver Namespace


IAspectDependencyAttributeParser Interface

IAspectDependencyAttributeParser Interface
Members See Also Send Feedback
Defines the semantics of a parser of custom attributes representing custom attributes. The parser must create instances of AspectDependency based on custom attributes derived from AspectDependencyAttribute.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAspectDependencyAttributeParser

See Also

IAspectDependencyAttributeParser Members
PostSharp.Sdk.AspectWeaver Namespace


IAspectDependencyAttributeParser Members

[image]

PostSharp 2.0 Documentation
IAspectDependencyAttributeParser Members
IAspectDependencyAttributeParser Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | Parse | Overloaded.

See Also

IAspectDependencyAttributeParser Interface
PostSharp.Sdk.AspectWeaver Namespace


IAspectDependencyAttributeParser Methods

[image]

PostSharp 2.0 Documentation
IAspectDependencyAttributeParser Methods
IAspectDependencyAttributeParser Interface See Also Send Feedback

Methods

 | Name | Description
Public method | Parse | Overloaded.

See Also

IAspectDependencyAttributeParser Interface
PostSharp.Sdk.AspectWeaver Namespace


Parse Method

[image]

PostSharp 2.0 Documentation
IAspectDependencyAttributeParser..::..Parse Method
IAspectDependencyAttributeParser Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Parse(AspectDependencyAttribute, ModuleDeclaration) | Parses a dependency custom attribute, given as a constructed AspectDependencyAttribute, into an AspectDependency.
Public method | Parse(IAnnotationValue, ModuleDeclaration) | Parses a dependency custom attribute, given as an IAnnotationValue, into am AspectDependencyAttributeInfo.

See Also

IAspectDependencyAttributeParser Interface
IAspectDependencyAttributeParser Members
PostSharp.Sdk.AspectWeaver Namespace


Parse Method (AspectDependencyAttribute, ModuleDeclaration)

IAspectDependencyAttributeParser..::..Parse Method (AspectDependencyAttribute, ModuleDeclaration)
IAspectDependencyAttributeParser Interface See Also Send Feedback
Parses a dependency custom attribute, given as a constructed AspectDependencyAttribute, into an AspectDependency.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
AspectDependency Parse(
    AspectDependencyAttribute attribute,
    ModuleDeclaration module
)

Parameters

attribute
Type: PostSharp.Aspects.Dependencies..::.AspectDependencyAttribute
The custom attribute to be parsed.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module in which the aspect dependency should be expressed.

Return Value

An AspectDependency object representing attribute, expressed for the specified module.

See Also

IAspectDependencyAttributeParser Interface
Parse Overload
PostSharp.Sdk.AspectWeaver Namespace


Parse Method (IAnnotationValue, ModuleDeclaration)

IAspectDependencyAttributeParser..::..Parse Method (IAnnotationValue, ModuleDeclaration)
IAspectDependencyAttributeParser Interface See Also Send Feedback
Parses a dependency custom attribute, given as an IAnnotationValue, into am AspectDependencyAttributeInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
AspectDependencyAttributeInfo Parse(
    IAnnotationValue attribute,
    ModuleDeclaration module
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
The custom attribute to be parsed.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module in which the aspect dependency should be expressed.

Return Value

An AspectDependencyAttributeInfo object representing attribute, expressed for the specified module.

See Also

IAspectDependencyAttributeParser Interface
Parse Overload
PostSharp.Sdk.AspectWeaver Namespace


InterceptionAdviceArgsBuilder Class

InterceptionAdviceArgsBuilder Class
Members See Also Send Feedback
Implementation of AdviceArgsBuilder that can emit instructions to create objects MethodInterceptionArgs, LocationInterceptionArgs or EventInterceptionArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class InterceptionAdviceArgsBuilder : AdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.InterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.EventInterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.LocationInterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.MethodInterceptionAdviceArgsBuilder

See Also

InterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


InterceptionAdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
InterceptionAdviceArgsBuilder Members
InterceptionAdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The InterceptionAdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | InterceptionAdviceArgsBuilder | Initializes a new InterceptionAdviceArgsBuilder.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

InterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


InterceptionAdviceArgsBuilder Constructor

InterceptionAdviceArgsBuilder Constructor
InterceptionAdviceArgsBuilder Class See Also Send Feedback
Initializes a new InterceptionAdviceArgsBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InterceptionAdviceArgsBuilder(
    AspectWeaverTask task,
    ReflectionObjectBuilder reflectionObjectBuilder,
    MethodMappingContextItem reflectionObjectContextItem,
    MethodMappingContextItem adviseArgsContextItem,
    IMethod setReflectionObjectMethod
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
The parent AspectWeaverTask.
reflectionObjectBuilder
Type: PostSharp.Sdk.AspectWeaver..::.ReflectionObjectBuilder
The ReflectionObjectBuilder used to set create the relevant reflection object.
reflectionObjectContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
Context item corresponding to the reflection object.
adviseArgsContextItem
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingContextItem
Context item corresponding to the AdviceArgs object.
setReflectionObjectMethod
Type: PostSharp.Sdk.CodeModel..::.IMethod
Method (property setter) setting the reflection object.

See Also

InterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


InterceptionAdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
InterceptionAdviceArgsBuilder Methods
InterceptionAdviceArgsBuilder Class See Also Send Feedback

The InterceptionAdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

See Also

InterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method

[image]

PostSharp 2.0 Documentation
InterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method
InterceptionAdviceArgsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable.
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField, Action<(Of <(InstructionWriter>)>)) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable.

See Also

InterceptionAdviceArgsBuilder Class
InterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method (AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol, LocalVariableSymbol, IMethod, IField, IField)

InterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method (AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField)
InterceptionAdviceArgsBuilder Class See Also Send Feedback
Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreAdviceArgsToLocal(
    AspectWeaverInstance aspectWeaverInstance,
    InstructionWriter instructionWriter,
    ArgumentsWriter argumentsWriter,
    MethodMappingWriter methodMappingWriter,
    MethodMapping bindingMethodMapping,
    bool requiresReflectionObject,
    MetadataDeclaration targetMember,
    IType targetType,
    ref LocalVariableSymbol adviseArgsVariable,
    LocalVariableSymbol oldBindingVariable,
    IMethod adviceArgsConstructor,
    IField adviceArgsBindingField,
    IField singletonBindingField
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which the AdviceArgs is created.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
argumentsWriter
Type: PostSharp.Sdk.AspectWeaver.Transformations..::.ArgumentsWriter
An ArgumentsWriter.
methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
The MethodMappingWriter for the current context.
bindingMethodMapping
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
Optionally, the MethodMapping for the next context, so that the relevant context items can be added to this context.
requiresReflectionObject
Type: System..::.Boolean
true if the property containing the reflection object should be set, otherwise false.
targetMember
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration on which the advice is applied.
targetType
Type: PostSharp.Sdk.CodeModel..::.IType
Relevant generic instance of the declaring type of targetMember.
adviseArgsVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
Local variable where the AdviceArgs should be stored. If the input value of this parameter is null, the local variable is created.
oldBindingVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
Variable into which the previous binding should be stored in case the AdviceArgs is reused.
adviceArgsConstructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Constructor of the AdviceArgs class.
adviceArgsBindingField
Type: PostSharp.Sdk.CodeModel..::.IField
Field of AdviceArgs containing the binding.
singletonBindingField
Type: PostSharp.Sdk.CodeModel..::.IField
Static field containing the singleton binding to be assigned to adviseArgsVariable.

See Also

InterceptionAdviceArgsBuilder Class
EmitStoreAdviceArgsToLocal Overload
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method (AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol, LocalVariableSymbol, IMethod, IField, IField, Action(InstructionWriter))

InterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method (AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField, Action<(Of <(<'InstructionWriter>)>)>)
InterceptionAdviceArgsBuilder Class See Also Send Feedback
Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreAdviceArgsToLocal(
    AspectWeaverInstance aspectWeaverInstance,
    InstructionWriter instructionWriter,
    ArgumentsWriter argumentsWriter,
    MethodMappingWriter methodMappingWriter,
    MethodMapping bindingMethodMapping,
    bool requiresReflectionObject,
    MetadataDeclaration targetMember,
    IType targetType,
    ref LocalVariableSymbol adviseArgsVariable,
    LocalVariableSymbol oldBindingVariable,
    IMethod adviceArgsConstructor,
    IField adviceArgsBindingField,
    IField singletonBindingField,
    Action<InstructionWriter> loadAdditionalConstructorParametersAction
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which the AdviceArgs is created.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
argumentsWriter
Type: PostSharp.Sdk.AspectWeaver.Transformations..::.ArgumentsWriter
An ArgumentsWriter.
methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
The MethodMappingWriter for the current context.
bindingMethodMapping
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
Optionally, the MethodMapping for the next context, so that the relevant context items can be added to this context.
requiresReflectionObject
Type: System..::.Boolean
true if the property containing the reflection object should be set, otherwise false.
targetMember
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration on which the advice is applied.
targetType
Type: PostSharp.Sdk.CodeModel..::.IType
Relevant generic instance of the declaring type of targetMember.
adviseArgsVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
Local variable where the AdviceArgs should be stored. If the input value of this parameter is null, the local variable is created.
oldBindingVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
Variable into which the previous binding should be stored in case the AdviceArgs is reused.
adviceArgsConstructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Constructor of the AdviceArgs class.
adviceArgsBindingField
Type: PostSharp.Sdk.CodeModel..::.IField
Field of AdviceArgs containing the binding.
singletonBindingField
Type: PostSharp.Sdk.CodeModel..::.IField
Static field containing the singleton binding to be assigned to adviseArgsVariable.
loadAdditionalConstructorParametersAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
Delegates that emit instructions that load additional constructor parameters on the stack.

See Also

InterceptionAdviceArgsBuilder Class
EmitStoreAdviceArgsToLocal Overload
PostSharp.Sdk.AspectWeaver Namespace


InterceptionAdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
InterceptionAdviceArgsBuilder Properties
InterceptionAdviceArgsBuilder Class See Also Send Feedback

The InterceptionAdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

InterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


IPointcutEngine Interface

IPointcutEngine Interface
Members See Also Send Feedback
Defines the semantics of a pointcut engine. Pointcut engines evaluate pointcuts.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IPointcutEngine

See Also

IPointcutEngine Members
PostSharp.Sdk.AspectWeaver Namespace


IPointcutEngine Members

[image]

PostSharp 2.0 Documentation
IPointcutEngine Members
IPointcutEngine Interface Methods See Also Send Feedback

The IPointcutEngine type exposes the following members.

Methods

 | Name | Description
Public method | EvaluatePointcut | Evaluates a pointcut, i.e. returns the set of elements of code the pointcut evaluates to.
Public method | Initialize | Initializes the current pointcut engine.

See Also

IPointcutEngine Interface
PostSharp.Sdk.AspectWeaver Namespace


IPointcutEngine Methods

[image]

PostSharp 2.0 Documentation
IPointcutEngine Methods
IPointcutEngine Interface See Also Send Feedback

The IPointcutEngine type exposes the following members.

Methods

 | Name | Description
Public method | EvaluatePointcut | Evaluates a pointcut, i.e. returns the set of elements of code the pointcut evaluates to.
Public method | Initialize | Initializes the current pointcut engine.

See Also

IPointcutEngine Interface
PostSharp.Sdk.AspectWeaver Namespace


EvaluatePointcut Method

IPointcutEngine..::..EvaluatePointcut Method
IPointcutEngine Interface See Also Send Feedback
Evaluates a pointcut, i.e. returns the set of elements of code the pointcut evaluates to.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<MetadataDeclaration> EvaluatePointcut(
    AspectWeaverInstance aspectWeaverInstance
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which the pointcut is evaluated.

Return Value

The set of elements of code to which the pointcut evaluates given the aspect usage (aspectWeaverInstance).

See Also

IPointcutEngine Interface
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

IPointcutEngine..::..Initialize Method
IPointcutEngine Interface See Also Send Feedback
Initializes the current pointcut engine.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Initialize(
    AspectWeaver aspectWeaver,
    IAnnotationInstance pointcutAnnotation,
    MulticastTargets validTargets,
    MulticastAttributes validAttributes
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaver
The parent AspectWeaver.
pointcutAnnotation
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
Annotation (custom attribute) representing the pointcut that will be evaluated by the current engine.
validTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of elements of code that the pointcut is allowed to return.
validAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
Attributes of elements of code that the pointcut is allowed to return.

See Also

IPointcutEngine Interface
PostSharp.Sdk.AspectWeaver Namespace


LocationInterceptionAdviceArgsBuilder Class

LocationInterceptionAdviceArgsBuilder Class
Members See Also Send Feedback
Implementation of AdviceArgsBuilder that can emit instructions to create objects of type LocationInterceptionArgs or EventInterceptionArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class LocationInterceptionAdviceArgsBuilder : InterceptionAdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.InterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.LocationInterceptionAdviceArgsBuilder

See Also

LocationInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


LocationInterceptionAdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
LocationInterceptionAdviceArgsBuilder Members
LocationInterceptionAdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The LocationInterceptionAdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | LocationInterceptionAdviceArgsBuilder | Initializes a new LocationInterceptionAdviceArgsBuilder/

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

LocationInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


LocationInterceptionAdviceArgsBuilder Constructor

LocationInterceptionAdviceArgsBuilder Constructor
LocationInterceptionAdviceArgsBuilder Class See Also Send Feedback
Initializes a new LocationInterceptionAdviceArgsBuilder/

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInterceptionAdviceArgsBuilder(
    AspectWeaverTask task
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
The parent AspectWeaverTask.

See Also

LocationInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


LocationInterceptionAdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
LocationInterceptionAdviceArgsBuilder Methods
LocationInterceptionAdviceArgsBuilder Class See Also Send Feedback

The LocationInterceptionAdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

See Also

LocationInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method

[image]

PostSharp 2.0 Documentation
LocationInterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method
LocationInterceptionAdviceArgsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField, Action<(Of <(InstructionWriter>)>)) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)

See Also

LocationInterceptionAdviceArgsBuilder Class
LocationInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


LocationInterceptionAdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
LocationInterceptionAdviceArgsBuilder Properties
LocationInterceptionAdviceArgsBuilder Class See Also Send Feedback

The LocationInterceptionAdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

LocationInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodBodyWrappingImplementation Class

MethodBodyWrappingImplementation Class
Members See Also Send Feedback
Makes it easier to implement transformations (IMethodBodyTransformationInstance) that wrap the method body with advices such as OnEntry, OnSuccess, OnExit and OnException.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodBodyWrappingImplementation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.MethodBodyWrappingImplementation

See Also

MethodBodyWrappingImplementation Members
PostSharp.Sdk.AspectWeaver Namespace


MethodBodyWrappingImplementation Members

[image]

PostSharp 2.0 Documentation
MethodBodyWrappingImplementation Members
MethodBodyWrappingImplementation Class Constructors Methods Properties See Also Send Feedback

The MethodBodyWrappingImplementation type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodBodyWrappingImplementation | Initializes a new MethodBodyWrappingImplementation.

Methods

 | Name | Description
Protected method | Implement | Implements the transformation.
Protected method | ImplementOnEntry | Implements the ImplementOnEntry advice.
Protected method | ImplementOnException | Implements the OnException advice.
Protected method | ImplementOnExit | Implements the ImplementOnExit advice.
Protected method | ImplementOnSuccess | Implements the ImplementOnSuccess advice.

Properties

 | Name | Description
Protected property | Context | Gets the current MethodBodyTransformationContext.
Protected property | Redirection | Gets the MethodBodyTransformationRedirection created for this transformation.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


MethodBodyWrappingImplementation Constructor

MethodBodyWrappingImplementation Constructor
MethodBodyWrappingImplementation Class See Also Send Feedback
Initializes a new MethodBodyWrappingImplementation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodBodyWrappingImplementation(
    AspectInfrastructureTask task,
    MethodBodyTransformationContext context
)

Parameters

task
Type: PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask
The parent AspectInfrastructureTask.
context
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationContext
The MethodBodyTransformationContext for which the transformation has to be implemented.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


MethodBodyWrappingImplementation Methods

[image]

PostSharp 2.0 Documentation
MethodBodyWrappingImplementation Methods
MethodBodyWrappingImplementation Class See Also Send Feedback

The MethodBodyWrappingImplementation type exposes the following members.

Methods

 | Name | Description
Protected method | Implement | Implements the transformation.
Protected method | ImplementOnEntry | Implements the ImplementOnEntry advice.
Protected method | ImplementOnException | Implements the OnException advice.
Protected method | ImplementOnExit | Implements the ImplementOnExit advice.
Protected method | ImplementOnSuccess | Implements the ImplementOnSuccess advice.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


Implement Method

MethodBodyWrappingImplementation..::..Implement Method
MethodBodyWrappingImplementation Class See Also Send Feedback
Implements the transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void Implement(
    bool hasOnEntry,
    bool hasOnSuccess,
    bool hasOnExit,
    ITypeSignature[] exceptionTypes
)

Parameters

hasOnEntry
Type: System..::.Boolean
true if the transformation has an OnEntry advise (implemented by method ImplementOnEntry(InstructionBlock, InstructionWriter)), otherwise false.
hasOnSuccess
Type: System..::.Boolean
true if the transformation has an OnSuccess advise (implemented by method ImplementOnEntry(InstructionBlock, InstructionWriter)), otherwise false.
hasOnExit
Type: System..::.Boolean
true if the transformation has an OnExit advise, otherwise false.
exceptionTypes
Type: array< PostSharp.Sdk.CodeModel..::.ITypeSignature >[]()[][]
Array of types for which exception handlers, or null if no exception handler should be implemented. The method ImplementOnException(InstructionBlock, ITypeSignature, InstructionWriter) is invoked for every exception type.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


ImplementOnEntry Method

MethodBodyWrappingImplementation..::..ImplementOnEntry Method
MethodBodyWrappingImplementation Class See Also Send Feedback
Implements the ImplementOnEntry advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void ImplementOnEntry(
    InstructionBlock block,
    InstructionWriter writer
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
InstructionBlock where the advice should be implemented.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


ImplementOnException Method

MethodBodyWrappingImplementation..::..ImplementOnException Method
MethodBodyWrappingImplementation Class See Also Send Feedback
Implements the OnException advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void ImplementOnException(
    InstructionBlock block,
    ITypeSignature exceptionType,
    InstructionWriter writer
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
InstructionBlock where the advice should be implemented.
exceptionType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of exceptions handled by this advice.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


ImplementOnExit Method

MethodBodyWrappingImplementation..::..ImplementOnExit Method
MethodBodyWrappingImplementation Class See Also Send Feedback
Implements the ImplementOnExit advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void ImplementOnExit(
    InstructionBlock block,
    InstructionWriter writer
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
InstructionBlock where the advice should be implemented.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


ImplementOnSuccess Method

MethodBodyWrappingImplementation..::..ImplementOnSuccess Method
MethodBodyWrappingImplementation Class See Also Send Feedback
Implements the ImplementOnSuccess advice.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void ImplementOnSuccess(
    InstructionBlock block,
    InstructionWriter writer
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
InstructionBlock where the advice should be implemented.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


MethodBodyWrappingImplementation Properties

[image]

PostSharp 2.0 Documentation
MethodBodyWrappingImplementation Properties
MethodBodyWrappingImplementation Class See Also Send Feedback

The MethodBodyWrappingImplementation type exposes the following members.

Properties

 | Name | Description
Protected property | Context | Gets the current MethodBodyTransformationContext.
Protected property | Redirection | Gets the MethodBodyTransformationRedirection created for this transformation.

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


Context Property

MethodBodyWrappingImplementation..::..Context Property
MethodBodyWrappingImplementation Class See Also Send Feedback
Gets the current MethodBodyTransformationContext.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodBodyTransformationContext Context { get; }

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


Redirection Property

MethodBodyWrappingImplementation..::..Redirection Property
MethodBodyWrappingImplementation Class See Also Send Feedback
Gets the MethodBodyTransformationRedirection created for this transformation.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodBodyTransformationRedirection Redirection { get; private set; }

See Also

MethodBodyWrappingImplementation Class
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionAdviceArgsBuilder Class

MethodExecutionAdviceArgsBuilder Class
Members See Also Send Feedback
Implementation of AdviceArgsBuilder that can emit instructions to create objects of type MethodExecutionArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MethodExecutionAdviceArgsBuilder : AdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.MethodExecutionAdviceArgsBuilder

See Also

MethodExecutionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionAdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
MethodExecutionAdviceArgsBuilder Members
MethodExecutionAdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The MethodExecutionAdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | MethodExecutionAdviceArgsBuilder | Initializes a new MethodExecutionAdviceArgsBuilder.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreMethodExecutionAdviceArgsIntoLocal | Emit instructions that build a MethodExecutionArgs instance.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

MethodExecutionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionAdviceArgsBuilder Constructor

MethodExecutionAdviceArgsBuilder Constructor
MethodExecutionAdviceArgsBuilder Class See Also Send Feedback
Initializes a new MethodExecutionAdviceArgsBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodExecutionAdviceArgsBuilder(
    AspectWeaverTask task
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask

[Missing <param name="task"/> documentation for "M:PostSharp.Sdk.AspectWeaver.MethodExecutionAdviceArgsBuilder.#ctor(PostSharp.Sdk.AspectWeaver.AspectWeaverTask)"]

See Also

MethodExecutionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionAdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
MethodExecutionAdviceArgsBuilder Methods
MethodExecutionAdviceArgsBuilder Class See Also Send Feedback

The MethodExecutionAdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreMethodExecutionAdviceArgsIntoLocal | Emit instructions that build a MethodExecutionArgs instance.

See Also

MethodExecutionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreMethodExecutionAdviceArgsIntoLocal Method

MethodExecutionAdviceArgsBuilder..::..EmitStoreMethodExecutionAdviceArgsIntoLocal Method
MethodExecutionAdviceArgsBuilder Class See Also Send Feedback
Emit instructions that build a MethodExecutionArgs instance.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreMethodExecutionAdviceArgsIntoLocal(
    AspectWeaverInstance aspectWeaverInstance,
    IMethod targetMethod,
    MethodMappingWriter methodMappingWriter,
    MethodMapping bindingMethodMapping,
    ArgumentsWriter argumentsWriter,
    InstructionWriter instructionWriter,
    MethodExecutionAdviceOptimizations optimizations,
    FieldDefDeclaration methodInfoFieldDef,
    InstructionBlock instructionBlock,
    out LocalVariableSymbol adviceArgsVariable
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which the AdviceArgs is created.
targetMethod
Type: PostSharp.Sdk.CodeModel..::.IMethod
Method to which the advise is applied.
methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
The MethodMappingWriter for the current context.
bindingMethodMapping
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMapping
Optionally, the MethodMapping for the next context, so that the relevant context items can be added to this context.
argumentsWriter
Type: PostSharp.Sdk.AspectWeaver.Transformations..::.ArgumentsWriter
An ArgumentsWriter.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
optimizations
Type: MethodExecutionAdviceOptimizations
Advise optimizations.
methodInfoFieldDef
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
Field containing the reflection object at runtime.
instructionBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
InstructionBlock where the local variable adviceArgsVariable must be defined.
adviceArgsVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol %
At output, the local variable containing the MethodExecutionArgs.

See Also

MethodExecutionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodExecutionAdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
MethodExecutionAdviceArgsBuilder Properties
MethodExecutionAdviceArgsBuilder Class See Also Send Feedback

The MethodExecutionAdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

MethodExecutionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodInterceptionAdviceArgsBuilder Class

MethodInterceptionAdviceArgsBuilder Class
Members See Also Send Feedback
Implementation of AdviceArgsBuilder that can emit instructions to create objects of type MethodInterceptionArgs.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MethodInterceptionAdviceArgsBuilder : InterceptionAdviceArgsBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.InterceptionAdviceArgsBuilder
PostSharp.Sdk.AspectWeaver..::.MethodInterceptionAdviceArgsBuilder

See Also

MethodInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


MethodInterceptionAdviceArgsBuilder Members

[image]

PostSharp 2.0 Documentation
MethodInterceptionAdviceArgsBuilder Members
MethodInterceptionAdviceArgsBuilder Class Constructors Methods Properties See Also Send Feedback

The MethodInterceptionAdviceArgsBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | MethodInterceptionAdviceArgsBuilder | Initializes a new MethodInterceptionAdviceArgsBuilder.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

MethodInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodInterceptionAdviceArgsBuilder Constructor

MethodInterceptionAdviceArgsBuilder Constructor
MethodInterceptionAdviceArgsBuilder Class See Also Send Feedback
Initializes a new MethodInterceptionAdviceArgsBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodInterceptionAdviceArgsBuilder(
    AspectWeaverTask task
)

Parameters

task
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
The parent AspectWeaverTask.

See Also

MethodInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodInterceptionAdviceArgsBuilder Methods

[image]

PostSharp 2.0 Documentation
MethodInterceptionAdviceArgsBuilder Methods
MethodInterceptionAdviceArgsBuilder Class See Also Send Feedback

The MethodInterceptionAdviceArgsBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadReflectionObject | Emits instructions that load the reflection object associated with the AdviceArgs. (Inherited from AdviceArgsBuilder.)
Public method | EmitSetInstanceCredentials | Emits instructions that set the InstanceCredentials property. (Inherited from AdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal | Overloaded.

See Also

MethodInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitStoreAdviceArgsToLocal Method

[image]

PostSharp 2.0 Documentation
MethodInterceptionAdviceArgsBuilder..::..EmitStoreAdviceArgsToLocal Method
MethodInterceptionAdviceArgsBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)
Public method | EmitStoreAdviceArgsToLocal(AspectWeaverInstance, InstructionWriter, ArgumentsWriter, MethodMappingWriter, MethodMapping, Boolean, MetadataDeclaration, IType, LocalVariableSymbol%, LocalVariableSymbol, IMethod, IField, IField, Action<(Of <(InstructionWriter>)>)) | Emits instructions that construct an AdviceArgs object (or load and complete construction of an existing one, if available) and store it into a local variable. (Inherited from InterceptionAdviceArgsBuilder.)

See Also

MethodInterceptionAdviceArgsBuilder Class
MethodInterceptionAdviceArgsBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


MethodInterceptionAdviceArgsBuilder Properties

[image]

PostSharp 2.0 Documentation
MethodInterceptionAdviceArgsBuilder Properties
MethodInterceptionAdviceArgsBuilder Class See Also Send Feedback

The MethodInterceptionAdviceArgsBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Task | Gets the parent AspectWeaverTask. (Inherited from AdviceArgsBuilder.)

See Also

MethodInterceptionAdviceArgsBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


PointcutAwareAdviceGroup Class

PointcutAwareAdviceGroup Class
Members See Also Send Feedback
An AdviceGroup where the master advice must be annotated with a Pointcut.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class PointcutAwareAdviceGroup : AdviceGroup

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AdviceGroup
PostSharp.Sdk.AspectWeaver..::.PointcutAwareAdviceGroup

See Also

PointcutAwareAdviceGroup Members
PostSharp.Sdk.AspectWeaver Namespace


PointcutAwareAdviceGroup Members

[image]

PostSharp 2.0 Documentation
PointcutAwareAdviceGroup Members
PointcutAwareAdviceGroup Class Constructors Methods Properties See Also Send Feedback

The PointcutAwareAdviceGroup type exposes the following members.

Constructors

 | Name | Description
Protected method | PointcutAwareAdviceGroup | Initializes a new PointcutAwareAdviceGroup.

Methods

 | Name | Description
Protected method | EvaluatePointcuts | Evaluates all pointcuts associated with the current advice group.
Protected method | Initialize | Initializes the current AdviceGroup. This method is invoked after the object has been fully set up. (Overrides AdviceGroup..::.Initialize()()().)
Protected method | PrepareTransformation | Prepares an AspectWeaverTransformation for use with the current AdviceGroup by adding relevant dependencies to the transformation. (Inherited from AdviceGroup.)
Public method | ProvideTransformations | Overloaded.
Protected method | ValidateTarget | Validates the element of code to which an advice has been applied.

Properties

 | Name | Description
Public property | AdviceWeaver | Gets the parent AdviceWeaver. (Inherited from AdviceGroup.)
Public property | Annotations | Gets the collection of annotations (custom attributes) in the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | Dependencies | Gets the collection of dependencies of the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | GroupKey | Gets the key of the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | MasterAnnotation | Gets the master annotation (custom attribute) of the current, i.e. the one where the Master property is set. (Inherited from AdviceGroup.)

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


PointcutAwareAdviceGroup Constructor

PointcutAwareAdviceGroup Constructor
PointcutAwareAdviceGroup Class See Also Send Feedback
Initializes a new PointcutAwareAdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected PointcutAwareAdviceGroup(
    AdviceWeaver parent,
    MulticastTargets validTargets,
    MulticastAttributes validTargetsAttributes
)

Parameters

parent
Type: PostSharp.Sdk.AspectWeaver..::.AdviceWeaver
The parent AdviceWeaver.
validTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of elements of code that the pointcuts are allowed to return.
validTargetsAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
Attributes of elements of code that the pointcuts are allowed to return.

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


PointcutAwareAdviceGroup Methods

[image]

PostSharp 2.0 Documentation
PointcutAwareAdviceGroup Methods
PointcutAwareAdviceGroup Class See Also Send Feedback

The PointcutAwareAdviceGroup type exposes the following members.

Methods

 | Name | Description
Protected method | EvaluatePointcuts | Evaluates all pointcuts associated with the current advice group.
Protected method | Initialize | Initializes the current AdviceGroup. This method is invoked after the object has been fully set up. (Overrides AdviceGroup..::.Initialize()()().)
Protected method | PrepareTransformation | Prepares an AspectWeaverTransformation for use with the current AdviceGroup by adding relevant dependencies to the transformation. (Inherited from AdviceGroup.)
Public method | ProvideTransformations | Overloaded.
Protected method | ValidateTarget | Validates the element of code to which an advice has been applied.

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


EvaluatePointcuts Method

PointcutAwareAdviceGroup..::..EvaluatePointcuts Method
PointcutAwareAdviceGroup Class See Also Send Feedback
Evaluates all pointcuts associated with the current advice group.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual IEnumerable<MetadataDeclaration> EvaluatePointcuts(
    AspectWeaverInstance aspectWeaverInstance
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
Information about the context in which the advice is being used.

Return Value

The set of code elements to which the pointcuts evaluate.

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


Initialize Method

PointcutAwareAdviceGroup..::..Initialize Method
PointcutAwareAdviceGroup Class See Also Send Feedback
Initializes the current AdviceGroup. This method is invoked after the object has been fully set up.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Initialize()

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


ProvideTransformations Method

[image]

PostSharp 2.0 Documentation
PointcutAwareAdviceGroup..::..ProvideTransformations Method
PointcutAwareAdviceGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProvideTransformations(AspectWeaverInstance, AspectWeaverTransformationAdder) | Provides the transformation instances necessary to implement the current AdviceGroup. (Overrides AdviceGroup..::.ProvideTransformations(AspectWeaverInstance, AspectWeaverTransformationAdder).)
Protected method | ProvideTransformations(AspectWeaverInstance, MetadataDeclaration, AspectWeaverTransformationAdder) | Provides the transformation instances necessary to implement the current AdviceGroup for a given target of the AdviceGroup.

See Also

PointcutAwareAdviceGroup Class
PointcutAwareAdviceGroup Members
PostSharp.Sdk.AspectWeaver Namespace


ProvideTransformations Method (AspectWeaverInstance, AspectWeaverTransformationAdder)

PointcutAwareAdviceGroup..::..ProvideTransformations Method (AspectWeaverInstance, AspectWeaverTransformationAdder)
PointcutAwareAdviceGroup Class See Also Send Feedback
Provides the transformation instances necessary to implement the current AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ProvideTransformations(
    AspectWeaverInstance aspectWeaverInstance,
    AspectWeaverTransformationAdder adder
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which transformations are collected.
adder
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder
The AspectWeaverTransformationAdder to used to add transformations.

See Also

PointcutAwareAdviceGroup Class
ProvideTransformations Overload
PostSharp.Sdk.AspectWeaver Namespace


ProvideTransformations Method (AspectWeaverInstance, MetadataDeclaration, AspectWeaverTransformationAdder)

PointcutAwareAdviceGroup..::..ProvideTransformations Method (AspectWeaverInstance, MetadataDeclaration, AspectWeaverTransformationAdder)
PointcutAwareAdviceGroup Class See Also Send Feedback
Provides the transformation instances necessary to implement the current AdviceGroup for a given target of the AdviceGroup.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void ProvideTransformations(
    AspectWeaverInstance aspectWeaverInstance,
    MetadataDeclaration targetElement,
    AspectWeaverTransformationAdder adder
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The AspectWeaverInstance for which transformations are collected.
targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the AdviceGroup has been applied.
adder
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationAdder
The AspectWeaverTransformationAdder to used to add transformations.

See Also

PointcutAwareAdviceGroup Class
ProvideTransformations Overload
PostSharp.Sdk.AspectWeaver Namespace


ValidateTarget Method

PointcutAwareAdviceGroup..::..ValidateTarget Method
PointcutAwareAdviceGroup Class See Also Send Feedback
Validates the element of code to which an advice has been applied.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual bool ValidateTarget(
    AspectWeaverInstance aspectWeaverInstance,
    MetadataDeclaration target
)

Parameters

aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
Information about the context in which the advice is being used.
target
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the advice has been applied.

Return Value

true if target is a valid target for the current advice group, otherwise false.

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


PointcutAwareAdviceGroup Properties

[image]

PostSharp 2.0 Documentation
PointcutAwareAdviceGroup Properties
PointcutAwareAdviceGroup Class See Also Send Feedback

The PointcutAwareAdviceGroup type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeaver | Gets the parent AdviceWeaver. (Inherited from AdviceGroup.)
Public property | Annotations | Gets the collection of annotations (custom attributes) in the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | Dependencies | Gets the collection of dependencies of the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | GroupKey | Gets the key of the current AdviceGroup. (Inherited from AdviceGroup.)
Public property | MasterAnnotation | Gets the master annotation (custom attribute) of the current, i.e. the one where the Master property is set. (Inherited from AdviceGroup.)

See Also

PointcutAwareAdviceGroup Class
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Class

ReflectionObjectBuilder Class
Members See Also Send Feedback
Base for classes able to emit instructions that load reflection objects (such as Type, MethodBase, FieldInfo, ... ).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class ReflectionObjectBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.ReflectionObjectBuilder

See Also

ReflectionObjectBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Members

[image]

PostSharp 2.0 Documentation
ReflectionObjectBuilder Members
ReflectionObjectBuilder Class Constructors Methods Fields See Also Send Feedback

The ReflectionObjectBuilder type exposes the following members.

Constructors

 | Name | Description
Protected method | ReflectionObjectBuilder | Initializes a new ReflectionObjectBuilder.

Methods

 | Name | Description
Public method | EmitLoadRuntimeReflectionObject | Overloaded.
Public method | GetReflectionObject | Gets the reflection object compatible with the current ReflectionObjectBuilder, given another reflection object (typically to map a FieldInfo to a LocationInfo, for instance).
Public method | GetRuntimeReflectionObjectType | Gets the type of the reflection object.
Public method | IsCacheable | Determines whether a reflection object can be cached at runtime.

Fields

Name | Description
Assembly | Gets an object able to emit instructions that load an Assembly.
Dynamic | Gets an object able to emit instructions that load any reflection object, by dynamically determining the kind of declaration.
EventInfo | Gets an object able to emit instructions that load a EventInfo.
FieldInfo | Gets an object able to emit instructions that load a FieldInfo.
LocationInfo | Gets an object able to emit instructions that load a LocationInfo.
MethodBase | Gets an object able to emit instructions that load a MethodBase.
Type | Gets an object able to emit instructions that load a Type.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Constructor

ReflectionObjectBuilder Constructor
ReflectionObjectBuilder Class See Also Send Feedback
Initializes a new ReflectionObjectBuilder.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected ReflectionObjectBuilder(
    string fieldPrefix
)

Parameters

fieldPrefix
Type: System..::.String
Prefix for fields storing cached reflection objects.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Fields

[image]

PostSharp 2.0 Documentation
ReflectionObjectBuilder Fields
ReflectionObjectBuilder Class See Also Send Feedback

The ReflectionObjectBuilder type exposes the following members.

Fields

Name | Description
Assembly | Gets an object able to emit instructions that load an Assembly.
Dynamic | Gets an object able to emit instructions that load any reflection object, by dynamically determining the kind of declaration.
EventInfo | Gets an object able to emit instructions that load a EventInfo.
FieldInfo | Gets an object able to emit instructions that load a FieldInfo.
LocationInfo | Gets an object able to emit instructions that load a LocationInfo.
MethodBase | Gets an object able to emit instructions that load a MethodBase.
Type | Gets an object able to emit instructions that load a Type.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


Assembly Field

ReflectionObjectBuilder..::..Assembly Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load an Assembly.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder Assembly

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


Dynamic Field

ReflectionObjectBuilder..::..Dynamic Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load any reflection object, by dynamically determining the kind of declaration.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder Dynamic

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EventInfo Field

ReflectionObjectBuilder..::..EventInfo Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load a EventInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder EventInfo

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


FieldInfo Field

ReflectionObjectBuilder..::..FieldInfo Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load a FieldInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder FieldInfo

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


LocationInfo Field

ReflectionObjectBuilder..::..LocationInfo Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load a LocationInfo.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder LocationInfo

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


MethodBase Field

ReflectionObjectBuilder..::..MethodBase Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load a MethodBase.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder MethodBase

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


Type Field

ReflectionObjectBuilder..::..Type Field
ReflectionObjectBuilder Class See Also Send Feedback
Gets an object able to emit instructions that load a Type.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ReflectionObjectBuilder Type

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


ReflectionObjectBuilder Methods

[image]

PostSharp 2.0 Documentation
ReflectionObjectBuilder Methods
ReflectionObjectBuilder Class See Also Send Feedback

The ReflectionObjectBuilder type exposes the following members.

Methods

 | Name | Description
Public method | EmitLoadRuntimeReflectionObject | Overloaded.
Public method | GetReflectionObject | Gets the reflection object compatible with the current ReflectionObjectBuilder, given another reflection object (typically to map a FieldInfo to a LocationInfo, for instance).
Public method | GetRuntimeReflectionObjectType | Gets the type of the reflection object.
Public method | IsCacheable | Determines whether a reflection object can be cached at runtime.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


EmitLoadRuntimeReflectionObject Method

[image]

PostSharp 2.0 Documentation
ReflectionObjectBuilder..::..EmitLoadRuntimeReflectionObject Method
ReflectionObjectBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitLoadRuntimeReflectionObject(IMetadataDeclaration, IType, InstructionWriter) | Emits instruction that load the reflection object corresponding to a declaration on the stack, without taking the reflection object from a cache field.
Public method | EmitLoadRuntimeReflectionObject(IMetadataDeclaration, IType, InstructionWriter, IField) | Emits instruction that load the reflection object corresponding to a declaration on the stack, and loads the field from a cache field if possible.

See Also

ReflectionObjectBuilder Class
ReflectionObjectBuilder Members
PostSharp.Sdk.AspectWeaver Namespace


EmitLoadRuntimeReflectionObject Method (IMetadataDeclaration, IType, InstructionWriter)

ReflectionObjectBuilder..::..EmitLoadRuntimeReflectionObject Method (IMetadataDeclaration, IType, InstructionWriter)
ReflectionObjectBuilder Class See Also Send Feedback
Emits instruction that load the reflection object corresponding to a declaration on the stack, without taking the reflection object from a cache field.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadRuntimeReflectionObject(
    IMetadataDeclaration declaration,
    IType declaringType,
    InstructionWriter writer
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration whose reflection object should be loaded.
declaringType
Type: PostSharp.Sdk.CodeModel..::.IType
Generic instance of the type declaring declaration (if applicable).
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ReflectionObjectBuilder Class
EmitLoadRuntimeReflectionObject Overload
PostSharp.Sdk.AspectWeaver Namespace


EmitLoadRuntimeReflectionObject Method (IMetadataDeclaration, IType, InstructionWriter, IField)

ReflectionObjectBuilder..::..EmitLoadRuntimeReflectionObject Method (IMetadataDeclaration, IType, InstructionWriter, IField)
ReflectionObjectBuilder Class See Also Send Feedback
Emits instruction that load the reflection object corresponding to a declaration on the stack, and loads the field from a cache field if possible.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitLoadRuntimeReflectionObject(
    IMetadataDeclaration declaration,
    IType declaringType,
    InstructionWriter writer,
    IField cacheField
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration whose reflection object should be loaded.
declaringType
Type: PostSharp.Sdk.CodeModel..::.IType
Generic instance of the type declaring declaration (if applicable).
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
cacheField
Type: PostSharp.Sdk.CodeModel..::.IField
A field containing the reflection object at run time, or null if no such field is available.

See Also

ReflectionObjectBuilder Class
EmitLoadRuntimeReflectionObject Overload
PostSharp.Sdk.AspectWeaver Namespace


GetReflectionObject Method

ReflectionObjectBuilder..::..GetReflectionObject Method
ReflectionObjectBuilder Class See Also Send Feedback
Gets the reflection object compatible with the current ReflectionObjectBuilder, given another reflection object (typically to map a FieldInfo to a LocationInfo, for instance).

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Object GetReflectionObject(
    Object reflectionObject
)

Parameters

reflectionObject
Type: System..::.Object
The original reflection object.

Return Value

A reflection object compatible with the current ReflectionObjectBuilder.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


GetRuntimeReflectionObjectType Method

ReflectionObjectBuilder..::..GetRuntimeReflectionObjectType Method
ReflectionObjectBuilder Class See Also Send Feedback
Gets the type of the reflection object.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature GetRuntimeReflectionObjectType(
    IMetadataDeclaration declaration,
    ModuleDeclaration module
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
Declaration whose reflection object type is required (useful for if the current object is the Dynamic builder).
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the ITypeSignature should be expressed.

Return Value

The type of reflection object required by declaration.

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


IsCacheable Method

ReflectionObjectBuilder..::..IsCacheable Method
ReflectionObjectBuilder Class See Also Send Feedback
Determines whether a reflection object can be cached at runtime.

Namespace: PostSharp.Sdk.AspectWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool IsCacheable(
    IMetadataDeclaration declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IMetadataDeclaration
A declaration.

Return Value

true if it is possible to cache the reflection object corresponding to declaration at run time , false otherwise (typically, because the declaration requires generic arguments).

See Also

ReflectionObjectBuilder Class
PostSharp.Sdk.AspectWeaver Namespace


PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace

PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace
Send Feedback
The PostSharp.Sdk.AspectWeaver.AspectWeavers namespace provides specific implementations of the T:PostSharp.Sdk.AspectWeaver.AspectWeaver class from which user aspect weavers can be derived.

Classes

 | Class | Description
Public class | AssemblyLevelAspectWeaver | Base class for weavers of assembly-level aspects (IAssemblyLevelAspect).
Public class | AssemblyLevelAspectWeaverInstance | Extension of the AssemblyLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | EventLevelAspectWeaver | Base class for weavers of event-level aspects (IEventLevelAspect).
Public class | EventLevelAspectWeaverInstance | Extension of the EventLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | FieldLevelAspectWeaver | Base class for weavers of field-level aspects (IFieldLevelAspect).
Public class | FieldLevelAspectWeaverInstance | Extension of the FieldLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | LocationLevelAspectWeaver | Base class for weavers of location-level aspects (ILocationLevelAspect).
Public class | LocationLevelAspectWeaverInstance | Extension of the LocationLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | MethodLevelAspectWeaver | Base class for weavers of method-level aspects (IMethodLevelAspect).
Public class | MethodLevelAspectWeaverInstance | Extension of the MethodLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.
Public class | TypeLevelAspectWeaver | Base class for weavers of type-level aspects (ITypeLevelAspect).
Public class | TypeLevelAspectWeaverInstance | Extension of the TypeLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.


AssemblyLevelAspectWeaver Class

AssemblyLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of assembly-level aspects (IAssemblyLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AssemblyLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.AssemblyLevelAspectWeaver

See Also

AssemblyLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaver Members
AssemblyLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The AssemblyLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | AssemblyLevelAspectWeaver | Initializes a new AssemblyLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

AssemblyLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaver Constructor

AssemblyLevelAspectWeaver Constructor
AssemblyLevelAspectWeaver Class See Also Send Feedback
Initializes a new AssemblyLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AssemblyLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.

See Also

AssemblyLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaver Methods
AssemblyLevelAspectWeaver Class See Also Send Feedback

The AssemblyLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

AssemblyLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

AssemblyLevelAspectWeaver..::..ValidateAspectInstance Method
AssemblyLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

AssemblyLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaver Properties
AssemblyLevelAspectWeaver Class See Also Send Feedback

The AssemblyLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

AssemblyLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaverInstance Class

AssemblyLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the AssemblyLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class AssemblyLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.AssemblyLevelAspectWeaverInstance

See Also

AssemblyLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaverInstance Members
AssemblyLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The AssemblyLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | AssemblyLevelAspectWeaverInstance | Initializes a new AssemblyLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | AssemblyLevelAspect | Gets the compile-time instance of the aspect, casted as a IAssemblyLevelAspect.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionAssembly | Gets the assembly to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaverInstance Constructor

AssemblyLevelAspectWeaverInstance Constructor
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new AssemblyLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AssemblyLevelAspectWeaverInstance(
    AssemblyLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.AssemblyLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaverInstance Methods
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback

The AssemblyLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

AssemblyLevelAspectWeaverInstance..::..InitializeAspect Method
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
AssemblyLevelAspectWeaverInstance Properties
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback

The AssemblyLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | AssemblyLevelAspect | Gets the compile-time instance of the aspect, casted as a IAssemblyLevelAspect.
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionAssembly | Gets the assembly to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


AssemblyLevelAspect Property

AssemblyLevelAspectWeaverInstance..::..AssemblyLevelAspect Property
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback
Gets the compile-time instance of the aspect, casted as a IAssemblyLevelAspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyLevelAspect AssemblyLevelAspect { get; }

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionAssembly Property

AssemblyLevelAspectWeaverInstance..::..TargetReflectionAssembly Property
AssemblyLevelAspectWeaverInstance Class See Also Send Feedback
Gets the assembly to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public _Assembly TargetReflectionAssembly { get; }

See Also

AssemblyLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaver Class

EventLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of event-level aspects (IEventLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class EventLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.EventLevelAspectWeaver

See Also

EventLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaver Members
EventLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The EventLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | EventLevelAspectWeaver | Initializes a new EventLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

EventLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaver Constructor

EventLevelAspectWeaver Constructor
EventLevelAspectWeaver Class See Also Send Feedback
Initializes a new EventLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected EventLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.

See Also

EventLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaver Methods
EventLevelAspectWeaver Class See Also Send Feedback

The EventLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

EventLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

EventLevelAspectWeaver..::..ValidateAspectInstance Method
EventLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

EventLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaver Properties
EventLevelAspectWeaver Class See Also Send Feedback

The EventLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

EventLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaverInstance Class

EventLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the EventLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class EventLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.EventLevelAspectWeaverInstance

See Also

EventLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaverInstance Members
EventLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The EventLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | EventLevelAspectWeaverInstance | Initializes a new EventLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | EventLevelAspect | Gets the aspect.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionEvent | Gets the EventInfo to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaverInstance Constructor

EventLevelAspectWeaverInstance Constructor
EventLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new EventLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected EventLevelAspectWeaverInstance(
    EventLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.EventLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaverInstance Methods
EventLevelAspectWeaverInstance Class See Also Send Feedback

The EventLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

EventLevelAspectWeaverInstance..::..InitializeAspect Method
EventLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
EventLevelAspectWeaverInstance Properties
EventLevelAspectWeaverInstance Class See Also Send Feedback

The EventLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | EventLevelAspect | Gets the aspect.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionEvent | Gets the EventInfo to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


EventLevelAspect Property

EventLevelAspectWeaverInstance..::..EventLevelAspect Property
EventLevelAspectWeaverInstance Class See Also Send Feedback
Gets the aspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEventLevelAspect EventLevelAspect { get; }

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionEvent Property

EventLevelAspectWeaverInstance..::..TargetReflectionEvent Property
EventLevelAspectWeaverInstance Class See Also Send Feedback
Gets the EventInfo to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInfo TargetReflectionEvent { get; private set; }

See Also

EventLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaver Class

FieldLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of field-level aspects (IFieldLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class FieldLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.FieldLevelAspectWeaver

See Also

FieldLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaver Members
FieldLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The FieldLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldLevelAspectWeaver | Initializes a new FieldLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

FieldLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaver Constructor

FieldLevelAspectWeaver Constructor
FieldLevelAspectWeaver Class See Also Send Feedback
Initializes a new FieldLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected FieldLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.

See Also

FieldLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaver Methods
FieldLevelAspectWeaver Class See Also Send Feedback

The FieldLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

FieldLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

FieldLevelAspectWeaver..::..ValidateAspectInstance Method
FieldLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

FieldLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaver Properties
FieldLevelAspectWeaver Class See Also Send Feedback

The FieldLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

FieldLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaverInstance Class

FieldLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the FieldLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class FieldLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.FieldLevelAspectWeaverInstance

See Also

FieldLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaverInstance Members
FieldLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The FieldLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | FieldLevelAspectWeaverInstance | Initializes a new FieldLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | FieldLevelAspect | Gets the aspect.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetField | Gets the target field.
Public property | TargetReflectionField | Gets the FieldInfo of the type to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaverInstance Constructor

FieldLevelAspectWeaverInstance Constructor
FieldLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new FieldLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected FieldLevelAspectWeaverInstance(
    FieldLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.FieldLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaverInstance Methods
FieldLevelAspectWeaverInstance Class See Also Send Feedback

The FieldLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

FieldLevelAspectWeaverInstance..::..InitializeAspect Method
FieldLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
FieldLevelAspectWeaverInstance Properties
FieldLevelAspectWeaverInstance Class See Also Send Feedback

The FieldLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | FieldLevelAspect | Gets the aspect.
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetField | Gets the target field.
Public property | TargetReflectionField | Gets the FieldInfo of the type to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


FieldLevelAspect Property

FieldLevelAspectWeaverInstance..::..FieldLevelAspect Property
FieldLevelAspectWeaverInstance Class See Also Send Feedback
Gets the aspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IFieldLevelAspect FieldLevelAspect { get; }

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetField Property

FieldLevelAspectWeaverInstance..::..TargetField Property
FieldLevelAspectWeaverInstance Class See Also Send Feedback
Gets the target field.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField TargetField { get; }

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionField Property

FieldLevelAspectWeaverInstance..::..TargetReflectionField Property
FieldLevelAspectWeaverInstance Class See Also Send Feedback
Gets the FieldInfo of the type to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo TargetReflectionField { get; }

See Also

FieldLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaver Class

LocationLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of location-level aspects (ILocationLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class LocationLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.LocationLevelAspectWeaver

See Also

LocationLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaver Members
LocationLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The LocationLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | LocationLevelAspectWeaver | Initializes a new LocationLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

LocationLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaver Constructor

LocationLevelAspectWeaver Constructor
LocationLevelAspectWeaver Class See Also Send Feedback
Initializes a new LocationLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected LocationLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration,
    MulticastTargets multicastTargets
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.
multicastTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of code elements to which the current aspect can be applied.

See Also

LocationLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaver Methods
LocationLevelAspectWeaver Class See Also Send Feedback

The LocationLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

LocationLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

LocationLevelAspectWeaver..::..ValidateAspectInstance Method
LocationLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

LocationLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaver Properties
LocationLevelAspectWeaver Class See Also Send Feedback

The LocationLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

LocationLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaverInstance Class

LocationLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the LocationLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class LocationLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.LocationLevelAspectWeaverInstance

See Also

LocationLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaverInstance Members
LocationLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The LocationLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | LocationLevelAspectWeaverInstance | Initializes a new LocationLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | LocationLevelAspect | Gets the aspect.
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionLocation | Gets the LocationInfo to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaverInstance Constructor

LocationLevelAspectWeaverInstance Constructor
LocationLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new LocationLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected LocationLevelAspectWeaverInstance(
    LocationLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.LocationLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaverInstance Methods
LocationLevelAspectWeaverInstance Class See Also Send Feedback

The LocationLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

LocationLevelAspectWeaverInstance..::..InitializeAspect Method
LocationLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
LocationLevelAspectWeaverInstance Properties
LocationLevelAspectWeaverInstance Class See Also Send Feedback

The LocationLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | LocationLevelAspect | Gets the aspect.
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionLocation | Gets the LocationInfo to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


LocationLevelAspect Property

LocationLevelAspectWeaverInstance..::..LocationLevelAspect Property
LocationLevelAspectWeaverInstance Class See Also Send Feedback
Gets the aspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ILocationLevelAspect LocationLevelAspect { get; }

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionLocation Property

LocationLevelAspectWeaverInstance..::..TargetReflectionLocation Property
LocationLevelAspectWeaverInstance Class See Also Send Feedback
Gets the LocationInfo to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocationInfo TargetReflectionLocation { get; private set; }

See Also

LocationLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaver Class

MethodLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of method-level aspects (IMethodLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.MethodLevelAspectWeaver

See Also

MethodLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaver Members
MethodLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The MethodLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodLevelAspectWeaver | Initializes a new MethodLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

MethodLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaver Constructor

MethodLevelAspectWeaver Constructor
MethodLevelAspectWeaver Class See Also Send Feedback
Initializes a new MethodLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration,
    MulticastTargets validTargets
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.
validTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of code elements to which the current aspect can be applied.

See Also

MethodLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaver Methods
MethodLevelAspectWeaver Class See Also Send Feedback

The MethodLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

MethodLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

MethodLevelAspectWeaver..::..ValidateAspectInstance Method
MethodLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

MethodLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaver Properties
MethodLevelAspectWeaver Class See Also Send Feedback

The MethodLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

MethodLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaverInstance Class

MethodLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the MethodLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.MethodLevelAspectWeaverInstance

See Also

MethodLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaverInstance Members
MethodLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The MethodLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodLevelAspectWeaverInstance | Initializes a new MethodLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | MethodLevelAspect | Gets the compile-time instance of the aspect, casted as a IMethodLevelAspect.
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetMethod | Gets the method to which the aspect is applied.
Public property | TargetReflectionMethod | Gets the Reflection representation of the method to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaverInstance Constructor

MethodLevelAspectWeaverInstance Constructor
MethodLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new MethodLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodLevelAspectWeaverInstance(
    MethodLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.MethodLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaverInstance Methods
MethodLevelAspectWeaverInstance Class See Also Send Feedback

The MethodLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

MethodLevelAspectWeaverInstance..::..InitializeAspect Method
MethodLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
MethodLevelAspectWeaverInstance Properties
MethodLevelAspectWeaverInstance Class See Also Send Feedback

The MethodLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | MethodLevelAspect | Gets the compile-time instance of the aspect, casted as a IMethodLevelAspect.
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetMethod | Gets the method to which the aspect is applied.
Public property | TargetReflectionMethod | Gets the Reflection representation of the method to which the current aspect is applied.
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


MethodLevelAspect Property

MethodLevelAspectWeaverInstance..::..MethodLevelAspect Property
MethodLevelAspectWeaverInstance Class See Also Send Feedback
Gets the compile-time instance of the aspect, casted as a IMethodLevelAspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethodLevelAspect MethodLevelAspect { get; }

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetMethod Property

MethodLevelAspectWeaverInstance..::..TargetMethod Property
MethodLevelAspectWeaverInstance Class See Also Send Feedback
Gets the method to which the aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod TargetMethod { get; }

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionMethod Property

MethodLevelAspectWeaverInstance..::..TargetReflectionMethod Property
MethodLevelAspectWeaverInstance Class See Also Send Feedback
Gets the Reflection representation of the method to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase TargetReflectionMethod { get; }

See Also

MethodLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaver Class

TypeLevelAspectWeaver Class
Members See Also Send Feedback
Base class for weavers of type-level aspects (ITypeLevelAspect).

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class TypeLevelAspectWeaver : AspectWeaver

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaver
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.TypeLevelAspectWeaver

See Also

TypeLevelAspectWeaver Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaver Members

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaver Members
TypeLevelAspectWeaver Class Constructors Methods Properties See Also Send Feedback

The TypeLevelAspectWeaver type exposes the following members.

Constructors

 | Name | Description
Protected method | TypeLevelAspectWeaver | Initializes a new MethodLevelAspectWeaver.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

TypeLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaver Constructor

TypeLevelAspectWeaver Constructor
TypeLevelAspectWeaver Class See Also Send Feedback
Initializes a new MethodLevelAspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected TypeLevelAspectWeaver(
    AspectConfigurationAttribute defaultConfiguration,
    MulticastTargets validTargets
)

Parameters

defaultConfiguration
Type: PostSharp.Aspects.Configuration..::.AspectConfigurationAttribute
Default weaver configuration.
validTargets
Type: PostSharp.Extensibility..::.MulticastTargets
Kinds of elements of code to which this aspect can be applied.

See Also

TypeLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaver Methods

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaver Methods
TypeLevelAspectWeaver Class See Also Send Feedback

The TypeLevelAspectWeaver type exposes the following members.

Methods

 | Name | Description
Protected method | ApplyWaivedEffects | Apply the effects waived from the current aspect type (as added to the WaivedEffects collection) to a transformation. (Inherited from AspectWeaver.)
Protected method | CreateAspectWeaverInstance | Creates a new AspectWeaverInstance for a given aspect instance. (Inherited from AspectWeaver.)
Public method | GetAspectDisplayName | Gets a human-readable name of the current aspect type. (Inherited from AspectWeaver.)
Public method | GetRequiredLicensedFeatures | Gets the set of licensed features required by the current AspectWeaver. (Inherited from AspectWeaver.)
Protected method | Initialize | Initialize the current weaver and its aspect. (Inherited from AspectWeaver.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaver.)
Public method | ValidateAspectInstance | Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver. (Overrides AspectWeaver..::.ValidateAspectInstance(AspectInstanceInfo).)

See Also

TypeLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


ValidateAspectInstance Method

TypeLevelAspectWeaver..::..ValidateAspectInstance Method
TypeLevelAspectWeaver Class See Also Send Feedback
Validates an aspect instance, i.e. a concrete usage of an aspect of the type supported by the current AspectWeaver.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ValidateAspectInstance(
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance (or aspect usage).

Return Value

true if the aspect usage is valid, false if it is invalid

See Also

TypeLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaver Properties

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaver Properties
TypeLevelAspectWeaver Class See Also Send Feedback

The TypeLevelAspectWeaver type exposes the following members.

Properties

 | Name | Description
Public property | AdviceWeavers | Gets the collection of weavers of advices included in the current aspect type. (Inherited from AspectWeaver.)
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaver.)
Public property | AspectType | Gets the aspect type processed by the current AspectWeaver. (Inherited from AspectWeaver.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaver.)
Public property | DeclarativeConfiguration | Gets the aspect configuration that was provided declaratively, using a custom attribute of type AspectConfigurationAttribute. (Inherited from AspectWeaver.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaver.)
Public property | IsInstanceScoped | Determines whether the current aspect type is instance-scoped. (Inherited from AspectWeaver.)
Public property | Module | Gets the ModuleDeclaration being processed. (Inherited from AspectWeaver.)
Public property | ReflectionObjectBuilder | Gets the ReflectionObjectBuilder able to emit instructions that load the reflection object corresponding to the element of code to which the aspects of this AspectWeaver are applied. (Inherited from AspectWeaver.)
Public property | RequiresReflectionWrapper | Determines whether the compile-time semantics of the current aspect require reflection wrappers. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstance | Determines whether the current aspect requires a runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeInstanceInitialization | Determines whether the current aspect requires initialization of the runtime instance. (Inherited from AspectWeaver.)
Public property | RequiresRuntimeReflectionObject | Determines whether the current AspectWeaver shall need a reference to the reflection object representing the element of code to which aspects are applied. (Inherited from AspectWeaver.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect type (where dependency objects of the current aspect weaver occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaver.)
Public property | ValidTargets | Gets the kinds of elements of code to which aspects of the current AspectWeaver can be applied. (Inherited from AspectWeaver.)
Public property | WaivedEffects | Gets the set of effects that are waived (opted out) for the current AspectWeaver. (Inherited from AspectWeaver.)

See Also

TypeLevelAspectWeaver Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaverInstance Class

TypeLevelAspectWeaverInstance Class
Members See Also Send Feedback
Extension of the TypeLevelAspectWeaver class that is specific to an aspect instance; an aspect instance (AspectInstanceInfo) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class TypeLevelAspectWeaverInstance : AspectWeaverInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
PostSharp.Sdk.AspectWeaver.AspectWeavers..::.TypeLevelAspectWeaverInstance

See Also

TypeLevelAspectWeaverInstance Members
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaverInstance Members

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaverInstance Members
TypeLevelAspectWeaverInstance Class Constructors Methods Properties See Also Send Feedback

The TypeLevelAspectWeaverInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | TypeLevelAspectWeaverInstance | Initializes a new TypeLevelAspectWeaverInstance.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionType | Gets the Type to which the current aspect is applied.
Public property | TypeLevelAspect | Gets the compile-time instance of the aspect, casted as a ITypeLevelAspect.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaverInstance Constructor

TypeLevelAspectWeaverInstance Constructor
TypeLevelAspectWeaverInstance Class See Also Send Feedback
Initializes a new TypeLevelAspectWeaverInstance.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected TypeLevelAspectWeaverInstance(
    TypeLevelAspectWeaver aspectWeaver,
    AspectInstanceInfo aspectInstanceInfo
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver.AspectWeavers..::.TypeLevelAspectWeaver
Parent AspectWeaver.
aspectInstanceInfo
Type: PostSharp.Sdk.AspectWeaver..::.AspectInstanceInfo
Information about the aspect instance.

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaverInstance Methods

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaverInstance Methods
TypeLevelAspectWeaverInstance Class See Also Send Feedback

The TypeLevelAspectWeaverInstance type exposes the following members.

Methods

 | Name | Description
Public method | EmitAspectConstruction | Emits instructions that build the custom attribute from AspectInfo. (Inherited from AspectWeaverInstance.)
Public method | EmitRuntimeInitialization | Emits instructions that initialize the aspect at runtime. These instructions will be injected in the static constructor of the PostSharp implementation details object, after the field containing the runtime instance of the instance (AspectRuntimeInstanceField) has been initialized. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationObject<(Of <(TConfiguration, TValue>)>) | Gets an object (i.e., reference type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetConfigurationValue<(Of <(TConfiguration, TValue>)>) | Gets a value (i.e., value type) from the aspect configuration. (Inherited from AspectWeaverInstance.)
Public method | GetSerializerType | Gets the type of AspectSerializer used to serialize the current aspect. (Inherited from AspectWeaverInstance.)
Public method | InitializeAspect | Initializes the aspect instance, typically by invoking some CompileTimeInitialize method. (Overrides AspectWeaverInstance..::.InitializeAspect()()().)
Public method | ProvideAdviceTransformations | Provides the transformations required by the advice weavers (AdviceWeavers). (Inherited from AspectWeaverInstance.)
Public method | ProvideAspects | Allows aspect weavers to provide other aspects. (Inherited from AspectWeaverInstance.)
Public method | ProvideAspectTransformations | Provides the transformations required by the current aspect (not those required by independent advices). (Inherited from AspectWeaverInstance.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverInstance.)
Public method | Validate | Validates the aspect use in itself, without regard to other aspects. (Inherited from AspectWeaverInstance.)

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


InitializeAspect Method

TypeLevelAspectWeaverInstance..::..InitializeAspect Method
TypeLevelAspectWeaverInstance Class See Also Send Feedback
Initializes the aspect instance, typically by invoking some CompileTimeInitialize method.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void InitializeAspect()

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspectWeaverInstance Properties

[image]

PostSharp 2.0 Documentation
TypeLevelAspectWeaverInstance Properties
TypeLevelAspectWeaverInstance Class See Also Send Feedback

The TypeLevelAspectWeaverInstance type exposes the following members.

Properties

 | Name | Description
Public property | Aspect | Gets the compile-time instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectConstruction | Gets the annotation (custom attribute) constructing the aspect instance, if any. (Inherited from AspectWeaverInstance.)
Public property | AspectRuntimeInstanceField | Gets the field that contains, at runtime, the deserialized instance of the aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectType | Gets the type of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverInstance.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | IsInstanceScoped | Determines whether the current aspect instance is instance-scoped. (Inherited from AspectWeaverInstance.)
Public property | Priority | Gets the priority of the current aspect. (Inherited from AspectWeaverInstance.)
Public property | RuntimeReflectionObjectField | Gets the field containing the reflection object representing, at run time, the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | SymAspectInstance | Gets the symbol representing the current aspect instance. (Inherited from AspectWeaverInstance.)
Public property | TargetElement | Gets the element to which the aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionObject | Gets the reflection object representing the element of code to which the current aspect is applied. (Inherited from AspectWeaverInstance.)
Public property | TargetReflectionType | Gets the Type to which the current aspect is applied.
Public property | TypeLevelAspect | Gets the compile-time instance of the aspect, casted as a ITypeLevelAspect.
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current aspect (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverInstance.)

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TargetReflectionType Property

TypeLevelAspectWeaverInstance..::..TargetReflectionType Property
TypeLevelAspectWeaverInstance Class See Also Send Feedback
Gets the Type to which the current aspect is applied.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type TargetReflectionType { get; }

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


TypeLevelAspect Property

TypeLevelAspectWeaverInstance..::..TypeLevelAspect Property
TypeLevelAspectWeaverInstance Class See Also Send Feedback
Gets the compile-time instance of the aspect, casted as a ITypeLevelAspect.

Namespace: PostSharp.Sdk.AspectWeaver.AspectWeavers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeLevelAspect TypeLevelAspect { get; }

See Also

TypeLevelAspectWeaverInstance Class
PostSharp.Sdk.AspectWeaver.AspectWeavers Namespace


PostSharp.Sdk.AspectWeaver.Dependencies Namespace

PostSharp.Sdk.AspectWeaver.Dependencies Namespace
Send Feedback
The PostSharp.Sdk.AspectWeaver.AdviceWeavers namespace contains specific implementations of aspect dependencies.

Classes

 | Class | Description
Public class | AspectTypeDependencyCondition | An AspectDependencyCondition checking that the aspect of the right member of the condition is of a given type.
Public class | DependencyObjectTypeDependencyCondition<(Of <(?0>)>) | An AspectDependencyCondition that evaluates to true if the right member of the condition is a dependency object of a specified type.
Public class | ProvidedByAdviceDependency | An AspectDependency representing the fact that the dependency object has been provided by an advice of a given name.
Public class | SameAspectInstanceDependencyCondition | An AspectDependencyCondition that evaluates to true if two dependency objects are related to the same aspect instance.

Interfaces

 | Interface | Description
Public interface | IPriorityAwareDependencyObject | A dependency object exposing a Priority priority.


AspectTypeDependencyCondition Class

AspectTypeDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition checking that the aspect of the right member of the condition is of a given type.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AspectTypeDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectWeaver.Dependencies..::.AspectTypeDependencyCondition

See Also

AspectTypeDependencyCondition Members
PostSharp.Sdk.AspectWeaver.Dependencies Namespace
PostSharp.Aspects.Dependencies..::.AspectTypeDependencyAttribute


AspectTypeDependencyCondition Members

[image]

PostSharp 2.0 Documentation
AspectTypeDependencyCondition Members
AspectTypeDependencyCondition Class Constructors Methods See Also Send Feedback

The AspectTypeDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AspectTypeDependencyCondition | Initializes a new AspectTypeDependencyCondition.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


AspectTypeDependencyCondition Constructor

AspectTypeDependencyCondition Constructor
AspectTypeDependencyCondition Class See Also Send Feedback
Initializes a new AspectTypeDependencyCondition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AspectTypeDependencyCondition(
    ITypeSignature aspectType
)

Parameters

aspectType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Aspect type.

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


AspectTypeDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
AspectTypeDependencyCondition Methods
AspectTypeDependencyCondition Class See Also Send Feedback

The AspectTypeDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


FormatCondition Method

AspectTypeDependencyCondition..::..FormatCondition Method
AspectTypeDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


Match Method

AspectTypeDependencyCondition..::..Match Method
AspectTypeDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ToString Method

AspectTypeDependencyCondition..::..ToString Method
AspectTypeDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AspectTypeDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


DependencyObjectTypeDependencyCondition(?0) Class

DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
An AspectDependencyCondition that evaluates to true if the right member of the condition is a dependency object of a specified type.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DependencyObjectTypeDependencyCondition<?0> : AspectDependencyCondition
where ?0 : IAspectDependencyObject

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.AspectWeaver.Dependencies.DependencyObjectTypeDependencyCondition`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectWeaver.Dependencies..::.DependencyObjectTypeDependencyCondition<(Of <(?0>)>)

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Members
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


DependencyObjectTypeDependencyCondition(?0) Members

[image]

PostSharp 2.0 Documentation
DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)> Members
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class Constructors Methods See Also Send Feedback

The DependencyObjectTypeDependencyCondition<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | DependencyObjectTypeDependencyCondition<(Of <(?0>)>) | Initializes a new instance of the DependencyObjectTypeDependencyCondition<(Of <(?0>)>) class

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


DependencyObjectTypeDependencyCondition(?0) Constructor

DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)> Constructor
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new instance of the DependencyObjectTypeDependencyCondition<(Of <(?0>)>) class

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependencyObjectTypeDependencyCondition()

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


DependencyObjectTypeDependencyCondition(?0) Methods

[image]

PostSharp 2.0 Documentation
DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)> Methods
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class See Also Send Feedback

The DependencyObjectTypeDependencyCondition<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


FormatCondition Method

DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)>..::..FormatCondition Method
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


Match Method

DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)>..::..Match Method
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ToString Method

DependencyObjectTypeDependencyCondition<(Of <(<'?0>)>)>..::..ToString Method
DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

DependencyObjectTypeDependencyCondition<(Of <(?0>)>) Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


IPriorityAwareDependencyObject Interface

IPriorityAwareDependencyObject Interface
Members See Also Send Feedback
A dependency object exposing a Priority priority.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IPriorityAwareDependencyObject : IAspectDependencyObject

See Also

IPriorityAwareDependencyObject Members
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


IPriorityAwareDependencyObject Members

[image]

PostSharp 2.0 Documentation
IPriorityAwareDependencyObject Members
IPriorityAwareDependencyObject Interface Methods Properties See Also Send Feedback

The IPriorityAwareDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)
Public property | Priority | Gets the priority of the dependency object.

See Also

IPriorityAwareDependencyObject Interface
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


IPriorityAwareDependencyObject Methods

[image]

PostSharp 2.0 Documentation
IPriorityAwareDependencyObject Methods
IPriorityAwareDependencyObject Interface See Also Send Feedback

The IPriorityAwareDependencyObject type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets a human-readable string representing the current object. (Inherited from IAspectDependencyObject.)
Public method | HasEffect | Determines whether the current object has a given effect. (Inherited from IAspectDependencyObject.)

See Also

IPriorityAwareDependencyObject Interface
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


IPriorityAwareDependencyObject Properties

[image]

PostSharp 2.0 Documentation
IPriorityAwareDependencyObject Properties
IPriorityAwareDependencyObject Interface See Also Send Feedback

The IPriorityAwareDependencyObject type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets the set of dependencies attached to the current object. The current object is the left member of all dependencies. (Inherited from IAspectDependencyObject.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from IAspectDependencyObject.)
Public property | Priority | Gets the priority of the dependency object.

See Also

IPriorityAwareDependencyObject Interface
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


Priority Property

IPriorityAwareDependencyObject..::..Priority Property
IPriorityAwareDependencyObject Interface See Also Send Feedback
Gets the priority of the dependency object.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int Priority { get; }

See Also

IPriorityAwareDependencyObject Interface
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ProvidedByAdviceDependency Class

ProvidedByAdviceDependency Class
Members See Also Send Feedback
An AspectDependency representing the fact that the dependency object has been provided by an advice of a given name.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ProvidedByAdviceDependency : AspectDependency

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependency
PostSharp.Sdk.AspectWeaver.Dependencies..::.ProvidedByAdviceDependency

See Also

ProvidedByAdviceDependency Members
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ProvidedByAdviceDependency Members

[image]

PostSharp 2.0 Documentation
ProvidedByAdviceDependency Members
ProvidedByAdviceDependency Class Constructors Methods Properties See Also Send Feedback

The ProvidedByAdviceDependency type exposes the following members.

Constructors

 | Name | Description
Public method | ProvidedByAdviceDependency | Initializes a new ProvidedByAdviceDependency.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides AspectDependency..::.ToString()()().)

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency. (Inherited from AspectDependency.)
Public property | AdviceName | Gets the name of the advice method.
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship. (Inherited from AspectDependency.)
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error. (Inherited from AspectDependency.)
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member. (Inherited from AspectDependency.)

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ProvidedByAdviceDependency Constructor

ProvidedByAdviceDependency Constructor
ProvidedByAdviceDependency Class See Also Send Feedback
Initializes a new ProvidedByAdviceDependency.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProvidedByAdviceDependency(
    string adviceName
)

Parameters

adviceName
Type: System..::.String
Name of the advice method.

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ProvidedByAdviceDependency Methods

[image]

PostSharp 2.0 Documentation
ProvidedByAdviceDependency Methods
ProvidedByAdviceDependency Class See Also Send Feedback

The ProvidedByAdviceDependency type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides AspectDependency..::.ToString()()().)

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ToString Method

ProvidedByAdviceDependency..::..ToString Method
ProvidedByAdviceDependency Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ProvidedByAdviceDependency Properties

[image]

PostSharp 2.0 Documentation
ProvidedByAdviceDependency Properties
ProvidedByAdviceDependency Class See Also Send Feedback

The ProvidedByAdviceDependency type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the kind of relationship represented by the current AspectDependency. (Inherited from AspectDependency.)
Public property | AdviceName | Gets the name of the advice method.
Public property | Condition | Gets the condition determining whether a pair of objects matches the current relationship. (Inherited from AspectDependency.)
Public property | IsWarning | Determines whether a violation of the current dependency rule should result in a warning instead of an error. (Inherited from AspectDependency.)
Public property | Position | Gets the position of the right member of the current relationship with respect to the left member. (Inherited from AspectDependency.)

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


AdviceName Property

ProvidedByAdviceDependency..::..AdviceName Property
ProvidedByAdviceDependency Class See Also Send Feedback
Gets the name of the advice method.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AdviceName { get; private set; }

See Also

ProvidedByAdviceDependency Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


SameAspectInstanceDependencyCondition Class

SameAspectInstanceDependencyCondition Class
Members See Also Send Feedback
An AspectDependencyCondition that evaluates to true if two dependency objects are related to the same aspect instance.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SameAspectInstanceDependencyCondition : AspectDependencyCondition

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectInfrastructure..::.AspectDependencyCondition
PostSharp.Sdk.AspectWeaver.Dependencies..::.SameAspectInstanceDependencyCondition

See Also

SameAspectInstanceDependencyCondition Members
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


SameAspectInstanceDependencyCondition Members

[image]

PostSharp 2.0 Documentation
SameAspectInstanceDependencyCondition Members
SameAspectInstanceDependencyCondition Class Constructors Methods See Also Send Feedback

The SameAspectInstanceDependencyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | SameAspectInstanceDependencyCondition | Initializes a new instance of the SameAspectInstanceDependencyCondition class

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


SameAspectInstanceDependencyCondition Constructor

SameAspectInstanceDependencyCondition Constructor
SameAspectInstanceDependencyCondition Class See Also Send Feedback
Initializes a new instance of the SameAspectInstanceDependencyCondition class

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SameAspectInstanceDependencyCondition()

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


SameAspectInstanceDependencyCondition Methods

[image]

PostSharp 2.0 Documentation
SameAspectInstanceDependencyCondition Methods
SameAspectInstanceDependencyCondition Class See Also Send Feedback

The SameAspectInstanceDependencyCondition type exposes the following members.

Methods

 | Name | Description
Public method | FormatCondition | Gets a human-readable string explaining the fact that a dependency object matches the current condition. (Overrides AspectDependencyCondition..::.FormatCondition(IAspectDependencyObject).)
Public method | Match | Determines whether a pair of objects match the current condition. (Overrides AspectDependencyCondition..::.Match(IAspectDependencyObject, IAspectDependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


FormatCondition Method

SameAspectInstanceDependencyCondition..::..FormatCondition Method
SameAspectInstanceDependencyCondition Class See Also Send Feedback
Gets a human-readable string explaining the fact that a dependency object matches the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string FormatCondition(
    IAspectDependencyObject right
)

Parameters

right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
A dependency object, evaluated in the right member of the condition.

Return Value

A human-readable string explain that the object on the left of the string does not match the current condition, where the right member of the condition is right. For instance: "equals <right>\"{0}\""

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


Match Method

SameAspectInstanceDependencyCondition..::..Match Method
SameAspectInstanceDependencyCondition Class See Also Send Feedback
Determines whether a pair of objects match the current condition.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Match(
    IAspectDependencyObject left,
    IAspectDependencyObject right
)

Parameters

left
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Left member of the condition.
right
Type: PostSharp.Sdk.AspectInfrastructure..::.IAspectDependencyObject
Right member of the condition.

Return Value

true if left and right match the condition, otherwise false.

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


ToString Method

SameAspectInstanceDependencyCondition..::..ToString Method
SameAspectInstanceDependencyCondition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.AspectWeaver.Dependencies
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

SameAspectInstanceDependencyCondition Class
PostSharp.Sdk.AspectWeaver.Dependencies Namespace


PostSharp.Sdk.AspectWeaver.Transformations Namespace

PostSharp.Sdk.AspectWeaver.Transformations Namespace
Send Feedback
The PostSharp.Sdk.AspectWeaver.Transformations namespace provides classes from which user-defined transformations can be derived.

Classes

 | Class | Description
Public class | ArgumentsWriter | Emits instructions that handle Arguments objects.
Public class | MethodBodyTransformation | An AspectWeaverTransformation that modifies the stream of MSIL instructions of method bodies.
Public class | MethodBodyTransformationInstance | Extension of the MethodBodyTransformationInstance class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.
Public class | StructuralTransformation | An AspectWeaverTransformation that does not affect the stream of MSIL instructions of a method.
Public class | StructuralTransformationInstance | Extension of the StructuralTransformation class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.


ArgumentsWriter Class

ArgumentsWriter Class
Members See Also Send Feedback
Emits instructions that handle Arguments objects.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class ArgumentsWriter

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver.Transformations..::.ArgumentsWriter

See Also

ArgumentsWriter Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


ArgumentsWriter Members

[image]

PostSharp 2.0 Documentation
ArgumentsWriter Members
ArgumentsWriter Class Methods Properties See Also Send Feedback

The ArgumentsWriter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Overloaded.
Public method | EmitCreateArguments | Emits instructions that create a new Arguments object based on a given MethodMappingWriter and stores it in a local variable.
Public method | EmitLoadArgument | Emits instructions that load a given argument on the stack.
Public method | EmitLoadArgumentAddress | Emits instructions that load the address of a given argument on the stack.
Public method | EmitLoadArguments | Emits instructions that load the Arguments object on the stack.
Public method | EmitStoreByRefArgument | Overloaded.
Public method | EmitStoreByRefArguments | Emits instructions that store the value of all out or ref parameters of a method (loaded using a MethodMappingWriter) into an Arguments object.
 | GetArgumentsWriter | Overloaded.
Public method | Reset | Resets any stateful information of the current ArgumentsWriter.
Public method | SetLoadArgumentsAction | Instructs the current ArgumentsWriter how the Arguments object can be loaded.
Public method | SetLoadArgumentsFromVariable | Instructs the current ArgumentsWriter that the Arguments object is stored in a given local variable.

Properties

 | Name | Description
Public property | ArgumentsType | Gets the specific type of the Arguments object.
Public property | CacheVariable | Gets the local variable in which the Arguments object is cached.
Public property | CanLoadArgumentAddress | Determines whether the current ArgumentsWriter is able to load the address of arguments.
Public property | HasLoadArgumentsAction | Determines whether the current ArgumentsWriter knows how to load the Arguments object.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


ArgumentsWriter Methods

[image]

PostSharp 2.0 Documentation
ArgumentsWriter Methods
ArgumentsWriter Class See Also Send Feedback

The ArgumentsWriter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Overloaded.
Public method | EmitCreateArguments | Emits instructions that create a new Arguments object based on a given MethodMappingWriter and stores it in a local variable.
Public method | EmitLoadArgument | Emits instructions that load a given argument on the stack.
Public method | EmitLoadArgumentAddress | Emits instructions that load the address of a given argument on the stack.
Public method | EmitLoadArguments | Emits instructions that load the Arguments object on the stack.
Public method | EmitStoreByRefArgument | Overloaded.
Public method | EmitStoreByRefArguments | Emits instructions that store the value of all out or ref parameters of a method (loaded using a MethodMappingWriter) into an Arguments object.
 | GetArgumentsWriter | Overloaded.
Public method | Reset | Resets any stateful information of the current ArgumentsWriter.
Public method | SetLoadArgumentsAction | Instructs the current ArgumentsWriter how the Arguments object can be loaded.
Public method | SetLoadArgumentsFromVariable | Instructs the current ArgumentsWriter that the Arguments object is stored in a given local variable.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Clone Method

[image]

PostSharp 2.0 Documentation
ArgumentsWriter..::..Clone Method
ArgumentsWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()() | Clones the current ArgumentsWriter.
Public method | Clone(Boolean) | Clones the current ArgumentsWriter and specifies whether the clone should be reset.

See Also

ArgumentsWriter Class
ArgumentsWriter Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Clone Method

ArgumentsWriter..::..Clone Method
ArgumentsWriter Class See Also Send Feedback
Clones the current ArgumentsWriter.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArgumentsWriter Clone()

Return Value

A clone of the current ArgumentsWriter.

See Also

ArgumentsWriter Class
Clone Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Clone Method (Boolean)

ArgumentsWriter..::..Clone Method (Boolean)
ArgumentsWriter Class See Also Send Feedback
Clones the current ArgumentsWriter and specifies whether the clone should be reset.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArgumentsWriter Clone(
    bool reset
)

Parameters

reset
Type: System..::.Boolean
true if all stateful information of the ArgumentsWriter should be cleared, otherwise false.

Return Value

A clone of the current ArgumentsWriter.

See Also

ArgumentsWriter Class
Clone Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitCreateArguments Method

ArgumentsWriter..::..EmitCreateArguments Method
ArgumentsWriter Class See Also Send Feedback
Emits instructions that create a new Arguments object based on a given MethodMappingWriter and stores it in a local variable.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitCreateArguments(
    MethodMappingWriter methodMappingWriter,
    InstructionWriter instructionWriter
)

Parameters

methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
A MethodMappingWriter.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitLoadArgument Method

ArgumentsWriter..::..EmitLoadArgument Method
ArgumentsWriter Class See Also Send Feedback
Emits instructions that load a given argument on the stack.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitLoadArgument(
    int index,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitLoadArgumentAddress Method

ArgumentsWriter..::..EmitLoadArgumentAddress Method
ArgumentsWriter Class See Also Send Feedback
Emits instructions that load the address of a given argument on the stack.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void EmitLoadArgumentAddress(
    int index,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitLoadArguments Method

ArgumentsWriter..::..EmitLoadArguments Method
ArgumentsWriter Class See Also Send Feedback
Emits instructions that load the Arguments object on the stack.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadArguments(
    InstructionWriter instructionWriter
)

Parameters

instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitStoreByRefArgument Method

[image]

PostSharp 2.0 Documentation
ArgumentsWriter..::..EmitStoreByRefArgument Method
ArgumentsWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmitStoreByRefArgument(Int32, MethodMappingWriter, InstructionWriter) | Emits instructions that read the value of an out or ref parameter using a MethodMappingWriter and store this value into the Arguments object.
Public method | EmitStoreByRefArgument(Int32, InstructionWriter, Action<(Of <(InstructionWriter>)>)) | Emits instructions that store a value, loaded on the stack by the instructions emitted by a given delegate, into the Arguments object.

See Also

ArgumentsWriter Class
ArgumentsWriter Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitStoreByRefArgument Method (Int32, MethodMappingWriter, InstructionWriter)

ArgumentsWriter..::..EmitStoreByRefArgument Method (Int32, MethodMappingWriter, InstructionWriter)
ArgumentsWriter Class See Also Send Feedback
Emits instructions that read the value of an out or ref parameter using a MethodMappingWriter and store this value into the Arguments object.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreByRefArgument(
    int index,
    MethodMappingWriter methodMappingWriter,
    InstructionWriter instructionWriter
)

Parameters

index
Type: System..::.Int32
Argument index.
methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
The MethodMappingWriter from which the argument should be read.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

ArgumentsWriter Class
EmitStoreByRefArgument Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitStoreByRefArgument Method (Int32, InstructionWriter, Action(InstructionWriter))

ArgumentsWriter..::..EmitStoreByRefArgument Method (Int32, InstructionWriter, Action<(Of <(<'InstructionWriter>)>)>)
ArgumentsWriter Class See Also Send Feedback
Emits instructions that store a value, loaded on the stack by the instructions emitted by a given delegate, into the Arguments object.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitStoreByRefArgument(
    int index,
    InstructionWriter instructionWriter,
    Action<InstructionWriter> loadValueAction
)

Parameters

index
Type: System..::.Int32
Argument index.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.
loadValueAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
A delegate that emits instructions that load the value to be stored.

See Also

ArgumentsWriter Class
EmitStoreByRefArgument Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


EmitStoreByRefArguments Method

ArgumentsWriter..::..EmitStoreByRefArguments Method
ArgumentsWriter Class See Also Send Feedback
Emits instructions that store the value of all out or ref parameters of a method (loaded using a MethodMappingWriter) into an Arguments object.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitStoreByRefArguments(
    MethodMappingWriter methodMappingWriter,
    InstructionWriter instructionWriter
)

Parameters

methodMappingWriter
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodMappingWriter
The MethodMappingWriter from which values are loaded.
instructionWriter
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An ArgumentsWriter.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


GetArgumentsWriter Method

[image]

PostSharp 2.0 Documentation
ArgumentsWriter..::..GetArgumentsWriter Method
ArgumentsWriter Class See Also Send Feedback

Overload List

Name | Description
GetArgumentsWriter(IMethodSignature) | Gets an ArgumentsWriter able to build an Arguments object for a given method signature.
GetArgumentsWriter(IMethodSignature, Int32, Int32) | Gets an ArgumentsWriter able to build an Arguments object for a given method signature, and allows to ignore the first and last parameters of this signature.

See Also

ArgumentsWriter Class
ArgumentsWriter Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


GetArgumentsWriter Method (IMethodSignature)

ArgumentsWriter..::..GetArgumentsWriter Method (IMethodSignature)
ArgumentsWriter Class See Also Send Feedback
Gets an ArgumentsWriter able to build an Arguments object for a given method signature.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ArgumentsWriter GetArgumentsWriter(
    IMethodSignature methodSignature
)

Parameters

methodSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature for which the Arguments object should be built.

Return Value

An ArgumentsWriter able to build an Arguments object for methodSignature.

See Also

ArgumentsWriter Class
GetArgumentsWriter Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


GetArgumentsWriter Method (IMethodSignature, Int32, Int32)

ArgumentsWriter..::..GetArgumentsWriter Method (IMethodSignature, Int32, Int32)
ArgumentsWriter Class See Also Send Feedback
Gets an ArgumentsWriter able to build an Arguments object for a given method signature, and allows to ignore the first and last parameters of this signature.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ArgumentsWriter GetArgumentsWriter(
    IMethodSignature methodSignature,
    int ignoredFirstParameters,
    int ignoredLastParameters
)

Parameters

methodSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature for which the Arguments object should be built.
ignoredFirstParameters
Type: System..::.Int32
Number of parameters that must be ignored at the beginning of the method signature.
ignoredLastParameters
Type: System..::.Int32
Number of parameters that must be ignored at the end of the method signature.

Return Value

An ArgumentsWriter able to build an Arguments object for methodSignature.

See Also

ArgumentsWriter Class
GetArgumentsWriter Overload
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Reset Method

ArgumentsWriter..::..Reset Method
ArgumentsWriter Class See Also Send Feedback
Resets any stateful information of the current ArgumentsWriter.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void Reset()

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


SetLoadArgumentsAction Method

ArgumentsWriter..::..SetLoadArgumentsAction Method
ArgumentsWriter Class See Also Send Feedback
Instructs the current ArgumentsWriter how the Arguments object can be loaded.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetLoadArgumentsAction(
    Action<InstructionWriter> loadArgumentsAction,
    ITypeSignature sourceType
)

Parameters

loadArgumentsAction
Type: System..::.Action <(Of <(<' InstructionWriter >)>)>
Delegate that emits instructions that load the Arguments object on the type.
sourceType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the object pushed on the stack by loadArgumentsAction.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


SetLoadArgumentsFromVariable Method

ArgumentsWriter..::..SetLoadArgumentsFromVariable Method
ArgumentsWriter Class See Also Send Feedback
Instructs the current ArgumentsWriter that the Arguments object is stored in a given local variable.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetLoadArgumentsFromVariable(
    LocalVariableSymbol variable
)

Parameters

variable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The local variable from which the Arguments object can be loaded.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


ArgumentsWriter Properties

[image]

PostSharp 2.0 Documentation
ArgumentsWriter Properties
ArgumentsWriter Class See Also Send Feedback

The ArgumentsWriter type exposes the following members.

Properties

 | Name | Description
Public property | ArgumentsType | Gets the specific type of the Arguments object.
Public property | CacheVariable | Gets the local variable in which the Arguments object is cached.
Public property | CanLoadArgumentAddress | Determines whether the current ArgumentsWriter is able to load the address of arguments.
Public property | HasLoadArgumentsAction | Determines whether the current ArgumentsWriter knows how to load the Arguments object.

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


ArgumentsType Property

ArgumentsWriter..::..ArgumentsType Property
ArgumentsWriter Class See Also Send Feedback
Gets the specific type of the Arguments object.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ArgumentsType { get; private set; }

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


CacheVariable Property

ArgumentsWriter..::..CacheVariable Property
ArgumentsWriter Class See Also Send Feedback
Gets the local variable in which the Arguments object is cached.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol CacheVariable { get; private set; }

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


CanLoadArgumentAddress Property

ArgumentsWriter..::..CanLoadArgumentAddress Property
ArgumentsWriter Class See Also Send Feedback
Determines whether the current ArgumentsWriter is able to load the address of arguments.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool CanLoadArgumentAddress { get; }

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


HasLoadArgumentsAction Property

ArgumentsWriter..::..HasLoadArgumentsAction Property
ArgumentsWriter Class See Also Send Feedback
Determines whether the current ArgumentsWriter knows how to load the Arguments object.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasLoadArgumentsAction { get; }

See Also

ArgumentsWriter Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace
ArgumentsWriter..::.SetLoadArgumentsFromVariable(LocalVariableSymbol)


MethodBodyTransformation Class

MethodBodyTransformation Class
Members See Also Send Feedback
An AspectWeaverTransformation that modifies the stream of MSIL instructions of method bodies.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodBodyTransformation : AspectWeaverTransformation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
PostSharp.Sdk.AspectWeaver.Transformations..::.MethodBodyTransformation

See Also

MethodBodyTransformation Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformation Members

[image]

PostSharp 2.0 Documentation
MethodBodyTransformation Members
MethodBodyTransformation Class Constructors Methods Properties See Also Send Feedback

The MethodBodyTransformation type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodBodyTransformation | Initializes a new MethodBodyTransformation.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation. (Inherited from AspectWeaverTransformation.)

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaverTransformation.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverTransformation.)
Public property | Effects | Gets the set of effects of the current transformation. (Inherited from AspectWeaverTransformation.)
Public property | IsCommutative | Determines whether the current transformation is commutative. (Inherited from AspectWeaverTransformation.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverTransformation.)

See Also

MethodBodyTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformation Constructor

MethodBodyTransformation Constructor
MethodBodyTransformation Class See Also Send Feedback
Initializes a new MethodBodyTransformation.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodBodyTransformation(
    AspectWeaver aspectWeaver
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaver
The parent AspectWeaver.

See Also

MethodBodyTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformation Methods

[image]

PostSharp 2.0 Documentation
MethodBodyTransformation Methods
MethodBodyTransformation Class See Also Send Feedback

The MethodBodyTransformation type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation. (Inherited from AspectWeaverTransformation.)

See Also

MethodBodyTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformation Properties

[image]

PostSharp 2.0 Documentation
MethodBodyTransformation Properties
MethodBodyTransformation Class See Also Send Feedback

The MethodBodyTransformation type exposes the following members.

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaverTransformation.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverTransformation.)
Public property | Effects | Gets the set of effects of the current transformation. (Inherited from AspectWeaverTransformation.)
Public property | IsCommutative | Determines whether the current transformation is commutative. (Inherited from AspectWeaverTransformation.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverTransformation.)

See Also

MethodBodyTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformationInstance Class

MethodBodyTransformationInstance Class
Members See Also Send Feedback
Extension of the MethodBodyTransformationInstance class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodBodyTransformationInstance : AspectWeaverTransformationInstance,
    IMethodBodyTransformationInstance, ITransformationInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationInstance
PostSharp.Sdk.AspectWeaver.Transformations..::.MethodBodyTransformationInstance

See Also

MethodBodyTransformationInstance Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformationInstance Members

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationInstance Members
MethodBodyTransformationInstance Class Constructors Methods Properties See Also Send Feedback

The MethodBodyTransformationInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | MethodBodyTransformationInstance | Initializes a new MethodBodyTransformationInstance.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Public method | GetOptions | Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.
Public method | HasEffect | Determines whether the current transformation has a given effect. (Inherited from AspectWeaverTransformationInstance.)
Public method | Implement | Implements the transformation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverTransformationInstance.)

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformationInstance.)
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance. (Inherited from AspectWeaverTransformationInstance.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from AspectWeaverTransformationInstance.)
Public property | Transformation | Gets the parent AspectWeaverTransformation. (Inherited from AspectWeaverTransformationInstance.)

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformationInstance Constructor

MethodBodyTransformationInstance Constructor
MethodBodyTransformationInstance Class See Also Send Feedback
Initializes a new MethodBodyTransformationInstance.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected MethodBodyTransformationInstance(
    MethodBodyTransformation parent,
    AspectWeaverInstance aspectWeaverInstance
)

Parameters

parent
Type: PostSharp.Sdk.AspectWeaver.Transformations..::.MethodBodyTransformation
The parent MethodBodyTransformation.
aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The related AspectWeaverInstance.

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationInstance Methods
MethodBodyTransformationInstance Class See Also Send Feedback

The MethodBodyTransformationInstance type exposes the following members.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Public method | GetOptions | Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.
Public method | HasEffect | Determines whether the current transformation has a given effect. (Inherited from AspectWeaverTransformationInstance.)
Public method | Implement | Implements the transformation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverTransformationInstance.)

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


AddSymJoinPoint Method

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationInstance..::..AddSymJoinPoint Method
MethodBodyTransformationInstance Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddSymJoinPoint(TransformationContext) | Adds a join point to the symbol file for the current transformation given a TransformationContext. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(TransformationContext, String) | Adds a join point to the symbol file for the current transformation given a TransformationContext, with the possibility to override the description of the join point. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32) | Adds a join point to the symbol file for the current transformation, using GetDisplayName(MethodSemantics) to get the description of the join point. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32, String) | Adds a join point to the symbol file for the current transformation, with the possibility to override the description of the join point. (Inherited from AspectWeaverTransformationInstance.)

See Also

MethodBodyTransformationInstance Class
MethodBodyTransformationInstance Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


GetOptions Method

MethodBodyTransformationInstance..::..GetOptions Method
MethodBodyTransformationInstance Class See Also Send Feedback
Gets options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract MethodBodyTransformationOptions GetOptions(
    MetadataDeclaration originalTargetElement,
    MethodSemantics semantic
)

Parameters

originalTargetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element of code to which the transformation will be applied.
semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic of the method (if the method is a member of a property or event).

Return Value

Options that allow the aspect framework to predict the behavior of the Implement(MethodBodyTransformationContext) method

Implements

IMethodBodyTransformationInstance..::.GetOptions(MetadataDeclaration, MethodSemantics)

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Implement Method

MethodBodyTransformationInstance..::..Implement Method
MethodBodyTransformationInstance Class See Also Send Feedback
Implements the transformation.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void Implement(
    MethodBodyTransformationContext context
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.MethodBodyTransformationContext
Context.

Implements

IMethodBodyTransformationInstance..::.Implement(MethodBodyTransformationContext)

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


MethodBodyTransformationInstance Properties

[image]

PostSharp 2.0 Documentation
MethodBodyTransformationInstance Properties
MethodBodyTransformationInstance Class See Also Send Feedback

The MethodBodyTransformationInstance type exposes the following members.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformationInstance.)
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance. (Inherited from AspectWeaverTransformationInstance.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from AspectWeaverTransformationInstance.)
Public property | Transformation | Gets the parent AspectWeaverTransformation. (Inherited from AspectWeaverTransformationInstance.)

See Also

MethodBodyTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformation Class

StructuralTransformation Class
Members See Also Send Feedback
An AspectWeaverTransformation that does not affect the stream of MSIL instructions of a method.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class StructuralTransformation : AspectWeaverTransformation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformation
PostSharp.Sdk.AspectWeaver.Transformations..::.StructuralTransformation

See Also

StructuralTransformation Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformation Members

[image]

PostSharp 2.0 Documentation
StructuralTransformation Members
StructuralTransformation Class Constructors Methods Properties See Also Send Feedback

The StructuralTransformation type exposes the following members.

Constructors

 | Name | Description
Protected method | StructuralTransformation | Initializes a new StructuralTransformation.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation. (Inherited from AspectWeaverTransformation.)

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaverTransformation.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverTransformation.)
Public property | Effects | Gets the set of effects of the current transformation. (Inherited from AspectWeaverTransformation.)
Public property | IsCommutative | Determines whether the current transformation is commutative. (Inherited from AspectWeaverTransformation.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverTransformation.)

See Also

StructuralTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformation Constructor

StructuralTransformation Constructor
StructuralTransformation Class See Also Send Feedback
Initializes a new StructuralTransformation.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected StructuralTransformation(
    AspectWeaver aspectWeaver
)

Parameters

aspectWeaver
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaver
The parent AspectWeaver.

See Also

StructuralTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformation Methods

[image]

PostSharp 2.0 Documentation
StructuralTransformation Methods
StructuralTransformation Class See Also Send Feedback

The StructuralTransformation type exposes the following members.

Methods

 | Name | Description
Public method | GetDisplayName | Gets the human-readable name of the current transformation. (Inherited from AspectWeaverTransformation.)

See Also

StructuralTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformation Properties

[image]

PostSharp 2.0 Documentation
StructuralTransformation Properties
StructuralTransformation Class See Also Send Feedback

The StructuralTransformation type exposes the following members.

Properties

 | Name | Description
Public property | AspectInfrastructureTask | Gets the parent AspectInfrastructureTask. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformation.)
Public property | AspectWeaverTask | Gets the parent AspectWeaverTask. (Inherited from AspectWeaverTransformation.)
Public property | Dependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on the element of code to which this aspect is applied. (Inherited from AspectWeaverTransformation.)
Public property | Effects | Gets the set of effects of the current transformation. (Inherited from AspectWeaverTransformation.)
Public property | IsCommutative | Determines whether the current transformation is commutative. (Inherited from AspectWeaverTransformation.)
Public property | TypeLevelDependencies | Gets the collection of dependencies (AspectDependency) of the current transformation (where dependency objects of the current aspect occupy the left position of the relationship), for dependency objects that apply on type declaring the element of code to which this aspect is applied. If the aspect is not applied to a type member (or a parameter of a type member), this property is equal to Dependencies. (Inherited from AspectWeaverTransformation.)

See Also

StructuralTransformation Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformationInstance Class

StructuralTransformationInstance Class
Members See Also Send Feedback
Extension of the StructuralTransformation class that is specific to an aspect instance; an aspect instance (AspectWeaverInstance) appears when an aspect type is applied to an element of code.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class StructuralTransformationInstance : AspectWeaverTransformationInstance,
    IStructuralTransformationInstance, ITransformationInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTransformationInstance
PostSharp.Sdk.AspectWeaver.Transformations..::.StructuralTransformationInstance

See Also

StructuralTransformationInstance Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformationInstance Members

[image]

PostSharp 2.0 Documentation
StructuralTransformationInstance Members
StructuralTransformationInstance Class Constructors Methods Properties See Also Send Feedback

The StructuralTransformationInstance type exposes the following members.

Constructors

 | Name | Description
Protected method | StructuralTransformationInstance | Initializes a new StructuralTransformationInstance.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Public method | HasEffect | Determines whether the current transformation has a given effect. (Inherited from AspectWeaverTransformationInstance.)
Public method | Implement | Implements the transformation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverTransformationInstance.)

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformationInstance.)
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance. (Inherited from AspectWeaverTransformationInstance.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from AspectWeaverTransformationInstance.)
Public property | Transformation | Gets the parent AspectWeaverTransformation. (Inherited from AspectWeaverTransformationInstance.)

See Also

StructuralTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformationInstance Constructor

StructuralTransformationInstance Constructor
StructuralTransformationInstance Class See Also Send Feedback
Initializes a new StructuralTransformationInstance.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected StructuralTransformationInstance(
    StructuralTransformation parent,
    AspectWeaverInstance aspectWeaverInstance
)

Parameters

parent
Type: PostSharp.Sdk.AspectWeaver.Transformations..::.StructuralTransformation
The parent StructuralTransformation.
aspectWeaverInstance
Type: PostSharp.Sdk.AspectWeaver..::.AspectWeaverInstance
The related AspectWeaverInstance.

See Also

StructuralTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformationInstance Methods

[image]

PostSharp 2.0 Documentation
StructuralTransformationInstance Methods
StructuralTransformationInstance Class See Also Send Feedback

The StructuralTransformationInstance type exposes the following members.

Methods

 | Name | Description
Protected method | AddDependency | Adds a new AspectDependency to the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint | Overloaded.
Public method | GetDisplayName | Gets a human-readable description of the current transformation. (Inherited from AspectWeaverTransformationInstance.)
Public method | HasEffect | Determines whether the current transformation has a given effect. (Inherited from AspectWeaverTransformationInstance.)
Public method | Implement | Implements the transformation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from AspectWeaverTransformationInstance.)

See Also

StructuralTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


AddSymJoinPoint Method

[image]

PostSharp 2.0 Documentation
StructuralTransformationInstance..::..AddSymJoinPoint Method
StructuralTransformationInstance Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddSymJoinPoint(TransformationContext) | Adds a join point to the symbol file for the current transformation given a TransformationContext. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(TransformationContext, String) | Adds a join point to the symbol file for the current transformation given a TransformationContext, with the possibility to override the description of the join point. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32) | Adds a join point to the symbol file for the current transformation, using GetDisplayName(MethodSemantics) to get the description of the join point. (Inherited from AspectWeaverTransformationInstance.)
Protected method | AddSymJoinPoint(MetadataDeclaration, MethodSemantics, Int32, String) | Adds a join point to the symbol file for the current transformation, with the possibility to override the description of the join point. (Inherited from AspectWeaverTransformationInstance.)

See Also

StructuralTransformationInstance Class
StructuralTransformationInstance Members
PostSharp.Sdk.AspectWeaver.Transformations Namespace


Implement Method

StructuralTransformationInstance..::..Implement Method
StructuralTransformationInstance Class See Also Send Feedback
Implements the transformation.

Namespace: PostSharp.Sdk.AspectWeaver.Transformations
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void Implement(
    TransformationContext context
)

Parameters

context
Type: PostSharp.Sdk.AspectInfrastructure..::.TransformationContext
Context.

Implements

IStructuralTransformationInstance..::.Implement(TransformationContext)

See Also

StructuralTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


StructuralTransformationInstance Properties

[image]

PostSharp 2.0 Documentation
StructuralTransformationInstance Properties
StructuralTransformationInstance Class See Also Send Feedback

The StructuralTransformationInstance type exposes the following members.

Properties

 | Name | Description
Public property | AspectWeaver | Gets the parent AspectWeaver. (Inherited from AspectWeaverTransformationInstance.)
Public property | AspectWeaverInstance | Gets the parent AspectWeaverInstance. (Inherited from AspectWeaverTransformationInstance.)
Public property | IsCommutative | Determines whether the current object is commutative with any other object, irrespective of dependencies or effects. (Inherited from AspectWeaverTransformationInstance.)
Public property | Transformation | Gets the parent AspectWeaverTransformation. (Inherited from AspectWeaverTransformationInstance.)

See Also

StructuralTransformationInstance Class
PostSharp.Sdk.AspectWeaver.Transformations Namespace


PostSharp.Sdk.CodeModel Namespace

PostSharp.Sdk.CodeModel Namespace
Send Feedback
The PostSharp.Sdk.CodeModel namespace contains types that constitute the PostSharp's internal representation of an assembly.

Classes

 | Class | Description
Public class | AssemblyBindingPolicy | Specifies a mapping between an assembly reference and the assembly to which the reference is actually resolve. Assembly redirection policies allow to substitute other assemblies to the ones that are actually requested, and therefore support newer versions of these assemblies, or even different variants of the .NET Framework.
Public class | AssemblyBindingPolicyManager | Manages and resolves assembly redirection policies.
Public class | AssemblyEnvelope | Represents an assembly understood basically, internally, as a collection of modules (ModuleDeclaration) and, externally, as a collection of exported types.
Public class | AssemblyLoadException | Exception thrown when an assembly cannot be loaded.
Public class | AssemblyLoadHelper | Helper class to load assemblies. Provides a "binding log" for our custom binder and appends this log in exception text.
Public class | AssemblyLoadingEventArgs | Arguments of the event AssemblyLoading.
Public class | AssemblyLocateEventArgs | Arguments of the LocatingAssembly event.
Public class | AssemblyLocator | Locates an assembly in the search path or in GAC.
Public class | AssemblyManifestDeclaration | Represents an assembly manifest (Assembly).
Public class | AssemblyNameExtensions | Extension methods for the IAssemblyName interface.
Public class | AssemblyNameWrapper | Wraps an AssemblyName into an IAssemblyName.
Public class | AssemblyRefDeclaration | Represents a reference to an external assembly (AssemblyRef).
Public class | BaseInstructionWriter | Provides the base operations for emitting IL instructions. This abstract class does not specify to which kind of target instructions are written. This is specific to classes deriving BaseInstructionWriter.
Public class | BindingException | Exception thrown when a binding exception occurs in PostSharp.
Public class | CustomAttributeConstructorException | Wraps any exception thrown during the construction of a custom attribute runtime instance.
Public class | CustomAttributeDeclaration | Represents a custom attribute (CustomAttribute).
Public class | CustomAttributeHelper | Extension methods for IAnnotationValue.
Public class | DataSectionDeclaration | Represents a data section, where initial values of fieds are stored.
Public class | Declaration | Base type for all declarations of a module.
Public class | DeclarationCache | Caches some frequently-used declarations or constructions with lazy loading.
Public class | Domain | A domain is a scope, i.e. a context in which external references are resolved. A domain contains assemblies.
Public class | Element | Represents an element of a tree structure.
Public class | EventDeclaration | Represents an event (Event).
Public class | ExceptionHandler | Represents an exception handler.
Public class | ExportedTypeDeclaration | Represents a type exported by the current assembly but not defined in the current module.
Public class | FieldDefDeclaration | Represents a field definition (FieldDef).
Public class | FieldRefDeclaration | Represents a reference to a field of a type defined in an external assembly (MemberRef).
Public class | GenericEventReference | Reference to an EventDeclaration combined with a GenericMap specifying the generic arguments of this event with respect to the context that returned the GenericEventReference.
Public class | GenericFieldReference | Reference to a FieldDefDeclaration combined with a GenericMap specifying the generic arguments of this field with respect to the context that returned the GenericFieldReference.
Public class | GenericHelper | Extension methods for generic types and methods.
Public class | GenericMethodReference | Reference to a MethodDefDeclaration combined with a GenericMap specifying the generic arguments of this method with respect to the context that returned the GenericMethodReference.
Public class | GenericParameterConstraintDeclaration | Represents a constraint of a generic parameter (GenericParamConstraint).
Public class | GenericParameterDeclaration | Represents a generic parameter (GenericParam).
Public class | GenericPropertyReference | Reference to a PropertyDeclaration combined with a GenericMap specifying the generic arguments of this property with respect to the context that returned the GenericPropertyReference.
Public class | Instruction | Gives read-only access to the current instruction of an InstructionReader.
Public class | InstructionBlock | A single node of the hierarchical structure of a method body.
Public class | InstructionReader | Reads a stream of binary IL instructions and debugging sequence points.
Public class | InstructionReaderBookmark | Bookmark for the InstructionReader class.
Public class | InstructionSequence | Represents a sequence of instructions without branches, i.e. the control flow necessarily begins at the beginning of the sequence and ends at the end of the sequence.
Public class | InstructionWriter | writer a linear stream of instructions into an InstructionSequence.
Public class | InterfaceImplementationDeclaration | Represents an interface implementation (InterfaceImpl) of a TypeDefDeclaration.
Public class | LocalVariableDeclaration | Represents a local variable. Local variables are owned by method bodies (MethodBodyDeclaration).
Public class | LocalVariableSymbol | Assigns a name to a local variable LocalVariableDeclaration. Local variable symbols belong to an InstructionBlock, which is in the current case the lexical scope of the variable.
Public class | ManifestFileDeclaration | Represents a file reference (File).
Public class | ManifestResourceDeclaration | Represents a resource referenced by the assembly (ManifestResource).
Public class | MarshalType | Marshal types. Determines how fields and parameters are marshaled during PInvoke.
Public class | MemberRefDeclaration | Represents a reference to a field or method (MemberRef). This type is the base of FieldRefDeclaration and MethodRefDeclaration.
Public class | MemberValuePair | Represents the fact that a member is assigned a value.
Public class | MetadataDeclaration | Base class for all declarations represented in the metadata tables. Metadata declarations have a token (MetadataToken) and may have custom attributes (CustomAttributeDeclaration).
Public class | MetadataDeclarationTables | Exposes the metadata tables.
Public class | MethodBodyDeclaration | Represents the IL body of a method.
Public class | MethodDefDeclaration | Represents a method definition (MethodDef).
Public class | MethodGroupDeclaration | Implements the functionalities that are common to PropertyDeclaration and EventDeclaration, which are both lexical collections of method semantics (MethodSemanticDeclaration).
Public class | MethodImplementationDeclaration | Represents a method implementation (MethodImpl), i.e. an indication of the interface method being implemented by the current MethodDefDeclaration.
Public class | MethodRefDeclaration | Represents a method reference.
Public class | MethodSemanticDeclaration | Represents a method semantic (MethodSemantic), i.e. the association of a method and a role in a collection (PropertyDeclaration or EventDeclaration).
Public class | MethodSemanticDeclaration..::.BySemanticComparer | Implementation of IComparer<(Of <(T>)>) comparing instances by their Semantic property.
Public class | MethodSignature | Represents a method signature, which specifies primarily a calling convention and the type of parameters.
Public class | MethodSpecDeclaration | Represents a method specification (MethodSpec), i.e. the construction of a concrete generic method.
Public class | ModuleDeclaration | Represents a module (Module).
Public class | ModuleRefDeclaration | Represents a reference to another module in the same assembly (ModuleRef).
Public class | NamedMetadataDeclaration | Extends the MetadataDeclaration class with a Name property.
Public class | NamedPositionedMetadataDeclaration | A NamedMetadataDeclaration with an Ordinal property.
Public class | OpCodeDictionary<(Of <(?0>)>) | Efficient implementation of a dictionary taking an OpCodeNumber as the key type.
Public class | OpCodeMap | Maps OpCodeNumber to OpCode and provides the various properties of opcodes.
Public class | ParameterDeclaration | Represents a method parameter (ParamDef).
Public class | PermissionDeclaration | Represents a permission attribute.
Public class | PermissionSetDeclaration | Represents a permission set (Permission).
Public class | PInvokeMap | Maps a method declaration to an external unmanaged method.
Public class | PlatformInfo | Contains the characteristics of a platform, typically the target platform of the module.
Public class | PropertyDeclaration | Represents a property (Property).
Public class | RawUnmanagedResource | Unmanaged resource given in raw form, as an array of bytes.
Public class | SerializationType | Represents the type of a serialized value.
Public class | SerializedValue | Represents a serialized value and stores enough information to serialize it back using the exact representation.
Public class | StandaloneAssemblyName | Standalone implementation of IAssemblyName.
Public class | StandaloneSignatureDeclaration | Represents a stand-alone signature (Signature).
Public class | TypeDefDeclaration | Represents a type.
Public class | TypeRefDeclaration | Represents a type reference (TypeRef).
Public class | TypeSignature | Represents a type construction (pointer, array, generic type instance, intrinsic, ...).
Public class | TypeSignatureCollection | Collection of types (IType).
Public class | TypeSignatureExtensions |
Public class | TypeSpecDeclaration | Represents a type specification (TypeSpec).
Public class | UnmanagedResource | Abstract class representing an unmanaged (Windows) resource. The only current implementation is RawUnmanagedResource, but later versions may provide implementations for specific types of resources.
Public class | VisibilityHelper | Provides methods that determines the visibility of classes, fields and methods.
Public class | WriteReflectionNameExtensions | Extension methods for the interface IWriteReflectionName.

Structures

 | Structure | Description
Public structure | GenericMap | Map generic arguments to their value.
Public structure | LiteralString | Encapsulates a read-only array of characters.
Public structure | MappedGenericDeclaration<(Of <(?0>)>) | Pair of a generic definition (IGenericDefinition) and a GenericMap.
Public structure | MetadataToken | Encapsulates a metadata token, which unambiguously identifies a MetadataDeclaration inside a ModuleDeclaration.
Public structure | NullableBool | Three-state boolean: True, False and Null.
Public structure | TagId | Unique identifier of a tag of the interface ITaggable.
Public structure | UncompressedOpCode | Uncompressed opcode (i.e. an opcode with its operand).
Public structure | UnmanagedResourceName | Represents the name or the type of an UnmanagedResource, which can consist either in a string, either in an integer.

Interfaces

 | Interface | Description
Public interface | IAnnotationInstance | Exposes the fact that a custom attribute (IAnnotationValue) is applied to an element (MetadataDeclaration).
Public interface | IAnnotationValue | Defines the semantics of a custom attribute value, i.e. basically a constructor, its arguments and other named arguments.
Public interface | IAssembly | Defines the semantics of an assembly (AssemblyRefDeclaration AssemblyEnvelope).
Public interface | IAssemblyDeclaration | Defines the semantics of assemblies.
Public interface | ICloneableModuleElement | A module element that has the ability to create a clone of itself, expressed for a different module.
Public interface | IDeclaration | Exposes the semantics of a declaration, which is basically a module-scoped domain element.
Public interface | IElement | Defines the semantics of a domain element, which is basically a domain-rooted tree node.
Public interface | IField | Defines the semantics of a field (FieldDefDeclaration, FieldRefDeclaration).
Public interface | IGeneric | Exposes the common semantics to generic instances and generic definitions.
Public interface | IGenericDefinition | Exposes the semantics of a generic definition (i.e. a type or method having (unbound) generic parameters). Classes implementing IGenericDefinition can also represent references to generic definitions.
Public interface | IGenericDefinitionDefinition | Exposes the semantics of a generic definition but, unlike IGenericDefinition, are a real definition and not a reference.
Public interface | IGenericInstance | Exposes the semantics of a generic instance (i.e. an instance of generic definition, with concretely specified generic, bound arguments).
Public interface | IGenericMethodDefinition | Declares the semantics of a generic method definition, i.e. a method that may have unbound generic parameter and method constructions (MethodSpecDeclaration).
Public interface | IGenericParameter | Defines the semantics of a generic parameter or argument.
Public interface | IGenericTypeDefinition | A type that can be a generic definition (TypeDefDeclaration or ITypeRefResolutionScope).
Public interface | IManifestResourceImplementation | Defines the semantics that are common to all physical locations that can contain resources (ManifestResourceDeclaration).
Public interface | IMember | Defines the semantics of a type member (DeclaringType and Name properties).
Public interface | IMemberRefResolutionScope | Defines semantics of all classes declaring external fields or methods.
Public interface | IMetadataDeclaration | Defines the semantics of a metadata declaration, i.e. a declaration with a token.
Public interface | IMethod | Defines the functionalities that are common to all representations of a method (MethodDefDeclaration, MethodRefDeclaration, MethodSpecDeclaration).
Public interface | IMethodSignature | Exposes the semantics of a method signature.
Public interface | IModule | Defines the functionalities that are common to all representations of a module (ModuleDeclaration, ModuleRefDeclaration).
Public interface | IModuleElement | Part of a ModuleDeclaration.
Public interface | INamedType | Defines the semantics of a type (IType) that can be named.
Public interface | IRemovable | Defines the semantics of a declaration that can be removed from its parent.
Public interface | ISecurable | Defines semantics of declarations that can be secured by permission sets (TypeDefDeclaration, MethodDefDeclaration, AssemblyManifestDeclaration).
Public interface | ITaggable | Defines the semantics of a taggable object. User code can add custom pieces of information to PostSharp objects using this mechanism. DomainTags are identified by a Guid. There is no difference between an absent tag and a null tag value.
Public interface | IType | Defines the semantics of a type.
Public interface | ITypeContainer | Exposes the semantics of a declaration that can contain type definitions (ModuleDeclaration or TypeDefDeclaration).
Public interface | ITypeRefResolutionScope | Defines semantics of TypeRefDeclaration resolution scopes (TypeRefDeclaration, AssemblyRefDeclaration, ModuleDeclaration).
Public interface | ITypeSignature | Defines the functionalities that are common to all representations of a type (TypeDefDeclaration, TypeRefDeclaration, TypeSpecDeclaration, TypeSignature).
Public interface | IWeakReferenceable | Defines the semantics of declarations (TypeRefDeclaration and AssemblyRefDeclaration) that can be "weakly references".
Public interface | IWriteReflectionName | Defines a method WriteReflectionName(StringBuilder, ReflectionNameOptions).

Delegates

 | Delegate | Description
Public delegate | InstructionAction | Represents an action that performs an action on the current instruction of a specified InstructionReader.

Enumerations

 | Enumeration | Description
Public enumeration | AssemblyRefAttributes | Options of assembly references (AssemblyRefDeclaration).
Public enumeration | BindingOptions | Determines how the binding methods behave when the requested object is not found.
Public enumeration | CallingConvention | Determines the calling convention of methods.
Public enumeration | GenericContextOptions | Options of the GetGenericContext(GenericContextOptions) method.
Public enumeration | GenericParameterKind | Enumerates the kind of classes accepting generic parameters.
Public enumeration | ImageAttributes | Attributes of a .NET PE module.
Public enumeration | InstructionPrefixes | Enumeration of IL prefixes.
Public enumeration | IntrinsicType | Enumeration of primitive types of the .NET runtime. This includes intrinsic types.
Public enumeration | MemberKind | Enumerates the kinds of type members.
Public enumeration | MethodSemantics | Enumerates the method semantics.
Public enumeration | OpCodeNumber | Enumeration of all opcode numbers.
Public enumeration | PInvokeAttributes | P-Invoke attributes.
Public enumeration | PortableExecutableKind | Kinds of PE formats.
Public enumeration | ReadModuleStrategy | Determines how a module should be loaded.
Public enumeration | ReflectionNameOptions | Options for the methods WriteReflectionName(StringBuilder, ReflectionNameOptions).
Public enumeration | SerializedValueBindingOptions | Options for method GetRuntimeValue(SerializedValueBindingOptions).
Public enumeration | StandaloneSignatureKind | Enumerates the kind of stand-alone signatures (StandaloneSignatureDeclaration).
Public enumeration | TokenType | Specifies the type of metadata token.
Public enumeration | TypeClassifications | Type classifications are predicate that applies on types.
Public enumeration | TypeNakingOptions | Determines the behavior of the GetNakedType(TypeNakingOptions) method.
Public enumeration | UnmanagedResourceType | Types of unmanaged resources (like Accelerator, Icon, ...).


AssemblyBindingPolicy Class

AssemblyBindingPolicy Class
Members See Also Send Feedback
Specifies a mapping between an assembly reference and the assembly to which the reference is actually resolve. Assembly redirection policies allow to substitute other assemblies to the ones that are actually requested, and therefore support newer versions of these assemblies, or even different variants of the .NET Framework.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyBindingPolicy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyBindingPolicy

See Also

AssemblyBindingPolicy Members
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicy Members

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicy Members
AssemblyBindingPolicy Class Constructors Methods Properties See Also Send Feedback

The AssemblyBindingPolicy type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyBindingPolicy | Initializes a new AssemblyBindingPolicy.

Methods

 | Name | Description
Public method | Apply | Applies the current policy to an assembly reference and returns the transformed assembly reference.
Public method | Matches | Determines whether the current policy applies to a given assembly name.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Culture | Gets or sets the culture of the assembly reference.
Public property | NewPublicKeyToken | Gets or sets the new public key token of the resolved assembly reference.
Public property | NewVersion | Gets or sets the new version of the resolved assembly reference.
Public property | OldName | Gets or sets the short name of the assembly reference.
Public property | OldPublicKeyToken | Gets or sets the public key token of the assembly reference.
Public property | OldVersionLowerBound | Gets or sets the lower bound of the version of the assembly reference.
Public property | OldVersionUpperBound | Gets or sets the upper bound of the version of the assembly reference.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicy Constructor

AssemblyBindingPolicy Constructor
AssemblyBindingPolicy Class See Also Send Feedback
Initializes a new AssemblyBindingPolicy.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingPolicy(
    string oldShortName,
    byte[] oldPublicKeyToken,
    string culture,
    Version oldVersionLowerBound,
    Version oldVersionUpperBound,
    string newName,
    byte[] newPublicKeyToken,
    Version newVersion
)

Parameters

oldShortName
Type: System..::.String
Short name of the assembly reference, or '*' to match any assembly name.
oldPublicKeyToken
Type: array< System..::.Byte >[]()[][]
Public key token of the assembly reference, or null to match any public key token.
culture
Type: System..::.String
Culture of the assembly reference, or null to match any culture.
oldVersionLowerBound
Type: System..::.Version
Lower bound of the version of the assembly reference, null not to specify any version lower bound.
oldVersionUpperBound
Type: System..::.Version
Upper bound of the version of the assembly reference, null not to specify any version upper bound.
newName
Type: System..::.String
New short name of the resolved assembly reference, or null to copy the reference name.
newPublicKeyToken
Type: array< System..::.Byte >[]()[][]
New public key token of the resolved assembly reference, or null to copy the public key token of the unresolved reference.
newVersion
Type: System..::.Version
New version of the resolved assembly reference, or null to copy the version of the unresolved reference.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicy Methods

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicy Methods
AssemblyBindingPolicy Class See Also Send Feedback

The AssemblyBindingPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Applies the current policy to an assembly reference and returns the transformed assembly reference.
Public method | Matches | Determines whether the current policy applies to a given assembly name.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


Apply Method

AssemblyBindingPolicy..::..Apply Method
AssemblyBindingPolicy Class See Also Send Feedback
Applies the current policy to an assembly reference and returns the transformed assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyName Apply(
    IAssemblyName oldAssemblyName
)

Parameters

oldAssemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name to be transformed.

Return Value

The transformed, resolved assembly name, obtained by applying the current policy.

Remarks

This method assumes that the current policy actually matches oldAssemblyName, which can be determined using the Matches(IAssemblyName) method.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


Matches Method

AssemblyBindingPolicy..::..Matches Method
AssemblyBindingPolicy Class See Also Send Feedback
Determines whether the current policy applies to a given assembly name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Matches(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name (typically an assembly reference).

Return Value

true if the current policy applies to assemblyName, otherwise false.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

AssemblyBindingPolicy..::..ToString Method
AssemblyBindingPolicy Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicy Properties

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicy Properties
AssemblyBindingPolicy Class See Also Send Feedback

The AssemblyBindingPolicy type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets or sets the culture of the assembly reference.
Public property | NewPublicKeyToken | Gets or sets the new public key token of the resolved assembly reference.
Public property | NewVersion | Gets or sets the new version of the resolved assembly reference.
Public property | OldName | Gets or sets the short name of the assembly reference.
Public property | OldPublicKeyToken | Gets or sets the public key token of the assembly reference.
Public property | OldVersionLowerBound | Gets or sets the lower bound of the version of the assembly reference.
Public property | OldVersionUpperBound | Gets or sets the upper bound of the version of the assembly reference.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

AssemblyBindingPolicy..::..Culture Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the culture of the assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; }

Field Value

Culture of the assembly reference, or null to match any culture.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


NewPublicKeyToken Property

AssemblyBindingPolicy..::..NewPublicKeyToken Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the new public key token of the resolved assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] NewPublicKeyToken { get; }

Field Value

The new public key token of the resolved assembly reference, or null to copy the public key token of the unresolved reference.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


NewVersion Property

AssemblyBindingPolicy..::..NewVersion Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the new version of the resolved assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version NewVersion { get; }

Field Value

New version of the resolved assembly reference, or null to copy the version of the unresolved reference.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


OldName Property

AssemblyBindingPolicy..::..OldName Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the short name of the assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OldName { get; }

Field Value

The short name of the assembly reference, or '*' to match any assembly name.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


OldPublicKeyToken Property

AssemblyBindingPolicy..::..OldPublicKeyToken Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the public key token of the assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] OldPublicKeyToken { get; }

Field Value

The public key token of the assembly reference, or null to match any public key token.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


OldVersionLowerBound Property

AssemblyBindingPolicy..::..OldVersionLowerBound Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the lower bound of the version of the assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version OldVersionLowerBound { get; }

Field Value

Lower bound of the version of the assembly reference, null not to specify any version lower bound.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


OldVersionUpperBound Property

AssemblyBindingPolicy..::..OldVersionUpperBound Property
AssemblyBindingPolicy Class See Also Send Feedback
Gets or sets the upper bound of the version of the assembly reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version OldVersionUpperBound { get; }

Field Value

Upper bound of the version of the assembly reference, null not to specify any version upper bound.

See Also

AssemblyBindingPolicy Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicyManager Class

AssemblyBindingPolicyManager Class
Members See Also Send Feedback
Manages and resolves assembly redirection policies.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyBindingPolicyManager

Remarks

Assembly redirection is the process of replacing an assembly reference by another reference, allowing to load another assembly than the one that is actually referenced.

The resolved and redirected assembly name is here named the canonical assembly name.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyBindingPolicyManager

See Also

AssemblyBindingPolicyManager Members
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicyManager Members

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicyManager Members
AssemblyBindingPolicyManager Class Methods See Also Send Feedback

The AssemblyBindingPolicyManager type exposes the following members.

Methods

 | Name | Description
Public method | EvaluatePolicy | Applies redirection policies on an assembly name given as a IAssemblyName.

See Also

AssemblyBindingPolicyManager Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicyManager Methods

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicyManager Methods
AssemblyBindingPolicyManager Class See Also Send Feedback

The AssemblyBindingPolicyManager type exposes the following members.

Methods

 | Name | Description
Public method | EvaluatePolicy | Applies redirection policies on an assembly name given as a IAssemblyName.

See Also

AssemblyBindingPolicyManager Class
PostSharp.Sdk.CodeModel Namespace


EvaluatePolicy Method

AssemblyBindingPolicyManager..::..EvaluatePolicy Method
AssemblyBindingPolicyManager Class See Also Send Feedback
Applies redirection policies on an assembly name given as a IAssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyName EvaluatePolicy(
    IAssemblyName assemblyName,
    bool evaluateSystemPolicies
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Name of the referenced assembly.
evaluateSystemPolicies
Type: System..::.Boolean

[Missing <param name="evaluateSystemPolicies"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyBindingPolicyManager.EvaluatePolicy(PostSharp.Reflection.IAssemblyName,System.Boolean)"]

Return Value

Name of the resolved assembly reference, after application of redirection policies.

See Also

AssemblyBindingPolicyManager Class
PostSharp.Sdk.CodeModel Namespace


AssemblyEnvelope Class

AssemblyEnvelope Class
Members See Also Send Feedback
Represents an assembly understood basically, internally, as a collection of modules (ModuleDeclaration) and, externally, as a collection of exported types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyEnvelope : Element,
    IAssembly, IAssemblyName, ITaggable, INamed

Remarks

Do not mistake for AssemblyManifestDeclaration, which is the assembly manifest and is contained in one of the module of the assembly.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.AssemblyEnvelope

See Also

AssemblyEnvelope Members
PostSharp.Sdk.CodeModel Namespace


AssemblyEnvelope Members

[image]

PostSharp 2.0 Documentation
AssemblyEnvelope Members
AssemblyEnvelope Class Methods Properties See Also Send Feedback

The AssemblyEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Releases all resources used by the AssemblyEnvelope
Public method | Equals |
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTypeDefinition | Overloaded.
Public method | MatchesReference |
Public method | SetTag | Set a tag to the current declaration.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Location | Gets the full path of the file from which the assembly has been loaded.
Public property | ManifestModule | Gets the module containing the assembly manifest (AssemblyManifestDeclaration).
Public property | Modules | Gets the collection of modules contained in this assembly.
Public property | Name | Gets the assembly friendly name.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Version | Gets the assembly version.

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


AssemblyEnvelope Methods

[image]

PostSharp 2.0 Documentation
AssemblyEnvelope Methods
AssemblyEnvelope Class See Also Send Feedback

The AssemblyEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose |
Public method | Equals |
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTypeDefinition | Overloaded.
Public method | MatchesReference |
Public method | SetTag | Set a tag to the current declaration.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

AssemblyEnvelope..::..Dispose Method
AssemblyEnvelope Class See Also Send Feedback
Releases all resources used by the AssemblyEnvelope

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

AssemblyEnvelope..::..Equals Method
AssemblyEnvelope Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.Equals(PostSharp.Sdk.CodeModel.IAssembly)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IAssembly other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IAssembly

[Missing <param name="other"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.Equals(PostSharp.Sdk.CodeModel.IAssembly)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.Equals(PostSharp.Sdk.CodeModel.IAssembly)"]

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKey Method

AssemblyEnvelope..::..GetPublicKey Method
AssemblyEnvelope Class See Also Send Feedback
Gets the assembly public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKey()

Field Value

An array of bytes containing the public key, or null if no public key is specified (for instance if only the public key token is given).

Return Value

An array of bytes containing the public key, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKey()()()

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKeyToken Method

AssemblyEnvelope..::..GetPublicKeyToken Method
AssemblyEnvelope Class See Also Send Feedback
Gets the assembly public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKeyToken()

Return Value

An array of bytes containing the public key token, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKeyToken()()()

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


GetSystemAssembly Method

AssemblyEnvelope..::..GetSystemAssembly Method
AssemblyEnvelope Class See Also Send Feedback
Gets the reflection Assembly corresponding to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Assembly GetSystemAssembly()

Return Value

The Assembly corresponding to this instance, or null if the assembly could not be found.

Implements

IAssembly..::.GetSystemAssembly()()()

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


GetTag Method

AssemblyEnvelope..::..GetTag Method
AssemblyEnvelope Class See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

Implements

ITaggable..::.GetTag(TagId)

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
AssemblyEnvelope..::..GetTypeDefinition Method
AssemblyEnvelope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition(String) | Gets a type defined in this assembly given its name.
Public method | GetTypeDefinition(String, BindingOptions) | Gets a type defined in this assembly given its name.

See Also

AssemblyEnvelope Class
AssemblyEnvelope Members
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (String)

AssemblyEnvelope..::..GetTypeDefinition Method (String)
AssemblyEnvelope Class See Also Send Feedback
Gets a type defined in this assembly given its name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition(
    string typeName
)

Parameters

typeName
Type: System..::.String
Type name (in Reflection format).

Return Value

The TypeDefDeclaration named typeName, or null if there is no type named typeName in this assembly.s

See Also

AssemblyEnvelope Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (String, BindingOptions)

AssemblyEnvelope..::..GetTypeDefinition Method (String, BindingOptions)
AssemblyEnvelope Class See Also Send Feedback
Gets a type defined in this assembly given its name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition(
    string typeName,
    BindingOptions bindingOptions
)

Parameters

typeName
Type: System..::.String
Type name (in Reflection format).
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration named typeName, or null if there is no type named typeName in this assembly.s

See Also

AssemblyEnvelope Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

AssemblyEnvelope..::..MatchesReference Method
AssemblyEnvelope Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.MatchesReference(PostSharp.Reflection.IAssemblyName)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName

[Missing <param name="assemblyName"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.MatchesReference(PostSharp.Reflection.IAssemblyName)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyEnvelope.MatchesReference(PostSharp.Reflection.IAssemblyName)"]

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


SetTag Method

AssemblyEnvelope..::..SetTag Method
AssemblyEnvelope Class See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

Implements

ITaggable..::.SetTag(TagId, Object)

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

AssemblyEnvelope..::..ToString Method
AssemblyEnvelope Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


AssemblyEnvelope Properties

[image]

PostSharp 2.0 Documentation
AssemblyEnvelope Properties
AssemblyEnvelope Class See Also Send Feedback

The AssemblyEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Location | Gets the full path of the file from which the assembly has been loaded.
Public property | ManifestModule | Gets the module containing the assembly manifest (AssemblyManifestDeclaration).
Public property | Modules | Gets the collection of modules contained in this assembly.
Public property | Name | Gets the assembly friendly name.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Version | Gets the assembly version.

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

AssemblyEnvelope..::..Culture Property
AssemblyEnvelope Class See Also Send Feedback
Gets the assembly culture name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; }

Field Value

The standard assembly culture name, or null if the assembly is culture-neutral.

Implements

IAssemblyName..::.Culture

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

AssemblyEnvelope..::..IsMscorlib Property
AssemblyEnvelope Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; }

Implements

IAssemblyName..::.IsMscorlib

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


IsStronglyNamed Property

AssemblyEnvelope..::..IsStronglyNamed Property
AssemblyEnvelope Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStronglyNamed { get; }

Implements

IAssemblyName..::.IsStronglyNamed

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Location Property

AssemblyEnvelope..::..Location Property
AssemblyEnvelope Class See Also Send Feedback
Gets the full path of the file from which the assembly has been loaded.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Location { get; }

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


ManifestModule Property

AssemblyEnvelope..::..ManifestModule Property
AssemblyEnvelope Class See Also Send Feedback
Gets the module containing the assembly manifest (AssemblyManifestDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration ManifestModule { get; internal set; }

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Modules Property

AssemblyEnvelope..::..Modules Property
AssemblyEnvelope Class See Also Send Feedback
Gets the collection of modules contained in this assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclarationCollection Modules { get; }

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Name Property

AssemblyEnvelope..::..Name Property
AssemblyEnvelope Class See Also Send Feedback
Gets the assembly friendly name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

Field Value

The assembly friendly name.

Implements

IAssemblyName..::.Name
INamed..::.Name

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

AssemblyEnvelope..::..ProcessorArchitecture Property
AssemblyEnvelope Class See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; }

Implements

IAssemblyName..::.ProcessorArchitecture

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


Version Property

AssemblyEnvelope..::..Version Property
AssemblyEnvelope Class See Also Send Feedback
Gets the assembly version.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; }

Field Value

A Version.

Implements

IAssemblyName..::.Version

See Also

AssemblyEnvelope Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Class

AssemblyLoadException Class
Members See Also Send Feedback
Exception thrown when an assembly cannot be loaded.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class AssemblyLoadException : UserException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
PostSharp.Sdk..::.UserException
PostSharp.Sdk.CodeModel..::.AssemblyLoadException

See Also

AssemblyLoadException Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Members

[image]

PostSharp 2.0 Documentation
AssemblyLoadException Members
AssemblyLoadException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | AssemblyLoadException | Overloaded.

See Also

AssemblyLoadException Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Constructor

[image]

PostSharp 2.0 Documentation
AssemblyLoadException Constructor
AssemblyLoadException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssemblyLoadException()()() | Initializes a new AssemblyLoadException.
Public method | AssemblyLoadException(String) | Initializes a new AssemblyLoadException and specifies the error message.
Protected method | AssemblyLoadException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | AssemblyLoadException(String, Exception) | Initializes a new AssemblyLoadException and specifies the error message and the inner exception.

See Also

AssemblyLoadException Class
AssemblyLoadException Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Constructor

AssemblyLoadException Constructor
AssemblyLoadException Class See Also Send Feedback
Initializes a new AssemblyLoadException.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyLoadException()

See Also

AssemblyLoadException Class
AssemblyLoadException Overload
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Constructor (String)

AssemblyLoadException Constructor (String)
AssemblyLoadException Class See Also Send Feedback
Initializes a new AssemblyLoadException and specifies the error message.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyLoadException(
    string message
)

Parameters

message
Type: System..::.String
Error message.

See Also

AssemblyLoadException Class
AssemblyLoadException Overload
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Constructor (SerializationInfo, StreamingContext)

AssemblyLoadException Constructor (SerializationInfo, StreamingContext)
AssemblyLoadException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected AssemblyLoadException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
SerializationInfo.
context
Type: System.Runtime.Serialization..::.StreamingContext
StreamingContext.

See Also

AssemblyLoadException Class
AssemblyLoadException Overload
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadException Constructor (String, Exception)

AssemblyLoadException Constructor (String, Exception)
AssemblyLoadException Class See Also Send Feedback
Initializes a new AssemblyLoadException and specifies the error message and the inner exception.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyLoadException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Error message.
inner
Type: System..::.Exception
Inner exception.

See Also

AssemblyLoadException Class
AssemblyLoadException Overload
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadHelper Class

AssemblyLoadHelper Class
Members See Also Send Feedback
Helper class to load assemblies. Provides a "binding log" for our custom binder and appends this log in exception text.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class AssemblyLoadHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyLoadHelper

See Also

AssemblyLoadHelper Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadHelper Members

[image]

PostSharp 2.0 Documentation
AssemblyLoadHelper Members
AssemblyLoadHelper Class Methods See Also Send Feedback

The AssemblyLoadHelper type exposes the following members.

Methods

Name | Description
ClearLog | Clears the log.
GetLog | Gets the current log content.
LoadAssemblyFromFile | Loads an assembly given its location full path.
LoadAssemblyFromName | Overloaded.
LoadType | Loads a type given its fully qualified name.
SplitTypeName | Splits a assembly-qualified type name into a type name and an assembly name.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadHelper Methods

[image]

PostSharp 2.0 Documentation
AssemblyLoadHelper Methods
AssemblyLoadHelper Class See Also Send Feedback

The AssemblyLoadHelper type exposes the following members.

Methods

Name | Description
ClearLog | Clears the log.
GetLog | Gets the current log content.
LoadAssemblyFromFile | Loads an assembly given its location full path.
LoadAssemblyFromName | Overloaded.
LoadType | Loads a type given its fully qualified name.
SplitTypeName | Splits a assembly-qualified type name into a type name and an assembly name.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


ClearLog Method

AssemblyLoadHelper..::..ClearLog Method
AssemblyLoadHelper Class See Also Send Feedback
Clears the log.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void ClearLog()

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


GetLog Method

AssemblyLoadHelper..::..GetLog Method
AssemblyLoadHelper Class See Also Send Feedback
Gets the current log content.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetLog()

Return Value

The current log content.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


LoadAssemblyFromFile Method

AssemblyLoadHelper..::..LoadAssemblyFromFile Method
AssemblyLoadHelper Class See Also Send Feedback
Loads an assembly given its location full path.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Assembly LoadAssemblyFromFile(
    string fileName
)

Parameters

fileName
Type: System..::.String
Full path of the assembly file.

Return Value

The Assembly located at fileName.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


LoadAssemblyFromName Method

[image]

PostSharp 2.0 Documentation
AssemblyLoadHelper..::..LoadAssemblyFromName Method
AssemblyLoadHelper Class See Also Send Feedback

Overload List

Name | Description
LoadAssemblyFromName(IAssemblyName) | Loads an assembly given its name.
LoadAssemblyFromName(IAssemblyName, Evidence) | Loads an assembly given its name, and passes an Evidence.

See Also

AssemblyLoadHelper Class
AssemblyLoadHelper Members
PostSharp.Sdk.CodeModel Namespace


LoadAssemblyFromName Method (IAssemblyName)

AssemblyLoadHelper..::..LoadAssemblyFromName Method (IAssemblyName)
AssemblyLoadHelper Class See Also Send Feedback
Loads an assembly given its name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Assembly LoadAssemblyFromName(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
The full assembly name.

Return Value

The assembly whose name is assemblyName.

See Also

AssemblyLoadHelper Class
LoadAssemblyFromName Overload
PostSharp.Sdk.CodeModel Namespace


LoadAssemblyFromName Method (IAssemblyName, Evidence)

AssemblyLoadHelper..::..LoadAssemblyFromName Method (IAssemblyName, Evidence)
AssemblyLoadHelper Class See Also Send Feedback
Loads an assembly given its name, and passes an Evidence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Assembly LoadAssemblyFromName(
    IAssemblyName assemblyName,
    Evidence assemblySecurity
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
The full assembly name.
assemblySecurity
Type: System.Security.Policy..::.Evidence
Evidence with which the assembly should be loaded.

Return Value

The assembly whose name is assemblyName.

See Also

AssemblyLoadHelper Class
LoadAssemblyFromName Overload
PostSharp.Sdk.CodeModel Namespace


LoadType Method

AssemblyLoadHelper..::..LoadType Method
AssemblyLoadHelper Class See Also Send Feedback
Loads a type given its fully qualified name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Type LoadType(
    string qualifiedTypeName
)

Parameters

qualifiedTypeName
Type: System..::.String
Fully qualified type name.

Return Value

The type named qualifiedTypeName.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


SplitTypeName Method

AssemblyLoadHelper..::..SplitTypeName Method
AssemblyLoadHelper Class See Also Send Feedback
Splits a assembly-qualified type name into a type name and an assembly name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void SplitTypeName(
    string qualifiedTypeName,
    out string typeName,
    out string assemblyName
)

Parameters

qualifiedTypeName
Type: System..::.String
Assembly-qualified type name.
typeName
Type: System..::.String %
Type name.
assemblyName
Type: System..::.String %
Assembly name.

See Also

AssemblyLoadHelper Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadingEventArgs Class

AssemblyLoadingEventArgs Class
Members See Also Send Feedback
Arguments of the event AssemblyLoading.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyLoadingEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PostSharp.Sdk.CodeModel..::.AssemblyLoadingEventArgs

See Also

AssemblyLoadingEventArgs Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadingEventArgs Members

[image]

PostSharp 2.0 Documentation
AssemblyLoadingEventArgs Members
AssemblyLoadingEventArgs Class Properties See Also Send Feedback

The AssemblyLoadingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Assembly being loaded (if available).
Public property | AssemblyLocation | Full path of the assembly being loaded.
Public property | AssemblyName | Name of the assembly being loaded.
Public property | LazyLoading | Determines whether the assembly should be loaded lazily.

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoadingEventArgs Properties

[image]

PostSharp 2.0 Documentation
AssemblyLoadingEventArgs Properties
AssemblyLoadingEventArgs Class See Also Send Feedback

The AssemblyLoadingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Assembly being loaded (if available).
Public property | AssemblyLocation | Full path of the assembly being loaded.
Public property | AssemblyName | Name of the assembly being loaded.
Public property | LazyLoading | Determines whether the assembly should be loaded lazily.

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


Assembly Property

AssemblyLoadingEventArgs..::..Assembly Property
AssemblyLoadingEventArgs Class See Also Send Feedback
Assembly being loaded (if available).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Assembly Assembly { get; private set; }

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocation Property

AssemblyLoadingEventArgs..::..AssemblyLocation Property
AssemblyLoadingEventArgs Class See Also Send Feedback
Full path of the assembly being loaded.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AssemblyLocation { get; private set; }

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyName Property

AssemblyLoadingEventArgs..::..AssemblyName Property
AssemblyLoadingEventArgs Class See Also Send Feedback
Name of the assembly being loaded.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyName AssemblyName { get; private set; }

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


LazyLoading Property

AssemblyLoadingEventArgs..::..LazyLoading Property
AssemblyLoadingEventArgs Class See Also Send Feedback
Determines whether the assembly should be loaded lazily.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool LazyLoading { get; set; }

See Also

AssemblyLoadingEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocateEventArgs Class

AssemblyLocateEventArgs Class
Members See Also Send Feedback
Arguments of the LocatingAssembly event.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyLocateEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PostSharp.Sdk.CodeModel..::.AssemblyLocateEventArgs

See Also

AssemblyLocateEventArgs Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLocateEventArgs Members

[image]

PostSharp 2.0 Documentation
AssemblyLocateEventArgs Members
AssemblyLocateEventArgs Class Properties See Also Send Feedback

The AssemblyLocateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyLocation | Gets or sets the assembly location on the file system.
Public property | AssemblyName | Gets the name of the assembly being resolved.

See Also

AssemblyLocateEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocateEventArgs Properties

[image]

PostSharp 2.0 Documentation
AssemblyLocateEventArgs Properties
AssemblyLocateEventArgs Class See Also Send Feedback

The AssemblyLocateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyLocation | Gets or sets the assembly location on the file system.
Public property | AssemblyName | Gets the name of the assembly being resolved.

See Also

AssemblyLocateEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocation Property

AssemblyLocateEventArgs..::..AssemblyLocation Property
AssemblyLocateEventArgs Class See Also Send Feedback
Gets or sets the assembly location on the file system.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string AssemblyLocation { get; set; }

See Also

AssemblyLocateEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyName Property

AssemblyLocateEventArgs..::..AssemblyName Property
AssemblyLocateEventArgs Class See Also Send Feedback
Gets the name of the assembly being resolved.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyName AssemblyName { get; }

See Also

AssemblyLocateEventArgs Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Class

AssemblyLocator Class
Members See Also Send Feedback
Locates an assembly in the search path or in GAC.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyLocator

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyLocator

See Also

AssemblyLocator Members
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Members

[image]

PostSharp 2.0 Documentation
AssemblyLocator Members
AssemblyLocator Class Methods Properties Events See Also Send Feedback

The AssemblyLocator type exposes the following members.

Methods

 | Name | Description
Public method | AddDirectories | Adds a set of directories to the search path.
Public method | AddDirectory | Add a directory to the search path.
Public method | AddFile | Add a file to the search path.
Public method | FindAssembly | Overloaded.
Public method | FindAssemblyInAppDomain | Finds an assembly in the current AppDomain.
Public method | RemoveDirectory | Removes a directory from the search path.
Public method | SetAssemblyLocation | Sets the full path of an assembly.

Properties

 | Name | Description
Public property | Domain | Gets the Domain used by the AssemblyLocator to resolve assembly name redirection.

Events

 | Name | Description
Public event | LocatingAssembly | Event raised when an assembly reference is resolved.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Methods

[image]

PostSharp 2.0 Documentation
AssemblyLocator Methods
AssemblyLocator Class See Also Send Feedback

The AssemblyLocator type exposes the following members.

Methods

 | Name | Description
Public method | AddDirectories | Adds a set of directories to the search path.
Public method | AddDirectory | Add a directory to the search path.
Public method | AddFile | Add a file to the search path.
Public method | FindAssembly | Overloaded.
Public method | FindAssemblyInAppDomain | Finds an assembly in the current AppDomain.
Public method | RemoveDirectory | Removes a directory from the search path.
Public method | SetAssemblyLocation | Sets the full path of an assembly.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AddDirectories Method

AssemblyLocator..::..AddDirectories Method
AssemblyLocator Class See Also Send Feedback
Adds a set of directories to the search path.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddDirectories(
    IEnumerable<string> directories
)

Parameters

directories
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' String >)>)>
A set of directories.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AddDirectory Method

AssemblyLocator..::..AddDirectory Method
AssemblyLocator Class See Also Send Feedback
Add a directory to the search path.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AddDirectory(
    string directory
)

Parameters

directory
Type: System..::.String
A directory.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyLocator.AddDirectory(System.String)"]

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AddFile Method

AssemblyLocator..::..AddFile Method
AssemblyLocator Class See Also Send Feedback
Add a file to the search path.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddFile(
    string fullPath
)

Parameters

fullPath
Type: System..::.String
Full file path.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method

[image]

PostSharp 2.0 Documentation
AssemblyLocator..::..FindAssembly Method
AssemblyLocator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAssembly(IAssemblyName, Boolean) | Finds an assembly.
Public method | FindAssembly(IAssemblyName, Boolean, String%, IAssemblyName%) | Finds an assembly.

See Also

AssemblyLocator Class
AssemblyLocator Members
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method (IAssemblyName, Boolean)

AssemblyLocator..::..FindAssembly Method (IAssemblyName, Boolean)
AssemblyLocator Class See Also Send Feedback
Finds an assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FindAssembly(
    IAssemblyName assemblyName,
    bool searchForClrLoading
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name.
searchForClrLoading
Type: System..::.Boolean
true if CLR locations (the current AppDomain and the GAC) should be searched, otherwise false.

Return Value

The full path of the assembly, or null if the assembly was not found.

See Also

AssemblyLocator Class
FindAssembly Overload
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method (IAssemblyName, Boolean, String, IAssemblyName)

AssemblyLocator..::..FindAssembly Method (IAssemblyName, Boolean, String%, IAssemblyName%)
AssemblyLocator Class See Also Send Feedback
Finds an assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool FindAssembly(
    IAssemblyName assemblyName,
    bool searchForClrLoading,
    out string assemblyLocation,
    out IAssemblyName locatedAssemblyBindingIdentity
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Assembly name.
searchForClrLoading
Type: System..::.Boolean
true if CLR locations (the current AppDomain and the GAC) should be searched, otherwise false.
assemblyLocation
Type: System..::.String %
At output, full path of the assembly.
locatedAssemblyBindingIdentity
Type: PostSharp.Reflection..::.IAssemblyName %
At output, binding identity of the assembly.

Return Value

true if the assembly was found, otherwise false.

See Also

AssemblyLocator Class
FindAssembly Overload
PostSharp.Sdk.CodeModel Namespace


FindAssemblyInAppDomain Method

AssemblyLocator..::..FindAssemblyInAppDomain Method
AssemblyLocator Class See Also Send Feedback
Finds an assembly in the current AppDomain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Assembly FindAssemblyInAppDomain(
    IAssemblyName requestedAssemblyName
)

Parameters

requestedAssemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Name of the requested assembly.

Return Value

The assembly whose name is compatible with requestedAssemblyName, or null if the current AppDomain does not contain such an assembly.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


RemoveDirectory Method

AssemblyLocator..::..RemoveDirectory Method
AssemblyLocator Class See Also Send Feedback
Removes a directory from the search path.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RemoveDirectory(
    string directory
)

Parameters

directory
Type: System..::.String
Directory to be removed.

Return Value

true if the directory was previously present and removed, false if the directory was previously not in the search path.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


SetAssemblyLocation Method

AssemblyLocator..::..SetAssemblyLocation Method
AssemblyLocator Class See Also Send Feedback
Sets the full path of an assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetAssemblyLocation(
    IAssemblyName assemblyBindingIdentity,
    string assemblyLocation
)

Parameters

assemblyBindingIdentity
Type: PostSharp.Reflection..::.IAssemblyName
Binding identity of the assembly.
assemblyLocation
Type: System..::.String
Full path of the assembly.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Properties

[image]

PostSharp 2.0 Documentation
AssemblyLocator Properties
AssemblyLocator Class See Also Send Feedback

The AssemblyLocator type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets the Domain used by the AssemblyLocator to resolve assembly name redirection.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


Domain Property

AssemblyLocator..::..Domain Property
AssemblyLocator Class See Also Send Feedback
Gets the Domain used by the AssemblyLocator to resolve assembly name redirection.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Domain Domain { get; private set; }

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Events

[image]

PostSharp 2.0 Documentation
AssemblyLocator Events
AssemblyLocator Class See Also Send Feedback

The AssemblyLocator type exposes the following members.

Events

 | Name | Description
Public event | LocatingAssembly | Event raised when an assembly reference is resolved.

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


LocatingAssembly Event

AssemblyLocator..::..LocatingAssembly Event
AssemblyLocator Class See Also Send Feedback
Event raised when an assembly reference is resolved.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<AssemblyLocateEventArgs> LocatingAssembly

See Also

AssemblyLocator Class
PostSharp.Sdk.CodeModel Namespace


AssemblyManifestDeclaration Class

AssemblyManifestDeclaration Class
Members See Also Send Feedback
Represents an assembly manifest (Assembly).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyManifestDeclaration : NamedMetadataDeclaration,
    ISecurable, IAssemblyDeclaration, IAssemblyName, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable, IWriteReflectionName

Remarks

The assembly manifest is owned by the module (ModuleDeclaration) and is exposed by the AssemblyManifest property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.AssemblyManifestDeclaration

See Also

AssemblyManifestDeclaration Members
PostSharp.Sdk.CodeModel Namespace


AssemblyManifestDeclaration Members

[image]

PostSharp 2.0 Documentation
AssemblyManifestDeclaration Members
AssemblyManifestDeclaration Class Constructors Methods Properties See Also Send Feedback

The AssemblyManifestDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyManifestDeclaration | Initializes a new AssemblyManifestDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetPublicKey | Sets the public key.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the name of the assembly culture.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ExportedTypes | Gets the collection of types exported outside the current assembly but not defined inside the current module.
Public property | Files | Gets the collection of manifestFiles (ManifestFileDeclaration) linked to the assembly.
Public property | HashAlgorithm | Gets or set the hash algorithm identifier.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current assembly is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | OverwrittenFullName | Gets the full name based on the OverwrittenName instead of the normal Name.
Public property | OverwrittenName | Name of the assembly as it will be emitted during compilation.
Public property | Parent | Gets the parent ModuleDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Resources | Gets the collection of resources (ManifestResourceDeclaration) referred to by the assembly.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Version | Gets or set the assembly version.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyManifestDeclaration Constructor

AssemblyManifestDeclaration Constructor
AssemblyManifestDeclaration Class See Also Send Feedback
Initializes a new AssemblyManifestDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyManifestDeclaration()

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyManifestDeclaration Methods

[image]

PostSharp 2.0 Documentation
AssemblyManifestDeclaration Methods
AssemblyManifestDeclaration Class See Also Send Feedback

The AssemblyManifestDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetPublicKey | Sets the public key.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKey Method

AssemblyManifestDeclaration..::..GetPublicKey Method
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the assembly public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKey()

Field Value

An array of bytes containing the public key, or null if no public key is specified (for instance if only the public key token is given).

Return Value

An array of bytes containing the public key, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKey()()()

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKeyToken Method

AssemblyManifestDeclaration..::..GetPublicKeyToken Method
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the assembly public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKeyToken()

Return Value

An array of bytes containing the public key token, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKeyToken()()()

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

AssemblyManifestDeclaration..::..GetTokenType Method
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetPublicKey Method

AssemblyManifestDeclaration..::..SetPublicKey Method
AssemblyManifestDeclaration Class See Also Send Feedback
Sets the public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetPublicKey(
    byte[] value
)

Parameters

value
Type: array< System..::.Byte >[]()[][]

[Missing <param name="value"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyManifestDeclaration.SetPublicKey(System.Byte[])"]

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

AssemblyManifestDeclaration..::..ToString Method
AssemblyManifestDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

AssemblyManifestDeclaration..::..Translate Method
AssemblyManifestDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyManifestDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyDeclaration Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyManifestDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyManifestDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

AssemblyManifestDeclaration..::..WriteReflectionName Method
AssemblyManifestDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyManifestDeclaration Properties

[image]

PostSharp 2.0 Documentation
AssemblyManifestDeclaration Properties
AssemblyManifestDeclaration Class See Also Send Feedback

The AssemblyManifestDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the name of the assembly culture.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ExportedTypes | Gets the collection of types exported outside the current assembly but not defined inside the current module.
Public property | Files | Gets the collection of manifestFiles (ManifestFileDeclaration) linked to the assembly.
Public property | HashAlgorithm | Gets or set the hash algorithm identifier.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current assembly is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | OverwrittenFullName | Gets the full name based on the OverwrittenName instead of the normal Name.
Public property | OverwrittenName | Name of the assembly as it will be emitted during compilation.
Public property | Parent | Gets the parent ModuleDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Resources | Gets the collection of resources (ManifestResourceDeclaration) referred to by the assembly.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Version | Gets or set the assembly version.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

AssemblyManifestDeclaration..::..Culture Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the name of the assembly culture.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; set; }

Field Value

A standard culture name (see CultureInfo), or null to specify the neutral culture.

Implements

IAssemblyName..::.Culture

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExportedTypes Property

AssemblyManifestDeclaration..::..ExportedTypes Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the collection of types exported outside the current assembly but not defined inside the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExportedTypeDeclarationCollection ExportedTypes { get; }

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Files Property

AssemblyManifestDeclaration..::..Files Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the collection of manifestFiles (ManifestFileDeclaration) linked to the assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManifestFileDeclarationCollection Files { get; }

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HashAlgorithm Property

AssemblyManifestDeclaration..::..HashAlgorithm Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets or set the hash algorithm identifier.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyHashAlgorithm HashAlgorithm { get; set; }

Field Value

The identifier of the algorithm (an AssemblyHashAlgorithm) used to produce the assembly signature.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

AssemblyManifestDeclaration..::..IsMscorlib Property
AssemblyManifestDeclaration Class See Also Send Feedback
Determines whether the current assembly is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; }

Field Value

true if the current assembly is mscorlib, otherwise false.

Implements

IAssemblyName..::.IsMscorlib

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStronglyNamed Property

AssemblyManifestDeclaration..::..IsStronglyNamed Property
AssemblyManifestDeclaration Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStronglyNamed { get; }

Implements

IAssemblyName..::.IsStronglyNamed

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


OverwrittenFullName Property

AssemblyManifestDeclaration..::..OverwrittenFullName Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the full name based on the OverwrittenName instead of the normal Name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OverwrittenFullName { get; }

Field Value

A value of the form: {Name}, Version={Version}, Culture={Culture}|neutral (in any case without public key), or null if the OverwrittenName property is null.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


OverwrittenName Property

AssemblyManifestDeclaration..::..OverwrittenName Property
AssemblyManifestDeclaration Class See Also Send Feedback
Name of the assembly as it will be emitted during compilation.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OverwrittenName { get; set; }

Field Value

A valid name, or null if the name is not overwritten.

Remarks

Overwriting an assembly name allows to change the name of the compiled assembly without breaking references in the current domain (because changing the Name would make it impossible to resolve assembly references).

When the name is overwritten, the public key is automatically ignored during compilation.

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

AssemblyManifestDeclaration..::..Parent Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the parent ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Parent { get; }

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

AssemblyManifestDeclaration..::..ParentMember Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

AssemblyManifestDeclaration..::..ParentType Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSets Property

AssemblyManifestDeclaration..::..PermissionSets Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the collection of permission sets (PermissionSetDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionSetDeclarationCollection PermissionSets { get; }

Implements

ISecurable..::.PermissionSets

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

AssemblyManifestDeclaration..::..ProcessorArchitecture Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; }

Implements

IAssemblyName..::.ProcessorArchitecture

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Resources Property

AssemblyManifestDeclaration..::..Resources Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets the collection of resources (ManifestResourceDeclaration) referred to by the assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManifestResourceDeclarationCollection Resources { get; }

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Version Property

AssemblyManifestDeclaration..::..Version Property
AssemblyManifestDeclaration Class See Also Send Feedback
Gets or set the assembly version.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; set; }

Field Value

A Version.

Implements

IAssemblyName..::.Version

See Also

AssemblyManifestDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyNameExtensions Class

AssemblyNameExtensions Class
Members See Also Send Feedback
Extension methods for the IAssemblyName interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class AssemblyNameExtensions

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyNameExtensions

See Also

AssemblyNameExtensions Members
PostSharp.Sdk.CodeModel Namespace


AssemblyNameExtensions Members

[image]

PostSharp 2.0 Documentation
AssemblyNameExtensions Members
AssemblyNameExtensions Class Methods See Also Send Feedback

The AssemblyNameExtensions type exposes the following members.

Methods

Name | Description
GetBindingIdentity | Gets the binding identity of an assembly.
GetFullName | Gets the full name of an assembly.
ToAssemblyName | Converts an IAssemblyName into an AssemblyName.

See Also

AssemblyNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


AssemblyNameExtensions Methods

[image]

PostSharp 2.0 Documentation
AssemblyNameExtensions Methods
AssemblyNameExtensions Class See Also Send Feedback

The AssemblyNameExtensions type exposes the following members.

Methods

Name | Description
GetBindingIdentity | Gets the binding identity of an assembly.
GetFullName | Gets the full name of an assembly.
ToAssemblyName | Converts an IAssemblyName into an AssemblyName.

See Also

AssemblyNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


GetBindingIdentity Method

AssemblyNameExtensions..::..GetBindingIdentity Method
AssemblyNameExtensions Class See Also Send Feedback
Gets the binding identity of an assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetBindingIdentity(
    this IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

The binding identity of assemblyName.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAssemblyName. When you use instance method syntax to call this method, omit the first parameter.

See Also

AssemblyNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


GetFullName Method

AssemblyNameExtensions..::..GetFullName Method
AssemblyNameExtensions Class See Also Send Feedback
Gets the full name of an assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetFullName(
    this IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

The full name string of assemblyName.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAssemblyName. When you use instance method syntax to call this method, omit the first parameter.

See Also

AssemblyNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


ToAssemblyName Method

AssemblyNameExtensions..::..ToAssemblyName Method
AssemblyNameExtensions Class See Also Send Feedback
Converts an IAssemblyName into an AssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AssemblyName ToAssemblyName(
    this IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An IAssemblyName.

Return Value

The AssemblyName corresponding to assemblyName.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAssemblyName. When you use instance method syntax to call this method, omit the first parameter.

See Also

AssemblyNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


AssemblyNameWrapper Class

AssemblyNameWrapper Class
Members See Also Send Feedback
Wraps an AssemblyName into an IAssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyNameWrapper : IAssemblyName

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.AssemblyNameWrapper

See Also

AssemblyNameWrapper Members
PostSharp.Sdk.CodeModel Namespace


AssemblyNameWrapper Members

[image]

PostSharp 2.0 Documentation
AssemblyNameWrapper Members
AssemblyNameWrapper Class Methods Properties See Also Send Feedback

The AssemblyNameWrapper type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
 | GetWrapper | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Version | Gets the assembly version.

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


AssemblyNameWrapper Methods

[image]

PostSharp 2.0 Documentation
AssemblyNameWrapper Methods
AssemblyNameWrapper Class See Also Send Feedback

The AssemblyNameWrapper type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
 | GetWrapper | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKey Method

AssemblyNameWrapper..::..GetPublicKey Method
AssemblyNameWrapper Class See Also Send Feedback
Gets the assembly public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKey()

Field Value

An array of bytes containing the public key, or null if no public key is specified (for instance if only the public key token is given).

Return Value

An array of bytes containing the public key, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKey()()()

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKeyToken Method

AssemblyNameWrapper..::..GetPublicKeyToken Method
AssemblyNameWrapper Class See Also Send Feedback
Gets the assembly public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKeyToken()

Return Value

An array of bytes containing the public key token, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKeyToken()()()

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


GetWrapper Method

[image]

PostSharp 2.0 Documentation
AssemblyNameWrapper..::..GetWrapper Method
AssemblyNameWrapper Class See Also Send Feedback

Overload List

Name | Description
GetWrapper(Assembly) | Gets an AssemblyName for an Assembly.
GetWrapper(AssemblyName) | Gets an AssemblyName for an assembly given as an AssemblyName.
GetWrapper(String) | Gets an AssemblyName for an assembly given as a String containing its full name.

See Also

AssemblyNameWrapper Class
AssemblyNameWrapper Members
PostSharp.Sdk.CodeModel Namespace


GetWrapper Method (Assembly)

AssemblyNameWrapper..::..GetWrapper Method (Assembly)
AssemblyNameWrapper Class See Also Send Feedback
Gets an AssemblyName for an Assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AssemblyNameWrapper GetWrapper(
    Assembly assembly
)

Parameters

assembly
Type: System.Reflection..::.Assembly
Assembly.

Return Value

An AssemblyNameWrapper instance (eventually cached) corresponding to assembly.

See Also

AssemblyNameWrapper Class
GetWrapper Overload
PostSharp.Sdk.CodeModel Namespace


GetWrapper Method (AssemblyName)

AssemblyNameWrapper..::..GetWrapper Method (AssemblyName)
AssemblyNameWrapper Class See Also Send Feedback
Gets an AssemblyName for an assembly given as an AssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AssemblyNameWrapper GetWrapper(
    AssemblyName assemblyName
)

Parameters

assemblyName
Type: System.Reflection..::.AssemblyName
Assembly name.

Return Value

An AssemblyNameWrapper instance (eventually cached) corresponding to assemblyName.

See Also

AssemblyNameWrapper Class
GetWrapper Overload
PostSharp.Sdk.CodeModel Namespace


GetWrapper Method (String)

AssemblyNameWrapper..::..GetWrapper Method (String)
AssemblyNameWrapper Class See Also Send Feedback
Gets an AssemblyName for an assembly given as a String containing its full name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AssemblyNameWrapper GetWrapper(
    string assemblyFullName
)

Parameters

assemblyFullName
Type: System..::.String
Full name of the assembly.

Return Value

An AssemblyNameWrapper instance (eventually cached) corresponding to assemblyFullName.

See Also

AssemblyNameWrapper Class
GetWrapper Overload
PostSharp.Sdk.CodeModel Namespace


ToString Method

AssemblyNameWrapper..::..ToString Method
AssemblyNameWrapper Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


AssemblyNameWrapper Properties

[image]

PostSharp 2.0 Documentation
AssemblyNameWrapper Properties
AssemblyNameWrapper Class See Also Send Feedback

The AssemblyNameWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Version | Gets the assembly version.

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

AssemblyNameWrapper..::..Culture Property
AssemblyNameWrapper Class See Also Send Feedback
Gets the assembly culture name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; }

Field Value

The standard assembly culture name, or null if the assembly is culture-neutral.

Implements

IAssemblyName..::.Culture

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

AssemblyNameWrapper..::..IsMscorlib Property
AssemblyNameWrapper Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; }

Implements

IAssemblyName..::.IsMscorlib

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


IsStronglyNamed Property

AssemblyNameWrapper..::..IsStronglyNamed Property
AssemblyNameWrapper Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStronglyNamed { get; }

Implements

IAssemblyName..::.IsStronglyNamed

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


Name Property

AssemblyNameWrapper..::..Name Property
AssemblyNameWrapper Class See Also Send Feedback
Gets the assembly friendly name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

Field Value

The assembly friendly name.

Implements

IAssemblyName..::.Name

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

AssemblyNameWrapper..::..ProcessorArchitecture Property
AssemblyNameWrapper Class See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; }

Implements

IAssemblyName..::.ProcessorArchitecture

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


Version Property

AssemblyNameWrapper..::..Version Property
AssemblyNameWrapper Class See Also Send Feedback
Gets the assembly version.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; }

Field Value

A Version.

Implements

IAssemblyName..::.Version

See Also

AssemblyNameWrapper Class
PostSharp.Sdk.CodeModel Namespace


AssemblyRefAttributes Enumeration

AssemblyRefAttributes Enumeration
See Also Send Feedback
Options of assembly references (AssemblyRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum AssemblyRefAttributes

Members

Member name | Value | Description
None | 0 | Default.
PublicKey | 1 | The assembly reference holds the full (unhashed) public key.
Retargetable | 256 | The implementation of the current assembly used at runtime is not expected to match the version seen at compile time.
EnableJitCompileTracking | 32768 | Reserved.
DisableJitCompileOptimizer | 16384 | Reserved.

See Also

PostSharp.Sdk.CodeModel Namespace


AssemblyRefDeclaration Class

AssemblyRefDeclaration Class
Members See Also Send Feedback
Represents a reference to an external assembly (AssemblyRef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyRefDeclaration : NamedMetadataDeclaration,
    ITypeRefResolutionScope, IAssembly, IManifestResourceImplementation, IWeakReferenceable, IRemovable,
    IAssemblyDeclaration, IAssemblyName, IMetadataDeclaration, IDeclaration, IElement,
    IModuleElement, ITaggable, IWriteReflectionName

Remarks

Assembly references are owned by the module (ModuleDeclaration) an are exposed by the AssemblyRefs collection.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.AssemblyRefDeclaration

See Also

AssemblyRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


AssemblyRefDeclaration Members

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclaration Members
AssemblyRefDeclaration Class Constructors Methods Properties See Also Send Feedback

The AssemblyRefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyRefDeclaration | Initializes a new AssemblyRefDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindType |
Public method | GetAssemblyEnvelope | Gets the AssemblyEnvelope corresponding to the current instance in the current domain.
Public method | GetPublicKey | Gets the public key.
Public method | GetPublicKeyToken | Gets the public key token.
Public method | GetReflectionWrapper |
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetPublicKey | Sets the public key.
Public method | SetPublicKeyToken | Sets the public key token.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate | Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the assembly reference attributes.
Public property | Culture | Gets the assembly culture name.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | HashAlgorithm |
Public property | HashValue |
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | OverwrittenName | Name of the assembly as it will be emitted during compilation.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.
Public property | Version | Gets the assembly version.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyRefDeclaration Constructor

AssemblyRefDeclaration Constructor
AssemblyRefDeclaration Class See Also Send Feedback
Initializes a new AssemblyRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyRefDeclaration()

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclaration Methods
AssemblyRefDeclaration Class See Also Send Feedback

The AssemblyRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindType |
Public method | GetAssemblyEnvelope | Gets the AssemblyEnvelope corresponding to the current instance in the current domain.
Public method | GetPublicKey | Gets the public key.
Public method | GetPublicKeyToken | Gets the public key token.
Public method | GetReflectionWrapper |
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetPublicKey | Sets the public key.
Public method | SetPublicKeyToken | Sets the public key token.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate | Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

AssemblyRefDeclaration..::..ClearCache Method
AssemblyRefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindType Method

AssemblyRefDeclaration..::..FindType Method
AssemblyRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FindType(
    string name,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions

[Missing <param name="bindingOptions"/> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetAssemblyEnvelope Method

AssemblyRefDeclaration..::..GetAssemblyEnvelope Method
AssemblyRefDeclaration Class See Also Send Feedback
Gets the AssemblyEnvelope corresponding to the current instance in the current domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssemblyEnvelope()

Return Value

An AssemblyEnvelope.

Implements

IAssembly..::.GetAssemblyEnvelope()()()

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKey Method

AssemblyRefDeclaration..::..GetPublicKey Method
AssemblyRefDeclaration Class See Also Send Feedback
Gets the public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKey()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.GetPublicKey"]

Implements

IAssemblyName..::.GetPublicKey()()()

Remarks

The PublicKey flag should be cleared on the Attributes property.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKeyToken Method

AssemblyRefDeclaration..::..GetPublicKeyToken Method
AssemblyRefDeclaration Class See Also Send Feedback
Gets the public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKeyToken()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.GetPublicKeyToken"]

Implements

IAssemblyName..::.GetPublicKeyToken()()()

Remarks

The PublicKey flag should be cleared on the Attributes property.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

AssemblyRefDeclaration..::..GetReflectionWrapper Method
AssemblyRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.GetReflectionWrapper"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyWrapper GetReflectionWrapper()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.GetReflectionWrapper"]

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemAssembly Method

AssemblyRefDeclaration..::..GetSystemAssembly Method
AssemblyRefDeclaration Class See Also Send Feedback
Gets the reflection Assembly corresponding to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Assembly GetSystemAssembly()

Return Value

The Assembly corresponding to this instance, or null if the assembly could not be found.

Implements

IAssembly..::.GetSystemAssembly()()()

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

AssemblyRefDeclaration..::..GetTokenType Method
AssemblyRefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

AssemblyRefDeclaration..::..Remove Method
AssemblyRefDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetPublicKey Method

AssemblyRefDeclaration..::..SetPublicKey Method
AssemblyRefDeclaration Class See Also Send Feedback
Sets the public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetPublicKey(
    byte[] value
)

Parameters

value
Type: array< System..::.Byte >[]()[][]
The public key, or null to remove the public key.

Remarks

The PublicKey flag should be set on the Attributes property.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetPublicKeyToken Method

AssemblyRefDeclaration..::..SetPublicKeyToken Method
AssemblyRefDeclaration Class See Also Send Feedback
Sets the public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetPublicKeyToken(
    byte[] value
)

Parameters

value
Type: array< System..::.Byte >[]()[][]
The public key token, or null to remote the public key token.

Remarks

The PublicKey flag should be cleared on the Attributes property.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

AssemblyRefDeclaration..::..ToString Method
AssemblyRefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

AssemblyRefDeclaration..::..Translate Method
AssemblyRefDeclaration Class See Also Send Feedback
Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssemblyDeclaration Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the current AssemblyManifestDeclaration should be translated.

Return Value

The translation of the current AssemblyManifestDeclaration for targetModule.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

AssemblyRefDeclaration..::..WriteReflectionName Method
AssemblyRefDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclaration Properties
AssemblyRefDeclaration Class See Also Send Feedback

The AssemblyRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the assembly reference attributes.
Public property | Culture | Gets the assembly culture name.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | HashAlgorithm |
Public property | HashValue |
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | OverwrittenName | Name of the assembly as it will be emitted during compilation.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.
Public property | Version | Gets the assembly version.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

AssemblyRefDeclaration..::..Attributes Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets or sets the assembly reference attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyRefAttributes Attributes { get; set; }

Field Value

A combination of AssemblyRefAttributes.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

AssemblyRefDeclaration..::..Culture Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the assembly culture name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; set; }

Field Value

The standard assembly culture name, or null if the assembly is culture-neutral.

Implements

IAssemblyName..::.Culture

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HashAlgorithm Property

AssemblyRefDeclaration..::..HashAlgorithm Property
AssemblyRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.HashAlgorithm"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyHashAlgorithm HashAlgorithm { get; set; }

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HashValue Property

AssemblyRefDeclaration..::..HashValue Property
AssemblyRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.AssemblyRefDeclaration.HashValue"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] HashValue { get; set; }

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

AssemblyRefDeclaration..::..IsMscorlib Property
AssemblyRefDeclaration Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; }

Implements

IAssemblyName..::.IsMscorlib

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStronglyNamed Property

AssemblyRefDeclaration..::..IsStronglyNamed Property
AssemblyRefDeclaration Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStronglyNamed { get; }

Implements

IAssemblyName..::.IsStronglyNamed

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsWeaklyReferenced Property

AssemblyRefDeclaration..::..IsWeaklyReferenced Property
AssemblyRefDeclaration Class See Also Send Feedback
Determines whether the current declaration is weakly or strongly referenced in the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsWeaklyReferenced { get; set; }

Implements

IWeakReferenceable..::.IsWeaklyReferenced

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


OverwrittenName Property

AssemblyRefDeclaration..::..OverwrittenName Property
AssemblyRefDeclaration Class See Also Send Feedback
Name of the assembly as it will be emitted during compilation.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OverwrittenName { get; set; }

Field Value

A valid name, or null if the name is not overwritten.

Remarks

Overwriting an assembly name allows to change the name of the compiled assembly without breaking references in the current domain (because changing the Name would make it impossible to resolve assembly references).

When the name is overwritten, the public key is automatically ignored during compilation.

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

AssemblyRefDeclaration..::..ParentMember Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

AssemblyRefDeclaration..::..ParentType Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

AssemblyRefDeclaration..::..ProcessorArchitecture Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; set; }

Implements

IAssemblyName..::.ProcessorArchitecture

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefs Property

AssemblyRefDeclaration..::..TypeRefs Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclarationCollection TypeRefs { get; }

Implements

ITypeRefResolutionScope..::.TypeRefs

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Version Property

AssemblyRefDeclaration..::..Version Property
AssemblyRefDeclaration Class See Also Send Feedback
Gets the assembly version.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; set; }

Field Value

A Version.

Implements

IAssemblyName..::.Version

See Also

AssemblyRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BaseInstructionWriter Class

BaseInstructionWriter Class
Members See Also Send Feedback
Provides the base operations for emitting IL instructions. This abstract class does not specify to which kind of target instructions are written. This is specific to classes deriving BaseInstructionWriter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class BaseInstructionWriter

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
PostSharp.Sdk.CodeModel..::.InstructionWriter

See Also

BaseInstructionWriter Members
PostSharp.Sdk.CodeModel Namespace


BaseInstructionWriter Members

[image]

PostSharp 2.0 Documentation
BaseInstructionWriter Members
BaseInstructionWriter Class Methods Properties See Also Send Feedback

The BaseInstructionWriter type exposes the following members.

Methods

 | Name | Description
Public method | EmitBranchingInstruction | Emits a branching instruction.
Public method | EmitInstruction | Emits an instruction without operand.
Public method | EmitInstructionByte | Emits an instruction with a Byte operand.
Public method | EmitInstructionDouble | Emits an instruction with a Double operand.
Public method | EmitInstructionField | Emits an instruction with an IField operand.
Public method | EmitInstructionInt16 | Emits an instruction with an Int16 operand.
Public method | EmitInstructionInt32 | Emits an instruction with an Int32 operand.
Public method | EmitInstructionInt64 | Emits an instruction with an Int64 operand.
Public method | EmitInstructionLoadIndirect | Emits the proper "load indirect" instruction as a function of the operand type.
Public method | EmitInstructionLocalVariable | Emits an instruction with a LocalVariableSymbol operand.
Public method | EmitInstructionMethod | Emits an instruction with an IMethod operand.
Public method | EmitInstructionParameter | Emits an instruction with a ParameterDeclaration operand.
Public method | EmitInstructionSignature | Emits an instruction with a StandaloneSignatureDeclaration operand.
Public method | EmitInstructionSingle | Emits an instruction with a Single operand.
Public method | EmitInstructionStoreElement | Emits the proper instruction that stores an array element for a given ITypeSignature.
Public method | EmitInstructionStoreIndirect | Emits the proper "store indirect" instruction as a function of the operand type.
Public method | EmitInstructionString | Emits an instruction with a string operand.
Public method | EmitInstructionType | Emits an instruction with an IType operand.
Public method | EmitPrefix | Emits a prefix without operand.
Public method | EmitPrefixType | Emits a prefix with an IType operand.
Public method | EmitSwitchInstruction | Emits a Switch instruction.
Public method | EmitSymbolSequencePoint | Emits a symbol sequence point.
 | FindBranchingOpCode | Given an arbitrary branching opcode, looks up the corresponding near and far opcodes.

Properties

 | Name | Description
Public property | ForceFarBranchingOperands | Determines whether far branching instructions should be unconditionally used.
Public property | MethodBody | Gets or sets the method body assigned to the current BaseInstructionWriter.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


BaseInstructionWriter Methods

[image]

PostSharp 2.0 Documentation
BaseInstructionWriter Methods
BaseInstructionWriter Class See Also Send Feedback

The BaseInstructionWriter type exposes the following members.

Methods

 | Name | Description
Public method | EmitBranchingInstruction | Emits a branching instruction.
Public method | EmitInstruction | Emits an instruction without operand.
Public method | EmitInstructionByte | Emits an instruction with a Byte operand.
Public method | EmitInstructionDouble | Emits an instruction with a Double operand.
Public method | EmitInstructionField | Emits an instruction with an IField operand.
Public method | EmitInstructionInt16 | Emits an instruction with an Int16 operand.
Public method | EmitInstructionInt32 | Emits an instruction with an Int32 operand.
Public method | EmitInstructionInt64 | Emits an instruction with an Int64 operand.
Public method | EmitInstructionLoadIndirect | Emits the proper "load indirect" instruction as a function of the operand type.
Public method | EmitInstructionLocalVariable | Emits an instruction with a LocalVariableSymbol operand.
Public method | EmitInstructionMethod | Emits an instruction with an IMethod operand.
Public method | EmitInstructionParameter | Emits an instruction with a ParameterDeclaration operand.
Public method | EmitInstructionSignature | Emits an instruction with a StandaloneSignatureDeclaration operand.
Public method | EmitInstructionSingle | Emits an instruction with a Single operand.
Public method | EmitInstructionStoreElement | Emits the proper instruction that stores an array element for a given ITypeSignature.
Public method | EmitInstructionStoreIndirect | Emits the proper "store indirect" instruction as a function of the operand type.
Public method | EmitInstructionString | Emits an instruction with a string operand.
Public method | EmitInstructionType | Emits an instruction with an IType operand.
Public method | EmitPrefix | Emits a prefix without operand.
Public method | EmitPrefixType | Emits a prefix with an IType operand.
Public method | EmitSwitchInstruction | Emits a Switch instruction.
Public method | EmitSymbolSequencePoint | Emits a symbol sequence point.
 | FindBranchingOpCode | Given an arbitrary branching opcode, looks up the corresponding near and far opcodes.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitBranchingInstruction Method

BaseInstructionWriter..::..EmitBranchingInstruction Method
BaseInstructionWriter Class See Also Send Feedback
Emits a branching instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitBranchingInstruction(
    OpCodeNumber code,
    InstructionSequence sequence
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction code.
sequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The target InstructionSequence.

Return Value

The distance of sequence w.r.t. the current instruction.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstruction Method

BaseInstructionWriter..::..EmitInstruction Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction without operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstruction(
    OpCodeNumber code
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionByte Method

BaseInstructionWriter..::..EmitInstructionByte Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a Byte operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionByte(
    OpCodeNumber code,
    byte operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Byte
The Byte operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionDouble Method

BaseInstructionWriter..::..EmitInstructionDouble Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a Double operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionDouble(
    OpCodeNumber code,
    double operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Double
The Double operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionField Method

BaseInstructionWriter..::..EmitInstructionField Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an IField operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionField(
    OpCodeNumber code,
    IField field
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
field
Type: PostSharp.Sdk.CodeModel..::.IField
The IField operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt16 Method

BaseInstructionWriter..::..EmitInstructionInt16 Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an Int16 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionInt16(
    OpCodeNumber code,
    short operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int16
The Int16 operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt32 Method

BaseInstructionWriter..::..EmitInstructionInt32 Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an Int32 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionInt32(
    OpCodeNumber code,
    int operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int32
The Int32 operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt64 Method

BaseInstructionWriter..::..EmitInstructionInt64 Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an Int64 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionInt64(
    OpCodeNumber code,
    long operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int64
The Int64 operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionLoadIndirect Method

BaseInstructionWriter..::..EmitInstructionLoadIndirect Method
BaseInstructionWriter Class See Also Send Feedback
Emits the proper "load indirect" instruction as a function of the operand type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitInstructionLoadIndirect(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Operand type.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionLocalVariable Method

BaseInstructionWriter..::..EmitInstructionLocalVariable Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a LocalVariableSymbol operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionLocalVariable(
    OpCodeNumber code,
    LocalVariableSymbol localVariableSymbol
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
localVariableSymbol
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The LocalVariableSymbol operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionMethod Method

BaseInstructionWriter..::..EmitInstructionMethod Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an IMethod operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionMethod(
    OpCodeNumber code,
    IMethod method
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
method
Type: PostSharp.Sdk.CodeModel..::.IMethod
The IMethod operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionParameter Method

BaseInstructionWriter..::..EmitInstructionParameter Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a ParameterDeclaration operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionParameter(
    OpCodeNumber code,
    ParameterDeclaration parameter
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
parameter
Type: PostSharp.Sdk.CodeModel..::.ParameterDeclaration
The ParameterDeclaration operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionSignature Method

BaseInstructionWriter..::..EmitInstructionSignature Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a StandaloneSignatureDeclaration operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionSignature(
    OpCodeNumber code,
    StandaloneSignatureDeclaration signature
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
signature
Type: PostSharp.Sdk.CodeModel..::.StandaloneSignatureDeclaration
The StandaloneSignatureDeclaration operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionSingle Method

BaseInstructionWriter..::..EmitInstructionSingle Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a Single operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionSingle(
    OpCodeNumber code,
    float operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Single
The Single operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionStoreElement Method

BaseInstructionWriter..::..EmitInstructionStoreElement Method
BaseInstructionWriter Class See Also Send Feedback
Emits the proper instruction that stores an array element for a given ITypeSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitInstructionStoreElement(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of elements of the array.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionStoreIndirect Method

BaseInstructionWriter..::..EmitInstructionStoreIndirect Method
BaseInstructionWriter Class See Also Send Feedback
Emits the proper "store indirect" instruction as a function of the operand type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitInstructionStoreIndirect(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Operand type.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionString Method

BaseInstructionWriter..::..EmitInstructionString Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with a string operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionString(
    OpCodeNumber code,
    LiteralString operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: PostSharp.Sdk.CodeModel..::.LiteralString
The string operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionType Method

BaseInstructionWriter..::..EmitInstructionType Method
BaseInstructionWriter Class See Also Send Feedback
Emits an instruction with an IType operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitInstructionType(
    OpCodeNumber code,
    ITypeSignature type
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The IType operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitPrefix Method

BaseInstructionWriter..::..EmitPrefix Method
BaseInstructionWriter Class See Also Send Feedback
Emits a prefix without operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitPrefix(
    InstructionPrefixes prefix
)

Parameters

prefix
Type: PostSharp.Sdk.CodeModel..::.InstructionPrefixes
A combination of prefixes.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitPrefixType Method

BaseInstructionWriter..::..EmitPrefixType Method
BaseInstructionWriter Class See Also Send Feedback
Emits a prefix with an IType operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitPrefixType(
    OpCodeNumber prefix,
    ITypeSignature type
)

Parameters

prefix
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
A single prefix (not a combination).
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The IType operand.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitSwitchInstruction Method

BaseInstructionWriter..::..EmitSwitchInstruction Method
BaseInstructionWriter Class See Also Send Feedback
Emits a Switch instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitSwitchInstruction(
    InstructionSequence[] switchTargets
)

Parameters

switchTargets
Type: array< PostSharp.Sdk.CodeModel..::.InstructionSequence >[]()[][]
An array of instruction sequences (InstructionSequence) which are the targets of the switch instruction.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitSymbolSequencePoint Method

BaseInstructionWriter..::..EmitSymbolSequencePoint Method
BaseInstructionWriter Class See Also Send Feedback
Emits a symbol sequence point.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void EmitSymbolSequencePoint(
    SymbolSequencePoint sequencePoint
)

Parameters

sequencePoint
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint, or null.

Remarks

This method does nothing if sequencePoint is null.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


FindBranchingOpCode Method

BaseInstructionWriter..::..FindBranchingOpCode Method
BaseInstructionWriter Class See Also Send Feedback
Given an arbitrary branching opcode, looks up the corresponding near and far opcodes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected static void FindBranchingOpCode(
    OpCodeNumber opCode,
    out OpCodeNumber nearOpCode,
    out OpCodeNumber farOpCode
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An arbitrary branching opcode (short or long).
nearOpCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber %
The near variant of opCode.
farOpCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber %
The far variant of opCode.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


BaseInstructionWriter Properties

[image]

PostSharp 2.0 Documentation
BaseInstructionWriter Properties
BaseInstructionWriter Class See Also Send Feedback

The BaseInstructionWriter type exposes the following members.

Properties

 | Name | Description
Public property | ForceFarBranchingOperands | Determines whether far branching instructions should be unconditionally used.
Public property | MethodBody | Gets or sets the method body assigned to the current BaseInstructionWriter.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


ForceFarBranchingOperands Property

BaseInstructionWriter..::..ForceFarBranchingOperands Property
BaseInstructionWriter Class See Also Send Feedback
Determines whether far branching instructions should be unconditionally used.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ForceFarBranchingOperands { get; }

Remarks

When this property is true, this class will not try to emit different instructions according to the address distance. This may be only used when (1) one does not emit final IL code, (2) near and far instructions are considered equivalently and (3) the reader is aware that near instructions expect a large operand. This is typically the case when we emit temporary IL code and the operand is an InstructionSequence token.

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

BaseInstructionWriter..::..MethodBody Property
BaseInstructionWriter Class See Also Send Feedback
Gets or sets the method body assigned to the current BaseInstructionWriter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; protected set; }

See Also

BaseInstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


BindingException Class

BindingException Class
Members See Also Send Feedback
Exception thrown when a binding exception occurs in PostSharp.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class BindingException : ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
PostSharp.Sdk.CodeModel..::.BindingException

See Also

BindingException Members
PostSharp.Sdk.CodeModel Namespace


BindingException Members

[image]

PostSharp 2.0 Documentation
BindingException Members
BindingException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | BindingException | Overloaded.

See Also

BindingException Class
PostSharp.Sdk.CodeModel Namespace


BindingException Constructor

[image]

PostSharp 2.0 Documentation
BindingException Constructor
BindingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BindingException()()() | Initializes a new BindingException.
Public method | BindingException(String) | Initializes a new BindingException and defines the message.
Protected method | BindingException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | BindingException(String, Exception) | Initializes a new BindingException and defines the message and the inner exception.

See Also

BindingException Class
BindingException Members
PostSharp.Sdk.CodeModel Namespace


BindingException Constructor

BindingException Constructor
BindingException Class See Also Send Feedback
Initializes a new BindingException.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BindingException()

See Also

BindingException Class
BindingException Overload
PostSharp.Sdk.CodeModel Namespace


BindingException Constructor (String)

BindingException Constructor (String)
BindingException Class See Also Send Feedback
Initializes a new BindingException and defines the message.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BindingException(
    string message
)

Parameters

message
Type: System..::.String
Error message.

See Also

BindingException Class
BindingException Overload
PostSharp.Sdk.CodeModel Namespace


BindingException Constructor (SerializationInfo, StreamingContext)

BindingException Constructor (SerializationInfo, StreamingContext)
BindingException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected BindingException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming context.

See Also

BindingException Class
BindingException Overload
PostSharp.Sdk.CodeModel Namespace


BindingException Constructor (String, Exception)

BindingException Constructor (String, Exception)
BindingException Class See Also Send Feedback
Initializes a new BindingException and defines the message and the inner exception.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BindingException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Error message.
inner
Type: System..::.Exception
Inner exception.

See Also

BindingException Class
BindingException Overload
PostSharp.Sdk.CodeModel Namespace


BindingOptions Enumeration

BindingOptions Enumeration
See Also Send Feedback
Determines how the binding methods behave when the requested object is not found.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum BindingOptions

Members

Member name | Value | Description
Default | 0 | Default. The library shall create the object and assign it a MetadataToken if the requested object is not found.
OnlyExisting | 1 | Indicates that the methods shall return null if the requested object is not found.
WeakReference | 2 | Indicates that the methods shall create the object but shall not assign it a MetadataToken. This option is typically used when the object should not be linked statically using the module metadata, but the full name of the object is included (for instance with permission sets and custom attributes).
ExistenceMask | 3 | Masks OnlyExisting and WeakReference.
RequireGenericInstance | 16 | Indicates generic type or method instances are required (all generic parameters should be bound).
RequireGenericDefinition | 32 | Indicates that generic or method definitions are required (generic parameters should not be bound).
RequireGenericMask | 48 | Mask isolating the way how generic types or methods should be bound. RequireGenericInstance, RequireGenericDefinition or Default.
DisallowIntrinsicSubstitution | 8 | Indicates that normal types (Object, Int32, ...) should be used instead of intrinsics (object, int32, ...).
DontThrowException | 64 | Returns a null pointer instead of throwing an exception if the declaration is not found.
OnlyDefinition | 128 | Indicates that only definitions (not references or constructions) are allowed.
RequireIType | 256 | Indicates that a only objects derived from IType should be returned; if the type appears to be a TypeSignature, it will be wrapped into a TypeSpecDeclaration.
RequireEquality | 512 | Indicates that strict equality is required when comparing assembly names.
WeakenReferenceProcessorArchitecture | 1024 | Indicates that the processor architecture is not checked if processor architecture in the definition tern is None.
IgnoreProcessorArchitecture | 2048 | Indicates that the processor architecture is not checked.
BindingEqualityOptions | 2560 | Options used when comparing for equality.

See Also

PostSharp.Sdk.CodeModel Namespace


CallingConvention Enumeration

CallingConvention Enumeration
See Also Send Feedback
Determines the calling convention of methods.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum CallingConvention

Members

Member name | Value | Description
Default | 0 | Default.
UnmanagedCdecl | 1 | Unmanaged cdecl.
UnmanagedStdCall | 2 | Unmanaged StdCall.
UnmanagedThisCall | 3 | Unmanaged ThisCall.
UnmanagedFastCall | 4 | Unmanaged FastCall.
VarArg | 5 | Managed VarArg.
NativeVarArg | 11 | NativeVarArg (Used ONLY for 64bit vararg PInvoke calls).
CallingConventionMask | 15 | Bit mask for the calling convention.
HasThis | 32 | There is a this parameter.
ExplicitThis | 64 | The this parameter is explicitely in the signature.

See Also

PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Class

CustomAttributeConstructorException Class
Members See Also Send Feedback
Wraps any exception thrown during the construction of a custom attribute runtime instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class CustomAttributeConstructorException : ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException

See Also

CustomAttributeConstructorException Members
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Members

[image]

PostSharp 2.0 Documentation
CustomAttributeConstructorException Members
CustomAttributeConstructorException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | CustomAttributeConstructorException | Overloaded.

See Also

CustomAttributeConstructorException Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Constructor

[image]

PostSharp 2.0 Documentation
CustomAttributeConstructorException Constructor
CustomAttributeConstructorException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomAttributeConstructorException()()() | Initializes a new CustomAttributeConstructorException
Public method | CustomAttributeConstructorException(String) | Initializes a new CustomAttributeConstructorException and specifies the exception message.
Protected method | CustomAttributeConstructorException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | CustomAttributeConstructorException(String, Exception) | Initializes a new CustomAttributeConstructorException and specifies the error message and the inner exception.

See Also

CustomAttributeConstructorException Class
CustomAttributeConstructorException Members
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Constructor

CustomAttributeConstructorException Constructor
CustomAttributeConstructorException Class See Also Send Feedback
Initializes a new CustomAttributeConstructorException

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeConstructorException()

See Also

CustomAttributeConstructorException Class
CustomAttributeConstructorException Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Constructor (String)

CustomAttributeConstructorException Constructor (String)
CustomAttributeConstructorException Class See Also Send Feedback
Initializes a new CustomAttributeConstructorException and specifies the exception message.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeConstructorException(
    string message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

CustomAttributeConstructorException Class
CustomAttributeConstructorException Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Constructor (SerializationInfo, StreamingContext)

CustomAttributeConstructorException Constructor (SerializationInfo, StreamingContext)
CustomAttributeConstructorException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected CustomAttributeConstructorException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming context.

See Also

CustomAttributeConstructorException Class
CustomAttributeConstructorException Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeConstructorException Constructor (String, Exception)

CustomAttributeConstructorException Constructor (String, Exception)
CustomAttributeConstructorException Class See Also Send Feedback
Initializes a new CustomAttributeConstructorException and specifies the error message and the inner exception.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeConstructorException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

CustomAttributeConstructorException Class
CustomAttributeConstructorException Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Class

CustomAttributeDeclaration Class
Members See Also Send Feedback
Represents a custom attribute (CustomAttribute).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomAttributeDeclaration : MetadataDeclaration,
    IAnnotationInstance, IAnnotationValue, IRemovable, IMetadataDeclaration, IDeclaration,
    IElement, ITaggable, ICloneableModuleElement, IModuleElement

Remarks

Any MetadataDeclaration can have custom attributes. They are exposed on the CustomAttributes property.

If you change any member of an instance of CustomAttributeDeclaration, you have to call the InvalidateSerialization()()() to force the custom attribute to be serialized again.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.CustomAttributeDeclaration

See Also

CustomAttributeDeclaration Members
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Members

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclaration Members
CustomAttributeDeclaration Class Constructors Methods Properties See Also Send Feedback

The CustomAttributeDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | CustomAttributeDeclaration | Overloaded.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone |
Public method | ConstructRuntimeObject | Gets the runtime object constructed from the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | InvalidateSerialization | Invalidates the original serialization. Indicates that the serialization should be computed again, if requested.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the custom attribute so that it can be used in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the set of constructor arguments.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | NamedArguments | Gets the set of named arguments.
Public property | Parent | Gets the parent MetadataDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Symbol | Element of the symbol file representing the current aspect instance.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Constructor

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclaration Constructor
CustomAttributeDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomAttributeDeclaration(IAnnotationValue) | Initializes a new CustomAttributeDeclaration cloned from a IAnnotationValue.
Public method | CustomAttributeDeclaration(IMethod) | Initializes a new instance of the CustomAttributeDeclaration type.

See Also

CustomAttributeDeclaration Class
CustomAttributeDeclaration Members
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Constructor (IAnnotationValue)

CustomAttributeDeclaration Constructor (IAnnotationValue)
CustomAttributeDeclaration Class See Also Send Feedback
Initializes a new CustomAttributeDeclaration cloned from a IAnnotationValue.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration(
    IAnnotationValue source
)

Parameters

source
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
Source IAnnotationValue from which the new instance has to be copied.

See Also

CustomAttributeDeclaration Class
CustomAttributeDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Constructor (IMethod)

CustomAttributeDeclaration Constructor (IMethod)
CustomAttributeDeclaration Class See Also Send Feedback
Initializes a new instance of the CustomAttributeDeclaration type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration(
    IMethod constructor
)

Parameters

constructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Custom attribute constructor.

Remarks

The constructor parameter should be set to a valid instance constructor. This rule is not enforced.

See Also

CustomAttributeDeclaration Class
CustomAttributeDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Methods

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclaration Methods
CustomAttributeDeclaration Class See Also Send Feedback

The CustomAttributeDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone |
Public method | ConstructRuntimeObject | Gets the runtime object constructed from the current instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | InvalidateSerialization | Invalidates the original serialization. Indicates that the serialization should be computed again, if requested.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the custom attribute so that it can be used in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

CustomAttributeDeclaration..::..Clone Method
CustomAttributeDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.CustomAttributeDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.CustomAttributeDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.CustomAttributeDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ConstructRuntimeObject Method

CustomAttributeDeclaration..::..ConstructRuntimeObject Method
CustomAttributeDeclaration Class See Also Send Feedback
Gets the runtime object constructed from the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object ConstructRuntimeObject()

Return Value

An object constructed from Constructor with all NamedArguments properly set.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

CustomAttributeDeclaration..::..GetTokenType Method
CustomAttributeDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InvalidateSerialization Method

CustomAttributeDeclaration..::..InvalidateSerialization Method
CustomAttributeDeclaration Class See Also Send Feedback
Invalidates the original serialization. Indicates that the serialization should be computed again, if requested.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void InvalidateSerialization()

Remarks

Use the current method if you change a value in the custom attribute.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

CustomAttributeDeclaration..::..Remove Method
CustomAttributeDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

CustomAttributeDeclaration..::..ToString Method
CustomAttributeDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

CustomAttributeDeclaration..::..Translate Method
CustomAttributeDeclaration Class See Also Send Feedback
Translates the custom attribute so that it can be used in another module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
A module.

Return Value

A CustomAttributeDeclaration equivalent to the current instance, but valid inside the other module.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributeDeclaration Properties

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclaration Properties
CustomAttributeDeclaration Class See Also Send Feedback

The CustomAttributeDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the set of constructor arguments.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | NamedArguments | Gets the set of named arguments.
Public property | Parent | Gets the parent MetadataDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Symbol | Element of the symbol file representing the current aspect instance.

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Constructor Property

CustomAttributeDeclaration..::..Constructor Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the custom attribute constructor.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod Constructor { get; }

Implements

IAnnotationValue..::.Constructor

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ConstructorArguments Property

CustomAttributeDeclaration..::..ConstructorArguments Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the set of constructor arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection ConstructorArguments { get; }

Implements

IAnnotationValue..::.ConstructorArguments

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedArguments Property

CustomAttributeDeclaration..::..NamedArguments Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the set of named arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection NamedArguments { get; }

Implements

IAnnotationValue..::.NamedArguments

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

CustomAttributeDeclaration..::..Parent Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the parent MetadataDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration Parent { get; }

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

CustomAttributeDeclaration..::..ParentMember Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

CustomAttributeDeclaration..::..ParentType Property
CustomAttributeDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Symbol Property

CustomAttributeDeclaration..::..Symbol Property
CustomAttributeDeclaration Class See Also Send Feedback
Element of the symbol file representing the current aspect instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsage Symbol { get; }

Implements

IAnnotationInstance..::.Symbol

See Also

CustomAttributeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributeHelper Class

CustomAttributeHelper Class
Members See Also Send Feedback
Extension methods for IAnnotationValue.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class CustomAttributeHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.CustomAttributeHelper

See Also

CustomAttributeHelper Members
PostSharp.Sdk.CodeModel Namespace


CustomAttributeHelper Members

[image]

PostSharp 2.0 Documentation
CustomAttributeHelper Members
CustomAttributeHelper Class Methods See Also Send Feedback

The CustomAttributeHelper type exposes the following members.

Methods

Name | Description
ConstructRuntimeObject | Overloaded.
ConstructRuntimeObject<(Of <(T>)>) | Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework.
Render | Overloaded.

See Also

CustomAttributeHelper Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributeHelper Methods

[image]

PostSharp 2.0 Documentation
CustomAttributeHelper Methods
CustomAttributeHelper Class See Also Send Feedback

The CustomAttributeHelper type exposes the following members.

Methods

Name | Description
ConstructRuntimeObject | Overloaded.
ConstructRuntimeObject<(Of <(T>)>) | Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework.
Render | Overloaded.

See Also

CustomAttributeHelper Class
PostSharp.Sdk.CodeModel Namespace


ConstructRuntimeObject Method

[image]

PostSharp 2.0 Documentation
CustomAttributeHelper..::..ConstructRuntimeObject Method
CustomAttributeHelper Class See Also Send Feedback

Overload List

Name | Description
ConstructRuntimeObject(IAnnotationValue) | Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework.
ConstructRuntimeObject(IAnnotationValue, Type) | Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework.

See Also

CustomAttributeHelper Class
CustomAttributeHelper Members
PostSharp.Sdk.CodeModel Namespace


ConstructRuntimeObject Method (IAnnotationValue)

CustomAttributeHelper..::..ConstructRuntimeObject Method (IAnnotationValue)
CustomAttributeHelper Class See Also Send Feedback
Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Object ConstructRuntimeObject(
    this IAnnotationValue attribute
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
Custom attribute to be constructed.

Return Value

A new instance (typically derived from Attribute) constructed on by the constructor represented by the Constructor property and based on the values given in ConstructorArguments and NamedArguments.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAnnotationValue. When you use instance method syntax to call this method, omit the first parameter.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeHelper Class
ConstructRuntimeObject Overload
PostSharp.Sdk.CodeModel Namespace


ConstructRuntimeObject Method (IAnnotationValue, Type)

CustomAttributeHelper..::..ConstructRuntimeObject Method (IAnnotationValue, Type)
CustomAttributeHelper Class See Also Send Feedback
Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Object ConstructRuntimeObject(
    this IAnnotationValue attribute,
    Type instanceType
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
Custom attribute to be constructed.
instanceType
Type: System..::.Type
Type of the custom attribute.

Return Value

A new instance (typically derived from Attribute) constructed on by the constructor represented by the Constructor property and based on the values given in ConstructorArguments and NamedArguments.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAnnotationValue. When you use instance method syntax to call this method, omit the first parameter.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeHelper Class
ConstructRuntimeObject Overload
PostSharp.Sdk.CodeModel Namespace


ConstructRuntimeObject(T) Method

CustomAttributeHelper..::..ConstructRuntimeObject<(Of <(<'T>)>)> Method
CustomAttributeHelper Class See Also Send Feedback
Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static T ConstructRuntimeObject<T>(
    this IAnnotationValue attribute
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
Custom attribute to be constructed.

Type Parameters

T
Type of the custom attribute.

Return Value

A new instance (typically derived from Attribute) constructed on by the constructor represented by the Constructor property and based on the values given in ConstructorArguments and NamedArguments.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAnnotationValue. When you use instance method syntax to call this method, omit the first parameter.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeHelper Class
PostSharp.Sdk.CodeModel Namespace


Render Method

[image]

PostSharp 2.0 Documentation
CustomAttributeHelper..::..Render Method
CustomAttributeHelper Class See Also Send Feedback

Overload List

Name | Description
Render(IAnnotationValue) | Renders a custom attribute value to a string.
Render(IAnnotationValue, StringBuilder) | Renders a custom attribute value to an existing StringBuilder.

See Also

CustomAttributeHelper Class
CustomAttributeHelper Members
PostSharp.Sdk.CodeModel Namespace


Render Method (IAnnotationValue)

CustomAttributeHelper..::..Render Method (IAnnotationValue)
CustomAttributeHelper Class See Also Send Feedback
Renders a custom attribute value to a string.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string Render(
    this IAnnotationValue attribute
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
A custom attribute value.

Return Value

A string representing attribute.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAnnotationValue. When you use instance method syntax to call this method, omit the first parameter.

See Also

CustomAttributeHelper Class
Render Overload
PostSharp.Sdk.CodeModel Namespace


Render Method (IAnnotationValue, StringBuilder)

CustomAttributeHelper..::..Render Method (IAnnotationValue, StringBuilder)
CustomAttributeHelper Class See Also Send Feedback
Renders a custom attribute value to an existing StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Render(
    this IAnnotationValue attribute,
    StringBuilder target
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
A custom attribute.
target
Type: System.Text..::.StringBuilder
A StringBuilder where to writer the attribute.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAnnotationValue. When you use instance method syntax to call this method, omit the first parameter.

See Also

CustomAttributeHelper Class
Render Overload
PostSharp.Sdk.CodeModel Namespace


DataSectionDeclaration Class

DataSectionDeclaration Class
Members See Also Send Feedback
Represents a data section, where initial values of fieds are stored.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DataSectionDeclaration : Declaration,
    IPositioned

Remarks

Data declarations are owned by the module (ModuleDeclaration) on the Data property.

Fields (FieldDefDeclaration) with fixed binary layout may be initialized to a value stored in a DataSectionDeclaration by setting the InitialValue property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.DataSectionDeclaration

See Also

DataSectionDeclaration Members
PostSharp.Sdk.CodeModel Namespace


DataSectionDeclaration Members

[image]

PostSharp 2.0 Documentation
DataSectionDeclaration Members
DataSectionDeclaration Class Constructors Methods Properties See Also Send Feedback

The DataSectionDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | DataSectionDeclaration | Initializes a new DataSectionDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsManaged | Determines whether the data section is managed.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the data section.
Public property | Ordinal | Gets or set the emit order of the data section in the module.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Value | Gets or sets the raw data.

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DataSectionDeclaration Constructor

DataSectionDeclaration Constructor
DataSectionDeclaration Class See Also Send Feedback
Initializes a new DataSectionDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DataSectionDeclaration(
    string name,
    byte[] data,
    bool isManaged
)

Parameters

name
Type: System..::.String
Data section name (label).
data
Type: array< System..::.Byte >[]()[][]
Raw data.
isManaged
Type: System..::.Boolean
true if the data section is managed, otherwise false.

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DataSectionDeclaration Methods

[image]

PostSharp 2.0 Documentation
DataSectionDeclaration Methods
DataSectionDeclaration Class See Also Send Feedback

The DataSectionDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DataSectionDeclaration Properties

[image]

PostSharp 2.0 Documentation
DataSectionDeclaration Properties
DataSectionDeclaration Class See Also Send Feedback

The DataSectionDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsManaged | Determines whether the data section is managed.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the data section.
Public property | Ordinal | Gets or set the emit order of the data section in the module.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Value | Gets or sets the raw data.

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsManaged Property

DataSectionDeclaration..::..IsManaged Property
DataSectionDeclaration Class See Also Send Feedback
Determines whether the data section is managed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsManaged { get; set; }

Field Value

true if the data section is managed, otherwise false.

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Name Property

DataSectionDeclaration..::..Name Property
DataSectionDeclaration Class See Also Send Feedback
Gets or sets the name of the data section.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

Field Value

The name (value) of the data section.

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

DataSectionDeclaration..::..Ordinal Property
DataSectionDeclaration Class See Also Send Feedback
Gets or set the emit order of the data section in the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; set; }

Field Value

The emit order of the current data section in the containing module.

Implements

IPositioned..::.Ordinal

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Value Property

DataSectionDeclaration..::..Value Property
DataSectionDeclaration Class See Also Send Feedback
Gets or sets the raw data.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] Value { get; set; }

See Also

DataSectionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Declaration Class

Declaration Class
Members See Also Send Feedback
Base type for all declarations of a module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Declaration : Element,
    IDeclaration, IElement, IModuleElement

Remarks

A Declaration is basically an Element that has a ModuleDeclaration in its ancestor axis. It is exposed in the Module property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.DataSectionDeclaration
PostSharp.Sdk.CodeModel..::.ExceptionHandler
PostSharp.Sdk.CodeModel.Helpers..::.DelegateSignature
PostSharp.Sdk.CodeModel..::.LocalVariableDeclaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodBodyDeclaration
PostSharp.Sdk.CodeModel..::.PermissionDeclaration
PostSharp.Sdk.WeavingSymbols..::.SymAspectClass
PostSharp.Sdk.WeavingSymbols..::.SymAspectInstance
PostSharp.Sdk.WeavingSymbols..::.SymAspectModule
PostSharp.Sdk.WeavingSymbols..::.SymAspectUsage
PostSharp.Sdk.WeavingSymbols..::.SymEvolution
PostSharp.Sdk.WeavingSymbols..::.SymJoinPoint

See Also

Declaration Members
PostSharp.Sdk.CodeModel Namespace


Declaration Members

[image]

PostSharp 2.0 Documentation
Declaration Members
Declaration Class Constructors Methods Properties See Also Send Feedback

The Declaration type exposes the following members.

Constructors

 | Name | Description
Protected method | Declaration | Initializes a new instance of the Declaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


Declaration Constructor

Declaration Constructor
Declaration Class See Also Send Feedback
Initializes a new instance of the Declaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Declaration()

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


Declaration Methods

[image]

PostSharp 2.0 Documentation
Declaration Methods
Declaration Class See Also Send Feedback

The Declaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


Declaration Properties

[image]

PostSharp 2.0 Documentation
Declaration Properties
Declaration Class See Also Send Feedback

The Declaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

Declaration..::..DeclaringAssembly Property
Declaration Class See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual IAssembly DeclaringAssembly { get; }

Implements

IModuleElement..::.DeclaringAssembly

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


Module Property

Declaration..::..Module Property
Declaration Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; protected set; }

Implements

IModuleElement..::.Module

See Also

Declaration Class
PostSharp.Sdk.CodeModel Namespace


DeclarationCache Class

DeclarationCache Class
Members See Also Send Feedback
Caches some frequently-used declarations or constructions with lazy loading.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DeclarationCache

Remarks

This cache can serve three types of content: types, intrinsic types and arbitrary content served by providers. The last mechanism is used to cache methods (which are difficult to reference otherwise).

The current class provides itself the contents whose key is declared here (see static fields of this class).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.DeclarationCache

See Also

DeclarationCache Members
PostSharp.Sdk.CodeModel Namespace


DeclarationCache Members

[image]

PostSharp 2.0 Documentation
DeclarationCache Members
DeclarationCache Class Methods Fields See Also Send Feedback

The DeclarationCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear the cache content.
Public method | GetGenericParameter | Gets a GenericParameterTypeSignature.
Public method | GetGenericParameterArray | Creates an array of GenericParameterTypeSignature with incremental ordinals.
Public method | GetIntrinsic | Overloaded.
Public method | GetIntrinsicBoxedType | Gets the boxed type of an intrinsic.
Public method | GetIntrinsicSerializationType | Gets an IntrinsicSerializationType, given an IntrinsicType.
Public method | GetItem<(Of <(T>)>) | Gets a declaration served by a provider.
Public method | GetType | Overloaded.

Fields

 | Name | Description
Public field | FieldInfoGetFieldFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle) method.
Public field | FieldInfoGetFieldFromHandle2 | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle, RuntimeTypeHandle) method.
Public field | IdentityGenericMap | Gets a GenericMap mapping generic parameters on themselves, valid for the current module.
Public field | MethodBaseGetMethodFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the MethodBase.GetMethodFromHandle(RuntimeMethodHandle) method.
Public field | MethodBaseGetMethodFromHandle2 | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetMethodFromHandle(RuntimeMethodHandle, RuntimeTypeHandle) method.
Public field | TaggedObjectSerializationType | Gets an instance of TaggedObjectSerializationType that is valid for the current module.
Public field | TypeGetTypeFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetTypeFromHandle(RuntimeTypeHandle) method.
Public field | TypeSerializationType | Gets an instance of TypeSerializationType that is valid for the current module.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


DeclarationCache Fields

[image]

PostSharp 2.0 Documentation
DeclarationCache Fields
DeclarationCache Class See Also Send Feedback

The DeclarationCache type exposes the following members.

Fields

 | Name | Description
Public field | FieldInfoGetFieldFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle) method.
Public field | FieldInfoGetFieldFromHandle2 | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle, RuntimeTypeHandle) method.
Public field | IdentityGenericMap | Gets a GenericMap mapping generic parameters on themselves, valid for the current module.
Public field | MethodBaseGetMethodFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the MethodBase.GetMethodFromHandle(RuntimeMethodHandle) method.
Public field | MethodBaseGetMethodFromHandle2 | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetMethodFromHandle(RuntimeMethodHandle, RuntimeTypeHandle) method.
Public field | TaggedObjectSerializationType | Gets an instance of TaggedObjectSerializationType that is valid for the current module.
Public field | TypeGetTypeFromHandle | Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetTypeFromHandle(RuntimeTypeHandle) method.
Public field | TypeSerializationType | Gets an instance of TypeSerializationType that is valid for the current module.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


FieldInfoGetFieldFromHandle Field

DeclarationCache..::..FieldInfoGetFieldFromHandle Field
DeclarationCache Class See Also Send Feedback
Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly Func<IMethod> FieldInfoGetFieldFromHandle

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


FieldInfoGetFieldFromHandle2 Field

DeclarationCache..::..FieldInfoGetFieldFromHandle2 Field
DeclarationCache Class See Also Send Feedback
Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the FieldInfo.GetFieldFromHandle(RuntimeFieldHandle, RuntimeTypeHandle) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly Func<IMethod> FieldInfoGetFieldFromHandle2

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


IdentityGenericMap Field

DeclarationCache..::..IdentityGenericMap Field
DeclarationCache Class See Also Send Feedback
Gets a GenericMap mapping generic parameters on themselves, valid for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly GenericMap IdentityGenericMap

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


MethodBaseGetMethodFromHandle Field

DeclarationCache..::..MethodBaseGetMethodFromHandle Field
DeclarationCache Class See Also Send Feedback
Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the MethodBase.GetMethodFromHandle(RuntimeMethodHandle) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly Func<IMethod> MethodBaseGetMethodFromHandle

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


MethodBaseGetMethodFromHandle2 Field

DeclarationCache..::..MethodBaseGetMethodFromHandle2 Field
DeclarationCache Class See Also Send Feedback
Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetMethodFromHandle(RuntimeMethodHandle, RuntimeTypeHandle) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly Func<IMethod> MethodBaseGetMethodFromHandle2

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


TaggedObjectSerializationType Field

DeclarationCache..::..TaggedObjectSerializationType Field
DeclarationCache Class See Also Send Feedback
Gets an instance of TaggedObjectSerializationType that is valid for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly TaggedObjectSerializationType TaggedObjectSerializationType

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


TypeGetTypeFromHandle Field

DeclarationCache..::..TypeGetTypeFromHandle Field
DeclarationCache Class See Also Send Feedback
Callback method for the GetItem<(Of <(T>)>)(Func<(Of <(T>)>)) method, retrieving the Type.GetTypeFromHandle(RuntimeTypeHandle) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly Func<IMethod> TypeGetTypeFromHandle

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


TypeSerializationType Field

DeclarationCache..::..TypeSerializationType Field
DeclarationCache Class See Also Send Feedback
Gets an instance of TypeSerializationType that is valid for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public readonly TypeSerializationType TypeSerializationType

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


DeclarationCache Methods

[image]

PostSharp 2.0 Documentation
DeclarationCache Methods
DeclarationCache Class See Also Send Feedback

The DeclarationCache type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear the cache content.
Public method | GetGenericParameter | Gets a GenericParameterTypeSignature.
Public method | GetGenericParameterArray | Creates an array of GenericParameterTypeSignature with incremental ordinals.
Public method | GetIntrinsic | Overloaded.
Public method | GetIntrinsicBoxedType | Gets the boxed type of an intrinsic.
Public method | GetIntrinsicSerializationType | Gets an IntrinsicSerializationType, given an IntrinsicType.
Public method | GetItem<(Of <(T>)>) | Gets a declaration served by a provider.
Public method | GetType | Overloaded.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


Clear Method

DeclarationCache..::..Clear Method
DeclarationCache Class See Also Send Feedback
Clear the cache content.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Remarks

This obviously does not clear the list of providers.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method

DeclarationCache..::..GetGenericParameter Method
DeclarationCache Class See Also Send Feedback
Gets a GenericParameterTypeSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterTypeSignature GetGenericParameter(
    int ordinal,
    GenericParameterKind kind
)

Parameters

ordinal
Type: System..::.Int32
Ordinal (index) of the generic parameter.
kind
Type: PostSharp.Sdk.CodeModel..::.GenericParameterKind
Kind (Type or Method of this generic parameter.

Return Value

A GenericParameterTypeSignature with the given ordinal and kind, valid in the current module.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetGenericParameterArray Method

DeclarationCache..::..GetGenericParameterArray Method
DeclarationCache Class See Also Send Feedback
Creates an array of GenericParameterTypeSignature with incremental ordinals.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<ITypeSignature> GetGenericParameterArray(
    int length,
    GenericParameterKind kind
)

Parameters

length
Type: System..::.Int32
Array length.
kind
Type: PostSharp.Sdk.CodeModel..::.GenericParameterKind
Kind of generic parameter.

Return Value

An array of ITypeSignature that can be used to construct a generic type or method instance with generic parameters like <!0, !1, ..., !length> or <!!0, !!1, ..., !!length>

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetIntrinsic Method

[image]

PostSharp 2.0 Documentation
DeclarationCache..::..GetIntrinsic Method
DeclarationCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetIntrinsic(Type) | Gets an IntrinsicTypeSignature, given a reflection Type.
Public method | GetIntrinsic(IntrinsicType) | Gets an IntrinsicTypeSignature, given an IntrinsicType.

See Also

DeclarationCache Class
DeclarationCache Members
PostSharp.Sdk.CodeModel Namespace


GetIntrinsic Method (Type)

DeclarationCache..::..GetIntrinsic Method (Type)
DeclarationCache Class See Also Send Feedback
Gets an IntrinsicTypeSignature, given a reflection Type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicTypeSignature GetIntrinsic(
    Type reflectionType
)

Parameters

reflectionType
Type: System..::.Type
A reflection Type corresponding to an intrinsic.

Return Value

The IntrinsicTypeSignature corresponding to reflectionType.

See Also

DeclarationCache Class
GetIntrinsic Overload
PostSharp.Sdk.CodeModel Namespace


GetIntrinsic Method (IntrinsicType)

DeclarationCache..::..GetIntrinsic Method (IntrinsicType)
DeclarationCache Class See Also Send Feedback
Gets an IntrinsicTypeSignature, given an IntrinsicType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicTypeSignature GetIntrinsic(
    IntrinsicType intrinsic
)

Parameters

intrinsic
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
An intrinsic.

Return Value

The IntrinsicTypeSignature corresponding to intrinsic.

See Also

DeclarationCache Class
GetIntrinsic Overload
PostSharp.Sdk.CodeModel Namespace


GetIntrinsicBoxedType Method

DeclarationCache..::..GetIntrinsicBoxedType Method
DeclarationCache Class Example See Also Send Feedback
Gets the boxed type of an intrinsic.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public INamedType GetIntrinsicBoxedType(
    IntrinsicType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
The intrinsic type.

Return Value

The boxed type corresponding to the intrinsic type.

Examples

GetIntrinsicBoxedType(IntrinsicType.Object) returns Object.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetIntrinsicSerializationType Method

DeclarationCache..::..GetIntrinsicSerializationType Method
DeclarationCache Class See Also Send Feedback
Gets an IntrinsicSerializationType, given an IntrinsicType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicSerializationType GetIntrinsicSerializationType(
    IntrinsicType intrinsic
)

Parameters

intrinsic
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
An intrinsic.

Return Value

The IntrinsicSerializationType corresponding to intrinsic.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetItem(T) Method

DeclarationCache..::..GetItem<(Of <(<'T>)>)> Method
DeclarationCache Class See Also Send Feedback
Gets a declaration served by a provider.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public T GetItem<T>(
    Func<T> getter
)

Parameters

getter
Type: System..::.Func <(Of <(<'T>)>)>
Method providing the cached item

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PostSharp.Sdk.CodeModel.DeclarationCache.GetItem``1(System.Func{``0})"]

Return Value

The cached item.

Remarks

The getter parameter is used both as the item key (identification of the requested item) and in order to get the value in case it is not yet in cache. The item cache is not strictly the passed delegate, but only its method, i.e. the object instance is ignored.

See Also

DeclarationCache Class
PostSharp.Sdk.CodeModel Namespace


GetType Method

[image]

PostSharp 2.0 Documentation
DeclarationCache..::..GetType Method
DeclarationCache Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetType(String) | Gets a type (ITypeSignature) given its name.
Public method | GetType(Type) | Gets a type (ITypeSignature) given a reflection type (Type), with default binding options.
Public method | GetType(Type, BindingOptions) | Gets a type (ITypeSignature) given a reflection type (Type), but specifies BindingOptions.

See Also

DeclarationCache Class
DeclarationCache Members
PostSharp.Sdk.CodeModel Namespace


GetType Method (String)

DeclarationCache..::..GetType Method (String)
DeclarationCache Class See Also Send Feedback
Gets a type (ITypeSignature) given its name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetType(
    string typeName
)

Parameters

typeName
Type: System..::.String
The reflection type.

Return Value

An ITypeSignature.

See Also

DeclarationCache Class
GetType Overload
PostSharp.Sdk.CodeModel Namespace


GetType Method (Type)

DeclarationCache..::..GetType Method (Type)
DeclarationCache Class See Also Send Feedback
Gets a type (ITypeSignature) given a reflection type (Type), with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetType(
    Type type
)

Parameters

type
Type: System..::.Type
The reflection type.

Return Value

An ITypeSignature.

Remarks

You are required to use the second overload and to specify BindingOptions when you require a generic type.

If type is a primitive type, the method returns the class representing it, i.e. it does not return the intrinsic type. Intrinsic type substitution is allowed for type constructions.

See Also

DeclarationCache Class
GetType Overload
PostSharp.Sdk.CodeModel Namespace


GetType Method (Type, BindingOptions)

DeclarationCache..::..GetType Method (Type, BindingOptions)
DeclarationCache Class See Also Send Feedback
Gets a type (ITypeSignature) given a reflection type (Type), but specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetType(
    Type type,
    BindingOptions bindingOptions
)

Parameters

type
Type: System..::.Type
The reflection type.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options. Specify RequireGenericInstance or RequireGenericDefinition when requesting a generic type.

Return Value

An ITypeSignature.

Remarks

If type is a primitive type, the method returns the class representing it, i.e. it does not return the intrinsic type. Intrinsic type substitution is allowed for type constructions.

See Also

DeclarationCache Class
GetType Overload
PostSharp.Sdk.CodeModel Namespace


Domain Class

Domain Class
Members See Also Send Feedback
A domain is a scope, i.e. a context in which external references are resolved. A domain contains assemblies.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class Domain : Element,
    IDisposable, ITaggable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Domain

See Also

Domain Members
PostSharp.Sdk.CodeModel Namespace


Domain Members

[image]

PostSharp 2.0 Documentation
Domain Members
Domain Class Constructors Methods Properties Events See Also Send Feedback

The Domain type exposes the following members.

Constructors

 | Name | Description
Public method | Domain | Overloaded.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | FindTypeDefinition | Overloaded.
Public method | GetAssembly | Overloaded.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | IsAssemblyLoaded | Determines whether an assembly (given the reflection Assembly) has already been loaded in the current Domain.
Public method | LoadAssembly | Overloaded.
Public method | SetTag | Set a tag to the current declaration.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Assemblies | Gets the collection of assemblies loaded in the domain.
Public property | AssemblyBindingPolicyManager | Gets the AssemblyBindingPolicyManager for the current domain.
Public property | AssemblyLocator | The AssemblyLocator for the current Domain.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Guid | Gets the GUID of this domain.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ReflectionAssemblyBindingPolicyManager | Gets the AssemblyBindingPolicyManager used to map reflection types to declarations.
Public property | ReflectionDisabled | Determines whether assemblies of the current Domain are loaded into the CLR.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

Events

 | Name | Description
Public event | AssemblyLoading | Event raised when an assembly is requested to be loaded in the assembly. Event clients can specify whether the assembly should be loaded lazily or not.

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Domain Constructor

[image]

PostSharp 2.0 Documentation
Domain Constructor
Domain Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Domain()()() | Initializes a new Domain.
Public method | Domain(Boolean) | Initializes a new Domain and specifies whether assemblies are allowed to be loaded into the CLR.

See Also

Domain Class
Domain Members
PostSharp.Sdk.CodeModel Namespace


Domain Constructor

Domain Constructor
Domain Class See Also Send Feedback
Initializes a new Domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Domain()

See Also

Domain Class
Domain Overload
PostSharp.Sdk.CodeModel Namespace


Domain Constructor (Boolean)

Domain Constructor (Boolean)
Domain Class See Also Send Feedback
Initializes a new Domain and specifies whether assemblies are allowed to be loaded into the CLR.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Domain(
    bool disableReflection
)

Parameters

disableReflection
Type: System..::.Boolean
true if assemblies are loaded in the CLR, otherwise false.

See Also

Domain Class
Domain Overload
PostSharp.Sdk.CodeModel Namespace


Domain Methods

[image]

PostSharp 2.0 Documentation
Domain Methods
Domain Class See Also Send Feedback

The Domain type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | FindTypeDefinition | Overloaded.
Public method | GetAssembly | Overloaded.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | IsAssemblyLoaded | Determines whether an assembly (given the reflection Assembly) has already been loaded in the current Domain.
Public method | LoadAssembly | Overloaded.
Public method | SetTag | Set a tag to the current declaration.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

Domain..::..Dispose Method
Domain Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


FindTypeDefinition Method

[image]

PostSharp 2.0 Documentation
Domain..::..FindTypeDefinition Method
Domain Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindTypeDefinition(String) | Find the TypeDefDeclaration of a type given its name in the current Domain with default binding options.
Public method | FindTypeDefinition(Type) | Find the TypeDefDeclaration of a given Type in the current Domain with default binding options.
Public method | FindTypeDefinition(String, BindingOptions) | Find the TypeDefDeclaration of a type given its name in the current Domain and specifies binding options.
Public method | FindTypeDefinition(Type, BindingOptions) | Find the TypeDefDeclaration of a given Type in the current Domain and specifies binding options.

See Also

Domain Class
Domain Members
PostSharp.Sdk.CodeModel Namespace


FindTypeDefinition Method (String)

Domain..::..FindTypeDefinition Method (String)
Domain Class See Also Send Feedback
Find the TypeDefDeclaration of a type given its name in the current Domain with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration FindTypeDefinition(
    string assemblyQualifiedTypeName
)

Parameters

assemblyQualifiedTypeName
Type: System..::.String
Assembly-qualified name of the type to be found.

Return Value

The TypeDefDeclaration corresponding to assemblyQualifiedTypeName.

See Also

Domain Class
FindTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


FindTypeDefinition Method (Type)

Domain..::..FindTypeDefinition Method (Type)
Domain Class See Also Send Feedback
Find the TypeDefDeclaration of a given Type in the current Domain with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration FindTypeDefinition(
    Type type
)

Parameters

type
Type: System..::.Type
The Type whose definition is requested.

Return Value

The TypeDefDeclaration corresponding to type.

See Also

Domain Class
FindTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


FindTypeDefinition Method (String, BindingOptions)

Domain..::..FindTypeDefinition Method (String, BindingOptions)
Domain Class See Also Send Feedback
Find the TypeDefDeclaration of a type given its name in the current Domain and specifies binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration FindTypeDefinition(
    string assemblyQualifiedTypeName,
    BindingOptions bindingOptions
)

Parameters

assemblyQualifiedTypeName
Type: System..::.String
Assembly-qualified name of the type to be found.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to assemblyQualifiedTypeName.

See Also

Domain Class
FindTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


FindTypeDefinition Method (Type, BindingOptions)

Domain..::..FindTypeDefinition Method (Type, BindingOptions)
Domain Class See Also Send Feedback
Find the TypeDefDeclaration of a given Type in the current Domain and specifies binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration FindTypeDefinition(
    Type type,
    BindingOptions bindingOptions
)

Parameters

type
Type: System..::.Type
The Type whose definition is requested.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to type.

See Also

Domain Class
FindTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method

[image]

PostSharp 2.0 Documentation
Domain..::..GetAssembly Method
Domain Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAssembly(Assembly) | Gets the AssemblyEnvelope of the current Domain corresponding to a given Assembly, but does not load the assembly into the domain if it is not found.
Public method | GetAssembly(String) | Gets an assembly given its name with default binding options.
Public method | GetAssembly(IAssemblyName) | Gets an assembly from the current domain given its name or loads it into the domain if not yet present, with default binding options.
Public method | GetAssembly(String, BindingOptions) | Gets an assembly given its name and specifies binding options.
Public method | GetAssembly(IAssemblyName, BindingOptions) | Gets an assembly from the current domain given its name or loads it into the domain if not yet present, and specifies binding options.

See Also

Domain Class
Domain Members
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method (Assembly)

Domain..::..GetAssembly Method (Assembly)
Domain Class See Also Send Feedback
Gets the AssemblyEnvelope of the current Domain corresponding to a given Assembly, but does not load the assembly into the domain if it is not found.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssembly(
    Assembly reflectionAssembly
)

Parameters

reflectionAssembly
Type: System.Reflection..::.Assembly
The Assembly to be located.

Return Value

The AssemblyEnvelope corresponding to reflectionAssembly, or null if the current Domain does not contain reflectionAssembly.

See Also

Domain Class
GetAssembly Overload
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method (String)

Domain..::..GetAssembly Method (String)
Domain Class See Also Send Feedback
Gets an assembly given its name with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssembly(
    string assemblyName
)

Parameters

assemblyName
Type: System..::.String
Assembly name.

Return Value

The assembly named assemblyName.

See Also

Domain Class
GetAssembly Overload
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method (IAssemblyName)

Domain..::..GetAssembly Method (IAssemblyName)
Domain Class See Also Send Feedback
Gets an assembly from the current domain given its name or loads it into the domain if not yet present, with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssembly(
    IAssemblyName assemblyName
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Name of the assembly to load.

Return Value

The AssemblyEnvelope corresponding to assemblyName.

See Also

Domain Class
GetAssembly Overload
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method (String, BindingOptions)

Domain..::..GetAssembly Method (String, BindingOptions)
Domain Class See Also Send Feedback
Gets an assembly given its name and specifies binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssembly(
    string assemblyName,
    BindingOptions bindingOptions
)

Parameters

assemblyName
Type: System..::.String
Assembly name.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The assembly named assemblyName.

See Also

Domain Class
GetAssembly Overload
PostSharp.Sdk.CodeModel Namespace


GetAssembly Method (IAssemblyName, BindingOptions)

Domain..::..GetAssembly Method (IAssemblyName, BindingOptions)
Domain Class See Also Send Feedback
Gets an assembly from the current domain given its name or loads it into the domain if not yet present, and specifies binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope GetAssembly(
    IAssemblyName assemblyName,
    BindingOptions bindingOptions
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
Name of the assembly to load.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The AssemblyEnvelope corresponding to assemblyName.

See Also

Domain Class
GetAssembly Overload
PostSharp.Sdk.CodeModel Namespace


GetTag Method

Domain..::..GetTag Method
Domain Class See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

Implements

ITaggable..::.GetTag(TagId)

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


IsAssemblyLoaded Method

Domain..::..IsAssemblyLoaded Method
Domain Class See Also Send Feedback
Determines whether an assembly (given the reflection Assembly) has already been loaded in the current Domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssemblyLoaded(
    Assembly reflectionAssembly
)

Parameters

reflectionAssembly
Type: System.Reflection..::.Assembly
The Assembly whose presence in the current Domain should be determined.

Return Value

true if reflectionAssembly has already, otherwise false.

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


LoadAssembly Method

[image]

PostSharp 2.0 Documentation
Domain..::..LoadAssembly Method
Domain Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadAssembly(Assembly) | Loads an assembly into the current domain (without lazy loaded).
Public method | LoadAssembly(Assembly, Boolean) | Loads an assembly (given as an Assembly) into the current domain and specifies whether the assembly should be lazily loaded or not.
Public method | LoadAssembly(String, Boolean) | Loads an assembly (given by file name) into the current domain and specifies whether the assembly should be lazily loaded or not.

See Also

Domain Class
Domain Members
PostSharp.Sdk.CodeModel Namespace


LoadAssembly Method (Assembly)

Domain..::..LoadAssembly Method (Assembly)
Domain Class See Also Send Feedback
Loads an assembly into the current domain (without lazy loaded).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope LoadAssembly(
    Assembly reflectionAssembly
)

Parameters

reflectionAssembly
Type: System.Reflection..::.Assembly
A reflection Assembly.

Return Value

The AssemblyEnvelope representing the loaded assembly.

See Also

Domain Class
LoadAssembly Overload
PostSharp.Sdk.CodeModel Namespace


LoadAssembly Method (Assembly, Boolean)

Domain..::..LoadAssembly Method (Assembly, Boolean)
Domain Class See Also Send Feedback
Loads an assembly (given as an Assembly) into the current domain and specifies whether the assembly should be lazily loaded or not.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope LoadAssembly(
    Assembly reflectionAssembly,
    bool lazyLoading
)

Parameters

reflectionAssembly
Type: System.Reflection..::.Assembly
A reflection Assembly.
lazyLoading
Type: System..::.Boolean
Whether the assembly should be lazily loaded.

Return Value

The AssemblyEnvelope representing the loaded assembly.

Remarks

Typically, the principal assembly is loaded completely at first time and referenced assemblies are loaded lazily.

See Also

Domain Class
LoadAssembly Overload
PostSharp.Sdk.CodeModel Namespace


LoadAssembly Method (String, Boolean)

Domain..::..LoadAssembly Method (String, Boolean)
Domain Class See Also Send Feedback
Loads an assembly (given by file name) into the current domain and specifies whether the assembly should be lazily loaded or not.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope LoadAssembly(
    string assemblyLocation,
    bool lazyLoading
)

Parameters

assemblyLocation
Type: System..::.String
Full path of the physical location of the assembly to be loaded.
lazyLoading
Type: System..::.Boolean
Whether the assembly should be lazily loaded.

Return Value

The AssemblyEnvelope representing the loaded assembly.

Remarks

Typically, the principal assembly is loaded completely at first time and referenced assemblies are loaded lazily.

See Also

Domain Class
LoadAssembly Overload
PostSharp.Sdk.CodeModel Namespace


SetTag Method

Domain..::..SetTag Method
Domain Class See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

Implements

ITaggable..::.SetTag(TagId, Object)

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

Domain..::..ToString Method
Domain Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Domain Properties

[image]

PostSharp 2.0 Documentation
Domain Properties
Domain Class See Also Send Feedback

The Domain type exposes the following members.

Properties

 | Name | Description
Public property | Assemblies | Gets the collection of assemblies loaded in the domain.
Public property | AssemblyBindingPolicyManager | Gets the AssemblyBindingPolicyManager for the current domain.
Public property | AssemblyLocator | The AssemblyLocator for the current Domain.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Guid | Gets the GUID of this domain.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ReflectionAssemblyBindingPolicyManager | Gets the AssemblyBindingPolicyManager used to map reflection types to declarations.
Public property | ReflectionDisabled | Determines whether assemblies of the current Domain are loaded into the CLR.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Assemblies Property

Domain..::..Assemblies Property
Domain Class See Also Send Feedback
Gets the collection of assemblies loaded in the domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelopeCollection Assemblies { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


AssemblyBindingPolicyManager Property

Domain..::..AssemblyBindingPolicyManager Property
Domain Class See Also Send Feedback
Gets the AssemblyBindingPolicyManager for the current domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingPolicyManager AssemblyBindingPolicyManager { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLocator Property

Domain..::..AssemblyLocator Property
Domain Class See Also Send Feedback
The AssemblyLocator for the current Domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyLocator AssemblyLocator { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Guid Property

Domain..::..Guid Property
Domain Class See Also Send Feedback
Gets the GUID of this domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Guid Guid { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


ReflectionAssemblyBindingPolicyManager Property

Domain..::..ReflectionAssemblyBindingPolicyManager Property
Domain Class See Also Send Feedback
Gets the AssemblyBindingPolicyManager used to map reflection types to declarations.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingPolicyManager ReflectionAssemblyBindingPolicyManager { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


ReflectionDisabled Property

Domain..::..ReflectionDisabled Property
Domain Class See Also Send Feedback
Determines whether assemblies of the current Domain are loaded into the CLR.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ReflectionDisabled { get; }

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Domain Events

[image]

PostSharp 2.0 Documentation
Domain Events
Domain Class See Also Send Feedback

The Domain type exposes the following members.

Events

 | Name | Description
Public event | AssemblyLoading | Event raised when an assembly is requested to be loaded in the assembly. Event clients can specify whether the assembly should be loaded lazily or not.

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


AssemblyLoading Event

Domain..::..AssemblyLoading Event
Domain Class See Also Send Feedback
Event raised when an assembly is requested to be loaded in the assembly. Event clients can specify whether the assembly should be loaded lazily or not.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<AssemblyLoadingEventArgs> AssemblyLoading

See Also

Domain Class
PostSharp.Sdk.CodeModel Namespace


Element Class

Element Class
Members See Also Send Feedback
Represents an element of a tree structure.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Element

Remarks

The CLI module is basically represented as a tree of objects what are called Declaration in PostSharp. The root of the module tree is the ModuleDeclaration. Modules are contained in assemblies (AssemblyEnvelope) and assemblies are bounded in the scope of a specified Domain.

All elements that are a part of a Domain are represented by the Element type. This class is basically a tree node. Element instances have two properties: Parent gives the direct parent, and Domain gives the root Domain.

The child-parent relationship is managed automatically when the child is related to the parent either adding it into a collection of children, either setting it as the value of a property of the parent.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.AssemblyEnvelope
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.Domain
PostSharp.Sdk.CodeModel..::.InstructionBlock

See Also

Element Members
PostSharp.Sdk.CodeModel Namespace


Element Members

[image]

PostSharp 2.0 Documentation
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed.
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed.

Properties

 | Name | Description
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration.
Public property | Parent | Gets the parent Element.
Public property | Role | Gets the role of the current Element in its parent.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


Element Methods

[image]

PostSharp 2.0 Documentation
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed.
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

Element..::..ClearCache Method
Element Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void ClearCache()

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


NotifyChildPropertyChanged Method

Element..::..NotifyChildPropertyChanged Method
Element Class See Also Send Feedback
Method invoked when a property of a child has been changed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual bool NotifyChildPropertyChanged(
    Element child,
    string property,
    Object oldValue,
    Object newValue
)

Parameters

child
Type: PostSharp.Sdk.CodeModel..::.Element
Child object that has been changed.
property
Type: System..::.String
Name of the changed property.
oldValue
Type: System..::.Object
Old value of the property.
newValue
Type: System..::.Object
New value of the property.

Return Value

true if the notification was processed by the current method, otherwise false.

Remarks

Implementations of this method should first call the base implementation; if the base implementation returns true, the notification has been processed, so the current implementation can return immediately true.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


OnPropertyChanged Method

Element..::..OnPropertyChanged Method
Element Class See Also Send Feedback
Method invoked when a property of the current instance has been changed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void OnPropertyChanged(
    string property,
    Object oldValue,
    Object newValue
)

Parameters

property
Type: System..::.String
Name of the changed property.
oldValue
Type: System..::.Object
Old value of the property.
newValue
Type: System..::.Object
New value of the property.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


Element Properties

[image]

PostSharp 2.0 Documentation
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration.
Public property | Parent | Gets the parent Element.
Public property | Role | Gets the role of the current Element in its parent.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


Domain Property

Element..::..Domain Property
Element Class See Also Send Feedback
Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Domain Domain { get; }

Remarks

This property is implemented recursively on the Parent property. Since the cost may be non-trivial for some declaration, consider caching its result where appropriate.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

Element..::..Parent Property
Element Class See Also Send Feedback
Gets the parent Element.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Element Parent { get; internal set; }

Field Value

A Element, or null if the current element is a Domain or is a stand-alone (detached) declaration.

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


Role Property

Element..::..Role Property
Element Class See Also Send Feedback
Gets the role of the current Element in its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Role { get; }

Remarks

This property allows the parent to determine to which collection a child belong, and take appropriate actions in case of notification (as NotifyChildPropertyChanged(Element, String, Object, Object)).

See Also

Element Class
PostSharp.Sdk.CodeModel Namespace


EventDeclaration Class

EventDeclaration Class
Members See Also Send Feedback
Represents an event (Event).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EventDeclaration : MethodGroupDeclaration,
    IRemovable, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable, IWriteReflectionName

Remarks

Events are owned by types (TypeDefDeclaration) and are exposed on the Events property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodGroupDeclaration
PostSharp.Sdk.CodeModel..::.EventDeclaration

See Also

EventDeclaration Members
PostSharp.Sdk.CodeModel Namespace


EventDeclaration Members

[image]

PostSharp 2.0 Documentation
EventDeclaration Members
EventDeclaration Class Constructors Methods Properties See Also Send Feedback

The EventDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | EventDeclaration | Initializes a new instance of the EventDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method. (Inherited from MethodGroupDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection EventInfo that wraps the current event.
Public method | GetSystemEvent | Gets the system runtime event corresponding to the current event.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the event attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration. (Inherited from MethodGroupDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | EventType | Gets or sets the type of the event handler.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from MethodGroupDeclaration.)
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property. (Inherited from MethodGroupDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current element. (Inherited from MethodGroupDeclaration.)

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EventDeclaration Constructor

EventDeclaration Constructor
EventDeclaration Class See Also Send Feedback
Initializes a new instance of the EventDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventDeclaration()

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EventDeclaration Methods

[image]

PostSharp 2.0 Documentation
EventDeclaration Methods
EventDeclaration Class See Also Send Feedback

The EventDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method. (Inherited from MethodGroupDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection EventInfo that wraps the current event.
Public method | GetSystemEvent | Gets the system runtime event corresponding to the current event.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

EventDeclaration..::..ClearCache Method
EventDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

EventDeclaration..::..GetReflectionWrapper Method
EventDeclaration Class See Also Send Feedback
Gets a reflection EventInfo that wraps the current event.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A EventInfo wrapping current event in the given generic context.

Remarks

This method returns a EventInfo that is different from the system runtime event that is retrieved by GetSystemEvent(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current event even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemEvent Method

EventDeclaration..::..GetSystemEvent Method
EventDeclaration Class See Also Send Feedback
Gets the system runtime event corresponding to the current event.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventInfo GetSystemEvent(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime EventInfo, or null if the current event could not be bound.

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

EventDeclaration..::..GetTokenType Method
EventDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

EventDeclaration..::..Remove Method
EventDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

EventDeclaration..::..WriteReflectionName Method
EventDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EventDeclaration Properties

[image]

PostSharp 2.0 Documentation
EventDeclaration Properties
EventDeclaration Class See Also Send Feedback

The EventDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the event attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration. (Inherited from MethodGroupDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | EventType | Gets or sets the type of the event handler.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from MethodGroupDeclaration.)
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property. (Inherited from MethodGroupDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current element. (Inherited from MethodGroupDeclaration.)

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

EventDeclaration..::..Attributes Property
EventDeclaration Class See Also Send Feedback
Gets or sets the event attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventAttributes Attributes { get; set; }

Field Value

A combination of EventAttributes.

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EventType Property

EventDeclaration..::..EventType Property
EventDeclaration Class See Also Send Feedback
Gets or sets the type of the event handler.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature EventType { get; set; }

Field Value

A delegate type.

See Also

EventDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExceptionHandler Class

ExceptionHandler Class
Members See Also Send Feedback
Represents an exception handler.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExceptionHandler : Declaration

Remarks

An ExceptionHandler is contained in an InstructionBlock, which is the protected block (i.e. the try block).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.ExceptionHandler

See Also

ExceptionHandler Members
PostSharp.Sdk.CodeModel Namespace


ExceptionHandler Members

[image]

PostSharp 2.0 Documentation
ExceptionHandler Members
ExceptionHandler Class Methods Properties See Also Send Feedback

The ExceptionHandler type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | CatchType | Gets or sets the catch type.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FilterBlock | Gets the filter block.
Public property | HandlerBlock | Gets the handler block.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | NextSiblingExceptionHandler | Gets the next exception handler of the parent block.
Public property | Options | Gets or sets the kind of exception handling clause.
Public property | Parent | Gets the parent try block.
Public property | PreviousSiblingExceptionHandler | Gets the previous exception handler of the parent block.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


ExceptionHandler Methods

[image]

PostSharp 2.0 Documentation
ExceptionHandler Methods
ExceptionHandler Class See Also Send Feedback

The ExceptionHandler type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

ExceptionHandler..::..ToString Method
ExceptionHandler Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


ExceptionHandler Properties

[image]

PostSharp 2.0 Documentation
ExceptionHandler Properties
ExceptionHandler Class See Also Send Feedback

The ExceptionHandler type exposes the following members.

Properties

 | Name | Description
Public property | CatchType | Gets or sets the catch type.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FilterBlock | Gets the filter block.
Public property | HandlerBlock | Gets the handler block.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | NextSiblingExceptionHandler | Gets the next exception handler of the parent block.
Public property | Options | Gets or sets the kind of exception handling clause.
Public property | Parent | Gets the parent try block.
Public property | PreviousSiblingExceptionHandler | Gets the previous exception handler of the parent block.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


CatchType Property

ExceptionHandler..::..CatchType Property
ExceptionHandler Class See Also Send Feedback
Gets or sets the catch type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature CatchType { get; set; }

Field Value

A reference to an IType, or null if the handler type is not Clause.

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


FilterBlock Property

ExceptionHandler..::..FilterBlock Property
ExceptionHandler Class See Also Send Feedback
Gets the filter block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock FilterBlock { get; }

Field Value

An InstructionBlock, or null if the handler kind is not Filter.

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


HandlerBlock Property

ExceptionHandler..::..HandlerBlock Property
ExceptionHandler Class See Also Send Feedback
Gets the handler block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock HandlerBlock { get; }

Field Value

An InstructionBlock.

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


NextSiblingExceptionHandler Property

ExceptionHandler..::..NextSiblingExceptionHandler Property
ExceptionHandler Class See Also Send Feedback
Gets the next exception handler of the parent block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler NextSiblingExceptionHandler { get; }

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


Options Property

ExceptionHandler..::..Options Property
ExceptionHandler Class See Also Send Feedback
Gets or sets the kind of exception handling clause.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandlingClauseOptions Options { get; set; }

Remarks

You have to set the properties CatchType, and FilterBlock according to the kind of exception handler. This rule is not enforced.

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

ExceptionHandler..::..Parent Property
ExceptionHandler Class See Also Send Feedback
Gets the parent try block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock Parent { get; }

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


PreviousSiblingExceptionHandler Property

ExceptionHandler..::..PreviousSiblingExceptionHandler Property
ExceptionHandler Class See Also Send Feedback
Gets the previous exception handler of the parent block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler PreviousSiblingExceptionHandler { get; }

See Also

ExceptionHandler Class
PostSharp.Sdk.CodeModel Namespace


ExportedTypeDeclaration Class

ExportedTypeDeclaration Class
Members See Also Send Feedback
Represents a type exported by the current assembly but not defined in the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExportedTypeDeclaration : NamedMetadataDeclaration,
    IManifestResourceImplementation

Remarks

Exported types are owned by the assembly manifest (AssemblyManifestDeclaration.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ExportedTypeDeclaration

See Also

ExportedTypeDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ExportedTypeDeclaration Members

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclaration Members
ExportedTypeDeclaration Class Constructors Methods Properties See Also Send Feedback

The ExportedTypeDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ExportedTypeDeclaration | Initializes a new instance of the ExportedTypeDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringExportedType | Gets the parent exported type, if the current type is a nested one.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Implementation | Gets or sets the external class or the external file implementing this type.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeDefId | Gets or sets the identifier of the type definition.

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExportedTypeDeclaration Constructor

ExportedTypeDeclaration Constructor
ExportedTypeDeclaration Class See Also Send Feedback
Initializes a new instance of the ExportedTypeDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExportedTypeDeclaration()

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExportedTypeDeclaration Methods

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclaration Methods
ExportedTypeDeclaration Class See Also Send Feedback

The ExportedTypeDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ExportedTypeDeclaration..::..GetTokenType Method
ExportedTypeDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExportedTypeDeclaration Properties

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclaration Properties
ExportedTypeDeclaration Class See Also Send Feedback

The ExportedTypeDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringExportedType | Gets the parent exported type, if the current type is a nested one.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Implementation | Gets or sets the external class or the external file implementing this type.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeDefId | Gets or sets the identifier of the type definition.

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

ExportedTypeDeclaration..::..Attributes Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets or sets the type attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeAttributes Attributes { get; set; }

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringExportedType Property

ExportedTypeDeclaration..::..DeclaringExportedType Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets the parent exported type, if the current type is a nested one.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExportedTypeDeclaration DeclaringExportedType { get; }

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Implementation Property

ExportedTypeDeclaration..::..Implementation Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets or sets the external class or the external file implementing this type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IManifestResourceImplementation Implementation { get; set; }

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ExportedTypeDeclaration..::..ParentMember Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ExportedTypeDeclaration..::..ParentType Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeDefId Property

ExportedTypeDeclaration..::..TypeDefId Property
ExportedTypeDeclaration Class See Also Send Feedback
Gets or sets the identifier of the type definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long TypeDefId { get; set; }

See Also

ExportedTypeDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Class

FieldDefDeclaration Class
Members See Also Send Feedback
Represents a field definition (FieldDef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FieldDefDeclaration : NamedPositionedMetadataDeclaration,
    IField, IMember, IRemovable, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable, IWriteReflectionName

Remarks

Fields are owned by a types (TypeDefDeclaration) on the Fields property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedPositionedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.FieldDefDeclaration

See Also

FieldDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Members

[image]

PostSharp 2.0 Documentation
FieldDefDeclaration Members
FieldDefDeclaration Class Constructors Methods Fields Properties See Also Send Feedback

The FieldDefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDefDeclaration | Initializes a new instance of the FieldDefDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetGenericContext | Gets the generic context of the declaring type.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a field. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Overloaded. Determines whether a field is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Fields

Name | Description
AutoOffset | When applied to the Offset value, indicates that the offset is determined by the runtime automatically.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the type declaring the current field.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldType | Gets or set the field type.
Public property | InitialValue | Gets or sets the DataSectionDeclaration used to initialize the field.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static.
Public property | LiteralValue | Gets the value of the literal field.
Public property | MarshalType | Gets or sets the MarshalType of the field.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Offset | Gets or sets the offset of the current field in the type layout.
Public property | Ordinal | Position of the current item in its parent collection. (Inherited from NamedPositionedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the field visibility.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Constructor

FieldDefDeclaration Constructor
FieldDefDeclaration Class See Also Send Feedback
Initializes a new instance of the FieldDefDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration()

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Fields

[image]

PostSharp 2.0 Documentation
FieldDefDeclaration Fields
FieldDefDeclaration Class See Also Send Feedback

The FieldDefDeclaration type exposes the following members.

Fields

Name | Description
AutoOffset | When applied to the Offset value, indicates that the offset is determined by the runtime automatically.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AutoOffset Field

FieldDefDeclaration..::..AutoOffset Field
FieldDefDeclaration Class See Also Send Feedback
When applied to the Offset value, indicates that the offset is determined by the runtime automatically.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int AutoOffset

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Methods

[image]

PostSharp 2.0 Documentation
FieldDefDeclaration Methods
FieldDefDeclaration Class See Also Send Feedback

The FieldDefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetGenericContext | Gets the generic context of the declaring type.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a field. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Overloaded. Determines whether a field is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

FieldDefDeclaration..::..GetGenericContext Method
FieldDefDeclaration Class See Also Send Feedback
Gets the generic context of the declaring type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.FieldDefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

The generic context of the declaring type, or an empty context if the current field is declared at module level.

Implements

IField..::.GetGenericContext(GenericContextOptions)

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

FieldDefDeclaration..::..GetGenericInstance Method
FieldDefDeclaration Class See Also Send Feedback
Gets a generic instance of the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current field constructed using genericMap for generic arguments.

Implements

IField..::.GetGenericInstance(GenericMap)

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

FieldDefDeclaration..::..GetReflectionWrapper Method
FieldDefDeclaration Class See Also Send Feedback
Gets a reflection FieldInfo that wraps the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A FieldInfo wrapping current field in the given generic context.

Implements

IField..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a FieldInfo that is different from the system runtime field that is retrieved by GetSystemField(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current field even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemField Method

FieldDefDeclaration..::..GetSystemField Method
FieldDefDeclaration Class See Also Send Feedback
Gets the system runtime field corresponding to the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo GetSystemField(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime FieldInfo, or null if the current field could not be bound.

Implements

IField..::.GetSystemField(array<Type>[]()[], array<Type>[]()[])

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

FieldDefDeclaration..::..GetTokenType Method
FieldDefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

FieldDefDeclaration..::..Remove Method
FieldDefDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

FieldDefDeclaration..::..ToString Method
FieldDefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

FieldDefDeclaration..::..Translate Method
FieldDefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.FieldDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.FieldDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.FieldDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

FieldDefDeclaration..::..WriteReflectionName Method
FieldDefDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldDefDeclaration Properties

[image]

PostSharp 2.0 Documentation
FieldDefDeclaration Properties
FieldDefDeclaration Class See Also Send Feedback

The FieldDefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the type declaring the current field.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldType | Gets or set the field type.
Public property | InitialValue | Gets or sets the DataSectionDeclaration used to initialize the field.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static.
Public property | LiteralValue | Gets the value of the literal field.
Public property | MarshalType | Gets or sets the MarshalType of the field.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Offset | Gets or sets the offset of the current field in the type layout.
Public property | Ordinal | Position of the current item in its parent collection. (Inherited from NamedPositionedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the field visibility.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

FieldDefDeclaration..::..Attributes Property
FieldDefDeclaration Class See Also Send Feedback
Gets or sets the field attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldAttributes Attributes { get; set; }

Field Value

A combination of FieldAttributes.

Implements

IField..::.Attributes

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

FieldDefDeclaration..::..DeclaringType Property
FieldDefDeclaration Class See Also Send Feedback
Gets the type declaring the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration DeclaringType { get; }

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldType Property

FieldDefDeclaration..::..FieldType Property
FieldDefDeclaration Class See Also Send Feedback
Gets or set the field type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FieldType { get; set; }

Field Value

A TypeSignature.

Implements

IField..::.FieldType

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InitialValue Property

FieldDefDeclaration..::..InitialValue Property
FieldDefDeclaration Class See Also Send Feedback
Gets or sets the DataSectionDeclaration used to initialize the field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DataSectionDeclaration InitialValue { get; set; }

Field Value

A DataSectionDeclaration, or null if the field should be initialized with its default (zero) value.

Remarks

This field should be set if and only if the field Attributes includes HasFieldRVA. Some rules apply to initialized fields. They are not enforced by the Code Object Model.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsConst Property

FieldDefDeclaration..::..IsConst Property
FieldDefDeclaration Class See Also Send Feedback
Determines whether the field is constant (i.e. literal).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsConst { get; }

Implements

IField..::.IsConst

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsReadOnly Property

FieldDefDeclaration..::..IsReadOnly Property
FieldDefDeclaration Class See Also Send Feedback
Determines whether the field is read-only (i.e. init only).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Implements

IField..::.IsReadOnly

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

FieldDefDeclaration..::..IsStatic Property
FieldDefDeclaration Class See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LiteralValue Property

FieldDefDeclaration..::..LiteralValue Property
FieldDefDeclaration Class See Also Send Feedback
Gets the value of the literal field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue LiteralValue { get; set; }

Field Value

A SerializedValue, or null if the field is not literal.

Remarks

The value of the current property determines the value of a literal field, i.e. a field whose Attributes includes Literal. Some rules apply to literal fields. They are not enforced by the Code Object Model.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MarshalType Property

FieldDefDeclaration..::..MarshalType Property
FieldDefDeclaration Class See Also Send Feedback
Gets or sets the MarshalType of the field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalType MarshalType { get; set; }

Field Value

A MarshalType, or null if default marshaling should be performed.

Remarks

This field should be set if and only if the field Attributes includes HasFieldMarshal. This rule is not enforced by the Code Object Model.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Offset Property

FieldDefDeclaration..::..Offset Property
FieldDefDeclaration Class See Also Send Feedback
Gets or sets the offset of the current field in the type layout.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Offset { get; set; }

Field Value

The offset of the current field in the type layout, or AutoOffset if the field offset is computed by the runtime.

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

FieldDefDeclaration..::..ParentMember Property
FieldDefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

FieldDefDeclaration..::..ParentType Property
FieldDefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

FieldDefDeclaration..::..Visibility Property
FieldDefDeclaration Class See Also Send Feedback
Gets the field visibility.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

FieldDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefDeclaration Class

FieldRefDeclaration Class
Members See Also Send Feedback
Represents a reference to a field of a type defined in an external assembly (MemberRef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FieldRefDeclaration : MemberRefDeclaration,
    IField, IMember, IMetadataDeclaration, IDeclaration, IElement,
    IModuleElement, ITaggable

Remarks

Field references are owned by type references (TypeRefDeclaration) on the FieldRefs property, or by type specifications (TypeSpecDeclaration) on the FieldRefs property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MemberRefDeclaration
PostSharp.Sdk.CodeModel..::.FieldRefDeclaration

See Also

FieldRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FieldRefDeclaration Members

[image]

PostSharp 2.0 Documentation
FieldRefDeclaration Members
FieldRefDeclaration Class Constructors Methods Properties See Also Send Feedback

The FieldRefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | FieldRefDeclaration | Initializes a new instance of the FieldRefDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetFieldDefinition | Overloaded.
Public method | GetGenericContext | Gets the generic context of the declaring type, or an empty context if the member is contained by the module.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MemberRefDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Inherited from MemberRefDeclaration.)
Public property | DeclaringType | Gets the declaring IType. (Inherited from MemberRefDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldType | Gets or sets the type of the referenced field.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved. (Inherited from MemberRefDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefDeclaration Constructor

FieldRefDeclaration Constructor
FieldRefDeclaration Class See Also Send Feedback
Initializes a new instance of the FieldRefDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldRefDeclaration()

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
FieldRefDeclaration Methods
FieldRefDeclaration Class See Also Send Feedback

The FieldRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetFieldDefinition | Overloaded.
Public method | GetGenericContext | Gets the generic context of the declaring type, or an empty context if the member is contained by the module.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MemberRefDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

FieldRefDeclaration..::..ClearCache Method
FieldRefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method

[image]

PostSharp 2.0 Documentation
FieldRefDeclaration..::..GetFieldDefinition Method
FieldRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldDefinition()()() | Finds in the current domain the FieldDefDeclaration corresponding to the current field with default BindingOptions.
Public method | GetFieldDefinition(BindingOptions) | Finds in the current domain the FieldDefDeclaration corresponding to the current field and specifies BindingOptions.

See Also

FieldRefDeclaration Class
FieldRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method

FieldRefDeclaration..::..GetFieldDefinition Method
FieldRefDeclaration Class See Also Send Feedback
Finds in the current domain the FieldDefDeclaration corresponding to the current field with default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration GetFieldDefinition()

Return Value

The FieldDefDeclaration corresponding to the current instance in the current domain.

Implements

IField..::.GetFieldDefinition()()()

See Also

FieldRefDeclaration Class
GetFieldDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method (BindingOptions)

FieldRefDeclaration..::..GetFieldDefinition Method (BindingOptions)
FieldRefDeclaration Class See Also Send Feedback
Finds in the current domain the FieldDefDeclaration corresponding to the current field and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration GetFieldDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The FieldDefDeclaration corresponding to the current instance in the current domain.

Implements

IField..::.GetFieldDefinition(BindingOptions)

See Also

FieldRefDeclaration Class
GetFieldDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

FieldRefDeclaration..::..GetGenericContext Method
FieldRefDeclaration Class See Also Send Feedback
Gets the generic context of the declaring type, or an empty context if the member is contained by the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.FieldRefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.FieldRefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Implements

IField..::.GetGenericContext(GenericContextOptions)

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

FieldRefDeclaration..::..GetGenericInstance Method
FieldRefDeclaration Class See Also Send Feedback
Gets a generic instance of the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current field constructed using genericMap for generic arguments.

Implements

IField..::.GetGenericInstance(GenericMap)

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

FieldRefDeclaration..::..GetReflectionWrapper Method
FieldRefDeclaration Class See Also Send Feedback
Gets a reflection FieldInfo that wraps the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A FieldInfo wrapping current field in the given generic context.

Implements

IField..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a FieldInfo that is different from the system runtime field that is retrieved by GetSystemField(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current field even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemField Method

FieldRefDeclaration..::..GetSystemField Method
FieldRefDeclaration Class See Also Send Feedback
Gets the system runtime field corresponding to the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldInfo GetSystemField(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime FieldInfo, or null if the current field could not be bound.

Implements

IField..::.GetSystemField(array<Type>[]()[], array<Type>[]()[])

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

FieldRefDeclaration..::..ToString Method
FieldRefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

FieldRefDeclaration..::..Translate Method
FieldRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.FieldRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.FieldRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.FieldRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
FieldRefDeclaration Properties
FieldRefDeclaration Class See Also Send Feedback

The FieldRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Inherited from MemberRefDeclaration.)
Public property | DeclaringType | Gets the declaring IType. (Inherited from MemberRefDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldType | Gets or sets the type of the referenced field.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved. (Inherited from MemberRefDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

FieldRefDeclaration..::..Attributes Property
FieldRefDeclaration Class See Also Send Feedback
Gets the field attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldAttributes Attributes { get; }

Implements

IField..::.Attributes

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldType Property

FieldRefDeclaration..::..FieldType Property
FieldRefDeclaration Class See Also Send Feedback
Gets or sets the type of the referenced field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FieldType { get; set; }

Field Value

A TypeSignature.

Implements

IField..::.FieldType

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsConst Property

FieldRefDeclaration..::..IsConst Property
FieldRefDeclaration Class See Also Send Feedback
Determines whether the field is constant (i.e. literal).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsConst { get; }

Implements

IField..::.IsConst

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsReadOnly Property

FieldRefDeclaration..::..IsReadOnly Property
FieldRefDeclaration Class See Also Send Feedback
Determines whether the field is read-only (i.e. init only).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Implements

IField..::.IsReadOnly

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

FieldRefDeclaration..::..IsStatic Property
FieldRefDeclaration Class See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

FieldRefDeclaration..::..ParentMember Property
FieldRefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

FieldRefDeclaration..::..ParentType Property
FieldRefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

FieldRefDeclaration..::..Visibility Property
FieldRefDeclaration Class See Also Send Feedback
Gets the Visibility of the current member.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

FieldRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericContextOptions Enumeration

GenericContextOptions Enumeration
See Also Send Feedback
Options of the GetGenericContext(GenericContextOptions) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum GenericContextOptions

Members

Member name | Value | Description
None | 0 | Default.
ResolveGenericParameterDefinitions | 1 | Force type and method references (TypeRefDeclaration and MethodRefDeclaration) to return the generic context of their definition (TypeDefDeclaration and MethodDefDeclaration), that is, to put in the generic context their real generic parameters (GenericParameterDeclaration) instead of a placeholder (GenericParameterTypeSignature). Note that it forces the references to be resolved.

See Also

PostSharp.Sdk.CodeModel Namespace


GenericEventReference Class

GenericEventReference Class
Members See Also Send Feedback
Reference to an EventDeclaration combined with a GenericMap specifying the generic arguments of this event with respect to the context that returned the GenericEventReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericEventReference

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.GenericEventReference

See Also

GenericEventReference Members
PostSharp.Sdk.CodeModel Namespace


GenericEventReference Members

[image]

PostSharp 2.0 Documentation
GenericEventReference Members
GenericEventReference Class Constructors Methods Properties See Also Send Feedback

The GenericEventReference type exposes the following members.

Constructors

 | Name | Description
Public method | GenericEventReference | Initializes a new GenericEventReference.

Methods

 | Name | Description
Public method | GetEventType | Overloaded.
Public method | GetSemantic | Gets the GenericMethodReference corresponding to the current GenericEventReference for a given semantic.

Properties

 | Name | Description
Public property | Event | Gets the EventDeclaration.
Public property | GenericMap | Gets the generic arguments of Event.

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GenericEventReference Constructor

GenericEventReference Constructor
GenericEventReference Class See Also Send Feedback
Initializes a new GenericEventReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericEventReference(
    EventDeclaration event,
    GenericMap genericMap
)

Parameters

event
Type: PostSharp.Sdk.CodeModel..::.EventDeclaration
An event.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments of this event with respect to the current context.

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GenericEventReference Methods

[image]

PostSharp 2.0 Documentation
GenericEventReference Methods
GenericEventReference Class See Also Send Feedback

The GenericEventReference type exposes the following members.

Methods

 | Name | Description
Public method | GetEventType | Overloaded.
Public method | GetSemantic | Gets the GenericMethodReference corresponding to the current GenericEventReference for a given semantic.

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GetEventType Method

[image]

PostSharp 2.0 Documentation
GenericEventReference..::..GetEventType Method
GenericEventReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEventType(ITypeSignature) | Gets the type of Event after generic arguments in GenericMap have been mapped with the generic arguments of a given type.
Public method | GetEventType(ModuleDeclaration, GenericMap) | Gets the type of Event after generic arguments in GenericMap have been mapped with a given GenericMap.

See Also

GenericEventReference Class
GenericEventReference Members
PostSharp.Sdk.CodeModel Namespace


GetEventType Method (ITypeSignature)

GenericEventReference..::..GetEventType Method (ITypeSignature)
GenericEventReference Class See Also Send Feedback
Gets the type of Event after generic arguments in GenericMap have been mapped with the generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetEventType(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type whose generic context should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Event after its generic arguments in GenericMap have been mapped with the generic arguments of type.

See Also

GenericEventReference Class
GetEventType Overload
PostSharp.Sdk.CodeModel Namespace


GetEventType Method (ModuleDeclaration, GenericMap)

GenericEventReference..::..GetEventType Method (ModuleDeclaration, GenericMap)
GenericEventReference Class See Also Send Feedback
Gets the type of Event after generic arguments in GenericMap have been mapped with a given GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetEventType(
    ModuleDeclaration module,
    GenericMap genericMap
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the generic method instance should be expressed.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Event after its generic arguments in GenericMap have been mapped with genericMap.

See Also

GenericEventReference Class
GetEventType Overload
PostSharp.Sdk.CodeModel Namespace


GetSemantic Method

GenericEventReference..::..GetSemantic Method
GenericEventReference Class See Also Send Feedback
Gets the GenericMethodReference corresponding to the current GenericEventReference for a given semantic.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMethodReference GetSemantic(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
The required method semantic.

Return Value

The GenericMethodReference corresponding to the current GenericEventReference for a given semantic, or null if the Event does not define this semantic.

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GenericEventReference Properties

[image]

PostSharp 2.0 Documentation
GenericEventReference Properties
GenericEventReference Class See Also Send Feedback

The GenericEventReference type exposes the following members.

Properties

 | Name | Description
Public property | Event | Gets the EventDeclaration.
Public property | GenericMap | Gets the generic arguments of Event.

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


Event Property

GenericEventReference..::..Event Property
GenericEventReference Class See Also Send Feedback
Gets the EventDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventDeclaration Event { get; private set; }

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMap Property

GenericEventReference..::..GenericMap Property
GenericEventReference Class See Also Send Feedback
Gets the generic arguments of Event.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GenericMap { get; private set; }

See Also

GenericEventReference Class
PostSharp.Sdk.CodeModel Namespace


GenericFieldReference Class

GenericFieldReference Class
Members See Also Send Feedback
Reference to a FieldDefDeclaration combined with a GenericMap specifying the generic arguments of this field with respect to the context that returned the GenericFieldReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericFieldReference

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.GenericFieldReference

See Also

GenericFieldReference Members
PostSharp.Sdk.CodeModel Namespace


GenericFieldReference Members

[image]

PostSharp 2.0 Documentation
GenericFieldReference Members
GenericFieldReference Class Constructors Methods Properties See Also Send Feedback

The GenericFieldReference type exposes the following members.

Constructors

 | Name | Description
Public method | GenericFieldReference | Initializes a new GenericFieldReference.

Methods

 | Name | Description
Public method | GetFieldType | Overloaded.
Public method | GetInstance | Overloaded.

Properties

 | Name | Description
Public property | Field | Gets the FieldDefDeclaration.
Public property | GenericMap | Gets the generic arguments of Field.

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


GenericFieldReference Constructor

GenericFieldReference Constructor
GenericFieldReference Class See Also Send Feedback
Initializes a new GenericFieldReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericFieldReference(
    FieldDefDeclaration field,
    GenericMap genericMap
)

Parameters

field
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
A field.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments of this field with respect to the current context.

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


GenericFieldReference Methods

[image]

PostSharp 2.0 Documentation
GenericFieldReference Methods
GenericFieldReference Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetFieldType | Overloaded.
Public method | GetInstance | Overloaded.

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


GetFieldType Method

[image]

PostSharp 2.0 Documentation
GenericFieldReference..::..GetFieldType Method
GenericFieldReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldType(ITypeSignature) | Gets the type of Field after generic arguments in GenericMap have been mapped with the generic arguments of a given type.
Public method | GetFieldType(ModuleDeclaration, GenericMap) | Gets the type of Field after generic arguments in GenericMap have been mapped with a given GenericMap.

See Also

GenericFieldReference Class
GenericFieldReference Members
PostSharp.Sdk.CodeModel Namespace


GetFieldType Method (ITypeSignature)

GenericFieldReference..::..GetFieldType Method (ITypeSignature)
GenericFieldReference Class See Also Send Feedback
Gets the type of Field after generic arguments in GenericMap have been mapped with the generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetFieldType(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type whose generic context should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Field after its generic arguments in GenericMap have been mapped with the generic arguments of type.

See Also

GenericFieldReference Class
GetFieldType Overload
PostSharp.Sdk.CodeModel Namespace


GetFieldType Method (ModuleDeclaration, GenericMap)

GenericFieldReference..::..GetFieldType Method (ModuleDeclaration, GenericMap)
GenericFieldReference Class See Also Send Feedback
Gets the type of Field after generic arguments in GenericMap have been mapped with a given GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetFieldType(
    ModuleDeclaration module,
    GenericMap genericMap
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the generic method instance should be expressed.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Field after its generic arguments in GenericMap have been mapped with genericMap.

See Also

GenericFieldReference Class
GetFieldType Overload
PostSharp.Sdk.CodeModel Namespace


GetInstance Method

[image]

PostSharp 2.0 Documentation
GenericFieldReference..::..GetInstance Method
GenericFieldReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstance(ITypeSignature) | Gets a generic instance of the Field by mapping the generic arguments in GenericMap with the generic arguments of a given type.
Public method | GetInstance(ModuleDeclaration, GenericMap) | Gets a generic instance of the Field by mapping the generic arguments in GenericMap with a given GenericMap.

See Also

GenericFieldReference Class
GenericFieldReference Members
PostSharp.Sdk.CodeModel Namespace


GetInstance Method (ITypeSignature)

GenericFieldReference..::..GetInstance Method (ITypeSignature)
GenericFieldReference Class See Also Send Feedback
Gets a generic instance of the Field by mapping the generic arguments in GenericMap with the generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetInstance(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type whose generic context should be applied to the generic arguments specified in the GenericMap property.

Return Value

A generic instance of the Field by mapping the generic arguments in GenericMap with the generic arguments of type.

See Also

GenericFieldReference Class
GetInstance Overload
PostSharp.Sdk.CodeModel Namespace


GetInstance Method (ModuleDeclaration, GenericMap)

GenericFieldReference..::..GetInstance Method (ModuleDeclaration, GenericMap)
GenericFieldReference Class See Also Send Feedback
Gets a generic instance of the Field by mapping the generic arguments in GenericMap with a given GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetInstance(
    ModuleDeclaration module,
    GenericMap genericMap
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the generic method instance should be expressed.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied to the generic arguments specified in the GenericMap property.

Return Value

A generic instance of the Field by mapping the generic arguments in GenericMap with genericMap.

See Also

GenericFieldReference Class
GetInstance Overload
PostSharp.Sdk.CodeModel Namespace


GenericFieldReference Properties

[image]

PostSharp 2.0 Documentation
GenericFieldReference Properties
GenericFieldReference Class See Also Send Feedback

The GenericFieldReference type exposes the following members.

Properties

 | Name | Description
Public property | Field | Gets the FieldDefDeclaration.
Public property | GenericMap | Gets the generic arguments of Field.

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


Field Property

GenericFieldReference..::..Field Property
GenericFieldReference Class See Also Send Feedback
Gets the FieldDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclaration Field { get; }

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMap Property

GenericFieldReference..::..GenericMap Property
GenericFieldReference Class See Also Send Feedback
Gets the generic arguments of Field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GenericMap { get; }

See Also

GenericFieldReference Class
PostSharp.Sdk.CodeModel Namespace


GenericHelper Class

GenericHelper Class
Members See Also Send Feedback
Extension methods for generic types and methods.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class GenericHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.GenericHelper

See Also

GenericHelper Members
PostSharp.Sdk.CodeModel Namespace


GenericHelper Members

[image]

PostSharp 2.0 Documentation
GenericHelper Members
GenericHelper Class Methods See Also Send Feedback

The GenericHelper type exposes the following members.

Methods

Name | Description
GetFieldCanonicalGenericInstance | Gets the canonical generic instance of a field.
GetMethodCanonicalGenericInstance | Gets the canonical generic instance of a generic method.
GetTypeCanonicalGenericInstance | Gets the canonical generic instance of a generic type.

See Also

GenericHelper Class
PostSharp.Sdk.CodeModel Namespace


GenericHelper Methods

[image]

PostSharp 2.0 Documentation
GenericHelper Methods
GenericHelper Class See Also Send Feedback

The GenericHelper type exposes the following members.

Methods

Name | Description
GetFieldCanonicalGenericInstance | Gets the canonical generic instance of a field.
GetMethodCanonicalGenericInstance | Gets the canonical generic instance of a generic method.
GetTypeCanonicalGenericInstance | Gets the canonical generic instance of a generic type.

See Also

GenericHelper Class
PostSharp.Sdk.CodeModel Namespace


GetFieldCanonicalGenericInstance Method

GenericHelper..::..GetFieldCanonicalGenericInstance Method
GenericHelper Class See Also Send Feedback
Gets the canonical generic instance of a field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IField GetFieldCanonicalGenericInstance(
    this FieldDefDeclaration field
)

Parameters

field
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
field whose canonical generic instance is requested.

Return Value

The canonical generic instance of field, or the unmodified field if the declaring type of field is not a generic type definition.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FieldDefDeclaration. When you use instance method syntax to call this method, omit the first parameter.

Remarks

The canonical generic instance of a field is the field defined on the canonical generic instance of the declaring type. For instance, the canonical generic instance of the type MyType`3::myField is MyType`3<!0,!1,!2>::myField.

See Also

GenericHelper Class
PostSharp.Sdk.CodeModel Namespace


GetMethodCanonicalGenericInstance Method

GenericHelper..::..GetMethodCanonicalGenericInstance Method
GenericHelper Class See Also Send Feedback
Gets the canonical generic instance of a generic method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IMethod GetMethodCanonicalGenericInstance(
    this IGenericMethodDefinition method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.IGenericMethodDefinition
Method whose canonical generic instance is requested.

Return Value

The canonical generic instance of method, or the unmodified method if method is not a generic method definition.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IGenericMethodDefinition. When you use instance method syntax to call this method, omit the first parameter.

Remarks

The canonical generic instance of a method is a generic instance where the n-th formal generic method argument is mapped to the n-th concrete generic method parameter. If the declaring type is a generic type definition, the canonical generic instance of the method is defined on the canonical generic instance of the declaring type (see GetTypeCanonicalGenericInstance(IGenericTypeDefinition)).

For instance, the canonical generic instance of the type MyType`3::MyMethod is MyType`3<!0,!1,!2>::MyMethod<!0,!1>. if MyMethod has two generic arguments.

See Also

GenericHelper Class
PostSharp.Sdk.CodeModel Namespace


GetTypeCanonicalGenericInstance Method

GenericHelper..::..GetTypeCanonicalGenericInstance Method
GenericHelper Class See Also Send Feedback
Gets the canonical generic instance of a generic type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IType GetTypeCanonicalGenericInstance(
    this IGenericTypeDefinition type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IGenericTypeDefinition
Type whose canonical generic instance is requested.

Return Value

The canonical generic instance of type, or the unmodified type if type is not a generic type definition.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IGenericTypeDefinition. When you use instance method syntax to call this method, omit the first parameter.

Remarks

The canonical generic instance of a type is a generic instance where the n-th formal generic type argument is mapped to the n-th concrete generic type parameter. For instance, the canonical generic instance of the type MyType`3 is MyType`3<!0,!1,!2>.

See Also

GenericHelper Class
PostSharp.Sdk.CodeModel Namespace


GenericMap Structure

GenericMap Structure
Members See Also Send Feedback
Map generic arguments to their value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct GenericMap

Remarks

Generic arguments are always given by ordinal. The current object stores a map between ordinals and a type signature to which the ordinal is mapped.

Do not rely on the Equals(Object) method to test for equality.

See Also

GenericMap Members
PostSharp.Sdk.CodeModel Namespace


GenericMap Members

[image]

PostSharp 2.0 Documentation
GenericMap Members
GenericMap Structure Constructors Methods Fields Properties See Also Send Feedback

The GenericMap type exposes the following members.

Constructors

 | Name | Description
Public method | GenericMap | Overloaded.

Methods

 | Name | Description
Public method | Apply | Transform the current GenericMap using a second GenericMap.
Public method | ContainsGenericParameter | Determines whether the current GenericMap contains a mapping for a given generic parameter.
Public method | GetGenericMethodParameter | Gets the type mapped to a given method generic parameter.
Public method | GetGenericMethodParameters | Gets the array of method generic arguments in the current GenericMap.
Public method | GetGenericParameter | Overloaded.
Public method | GetGenericTypeParameter | Gets the type mapped to a given type generic parameter.
Public method | GetGenericTypeParameters | Gets the array of type generic arguments in the current GenericMap.
Public method | GetTypeContext | Gets a GenericMap based on the current context, but remove method generic parameters.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)
Public method | Translate | Translates the current GenericMap to another ModuleDeclaration.

Fields

Name | Description
Empty | Gets an empty GenericMap (a context without generic parameters).

Properties

 | Name | Description
Public property | GenericMethodParameterCount | Gets the number of generic method parameters.
Public property | GenericTypeParameterCount | Gets the number of generic type parameters.
Public property | IsEmpty | Determines whether the current generic context is empty, i.e. has no generic argument or parameter at all.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericMap Constructor

[image]

PostSharp 2.0 Documentation
GenericMap Constructor
GenericMap Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GenericMap(GenericMap, IList<(Of <(ITypeSignature>)>)) | Initializes a new GenericMap and copies the type parameters of another GenericMap.
Public method | GenericMap(IList<(Of <(ITypeSignature>)>), IList<(Of <(ITypeSignature>)>)) | Initializes a new instance of the GenericMap type with explicit values.

See Also

GenericMap Structure
GenericMap Members
PostSharp.Sdk.CodeModel Namespace


GenericMap Constructor (GenericMap, IList(ITypeSignature))

GenericMap Constructor (GenericMap, IList<(Of <(<'ITypeSignature>)>)>)
GenericMap Structure See Also Send Feedback
Initializes a new GenericMap and copies the type parameters of another GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap(
    GenericMap typeGenericMap,
    IList<ITypeSignature> genericMethodParameters
)

Parameters

typeGenericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
GenericMap from which type parameters have to be copied.
genericMethodParameters
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic method parameters, or null.

Remarks

This is typically used to complete a type-level context with generic method parameters.

See Also

GenericMap Structure
GenericMap Overload
PostSharp.Sdk.CodeModel Namespace


GenericMap Constructor (IList(ITypeSignature), IList(ITypeSignature))

GenericMap Constructor (IList<(Of <(<'ITypeSignature>)>)>, IList<(Of <(<'ITypeSignature>)>)>)
GenericMap Structure See Also Send Feedback
Initializes a new instance of the GenericMap type with explicit values.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap(
    IList<ITypeSignature> genericTypeParameters,
    IList<ITypeSignature> genericMethodParameters
)

Parameters

genericTypeParameters
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic type parameters, or null.
genericMethodParameters
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic method parameters, or null.

See Also

GenericMap Structure
GenericMap Overload
PostSharp.Sdk.CodeModel Namespace


GenericMap Fields

[image]

PostSharp 2.0 Documentation
GenericMap Fields
GenericMap Structure See Also Send Feedback

The GenericMap type exposes the following members.

Fields

Name | Description
Empty | Gets an empty GenericMap (a context without generic parameters).

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


Empty Field

GenericMap..::..Empty Field
GenericMap Structure See Also Send Feedback
Gets an empty GenericMap (a context without generic parameters).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly GenericMap Empty

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericMap Methods

[image]

PostSharp 2.0 Documentation
GenericMap Methods
GenericMap Structure See Also Send Feedback

The GenericMap type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Transform the current GenericMap using a second GenericMap.
Public method | ContainsGenericParameter | Determines whether the current GenericMap contains a mapping for a given generic parameter.
Public method | GetGenericMethodParameter | Gets the type mapped to a given method generic parameter.
Public method | GetGenericMethodParameters | Gets the array of method generic arguments in the current GenericMap.
Public method | GetGenericParameter | Overloaded.
Public method | GetGenericTypeParameter | Gets the type mapped to a given type generic parameter.
Public method | GetGenericTypeParameters | Gets the array of type generic arguments in the current GenericMap.
Public method | GetTypeContext | Gets a GenericMap based on the current context, but remove method generic parameters.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)
Public method | Translate | Translates the current GenericMap to another ModuleDeclaration.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


Apply Method

GenericMap..::..Apply Method
GenericMap Structure See Also Send Feedback
Transform the current GenericMap using a second GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap Apply(
    GenericMap map
)

Parameters

map
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied on the current map.

Return Value

A GenericMap where all generic arguments where mapped by map.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


ContainsGenericParameter Method

GenericMap..::..ContainsGenericParameter Method
GenericMap Structure See Also Send Feedback
Determines whether the current GenericMap contains a mapping for a given generic parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsGenericParameter(
    GenericParameterKind kind,
    int ordinal
)

Parameters

kind
Type: PostSharp.Sdk.CodeModel..::.GenericParameterKind
Kind of generic parameter.
ordinal
Type: System..::.Int32
Ordinal of the generic parameter.

Return Value

true if the current GenericMap contains a mapping for the generic parameter of kind kind and ordinal ordinal, otherwise false.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GetGenericMethodParameter Method

GenericMap..::..GetGenericMethodParameter Method
GenericMap Structure See Also Send Feedback
Gets the type mapped to a given method generic parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetGenericMethodParameter(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The parameter position.

Return Value

The ITypeSignature mapped to this generic parameter.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GetGenericMethodParameters Method

GenericMap..::..GetGenericMethodParameters Method
GenericMap Structure See Also Send Feedback
Gets the array of method generic arguments in the current GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature[] GetGenericMethodParameters()

Return Value

An array of ITypeSignature, or null if the current GenericMap has no method generic argument.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method

[image]

PostSharp 2.0 Documentation
GenericMap..::..GetGenericParameter Method
GenericMap Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGenericParameter(IGenericParameter) | Gets the type mapped to a given generic parameter given an IGenericParameter.
Public method | GetGenericParameter(GenericParameterKind, Int32) | Gets the type mapped to a generic parameter given its kind and ordinal.

See Also

GenericMap Structure
GenericMap Members
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method (IGenericParameter)

GenericMap..::..GetGenericParameter Method (IGenericParameter)
GenericMap Structure See Also Send Feedback
Gets the type mapped to a given generic parameter given an IGenericParameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetGenericParameter(
    IGenericParameter genericParameter
)

Parameters

genericParameter
Type: PostSharp.Sdk.CodeModel..::.IGenericParameter
A generic parameter.

Return Value

The ITypeSignature mapped to this generic parameter.

See Also

GenericMap Structure
GetGenericParameter Overload
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method (GenericParameterKind, Int32)

GenericMap..::..GetGenericParameter Method (GenericParameterKind, Int32)
GenericMap Structure See Also Send Feedback
Gets the type mapped to a generic parameter given its kind and ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetGenericParameter(
    GenericParameterKind kind,
    int ordinal
)

Parameters

kind
Type: PostSharp.Sdk.CodeModel..::.GenericParameterKind
The kind of generic parameter (type or method).
ordinal
Type: System..::.Int32
The ordinal.

Return Value

The ITypeSignature mapped to this generic parameter.

See Also

GenericMap Structure
GetGenericParameter Overload
PostSharp.Sdk.CodeModel Namespace


GetGenericTypeParameter Method

GenericMap..::..GetGenericTypeParameter Method
GenericMap Structure See Also Send Feedback
Gets the type mapped to a given type generic parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetGenericTypeParameter(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The parameter position.

Return Value

The ITypeSignature mapped to this generic parameter.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GetGenericTypeParameters Method

GenericMap..::..GetGenericTypeParameters Method
GenericMap Structure See Also Send Feedback
Gets the array of type generic arguments in the current GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature[] GetGenericTypeParameters()

Return Value

An array of ITypeSignature, or null if the current GenericMap has no type generic argument.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GetTypeContext Method

GenericMap..::..GetTypeContext Method
GenericMap Structure See Also Send Feedback
Gets a GenericMap based on the current context, but remove method generic parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetTypeContext()

Return Value

A GenericMap.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

GenericMap..::..ToString Method
GenericMap Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


Translate Method

GenericMap..::..Translate Method
GenericMap Structure See Also Send Feedback
Translates the current GenericMap to another ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration in which the current GenericMap must be translated.

Return Value

A GenericMap equivalent to the current one, but expressed for the module.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericMap Properties

[image]

PostSharp 2.0 Documentation
GenericMap Properties
GenericMap Structure See Also Send Feedback

The GenericMap type exposes the following members.

Properties

 | Name | Description
Public property | GenericMethodParameterCount | Gets the number of generic method parameters.
Public property | GenericTypeParameterCount | Gets the number of generic type parameters.
Public property | IsEmpty | Determines whether the current generic context is empty, i.e. has no generic argument or parameter at all.

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericMethodParameterCount Property

GenericMap..::..GenericMethodParameterCount Property
GenericMap Structure See Also Send Feedback
Gets the number of generic method parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GenericMethodParameterCount { get; }

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericTypeParameterCount Property

GenericMap..::..GenericTypeParameterCount Property
GenericMap Structure See Also Send Feedback
Gets the number of generic type parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GenericTypeParameterCount { get; }

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


IsEmpty Property

GenericMap..::..IsEmpty Property
GenericMap Structure See Also Send Feedback
Determines whether the current generic context is empty, i.e. has no generic argument or parameter at all.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsEmpty { get; }

See Also

GenericMap Structure
PostSharp.Sdk.CodeModel Namespace


GenericMethodReference Class

GenericMethodReference Class
Members See Also Send Feedback
Reference to a MethodDefDeclaration combined with a GenericMap specifying the generic arguments of this method with respect to the context that returned the GenericMethodReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMethodReference

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.GenericMethodReference

See Also

GenericMethodReference Members
PostSharp.Sdk.CodeModel Namespace


GenericMethodReference Members

[image]

PostSharp 2.0 Documentation
GenericMethodReference Members
GenericMethodReference Class Constructors Methods Properties See Also Send Feedback

The GenericMethodReference type exposes the following members.

Constructors

 | Name | Description
Public method | GenericMethodReference | Initializes a new GenericMethodReference.

Methods

 | Name | Description
Public method | GetInstance | Overloaded.

Properties

 | Name | Description
Public property | GenericMap | Gets the generic arguments of Method.
Public property | Method | Gets the MethodDefDeclaration.

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMethodReference Constructor

GenericMethodReference Constructor
GenericMethodReference Class See Also Send Feedback
Initializes a new GenericMethodReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMethodReference(
    MethodDefDeclaration method,
    GenericMap genericMap
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A method.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments of this method with respect to the current context.

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMethodReference Methods

[image]

PostSharp 2.0 Documentation
GenericMethodReference Methods
GenericMethodReference Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetInstance | Overloaded.

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


GetInstance Method

[image]

PostSharp 2.0 Documentation
GenericMethodReference..::..GetInstance Method
GenericMethodReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstance(ITypeSignature) | Gets a generic instance of the Method by mapping the generic arguments in GenericMap with the generic arguments of a given type.
Public method | GetInstance(ModuleDeclaration, GenericMap) | Gets a generic instance of the Method by mapping the generic arguments in GenericMap with a given GenericMap.

See Also

GenericMethodReference Class
GenericMethodReference Members
PostSharp.Sdk.CodeModel Namespace


GetInstance Method (ITypeSignature)

GenericMethodReference..::..GetInstance Method (ITypeSignature)
GenericMethodReference Class See Also Send Feedback
Gets a generic instance of the Method by mapping the generic arguments in GenericMap with the generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetInstance(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type whose generic context should be applied to the generic arguments specified in the GenericMap property.

Return Value

A generic instance of the Method by mapping the generic arguments in GenericMap with the generic arguments of type.

See Also

GenericMethodReference Class
GetInstance Overload
PostSharp.Sdk.CodeModel Namespace


GetInstance Method (ModuleDeclaration, GenericMap)

GenericMethodReference..::..GetInstance Method (ModuleDeclaration, GenericMap)
GenericMethodReference Class See Also Send Feedback
Gets a generic instance of the Method by mapping the generic arguments in GenericMap with a given GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetInstance(
    ModuleDeclaration module,
    GenericMap genericMap
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the generic method instance should be expressed.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied to the generic arguments specified in the GenericMap property.

Return Value

A generic instance of the Method by mapping the generic arguments in GenericMap with genericMap.

See Also

GenericMethodReference Class
GetInstance Overload
PostSharp.Sdk.CodeModel Namespace


GenericMethodReference Properties

[image]

PostSharp 2.0 Documentation
GenericMethodReference Properties
GenericMethodReference Class See Also Send Feedback

The GenericMethodReference type exposes the following members.

Properties

 | Name | Description
Public property | GenericMap | Gets the generic arguments of Method.
Public property | Method | Gets the MethodDefDeclaration.

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMap Property

GenericMethodReference..::..GenericMap Property
GenericMethodReference Class See Also Send Feedback
Gets the generic arguments of Method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GenericMap { get; }

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


Method Property

GenericMethodReference..::..Method Property
GenericMethodReference Class See Also Send Feedback
Gets the MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Method { get; }

See Also

GenericMethodReference Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterConstraintDeclaration Class

GenericParameterConstraintDeclaration Class
Members See Also Send Feedback
Represents a constraint of a generic parameter (GenericParamConstraint).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericParameterConstraintDeclaration : MetadataDeclaration

Remarks

Generic parameter constraints are owner by generic parameters (GenericParameterDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.GenericParameterConstraintDeclaration

See Also

GenericParameterConstraintDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GenericParameterConstraintDeclaration Members

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclaration Members
GenericParameterConstraintDeclaration Class Constructors Methods Properties See Also Send Feedback

The GenericParameterConstraintDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | GenericParameterConstraintDeclaration | Initializes a new instance of the GenericParameterConstraintDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

Properties

 | Name | Description
Public property | ConstraintType | Gets or sets the constraint type.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringGenericParameter | Gets the parent GenericParameterDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterConstraintDeclaration Constructor

GenericParameterConstraintDeclaration Constructor
GenericParameterConstraintDeclaration Class See Also Send Feedback
Initializes a new instance of the GenericParameterConstraintDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterConstraintDeclaration()

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterConstraintDeclaration Methods

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclaration Methods
GenericParameterConstraintDeclaration Class See Also Send Feedback

The GenericParameterConstraintDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

GenericParameterConstraintDeclaration..::..GetTokenType Method
GenericParameterConstraintDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterConstraintDeclaration Properties

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclaration Properties
GenericParameterConstraintDeclaration Class See Also Send Feedback

The GenericParameterConstraintDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | ConstraintType | Gets or sets the constraint type.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringGenericParameter | Gets the parent GenericParameterDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ConstraintType Property

GenericParameterConstraintDeclaration..::..ConstraintType Property
GenericParameterConstraintDeclaration Class See Also Send Feedback
Gets or sets the constraint type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ConstraintType { get; set; }

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringGenericParameter Property

GenericParameterConstraintDeclaration..::..DeclaringGenericParameter Property
GenericParameterConstraintDeclaration Class See Also Send Feedback
Gets the parent GenericParameterDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclaration DeclaringGenericParameter { get; }

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

GenericParameterConstraintDeclaration..::..ParentMember Property
GenericParameterConstraintDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

GenericParameterConstraintDeclaration..::..ParentType Property
GenericParameterConstraintDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

GenericParameterConstraintDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterDeclaration Class

GenericParameterDeclaration Class
Members See Also Send Feedback
Represents a generic parameter (GenericParam).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericParameterDeclaration : NamedMetadataDeclaration,
    IPositioned, IGenericParameter, ITypeSignature, IModuleElement, IVisitable<ITypeSignature>,
    IGeneric, IEquatable<ITypeSignature>, IWriteReflectionName

Remarks

Generic parameters are owned by types (TypeDefDeclaration) or methods (MethodDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.GenericParameterDeclaration

See Also

GenericParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GenericParameterDeclaration Members

[image]

PostSharp 2.0 Documentation
GenericParameterDeclaration Members
GenericParameterDeclaration Class Constructors Methods Properties See Also Send Feedback

The GenericParameterDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | GenericParameterDeclaration | Initializes a new GenericParameterDeclaration.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Clones the current instance and makes the clone compatible within a given module.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetReference | Gets the GenericParameterTypeSignature that references to the current instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes of the generic parameter.
Public property | Constraints | Gets the list of type constraints applying on the type parameter.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringGenericDefinition | Gets the IGenericDefinition that declares the current generic parameter.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | Kind | Gets the kind of generic parameters (Type or Method).
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Gets or sets the generic parameter ordinal.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterDeclaration Constructor

GenericParameterDeclaration Constructor
GenericParameterDeclaration Class See Also Send Feedback
Initializes a new GenericParameterDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclaration()

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterDeclaration Methods

[image]

PostSharp 2.0 Documentation
GenericParameterDeclaration Methods
GenericParameterDeclaration Class See Also Send Feedback

The GenericParameterDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Clones the current instance and makes the clone compatible within a given module.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetReference | Gets the GenericParameterTypeSignature that references to the current instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

GenericParameterDeclaration..::..BelongsToClassification Method
GenericParameterDeclaration Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

GenericParameterDeclaration..::..Clone Method
GenericParameterDeclaration Class See Also Send Feedback
Clones the current instance and makes the clone compatible within a given module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclaration Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the clone should be meaningful.

Return Value

A GenericParameterDeclaration mmeaningfulin targetModule.

Remarks

This method does not clone the constraints.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
GenericParameterDeclaration..::..Equals Method
GenericParameterDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(ITypeSignature) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(GenericParameterDeclaration, Boolean) | Compares the current GenericParameterDeclaration with an other.

See Also

GenericParameterDeclaration Class
GenericParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (ITypeSignature)

GenericParameterDeclaration..::..Equals Method (ITypeSignature)
GenericParameterDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

GenericParameterDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (GenericParameterDeclaration, Boolean)

GenericParameterDeclaration..::..Equals Method (GenericParameterDeclaration, Boolean)
GenericParameterDeclaration Class See Also Send Feedback
Compares the current GenericParameterDeclaration with an other.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    GenericParameterDeclaration other,
    bool compareConstraints
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.GenericParameterDeclaration
Another GenericParameterDeclaration.
compareConstraints
Type: System..::.Boolean
true if constraints of generic parameters have to be compared also, otherwise false.

Return Value

true if both generic parameters are equal, otherwise false.

See Also

GenericParameterDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

GenericParameterDeclaration..::..GetCanonicalHashCode Method
GenericParameterDeclaration Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReference Method

GenericParameterDeclaration..::..GetReference Method
GenericParameterDeclaration Class See Also Send Feedback
Gets the GenericParameterTypeSignature that references to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterTypeSignature GetReference()

Return Value

A GenericParameterTypeSignature with same ordinal and kind as the current instance.

Implements

IGenericParameter..::.GetReference()()()

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

GenericParameterDeclaration..::..GetReflectionWrapper Method
GenericParameterDeclaration Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

GenericParameterDeclaration..::..GetSystemType Method
GenericParameterDeclaration Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

GenericParameterDeclaration..::..GetTokenType Method
GenericParameterDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetValueSize Method

GenericParameterDeclaration..::..GetValueSize Method
GenericParameterDeclaration Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

Remarks

Returns always -1 (unknown size).

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
GenericParameterDeclaration..::..IsAssignableTo Method
GenericParameterDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

GenericParameterDeclaration Class
GenericParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

GenericParameterDeclaration..::..IsAssignableTo Method (ITypeSignature)
GenericParameterDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

GenericParameterDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

GenericParameterDeclaration..::..IsAssignableTo Method (ITypeSignature, GenericMap)
GenericParameterDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature, GenericMap)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

GenericParameterDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

GenericParameterDeclaration..::..MapGenericArguments Method
GenericParameterDeclaration Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

GenericParameterDeclaration..::..MatchesReference Method
GenericParameterDeclaration Class See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

Implements

ITypeSignature..::.MatchesReference(ITypeSignature)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

GenericParameterDeclaration..::..ToString Method
GenericParameterDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TranslateType Method

GenericParameterDeclaration..::..TranslateType Method
GenericParameterDeclaration Class See Also Send Feedback
Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature TranslateType(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the type signature should be translated.

Return Value

A type signature meaningful in the targetModule module.

Implements

ITypeSignature..::.TranslateType(ModuleDeclaration)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

GenericParameterDeclaration..::..WriteReflectionName Method
GenericParameterDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterDeclaration Properties

[image]

PostSharp 2.0 Documentation
GenericParameterDeclaration Properties
GenericParameterDeclaration Class See Also Send Feedback

The GenericParameterDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes of the generic parameter.
Public property | Constraints | Gets the list of type constraints applying on the type parameter.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringGenericDefinition | Gets the IGenericDefinition that declares the current generic parameter.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | Kind | Gets the kind of generic parameters (Type or Method).
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Gets or sets the generic parameter ordinal.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

GenericParameterDeclaration..::..Attributes Property
GenericParameterDeclaration Class See Also Send Feedback
Gets or sets the attributes of the generic parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterAttributes Attributes { get; set; }

Field Value

A combination of GenericParameterAttributes.

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Constraints Property

GenericParameterDeclaration..::..Constraints Property
GenericParameterDeclaration Class See Also Send Feedback
Gets the list of type constraints applying on the type parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterConstraintDeclarationCollection Constraints { get; }

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringGenericDefinition Property

GenericParameterDeclaration..::..DeclaringGenericDefinition Property
GenericParameterDeclaration Class See Also Send Feedback
Gets the IGenericDefinition that declares the current generic parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericDefinitionDefinition DeclaringGenericDefinition { get; }

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Kind Property

GenericParameterDeclaration..::..Kind Property
GenericParameterDeclaration Class See Also Send Feedback
Gets the kind of generic parameters (Type or Method).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterKind Kind { get; set; }

Field Value

A GenericParameterKind.

Implements

IGenericParameter..::.Kind

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

GenericParameterDeclaration..::..Ordinal Property
GenericParameterDeclaration Class See Also Send Feedback
Gets or sets the generic parameter ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; set; }

Field Value

The ordinal of the current generic parameter, i.e. its position in its parent collection.

Implements

IPositioned..::.Ordinal
IGenericParameter..::.Ordinal

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

GenericParameterDeclaration..::..ParentMember Property
GenericParameterDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

GenericParameterDeclaration..::..ParentType Property
GenericParameterDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

GenericParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterKind Enumeration

GenericParameterKind Enumeration
See Also Send Feedback
Enumerates the kind of classes accepting generic parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum GenericParameterKind

Members

Member name | Value | Description
Type | 0 | Type.
Method | 1 | Method.

See Also

PostSharp.Sdk.CodeModel Namespace


GenericPropertyReference Class

GenericPropertyReference Class
Members See Also Send Feedback
Reference to a PropertyDeclaration combined with a GenericMap specifying the generic arguments of this property with respect to the context that returned the GenericPropertyReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericPropertyReference

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.GenericPropertyReference

See Also

GenericPropertyReference Members
PostSharp.Sdk.CodeModel Namespace


GenericPropertyReference Members

[image]

PostSharp 2.0 Documentation
GenericPropertyReference Members
GenericPropertyReference Class Constructors Methods Properties See Also Send Feedback

The GenericPropertyReference type exposes the following members.

Constructors

 | Name | Description
Public method | GenericPropertyReference | Initializes a new GenericEventReference.

Methods

 | Name | Description
Public method | GetPropertyType | Overloaded.
Public method | GetSemantic | Gets the GenericMethodReference corresponding to the current GenericPropertyReference for a given semantic.

Properties

 | Name | Description
Public property | GenericMap | Gets the generic arguments of Property.
Public property | Property | Gets the PropertyDeclaration.

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


GenericPropertyReference Constructor

GenericPropertyReference Constructor
GenericPropertyReference Class See Also Send Feedback
Initializes a new GenericEventReference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericPropertyReference(
    PropertyDeclaration property,
    GenericMap genericMap
)

Parameters

property
Type: PostSharp.Sdk.CodeModel..::.PropertyDeclaration
A property.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments of this property with respect to the current context.

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


GenericPropertyReference Methods

[image]

PostSharp 2.0 Documentation
GenericPropertyReference Methods
GenericPropertyReference Class See Also Send Feedback

The GenericPropertyReference type exposes the following members.

Methods

 | Name | Description
Public method | GetPropertyType | Overloaded.
Public method | GetSemantic | Gets the GenericMethodReference corresponding to the current GenericPropertyReference for a given semantic.

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


GetPropertyType Method

[image]

PostSharp 2.0 Documentation
GenericPropertyReference..::..GetPropertyType Method
GenericPropertyReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPropertyType(ITypeSignature) | Gets the type of Property after generic arguments in GenericMap have been mapped with the generic arguments of a given type.
Public method | GetPropertyType(ModuleDeclaration, GenericMap) | Gets the type of Property after generic arguments in GenericMap have been mapped with a given GenericMap.

See Also

GenericPropertyReference Class
GenericPropertyReference Members
PostSharp.Sdk.CodeModel Namespace


GetPropertyType Method (ITypeSignature)

GenericPropertyReference..::..GetPropertyType Method (ITypeSignature)
GenericPropertyReference Class See Also Send Feedback
Gets the type of Property after generic arguments in GenericMap have been mapped with the generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetPropertyType(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type whose generic context should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Property after its generic arguments in GenericMap have been mapped with the generic arguments of type.

See Also

GenericPropertyReference Class
GetPropertyType Overload
PostSharp.Sdk.CodeModel Namespace


GetPropertyType Method (ModuleDeclaration, GenericMap)

GenericPropertyReference..::..GetPropertyType Method (ModuleDeclaration, GenericMap)
GenericPropertyReference Class See Also Send Feedback
Gets the type of Property after generic arguments in GenericMap have been mapped with a given GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetPropertyType(
    ModuleDeclaration module,
    GenericMap genericMap
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the generic method instance should be expressed.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap that should be applied to the generic arguments specified in the GenericMap property.

Return Value

The type of Property after its generic arguments in GenericMap have been mapped with genericMap.

See Also

GenericPropertyReference Class
GetPropertyType Overload
PostSharp.Sdk.CodeModel Namespace


GetSemantic Method

GenericPropertyReference..::..GetSemantic Method
GenericPropertyReference Class See Also Send Feedback
Gets the GenericMethodReference corresponding to the current GenericPropertyReference for a given semantic.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMethodReference GetSemantic(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
The required method semantic.

Return Value

The GenericMethodReference corresponding to the current GenericPropertyReference for a given semantic, or null if the Property does not define this semantic.

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


GenericPropertyReference Properties

[image]

PostSharp 2.0 Documentation
GenericPropertyReference Properties
GenericPropertyReference Class See Also Send Feedback

The GenericPropertyReference type exposes the following members.

Properties

 | Name | Description
Public property | GenericMap | Gets the generic arguments of Property.
Public property | Property | Gets the PropertyDeclaration.

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


GenericMap Property

GenericPropertyReference..::..GenericMap Property
GenericPropertyReference Class See Also Send Feedback
Gets the generic arguments of Property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GenericMap { get; private set; }

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


Property Property

GenericPropertyReference..::..Property Property
GenericPropertyReference Class See Also Send Feedback
Gets the PropertyDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyDeclaration Property { get; private set; }

See Also

GenericPropertyReference Class
PostSharp.Sdk.CodeModel Namespace


IAnnotationInstance Interface

IAnnotationInstance Interface
Members See Also Send Feedback
Exposes the fact that a custom attribute (IAnnotationValue) is applied to an element (MetadataDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAnnotationInstance

See Also

IAnnotationInstance Members
PostSharp.Sdk.CodeModel Namespace


IAnnotationInstance Members

[image]

PostSharp 2.0 Documentation
IAnnotationInstance Members
IAnnotationInstance Interface Properties See Also Send Feedback

The IAnnotationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

IAnnotationInstance Interface
PostSharp.Sdk.CodeModel Namespace


IAnnotationInstance Properties

[image]

PostSharp 2.0 Documentation
IAnnotationInstance Properties
IAnnotationInstance Interface See Also Send Feedback

The IAnnotationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

IAnnotationInstance Interface
PostSharp.Sdk.CodeModel Namespace


Symbol Property

IAnnotationInstance..::..Symbol Property
IAnnotationInstance Interface See Also Send Feedback
Element of the symbol file representing the current aspect instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
SymAspectUsage Symbol { get; }

See Also

IAnnotationInstance Interface
PostSharp.Sdk.CodeModel Namespace


TargetElement Property

IAnnotationInstance..::..TargetElement Property
IAnnotationInstance Interface See Also Send Feedback
Element on which the annotation value is applied.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MetadataDeclaration TargetElement { get; }

See Also

IAnnotationInstance Interface
PostSharp.Sdk.CodeModel Namespace


Value Property

IAnnotationInstance..::..Value Property
IAnnotationInstance Interface See Also Send Feedback
Custom attribute value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAnnotationValue Value { get; }

See Also

IAnnotationInstance Interface
PostSharp.Sdk.CodeModel Namespace


IAnnotationValue Interface

IAnnotationValue Interface
Members See Also Send Feedback
Defines the semantics of a custom attribute value, i.e. basically a constructor, its arguments and other named arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAnnotationValue

See Also

IAnnotationValue Members
PostSharp.Sdk.CodeModel Namespace


IAnnotationValue Members

[image]

PostSharp 2.0 Documentation
IAnnotationValue Members
IAnnotationValue Interface Methods Properties See Also Send Feedback

The IAnnotationValue type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current annotation so that it is valid in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the set of constructor arguments.
Public property | NamedArguments | Gets the set of named arguments.

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


IAnnotationValue Methods

[image]

PostSharp 2.0 Documentation
IAnnotationValue Methods
IAnnotationValue Interface See Also Send Feedback

The IAnnotationValue type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current annotation so that it is valid in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


Translate Method

IAnnotationValue..::..Translate Method
IAnnotationValue Interface See Also Send Feedback
Translates the current annotation so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAnnotationValue Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module into which the current IAnnotationValue should be translated.

Return Value

An IAnnotationValue valid in module.

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


IAnnotationValue Properties

[image]

PostSharp 2.0 Documentation
IAnnotationValue Properties
IAnnotationValue Interface See Also Send Feedback

The IAnnotationValue type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gets the custom attribute constructor.
Public property | ConstructorArguments | Gets the set of constructor arguments.
Public property | NamedArguments | Gets the set of named arguments.

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


Constructor Property

IAnnotationValue..::..Constructor Property
IAnnotationValue Interface See Also Send Feedback
Gets the custom attribute constructor.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethod Constructor { get; }

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


ConstructorArguments Property

IAnnotationValue..::..ConstructorArguments Property
IAnnotationValue Interface See Also Send Feedback
Gets the set of constructor arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MemberValuePairCollection ConstructorArguments { get; }

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


NamedArguments Property

IAnnotationValue..::..NamedArguments Property
IAnnotationValue Interface See Also Send Feedback
Gets the set of named arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MemberValuePairCollection NamedArguments { get; }

See Also

IAnnotationValue Interface
PostSharp.Sdk.CodeModel Namespace


IAssembly Interface

IAssembly Interface
Members See Also Send Feedback
Defines the semantics of an assembly (AssemblyRefDeclaration AssemblyEnvelope).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssembly : IAssemblyName,
    ITaggable

See Also

IAssembly Members
PostSharp.Sdk.CodeModel Namespace


IAssembly Members

[image]

PostSharp 2.0 Documentation
IAssembly Members
IAssembly Interface Methods Properties See Also Send Feedback

The IAssembly type exposes the following members.

Methods

 | Name | Description
Public method | GetAssemblyEnvelope | Gets the AssemblyEnvelope corresponding to the current instance in the current domain.
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | AssemblyDeclaration | Gets the AssemblyDeclaration for the current assembly.
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


IAssembly Methods

[image]

PostSharp 2.0 Documentation
IAssembly Methods
IAssembly Interface See Also Send Feedback

The IAssembly type exposes the following members.

Methods

 | Name | Description
Public method | GetAssemblyEnvelope | Gets the AssemblyEnvelope corresponding to the current instance in the current domain.
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetSystemAssembly | Gets the reflection Assembly corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


GetAssemblyEnvelope Method

IAssembly..::..GetAssemblyEnvelope Method
IAssembly Interface See Also Send Feedback
Gets the AssemblyEnvelope corresponding to the current instance in the current domain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
AssemblyEnvelope GetAssemblyEnvelope()

Return Value

An AssemblyEnvelope.

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


GetSystemAssembly Method

IAssembly..::..GetSystemAssembly Method
IAssembly Interface See Also Send Feedback
Gets the reflection Assembly corresponding to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Assembly GetSystemAssembly()

Return Value

The Assembly corresponding to this instance, or null if the assembly could not be found.

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


IAssembly Properties

[image]

PostSharp 2.0 Documentation
IAssembly Properties
IAssembly Interface See Also Send Feedback

The IAssembly type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyDeclaration | Gets the AssemblyDeclaration for the current assembly.
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


AssemblyDeclaration Property

IAssembly..::..AssemblyDeclaration Property
IAssembly Interface See Also Send Feedback
Gets the AssemblyDeclaration for the current assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAssemblyDeclaration AssemblyDeclaration { get; }

See Also

IAssembly Interface
PostSharp.Sdk.CodeModel Namespace


IAssemblyDeclaration Interface

IAssemblyDeclaration Interface
Members See Also Send Feedback
Defines the semantics of assemblies.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAssemblyDeclaration : IAssemblyName,
    IMetadataDeclaration, IDeclaration, IElement, IModuleElement, ITaggable,
    IWriteReflectionName

See Also

IAssemblyDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IAssemblyDeclaration Members

[image]

PostSharp 2.0 Documentation
IAssemblyDeclaration Members
IAssemblyDeclaration Interface Methods Properties See Also Send Feedback

The IAssemblyDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateAssembly | Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssemblyDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IAssemblyDeclaration Methods

[image]

PostSharp 2.0 Documentation
IAssemblyDeclaration Methods
IAssemblyDeclaration Interface See Also Send Feedback

The IAssemblyDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key. (Inherited from IAssemblyName.)
Public method | GetPublicKeyToken | Gets the assembly public key token. (Inherited from IAssemblyName.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateAssembly | Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

IAssemblyDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


TranslateAssembly Method

IAssemblyDeclaration..::..TranslateAssembly Method
IAssemblyDeclaration Interface See Also Send Feedback
Translates the current AssemblyManifestDeclaration into a different ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAssemblyDeclaration TranslateAssembly(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the current AssemblyManifestDeclaration should be translated.

Return Value

The translation of the current AssemblyManifestDeclaration for targetModule.

See Also

IAssemblyDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IAssemblyDeclaration Properties

[image]

PostSharp 2.0 Documentation
IAssemblyDeclaration Properties
IAssemblyDeclaration Interface See Also Send Feedback

The IAssemblyDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name. (Inherited from IAssemblyName.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib. (Inherited from IAssemblyName.)
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature. (Inherited from IAssemblyName.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the assembly friendly name. (Inherited from IAssemblyName.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets. (Inherited from IAssemblyName.)
Public property | Version | Gets the assembly version. (Inherited from IAssemblyName.)

See Also

IAssemblyDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


ICloneableModuleElement Interface

ICloneableModuleElement Interface
Members See Also Send Feedback
A module element that has the ability to create a clone of itself, expressed for a different module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ICloneableModuleElement : IModuleElement

See Also

ICloneableModuleElement Members
PostSharp.Sdk.CodeModel Namespace


ICloneableModuleElement Members

[image]

PostSharp 2.0 Documentation
ICloneableModuleElement Members
ICloneableModuleElement Interface Methods Properties See Also Send Feedback

The ICloneableModuleElement type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a clone of the current module element and express this clone for use in a different module.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)

See Also

ICloneableModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


ICloneableModuleElement Methods

[image]

PostSharp 2.0 Documentation
ICloneableModuleElement Methods
ICloneableModuleElement Interface See Also Send Feedback

The ICloneableModuleElement type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a clone of the current module element and express this clone for use in a different module.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

ICloneableModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


Clone Method

ICloneableModuleElement..::..Clone Method
ICloneableModuleElement Interface See Also Send Feedback
Creates a clone of the current module element and express this clone for use in a different module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ICloneableModuleElement Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration for which the clone should be expressed.

Return Value

A clone of the current element, expressed for targetModule.

See Also

ICloneableModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


ICloneableModuleElement Properties

[image]

PostSharp 2.0 Documentation
ICloneableModuleElement Properties
ICloneableModuleElement Interface See Also Send Feedback

The ICloneableModuleElement type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)

See Also

ICloneableModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


IDeclaration Interface

IDeclaration Interface
Members See Also Send Feedback
Exposes the semantics of a declaration, which is basically a module-scoped domain element.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IDeclaration : IElement,
    IModuleElement

See Also

IDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IDeclaration Members

[image]

PostSharp 2.0 Documentation
IDeclaration Members
IDeclaration Interface Methods Properties See Also Send Feedback

The IDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)

See Also

IDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IDeclaration Methods

[image]

PostSharp 2.0 Documentation
IDeclaration Methods
IDeclaration Interface See Also Send Feedback

The IDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IDeclaration Properties

[image]

PostSharp 2.0 Documentation
IDeclaration Properties
IDeclaration Interface See Also Send Feedback

The IDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)

See Also

IDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IElement Interface

IElement Interface
Members See Also Send Feedback
Defines the semantics of a domain element, which is basically a domain-rooted tree node.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IElement

See Also

IElement Members
PostSharp.Sdk.CodeModel Namespace


IElement Members

[image]

PostSharp 2.0 Documentation
IElement Members
IElement Interface Properties See Also Send Feedback

The IElement type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets the Domain to which the current element belongs.
Public property | Parent | Gets the direct parent of the current element.

See Also

IElement Interface
PostSharp.Sdk.CodeModel Namespace


IElement Properties

[image]

PostSharp 2.0 Documentation
IElement Properties
IElement Interface See Also Send Feedback

The IElement type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets the Domain to which the current element belongs.
Public property | Parent | Gets the direct parent of the current element.

See Also

IElement Interface
PostSharp.Sdk.CodeModel Namespace


Domain Property

IElement..::..Domain Property
IElement Interface See Also Send Feedback
Gets the Domain to which the current element belongs.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Domain Domain { get; }

Field Value

A Domain, or null if the element is detached.

See Also

IElement Interface
PostSharp.Sdk.CodeModel Namespace


Parent Property

IElement..::..Parent Property
IElement Interface See Also Send Feedback
Gets the direct parent of the current element.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Element Parent { get; }

Field Value

An Element, or null if the element is detached.

See Also

IElement Interface
PostSharp.Sdk.CodeModel Namespace


IField Interface

IField Interface
Members See Also Send Feedback
Defines the semantics of a field (FieldDefDeclaration, FieldRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IField : IMember, IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

IField Members
PostSharp.Sdk.CodeModel Namespace


IField Members

[image]

PostSharp 2.0 Documentation
IField Members
IField Interface Methods Properties See Also Send Feedback

The IField type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldDefinition | Overloaded.
Public method | GetGenericContext | Gets the generic context of the declaring type, or an empty context if the member is contained by the module.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateField | Translates the current field so that it is meaningful in another module than the one to which it primarily belong.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | FieldType | Gets the field type.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


IField Methods

[image]

PostSharp 2.0 Documentation
IField Methods
IField Interface See Also Send Feedback

The IField type exposes the following members.

Methods

 | Name | Description
Public method | GetFieldDefinition | Overloaded.
Public method | GetGenericContext | Gets the generic context of the declaring type, or an empty context if the member is contained by the module.
Public method | GetGenericInstance | Gets a generic instance of the current field.
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection FieldInfo that wraps the current field.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemField | Gets the system runtime field corresponding to the current field.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateField | Translates the current field so that it is meaningful in another module than the one to which it primarily belong.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method

[image]

PostSharp 2.0 Documentation
IField..::..GetFieldDefinition Method
IField Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFieldDefinition()()() | Finds in the current domain the FieldDefDeclaration corresponding to the current field with default BindingOptions.
Public method | GetFieldDefinition(BindingOptions) | Finds in the current domain the FieldDefDeclaration corresponding to the current field and specifies BindingOptions.

See Also

IField Interface
IField Members
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method

IField..::..GetFieldDefinition Method
IField Interface See Also Send Feedback
Finds in the current domain the FieldDefDeclaration corresponding to the current field with default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldDefDeclaration GetFieldDefinition()

Return Value

The FieldDefDeclaration corresponding to the current instance in the current domain.

See Also

IField Interface
GetFieldDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetFieldDefinition Method (BindingOptions)

IField..::..GetFieldDefinition Method (BindingOptions)
IField Interface See Also Send Feedback
Finds in the current domain the FieldDefDeclaration corresponding to the current field and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldDefDeclaration GetFieldDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The FieldDefDeclaration corresponding to the current instance in the current domain.

See Also

IField Interface
GetFieldDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

IField..::..GetGenericContext Method
IField Interface See Also Send Feedback
Gets the generic context of the declaring type, or an empty context if the member is contained by the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.IField.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.IField.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

IField..::..GetGenericInstance Method
IField Interface See Also Send Feedback
Gets a generic instance of the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IField GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current field constructed using genericMap for generic arguments.

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

IField..::..GetReflectionWrapper Method
IField Interface See Also Send Feedback
Gets a reflection FieldInfo that wraps the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A FieldInfo wrapping current field in the given generic context.

Remarks

This method returns a FieldInfo that is different from the system runtime field that is retrieved by GetSystemField(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current field even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


GetSystemField Method

IField..::..GetSystemField Method
IField Interface See Also Send Feedback
Gets the system runtime field corresponding to the current field.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldInfo GetSystemField(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime FieldInfo, or null if the current field could not be bound.

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


TranslateField Method

IField..::..TranslateField Method
IField Interface See Also Send Feedback
Translates the current field so that it is meaningful in another module than the one to which it primarily belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IField TranslateField(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the type signature should be translated.

Return Value

A field meaningful in the targetModule module.

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


IField Properties

[image]

PostSharp 2.0 Documentation
IField Properties
IField Interface See Also Send Feedback

The IField type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the field attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | FieldType | Gets the field type.
Public property | IsConst | Determines whether the field is constant (i.e. literal).
Public property | IsReadOnly | Determines whether the field is read-only (i.e. init only).
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


Attributes Property

IField..::..Attributes Property
IField Interface See Also Send Feedback
Gets the field attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldAttributes Attributes { get; }

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


FieldType Property

IField..::..FieldType Property
IField Interface See Also Send Feedback
Gets the field type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature FieldType { get; }

Field Value

A TypeSignature.

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


IsConst Property

IField..::..IsConst Property
IField Interface See Also Send Feedback
Determines whether the field is constant (i.e. literal).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsConst { get; }

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


IsReadOnly Property

IField..::..IsReadOnly Property
IField Interface See Also Send Feedback
Determines whether the field is read-only (i.e. init only).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsReadOnly { get; }

See Also

IField Interface
PostSharp.Sdk.CodeModel Namespace


IGeneric Interface

IGeneric Interface
Members See Also Send Feedback
Exposes the common semantics to generic instances and generic definitions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGeneric

See Also

IGeneric Members
PostSharp.Sdk.CodeModel Namespace


IGeneric Members

[image]

PostSharp 2.0 Documentation
IGeneric Members
IGeneric Interface Methods Properties See Also Send Feedback

The IGeneric type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.

Properties

 | Name | Description
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


IGeneric Methods

[image]

PostSharp 2.0 Documentation
IGeneric Methods
IGeneric Interface See Also Send Feedback

The IGeneric type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

IGeneric..::..GetGenericContext Method
IGeneric Interface See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.IGeneric.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


IGeneric Properties

[image]

PostSharp 2.0 Documentation
IGeneric Properties
IGeneric Interface See Also Send Feedback

The IGeneric type exposes the following members.

Properties

 | Name | Description
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


IsGenericDefinition Property

IGeneric..::..IsGenericDefinition Property
IGeneric Interface See Also Send Feedback
Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsGenericDefinition { get; }

Remarks

If the current property returns true, the semantics of IGenericDefinition are meaningful for the current instance.

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


IsGenericInstance Property

IGeneric..::..IsGenericInstance Property
IGeneric Interface See Also Send Feedback
Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsGenericInstance { get; }

Remarks

If the current property returns true, the semantics of IGenericInstance are meaningful for the current instance.

See Also

IGeneric Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinition Interface

IGenericDefinition Interface
Members See Also Send Feedback
Exposes the semantics of a generic definition (i.e. a type or method having (unbound) generic parameters). Classes implementing IGenericDefinition can also represent references to generic definitions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericDefinition : IGeneric,
    IMetadataDeclaration, IDeclaration, IElement, IModuleElement, ITaggable

Remarks

The fact that an object can be casted to IGenericDefinition does not automatically mean that it is actually a generic definition. It is always necessary to check the IsGenericDefinition property.

See Also

IGenericDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericDefinition Members

[image]

PostSharp 2.0 Documentation
IGenericDefinition Members
IGenericDefinition Interface Methods Properties See Also Send Feedback

The IGenericDefinition type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinition Methods

[image]

PostSharp 2.0 Documentation
IGenericDefinition Methods
IGenericDefinition Interface See Also Send Feedback

The IGenericDefinition type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IGenericDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method

IGenericDefinition..::..GetGenericParameter Method
IGenericDefinition Interface See Also Send Feedback
Gets a generic (formal, unbound) parameter given its ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IGenericParameter GetGenericParameter(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The generic parameter ordinal (position).

Return Value

A GenericParameterDeclaration, or null if the current generic parameter does not exist.

Remarks

If the current instance is a defined in the current module (MethodDefDeclaration, TypeDefDeclaration), this method returns a GenericParameterDeclaration. Otherwise, it returns a reference to a generic parameter, i.e. a GenericParameterTypeSignature.

See Also

IGenericDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinition Properties

[image]

PostSharp 2.0 Documentation
IGenericDefinition Properties
IGenericDefinition Interface See Also Send Feedback

The IGenericDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GenericParameterCount Property

IGenericDefinition..::..GenericParameterCount Property
IGenericDefinition Interface See Also Send Feedback
Gets the number of (formal, unbound) generic parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int GenericParameterCount { get; }

See Also

IGenericDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinitionDefinition Interface

IGenericDefinitionDefinition Interface
Members See Also Send Feedback
Exposes the semantics of a generic definition but, unlike IGenericDefinition, are a real definition and not a reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericDefinitionDefinition : IGenericDefinition,
    IGeneric, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

See Also

IGenericDefinitionDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericDefinitionDefinition Members

[image]

PostSharp 2.0 Documentation
IGenericDefinitionDefinition Members
IGenericDefinitionDefinition Interface Methods Properties See Also Send Feedback

The IGenericDefinitionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | GenericParameters | Gets the collection of generic parameters.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericDefinitionDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinitionDefinition Methods

[image]

PostSharp 2.0 Documentation
IGenericDefinitionDefinition Methods
IGenericDefinitionDefinition Interface See Also Send Feedback

The IGenericDefinitionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IGenericDefinitionDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericDefinitionDefinition Properties

[image]

PostSharp 2.0 Documentation
IGenericDefinitionDefinition Properties
IGenericDefinitionDefinition Interface See Also Send Feedback

The IGenericDefinitionDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | GenericParameters | Gets the collection of generic parameters.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericDefinitionDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GenericParameters Property

IGenericDefinitionDefinition..::..GenericParameters Property
IGenericDefinitionDefinition Interface See Also Send Feedback
Gets the collection of generic parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
GenericParameterDeclarationCollection GenericParameters { get; }

See Also

IGenericDefinitionDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericInstance Interface

IGenericInstance Interface
Members See Also Send Feedback
Exposes the semantics of a generic instance (i.e. an instance of generic definition, with concretely specified generic, bound arguments).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericInstance : IGeneric

Remarks

The fact that an object can be casted to IGenericInstance does not automatically mean that it is actually a generic instance. It is always necessary to check the IsGenericInstance property.

See Also

IGenericInstance Members
PostSharp.Sdk.CodeModel Namespace


IGenericInstance Members

[image]

PostSharp 2.0 Documentation
IGenericInstance Members
IGenericInstance Interface Methods Properties See Also Send Feedback

The IGenericInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericArgument | Gets a generic (concrete, bound) argument given its ordinal.
Public method | GetGenericArguments | Gets the list of generic arguments of the current generic instance.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)

Properties

 | Name | Description
Public property | GenericArgumentCount | Gets the number of (concrete, bound) generic arguments.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


IGenericInstance Methods

[image]

PostSharp 2.0 Documentation
IGenericInstance Methods
IGenericInstance Interface See Also Send Feedback

The IGenericInstance type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericArgument | Gets a generic (concrete, bound) argument given its ordinal.
Public method | GetGenericArguments | Gets the list of generic arguments of the current generic instance.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericArgument Method

IGenericInstance..::..GetGenericArgument Method
IGenericInstance Interface See Also Send Feedback
Gets a generic (concrete, bound) argument given its ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature GetGenericArgument(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The generic argument ordinal (position).

Return Value

An IType, or null if the current generic original does not exist.

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericArguments Method

IGenericInstance..::..GetGenericArguments Method
IGenericInstance Interface See Also Send Feedback
Gets the list of generic arguments of the current generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IList<ITypeSignature> GetGenericArguments()

Return Value

The list of generic arguments.

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


IGenericInstance Properties

[image]

PostSharp 2.0 Documentation
IGenericInstance Properties
IGenericInstance Interface See Also Send Feedback

The IGenericInstance type exposes the following members.

Properties

 | Name | Description
Public property | GenericArgumentCount | Gets the number of (concrete, bound) generic arguments.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


GenericArgumentCount Property

IGenericInstance..::..GenericArgumentCount Property
IGenericInstance Interface See Also Send Feedback
Gets the number of (concrete, bound) generic arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int GenericArgumentCount { get; }

See Also

IGenericInstance Interface
PostSharp.Sdk.CodeModel Namespace


IGenericMethodDefinition Interface

IGenericMethodDefinition Interface
Members See Also Send Feedback
Declares the semantics of a generic method definition, i.e. a method that may have unbound generic parameter and method constructions (MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericMethodDefinition : IMethod,
    IMethodSignature, IEquatable<IMethodSignature>, IMember, IEquatable<IMethod>,
    IWriteReflectionName, IGenericDefinition, IGeneric, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable

See Also

IGenericMethodDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericMethodDefinition Members

[image]

PostSharp 2.0 Documentation
IGenericMethodDefinition Members
IGenericMethodDefinition Interface Methods Properties See Also Send Feedback

The IGenericMethodDefinition type exposes the following members.

Methods

 | Name | Description
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position. (Inherited from IMethodSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method. (Inherited from IMethod.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method. (Inherited from IMethod.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature. (Inherited from IMethodSignature.)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature. (Inherited from IMethodSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethod | Translates the current method so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethod.)
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethodSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method. (Inherited from IMethod.)
Public property | CallingConvention | Gets the method calling convention. (Inherited from IMethodSignature.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | IsAbstract | Determines whether the method is abstract. (Inherited from IMethod.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsNew | Determines whether the method takes a new slot. (Inherited from IMethod.)
Public property | IsSealed | Determines whether the method is sealed. (Inherited from IMethod.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | IsVirtual | Determines whether the method is virtual. (Inherited from IMethod.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | ParameterCount | Gets the number of parameters. (Inherited from IMethodSignature.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ReturnType | Gets the return type. (Inherited from IMethodSignature.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericMethodDefinition Methods

[image]

PostSharp 2.0 Documentation
IGenericMethodDefinition Methods
IGenericMethodDefinition Interface See Also Send Feedback

The IGenericMethodDefinition type exposes the following members.

Methods

 | Name | Description
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position. (Inherited from IMethodSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method. (Inherited from IMethod.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method. (Inherited from IMethod.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature. (Inherited from IMethodSignature.)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature. (Inherited from IMethodSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethod | Translates the current method so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethod.)
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethodSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


FindGenericInstance Method

IGenericMethodDefinition..::..FindGenericInstance Method
IGenericMethodDefinition Interface See Also Send Feedback
Finds or construct a specific generic instance of the current generic method definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethod FindGenericInstance(
    IList<ITypeSignature> genericArguments,
    BindingOptions bindingOptions
)

Parameters

genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic arguments.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The generic instance, or null if it was not found and was not requested to be created.

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

IGenericMethodDefinition..::..GetGenericInstance Method
IGenericMethodDefinition Interface See Also Send Feedback
Gets a generic instance of the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethod GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current method constructed using genericMap as generic arguments.

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

[image]

PostSharp 2.0 Documentation
IGenericMethodDefinition..::..GetMethodDefinition Method
IGenericMethodDefinition Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMethodDefinition()()() | Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions. (Inherited from IMethod.)
Public method | GetMethodDefinition(BindingOptions) | Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions. (Inherited from IMethod.)

See Also

IGenericMethodDefinition Interface
IGenericMethodDefinition Members
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

[image]

PostSharp 2.0 Documentation
IGenericMethodDefinition..::..MatchesReference Method
IGenericMethodDefinition Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchesReference(IMethod) | Determines whether the current method matches a given method reference. (Inherited from IMethod.)
Public method | MatchesReference(IMethodSignature) | Determines whether the current method signature matches a given method signature reference. (Inherited from IMethodSignature.)

See Also

IGenericMethodDefinition Interface
IGenericMethodDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericMethodDefinition Properties

[image]

PostSharp 2.0 Documentation
IGenericMethodDefinition Properties
IGenericMethodDefinition Interface See Also Send Feedback

The IGenericMethodDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method. (Inherited from IMethod.)
Public property | CallingConvention | Gets the method calling convention. (Inherited from IMethodSignature.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | IsAbstract | Determines whether the method is abstract. (Inherited from IMethod.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsNew | Determines whether the method takes a new slot. (Inherited from IMethod.)
Public property | IsSealed | Determines whether the method is sealed. (Inherited from IMethod.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | IsVirtual | Determines whether the method is virtual. (Inherited from IMethod.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | ParameterCount | Gets the number of parameters. (Inherited from IMethodSignature.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ReturnType | Gets the return type. (Inherited from IMethodSignature.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


MethodSpecs Property

IGenericMethodDefinition..::..MethodSpecs Property
IGenericMethodDefinition Interface See Also Send Feedback
Gets the collection of method specifications (MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodSpecDeclarationCollection MethodSpecs { get; }

See Also

IGenericMethodDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericParameter Interface

IGenericParameter Interface
Members See Also Send Feedback
Defines the semantics of a generic parameter or argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericParameter : ITypeSignature,
    IModuleElement, IVisitable<ITypeSignature>, IGeneric, IEquatable<ITypeSignature>,
    IWriteReflectionName

See Also

IGenericParameter Members
PostSharp.Sdk.CodeModel Namespace


IGenericParameter Members

[image]

PostSharp 2.0 Documentation
IGenericParameter Members
IGenericParameter Interface Methods Properties See Also Send Feedback

The IGenericParameter type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReference | Gets the GenericParameterTypeSignature that references to the current instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | Kind | Gets the kind of generic parameter (Method or Type).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Ordinal | Gets the generic parameter ordinal.

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


IGenericParameter Methods

[image]

PostSharp 2.0 Documentation
IGenericParameter Methods
IGenericParameter Interface See Also Send Feedback

The IGenericParameter type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReference | Gets the GenericParameterTypeSignature that references to the current instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


GetReference Method

IGenericParameter..::..GetReference Method
IGenericParameter Interface See Also Send Feedback
Gets the GenericParameterTypeSignature that references to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
GenericParameterTypeSignature GetReference()

Return Value

A GenericParameterTypeSignature with same ordinal and kind as the current instance.

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
IGenericParameter..::..GetTypeDefinition Method
IGenericParameter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from ITypeSignature.)

See Also

IGenericParameter Interface
IGenericParameter Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
IGenericParameter..::..IsAssignableTo Method
IGenericParameter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from ITypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from ITypeSignature.)

See Also

IGenericParameter Interface
IGenericParameter Members
PostSharp.Sdk.CodeModel Namespace


IGenericParameter Properties

[image]

PostSharp 2.0 Documentation
IGenericParameter Properties
IGenericParameter Interface See Also Send Feedback

The IGenericParameter type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | Kind | Gets the kind of generic parameter (Method or Type).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Ordinal | Gets the generic parameter ordinal.

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


Kind Property

IGenericParameter..::..Kind Property
IGenericParameter Interface See Also Send Feedback
Gets the kind of generic parameter (Method or Type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
GenericParameterKind Kind { get; }

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

IGenericParameter..::..Ordinal Property
IGenericParameter Interface See Also Send Feedback
Gets the generic parameter ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int Ordinal { get; }

See Also

IGenericParameter Interface
PostSharp.Sdk.CodeModel Namespace


IGenericTypeDefinition Interface

IGenericTypeDefinition Interface
Members See Also Send Feedback
A type that can be a generic definition (TypeDefDeclaration or ITypeRefResolutionScope).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IGenericTypeDefinition : IGenericDefinition,
    INamedType, IType, ITypeSignature, IVisitable<ITypeSignature>,
    IGeneric, IEquatable<ITypeSignature>, IWriteReflectionName, IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable, INamed

See Also

IGenericTypeDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericTypeDefinition Members

[image]

PostSharp 2.0 Documentation
IGenericTypeDefinition Members
IGenericTypeDefinition Interface Methods Properties See Also Send Feedback

The IGenericTypeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes. (Inherited from IType.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested. (Inherited from IType.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields. (Inherited from IType.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | IsAbstract | Determines whether the class is abstract. (Inherited from IType.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface. (Inherited from IType.)
Public property | IsSealed | Determines whether the type is sealed. (Inherited from IType.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods. (Inherited from IType.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the name of the current object. (Inherited from INamed.)
Public property | NestedTypes | Gets the collection of types nested in the current type. (Inherited from INamedType.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericTypeDefinition Interface
PostSharp.Sdk.CodeModel Namespace


IGenericTypeDefinition Methods

[image]

PostSharp 2.0 Documentation
IGenericTypeDefinition Methods
IGenericTypeDefinition Interface See Also Send Feedback

The IGenericTypeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal. (Inherited from IGenericDefinition.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

IGenericTypeDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

IGenericTypeDefinition..::..GetGenericInstance Method
IGenericTypeDefinition Interface See Also Send Feedback
Gets a generic instance of this type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IType GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current generic type, using genericMap for generic arguments.

See Also

IGenericTypeDefinition Interface
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
IGenericTypeDefinition..::..GetTypeDefinition Method
IGenericTypeDefinition Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from ITypeSignature.)

See Also

IGenericTypeDefinition Interface
IGenericTypeDefinition Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
IGenericTypeDefinition..::..IsAssignableTo Method
IGenericTypeDefinition Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from ITypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from ITypeSignature.)

See Also

IGenericTypeDefinition Interface
IGenericTypeDefinition Members
PostSharp.Sdk.CodeModel Namespace


IGenericTypeDefinition Properties

[image]

PostSharp 2.0 Documentation
IGenericTypeDefinition Properties
IGenericTypeDefinition Interface See Also Send Feedback

The IGenericTypeDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes. (Inherited from IType.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested. (Inherited from IType.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields. (Inherited from IType.)
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters. (Inherited from IGenericDefinition.)
Public property | IsAbstract | Determines whether the class is abstract. (Inherited from IType.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface. (Inherited from IType.)
Public property | IsSealed | Determines whether the type is sealed. (Inherited from IType.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods. (Inherited from IType.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the name of the current object. (Inherited from INamed.)
Public property | NestedTypes | Gets the collection of types nested in the current type. (Inherited from INamedType.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IGenericTypeDefinition Interface
PostSharp.Sdk.CodeModel Namespace


ImageAttributes Enumeration

ImageAttributes Enumeration
See Also Send Feedback
Attributes of a .NET PE module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum ImageAttributes

Members

Member name | Value | Description
ILOnly | 1 | Always 1 (§23.1).
Requires32Bits | 2 | Image may only be loaded into a 32-bit process, for instance if there are 32-bit vtablefixups, or casts from native integers to int32. CLI implementations that have 64-bit native integers shall refuse loading binaries with the current flag set.
StrongNameRequired | 8 | Image has a strong name signature.
TrackDebugData | 65536 | Always 0 (§23.1).

See Also

PostSharp.Sdk.CodeModel Namespace


IManifestResourceImplementation Interface

IManifestResourceImplementation Interface
See Also Send Feedback
Defines the semantics that are common to all physical locations that can contain resources (ManifestResourceDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IManifestResourceImplementation

See Also

PostSharp.Sdk.CodeModel Namespace


IMember Interface

IMember Interface
Members See Also Send Feedback
Defines the semantics of a type member (DeclaringType and Name properties).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMember : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

IMember Members
PostSharp.Sdk.CodeModel Namespace


IMember Members

[image]

PostSharp 2.0 Documentation
IMember Members
IMember Interface Methods Properties See Also Send Feedback

The IMember type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type.
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | IsStatic | Determines whether the current member is static.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name.
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


IMember Methods

[image]

PostSharp 2.0 Documentation
IMember Methods
IMember Interface See Also Send Feedback

The IMember type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


IMember Properties

[image]

PostSharp 2.0 Documentation
IMember Properties
IMember Interface See Also Send Feedback

The IMember type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type.
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | IsStatic | Determines whether the current member is static.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name.
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

IMember..::..DeclaringType Property
IMember Interface See Also Send Feedback
Gets the declaring type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IType DeclaringType { get; }

Field Value

The declaring type (IType), or null if the member is contained by the module.

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

IMember..::..IsStatic Property
IMember Interface See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsStatic { get; }

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


Name Property

IMember..::..Name Property
IMember Interface See Also Send Feedback
Gets the method name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string Name { get; }

Field Value

The method name.

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


Visibility Property

IMember..::..Visibility Property
IMember Interface See Also Send Feedback
Gets the Visibility of the current member.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Visibility Visibility { get; }

See Also

IMember Interface
PostSharp.Sdk.CodeModel Namespace


IMemberRefResolutionScope Interface

IMemberRefResolutionScope Interface
Members See Also Send Feedback
Defines semantics of all classes declaring external fields or methods.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMemberRefResolutionScope : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable, IGeneric

See Also

IMemberRefResolutionScope Members
PostSharp.Sdk.CodeModel Namespace


IMemberRefResolutionScope Members

[image]

PostSharp 2.0 Documentation
IMemberRefResolutionScope Members
IMemberRefResolutionScope Interface Methods Properties See Also Send Feedback

The IMemberRefResolutionScope type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IMemberRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


IMemberRefResolutionScope Methods

[image]

PostSharp 2.0 Documentation
IMemberRefResolutionScope Methods
IMemberRefResolutionScope Interface See Also Send Feedback

The IMemberRefResolutionScope type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IMemberRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


IMemberRefResolutionScope Properties

[image]

PostSharp 2.0 Documentation
IMemberRefResolutionScope Properties
IMemberRefResolutionScope Interface See Also Send Feedback

The IMemberRefResolutionScope type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IMemberRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


FieldRefs Property

IMemberRefResolutionScope..::..FieldRefs Property
IMemberRefResolutionScope Interface See Also Send Feedback
Gets the collection of fields (FieldRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
FieldRefDeclarationCollection FieldRefs { get; }

See Also

IMemberRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


MethodRefs Property

IMemberRefResolutionScope..::..MethodRefs Property
IMemberRefResolutionScope Interface See Also Send Feedback
Gets the collection of methods (MethodRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodRefDeclarationCollection MethodRefs { get; }

See Also

IMemberRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


IMetadataDeclaration Interface

IMetadataDeclaration Interface
Members See Also Send Feedback
Defines the semantics of a metadata declaration, i.e. a declaration with a token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMetadataDeclaration : IDeclaration,
    IElement, IModuleElement, ITaggable

See Also

IMetadataDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IMetadataDeclaration Members

[image]

PostSharp 2.0 Documentation
IMetadataDeclaration Members
IMetadataDeclaration Interface Methods Properties See Also Send Feedback

The IMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration.
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration.
Public property | ParentType | Gets the parent type of the current declaration.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IMetadataDeclaration Methods

[image]

PostSharp 2.0 Documentation
IMetadataDeclaration Methods
IMetadataDeclaration Interface See Also Send Feedback

The IMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration.
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


GetReflectionSystemObject Method

IMetadataDeclaration..::..GetReflectionSystemObject Method
IMetadataDeclaration Interface See Also Send Feedback
Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object GetReflectionSystemObject(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system object associated the current type in the given generic context.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapperObject Method

IMetadataDeclaration..::..GetReflectionWrapperObject Method
IMetadataDeclaration Interface See Also Send Feedback
Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object GetReflectionWrapperObject(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A System.Reflection object wrapping current declaration. If the current declaration is an assembly (IAssembly), an IAssemblyWrapper object is returned.

Remarks

This method returns an object that is different from the system runtime type that is retrieved by GetReflectionSystemObject(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current declaration even when it cannot be loaded in the Virtual Runtime Engine.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

IMetadataDeclaration..::..GetTokenType Method
IMetadataDeclaration Interface See Also Send Feedback
Gets the metadata token type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TokenType GetTokenType()

Return Value

A TokenType.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IMetadataDeclaration Properties

[image]

PostSharp 2.0 Documentation
IMetadataDeclaration Properties
IMetadataDeclaration Interface See Also Send Feedback

The IMetadataDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration.
Public property | ParentType | Gets the parent type of the current declaration.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


CustomAttributes Property

IMetadataDeclaration..::..CustomAttributes Property
IMetadataDeclaration Interface See Also Send Feedback
Gets the collection of custom attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
CustomAttributeDeclarationCollection CustomAttributes { get; }

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


MetadataToken Property

IMetadataDeclaration..::..MetadataToken Property
IMetadataDeclaration Interface See Also Send Feedback
Gets the metadata token of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MetadataToken MetadataToken { get; }

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

IMetadataDeclaration..::..ParentMember Property
IMetadataDeclaration Interface See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


ParentType Property

IMetadataDeclaration..::..ParentType Property
IMetadataDeclaration Interface See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

See Also

IMetadataDeclaration Interface
PostSharp.Sdk.CodeModel Namespace


IMethod Interface

IMethod Interface
Members See Also Send Feedback
Defines the functionalities that are common to all representations of a method (MethodDefDeclaration, MethodRefDeclaration, MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethod : IMethodSignature,
    IEquatable<IMethodSignature>, IMember, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable, IGeneric, IEquatable<IMethod>,
    IWriteReflectionName

See Also

IMethod Members
PostSharp.Sdk.CodeModel Namespace


IMethod Members

[image]

PostSharp 2.0 Documentation
IMethod Members
IMethod Interface Methods Properties See Also Send Feedback

The IMethod type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position. (Inherited from IMethodSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature. (Inherited from IMethodSignature.)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature. (Inherited from IMethodSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethod | Translates the current method so that it is meaningful in another module than the one to which it primarily belong.
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethodSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CallingConvention | Gets the method calling convention. (Inherited from IMethodSignature.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity). (Inherited from IMethodSignature.)
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | ParameterCount | Gets the number of parameters. (Inherited from IMethodSignature.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ReturnType | Gets the return type. (Inherited from IMethodSignature.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IMethod Methods

[image]

PostSharp 2.0 Documentation
IMethod Methods
IMethod Interface See Also Send Feedback

The IMethod type exposes the following members.

Methods

 | Name | Description
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position. (Inherited from IMethodSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature. (Inherited from IMethodSignature.)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature. (Inherited from IMethodSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethod | Translates the current method so that it is meaningful in another module than the one to which it primarily belong.
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from IMethodSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

[image]

PostSharp 2.0 Documentation
IMethod..::..GetMethodDefinition Method
IMethod Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMethodDefinition()()() | Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.
Public method | GetMethodDefinition(BindingOptions) | Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

See Also

IMethod Interface
IMethod Members
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

IMethod..::..GetMethodDefinition Method
IMethod Interface See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodDefDeclaration GetMethodDefinition()

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

See Also

IMethod Interface
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method (BindingOptions)

IMethod..::..GetMethodDefinition Method (BindingOptions)
IMethod Interface See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodDefDeclaration GetMethodDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

See Also

IMethod Interface
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

IMethod..::..GetReflectionWrapper Method
IMethod Interface See Also Send Feedback
Gets a reflection MethodInfo that wraps the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodBase GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A MethodInfo wrapping current method in the given generic context.

Remarks

This method returns a MethodInfo that is different from the system runtime method that is retrieved by GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions). This allows a have a System.Reflection representation of the current method even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


GetSystemMethod Method

IMethod..::..GetSystemMethod Method
IMethod Interface See Also Send Feedback
Gets the system runtime method corresponding to the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodBase GetSystemMethod(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments,
    BindingOptions bindingOptions
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The system runtime MethodBase, or null if the current method could not be bound.

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

[image]

PostSharp 2.0 Documentation
IMethod..::..MatchesReference Method
IMethod Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchesReference(IMethod) | Determines whether the current method matches a given method reference.
Public method | MatchesReference(IMethodSignature) | Determines whether the current method signature matches a given method signature reference. (Inherited from IMethodSignature.)

See Also

IMethod Interface
IMethod Members
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethod)

IMethod..::..MatchesReference Method (IMethod)
IMethod Interface See Also Send Feedback
Determines whether the current method matches a given method reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool MatchesReference(
    IMethod reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethod
The method reference.

Return Value

true if the current method matches reference, otherwise false.

See Also

IMethod Interface
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


TranslateMethod Method

IMethod..::..TranslateMethod Method
IMethod Interface See Also Send Feedback
Translates the current method so that it is meaningful in another module than the one to which it primarily belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethod TranslateMethod(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the method signature should be translated.

Return Value

A method signature meaningful in the targetModule module.

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IMethod Properties

[image]

PostSharp 2.0 Documentation
IMethod Properties
IMethod Interface See Also Send Feedback

The IMethod type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CallingConvention | Gets the method calling convention. (Inherited from IMethodSignature.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type. (Inherited from IMember.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity). (Inherited from IMethodSignature.)
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static. (Inherited from IMember.)
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the method name. (Inherited from IMember.)
Public property | ParameterCount | Gets the number of parameters. (Inherited from IMethodSignature.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ReturnType | Gets the return type. (Inherited from IMethodSignature.)
Public property | Visibility | Gets the Visibility of the current member. (Inherited from IMember.)

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


Attributes Property

IMethod..::..Attributes Property
IMethod Interface See Also Send Feedback
Gets the attributes of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
MethodAttributes Attributes { get; }

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

IMethod..::..IsAbstract Property
IMethod Interface See Also Send Feedback
Determines whether the method is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsAbstract { get; }

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IsNew Property

IMethod..::..IsNew Property
IMethod Interface See Also Send Feedback
Determines whether the method takes a new slot.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsNew { get; }

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

IMethod..::..IsSealed Property
IMethod Interface See Also Send Feedback
Determines whether the method is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsSealed { get; }

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IsVirtual Property

IMethod..::..IsVirtual Property
IMethod Interface See Also Send Feedback
Determines whether the method is virtual.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsVirtual { get; }

See Also

IMethod Interface
PostSharp.Sdk.CodeModel Namespace


IMethodSignature Interface

IMethodSignature Interface
Members See Also Send Feedback
Exposes the semantics of a method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodSignature : IModuleElement,
    IEquatable<IMethodSignature>

See Also

IMethodSignature Members
PostSharp.Sdk.CodeModel Namespace


IMethodSignature Members

[image]

PostSharp 2.0 Documentation
IMethodSignature Members
IMethodSignature Interface Methods Properties See Also Send Feedback

The IMethodSignature type exposes the following members.

Methods

 | Name | Description
Public method | GetParameterType | Gets the type of a parameter given its position.
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Determines whether the current method signature matches a given method signature reference.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong.

Properties

 | Name | Description
Public property | CallingConvention | Gets the method calling convention.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | ParameterCount | Gets the number of parameters.
Public property | ReturnType | Gets the return type.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


IMethodSignature Methods

[image]

PostSharp 2.0 Documentation
IMethodSignature Methods
IMethodSignature Interface See Also Send Feedback

The IMethodSignature type exposes the following members.

Methods

 | Name | Description
Public method | GetParameterType | Gets the type of a parameter given its position.
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Determines whether the current method signature matches a given method signature reference.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateMethodSignature | Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetParameterType Method

IMethodSignature..::..GetParameterType Method
IMethodSignature Interface See Also Send Feedback
Gets the type of a parameter given its position.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature GetParameterType(
    int index
)

Parameters

index
Type: System..::.Int32
The parameter position.

Return Value

The type (TypeSignature) of the parameter.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

IMethodSignature..::..MapGenericArguments Method
IMethodSignature Interface See Also Send Feedback
Resolves all generic arguments in the current method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethodSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A method signature resolved against genericMap.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

IMethodSignature..::..MatchesReference Method
IMethodSignature Interface See Also Send Feedback
Determines whether the current method signature matches a given method signature reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool MatchesReference(
    IMethodSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature reference.

Return Value

true if the current method signature matches reference, otherwise false.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


ReferencesAnyGenericArgument Method

IMethodSignature..::..ReferencesAnyGenericArgument Method
IMethodSignature Interface See Also Send Feedback
Determines whether generic arguments are used in the current signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool ReferencesAnyGenericArgument()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.IMethodSignature.ReferencesAnyGenericArgument"]

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


TranslateMethodSignature Method

IMethodSignature..::..TranslateMethodSignature Method
IMethodSignature Interface See Also Send Feedback
Translates the current method signature so that it is meaningful in another module than the one to which it primarily belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethodSignature TranslateMethodSignature(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the method signature should be translated.

Return Value

A method signature meaningful in the targetModule module.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


IMethodSignature Properties

[image]

PostSharp 2.0 Documentation
IMethodSignature Properties
IMethodSignature Interface See Also Send Feedback

The IMethodSignature type exposes the following members.

Properties

 | Name | Description
Public property | CallingConvention | Gets the method calling convention.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity).
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | ParameterCount | Gets the number of parameters.
Public property | ReturnType | Gets the return type.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


CallingConvention Property

IMethodSignature..::..CallingConvention Property
IMethodSignature Interface See Also Send Feedback
Gets the method calling convention.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
CallingConvention CallingConvention { get; }

Field Value

The calling convention.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


GenericParameterCount Property

IMethodSignature..::..GenericParameterCount Property
IMethodSignature Interface See Also Send Feedback
Gets the number of generic parameters or arguments (i.e. the arity).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int GenericParameterCount { get; }

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


ParameterCount Property

IMethodSignature..::..ParameterCount Property
IMethodSignature Interface See Also Send Feedback
Gets the number of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int ParameterCount { get; }

Field Value

The number of parameters.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


ReturnType Property

IMethodSignature..::..ReturnType Property
IMethodSignature Interface See Also Send Feedback
Gets the return type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature ReturnType { get; }

Field Value

The return type.

See Also

IMethodSignature Interface
PostSharp.Sdk.CodeModel Namespace


IModule Interface

IModule Interface
Members See Also Send Feedback
Defines the functionalities that are common to all representations of a module (ModuleDeclaration, ModuleRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IModule

See Also

IModule Members
PostSharp.Sdk.CodeModel Namespace


IModule Members

[image]

PostSharp 2.0 Documentation
IModule Members
IModule Interface Properties See Also Send Feedback

The IModule type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the assembly containing the module.
Public property | Name | Gets the module name.

See Also

IModule Interface
PostSharp.Sdk.CodeModel Namespace


IModule Properties

[image]

PostSharp 2.0 Documentation
IModule Properties
IModule Interface See Also Send Feedback

The IModule type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the assembly containing the module.
Public property | Name | Gets the module name.

See Also

IModule Interface
PostSharp.Sdk.CodeModel Namespace


Assembly Property

IModule..::..Assembly Property
IModule Interface See Also Send Feedback
Gets the assembly containing the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAssembly Assembly { get; }

Field Value

The assembly (IAssembly) containing the module.

See Also

IModule Interface
PostSharp.Sdk.CodeModel Namespace


Name Property

IModule..::..Name Property
IModule Interface See Also Send Feedback
Gets the module name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string Name { get; }

Field Value

The module name.

See Also

IModule Interface
PostSharp.Sdk.CodeModel Namespace


IModuleElement Interface

IModuleElement Interface
Members See Also Send Feedback
Part of a ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IModuleElement

See Also

IModuleElement Members
PostSharp.Sdk.CodeModel Namespace


IModuleElement Members

[image]

PostSharp 2.0 Documentation
IModuleElement Members
IModuleElement Interface Methods Properties See Also Send Feedback

The IModuleElement type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current element so that it can be used in a given module.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | Module | Gets the declaring module.

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


IModuleElement Methods

[image]

PostSharp 2.0 Documentation
IModuleElement Methods
IModuleElement Interface See Also Send Feedback

The IModuleElement type exposes the following members.

Methods

 | Name | Description
Public method | Translate | Translates the current element so that it can be used in a given module.

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


Translate Method

IModuleElement..::..Translate Method
IModuleElement Interface See Also Send Feedback
Translates the current element so that it can be used in a given module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IModuleElement Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration into which the current element should be translated.

Return Value

An element equivalent to the current element, but expressed for targetModule.

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


IModuleElement Properties

[image]

PostSharp 2.0 Documentation
IModuleElement Properties
IModuleElement Interface See Also Send Feedback

The IModuleElement type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | Module | Gets the declaring module.

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

IModuleElement..::..DeclaringAssembly Property
IModuleElement Interface See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IAssembly DeclaringAssembly { get; }

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


Module Property

IModuleElement..::..Module Property
IModuleElement Interface See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ModuleDeclaration Module { get; }

See Also

IModuleElement Interface
PostSharp.Sdk.CodeModel Namespace


INamedType Interface

INamedType Interface
Members See Also Send Feedback
Defines the semantics of a type (IType) that can be named.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface INamedType : IType,
    ITypeSignature, IVisitable<ITypeSignature>, IGeneric, IEquatable<ITypeSignature>,
    IWriteReflectionName, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable, INamed

Remarks

The only named types are TypeDefDeclaration and TypeRefDeclaration.

See Also

INamedType Members
PostSharp.Sdk.CodeModel Namespace


INamedType Members

[image]

PostSharp 2.0 Documentation
INamedType Members
INamedType Interface Methods Properties See Also Send Feedback

The INamedType type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes. (Inherited from IType.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested. (Inherited from IType.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields. (Inherited from IType.)
Public property | IsAbstract | Determines whether the class is abstract. (Inherited from IType.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface. (Inherited from IType.)
Public property | IsSealed | Determines whether the type is sealed. (Inherited from IType.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods. (Inherited from IType.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the name of the current object. (Inherited from INamed.)
Public property | NestedTypes | Gets the collection of types nested in the current type.
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

INamedType Interface
PostSharp.Sdk.CodeModel Namespace


INamedType Methods

[image]

PostSharp 2.0 Documentation
INamedType Methods
INamedType Interface See Also Send Feedback

The INamedType type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

INamedType Interface
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
INamedType..::..GetTypeDefinition Method
INamedType Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from ITypeSignature.)

See Also

INamedType Interface
INamedType Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
INamedType..::..IsAssignableTo Method
INamedType Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from ITypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from ITypeSignature.)

See Also

INamedType Interface
INamedType Members
PostSharp.Sdk.CodeModel Namespace


INamedType Properties

[image]

PostSharp 2.0 Documentation
INamedType Properties
INamedType Interface See Also Send Feedback

The INamedType type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes. (Inherited from IType.)
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested. (Inherited from IType.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields. (Inherited from IType.)
Public property | IsAbstract | Determines whether the class is abstract. (Inherited from IType.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface. (Inherited from IType.)
Public property | IsSealed | Determines whether the type is sealed. (Inherited from IType.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods. (Inherited from IType.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Name | Gets the name of the current object. (Inherited from INamed.)
Public property | NestedTypes | Gets the collection of types nested in the current type.
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

INamedType Interface
PostSharp.Sdk.CodeModel Namespace


NestedTypes Property

INamedType..::..NestedTypes Property
INamedType Interface See Also Send Feedback
Gets the collection of types nested in the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
INamedTypeCollection NestedTypes { get; }

See Also

INamedType Interface
PostSharp.Sdk.CodeModel Namespace


Instruction Class

Instruction Class
Members See Also Send Feedback
Gives read-only access to the current instruction of an InstructionReader.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class Instruction

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Instruction

See Also

Instruction Members
PostSharp.Sdk.CodeModel Namespace


Instruction Members

[image]

PostSharp 2.0 Documentation
Instruction Members
Instruction Class Methods Properties See Also Send Feedback

The Instruction type exposes the following members.

Methods

 | Name | Description
Public method | GetLocalVariableSymbol | Gets the LocalVariableSymbol corresponding to a given ordinal in the current context.
Public method | GetOperand | Gets the typed (and eventually boxed) operand.
Public method | GetParameter | Gets a ParameterDeclaration given the index of the ldarg instruction.
Public method | GetSwitchOperandTarget | Gets a target of a switch operand given its index.
Public method | GetSwitchTargetsOperand |
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Write | Writes the current Instruction an an BaseInstructionWriter.

Properties

 | Name | Description
Public property | BranchTargetOperand | Gets the InstructionSequence operand of the current instruction.
Public property | ByteOperand | Gets the Byte operand of the current instruction.
Public property | ConstrainedType | Gets the operand of the constrained prefix of the current instruction.
Public property | DeclarationOperand | Gets the MetadataDeclaration operand for the current instruction.
Public property | DoubleOperand | Gets the Double operand of the current instruction.
Public property | FieldOperand | Gets the IField operand of the current instruction.
Public property | HasSymbolSequencePoint | Determines whether there is a SymbolSequencePoint before the current instruction.
Public property | InstructionPrefixes | Gets the combination of prefixes modifying the current instruction.
Public property | Int16Operand | Gets the Int16 operand of the current instruction.
Public property | Int32Operand | Gets the Int32 operand of the current instruction.
Public property | Int64Operand | Gets the Int64 operand of the current instruction.
Public property | LastSymbolSequencePoint | Gets the last symbol sequence point, which covers the current instruction.
Public property | LocalVariableOperand | Gets the LocalVariableSymbol operand of the current instruction.
Public property | MemberRefOperand | Gets the MemberRefDeclaration operand of the current instruction.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current instruction belong.
Public property | MethodOperand | Gets the IMethod operand of the current instruction.
Public property | Module | Gets the ModuleDeclaration to which the current instruction belong.
Public property | OpCodeNumber | Gets the OpCodeNumber of the current instruction.
Public property | OperandType | Gets the OperandType of the current instruction.
Public property | ParameterOperand | Gets the ParameterDeclaration operand of the current instruction.
Public property | SignatureOperand | Gets the StringOperand operand of the current instruction.
Public property | SingleOperand | Gets the Single operand of the current instruction.
Public property | StringOperand | Gets the StringOperand operand of the current instruction.
Public property | SwitchOperandTargetCount | Gets the number of targets in the switch operand.
Public property | SymbolSequencePoint | Gets the SymbolSequencePoint before the current instruction.
Public property | TypeOperand | Gets the IType operand of the current instruction.
Public property | UnalignedPrefix | Gets the value of the unaligned prefix.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Instruction Methods

[image]

PostSharp 2.0 Documentation
Instruction Methods
Instruction Class See Also Send Feedback

The Instruction type exposes the following members.

Methods

 | Name | Description
Public method | GetLocalVariableSymbol | Gets the LocalVariableSymbol corresponding to a given ordinal in the current context.
Public method | GetOperand | Gets the typed (and eventually boxed) operand.
Public method | GetParameter | Gets a ParameterDeclaration given the index of the ldarg instruction.
Public method | GetSwitchOperandTarget | Gets a target of a switch operand given its index.
Public method | GetSwitchTargetsOperand |
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Write | Writes the current Instruction an an BaseInstructionWriter.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


GetLocalVariableSymbol Method

Instruction..::..GetLocalVariableSymbol Method
Instruction Class See Also Send Feedback
Gets the LocalVariableSymbol corresponding to a given ordinal in the current context.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol GetLocalVariableSymbol(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
Ordinal.

Return Value

The LocalVariableSymbol corresponding to ordinal in the current context.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


GetOperand Method

Instruction..::..GetOperand Method
Instruction Class See Also Send Feedback
Gets the typed (and eventually boxed) operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetOperand()

Return Value

The typed operand of the current instruction, or null if the current instruction has no operand.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


GetParameter Method

Instruction..::..GetParameter Method
Instruction Class See Also Send Feedback
Gets a ParameterDeclaration given the index of the ldarg instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration GetParameter(
    int index
)

Parameters

index
Type: System..::.Int32
Parameter index. 0-based in static methods, 1-based in instant methods

Return Value

The ParameterDeclaration corresponding to index.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


GetSwitchOperandTarget Method

Instruction..::..GetSwitchOperandTarget Method
Instruction Class See Also Send Feedback
Gets a target of a switch operand given its index.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence GetSwitchOperandTarget(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the required target.

Return Value

The target InvalidOperationException whose position in the switch statement is index.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


GetSwitchTargetsOperand Method

Instruction..::..GetSwitchTargetsOperand Method
Instruction Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Instruction.GetSwitchTargetsOperand"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence[] GetSwitchTargetsOperand()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Instruction.GetSwitchTargetsOperand"]

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

Instruction..::..ToString Method
Instruction Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Write Method

Instruction..::..Write Method
Instruction Class See Also Send Feedback
Writes the current Instruction an an BaseInstructionWriter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    BaseInstructionWriter writer
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
An BaseInstructionWriter.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Instruction Properties

[image]

PostSharp 2.0 Documentation
Instruction Properties
Instruction Class See Also Send Feedback

The Instruction type exposes the following members.

Properties

 | Name | Description
Public property | BranchTargetOperand | Gets the InstructionSequence operand of the current instruction.
Public property | ByteOperand | Gets the Byte operand of the current instruction.
Public property | ConstrainedType | Gets the operand of the constrained prefix of the current instruction.
Public property | DeclarationOperand | Gets the MetadataDeclaration operand for the current instruction.
Public property | DoubleOperand | Gets the Double operand of the current instruction.
Public property | FieldOperand | Gets the IField operand of the current instruction.
Public property | HasSymbolSequencePoint | Determines whether there is a SymbolSequencePoint before the current instruction.
Public property | InstructionPrefixes | Gets the combination of prefixes modifying the current instruction.
Public property | Int16Operand | Gets the Int16 operand of the current instruction.
Public property | Int32Operand | Gets the Int32 operand of the current instruction.
Public property | Int64Operand | Gets the Int64 operand of the current instruction.
Public property | LastSymbolSequencePoint | Gets the last symbol sequence point, which covers the current instruction.
Public property | LocalVariableOperand | Gets the LocalVariableSymbol operand of the current instruction.
Public property | MemberRefOperand | Gets the MemberRefDeclaration operand of the current instruction.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current instruction belong.
Public property | MethodOperand | Gets the IMethod operand of the current instruction.
Public property | Module | Gets the ModuleDeclaration to which the current instruction belong.
Public property | OpCodeNumber | Gets the OpCodeNumber of the current instruction.
Public property | OperandType | Gets the OperandType of the current instruction.
Public property | ParameterOperand | Gets the ParameterDeclaration operand of the current instruction.
Public property | SignatureOperand | Gets the StringOperand operand of the current instruction.
Public property | SingleOperand | Gets the Single operand of the current instruction.
Public property | StringOperand | Gets the StringOperand operand of the current instruction.
Public property | SwitchOperandTargetCount | Gets the number of targets in the switch operand.
Public property | SymbolSequencePoint | Gets the SymbolSequencePoint before the current instruction.
Public property | TypeOperand | Gets the IType operand of the current instruction.
Public property | UnalignedPrefix | Gets the value of the unaligned prefix.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


BranchTargetOperand Property

Instruction..::..BranchTargetOperand Property
Instruction Class See Also Send Feedback
Gets the InstructionSequence operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence BranchTargetOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


ByteOperand Property

Instruction..::..ByteOperand Property
Instruction Class See Also Send Feedback
Gets the Byte operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte ByteOperand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


ConstrainedType Property

Instruction..::..ConstrainedType Property
Instruction Class See Also Send Feedback
Gets the operand of the constrained prefix of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ConstrainedType { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has no Constrained prefix.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


DeclarationOperand Property

Instruction..::..DeclarationOperand Property
Instruction Class See Also Send Feedback
Gets the MetadataDeclaration operand for the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration DeclarationOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


DoubleOperand Property

Instruction..::..DoubleOperand Property
Instruction Class See Also Send Feedback
Gets the Double operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public double DoubleOperand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


FieldOperand Property

Instruction..::..FieldOperand Property
Instruction Class See Also Send Feedback
Gets the IField operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField FieldOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


HasSymbolSequencePoint Property

Instruction..::..HasSymbolSequencePoint Property
Instruction Class See Also Send Feedback
Determines whether there is a SymbolSequencePoint before the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasSymbolSequencePoint { get; }

Field Value

true if there is a SymbolSequencePoint before the current instruction, otherwise false.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


InstructionPrefixes Property

Instruction..::..InstructionPrefixes Property
Instruction Class See Also Send Feedback
Gets the combination of prefixes modifying the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionPrefixes InstructionPrefixes { get; internal set; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Int16Operand Property

Instruction..::..Int16Operand Property
Instruction Class See Also Send Feedback
Gets the Int16 operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public short Int16Operand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Int32Operand Property

Instruction..::..Int32Operand Property
Instruction Class See Also Send Feedback
Gets the Int32 operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Int32Operand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Int64Operand Property

Instruction..::..Int64Operand Property
Instruction Class See Also Send Feedback
Gets the Int64 operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public long Int64Operand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


LastSymbolSequencePoint Property

Instruction..::..LastSymbolSequencePoint Property
Instruction Class See Also Send Feedback
Gets the last symbol sequence point, which covers the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymbolSequencePoint LastSymbolSequencePoint { get; internal set; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableOperand Property

Instruction..::..LocalVariableOperand Property
Instruction Class See Also Send Feedback
Gets the LocalVariableSymbol operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol LocalVariableOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


MemberRefOperand Property

Instruction..::..MemberRefOperand Property
Instruction Class See Also Send Feedback
Gets the MemberRefDeclaration operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberRefDeclaration MemberRefOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

Instruction..::..MethodBody Property
Instruction Class See Also Send Feedback
Gets the MethodBodyDeclaration to which the current instruction belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


MethodOperand Property

Instruction..::..MethodOperand Property
Instruction Class See Also Send Feedback
Gets the IMethod operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod MethodOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


Module Property

Instruction..::..Module Property
Instruction Class See Also Send Feedback
Gets the ModuleDeclaration to which the current instruction belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


OpCodeNumber Property

Instruction..::..OpCodeNumber Property
Instruction Class See Also Send Feedback
Gets the OpCodeNumber of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OpCodeNumber OpCodeNumber { get; internal set; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


OperandType Property

Instruction..::..OperandType Property
Instruction Class See Also Send Feedback
Gets the OperandType of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OperandType OperandType { get; }

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


ParameterOperand Property

Instruction..::..ParameterOperand Property
Instruction Class See Also Send Feedback
Gets the ParameterDeclaration operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration ParameterOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


SignatureOperand Property

Instruction..::..SignatureOperand Property
Instruction Class See Also Send Feedback
Gets the StringOperand operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneSignatureDeclaration SignatureOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


SingleOperand Property

Instruction..::..SingleOperand Property
Instruction Class See Also Send Feedback
Gets the Single operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public float SingleOperand { get; internal set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


StringOperand Property

Instruction..::..StringOperand Property
Instruction Class See Also Send Feedback
Gets the StringOperand operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LiteralString StringOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


SwitchOperandTargetCount Property

Instruction..::..SwitchOperandTargetCount Property
Instruction Class See Also Send Feedback
Gets the number of targets in the switch operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int SwitchOperandTargetCount { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


SymbolSequencePoint Property

Instruction..::..SymbolSequencePoint Property
Instruction Class See Also Send Feedback
Gets the SymbolSequencePoint before the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymbolSequencePoint SymbolSequencePoint { get; internal set; }

Field Value

A SymbolSequencePoint, or a null SymbolSequencePoint if there is no symbol sequence point at the current instruction.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


TypeOperand Property

Instruction..::..TypeOperand Property
Instruction Class See Also Send Feedback
Gets the IType operand of the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature TypeOperand { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current instruction has a different operand type.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


UnalignedPrefix Property

Instruction..::..UnalignedPrefix Property
Instruction Class See Also Send Feedback
Gets the value of the unaligned prefix.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int UnalignedPrefix { get; }

Field Value

The value 1, 2 or 4 if there is an unaligned prefix for the current instruction, otherwise 0.

See Also

Instruction Class
PostSharp.Sdk.CodeModel Namespace


InstructionAction Delegate

InstructionAction Delegate
See Also Send Feedback
Represents an action that performs an action on the current instruction of a specified InstructionReader.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate bool InstructionAction(
    InstructionReader reader
)

Parameters

reader
Type: PostSharp.Sdk.CodeModel..::.InstructionReader
An InstructionReader positioned at an instruction.

See Also

PostSharp.Sdk.CodeModel Namespace


InstructionBlock Class

InstructionBlock Class
Members See Also Send Feedback
A single node of the hierarchical structure of a method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionBlock : Element

Remarks

A method body (MethodBodyDeclaration) is represented as a tree of instruction blocks. Lexical scopes (definition of local variable symbols) and exception handlers are defined at InstructionBlock level. Instruction blocks may contain either children blocks, either instruction sequences (InstructionSequence). Independently, every InstructionBlock can contain exception handlers and local variable symbols.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.InstructionBlock

See Also

InstructionBlock Members
PostSharp.Sdk.CodeModel Namespace


InstructionBlock Members

[image]

PostSharp 2.0 Documentation
InstructionBlock Members
InstructionBlock Class Methods Properties See Also Send Feedback

The InstructionBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildBlock | Adds a child block.
Public method | AddExceptionHandlerCatch | Constructs an catch ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFault | Constructs a Fault ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFilter | Constructs a Filter ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFinally | Constructs a finally ExceptionHandler and add it to the current block.
Public method | AddInstructionSequence | Adds an InstructionSequence after a given sequence in the current the block.
Public method | AddLocalVariableSymbol | Adds a LocalVariableSymbol to the current InstructionBlock.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | DefineLocalVariable | Creates a new local variable in the current block.
Public method | Detach | Detaches the current block from its parent.
 | FindCommonAncestor | Finds the deepest common ancestor of two blocks in the method body tree.
Public method | FindFirstInstructionSequence | Finds the first InstructionSequence of the tree whose current InstructionBlock is the root.
Public method | GetChildrenEnumerator | Overloaded.
Public method | GetLocalVariableSymbol | Gets a LocalVariableSymbol given its position in the current block.
Public method | MoveInstructionBlock | Moves an InstructionBlock from another block into the current one.
Public method | MoveInstructionSequence | Adds an InstructionSequence after a given sequence in the current the block.
Public method | Nest | Overloaded.
Public method | SplitBlockAfterSequence | Splits the current InstructionBlock in two blocks after an InstructionSequence.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Comment | Gets or sets the comment associated to the current block.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FirstChildBlock | Gets the first child block.
Public property | FirstExceptionHandler | Gets the first exception handler protecting the current block.
Public property | FirstInstructionSequence | Gets the number first InstructionSequence of the current block.
Public property | HasChildrenBlocks | Determines whether the current block has children blocks.
Public property | HasExceptionHandlers | Determines whether the current block has exception handlers (ExceptionHandler).
Public property | HasInstructionSequences | Determines whether the current block has instruction sequences (InstructionSequence).
Public property | HasLocalVariableSymbols | Determines whether the current block has local variable symbols (LocalVariableSymbol).
Public property | IsExceptionHandler | Determines whether the current block is a direct child of an exception handler (i.e. is a handler or filter block).
Public property | IsProtected | Determines whether the current block is protected (directly or indirectly) by an exception handler.
Public property | LastChildBlock | Gets the last child block.
Public property | LastExceptionHandler | Gets the last exception handler protecting the current block.
Public property | LastInstructionSequence | Gets the number last InstructionSequence of the current block.
Public property | LocalVariableSymbolCount | Gets the number of local variable symbols (LocalVariableSymbol).
Public property | MethodBody | Gets the method body containing the current instruction block.
Public property | NextDeepBlock | Gets the next block in the method body tree, eventually with a different parent block.
Public property | NextSiblingBlock | Gets the next block with the same parent as the current block.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentBlock | Gets the parent block.
Public property | ParentExceptionHandler | Gets the parent exception handler.
Public property | PreviousDeepBlock | Gets the previous block in the method body tree, eventually with a different parent block.
Public property | PreviousSiblingBlock | Gets the previous block with the same parent as the current block.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Token | Gets the instruction sequence token.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


InstructionBlock Methods

[image]

PostSharp 2.0 Documentation
InstructionBlock Methods
InstructionBlock Class See Also Send Feedback

The InstructionBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildBlock | Adds a child block.
Public method | AddExceptionHandlerCatch | Constructs an catch ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFault | Constructs a Fault ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFilter | Constructs a Filter ExceptionHandler and add it to the current block.
Public method | AddExceptionHandlerFinally | Constructs a finally ExceptionHandler and add it to the current block.
Public method | AddInstructionSequence | Adds an InstructionSequence after a given sequence in the current the block.
Public method | AddLocalVariableSymbol | Adds a LocalVariableSymbol to the current InstructionBlock.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | DefineLocalVariable | Creates a new local variable in the current block.
Public method | Detach | Detaches the current block from its parent.
 | FindCommonAncestor | Finds the deepest common ancestor of two blocks in the method body tree.
Public method | FindFirstInstructionSequence | Finds the first InstructionSequence of the tree whose current InstructionBlock is the root.
Public method | GetChildrenEnumerator | Overloaded.
Public method | GetLocalVariableSymbol | Gets a LocalVariableSymbol given its position in the current block.
Public method | MoveInstructionBlock | Moves an InstructionBlock from another block into the current one.
Public method | MoveInstructionSequence | Adds an InstructionSequence after a given sequence in the current the block.
Public method | Nest | Overloaded.
Public method | SplitBlockAfterSequence | Splits the current InstructionBlock in two blocks after an InstructionSequence.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddChildBlock Method

InstructionBlock..::..AddChildBlock Method
InstructionBlock Class See Also Send Feedback
Adds a child block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock AddChildBlock(
    InstructionBlock newBlock,
    NodePosition position,
    InstructionBlock referenceBlock
)

Parameters

newBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Block to insert.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Relative position of the new block w.r.t. referenceBlock.
referenceBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Block after or before which newBlock has to be inserted, or null if the new block has to be inserted at the first or the last.

Return Value

The InstructionBlock passed in the newBlock parameter, or the newly created InstructionBlock if newBlock was null.

Exceptions

Exception | Condition
System..::.ArgumentException | The newBlock instruction block is already attached.
System..::.InvalidOperationException | The current block is detached or has no parent block.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddExceptionHandlerCatch Method

InstructionBlock..::..AddExceptionHandlerCatch Method
InstructionBlock Class See Also Send Feedback
Constructs an catch ExceptionHandler and add it to the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler AddExceptionHandlerCatch(
    ITypeSignature catchType,
    InstructionBlock handlerBlock,
    NodePosition position,
    ExceptionHandler referenceHandler
)

Parameters

catchType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type caught.
handlerBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Handler block.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new ExceptionHandler w.r.t. referenceHandler.
referenceHandler
Type: PostSharp.Sdk.CodeModel..::.ExceptionHandler
Handler before or after which the new handler has to be inserted, or null if the new handler has to be the first or the last.

Return Value

The new ExceptionHandler.

Exceptions

Exception | Condition
System..::.ArgumentNullException | handlerBlock is null.
System..::.ArgumentNullException | catchType is null.
System..::.InvalidOperationException | The current block is detached or is the root.
System..::.ArgumentException | handlerBlock is attached.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddExceptionHandlerFault Method

InstructionBlock..::..AddExceptionHandlerFault Method
InstructionBlock Class See Also Send Feedback
Constructs a Fault ExceptionHandler and add it to the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler AddExceptionHandlerFault(
    InstructionBlock handlerBlock,
    NodePosition position,
    ExceptionHandler referenceHandler
)

Parameters

handlerBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Handler block.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new ExceptionHandler w.r.t. referenceHandler.
referenceHandler
Type: PostSharp.Sdk.CodeModel..::.ExceptionHandler
Handler before or after which the new handler has to be inserted, or null if the new handler has to be the first or the last.

Return Value

The new ExceptionHandler.

Exceptions

Exception | Condition
System..::.ArgumentNullException | handlerBlock is null.
System..::.InvalidOperationException | The current block is detached or is the root.
System..::.ArgumentException | handlerBlock is attached.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddExceptionHandlerFilter Method

InstructionBlock..::..AddExceptionHandlerFilter Method
InstructionBlock Class See Also Send Feedback
Constructs a Filter ExceptionHandler and add it to the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler AddExceptionHandlerFilter(
    InstructionBlock handlerBlock,
    InstructionBlock filterBlock,
    NodePosition position,
    ExceptionHandler referenceHandler
)

Parameters

handlerBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Handler block.
filterBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Filter block.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new ExceptionHandler w.r.t. referenceHandler.
referenceHandler
Type: PostSharp.Sdk.CodeModel..::.ExceptionHandler
Handler before or after which the new handler has to be inserted, or null if the new handler has to be the first or the last.

Return Value

The new ExceptionHandler.

Exceptions

Exception | Condition
System..::.ArgumentNullException | handlerBlock is null.
System..::.ArgumentNullException | filterBlock is null.
System..::.InvalidOperationException | The current block is detached or is the root.
System..::.ArgumentException | handlerBlock is attached.
System..::.ArgumentException | filterBlock is attached.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddExceptionHandlerFinally Method

InstructionBlock..::..AddExceptionHandlerFinally Method
InstructionBlock Class See Also Send Feedback
Constructs a finally ExceptionHandler and add it to the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler AddExceptionHandlerFinally(
    InstructionBlock handlerBlock,
    NodePosition position,
    ExceptionHandler referenceHandler
)

Parameters

handlerBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Handler block.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new ExceptionHandler w.r.t. referenceHandler.
referenceHandler
Type: PostSharp.Sdk.CodeModel..::.ExceptionHandler
Handler before or after which the new handler has to be inserted, or null if the new handler has to be the first or the last.

Return Value

The new ExceptionHandler.

Exceptions

Exception | Condition
System..::.ArgumentNullException | handlerBlock is null.
System..::.InvalidOperationException | The current block is detached or is the root.
System..::.ArgumentException | handlerBlock is attached.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddInstructionSequence Method

InstructionBlock..::..AddInstructionSequence Method
InstructionBlock Class See Also Send Feedback
Adds an InstructionSequence after a given sequence in the current the block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence AddInstructionSequence(
    InstructionSequence newSequence,
    NodePosition position,
    InstructionSequence referenceSequence
)

Parameters

newSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
A detached InstructionSequence, or null if a new InstructionSequence should be created.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new InstructionSequence w.r.t. referenceSequence.
referenceSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
Sequence before or after which newSequence has to be inserted, or null if newSequencehas to be the first or the last.

Return Value

The InstructionSequence passed in the newSequence parameter, or the newly created InstructionSequence if newSequence was null.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


AddLocalVariableSymbol Method

InstructionBlock..::..AddLocalVariableSymbol Method
InstructionBlock Class See Also Send Feedback
Adds a LocalVariableSymbol to the current InstructionBlock.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddLocalVariableSymbol(
    LocalVariableSymbol symbol
)

Parameters

symbol
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
A LocalVariableSymbol.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


DefineLocalVariable Method

InstructionBlock..::..DefineLocalVariable Method
InstructionBlock Class See Also Send Feedback
Creates a new local variable in the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol DefineLocalVariable(
    ITypeSignature type,
    string name
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Variable type.
name
Type: System..::.String
Variable name, or null if the local variable is anonymous. The variable name may contain the placeholder {0}. It will be replaced by the local variable ordinal at runtime (useful to create unique names).

Return Value

The LocalVariableSymbol referencing the new local variable.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


Detach Method

InstructionBlock..::..Detach Method
InstructionBlock Class See Also Send Feedback
Detaches the current block from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Detach()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The instruction block has neither parent InstructionBlock neither parent MethodBodyDeclaration.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


FindCommonAncestor Method

InstructionBlock..::..FindCommonAncestor Method
InstructionBlock Class See Also Send Feedback
Finds the deepest common ancestor of two blocks in the method body tree.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static InstructionBlock FindCommonAncestor(
    InstructionBlock first,
    InstructionBlock second
)

Parameters

first
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
An InstructionBlock.
second
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
An InstructionBlock.

Return Value

An InstructionBlock, or null if no common ancestor was found.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


FindFirstInstructionSequence Method

InstructionBlock..::..FindFirstInstructionSequence Method
InstructionBlock Class See Also Send Feedback
Finds the first InstructionSequence of the tree whose current InstructionBlock is the root.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence FindFirstInstructionSequence()

Return Value

An InstructionSequence, or null if the block do not contain any InstructionSequence.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


GetChildrenEnumerator Method

[image]

PostSharp 2.0 Documentation
InstructionBlock..::..GetChildrenEnumerator Method
InstructionBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildrenEnumerator()()() | Gets an enumerator to enumerate children blocks
Public method | GetChildrenEnumerator(Boolean) | Gets an enumerator to enumerate children blocks and allow to enumerate them children of children recursively.

See Also

InstructionBlock Class
InstructionBlock Members
PostSharp.Sdk.CodeModel Namespace


GetChildrenEnumerator Method

InstructionBlock..::..GetChildrenEnumerator Method
InstructionBlock Class See Also Send Feedback
Gets an enumerator to enumerate children blocks

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<InstructionBlock> GetChildrenEnumerator()

Return Value

An IEnumerator<(Of <(T>)>).

Remarks

For performance reason, it is better to enumerate the children blocks using the linked list formed by the FirstChildBlock and NextSiblingBlock properties.

See Also

InstructionBlock Class
GetChildrenEnumerator Overload
PostSharp.Sdk.CodeModel Namespace


GetChildrenEnumerator Method (Boolean)

InstructionBlock..::..GetChildrenEnumerator Method (Boolean)
InstructionBlock Class See Also Send Feedback
Gets an enumerator to enumerate children blocks and allow to enumerate them children of children recursively.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<InstructionBlock> GetChildrenEnumerator(
    bool deep
)

Parameters

deep
Type: System..::.Boolean
true if children have to be enumerated recursively, otherwise false.

Return Value

An IEnumerator<(Of <(T>)>).

See Also

InstructionBlock Class
GetChildrenEnumerator Overload
PostSharp.Sdk.CodeModel Namespace


GetLocalVariableSymbol Method

InstructionBlock..::..GetLocalVariableSymbol Method
InstructionBlock Class See Also Send Feedback
Gets a LocalVariableSymbol given its position in the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol GetLocalVariableSymbol(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the required symbol in the collection of symbols of the current block. This is not the ordinal of the local variable to which it refers.

Return Value

The LocalVariableSymbol at position index.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


MoveInstructionBlock Method

InstructionBlock..::..MoveInstructionBlock Method
InstructionBlock Class See Also Send Feedback
Moves an InstructionBlock from another block into the current one.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MoveInstructionBlock(
    InstructionBlock movedBlock,
    NodePosition position,
    InstructionBlock referenceBlock
)

Parameters

movedBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Block to be moved.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Relative position of the new block w.r.t. referenceBlock.
referenceBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Block after or before which movedBlock has to be inserted, or null if the new block has to be inserted at the first or the last.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


MoveInstructionSequence Method

InstructionBlock..::..MoveInstructionSequence Method
InstructionBlock Class See Also Send Feedback
Adds an InstructionSequence after a given sequence in the current the block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MoveInstructionSequence(
    InstructionSequence newSequence,
    NodePosition position,
    InstructionSequence referenceSequence
)

Parameters

newSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
A detached InstructionSequence.
position
Type: PostSharp.Sdk.Collections..::.NodePosition
Position of the new InstructionSequence w.r.t. referenceSequence.
referenceSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
Sequence before or after which newSequence has to be inserted, or null if newSequencehas to be the first or the last.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


Nest Method

[image]

PostSharp 2.0 Documentation
InstructionBlock..::..Nest Method
InstructionBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Nest()()() | Inserts a new InstructionBlock between the current block and its parent.
Public method | Nest(Boolean) | Inserts a new InstructionBlock between the current block and its parent.

See Also

InstructionBlock Class
InstructionBlock Members
PostSharp.Sdk.CodeModel Namespace


Nest Method

InstructionBlock..::..Nest Method
InstructionBlock Class See Also Send Feedback
Inserts a new InstructionBlock between the current block and its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock Nest()

Return Value

The new InstructionBlock.

See Also

InstructionBlock Class
Nest Overload
PostSharp.Sdk.CodeModel Namespace


Nest Method (Boolean)

InstructionBlock..::..Nest Method (Boolean)
InstructionBlock Class See Also Send Feedback
Inserts a new InstructionBlock between the current block and its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock Nest(
    bool moveLocalVariableSymbols
)

Parameters

moveLocalVariableSymbols
Type: System..::.Boolean

[Missing <param name="moveLocalVariableSymbols"/> documentation for "M:PostSharp.Sdk.CodeModel.InstructionBlock.Nest(System.Boolean)"]

Return Value

The new InstructionBlock.

See Also

InstructionBlock Class
Nest Overload
PostSharp.Sdk.CodeModel Namespace


SplitBlockAfterSequence Method

InstructionBlock..::..SplitBlockAfterSequence Method
InstructionBlock Class See Also Send Feedback
Splits the current InstructionBlock in two blocks after an InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock SplitBlockAfterSequence(
    InstructionSequence sequence
)

Parameters

sequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
An InstructionSequence belonging to the current InstructionBlock.

Return Value

A new InstructionBlock containing the second part of the split block.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The sequence argument is null.
System..::.ArgumentException | The sequence does not belong to the current InstructionBlock.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

InstructionBlock..::..ToString Method
InstructionBlock Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


InstructionBlock Properties

[image]

PostSharp 2.0 Documentation
InstructionBlock Properties
InstructionBlock Class See Also Send Feedback

The InstructionBlock type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets or sets the comment associated to the current block.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FirstChildBlock | Gets the first child block.
Public property | FirstExceptionHandler | Gets the first exception handler protecting the current block.
Public property | FirstInstructionSequence | Gets the number first InstructionSequence of the current block.
Public property | HasChildrenBlocks | Determines whether the current block has children blocks.
Public property | HasExceptionHandlers | Determines whether the current block has exception handlers (ExceptionHandler).
Public property | HasInstructionSequences | Determines whether the current block has instruction sequences (InstructionSequence).
Public property | HasLocalVariableSymbols | Determines whether the current block has local variable symbols (LocalVariableSymbol).
Public property | IsExceptionHandler | Determines whether the current block is a direct child of an exception handler (i.e. is a handler or filter block).
Public property | IsProtected | Determines whether the current block is protected (directly or indirectly) by an exception handler.
Public property | LastChildBlock | Gets the last child block.
Public property | LastExceptionHandler | Gets the last exception handler protecting the current block.
Public property | LastInstructionSequence | Gets the number last InstructionSequence of the current block.
Public property | LocalVariableSymbolCount | Gets the number of local variable symbols (LocalVariableSymbol).
Public property | MethodBody | Gets the method body containing the current instruction block.
Public property | NextDeepBlock | Gets the next block in the method body tree, eventually with a different parent block.
Public property | NextSiblingBlock | Gets the next block with the same parent as the current block.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentBlock | Gets the parent block.
Public property | ParentExceptionHandler | Gets the parent exception handler.
Public property | PreviousDeepBlock | Gets the previous block in the method body tree, eventually with a different parent block.
Public property | PreviousSiblingBlock | Gets the previous block with the same parent as the current block.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Token | Gets the instruction sequence token.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


Comment Property

InstructionBlock..::..Comment Property
InstructionBlock Class See Also Send Feedback
Gets or sets the comment associated to the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Comment { get; set; }

Remarks

This comment is a purely informative string that will be rendered into the MSIL code. It should be used for diagnostics only.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


FirstChildBlock Property

InstructionBlock..::..FirstChildBlock Property
InstructionBlock Class See Also Send Feedback
Gets the first child block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock FirstChildBlock { get; }

Field Value

The first child block, or null if the current block has no child.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


FirstExceptionHandler Property

InstructionBlock..::..FirstExceptionHandler Property
InstructionBlock Class See Also Send Feedback
Gets the first exception handler protecting the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler FirstExceptionHandler { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


FirstInstructionSequence Property

InstructionBlock..::..FirstInstructionSequence Property
InstructionBlock Class See Also Send Feedback
Gets the number first InstructionSequence of the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence FirstInstructionSequence { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


HasChildrenBlocks Property

InstructionBlock..::..HasChildrenBlocks Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block has children blocks.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasChildrenBlocks { get; }

Field Value

true if the current block has at least one children block, otherwise false.

Remarks

A block may have either children blocks either instruction sequences.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


HasExceptionHandlers Property

InstructionBlock..::..HasExceptionHandlers Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block has exception handlers (ExceptionHandler).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasExceptionHandlers { get; }

Field Value

true if the current block has at least one exception handler, otherwise false.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


HasInstructionSequences Property

InstructionBlock..::..HasInstructionSequences Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block has instruction sequences (InstructionSequence).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasInstructionSequences { get; }

Field Value

true if the current block has at least one instruction sequence, otherwise false.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


HasLocalVariableSymbols Property

InstructionBlock..::..HasLocalVariableSymbols Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block has local variable symbols (LocalVariableSymbol).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasLocalVariableSymbols { get; }

Field Value

true if the current block has at least one local variable symbol, otherwise false.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


IsExceptionHandler Property

InstructionBlock..::..IsExceptionHandler Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block is a direct child of an exception handler (i.e. is a handler or filter block).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsExceptionHandler { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


IsProtected Property

InstructionBlock..::..IsProtected Property
InstructionBlock Class See Also Send Feedback
Determines whether the current block is protected (directly or indirectly) by an exception handler.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsProtected { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


LastChildBlock Property

InstructionBlock..::..LastChildBlock Property
InstructionBlock Class See Also Send Feedback
Gets the last child block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock LastChildBlock { get; }

Field Value

The last child block, or null if the current block has no child.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


LastExceptionHandler Property

InstructionBlock..::..LastExceptionHandler Property
InstructionBlock Class See Also Send Feedback
Gets the last exception handler protecting the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler LastExceptionHandler { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


LastInstructionSequence Property

InstructionBlock..::..LastInstructionSequence Property
InstructionBlock Class See Also Send Feedback
Gets the number last InstructionSequence of the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence LastInstructionSequence { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableSymbolCount Property

InstructionBlock..::..LocalVariableSymbolCount Property
InstructionBlock Class See Also Send Feedback
Gets the number of local variable symbols (LocalVariableSymbol).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int LocalVariableSymbolCount { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

InstructionBlock..::..MethodBody Property
InstructionBlock Class See Also Send Feedback
Gets the method body containing the current instruction block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; }

Field Value

The method body (MethodBodyDeclaration) containing this block, or null if the current block is not attached to any method body.

Remarks

Consider caching the result of the current method since its implementation is recursive.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


NextDeepBlock Property

InstructionBlock..::..NextDeepBlock Property
InstructionBlock Class See Also Send Feedback
Gets the next block in the method body tree, eventually with a different parent block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock NextDeepBlock { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


NextSiblingBlock Property

InstructionBlock..::..NextSiblingBlock Property
InstructionBlock Class See Also Send Feedback
Gets the next block with the same parent as the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock NextSiblingBlock { get; }

Field Value

The child of the parent of the current block that is just next to the current block, or null if the current node is detached or has no is the last child of its parent.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


ParentBlock Property

InstructionBlock..::..ParentBlock Property
InstructionBlock Class See Also Send Feedback
Gets the parent block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock ParentBlock { get; }

Field Value

The parent block, or null if (a) the current block is the root block, or (b) has simply no parent.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


ParentExceptionHandler Property

InstructionBlock..::..ParentExceptionHandler Property
InstructionBlock Class See Also Send Feedback
Gets the parent exception handler.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler ParentExceptionHandler { get; internal set; }

Field Value

An ExceptionHandler, or null if the current block is not a direct child of an exception handler.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


PreviousDeepBlock Property

InstructionBlock..::..PreviousDeepBlock Property
InstructionBlock Class See Also Send Feedback
Gets the previous block in the method body tree, eventually with a different parent block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock PreviousDeepBlock { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


PreviousSiblingBlock Property

InstructionBlock..::..PreviousSiblingBlock Property
InstructionBlock Class See Also Send Feedback
Gets the previous block with the same parent as the current block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock PreviousSiblingBlock { get; }

Field Value

The child of the parent of the current block that is just previous to the current block, or null if the current node is detached or has no is the first child of its parent.

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


Token Property

InstructionBlock..::..Token Property
InstructionBlock Class See Also Send Feedback
Gets the instruction sequence token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public short Token { get; }

See Also

InstructionBlock Class
PostSharp.Sdk.CodeModel Namespace


InstructionPrefixes Enumeration

InstructionPrefixes Enumeration
See Also Send Feedback
Enumeration of IL prefixes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum InstructionPrefixes

Members

Member name | Value | Description
None | 0 | No prefix.
Unaligned1 | 1 | Indicates that a pointer instruction might be unaligned to the natural size of the following instruction operand. The runtime should assume that the pointer instruction is aligned at byte boundary.
Unaligned2 | 2 | Indicates that a pointer instruction might be unaligned to the natural size of the following instruction operand. The runtime should assume that the pointer instruction is aligned at 2 bytes boundary.
Unaligned4 | 3 | Indicates that a pointer instruction might be unaligned to the natural size of the following instruction operand. The runtime should assume that the pointer instruction is aligned at 4 bytes boundary.
UnalignedMask | 3 | Masks isolating the unaligned prefixes.
Volatile | 4 | Indicates that the content of the read location is volatile and cannot be cached for later access.
Tail | 8 | Indicates that the method could be terminated after the next call instruction.
Constrained | 16 | Indicates that the virtual call of the next instruction is constrained to a given type.
ReadOnly | 32 | Tndicates that the subsequent array address operation performs no type check at runtime, and that it returns a controlled-mutability managed pointer

See Also

PostSharp.Sdk.CodeModel Namespace


InstructionReader Class

InstructionReader Class
Members See Also Send Feedback
Reads a stream of binary IL instructions and debugging sequence points.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionReader : IDisposable

Remarks

Each InstructionReader instance is assigned to a single method. Developers must use the CreateInstructionReader()()() method to get an InstructionReader instance.

When you want to read an instruction block, you first need to enter it using the EnterInstructionBlock(InstructionBlock) method. The EnterInstructionBlock(InstructionBlock) method expect that the active block of the InstructionReader is the parent of the block you want to enter, so you have to enter all ascendant blocks, from the root to the leave, like in a stack model. Then you attach the reader to a sequence using EnterInstructionSequence(InstructionSequence). To read another sequence, you need first to use LeaveInstructionSequence()()(), then again EnterInstructionSequence(InstructionSequence). Use LeaveInstructionBlock()()() to leave a block.

If you want to enter a specific block without entering all its ancestors, use the JumpToInstructionBlock(InstructionBlock) method, which will make the proper calls to LeaveInstructionBlock()()() and EnterInstructionBlock(InstructionBlock) automatically.

When the InstructionReader has entered an InstructionSequence, you can use it as a classic reader. The ReadInstruction()()() reads the next instruction and you can read it on the instance properties of the InstructionReader.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.InstructionReader

See Also

InstructionReader Members
PostSharp.Sdk.CodeModel Namespace


InstructionReader Members

[image]

PostSharp 2.0 Documentation
InstructionReader Members
InstructionReader Class Methods Properties See Also Send Feedback

The InstructionReader type exposes the following members.

Methods

 | Name | Description
Public method | CreateBookmark | Creates a bookmark, thanks to which the current InstructionReader can move forward and then return to the current location.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnterInstructionBlock | Enters an InstructionBlock.
Public method | EnterInstructionSequence | Enters an InstructionSequence.
Public method | GetLocalVariableSymbol | Overloaded.
Public method | GoToBookmark | Moves the current InstructionReader to a given bookmark.
Public method | JumpToInstructionBlock | Prepares the current InstructionReader so that it can read a specific block, without assumption on the current state of the InstructionReader.
Public method | LeaveInstructionBlock | Leaves the active InstructionBlock, and sets the position of the current InstructionReader to the parent block of the active block.
Public method | LeaveInstructionSequence | Leaves the active InstructionSequence, and sets the position of the current InstructionReader to the parent block of the active sequence.
Public method | ReadInstruction | Reads the next instruction of the active InstructionSequence.

Properties

 | Name | Description
Public property | CurrentInstruction | Gets the current instruction.
Public property | CurrentInstructionBlock | Gets the InstructionBlock on which the current InstructionReader is positioned.
Public property | CurrentInstructionSequence | Gets the InstructionSequence on which the current InstructionReader is positioned.
Public property | IsAtEnfOfSequence | Determines whether the current instruction is the last of the sequence.
Public property | IsSymbolResolutionEnabled | Determines whether resolution of local variable symbols is enabled for the current reader.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current InstructionReader is assigned.
Public property | Module | Gets the module to which this InstructionReader is associates.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


InstructionReader Methods

[image]

PostSharp 2.0 Documentation
InstructionReader Methods
InstructionReader Class See Also Send Feedback

The InstructionReader type exposes the following members.

Methods

 | Name | Description
Public method | CreateBookmark | Creates a bookmark, thanks to which the current InstructionReader can move forward and then return to the current location.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnterInstructionBlock | Enters an InstructionBlock.
Public method | EnterInstructionSequence | Enters an InstructionSequence.
Public method | GetLocalVariableSymbol | Overloaded.
Public method | GoToBookmark | Moves the current InstructionReader to a given bookmark.
Public method | JumpToInstructionBlock | Prepares the current InstructionReader so that it can read a specific block, without assumption on the current state of the InstructionReader.
Public method | LeaveInstructionBlock | Leaves the active InstructionBlock, and sets the position of the current InstructionReader to the parent block of the active block.
Public method | LeaveInstructionSequence | Leaves the active InstructionSequence, and sets the position of the current InstructionReader to the parent block of the active sequence.
Public method | ReadInstruction | Reads the next instruction of the active InstructionSequence.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


CreateBookmark Method

InstructionReader..::..CreateBookmark Method
InstructionReader Class See Also Send Feedback
Creates a bookmark, thanks to which the current InstructionReader can move forward and then return to the current location.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionReaderBookmark CreateBookmark()

Return Value

A bookmark for the current location.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

InstructionReader..::..Dispose Method
InstructionReader Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


EnterInstructionBlock Method

InstructionReader..::..EnterInstructionBlock Method
InstructionReader Class See Also Send Feedback
Enters an InstructionBlock.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnterInstructionBlock(
    InstructionBlock block
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock to open.

Remarks

Prepares the current InstructionReader so that it can read a specific InstructionBlock, with the assumption that the InstructionReader is in the parent of the block to open.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current InstructionReader is currently at an invalid position. It should be open on the parent of block.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


EnterInstructionSequence Method

InstructionReader..::..EnterInstructionSequence Method
InstructionReader Class See Also Send Feedback
Enters an InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnterInstructionSequence(
    InstructionSequence sequence
)

Parameters

sequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The InstructionSequence to open.

Remarks

Prepares the current InstructionReader so that it can read a specific InstructionSequence, with the assumption that the InstructionReader is in the parent of the sequence to open.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current InstructionReader is currently at an invalid position. It should be open on the parent block of sequence.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


GetLocalVariableSymbol Method

[image]

PostSharp 2.0 Documentation
InstructionReader..::..GetLocalVariableSymbol Method
InstructionReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLocalVariableSymbol(Int32) | Gets the LocalVariableSymbol associated to a given ordinal in the current context.
Public method | GetLocalVariableSymbol(Int32, Boolean) | Gets the LocalVariableSymbol of a local variable given its ordinal and optionally creates default symbol is no symbol is associated to the given ordinal in the current context.

See Also

InstructionReader Class
InstructionReader Members
PostSharp.Sdk.CodeModel Namespace


GetLocalVariableSymbol Method (Int32)

InstructionReader..::..GetLocalVariableSymbol Method (Int32)
InstructionReader Class See Also Send Feedback
Gets the LocalVariableSymbol associated to a given ordinal in the current context.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol GetLocalVariableSymbol(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The ordinal.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.InstructionReader.GetLocalVariableSymbol(System.Int32)"]

See Also

InstructionReader Class
GetLocalVariableSymbol Overload
PostSharp.Sdk.CodeModel Namespace


GetLocalVariableSymbol Method (Int32, Boolean)

InstructionReader..::..GetLocalVariableSymbol Method (Int32, Boolean)
InstructionReader Class See Also Send Feedback
Gets the LocalVariableSymbol of a local variable given its ordinal and optionally creates default symbol is no symbol is associated to the given ordinal in the current context.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol GetLocalVariableSymbol(
    int ordinal,
    bool createDefault
)

Parameters

ordinal
Type: System..::.Int32
The ordinal.
createDefault
Type: System..::.Boolean
Determines whether a default LocalVariableSymbol should be created is none is associated to the given ordinal in the current context.

Return Value

The LocalVariableSymbol of the local variable at position ordinal, or null if no symbol is associated to the given ordinal in the current context and the createDefault parameter is false.

See Also

InstructionReader Class
GetLocalVariableSymbol Overload
PostSharp.Sdk.CodeModel Namespace


GoToBookmark Method

InstructionReader..::..GoToBookmark Method
InstructionReader Class See Also Send Feedback
Moves the current InstructionReader to a given bookmark.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void GoToBookmark(
    InstructionReaderBookmark bookmark
)

Parameters

bookmark
Type: PostSharp.Sdk.CodeModel..::.InstructionReaderBookmark
A bookmark that was created for the current InstructionReader and for the InstructionSequence into which the bookmark was created.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


JumpToInstructionBlock Method

InstructionReader..::..JumpToInstructionBlock Method
InstructionReader Class See Also Send Feedback
Prepares the current InstructionReader so that it can read a specific block, without assumption on the current state of the InstructionReader.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void JumpToInstructionBlock(
    InstructionBlock block
)

Parameters

block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The target InstructionBlock.

Remarks

For better performances, use EnterInstructionBlock(InstructionBlock) and LeaveInstructionBlock()()().

Exceptions

Exception | Condition
System..::.ArgumentException | The target instruction block do not belong to the method body to which the current InstructionReader is attached.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


LeaveInstructionBlock Method

InstructionReader..::..LeaveInstructionBlock Method
InstructionReader Class See Also Send Feedback
Leaves the active InstructionBlock, and sets the position of the current InstructionReader to the parent block of the active block.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void LeaveInstructionBlock()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current InstructionReader is not positioned in an InstructionBlock.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


LeaveInstructionSequence Method

InstructionReader..::..LeaveInstructionSequence Method
InstructionReader Class See Also Send Feedback
Leaves the active InstructionSequence, and sets the position of the current InstructionReader to the parent block of the active sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void LeaveInstructionSequence()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current InstructionReader is not positioned in an InstructionSequence.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


ReadInstruction Method

InstructionReader..::..ReadInstruction Method
InstructionReader Class See Also Send Feedback
Reads the next instruction of the active InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ReadInstruction()

Return Value

true if some instruction could be read, or false if the end of the instruction sequence was reached.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The current InstructionReader is not positioned in an InstructionSequence.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


InstructionReader Properties

[image]

PostSharp 2.0 Documentation
InstructionReader Properties
InstructionReader Class See Also Send Feedback

The InstructionReader type exposes the following members.

Properties

 | Name | Description
Public property | CurrentInstruction | Gets the current instruction.
Public property | CurrentInstructionBlock | Gets the InstructionBlock on which the current InstructionReader is positioned.
Public property | CurrentInstructionSequence | Gets the InstructionSequence on which the current InstructionReader is positioned.
Public property | IsAtEnfOfSequence | Determines whether the current instruction is the last of the sequence.
Public property | IsSymbolResolutionEnabled | Determines whether resolution of local variable symbols is enabled for the current reader.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current InstructionReader is assigned.
Public property | Module | Gets the module to which this InstructionReader is associates.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


CurrentInstruction Property

InstructionReader..::..CurrentInstruction Property
InstructionReader Class See Also Send Feedback
Gets the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Instruction CurrentInstruction { get; }

Remarks

You always get the same instance of the Instruction class, so it is useless to "store" it somewhere for later use. Once the cursor has moved, the returned instance will be modified.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


CurrentInstructionBlock Property

InstructionReader..::..CurrentInstructionBlock Property
InstructionReader Class See Also Send Feedback
Gets the InstructionBlock on which the current InstructionReader is positioned.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock CurrentInstructionBlock { get; }

Field Value

An InstructionBlock, or null if the current InstructionReader is not positioned at an InstructionBlock.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


CurrentInstructionSequence Property

InstructionReader..::..CurrentInstructionSequence Property
InstructionReader Class See Also Send Feedback
Gets the InstructionSequence on which the current InstructionReader is positioned.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence CurrentInstructionSequence { get; }

Field Value

An InstructionSequence, or null if the current InstructionReader is not positioned at an InstructionSequence.

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


IsAtEnfOfSequence Property

InstructionReader..::..IsAtEnfOfSequence Property
InstructionReader Class See Also Send Feedback
Determines whether the current instruction is the last of the sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAtEnfOfSequence { get; }

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


IsSymbolResolutionEnabled Property

InstructionReader..::..IsSymbolResolutionEnabled Property
InstructionReader Class See Also Send Feedback
Determines whether resolution of local variable symbols is enabled for the current reader.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSymbolResolutionEnabled { get; }

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

InstructionReader..::..MethodBody Property
InstructionReader Class See Also Send Feedback
Gets the MethodBodyDeclaration to which the current InstructionReader is assigned.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; }

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


Module Property

InstructionReader..::..Module Property
InstructionReader Class See Also Send Feedback
Gets the module to which this InstructionReader is associates.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

See Also

InstructionReader Class
PostSharp.Sdk.CodeModel Namespace


InstructionReaderBookmark Class

InstructionReaderBookmark Class
See Also Send Feedback
Bookmark for the InstructionReader class.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionReaderBookmark

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.InstructionReaderBookmark

See Also

PostSharp.Sdk.CodeModel Namespace
InstructionReader..::.CreateBookmark()()()
InstructionReader..::.GoToBookmark(InstructionReaderBookmark)


InstructionSequence Class

InstructionSequence Class
Members See Also Send Feedback
Represents a sequence of instructions without branches, i.e. the control flow necessarily begins at the beginning of the sequence and ends at the end of the sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionSequence : IDisposable

Remarks

By default, PostSharp only analyzes the normal control flow on the base of branching instructions, i.e. it ignores the control flow caused by exceptions. So it is possible that, in case of exception, the sequence is left from an textWriter point instead of from the last instruction.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.InstructionSequence

See Also

InstructionSequence Members
PostSharp.Sdk.CodeModel Namespace


InstructionSequence Members

[image]

PostSharp 2.0 Documentation
InstructionSequence Members
InstructionSequence Class Methods Properties See Also Send Feedback

The InstructionSequence type exposes the following members.

Methods

 | Name | Description
Public method | CheckInstructions | Checks whether the instruction stream can be read.
Public method | Detach | Detaches the current InstructionSequence from its parent InstructionBlock.
Public method | Redirect | Redirects to another InstructionSequence all branch targets currently referencing the current InstructionSequence.
Public method | Remove | Overloaded.
Public method | SplitAfterReaderPosition | Splits the current sequence after the position of an InstructionReader, and returns a new InstructionSequence containing the second part of the sequence.
Public method | SplitAroundReaderPosition | Splits the current InstructionSequence in maximally three sequences, one containing the instructions before the current instruction of a given InstructionReader, one containing only the current instruction and one containing the instructions after the current instruction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Comment | Gets or sets the comment on this instruction sequence.
Public property | IsOriginal | Determines whether the current instruction sequence is original, i.e. whether it was unmodified from the original module.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current instance is related.
Public property | NextDeepSequence | Gets the next InstructionSequence in the current InstructionBlock or in the next sibling InstructionBlock.
Public property | NextSiblingSequence | Gets the next sibling InstructionSequence.
Public property | ParentInstructionBlock | Gets the block to which the current sequences belongs.
Public property | PreviousSiblingSequence | Gets the previous sibling InstructionSequence.
Public property | Token | Gets the instruction sequence token.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


InstructionSequence Methods

[image]

PostSharp 2.0 Documentation
InstructionSequence Methods
InstructionSequence Class See Also Send Feedback

The InstructionSequence type exposes the following members.

Methods

 | Name | Description
Public method | CheckInstructions | Checks whether the instruction stream can be read.
Public method | Detach | Detaches the current InstructionSequence from its parent InstructionBlock.
Public method | Redirect | Redirects to another InstructionSequence all branch targets currently referencing the current InstructionSequence.
Public method | Remove | Overloaded.
Public method | SplitAfterReaderPosition | Splits the current sequence after the position of an InstructionReader, and returns a new InstructionSequence containing the second part of the sequence.
Public method | SplitAroundReaderPosition | Splits the current InstructionSequence in maximally three sequences, one containing the instructions before the current instruction of a given InstructionReader, one containing only the current instruction and one containing the instructions after the current instruction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


CheckInstructions Method

InstructionSequence..::..CheckInstructions Method
InstructionSequence Class See Also Send Feedback
Checks whether the instruction stream can be read.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CheckInstructions()

Remarks

Should be used only in debugging scenarios. Conditional to the DEBUG compilation symbol.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


Detach Method

InstructionSequence..::..Detach Method
InstructionSequence Class See Also Send Feedback
Detaches the current InstructionSequence from its parent InstructionBlock.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Detach()

Remarks

This method does not detaches the InstructionSequence to the MethodBodyDeclaration to which it belongs. Note that the state of the instruction stream may be inconsistent after calling this method, because instructions may still reference the current InstructionSequence as a branch target. In order to redirect branch targets, call the Remove(InstructionSequence) or Redirect(InstructionSequence) method.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The instruction sequence is not attached.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


Redirect Method

InstructionSequence..::..Redirect Method
InstructionSequence Class See Also Send Feedback
Redirects to another InstructionSequence all branch targets currently referencing the current InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Redirect(
    InstructionSequence newSequence
)

Parameters

newSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The InstructionSequence that should become the new target.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
InstructionSequence..::..Remove Method
InstructionSequence Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove()()() | Removes the current InstructionSequence from the MethodBodyDeclaration to which it belongs, but does not redirect branching targets.
Public method | Remove(InstructionSequence) | Removes the current InstructionSequence from the MethodBodyDeclaration to which it belongs, and optionally redirects to another InstructionSequence all branching targets to the current InstructionSequence

See Also

InstructionSequence Class
InstructionSequence Members
PostSharp.Sdk.CodeModel Namespace


Remove Method

InstructionSequence..::..Remove Method
InstructionSequence Class See Also Send Feedback
Removes the current InstructionSequence from the MethodBodyDeclaration to which it belongs, but does not redirect branching targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

See Also

InstructionSequence Class
Remove Overload
PostSharp.Sdk.CodeModel Namespace


Remove Method (InstructionSequence)

InstructionSequence..::..Remove Method (InstructionSequence)
InstructionSequence Class See Also Send Feedback
Removes the current InstructionSequence from the MethodBodyDeclaration to which it belongs, and optionally redirects to another InstructionSequence all branching targets to the current InstructionSequence

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove(
    InstructionSequence redirectInstructionSequence
)

Parameters

redirectInstructionSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
InstructionSequence to which branches to the current sequence should be redirected, or null if branching targets should not be redirected.

Remarks

This method has the effect of disposing the current InstructionSequence.

See Also

InstructionSequence Class
Remove Overload
PostSharp.Sdk.CodeModel Namespace


SplitAfterReaderPosition Method

InstructionSequence..::..SplitAfterReaderPosition Method
InstructionSequence Class See Also Send Feedback
Splits the current sequence after the position of an InstructionReader, and returns a new InstructionSequence containing the second part of the sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence SplitAfterReaderPosition(
    InstructionReader reader
)

Parameters

reader
Type: PostSharp.Sdk.CodeModel..::.InstructionReader
An InstructionReader positioned on the current InstructionSequence.

Return Value

The InstructionSequence containing the second part of the sequence, or null if reader is at the end of the sequence.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The InstructionReader is not positioned at the current InstructionSequence.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


SplitAroundReaderPosition Method

InstructionSequence..::..SplitAroundReaderPosition Method
InstructionSequence Class See Also Send Feedback
Splits the current InstructionSequence in maximally three sequences, one containing the instructions before the current instruction of a given InstructionReader, one containing only the current instruction and one containing the instructions after the current instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SplitAroundReaderPosition(
    InstructionReader reader,
    out InstructionSequence sequenceBefore,
    out InstructionSequence sequenceAfter
)

Parameters

reader
Type: PostSharp.Sdk.CodeModel..::.InstructionReader
InstructionReader positioned in the current InstructionSequence.
sequenceBefore
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence %
Returns a new sequence containing all instructions before the current one, or null if the current instruction is the first one.
sequenceAfter
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence %
Returns a new sequence containing all instructions after the current one, or null if the current instruction is the last one.

Remarks

After having called this method, the current sequence contains only the current instruction of InstructionReader.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

InstructionSequence..::..ToString Method
InstructionSequence Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


InstructionSequence Properties

[image]

PostSharp 2.0 Documentation
InstructionSequence Properties
InstructionSequence Class See Also Send Feedback

The InstructionSequence type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets or sets the comment on this instruction sequence.
Public property | IsOriginal | Determines whether the current instruction sequence is original, i.e. whether it was unmodified from the original module.
Public property | MethodBody | Gets the MethodBodyDeclaration to which the current instance is related.
Public property | NextDeepSequence | Gets the next InstructionSequence in the current InstructionBlock or in the next sibling InstructionBlock.
Public property | NextSiblingSequence | Gets the next sibling InstructionSequence.
Public property | ParentInstructionBlock | Gets the block to which the current sequences belongs.
Public property | PreviousSiblingSequence | Gets the previous sibling InstructionSequence.
Public property | Token | Gets the instruction sequence token.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


Comment Property

InstructionSequence..::..Comment Property
InstructionSequence Class See Also Send Feedback
Gets or sets the comment on this instruction sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Comment { get; set; }

Remarks

This comment will be written in MSIL output. This is for code weaver debugging only.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


IsOriginal Property

InstructionSequence..::..IsOriginal Property
InstructionSequence Class See Also Send Feedback
Determines whether the current instruction sequence is original, i.e. whether it was unmodified from the original module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsOriginal { get; }

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

InstructionSequence..::..MethodBody Property
InstructionSequence Class See Also Send Feedback
Gets the MethodBodyDeclaration to which the current instance is related.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; }

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


NextDeepSequence Property

InstructionSequence..::..NextDeepSequence Property
InstructionSequence Class See Also Send Feedback
Gets the next InstructionSequence in the current InstructionBlock or in the next sibling InstructionBlock.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence NextDeepSequence { get; }

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


NextSiblingSequence Property

InstructionSequence..::..NextSiblingSequence Property
InstructionSequence Class See Also Send Feedback
Gets the next sibling InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence NextSiblingSequence { get; }

Field Value

An InstructionSequence having the same parent InstructionBlock, or null if the current sequence is the last of its block.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


ParentInstructionBlock Property

InstructionSequence..::..ParentInstructionBlock Property
InstructionSequence Class See Also Send Feedback
Gets the block to which the current sequences belongs.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock ParentInstructionBlock { get; internal set; }

Field Value

An InstructionBlock, or null if the current InstructionSequence is detached.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


PreviousSiblingSequence Property

InstructionSequence..::..PreviousSiblingSequence Property
InstructionSequence Class See Also Send Feedback
Gets the previous sibling InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence PreviousSiblingSequence { get; }

Field Value

An InstructionSequence having the same parent InstructionBlock, or null if the current sequence is the first of its block.

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


Token Property

InstructionSequence..::..Token Property
InstructionSequence Class See Also Send Feedback
Gets the instruction sequence token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public short Token { get; internal set; }

See Also

InstructionSequence Class
PostSharp.Sdk.CodeModel Namespace


InstructionWriter Class

InstructionWriter Class
Members See Also Send Feedback
writer a linear stream of instructions into an InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionWriter : BaseInstructionWriter,
    IDisposable

Remarks

After having been instantiated, the InstructionWriter should be associated to an InstructionSequence using the AttachInstructionSequence(InstructionSequence). After all instructions have been written, the DetachInstructionSequence()()() method should be called.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
PostSharp.Sdk.CodeModel..::.InstructionWriter

See Also

InstructionWriter Members
PostSharp.Sdk.CodeModel Namespace


InstructionWriter Members

[image]

PostSharp 2.0 Documentation
InstructionWriter Members
InstructionWriter Class Constructors Methods Properties See Also Send Feedback

The InstructionWriter type exposes the following members.

Constructors

 | Name | Description
Public method | InstructionWriter | Initializes a new InstructionWriter.

Methods

 | Name | Description
Public method | AttachInstructionSequence | Attaches the current InstructionWriter to an InstructionSequence.
Public method | DetachInstructionSequence | Overloaded. Detaches the current InstructionWriter from the active InstructionSequence.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EmitBranchingInstruction | Emits a branching instruction. (Overrides BaseInstructionWriter..::.EmitBranchingInstruction(OpCodeNumber, InstructionSequence).)
Public method | EmitConvertFromObject | Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.
Public method | EmitConvertToObject | Emits MSIL instructions that cast an object of any type to an object (eventually boxed).
Public method | EmitInstruction | Emits an instruction without operand. (Overrides BaseInstructionWriter..::.EmitInstruction(OpCodeNumber).)
Public method | EmitInstructionByte | Emits an instruction with a Byte operand. (Overrides BaseInstructionWriter..::.EmitInstructionByte(OpCodeNumber, Byte).)
Public method | EmitInstructionDouble | Emits an instruction with a Double operand. (Overrides BaseInstructionWriter..::.EmitInstructionDouble(OpCodeNumber, Double).)
Public method | EmitInstructionField | Emits an instruction with an IField operand. (Overrides BaseInstructionWriter..::.EmitInstructionField(OpCodeNumber, IField).)
Public method | EmitInstructionInt16 | Emits an instruction with an Int16 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt16(OpCodeNumber, Int16).)
Public method | EmitInstructionInt32 | Emits an instruction with an Int32 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt32(OpCodeNumber, Int32).)
Public method | EmitInstructionInt64 | Emits an instruction with an Int64 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt64(OpCodeNumber, Int64).)
Public method | EmitInstructionLoadIndirect | Emits the proper "load indirect" instruction as a function of the operand type. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionLocalVariable | Emits an instruction with a LocalVariableSymbol operand. (Overrides BaseInstructionWriter..::.EmitInstructionLocalVariable(OpCodeNumber, LocalVariableSymbol).)
Public method | EmitInstructionMethod | Emits an instruction with an IMethod operand. (Overrides BaseInstructionWriter..::.EmitInstructionMethod(OpCodeNumber, IMethod).)
Public method | EmitInstructionParameter | Emits an instruction with a ParameterDeclaration operand. (Overrides BaseInstructionWriter..::.EmitInstructionParameter(OpCodeNumber, ParameterDeclaration).)
Public method | EmitInstructionSignature | Emits an instruction with a StandaloneSignatureDeclaration operand. (Overrides BaseInstructionWriter..::.EmitInstructionSignature(OpCodeNumber, StandaloneSignatureDeclaration).)
Public method | EmitInstructionSingle | Emits an instruction with a Single operand. (Overrides BaseInstructionWriter..::.EmitInstructionSingle(OpCodeNumber, Single).)
Public method | EmitInstructionStoreElement | Emits the proper instruction that stores an array element for a given ITypeSignature. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionStoreIndirect | Emits the proper "store indirect" instruction as a function of the operand type. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionString | Emits an instruction with a string operand. (Overrides BaseInstructionWriter..::.EmitInstructionString(OpCodeNumber, LiteralString).)
Public method | EmitInstructionType | Emits an instruction with an IType operand. (Overrides BaseInstructionWriter..::.EmitInstructionType(OpCodeNumber, ITypeSignature).)
Public method | EmitNopIfNecessary | Emits a Nop if necessary, i.e. there is a SymbolSequencePoint just before the current point.
Public method | EmitPrefix | Emits a prefix without operand. (Overrides BaseInstructionWriter..::.EmitPrefix(InstructionPrefixes).)
Public method | EmitPrefixType | Emits a prefix with an IType operand. (Overrides BaseInstructionWriter..::.EmitPrefixType(OpCodeNumber, ITypeSignature).)
Public method | EmitSwitchInstruction | Emits a Switch instruction. (Overrides BaseInstructionWriter..::.EmitSwitchInstruction(array<InstructionSequence>[]()[]).)
Public method | EmitSymbolSequencePoint | Emits a symbol sequence point. (Overrides BaseInstructionWriter..::.EmitSymbolSequencePoint(SymbolSequencePoint).)

Properties

 | Name | Description
Public property | CheckEnabled | Determines whether operand types should be checked at runtime.
Public property | CurrentInstructionSequence | Gets the current instruction sequence.
Public property | ForceFarBranchingOperands | Determines whether far branching instructions should be unconditionally used. (Inherited from BaseInstructionWriter.)
Public property | MethodBody | Gets or sets the method body assigned to the current BaseInstructionWriter. (Inherited from BaseInstructionWriter.)

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


InstructionWriter Constructor

InstructionWriter Constructor
InstructionWriter Class See Also Send Feedback
Initializes a new InstructionWriter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionWriter()

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


InstructionWriter Methods

[image]

PostSharp 2.0 Documentation
InstructionWriter Methods
InstructionWriter Class See Also Send Feedback

The InstructionWriter type exposes the following members.

Methods

 | Name | Description
Public method | AttachInstructionSequence | Attaches the current InstructionWriter to an InstructionSequence.
Public method | DetachInstructionSequence | Overloaded. Detaches the current InstructionWriter from the active InstructionSequence.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EmitBranchingInstruction | Emits a branching instruction. (Overrides BaseInstructionWriter..::.EmitBranchingInstruction(OpCodeNumber, InstructionSequence).)
Public method | EmitConvertFromObject | Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.
Public method | EmitConvertToObject | Emits MSIL instructions that cast an object of any type to an object (eventually boxed).
Public method | EmitInstruction | Emits an instruction without operand. (Overrides BaseInstructionWriter..::.EmitInstruction(OpCodeNumber).)
Public method | EmitInstructionByte | Emits an instruction with a Byte operand. (Overrides BaseInstructionWriter..::.EmitInstructionByte(OpCodeNumber, Byte).)
Public method | EmitInstructionDouble | Emits an instruction with a Double operand. (Overrides BaseInstructionWriter..::.EmitInstructionDouble(OpCodeNumber, Double).)
Public method | EmitInstructionField | Emits an instruction with an IField operand. (Overrides BaseInstructionWriter..::.EmitInstructionField(OpCodeNumber, IField).)
Public method | EmitInstructionInt16 | Emits an instruction with an Int16 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt16(OpCodeNumber, Int16).)
Public method | EmitInstructionInt32 | Emits an instruction with an Int32 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt32(OpCodeNumber, Int32).)
Public method | EmitInstructionInt64 | Emits an instruction with an Int64 operand. (Overrides BaseInstructionWriter..::.EmitInstructionInt64(OpCodeNumber, Int64).)
Public method | EmitInstructionLoadIndirect | Emits the proper "load indirect" instruction as a function of the operand type. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionLocalVariable | Emits an instruction with a LocalVariableSymbol operand. (Overrides BaseInstructionWriter..::.EmitInstructionLocalVariable(OpCodeNumber, LocalVariableSymbol).)
Public method | EmitInstructionMethod | Emits an instruction with an IMethod operand. (Overrides BaseInstructionWriter..::.EmitInstructionMethod(OpCodeNumber, IMethod).)
Public method | EmitInstructionParameter | Emits an instruction with a ParameterDeclaration operand. (Overrides BaseInstructionWriter..::.EmitInstructionParameter(OpCodeNumber, ParameterDeclaration).)
Public method | EmitInstructionSignature | Emits an instruction with a StandaloneSignatureDeclaration operand. (Overrides BaseInstructionWriter..::.EmitInstructionSignature(OpCodeNumber, StandaloneSignatureDeclaration).)
Public method | EmitInstructionSingle | Emits an instruction with a Single operand. (Overrides BaseInstructionWriter..::.EmitInstructionSingle(OpCodeNumber, Single).)
Public method | EmitInstructionStoreElement | Emits the proper instruction that stores an array element for a given ITypeSignature. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionStoreIndirect | Emits the proper "store indirect" instruction as a function of the operand type. (Inherited from BaseInstructionWriter.)
Public method | EmitInstructionString | Emits an instruction with a string operand. (Overrides BaseInstructionWriter..::.EmitInstructionString(OpCodeNumber, LiteralString).)
Public method | EmitInstructionType | Emits an instruction with an IType operand. (Overrides BaseInstructionWriter..::.EmitInstructionType(OpCodeNumber, ITypeSignature).)
Public method | EmitNopIfNecessary | Emits a Nop if necessary, i.e. there is a SymbolSequencePoint just before the current point.
Public method | EmitPrefix | Emits a prefix without operand. (Overrides BaseInstructionWriter..::.EmitPrefix(InstructionPrefixes).)
Public method | EmitPrefixType | Emits a prefix with an IType operand. (Overrides BaseInstructionWriter..::.EmitPrefixType(OpCodeNumber, ITypeSignature).)
Public method | EmitSwitchInstruction | Emits a Switch instruction. (Overrides BaseInstructionWriter..::.EmitSwitchInstruction(array<InstructionSequence>[]()[]).)
Public method | EmitSymbolSequencePoint | Emits a symbol sequence point. (Overrides BaseInstructionWriter..::.EmitSymbolSequencePoint(SymbolSequencePoint).)

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


AttachInstructionSequence Method

InstructionWriter..::..AttachInstructionSequence Method
InstructionWriter Class See Also Send Feedback
Attaches the current InstructionWriter to an InstructionSequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AttachInstructionSequence(
    InstructionSequence sequence
)

Parameters

sequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
An InstructionSequence that is attached to a method.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The sequence parameter is null.
System..::.ArgumentException | The sequence is not attached to a method.
System..::.InvalidOperationException | This InstructionWriter has already an active InstructionSequence.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


DetachInstructionSequence Method

[image]

PostSharp 2.0 Documentation
InstructionWriter..::..DetachInstructionSequence Method
InstructionWriter Class See Also Send Feedback
Detaches the current InstructionWriter from the active InstructionSequence.

Overload List

 | Name | Description
Public method | DetachInstructionSequence()()() | Detaches the current InstructionWriter from the active InstructionSequence and commits the changes.
Public method | DetachInstructionSequence(Boolean) | Detaches the current InstructionWriter form the active InstructionSequence by specifying whether the changes should be committed or rolled back.

See Also

InstructionWriter Class
InstructionWriter Members
PostSharp.Sdk.CodeModel Namespace


DetachInstructionSequence Method

InstructionWriter..::..DetachInstructionSequence Method
InstructionWriter Class See Also Send Feedback
Detaches the current InstructionWriter from the active InstructionSequence and commits the changes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void DetachInstructionSequence()

See Also

InstructionWriter Class
DetachInstructionSequence Overload
PostSharp.Sdk.CodeModel Namespace


DetachInstructionSequence Method (Boolean)

InstructionWriter..::..DetachInstructionSequence Method (Boolean)
InstructionWriter Class See Also Send Feedback
Detaches the current InstructionWriter form the active InstructionSequence by specifying whether the changes should be committed or rolled back.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void DetachInstructionSequence(
    bool commit
)

Parameters

commit
Type: System..::.Boolean
true if the changes should be committed, or false of they should be rolled back.

Exceptions

Exception | Condition
System..::.InvalidOperationException | This InstructionWriter has no active InstructionSequence.

See Also

InstructionWriter Class
DetachInstructionSequence Overload
PostSharp.Sdk.CodeModel Namespace


Dispose Method

InstructionWriter..::..Dispose Method
InstructionWriter Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitBranchingInstruction Method

InstructionWriter..::..EmitBranchingInstruction Method
InstructionWriter Class See Also Send Feedback
Emits a branching instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitBranchingInstruction(
    OpCodeNumber code,
    InstructionSequence sequence
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction code.
sequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The target InstructionSequence.

Return Value

The distance of sequence w.r.t. the current instruction.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitConvertFromObject Method

InstructionWriter..::..EmitConvertFromObject Method
InstructionWriter Class See Also Send Feedback
Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitConvertFromObject(
    ITypeSignature targetType
)

Parameters

targetType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type into which the object has to be converted.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitConvertToObject Method

InstructionWriter..::..EmitConvertToObject Method
InstructionWriter Class See Also Send Feedback
Emits MSIL instructions that cast an object of any type to an object (eventually boxed).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitConvertToObject(
    ITypeSignature originalType
)

Parameters

originalType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type to be converted.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstruction Method

InstructionWriter..::..EmitInstruction Method
InstructionWriter Class See Also Send Feedback
Emits an instruction without operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstruction(
    OpCodeNumber code
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionByte Method

InstructionWriter..::..EmitInstructionByte Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a Byte operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionByte(
    OpCodeNumber code,
    byte operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Byte
The Byte operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionDouble Method

InstructionWriter..::..EmitInstructionDouble Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a Double operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionDouble(
    OpCodeNumber code,
    double operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Double
The Double operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionField Method

InstructionWriter..::..EmitInstructionField Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an IField operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionField(
    OpCodeNumber code,
    IField field
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
field
Type: PostSharp.Sdk.CodeModel..::.IField
The IField operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt16 Method

InstructionWriter..::..EmitInstructionInt16 Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an Int16 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionInt16(
    OpCodeNumber code,
    short operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int16
The Int16 operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt32 Method

InstructionWriter..::..EmitInstructionInt32 Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an Int32 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionInt32(
    OpCodeNumber code,
    int operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int32
The Int32 operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionInt64 Method

InstructionWriter..::..EmitInstructionInt64 Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an Int64 operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionInt64(
    OpCodeNumber code,
    long operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Int64
The Int64 operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionLocalVariable Method

InstructionWriter..::..EmitInstructionLocalVariable Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a LocalVariableSymbol operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionLocalVariable(
    OpCodeNumber code,
    LocalVariableSymbol localVariableSymbol
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
localVariableSymbol
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
The LocalVariableSymbol operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionMethod Method

InstructionWriter..::..EmitInstructionMethod Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an IMethod operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionMethod(
    OpCodeNumber code,
    IMethod method
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
method
Type: PostSharp.Sdk.CodeModel..::.IMethod
The IMethod operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionParameter Method

InstructionWriter..::..EmitInstructionParameter Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a ParameterDeclaration operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionParameter(
    OpCodeNumber code,
    ParameterDeclaration parameter
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
parameter
Type: PostSharp.Sdk.CodeModel..::.ParameterDeclaration
The ParameterDeclaration operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionSignature Method

InstructionWriter..::..EmitInstructionSignature Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a StandaloneSignatureDeclaration operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionSignature(
    OpCodeNumber code,
    StandaloneSignatureDeclaration signature
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
signature
Type: PostSharp.Sdk.CodeModel..::.StandaloneSignatureDeclaration
The StandaloneSignatureDeclaration operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionSingle Method

InstructionWriter..::..EmitInstructionSingle Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a Single operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionSingle(
    OpCodeNumber code,
    float operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: System..::.Single
The Single operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionString Method

InstructionWriter..::..EmitInstructionString Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with a string operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionString(
    OpCodeNumber code,
    LiteralString operand
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
operand
Type: PostSharp.Sdk.CodeModel..::.LiteralString
The string operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitInstructionType Method

InstructionWriter..::..EmitInstructionType Method
InstructionWriter Class See Also Send Feedback
Emits an instruction with an IType operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitInstructionType(
    OpCodeNumber code,
    ITypeSignature type
)

Parameters

code
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The instruction opcode.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The IType operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitNopIfNecessary Method

InstructionWriter..::..EmitNopIfNecessary Method
InstructionWriter Class See Also Send Feedback
Emits a Nop if necessary, i.e. there is a SymbolSequencePoint just before the current point.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitNopIfNecessary()

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitPrefix Method

InstructionWriter..::..EmitPrefix Method
InstructionWriter Class See Also Send Feedback
Emits a prefix without operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitPrefix(
    InstructionPrefixes prefix
)

Parameters

prefix
Type: PostSharp.Sdk.CodeModel..::.InstructionPrefixes
A combination of prefixes.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitPrefixType Method

InstructionWriter..::..EmitPrefixType Method
InstructionWriter Class See Also Send Feedback
Emits a prefix with an IType operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitPrefixType(
    OpCodeNumber prefix,
    ITypeSignature type
)

Parameters

prefix
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
A single prefix (not a combination).
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The IType operand.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitSwitchInstruction Method

InstructionWriter..::..EmitSwitchInstruction Method
InstructionWriter Class See Also Send Feedback
Emits a Switch instruction.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitSwitchInstruction(
    InstructionSequence[] switchTargets
)

Parameters

switchTargets
Type: array< PostSharp.Sdk.CodeModel..::.InstructionSequence >[]()[][]
An array of instruction sequences (InstructionSequence) which are the targets of the switch instruction.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


EmitSymbolSequencePoint Method

InstructionWriter..::..EmitSymbolSequencePoint Method
InstructionWriter Class See Also Send Feedback
Emits a symbol sequence point.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void EmitSymbolSequencePoint(
    SymbolSequencePoint sequencePoint
)

Parameters

sequencePoint
Type: PostSharp.Reflection..::.SymbolSequencePoint
A SymbolSequencePoint, or null.

Remarks

This method does nothing if sequencePoint is null.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


InstructionWriter Properties

[image]

PostSharp 2.0 Documentation
InstructionWriter Properties
InstructionWriter Class See Also Send Feedback

The InstructionWriter type exposes the following members.

Properties

 | Name | Description
Public property | CheckEnabled | Determines whether operand types should be checked at runtime.
Public property | CurrentInstructionSequence | Gets the current instruction sequence.
Public property | ForceFarBranchingOperands | Determines whether far branching instructions should be unconditionally used. (Inherited from BaseInstructionWriter.)
Public property | MethodBody | Gets or sets the method body assigned to the current BaseInstructionWriter. (Inherited from BaseInstructionWriter.)

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


CheckEnabled Property

InstructionWriter..::..CheckEnabled Property
InstructionWriter Class See Also Send Feedback
Determines whether operand types should be checked at runtime.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CheckEnabled { get; set; }

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


CurrentInstructionSequence Property

InstructionWriter..::..CurrentInstructionSequence Property
InstructionWriter Class See Also Send Feedback
Gets the current instruction sequence.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence CurrentInstructionSequence { get; }

Field Value

The current instruction sequence, or null if the current writer is not attached to any sequence.

See Also

InstructionWriter Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementationDeclaration Class

InterfaceImplementationDeclaration Class
Members See Also Send Feedback
Represents an interface implementation (InterfaceImpl) of a TypeDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InterfaceImplementationDeclaration : MetadataDeclaration,
    IRemovable, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

Remarks

Interface implementations are owned by type definitions (TypeDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.InterfaceImplementationDeclaration

See Also

InterfaceImplementationDeclaration Members
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementationDeclaration Members

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclaration Members
InterfaceImplementationDeclaration Class Constructors Methods Properties See Also Send Feedback

The InterfaceImplementationDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | InterfaceImplementationDeclaration | Initializes a new instance of the InterfaceImplementationDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType |
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ImplementedInterface | Gets or sets the implemented interface.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementationDeclaration Constructor

InterfaceImplementationDeclaration Constructor
InterfaceImplementationDeclaration Class See Also Send Feedback
Initializes a new instance of the InterfaceImplementationDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceImplementationDeclaration()

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementationDeclaration Methods

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclaration Methods
InterfaceImplementationDeclaration Class See Also Send Feedback

The InterfaceImplementationDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

InterfaceImplementationDeclaration..::..GetTokenType Method
InterfaceImplementationDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

InterfaceImplementationDeclaration..::..Remove Method
InterfaceImplementationDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementationDeclaration Properties

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclaration Properties
InterfaceImplementationDeclaration Class See Also Send Feedback

The InterfaceImplementationDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType |
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ImplementedInterface | Gets or sets the implemented interface.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

InterfaceImplementationDeclaration..::..DeclaringType Property
InterfaceImplementationDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.InterfaceImplementationDeclaration.DeclaringType"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration DeclaringType { get; }

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImplementedInterface Property

InterfaceImplementationDeclaration..::..ImplementedInterface Property
InterfaceImplementationDeclaration Class See Also Send Feedback
Gets or sets the implemented interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ImplementedInterface { get; set; }

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

InterfaceImplementationDeclaration..::..ParentMember Property
InterfaceImplementationDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

InterfaceImplementationDeclaration..::..ParentType Property
InterfaceImplementationDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

InterfaceImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IntrinsicType Enumeration

IntrinsicType Enumeration
See Also Send Feedback
Enumeration of primitive types of the .NET runtime. This includes intrinsic types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum IntrinsicType

Members

Member name | Value | Description
Void | 0 | Void.
Object | 1 | Object.
Boolean | 3 | Boolean.
Char | 4 | Char.
SByte | 5 | SByte.
Byte | 6 | Byte.
Int16 | 7 | Int16.
UInt16 | 8 | UInt16.
Int32 | 9 | Int32.
UInt32 | 10 | UInt32.
Int64 | 11 | Int64.
UInt64 | 12 | UInt64.
Single | 13 | Single.
Double | 14 | Double.
String | 18 | String.
IntPtr | 19 | IntPtr (not serializable).
UIntPtr | 20 | UIntPtr (not serializable).
NativeReal | 21 | Real number with platform-specific precision (not serializable).
TypedReference | 22 | TypedReference (not serializable).
Null | 23 | Null value.
Token | 24 | Metadata token.

See Also

PostSharp.Sdk.CodeModel Namespace


IRemovable Interface

IRemovable Interface
Members See Also Send Feedback
Defines the semantics of a declaration that can be removed from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IRemovable : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

IRemovable Members
PostSharp.Sdk.CodeModel Namespace


IRemovable Members

[image]

PostSharp 2.0 Documentation
IRemovable Members
IRemovable Interface Methods Properties See Also Send Feedback

The IRemovable type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IRemovable Interface
PostSharp.Sdk.CodeModel Namespace


IRemovable Methods

[image]

PostSharp 2.0 Documentation
IRemovable Methods
IRemovable Interface See Also Send Feedback

The IRemovable type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

IRemovable Interface
PostSharp.Sdk.CodeModel Namespace


Remove Method

IRemovable..::..Remove Method
IRemovable Interface See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Remove()

See Also

IRemovable Interface
PostSharp.Sdk.CodeModel Namespace


IRemovable Properties

[image]

PostSharp 2.0 Documentation
IRemovable Properties
IRemovable Interface See Also Send Feedback

The IRemovable type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IRemovable Interface
PostSharp.Sdk.CodeModel Namespace


ISecurable Interface

ISecurable Interface
Members See Also Send Feedback
Defines semantics of declarations that can be secured by permission sets (TypeDefDeclaration, MethodDefDeclaration, AssemblyManifestDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ISecurable : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

ISecurable Members
PostSharp.Sdk.CodeModel Namespace


ISecurable Members

[image]

PostSharp 2.0 Documentation
ISecurable Members
ISecurable Interface Methods Properties See Also Send Feedback

The ISecurable type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).

See Also

ISecurable Interface
PostSharp.Sdk.CodeModel Namespace


ISecurable Methods

[image]

PostSharp 2.0 Documentation
ISecurable Methods
ISecurable Interface See Also Send Feedback

The ISecurable type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

ISecurable Interface
PostSharp.Sdk.CodeModel Namespace


ISecurable Properties

[image]

PostSharp 2.0 Documentation
ISecurable Properties
ISecurable Interface See Also Send Feedback

The ISecurable type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).

See Also

ISecurable Interface
PostSharp.Sdk.CodeModel Namespace


PermissionSets Property

ISecurable..::..PermissionSets Property
ISecurable Interface See Also Send Feedback
Gets the collection of permission sets (PermissionSetDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
PermissionSetDeclarationCollection PermissionSets { get; }

See Also

ISecurable Interface
PostSharp.Sdk.CodeModel Namespace


ITaggable Interface

ITaggable Interface
Members See Also Send Feedback
Defines the semantics of a taggable object. User code can add custom pieces of information to PostSharp objects using this mechanism. DomainTags are identified by a Guid. There is no difference between an absent tag and a null tag value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITaggable

See Also

ITaggable Members
PostSharp.Sdk.CodeModel Namespace


ITaggable Members

[image]

PostSharp 2.0 Documentation
ITaggable Members
ITaggable Interface Methods See Also Send Feedback

The ITaggable type exposes the following members.

Methods

 | Name | Description
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | SetTag | Set a tag to the current declaration.

See Also

ITaggable Interface
PostSharp.Sdk.CodeModel Namespace


ITaggable Methods

[image]

PostSharp 2.0 Documentation
ITaggable Methods
ITaggable Interface See Also Send Feedback

The ITaggable type exposes the following members.

Methods

 | Name | Description
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | SetTag | Set a tag to the current declaration.

See Also

ITaggable Interface
PostSharp.Sdk.CodeModel Namespace


GetTag Method

ITaggable..::..GetTag Method
ITaggable Interface See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

See Also

ITaggable Interface
PostSharp.Sdk.CodeModel Namespace


SetTag Method

ITaggable..::..SetTag Method
ITaggable Interface See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

See Also

ITaggable Interface
PostSharp.Sdk.CodeModel Namespace


IType Interface

IType Interface
Members See Also Send Feedback
Defines the semantics of a type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IType : ITypeSignature, IVisitable<ITypeSignature>,
    IGeneric, IEquatable<ITypeSignature>, IWriteReflectionName, IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

Remarks

A type has all the semantics of a type signature (ITypeSignature) and exposes additionally methods and fields.

See Also

IType Members
PostSharp.Sdk.CodeModel Namespace


IType Members

[image]

PostSharp 2.0 Documentation
IType Members
IType Interface Methods Properties See Also Send Feedback

The IType type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


IType Methods

[image]

PostSharp 2.0 Documentation
IType Methods
IType Interface See Also Send Feedback

The IType type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Inherited from ITypeSignature.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Inherited from ITypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Inherited from ITypeSignature.)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references. (Inherited from ITypeSignature.)
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Inherited from ITypeSignature.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Inherited from ITypeSignature.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from ITypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Inherited from ITypeSignature.)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from ITypeSignature.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong. (Inherited from ITypeSignature.)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
IType..::..GetTypeDefinition Method
IType Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from ITypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from ITypeSignature.)

See Also

IType Interface
IType Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
IType..::..IsAssignableTo Method
IType Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from ITypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from ITypeSignature.)

See Also

IType Interface
IType Members
PostSharp.Sdk.CodeModel Namespace


IType Properties

[image]

PostSharp 2.0 Documentation
IType Properties
IType Interface See Also Send Feedback

The IType type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | Fields | Gets the collection of fields.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Methods | Gets the collection of methods.
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


Attributes Property

IType..::..Attributes Property
IType Interface See Also Send Feedback
Gets or sets the type attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TypeAttributes Attributes { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

IType..::..DeclaringType Property
IType Interface See Also Send Feedback
Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IType DeclaringType { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


Fields Property

IType..::..Fields Property
IType Interface See Also Send Feedback
Gets the collection of fields.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IFieldCollection Fields { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

IType..::..IsAbstract Property
IType Interface See Also Send Feedback
Determines whether the class is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsAbstract { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


IsInterface Property

IType..::..IsInterface Property
IType Interface See Also Send Feedback
Determines whether the type is an interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsInterface { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

IType..::..IsSealed Property
IType Interface See Also Send Feedback
Determines whether the type is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsSealed { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


Methods Property

IType..::..Methods Property
IType Interface See Also Send Feedback
Gets the collection of methods.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethodCollection Methods { get; }

See Also

IType Interface
PostSharp.Sdk.CodeModel Namespace


ITypeContainer Interface

ITypeContainer Interface
Members See Also Send Feedback
Exposes the semantics of a declaration that can contain type definitions (ModuleDeclaration or TypeDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeContainer : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

ITypeContainer Members
PostSharp.Sdk.CodeModel Namespace


ITypeContainer Members

[image]

PostSharp 2.0 Documentation
ITypeContainer Members
ITypeContainer Interface Methods Properties See Also Send Feedback

The ITypeContainer type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Types | Gets the collection of types.

See Also

ITypeContainer Interface
PostSharp.Sdk.CodeModel Namespace


ITypeContainer Methods

[image]

PostSharp 2.0 Documentation
ITypeContainer Methods
ITypeContainer Interface See Also Send Feedback

The ITypeContainer type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

ITypeContainer Interface
PostSharp.Sdk.CodeModel Namespace


ITypeContainer Properties

[image]

PostSharp 2.0 Documentation
ITypeContainer Properties
ITypeContainer Interface See Also Send Feedback

The ITypeContainer type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Types | Gets the collection of types.

See Also

ITypeContainer Interface
PostSharp.Sdk.CodeModel Namespace


Types Property

ITypeContainer..::..Types Property
ITypeContainer Interface See Also Send Feedback
Gets the collection of types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TypeDefDeclarationCollection Types { get; }

See Also

ITypeContainer Interface
PostSharp.Sdk.CodeModel Namespace


ITypeRefResolutionScope Interface

ITypeRefResolutionScope Interface
Members See Also Send Feedback
Defines semantics of TypeRefDeclaration resolution scopes (TypeRefDeclaration, AssemblyRefDeclaration, ModuleDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeRefResolutionScope : IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

See Also

ITypeRefResolutionScope Members
PostSharp.Sdk.CodeModel Namespace


ITypeRefResolutionScope Members

[image]

PostSharp 2.0 Documentation
ITypeRefResolutionScope Members
ITypeRefResolutionScope Interface Methods Properties See Also Send Feedback

The ITypeRefResolutionScope type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

See Also

ITypeRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


ITypeRefResolutionScope Methods

[image]

PostSharp 2.0 Documentation
ITypeRefResolutionScope Methods
ITypeRefResolutionScope Interface See Also Send Feedback

The ITypeRefResolutionScope type exposes the following members.

Methods

 | Name | Description
Public method | GetReflectionSystemObject | Gets the system, runtime object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) corresponding to the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetReflectionWrapperObject | Gets a reflection object (Type, FieldInfo, MethodInfo, ParameterInfo, ...) that wraps the current declaration. (Inherited from IMetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from ITaggable.)
Public method | GetTokenType | Gets the metadata token type of the current declaration. (Inherited from IMetadataDeclaration.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from ITaggable.)
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)

See Also

ITypeRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


ITypeRefResolutionScope Properties

[image]

PostSharp 2.0 Documentation
ITypeRefResolutionScope Properties
ITypeRefResolutionScope Interface See Also Send Feedback

The ITypeRefResolutionScope type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from IMetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | Domain | Gets the Domain to which the current element belongs. (Inherited from IElement.)
Public property | MetadataToken | Gets the metadata token of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)
Public property | Parent | Gets the direct parent of the current element. (Inherited from IElement.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from IMetadataDeclaration.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

See Also

ITypeRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


TypeRefs Property

ITypeRefResolutionScope..::..TypeRefs Property
ITypeRefResolutionScope Interface See Also Send Feedback
Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TypeRefDeclarationCollection TypeRefs { get; }

See Also

ITypeRefResolutionScope Interface
PostSharp.Sdk.CodeModel Namespace


ITypeSignature Interface

ITypeSignature Interface
Members See Also Send Feedback
Defines the functionalities that are common to all representations of a type (TypeDefDeclaration, TypeRefDeclaration, TypeSpecDeclaration, TypeSignature).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypeSignature : IModuleElement,
    IVisitable<ITypeSignature>, IGeneric, IEquatable<ITypeSignature>,
    IWriteReflectionName

See Also

ITypeSignature Members
PostSharp.Sdk.CodeModel Namespace


ITypeSignature Members

[image]

PostSharp 2.0 Documentation
ITypeSignature Members
ITypeSignature Interface Methods Properties See Also Send Feedback

The ITypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


ITypeSignature Methods

[image]

PostSharp 2.0 Documentation
ITypeSignature Methods
ITypeSignature Interface See Also Send Feedback

The ITypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from IGeneric.)
Public method | GetNakedType | Returns the meaningful type. Removes specified modifiers and resolves type references.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Translate | Translates the current element so that it can be used in a given module. (Inherited from IModuleElement.)
Public method | TranslateType | Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from IVisitable<(Of <(?0>)>).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Inherited from IWriteReflectionName.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

ITypeSignature..::..BelongsToClassification Method
ITypeSignature Interface See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


ContainsGenericArguments Method

ITypeSignature..::..ContainsGenericArguments Method
ITypeSignature Interface See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

ITypeSignature..::..GetCanonicalHashCode Method
ITypeSignature Interface See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetNakedType Method

ITypeSignature..::..GetNakedType Method
ITypeSignature Interface See Also Send Feedback
Returns the meaningful type. Removes specified modifiers and resolves type references.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature GetNakedType(
    TypeNakingOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.TypeNakingOptions
Specifies what has to be ignored.

Return Value

A 'naked' IType.

Remarks

This method only removes the modifiers on the current object, all of the nodes of a type signature. However, the object returned by this method (i.e. the head of the chain) is guaranteed to be free from modifiers specified in options.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

ITypeSignature..::..GetReflectionWrapper Method
ITypeSignature Interface See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

ITypeSignature..::..GetSystemType Method
ITypeSignature Interface See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
ITypeSignature..::..GetTypeDefinition Method
ITypeSignature Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

See Also

ITypeSignature Interface
ITypeSignature Members
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

ITypeSignature..::..GetTypeDefinition Method
ITypeSignature Interface See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TypeDefDeclaration GetTypeDefinition()

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

See Also

ITypeSignature Interface
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (BindingOptions)

ITypeSignature..::..GetTypeDefinition Method (BindingOptions)
ITypeSignature Interface See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
TypeDefDeclaration GetTypeDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

See Also

ITypeSignature Interface
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetValueSize Method

ITypeSignature..::..GetValueSize Method
ITypeSignature Interface See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
ITypeSignature..::..IsAssignableTo Method
ITypeSignature Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

ITypeSignature Interface
ITypeSignature Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

ITypeSignature..::..IsAssignableTo Method (ITypeSignature)
ITypeSignature Interface See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

ITypeSignature Interface
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

ITypeSignature..::..IsAssignableTo Method (ITypeSignature, GenericMap)
ITypeSignature Interface See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

ITypeSignature Interface
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

ITypeSignature..::..MapGenericArguments Method
ITypeSignature Interface See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

ITypeSignature..::..MatchesReference Method
ITypeSignature Interface See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


TranslateType Method

ITypeSignature..::..TranslateType Method
ITypeSignature Interface See Also Send Feedback
Translates the current type signature so that it is meaningful in another module than the one to which it primarily belong.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature TranslateType(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the type signature should be translated.

Return Value

A type signature meaningful in the targetModule module.

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


ITypeSignature Properties

[image]

PostSharp 2.0 Documentation
ITypeSignature Properties
ITypeSignature Interface See Also Send Feedback

The ITypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from IModuleElement.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances. (Inherited from IGeneric.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from IGeneric.)
Public property | Module | Gets the declaring module. (Inherited from IModuleElement.)

See Also

ITypeSignature Interface
PostSharp.Sdk.CodeModel Namespace


IWeakReferenceable Interface

IWeakReferenceable Interface
Members See Also Send Feedback
Defines the semantics of declarations (TypeRefDeclaration and AssemblyRefDeclaration) that can be "weakly references".

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IWeakReferenceable

Remarks

Serialized constructions (custom attributes and permission set) may reference a type using its fully qualified name instead of an entry in a metadata table. In PostSharp, these "weak references" are not implemented by strings but by references to pseudo-metadata declarations. They are metadata declarations that are marked to have no "strong" reference.

Metadata declarations with "strong" references are called linked and other non-linked.

See Also

IWeakReferenceable Members
PostSharp.Sdk.CodeModel Namespace


IWeakReferenceable Members

[image]

PostSharp 2.0 Documentation
IWeakReferenceable Members
IWeakReferenceable Interface Properties See Also Send Feedback

The IWeakReferenceable type exposes the following members.

Properties

 | Name | Description
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.

See Also

IWeakReferenceable Interface
PostSharp.Sdk.CodeModel Namespace


IWeakReferenceable Properties

[image]

PostSharp 2.0 Documentation
IWeakReferenceable Properties
IWeakReferenceable Interface See Also Send Feedback

The IWeakReferenceable type exposes the following members.

Properties

 | Name | Description
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.

See Also

IWeakReferenceable Interface
PostSharp.Sdk.CodeModel Namespace


IsWeaklyReferenced Property

IWeakReferenceable..::..IsWeaklyReferenced Property
IWeakReferenceable Interface See Also Send Feedback
Determines whether the current declaration is weakly or strongly referenced in the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsWeaklyReferenced { get; set; }

See Also

IWeakReferenceable Interface
PostSharp.Sdk.CodeModel Namespace


IWriteReflectionName Interface

IWriteReflectionName Interface
Members See Also Send Feedback
Defines a method WriteReflectionName(StringBuilder, ReflectionNameOptions).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IWriteReflectionName

See Also

IWriteReflectionName Members
PostSharp.Sdk.CodeModel Namespace


IWriteReflectionName Members

[image]

PostSharp 2.0 Documentation
IWriteReflectionName Members
IWriteReflectionName Interface Methods See Also Send Feedback

The IWriteReflectionName type exposes the following members.

Methods

 | Name | Description
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

See Also

IWriteReflectionName Interface
PostSharp.Sdk.CodeModel Namespace


IWriteReflectionName Methods

[image]

PostSharp 2.0 Documentation
IWriteReflectionName Methods
IWriteReflectionName Interface See Also Send Feedback

The IWriteReflectionName type exposes the following members.

Methods

 | Name | Description
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

See Also

IWriteReflectionName Interface
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

IWriteReflectionName..::..WriteReflectionName Method
IWriteReflectionName Interface See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

See Also

IWriteReflectionName Interface
PostSharp.Sdk.CodeModel Namespace


LiteralString Structure

LiteralString Structure
Members See Also Send Feedback
Encapsulates a read-only array of characters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct LiteralString : IEquatable<LiteralString>

Remarks

We use LiteralString instead of String because String sometimes transforms the array of characters, but we require binary identity between what we read and what we writer.

See Also

LiteralString Members
PostSharp.Sdk.CodeModel Namespace


LiteralString Members

[image]

PostSharp 2.0 Documentation
LiteralString Members
LiteralString Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The LiteralString type exposes the following members.

Constructors

 | Name | Description
Public method | LiteralString | Overloaded.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetChar | Gets a character given its position.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Convert this instance to a String. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two strings are equal.
Implicit(String) | Converts a String to a LiteralString.
Inequality | Determines whether two strings are different.

Fields

Name | Description
Null | Represents a null LiteralString.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current instance represents a null string.
Public property | Length | Gets the string length.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


LiteralString Constructor

[image]

PostSharp 2.0 Documentation
LiteralString Constructor
LiteralString Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | LiteralString(array<Char>[]()[]) | Initializes a new LiteralString from an array of characters.
Public method | LiteralString(String) | Initializes a new LiteralString from a string.

See Also

LiteralString Structure
LiteralString Members
PostSharp.Sdk.CodeModel Namespace


LiteralString Constructor (Char[])

LiteralString Constructor (array<Char>[]()[][])
LiteralString Structure See Also Send Feedback
Initializes a new LiteralString from an array of characters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LiteralString(
    char[] chars
)

Parameters

chars
Type: array< System..::.Char >[]()[][]
An array of characters, or null to construct a null LiteralString.

Remarks

For performance reasons, the current constructor stores a reference to chars, i.e. does not take a copy of the array.

See Also

LiteralString Structure
LiteralString Overload
PostSharp.Sdk.CodeModel Namespace


LiteralString Constructor (String)

LiteralString Constructor (String)
LiteralString Structure See Also Send Feedback
Initializes a new LiteralString from a string.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LiteralString(
    string text
)

Parameters

text
Type: System..::.String
A string, or null to construct a null LiteralString.

See Also

LiteralString Structure
LiteralString Overload
PostSharp.Sdk.CodeModel Namespace


LiteralString Fields

[image]

PostSharp 2.0 Documentation
LiteralString Fields
LiteralString Structure See Also Send Feedback

The LiteralString type exposes the following members.

Fields

Name | Description
Null | Represents a null LiteralString.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Null Field

LiteralString..::..Null Field
LiteralString Structure See Also Send Feedback
Represents a null LiteralString.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly LiteralString Null

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


LiteralString Methods

[image]

PostSharp 2.0 Documentation
LiteralString Methods
LiteralString Structure See Also Send Feedback

The LiteralString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetChar | Gets a character given its position.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Convert this instance to a String. (Overrides ValueType..::.ToString()()().)

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
LiteralString..::..Equals Method
LiteralString Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(LiteralString) | Indicates whether the current object is equal to another object of the same type.

See Also

LiteralString Structure
LiteralString Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (Object)

LiteralString..::..Equals Method (Object)
LiteralString Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

LiteralString Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (LiteralString)

LiteralString..::..Equals Method (LiteralString)
LiteralString Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    LiteralString other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.LiteralString
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

LiteralString Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetChar Method

LiteralString..::..GetChar Method
LiteralString Structure See Also Send Feedback
Gets a character given its position.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public char GetChar(
    int index
)

Parameters

index
Type: System..::.Int32
The character position.

Return Value

The character at position index.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The LiteralString is null.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


GetHashCode Method

LiteralString..::..GetHashCode Method
LiteralString Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

LiteralString..::..ToString Method
LiteralString Structure See Also Send Feedback
Convert this instance to a String.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

The String contained in the current instance, or null if the current instance is null.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


LiteralString Operators and Type Conversions

[image]

PostSharp 2.0 Documentation
LiteralString Operators and Type Conversions
LiteralString Structure See Also Send Feedback

The LiteralString type exposes the following members.

Operators

Name | Description
Equality | Determines whether two strings are equal.
Implicit(String) | Converts a String to a LiteralString.
Inequality | Determines whether two strings are different.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Equality Operator

LiteralString..::..Equality Operator
LiteralString Structure See Also Send Feedback
Determines whether two strings are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    LiteralString left,
    LiteralString right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.LiteralString
A LiteralString.
right
Type: PostSharp.Sdk.CodeModel..::.LiteralString
A LiteralString.

Return Value

true if both strings are equal, otherwise false.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Implicit Conversion (String to LiteralString)

LiteralString ImplicitWideningImplicitImplicitImplicit Conversion (String to LiteralString)
LiteralString Structure See Also Send Feedback
Converts a String to a LiteralString.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static implicit operator LiteralString (
    string text
)

Parameters

text
Type: System..::.String
A string, or null to construct a null LiteralString.

Return Value

A LiteralString.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Inequality Operator

LiteralString..::..Inequality Operator
LiteralString Structure See Also Send Feedback
Determines whether two strings are different.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    LiteralString left,
    LiteralString right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.LiteralString
A LiteralString.
right
Type: PostSharp.Sdk.CodeModel..::.LiteralString
A LiteralString.

Return Value

true if both strings are different, otherwise false.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


LiteralString Properties

[image]

PostSharp 2.0 Documentation
LiteralString Properties
LiteralString Structure See Also Send Feedback

The LiteralString type exposes the following members.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current instance represents a null string.
Public property | Length | Gets the string length.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


IsNull Property

LiteralString..::..IsNull Property
LiteralString Structure See Also Send Feedback
Determines whether the current instance represents a null string.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNull { get; }

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


Length Property

LiteralString..::..Length Property
LiteralString Structure See Also Send Feedback
Gets the string length.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Length { get; }

Field Value

The number of characters in the array.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The LiteralString is null.

See Also

LiteralString Structure
PostSharp.Sdk.CodeModel Namespace


LocalVariableDeclaration Class

LocalVariableDeclaration Class
Members See Also Send Feedback
Represents a local variable. Local variables are owned by method bodies (MethodBodyDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocalVariableDeclaration : Declaration,
    ICloneable, IPositioned

Remarks

A LocalVariableDeclaration it referenced by ordinal; it has no name. Positions are assigned to a name in lexical scopes. Lexical scopes are implemented by the InstructionBlock type and assignment of names to a local variable are done by the LocalVariableSymbol type.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.LocalVariableDeclaration

See Also

LocalVariableDeclaration Members
PostSharp.Sdk.CodeModel Namespace


LocalVariableDeclaration Members

[image]

PostSharp 2.0 Documentation
LocalVariableDeclaration Members
LocalVariableDeclaration Class Methods Properties See Also Send Feedback

The LocalVariableDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Clones the current instance.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsReadOnly | Determines whether the current variable is read-only.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Ordinal | Gets the local variable ordinal.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Type | Gets or sets the local variable type.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableDeclaration Methods

[image]

PostSharp 2.0 Documentation
LocalVariableDeclaration Methods
LocalVariableDeclaration Class See Also Send Feedback

The LocalVariableDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Clones the current instance.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

LocalVariableDeclaration..::..Clone Method
LocalVariableDeclaration Class See Also Send Feedback
Clones the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclaration Clone()

Return Value

A clone of the current instance (but unattached).

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

LocalVariableDeclaration..::..ToString Method
LocalVariableDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableDeclaration Properties

[image]

PostSharp 2.0 Documentation
LocalVariableDeclaration Properties
LocalVariableDeclaration Class See Also Send Feedback

The LocalVariableDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsReadOnly | Determines whether the current variable is read-only.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Ordinal | Gets the local variable ordinal.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Type | Gets or sets the local variable type.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsReadOnly Property

LocalVariableDeclaration..::..IsReadOnly Property
LocalVariableDeclaration Class See Also Send Feedback
Determines whether the current variable is read-only.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Remarks

A local variable may be read-only if it is owned by a StandaloneSignatureDeclaration. This constraint is defined by PostSharp because, in this case, the variable is shared by many method bodies.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

LocalVariableDeclaration..::..Ordinal Property
LocalVariableDeclaration Class See Also Send Feedback
Gets the local variable ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; }

Field Value

A positive integer.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Type Property

LocalVariableDeclaration..::..Type Property
LocalVariableDeclaration Class See Also Send Feedback
Gets or sets the local variable type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Type { get; set; }

Field Value

Any TypeSignature.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Trying to set the property to null.

See Also

LocalVariableDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableSymbol Class

LocalVariableSymbol Class
Members See Also Send Feedback
Assigns a name to a local variable LocalVariableDeclaration. Local variable symbols belong to an InstructionBlock, which is in the current case the lexical scope of the variable.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocalVariableSymbol : IComparable<LocalVariableSymbol>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.LocalVariableSymbol

See Also

LocalVariableSymbol Members
PostSharp.Sdk.CodeModel Namespace


LocalVariableSymbol Members

[image]

PostSharp 2.0 Documentation
LocalVariableSymbol Members
LocalVariableSymbol Class Methods Properties See Also Send Feedback

The LocalVariableSymbol type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals |
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | LocalVariable | Gets or sets the named LocalVariableDeclaration.
Public property | Name | Gets or sets the local variable name.

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableSymbol Methods

[image]

PostSharp 2.0 Documentation
LocalVariableSymbol Methods
LocalVariableSymbol Class See Also Send Feedback

The LocalVariableSymbol type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals |
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


CompareTo Method

LocalVariableSymbol..::..CompareTo Method
LocalVariableSymbol Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int CompareTo(
    LocalVariableSymbol other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
An object to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter. Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

LocalVariableSymbol..::..Equals Method
LocalVariableSymbol Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.LocalVariableSymbol.Equals(PostSharp.Sdk.CodeModel.LocalVariableSymbol)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    LocalVariableSymbol other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol

[Missing <param name="other"/> documentation for "M:PostSharp.Sdk.CodeModel.LocalVariableSymbol.Equals(PostSharp.Sdk.CodeModel.LocalVariableSymbol)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.LocalVariableSymbol.Equals(PostSharp.Sdk.CodeModel.LocalVariableSymbol)"]

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

LocalVariableSymbol..::..ToString Method
LocalVariableSymbol Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableSymbol Properties

[image]

PostSharp 2.0 Documentation
LocalVariableSymbol Properties
LocalVariableSymbol Class See Also Send Feedback

The LocalVariableSymbol type exposes the following members.

Properties

 | Name | Description
Public property | LocalVariable | Gets or sets the named LocalVariableDeclaration.
Public property | Name | Gets or sets the local variable name.

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


LocalVariable Property

LocalVariableSymbol..::..LocalVariable Property
LocalVariableSymbol Class See Also Send Feedback
Gets or sets the named LocalVariableDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclaration LocalVariable { get; set; }

Field Value

A LocalVariableDeclaration.

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


Name Property

LocalVariableSymbol..::..Name Property
LocalVariableSymbol Class See Also Send Feedback
Gets or sets the local variable name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

Field Value

The local variable name, or null if the local variable is not named in the current scope.

See Also

LocalVariableSymbol Class
PostSharp.Sdk.CodeModel Namespace


ManifestFileDeclaration Class

ManifestFileDeclaration Class
Members See Also Send Feedback
Represents a file reference (File).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManifestFileDeclaration : NamedMetadataDeclaration,
    IManifestResourceImplementation

Remarks

File references are owned by the AssemblyManifestDeclaration.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ManifestFileDeclaration

See Also

ManifestFileDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ManifestFileDeclaration Members

[image]

PostSharp 2.0 Documentation
ManifestFileDeclaration Members
ManifestFileDeclaration Class Constructors Methods Properties See Also Send Feedback

The ManifestFileDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ManifestFileDeclaration | Initializes a new instance of the ManifestFileDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Hash | Gets or sets the file hash value.
Public property | HasMetadata | Determines whether the referenced file has CLI metadata.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestFileDeclaration Constructor

ManifestFileDeclaration Constructor
ManifestFileDeclaration Class See Also Send Feedback
Initializes a new instance of the ManifestFileDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManifestFileDeclaration()

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestFileDeclaration Methods

[image]

PostSharp 2.0 Documentation
ManifestFileDeclaration Methods
ManifestFileDeclaration Class See Also Send Feedback

The ManifestFileDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ManifestFileDeclaration..::..GetTokenType Method
ManifestFileDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestFileDeclaration Properties

[image]

PostSharp 2.0 Documentation
ManifestFileDeclaration Properties
ManifestFileDeclaration Class See Also Send Feedback

The ManifestFileDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Hash | Gets or sets the file hash value.
Public property | HasMetadata | Determines whether the referenced file has CLI metadata.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Hash Property

ManifestFileDeclaration..::..Hash Property
ManifestFileDeclaration Class See Also Send Feedback
Gets or sets the file hash value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] Hash { get; set; }

Field Value

An array of bytes containing the file hash, or null if the hash value was not computed.

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HasMetadata Property

ManifestFileDeclaration..::..HasMetadata Property
ManifestFileDeclaration Class See Also Send Feedback
Determines whether the referenced file has CLI metadata.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasMetadata { get; set; }

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ManifestFileDeclaration..::..ParentMember Property
ManifestFileDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ManifestFileDeclaration..::..ParentType Property
ManifestFileDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

ManifestFileDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestResourceDeclaration Class

ManifestResourceDeclaration Class
Members See Also Send Feedback
Represents a resource referenced by the assembly (ManifestResource).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManifestResourceDeclaration : NamedMetadataDeclaration

Remarks

Resources are owned by a AssemblyManifestDeclaration but can be stored physically ("implemented") in the current assemly, an external assembly (AssemblyRefDeclaration) or a file (ManifestFileDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ManifestResourceDeclaration

See Also

ManifestResourceDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ManifestResourceDeclaration Members

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclaration Members
ManifestResourceDeclaration Class Constructors Methods Properties See Also Send Feedback

The ManifestResourceDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ManifestResourceDeclaration | Initializes a new instance of the ManifestResourceDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | ContentStreamProvider | Gets or sets a method that returns a read-only Stream giving the resource content.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FileOffset | Gets the offset of the resource in the external file.
Public property | Implementation | Gets or sets the resource implementation, i.e. its physical location.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsPublic | Determines whether the resource is public.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestResourceDeclaration Constructor

ManifestResourceDeclaration Constructor
ManifestResourceDeclaration Class See Also Send Feedback
Initializes a new instance of the ManifestResourceDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ManifestResourceDeclaration()

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestResourceDeclaration Methods

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclaration Methods
ManifestResourceDeclaration Class See Also Send Feedback

The ManifestResourceDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ManifestResourceDeclaration..::..GetTokenType Method
ManifestResourceDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ManifestResourceDeclaration Properties

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclaration Properties
ManifestResourceDeclaration Class See Also Send Feedback

The ManifestResourceDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | ContentStreamProvider | Gets or sets a method that returns a read-only Stream giving the resource content.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FileOffset | Gets the offset of the resource in the external file.
Public property | Implementation | Gets or sets the resource implementation, i.e. its physical location.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsPublic | Determines whether the resource is public.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ContentStreamProvider Property

ManifestResourceDeclaration..::..ContentStreamProvider Property
ManifestResourceDeclaration Class See Also Send Feedback
Gets or sets a method that returns a read-only Stream giving the resource content.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Func<Stream> ContentStreamProvider { get; set; }

Field Value

A delegate returning a Stream with Seek capability, or null if the resource is not stored in the declaring assembly.

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FileOffset Property

ManifestResourceDeclaration..::..FileOffset Property
ManifestResourceDeclaration Class See Also Send Feedback
Gets the offset of the resource in the external file.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int FileOffset { get; set; }

Field Value

A positive integer equal to the offset of the resource in case Implementation is a ManifestFileDeclaration, otherwise 0.

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Implementation Property

ManifestResourceDeclaration..::..Implementation Property
ManifestResourceDeclaration Class See Also Send Feedback
Gets or sets the resource implementation, i.e. its physical location.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IManifestResourceImplementation Implementation { get; set; }

Field Value

An IManifestResourceImplementation (AssemblyRefDeclaration, ManifestFileDeclaration), or null if the resource is stored in its declaring assembly.

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsPublic Property

ManifestResourceDeclaration..::..IsPublic Property
ManifestResourceDeclaration Class See Also Send Feedback
Determines whether the resource is public.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsPublic { get; set; }

Field Value

true if the resource is public, otherwise false.

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ManifestResourceDeclaration..::..ParentMember Property
ManifestResourceDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ManifestResourceDeclaration..::..ParentType Property
ManifestResourceDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

ManifestResourceDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MappedGenericDeclaration(?0) Structure

MappedGenericDeclaration<(Of <(<'?0>)>)> Structure
Members See Also Send Feedback
Pair of a generic definition (IGenericDefinition) and a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct MappedGenericDeclaration<?0>
where ?0 : IGenericDefinition

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.MappedGenericDeclaration`1"]

See Also

MappedGenericDeclaration<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel Namespace


MappedGenericDeclaration(?0) Members

[image]

PostSharp 2.0 Documentation
MappedGenericDeclaration<(Of <(<'?0>)>)> Members
MappedGenericDeclaration<(Of <(?0>)>) Structure Constructors Methods Properties See Also Send Feedback

The MappedGenericDeclaration<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MappedGenericDeclaration<(Of <(?0>)>) | Initializes a new MappedGenericDeclaration<(Of <(?0>)>).

Methods

 | Name | Description
Public method | Apply | Apply a GenericMap to the current MappedGenericDeclaration<(Of <(?0>)>).
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Properties

 | Name | Description
Public property | Declaration | Gets the generic definition.
Public property | GenericMap | Gets the GenericMap.

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


MappedGenericDeclaration(?0) Constructor

MappedGenericDeclaration<(Of <(<'?0>)>)> Constructor
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback
Initializes a new MappedGenericDeclaration<(Of <(?0>)>).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MappedGenericDeclaration(
    ?0 declaration,
    GenericMap genericMap
)

Parameters

declaration
Type: ?0
A generic definition.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
A GenericMap

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


MappedGenericDeclaration(?0) Methods

[image]

PostSharp 2.0 Documentation
MappedGenericDeclaration<(Of <(<'?0>)>)> Methods
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback

The MappedGenericDeclaration<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply a GenericMap to the current MappedGenericDeclaration<(Of <(?0>)>).
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


Apply Method

MappedGenericDeclaration<(Of <(<'?0>)>)>..::..Apply Method
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback
Apply a GenericMap to the current MappedGenericDeclaration<(Of <(?0>)>).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MappedGenericDeclaration<?0> Apply(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
A GenericMap.

Return Value

A new MappedGenericDeclaration<(Of <(?0>)>) where the GenericMap has been transformed by genericMap.

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

MappedGenericDeclaration<(Of <(<'?0>)>)>..::..ToString Method
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


MappedGenericDeclaration(?0) Properties

[image]

PostSharp 2.0 Documentation
MappedGenericDeclaration<(Of <(<'?0>)>)> Properties
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback

The MappedGenericDeclaration<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Declaration | Gets the generic definition.
Public property | GenericMap | Gets the GenericMap.

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


Declaration Property

MappedGenericDeclaration<(Of <(<'?0>)>)>..::..Declaration Property
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback
Gets the generic definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Declaration { get; }

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


GenericMap Property

MappedGenericDeclaration<(Of <(<'?0>)>)>..::..GenericMap Property
MappedGenericDeclaration<(Of <(?0>)>) Structure See Also Send Feedback
Gets the GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GenericMap { get; }

See Also

MappedGenericDeclaration<(Of <(?0>)>) Structure
PostSharp.Sdk.CodeModel Namespace


MarshalType Class

MarshalType Class
See Also Send Feedback
Marshal types. Determines how fields and parameters are marshaled during PInvoke.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MarshalType

Remarks

Concrete implementations are in the PostSharp.Sdk.CodeModel.MarshalTypes namespace.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.ArrayMarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.CustomMarshallerMarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.FixedArrayMarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.FixedStringMarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.IntrinsicMarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.SafeArrayMarshalType

See Also

PostSharp.Sdk.CodeModel Namespace


MemberKind Enumeration

MemberKind Enumeration
See Also Send Feedback
Enumerates the kinds of type members.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum MemberKind

Members

Member name | Value | Description
Type | 0 | Type.
Field | 1 | Field.
Property | 2 | Property.
Method | 3 | Method.
Event | 4 | Event.
Parameter | 5 | Method parameter.

See Also

PostSharp.Sdk.CodeModel Namespace


MemberRefDeclaration Class

MemberRefDeclaration Class
Members See Also Send Feedback
Represents a reference to a field or method (MemberRef). This type is the base of FieldRefDeclaration and MethodRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MemberRefDeclaration : NamedMetadataDeclaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MemberRefDeclaration
PostSharp.Sdk.CodeModel..::.FieldRefDeclaration
PostSharp.Sdk.CodeModel..::.MethodRefDeclaration

See Also

MemberRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MemberRefDeclaration Members

[image]

PostSharp 2.0 Documentation
MemberRefDeclaration Members
MemberRefDeclaration Class Methods Properties See Also Send Feedback

The MemberRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Overrides Declaration..::.DeclaringAssembly.)
Public property | DeclaringType | Gets the declaring IType.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MemberRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
MemberRefDeclaration Methods
MemberRefDeclaration Class See Also Send Feedback

The MemberRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MemberRefDeclaration..::..GetTokenType Method
MemberRefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override sealed TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MemberRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
MemberRefDeclaration Properties
MemberRefDeclaration Class See Also Send Feedback

The MemberRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Overrides Declaration..::.DeclaringAssembly.)
Public property | DeclaringType | Gets the declaring IType.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

MemberRefDeclaration..::..DeclaringAssembly Property
MemberRefDeclaration Class See Also Send Feedback
Gets the assembly in which the member is defined.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAssembly DeclaringAssembly { get; }

Field Value

An IAssembly.

Implements

IModuleElement..::.DeclaringAssembly

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

MemberRefDeclaration..::..DeclaringType Property
MemberRefDeclaration Class See Also Send Feedback
Gets the declaring IType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType DeclaringType { get; }

Field Value

The declaring type (TypeRefDeclaration or TypeSpecDeclaration) or null if ResolutionScope is not a type.

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ResolutionScope Property

MemberRefDeclaration..::..ResolutionScope Property
MemberRefDeclaration Class See Also Send Feedback
Gets scope in which the current reference should be resolved.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMemberRefResolutionScope ResolutionScope { get; }

See Also

MemberRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MemberValuePair Class

MemberValuePair Class
Members See Also Send Feedback
Represents the fact that a member is assigned a value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MemberValuePair : ICloneableModuleElement,
    IModuleElement, IPositioned, INamed

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MemberValuePair

See Also

MemberValuePair Members
PostSharp.Sdk.CodeModel Namespace


MemberValuePair Members

[image]

PostSharp 2.0 Documentation
MemberValuePair Members
MemberValuePair Class Constructors Methods Properties See Also Send Feedback

The MemberValuePair type exposes the following members.

Constructors

 | Name | Description
Public method | MemberValuePair | Initializes a new MemberValuePair.

Methods

 | Name | Description
Public method | Clone | Clone the current instance, but sets another ordinal.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the current MemberValuePair so that it can be used in another module.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | MemberKind | Kind of member (Field, Parameter or Property).
Public property | MemberName | Member name.
Public property | Module | Gets the declaring module.
Public property | Ordinal | Gets the ordinal of this instance in the parent collection.
Public property | Value | Member value.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MemberValuePair Constructor

MemberValuePair Constructor
MemberValuePair Class See Also Send Feedback
Initializes a new MemberValuePair.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePair(
    MemberKind memberKind,
    int ordinal,
    string memberName,
    SerializedValue value
)

Parameters

memberKind
Type: PostSharp.Sdk.CodeModel..::.MemberKind
Member kind (Field, Parameter or Property).
ordinal
Type: System..::.Int32
Ordinal of this instance in the parent collection.
memberName
Type: System..::.String
Member name.
value
Type: PostSharp.Sdk.CodeModel..::.SerializedValue
Value.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MemberValuePair Methods

[image]

PostSharp 2.0 Documentation
MemberValuePair Methods
MemberValuePair Class See Also Send Feedback

The MemberValuePair type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clone the current instance, but sets another ordinal.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the current MemberValuePair so that it can be used in another module.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

MemberValuePair..::..Clone Method
MemberValuePair Class See Also Send Feedback
Clone the current instance, but sets another ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePair Clone(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The ordinal of the new instance.

Return Value

A clone of the current instance, but with the specified ordinal.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

MemberValuePair..::..ToString Method
MemberValuePair Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

MemberValuePair..::..Translate Method
MemberValuePair Class See Also Send Feedback
Translates the current MemberValuePair so that it can be used in another module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePair Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module into which the translated instance should be expressed.

Return Value

A new MemberValuePair equivalent to the current one, but expressed for the other module.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MemberValuePair Properties

[image]

PostSharp 2.0 Documentation
MemberValuePair Properties
MemberValuePair Class See Also Send Feedback

The MemberValuePair type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | MemberKind | Kind of member (Field, Parameter or Property).
Public property | MemberName | Member name.
Public property | Module | Gets the declaring module.
Public property | Ordinal | Gets the ordinal of this instance in the parent collection.
Public property | Value | Member value.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

MemberValuePair..::..DeclaringAssembly Property
MemberValuePair Class See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly DeclaringAssembly { get; }

Implements

IModuleElement..::.DeclaringAssembly

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MemberKind Property

MemberValuePair..::..MemberKind Property
MemberValuePair Class See Also Send Feedback
Kind of member (Field, Parameter or Property).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberKind MemberKind { get; }

Field Value

A MemberKind.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MemberName Property

MemberValuePair..::..MemberName Property
MemberValuePair Class See Also Send Feedback
Member name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MemberName { get; }

Field Value

A non-empty string.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


Module Property

MemberValuePair..::..Module Property
MemberValuePair Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

MemberValuePair..::..Ordinal Property
MemberValuePair Class See Also Send Feedback
Gets the ordinal of this instance in the parent collection.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; }

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


Value Property

MemberValuePair..::..Value Property
MemberValuePair Class See Also Send Feedback
Member value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue Value { get; set; }

Field Value

A SerializedValue.

See Also

MemberValuePair Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclaration Class

MetadataDeclaration Class
Members See Also Send Feedback
Base class for all declarations represented in the metadata tables. Metadata declarations have a token (MetadataToken) and may have custom attributes (CustomAttributeDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MetadataDeclaration : Declaration,
    IMetadataDeclaration, IDeclaration, IElement, IModuleElement, ITaggable,
    IDisposable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.CustomAttributeDeclaration
PostSharp.Sdk.CodeModel..::.GenericParameterConstraintDeclaration
PostSharp.Sdk.CodeModel..::.InterfaceImplementationDeclaration
PostSharp.Sdk.CodeModel..::.MethodImplementationDeclaration
PostSharp.Sdk.CodeModel..::.MethodSemanticDeclaration
PostSharp.Sdk.CodeModel..::.MethodSpecDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ParameterDeclaration
PostSharp.Sdk.CodeModel..::.PermissionSetDeclaration
PostSharp.Sdk.CodeModel..::.StandaloneSignatureDeclaration
PostSharp.Sdk.CodeModel..::.TypeSpecDeclaration

See Also

MetadataDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MetadataDeclaration Members

[image]

PostSharp 2.0 Documentation
MetadataDeclaration Members
MetadataDeclaration Class Methods Properties See Also Send Feedback

The MetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTokenType | Gets the TokenType of the derived declaration.
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed.
Public property | MetadataToken | Gets or sets the token of the current declaration.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration.
Public property | ParentType | Gets the parent type of the current declaration.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclaration Methods

[image]

PostSharp 2.0 Documentation
MetadataDeclaration Methods
MetadataDeclaration Class See Also Send Feedback

The MetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTokenType | Gets the TokenType of the derived declaration.
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration.

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

MetadataDeclaration..::..Dispose Method
MetadataDeclaration Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTag Method

MetadataDeclaration..::..GetTag Method
MetadataDeclaration Class See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

Implements

ITaggable..::.GetTag(TagId)

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MetadataDeclaration..::..GetTokenType Method
MetadataDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetTag Method

MetadataDeclaration..::..SetTag Method
MetadataDeclaration Class See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

Implements

ITaggable..::.SetTag(TagId, Object)

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclaration Properties

[image]

PostSharp 2.0 Documentation
MetadataDeclaration Properties
MetadataDeclaration Class See Also Send Feedback

The MetadataDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed.
Public property | MetadataToken | Gets or sets the token of the current declaration.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration.
Public property | ParentType | Gets the parent type of the current declaration.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CustomAttributes Property

MetadataDeclaration..::..CustomAttributes Property
MetadataDeclaration Class See Also Send Feedback
Gets the collection of custom attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclarationCollection CustomAttributes { get; }

Implements

IMetadataDeclaration..::.CustomAttributes

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsDisposed Property

MetadataDeclaration..::..IsDisposed Property
MetadataDeclaration Class See Also Send Feedback
Determines whether the current instance is disposed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; private set; }

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataToken Property

MetadataDeclaration..::..MetadataToken Property
MetadataDeclaration Class See Also Send Feedback
Gets or sets the token of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataToken MetadataToken { get; internal set; }

Field Value

A MetadataToken.

Implements

IMetadataDeclaration..::.MetadataToken

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MetadataDeclaration..::..ParentMember Property
MetadataDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MetadataDeclaration..::..ParentType Property
MetadataDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

MetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclarationTables Class

MetadataDeclarationTables Class
Members See Also Send Feedback
Exposes the metadata tables.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MetadataDeclarationTables

Remarks

These provide a by-token access to all metadata declarations of the assembly. This class is accessible on the Tables()()() property.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MetadataDeclarationTables

See Also

MetadataDeclarationTables Members
PostSharp.Sdk.CodeModel Namespace


MetadataDeclarationTables Members

[image]

PostSharp 2.0 Documentation
MetadataDeclarationTables Members
MetadataDeclarationTables Class Methods Fields See Also Send Feedback

The MetadataDeclarationTables type exposes the following members.

Methods

 | Name | Description
Public method | AddStronglyReferencedDeclaration | Adds a MetadataDeclaration to the proper table.
Public method | GetDeclaration | Gets the MetadataDeclaration given its MetadataToken.
Public method | GetEnumerator | Gets an enumerator of all declarations of a given TokenType.
Public method | GetField | Gets the IField corresponding to a given MetadataToken.
Public method | GetMemberRef | Gets the MemberRefDeclaration corresponding to a given MetadataToken.
Public method | GetMethod | Gets the IMethod corresponding to a given MetadataToken.
Public method | GetStandaloneSignature | Gets the StandaloneSignatureDeclaration corresponding to a given MetadataToken.
Public method | GetType | Gets the IType corresponding to a given MetadataToken.
Public method | GetUserString | Gets the LiteralString corresponding to a given MetadataToken.
Public method | RemoveDeclaration | Removes a MetadataDeclaration from its table.
Public method | RvaToPointer | Gets the physical address corresponding to a given RVA.

Fields

Name | Description
TableCount | Number of metadata tables.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclarationTables Fields

[image]

PostSharp 2.0 Documentation
MetadataDeclarationTables Fields
MetadataDeclarationTables Class See Also Send Feedback

The MetadataDeclarationTables type exposes the following members.

Fields

Name | Description
TableCount | Number of metadata tables.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


TableCount Field

MetadataDeclarationTables..::..TableCount Field
MetadataDeclarationTables Class See Also Send Feedback
Number of metadata tables.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int TableCount

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


MetadataDeclarationTables Methods

[image]

PostSharp 2.0 Documentation
MetadataDeclarationTables Methods
MetadataDeclarationTables Class See Also Send Feedback

The MetadataDeclarationTables type exposes the following members.

Methods

 | Name | Description
Public method | AddStronglyReferencedDeclaration | Adds a MetadataDeclaration to the proper table.
Public method | GetDeclaration | Gets the MetadataDeclaration given its MetadataToken.
Public method | GetEnumerator | Gets an enumerator of all declarations of a given TokenType.
Public method | GetField | Gets the IField corresponding to a given MetadataToken.
Public method | GetMemberRef | Gets the MemberRefDeclaration corresponding to a given MetadataToken.
Public method | GetMethod | Gets the IMethod corresponding to a given MetadataToken.
Public method | GetStandaloneSignature | Gets the StandaloneSignatureDeclaration corresponding to a given MetadataToken.
Public method | GetType | Gets the IType corresponding to a given MetadataToken.
Public method | GetUserString | Gets the LiteralString corresponding to a given MetadataToken.
Public method | RemoveDeclaration | Removes a MetadataDeclaration from its table.
Public method | RvaToPointer | Gets the physical address corresponding to a given RVA.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


AddStronglyReferencedDeclaration Method

MetadataDeclarationTables..::..AddStronglyReferencedDeclaration Method
MetadataDeclarationTables Class See Also Send Feedback
Adds a MetadataDeclaration to the proper table.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataToken AddStronglyReferencedDeclaration(
    MetadataDeclaration declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
A MetadataDeclaration with null token.

Return Value

The new MetadataToken of declaration.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetDeclaration Method

MetadataDeclarationTables..::..GetDeclaration Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the MetadataDeclaration given its MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration GetDeclaration(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

The MetadataDeclaration whose token is token, or null if token is null.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetEnumerator Method

MetadataDeclarationTables..::..GetEnumerator Method
MetadataDeclarationTables Class See Also Send Feedback
Gets an enumerator of all declarations of a given TokenType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<MetadataDeclaration> GetEnumerator(
    TokenType tokenType
)

Parameters

tokenType
Type: PostSharp.Sdk.CodeModel..::.TokenType
A TokenType.

Return Value

An enumerator.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetField Method

MetadataDeclarationTables..::..GetField Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the IField corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetField(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An IField, or null if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetMemberRef Method

MetadataDeclarationTables..::..GetMemberRef Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the MemberRefDeclaration corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberRefDeclaration GetMemberRef(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An MemberRefDeclaration, or null if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetMethod Method

MetadataDeclarationTables..::..GetMethod Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the IMethod corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetMethod(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An IMethod, or null if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetStandaloneSignature Method

MetadataDeclarationTables..::..GetStandaloneSignature Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the StandaloneSignatureDeclaration corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneSignatureDeclaration GetStandaloneSignature(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An StandaloneSignatureDeclaration, or null if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetType Method

MetadataDeclarationTables..::..GetType Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the IType corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetType(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An IType, or null if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


GetUserString Method

MetadataDeclarationTables..::..GetUserString Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the LiteralString corresponding to a given MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LiteralString GetUserString(
    MetadataToken token
)

Parameters

token
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

An LiteralString, or a null LiteralString if the current token was not found in the tables.

Exceptions

Exception | Condition
System..::.ArgumentException | The token type is invalid.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


RemoveDeclaration Method

MetadataDeclarationTables..::..RemoveDeclaration Method
MetadataDeclarationTables Class See Also Send Feedback
Removes a MetadataDeclaration from its table.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveDeclaration(
    MetadataDeclaration declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
A MetadataDeclaration with non null token.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


RvaToPointer Method

MetadataDeclarationTables..::..RvaToPointer Method
MetadataDeclarationTables Class See Also Send Feedback
Gets the physical address corresponding to a given RVA.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntPtr RvaToPointer(
    uint rva
)

Parameters

rva
Type: System..::.UInt32
A RVA (offset relative to the first byte of the PE image).

Return Value

A pointer to the location corresponding to rva.

See Also

MetadataDeclarationTables Class
PostSharp.Sdk.CodeModel Namespace


MetadataToken Structure

MetadataToken Structure
Members See Also Send Feedback
Encapsulates a metadata token, which unambiguously identifies a MetadataDeclaration inside a ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct MetadataToken : IComparable<MetadataToken>,
    IEquatable<MetadataToken>

See Also

MetadataToken Members
PostSharp.Sdk.CodeModel Namespace


MetadataToken Members

[image]

PostSharp 2.0 Documentation
MetadataToken Members
MetadataToken Structure Methods Operators Fields Properties See Also Send Feedback

The MetadataToken type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two metadata tokens are equal.
Inequality | Determines whether two metadata tokens are different.

Fields

Name | Description
Null | Null MetadataToken.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current token is null.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


MetadataToken Fields

[image]

PostSharp 2.0 Documentation
MetadataToken Fields
MetadataToken Structure See Also Send Feedback

The MetadataToken type exposes the following members.

Fields

Name | Description
Null | Null MetadataToken.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


Null Field

MetadataToken..::..Null Field
MetadataToken Structure See Also Send Feedback
Null MetadataToken.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MetadataToken Null

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


MetadataToken Methods

[image]

PostSharp 2.0 Documentation
MetadataToken Methods
MetadataToken Structure See Also Send Feedback

The MetadataToken type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


CompareTo Method

MetadataToken..::..CompareTo Method
MetadataToken Structure See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int CompareTo(
    MetadataToken other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
An object to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter. Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
MetadataToken..::..Equals Method
MetadataToken Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(MetadataToken) | Indicates whether the current object is equal to another object of the same type.

See Also

MetadataToken Structure
MetadataToken Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (Object)

MetadataToken..::..Equals Method (Object)
MetadataToken Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

MetadataToken Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (MetadataToken)

MetadataToken..::..Equals Method (MetadataToken)
MetadataToken Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    MetadataToken other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MetadataToken Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetHashCode Method

MetadataToken..::..GetHashCode Method
MetadataToken Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

MetadataToken..::..ToString Method
MetadataToken Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


MetadataToken Operators

[image]

PostSharp 2.0 Documentation
MetadataToken Operators
MetadataToken Structure See Also Send Feedback

The MetadataToken type exposes the following members.

Operators

Name | Description
Equality | Determines whether two metadata tokens are equal.
Inequality | Determines whether two metadata tokens are different.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


Equality Operator

MetadataToken..::..Equality Operator
MetadataToken Structure See Also Send Feedback
Determines whether two metadata tokens are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    MetadataToken left,
    MetadataToken right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.
right
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

true if both tokens are equal, otherwise false.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


Inequality Operator

MetadataToken..::..Inequality Operator
MetadataToken Structure See Also Send Feedback
Determines whether two metadata tokens are different.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    MetadataToken left,
    MetadataToken right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.
right
Type: PostSharp.Sdk.CodeModel..::.MetadataToken
A MetadataToken.

Return Value

true if tokens are different, otherwise false.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


MetadataToken Properties

[image]

PostSharp 2.0 Documentation
MetadataToken Properties
MetadataToken Structure See Also Send Feedback

The MetadataToken type exposes the following members.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current token is null.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


IsNull Property

MetadataToken..::..IsNull Property
MetadataToken Structure See Also Send Feedback
Determines whether the current token is null.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNull { get; }

Field Value

true if the current token is null, otherwise false.

See Also

MetadataToken Structure
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Class

MethodBodyDeclaration Class
Members See Also Send Feedback
Represents the IL body of a method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodBodyDeclaration : Declaration,
    IDisposable

Remarks

Method bodies are owned by methods (MethodDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MethodBodyDeclaration

See Also

MethodBodyDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration Members
MethodBodyDeclaration Class Constructors Methods Fields Properties See Also Send Feedback

The MethodBodyDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodBodyDeclaration | Initializes a new instance of the MethodBodyDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | CreateInstructionBlock | Creates an InstructionBlock for the current method body.
Public method | CreateInstructionReader | Overloaded.
Public method | CreateInstructionSequence | Creates an InstructionSequence for the current method body.
Public method | CreateLocalVariable | Creates a local variable for the current method body.
Public method | CreateOriginalInstructionReader | Gets an InstructionReader over the original and unstructured instruction stream.
Public method | DebugWriteIL | WriteValue the current method body (as MSIL) to the console.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnsureWritableLocalVariables | Ensure that the collection of local variables are writable.
Public method | ForEachInstruction | Calls a specified delegate for each instruction of the current method body.
Public method | GetInstructionBlockByToken | Gets an InstructionBlock given its token.
Public method | GetInstructionSequenceByToken | Gets an InstructionSequence given its token.
Public method | GetInstructionSequenceEnumerator | Gets an enumerator for all the instruction sequences (InstructionSequence) contained in the current method body.
Public method | GetLocalVariable | Overloaded.
Public method | RemoveLocalVariable | Removes a local variable.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Fields

Name | Description
RecomputeMaxStack | Value of the MaxStack property that specifies that the current property should be computed.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | InitLocalVariables | Determines whether local variables should be initialized by the runtime to their default value.
Public property | InstructionBlockCount | Gets the number of instruction blocks (InstructionBlock) created for the current method body.
Public property | InstructionSequenceCount | Gets the number of sequences in the current method body.
Public property | IsModified | Determines whether the current method body has been modified.
Public property | LocalVariableMaxOrdinal | Gets the number of local variables.
Public property | MaxStack | Gets or sets the maximal number of items that the runtime evaluation stack should contain.
Public property | Method | Gets the MethodDefDeclaration to which the current body belongs.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | RootInstructionBlock | Gets or sets the root InstructionBlock.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Constructor

MethodBodyDeclaration Constructor
MethodBodyDeclaration Class See Also Send Feedback
Initializes a new instance of the MethodBodyDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration()

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Fields

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration Fields
MethodBodyDeclaration Class See Also Send Feedback

The MethodBodyDeclaration type exposes the following members.

Fields

Name | Description
RecomputeMaxStack | Value of the MaxStack property that specifies that the current property should be computed.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


RecomputeMaxStack Field

MethodBodyDeclaration..::..RecomputeMaxStack Field
MethodBodyDeclaration Class See Also Send Feedback
Value of the MaxStack property that specifies that the current property should be computed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int RecomputeMaxStack

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration Methods
MethodBodyDeclaration Class See Also Send Feedback

The MethodBodyDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | CreateInstructionBlock | Creates an InstructionBlock for the current method body.
Public method | CreateInstructionReader | Overloaded.
Public method | CreateInstructionSequence | Creates an InstructionSequence for the current method body.
Public method | CreateLocalVariable | Creates a local variable for the current method body.
Public method | CreateOriginalInstructionReader | Gets an InstructionReader over the original and unstructured instruction stream.
Public method | DebugWriteIL | WriteValue the current method body (as MSIL) to the console.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnsureWritableLocalVariables | Ensure that the collection of local variables are writable.
Public method | ForEachInstruction | Calls a specified delegate for each instruction of the current method body.
Public method | GetInstructionBlockByToken | Gets an InstructionBlock given its token.
Public method | GetInstructionSequenceByToken | Gets an InstructionSequence given its token.
Public method | GetInstructionSequenceEnumerator | Gets an enumerator for all the instruction sequences (InstructionSequence) contained in the current method body.
Public method | GetLocalVariable | Overloaded.
Public method | RemoveLocalVariable | Removes a local variable.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CreateInstructionBlock Method

MethodBodyDeclaration..::..CreateInstructionBlock Method
MethodBodyDeclaration Class See Also Send Feedback
Creates an InstructionBlock for the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock CreateInstructionBlock()

Return Value

The new InstructionBlock.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CreateInstructionReader Method

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration..::..CreateInstructionReader Method
MethodBodyDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstructionReader()()() | Gets an InstructionReader for the current method body, which will resolve local variable symbols.
Public method | CreateInstructionReader(Boolean) | Gets an InstructionReader for the current method body and specify whether it should resolve local variable symbols.

See Also

MethodBodyDeclaration Class
MethodBodyDeclaration Members
PostSharp.Sdk.CodeModel Namespace


CreateInstructionReader Method

MethodBodyDeclaration..::..CreateInstructionReader Method
MethodBodyDeclaration Class See Also Send Feedback
Gets an InstructionReader for the current method body, which will resolve local variable symbols.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionReader CreateInstructionReader()

Return Value

An InstructionReader assigned to the current MethodBodyDeclaration.

See Also

MethodBodyDeclaration Class
CreateInstructionReader Overload
PostSharp.Sdk.CodeModel Namespace


CreateInstructionReader Method (Boolean)

MethodBodyDeclaration..::..CreateInstructionReader Method (Boolean)
MethodBodyDeclaration Class See Also Send Feedback
Gets an InstructionReader for the current method body and specify whether it should resolve local variable symbols.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionReader CreateInstructionReader(
    bool resolveSymbols
)

Parameters

resolveSymbols
Type: System..::.Boolean
Whether the InstructionReader should resolve local variable symbols.

Return Value

An InstructionReader assigned to the current MethodBodyDeclaration.

See Also

MethodBodyDeclaration Class
CreateInstructionReader Overload
PostSharp.Sdk.CodeModel Namespace


CreateInstructionSequence Method

MethodBodyDeclaration..::..CreateInstructionSequence Method
MethodBodyDeclaration Class See Also Send Feedback
Creates an InstructionSequence for the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence CreateInstructionSequence()

Return Value

The new InstructionSequence.

Remarks

This method does not add the new InstructionSequence to any block. This should be done in user code.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CreateLocalVariable Method

MethodBodyDeclaration..::..CreateLocalVariable Method
MethodBodyDeclaration Class See Also Send Feedback
Creates a local variable for the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclaration CreateLocalVariable(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the local variable.

Return Value

The newly created LocalVariableDeclaration.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CreateOriginalInstructionReader Method

MethodBodyDeclaration..::..CreateOriginalInstructionReader Method
MethodBodyDeclaration Class See Also Send Feedback
Gets an InstructionReader over the original and unstructured instruction stream.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionReader CreateOriginalInstructionReader()

Return Value

An InstructionReader that does not resolve lexical scopes.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DebugWriteIL Method

MethodBodyDeclaration..::..DebugWriteIL Method
MethodBodyDeclaration Class See Also Send Feedback
WriteValue the current method body (as MSIL) to the console.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void DebugWriteIL()

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

MethodBodyDeclaration..::..Dispose Method
MethodBodyDeclaration Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EnsureWritableLocalVariables Method

MethodBodyDeclaration..::..EnsureWritableLocalVariables Method
MethodBodyDeclaration Class See Also Send Feedback
Ensure that the collection of local variables are writable.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureWritableLocalVariables()

Remarks

This method is called automatically when you try to add a new local variable. You should call it explicitly in the rare case where you want to remove a local variable or change its type.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ForEachInstruction Method

MethodBodyDeclaration..::..ForEachInstruction Method
MethodBodyDeclaration Class Example See Also Send Feedback
Calls a specified delegate for each instruction of the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ForEachInstruction(
    InstructionAction action
)

Parameters

action
Type: PostSharp.Sdk.CodeModel..::.InstructionAction
A delegate of type InstructionAction that will be called for each instruction.

Remarks

This method offers an easy way to iterate the instructions of a method.

Examples

MethodDefDeclaration.MethodBody.ForEachInstruction(
    delegate(InstructionReader instructionReader)
    {
        // To something.
    }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetInstructionBlockByToken Method

MethodBodyDeclaration..::..GetInstructionBlockByToken Method
MethodBodyDeclaration Class See Also Send Feedback
Gets an InstructionBlock given its token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock GetInstructionBlockByToken(
    short token
)

Parameters

token
Type: System..::.Int16
An InstructionBlock token.

Return Value

The InstructionBlock whose token is token.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetInstructionSequenceByToken Method

MethodBodyDeclaration..::..GetInstructionSequenceByToken Method
MethodBodyDeclaration Class See Also Send Feedback
Gets an InstructionSequence given its token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence GetInstructionSequenceByToken(
    int token
)

Parameters

token
Type: System..::.Int32
An InstructionSequence token.

Return Value

The InstructionSequence whose token is token.

Remarks

Many tokens may resolve to the same InstructionSequence. This method may return an InstructionSequence whose token is different than token.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetInstructionSequenceEnumerator Method

MethodBodyDeclaration..::..GetInstructionSequenceEnumerator Method
MethodBodyDeclaration Class See Also Send Feedback
Gets an enumerator for all the instruction sequences (InstructionSequence) contained in the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<InstructionSequence> GetInstructionSequenceEnumerator()

Return Value

An enumerator of the sequences contained in the current method body.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetLocalVariable Method

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration..::..GetLocalVariable Method
MethodBodyDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLocalVariable(Int32) | Gets a LocalVariableDeclaration given its index.
Public method | GetLocalVariable(Int32, Boolean) | Gets a LocalVariableDeclaration given its index.

See Also

MethodBodyDeclaration Class
MethodBodyDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetLocalVariable Method (Int32)

MethodBodyDeclaration..::..GetLocalVariable Method (Int32)
MethodBodyDeclaration Class See Also Send Feedback
Gets a LocalVariableDeclaration given its index.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclaration GetLocalVariable(
    int index
)

Parameters

index
Type: System..::.Int32
The local variable index.

Return Value

The LocalVariableDeclaration whose position is index.

See Also

MethodBodyDeclaration Class
GetLocalVariable Overload
PostSharp.Sdk.CodeModel Namespace


GetLocalVariable Method (Int32, Boolean)

MethodBodyDeclaration..::..GetLocalVariable Method (Int32, Boolean)
MethodBodyDeclaration Class See Also Send Feedback
Gets a LocalVariableDeclaration given its index.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclaration GetLocalVariable(
    int index,
    bool throwException
)

Parameters

index
Type: System..::.Int32
The local variable index.
throwException
Type: System..::.Boolean

[Missing <param name="throwException"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodBodyDeclaration.GetLocalVariable(System.Int32,System.Boolean)"]

Return Value

The LocalVariableDeclaration whose position is index.

See Also

MethodBodyDeclaration Class
GetLocalVariable Overload
PostSharp.Sdk.CodeModel Namespace


RemoveLocalVariable Method

MethodBodyDeclaration..::..RemoveLocalVariable Method
MethodBodyDeclaration Class See Also Send Feedback
Removes a local variable.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveLocalVariable(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the local variable.

Remarks

This method does not remove symbols (see LocalVariableSymbol) associated to the current local variable. Be sure to remove all associated symbols before removing the current local variable.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

MethodBodyDeclaration..::..ToString Method
MethodBodyDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodBodyDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodBodyDeclaration Properties
MethodBodyDeclaration Class See Also Send Feedback

The MethodBodyDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | InitLocalVariables | Determines whether local variables should be initialized by the runtime to their default value.
Public property | InstructionBlockCount | Gets the number of instruction blocks (InstructionBlock) created for the current method body.
Public property | InstructionSequenceCount | Gets the number of sequences in the current method body.
Public property | IsModified | Determines whether the current method body has been modified.
Public property | LocalVariableMaxOrdinal | Gets the number of local variables.
Public property | MaxStack | Gets or sets the maximal number of items that the runtime evaluation stack should contain.
Public property | Method | Gets the MethodDefDeclaration to which the current body belongs.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | RootInstructionBlock | Gets or sets the root InstructionBlock.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InitLocalVariables Property

MethodBodyDeclaration..::..InitLocalVariables Property
MethodBodyDeclaration Class See Also Send Feedback
Determines whether local variables should be initialized by the runtime to their default value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool InitLocalVariables { get; set; }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InstructionBlockCount Property

MethodBodyDeclaration..::..InstructionBlockCount Property
MethodBodyDeclaration Class See Also Send Feedback
Gets the number of instruction blocks (InstructionBlock) created for the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int InstructionBlockCount { get; }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InstructionSequenceCount Property

MethodBodyDeclaration..::..InstructionSequenceCount Property
MethodBodyDeclaration Class See Also Send Feedback
Gets the number of sequences in the current method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int InstructionSequenceCount { get; }

Remarks

This property returns the size of the vector needed to store additional information about sequences, while using the sequence token as the array index.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsModified Property

MethodBodyDeclaration..::..IsModified Property
MethodBodyDeclaration Class See Also Send Feedback
Determines whether the current method body has been modified.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsModified { get; internal set; }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LocalVariableMaxOrdinal Property

MethodBodyDeclaration..::..LocalVariableMaxOrdinal Property
MethodBodyDeclaration Class See Also Send Feedback
Gets the number of local variables.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int LocalVariableMaxOrdinal { get; }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MaxStack Property

MethodBodyDeclaration..::..MaxStack Property
MethodBodyDeclaration Class See Also Send Feedback
Gets or sets the maximal number of items that the runtime evaluation stack should contain.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int MaxStack { get; set; }

Field Value

Any positive integer, or RecomputeMaxStack if the property should be recomputed by the library.

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Method Property

MethodBodyDeclaration..::..Method Property
MethodBodyDeclaration Class See Also Send Feedback
Gets the MethodDefDeclaration to which the current body belongs.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Method { get; }

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


RootInstructionBlock Property

MethodBodyDeclaration..::..RootInstructionBlock Property
MethodBodyDeclaration Class See Also Send Feedback
Gets or sets the root InstructionBlock.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock RootInstructionBlock { get; set; }

Field Value

An InstructionBlock, or null if no root block is specified (in the current case the method body is empty).

See Also

MethodBodyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodDefDeclaration Class

MethodDefDeclaration Class
Members See Also Send Feedback
Represents a method definition (MethodDef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodDefDeclaration : NamedPositionedMetadataDeclaration,
    IMemberRefResolutionScope, ISecurable, IGenericMethodDefinition, IMethod, IMethodSignature,
    IEquatable<IMethodSignature>, IMember, IEquatable<IMethod>,
    IWriteReflectionName, IGenericDefinitionDefinition, IGenericDefinition, IGeneric, IVisitable<ITypeSignature>,
    IRemovable, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedPositionedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodDefDeclaration

See Also

MethodDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodDefDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration Members
MethodDefDeclaration Class Constructors Methods Properties See Also Send Feedback

The MethodDefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodDefDeclaration | Initializes a new MethodDefDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | FindOverride | Finds the override method that should be called when the current virtual method is called with an instance of a given type.
Public method | GetGenericContext | Gets the GenericMap of the current method.
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetParentDefinition | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | ReleaseBody | Indicates that the body is no more needed in memory, so that it is marked for garbage collection.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Overloaded. Determines whether a method is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the method attributes.
Public property | CallingConvention | Gets or sets the method calling convention.
Public property | CallSiteSignatures | Call-site signature of the current method, if it calling convention is VarArg.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring TypeDefDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameters | Gets the collection of generic formal parameters (GenericParameterDeclaration).
Public property | HasBody | Determines whether the method currently has a body.
Public property | ImplementationAttributes | Gets or sets the method implementation attributes.
Public property | InterfaceImplementations | Gets the collection of interface methods that are implemented by the current method.
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the method is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MayHaveBody | Determines whether this method may have a body.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodBody | Gets the method body.
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Position of the current item in its parent collection. (Inherited from NamedPositionedMetadataDeclaration.)
Public property | Parameters | Gets the collection of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | PInvokeMap | Gets the P-Invoke map.
Public property | ReturnParameter | Gets the return parameter.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current method.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodDefDeclaration Constructor

MethodDefDeclaration Constructor
MethodDefDeclaration Class See Also Send Feedback
Initializes a new MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration()

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodDefDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration Methods
MethodDefDeclaration Class See Also Send Feedback

The MethodDefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | FindOverride | Finds the override method that should be called when the current virtual method is called with an instance of a given type.
Public method | GetGenericContext | Gets the GenericMap of the current method.
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetParentDefinition | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | ReleaseBody | Indicates that the body is no more needed in memory, so that it is marked for garbage collection.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Overloaded. Determines whether a method is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

MethodDefDeclaration..::..ClearCache Method
MethodDefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration..::..Equals Method
MethodDefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(IMethod) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(IMethodSignature) | Indicates whether the current object is equal to another object of the same type.

See Also

MethodDefDeclaration Class
MethodDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethod)

MethodDefDeclaration..::..Equals Method (IMethod)
MethodDefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethod other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethod
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodDefDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethodSignature)

MethodDefDeclaration..::..Equals Method (IMethodSignature)
MethodDefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethodSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodDefDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


FindGenericInstance Method

MethodDefDeclaration..::..FindGenericInstance Method
MethodDefDeclaration Class See Also Send Feedback
Finds or construct a specific generic instance of the current generic method definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindGenericInstance(
    IList<ITypeSignature> genericArguments,
    BindingOptions bindingOptions
)

Parameters

genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic arguments.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The generic instance, or null if it was not found and was not requested to be created.

Implements

IGenericMethodDefinition..::.FindGenericInstance(IList<(Of <(ITypeSignature>)>), BindingOptions)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindOverride Method

MethodDefDeclaration..::..FindOverride Method
MethodDefDeclaration Class See Also Send Feedback
Finds the override method that should be called when the current virtual method is called with an instance of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMethodReference FindOverride(
    TypeDefDeclaration typeDef
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Type of the instance on which the method is invoked.

Return Value

The method implementing the current semantic.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

MethodDefDeclaration..::..GetGenericContext Method
MethodDefDeclaration Class See Also Send Feedback
Gets the GenericMap of the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodDefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

The GenericMap of the current method.

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

MethodDefDeclaration..::..GetGenericInstance Method
MethodDefDeclaration Class See Also Send Feedback
Gets a generic instance of the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current method constructed using genericMap as generic arguments.

Implements

IGenericMethodDefinition..::.GetGenericInstance(GenericMap)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetParentDefinition Method

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration..::..GetParentDefinition Method
MethodDefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetParentDefinition()()() | When the current method overrides a method in a parent type, returns the overridden method.
Public method | GetParentDefinition(Boolean) | When the current method overrides a method in a parent type, returns the overridden method, and specifies whether the method should recurse to the root definition of the method.

See Also

MethodDefDeclaration Class
MethodDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetParentDefinition Method

MethodDefDeclaration..::..GetParentDefinition Method
MethodDefDeclaration Class See Also Send Feedback
When the current method overrides a method in a parent type, returns the overridden method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetParentDefinition()

Return Value

The overridden method, or nullif the current method does not override any method.

See Also

MethodDefDeclaration Class
GetParentDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetParentDefinition Method (Boolean)

MethodDefDeclaration..::..GetParentDefinition Method (Boolean)
MethodDefDeclaration Class See Also Send Feedback
When the current method overrides a method in a parent type, returns the overridden method, and specifies whether the method should recurse to the root definition of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetParentDefinition(
    bool recursive
)

Parameters

recursive
Type: System..::.Boolean
true to return the root definition of the method, false to return the closest parent.

Return Value

The overridden method, or nullif the current method does not override any method.

See Also

MethodDefDeclaration Class
GetParentDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

MethodDefDeclaration..::..GetReflectionWrapper Method
MethodDefDeclaration Class See Also Send Feedback
Gets a reflection MethodInfo that wraps the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A MethodInfo wrapping current method in the given generic context.

Implements

IMethod..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a MethodInfo that is different from the system runtime method that is retrieved by GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions). This allows a have a System.Reflection representation of the current method even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemMethod Method

MethodDefDeclaration..::..GetSystemMethod Method
MethodDefDeclaration Class See Also Send Feedback
Gets the system runtime method corresponding to the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetSystemMethod(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments,
    BindingOptions bindingOptions
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The system runtime MethodBase, or null if the current method could not be bound.

Implements

IMethod..::.GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MethodDefDeclaration..::..GetTokenType Method
MethodDefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

MethodDefDeclaration..::..MapGenericArguments Method
MethodDefDeclaration Class See Also Send Feedback
Resolves all generic arguments in the current method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethodSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A method signature resolved against genericMap.

Implements

IMethodSignature..::.MapGenericArguments(GenericMap)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration..::..MatchesReference Method
MethodDefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchesReference(IMethod) | Determines whether the current method matches a given method reference.
Public method | MatchesReference(IMethodSignature) | Determines whether the current method signature matches a given method signature reference.

See Also

MethodDefDeclaration Class
MethodDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethod)

MethodDefDeclaration..::..MatchesReference Method (IMethod)
MethodDefDeclaration Class See Also Send Feedback
Determines whether the current method matches a given method reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethod reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethod
The method reference.

Return Value

true if the current method matches reference, otherwise false.

Implements

IMethod..::.MatchesReference(IMethod)

See Also

MethodDefDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethodSignature)

MethodDefDeclaration..::..MatchesReference Method (IMethodSignature)
MethodDefDeclaration Class See Also Send Feedback
Determines whether the current method signature matches a given method signature reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethodSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature reference.

Return Value

true if the current method signature matches reference, otherwise false.

Implements

IMethodSignature..::.MatchesReference(IMethodSignature)

See Also

MethodDefDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


ReferencesAnyGenericArgument Method

MethodDefDeclaration..::..ReferencesAnyGenericArgument Method
MethodDefDeclaration Class See Also Send Feedback
Determines whether generic arguments are used in the current signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ReferencesAnyGenericArgument()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodDefDeclaration.ReferencesAnyGenericArgument"]

Implements

IMethodSignature..::.ReferencesAnyGenericArgument()()()

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ReleaseBody Method

MethodDefDeclaration..::..ReleaseBody Method
MethodDefDeclaration Class See Also Send Feedback
Indicates that the body is no more needed in memory, so that it is marked for garbage collection.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ReleaseBody()

Remarks

The body will be rebuilt from the PE image the next time it will be requested. All changes will be lost.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

MethodDefDeclaration..::..Remove Method
MethodDefDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

MethodDefDeclaration..::..ToString Method
MethodDefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

MethodDefDeclaration..::..Translate Method
MethodDefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.MethodDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visit Method

MethodDefDeclaration..::..Visit Method
MethodDefDeclaration Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

MethodDefDeclaration..::..WriteReflectionName Method
MethodDefDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodDefDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodDefDeclaration Properties
MethodDefDeclaration Class See Also Send Feedback

The MethodDefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the method attributes.
Public property | CallingConvention | Gets or sets the method calling convention.
Public property | CallSiteSignatures | Call-site signature of the current method, if it calling convention is VarArg.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring TypeDefDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameters | Gets the collection of generic formal parameters (GenericParameterDeclaration).
Public property | HasBody | Determines whether the method currently has a body.
Public property | ImplementationAttributes | Gets or sets the method implementation attributes.
Public property | InterfaceImplementations | Gets the collection of interface methods that are implemented by the current method.
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the method is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MayHaveBody | Determines whether this method may have a body.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodBody | Gets the method body.
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Position of the current item in its parent collection. (Inherited from NamedPositionedMetadataDeclaration.)
Public property | Parameters | Gets the collection of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | PInvokeMap | Gets the P-Invoke map.
Public property | ReturnParameter | Gets the return parameter.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current method.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

MethodDefDeclaration..::..Attributes Property
MethodDefDeclaration Class See Also Send Feedback
Gets or sets the method attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodAttributes Attributes { get; set; }

Implements

IMethod..::.Attributes

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CallingConvention Property

MethodDefDeclaration..::..CallingConvention Property
MethodDefDeclaration Class See Also Send Feedback
Gets or sets the method calling convention.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CallingConvention CallingConvention { get; set; }

Implements

IMethodSignature..::.CallingConvention

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CallSiteSignatures Property

MethodDefDeclaration..::..CallSiteSignatures Property
MethodDefDeclaration Class See Also Send Feedback
Call-site signature of the current method, if it calling convention is VarArg.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodRefDeclarationCollection CallSiteSignatures { get; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

MethodDefDeclaration..::..DeclaringType Property
MethodDefDeclaration Class See Also Send Feedback
Gets the declaring TypeDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration DeclaringType { get; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameters Property

MethodDefDeclaration..::..GenericParameters Property
MethodDefDeclaration Class See Also Send Feedback
Gets the collection of generic formal parameters (GenericParameterDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclarationCollection GenericParameters { get; }

Implements

IGenericDefinitionDefinition..::.GenericParameters

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HasBody Property

MethodDefDeclaration..::..HasBody Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method currently has a body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasBody { get; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImplementationAttributes Property

MethodDefDeclaration..::..ImplementationAttributes Property
MethodDefDeclaration Class See Also Send Feedback
Gets or sets the method implementation attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodImplAttributes ImplementationAttributes { get; set; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementations Property

MethodDefDeclaration..::..InterfaceImplementations Property
MethodDefDeclaration Class See Also Send Feedback
Gets the collection of interface methods that are implemented by the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodImplementationDeclarationCollection InterfaceImplementations { get; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

MethodDefDeclaration..::..IsAbstract Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IMethod..::.IsAbstract

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericDefinition Property

MethodDefDeclaration..::..IsGenericDefinition Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericDefinition { get; }

Implements

IGeneric..::.IsGenericDefinition

Remarks

If the current property returns true, the semantics of IGenericDefinition are meaningful for the current instance.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsNew Property

MethodDefDeclaration..::..IsNew Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method takes a new slot.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNew { get; }

Implements

IMethod..::.IsNew

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

MethodDefDeclaration..::..IsSealed Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IMethod..::.IsSealed

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

MethodDefDeclaration..::..IsStatic Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsVirtual Property

MethodDefDeclaration..::..IsVirtual Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether the method is virtual.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsVirtual { get; }

Implements

IMethod..::.IsVirtual

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MayHaveBody Property

MethodDefDeclaration..::..MayHaveBody Property
MethodDefDeclaration Class See Also Send Feedback
Determines whether this method may have a body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MayHaveBody { get; }

Remarks

The difference with HasBody is that property returns true if the method body is not yet implemented, for instance because it was marked as external in C#. But the method would accept a method body. The current property returns false even if the current method has a body, but may not.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodBody Property

MethodDefDeclaration..::..MethodBody Property
MethodDefDeclaration Class See Also Send Feedback
Gets the method body.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyDeclaration MethodBody { get; set; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | This method can have no body.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecs Property

MethodDefDeclaration..::..MethodSpecs Property
MethodDefDeclaration Class See Also Send Feedback
Gets the collection of method specifications (MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclarationCollection MethodSpecs { get; }

Implements

IGenericMethodDefinition..::.MethodSpecs

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parameters Property

MethodDefDeclaration..::..Parameters Property
MethodDefDeclaration Class See Also Send Feedback
Gets the collection of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclarationCollection Parameters { get; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodDefDeclaration..::..ParentMember Property
MethodDefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodDefDeclaration..::..ParentType Property
MethodDefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSets Property

MethodDefDeclaration..::..PermissionSets Property
MethodDefDeclaration Class See Also Send Feedback
Gets the collection of permission sets (PermissionSetDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionSetDeclarationCollection PermissionSets { get; }

Implements

ISecurable..::.PermissionSets

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PInvokeMap Property

MethodDefDeclaration..::..PInvokeMap Property
MethodDefDeclaration Class See Also Send Feedback
Gets the P-Invoke map.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PInvokeMap PInvokeMap { get; set; }

Field Value

A PInvokeMap, or null if the current method is not a P-Invoke.

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ReturnParameter Property

MethodDefDeclaration..::..ReturnParameter Property
MethodDefDeclaration Class See Also Send Feedback
Gets the return parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration ReturnParameter { get; set; }

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

MethodDefDeclaration..::..Visibility Property
MethodDefDeclaration Class See Also Send Feedback
Gets the visibility of the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

MethodDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodGroupDeclaration Class

MethodGroupDeclaration Class
Members See Also Send Feedback
Implements the functionalities that are common to PropertyDeclaration and EventDeclaration, which are both lexical collections of method semantics (MethodSemanticDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class MethodGroupDeclaration : NamedMetadataDeclaration,
    IMember, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodGroupDeclaration
PostSharp.Sdk.CodeModel..::.EventDeclaration
PostSharp.Sdk.CodeModel..::.PropertyDeclaration

See Also

MethodGroupDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodGroupDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodGroupDeclaration Members
MethodGroupDeclaration Class Methods Properties See Also Send Feedback

The MethodGroupDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static.
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current element.

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodGroupDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodGroupDeclaration Methods
MethodGroupDeclaration Class See Also Send Feedback

The MethodGroupDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetAccessor Method

MethodGroupDeclaration..::..GetAccessor Method
MethodGroupDeclaration Class See Also Send Feedback
Gets an accessor method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetAccessor(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic of the requested accessor method.

Return Value

The method of requested semantic, or null if the current MethodGroupDeclaration does not contain the requested semantic.

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodGroupDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodGroupDeclaration Properties
MethodGroupDeclaration Class See Also Send Feedback

The MethodGroupDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static.
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the visibility of the current element.

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

MethodGroupDeclaration..::..DeclaringType Property
MethodGroupDeclaration Class See Also Send Feedback
Gets the parent TypeDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration DeclaringType { get; }

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

MethodGroupDeclaration..::..IsStatic Property
MethodGroupDeclaration Class See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Members Property

MethodGroupDeclaration..::..Members Property
MethodGroupDeclaration Class See Also Send Feedback
Gets the collection of method semantics, which map a method to a role in the current event or property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemanticDeclarationCollection Members { get; }

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodGroupDeclaration..::..ParentMember Property
MethodGroupDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodGroupDeclaration..::..ParentType Property
MethodGroupDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

MethodGroupDeclaration..::..Visibility Property
MethodGroupDeclaration Class See Also Send Feedback
Gets the visibility of the current element.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

MethodGroupDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodImplementationDeclaration Class

MethodImplementationDeclaration Class
Members See Also Send Feedback
Represents a method implementation (MethodImpl), i.e. an indication of the interface method being implemented by the current MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodImplementationDeclaration : MetadataDeclaration

Remarks

Method implementations are owned by method definitions (MethodDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodImplementationDeclaration

See Also

MethodImplementationDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodImplementationDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclaration Members
MethodImplementationDeclaration Class Constructors Methods Properties See Also Send Feedback

The MethodImplementationDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodImplementationDeclaration | Initializes a new instance of the MethodImplementationDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMethod |
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ImplementedMethod | Gets or sets the implemented method (an interface method).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodImplementationDeclaration Constructor

MethodImplementationDeclaration Constructor
MethodImplementationDeclaration Class See Also Send Feedback
Initializes a new instance of the MethodImplementationDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodImplementationDeclaration()

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodImplementationDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclaration Methods
MethodImplementationDeclaration Class See Also Send Feedback

The MethodImplementationDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MethodImplementationDeclaration..::..GetTokenType Method
MethodImplementationDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodImplementationDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclaration Properties
MethodImplementationDeclaration Class See Also Send Feedback

The MethodImplementationDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMethod |
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | ImplementedMethod | Gets or sets the implemented method (an interface method).
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringMethod Property

MethodImplementationDeclaration..::..DeclaringMethod Property
MethodImplementationDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.MethodImplementationDeclaration.DeclaringMethod"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration DeclaringMethod { get; }

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImplementedMethod Property

MethodImplementationDeclaration..::..ImplementedMethod Property
MethodImplementationDeclaration Class See Also Send Feedback
Gets or sets the implemented method (an interface method).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod ImplementedMethod { get; set; }

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodImplementationDeclaration..::..ParentMember Property
MethodImplementationDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodImplementationDeclaration..::..ParentType Property
MethodImplementationDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

MethodImplementationDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefDeclaration Class

MethodRefDeclaration Class
Members See Also Send Feedback
Represents a method reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodRefDeclaration : MemberRefDeclaration,
    IGenericMethodDefinition, IMethod, IMethodSignature, IEquatable<IMethodSignature>,
    IMember, IEquatable<IMethod>, IWriteReflectionName, IGenericDefinition,
    IGeneric, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

Remarks

Method references are owned by IMemberRefResolutionScope.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MemberRefDeclaration
PostSharp.Sdk.CodeModel..::.MethodRefDeclaration

See Also

MethodRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodRefDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration Members
MethodRefDeclaration Class Constructors Methods Properties See Also Send Feedback

The MethodRefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodRefDeclaration | Initializes a new MethodRefDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetMethodDefinition | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MemberRefDeclaration.)
Public method | MatchesReference | Overloaded.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Inherited from MemberRefDeclaration.)
Public property | DeclaringType | Gets the declaring IType. (Inherited from MemberRefDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity).
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved. (Inherited from MemberRefDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Signature | Gets or sets the method signature.
Public property | Visibility | Gets the Visibility of the current member.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefDeclaration Constructor

MethodRefDeclaration Constructor
MethodRefDeclaration Class See Also Send Feedback
Initializes a new MethodRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodRefDeclaration()

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration Methods
MethodRefDeclaration Class See Also Send Feedback

The MethodRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | FindGenericInstance | Finds or construct a specific generic instance of the current generic method definition.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of the current method.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetMethodDefinition | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MemberRefDeclaration.)
Public method | MatchesReference | Overloaded.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic method. (Defined by GenericHelper.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

MethodRefDeclaration..::..ClearCache Method
MethodRefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration..::..Equals Method
MethodRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(IMethod) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(IMethodSignature) | Indicates whether the current object is equal to another object of the same type.

See Also

MethodRefDeclaration Class
MethodRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethod)

MethodRefDeclaration..::..Equals Method (IMethod)
MethodRefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethod other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethod
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodRefDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethodSignature)

MethodRefDeclaration..::..Equals Method (IMethodSignature)
MethodRefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethodSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodRefDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


FindGenericInstance Method

MethodRefDeclaration..::..FindGenericInstance Method
MethodRefDeclaration Class See Also Send Feedback
Finds or construct a specific generic instance of the current generic method definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindGenericInstance(
    IList<ITypeSignature> genericArguments,
    BindingOptions bindingOptions
)

Parameters

genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic arguments.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The generic instance, or null if it was not found and was not requested to be created.

Implements

IGenericMethodDefinition..::.FindGenericInstance(IList<(Of <(ITypeSignature>)>), BindingOptions)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

MethodRefDeclaration..::..GetGenericContext Method
MethodRefDeclaration Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodRefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

MethodRefDeclaration..::..GetGenericInstance Method
MethodRefDeclaration Class See Also Send Feedback
Gets a generic instance of the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current method constructed using genericMap as generic arguments.

Implements

IGenericMethodDefinition..::.GetGenericInstance(GenericMap)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method

MethodRefDeclaration..::..GetGenericParameter Method
MethodRefDeclaration Class See Also Send Feedback
Gets a generic (formal, unbound) parameter given its ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericParameter GetGenericParameter(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The generic parameter ordinal (position).

Return Value

A GenericParameterDeclaration, or null if the current generic parameter does not exist.

Implements

IGenericDefinition..::.GetGenericParameter(Int32)

Remarks

If the current instance is a defined in the current module (MethodDefDeclaration, TypeDefDeclaration), this method returns a GenericParameterDeclaration. Otherwise, it returns a reference to a generic parameter, i.e. a GenericParameterTypeSignature.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration..::..GetMethodDefinition Method
MethodRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMethodDefinition()()() | Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.
Public method | GetMethodDefinition(BindingOptions) | Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

See Also

MethodRefDeclaration Class
MethodRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

MethodRefDeclaration..::..GetMethodDefinition Method
MethodRefDeclaration Class See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetMethodDefinition()

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

Implements

IMethod..::.GetMethodDefinition()()()

See Also

MethodRefDeclaration Class
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method (BindingOptions)

MethodRefDeclaration..::..GetMethodDefinition Method (BindingOptions)
MethodRefDeclaration Class See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetMethodDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

Implements

IMethod..::.GetMethodDefinition(BindingOptions)

See Also

MethodRefDeclaration Class
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

MethodRefDeclaration..::..GetReflectionWrapper Method
MethodRefDeclaration Class See Also Send Feedback
Gets a reflection MethodInfo that wraps the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A MethodInfo wrapping current method in the given generic context.

Implements

IMethod..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a MethodInfo that is different from the system runtime method that is retrieved by GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions). This allows a have a System.Reflection representation of the current method even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemMethod Method

MethodRefDeclaration..::..GetSystemMethod Method
MethodRefDeclaration Class See Also Send Feedback
Gets the system runtime method corresponding to the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetSystemMethod(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments,
    BindingOptions bindingOptions
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The system runtime MethodBase, or null if the current method could not be bound.

Implements

IMethod..::.GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration..::..MatchesReference Method
MethodRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchesReference(IMethod) | Determines whether the current method matches a given method reference.
Public method | MatchesReference(IMethodSignature) | Determines whether the current method signature matches a given method signature reference.

See Also

MethodRefDeclaration Class
MethodRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethod)

MethodRefDeclaration..::..MatchesReference Method (IMethod)
MethodRefDeclaration Class See Also Send Feedback
Determines whether the current method matches a given method reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethod reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethod
The method reference.

Return Value

true if the current method matches reference, otherwise false.

Implements

IMethod..::.MatchesReference(IMethod)

See Also

MethodRefDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethodSignature)

MethodRefDeclaration..::..MatchesReference Method (IMethodSignature)
MethodRefDeclaration Class See Also Send Feedback
Determines whether the current method signature matches a given method signature reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethodSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature reference.

Return Value

true if the current method signature matches reference, otherwise false.

Implements

IMethodSignature..::.MatchesReference(IMethodSignature)

See Also

MethodRefDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


ToString Method

MethodRefDeclaration..::..ToString Method
MethodRefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

MethodRefDeclaration..::..Translate Method
MethodRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.MethodRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

MethodRefDeclaration..::..WriteReflectionName Method
MethodRefDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodRefDeclaration Properties
MethodRefDeclaration Class See Also Send Feedback

The MethodRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the assembly in which the member is defined. (Inherited from MemberRefDeclaration.)
Public property | DeclaringType | Gets the declaring IType. (Inherited from MemberRefDeclaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameterCount | Gets the number of generic parameters or arguments (i.e. the arity).
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodSpecs | Gets the collection of method specifications (MethodSpecDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets scope in which the current reference should be resolved. (Inherited from MemberRefDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Signature | Gets or sets the method signature.
Public property | Visibility | Gets the Visibility of the current member.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

MethodRefDeclaration..::..Attributes Property
MethodRefDeclaration Class See Also Send Feedback
Gets the attributes of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodAttributes Attributes { get; }

Implements

IMethod..::.Attributes

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterCount Property

MethodRefDeclaration..::..GenericParameterCount Property
MethodRefDeclaration Class See Also Send Feedback
Gets the number of generic parameters or arguments (i.e. the arity).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GenericParameterCount { get; }

Implements

IMethodSignature..::.GenericParameterCount

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

MethodRefDeclaration..::..IsAbstract Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the method is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IMethod..::.IsAbstract

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericDefinition Property

MethodRefDeclaration..::..IsGenericDefinition Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericDefinition { get; }

Implements

IGeneric..::.IsGenericDefinition

Remarks

If the current property returns true, the semantics of IGenericDefinition are meaningful for the current instance.

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsNew Property

MethodRefDeclaration..::..IsNew Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the method takes a new slot.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNew { get; }

Implements

IMethod..::.IsNew

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

MethodRefDeclaration..::..IsSealed Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the method is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IMethod..::.IsSealed

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

MethodRefDeclaration..::..IsStatic Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsVirtual Property

MethodRefDeclaration..::..IsVirtual Property
MethodRefDeclaration Class See Also Send Feedback
Determines whether the method is virtual.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsVirtual { get; }

Implements

IMethod..::.IsVirtual

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecs Property

MethodRefDeclaration..::..MethodSpecs Property
MethodRefDeclaration Class See Also Send Feedback
Gets the collection of method specifications (MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclarationCollection MethodSpecs { get; }

Implements

IGenericMethodDefinition..::.MethodSpecs

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodRefDeclaration..::..ParentMember Property
MethodRefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodRefDeclaration..::..ParentType Property
MethodRefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Signature Property

MethodRefDeclaration..::..Signature Property
MethodRefDeclaration Class See Also Send Feedback
Gets or sets the method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature Signature { get; set; }

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

MethodRefDeclaration..::..Visibility Property
MethodRefDeclaration Class See Also Send Feedback
Gets the Visibility of the current member.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

MethodRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Class

MethodSemanticDeclaration Class
Members See Also Send Feedback
Represents a method semantic (MethodSemantic), i.e. the association of a method and a role in a collection (PropertyDeclaration or EventDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSemanticDeclaration : MetadataDeclaration,
    IRemovable, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable

Remarks

Method semantics are owned by MethodGroupDeclaration (PropertyDeclaration or EventDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodSemanticDeclaration

See Also

MethodSemanticDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration Members
MethodSemanticDeclaration Class Constructors Methods Properties See Also Send Feedback

The MethodSemanticDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodSemanticDeclaration | Overloaded.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMember | Gets the parent MethodGroupDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Method | Gets or sets the method linked to the semantic.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Semantic | Gets or sets the semantic of the method in the containing collection.

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Constructor

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration Constructor
MethodSemanticDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MethodSemanticDeclaration()()() | Initializes a new empty MethodSemanticDeclaration.
Public method | MethodSemanticDeclaration(MethodSemantics, MethodDefDeclaration) | Initializes a new MethodSemanticDeclaration and sets its content.

See Also

MethodSemanticDeclaration Class
MethodSemanticDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Constructor

MethodSemanticDeclaration Constructor
MethodSemanticDeclaration Class See Also Send Feedback
Initializes a new empty MethodSemanticDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemanticDeclaration()

See Also

MethodSemanticDeclaration Class
MethodSemanticDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Constructor (MethodSemantics, MethodDefDeclaration)

MethodSemanticDeclaration Constructor (MethodSemantics, MethodDefDeclaration)
MethodSemanticDeclaration Class See Also Send Feedback
Initializes a new MethodSemanticDeclaration and sets its content.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemanticDeclaration(
    MethodSemantics semantic,
    MethodDefDeclaration method
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic.
method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
Method implementing the semantic.

See Also

MethodSemanticDeclaration Class
MethodSemanticDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration Methods
MethodSemanticDeclaration Class See Also Send Feedback

The MethodSemanticDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MethodSemanticDeclaration..::..GetTokenType Method
MethodSemanticDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

MethodSemanticDeclaration..::..Remove Method
MethodSemanticDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration Properties
MethodSemanticDeclaration Class See Also Send Feedback

The MethodSemanticDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMember | Gets the parent MethodGroupDeclaration.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Method | Gets or sets the method linked to the semantic.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Semantic | Gets or sets the semantic of the method in the containing collection.

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringMember Property

MethodSemanticDeclaration..::..DeclaringMember Property
MethodSemanticDeclaration Class See Also Send Feedback
Gets the parent MethodGroupDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodGroupDeclaration DeclaringMember { get; }

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Method Property

MethodSemanticDeclaration..::..Method Property
MethodSemanticDeclaration Class See Also Send Feedback
Gets or sets the method linked to the semantic.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Method { get; set; }

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodSemanticDeclaration..::..ParentMember Property
MethodSemanticDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodSemanticDeclaration..::..ParentType Property
MethodSemanticDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Semantic Property

MethodSemanticDeclaration..::..Semantic Property
MethodSemanticDeclaration Class See Also Send Feedback
Gets or sets the semantic of the method in the containing collection.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemantics Semantic { get; set; }

See Also

MethodSemanticDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration.BySemanticComparer Class

MethodSemanticDeclaration..::..BySemanticComparer Class
MethodSemanticDeclaration Class Members See Also Send Feedback
Implementation of IComparer<(Of <(T>)>) comparing instances by their Semantic property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class BySemanticComparer : IComparer<MethodSemanticDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MethodSemanticDeclaration..::.BySemanticComparer

See Also

MethodSemanticDeclaration..::.BySemanticComparer Members
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration.BySemanticComparer Members

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration..::..BySemanticComparer Members
MethodSemanticDeclaration..::.BySemanticComparer Class Constructors Methods See Also Send Feedback

Represents a method semantic (MethodSemantic), i.e. the association of a method and a role in a collection (PropertyDeclaration or EventDeclaration).

The MethodSemanticDeclaration..::.BySemanticComparer type exposes the following members.

Constructors

 | Name | Description
Public method | MethodSemanticDeclaration..::.BySemanticComparer | Initializes a new instance of the MethodSemanticDeclaration..::.BySemanticComparer class

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | GetInstance | Gets an instance of MethodSemanticDeclaration..::.BySemanticComparer.

See Also

MethodSemanticDeclaration..::.BySemanticComparer Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration.BySemanticComparer Constructor

MethodSemanticDeclaration..::..BySemanticComparer Constructor
MethodSemanticDeclaration..::.BySemanticComparer Class See Also Send Feedback
Initializes a new instance of the MethodSemanticDeclaration..::.BySemanticComparer class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BySemanticComparer()

See Also

MethodSemanticDeclaration..::.BySemanticComparer Class
PostSharp.Sdk.CodeModel Namespace


MethodSemanticDeclaration.BySemanticComparer Methods

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclaration..::..BySemanticComparer Methods
MethodSemanticDeclaration..::.BySemanticComparer Class See Also Send Feedback

The MethodSemanticDeclaration..::.BySemanticComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
 | GetInstance | Gets an instance of MethodSemanticDeclaration..::.BySemanticComparer.

See Also

MethodSemanticDeclaration..::.BySemanticComparer Class
PostSharp.Sdk.CodeModel Namespace


Compare Method

MethodSemanticDeclaration..::..BySemanticComparer..::..Compare Method
MethodSemanticDeclaration..::.BySemanticComparer Class See Also Send Feedback
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Compare(
    MethodSemanticDeclaration x,
    MethodSemanticDeclaration y
)

Parameters

x
Type: PostSharp.Sdk.CodeModel..::.MethodSemanticDeclaration
The first object to compare.
y
Type: PostSharp.Sdk.CodeModel..::.MethodSemanticDeclaration
The second object to compare.

Return Value

Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.

Implements

IComparer<(Of <(T>)>)..::.Compare(T, T)

See Also

MethodSemanticDeclaration..::.BySemanticComparer Class
PostSharp.Sdk.CodeModel Namespace


GetInstance Method

MethodSemanticDeclaration..::..BySemanticComparer..::..GetInstance Method
MethodSemanticDeclaration..::.BySemanticComparer Class See Also Send Feedback
Gets an instance of MethodSemanticDeclaration..::.BySemanticComparer.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static MethodSemanticDeclaration..::.BySemanticComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodSemanticDeclaration.BySemanticComparer.GetInstance"]

See Also

MethodSemanticDeclaration..::.BySemanticComparer Class
PostSharp.Sdk.CodeModel Namespace


MethodSemantics Enumeration

MethodSemantics Enumeration
See Also Send Feedback
Enumerates the method semantics.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum MethodSemantics

Members

Member name | Value | Description
None | 0 | No semantic.
Setter | 1 | Setter for property.
Getter | 2 | Getter for property
Other | 4 | Other method for property or event
AddOn | 8 | AddOn method for event
RemoveOn | 16 | RemoveOn method for event
Fire | 32 | Fire method for event

See Also

PostSharp.Sdk.CodeModel Namespace


MethodSignature Class

MethodSignature Class
Members See Also Send Feedback
Represents a method signature, which specifies primarily a calling convention and the type of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSignature : IMethodSignature,
    IModuleElement, IEquatable<IMethodSignature>, IVisitable<ITypeSignature>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MethodSignature

See Also

MethodSignature Members
PostSharp.Sdk.CodeModel Namespace


MethodSignature Members

[image]

PostSharp 2.0 Documentation
MethodSignature Members
MethodSignature Class Constructors Methods Properties See Also Send Feedback

The MethodSignature type exposes the following members.

Constructors

 | Name | Description
Public method | MethodSignature | Overloaded.

Methods

 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Determines whether the current method signature matches a given method signature reference.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Properties

 | Name | Description
Public property | CallingConvention | Gets or sets the calling convention.
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | GenericParameterCount | Gets or sets the arity, i.e. the number of generic method parameters.
Public property | Module | Gets the declaring module.
Public property | ParameterTypes | Gets the collection of parameter types.
Public property | ReturnType | Gets or sets the return type.
Public property | VariableParameterTypes | Gets the collection of variable parameters types (i.e. the parameters sent as the list of unknown parameters of a vararg method.

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


MethodSignature Constructor

[image]

PostSharp 2.0 Documentation
MethodSignature Constructor
MethodSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MethodSignature(IMethodSignature) | Initializes a new MethodSignature from an existing IMethodSignature.
Public method | MethodSignature(ModuleDeclaration) | Initializes a new MethodSignature.
Public method | MethodSignature(IMethodSignature, Int32, Int32) | Initializes a new MethodSignature from an existing IMethodSignature and allows to ignore the first and the last parameters of the method.
Public method | MethodSignature(ModuleDeclaration, CallingConvention, ITypeSignature, ICollection<(Of <(ITypeSignature>)>), Int32) | Initializes a new MethodSignature.

See Also

MethodSignature Class
MethodSignature Members
PostSharp.Sdk.CodeModel Namespace


MethodSignature Constructor (IMethodSignature)

MethodSignature Constructor (IMethodSignature)
MethodSignature Class See Also Send Feedback
Initializes a new MethodSignature from an existing IMethodSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature(
    IMethodSignature signature
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The signature to copy.

See Also

MethodSignature Class
MethodSignature Overload
PostSharp.Sdk.CodeModel Namespace


MethodSignature Constructor (ModuleDeclaration)

MethodSignature Constructor (ModuleDeclaration)
MethodSignature Class See Also Send Feedback
Initializes a new MethodSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="module"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodSignature.#ctor(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodSignature Class
MethodSignature Overload
PostSharp.Sdk.CodeModel Namespace


MethodSignature Constructor (IMethodSignature, Int32, Int32)

MethodSignature Constructor (IMethodSignature, Int32, Int32)
MethodSignature Class See Also Send Feedback
Initializes a new MethodSignature from an existing IMethodSignature and allows to ignore the first and the last parameters of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature(
    IMethodSignature signature,
    int ignoreFirst,
    int ignoreLast
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The signature to copy.
ignoreFirst
Type: System..::.Int32
Number of first parameters to ignore.
ignoreLast
Type: System..::.Int32
Number of last parameters to ignore.

See Also

MethodSignature Class
MethodSignature Overload
PostSharp.Sdk.CodeModel Namespace


MethodSignature Constructor (ModuleDeclaration, CallingConvention, ITypeSignature, ICollection(ITypeSignature), Int32)

MethodSignature Constructor (ModuleDeclaration, CallingConvention, ITypeSignature, ICollection<(Of <(<'ITypeSignature>)>)>, Int32)
MethodSignature Class See Also Send Feedback
Initializes a new MethodSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature(
    ModuleDeclaration module,
    CallingConvention callingConvention,
    ITypeSignature returnType,
    ICollection<ITypeSignature> parameterTypes,
    int genericParameterCount
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which the new signature belongs.
callingConvention
Type: PostSharp.Sdk.CodeModel..::.CallingConvention
Calling convention.
returnType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Return type.
parameterTypes
Type: System.Collections.Generic..::.ICollection <(Of <(<' ITypeSignature >)>)>
Parameter types (the content of the current collection is copied, i.e. the collection is not copied by reference).
genericParameterCount
Type: System..::.Int32
Number of generic parameters (arity).

See Also

MethodSignature Class
MethodSignature Overload
PostSharp.Sdk.CodeModel Namespace


MethodSignature Methods

[image]

PostSharp 2.0 Documentation
MethodSignature Methods
MethodSignature Class See Also Send Feedback

The MethodSignature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | MapGenericArguments | Resolves all generic arguments in the current method signature.
Public method | MatchesReference | Determines whether the current method signature matches a given method signature reference.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

MethodSignature..::..Equals Method
MethodSignature Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethodSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

MethodSignature..::..MapGenericArguments Method
MethodSignature Class See Also Send Feedback
Resolves all generic arguments in the current method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethodSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A method signature resolved against genericMap.

Implements

IMethodSignature..::.MapGenericArguments(GenericMap)

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

MethodSignature..::..MatchesReference Method
MethodSignature Class See Also Send Feedback
Determines whether the current method signature matches a given method signature reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethodSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature reference.

Return Value

true if the current method signature matches reference, otherwise false.

Implements

IMethodSignature..::.MatchesReference(IMethodSignature)

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


ReferencesAnyGenericArgument Method

MethodSignature..::..ReferencesAnyGenericArgument Method
MethodSignature Class See Also Send Feedback
Determines whether generic arguments are used in the current signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ReferencesAnyGenericArgument()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodSignature.ReferencesAnyGenericArgument"]

Implements

IMethodSignature..::.ReferencesAnyGenericArgument()()()

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

MethodSignature..::..ToString Method
MethodSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

MethodSignature..::..Translate Method
MethodSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.MethodSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethodSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


Visit Method

MethodSignature..::..Visit Method
MethodSignature Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


MethodSignature Properties

[image]

PostSharp 2.0 Documentation
MethodSignature Properties
MethodSignature Class See Also Send Feedback

The MethodSignature type exposes the following members.

Properties

 | Name | Description
Public property | CallingConvention | Gets or sets the calling convention.
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | GenericParameterCount | Gets or sets the arity, i.e. the number of generic method parameters.
Public property | Module | Gets the declaring module.
Public property | ParameterTypes | Gets the collection of parameter types.
Public property | ReturnType | Gets or sets the return type.
Public property | VariableParameterTypes | Gets the collection of variable parameters types (i.e. the parameters sent as the list of unknown parameters of a vararg method.

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


CallingConvention Property

MethodSignature..::..CallingConvention Property
MethodSignature Class See Also Send Feedback
Gets or sets the calling convention.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CallingConvention CallingConvention { get; set; }

Field Value

A CallingConvention.

Implements

IMethodSignature..::.CallingConvention

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

MethodSignature..::..DeclaringAssembly Property
MethodSignature Class See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly DeclaringAssembly { get; }

Implements

IModuleElement..::.DeclaringAssembly

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterCount Property

MethodSignature..::..GenericParameterCount Property
MethodSignature Class See Also Send Feedback
Gets or sets the arity, i.e. the number of generic method parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GenericParameterCount { get; set; }

Implements

IMethodSignature..::.GenericParameterCount

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


Module Property

MethodSignature..::..Module Property
MethodSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


ParameterTypes Property

MethodSignature..::..ParameterTypes Property
MethodSignature Class See Also Send Feedback
Gets the collection of parameter types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSignatureCollection ParameterTypes { get; }

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


ReturnType Property

MethodSignature..::..ReturnType Property
MethodSignature Class See Also Send Feedback
Gets or sets the return type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ReturnType { get; set; }

Implements

IMethodSignature..::.ReturnType

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


VariableParameterTypes Property

MethodSignature..::..VariableParameterTypes Property
MethodSignature Class See Also Send Feedback
Gets the collection of variable parameters types (i.e. the parameters sent as the list of unknown parameters of a vararg method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSignatureCollection VariableParameterTypes { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | The calling convention is not VarArg.

See Also

MethodSignature Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecDeclaration Class

MethodSpecDeclaration Class
Members See Also Send Feedback
Represents a method specification (MethodSpec), i.e. the construction of a concrete generic method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSpecDeclaration : MetadataDeclaration,
    IMethod, IMethodSignature, IEquatable<IMethodSignature>, IMember,
    IMetadataDeclaration, IDeclaration, IElement, IModuleElement, ITaggable,
    IEquatable<IMethod>, IWriteReflectionName, IGenericInstance, IGeneric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodSpecDeclaration

See Also

MethodSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MethodSpecDeclaration Members

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration Members
MethodSpecDeclaration Class Constructors Methods Properties See Also Send Feedback

The MethodSpecDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | MethodSpecDeclaration | Initializes a new instance of the MethodSpecDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CallingConvention | Gets the method calling convention.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring type.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericArguments | Gets the collection of generic method arguments.
Public property | GenericMethod | Gets the generic method (with formal generic method arguments).
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericInstance |
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets the method name.
Public property | ParameterCount | Gets the number of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ReturnType | Gets the return type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecDeclaration Constructor

MethodSpecDeclaration Constructor
MethodSpecDeclaration Class See Also Send Feedback
Initializes a new instance of the MethodSpecDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclaration()

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecDeclaration Methods

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration Methods
MethodSpecDeclaration Class See Also Send Feedback

The MethodSpecDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Overloaded.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetMethodDefinition | Overloaded.
Public method | GetParameterType | Gets the type of a parameter given its position.
Public method | GetReflectionWrapper | Gets a reflection MethodInfo that wraps the current method.
Public method | GetSystemMethod | Gets the system runtime method corresponding to the current method.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | MatchesReference | Overloaded.
Public method | ReferencesAnyGenericArgument | Determines whether generic arguments are used in the current signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a member is visible outside its assembly. (Defined by VisibilityHelper.)
Public Extension Method | [extension] | Determines whether a member is visible from a given scope. (Defined by VisibilityHelper.)

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration..::..Equals Method
MethodSpecDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(IMethod) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(IMethodSignature) | Indicates whether the current object is equal to another object of the same type.

See Also

MethodSpecDeclaration Class
MethodSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethod)

MethodSpecDeclaration..::..Equals Method (IMethod)
MethodSpecDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethod other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethod
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodSpecDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (IMethodSignature)

MethodSpecDeclaration..::..Equals Method (IMethodSignature)
MethodSpecDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IMethodSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

MethodSpecDeclaration Class
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

MethodSpecDeclaration..::..GetGenericContext Method
MethodSpecDeclaration Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration..::..GetMethodDefinition Method
MethodSpecDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMethodDefinition()()() | Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.
Public method | GetMethodDefinition(BindingOptions) | Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

See Also

MethodSpecDeclaration Class
MethodSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method

MethodSpecDeclaration..::..GetMethodDefinition Method
MethodSpecDeclaration Class See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method with default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetMethodDefinition()

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

Implements

IMethod..::.GetMethodDefinition()()()

See Also

MethodSpecDeclaration Class
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetMethodDefinition Method (BindingOptions)

MethodSpecDeclaration..::..GetMethodDefinition Method (BindingOptions)
MethodSpecDeclaration Class See Also Send Feedback
Finds in the current domain the MethodDefDeclaration corresponding to the current method and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetMethodDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The MethodDefDeclaration corresponding to the current instance in the current domain.

Implements

IMethod..::.GetMethodDefinition(BindingOptions)

See Also

MethodSpecDeclaration Class
GetMethodDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetParameterType Method

MethodSpecDeclaration..::..GetParameterType Method
MethodSpecDeclaration Class See Also Send Feedback
Gets the type of a parameter given its position.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetParameterType(
    int index
)

Parameters

index
Type: System..::.Int32
The parameter position.

Return Value

The type (TypeSignature) of the parameter.

Implements

IMethodSignature..::.GetParameterType(Int32)

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

MethodSpecDeclaration..::..GetReflectionWrapper Method
MethodSpecDeclaration Class See Also Send Feedback
Gets a reflection MethodInfo that wraps the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A MethodInfo wrapping current method in the given generic context.

Implements

IMethod..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a MethodInfo that is different from the system runtime method that is retrieved by GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions). This allows a have a System.Reflection representation of the current method even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemMethod Method

MethodSpecDeclaration..::..GetSystemMethod Method
MethodSpecDeclaration Class See Also Send Feedback
Gets the system runtime method corresponding to the current method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBase GetSystemMethod(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments,
    BindingOptions bindingOptions
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The system runtime MethodBase, or null if the current method could not be bound.

Implements

IMethod..::.GetSystemMethod(array<Type>[]()[], array<Type>[]()[], BindingOptions)

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

MethodSpecDeclaration..::..GetTokenType Method
MethodSpecDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration..::..MatchesReference Method
MethodSpecDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MatchesReference(IMethod) | Determines whether the current method matches a given method reference.
Public method | MatchesReference(IMethodSignature) | Determines whether the current method signature matches a given method signature reference.

See Also

MethodSpecDeclaration Class
MethodSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethod)

MethodSpecDeclaration..::..MatchesReference Method (IMethod)
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the current method matches a given method reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethod reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethod
The method reference.

Return Value

true if the current method matches reference, otherwise false.

Implements

IMethod..::.MatchesReference(IMethod)

See Also

MethodSpecDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method (IMethodSignature)

MethodSpecDeclaration..::..MatchesReference Method (IMethodSignature)
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the current method signature matches a given method signature reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    IMethodSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
The method signature reference.

Return Value

true if the current method signature matches reference, otherwise false.

Implements

IMethodSignature..::.MatchesReference(IMethodSignature)

See Also

MethodSpecDeclaration Class
MatchesReference Overload
PostSharp.Sdk.CodeModel Namespace


ReferencesAnyGenericArgument Method

MethodSpecDeclaration..::..ReferencesAnyGenericArgument Method
MethodSpecDeclaration Class See Also Send Feedback
Determines whether generic arguments are used in the current signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ReferencesAnyGenericArgument()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.ReferencesAnyGenericArgument"]

Implements

IMethodSignature..::.ReferencesAnyGenericArgument()()()

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

MethodSpecDeclaration..::..ToString Method
MethodSpecDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

MethodSpecDeclaration..::..Translate Method
MethodSpecDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclaration Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

MethodSpecDeclaration..::..WriteReflectionName Method
MethodSpecDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSpecDeclaration Properties

[image]

PostSharp 2.0 Documentation
MethodSpecDeclaration Properties
MethodSpecDeclaration Class See Also Send Feedback

The MethodSpecDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes of the method.
Public property | CallingConvention | Gets the method calling convention.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring type.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericArguments | Gets the collection of generic method arguments.
Public property | GenericMethod | Gets the generic method (with formal generic method arguments).
Public property | IsAbstract | Determines whether the method is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericInstance |
Public property | IsNew | Determines whether the method takes a new slot.
Public property | IsSealed | Determines whether the method is sealed.
Public property | IsStatic | Determines whether the current member is static.
Public property | IsVirtual | Determines whether the method is virtual.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets the method name.
Public property | ParameterCount | Gets the number of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ReturnType | Gets the return type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Visibility | Gets the Visibility of the current member.

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

MethodSpecDeclaration..::..Attributes Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the attributes of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodAttributes Attributes { get; }

Implements

IMethod..::.Attributes

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CallingConvention Property

MethodSpecDeclaration..::..CallingConvention Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the method calling convention.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CallingConvention CallingConvention { get; set; }

Field Value

The calling convention.

Implements

IMethodSignature..::.CallingConvention

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

MethodSpecDeclaration..::..DeclaringType Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the declaring type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType DeclaringType { get; }

Field Value

The declaring type (IType), or null if the member is contained by the module.

Implements

IMember..::.DeclaringType

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericArguments Property

MethodSpecDeclaration..::..GenericArguments Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the collection of generic method arguments.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSignatureCollection GenericArguments { get; }

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericMethod Property

MethodSpecDeclaration..::..GenericMethod Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the generic method (with formal generic method arguments).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition GenericMethod { get; }

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

MethodSpecDeclaration..::..IsAbstract Property
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the method is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IMethod..::.IsAbstract

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericInstance Property

MethodSpecDeclaration..::..IsGenericInstance Property
MethodSpecDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.MethodSpecDeclaration.IsGenericInstance"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericInstance { get; }

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsNew Property

MethodSpecDeclaration..::..IsNew Property
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the method takes a new slot.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNew { get; }

Implements

IMethod..::.IsNew

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

MethodSpecDeclaration..::..IsSealed Property
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the method is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IMethod..::.IsSealed

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsStatic Property

MethodSpecDeclaration..::..IsStatic Property
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the current member is static.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStatic { get; }

Implements

IMember..::.IsStatic

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsVirtual Property

MethodSpecDeclaration..::..IsVirtual Property
MethodSpecDeclaration Class See Also Send Feedback
Determines whether the method is virtual.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsVirtual { get; }

Implements

IMethod..::.IsVirtual

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Name Property

MethodSpecDeclaration..::..Name Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the method name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

Field Value

The method name.

Implements

IMember..::.Name

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParameterCount Property

MethodSpecDeclaration..::..ParameterCount Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the number of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ParameterCount { get; }

Field Value

The number of parameters.

Implements

IMethodSignature..::.ParameterCount

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

MethodSpecDeclaration..::..ParentMember Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

MethodSpecDeclaration..::..ParentType Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ReturnType Property

MethodSpecDeclaration..::..ReturnType Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the return type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ReturnType { get; }

Field Value

The return type.

Implements

IMethodSignature..::.ReturnType

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

MethodSpecDeclaration..::..Visibility Property
MethodSpecDeclaration Class See Also Send Feedback
Gets the Visibility of the current member.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

Implements

IMember..::.Visibility

See Also

MethodSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleDeclaration Class

ModuleDeclaration Class
Members See Also Send Feedback
Represents a module (Module).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ModuleDeclaration : NamedMetadataDeclaration,
    IModule, ITypeRefResolutionScope, ITypeContainer, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable

Remarks

Since PostSharp is module-centric, a module contains all other declarations.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ModuleDeclaration

See Also

ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ModuleDeclaration Members

[image]

PostSharp 2.0 Documentation
ModuleDeclaration Members
ModuleDeclaration Class Constructors Methods Properties See Also Send Feedback

The ModuleDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleDeclaration | Initializes a new ModuleDeclaration.

Methods

 | Name | Description
Public method | ClearAllTags | Removes, from all elements of this module (MetadataDeclaration only), all tags of a given Guid.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindAssembly | Overloaded. Finds an assembly in the current module.
Public method | FindDeclaration | Finds a declaration given its reflection object and returns it translated for the current module.
Public method | FindField | Overloaded.
Public method | FindMethod | Overloaded.
Public method | FindMscorlib | Finds the mscorlib assembly referred to by the current module.
Public method | FindType | Overloaded. Finds a type in the current module.
Public method | GetDeclarationEnumerator | Gets an enumeration of declarations of a given type.
Public method | GetFrameworkVariant |
Public method | GetMethodSignature | Gets a MethodSignature for a MethodBase.
Public method | GetSystemModule | Gets the runtime module corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetType | Gets a IType given a ITypeSignature.
Public method | GetTypeForFrameworkVariant | Overloaded.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | Assembly |
Public property | AssemblyManifest | Gets or sets the assembly manifest contained in the current module.
Public property | AssemblyRefs | Gets the collection of assembly references (AssemblyRefDeclaration).
Public property | Cache | Caches a set of frequently used declarations.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | Data | Gets the collection of raw data declarations (DataSectionDeclaration).
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | EntryPoint | Gets or sets the entry point of the current module.
Public property | FileAlignment | Gets or sets the FileAlignment value in the NT Optional header.
Public property | FileName | Gets the name of the file containing the module.
Public property | HasDebugInfo | Determines whether the current module has debugging information.
Public property | ImageAttributes | Gets the attributes of the PE image.
Public property | ImageBase | Gets or sets the ImageBase value in the NT Optional header.
Public property | ImageFileMachine | Gets or sets the ImageFileMachine information from the PE headers.
Public property | ImageKind | Gets or sets the PortableExecutableKind information from the PE headers.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current module is mscorlib.
Public property | IsObfuscated | Determines whether the current module is obfuscated.
Public property | MetadataMajorVersion | Gets or sets the MajorVersion field of the metadata header.
Public property | MetadataMinorVersion | Gets or sets the MinorVersion field of the metadata header.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MetadataVersionString | Gets or sets the VersionString field of the metadata header.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | ModuleGuid | Gets or sets the GUID of the current module.
Public property | ModuleRefs | Gets the collection of module references (ModuleRefDeclaration).
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ProcessorArchitecture | Gets the ProcessorArchitecture information from the PE headers.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | RuntimeMajorVersion | Gets or sets the RuntimeMajorVersion field of the CLI header.
Public property | RuntimeMinorVersion | Gets or sets the RuntimeMinorVersion field of the CLI header.
Public property | StackReserve | Gets or sets the SizeOfStackReserve value in the NT Optional header.
Public property | StandaloneSignatures | Gets the collection of standalone signatures (StandaloneSignatureDeclarationCollection).
Public property | Subsystem | Gets or sets the kind of PE file (library, console executable, graphic executable).
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current module.
Public property | Types | Gets the collection of types (TypeDefDeclaration).
Public property | TypeSpecs | Gets the collection of type specifications (TypeSpecDeclaration).
Public property | UnmanagedResources | Gets the collection of unmanaged resources.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleDeclaration Constructor

ModuleDeclaration Constructor
ModuleDeclaration Class See Also Send Feedback
Initializes a new ModuleDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration()

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleDeclaration Methods

[image]

PostSharp 2.0 Documentation
ModuleDeclaration Methods
ModuleDeclaration Class See Also Send Feedback

The ModuleDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllTags | Removes, from all elements of this module (MetadataDeclaration only), all tags of a given Guid.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindAssembly | Overloaded. Finds an assembly in the current module.
Public method | FindDeclaration | Finds a declaration given its reflection object and returns it translated for the current module.
Public method | FindField | Overloaded.
Public method | FindMethod | Overloaded.
Public method | FindMscorlib | Finds the mscorlib assembly referred to by the current module.
Public method | FindType | Overloaded. Finds a type in the current module.
Public method | GetDeclarationEnumerator | Gets an enumeration of declarations of a given type.
Public method | GetFrameworkVariant |
Public method | GetMethodSignature | Gets a MethodSignature for a MethodBase.
Public method | GetSystemModule | Gets the runtime module corresponding to the current instance.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetType | Gets a IType given a ITypeSignature.
Public method | GetTypeForFrameworkVariant | Overloaded.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearAllTags Method

ModuleDeclaration..::..ClearAllTags Method
ModuleDeclaration Class See Also Send Feedback
Removes, from all elements of this module (MetadataDeclaration only), all tags of a given Guid.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ClearAllTags(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identification.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method

[image]

PostSharp 2.0 Documentation
ModuleDeclaration..::..FindAssembly Method
ModuleDeclaration Class See Also Send Feedback
Finds an assembly in the current module.

Overload List

 | Name | Description
Public method | FindAssembly(Assembly, BindingOptions) | Finds in the current module an assembly corresponding to a given runtime assembly.
Public method | FindAssembly(IAssemblyName, BindingOptions) | Finds in the current module an assembly corresponding to a given AssemblyName.

See Also

ModuleDeclaration Class
ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method (Assembly, BindingOptions)

ModuleDeclaration..::..FindAssembly Method (Assembly, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module an assembly corresponding to a given runtime assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly FindAssembly(
    Assembly reflectionAssembly,
    BindingOptions bindingOptions
)

Parameters

reflectionAssembly
Type: System.Reflection..::.Assembly
A runtime Assembly.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior of the binding in case that reflectionAssembly could not be found in the current module.

Return Value

The IAssembly corresponding to reflectionAssembly, or null if no assembly was found.

See Also

ModuleDeclaration Class
FindAssembly Overload
PostSharp.Sdk.CodeModel Namespace


FindAssembly Method (IAssemblyName, BindingOptions)

ModuleDeclaration..::..FindAssembly Method (IAssemblyName, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module an assembly corresponding to a given AssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly FindAssembly(
    IAssemblyName assemblyName,
    BindingOptions bindingOptions
)

Parameters

assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An AssemblyName.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior of the binding in case that assemblyName could not be found in the current module.

Return Value

The IAssembly corresponding to assemblyName, or null if no assembly was found.

See Also

ModuleDeclaration Class
FindAssembly Overload
PostSharp.Sdk.CodeModel Namespace


FindDeclaration Method

ModuleDeclaration..::..FindDeclaration Method
ModuleDeclaration Class See Also Send Feedback
Finds a declaration given its reflection object and returns it translated for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool FindDeclaration(
    Object reflectionElement,
    out MetadataDeclaration target,
    out TokenType tokenType
)

Parameters

reflectionElement
Type: System..::.Object
A reflection element, such as a Type or a MethodInfo.
target
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration %
At output, the declaration corresponding to reflectionElement, or null if the declaration could not be found.
tokenType
Type: PostSharp.Sdk.CodeModel..::.TokenType %
At output, the kind of declaration represented by reflectionElement. The value of this output parameter is set even if the method returns false.

Return Value

true in case of success, otherwise false.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindField Method

[image]

PostSharp 2.0 Documentation
ModuleDeclaration..::..FindField Method
ModuleDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindField(FieldInfo, BindingOptions) | Finds in the current module a field given its runtime representation (FieldInfo).
Public method | FindField(ITypeSignature, String) | Finds a field defined in a type (given as an ITypeSignature) and translates it for the current module.
Public method | FindField(TypeDefDeclaration, String) | Finds a field defined in a TypeDefDeclaration and translates it for the current module.

See Also

ModuleDeclaration Class
ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FindField Method (FieldInfo, BindingOptions)

ModuleDeclaration..::..FindField Method (FieldInfo, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module a field given its runtime representation (FieldInfo).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField FindField(
    FieldInfo reflectionField,
    BindingOptions bindingOptions
)

Parameters

reflectionField
Type: System.Reflection..::.FieldInfo
The runtime field representation.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The requested field, or null if the requested field could not be found.

See Also

ModuleDeclaration Class
FindField Overload
PostSharp.Sdk.CodeModel Namespace


FindField Method (ITypeSignature, String)

ModuleDeclaration..::..FindField Method (ITypeSignature, String)
ModuleDeclaration Class See Also Send Feedback
Finds a field defined in a type (given as an ITypeSignature) and translates it for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField FindField(
    ITypeSignature type,
    string fieldName
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type defining the field.
fieldName
Type: System..::.String
Field name.

Return Value

The field named fieldName in type type.

See Also

ModuleDeclaration Class
FindField Overload
PostSharp.Sdk.CodeModel Namespace


FindField Method (TypeDefDeclaration, String)

ModuleDeclaration..::..FindField Method (TypeDefDeclaration, String)
ModuleDeclaration Class See Also Send Feedback
Finds a field defined in a TypeDefDeclaration and translates it for the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField FindField(
    TypeDefDeclaration type,
    string fieldName
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The type defining the field.
fieldName
Type: System..::.String
Field name.

Return Value

The field named fieldName in type type.

See Also

ModuleDeclaration Class
FindField Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method

[image]

PostSharp 2.0 Documentation
ModuleDeclaration..::..FindMethod Method
ModuleDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindMethod(MethodBase, BindingOptions) | Finds in the current module a method given its runtime representation (MethodBase).
Public method | FindMethod(String, String) | Finds a method in a type given its name.
Public method | FindMethod(ITypeSignature, String) | Finds a method in the current module given its declaring type and the method name.
Public method | FindMethod(String, String, Int32) | Finds a method in a type given its name and number of parameters.
Public method | FindMethod(String, String, Predicate<(Of <(MethodDefDeclaration>)>)) | Finds a method given the name of its declaring type, the method name, and a predicate.
Public method | FindMethod(String, String, array<String>[]()[]) | Finds a method in a type given its name and the name of the parameter types.
Public method | FindMethod(ITypeSignature, String, Int32) | Finds a method in the current module given its declaring type, its name, and its number of parameters.
Public method | FindMethod(ITypeSignature, String, Predicate<(Of <(MethodDefDeclaration>)>)) | Finds a method in the current module given its declaring type, its name, and a predicate.
Public method | FindMethod(TypeDefDeclaration, String, Predicate<(Of <(MethodDefDeclaration>)>)) | Finds a method in the current module given its declaring type, its name, and a predicate.

See Also

ModuleDeclaration Class
ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (MethodBase, BindingOptions)

ModuleDeclaration..::..FindMethod Method (MethodBase, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module a method given its runtime representation (MethodBase).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindMethod(
    MethodBase reflectionMethod,
    BindingOptions bindingOptions
)

Parameters

reflectionMethod
Type: System.Reflection..::.MethodBase
The method runtime representation.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior of the binder in case that the method could not be found in the current module.

Return Value

The requested method, or null if the requested method could not be found.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (String, String)

ModuleDeclaration..::..FindMethod Method (String, String)
ModuleDeclaration Class See Also Send Feedback
Finds a method in a type given its name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindMethod(
    string typeName,
    string methodName
)

Parameters

typeName
Type: System..::.String
Name of the type declaring the method.
methodName
Type: System..::.String
Method name (should be unique in that type).

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (ITypeSignature, String)

ModuleDeclaration..::..FindMethod Method (ITypeSignature, String)
ModuleDeclaration Class See Also Send Feedback
Finds a method in the current module given its declaring type and the method name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition FindMethod(
    ITypeSignature type,
    string methodName
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type declaring the method.
methodName
Type: System..::.String
Method name.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (String, String, Int32)

ModuleDeclaration..::..FindMethod Method (String, String, Int32)
ModuleDeclaration Class See Also Send Feedback
Finds a method in a type given its name and number of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindMethod(
    string typeName,
    string methodName,
    int parameterCount
)

Parameters

typeName
Type: System..::.String
Name of the type declaring the method.
methodName
Type: System..::.String
Method name.
parameterCount
Type: System..::.Int32
Number of parameters of the method (there should be a single method named methodName with that number of parameters).

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (String, String, Predicate(MethodDefDeclaration))

ModuleDeclaration..::..FindMethod Method (String, String, Predicate<(Of <(<'MethodDefDeclaration>)>)>)
ModuleDeclaration Class See Also Send Feedback
Finds a method given the name of its declaring type, the method name, and a predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition FindMethod(
    string typeName,
    string methodName,
    Predicate<MethodDefDeclaration> predicate
)

Parameters

typeName
Type: System..::.String
Name of the declaring type.
methodName
Type: System..::.String
Method name.
predicate
Type: System..::.Predicate <(Of <(<' MethodDefDeclaration >)>)>
Predicate evaluated for each method overload. It can be true only once.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (String, String, String[])

ModuleDeclaration..::..FindMethod Method (String, String, array<String>[]()[][])
ModuleDeclaration Class See Also Send Feedback
Finds a method in a type given its name and the name of the parameter types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod FindMethod(
    string typeName,
    string methodName,
    params string[] parameterTypeNames
)

Parameters

typeName
Type: System..::.String
Name of the type declaring the method.
methodName
Type: System..::.String
Method name.
parameterTypeNames
Type: array< System..::.String >[]()[][]
Name of the parameter types.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (ITypeSignature, String, Int32)

ModuleDeclaration..::..FindMethod Method (ITypeSignature, String, Int32)
ModuleDeclaration Class See Also Send Feedback
Finds a method in the current module given its declaring type, its name, and its number of parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition FindMethod(
    ITypeSignature type,
    string methodName,
    int parameterCount
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type declaring the method.
methodName
Type: System..::.String
Method name.
parameterCount
Type: System..::.Int32
Number of parameters of the method.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (ITypeSignature, String, Predicate(MethodDefDeclaration))

ModuleDeclaration..::..FindMethod Method (ITypeSignature, String, Predicate<(Of <(<'MethodDefDeclaration>)>)>)
ModuleDeclaration Class See Also Send Feedback
Finds a method in the current module given its declaring type, its name, and a predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition FindMethod(
    ITypeSignature type,
    string methodName,
    Predicate<MethodDefDeclaration> predicate
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type declaring the method.
methodName
Type: System..::.String
Method name.
predicate
Type: System..::.Predicate <(Of <(<' MethodDefDeclaration >)>)>
Predicate determining of the method is the right one.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMethod Method (TypeDefDeclaration, String, Predicate(MethodDefDeclaration))

ModuleDeclaration..::..FindMethod Method (TypeDefDeclaration, String, Predicate<(Of <(<'MethodDefDeclaration>)>)>)
ModuleDeclaration Class See Also Send Feedback
Finds a method in the current module given its declaring type, its name, and a predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericMethodDefinition FindMethod(
    TypeDefDeclaration typeDef,
    string methodName,
    Predicate<MethodDefDeclaration> predicate
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Type declaring the method.
methodName
Type: System..::.String
Method name.
predicate
Type: System..::.Predicate <(Of <(<' MethodDefDeclaration >)>)>
Predicate determining of the method is the right one.

Return Value

The method.

See Also

ModuleDeclaration Class
FindMethod Overload
PostSharp.Sdk.CodeModel Namespace


FindMscorlib Method

ModuleDeclaration..::..FindMscorlib Method
ModuleDeclaration Class See Also Send Feedback
Finds the mscorlib assembly referred to by the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly FindMscorlib()

Return Value

An AssemblyRefDeclaration, or the current AssemblyEnvelope if the current module is mscorlib.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindType Method

[image]

PostSharp 2.0 Documentation
ModuleDeclaration..::..FindType Method
ModuleDeclaration Class See Also Send Feedback
Finds a type in the current module.

Overload List

 | Name | Description
Public method | FindType(Type) | Finds in the current module a type given its runtime representation.
Public method | FindType(String, BindingOptions) | Finds in the current module a type given its full name.
Public method | FindType(Type, BindingOptions) | Finds in the current module a type given its runtime representation and specifies BindingOptions.

See Also

ModuleDeclaration Class
ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FindType Method (Type)

ModuleDeclaration..::..FindType Method (Type)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module a type given its runtime representation.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FindType(
    Type reflectionType
)

Parameters

reflectionType
Type: System..::.Type
The type reflection representation.

Return Value

The requested type, or null if the requested type could not be found.

See Also

ModuleDeclaration Class
FindType Overload
PostSharp.Sdk.CodeModel Namespace


FindType Method (String, BindingOptions)

ModuleDeclaration..::..FindType Method (String, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module a type given its full name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FindType(
    string fullTypeName,
    BindingOptions bindingOptions
)

Parameters

fullTypeName
Type: System..::.String
The full type name, including the assembly name.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior of the binder in case that the assembly and/or type could not be found in the current module.

Return Value

The requested type.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.BindingException | The type could not be found.

See Also

ModuleDeclaration Class
FindType Overload
PostSharp.Sdk.CodeModel Namespace


FindType Method (Type, BindingOptions)

ModuleDeclaration..::..FindType Method (Type, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Finds in the current module a type given its runtime representation and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FindType(
    Type reflectionType,
    BindingOptions bindingOptions
)

Parameters

reflectionType
Type: System..::.Type
The type reflection representation.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior of the binder in case that the type could not be found in the current module.

Return Value

The requested type, or null if the requested type could not be found.

See Also

ModuleDeclaration Class
FindType Overload
PostSharp.Sdk.CodeModel Namespace


GetDeclarationEnumerator Method

ModuleDeclaration..::..GetDeclarationEnumerator Method
ModuleDeclaration Class See Also Send Feedback
Gets an enumeration of declarations of a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<MetadataDeclaration> GetDeclarationEnumerator(
    TokenType tokenType
)

Parameters

tokenType
Type: PostSharp.Sdk.CodeModel..::.TokenType
Types of declaration to be retrieved.

Return Value

An enumerator of all declarations of type TokenType present in the current module.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetFrameworkVariant Method

ModuleDeclaration..::..GetFrameworkVariant Method
ModuleDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.ModuleDeclaration.GetFrameworkVariant"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetFrameworkVariant()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.ModuleDeclaration.GetFrameworkVariant"]

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetMethodSignature Method

ModuleDeclaration..::..GetMethodSignature Method
ModuleDeclaration Class See Also Send Feedback
Gets a MethodSignature for a MethodBase.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature GetMethodSignature(
    MethodBase method,
    BindingOptions bindingOptions
)

Parameters

method
Type: System.Reflection..::.MethodBase
A method.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The MethodSignature corresponding to method in the current module.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemModule Method

ModuleDeclaration..::..GetSystemModule Method
ModuleDeclaration Class See Also Send Feedback
Gets the runtime module corresponding to the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Module GetSystemModule()

Return Value

A Module, or null if the current instance does not correspond to any runtime module.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ModuleDeclaration..::..GetTokenType Method
ModuleDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetType Method

ModuleDeclaration..::..GetType Method
ModuleDeclaration Class See Also Send Feedback
Gets a IType given a ITypeSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType GetType(
    ITypeSignature typeSignature
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type signature.

Return Value

The IType corresponding to typeSignature.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTypeForFrameworkVariant Method

[image]

PostSharp 2.0 Documentation
ModuleDeclaration..::..GetTypeForFrameworkVariant Method
ModuleDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeForFrameworkVariant(Type) | Obsolete. Gets an internal representation for a given type, but for the framework variant to which the current module is linked, with default binding options.
Public method | GetTypeForFrameworkVariant(Type, BindingOptions) | Obsolete. Gets an internal representation for a given type, but for the framework variant to which the current module is linked, and specifies binding options.

See Also

ModuleDeclaration Class
ModuleDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetTypeForFrameworkVariant Method (Type)

ModuleDeclaration..::..GetTypeForFrameworkVariant Method (Type)
ModuleDeclaration Class See Also Send Feedback
Gets an internal representation for a given type, but for the framework variant to which the current module is linked, with default binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Use Domain.FindType(Type).")]
public ITypeSignature GetTypeForFrameworkVariant(
    Type type
)

Parameters

type
Type: System..::.Type
Type.

Return Value

The internal type corresponding to type for the framework variant to which the current module is linked.

See Also

ModuleDeclaration Class
GetTypeForFrameworkVariant Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeForFrameworkVariant Method (Type, BindingOptions)

ModuleDeclaration..::..GetTypeForFrameworkVariant Method (Type, BindingOptions)
ModuleDeclaration Class See Also Send Feedback
Gets an internal representation for a given type, but for the framework variant to which the current module is linked, and specifies binding options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Use Domain.FindType(Type,BindingOptions).")]
public ITypeSignature GetTypeForFrameworkVariant(
    Type type,
    BindingOptions bindingOptions
)

Parameters

type
Type: System..::.Type
Type.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The internal type corresponding to type for the framework variant to which the current module is linked.

See Also

ModuleDeclaration Class
GetTypeForFrameworkVariant Overload
PostSharp.Sdk.CodeModel Namespace


ModuleDeclaration Properties

[image]

PostSharp 2.0 Documentation
ModuleDeclaration Properties
ModuleDeclaration Class See Also Send Feedback

The ModuleDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Assembly |
Public property | AssemblyManifest | Gets or sets the assembly manifest contained in the current module.
Public property | AssemblyRefs | Gets the collection of assembly references (AssemblyRefDeclaration).
Public property | Cache | Caches a set of frequently used declarations.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | Data | Gets the collection of raw data declarations (DataSectionDeclaration).
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | EntryPoint | Gets or sets the entry point of the current module.
Public property | FileAlignment | Gets or sets the FileAlignment value in the NT Optional header.
Public property | FileName | Gets the name of the file containing the module.
Public property | HasDebugInfo | Determines whether the current module has debugging information.
Public property | ImageAttributes | Gets the attributes of the PE image.
Public property | ImageBase | Gets or sets the ImageBase value in the NT Optional header.
Public property | ImageFileMachine | Gets or sets the ImageFileMachine information from the PE headers.
Public property | ImageKind | Gets or sets the PortableExecutableKind information from the PE headers.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsMscorlib | Determines whether the current module is mscorlib.
Public property | IsObfuscated | Determines whether the current module is obfuscated.
Public property | MetadataMajorVersion | Gets or sets the MajorVersion field of the metadata header.
Public property | MetadataMinorVersion | Gets or sets the MinorVersion field of the metadata header.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MetadataVersionString | Gets or sets the VersionString field of the metadata header.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | ModuleGuid | Gets or sets the GUID of the current module.
Public property | ModuleRefs | Gets the collection of module references (ModuleRefDeclaration).
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ProcessorArchitecture | Gets the ProcessorArchitecture information from the PE headers.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | RuntimeMajorVersion | Gets or sets the RuntimeMajorVersion field of the CLI header.
Public property | RuntimeMinorVersion | Gets or sets the RuntimeMinorVersion field of the CLI header.
Public property | StackReserve | Gets or sets the SizeOfStackReserve value in the NT Optional header.
Public property | StandaloneSignatures | Gets the collection of standalone signatures (StandaloneSignatureDeclarationCollection).
Public property | Subsystem | Gets or sets the kind of PE file (library, console executable, graphic executable).
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current module.
Public property | Types | Gets the collection of types (TypeDefDeclaration).
Public property | TypeSpecs | Gets the collection of type specifications (TypeSpecDeclaration).
Public property | UnmanagedResources | Gets the collection of unmanaged resources.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Assembly Property

ModuleDeclaration..::..Assembly Property
ModuleDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.ModuleDeclaration.Assembly"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyEnvelope Assembly { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyManifest Property

ModuleDeclaration..::..AssemblyManifest Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the assembly manifest contained in the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyManifestDeclaration AssemblyManifest { get; set; }

Remarks

An AssemblyManifestDeclaration, or null if this module does not contain any assembly manifest.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


AssemblyRefs Property

ModuleDeclaration..::..AssemblyRefs Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of assembly references (AssemblyRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyRefDeclarationCollection AssemblyRefs { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Cache Property

ModuleDeclaration..::..Cache Property
ModuleDeclaration Class See Also Send Feedback
Caches a set of frequently used declarations.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DeclarationCache Cache { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Data Property

ModuleDeclaration..::..Data Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of raw data declarations (DataSectionDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DataDeclarationCollection Data { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


EntryPoint Property

ModuleDeclaration..::..EntryPoint Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the entry point of the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration EntryPoint { get; set; }

Field Value

A reference to a MethodDefDeclaration, or null if the module has no entry point.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FileAlignment Property

ModuleDeclaration..::..FileAlignment Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the FileAlignment value in the NT Optional header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public uint FileAlignment { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FileName Property

ModuleDeclaration..::..FileName Property
ModuleDeclaration Class See Also Send Feedback
Gets the name of the file containing the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FileName { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


HasDebugInfo Property

ModuleDeclaration..::..HasDebugInfo Property
ModuleDeclaration Class See Also Send Feedback
Determines whether the current module has debugging information.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasDebugInfo { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImageAttributes Property

ModuleDeclaration..::..ImageAttributes Property
ModuleDeclaration Class See Also Send Feedback
Gets the attributes of the PE image.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImageAttributes ImageAttributes { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImageBase Property

ModuleDeclaration..::..ImageBase Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the ImageBase value in the NT Optional header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ulong ImageBase { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImageFileMachine Property

ModuleDeclaration..::..ImageFileMachine Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the ImageFileMachine information from the PE headers.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImageFileMachine ImageFileMachine { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ImageKind Property

ModuleDeclaration..::..ImageKind Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the PortableExecutableKind information from the PE headers.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PortableExecutableKind ImageKind { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

ModuleDeclaration..::..IsMscorlib Property
ModuleDeclaration Class See Also Send Feedback
Determines whether the current module is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; private set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsObfuscated Property

ModuleDeclaration..::..IsObfuscated Property
ModuleDeclaration Class See Also Send Feedback
Determines whether the current module is obfuscated.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsObfuscated { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataMajorVersion Property

ModuleDeclaration..::..MetadataMajorVersion Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the MajorVersion field of the metadata header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int MetadataMajorVersion { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataMinorVersion Property

ModuleDeclaration..::..MetadataMinorVersion Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the MinorVersion field of the metadata header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int MetadataMinorVersion { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MetadataVersionString Property

ModuleDeclaration..::..MetadataVersionString Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the VersionString field of the metadata header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MetadataVersionString { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleGuid Property

ModuleDeclaration..::..ModuleGuid Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the GUID of the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Guid ModuleGuid { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleRefs Property

ModuleDeclaration..::..ModuleRefs Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of module references (ModuleRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleRefDeclarationCollection ModuleRefs { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ModuleDeclaration..::..ParentMember Property
ModuleDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ModuleDeclaration..::..ParentType Property
ModuleDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

ModuleDeclaration..::..ProcessorArchitecture Property
ModuleDeclaration Class See Also Send Feedback
Gets the ProcessorArchitecture information from the PE headers.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


RuntimeMajorVersion Property

ModuleDeclaration..::..RuntimeMajorVersion Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the RuntimeMajorVersion field of the CLI header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int RuntimeMajorVersion { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


RuntimeMinorVersion Property

ModuleDeclaration..::..RuntimeMinorVersion Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the RuntimeMinorVersion field of the CLI header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int RuntimeMinorVersion { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StackReserve Property

ModuleDeclaration..::..StackReserve Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the SizeOfStackReserve value in the NT Optional header.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ulong StackReserve { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatures Property

ModuleDeclaration..::..StandaloneSignatures Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of standalone signatures (StandaloneSignatureDeclarationCollection).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneSignatureDeclarationCollection StandaloneSignatures { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Subsystem Property

ModuleDeclaration..::..Subsystem Property
ModuleDeclaration Class See Also Send Feedback
Gets or sets the kind of PE file (library, console executable, graphic executable).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Subsystem { get; set; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefs Property

ModuleDeclaration..::..TypeRefs Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclarationCollection TypeRefs { get; }

Implements

ITypeRefResolutionScope..::.TypeRefs

Remarks

A correct CLI module will not define type references whose resolution scope is a module. It will use directly a TypeDef token instead of a TypeRef token.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Types Property

ModuleDeclaration..::..Types Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of types (TypeDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclarationCollection Types { get; }

Implements

ITypeContainer..::.Types

Remarks

Note that this collection does not contain nested types. Nested types are nested in their parent type.

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSpecs Property

ModuleDeclaration..::..TypeSpecs Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of type specifications (TypeSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSpecDeclarationCollection TypeSpecs { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


UnmanagedResources Property

ModuleDeclaration..::..UnmanagedResources Property
ModuleDeclaration Class See Also Send Feedback
Gets the collection of unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceCollection UnmanagedResources { get; }

See Also

ModuleDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleRefDeclaration Class

ModuleRefDeclaration Class
Members See Also Send Feedback
Represents a reference to another module in the same assembly (ModuleRef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ModuleRefDeclaration : NamedMetadataDeclaration,
    IMemberRefResolutionScope, IGeneric, IModule, ITypeRefResolutionScope, IMetadataDeclaration,
    IDeclaration, IElement, IModuleElement, ITaggable

Remarks

Module references are contained by modules (ModuleDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.ModuleRefDeclaration

See Also

ModuleRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ModuleRefDeclaration Members

[image]

PostSharp 2.0 Documentation
ModuleRefDeclaration Members
ModuleRefDeclaration Class Constructors Methods Properties See Also Send Feedback

The ModuleRefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleRefDeclaration | Initializes a new ModuleRefDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindType |
Public method | GetModuleDefinition | Gets the ModuleDeclaration corresponding to the current reference.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | Assembly | Gets the assembly containing the module.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of field references (FieldRefDeclaration) declared in the referenced module.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of method references (MethodRefDeclaration) declared in the referenced module.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) declared in the referenced module.

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleRefDeclaration Constructor

ModuleRefDeclaration Constructor
ModuleRefDeclaration Class See Also Send Feedback
Initializes a new ModuleRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleRefDeclaration()

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
ModuleRefDeclaration Methods
ModuleRefDeclaration Class See Also Send Feedback

The ModuleRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | FindType |
Public method | GetModuleDefinition | Gets the ModuleDeclaration corresponding to the current reference.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

ModuleRefDeclaration..::..ClearCache Method
ModuleRefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindType Method

ModuleRefDeclaration..::..FindType Method
ModuleRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.ModuleRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature FindType(
    string typeName,
    BindingOptions options
)

Parameters

typeName
Type: System..::.String

[Missing <param name="typeName"/> documentation for "M:PostSharp.Sdk.CodeModel.ModuleRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

options
Type: PostSharp.Sdk.CodeModel..::.BindingOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.ModuleRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.ModuleRefDeclaration.FindType(System.String,PostSharp.Sdk.CodeModel.BindingOptions)"]

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetModuleDefinition Method

ModuleRefDeclaration..::..GetModuleDefinition Method
ModuleRefDeclaration Class See Also Send Feedback
Gets the ModuleDeclaration corresponding to the current reference.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration GetModuleDefinition()

Return Value

The ModuleDeclaration corresponding to the current reference.

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ModuleRefDeclaration..::..GetTokenType Method
ModuleRefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ModuleRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
ModuleRefDeclaration Properties
ModuleRefDeclaration Class See Also Send Feedback

The ModuleRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the assembly containing the module.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of field references (FieldRefDeclaration) declared in the referenced module.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of method references (MethodRefDeclaration) declared in the referenced module.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) declared in the referenced module.

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Assembly Property

ModuleRefDeclaration..::..Assembly Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the assembly containing the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAssembly Assembly { get; }

Field Value

The assembly (IAssembly) containing the module.

Implements

IModule..::.Assembly

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefs Property

ModuleRefDeclaration..::..FieldRefs Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the collection of field references (FieldRefDeclaration) declared in the referenced module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldRefDeclarationCollection FieldRefs { get; }

Implements

IMemberRefResolutionScope..::.FieldRefs

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefs Property

ModuleRefDeclaration..::..MethodRefs Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the collection of method references (MethodRefDeclaration) declared in the referenced module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodRefDeclarationCollection MethodRefs { get; }

Implements

IMemberRefResolutionScope..::.MethodRefs

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ModuleRefDeclaration..::..ParentMember Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ModuleRefDeclaration..::..ParentType Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefs Property

ModuleRefDeclaration..::..TypeRefs Property
ModuleRefDeclaration Class See Also Send Feedback
Gets the collection of type references (TypeRefDeclaration) declared in the referenced module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclarationCollection TypeRefs { get; }

Implements

ITypeRefResolutionScope..::.TypeRefs

See Also

ModuleRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedMetadataDeclaration Class

NamedMetadataDeclaration Class
Members See Also Send Feedback
Extends the MetadataDeclaration class with a Name property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class NamedMetadataDeclaration : MetadataDeclaration,
    INamed

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.AssemblyManifestDeclaration
PostSharp.Sdk.CodeModel..::.AssemblyRefDeclaration
PostSharp.Sdk.CodeModel..::.ExportedTypeDeclaration
PostSharp.Sdk.CodeModel..::.GenericParameterDeclaration
PostSharp.Sdk.CodeModel..::.ManifestFileDeclaration
PostSharp.Sdk.CodeModel..::.ManifestResourceDeclaration
PostSharp.Sdk.CodeModel..::.MemberRefDeclaration
PostSharp.Sdk.CodeModel..::.MethodGroupDeclaration
PostSharp.Sdk.CodeModel..::.ModuleDeclaration
PostSharp.Sdk.CodeModel..::.ModuleRefDeclaration
PostSharp.Sdk.CodeModel..::.NamedPositionedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
PostSharp.Sdk.CodeModel..::.TypeRefDeclaration

See Also

NamedMetadataDeclaration Members
PostSharp.Sdk.CodeModel Namespace


NamedMetadataDeclaration Members

[image]

PostSharp 2.0 Documentation
NamedMetadataDeclaration Members
NamedMetadataDeclaration Class Methods Properties See Also Send Feedback

The NamedMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

NamedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedMetadataDeclaration Methods

[image]

PostSharp 2.0 Documentation
NamedMetadataDeclaration Methods
NamedMetadataDeclaration Class See Also Send Feedback

The NamedMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

NamedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

NamedMetadataDeclaration..::..ToString Method
NamedMetadataDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

NamedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedMetadataDeclaration Properties

[image]

PostSharp 2.0 Documentation
NamedMetadataDeclaration Properties
NamedMetadataDeclaration Class See Also Send Feedback

The NamedMetadataDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

NamedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Name Property

NamedMetadataDeclaration..::..Name Property
NamedMetadataDeclaration Class See Also Send Feedback
Gets or sets the name of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string Name { get; set; }

Implements

INamed..::.Name

See Also

NamedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedPositionedMetadataDeclaration Class

NamedPositionedMetadataDeclaration Class
Members See Also Send Feedback
A NamedMetadataDeclaration with an Ordinal property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class NamedPositionedMetadataDeclaration : NamedMetadataDeclaration,
    IPositioned

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedPositionedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
PostSharp.Sdk.CodeModel..::.MethodDefDeclaration

See Also

NamedPositionedMetadataDeclaration Members
PostSharp.Sdk.CodeModel Namespace


NamedPositionedMetadataDeclaration Members

[image]

PostSharp 2.0 Documentation
NamedPositionedMetadataDeclaration Members
NamedPositionedMetadataDeclaration Class Methods Properties See Also Send Feedback

The NamedPositionedMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Position of the current item in its parent collection.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

NamedPositionedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedPositionedMetadataDeclaration Methods

[image]

PostSharp 2.0 Documentation
NamedPositionedMetadataDeclaration Methods
NamedPositionedMetadataDeclaration Class See Also Send Feedback

The NamedPositionedMetadataDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Inherited from MetadataDeclaration.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)

See Also

NamedPositionedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NamedPositionedMetadataDeclaration Properties

[image]

PostSharp 2.0 Documentation
NamedPositionedMetadataDeclaration Properties
NamedPositionedMetadataDeclaration Class See Also Send Feedback

The NamedPositionedMetadataDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Ordinal | Position of the current item in its parent collection.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MetadataDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

NamedPositionedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

NamedPositionedMetadataDeclaration..::..Ordinal Property
NamedPositionedMetadataDeclaration Class See Also Send Feedback
Position of the current item in its parent collection.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; set; }

Implements

IPositioned..::.Ordinal

See Also

NamedPositionedMetadataDeclaration Class
PostSharp.Sdk.CodeModel Namespace


NullableBool Structure

NullableBool Structure
Members See Also Send Feedback
Three-state boolean: True, False and Null.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct NullableBool : IEquatable<NullableBool>

Remarks

As in any three-state logic implementation, the Null element is absorbing for all operations.

See Also

NullableBool Members
PostSharp.Sdk.CodeModel Namespace


NullableBool Members

[image]

PostSharp 2.0 Documentation
NullableBool Members
NullableBool Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The NullableBool type exposes the following members.

Constructors

 | Name | Description
Public method | NullableBool | Initializes a new NullableBool from a Boolean.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
BitwiseAnd | Determines whether both instances are True.
BitwiseOr | Determines whether any of two instances is True.
Equality | Determines whether two instances of NullableBool are equal.
False | Determines whether a NullableBool is False.
Implicit | Overloaded.
Inequality | Determines whether two instances of NullableBool are different.
LogicalNot | Inverses the value of a NullableBool.
True | Determines whether a NullableBool is True.

Fields

Name | Description
False | False.
Null | Null.
True | True.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current instance is null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


NullableBool Constructor

NullableBool Constructor
NullableBool Structure See Also Send Feedback
Initializes a new NullableBool from a Boolean.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NullableBool(
    bool value
)

Parameters

value
Type: System..::.Boolean
Initial value.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


NullableBool Fields

[image]

PostSharp 2.0 Documentation
NullableBool Fields
NullableBool Structure See Also Send Feedback

The NullableBool type exposes the following members.

Fields

Name | Description
False | False.
Null | Null.
True | True.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


False Field

NullableBool..::..False Field
NullableBool Structure See Also Send Feedback
False.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly NullableBool False

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


Null Field

NullableBool..::..Null Field
NullableBool Structure See Also Send Feedback
Null.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly NullableBool Null

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


True Field

NullableBool..::..True Field
NullableBool Structure See Also Send Feedback
True.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly NullableBool True

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


NullableBool Methods

[image]

PostSharp 2.0 Documentation
NullableBool Methods
NullableBool Structure See Also Send Feedback

The NullableBool type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
NullableBool..::..Equals Method
NullableBool Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the current instance equals another. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(NullableBool) | Determines whether the current instance equals another.

See Also

NullableBool Structure
NullableBool Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (Object)

NullableBool..::..Equals Method (Object)
NullableBool Structure See Also Send Feedback
Determines whether the current instance equals another.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
A NullableBool.

Return Value

true if both instances are equal or false if they are different or at least one is Null.

See Also

NullableBool Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (NullableBool)

NullableBool..::..Equals Method (NullableBool)
NullableBool Structure See Also Send Feedback
Determines whether the current instance equals another.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    NullableBool other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

true if both instances are equal or false if they are different or at least one is Null.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

NullableBool Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetHashCode Method

NullableBool..::..GetHashCode Method
NullableBool Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

NullableBool..::..ToString Method
NullableBool Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


NullableBool Operators and Type Conversions

[image]

PostSharp 2.0 Documentation
NullableBool Operators and Type Conversions
NullableBool Structure See Also Send Feedback

The NullableBool type exposes the following members.

Operators

Name | Description
BitwiseAnd | Determines whether both instances are True.
BitwiseOr | Determines whether any of two instances is True.
Equality | Determines whether two instances of NullableBool are equal.
False | Determines whether a NullableBool is False.
Implicit | Overloaded.
Inequality | Determines whether two instances of NullableBool are different.
LogicalNot | Inverses the value of a NullableBool.
True | Determines whether a NullableBool is True.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


BitwiseAnd Operator

NullableBool..::..BitwiseAnd Operator
NullableBool Structure See Also Send Feedback
Determines whether both instances are True.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static NullableBool operator &(
    NullableBool left,
    NullableBool right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.
right
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

True if both instances are True, False if any instance is False or Null if any instance is Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


BitwiseOr Operator

NullableBool..::..BitwiseOr Operator
NullableBool Structure See Also Send Feedback
Determines whether any of two instances is True.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static NullableBool operator |(
    NullableBool left,
    NullableBool right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.
right
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

True if any instance is True, False if both instances is False or Null if any instance is Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


Equality Operator

NullableBool..::..Equality Operator
NullableBool Structure See Also Send Feedback
Determines whether two instances of NullableBool are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static NullableBool operator ==(
    NullableBool left,
    NullableBool right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.
right
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

True if both instances are equal, False if they are different or Null if any of them is Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


False Operator

NullableBool..::..False Operator
NullableBool Structure See Also Send Feedback
Determines whether a NullableBool is False.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator false(
    NullableBool value
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

true if value is False, false if it is True or Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


Implicit Conversion Operators

[image]

PostSharp 2.0 Documentation
NullableBool ImplicitWideningImplicitImplicitImplicit Conversion Operators
NullableBool Structure See Also Send Feedback

Overload List

Name | Description
Implicit(Boolean) | Converts a Boolean into a NullableBool.
Implicit(NullableBool) | Converts a NullableBool into a Boolean.

See Also

NullableBool Structure
NullableBool Members
PostSharp.Sdk.CodeModel Namespace


Implicit Conversion (Boolean to NullableBool)

NullableBool ImplicitWideningImplicitImplicitImplicit Conversion (Boolean to NullableBool)
NullableBool Structure See Also Send Feedback
Converts a Boolean into a NullableBool.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static implicit operator NullableBool (
    bool value
)

Parameters

value
Type: System..::.Boolean
A Boolean.

Return Value

True or False.

See Also

NullableBool Structure
Implicit Overload
PostSharp.Sdk.CodeModel Namespace


Implicit Conversion (NullableBool to Boolean)

NullableBool ImplicitWideningImplicitImplicitImplicit Conversion (NullableBool to Boolean)
NullableBool Structure See Also Send Feedback
Converts a NullableBool into a Boolean.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static implicit operator bool (
    NullableBool value
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool

Return Value

true if value equals True, otherwise false.

See Also

NullableBool Structure
Implicit Overload
PostSharp.Sdk.CodeModel Namespace


Inequality Operator

NullableBool..::..Inequality Operator
NullableBool Structure See Also Send Feedback
Determines whether two instances of NullableBool are different.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static NullableBool operator !=(
    NullableBool left,
    NullableBool right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.
right
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

True if instances are different, False if they are equal or Null if any of them is Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


LogicalNot Operator

NullableBool..::..LogicalNot Operator
NullableBool Structure See Also Send Feedback
Inverses the value of a NullableBool.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static NullableBool operator !(
    NullableBool value
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

True if the instance is False, False if it is True or Null if it is Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


True Operator

NullableBool..::..True Operator
NullableBool Structure See Also Send Feedback
Determines whether a NullableBool is True.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator true(
    NullableBool value
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.NullableBool
A NullableBool.

Return Value

true if value is True, false if it is False or Null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


NullableBool Properties

[image]

PostSharp 2.0 Documentation
NullableBool Properties
NullableBool Structure See Also Send Feedback

The NullableBool type exposes the following members.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current instance is null.

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


IsNull Property

NullableBool..::..IsNull Property
NullableBool Structure See Also Send Feedback
Determines whether the current instance is null.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNull { get; }

See Also

NullableBool Structure
PostSharp.Sdk.CodeModel Namespace


OpCodeDictionary(?0) Class

OpCodeDictionary<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Efficient implementation of a dictionary taking an OpCodeNumber as the key type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class OpCodeDictionary<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.OpCodeDictionary`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.OpCodeDictionary<(Of <(?0>)>)

See Also

OpCodeDictionary<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel Namespace


OpCodeDictionary(?0) Members

[image]

PostSharp 2.0 Documentation
OpCodeDictionary<(Of <(<'?0>)>)> Members
OpCodeDictionary<(Of <(?0>)>) Class Constructors Methods See Also Send Feedback

The OpCodeDictionary<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | OpCodeDictionary<(Of <(?0>)>) | Initializes a new OpCodeDictionary<(Of <(?0>)>).

Methods

 | Name | Description
Public method | GetValue | Gets a value associated with an OpCodeNumber.
Public method | SetValue | Sets a value associated with an OpCodeNumber.

See Also

OpCodeDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel Namespace


OpCodeDictionary(?0) Constructor

OpCodeDictionary<(Of <(<'?0>)>)> Constructor
OpCodeDictionary<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new OpCodeDictionary<(Of <(?0>)>).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OpCodeDictionary()

See Also

OpCodeDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel Namespace


OpCodeDictionary(?0) Methods

[image]

PostSharp 2.0 Documentation
OpCodeDictionary<(Of <(<'?0>)>)> Methods
OpCodeDictionary<(Of <(?0>)>) Class See Also Send Feedback

The OpCodeDictionary<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetValue | Gets a value associated with an OpCodeNumber.
Public method | SetValue | Sets a value associated with an OpCodeNumber.

See Also

OpCodeDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel Namespace


GetValue Method

OpCodeDictionary<(Of <(<'?0>)>)>..::..GetValue Method
OpCodeDictionary<(Of <(?0>)>) Class See Also Send Feedback
Gets a value associated with an OpCodeNumber.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 GetValue(
    OpCodeNumber opCode
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The value associated to opCode, or the default value of T if no value is associated with opCode.

See Also

OpCodeDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel Namespace


SetValue Method

OpCodeDictionary<(Of <(<'?0>)>)>..::..SetValue Method
OpCodeDictionary<(Of <(?0>)>) Class See Also Send Feedback
Sets a value associated with an OpCodeNumber.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetValue(
    OpCodeNumber opCode,
    ?0 value
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.
value
Type: ?0
The value associated with opCode.

See Also

OpCodeDictionary<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel Namespace


OpCodeMap Class

OpCodeMap Class
Members See Also Send Feedback
Maps OpCodeNumber to OpCode and provides the various properties of opcodes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class OpCodeMap

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.OpCodeMap

See Also

OpCodeMap Members
PostSharp.Sdk.CodeModel Namespace


OpCodeMap Members

[image]

PostSharp 2.0 Documentation
OpCodeMap Members
OpCodeMap Class Methods See Also Send Feedback

The OpCodeMap type exposes the following members.

Methods

Name | Description
AssertValidInstruction | Throws an ArgumentException if an instruction code is incorrect.
GetFlowControl | Gets the FlowControl of a given opcode.
GetName | Gets the name of a given opcode.
GetOpCode | Gets the OpCode corresponding to an OpCodeNumber.
GetOpCodeType | Gets the OpCodeType of a given opcode.
GetOperandType | Gets the OperandType of a given opcode.
GetSize | Gets the size of a given opcode.
GetStackBehaviourPop | Gets the pop StackBehaviour of a given opcode.
GetStackBehaviourPush | Gets the push StackBehaviour of a given opcode.
GetUncompressedOpCode | Gets the uncompressed opcode corresponding to a compressed opcode.
IsCompressedOpCode | Determines whether a given opcode is compressed.
IsParameterOperand | Determines whether an opcode takes a parameter operand.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


OpCodeMap Methods

[image]

PostSharp 2.0 Documentation
OpCodeMap Methods
OpCodeMap Class See Also Send Feedback

The OpCodeMap type exposes the following members.

Methods

Name | Description
AssertValidInstruction | Throws an ArgumentException if an instruction code is incorrect.
GetFlowControl | Gets the FlowControl of a given opcode.
GetName | Gets the name of a given opcode.
GetOpCode | Gets the OpCode corresponding to an OpCodeNumber.
GetOpCodeType | Gets the OpCodeType of a given opcode.
GetOperandType | Gets the OperandType of a given opcode.
GetSize | Gets the size of a given opcode.
GetStackBehaviourPop | Gets the pop StackBehaviour of a given opcode.
GetStackBehaviourPush | Gets the push StackBehaviour of a given opcode.
GetUncompressedOpCode | Gets the uncompressed opcode corresponding to a compressed opcode.
IsCompressedOpCode | Determines whether a given opcode is compressed.
IsParameterOperand | Determines whether an opcode takes a parameter operand.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


AssertValidInstruction Method

OpCodeMap..::..AssertValidInstruction Method
OpCodeMap Class See Also Send Feedback
Throws an ArgumentException if an instruction code is incorrect.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AssertValidInstruction(
    OpCodeNumber opCode
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An opcode.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetFlowControl Method

OpCodeMap..::..GetFlowControl Method
OpCodeMap Class See Also Send Feedback
Gets the FlowControl of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static FlowControl GetFlowControl(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The FlowControl corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetName Method

OpCodeMap..::..GetName Method
OpCodeMap Class See Also Send Feedback
Gets the name of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetName(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The name of the opcode corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetOpCode Method

OpCodeMap..::..GetOpCode Method
OpCodeMap Class See Also Send Feedback
Gets the OpCode corresponding to an OpCodeNumber.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static OpCode GetOpCode(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The OpCode corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetOpCodeType Method

OpCodeMap..::..GetOpCodeType Method
OpCodeMap Class See Also Send Feedback
Gets the OpCodeType of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static OpCodeType GetOpCodeType(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The OpCodeType corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetOperandType Method

OpCodeMap..::..GetOperandType Method
OpCodeMap Class See Also Send Feedback
Gets the OperandType of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static OperandType GetOperandType(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The OpCodeType corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetSize Method

OpCodeMap..::..GetSize Method
OpCodeMap Class See Also Send Feedback
Gets the size of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static int GetSize(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The size of the opcode corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetStackBehaviourPop Method

OpCodeMap..::..GetStackBehaviourPop Method
OpCodeMap Class See Also Send Feedback
Gets the pop StackBehaviour of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static StackBehaviour GetStackBehaviourPop(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The pop StackBehaviour corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetStackBehaviourPush Method

OpCodeMap..::..GetStackBehaviourPush Method
OpCodeMap Class See Also Send Feedback
Gets the push StackBehaviour of a given opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static StackBehaviour GetStackBehaviourPush(
    OpCodeNumber opCodeNumber
)

Parameters

opCodeNumber
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

The push StackBehaviour corresponding to opCodeNumber.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


GetUncompressedOpCode Method

OpCodeMap..::..GetUncompressedOpCode Method
OpCodeMap Class See Also Send Feedback
Gets the uncompressed opcode corresponding to a compressed opcode.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static UncompressedOpCode GetUncompressedOpCode(
    OpCodeNumber compressedOpCode
)

Parameters

compressedOpCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
The OpCodeNumber of a compressed opcode.

Return Value

An UncompressedOpCode, or a null UncompressedOpCode if compressedOpCode is not compressed.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


IsCompressedOpCode Method

OpCodeMap..::..IsCompressedOpCode Method
OpCodeMap Class See Also Send Feedback
Determines whether a given opcode is compressed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsCompressedOpCode(
    OpCodeNumber opCode
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

true if opCode is in compressed form, otherwise false.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


IsParameterOperand Method

OpCodeMap..::..IsParameterOperand Method
OpCodeMap Class See Also Send Feedback
Determines whether an opcode takes a parameter operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsParameterOperand(
    OpCodeNumber opCode
)

Parameters

opCode
Type: PostSharp.Sdk.CodeModel..::.OpCodeNumber
An OpCodeNumber.

Return Value

true if opCode takes a parameter operand, false otherwise.

See Also

OpCodeMap Class
PostSharp.Sdk.CodeModel Namespace


OpCodeNumber Enumeration

OpCodeNumber Enumeration
See Also Send Feedback
Enumeration of all opcode numbers.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum OpCodeNumber

Members

Member name | Value | Description
Nop | 0 | 0x00 nop
Break | 1 | 0x01 break
Ldarg_0 | 2 | 0x02 ldarg.0
Ldarg_1 | 3 | 0x03 ldarg.1
Ldarg_2 | 4 | 0x04 ldarg.2
Ldarg_3 | 5 | 0x05 ldarg.3
Ldloc_0 | 6 | 0x06 ldloc.0
Ldloc_1 | 7 | 0x07 ldloc.1
Ldloc_2 | 8 | 0x08 ldloc.2
Ldloc_3 | 9 | 0x09 ldloc.3
Stloc_0 | 10 | 0x0A stloc.0
Stloc_1 | 11 | 0x0B stloc.1
Stloc_2 | 12 | 0x0C stloc.2
Stloc_3 | 13 | 0x0D stloc.3
Ldarg_S | 14 | 0x0E ldarg.s
Ldarga_S | 15 | 0x0F ldarga.s
Starg_S | 16 | 0x10 starg.s
Ldloc_S | 17 | 0x11 ldloc.s
Ldloca_S | 18 | 0x12 ldloca.s
Stloc_S | 19 | 0x13 stloc.s
Ldnull | 20 | 0x14 ldnull
Ldc_I4_M1 | 21 | 0x15 ldc.i4.m1
Ldc_I4_0 | 22 | 0x16 ldc.i4.0
Ldc_I4_1 | 23 | 0x17 ldc.i4.1
Ldc_I4_2 | 24 | 0x18 ldc.i4.2
Ldc_I4_3 | 25 | 0x19 ldc.i4.3
Ldc_I4_4 | 26 | 0x1A ldc.i4.4
Ldc_I4_5 | 27 | 0x1B ldc.i4.5
Ldc_I4_6 | 28 | 0x1C ldc.i4.6
Ldc_I4_7 | 29 | 0x1D ldc.i4.7
Ldc_I4_8 | 30 | 0x1E ldc.i4.8
Ldc_I4_S | 31 | 0x1F ldc.i4.s
Ldc_I4 | 32 | 0x20 ldc.i4
Ldc_I8 | 33 | 0x21 ldc.i8
Ldc_R4 | 34 | 0x22 ldc.r4
Ldc_R8 | 35 | 0x23 ldc.r8
Dup | 37 | 0x25 dup
Pop | 38 | 0x26 pop
Jmp | 39 | 0x27 jmp
Call | 40 | 0x28 call
Calli | 41 | 0x29 calli
Ret | 42 | 0x2A ret
Br_S | 43 | 0x2B br.s
Brfalse_S | 44 | 0x2C brfalse.s
Brtrue_S | 45 | 0x2D brtrue.s
Beq_S | 46 | 0x2E beq.s
Bge_S | 47 | 0x2F bge.s
Bgt_S | 48 | 0x30 bgt.s
Ble_S | 49 | 0x31 ble.s
Blt_S | 50 | 0x32 blt.s
Bne_Un_S | 51 | 0x33 bne.un.s
Bge_Un_S | 52 | 0x34 bge.un.s
Bgt_Un_S | 53 | 0x35 bgt.un.s
Ble_Un_S | 54 | 0x36 ble.un.s
Blt_Un_S | 55 | 0x37 blt.un.s
Br | 56 | 0x38 br
Brfalse | 57 | 0x39 brfalse
Brtrue | 58 | 0x3A brtrue
Beq | 59 | 0x3B beq
Bge | 60 | 0x3C bge
Bgt | 61 | 0x3D bgt
Ble | 62 | 0x3E ble
Blt | 63 | 0x3F blt
Bne_Un | 64 | 0x40 bne.un
Bge_Un | 65 | 0x41 bge.un
Bgt_Un | 66 | 0x42 bgt.un
Ble_Un | 67 | 0x43 ble.un
Blt_Un | 68 | 0x44 blt.un
Switch | 69 | 0x45 switch
Ldind_I1 | 70 | 0x46 ldind.i1
Ldind_U1 | 71 | 0x47 ldind.u1
Ldind_I2 | 72 | 0x48 ldind.i2
Ldind_U2 | 73 | 0x49 ldind.u2
Ldind_I4 | 74 | 0x4A ldind.i4
Ldind_U4 | 75 | 0x4B ldind.u4
Ldind_I8 | 76 | 0x4C ldind.i8
Ldind_I | 77 | 0x4D ldind.i
Ldind_R4 | 78 | 0x4E ldind.r4
Ldind_R8 | 79 | 0x4F ldind.r8
Ldind_Ref | 80 | 0x50 ldind.ref
Stind_Ref | 81 | 0x51 stind.ref
Stind_I1 | 82 | 0x52 stind.i1
Stind_I2 | 83 | 0x53 stind.i2
Stind_I4 | 84 | 0x54 stind.i4
Stind_I8 | 85 | 0x55 stind.i8
Stind_R4 | 86 | 0x56 stind.r4
Stind_R8 | 87 | 0x57 stind.r8
Add | 88 | 0x58 add
Sub | 89 | 0x59 sub
Mul | 90 | 0x5A mul
Div | 91 | 0x5B div
Div_Un | 92 | 0x5C div.un
Rem | 93 | 0x5D rem
Rem_Un | 94 | 0x5E rem.un
And | 95 | 0x5F and
Or | 96 | 0x60 or
Xor | 97 | 0x61 xor
Shl | 98 | 0x62 shl
Shr | 99 | 0x63 shr
Shr_Un | 100 | 0x64 shr.un
Neg | 101 | 0x65 neg
Not | 102 | 0x66 not
Conv_I1 | 103 | 0x67 conv.i1
Conv_I2 | 104 | 0x68 conv.i2
Conv_I4 | 105 | 0x69 conv.i4
Conv_I8 | 106 | 0x6A conv.i8
Conv_R4 | 107 | 0x6B conv.r4
Conv_R8 | 108 | 0x6C conv.r8
Conv_U4 | 109 | 0x6D conv.u4
Conv_U8 | 110 | 0x6E conv.u8
Callvirt | 111 | 0x6F callvirt
Cpobj | 112 | 0x70 cpobj
Ldobj | 113 | 0x71 ldobj
Ldstr | 114 | 0x72 ldstr
Newobj | 115 | 0x73 newobj
Castclass | 116 | 0x74 castclass
Isinst | 117 | 0x75 isinst
Conv_R_Un | 118 | 0x76 conv.r.un
Unbox | 121 | 0x79 unbox
Throw | 122 | 0x7A throw
Ldfld | 123 | 0x7B ldfld
Ldflda | 124 | 0x7C ldflda
Stfld | 125 | 0x7D stfld
Ldsfld | 126 | 0x7E ldsfld
Ldsflda | 127 | 0x7F ldsflda
Stsfld | 128 | 0x80 stsfld
Stobj | 129 | 0x81 stobj
Conv_Ovf_I1_Un | 130 | 0x82 conv.ovf.i1.un
Conv_Ovf_I2_Un | 131 | 0x83 conv.ovf.i2.un
Conv_Ovf_I4_Un | 132 | 0x84 conv.ovf.i4.un
Conv_Ovf_I8_Un | 133 | 0x85 conv.ovf.i8.un
Conv_Ovf_U1_Un | 134 | 0x86 conv.ovf.u1.un
Conv_Ovf_U2_Un | 135 | 0x87 conv.ovf.u2.un
Conv_Ovf_U4_Un | 136 | 0x88 conv.ovf.u4.un
Conv_Ovf_U8_Un | 137 | 0x89 conv.ovf.u8.un
Conv_Ovf_I_Un | 138 | 0x8A conv.ovf.i.un
Conv_Ovf_U_Un | 139 | 0x8B conv.ovf.u.un
Box | 140 | 0x8C box
Newarr | 141 | 0x8D newarr
Ldlen | 142 | 0x8E ldlen
Ldelema | 143 | 0x8F ldelema
Ldelem_I1 | 144 | 0x90 ldelem.i1
Ldelem_U1 | 145 | 0x91 ldelem.u1
Ldelem_I2 | 146 | 0x92 ldelem.i2
Ldelem_U2 | 147 | 0x93 ldelem.u2
Ldelem_I4 | 148 | 0x94 ldelem.i4
Ldelem_U4 | 149 | 0x95 ldelem.u4
Ldelem_I8 | 150 | 0x96 ldelem.i8
Ldelem_I | 151 | 0x97 ldelem.i
Ldelem_R4 | 152 | 0x98 ldelem.r4
Ldelem_R8 | 153 | 0x99 ldelem.r8
Ldelem_Ref | 154 | 0x9A ldelem.ref
Stelem_I | 155 | 0x9B stelem.i
Stelem_I1 | 156 | 0x9C stelem.i1
Stelem_I2 | 157 | 0x9D stelem.i2
Stelem_I4 | 158 | 0x9E stelem.i4
Stelem_I8 | 159 | 0x9F stelem.i8
Stelem_R4 | 160 | 0xA0 stelem.r4
Stelem_R8 | 161 | 0xA1 stelem.r8
Stelem_Ref | 162 | 0xA2 stelem.ref
Ldelem | 163 | 0xA3 ldelem
Stelem | 164 | 0xA4 stelem
Unbox_Any | 165 | 0xA5 unbox.any
Conv_Ovf_I1 | 179 | 0xB3 conv.ovf.i1
Conv_Ovf_U1 | 180 | 0xB4 conv.ovf.u1
Conv_Ovf_I2 | 181 | 0xB5 conv.ovf.i2
Conv_Ovf_U2 | 182 | 0xB6 conv.ovf.u2
Conv_Ovf_I4 | 183 | 0xB7 conv.ovf.i4
Conv_Ovf_U4 | 184 | 0xB8 conv.ovf.u4
Conv_Ovf_I8 | 185 | 0xB9 conv.ovf.i8
Conv_Ovf_U8 | 186 | 0xBA conv.ovf.u8
Refanyval | 194 | 0xC2 refanyval
Ckfinite | 195 | 0xC3 ckfinite
Mkrefany | 198 | 0xC6 mkrefany
Ldtoken | 208 | 0xD0 ldtoken
Conv_U2 | 209 | 0xD1 conv.u2
Conv_U1 | 210 | 0xD2 conv.u1
Conv_I | 211 | 0xD3 conv.i
Conv_Ovf_I | 212 | 0xD4 conv.ovf.i
Conv_Ovf_U | 213 | 0xD5 conv.ovf.u
Add_Ovf | 214 | 0xD6 add.ovf
Add_Ovf_Un | 215 | 0xD7 add.ovf.un
Mul_Ovf | 216 | 0xD8 mul.ovf
Mul_Ovf_Un | 217 | 0xD9 mul.ovf.un
Sub_Ovf | 218 | 0xDA sub.ovf
Sub_Ovf_Un | 219 | 0xDB sub.ovf.un
Endfinally | 220 | 0xDC endfinally
Leave | 221 | 0xDD leave
Leave_S | 222 | 0xDE leave.s
Stind_I | 223 | 0xDF stind.i
Conv_U | 224 | 0xE0 conv.u
_CountShort | 225 | Number of short opcodes.
Arglist | 65024 | 0xFE 0x00 arglist
Ceq | 65025 | 0xFE 0x01 ceq
Cgt | 65026 | 0xFE 0x02 cgt
Cgt_Un | 65027 | 0xFE 0x03 cgt.un
Clt | 65028 | 0xFE 0x04 clt
Clt_Un | 65029 | 0xFE 0x05 clt.un
Ldftn | 65030 | 0xFE 0x06 ldftn
Ldvirtftn | 65031 | 0xFE 0x07 ldvirtftn
Ldarg | 65033 | 0xFE 0x09 ldarg
Ldarga | 65034 | 0xFE 0x0A ldarga
Starg | 65035 | 0xFE 0x0B starg
Ldloc | 65036 | 0xFE 0x0C ldloc
Ldloca | 65037 | 0xFE 0x0D ldloca
Stloc | 65038 | 0xFE 0x0E stloc
Localloc | 65039 | 0xFE 0x0F localloc
Endfilter | 65041 | 0xFE 0x11 endfilter
Unaligned | 65042 | 0xFE 0x12 unaligned.
Volatile | 65043 | 0xFE 0x13 volatile.
Tail | 65044 | 0xFE 0x14 tail.
Initobj | 65045 | 0xFE 0x15 initobj
Constrained | 65046 | 0xFE 0x16 constrained.
Cpblk | 65047 | 0xFE 0x17 cpblk
Initblk | 65048 | 0xFE 0x18 initblk
Rethrow | 65050 | 0xFE 0x1A rethrow
Sizeof | 65052 | 0xFE 0x1C sizeof
Refanytype | 65053 | 0xFE 0x1D refanytype
Readonly | 65054 | 0xFE 0x1E readonly.
_SequencePoint | 65279 | Pseudo-instruction used internally by to denote a SymbolSequencePoint.
_CountLarge | 31 | Number of large opcodes.

See Also

PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Class

ParameterDeclaration Class
Members See Also Send Feedback
Represents a method parameter (ParamDef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ParameterDeclaration : MetadataDeclaration,
    ICloneable, IPositioned, IWriteReflectionName

Remarks

Parameters are owned by methods (MethodDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.ParameterDeclaration

See Also

ParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Members

[image]

PostSharp 2.0 Documentation
ParameterDeclaration Members
ParameterDeclaration Class Constructors Methods Properties See Also Send Feedback

The ParameterDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterDeclaration | Overloaded.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Overloaded.
 | CreateReturnParameter | Creates a new instance of ParameterDeclaration representing a return parameter.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection ParameterInfo that wraps the current parameter.
Public method | GetSystemParameter | Gets the system runtime parameter corresponding to the current parameter.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the parameters attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMethod | Gets the parent MethodDefDeclaration.
Public property | DefaultValue | Gets or sets the default value.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MarshalType | Gets or sets the parameter marshal type.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the parameter name.
Public property | Ordinal | Gets or sets the parameter ordinal, i.e. its position in the list of parameters of the parent method.
Public property | ParameterType | Gets or sets the parameter type.
Public property | Parent | Gets the parent MethodDefDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Constructor

[image]

PostSharp 2.0 Documentation
ParameterDeclaration Constructor
ParameterDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParameterDeclaration()()() | Initializes a new ParameterDeclaration.
Public method | ParameterDeclaration(Int32, String, ITypeSignature) | Initializes a new ParameterDeclaration and sets some of its properties.

See Also

ParameterDeclaration Class
ParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Constructor

ParameterDeclaration Constructor
ParameterDeclaration Class See Also Send Feedback
Initializes a new ParameterDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration()

See Also

ParameterDeclaration Class
ParameterDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Constructor (Int32, String, ITypeSignature)

ParameterDeclaration Constructor (Int32, String, ITypeSignature)
ParameterDeclaration Class See Also Send Feedback
Initializes a new ParameterDeclaration and sets some of its properties.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration(
    int ordinal,
    string name,
    ITypeSignature parameterType
)

Parameters

ordinal
Type: System..::.Int32
Position of the parameter in the signature.
name
Type: System..::.String
Parameter name.
parameterType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Parameter type.

See Also

ParameterDeclaration Class
ParameterDeclaration Overload
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Methods

[image]

PostSharp 2.0 Documentation
ParameterDeclaration Methods
ParameterDeclaration Class See Also Send Feedback

The ParameterDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Overloaded.
 | CreateReturnParameter | Creates a new instance of ParameterDeclaration representing a return parameter.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection ParameterInfo that wraps the current parameter.
Public method | GetSystemParameter | Gets the system runtime parameter corresponding to the current parameter.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

[image]

PostSharp 2.0 Documentation
ParameterDeclaration..::..Clone Method
ParameterDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clone()()() | Returns a copy of the current parameter, targeted to the same module as the current parameter.
Public method | Clone(ModuleDeclaration) | Returns a copy of the current parameter and allows to translate it to a different module as the module of the current parameter, without copying custom attributes;
Public method | Clone(ModuleDeclaration, Boolean) | Returns a copy of the current parameter and allows to translate it to a different module as the module of the current parameter and specifies whether custom attributes should be copied.

See Also

ParameterDeclaration Class
ParameterDeclaration Members
PostSharp.Sdk.CodeModel Namespace


Clone Method

ParameterDeclaration..::..Clone Method
ParameterDeclaration Class See Also Send Feedback
Returns a copy of the current parameter, targeted to the same module as the current parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration Clone()

Return Value

A copy of the current parameter, detached from its parent method, but related to the same module as the current parameter.

See Also

ParameterDeclaration Class
Clone Overload
PostSharp.Sdk.CodeModel Namespace


Clone Method (ModuleDeclaration)

ParameterDeclaration..::..Clone Method (ModuleDeclaration)
ParameterDeclaration Class See Also Send Feedback
Returns a copy of the current parameter and allows to translate it to a different module as the module of the current parameter, without copying custom attributes;

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which the current ParameterDeclaration should be translated.

Return Value

A copy of the current parameter, detached from its parent method, translated to targetModule.

See Also

ParameterDeclaration Class
Clone Overload
PostSharp.Sdk.CodeModel Namespace


Clone Method (ModuleDeclaration, Boolean)

ParameterDeclaration..::..Clone Method (ModuleDeclaration, Boolean)
ParameterDeclaration Class See Also Send Feedback
Returns a copy of the current parameter and allows to translate it to a different module as the module of the current parameter and specifies whether custom attributes should be copied.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclaration Clone(
    ModuleDeclaration targetModule,
    bool copyCustomAttributes
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which the current ParameterDeclaration should be translated.
copyCustomAttributes
Type: System..::.Boolean
true if custom attributes have to be cloned and copied, otherwise false.

Return Value

A copy of the current parameter, detached from its parent method, translated to targetModule.

See Also

ParameterDeclaration Class
Clone Overload
PostSharp.Sdk.CodeModel Namespace


CreateReturnParameter Method

ParameterDeclaration..::..CreateReturnParameter Method
ParameterDeclaration Class See Also Send Feedback
Creates a new instance of ParameterDeclaration representing a return parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ParameterDeclaration CreateReturnParameter(
    ITypeSignature returnType
)

Parameters

returnType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Return type.

Return Value

A new instance of ParameterDeclaration whose parameter type is returnType, representing a return parameter.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

ParameterDeclaration..::..GetReflectionWrapper Method
ParameterDeclaration Class See Also Send Feedback
Gets a reflection ParameterInfo that wraps the current parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A ParameterInfo wrapping current parameter in the given generic context.

Remarks

This method returns a ParameterInfo that is different from the system runtime parameter that is retrieved by GetSystemParameter(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current parameter even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemParameter Method

ParameterDeclaration..::..GetSystemParameter Method
ParameterDeclaration Class See Also Send Feedback
Gets the system runtime parameter corresponding to the current parameter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterInfo GetSystemParameter(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime ParameterInfo, or null if the current parameter could not be bound.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

ParameterDeclaration..::..GetTokenType Method
ParameterDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

ParameterDeclaration..::..ToString Method
ParameterDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

ParameterDeclaration..::..WriteReflectionName Method
ParameterDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParameterDeclaration Properties

[image]

PostSharp 2.0 Documentation
ParameterDeclaration Properties
ParameterDeclaration Class See Also Send Feedback

The ParameterDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the parameters attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringMethod | Gets the parent MethodDefDeclaration.
Public property | DefaultValue | Gets or sets the default value.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MarshalType | Gets or sets the parameter marshal type.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the parameter name.
Public property | Ordinal | Gets or sets the parameter ordinal, i.e. its position in the list of parameters of the parent method.
Public property | ParameterType | Gets or sets the parameter type.
Public property | Parent | Gets the parent MethodDefDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

ParameterDeclaration..::..Attributes Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the parameters attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterAttributes Attributes { get; set; }

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringMethod Property

ParameterDeclaration..::..DeclaringMethod Property
ParameterDeclaration Class See Also Send Feedback
Gets the parent MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration DeclaringMethod { get; }

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DefaultValue Property

ParameterDeclaration..::..DefaultValue Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the default value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue DefaultValue { get; set; }

Remarks

A SerializedValue, or null if the parameter has no default value.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MarshalType Property

ParameterDeclaration..::..MarshalType Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the parameter marshal type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalType MarshalType { get; set; }

Field Value

A MarshalType, or null if the parameter has default marshaling.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Name Property

ParameterDeclaration..::..Name Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the parameter name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Ordinal Property

ParameterDeclaration..::..Ordinal Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the parameter ordinal, i.e. its position in the list of parameters of the parent method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; set; }

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParameterType Property

ParameterDeclaration..::..ParameterType Property
ParameterDeclaration Class See Also Send Feedback
Gets or sets the parameter type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ParameterType { get; set; }

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

ParameterDeclaration..::..Parent Property
ParameterDeclaration Class See Also Send Feedback
Gets the parent MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Parent { get; }

Remarks

This is a synonym to DeclaringMethod.

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

ParameterDeclaration..::..ParentMember Property
ParameterDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

ParameterDeclaration..::..ParentType Property
ParameterDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

ParameterDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionDeclaration Class

PermissionDeclaration Class
Members See Also Send Feedback
Represents a permission attribute.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PermissionDeclaration : Declaration,
    IDisposable, ICloneableModuleElement, IModuleElement

Remarks

Permission attributes are owned by permission sets (PermissionSetDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.PermissionDeclaration

See Also

PermissionDeclaration Members
PostSharp.Sdk.CodeModel Namespace


PermissionDeclaration Members

[image]

PostSharp 2.0 Documentation
PermissionDeclaration Members
PermissionDeclaration Class Constructors Methods Properties See Also Send Feedback

The PermissionDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | PermissionDeclaration | Initializes a new instance of the PermissionDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Properties | Gets the list of properties.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Type | Gets the type of permission attribute.

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionDeclaration Constructor

PermissionDeclaration Constructor
PermissionDeclaration Class See Also Send Feedback
Initializes a new instance of the PermissionDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionDeclaration()

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionDeclaration Methods

[image]

PostSharp 2.0 Documentation
PermissionDeclaration Methods
PermissionDeclaration Class See Also Send Feedback

The PermissionDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

PermissionDeclaration..::..Clone Method
PermissionDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.PermissionDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionDeclaration Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.PermissionDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.PermissionDeclaration.Clone(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Dispose Method

PermissionDeclaration..::..Dispose Method
PermissionDeclaration Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionDeclaration Properties

[image]

PostSharp 2.0 Documentation
PermissionDeclaration Properties
PermissionDeclaration Class See Also Send Feedback

The PermissionDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Properties | Gets the list of properties.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Type | Gets the type of permission attribute.

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsDisposed Property

PermissionDeclaration..::..IsDisposed Property
PermissionDeclaration Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Properties Property

PermissionDeclaration..::..Properties Property
PermissionDeclaration Class See Also Send Feedback
Gets the list of properties.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection Properties { get; }

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Type Property

PermissionDeclaration..::..Type Property
PermissionDeclaration Class See Also Send Feedback
Gets the type of permission attribute.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Type { get; set; }

See Also

PermissionDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSetDeclaration Class

PermissionSetDeclaration Class
Members See Also Send Feedback
Represents a permission set (Permission).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PermissionSetDeclaration : MetadataDeclaration,
    ICloneableModuleElement, IModuleElement

Remarks

Permissions sets are owned by types implementing ISecurable, i.e. types (TypeDefDeclaration) and methods (MethodDefDeclaration).

A permission set can be represented in the PE image either as a serialized custom attributes (in such case the Attributes property is set), either as XML (in such case the Xml property is set).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.PermissionSetDeclaration

See Also

PermissionSetDeclaration Members
PostSharp.Sdk.CodeModel Namespace


PermissionSetDeclaration Members

[image]

PostSharp 2.0 Documentation
PermissionSetDeclaration Members
PermissionSetDeclaration Class Constructors Methods Properties See Also Send Feedback

The PermissionSetDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | PermissionSetDeclaration | Initializes a new PermissionSetDeclaration.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Creates a clone of the current module element and express this clone for use in a different module.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

Properties

 | Name | Description
Public property | Attributes | Gets the collection of permission attributes (PermissionDeclaration).
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent declaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | SecurityAction | Gets or sets the SecurityAction of the current permission set.
Public property | Xml | Gets the XML representation.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSetDeclaration Constructor

PermissionSetDeclaration Constructor
PermissionSetDeclaration Class See Also Send Feedback
Initializes a new PermissionSetDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionSetDeclaration()

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSetDeclaration Methods

[image]

PostSharp 2.0 Documentation
PermissionSetDeclaration Methods
PermissionSetDeclaration Class See Also Send Feedback

The PermissionSetDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Clone | Creates a clone of the current module element and express this clone for use in a different module.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

PermissionSetDeclaration..::..Clone Method
PermissionSetDeclaration Class See Also Send Feedback
Creates a clone of the current module element and express this clone for use in a different module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionSetDeclaration Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration for which the clone should be expressed.

Return Value

A clone of the current element, expressed for targetModule.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

PermissionSetDeclaration..::..GetTokenType Method
PermissionSetDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSetDeclaration Properties

[image]

PostSharp 2.0 Documentation
PermissionSetDeclaration Properties
PermissionSetDeclaration Class See Also Send Feedback

The PermissionSetDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the collection of permission attributes (PermissionDeclaration).
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent declaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | SecurityAction | Gets or sets the SecurityAction of the current permission set.
Public property | Xml | Gets the XML representation.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

PermissionSetDeclaration..::..Attributes Property
PermissionSetDeclaration Class See Also Send Feedback
Gets the collection of permission attributes (PermissionDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionDeclarationCollection Attributes { get; }

Remarks

This collection is not relevant if the Xml property is not null.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

PermissionSetDeclaration..::..Parent Property
PermissionSetDeclaration Class See Also Send Feedback
Gets the parent declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration Parent { get; }

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

PermissionSetDeclaration..::..ParentMember Property
PermissionSetDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

PermissionSetDeclaration..::..ParentType Property
PermissionSetDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SecurityAction Property

PermissionSetDeclaration..::..SecurityAction Property
PermissionSetDeclaration Class See Also Send Feedback
Gets or sets the SecurityAction of the current permission set.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SecurityAction SecurityAction { get; set; }

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Xml Property

PermissionSetDeclaration..::..Xml Property
PermissionSetDeclaration Class See Also Send Feedback
Gets the XML representation.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Xml { get; set; }

Field Value

A String containing the XML representation, or null if the permission set is serialized to binary form, in which case individual attributes are available on the Attributes property.

See Also

PermissionSetDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PInvokeAttributes Enumeration

PInvokeAttributes Enumeration
See Also Send Feedback
P-Invoke attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum PInvokeAttributes

Members

Member name | Value | Description
None | 0 | Default.
NoMangle | 1 | Parameter types will not be mangled into the method name.
CharSetMask | 6 | Character set mask.
CharSetNotSpec | 0 | Character set not specified.
CharSetAnsi | 2 | Character set is ANSI.
CharSetUnicode | 4 | Character set is Unicode.
CharSetAuto | 6 | Character set choice is automatic.
SupportsLastError | 64 | Supports Windows GetLastError().
BestFitDisabled | 32 | Best fit disabled.
BestFitEnabled | 16 | Best fit enabled.
ThrowOnUnmappableCharEnabled | 4096 | Throws an exception when characters cannot be mapped to the target character set.
CallConventionMask | 1792 | Calling convention mask.
CallConventionWinApi | 256 | Calling convention is WINAPI.
CallConventionCdecl | 512 | Calling convention is cdecl.
CallConventionStdCall | 768 | Calling convention is stdcall.
CallConventionThisCall | 1024 | Calling convention is thiscall.
CallConventionFastCall | 1280 | Calling convention is fastcall.

See Also

PostSharp.Sdk.CodeModel Namespace


PInvokeMap Class

PInvokeMap Class
Members See Also Send Feedback
Maps a method declaration to an external unmanaged method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PInvokeMap

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.PInvokeMap

See Also

PInvokeMap Members
PostSharp.Sdk.CodeModel Namespace


PInvokeMap Members

[image]

PostSharp 2.0 Documentation
PInvokeMap Members
PInvokeMap Class Constructors Properties See Also Send Feedback

The PInvokeMap type exposes the following members.

Constructors

 | Name | Description
Public method | PInvokeMap | Initializes a new instance of the PInvokeMap class

Properties

 | Name | Description
Public property | Attributes | Gets or sets the PInvoke attributes.
Public property | MethodName | Gets or sets the name of the method.
Public property | Module | Gets or sets the module reference containing the unmanaged method.

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


PInvokeMap Constructor

PInvokeMap Constructor
PInvokeMap Class See Also Send Feedback
Initializes a new instance of the PInvokeMap class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PInvokeMap()

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


PInvokeMap Properties

[image]

PostSharp 2.0 Documentation
PInvokeMap Properties
PInvokeMap Class See Also Send Feedback

The PInvokeMap type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the PInvoke attributes.
Public property | MethodName | Gets or sets the name of the method.
Public property | Module | Gets or sets the module reference containing the unmanaged method.

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

PInvokeMap..::..Attributes Property
PInvokeMap Class See Also Send Feedback
Gets or sets the PInvoke attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PInvokeAttributes Attributes { get; set; }

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


MethodName Property

PInvokeMap..::..MethodName Property
PInvokeMap Class See Also Send Feedback
Gets or sets the name of the method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string MethodName { get; set; }

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


Module Property

PInvokeMap..::..Module Property
PInvokeMap Class See Also Send Feedback
Gets or sets the module reference containing the unmanaged method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleRefDeclaration Module { get; set; }

See Also

PInvokeMap Class
PostSharp.Sdk.CodeModel Namespace


PlatformInfo Class

PlatformInfo Class
Members See Also Send Feedback
Contains the characteristics of a platform, typically the target platform of the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PlatformInfo

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.PlatformInfo

See Also

PlatformInfo Members
PostSharp.Sdk.CodeModel Namespace


PlatformInfo Members

[image]

PostSharp 2.0 Documentation
PlatformInfo Members
PlatformInfo Class Properties See Also Send Feedback

The PlatformInfo type exposes the following members.

Properties

 | Name | Description
Public property | NativePointerSize | Gets the size of a native pointer in bytes.

See Also

PlatformInfo Class
PostSharp.Sdk.CodeModel Namespace


PlatformInfo Properties

[image]

PostSharp 2.0 Documentation
PlatformInfo Properties
PlatformInfo Class See Also Send Feedback

The PlatformInfo type exposes the following members.

Properties

 | Name | Description
Public property | NativePointerSize | Gets the size of a native pointer in bytes.

See Also

PlatformInfo Class
PostSharp.Sdk.CodeModel Namespace


NativePointerSize Property

PlatformInfo..::..NativePointerSize Property
PlatformInfo Class See Also Send Feedback
Gets the size of a native pointer in bytes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int NativePointerSize { get; }

See Also

PlatformInfo Class
PostSharp.Sdk.CodeModel Namespace


PortableExecutableKind Enumeration

PortableExecutableKind Enumeration
See Also Send Feedback
Kinds of PE formats.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum PortableExecutableKind

Members

Member name | Value | Description
PE32 | 267 | Format PE32.
PE32Plus | 523 | Format PE32+.

See Also

PostSharp.Sdk.CodeModel Namespace


PropertyDeclaration Class

PropertyDeclaration Class
Members See Also Send Feedback
Represents a property (Property).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PropertyDeclaration : MethodGroupDeclaration,
    IRemovable, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable, IWriteReflectionName

Remarks

Properties are owned by types (TypeDefDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.MethodGroupDeclaration
PostSharp.Sdk.CodeModel..::.PropertyDeclaration

See Also

PropertyDeclaration Members
PostSharp.Sdk.CodeModel Namespace


PropertyDeclaration Members

[image]

PostSharp 2.0 Documentation
PropertyDeclaration Members
PropertyDeclaration Class Constructors Methods Properties See Also Send Feedback

The PropertyDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyDeclaration | Initializes a new instance of the PropertyDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method. (Inherited from MethodGroupDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection PropertyInfo that wraps the current property.
Public method | GetSystemProperty | Gets the system runtime property corresponding to the current property.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the property attributes.
Public property | CallingConvention | Gets or sets the calling convention.
Public property | CanRead | Determines whether the current property can be read (i.e. has a get accessor).
Public property | CanWrite | Determines whether the current property can be written (i.e. has a set accessor).
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration. (Inherited from MethodGroupDeclaration.)
Public property | DefaultValue | Gets or sets the default value.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Getter | Gets the getter accessor, or null if the current property has no getter.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from MethodGroupDeclaration.)
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property. (Inherited from MethodGroupDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parameters | Gets the collection of parameter types.
Public property | Parent | Gets the parent TypeDefDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | PropertyType | Gets or sets the type of the property value.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Setter | Gets the getter accessor, or null if the current property has no getter.
Public property | Visibility | Gets the visibility of the current element. (Inherited from MethodGroupDeclaration.)

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PropertyDeclaration Constructor

PropertyDeclaration Constructor
PropertyDeclaration Class See Also Send Feedback
Initializes a new instance of the PropertyDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyDeclaration()

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PropertyDeclaration Methods

[image]

PostSharp 2.0 Documentation
PropertyDeclaration Methods
PropertyDeclaration Class See Also Send Feedback

The PropertyDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetAccessor | Gets an accessor method. (Inherited from MethodGroupDeclaration.)
Public method | GetReflectionWrapper | Gets a reflection PropertyInfo that wraps the current property.
Public method | GetSystemProperty | Gets the system runtime property corresponding to the current property.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from NamedMetadataDeclaration.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

PropertyDeclaration..::..ClearCache Method
PropertyDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

PropertyDeclaration..::..GetReflectionWrapper Method
PropertyDeclaration Class See Also Send Feedback
Gets a reflection PropertyInfo that wraps the current property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyInfo GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A PropertyInfo wrapping current property in the given generic context.

Remarks

This method returns a PropertyInfo that is different from the system runtime property that is retrieved by GetSystemProperty(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current property even when the declaring type it cannot be loaded in the Virtual Runtime Engine.

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemProperty Method

PropertyDeclaration..::..GetSystemProperty Method
PropertyDeclaration Class See Also Send Feedback
Gets the system runtime property corresponding to the current property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyInfo GetSystemProperty(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments valid in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments valid in the current context.

Return Value

The system runtime PropertyInfo, or null if the current property could not be bound.

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

PropertyDeclaration..::..GetTokenType Method
PropertyDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

PropertyDeclaration..::..Remove Method
PropertyDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

PropertyDeclaration..::..WriteReflectionName Method
PropertyDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PropertyDeclaration Properties

[image]

PostSharp 2.0 Documentation
PropertyDeclaration Properties
PropertyDeclaration Class See Also Send Feedback

The PropertyDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the property attributes.
Public property | CallingConvention | Gets or sets the calling convention.
Public property | CanRead | Determines whether the current property can be read (i.e. has a get accessor).
Public property | CanWrite | Determines whether the current property can be written (i.e. has a set accessor).
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the parent TypeDefDeclaration. (Inherited from MethodGroupDeclaration.)
Public property | DefaultValue | Gets or sets the default value.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Getter | Gets the getter accessor, or null if the current property has no getter.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsStatic | Determines whether the current member is static. (Inherited from MethodGroupDeclaration.)
Public property | Members | Gets the collection of method semantics, which map a method to a role in the current event or property. (Inherited from MethodGroupDeclaration.)
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parameters | Gets the collection of parameter types.
Public property | Parent | Gets the parent TypeDefDeclaration.
Public property | ParentMember | Gets the parent member of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | ParentType | Gets the parent type of the current declaration. (Inherited from MethodGroupDeclaration.)
Public property | PropertyType | Gets or sets the type of the property value.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Setter | Gets the getter accessor, or null if the current property has no getter.
Public property | Visibility | Gets the visibility of the current element. (Inherited from MethodGroupDeclaration.)

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

PropertyDeclaration..::..Attributes Property
PropertyDeclaration Class See Also Send Feedback
Gets or sets the property attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyAttributes Attributes { get; set; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CallingConvention Property

PropertyDeclaration..::..CallingConvention Property
PropertyDeclaration Class See Also Send Feedback
Gets or sets the calling convention.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CallingConvention CallingConvention { get; set; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CanRead Property

PropertyDeclaration..::..CanRead Property
PropertyDeclaration Class See Also Send Feedback
Determines whether the current property can be read (i.e. has a get accessor).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CanRead { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


CanWrite Property

PropertyDeclaration..::..CanWrite Property
PropertyDeclaration Class See Also Send Feedback
Determines whether the current property can be written (i.e. has a set accessor).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CanWrite { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DefaultValue Property

PropertyDeclaration..::..DefaultValue Property
PropertyDeclaration Class See Also Send Feedback
Gets or sets the default value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue DefaultValue { get; set; }

Field Value

A SerializedValue, or null if the property has no default value.

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Getter Property

PropertyDeclaration..::..Getter Property
PropertyDeclaration Class See Also Send Feedback
Gets the getter accessor, or null if the current property has no getter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Getter { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parameters Property

PropertyDeclaration..::..Parameters Property
PropertyDeclaration Class See Also Send Feedback
Gets the collection of parameter types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSignatureCollection Parameters { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Parent Property

PropertyDeclaration..::..Parent Property
PropertyDeclaration Class See Also Send Feedback
Gets the parent TypeDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration Parent { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PropertyType Property

PropertyDeclaration..::..PropertyType Property
PropertyDeclaration Class See Also Send Feedback
Gets or sets the type of the property value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature PropertyType { get; set; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Setter Property

PropertyDeclaration..::..Setter Property
PropertyDeclaration Class See Also Send Feedback
Gets the getter accessor, or null if the current property has no getter.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Setter { get; }

See Also

PropertyDeclaration Class
PostSharp.Sdk.CodeModel Namespace


RawUnmanagedResource Class

RawUnmanagedResource Class
Members See Also Send Feedback
Unmanaged resource given in raw form, as an array of bytes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class RawUnmanagedResource : UnmanagedResource

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.UnmanagedResource
PostSharp.Sdk.CodeModel..::.RawUnmanagedResource

See Also

RawUnmanagedResource Members
PostSharp.Sdk.CodeModel Namespace


RawUnmanagedResource Members

[image]

PostSharp 2.0 Documentation
RawUnmanagedResource Members
RawUnmanagedResource Class Constructors Methods Properties See Also Send Feedback

The RawUnmanagedResource type exposes the following members.

Constructors

 | Name | Description
Public method | RawUnmanagedResource | Initializes a new RawUnmanagedResource

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Characteristics | Gets or sets the characteristics (attributes) of the resource. (Inherited from UnmanagedResource.)
Public property | CodePage | Gets or sets the code page identifier of the current resource. (Inherited from UnmanagedResource.)
Public property | Data | Gets or sets the array of bytes implementing the resource.
Public property | Language | Gets or sets the language identifier of the current resource. (Inherited from UnmanagedResource.)
Public property | Name | Gets the name of the current resource. (Inherited from UnmanagedResource.)
Public property | TypeId | Gets the well-known type of the current resource, or None if the type is not well-known, in which case its name is given by the TypeName property. (Inherited from UnmanagedResource.)
Public property | TypeName | Gets the name of the type of the current resource, in case that the TypeId property is None/. (Inherited from UnmanagedResource.)
Public property | Version | Gets or sets the version of the current resource. (Inherited from UnmanagedResource.)

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


RawUnmanagedResource Constructor

RawUnmanagedResource Constructor
RawUnmanagedResource Class See Also Send Feedback
Initializes a new RawUnmanagedResource

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public RawUnmanagedResource(
    UnmanagedResourceName name,
    UnmanagedResourceName type,
    int codePage,
    int language,
    Version version,
    int characteristics,
    byte[] data
)

Parameters

name
Type: PostSharp.Sdk.CodeModel..::.UnmanagedResourceName
Resource name.
type
Type: PostSharp.Sdk.CodeModel..::.UnmanagedResourceName
Resource type. Typically, an UnmanagedResourceType wrapped into an UnmanagedResourceName.
codePage
Type: System..::.Int32
Code page identifier.
language
Type: System..::.Int32
Language identifier.
version
Type: System..::.Version
Resource version. Only Major and Minor properties are relevant.
characteristics
Type: System..::.Int32
Resource characteristics (attributes).
data
Type: array< System..::.Byte >[]()[][]
Raw data, or null.

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


RawUnmanagedResource Methods

[image]

PostSharp 2.0 Documentation
RawUnmanagedResource Methods
RawUnmanagedResource Class See Also Send Feedback

The RawUnmanagedResource type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

RawUnmanagedResource..::..ToString Method
RawUnmanagedResource Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


RawUnmanagedResource Properties

[image]

PostSharp 2.0 Documentation
RawUnmanagedResource Properties
RawUnmanagedResource Class See Also Send Feedback

The RawUnmanagedResource type exposes the following members.

Properties

 | Name | Description
Public property | Characteristics | Gets or sets the characteristics (attributes) of the resource. (Inherited from UnmanagedResource.)
Public property | CodePage | Gets or sets the code page identifier of the current resource. (Inherited from UnmanagedResource.)
Public property | Data | Gets or sets the array of bytes implementing the resource.
Public property | Language | Gets or sets the language identifier of the current resource. (Inherited from UnmanagedResource.)
Public property | Name | Gets the name of the current resource. (Inherited from UnmanagedResource.)
Public property | TypeId | Gets the well-known type of the current resource, or None if the type is not well-known, in which case its name is given by the TypeName property. (Inherited from UnmanagedResource.)
Public property | TypeName | Gets the name of the type of the current resource, in case that the TypeId property is None/. (Inherited from UnmanagedResource.)
Public property | Version | Gets or sets the version of the current resource. (Inherited from UnmanagedResource.)

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


Data Property

RawUnmanagedResource..::..Data Property
RawUnmanagedResource Class See Also Send Feedback
Gets or sets the array of bytes implementing the resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] Data { get; set; }

See Also

RawUnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


ReadModuleStrategy Enumeration

ReadModuleStrategy Enumeration
See Also Send Feedback
Determines how a module should be loaded.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum ReadModuleStrategy

Members

Member name | Value | Description
FromMemoryImage | 0 | The module should be loaded from its mapped image in memory, after it has been loaded into the CLR.
FromDisk | 1 | The module should be loaded directly from disk, without loading it into the CLR.

See Also

PostSharp.Sdk.CodeModel Namespace


ReflectionNameOptions Enumeration

ReflectionNameOptions Enumeration
See Also Send Feedback
Options for the methods WriteReflectionName(StringBuilder, ReflectionNameOptions).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum ReflectionNameOptions

Members

Member name | Value | Description
None | 0 | Default.
UseAssemblyName | 1 | Use assembly-qualified type names.
AngleGenericBrackets | 0 | Use angle brackets (e.g. <T>) for generic arguments. This is the default option.
SquareGenericBrackets | 2 | Use square brackets (e.g. [T]) instead of angle brackets (e.g. <T>). By default, angle brackets are used.
CurlGenericBrackets | 4 | Use curle brackets (e.g. {T}) instead of angle brackets (e.g. <T>) for generic arguments. By default, angle brackets are used.
GenericBracketsMask | 6 | Bit mask specifying the kind of brackets used for generic arguments. Valid values are AngleGenericBrackets (by default), SquareGenericBrackets and CurlGenericBrackets.
IgnoreGenericTypeDefParameters | 8 | Do not write generic parameters in type definitions. By default, the list of generic parameters is written.
DefaultContext | 0 | Default context. Masked by ContextMask.
MethodParameterContext | 16 | Encode using the rule that System.Reflection follows when it writes method parameters. Masked by ContextMask.
GenericArgumentContext | 32 | Encode using the rule that System.Reflection follows when it writes generic arguments. Masked by ContextMask.
ContextMask | 48 | Masks the bits determining the encoding rules. Encoding rules are needed when trying to mimmic fidelly the behavior of System.Reflection.
UseOrdinalsForGenerics | 64 | WriteValue ordinals of generic parameters (.e.g. !0, !1, !!0, ...) instead of the name of generic parameters.
SkipNamespace | 128 | Do not write namespaces of types.
XmlDoc | 256 | Indicates that the name should be generated in the XML documentation format.
XmlDocOptions | 268 | All options necessary to generate a name compatible with the XML documentation format.
XmlDocPrefix | 512 | Indicates that the name should start with the XML documentation format.
SymFile | 1024 | Indicates that the name should be generated for compatibility for the symbol file.
SymFileOptions | 1024 | All options necessary to generate a name for the symbol file.
SerializedValue | 2048 | Indicates that the type name should be compatible with serialized values.
SerializedValueOptions | 2051 | All options necessary to generate a name compatible with serialized values.

See Also

PostSharp.Sdk.CodeModel Namespace


SerializationType Class

SerializationType Class
Members See Also Send Feedback
Represents the type of a serialized value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class SerializationType

Remarks

Implementations of this abstract type are present in the PostSharp.Sdk.CodeModel.SerializationTypes namespace.

Note that this type and its implementation only represent intrinsic serialization types and arrays. Compound types are not covered.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.ArraySerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.EnumerationSerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.IntrinsicSerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.TaggedObjectSerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.TypeSerializationType

See Also

SerializationType Members
PostSharp.Sdk.CodeModel Namespace


SerializationType Members

[image]

PostSharp 2.0 Documentation
SerializationType Members
SerializationType Class Methods Properties See Also Send Feedback

The SerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue.
 | GetSerializationType | Gets the SerializationType corresponding to a given ITypeSignature.
Public method | Translate | Translates the current SerializationType so that it is valid in another module.
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type.
Public method | ValidateValue | Ensures that a value is compatible with the current type.

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs.
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType.
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


SerializationType Methods

[image]

PostSharp 2.0 Documentation
SerializationType Methods
SerializationType Class See Also Send Feedback

The SerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue.
 | GetSerializationType | Gets the SerializationType corresponding to a given ITypeSignature.
Public method | Translate | Translates the current SerializationType so that it is valid in another module.
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type.
Public method | ValidateValue | Ensures that a value is compatible with the current type.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


FromRuntimeValue Method

SerializationType..::..FromRuntimeValue Method
SerializationType Class See Also Send Feedback
Converts a runtime value into a SerializedValue.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue FromRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
A runtime value.

Return Value

A serialized value built from value.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


GetSerializationType Method

SerializationType..::..GetSerializationType Method
SerializationType Class See Also Send Feedback
Gets the SerializationType corresponding to a given ITypeSignature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializationType GetSerializationType(
    ITypeSignature typeSignature
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A ITypeSignature.

Return Value

The SerializationType corresponding to typeSignature.

Exceptions

Exception | Condition
System..::.ArgumentException | The given type cannot be serialized in intrinsic types.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

SerializationType..::..Translate Method
SerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


ValidateRuntimeValue Method

SerializationType..::..ValidateRuntimeValue Method
SerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


ValidateValue Method

SerializationType..::..ValidateValue Method
SerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


SerializationType Properties

[image]

PostSharp 2.0 Documentation
SerializationType Properties
SerializationType Class See Also Send Feedback

The SerializationType type exposes the following members.

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs.
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType.
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


Module Property

SerializationType..::..Module Property
SerializationType Class See Also Send Feedback
Gets the module to which the current SerializationType belongs.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


SystemType Property

SerializationType..::..SystemType Property
SerializationType Class See Also Send Feedback
Gets the system reflection type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual Type SystemType { get; }

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


TypeSignature Property

SerializationType..::..TypeSignature Property
SerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

SerializationType Class
PostSharp.Sdk.CodeModel Namespace


SerializedValue Class

SerializedValue Class
Members See Also Send Feedback
Represents a serialized value and stores enough information to serialize it back using the exact representation.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SerializedValue

Remarks

An instance of this class should be understood as a 'location' that can be assigned a value. The location has a type (Type property) and optionally a value (Value property).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializedValue

See Also

SerializedValue Members
PostSharp.Sdk.CodeModel Namespace
PostSharp.Sdk.CodeModel..::.SerializationType


SerializedValue Members

[image]

PostSharp 2.0 Documentation
SerializedValue Members
SerializedValue Class Constructors Methods Properties See Also Send Feedback

The SerializedValue type exposes the following members.

Constructors

 | Name | Description
Public method | SerializedValue | Initializes a new SerializedValue.

Methods

 | Name | Description
Public method | Clone | Creates a clone of the current SerializedValue and express this clone for use in a different module.
Public method | EmitLoadValue | Emits instructions that load the current value on the stack.
Public method | GetRuntimeValue | Overloaded.
 | GetValue | Gets an instance of SerializedValue.
Public method | Set | Set a new value and its type.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the current value so that it is valid in another module.

Properties

 | Name | Description
Public property | Type | Gets the type of the serialized value.
Public property | Value | Gets the value of the serialized value.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


SerializedValue Constructor

SerializedValue Constructor
SerializedValue Class See Also Send Feedback
Initializes a new SerializedValue.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue(
    SerializationType type,
    Object value
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.SerializationType
Value type.
value
Type: System..::.Object
Value.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


SerializedValue Methods

[image]

PostSharp 2.0 Documentation
SerializedValue Methods
SerializedValue Class See Also Send Feedback

The SerializedValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a clone of the current SerializedValue and express this clone for use in a different module.
Public method | EmitLoadValue | Emits instructions that load the current value on the stack.
Public method | GetRuntimeValue | Overloaded.
 | GetValue | Gets an instance of SerializedValue.
Public method | Set | Set a new value and its type.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | Translates the current value so that it is valid in another module.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


Clone Method

SerializedValue..::..Clone Method
SerializedValue Class See Also Send Feedback
Creates a clone of the current SerializedValue and express this clone for use in a different module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue Clone(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The ModuleDeclaration for which the clone should be expressed.

Return Value

A clone of the current SerializedValue , expressed for targetModule.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


EmitLoadValue Method

SerializedValue..::..EmitLoadValue Method
SerializedValue Class See Also Send Feedback
Emits instructions that load the current value on the stack.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitLoadValue(
    BaseInstructionWriter writer
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
Writer.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


GetRuntimeValue Method

[image]

PostSharp 2.0 Documentation
SerializedValue..::..GetRuntimeValue Method
SerializedValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuntimeValue()()() | Gets the value as required by the runtime.
Public method | GetRuntimeValue(SerializedValueBindingOptions) | Gets the value as required by the runtime and specifies SerializedValueBindingOptions.

See Also

SerializedValue Class
SerializedValue Members
PostSharp.Sdk.CodeModel Namespace


GetRuntimeValue Method

SerializedValue..::..GetRuntimeValue Method
SerializedValue Class See Also Send Feedback
Gets the value as required by the runtime.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetRuntimeValue()

Return Value

The value typed for use outside PostSharp.

See Also

SerializedValue Class
GetRuntimeValue Overload
PostSharp.Sdk.CodeModel Namespace


GetRuntimeValue Method (SerializedValueBindingOptions)

SerializedValue..::..GetRuntimeValue Method (SerializedValueBindingOptions)
SerializedValue Class See Also Send Feedback
Gets the value as required by the runtime and specifies SerializedValueBindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetRuntimeValue(
    SerializedValueBindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.SerializedValueBindingOptions
Options.

Return Value

The value typed for use outside PostSharp.

See Also

SerializedValue Class
GetRuntimeValue Overload
PostSharp.Sdk.CodeModel Namespace


GetValue Method

SerializedValue..::..GetValue Method
SerializedValue Class See Also Send Feedback
Gets an instance of SerializedValue.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue GetValue(
    ITypeSignature typeSignature,
    Object value
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Value type.
value
Type: System..::.Object
Value.

Return Value

A SerializedValue encapsulating typeSignature and value.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


Set Method

SerializedValue..::..Set Method
SerializedValue Class See Also Send Feedback
Set a new value and its type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Set(
    SerializationType type,
    Object value
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.SerializationType
Value type.
value
Type: System..::.Object
Value.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

SerializedValue..::..ToString Method
SerializedValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

SerializedValue..::..Translate Method
SerializedValue Class See Also Send Feedback
Translates the current value so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializedValue Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializedValue should be expressed.

Return Value

A SerializedValue equivalent to the current instance, but expressed for the other module.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


SerializedValue Properties

[image]

PostSharp 2.0 Documentation
SerializedValue Properties
SerializedValue Class See Also Send Feedback

The SerializedValue type exposes the following members.

Properties

 | Name | Description
Public property | Type | Gets the type of the serialized value.
Public property | Value | Gets the value of the serialized value.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


Type Property

SerializedValue..::..Type Property
SerializedValue Class See Also Send Feedback
Gets the type of the serialized value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializationType Type { get; }

Remarks

This property is read-only. Use the Set(SerializationType, Object) method to change the type and/or method of this instance.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


Value Property

SerializedValue..::..Value Property
SerializedValue Class See Also Send Feedback
Gets the value of the serialized value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object Value { get; }

Remarks

This property is read-only. Use the Set(SerializationType, Object) method to change the type and/or method of this instance.

See Also

SerializedValue Class
PostSharp.Sdk.CodeModel Namespace


SerializedValueBindingOptions Enumeration

SerializedValueBindingOptions Enumeration
See Also Send Feedback
Options for method GetRuntimeValue(SerializedValueBindingOptions).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum SerializedValueBindingOptions

Members

Member name | Value | Description
None | 0 | Default.
UseReflectionWrappers | 1 | Use reflection wrappers instead of system reflection objects.

See Also

PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Class

StandaloneAssemblyName Class
Members See Also Send Feedback
Standalone implementation of IAssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class StandaloneAssemblyName : IAssemblyName

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.StandaloneAssemblyName

See Also

StandaloneAssemblyName Members
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Members

[image]

PostSharp 2.0 Documentation
StandaloneAssemblyName Members
StandaloneAssemblyName Class Constructors Methods Properties See Also Send Feedback

The StandaloneAssemblyName type exposes the following members.

Constructors

 | Name | Description
Public method | StandaloneAssemblyName | Overloaded.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | PublicKeyToken |
Public property | Version | Gets the assembly version.

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Constructor

[image]

PostSharp 2.0 Documentation
StandaloneAssemblyName Constructor
StandaloneAssemblyName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StandaloneAssemblyName(String, Version, String, array<Byte>[]()[]) | Initializes a new StandaloneAssemblyName.
Public method | StandaloneAssemblyName(String, Version, String, array<Byte>[]()[], ProcessorArchitecture) | Initializes a new StandaloneAssemblyName.

See Also

StandaloneAssemblyName Class
StandaloneAssemblyName Members
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Constructor (String, Version, String, Byte[])

StandaloneAssemblyName Constructor (String, Version, String, array<Byte>[]()[][])
StandaloneAssemblyName Class See Also Send Feedback
Initializes a new StandaloneAssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneAssemblyName(
    string name,
    Version version,
    string culture,
    byte[] publicKeyToken
)

Parameters

name
Type: System..::.String
Short assembly name.
version
Type: System..::.Version
Assembly version.
culture
Type: System..::.String
Assembly culture.
publicKeyToken
Type: array< System..::.Byte >[]()[][]
Assembly public key token/

See Also

StandaloneAssemblyName Class
StandaloneAssemblyName Overload
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Constructor (String, Version, String, Byte[], ProcessorArchitecture)

StandaloneAssemblyName Constructor (String, Version, String, array<Byte>[]()[][], ProcessorArchitecture)
StandaloneAssemblyName Class See Also Send Feedback
Initializes a new StandaloneAssemblyName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneAssemblyName(
    string name,
    Version version,
    string culture,
    byte[] publicKeyToken,
    ProcessorArchitecture processorArchitecture
)

Parameters

name
Type: System..::.String
Short assembly name.
version
Type: System..::.Version
Assembly version.
culture
Type: System..::.String
Assembly culture.
publicKeyToken
Type: array< System..::.Byte >[]()[][]
Assembly public key token/
processorArchitecture
Type: System.Reflection..::.ProcessorArchitecture
Processor architecture.

See Also

StandaloneAssemblyName Class
StandaloneAssemblyName Overload
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Methods

[image]

PostSharp 2.0 Documentation
StandaloneAssemblyName Methods
StandaloneAssemblyName Class See Also Send Feedback

The StandaloneAssemblyName type exposes the following members.

Methods

 | Name | Description
Public method | GetPublicKey | Gets the assembly public key.
Public method | GetPublicKeyToken | Gets the assembly public key token.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the binding identity of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Gets the full name of an assembly. (Defined by AssemblyNameExtensions.)
Public Extension Method | [extension] | Converts an IAssemblyName into an AssemblyName. (Defined by AssemblyNameExtensions.)

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKey Method

StandaloneAssemblyName..::..GetPublicKey Method
StandaloneAssemblyName Class See Also Send Feedback
Gets the assembly public key.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKey()

Field Value

An array of bytes containing the public key, or null if no public key is specified (for instance if only the public key token is given).

Return Value

An array of bytes containing the public key, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKey()()()

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


GetPublicKeyToken Method

StandaloneAssemblyName..::..GetPublicKeyToken Method
StandaloneAssemblyName Class See Also Send Feedback
Gets the assembly public key token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] GetPublicKeyToken()

Return Value

An array of bytes containing the public key token, or null if no public key is specified.

Implements

IAssemblyName..::.GetPublicKeyToken()()()

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

StandaloneAssemblyName..::..ToString Method
StandaloneAssemblyName Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


StandaloneAssemblyName Properties

[image]

PostSharp 2.0 Documentation
StandaloneAssemblyName Properties
StandaloneAssemblyName Class See Also Send Feedback

The StandaloneAssemblyName type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the assembly culture name.
Public property | IsMscorlib | Determines whether the current assembly (or assembly reference) is mscorlib.
Public property | IsStronglyNamed | Determines whether the current assembly (or assembly reference) contains a strong name signature.
Public property | Name | Gets the assembly friendly name.
Public property | ProcessorArchitecture | Gets the processor architecture that the current assembly targets.
Public property | PublicKeyToken |
Public property | Version | Gets the assembly version.

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


Culture Property

StandaloneAssemblyName..::..Culture Property
StandaloneAssemblyName Class See Also Send Feedback
Gets the assembly culture name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; }

Field Value

The standard assembly culture name, or null if the assembly is culture-neutral.

Implements

IAssemblyName..::.Culture

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


IsMscorlib Property

StandaloneAssemblyName..::..IsMscorlib Property
StandaloneAssemblyName Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) is mscorlib.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsMscorlib { get; }

Implements

IAssemblyName..::.IsMscorlib

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


IsStronglyNamed Property

StandaloneAssemblyName..::..IsStronglyNamed Property
StandaloneAssemblyName Class See Also Send Feedback
Determines whether the current assembly (or assembly reference) contains a strong name signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsStronglyNamed { get; }

Implements

IAssemblyName..::.IsStronglyNamed

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


Name Property

StandaloneAssemblyName..::..Name Property
StandaloneAssemblyName Class See Also Send Feedback
Gets the assembly friendly name.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

Field Value

The assembly friendly name.

Implements

IAssemblyName..::.Name

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


ProcessorArchitecture Property

StandaloneAssemblyName..::..ProcessorArchitecture Property
StandaloneAssemblyName Class See Also Send Feedback
Gets the processor architecture that the current assembly targets.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProcessorArchitecture ProcessorArchitecture { get; private set; }

Implements

IAssemblyName..::.ProcessorArchitecture

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


PublicKeyToken Property

StandaloneAssemblyName..::..PublicKeyToken Property
StandaloneAssemblyName Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.StandaloneAssemblyName.PublicKeyToken"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public byte[] PublicKeyToken { get; }

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


Version Property

StandaloneAssemblyName..::..Version Property
StandaloneAssemblyName Class See Also Send Feedback
Gets the assembly version.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; }

Field Value

A Version.

Implements

IAssemblyName..::.Version

See Also

StandaloneAssemblyName Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureDeclaration Class

StandaloneSignatureDeclaration Class
Members See Also Send Feedback
Represents a stand-alone signature (Signature).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class StandaloneSignatureDeclaration : MetadataDeclaration

Remarks

Stand-alone signatures are owned by the module (ModuleDeclaration).

Stand-alone signatures are used solely inside method body. This information is read internally by PostSharp, so user code should not need to manipulate stand-alone signatures.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.StandaloneSignatureDeclaration

See Also

StandaloneSignatureDeclaration Members
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureDeclaration Members

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclaration Members
StandaloneSignatureDeclaration Class Constructors Methods Properties See Also Send Feedback

The StandaloneSignatureDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | StandaloneSignatureDeclaration | Initializes a new instance of the StandaloneSignatureDeclaration class

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetLocalVariables | Notify that the current StandaloneSignatureDeclaration shall contain local variables, and return the collection of local variables.
Public method | SetMethodSignature | Sets the current stand-alone signature to a method signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | SetTypeSignature | Sets the current stand-alone signature to a type signature.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | LocalVariables | Gets the collection of local variables
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodSignature | Gets the method signature.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | SignatureKind | Gets the kind of signature contained in the current instance.
Public property | TypeSignature | Gets the type signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureDeclaration Constructor

StandaloneSignatureDeclaration Constructor
StandaloneSignatureDeclaration Class See Also Send Feedback
Initializes a new instance of the StandaloneSignatureDeclaration class

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneSignatureDeclaration()

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureDeclaration Methods

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclaration Methods
StandaloneSignatureDeclaration Class See Also Send Feedback

The StandaloneSignatureDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | SetLocalVariables | Notify that the current StandaloneSignatureDeclaration shall contain local variables, and return the collection of local variables.
Public method | SetMethodSignature | Sets the current stand-alone signature to a method signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | SetTypeSignature | Sets the current stand-alone signature to a type signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

StandaloneSignatureDeclaration..::..GetTokenType Method
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetLocalVariables Method

StandaloneSignatureDeclaration..::..SetLocalVariables Method
StandaloneSignatureDeclaration Class See Also Send Feedback
Notify that the current StandaloneSignatureDeclaration shall contain local variables, and return the collection of local variables.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclarationCollection SetLocalVariables()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.StandaloneSignatureDeclaration.SetLocalVariables"]

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetMethodSignature Method

StandaloneSignatureDeclaration..::..SetMethodSignature Method
StandaloneSignatureDeclaration Class See Also Send Feedback
Sets the current stand-alone signature to a method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetMethodSignature(
    MethodSignature value
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.MethodSignature
A method signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SetTypeSignature Method

StandaloneSignatureDeclaration..::..SetTypeSignature Method
StandaloneSignatureDeclaration Class See Also Send Feedback
Sets the current stand-alone signature to a type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTypeSignature(
    ITypeSignature value,
    StandaloneSignatureKind kind
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature

[Missing <param name="value"/> documentation for "M:PostSharp.Sdk.CodeModel.StandaloneSignatureDeclaration.SetTypeSignature(PostSharp.Sdk.CodeModel.ITypeSignature,PostSharp.Sdk.CodeModel.StandaloneSignatureKind)"]

kind
Type: PostSharp.Sdk.CodeModel..::.StandaloneSignatureKind

[Missing <param name="kind"/> documentation for "M:PostSharp.Sdk.CodeModel.StandaloneSignatureDeclaration.SetTypeSignature(PostSharp.Sdk.CodeModel.ITypeSignature,PostSharp.Sdk.CodeModel.StandaloneSignatureKind)"]

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureDeclaration Properties

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclaration Properties
StandaloneSignatureDeclaration Class See Also Send Feedback

The StandaloneSignatureDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | LocalVariables | Gets the collection of local variables
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodSignature | Gets the method signature.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | SignatureKind | Gets the kind of signature contained in the current instance.
Public property | TypeSignature | Gets the type signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


LocalVariables Property

StandaloneSignatureDeclaration..::..LocalVariables Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the collection of local variables

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableDeclarationCollection LocalVariables { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance contains a different kind of signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodSignature Property

StandaloneSignatureDeclaration..::..MethodSignature Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the method signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature MethodSignature { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance contains a different kind of signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

StandaloneSignatureDeclaration..::..ParentMember Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

StandaloneSignatureDeclaration..::..ParentType Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


SignatureKind Property

StandaloneSignatureDeclaration..::..SignatureKind Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the kind of signature contained in the current instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StandaloneSignatureKind SignatureKind { get; }

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSignature Property

StandaloneSignatureDeclaration..::..TypeSignature Property
StandaloneSignatureDeclaration Class See Also Send Feedback
Gets the type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSignature TypeSignature { get; }

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance contains a different kind of signature.

See Also

StandaloneSignatureDeclaration Class
PostSharp.Sdk.CodeModel Namespace


StandaloneSignatureKind Enumeration

StandaloneSignatureKind Enumeration
See Also Send Feedback
Enumerates the kind of stand-alone signatures (StandaloneSignatureDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum StandaloneSignatureKind

Members

Member name | Value | Description
LocalVariables | 0 | Collection of local variables.
MethodSignature | 1 | Method signature.
FieldSignature | 2 | Field type signature.
PropertySignature | 3 | Property type signature.

See Also

PostSharp.Sdk.CodeModel Namespace


TagId Structure

TagId Structure
Members See Also Send Feedback
Unique identifier of a tag of the interface ITaggable.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public struct TagId

See Also

TagId Members
PostSharp.Sdk.CodeModel Namespace


TagId Members

[image]

PostSharp 2.0 Documentation
TagId Members
TagId Structure Methods See Also Send Feedback

The TagId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
 | Register | Registers a tag given a string Guid.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


TagId Methods

[image]

PostSharp 2.0 Documentation
TagId Methods
TagId Structure See Also Send Feedback

The TagId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)
 | Register | Registers a tag given a string Guid.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


Equals Method

TagId..::..Equals Method
TagId Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


GetHashCode Method

TagId..::..GetHashCode Method
TagId Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


Register Method

TagId..::..Register Method
TagId Structure See Also Send Feedback
Registers a tag given a string Guid.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TagId Register(
    string guid
)

Parameters

guid
Type: System..::.String
Tag Guid.

Return Value

The TagId corresponding to guid.

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

TagId..::..ToString Method
TagId Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

TagId Structure
PostSharp.Sdk.CodeModel Namespace


TokenType Enumeration

TokenType Enumeration
See Also Send Feedback
Specifies the type of metadata token.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum TokenType

Members

Member name | Value | Description
Module | 0 | Module definition (ModuleDeclaration).
TypeRef | 16777216 | Type reference (TypeRefDeclaration).
TypeDef | 33554432 | Type definition (TypeDefDeclaration).
FieldDef | 67108864 | Field definition (FieldDefDeclaration).
MethodDef | 100663296 | Method definition (MethodDefDeclaration).
ParamDef | 134217728 | Parameter definition (ParameterDeclaration).
InterfaceImpl | 150994944 | Interface implementation (InterfaceImplementations).
MemberRef | 167772160 | References to fields or methods (FieldRefDeclaration, MethodRefDeclaration).
CustomAttribute | 201326592 | Custom attribute (CustomAttributeDeclaration).
Permission | 234881024 | Permission set (PermissionSetDeclaration).
Signature | 285212672 | Stand-alone signature (StandaloneSignatureDeclaration).
Event | 335544320 | Event definition (EventDeclaration).
Property | 385875968 | Property definition (PropertyDeclaration).
MethodSemantic | 402653184 | Method semantic (MethodSemanticDeclaration).
MethodImpl | 419430400 | Method implementation (MethodImplementationDeclaration).
ModuleRef | 436207616 | Module reference (ModuleRefDeclaration).
TypeSpec | 452984832 | Type specification (TypeSpecDeclaration).
Assembly | 536870912 | Assembly manifest (AssemblyManifestDeclaration).
AssemblyRef | 587202560 | Assembly reference (AssemblyRefDeclaration).
File | 637534208 | External file reference (ManifestFileDeclaration).
ExportedType | 654311424 |
ManifestResource | 671088640 | Resource declaration or reference (ManifestResourceDeclaration).
GenericParam | 704643072 | Generic parameter (GenericParameterDeclaration).
GenericPar | 704643072 | Synonym for GenericParam).
MethodSpec | 721420288 | Method specification (MethodSpecDeclaration).
GenericParamConstraint | 738197504 | Constraint on a generic parameter (GenericParameterDeclaration.Constraints.
String | 1879048192 | User string (LiteralString).
WeaklyReferencedDeclaration | 771751936 | Non-linked declaration (see AddWeaklyReferencedDeclaration(MetadataDeclaration).
TableCount | 788529152 | Number of token types that are represented as a table in MetadataDeclarationTables.
None | 149946368 | None.

See Also

PostSharp.Sdk.CodeModel Namespace


TypeClassifications Enumeration

TypeClassifications Enumeration
See Also Send Feedback
Type classifications are predicate that applies on types.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum TypeClassifications

Members

Member name | Value | Description
None | 0 | No classification.
Interface | 2 | Interface.
Class | 4 | Class.
Struct | 8 | Value type (other than Enum).
Enum | 16 | Enumeration.
Module | 32 | The type representing the module.
Delegate | 64 | Delegate.
Pointer | 384 | Pointer (managed or unmanaged).
ManagedPointer | 128 | Managed pointer.
NativePointer | 256 | Native pointer.
MethodPointer | 512 | Pointer to method.
Array | 1024 | Array.
Boxed | 2048 | Boxed value type.
GenericTypeInstance | 4096 | Generic type instance.
GenericParameter | 8192 | Generic parameter.
Intrinsic | 16384 | Intrinsic.
Signature | 32640 | Any type represented by a signature (not directly a type definition or type reference).
ReferenceType | 3142 | Reference (heap) type.
ValueType | 920 | Value (stack) type.
Any | 4062 | Any type.

See Also

PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Class

TypeDefDeclaration Class
Members See Also Send Feedback
Represents a type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeDefDeclaration : NamedMetadataDeclaration,
    IGenericDefinitionDefinition, IGenericTypeDefinition, IGenericDefinition, INamedType, IType,
    INamed, ISecurable, ITypeSignature, IVisitable<ITypeSignature>,
    IEquatable<ITypeSignature>, IWriteReflectionName, ITypeContainer, IRemovable,
    IMemberRefResolutionScope, IMetadataDeclaration, IDeclaration, IElement, IModuleElement,
    ITaggable, IGeneric

Remarks

Types may be contained by other types (TypeDefDeclaration) or modules (ModuleDeclaration).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.TypeDefDeclaration

See Also

TypeDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Members

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration Members
TypeDefDeclaration Class Constructors Methods Fields Properties See Also Send Feedback

The TypeDefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | TypeDefDeclaration | Initializes a new TypeDefDeclaration.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | FindEvent | Finds an event in the current type or in its parents.
Public method | FindField | Finds a field in the current type or in its parents.
Public method | FindMethod | Finds a method in the current type or in parent types given its name and signature.
Public method | FindProperty | Overloaded.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetInterfacesRecursive | Gets the list of interfaces implemented directly or indirectly by the current type.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | IsDerivedFrom | Determines whether the current type is derived from a given type.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a type is visible outside its assembly. (Defined by VisibilityHelper.)

Fields

Name | Description
Auto | When applied to the ExplicitTypeSize or ExplicitAlignment property, specifies that the type size or alignment (packing size) is determined automatically by the runtime according to the current platform.
InstanceConstructorName | Method name for instance constructors.
TypeConstructorName | Method name for type constructors.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | BaseType | Gets or sets the base type, from which the current type derives.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Events | Gets the collection of events (EventDeclaration) defined in the current type.
Public property | ExplicitAlignment | Gets or sets the field alignment (packing size).
Public property | ExplicitTypeSize | Gets or sets the type size.
Public property | Fields | Gets the collection of fields (FieldDefDeclaration).
Public property | GenericParameters | Gets the collection of formal generic parameters of the current type.
Public property | InterfaceImplementations | Gets the collection of interfaces implemented by the current type.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsModuleSpecialType | Determines whether the current type is the special type representing the module.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Methods | Gets the collection of methods (MethodDefDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | Properties | Gets the collection of properties (PropertyDeclaration) defined in the current type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | ShortName | Gets the type name without the namespace and without the arity.
Public property | Types | Gets the collection of nested types (TypeDefDeclaration).
Public property | Visibility | Gets the type visibility.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Constructor

TypeDefDeclaration Constructor
TypeDefDeclaration Class See Also Send Feedback
Initializes a new TypeDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration()

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Fields

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration Fields
TypeDefDeclaration Class See Also Send Feedback

The TypeDefDeclaration type exposes the following members.

Fields

Name | Description
Auto | When applied to the ExplicitTypeSize or ExplicitAlignment property, specifies that the type size or alignment (packing size) is determined automatically by the runtime according to the current platform.
InstanceConstructorName | Method name for instance constructors.
TypeConstructorName | Method name for type constructors.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Auto Field

TypeDefDeclaration..::..Auto Field
TypeDefDeclaration Class See Also Send Feedback
When applied to the ExplicitTypeSize or ExplicitAlignment property, specifies that the type size or alignment (packing size) is determined automatically by the runtime according to the current platform.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int Auto

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InstanceConstructorName Field

TypeDefDeclaration..::..InstanceConstructorName Field
TypeDefDeclaration Class See Also Send Feedback
Method name for instance constructors.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string InstanceConstructorName

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeConstructorName Field

TypeDefDeclaration..::..TypeConstructorName Field
TypeDefDeclaration Class See Also Send Feedback
Method name for type constructors.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string TypeConstructorName

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Methods

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration Methods
TypeDefDeclaration Class See Also Send Feedback

The TypeDefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | FindEvent | Finds an event in the current type or in its parents.
Public method | FindField | Finds a field in the current type or in its parents.
Public method | FindMethod | Finds a method in the current type or in parent types given its name and signature.
Public method | FindProperty | Overloaded.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetInterfacesRecursive | Gets the list of interfaces implemented directly or indirectly by the current type.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | IsDerivedFrom | Determines whether the current type is derived from a given type.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Remove | Remove the current declaration from its parent.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a type is visible outside its assembly. (Defined by VisibilityHelper.)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

TypeDefDeclaration..::..BelongsToClassification Method
TypeDefDeclaration Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

TypeDefDeclaration..::..ClearCache Method
TypeDefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ContainsGenericArguments Method

TypeDefDeclaration..::..ContainsGenericArguments Method
TypeDefDeclaration Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

TypeDefDeclaration..::..Equals Method
TypeDefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindEvent Method

TypeDefDeclaration..::..FindEvent Method
TypeDefDeclaration Class See Also Send Feedback
Finds an event in the current type or in its parents.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericEventReference FindEvent(
    string eventName
)

Parameters

eventName
Type: System..::.String
Event name.

Return Value

The event named eventName, or null if the event was not found.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindField Method

TypeDefDeclaration..::..FindField Method
TypeDefDeclaration Class See Also Send Feedback
Finds a field in the current type or in its parents.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericFieldReference FindField(
    string fieldName
)

Parameters

fieldName
Type: System..::.String
Field name.

Return Value

The field named fieldName, or null if the field was not found.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindMethod Method

TypeDefDeclaration..::..FindMethod Method
TypeDefDeclaration Class See Also Send Feedback
Finds a method in the current type or in parent types given its name and signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMethodReference FindMethod(
    string methodName,
    IMethodSignature methodSignature
)

Parameters

methodName
Type: System..::.String
Method name.
methodSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Method signature.

Return Value

A GenericMethodReference referencing the method, with the GenericMap mapping the current generic context to the generic context of the method. null if the method could not be found.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FindProperty Method

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration..::..FindProperty Method
TypeDefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindProperty(String) | Finds a property in the current type or in its parents.
Public method | FindProperty(String, IList<(Of <(ITypeSignature>)>)) | Finds a property in the current type or in its parents.

See Also

TypeDefDeclaration Class
TypeDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


FindProperty Method (String)

TypeDefDeclaration..::..FindProperty Method (String)
TypeDefDeclaration Class See Also Send Feedback
Finds a property in the current type or in its parents.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericPropertyReference FindProperty(
    string propertyName
)

Parameters

propertyName
Type: System..::.String
Property name.

Return Value

The property named propertyName, or null if that property could not be found.

Remarks

Only parameterless properties are considered.

See Also

TypeDefDeclaration Class
FindProperty Overload
PostSharp.Sdk.CodeModel Namespace


FindProperty Method (String, IList(ITypeSignature))

TypeDefDeclaration..::..FindProperty Method (String, IList<(Of <(<'ITypeSignature>)>)>)
TypeDefDeclaration Class See Also Send Feedback
Finds a property in the current type or in its parents.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericPropertyReference FindProperty(
    string propertyName,
    IList<ITypeSignature> parameters
)

Parameters

propertyName
Type: System..::.String
Property name.
parameters
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
List of parameter types.

Return Value

The property named propertyName, or null if that property could not be found.

See Also

TypeDefDeclaration Class
FindProperty Overload
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

TypeDefDeclaration..::..GetCanonicalHashCode Method
TypeDefDeclaration Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

TypeDefDeclaration..::..GetGenericContext Method
TypeDefDeclaration Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

TypeDefDeclaration..::..GetGenericInstance Method
TypeDefDeclaration Class See Also Send Feedback
Gets a generic instance of this type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current generic type, using genericMap for generic arguments.

Implements

IGenericTypeDefinition..::.GetGenericInstance(GenericMap)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetInterfacesRecursive Method

TypeDefDeclaration..::..GetInterfacesRecursive Method
TypeDefDeclaration Class See Also Send Feedback
Gets the list of interfaces implemented directly or indirectly by the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<ITypeSignature> GetInterfacesRecursive()

Return Value

The of interfaces implemented directly or indirectly by the current type.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

TypeDefDeclaration..::..GetReflectionWrapper Method
TypeDefDeclaration Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

TypeDefDeclaration..::..GetSystemType Method
TypeDefDeclaration Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

TypeDefDeclaration..::..GetTokenType Method
TypeDefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetValueSize Method

TypeDefDeclaration..::..GetValueSize Method
TypeDefDeclaration Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration..::..IsAssignableTo Method
TypeDefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

TypeDefDeclaration Class
TypeDefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

TypeDefDeclaration..::..IsAssignableTo Method (ITypeSignature)
TypeDefDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeDefDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

TypeDefDeclaration..::..IsAssignableTo Method (ITypeSignature, GenericMap)
TypeDefDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature, GenericMap)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeDefDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsDerivedFrom Method

TypeDefDeclaration..::..IsDerivedFrom Method
TypeDefDeclaration Class See Also Send Feedback
Determines whether the current type is derived from a given type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDerivedFrom(
    TypeDefDeclaration baseType
)

Parameters

baseType
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
A type.

Return Value

true if the current type derives from baseType, otherwise false.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

TypeDefDeclaration..::..MapGenericArguments Method
TypeDefDeclaration Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

TypeDefDeclaration..::..MatchesReference Method
TypeDefDeclaration Class See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

Implements

ITypeSignature..::.MatchesReference(ITypeSignature)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Remove Method

TypeDefDeclaration..::..Remove Method
TypeDefDeclaration Class See Also Send Feedback
Remove the current declaration from its parent.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Remove()

Implements

IRemovable..::.Remove()()()

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

TypeDefDeclaration..::..ToString Method
TypeDefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

TypeDefDeclaration..::..Translate Method
TypeDefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

TypeDefDeclaration..::..WriteReflectionName Method
TypeDefDeclaration Class See Also Send Feedback
Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder

[Missing <param name="stringBuilder"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.WriteReflectionName(System.Text.StringBuilder,PostSharp.Sdk.CodeModel.ReflectionNameOptions)"]

options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeDefDeclaration.WriteReflectionName(System.Text.StringBuilder,PostSharp.Sdk.CodeModel.ReflectionNameOptions)"]

Return Value

The full type name (with the namespace and nesting type but without the assembly name).

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeDefDeclaration Properties

[image]

PostSharp 2.0 Documentation
TypeDefDeclaration Properties
TypeDefDeclaration Class See Also Send Feedback

The TypeDefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | BaseType | Gets or sets the base type, from which the current type derives.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Events | Gets the collection of events (EventDeclaration) defined in the current type.
Public property | ExplicitAlignment | Gets or sets the field alignment (packing size).
Public property | ExplicitTypeSize | Gets or sets the type size.
Public property | Fields | Gets the collection of fields (FieldDefDeclaration).
Public property | GenericParameters | Gets the collection of formal generic parameters of the current type.
Public property | InterfaceImplementations | Gets the collection of interfaces implemented by the current type.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsModuleSpecialType | Determines whether the current type is the special type representing the module.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | Methods | Gets the collection of methods (MethodDefDeclaration).
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | PermissionSets | Gets the collection of permission sets (PermissionSetDeclaration).
Public property | Properties | Gets the collection of properties (PropertyDeclaration) defined in the current type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | ShortName | Gets the type name without the namespace and without the arity.
Public property | Types | Gets the collection of nested types (TypeDefDeclaration).
Public property | Visibility | Gets the type visibility.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

TypeDefDeclaration..::..Attributes Property
TypeDefDeclaration Class See Also Send Feedback
Gets or sets the type attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeAttributes Attributes { get; set; }

Implements

IType..::.Attributes

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BaseType Property

TypeDefDeclaration..::..BaseType Property
TypeDefDeclaration Class See Also Send Feedback
Gets or sets the base type, from which the current type derives.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType BaseType { get; set; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

TypeDefDeclaration..::..DeclaringType Property
TypeDefDeclaration Class See Also Send Feedback
Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration DeclaringType { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Events Property

TypeDefDeclaration..::..Events Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of events (EventDeclaration) defined in the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EventDeclarationCollection Events { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExplicitAlignment Property

TypeDefDeclaration..::..ExplicitAlignment Property
TypeDefDeclaration Class See Also Send Feedback
Gets or sets the field alignment (packing size).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ExplicitAlignment { get; set; }

Field Value

Of of {1, 2, 4, 8, 16, 32, 64, 128}, or Auto to specify that the alignment shall be determined by the runtime.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ExplicitTypeSize Property

TypeDefDeclaration..::..ExplicitTypeSize Property
TypeDefDeclaration Class See Also Send Feedback
Gets or sets the type size.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ExplicitTypeSize { get; set; }

Field Value

A strictly positive integer, or Auto to specify that the size shall be computed by the runtime.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Fields Property

TypeDefDeclaration..::..Fields Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of fields (FieldDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldDefDeclarationCollection Fields { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameters Property

TypeDefDeclaration..::..GenericParameters Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of formal generic parameters of the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclarationCollection GenericParameters { get; }

Implements

IGenericDefinitionDefinition..::.GenericParameters

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


InterfaceImplementations Property

TypeDefDeclaration..::..InterfaceImplementations Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of interfaces implemented by the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceImplementationDeclarationCollection InterfaceImplementations { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

TypeDefDeclaration..::..IsAbstract Property
TypeDefDeclaration Class See Also Send Feedback
Determines whether the class is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IType..::.IsAbstract

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericDefinition Property

TypeDefDeclaration..::..IsGenericDefinition Property
TypeDefDeclaration Class See Also Send Feedback
Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericDefinition { get; }

Implements

IGeneric..::.IsGenericDefinition

Remarks

If the current property returns true, the semantics of IGenericDefinition are meaningful for the current instance.

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsInterface Property

TypeDefDeclaration..::..IsInterface Property
TypeDefDeclaration Class See Also Send Feedback
Determines whether the type is an interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsInterface { get; }

Implements

IType..::.IsInterface

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsModuleSpecialType Property

TypeDefDeclaration..::..IsModuleSpecialType Property
TypeDefDeclaration Class See Also Send Feedback
Determines whether the current type is the special type representing the module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsModuleSpecialType { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

TypeDefDeclaration..::..IsSealed Property
TypeDefDeclaration Class See Also Send Feedback
Determines whether the type is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IType..::.IsSealed

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Methods Property

TypeDefDeclaration..::..Methods Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of methods (MethodDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclarationCollection Methods { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

TypeDefDeclaration..::..ParentMember Property
TypeDefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

TypeDefDeclaration..::..ParentType Property
TypeDefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


PermissionSets Property

TypeDefDeclaration..::..PermissionSets Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of permission sets (PermissionSetDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PermissionSetDeclarationCollection PermissionSets { get; }

Implements

ISecurable..::.PermissionSets

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Properties Property

TypeDefDeclaration..::..Properties Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of properties (PropertyDeclaration) defined in the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyDeclarationCollection Properties { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ShortName Property

TypeDefDeclaration..::..ShortName Property
TypeDefDeclaration Class See Also Send Feedback
Gets the type name without the namespace and without the arity.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string ShortName { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Types Property

TypeDefDeclaration..::..Types Property
TypeDefDeclaration Class See Also Send Feedback
Gets the collection of nested types (TypeDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclarationCollection Types { get; }

Implements

ITypeContainer..::.Types

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visibility Property

TypeDefDeclaration..::..Visibility Property
TypeDefDeclaration Class See Also Send Feedback
Gets the type visibility.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Visibility Visibility { get; }

See Also

TypeDefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeNakingOptions Enumeration

TypeNakingOptions Enumeration
See Also Send Feedback
Determines the behavior of the GetNakedType(TypeNakingOptions) method.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum TypeNakingOptions

Members

Member name | Value | Description
None | 0 | No naking (unless unwrapping TypeSpecDeclaration).
IgnoreOptionalCustomModifiers | 1 | Optional custom modifiers should be removed.
IgnoreRequiredCustomModifiers | 2 | Required custom modifiers should be removed.
IgnoreAllCustomModifiers | 3 | All custom modifiers should be removed.
IgnorePinned | 4 | Pinned modifiers should be removed.
IgnoreAll | 7 | Obsolete. Obsolete.
IgnoreModifiers | 7 | All modifiers (custom modifiers and pinned modifier) should be removed.
IgnoreManagedPointers | 8 | Ignore managed pointers.

See Also

PostSharp.Sdk.CodeModel Namespace


TypeRefDeclaration Class

TypeRefDeclaration Class
Members See Also Send Feedback
Represents a type reference (TypeRef).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeRefDeclaration : NamedMetadataDeclaration,
    IMemberRefResolutionScope, ITypeRefResolutionScope, IGenericTypeDefinition, IGenericDefinition, INamedType,
    IType, ITypeSignature, IVisitable<ITypeSignature>, IGeneric,
    IEquatable<ITypeSignature>, IWriteReflectionName, IMetadataDeclaration, IDeclaration,
    IElement, IModuleElement, ITaggable, INamed, IWeakReferenceable

Remarks

Type references are owned by types implementing the ITypeRefResolutionScope interface, i.e. TypeRefDeclaration (in case of nested types), AssemblyRefDeclaration, ModuleRefDeclaration and ModuleDeclaration (although the latest case should never occur).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.NamedMetadataDeclaration
PostSharp.Sdk.CodeModel..::.TypeRefDeclaration

See Also

TypeRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


TypeRefDeclaration Members

[image]

PostSharp 2.0 Documentation
TypeRefDeclaration Members
TypeRefDeclaration Class Constructors Methods Properties See Also Send Feedback

The TypeRefDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | TypeRefDeclaration | Initializes a new TypeRefDeclaration.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetTypeDefinition | Overloaded.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Overrides Declaration..::.DeclaringAssembly.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets the scope in which the current TypeRefDeclaration should be resolved.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeClassifications | Classifications of the referred type. We use only ValueType and ReferenceType. In case of ambiguity, many conflicting bits may be set; in this case, the method BelongsToClassification(TypeClassifications) will request the type definition for classifications, which has the expensive side effect to load the referenced assembly.
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefDeclaration Constructor

TypeRefDeclaration Constructor
TypeRefDeclaration Class See Also Send Feedback
Initializes a new TypeRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclaration()

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefDeclaration Methods

[image]

PostSharp 2.0 Documentation
TypeRefDeclaration Methods
TypeRefDeclaration Class See Also Send Feedback

The TypeRefDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Overrides Element..::.ClearCache()()().)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetGenericInstance | Gets a generic instance of this type.
Public method | GetGenericParameter | Gets a generic (formal, unbound) parameter given its ordinal.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetTypeDefinition | Overloaded.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides NamedMetadataDeclaration..::.ToString()()().)
Public method | Translate |
Public method | WriteReflectionName | Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Gets the canonical generic instance of a generic type. (Defined by GenericHelper.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

TypeRefDeclaration..::..BelongsToClassification Method
TypeRefDeclaration Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ClearCache Method

TypeRefDeclaration..::..ClearCache Method
TypeRefDeclaration Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ClearCache()

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ContainsGenericArguments Method

TypeRefDeclaration..::..ContainsGenericArguments Method
TypeRefDeclaration Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

TypeRefDeclaration..::..Equals Method
TypeRefDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

TypeRefDeclaration..::..GetCanonicalHashCode Method
TypeRefDeclaration Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

TypeRefDeclaration..::..GetGenericContext Method
TypeRefDeclaration Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericInstance Method

TypeRefDeclaration..::..GetGenericInstance Method
TypeRefDeclaration Class See Also Send Feedback
Gets a generic instance of this type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IType GetGenericInstance(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic arguments.

Return Value

A generic instance of the current generic type, using genericMap for generic arguments.

Implements

IGenericTypeDefinition..::.GetGenericInstance(GenericMap)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericParameter Method

TypeRefDeclaration..::..GetGenericParameter Method
TypeRefDeclaration Class See Also Send Feedback
Gets a generic (formal, unbound) parameter given its ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IGenericParameter GetGenericParameter(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The generic parameter ordinal (position).

Return Value

A GenericParameterDeclaration, or null if the current generic parameter does not exist.

Implements

IGenericDefinition..::.GetGenericParameter(Int32)

Remarks

If the current instance is a defined in the current module (MethodDefDeclaration, TypeDefDeclaration), this method returns a GenericParameterDeclaration. Otherwise, it returns a reference to a generic parameter, i.e. a GenericParameterTypeSignature.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

TypeRefDeclaration..::..GetReflectionWrapper Method
TypeRefDeclaration Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

TypeRefDeclaration..::..GetSystemType Method
TypeRefDeclaration Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

TypeRefDeclaration..::..GetTokenType Method
TypeRefDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
TypeRefDeclaration..::..GetTypeDefinition Method
TypeRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

See Also

TypeRefDeclaration Class
TypeRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

TypeRefDeclaration..::..GetTypeDefinition Method
TypeRefDeclaration Class See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition()

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

Implements

ITypeSignature..::.GetTypeDefinition()()()

See Also

TypeRefDeclaration Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (BindingOptions)

TypeRefDeclaration..::..GetTypeDefinition Method (BindingOptions)
TypeRefDeclaration Class See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

Implements

ITypeSignature..::.GetTypeDefinition(BindingOptions)

See Also

TypeRefDeclaration Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
TypeRefDeclaration..::..IsAssignableTo Method
TypeRefDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

TypeRefDeclaration Class
TypeRefDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

TypeRefDeclaration..::..IsAssignableTo Method (ITypeSignature)
TypeRefDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeRefDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

TypeRefDeclaration..::..IsAssignableTo Method (ITypeSignature, GenericMap)
TypeRefDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature, GenericMap)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeRefDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

TypeRefDeclaration..::..MapGenericArguments Method
TypeRefDeclaration Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

TypeRefDeclaration..::..MatchesReference Method
TypeRefDeclaration Class See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

Implements

ITypeSignature..::.MatchesReference(ITypeSignature)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

TypeRefDeclaration..::..ToString Method
TypeRefDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

TypeRefDeclaration..::..Translate Method
TypeRefDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

TypeRefDeclaration..::..WriteReflectionName Method
TypeRefDeclaration Class See Also Send Feedback
Gets the full type name according the conventions of System.Reflection (with the namespace and nesting type but without the assembly name).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder

[Missing <param name="stringBuilder"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.WriteReflectionName(System.Text.StringBuilder,PostSharp.Sdk.CodeModel.ReflectionNameOptions)"]

options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeRefDeclaration.WriteReflectionName(System.Text.StringBuilder,PostSharp.Sdk.CodeModel.ReflectionNameOptions)"]

Return Value

The full type name (with the namespace and nesting type but without the assembly name).

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefDeclaration Properties

[image]

PostSharp 2.0 Documentation
TypeRefDeclaration Properties
TypeRefDeclaration Class See Also Send Feedback

The TypeRefDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Overrides Declaration..::.DeclaringAssembly.)
Public property | DeclaringType | Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | GenericParameterCount | Gets the number of (formal, unbound) generic parameters.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericDefinition | Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | IsWeaklyReferenced | Determines whether the current declaration is weakly or strongly referenced in the current module.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Name | Gets or sets the name of the current declaration. (Inherited from NamedMetadataDeclaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | ResolutionScope | Gets the scope in which the current TypeRefDeclaration should be resolved.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TypeClassifications | Classifications of the referred type. We use only ValueType and ReferenceType. In case of ambiguity, many conflicting bits may be set; in this case, the method BelongsToClassification(TypeClassifications) will request the type definition for classifications, which has the expensive side effect to load the referenced assembly.
Public property | TypeRefs | Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

TypeRefDeclaration..::..Attributes Property
TypeRefDeclaration Class See Also Send Feedback
Gets or sets the type attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeAttributes Attributes { get; }

Implements

IType..::.Attributes

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

TypeRefDeclaration..::..DeclaringAssembly Property
TypeRefDeclaration Class See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IAssembly DeclaringAssembly { get; }

Implements

IModuleElement..::.DeclaringAssembly
IModuleElement..::.DeclaringAssembly

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


DeclaringType Property

TypeRefDeclaration..::..DeclaringType Property
TypeRefDeclaration Class See Also Send Feedback
Gets the declaring type (i.e. the type in which the current type is nested), or null if the current type is not nested.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclaration DeclaringType { get; }

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefs Property

TypeRefDeclaration..::..FieldRefs Property
TypeRefDeclaration Class See Also Send Feedback
Gets the collection of fields (FieldRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldRefDeclarationCollection FieldRefs { get; }

Implements

IMemberRefResolutionScope..::.FieldRefs

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GenericParameterCount Property

TypeRefDeclaration..::..GenericParameterCount Property
TypeRefDeclaration Class See Also Send Feedback
Gets the number of (formal, unbound) generic parameters.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GenericParameterCount { get; }

Implements

IGenericDefinition..::.GenericParameterCount

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

TypeRefDeclaration..::..IsAbstract Property
TypeRefDeclaration Class See Also Send Feedback
Determines whether the class is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IType..::.IsAbstract

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericDefinition Property

TypeRefDeclaration..::..IsGenericDefinition Property
TypeRefDeclaration Class See Also Send Feedback
Determines whether the current instance is a generic definition, i.e. whether it can be used to construct generic instances.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericDefinition { get; }

Implements

IGeneric..::.IsGenericDefinition

Remarks

If the current property returns true, the semantics of IGenericDefinition are meaningful for the current instance.

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsInterface Property

TypeRefDeclaration..::..IsInterface Property
TypeRefDeclaration Class See Also Send Feedback
Determines whether the type is an interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsInterface { get; }

Implements

IType..::.IsInterface

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

TypeRefDeclaration..::..IsSealed Property
TypeRefDeclaration Class See Also Send Feedback
Determines whether the type is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IType..::.IsSealed

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsWeaklyReferenced Property

TypeRefDeclaration..::..IsWeaklyReferenced Property
TypeRefDeclaration Class See Also Send Feedback
Determines whether the current declaration is weakly or strongly referenced in the current module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsWeaklyReferenced { get; set; }

Implements

IWeakReferenceable..::.IsWeaklyReferenced

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefs Property

TypeRefDeclaration..::..MethodRefs Property
TypeRefDeclaration Class See Also Send Feedback
Gets the collection of methods (MethodRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodRefDeclarationCollection MethodRefs { get; }

Implements

IMemberRefResolutionScope..::.MethodRefs

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

TypeRefDeclaration..::..ParentMember Property
TypeRefDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

TypeRefDeclaration..::..ParentType Property
TypeRefDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ResolutionScope Property

TypeRefDeclaration..::..ResolutionScope Property
TypeRefDeclaration Class See Also Send Feedback
Gets the scope in which the current TypeRefDeclaration should be resolved.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeRefResolutionScope ResolutionScope { get; }

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeClassifications Property

TypeRefDeclaration..::..TypeClassifications Property
TypeRefDeclaration Class See Also Send Feedback
Classifications of the referred type. We use only ValueType and ReferenceType. In case of ambiguity, many conflicting bits may be set; in this case, the method BelongsToClassification(TypeClassifications) will request the type definition for classifications, which has the expensive side effect to load the referenced assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeClassifications TypeClassifications { get; set; }

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeRefs Property

TypeRefDeclaration..::..TypeRefs Property
TypeRefDeclaration Class See Also Send Feedback
Gets the collection of type references (TypeRefDeclaration) whose resolution scope is the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeRefDeclarationCollection TypeRefs { get; }

Implements

ITypeRefResolutionScope..::.TypeRefs

See Also

TypeRefDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSignature Class

TypeSignature Class
Members See Also Send Feedback
Represents a type construction (pointer, array, generic type instance, intrinsic, ...).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class TypeSignature : ITypeSignature,
    IModuleElement, IVisitable<ITypeSignature>, IGeneric, IEquatable<ITypeSignature>,
    IWriteReflectionName

Remarks

A type signature is composed of chains of type signature elements. Elements are instances of types of the PostSharp.Sdk.CodeModel.TypeSignatures namespace. All element types are derived from TypeSignature. The ElementType property gives the next element of the chain.

For instance, the type signature int * pinned is a chain formed by PinnedTypeSignature , PointerTypeSignature and IntrinsicTypeSignature. This type signature would be instantiated by the following code:

CopyC#
TypeSignature sig = TypeSignature.MakeIntrinsic(PrimitiveType.Int32).MakePointer(true).MakePinned();

The TypeSignature type defines the common functionalities of all type signature elements.

Instances of all types derived from TypeSignature are immutable.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.BoxedTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.CustomModifierTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.GenericParameterTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.GenericTypeInstanceTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.IntrinsicTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.MethodPointerTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.PinnedTypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.PointerTypeSignature

See Also

TypeSignature Members
PostSharp.Sdk.CodeModel Namespace


TypeSignature Members

[image]

PostSharp 2.0 Documentation
TypeSignature Members
TypeSignature Class Methods Properties See Also Send Feedback

The TypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Protected method | InternalGetTypeDefinition |
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | AssemblyQualifiedName |
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.
Public property | Module | Gets the declaring module.
Public property | Name |

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


TypeSignature Methods

[image]

PostSharp 2.0 Documentation
TypeSignature Methods
TypeSignature Class See Also Send Feedback

The TypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Protected method | InternalGetTypeDefinition |
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | Translate |
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

TypeSignature..::..BelongsToClassification Method
TypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


ContainsGenericArguments Method

TypeSignature..::..ContainsGenericArguments Method
TypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

TypeSignature..::..Equals Method
TypeSignature Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

TypeSignature..::..GetCanonicalHashCode Method
TypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

TypeSignature..::..GetGenericContext Method
TypeSignature Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

TypeSignature..::..GetReflectionWrapper Method
TypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

TypeSignature..::..GetSystemType Method
TypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
TypeSignature..::..GetTypeDefinition Method
TypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

See Also

TypeSignature Class
TypeSignature Members
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

TypeSignature..::..GetTypeDefinition Method
TypeSignature Class See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition()

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

Implements

ITypeSignature..::.GetTypeDefinition()()()

See Also

TypeSignature Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (BindingOptions)

TypeSignature..::..GetTypeDefinition Method (BindingOptions)
TypeSignature Class See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

Implements

ITypeSignature..::.GetTypeDefinition(BindingOptions)

See Also

TypeSignature Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetValueSize Method

TypeSignature..::..GetValueSize Method
TypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


InternalGetTypeDefinition Method

TypeSignature..::..InternalGetTypeDefinition Method
TypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.InternalGetTypeDefinition(PostSharp.Sdk.CodeModel.BindingOptions)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual TypeDefDeclaration InternalGetTypeDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions

[Missing <param name="bindingOptions"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.InternalGetTypeDefinition(PostSharp.Sdk.CodeModel.BindingOptions)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.InternalGetTypeDefinition(PostSharp.Sdk.CodeModel.BindingOptions)"]

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
TypeSignature..::..IsAssignableTo Method
TypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

TypeSignature Class
TypeSignature Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

TypeSignature..::..IsAssignableTo Method (ITypeSignature)
TypeSignature Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeSignature Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

TypeSignature..::..IsAssignableTo Method (ITypeSignature, GenericMap)
TypeSignature Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature, GenericMap)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeSignature Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

TypeSignature..::..MapGenericArguments Method
TypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

TypeSignature..::..MatchesReference Method
TypeSignature Class See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

Implements

ITypeSignature..::.MatchesReference(ITypeSignature)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

TypeSignature..::..Translate Method
TypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


Visit Method

TypeSignature..::..Visit Method
TypeSignature Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

TypeSignature..::..WriteReflectionName Method
TypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


TypeSignature Properties

[image]

PostSharp 2.0 Documentation
TypeSignature Properties
TypeSignature Class See Also Send Feedback

The TypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName |
Public property | DeclaringAssembly | Gets the declaring assembly.
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.
Public property | Module | Gets the declaring module.
Public property | Name |

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


AssemblyQualifiedName Property

TypeSignature..::..AssemblyQualifiedName Property
TypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.TypeSignature.AssemblyQualifiedName"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string AssemblyQualifiedName { get; }

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


DeclaringAssembly Property

TypeSignature..::..DeclaringAssembly Property
TypeSignature Class See Also Send Feedback
Gets the declaring assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual IAssembly DeclaringAssembly { get; }

Implements

IModuleElement..::.DeclaringAssembly

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


ElementType Property

TypeSignature..::..ElementType Property
TypeSignature Class See Also Send Feedback
Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ITypeSignature ElementType { get; }

Remarks

A TypeSignature, or null if there is no textWriter type.

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


IsGenericInstance Property

TypeSignature..::..IsGenericInstance Property
TypeSignature Class See Also Send Feedback
Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool IsGenericInstance { get; }

Implements

IGeneric..::.IsGenericInstance

Remarks

If the current property returns true, the semantics of IGenericInstance are meaningful for the current instance.

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


Module Property

TypeSignature..::..Module Property
TypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


Name Property

TypeSignature..::..Name Property
TypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.CodeModel.TypeSignature.Name"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual string Name { get; }

See Also

TypeSignature Class
PostSharp.Sdk.CodeModel Namespace


TypeSignatureCollection Class

TypeSignatureCollection Class
Members See Also Send Feedback
Collection of types (IType).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeSignatureCollection : NonNullableList<ITypeSignature>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.NonNullableList <(Of <(<' ITypeSignature >)>)>
PostSharp.Sdk.CodeModel..::.TypeSignatureCollection

See Also

TypeSignatureCollection Members
PostSharp.Sdk.CodeModel Namespace


TypeSignatureCollection Members

[image]

PostSharp 2.0 Documentation
TypeSignatureCollection Members
TypeSignatureCollection Class Methods Properties See Also Send Feedback

The TypeSignatureCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | AddRange | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Insert | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from NonNullableList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the capacity of the current list. (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | Item | (Inherited from NonNullableList<(Of <(?0>)>).)

See Also

TypeSignatureCollection Class
PostSharp.Sdk.CodeModel Namespace


TypeSignatureCollection Methods

[image]

PostSharp 2.0 Documentation
TypeSignatureCollection Methods
TypeSignatureCollection Class See Also Send Feedback

The TypeSignatureCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | AddRange | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Insert | (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from NonNullableList<(Of <(?0>)>).)

See Also

TypeSignatureCollection Class
PostSharp.Sdk.CodeModel Namespace


AddRange Method

[image]

PostSharp 2.0 Documentation
TypeSignatureCollection..::..AddRange Method
TypeSignatureCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(ICollection<(Of <(?0>)>)) | Adds a collection of items in the list. (Inherited from NonNullableList<(Of <(?0>)>).)
Public method | AddRange(IEnumerable<(Of <(?0>)>)) | Adds a set of items to the current collection. (Inherited from NonNullableList<(Of <(?0>)>).)

See Also

TypeSignatureCollection Class
TypeSignatureCollection Members
PostSharp.Sdk.CodeModel Namespace


TypeSignatureCollection Properties

[image]

PostSharp 2.0 Documentation
TypeSignatureCollection Properties
TypeSignatureCollection Class See Also Send Feedback

The TypeSignatureCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the capacity of the current list. (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from NonNullableList<(Of <(?0>)>).)
Public property | Item | (Inherited from NonNullableList<(Of <(?0>)>).)

See Also

TypeSignatureCollection Class
PostSharp.Sdk.CodeModel Namespace


TypeSignatureExtensions Class

TypeSignatureExtensions Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PostSharp.Sdk.CodeModel.TypeSignatureExtensions"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class TypeSignatureExtensions

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignatureExtensions

See Also

TypeSignatureExtensions Members
PostSharp.Sdk.CodeModel Namespace


TypeSignatureExtensions Members

[image]

PostSharp 2.0 Documentation
TypeSignatureExtensions Members
TypeSignatureExtensions Class Methods See Also Send Feedback

The TypeSignatureExtensions type exposes the following members.

Methods

Name | Description
GetNakedType | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.)
IsAssignableFromRuntimeValue | Determines whether a given type signature can be assigned a given runtime value.
IsNullable | Determines whether a given type signature can be assigned a null value.

See Also

TypeSignatureExtensions Class
PostSharp.Sdk.CodeModel Namespace


TypeSignatureExtensions Methods

[image]

PostSharp 2.0 Documentation
TypeSignatureExtensions Methods
TypeSignatureExtensions Class See Also Send Feedback

The TypeSignatureExtensions type exposes the following members.

Methods

Name | Description
GetNakedType | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.)
IsAssignableFromRuntimeValue | Determines whether a given type signature can be assigned a given runtime value.
IsNullable | Determines whether a given type signature can be assigned a null value.

See Also

TypeSignatureExtensions Class
PostSharp.Sdk.CodeModel Namespace


GetNakedType Method

TypeSignatureExtensions..::..GetNakedType Method
TypeSignatureExtensions Class See Also Send Feedback
Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.)

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ITypeSignature GetNakedType(
    this ITypeSignature typeSignature
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type signature

Return Value

A 'naked' IType corresponding to typeSignature.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITypeSignature. When you use instance method syntax to call this method, omit the first parameter.

Remarks

This method only removes the modifiers on the current object, all of the nodes of a type signature. However, the object returned by this method (i.e. the head of the chain) is guaranteed to be free from modifiers.

See Also

TypeSignatureExtensions Class
PostSharp.Sdk.CodeModel Namespace


IsAssignableFromRuntimeValue Method

TypeSignatureExtensions..::..IsAssignableFromRuntimeValue Method
TypeSignatureExtensions Class See Also Send Feedback
Determines whether a given type signature can be assigned a given runtime value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsAssignableFromRuntimeValue(
    this ITypeSignature typeSignature,
    Object value
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type signature.
value
Type: System..::.Object
A runtime value.

Return Value

true if value can be assigned to a location of type typeSignature, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITypeSignature. When you use instance method syntax to call this method, omit the first parameter.

See Also

TypeSignatureExtensions Class
PostSharp.Sdk.CodeModel Namespace


IsNullable Method

TypeSignatureExtensions..::..IsNullable Method
TypeSignatureExtensions Class See Also Send Feedback
Determines whether a given type signature can be assigned a null value.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsNullable(
    this ITypeSignature typeSignature
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type signature.

Return Value

true if a location of type typeSignature can be assigned a null value, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITypeSignature. When you use instance method syntax to call this method, omit the first parameter.

See Also

TypeSignatureExtensions Class
PostSharp.Sdk.CodeModel Namespace


TypeSpecDeclaration Class

TypeSpecDeclaration Class
Members See Also Send Feedback
Represents a type specification (TypeSpec).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeSpecDeclaration : MetadataDeclaration,
    IType, IMemberRefResolutionScope, IMetadataDeclaration, IDeclaration, IElement,
    ITaggable, ITypeSignature, IModuleElement, IVisitable<ITypeSignature>,
    IEquatable<ITypeSignature>, IWriteReflectionName, IGenericInstance, IGeneric

Remarks

Type specifications are owned by ModuleDeclaration.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel..::.MetadataDeclaration
PostSharp.Sdk.CodeModel..::.TypeSpecDeclaration

See Also

TypeSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


TypeSpecDeclaration Members

[image]

PostSharp 2.0 Documentation
TypeSpecDeclaration Members
TypeSpecDeclaration Class Constructors Methods Properties See Also Send Feedback

The TypeSpecDeclaration type exposes the following members.

Constructors

 | Name | Description
Public method | TypeSpecDeclaration | Initializes a new TypeSpecDeclaration.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericArgument | Gets a generic (concrete, bound) argument given its ordinal.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSiblings | Gets all instances of TypeSpecDeclaration that have the same signature.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
 | Unwrap | Conditionally unwraps the ITypeSignature contained in a TypeSpecDeclaration.
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Signature | Gets or sets the type signature specifying the current type specification.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSpecDeclaration Constructor

TypeSpecDeclaration Constructor
TypeSpecDeclaration Class See Also Send Feedback
Initializes a new TypeSpecDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSpecDeclaration()

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSpecDeclaration Methods

[image]

PostSharp 2.0 Documentation
TypeSpecDeclaration Methods
TypeSpecDeclaration Class See Also Send Feedback

The TypeSpecDeclaration type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MetadataDeclaration.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).
Public method | GetGenericArgument | Gets a generic (concrete, bound) argument given its ordinal.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type.
Public method | GetSiblings | Gets all instances of TypeSpecDeclaration that have the same signature.
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type.
Public method | GetTag | Gets a tag associated with the current declaration. (Inherited from MetadataDeclaration.)
Public method | GetTokenType | Gets the TokenType of the derived declaration. (Overrides MetadataDeclaration..::.GetTokenType()()().)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type.
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature.
Public method | SetTag | Set a tag to the current declaration. (Inherited from MetadataDeclaration.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate |
 | Unwrap | Conditionally unwraps the ITypeSignature contained in a TypeSpecDeclaration.
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


BelongsToClassification Method

TypeSpecDeclaration..::..BelongsToClassification Method
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ContainsGenericArguments Method

TypeSpecDeclaration..::..ContainsGenericArguments Method
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Equals Method

TypeSpecDeclaration..::..Equals Method
TypeSpecDeclaration Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetCanonicalHashCode Method

TypeSpecDeclaration..::..GetCanonicalHashCode Method
TypeSpecDeclaration Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericArgument Method

TypeSpecDeclaration..::..GetGenericArgument Method
TypeSpecDeclaration Class See Also Send Feedback
Gets a generic (concrete, bound) argument given its ordinal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature GetGenericArgument(
    int ordinal
)

Parameters

ordinal
Type: System..::.Int32
The generic argument ordinal (position).

Return Value

An IType, or null if the current generic original does not exist.

Implements

IGenericInstance..::.GetGenericArgument(Int32)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetGenericContext Method

TypeSpecDeclaration..::..GetGenericContext Method
TypeSpecDeclaration Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionWrapper Method

TypeSpecDeclaration..::..GetReflectionWrapper Method
TypeSpecDeclaration Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSiblings Method

TypeSpecDeclaration..::..GetSiblings Method
TypeSpecDeclaration Class See Also Send Feedback
Gets all instances of TypeSpecDeclaration that have the same signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerable<TypeSpecDeclaration> GetSiblings()

Return Value

The set of all instances of TypeSpecDeclaration that have the same signature.

Remarks

Compilers are supposed to generate a unique TypeSpecDeclaration for each signature. However, this rule is not always respected.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetSystemType Method

TypeSpecDeclaration..::..GetSystemType Method
TypeSpecDeclaration Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTokenType Method

TypeSpecDeclaration..::..GetTokenType Method
TypeSpecDeclaration Class See Also Send Feedback
Gets the TokenType of the derived declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override TokenType GetTokenType()

Return Value

A TokenType.

Implements

IMetadataDeclaration..::.GetTokenType()()()
IMetadataDeclaration..::.GetTokenType()()()

Remarks

This allows to determines to which metadata table the declaration belongs.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
TypeSpecDeclaration..::..GetTypeDefinition Method
TypeSpecDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() |
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

See Also

TypeSpecDeclaration Class
TypeSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method

TypeSpecDeclaration..::..GetTypeDefinition Method
TypeSpecDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.GetTypeDefinition"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.GetTypeDefinition"]

See Also

TypeSpecDeclaration Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetTypeDefinition Method (BindingOptions)

TypeSpecDeclaration..::..GetTypeDefinition Method (BindingOptions)
TypeSpecDeclaration Class See Also Send Feedback
Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeDefDeclaration GetTypeDefinition(
    BindingOptions bindingOptions
)

Parameters

bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Binding options.

Return Value

The TypeDefDeclaration corresponding to the current instance in the current domain.

Implements

ITypeSignature..::.GetTypeDefinition(BindingOptions)

See Also

TypeSpecDeclaration Class
GetTypeDefinition Overload
PostSharp.Sdk.CodeModel Namespace


GetValueSize Method

TypeSpecDeclaration..::..GetValueSize Method
TypeSpecDeclaration Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
TypeSpecDeclaration..::..IsAssignableTo Method
TypeSpecDeclaration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

See Also

TypeSpecDeclaration Class
TypeSpecDeclaration Members
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature)

TypeSpecDeclaration..::..IsAssignableTo Method (ITypeSignature)
TypeSpecDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeSpecDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


IsAssignableTo Method (ITypeSignature, GenericMap)

TypeSpecDeclaration..::..IsAssignableTo Method (ITypeSignature, GenericMap)
TypeSpecDeclaration Class See Also Send Feedback
Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAssignableTo(
    ITypeSignature type,
    GenericMap genericMap
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type that the current type may derive or inherit.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Map that has to be applied on generic arguments of type before the comparison is performed. It is generally wrong to pass an empty generic map (like Empty). The identical generic map should be passed instead.

Return Value

true if the current type can be assigned to (i.e., derives or implements) type, otherwise false.

Implements

ITypeSignature..::.IsAssignableTo(ITypeSignature, GenericMap)

Remarks

There are some exceptions to the rule that a type can be assigned to another if it derives or implements it. For instance, an Int32 is assignable to an UInt32.

See Also

TypeSpecDeclaration Class
IsAssignableTo Overload
PostSharp.Sdk.CodeModel Namespace


MapGenericArguments Method

TypeSpecDeclaration..::..MapGenericArguments Method
TypeSpecDeclaration Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MatchesReference Method

TypeSpecDeclaration..::..MatchesReference Method
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the current type signature matches a given type signature.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MatchesReference(
    ITypeSignature reference
)

Parameters

reference
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type reference.

Return Value

true if the current type signature matches reference, otherwise false.

Implements

ITypeSignature..::.MatchesReference(ITypeSignature)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ToString Method

TypeSpecDeclaration..::..ToString Method
TypeSpecDeclaration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Translate Method

TypeSpecDeclaration..::..Translate Method
TypeSpecDeclaration Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSpecDeclaration.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Unwrap Method

TypeSpecDeclaration..::..Unwrap Method
TypeSpecDeclaration Class See Also Send Feedback
Conditionally unwraps the ITypeSignature contained in a TypeSpecDeclaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ITypeSignature Unwrap(
    ITypeSignature signature
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A signature (eventually a TypeSpecDeclaration).

Return Value

If signature is a TypeSpecDeclaration, the current method returns the signature contained in the TypeSpecDeclaration. Otherwise, signature is returned.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Visit Method

TypeSpecDeclaration..::..Visit Method
TypeSpecDeclaration Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionName Method

TypeSpecDeclaration..::..WriteReflectionName Method
TypeSpecDeclaration Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


TypeSpecDeclaration Properties

[image]

PostSharp 2.0 Documentation
TypeSpecDeclaration Properties
TypeSpecDeclaration Class See Also Send Feedback

The TypeSpecDeclaration type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the type attributes.
Public property | CustomAttributes | Gets the collection of custom attributes. (Inherited from MetadataDeclaration.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | FieldRefs | Gets the collection of fields (FieldRefDeclaration) defined on the current object.
Public property | IsAbstract | Determines whether the class is abstract.
Public property | IsDisposed | Determines whether the current instance is disposed. (Inherited from MetadataDeclaration.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.
Public property | IsInterface | Determines whether the type is an interface.
Public property | IsSealed | Determines whether the type is sealed.
Public property | MetadataToken | Gets or sets the token of the current declaration. (Inherited from MetadataDeclaration.)
Public property | MethodRefs | Gets the collection of methods (MethodRefDeclaration) defined on the current object.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentMember | Gets the parent member of the current declaration. (Overrides MetadataDeclaration..::.ParentMember.)
Public property | ParentType | Gets the parent type of the current declaration. (Overrides MetadataDeclaration..::.ParentType.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Signature | Gets or sets the type signature specifying the current type specification.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Attributes Property

TypeSpecDeclaration..::..Attributes Property
TypeSpecDeclaration Class See Also Send Feedback
Gets or sets the type attributes.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeAttributes Attributes { get; }

Implements

IType..::.Attributes

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


FieldRefs Property

TypeSpecDeclaration..::..FieldRefs Property
TypeSpecDeclaration Class See Also Send Feedback
Gets the collection of fields (FieldRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldRefDeclarationCollection FieldRefs { get; }

Implements

IMemberRefResolutionScope..::.FieldRefs

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsAbstract Property

TypeSpecDeclaration..::..IsAbstract Property
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the class is abstract.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsAbstract { get; }

Implements

IType..::.IsAbstract

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsGenericInstance Property

TypeSpecDeclaration..::..IsGenericInstance Property
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsGenericInstance { get; }

Implements

IGeneric..::.IsGenericInstance

Remarks

If the current property returns true, the semantics of IGenericInstance are meaningful for the current instance.

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsInterface Property

TypeSpecDeclaration..::..IsInterface Property
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the type is an interface.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsInterface { get; }

Implements

IType..::.IsInterface

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


IsSealed Property

TypeSpecDeclaration..::..IsSealed Property
TypeSpecDeclaration Class See Also Send Feedback
Determines whether the type is sealed.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsSealed { get; }

Implements

IType..::.IsSealed

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


MethodRefs Property

TypeSpecDeclaration..::..MethodRefs Property
TypeSpecDeclaration Class See Also Send Feedback
Gets the collection of methods (MethodRefDeclaration) defined on the current object.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodRefDeclarationCollection MethodRefs { get; }

Implements

IMemberRefResolutionScope..::.MethodRefs

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentMember Property

TypeSpecDeclaration..::..ParentMember Property
TypeSpecDeclaration Class See Also Send Feedback
Gets the parent member of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IMember ParentMember { get; }

Field Value

The parent member if the current declaration is a parameter, the current member if the current declaration is a member, otherwise null.

Implements

IMetadataDeclaration..::.ParentMember
IMetadataDeclaration..::.ParentMember

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


ParentType Property

TypeSpecDeclaration..::..ParentType Property
TypeSpecDeclaration Class See Also Send Feedback
Gets the parent type of the current declaration.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override IType ParentType { get; }

Field Value

The declaring type if the current declaration is a member or a parameter, the current type if the current declaration is a type, otherwise null.

Implements

IMetadataDeclaration..::.ParentType
IMetadataDeclaration..::.ParentType

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


Signature Property

TypeSpecDeclaration..::..Signature Property
TypeSpecDeclaration Class See Also Send Feedback
Gets or sets the type signature specifying the current type specification.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Signature { get; set; }

See Also

TypeSpecDeclaration Class
PostSharp.Sdk.CodeModel Namespace


UncompressedOpCode Structure

UncompressedOpCode Structure
Members See Also Send Feedback
Uncompressed opcode (i.e. an opcode with its operand).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct UncompressedOpCode : IEquatable<UncompressedOpCode>

See Also

UncompressedOpCode Members
PostSharp.Sdk.CodeModel Namespace


UncompressedOpCode Members

[image]

PostSharp 2.0 Documentation
UncompressedOpCode Members
UncompressedOpCode Structure Methods Operators Properties See Also Send Feedback

The UncompressedOpCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Determines whether two UncompressedOpCode are equal.
Inequality | Determines whether two UncompressedOpCode are different.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current UncompressedOpCode is null.
Public property | OpCodeNumber | Gets the uncompressed OpCodeNumber.
Public property | Operand | Gets the uncompressed operand.
Public property | OperandType | Gets the OperandType of OpCodeNumber.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


UncompressedOpCode Methods

[image]

PostSharp 2.0 Documentation
UncompressedOpCode Methods
UncompressedOpCode Structure See Also Send Feedback

The UncompressedOpCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
UncompressedOpCode..::..Equals Method
UncompressedOpCode Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(UncompressedOpCode) | Indicates whether the current object is equal to another object of the same type.

See Also

UncompressedOpCode Structure
UncompressedOpCode Members
PostSharp.Sdk.CodeModel Namespace


Equals Method (Object)

UncompressedOpCode..::..Equals Method (Object)
UncompressedOpCode Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

UncompressedOpCode Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


Equals Method (UncompressedOpCode)

UncompressedOpCode..::..Equals Method (UncompressedOpCode)
UncompressedOpCode Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    UncompressedOpCode other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel..::.UncompressedOpCode
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

UncompressedOpCode Structure
Equals Overload
PostSharp.Sdk.CodeModel Namespace


GetHashCode Method

UncompressedOpCode..::..GetHashCode Method
UncompressedOpCode Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


UncompressedOpCode Operators

[image]

PostSharp 2.0 Documentation
UncompressedOpCode Operators
UncompressedOpCode Structure See Also Send Feedback

The UncompressedOpCode type exposes the following members.

Operators

Name | Description
Equality | Determines whether two UncompressedOpCode are equal.
Inequality | Determines whether two UncompressedOpCode are different.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


Equality Operator

UncompressedOpCode..::..Equality Operator
UncompressedOpCode Structure See Also Send Feedback
Determines whether two UncompressedOpCode are equal.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    UncompressedOpCode left,
    UncompressedOpCode right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.UncompressedOpCode
An UncompressedOpCode.
right
Type: PostSharp.Sdk.CodeModel..::.UncompressedOpCode
Another UncompressedOpCode.

Return Value

true if both UncompressedOpCode are equal, otherwise false.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


Inequality Operator

UncompressedOpCode..::..Inequality Operator
UncompressedOpCode Structure See Also Send Feedback
Determines whether two UncompressedOpCode are different.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    UncompressedOpCode left,
    UncompressedOpCode right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel..::.UncompressedOpCode
An UncompressedOpCode.
right
Type: PostSharp.Sdk.CodeModel..::.UncompressedOpCode
Another UncompressedOpCode.

Return Value

true if both UncompressedOpCode are different, otherwise false.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


UncompressedOpCode Properties

[image]

PostSharp 2.0 Documentation
UncompressedOpCode Properties
UncompressedOpCode Structure See Also Send Feedback

The UncompressedOpCode type exposes the following members.

Properties

 | Name | Description
Public property | IsNull | Determines whether the current UncompressedOpCode is null.
Public property | OpCodeNumber | Gets the uncompressed OpCodeNumber.
Public property | Operand | Gets the uncompressed operand.
Public property | OperandType | Gets the OperandType of OpCodeNumber.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


IsNull Property

UncompressedOpCode..::..IsNull Property
UncompressedOpCode Structure See Also Send Feedback
Determines whether the current UncompressedOpCode is null.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsNull { get; }

Remarks

A null UncompressedOpCode means that the original opcode was not compressed.

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


OpCodeNumber Property

UncompressedOpCode..::..OpCodeNumber Property
UncompressedOpCode Structure See Also Send Feedback
Gets the uncompressed OpCodeNumber.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OpCodeNumber OpCodeNumber { get; }

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


Operand Property

UncompressedOpCode..::..Operand Property
UncompressedOpCode Structure See Also Send Feedback
Gets the uncompressed operand.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Operand { get; }

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


OperandType Property

UncompressedOpCode..::..OperandType Property
UncompressedOpCode Structure See Also Send Feedback
Gets the OperandType of OpCodeNumber.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public OperandType OperandType { get; }

See Also

UncompressedOpCode Structure
PostSharp.Sdk.CodeModel Namespace


UnmanagedResource Class

UnmanagedResource Class
Members See Also Send Feedback
Abstract class representing an unmanaged (Windows) resource. The only current implementation is RawUnmanagedResource, but later versions may provide implementations for specific types of resources.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class UnmanagedResource

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.UnmanagedResource
PostSharp.Sdk.CodeModel..::.RawUnmanagedResource

See Also

UnmanagedResource Members
PostSharp.Sdk.CodeModel Namespace


UnmanagedResource Members

[image]

PostSharp 2.0 Documentation
UnmanagedResource Members
UnmanagedResource Class Properties See Also Send Feedback

The UnmanagedResource type exposes the following members.

Properties

 | Name | Description
Public property | Characteristics | Gets or sets the characteristics (attributes) of the resource.
Public property | CodePage | Gets or sets the code page identifier of the current resource.
Public property | Language | Gets or sets the language identifier of the current resource.
Public property | Name | Gets the name of the current resource.
Public property | TypeId | Gets the well-known type of the current resource, or None if the type is not well-known, in which case its name is given by the TypeName property.
Public property | TypeName | Gets the name of the type of the current resource, in case that the TypeId property is None/.
Public property | Version | Gets or sets the version of the current resource.

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


UnmanagedResource Properties

[image]

PostSharp 2.0 Documentation
UnmanagedResource Properties
UnmanagedResource Class See Also Send Feedback

The UnmanagedResource type exposes the following members.

Properties

 | Name | Description
Public property | Characteristics | Gets or sets the characteristics (attributes) of the resource.
Public property | CodePage | Gets or sets the code page identifier of the current resource.
Public property | Language | Gets or sets the language identifier of the current resource.
Public property | Name | Gets the name of the current resource.
Public property | TypeId | Gets the well-known type of the current resource, or None if the type is not well-known, in which case its name is given by the TypeName property.
Public property | TypeName | Gets the name of the type of the current resource, in case that the TypeId property is None/.
Public property | Version | Gets or sets the version of the current resource.

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


Characteristics Property

UnmanagedResource..::..Characteristics Property
UnmanagedResource Class See Also Send Feedback
Gets or sets the characteristics (attributes) of the resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Characteristics { get; set; }

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


CodePage Property

UnmanagedResource..::..CodePage Property
UnmanagedResource Class See Also Send Feedback
Gets or sets the code page identifier of the current resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int CodePage { get; set; }

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


Language Property

UnmanagedResource..::..Language Property
UnmanagedResource Class See Also Send Feedback
Gets or sets the language identifier of the current resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Language { get; set; }

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


Name Property

UnmanagedResource..::..Name Property
UnmanagedResource Class See Also Send Feedback
Gets the name of the current resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceName Name { get; }

Remarks

The combination of Name, type and Language should be unique.

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


TypeId Property

UnmanagedResource..::..TypeId Property
UnmanagedResource Class See Also Send Feedback
Gets the well-known type of the current resource, or None if the type is not well-known, in which case its name is given by the TypeName property.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceType TypeId { get; }

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


TypeName Property

UnmanagedResource..::..TypeName Property
UnmanagedResource Class See Also Send Feedback
Gets the name of the type of the current resource, in case that the TypeId property is None/.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TypeName { get; }

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


Version Property

UnmanagedResource..::..Version Property
UnmanagedResource Class See Also Send Feedback
Gets or sets the version of the current resource.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Version Version { get; set; }

Remarks

Note that only the Major and Minor parts of the version are relevant, and they should be coded on a Int16, not an Int32.

See Also

UnmanagedResource Class
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Structure

UnmanagedResourceName Structure
Members See Also Send Feedback
Represents the name or the type of an UnmanagedResource, which can consist either in a string, either in an integer.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct UnmanagedResourceName

See Also

UnmanagedResourceName Members
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Members

[image]

PostSharp 2.0 Documentation
UnmanagedResourceName Members
UnmanagedResourceName Structure Constructors Methods Properties See Also Send Feedback

The UnmanagedResourceName type exposes the following members.

Constructors

 | Name | Description
Public method | UnmanagedResourceName | Overloaded.

Methods

 | Name | Description
Public method | ToObject | Converts the current object to a boxed Int32 or to a String.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

Properties

 | Name | Description
Public property | Id | Gets the integer identifier representing the current UnmanagedResourceName, or 0 if the current object has a name (Name).
Public property | IsId | Determines whether the current UnmanagedResourceName is an identifier (Int32).
Public property | IsName | Determines whether the current UnmanagedResourceName is a name (String).
Public property | Name | Gets the string representing the current UnmanagedResourceName, or null if the current object has an identifier (Id).

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Constructor

[image]

PostSharp 2.0 Documentation
UnmanagedResourceName Constructor
UnmanagedResourceName Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | UnmanagedResourceName(Int32) | Initializes a new UnmanagedResourceName with an integer.
Public method | UnmanagedResourceName(Object) | Initializes a new UnmanagedResourceName with an integer or a string.
Public method | UnmanagedResourceName(String) | Initializes a new UnmanagedResourceName with a string.

See Also

UnmanagedResourceName Structure
UnmanagedResourceName Members
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Constructor (Int32)

UnmanagedResourceName Constructor (Int32)
UnmanagedResourceName Structure See Also Send Feedback
Initializes a new UnmanagedResourceName with an integer.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceName(
    int id
)

Parameters

id
Type: System..::.Int32
Integer identifier.

See Also

UnmanagedResourceName Structure
UnmanagedResourceName Overload
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Constructor (Object)

UnmanagedResourceName Constructor (Object)
UnmanagedResourceName Structure See Also Send Feedback
Initializes a new UnmanagedResourceName with an integer or a string.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceName(
    Object idOrName
)

Parameters

idOrName
Type: System..::.Object
An Int32 or a String.

See Also

UnmanagedResourceName Structure
UnmanagedResourceName Overload
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Constructor (String)

UnmanagedResourceName Constructor (String)
UnmanagedResourceName Structure See Also Send Feedback
Initializes a new UnmanagedResourceName with a string.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceName(
    string name
)

Parameters

name
Type: System..::.String
String representation of the name.

See Also

UnmanagedResourceName Structure
UnmanagedResourceName Overload
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Methods

[image]

PostSharp 2.0 Documentation
UnmanagedResourceName Methods
UnmanagedResourceName Structure See Also Send Feedback

The UnmanagedResourceName type exposes the following members.

Methods

 | Name | Description
Public method | ToObject | Converts the current object to a boxed Int32 or to a String.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueType..::.ToString()()().)

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


ToObject Method

UnmanagedResourceName..::..ToObject Method
UnmanagedResourceName Structure See Also Send Feedback
Converts the current object to a boxed Int32 or to a String.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object ToObject()

Return Value

A boxed Int32 or a String.

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


ToString Method

UnmanagedResourceName..::..ToString Method
UnmanagedResourceName Structure See Also Send Feedback
Returns the fully qualified type name of this instance.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String containing a fully qualified type name.

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceName Properties

[image]

PostSharp 2.0 Documentation
UnmanagedResourceName Properties
UnmanagedResourceName Structure See Also Send Feedback

The UnmanagedResourceName type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the integer identifier representing the current UnmanagedResourceName, or 0 if the current object has a name (Name).
Public property | IsId | Determines whether the current UnmanagedResourceName is an identifier (Int32).
Public property | IsName | Determines whether the current UnmanagedResourceName is a name (String).
Public property | Name | Gets the string representing the current UnmanagedResourceName, or null if the current object has an identifier (Id).

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


Id Property

UnmanagedResourceName..::..Id Property
UnmanagedResourceName Structure See Also Send Feedback
Gets the integer identifier representing the current UnmanagedResourceName, or 0 if the current object has a name (Name).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Id { get; set; }

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


IsId Property

UnmanagedResourceName..::..IsId Property
UnmanagedResourceName Structure See Also Send Feedback
Determines whether the current UnmanagedResourceName is an identifier (Int32).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsId { get; }

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


IsName Property

UnmanagedResourceName..::..IsName Property
UnmanagedResourceName Structure See Also Send Feedback
Determines whether the current UnmanagedResourceName is a name (String).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsName { get; }

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


Name Property

UnmanagedResourceName..::..Name Property
UnmanagedResourceName Structure See Also Send Feedback
Gets the string representing the current UnmanagedResourceName, or null if the current object has an identifier (Id).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

UnmanagedResourceName Structure
PostSharp.Sdk.CodeModel Namespace


UnmanagedResourceType Enumeration

UnmanagedResourceType Enumeration
See Also Send Feedback
Types of unmanaged resources (like Accelerator, Icon, ...).

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum UnmanagedResourceType

Members

Member name | Value | Description
None | 0 | Not a well-known type. It may be a named type (see TypeName).
Accelerator | 9 | Accelerator table.
AnimatedCursor | 21 | Animated cursor.
AnimatedIcon | 22 | Animated icon.
Bitmap | 2 | Bitmap resource.
Cursor | 1 | Hardware-dependent cursor resource.
Dialog | 5 | Dialog box.
DialogInclude | 17 | Allows a resource editing tool to associate a string with an .rc file. Typically, the string is the name of the header file that provides symbolic names. The resource compiler parses the string but otherwise ignores the value. For example, file MyFile.dlg: 1 DLGINCLUDE "MyFile.h"
Font | 8 | Font resource.
FontDirectory | 7 | Font directory resource.
GroupCursor | 12 | Hardware-independent cursor resource.
IconCursor | 14 | Hardware-independent icon resource.
Html | 23 | HTML
Icon | 3 | Hardware-dependent icon resource.
Manifest | 24 | Microsoft Windows XP: Side-by-Side Assembly XML Manifest.
Menu | 4 | Menu resource.
MessageTable | 11 | Message-table entry.
PlugPlay | 19 | Plug and Play resource.
RcData | 10 | Application-defined resource (raw data).
String | 6 | String-table entry.
Version | 16 | Version resource.
VxD | 20 | VxD.

See Also

PostSharp.Sdk.CodeModel Namespace


VisibilityHelper Class

VisibilityHelper Class
Members See Also Send Feedback
Provides methods that determines the visibility of classes, fields and methods.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class VisibilityHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.VisibilityHelper

See Also

VisibilityHelper Members
PostSharp.Sdk.CodeModel Namespace


VisibilityHelper Members

[image]

PostSharp 2.0 Documentation
VisibilityHelper Members
VisibilityHelper Class Methods See Also Send Feedback

The VisibilityHelper type exposes the following members.

Methods

Name | Description
IsPublic | Overloaded.
IsVisible | Determines whether a member is visible from a given scope.

See Also

VisibilityHelper Class
PostSharp.Sdk.CodeModel Namespace


VisibilityHelper Methods

[image]

PostSharp 2.0 Documentation
VisibilityHelper Methods
VisibilityHelper Class See Also Send Feedback

The VisibilityHelper type exposes the following members.

Methods

Name | Description
IsPublic | Overloaded.
IsVisible | Determines whether a member is visible from a given scope.

See Also

VisibilityHelper Class
PostSharp.Sdk.CodeModel Namespace


IsPublic Method

[image]

PostSharp 2.0 Documentation
VisibilityHelper..::..IsPublic Method
VisibilityHelper Class See Also Send Feedback

Overload List

Name | Description
IsPublic(FieldDefDeclaration) | Determines whether a field is visible outside its assembly.
IsPublic(IMember) | Determines whether a member is visible outside its assembly.
IsPublic(MethodDefDeclaration) | Determines whether a method is visible outside its assembly.
IsPublic(TypeDefDeclaration) | Determines whether a type is visible outside its assembly.

See Also

VisibilityHelper Class
VisibilityHelper Members
PostSharp.Sdk.CodeModel Namespace


IsPublic Method (FieldDefDeclaration)

VisibilityHelper..::..IsPublic Method (FieldDefDeclaration)
VisibilityHelper Class See Also Send Feedback
Determines whether a field is visible outside its assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsPublic(
    this FieldDefDeclaration fieldDef
)

Parameters

fieldDef
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
A field.

Return Value

true if fieldDef is visible outside its assembly, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FieldDefDeclaration. When you use instance method syntax to call this method, omit the first parameter.

See Also

VisibilityHelper Class
IsPublic Overload
PostSharp.Sdk.CodeModel Namespace


IsPublic Method (IMember)

VisibilityHelper..::..IsPublic Method (IMember)
VisibilityHelper Class See Also Send Feedback
Determines whether a member is visible outside its assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsPublic(
    this IMember member
)

Parameters

member
Type: PostSharp.Sdk.CodeModel..::.IMember
A member.

Return Value

true if member is visible outside its assembly, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMember. When you use instance method syntax to call this method, omit the first parameter.

See Also

VisibilityHelper Class
IsPublic Overload
PostSharp.Sdk.CodeModel Namespace


IsPublic Method (MethodDefDeclaration)

VisibilityHelper..::..IsPublic Method (MethodDefDeclaration)
VisibilityHelper Class See Also Send Feedback
Determines whether a method is visible outside its assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsPublic(
    this MethodDefDeclaration methodDef
)

Parameters

methodDef
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A method.

Return Value

true if methodDef is visible outside its assembly, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type MethodDefDeclaration. When you use instance method syntax to call this method, omit the first parameter.

See Also

VisibilityHelper Class
IsPublic Overload
PostSharp.Sdk.CodeModel Namespace


IsPublic Method (TypeDefDeclaration)

VisibilityHelper..::..IsPublic Method (TypeDefDeclaration)
VisibilityHelper Class See Also Send Feedback
Determines whether a type is visible outside its assembly.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsPublic(
    this TypeDefDeclaration typeDef
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
A type.

Return Value

true if typeDef is visible outside its assembly, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type TypeDefDeclaration. When you use instance method syntax to call this method, omit the first parameter.

See Also

VisibilityHelper Class
IsPublic Overload
PostSharp.Sdk.CodeModel Namespace


IsVisible Method

VisibilityHelper..::..IsVisible Method
VisibilityHelper Class See Also Send Feedback
Determines whether a member is visible from a given scope.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsVisible(
    this IMember member,
    TypeDefDeclaration scope
)

Parameters

member
Type: PostSharp.Sdk.CodeModel..::.IMember
A member.
scope
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Scope from which visibility is checked.

Return Value

true if member is visible outside from the scope, otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMember. When you use instance method syntax to call this method, omit the first parameter.

See Also

VisibilityHelper Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionNameExtensions Class

WriteReflectionNameExtensions Class
Members See Also Send Feedback
Extension methods for the interface IWriteReflectionName.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class WriteReflectionNameExtensions

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.WriteReflectionNameExtensions

See Also

WriteReflectionNameExtensions Members
PostSharp.Sdk.CodeModel Namespace


WriteReflectionNameExtensions Members

[image]

PostSharp 2.0 Documentation
WriteReflectionNameExtensions Members
WriteReflectionNameExtensions Class Methods See Also Send Feedback

The WriteReflectionNameExtensions type exposes the following members.

Methods

Name | Description
GetDisplayName | Gets the name of a given declaration as it should be displayed to the user.
GetReflectionName | Overloaded.

See Also

WriteReflectionNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


WriteReflectionNameExtensions Methods

[image]

PostSharp 2.0 Documentation
WriteReflectionNameExtensions Methods
WriteReflectionNameExtensions Class See Also Send Feedback

The WriteReflectionNameExtensions type exposes the following members.

Methods

Name | Description
GetDisplayName | Gets the name of a given declaration as it should be displayed to the user.
GetReflectionName | Overloaded.

See Also

WriteReflectionNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


GetDisplayName Method

WriteReflectionNameExtensions..::..GetDisplayName Method
WriteReflectionNameExtensions Class See Also Send Feedback
Gets the name of a given declaration as it should be displayed to the user.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetDisplayName(
    this IWriteReflectionName declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IWriteReflectionName
A declaration

Return Value

The name of declaration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IWriteReflectionName. When you use instance method syntax to call this method, omit the first parameter.

See Also

WriteReflectionNameExtensions Class
PostSharp.Sdk.CodeModel Namespace


GetReflectionName Method

[image]

PostSharp 2.0 Documentation
WriteReflectionNameExtensions..::..GetReflectionName Method
WriteReflectionNameExtensions Class See Also Send Feedback

Overload List

Name | Description
GetReflectionName(IWriteReflectionName) | Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects.
GetReflectionName(IWriteReflectionName, ReflectionNameOptions) | Gets the name of a given declaration, constructed using given options.

See Also

WriteReflectionNameExtensions Class
WriteReflectionNameExtensions Members
PostSharp.Sdk.CodeModel Namespace


GetReflectionName Method (IWriteReflectionName)

WriteReflectionNameExtensions..::..GetReflectionName Method (IWriteReflectionName)
WriteReflectionNameExtensions Class See Also Send Feedback
Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetReflectionName(
    this IWriteReflectionName declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IWriteReflectionName
A declaration.

Return Value

A string identical to the result of the ToString method of the reflection object corresponding to declaration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IWriteReflectionName. When you use instance method syntax to call this method, omit the first parameter.

See Also

WriteReflectionNameExtensions Class
GetReflectionName Overload
PostSharp.Sdk.CodeModel Namespace


GetReflectionName Method (IWriteReflectionName, ReflectionNameOptions)

WriteReflectionNameExtensions..::..GetReflectionName Method (IWriteReflectionName, ReflectionNameOptions)
WriteReflectionNameExtensions Class See Also Send Feedback
Gets the name of a given declaration, constructed using given options.

Namespace: PostSharp.Sdk.CodeModel
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetReflectionName(
    this IWriteReflectionName declaration,
    ReflectionNameOptions options
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IWriteReflectionName
A declarations.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options controlling the way how the name is constructed.

Return Value

The name of declaration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IWriteReflectionName. When you use instance method syntax to call this method, omit the first parameter.

See Also

WriteReflectionNameExtensions Class
GetReflectionName Overload
PostSharp.Sdk.CodeModel Namespace


PostSharp.Sdk.CodeModel.Binding Namespace

PostSharp.Sdk.CodeModel.Binding Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.Binding namespace contains comparer classes several kinds of declarations.

Classes

 | Class | Description
Public class | AssemblyComparer | Compares two assemblies (IAssembly).
Public class | GenericMapComparer | Compares instances of GenericMap.
Public class | MethodComparer | Compares two methods (IMethod).
Public class | MethodSignatureComparer | Compares two method signatures (IMethodSignature).
Public class | TypeComparer | Compares types (IType) using equivalence rules.


AssemblyComparer Class

AssemblyComparer Class
Members See Also Send Feedback
Compares two assemblies (IAssembly).

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AssemblyComparer : IEqualityComparer<IAssemblyName>

Remarks

The implementation of this class is preliminary. In the future, it should support cross-module comparison.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Binding..::.AssemblyComparer

See Also

AssemblyComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


AssemblyComparer Members

[image]

PostSharp 2.0 Documentation
AssemblyComparer Members
AssemblyComparer Class Methods See Also Send Feedback

The AssemblyComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified objects are equal.
Public method | GetHashCode | Returns a hash code for the specified object.
 | GetInstance | Gets a singleton instance of the AssemblyComparer class.

See Also

AssemblyComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


AssemblyComparer Methods

[image]

PostSharp 2.0 Documentation
AssemblyComparer Methods
AssemblyComparer Class See Also Send Feedback

The AssemblyComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified objects are equal.
Public method | GetHashCode | Returns a hash code for the specified object.
 | GetInstance | Gets a singleton instance of the AssemblyComparer class.

See Also

AssemblyComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method

AssemblyComparer..::..Equals Method
AssemblyComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    IAssemblyName x,
    IAssemblyName y
)

Parameters

x
Type: PostSharp.Reflection..::.IAssemblyName
The first object of type T to compare.
y
Type: PostSharp.Reflection..::.IAssemblyName
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

AssemblyComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method

AssemblyComparer..::..GetHashCode Method
AssemblyComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    IAssemblyName obj
)

Parameters

obj
Type: PostSharp.Reflection..::.IAssemblyName
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

AssemblyComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GetInstance Method

AssemblyComparer..::..GetInstance Method
AssemblyComparer Class See Also Send Feedback
Gets a singleton instance of the AssemblyComparer class.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AssemblyComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Binding.AssemblyComparer.GetInstance"]

See Also

AssemblyComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GenericMapComparer Class

GenericMapComparer Class
Members See Also Send Feedback
Compares instances of GenericMap.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericMapComparer : IEqualityComparer<GenericMap>,
    IEqualityComparer

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Binding..::.GenericMapComparer

See Also

GenericMapComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


GenericMapComparer Members

[image]

PostSharp 2.0 Documentation
GenericMapComparer Members
GenericMapComparer Class Methods See Also Send Feedback

The GenericMapComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Gets an instance of GenericMapComparer.

See Also

GenericMapComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GenericMapComparer Methods

[image]

PostSharp 2.0 Documentation
GenericMapComparer Methods
GenericMapComparer Class See Also Send Feedback

The GenericMapComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Gets an instance of GenericMapComparer.

See Also

GenericMapComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
GenericMapComparer..::..Equals Method
GenericMapComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object, Object) | Determines whether the specified objects are equal.
Public method | Equals(GenericMap, GenericMap) | Determines whether the specified objects are equal.

See Also

GenericMapComparer Class
GenericMapComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method (Object, Object)

GenericMapComparer..::..Equals Method (Object, Object)
GenericMapComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object
The first object to compare.
y
Type: System..::.Object
The second object to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer..::.Equals(Object, Object)

Exceptions

Exception | Condition
System..::.ArgumentException | x and y are of different types and neither one can handle comparisons with the other.

See Also

GenericMapComparer Class
Equals Overload
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method (GenericMap, GenericMap)

GenericMapComparer..::..Equals Method (GenericMap, GenericMap)
GenericMapComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    GenericMap x,
    GenericMap y
)

Parameters

x
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The first object of type T to compare.
y
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

GenericMapComparer Class
Equals Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method

[image]

PostSharp 2.0 Documentation
GenericMapComparer..::..GetHashCode Method
GenericMapComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode(Object) | Returns a hash code for the specified object.
Public method | GetHashCode(GenericMap) | Returns a hash code for the specified object.

See Also

GenericMapComparer Class
GenericMapComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method (Object)

GenericMapComparer..::..GetHashCode Method (Object)
GenericMapComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    Object obj
)

Parameters

obj
Type: System..::.Object
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer..::.GetHashCode(Object)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

GenericMapComparer Class
GetHashCode Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method (GenericMap)

GenericMapComparer..::..GetHashCode Method (GenericMap)
GenericMapComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    GenericMap obj
)

Parameters

obj
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

GenericMapComparer Class
GetHashCode Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetInstance Method

GenericMapComparer..::..GetInstance Method
GenericMapComparer Class See Also Send Feedback
Gets an instance of GenericMapComparer.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static GenericMapComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Binding.GenericMapComparer.GetInstance"]

See Also

GenericMapComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


MethodComparer Class

MethodComparer Class
Members See Also Send Feedback
Compares two methods (IMethod).

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodComparer : IEqualityComparer<IMethod>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Binding..::.MethodComparer

See Also

MethodComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


MethodComparer Members

[image]

PostSharp 2.0 Documentation
MethodComparer Members
MethodComparer Class Methods See Also Send Feedback

The MethodComparer type exposes the following members.

Methods

 | Name | Description
Public method | GetHashCode | Returns a hash code for the specified object.
 | GetInstance | Gets a singleton instance of MethodComparer.

See Also

MethodComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


MethodComparer Methods

[image]

PostSharp 2.0 Documentation
MethodComparer Methods
MethodComparer Class See Also Send Feedback

The MethodComparer type exposes the following members.

Methods

 | Name | Description
Public method | GetHashCode | Returns a hash code for the specified object.
 | GetInstance | Gets a singleton instance of MethodComparer.

See Also

MethodComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method

MethodComparer..::..GetHashCode Method
MethodComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    IMethod obj
)

Parameters

obj
Type: PostSharp.Sdk.CodeModel..::.IMethod
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

MethodComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GetInstance Method

MethodComparer..::..GetInstance Method
MethodComparer Class See Also Send Feedback
Gets a singleton instance of MethodComparer.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static MethodComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Binding.MethodComparer.GetInstance"]

See Also

MethodComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


MethodSignatureComparer Class

MethodSignatureComparer Class
Members See Also Send Feedback
Compares two method signatures (IMethodSignature).

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSignatureComparer : IEqualityComparer<IMethodSignature>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Binding..::.MethodSignatureComparer

See Also

MethodSignatureComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


MethodSignatureComparer Members

[image]

PostSharp 2.0 Documentation
MethodSignatureComparer Members
MethodSignatureComparer Class Methods See Also Send Feedback

The MethodSignatureComparer type exposes the following members.

Methods

Name | Description
GetInstance | Gets a singleton instance of MethodSignatureComparer.

See Also

MethodSignatureComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


MethodSignatureComparer Methods

[image]

PostSharp 2.0 Documentation
MethodSignatureComparer Methods
MethodSignatureComparer Class See Also Send Feedback

The MethodSignatureComparer type exposes the following members.

Methods

Name | Description
GetInstance | Gets a singleton instance of MethodSignatureComparer.

See Also

MethodSignatureComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


GetInstance Method

MethodSignatureComparer..::..GetInstance Method
MethodSignatureComparer Class See Also Send Feedback
Gets a singleton instance of MethodSignatureComparer.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static MethodSignatureComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Binding.MethodSignatureComparer.GetInstance"]

See Also

MethodSignatureComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


TypeComparer Class

TypeComparer Class
Members See Also Send Feedback
Compares types (IType) using equivalence rules.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeComparer : IEqualityComparer<ITypeSignature>,
    IEqualityComparer<TypeSignature>, IEqualityComparer

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Binding..::.TypeComparer

See Also

TypeComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


TypeComparer Members

[image]

PostSharp 2.0 Documentation
TypeComparer Members
TypeComparer Class Methods See Also Send Feedback

The TypeComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Gets a singleton instance of TypeComparer.

See Also

TypeComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


TypeComparer Methods

[image]

PostSharp 2.0 Documentation
TypeComparer Methods
TypeComparer Class See Also Send Feedback

The TypeComparer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Overloaded.
 | GetInstance | Gets a singleton instance of TypeComparer.

See Also

TypeComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
TypeComparer..::..Equals Method
TypeComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object, Object) | Determines whether the specified objects are equal.
Public method | Equals(ITypeSignature, ITypeSignature) | Determines whether the specified objects are equal.
Public method | Equals(TypeSignature, TypeSignature) | Determines whether the specified objects are equal.

See Also

TypeComparer Class
TypeComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method (Object, Object)

TypeComparer..::..Equals Method (Object, Object)
TypeComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object
The first object to compare.
y
Type: System..::.Object
The second object to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer..::.Equals(Object, Object)

Exceptions

Exception | Condition
System..::.ArgumentException | x and y are of different types and neither one can handle comparisons with the other.

See Also

TypeComparer Class
Equals Overload
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method (ITypeSignature, ITypeSignature)

TypeComparer..::..Equals Method (ITypeSignature, ITypeSignature)
TypeComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ITypeSignature x,
    ITypeSignature y
)

Parameters

x
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The first object of type T to compare.
y
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

TypeComparer Class
Equals Overload
PostSharp.Sdk.CodeModel.Binding Namespace


Equals Method (TypeSignature, TypeSignature)

TypeComparer..::..Equals Method (TypeSignature, TypeSignature)
TypeComparer Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    TypeSignature x,
    TypeSignature y
)

Parameters

x
Type: PostSharp.Sdk.CodeModel..::.TypeSignature
The first object of type T to compare.
y
Type: PostSharp.Sdk.CodeModel..::.TypeSignature
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

TypeComparer Class
Equals Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method

[image]

PostSharp 2.0 Documentation
TypeComparer..::..GetHashCode Method
TypeComparer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode(Object) | Returns a hash code for the specified object.
Public method | GetHashCode(ITypeSignature) | Returns a hash code for the specified object.
Public method | GetHashCode(TypeSignature) | Returns a hash code for the specified object.

See Also

TypeComparer Class
TypeComparer Members
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method (Object)

TypeComparer..::..GetHashCode Method (Object)
TypeComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    Object obj
)

Parameters

obj
Type: System..::.Object
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer..::.GetHashCode(Object)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

TypeComparer Class
GetHashCode Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method (ITypeSignature)

TypeComparer..::..GetHashCode Method (ITypeSignature)
TypeComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    ITypeSignature obj
)

Parameters

obj
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

TypeComparer Class
GetHashCode Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetHashCode Method (TypeSignature)

TypeComparer..::..GetHashCode Method (TypeSignature)
TypeComparer Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetHashCode(
    TypeSignature obj
)

Parameters

obj
Type: PostSharp.Sdk.CodeModel..::.TypeSignature
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

Exceptions

Exception | Condition
System..::.ArgumentNullException | The type of obj is a reference type and obj is null.

See Also

TypeComparer Class
GetHashCode Overload
PostSharp.Sdk.CodeModel.Binding Namespace


GetInstance Method

TypeComparer..::..GetInstance Method
TypeComparer Class See Also Send Feedback
Gets a singleton instance of TypeComparer.

Namespace: PostSharp.Sdk.CodeModel.Binding
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeComparer GetInstance()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Binding.TypeComparer.GetInstance"]

See Also

TypeComparer Class
PostSharp.Sdk.CodeModel.Binding Namespace


PostSharp.Sdk.CodeModel.Collections Namespace

PostSharp.Sdk.CodeModel.Collections Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.Collections namespaces contains collections of objects of the PostSharp.Sdk.CodeModel namespace.

Classes

 | Class | Description
Public class | AssemblyEnvelopeCollection | Collection of assemblies (AssemblyEnvelope).
Public class | AssemblyRefDeclarationCollection | Collection of AssemblyRefDeclaration.
Public class | CollectionHelper | Extension methods for the ICollection<(Of <(T>)>) interface.
Public class | CustomAttributeDeclarationCollection | Collection of custom attributes (CustomAttributeDeclaration).
Public class | DataDeclarationCollection | Collection of data sections (DataSectionDeclaration.
Public class | ElementCollection | Untyped based for ElementCollection<(Of <(?0>)>).
Public class | ElementCollection<(Of <(?0>)>) | Collection of elements (Element).
Public class | EventDeclarationCollection | Collection of events.
Public class | ExceptionHandlerCollection | Collection of exception handlers (ExceptionHandler).
Public class | ExportedTypeDeclarationCollection | Collection of exported types (ExportedTypeDeclaration).
Public class | FieldDefDeclarationCollection | Collection of FieldDefDeclaration objects.
Public class | FieldRefDeclarationCollection | Collection of FieldRefDeclaration objects.
Public class | GenericParameterConstraintDeclarationCollection | Collection of GenericParameterConstraintDeclaration.
Public class | GenericParameterDeclarationCollection | Collection of generic parameters (GenericParameterDeclaration).
Public class | InstructionBlockCollection | Linked list of instruction blocks (InstructionBlock).
Public class | InterfaceImplementationDeclarationCollection | Collection of InterfaceImplementationDeclaration.
Public class | LocalVariableDeclarationCollection | Collection of local variables (LocalVariableDeclaration).
Public class | LocalVariableSymbolCollection | Collection of local variable symbols (LocalVariableSymbol).
Public class | ManifestFileDeclarationCollection | Collection of assembly manifestFiles (ManifestFileDeclaration).
Public class | ManifestResourceDeclarationCollection | Collection of resources (ManifestResourceDeclaration).
Public class | MemberValuePairCollection | Collection of member-value pairs (MemberValuePair).
Public class | MetadataDeclarationDirectory<(Of <(?0>)>) | Dictionary where keys are declarations (MetadataDeclaration). The implementation is partially thread-safe and is optimized to have low lock contention.
Public class | MethodDefDeclarationCollection | Collection of methods (MethodDefDeclaration).
Public class | MethodImplementationDeclarationCollection | Collection of MethodImplementationDeclaration.
Public class | MethodRefDeclarationCollection | Collection of method references (MethodRefDeclaration).
Public class | MethodSemanticDeclarationCollection | Collection of method semantics (MethodSemanticDeclaration).
Public class | MethodSpecDeclarationCollection | Collection of method specifications (MethodSpecDeclaration).
Public class | ModuleDeclarationCollection | Collection of modules (ModuleDeclaration).
Public class | ModuleRefDeclarationCollection | Collection of module references (ModuleRefDeclaration).
Public class | NamedElementCollection<(Of <(?0>)>) | Base class for collections of elements having a name, with an index on the Name property.
Public class | ParameterDeclarationCollection | Collection of parameters (ParameterDeclaration).
Public class | PermissionDeclarationCollection | Collection of permission attributes (PermissionDeclaration).
Public class | PermissionSetDeclarationCollection | Collection of permission sets (PermissionSetDeclaration).
Public class | PropertyDeclarationCollection | Collection of properties (PropertyDeclaration).
Public class | StandaloneSignatureDeclarationCollection | Collection of StandaloneSignatureDeclaration.
Public class | TypeDefDeclarationCollection | Collection of types (TypeDefDeclaration).
Public class | TypeRefDeclarationCollection | Collection of type references (TypeRefDeclarationCollection).
Public class | TypeSpecDeclarationCollection | Collection of type specifications (TypeSpecDeclarationCollection).
Public class | UnmanagedResourceCollection | Collection of unmanaged resources (UnmanagedResource).

Interfaces

 | Interface | Description
Public interface | IFieldCollection | Semantics of collections of fields as required by IType.
Public interface | IMethodCollection | Semantics of collections of methods as required by IType.
Public interface | INamedTypeCollection | Semantics of collections of types as required by IType.


AssemblyEnvelopeCollection Class

AssemblyEnvelopeCollection Class
Members See Also Send Feedback
Collection of assemblies (AssemblyEnvelope).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyEnvelopeCollection : NonUniquelyNamedElementCollection<AssemblyEnvelope>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection <(Of <(<'?0>)>)>
NonUniquelyNamedElementCollection<(Of <(<' AssemblyEnvelope >)>)>
PostSharp.Sdk.CodeModel.Collections..::.AssemblyEnvelopeCollection

See Also

AssemblyEnvelopeCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyEnvelopeCollection Members

[image]

PostSharp 2.0 Documentation
AssemblyEnvelopeCollection Members
AssemblyEnvelopeCollection Class Methods Properties See Also Send Feedback

The AssemblyEnvelopeCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyEnvelopeCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyEnvelopeCollection Methods

[image]

PostSharp 2.0 Documentation
AssemblyEnvelopeCollection Methods
AssemblyEnvelopeCollection Class See Also Send Feedback

The AssemblyEnvelopeCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyEnvelopeCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyEnvelopeCollection Properties

[image]

PostSharp 2.0 Documentation
AssemblyEnvelopeCollection Properties
AssemblyEnvelopeCollection Class See Also Send Feedback

The AssemblyEnvelopeCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyEnvelopeCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyRefDeclarationCollection Class

AssemblyRefDeclarationCollection Class
Members See Also Send Feedback
Collection of AssemblyRefDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssemblyRefDeclarationCollection : TokenOrderedDeclarationCollection<AssemblyRefDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' AssemblyRefDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' AssemblyRefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.AssemblyRefDeclarationCollection

See Also

AssemblyRefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyRefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclarationCollection Members
AssemblyRefDeclarationCollection Class Methods Properties See Also Send Feedback

The AssemblyRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyRefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclarationCollection Methods
AssemblyRefDeclarationCollection Class See Also Send Feedback

The AssemblyRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


AssemblyRefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
AssemblyRefDeclarationCollection Properties
AssemblyRefDeclarationCollection Class See Also Send Feedback

The AssemblyRefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

AssemblyRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


CollectionHelper Class

CollectionHelper Class
Members See Also Send Feedback
Extension methods for the ICollection<(Of <(T>)>) interface.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class CollectionHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.CollectionHelper

See Also

CollectionHelper Members
PostSharp.Sdk.CodeModel.Collections Namespace


CollectionHelper Members

[image]

PostSharp 2.0 Documentation
CollectionHelper Members
CollectionHelper Class Methods See Also Send Feedback

The CollectionHelper type exposes the following members.

Methods

Name | Description
AddRangeCloned<(Of <(T>)>) | Adds a range of given items, after being cloned and translated for a given module, to a given collection.

See Also

CollectionHelper Class
PostSharp.Sdk.CodeModel.Collections Namespace


CollectionHelper Methods

[image]

PostSharp 2.0 Documentation
CollectionHelper Methods
CollectionHelper Class See Also Send Feedback

The CollectionHelper type exposes the following members.

Methods

Name | Description
AddRangeCloned<(Of <(T>)>) | Adds a range of given items, after being cloned and translated for a given module, to a given collection.

See Also

CollectionHelper Class
PostSharp.Sdk.CodeModel.Collections Namespace


AddRangeCloned(T) Method

CollectionHelper..::..AddRangeCloned<(Of <(<'T>)>)> Method
CollectionHelper Class See Also Send Feedback
Adds a range of given items, after being cloned and translated for a given module, to a given collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AddRangeCloned<T>(
    this ICollection<T> sourceCollection,
    IPreAllocatedCollection<T> targetCollection,
    ModuleDeclaration targetModule
)
where T : ICloneableModuleElement

Parameters

sourceCollection
Type: System.Collections.Generic..::.ICollection <(Of <(<'T>)>)>
Source collection.
targetCollection
Type: PostSharp.Sdk.Collections..::.IPreAllocatedCollection <(Of <(<'T>)>)>
Target collection.
targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which the items must be expressed.

Type Parameters

T
Type of elements.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICollection <(Of <(<'T>)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CollectionHelper Class
PostSharp.Sdk.CodeModel.Collections Namespace


CustomAttributeDeclarationCollection Class

CustomAttributeDeclarationCollection Class
Members See Also Send Feedback
Collection of custom attributes (CustomAttributeDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomAttributeDeclarationCollection : TokenOrderedDeclarationCollection<CustomAttributeDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' CustomAttributeDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' CustomAttributeDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.CustomAttributeDeclarationCollection

See Also

CustomAttributeDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


CustomAttributeDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclarationCollection Members
CustomAttributeDeclarationCollection Class Methods Properties See Also Send Feedback

The CustomAttributeDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ConstructRuntimeObjects | Overloaded.
Public method | Contains | Overloaded.
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetByTypeEnumerator | Gets an enumerator of all custom attribute instances of a given type.
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetOneByType | Gets one or zero custom attribute instance of a given type.
Public method | MoveContentTo | Moved all the custom attributes from this collection to another.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


CustomAttributeDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclarationCollection Methods
CustomAttributeDeclarationCollection Class See Also Send Feedback

The CustomAttributeDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ConstructRuntimeObjects | Overloaded.
Public method | Contains | Overloaded.
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetByTypeEnumerator | Gets an enumerator of all custom attribute instances of a given type.
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetOneByType | Gets one or zero custom attribute instance of a given type.
Public method | MoveContentTo | Moved all the custom attributes from this collection to another.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ConstructRuntimeObjects Method

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclarationCollection..::..ConstructRuntimeObjects Method
CustomAttributeDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstructRuntimeObjects(IType) | Constructs runtime objects for some of all declarations contained in the current collection and return them as an array.
Public method | ConstructRuntimeObjects(IType, IList) | Constructs runtime objects for some of all declarations contained in the current collection and store them in a collection.

See Also

CustomAttributeDeclarationCollection Class
CustomAttributeDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ConstructRuntimeObjects Method (IType)

CustomAttributeDeclarationCollection..::..ConstructRuntimeObjects Method (IType)
CustomAttributeDeclarationCollection Class See Also Send Feedback
Constructs runtime objects for some of all declarations contained in the current collection and return them as an array.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object[] ConstructRuntimeObjects(
    IType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
The type that built custom attributes should be of, or null if all custom attributes should be built.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Collections.CustomAttributeDeclarationCollection.ConstructRuntimeObjects(PostSharp.Sdk.CodeModel.IType)"]

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeDeclarationCollection Class
ConstructRuntimeObjects Overload
PostSharp.Sdk.CodeModel.Collections Namespace


ConstructRuntimeObjects Method (IType, IList)

CustomAttributeDeclarationCollection..::..ConstructRuntimeObjects Method (IType, IList)
CustomAttributeDeclarationCollection Class See Also Send Feedback
Constructs runtime objects for some of all declarations contained in the current collection and store them in a collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ConstructRuntimeObjects(
    IType type,
    IList objects
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
The type that built custom attributes should be of, or null if all custom attributes should be built.
objects
Type: System.Collections..::.IList
Collection into which custom attribute instances are added.

Exceptions

Exception | Condition
PostSharp.Sdk.CodeModel..::.CustomAttributeConstructorException | The constructor or a property setter threw an exception.

See Also

CustomAttributeDeclarationCollection Class
ConstructRuntimeObjects Overload
PostSharp.Sdk.CodeModel.Collections Namespace


Contains Method

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclarationCollection..::..Contains Method
CustomAttributeDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains(IType) | Determines whether the current collection contains a custom attribute of a given type.

See Also

CustomAttributeDeclarationCollection Class
CustomAttributeDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Contains Method (IType)

CustomAttributeDeclarationCollection..::..Contains Method (IType)
CustomAttributeDeclarationCollection Class See Also Send Feedback
Determines whether the current collection contains a custom attribute of a given type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    IType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
Type of the custom attribute.

Return Value

true if the current collection contains at least one custom attribute of type type, otherwise false.

See Also

CustomAttributeDeclarationCollection Class
Contains Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetByTypeEnumerator Method

CustomAttributeDeclarationCollection..::..GetByTypeEnumerator Method
CustomAttributeDeclarationCollection Class See Also Send Feedback
Gets an enumerator of all custom attribute instances of a given type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<CustomAttributeDeclaration> GetByTypeEnumerator(
    IType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
Type of requested custom attributes.

Return Value

An enumerator of all custom attribute instances of a given type. This method does not return custom attributes derived from type.

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetOneByType Method

CustomAttributeDeclarationCollection..::..GetOneByType Method
CustomAttributeDeclarationCollection Class See Also Send Feedback
Gets one or zero custom attribute instance of a given type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration GetOneByType(
    IType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
Type of the requested custom attribute.

Return Value

A CustomAttributeDeclaration of type type, or null if no such custom attribute was found. This method does not return custom attributes derived from type.

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MoveContentTo Method

CustomAttributeDeclarationCollection..::..MoveContentTo Method
CustomAttributeDeclarationCollection Class See Also Send Feedback
Moved all the custom attributes from this collection to another.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MoveContentTo(
    CustomAttributeDeclarationCollection target
)

Parameters

target
Type: PostSharp.Sdk.CodeModel.Collections..::.CustomAttributeDeclarationCollection
Collection where the custom attributes should be moved.

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


CustomAttributeDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
CustomAttributeDeclarationCollection Properties
CustomAttributeDeclarationCollection Class See Also Send Feedback

The CustomAttributeDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

CustomAttributeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


DataDeclarationCollection Class

DataDeclarationCollection Class
Members See Also Send Feedback
Collection of data sections (DataSectionDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DataDeclarationCollection : OrdinalDeclarationCollection<DataSectionDeclaration>

Remarks

This collection is populated lazily when clients (e.g. fields) are loaded, but it is not possible to load all the elements without loading all its clients before. Therefore, it is unsafe to enumerate this collection when it belongs to a module that has been loaded lazily.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
OrdinalDeclarationCollection<(Of <(<' DataSectionDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.DataDeclarationCollection

See Also

DataDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


DataDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
DataDeclarationCollection Members
DataDeclarationCollection Class Methods Properties See Also Send Feedback

The DataDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

DataDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


DataDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
DataDeclarationCollection Methods
DataDeclarationCollection Class See Also Send Feedback

The DataDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

DataDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


DataDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
DataDeclarationCollection Properties
DataDeclarationCollection Class See Also Send Feedback

The DataDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

DataDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection Class

ElementCollection Class
Members See Also Send Feedback
Untyped based for ElementCollection<(Of <(?0>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class ElementCollection

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection<(Of <(?0>)>)

See Also

ElementCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection Members

[image]

PostSharp 2.0 Documentation
ElementCollection Members
ElementCollection Class Methods See Also Send Feedback

The ElementCollection type exposes the following members.

Methods

Name | Description
Move | Moves an item from one collection to another.

See Also

ElementCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection Methods

[image]

PostSharp 2.0 Documentation
ElementCollection Methods
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Methods

Name | Description
Move | Moves an item from one collection to another.

See Also

ElementCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Move Method

ElementCollection..::..Move Method
ElementCollection Class See Also Send Feedback
Moves an item from one collection to another.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Move(
    Element item,
    ElementCollection oldCollection,
    ElementCollection newCollection
)

Parameters

item
Type: PostSharp.Sdk.CodeModel..::.Element
Item to move.
oldCollection
Type: PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
Old collection.
newCollection
Type: PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
New collection.

See Also

ElementCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection(?0) Class

ElementCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Collection of elements (Element).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class ElementCollection<?0> : ElementCollection,
    IPreAllocatedCollection<?0>, ICollection<?0>, IEnumerable<?0>, ICollection,
    IEnumerable, IDisposable
where ?0 : Element

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1"]

Remarks

This collection should be owned by an Element. The objective of the current class is to notify the owner element that a child was added or removed. In order for the owner element to know to which collection the child belongs, each collection has a role in the owner collection.

This class maintains the parent-child relationship.

In order to save memory, the underlying collection is created only on demand. Empty collections should not have underlying collection.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection<(Of <(?0>)>)
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection<(Of <(?0>)>)
PostSharp.Sdk.CodeModel.Collections..::.StandaloneSignatureDeclarationCollection
PostSharp.Sdk.CodeModel.Collections..::.TypeSpecDeclarationCollection
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectClassCollection
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectInstanceCollection
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectUsageCollection
PostSharp.Sdk.WeavingSymbols.Collections..::.SymEvolutionCollection
PostSharp.Sdk.WeavingSymbols.Collections..::.SymJoinPointCollection

See Also

ElementCollection<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection(?0) Members

[image]

PostSharp 2.0 Documentation
ElementCollection<(Of <(<'?0>)>)> Members
ElementCollection<(Of <(?0>)>) Class Methods Properties See Also Send Feedback

The ElementCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | AddRange | Adds a collection of items to the current collection.
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection.
Public method | Contains |
Public method | CopyTo |
Public method | Dispose | Disposes the resources held by the current instance.
Protected method | DoLazyLoading | Loads the content of the collection.
Public method | EnsureCapacity | Allocates additional capacity in the collection.
Public method | GetEnumerator |
Protected method | OnItemAdding | Called before adding an item to the collection.
Protected method | OnItemRemoved | Called before removing an item from the collection.
Public method | Remove |
Public method | ToArray | Converts the current collection into a typed array.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the current collection has been disposed.
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Owner | Gets the owner Element.
Public property | Role | Gets the role of the current collection in the owner element.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
ElementCollection<(Of <(<'?0>)>)> Methods
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

The ElementCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | AddRange | Adds a collection of items to the current collection.
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection.
Public method | Contains |
Public method | CopyTo |
Public method | Dispose | Disposes the resources held by the current instance.
Protected method | DoLazyLoading | Loads the content of the collection.
Public method | EnsureCapacity | Allocates additional capacity in the collection.
Public method | GetEnumerator |
Protected method | OnItemAdding | Called before adding an item to the collection.
Protected method | OnItemRemoved | Called before removing an item from the collection.
Public method | Remove |
Public method | ToArray | Converts the current collection into a typed array.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method

ElementCollection<(Of <(<'?0>)>)>..::..Add Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Add(`0)"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Add(`0)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


AddRange Method

ElementCollection<(Of <(<'?0>)>)>..::..AddRange Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Adds a collection of items to the current collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    ICollection<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
The collection of items to be added.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


AddRangeCloned Method

ElementCollection<(Of <(<'?0>)>)>..::..AddRangeCloned Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Adds clones of items of a given collection to the current collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRangeCloned(
    ICollection<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
The collection of items to be added.

Remarks

This method requires ItemType to implement the ICloneable interface. Clones should be themselves of the ItemType type.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Clear Method

ElementCollection<(Of <(<'?0>)>)>..::..Clear Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ClearCache Method

ElementCollection<(Of <(<'?0>)>)>..::..ClearCache Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ClearCache()

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Contains Method

ElementCollection<(Of <(<'?0>)>)>..::..Contains Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Contains(`0)"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Contains(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Contains(`0)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


CopyTo Method

ElementCollection<(Of <(<'?0>)>)>..::..CopyTo Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.CopyTo(`0[],System.Int32)"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]

[Missing <param name="array"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.CopyTo(`0[],System.Int32)"]

arrayIndex
Type: System..::.Int32

[Missing <param name="arrayIndex"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.CopyTo(`0[],System.Int32)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Dispose Method

ElementCollection<(Of <(<'?0>)>)>..::..Dispose Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Disposes the resources held by the current instance.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


DoLazyLoading Method

ElementCollection<(Of <(<'?0>)>)>..::..DoLazyLoading Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Loads the content of the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract void DoLazyLoading()

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


EnsureCapacity Method

ElementCollection<(Of <(<'?0>)>)>..::..EnsureCapacity Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Allocates additional capacity in the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Additional capacity.

Implements

IPreAllocatedCollection<(Of <(?0>)>)..::.EnsureCapacity(Int32)

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetEnumerator Method

ElementCollection<(Of <(<'?0>)>)>..::..GetEnumerator Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.GetEnumerator"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.GetEnumerator"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


OnItemAdding Method

ElementCollection<(Of <(<'?0>)>)>..::..OnItemAdding Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Called before adding an item to the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void OnItemAdding(
    ?0 item,
    bool moving
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.OnItemAdding(`0,System.Boolean)"]

moving
Type: System..::.Boolean

[Missing <param name="moving"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.OnItemAdding(`0,System.Boolean)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


OnItemRemoved Method

ElementCollection<(Of <(<'?0>)>)>..::..OnItemRemoved Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Called before removing an item from the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void OnItemRemoved(
    ?0 item,
    bool moving
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.OnItemRemoved(`0,System.Boolean)"]

moving
Type: System..::.Boolean

[Missing <param name="moving"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.OnItemRemoved(`0,System.Boolean)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Remove Method

ElementCollection<(Of <(<'?0>)>)>..::..Remove Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Remove(`0)"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Remove(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Collections.ElementCollection`1.Remove(`0)"]

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ToArray Method

ElementCollection<(Of <(<'?0>)>)>..::..ToArray Method
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Converts the current collection into a typed array.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0[] ToArray()

Return Value

An array containing all elements of the current collection.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ElementCollection(?0) Properties

[image]

PostSharp 2.0 Documentation
ElementCollection<(Of <(<'?0>)>)> Properties
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback

The ElementCollection<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the current collection has been disposed.
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Owner | Gets the owner Element.
Public property | Role | Gets the role of the current collection in the owner element.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Count Property

ElementCollection<(Of <(<'?0>)>)>..::..Count Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count
ICollection..::.Count

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsDisposed Property

ElementCollection<(Of <(<'?0>)>)>..::..IsDisposed Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the current collection has been disposed.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsLazyLoadingSupported Property

ElementCollection<(Of <(<'?0>)>)>..::..IsLazyLoadingSupported Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines if the current collection supports lazy loading.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract bool IsLazyLoadingSupported { get; }

Remarks

If a collection supports lazy loading, the method DoLazyLoading()()() should be implemented; it will be called before any access to the collection.

This property is evaluated before the collection constructor is invoked. Therefore, it is considered as static for the collection class.

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsReadOnly Property

ElementCollection<(Of <(<'?0>)>)>..::..IsReadOnly Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Owner Property

ElementCollection<(Of <(<'?0>)>)>..::..Owner Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the owner Element.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Element Owner { get; }

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Role Property

ElementCollection<(Of <(<'?0>)>)>..::..Role Property
ElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the role of the current collection in the owner element.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Role { get; }

See Also

ElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


EventDeclarationCollection Class

EventDeclarationCollection Class
Members See Also Send Feedback
Collection of events.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EventDeclarationCollection : UniquelyNamedTokenOrderedDeclarationCollection<EventDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' EventDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' EventDeclaration >)>)>
UniquelyNamedTokenOrderedDeclarationCollection<(Of <(<' EventDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.EventDeclarationCollection

See Also

EventDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


EventDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
EventDeclarationCollection Members
EventDeclarationCollection Class Methods Properties See Also Send Feedback

The EventDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

EventDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


EventDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
EventDeclarationCollection Methods
EventDeclarationCollection Class See Also Send Feedback

The EventDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

EventDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


EventDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
EventDeclarationCollection Properties
EventDeclarationCollection Class See Also Send Feedback

The EventDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

EventDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ExceptionHandlerCollection Class

ExceptionHandlerCollection Class
See Also Send Feedback
Collection of exception handlers (ExceptionHandler).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExceptionHandlerCollection : LinkedList<ExceptionHandler>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.LinkedList <(Of <(<' ExceptionHandler >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ExceptionHandlerCollection

See Also

PostSharp.Sdk.CodeModel.Collections Namespace


ExportedTypeDeclarationCollection Class

ExportedTypeDeclarationCollection Class
Members See Also Send Feedback
Collection of exported types (ExportedTypeDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ExportedTypeDeclarationCollection : UniquelyNamedTokenOrderedDeclarationCollection<ExportedTypeDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' ExportedTypeDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' ExportedTypeDeclaration >)>)>
UniquelyNamedTokenOrderedDeclarationCollection<(Of <(<' ExportedTypeDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ExportedTypeDeclarationCollection

See Also

ExportedTypeDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ExportedTypeDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclarationCollection Members
ExportedTypeDeclarationCollection Class Methods Properties See Also Send Feedback

The ExportedTypeDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ExportedTypeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ExportedTypeDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclarationCollection Methods
ExportedTypeDeclarationCollection Class See Also Send Feedback

The ExportedTypeDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ExportedTypeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ExportedTypeDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ExportedTypeDeclarationCollection Properties
ExportedTypeDeclarationCollection Class See Also Send Feedback

The ExportedTypeDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ExportedTypeDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldDefDeclarationCollection Class

FieldDefDeclarationCollection Class
Members See Also Send Feedback
Collection of FieldDefDeclaration objects.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FieldDefDeclarationCollection : UniquelyNamedPositionedDeclarationCollection<FieldDefDeclaration>,
    IFieldCollection, IEnumerable<IField>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PositionedDeclarationCollection<(Of <(<'?0>)>)>
UniquelyNamedPositionedDeclarationCollection<(Of <(<' FieldDefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.FieldDefDeclarationCollection

See Also

FieldDefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


FieldDefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
FieldDefDeclarationCollection Members
FieldDefDeclarationCollection Class Methods Properties See Also Send Feedback

The FieldDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetField | Finds a field in the type given its name and type.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldDefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
FieldDefDeclarationCollection Methods
FieldDefDeclarationCollection Class See Also Send Feedback

The FieldDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetField | Finds a field in the type given its name and type.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetField Method

FieldDefDeclarationCollection..::..GetField Method
FieldDefDeclarationCollection Class See Also Send Feedback
Finds a field in the type given its name and type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetField(
    string name,
    ITypeSignature type,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Field name.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Field type.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the field is not found.

Return Value

The field, or null if the method could not be found.

Implements

IFieldCollection..::.GetField(String, ITypeSignature, BindingOptions)

See Also

FieldDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldDefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
FieldDefDeclarationCollection Properties
FieldDefDeclarationCollection Class See Also Send Feedback

The FieldDefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldRefDeclarationCollection Class

FieldRefDeclarationCollection Class
Members See Also Send Feedback
Collection of FieldRefDeclaration objects.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FieldRefDeclarationCollection : UniquelyNamedElementCollection<FieldRefDeclaration>,
    IFieldCollection, IEnumerable<IField>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection <(Of <(<' FieldRefDeclaration >)>)>
UniquelyNamedElementCollection<(Of <(<' FieldRefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.FieldRefDeclarationCollection

See Also

FieldRefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


FieldRefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
FieldRefDeclarationCollection Members
FieldRefDeclarationCollection Class Methods Properties See Also Send Feedback

The FieldRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetField | Finds a field in the type given its name and type.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldRefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
FieldRefDeclarationCollection Methods
FieldRefDeclarationCollection Class See Also Send Feedback

The FieldRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetField | Finds a field in the type given its name and type.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetField Method

FieldRefDeclarationCollection..::..GetField Method
FieldRefDeclarationCollection Class See Also Send Feedback
Finds a field in the type given its name and type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IField GetField(
    string name,
    ITypeSignature type,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Field name.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Field type.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the field is not found.

Return Value

The field, or null if the method could not be found.

Implements

IFieldCollection..::.GetField(String, ITypeSignature, BindingOptions)

See Also

FieldRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


FieldRefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
FieldRefDeclarationCollection Properties
FieldRefDeclarationCollection Class See Also Send Feedback

The FieldRefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

FieldRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterConstraintDeclarationCollection Class

GenericParameterConstraintDeclarationCollection Class
Members See Also Send Feedback
Collection of GenericParameterConstraintDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericParameterConstraintDeclarationCollection : SimpleElementCollection<GenericParameterConstraintDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' GenericParameterConstraintDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.GenericParameterConstraintDeclarationCollection

See Also

GenericParameterConstraintDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterConstraintDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclarationCollection Members
GenericParameterConstraintDeclarationCollection Class Methods Properties See Also Send Feedback

The GenericParameterConstraintDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterConstraintDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterConstraintDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclarationCollection Methods
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback

The GenericParameterConstraintDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterConstraintDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclarationCollection..::..Add Method
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Add(ITypeSignature) | Adds a constraint to the current collection by specifying its type (ITypeSignature).

See Also

GenericParameterConstraintDeclarationCollection Class
GenericParameterConstraintDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method (ITypeSignature)

GenericParameterConstraintDeclarationCollection..::..Add Method (ITypeSignature)
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback
Adds a constraint to the current collection by specifying its type (ITypeSignature).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterConstraintDeclaration Add(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Constraint type.

Return Value

The GenericParameterConstraintDeclaration representing the new constraint.

See Also

GenericParameterConstraintDeclarationCollection Class
Add Overload
PostSharp.Sdk.CodeModel.Collections Namespace


AddRangeCloned Method

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclarationCollection..::..AddRangeCloned Method
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRangeCloned(ICollection<(Of <(?0>)>)) | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned(IEnumerable<(Of <(GenericParameterConstraintDeclaration>)>), GenericMap) | Clone a set of constraints and add them to the current collection after having mapped their generic arguments.

See Also

GenericParameterConstraintDeclarationCollection Class
GenericParameterConstraintDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


AddRangeCloned Method (IEnumerable(GenericParameterConstraintDeclaration), GenericMap)

GenericParameterConstraintDeclarationCollection..::..AddRangeCloned Method (IEnumerable<(Of <(<'GenericParameterConstraintDeclaration>)>)>, GenericMap)
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback
Clone a set of constraints and add them to the current collection after having mapped their generic arguments.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRangeCloned(
    IEnumerable<GenericParameterConstraintDeclaration> constraints,
    GenericMap genericMap
)

Parameters

constraints
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' GenericParameterConstraintDeclaration >)>)>
The set of constraints to be cloned and added to the current collection.
genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic map with which generic arguments in constraint types have to be mapped.

See Also

GenericParameterConstraintDeclarationCollection Class
AddRangeCloned Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterConstraintDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
GenericParameterConstraintDeclarationCollection Properties
GenericParameterConstraintDeclarationCollection Class See Also Send Feedback

The GenericParameterConstraintDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterConstraintDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterDeclarationCollection Class

GenericParameterDeclarationCollection Class
Members See Also Send Feedback
Collection of generic parameters (GenericParameterDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class GenericParameterDeclarationCollection : OrdinalDeclarationCollection<GenericParameterDeclaration>,
    IList<ITypeSignature>, ICollection<ITypeSignature>, IEnumerable<ITypeSignature>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
OrdinalDeclarationCollection<(Of <(<' GenericParameterDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.GenericParameterDeclarationCollection

See Also

GenericParameterDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
GenericParameterDeclarationCollection Members
GenericParameterDeclarationCollection Class Methods Properties See Also Send Feedback

The GenericParameterDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
GenericParameterDeclarationCollection Methods
GenericParameterDeclarationCollection Class See Also Send Feedback

The GenericParameterDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


DoLazyLoading Method

GenericParameterDeclarationCollection..::..DoLazyLoading Method
GenericParameterDeclarationCollection Class See Also Send Feedback
Loads the content of the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void DoLazyLoading()

See Also

GenericParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GenericParameterDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
GenericParameterDeclarationCollection Properties
GenericParameterDeclarationCollection Class See Also Send Feedback

The GenericParameterDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

GenericParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsLazyLoadingSupported Property

GenericParameterDeclarationCollection..::..IsLazyLoadingSupported Property
GenericParameterDeclarationCollection Class See Also Send Feedback
Determines if the current collection supports lazy loading.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override bool IsLazyLoadingSupported { get; }

Remarks

If a collection supports lazy loading, the method DoLazyLoading()()() should be implemented; it will be called before any access to the collection.

This property is evaluated before the collection constructor is invoked. Therefore, it is considered as static for the collection class.

See Also

GenericParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


IFieldCollection Interface

IFieldCollection Interface
Members See Also Send Feedback
Semantics of collections of fields as required by IType.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IFieldCollection : IEnumerable<IField>,
    IEnumerable

See Also

IFieldCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


IFieldCollection Members

[image]

PostSharp 2.0 Documentation
IFieldCollection Members
IFieldCollection Interface Methods See Also Send Feedback

The IFieldCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName | Gets a field given its name.
Public method | GetField | Finds a field in the type given its name and type.

See Also

IFieldCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


IFieldCollection Methods

[image]

PostSharp 2.0 Documentation
IFieldCollection Methods
IFieldCollection Interface See Also Send Feedback

The IFieldCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName | Gets a field given its name.
Public method | GetField | Finds a field in the type given its name and type.

See Also

IFieldCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


GetByName Method

IFieldCollection..::..GetByName Method
IFieldCollection Interface See Also Send Feedback
Gets a field given its name.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IField GetByName(
    string name
)

Parameters

name
Type: System..::.String
Field name.

Return Value

The field named name, or null if no such field exist in the collection.

See Also

IFieldCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


GetField Method

IFieldCollection..::..GetField Method
IFieldCollection Interface See Also Send Feedback
Finds a field in the type given its name and type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IField GetField(
    string name,
    ITypeSignature type,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Field name.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Field type.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the field is not found.

Return Value

The field, or null if the method could not be found.

See Also

IFieldCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


IMethodCollection Interface

IMethodCollection Interface
Members See Also Send Feedback
Semantics of collections of methods as required by IType.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMethodCollection : IEnumerable<IMethod>,
    IEnumerable

See Also

IMethodCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


IMethodCollection Members

[image]

PostSharp 2.0 Documentation
IMethodCollection Members
IMethodCollection Interface Methods See Also Send Feedback

The IMethodCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName | Gets a set of methods given their name.
Public method | GetMethod | Finds a method in the type given its name and signature.

See Also

IMethodCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


IMethodCollection Methods

[image]

PostSharp 2.0 Documentation
IMethodCollection Methods
IMethodCollection Interface See Also Send Feedback

The IMethodCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName | Gets a set of methods given their name.
Public method | GetMethod | Finds a method in the type given its name and signature.

See Also

IMethodCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


GetByName Method

IMethodCollection..::..GetByName Method
IMethodCollection Interface See Also Send Feedback
Gets a set of methods given their name.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<IMethod> GetByName(
    string name
)

Parameters

name
Type: System..::.String
Method name.

Return Value

The set of methods named name.

See Also

IMethodCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


GetMethod Method

IMethodCollection..::..GetMethod Method
IMethodCollection Interface See Also Send Feedback
Finds a method in the type given its name and signature.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IMethod GetMethod(
    string name,
    IMethodSignature signature,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Method name.
signature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Method signature.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the method is not found.

Return Value

The method, or null if the method could not be found.

See Also

IMethodCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


INamedTypeCollection Interface

INamedTypeCollection Interface
Members See Also Send Feedback
Semantics of collections of types as required by IType.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface INamedTypeCollection : IEnumerable<INamedType>,
    IEnumerable

See Also

INamedTypeCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


INamedTypeCollection Members

[image]

PostSharp 2.0 Documentation
INamedTypeCollection Members
INamedTypeCollection Interface Methods See Also Send Feedback

The INamedTypeCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName |

See Also

INamedTypeCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


INamedTypeCollection Methods

[image]

PostSharp 2.0 Documentation
INamedTypeCollection Methods
INamedTypeCollection Interface See Also Send Feedback

The INamedTypeCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetByName |

See Also

INamedTypeCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


GetByName Method

INamedTypeCollection..::..GetByName Method
INamedTypeCollection Interface See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.Collections.INamedTypeCollection.GetByName(System.String)"]

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
INamedType GetByName(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:PostSharp.Sdk.CodeModel.Collections.INamedTypeCollection.GetByName(System.String)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.Collections.INamedTypeCollection.GetByName(System.String)"]

See Also

INamedTypeCollection Interface
PostSharp.Sdk.CodeModel.Collections Namespace


InstructionBlockCollection Class

InstructionBlockCollection Class
See Also Send Feedback
Linked list of instruction blocks (InstructionBlock).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InstructionBlockCollection : LinkedList<InstructionBlock>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.LinkedList <(Of <(<' InstructionBlock >)>)>
PostSharp.Sdk.CodeModel.Collections..::.InstructionBlockCollection

See Also

PostSharp.Sdk.CodeModel.Collections Namespace


InterfaceImplementationDeclarationCollection Class

InterfaceImplementationDeclarationCollection Class
Members See Also Send Feedback
Collection of InterfaceImplementationDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class InterfaceImplementationDeclarationCollection : SimpleElementCollection<InterfaceImplementationDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' InterfaceImplementationDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.InterfaceImplementationDeclarationCollection

See Also

InterfaceImplementationDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


InterfaceImplementationDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclarationCollection Members
InterfaceImplementationDeclarationCollection Class Methods Properties See Also Send Feedback

The InterfaceImplementationDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

InterfaceImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


InterfaceImplementationDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclarationCollection Methods
InterfaceImplementationDeclarationCollection Class See Also Send Feedback

The InterfaceImplementationDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

InterfaceImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclarationCollection..::..Add Method
InterfaceImplementationDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Add(ITypeSignature) | Adds a new interface implementation to the current collection by only specifying the interface type.

See Also

InterfaceImplementationDeclarationCollection Class
InterfaceImplementationDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method (ITypeSignature)

InterfaceImplementationDeclarationCollection..::..Add Method (ITypeSignature)
InterfaceImplementationDeclarationCollection Class See Also Send Feedback
Adds a new interface implementation to the current collection by only specifying the interface type.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InterfaceImplementationDeclaration Add(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Interface type.

Return Value

The InterfaceImplementationDeclaration that has been created to encapsulate type.

See Also

InterfaceImplementationDeclarationCollection Class
Add Overload
PostSharp.Sdk.CodeModel.Collections Namespace


InterfaceImplementationDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
InterfaceImplementationDeclarationCollection Properties
InterfaceImplementationDeclarationCollection Class See Also Send Feedback

The InterfaceImplementationDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

InterfaceImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableDeclarationCollection Class

LocalVariableDeclarationCollection Class
Members See Also Send Feedback
Collection of local variables (LocalVariableDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocalVariableDeclarationCollection : OrdinalDeclarationCollection<LocalVariableDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
OrdinalDeclarationCollection<(Of <(<' LocalVariableDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.LocalVariableDeclarationCollection

See Also

LocalVariableDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
LocalVariableDeclarationCollection Members
LocalVariableDeclarationCollection Class Methods Properties See Also Send Feedback

The LocalVariableDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Determines whether the current collection of variables is read-only. (Overrides ElementCollection<(Of <(?0>)>)..::.IsReadOnly.)
Public property | OrdinalUpperBound | Upper bound of ordinals of local variables contained in this collection. The upper bound may not be reached.
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

LocalVariableDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
LocalVariableDeclarationCollection Methods
LocalVariableDeclarationCollection Class See Also Send Feedback

The LocalVariableDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

LocalVariableDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
LocalVariableDeclarationCollection Properties
LocalVariableDeclarationCollection Class See Also Send Feedback

The LocalVariableDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Determines whether the current collection of variables is read-only. (Overrides ElementCollection<(Of <(?0>)>)..::.IsReadOnly.)
Public property | OrdinalUpperBound | Upper bound of ordinals of local variables contained in this collection. The upper bound may not be reached.
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

LocalVariableDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsReadOnly Property

LocalVariableDeclarationCollection..::..IsReadOnly Property
LocalVariableDeclarationCollection Class See Also Send Feedback
Determines whether the current collection of variables is read-only.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool IsReadOnly { get; }

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

Remarks

A collection of local variables may be read-only if it is owned by a StandaloneSignatureDeclaration. This constraint is defined by PostSharp because, in this case, the collection is shared by many method bodies.

See Also

LocalVariableDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


OrdinalUpperBound Property

LocalVariableDeclarationCollection..::..OrdinalUpperBound Property
LocalVariableDeclarationCollection Class See Also Send Feedback
Upper bound of ordinals of local variables contained in this collection. The upper bound may not be reached.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int OrdinalUpperBound { get; private set; }

See Also

LocalVariableDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableSymbolCollection Class

LocalVariableSymbolCollection Class
Members See Also Send Feedback
Collection of local variable symbols (LocalVariableSymbol).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class LocalVariableSymbolCollection : Collection<LocalVariableSymbol>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' LocalVariableSymbol >)>)>
PostSharp.Sdk.CodeModel.Collections..::.LocalVariableSymbolCollection

See Also

LocalVariableSymbolCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableSymbolCollection Members

[image]

PostSharp 2.0 Documentation
LocalVariableSymbolCollection Members
LocalVariableSymbolCollection Class Methods See Also Send Feedback

The LocalVariableSymbolCollection type exposes the following members.

Methods

 | Name | Description
Public method | ToArray | Copies the current collection into a new array.

See Also

LocalVariableSymbolCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


LocalVariableSymbolCollection Methods

[image]

PostSharp 2.0 Documentation
LocalVariableSymbolCollection Methods
LocalVariableSymbolCollection Class See Also Send Feedback

The LocalVariableSymbolCollection type exposes the following members.

Methods

 | Name | Description
Public method | ToArray | Copies the current collection into a new array.

See Also

LocalVariableSymbolCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ToArray Method

LocalVariableSymbolCollection..::..ToArray Method
LocalVariableSymbolCollection Class See Also Send Feedback
Copies the current collection into a new array.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol[] ToArray()

Return Value

A new array containing the elements of the current collection.

See Also

LocalVariableSymbolCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestFileDeclarationCollection Class

ManifestFileDeclarationCollection Class
Members See Also Send Feedback
Collection of assembly manifestFiles (ManifestFileDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManifestFileDeclarationCollection : SimpleElementCollection<ManifestFileDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' ManifestFileDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ManifestFileDeclarationCollection

See Also

ManifestFileDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestFileDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ManifestFileDeclarationCollection Members
ManifestFileDeclarationCollection Class Methods Properties See Also Send Feedback

The ManifestFileDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestFileDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestFileDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ManifestFileDeclarationCollection Methods
ManifestFileDeclarationCollection Class See Also Send Feedback

The ManifestFileDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestFileDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestFileDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ManifestFileDeclarationCollection Properties
ManifestFileDeclarationCollection Class See Also Send Feedback

The ManifestFileDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestFileDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestResourceDeclarationCollection Class

ManifestResourceDeclarationCollection Class
Members See Also Send Feedback
Collection of resources (ManifestResourceDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ManifestResourceDeclarationCollection : SimpleElementCollection<ManifestResourceDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' ManifestResourceDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ManifestResourceDeclarationCollection

See Also

ManifestResourceDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestResourceDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclarationCollection Members
ManifestResourceDeclarationCollection Class Methods Properties See Also Send Feedback

The ManifestResourceDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestResourceDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestResourceDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclarationCollection Methods
ManifestResourceDeclarationCollection Class See Also Send Feedback

The ManifestResourceDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestResourceDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ManifestResourceDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ManifestResourceDeclarationCollection Properties
ManifestResourceDeclarationCollection Class See Also Send Feedback

The ManifestResourceDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ManifestResourceDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Class

MemberValuePairCollection Class
Members See Also Send Feedback
Collection of member-value pairs (MemberValuePair).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MemberValuePairCollection : IndexedCollection<MemberValuePair>,
    ICloneable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.IndexedCollection <(Of <(<' MemberValuePair >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MemberValuePairCollection

See Also

MemberValuePairCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Members

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection Members
MemberValuePairCollection Class Constructors Methods Properties See Also Send Feedback

The MemberValuePairCollection type exposes the following members.

Constructors

 | Name | Description
Public method | MemberValuePairCollection | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clone | Deeply clones the current collection.
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetRuntimeValue<(Of <(T>)>) | Overloaded.
Public method | GetValue<(Of <(T>)>) | Overloaded.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the collection has been disposed. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Item | Overloaded.

See Also

MemberValuePairCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Constructor

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection Constructor
MemberValuePairCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MemberValuePairCollection()()() | Initializes a new MemberValuePairCollection with default initial capacity.
Public method | MemberValuePairCollection(Int32) | Initializes a new MemberValuePairCollection and specifies the initial capacity.

See Also

MemberValuePairCollection Class
MemberValuePairCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Constructor

MemberValuePairCollection Constructor
MemberValuePairCollection Class See Also Send Feedback
Initializes a new MemberValuePairCollection with default initial capacity.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection()

See Also

MemberValuePairCollection Class
MemberValuePairCollection Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Constructor (Int32)

MemberValuePairCollection Constructor (Int32)
MemberValuePairCollection Class See Also Send Feedback
Initializes a new MemberValuePairCollection and specifies the initial capacity.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity.

See Also

MemberValuePairCollection Class
MemberValuePairCollection Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Methods

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection Methods
MemberValuePairCollection Class See Also Send Feedback

The MemberValuePairCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clone | Deeply clones the current collection.
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetRuntimeValue<(Of <(T>)>) | Overloaded.
Public method | GetValue<(Of <(T>)>) | Overloaded.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)

See Also

MemberValuePairCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Clone Method

MemberValuePairCollection..::..Clone Method
MemberValuePairCollection Class See Also Send Feedback
Deeply clones the current collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection Clone()

Return Value

A new MemberValuePairCollection containing clones of all members of the current collection.

See Also

MemberValuePairCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetRuntimeValue(T) Method

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection..::..GetRuntimeValue<(Of <(<'T>)>)> Method
MemberValuePairCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuntimeValue<(Of <(T>)>)(String) | Gets the runtime value of a given item of the collection, or returns the default value if the item is not defined.
Public method | GetRuntimeValue<(Of <(T>)>)(String, T) | Gets the runtime value of a given item of the collection, or returns a specified default value if the item is not defined.

See Also

MemberValuePairCollection Class
MemberValuePairCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GetRuntimeValue(T) Method (String)

MemberValuePairCollection..::..GetRuntimeValue<(Of <(<'T>)>)> Method (String)
MemberValuePairCollection Class See Also Send Feedback
Gets the runtime value of a given item of the collection, or returns the default value if the item is not defined.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public T GetRuntimeValue<T>(
    string name
)

Parameters

name
Type: System..::.String
Name of the item.

Type Parameters

T
Type of the runtime value.

Return Value

The value of item named name, or the default value of T.

See Also

MemberValuePairCollection Class
GetRuntimeValue<(Of <(T>)>) Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetRuntimeValue(T) Method (String, T)

MemberValuePairCollection..::..GetRuntimeValue<(Of <(<'T>)>)> Method (String, T)
MemberValuePairCollection Class See Also Send Feedback
Gets the runtime value of a given item of the collection, or returns a specified default value if the item is not defined.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public T GetRuntimeValue<T>(
    string name,
    T defaultValue
)

Parameters

name
Type: System..::.String
Name of the item.
defaultValue
Type: T
Default value.

Type Parameters

T
Type of the runtime value.

Return Value

The value of item named name, or defaultValue.

See Also

MemberValuePairCollection Class
GetRuntimeValue<(Of <(T>)>) Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetValue(T) Method

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection..::..GetValue<(Of <(<'T>)>)> Method
MemberValuePairCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <(T>)>)(String) | Gets the value of a given item of the collection, or returns the default value if the item is not defined.
Public method | GetValue<(Of <(T>)>)(String, T) | Gets the value of a given item of the collection, or returns a specified default value if the item is not defined.

See Also

MemberValuePairCollection Class
MemberValuePairCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GetValue(T) Method (String)

MemberValuePairCollection..::..GetValue<(Of <(<'T>)>)> Method (String)
MemberValuePairCollection Class See Also Send Feedback
Gets the value of a given item of the collection, or returns the default value if the item is not defined.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public T GetValue<T>(
    string name
)

Parameters

name
Type: System..::.String
Name of the item.

Type Parameters

T
Type of the value.

Return Value

The value of item named name, or the default value of T.

See Also

MemberValuePairCollection Class
GetValue<(Of <(T>)>) Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetValue(T) Method (String, T)

MemberValuePairCollection..::..GetValue<(Of <(<'T>)>)> Method (String, T)
MemberValuePairCollection Class See Also Send Feedback
Gets the value of a given item of the collection, or returns a specified default value if the item is not defined.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public T GetValue<T>(
    string name,
    T defaultValue
)

Parameters

name
Type: System..::.String
Name of the item.
defaultValue
Type: T
Default value.

Type Parameters

T
Type of the value.

Return Value

The value of item named name, or defaultValue.

See Also

MemberValuePairCollection Class
GetValue<(Of <(T>)>) Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MemberValuePairCollection Properties

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection Properties
MemberValuePairCollection Class See Also Send Feedback

The MemberValuePairCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the collection has been disposed. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Item | Overloaded.

See Also

MemberValuePairCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Item Property

[image]

PostSharp 2.0 Documentation
MemberValuePairCollection..::..Item Property
MemberValuePairCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([(Int32])]) | Gets a member given its ordinal.
Public property | Item[([(String])]) | Gets a member given its name.

See Also

MemberValuePairCollection Class
MemberValuePairCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Item Property (Int32)

MemberValuePairCollection..::..Item Property (Int32)
MemberValuePairCollection Class See Also Send Feedback
Gets a member given its ordinal.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePair Item[
    int ordinal
] { get; }

Parameters

ordinal
Type: System..::.Int32
Member ordinal.

Return Value

he MemberValuePair whose ordinal is ordinal, or null if it could not be found.

See Also

MemberValuePairCollection Class
Item Overload
PostSharp.Sdk.CodeModel.Collections Namespace


Item Property (String)

MemberValuePairCollection..::..Item Property (String)
MemberValuePairCollection Class See Also Send Feedback
Gets a member given its name.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePair Item[
    string name
] { get; }

Parameters

name
Type: System..::.String
Member name.

Return Value

he MemberValuePair whose name is name, or null if it could not be found.

See Also

MemberValuePairCollection Class
Item Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MetadataDeclarationDirectory(?0) Class

MetadataDeclarationDirectory<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Dictionary where keys are declarations (MetadataDeclaration). The implementation is partially thread-safe and is optimized to have low lock contention.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MetadataDeclarationDirectory<?0> : IDictionary<MetadataDeclaration, ?0>,
    ICollection<KeyValuePair<MetadataDeclaration, ?0>>, IEnumerable<KeyValuePair<MetadataDeclaration, ?0>>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.Collections.MetadataDeclarationDirectory`1"]

Remarks

This implementation does make the difference between an absent and a null item (or an item with default value, if T is a value type).

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.MetadataDeclarationDirectory<(Of <(?0>)>)

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel.Collections Namespace


MetadataDeclarationDirectory(?0) Members

[image]

PostSharp 2.0 Documentation
MetadataDeclarationDirectory<(Of <(<'?0>)>)> Members
MetadataDeclarationDirectory<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The MetadataDeclarationDirectory<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MetadataDeclarationDirectory<(Of <(?0>)>) | Initializes a new MetadataDeclarationDirectory<(Of <(?0>)>).

Methods

 | Name | Description
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | Remove | Overloaded.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets or sets the element with the specified key.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


MetadataDeclarationDirectory(?0) Constructor

MetadataDeclarationDirectory<(Of <(<'?0>)>)> Constructor
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MetadataDeclarationDirectory<(Of <(?0>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclarationDirectory(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module to which declarations should belong.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


MetadataDeclarationDirectory(?0) Methods

[image]

PostSharp 2.0 Documentation
MetadataDeclarationDirectory<(Of <(<'?0>)>)> Methods
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback

The MetadataDeclarationDirectory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | Remove | Overloaded.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Clear Method

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Clear Method
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ContainsKey Method

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..ContainsKey Method
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsKey(
    MetadataDeclaration key
)

Parameters

key
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The key to locate in the IDictionary<(Of <(TKey, TValue>)>).

Return Value

true if the IDictionary<(Of <(TKey, TValue>)>) contains an element with the key; otherwise, false.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


CopyTo Method

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..CopyTo Method
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    KeyValuePair<MetadataDeclaration, ?0>[] array,
    int arrayIndex
)

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <(<' MetadataDeclaration, ?0 >)>)> >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetEnumerator Method

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..GetEnumerator Method
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<KeyValuePair<MetadataDeclaration, ?0>> GetEnumerator()

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Remove Method
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(MetadataDeclaration) | Removes the element with the specified key from the IDictionary<(Of <(TKey, TValue>)>).
Public method | Remove(KeyValuePair<(Of <(MetadataDeclaration, ?0>)>)) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
MetadataDeclarationDirectory<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel.Collections Namespace


Remove Method (MetadataDeclaration)

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Remove Method (MetadataDeclaration)
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Removes the element with the specified key from the IDictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    MetadataDeclaration key
)

Parameters

key
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The key of the element to remove.

Return Value

true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionary<(Of <(TKey, TValue>)>).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Remove(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.
System..::.NotSupportedException | The IDictionary<(Of <(TKey, TValue>)>) is read-only.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
Remove Overload
PostSharp.Sdk.CodeModel.Collections Namespace


Remove Method (KeyValuePair(MetadataDeclaration, ?0))

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Remove Method (KeyValuePair<(Of <(<'MetadataDeclaration, ?0>)>)>)
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    KeyValuePair<MetadataDeclaration, ?0> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' MetadataDeclaration, ?0 >)>)>
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
Remove Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MetadataDeclarationDirectory(?0) Properties

[image]

PostSharp 2.0 Documentation
MetadataDeclarationDirectory<(Of <(<'?0>)>)> Properties
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback

The MetadataDeclarationDirectory<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets or sets the element with the specified key.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Count Property

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Count Property
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsReadOnly Property

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..IsReadOnly Property
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Item Property

MetadataDeclarationDirectory<(Of <(<'?0>)>)>..::..Item Property
MetadataDeclarationDirectory<(Of <(?0>)>) Class See Also Send Feedback
Gets or sets the element with the specified key.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Item[
    MetadataDeclaration key
] { get; set; }

Parameters

key
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The key of the element to get or set.

Return Value

The element with the specified key.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Item[([(TKey])])

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.
System.Collections.Generic..::.KeyNotFoundException | The property is retrieved and key is not found.
System..::.NotSupportedException | The property is set and the IDictionary<(Of <(TKey, TValue>)>) is read-only.

See Also

MetadataDeclarationDirectory<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodDefDeclarationCollection Class

MethodDefDeclarationCollection Class
Members See Also Send Feedback
Collection of methods (MethodDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodDefDeclarationCollection : NonUniquelyNamedPositionedDeclarationCollection<MethodDefDeclaration>,
    IMethodCollection, IEnumerable<IMethod>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PositionedDeclarationCollection<(Of <(<' MethodDefDeclaration >)>)>
NonUniquelyNamedPositionedDeclarationCollection<(Of <(<' MethodDefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MethodDefDeclarationCollection

See Also

MethodDefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MethodDefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
MethodDefDeclarationCollection Members
MethodDefDeclarationCollection Class Methods Properties See Also Send Feedback

The MethodDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetMethod | Finds a method in the type given its name and signature.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodDefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
MethodDefDeclarationCollection Methods
MethodDefDeclarationCollection Class See Also Send Feedback

The MethodDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetMethod | Finds a method in the type given its name and signature.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetMethod Method

MethodDefDeclarationCollection..::..GetMethod Method
MethodDefDeclarationCollection Class See Also Send Feedback
Finds a method in the type given its name and signature.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetMethod(
    string name,
    IMethodSignature signature,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Method name.
signature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Method signature.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the method is not found.

Return Value

The method, or null if the method could not be found.

Implements

IMethodCollection..::.GetMethod(String, IMethodSignature, BindingOptions)

See Also

MethodDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodDefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
MethodDefDeclarationCollection Properties
MethodDefDeclarationCollection Class See Also Send Feedback

The MethodDefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodImplementationDeclarationCollection Class

MethodImplementationDeclarationCollection Class
Members See Also Send Feedback
Collection of MethodImplementationDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodImplementationDeclarationCollection : SimpleElementCollection<MethodImplementationDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' MethodImplementationDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MethodImplementationDeclarationCollection

See Also

MethodImplementationDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MethodImplementationDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclarationCollection Members
MethodImplementationDeclarationCollection Class Methods Properties See Also Send Feedback

The MethodImplementationDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodImplementationDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclarationCollection Methods
MethodImplementationDeclarationCollection Class See Also Send Feedback

The MethodImplementationDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclarationCollection..::..Add Method
MethodImplementationDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Add(IMethod) | Adds a new method implementation to the current collection by specifying only the method.

See Also

MethodImplementationDeclarationCollection Class
MethodImplementationDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Add Method (IMethod)

MethodImplementationDeclarationCollection..::..Add Method (IMethod)
MethodImplementationDeclarationCollection Class See Also Send Feedback
Adds a new method implementation to the current collection by specifying only the method.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodImplementationDeclaration Add(
    IMethod method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.IMethod
The implemented method.

Return Value

The MethodImplementationDeclaration that has been created to encapsulate method and added to the current collection.

See Also

MethodImplementationDeclarationCollection Class
Add Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MethodImplementationDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
MethodImplementationDeclarationCollection Properties
MethodImplementationDeclarationCollection Class See Also Send Feedback

The MethodImplementationDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodImplementationDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodRefDeclarationCollection Class

MethodRefDeclarationCollection Class
Members See Also Send Feedback
Collection of method references (MethodRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodRefDeclarationCollection : NonUniquelyNamedElementCollection<MethodRefDeclaration>,
    IMethodCollection, IEnumerable<IMethod>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection <(Of <(<'?0>)>)>
NonUniquelyNamedElementCollection<(Of <(<' MethodRefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MethodRefDeclarationCollection

See Also

MethodRefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MethodRefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
MethodRefDeclarationCollection Members
MethodRefDeclarationCollection Class Methods Properties See Also Send Feedback

The MethodRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetMethod | Finds a method in the type given its name and signature.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodRefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
MethodRefDeclarationCollection Methods
MethodRefDeclarationCollection Class See Also Send Feedback

The MethodRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetMethod | Finds a method in the type given its name and signature.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetMethod Method

MethodRefDeclarationCollection..::..GetMethod Method
MethodRefDeclarationCollection Class See Also Send Feedback
Finds a method in the type given its name and signature.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod GetMethod(
    string name,
    IMethodSignature signature,
    BindingOptions bindingOptions
)

Parameters

name
Type: System..::.String
Method name.
signature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Method signature.
bindingOptions
Type: PostSharp.Sdk.CodeModel..::.BindingOptions
Determines the behavior in case the method is not found.

Return Value

The method, or null if the method could not be found.

Implements

IMethodCollection..::.GetMethod(String, IMethodSignature, BindingOptions)

See Also

MethodRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodRefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
MethodRefDeclarationCollection Properties
MethodRefDeclarationCollection Class See Also Send Feedback

The MethodRefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSemanticDeclarationCollection Class

MethodSemanticDeclarationCollection Class
Members See Also Send Feedback
Collection of method semantics (MethodSemanticDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSemanticDeclarationCollection : TokenOrderedDeclarationCollection<MethodSemanticDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' MethodSemanticDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' MethodSemanticDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MethodSemanticDeclarationCollection

See Also

MethodSemanticDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSemanticDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclarationCollection Members
MethodSemanticDeclarationCollection Class Methods Properties See Also Send Feedback

The MethodSemanticDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | Overloaded.
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetByMethod | Gets the MethodSemanticDeclaration corresponding to a given MethodDefDeclaration.
Public method | GetBySemantic | Gets the MethodSemanticDeclaration given its semantic (MethodSemantics).
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSemanticDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSemanticDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclarationCollection Methods
MethodSemanticDeclarationCollection Class See Also Send Feedback

The MethodSemanticDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | Overloaded.
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetByMethod | Gets the MethodSemanticDeclaration corresponding to a given MethodDefDeclaration.
Public method | GetBySemantic | Gets the MethodSemanticDeclaration given its semantic (MethodSemantics).
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSemanticDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


Contains Method

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclarationCollection..::..Contains Method
MethodSemanticDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains(MethodSemantics) | Determines whether the current collection contains a method with given semantic.

See Also

MethodSemanticDeclarationCollection Class
MethodSemanticDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


Contains Method (MethodSemantics)

MethodSemanticDeclarationCollection..::..Contains Method (MethodSemantics)
MethodSemanticDeclarationCollection Class See Also Send Feedback
Determines whether the current collection contains a method with given semantic.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Method semantic.

Return Value

true if the current collection contains at least one method with given semantic, otherwise false.

See Also

MethodSemanticDeclarationCollection Class
Contains Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetByMethod Method

MethodSemanticDeclarationCollection..::..GetByMethod Method
MethodSemanticDeclarationCollection Class See Also Send Feedback
Gets the MethodSemanticDeclaration corresponding to a given MethodDefDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemanticDeclaration GetByMethod(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A MethodDefDeclaration.

Return Value

The MethodSemanticDeclaration corresponding to method, or null if the current collection does not contain such item.

See Also

MethodSemanticDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetBySemantic Method

MethodSemanticDeclarationCollection..::..GetBySemantic Method
MethodSemanticDeclarationCollection Class See Also Send Feedback
Gets the MethodSemanticDeclaration given its semantic (MethodSemantics).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemanticDeclaration GetBySemantic(
    MethodSemantics semantic
)

Parameters

semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Method semantic.

Return Value

The MethodSemanticDeclaration whose semantic equals semantic, or null if the current collection does not contain a method with this semantic.

Remarks

If the collection contains more than one method with this semantic, the current method returns any arbitrary of them.

See Also

MethodSemanticDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSemanticDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
MethodSemanticDeclarationCollection Properties
MethodSemanticDeclarationCollection Class See Also Send Feedback

The MethodSemanticDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSemanticDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSpecDeclarationCollection Class

MethodSpecDeclarationCollection Class
Members See Also Send Feedback
Collection of method specifications (MethodSpecDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodSpecDeclarationCollection : SimpleElementCollection<MethodSpecDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' MethodSpecDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.MethodSpecDeclarationCollection

See Also

MethodSpecDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSpecDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
MethodSpecDeclarationCollection Members
MethodSpecDeclarationCollection Class Methods Properties See Also Send Feedback

The MethodSpecDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetGenericInstance | Overloaded.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSpecDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
MethodSpecDeclarationCollection Methods
MethodSpecDeclarationCollection Class See Also Send Feedback

The MethodSpecDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetGenericInstance | Overloaded.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetGenericInstance Method

[image]

PostSharp 2.0 Documentation
MethodSpecDeclarationCollection..::..GetGenericInstance Method
MethodSpecDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGenericInstance(IList<(Of <(ITypeSignature>)>)) | Gets a generic instance of the generic method that owns this collection but does not create the generic instance if it does not exist.
Public method | GetGenericInstance(IList<(Of <(ITypeSignature>)>), Boolean) | Gets a generic instance of the generic method that owns this collection and specifies whether to create the generic instance if it does not exist.

See Also

MethodSpecDeclarationCollection Class
MethodSpecDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GetGenericInstance Method (IList(ITypeSignature))

MethodSpecDeclarationCollection..::..GetGenericInstance Method (IList<(Of <(<'ITypeSignature>)>)>)
MethodSpecDeclarationCollection Class See Also Send Feedback
Gets a generic instance of the generic method that owns this collection but does not create the generic instance if it does not exist.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclaration GetGenericInstance(
    IList<ITypeSignature> genericArguments
)

Parameters

genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic arguments.

Return Value

A generic instance of the owner method constructed with genericArguments, or null if this generic instance does not exist.

See Also

MethodSpecDeclarationCollection Class
GetGenericInstance Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetGenericInstance Method (IList(ITypeSignature), Boolean)

MethodSpecDeclarationCollection..::..GetGenericInstance Method (IList<(Of <(<'ITypeSignature>)>)>, Boolean)
MethodSpecDeclarationCollection Class See Also Send Feedback
Gets a generic instance of the generic method that owns this collection and specifies whether to create the generic instance if it does not exist.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSpecDeclaration GetGenericInstance(
    IList<ITypeSignature> genericArguments,
    bool create
)

Parameters

genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
Generic arguments.
create
Type: System..::.Boolean
Whether the generic instance should be created if it does not exist.

Return Value

A generic instance of the owner method constructed with genericArguments, or null if this generic instance does not exist and the create parameter is false.

See Also

MethodSpecDeclarationCollection Class
GetGenericInstance Overload
PostSharp.Sdk.CodeModel.Collections Namespace


MethodSpecDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
MethodSpecDeclarationCollection Properties
MethodSpecDeclarationCollection Class See Also Send Feedback

The MethodSpecDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

MethodSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleDeclarationCollection Class

ModuleDeclarationCollection Class
Members See Also Send Feedback
Collection of modules (ModuleDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ModuleDeclarationCollection : UniquelyNamedElementCollection<ModuleDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection <(Of <(<' ModuleDeclaration >)>)>
UniquelyNamedElementCollection<(Of <(<' ModuleDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ModuleDeclarationCollection

See Also

ModuleDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ModuleDeclarationCollection Members
ModuleDeclarationCollection Class Methods Properties See Also Send Feedback

The ModuleDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ModuleDeclarationCollection Methods
ModuleDeclarationCollection Class See Also Send Feedback

The ModuleDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ModuleDeclarationCollection Properties
ModuleDeclarationCollection Class See Also Send Feedback

The ModuleDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleRefDeclarationCollection Class

ModuleRefDeclarationCollection Class
Members See Also Send Feedback
Collection of module references (ModuleRefDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ModuleRefDeclarationCollection : UniquelyNamedTokenOrderedDeclarationCollection<ModuleRefDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' ModuleRefDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' ModuleRefDeclaration >)>)>
UniquelyNamedTokenOrderedDeclarationCollection<(Of <(<' ModuleRefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ModuleRefDeclarationCollection

See Also

ModuleRefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleRefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ModuleRefDeclarationCollection Members
ModuleRefDeclarationCollection Class Methods Properties See Also Send Feedback

The ModuleRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleRefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ModuleRefDeclarationCollection Methods
ModuleRefDeclarationCollection Class See Also Send Feedback

The ModuleRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ModuleRefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ModuleRefDeclarationCollection Properties
ModuleRefDeclarationCollection Class See Also Send Feedback

The ModuleRefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ModuleRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


NamedElementCollection(?0) Class

NamedElementCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Base class for collections of elements having a name, with an index on the Name property.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class NamedElementCollection<?0> : ElementCollection<?0>
where ?0 : Element, INamed

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.Collections.NamedElementCollection`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection<(Of <(?0>)>)

See Also

NamedElementCollection<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel.Collections Namespace


NamedElementCollection(?0) Members

[image]

PostSharp 2.0 Documentation
NamedElementCollection<(Of <(<'?0>)>)> Members
NamedElementCollection<(Of <(?0>)>) Class Methods Properties See Also Send Feedback

The NamedElementCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | Implementation | Gets the underlying implementation (an Index<(Of <(?0, ?1>)>)).
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

NamedElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


NamedElementCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
NamedElementCollection<(Of <(<'?0>)>)> Methods
NamedElementCollection<(Of <(?0>)>) Class See Also Send Feedback

The NamedElementCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

NamedElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


NamedElementCollection(?0) Properties

[image]

PostSharp 2.0 Documentation
NamedElementCollection<(Of <(<'?0>)>)> Properties
NamedElementCollection<(Of <(?0>)>) Class See Also Send Feedback

The NamedElementCollection<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | Implementation | Gets the underlying implementation (an Index<(Of <(?0, ?1>)>)).
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

NamedElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


Implementation Property

NamedElementCollection<(Of <(<'?0>)>)>..::..Implementation Property
NamedElementCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the underlying implementation (an Index<(Of <(?0, ?1>)>)).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Index<string, ?0> Implementation { get; }

See Also

NamedElementCollection<(Of <(?0>)>) Class
PostSharp.Sdk.CodeModel.Collections Namespace


ParameterDeclarationCollection Class

ParameterDeclarationCollection Class
Members See Also Send Feedback
Collection of parameters (ParameterDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class ParameterDeclarationCollection : OrdinalDeclarationCollection<ParameterDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
OrdinalDeclarationCollection<(Of <(<' ParameterDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.ParameterDeclarationCollection

See Also

ParameterDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


ParameterDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
ParameterDeclarationCollection Members
ParameterDeclarationCollection Class Methods Properties See Also Send Feedback

The ParameterDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ParameterDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
ParameterDeclarationCollection Methods
ParameterDeclarationCollection Class See Also Send Feedback

The ParameterDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


DoLazyLoading Method

ParameterDeclarationCollection..::..DoLazyLoading Method
ParameterDeclarationCollection Class See Also Send Feedback
Loads the content of the collection.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void DoLazyLoading()

See Also

ParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


ParameterDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
ParameterDeclarationCollection Properties
ParameterDeclarationCollection Class See Also Send Feedback

The ParameterDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

ParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


IsLazyLoadingSupported Property

ParameterDeclarationCollection..::..IsLazyLoadingSupported Property
ParameterDeclarationCollection Class See Also Send Feedback
Determines if the current collection supports lazy loading.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override bool IsLazyLoadingSupported { get; }

Remarks

If a collection supports lazy loading, the method DoLazyLoading()()() should be implemented; it will be called before any access to the collection.

This property is evaluated before the collection constructor is invoked. Therefore, it is considered as static for the collection class.

See Also

ParameterDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionDeclarationCollection Class

PermissionDeclarationCollection Class
Members See Also Send Feedback
Collection of permission attributes (PermissionDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PermissionDeclarationCollection : SimpleElementCollection<PermissionDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
SimpleElementCollection<(Of <(<' PermissionDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.PermissionDeclarationCollection

See Also

PermissionDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
PermissionDeclarationCollection Members
PermissionDeclarationCollection Class Methods Properties See Also Send Feedback

The PermissionDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
PermissionDeclarationCollection Methods
PermissionDeclarationCollection Class See Also Send Feedback

The PermissionDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
PermissionDeclarationCollection Properties
PermissionDeclarationCollection Class See Also Send Feedback

The PermissionDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionSetDeclarationCollection Class

PermissionSetDeclarationCollection Class
Members See Also Send Feedback
Collection of permission sets (PermissionSetDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PermissionSetDeclarationCollection : TokenOrderedDeclarationCollection<PermissionSetDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' PermissionSetDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' PermissionSetDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.PermissionSetDeclarationCollection

See Also

PermissionSetDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionSetDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
PermissionSetDeclarationCollection Members
PermissionSetDeclarationCollection Class Methods Properties See Also Send Feedback

The PermissionSetDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionSetDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionSetDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
PermissionSetDeclarationCollection Methods
PermissionSetDeclarationCollection Class See Also Send Feedback

The PermissionSetDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionSetDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PermissionSetDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
PermissionSetDeclarationCollection Properties
PermissionSetDeclarationCollection Class See Also Send Feedback

The PermissionSetDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PermissionSetDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PropertyDeclarationCollection Class

PropertyDeclarationCollection Class
Members See Also Send Feedback
Collection of properties (PropertyDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PropertyDeclarationCollection : NonUniquelyNamedTokenOrderedDeclarationCollection<PropertyDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
TokenOrderedDeclarationCollection<(Of <(<'?0>)>)>
NonUniquelyNamedTokenOrderedDeclarationCollection<(Of <(<' PropertyDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.PropertyDeclarationCollection

See Also

PropertyDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


PropertyDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
PropertyDeclarationCollection Members
PropertyDeclarationCollection Class Methods Properties See Also Send Feedback

The PropertyDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetProperty | Gets a property given its name and the signature of its get accessor.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PropertyDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PropertyDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
PropertyDeclarationCollection Methods
PropertyDeclarationCollection Class See Also Send Feedback

The PropertyDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetProperty | Gets a property given its name and the signature of its get accessor.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PropertyDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetProperty Method

PropertyDeclarationCollection..::..GetProperty Method
PropertyDeclarationCollection Class See Also Send Feedback
Gets a property given its name and the signature of its get accessor.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyDeclaration GetProperty(
    string name,
    IMethodSignature getterSignature,
    IMethodSignature setterSignature
)

Parameters

name
Type: System..::.String
Property name.
getterSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Signature of the get accessor.
setterSignature
Type: PostSharp.Sdk.CodeModel..::.IMethodSignature
Signature of the set accessor.

Return Value

The property named name whose get accessor has the signature getterSignature and set accessor has the signature setterSignature, or null if there no such a property.

See Also

PropertyDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PropertyDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
PropertyDeclarationCollection Properties
PropertyDeclarationCollection Class See Also Send Feedback

The PropertyDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

PropertyDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


StandaloneSignatureDeclarationCollection Class

StandaloneSignatureDeclarationCollection Class
Members See Also Send Feedback
Collection of StandaloneSignatureDeclaration.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class StandaloneSignatureDeclarationCollection : ElementCollection<StandaloneSignatureDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' StandaloneSignatureDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.StandaloneSignatureDeclarationCollection

See Also

StandaloneSignatureDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


StandaloneSignatureDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclarationCollection Members
StandaloneSignatureDeclarationCollection Class Methods Properties See Also Send Feedback

The StandaloneSignatureDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

StandaloneSignatureDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


StandaloneSignatureDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclarationCollection Methods
StandaloneSignatureDeclarationCollection Class See Also Send Feedback

The StandaloneSignatureDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

StandaloneSignatureDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


StandaloneSignatureDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
StandaloneSignatureDeclarationCollection Properties
StandaloneSignatureDeclarationCollection Class See Also Send Feedback

The StandaloneSignatureDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

StandaloneSignatureDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeDefDeclarationCollection Class

TypeDefDeclarationCollection Class
Members See Also Send Feedback
Collection of types (TypeDefDeclaration).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeDefDeclarationCollection : UniquelyNamedTokenOrderedDeclarationCollection<TypeDefDeclaration>,
    INamedTypeCollection, IEnumerable<INamedType>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' TypeDefDeclaration >)>)>
TokenOrderedDeclarationCollection<(Of <(<' TypeDefDeclaration >)>)>
UniquelyNamedTokenOrderedDeclarationCollection<(Of <(<' TypeDefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.TypeDefDeclarationCollection

See Also

TypeDefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


TypeDefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
TypeDefDeclarationCollection Members
TypeDefDeclarationCollection Class Methods Properties See Also Send Feedback

The TypeDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeDefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
TypeDefDeclarationCollection Methods
TypeDefDeclarationCollection Class See Also Send Feedback

The TypeDefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeDefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
TypeDefDeclarationCollection Properties
TypeDefDeclarationCollection Class See Also Send Feedback

The TypeDefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeDefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeRefDeclarationCollection Class

TypeRefDeclarationCollection Class
Members See Also Send Feedback
Collection of type references (TypeRefDeclarationCollection).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeRefDeclarationCollection : UniquelyNamedElementCollection<TypeRefDeclaration>,
    INamedTypeCollection, IEnumerable<INamedType>, IEnumerable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<'?0>)>)>
PostSharp.Sdk.CodeModel.Collections..::.NamedElementCollection <(Of <(<' TypeRefDeclaration >)>)>
UniquelyNamedElementCollection<(Of <(<' TypeRefDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.TypeRefDeclarationCollection

See Also

TypeRefDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


TypeRefDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
TypeRefDeclarationCollection Members
TypeRefDeclarationCollection Class Methods Properties See Also Send Feedback

The TypeRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeRefDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
TypeRefDeclarationCollection Methods
TypeRefDeclarationCollection Class See Also Send Feedback

The TypeRefDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeRefDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
TypeRefDeclarationCollection Properties
TypeRefDeclarationCollection Class See Also Send Feedback

The TypeRefDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeRefDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeSpecDeclarationCollection Class

TypeSpecDeclarationCollection Class
Members See Also Send Feedback
Collection of type specifications (TypeSpecDeclarationCollection).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeSpecDeclarationCollection : ElementCollection<TypeSpecDeclaration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' TypeSpecDeclaration >)>)>
PostSharp.Sdk.CodeModel.Collections..::.TypeSpecDeclarationCollection

See Also

TypeSpecDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


TypeSpecDeclarationCollection Members

[image]

PostSharp 2.0 Documentation
TypeSpecDeclarationCollection Members
TypeSpecDeclarationCollection Class Methods Properties See Also Send Feedback

The TypeSpecDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetBySignature | Overloaded.
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetSiblingsBySignature | Gets all type specifications corresponding to a given IType.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeSpecDeclarationCollection Methods

[image]

PostSharp 2.0 Documentation
TypeSpecDeclarationCollection Methods
TypeSpecDeclarationCollection Class See Also Send Feedback

The TypeSpecDeclarationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetBySignature | Overloaded.
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetSiblingsBySignature | Gets all type specifications corresponding to a given IType.
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


GetBySignature Method

[image]

PostSharp 2.0 Documentation
TypeSpecDeclarationCollection..::..GetBySignature Method
TypeSpecDeclarationCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBySignature(ITypeSignature) | Gets the type specification corresponding to a given IType but does not create it if it is not found.
Public method | GetBySignature(ITypeSignature, Boolean) | Gets the type specification corresponding to a given IType and specifies whether to create it if it is not found.

See Also

TypeSpecDeclarationCollection Class
TypeSpecDeclarationCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


GetBySignature Method (ITypeSignature)

TypeSpecDeclarationCollection..::..GetBySignature Method (ITypeSignature)
TypeSpecDeclarationCollection Class See Also Send Feedback
Gets the type specification corresponding to a given IType but does not create it if it is not found.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSpecDeclaration GetBySignature(
    ITypeSignature signature
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A IType.

Return Value

The TypeSpecDeclaration corresponding to signature, or null if no type specification in the collection corresponds to the current signature.

See Also

TypeSpecDeclarationCollection Class
GetBySignature Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetBySignature Method (ITypeSignature, Boolean)

TypeSpecDeclarationCollection..::..GetBySignature Method (ITypeSignature, Boolean)
TypeSpecDeclarationCollection Class See Also Send Feedback
Gets the type specification corresponding to a given IType and specifies whether to create it if it is not found.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeSpecDeclaration GetBySignature(
    ITypeSignature signature,
    bool create
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A IType.
create
Type: System..::.Boolean
Whether the TypeSpecDeclaration should be created if not found.

Return Value

The TypeSpecDeclaration corresponding to signature, or null if no type specification in the collection corresponds to the current signature and the create parameter is false.

See Also

TypeSpecDeclarationCollection Class
GetBySignature Overload
PostSharp.Sdk.CodeModel.Collections Namespace


GetSiblingsBySignature Method

TypeSpecDeclarationCollection..::..GetSiblingsBySignature Method
TypeSpecDeclarationCollection Class See Also Send Feedback
Gets all type specifications corresponding to a given IType.

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerable<TypeSpecDeclaration> GetSiblingsBySignature(
    ITypeSignature signature
)

Parameters

signature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A IType.

Return Value

The set of TypeSpecDeclaration instances corresponding to signature, or an empty collection if no type specification in the collection corresponds to signature.

See Also

TypeSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


TypeSpecDeclarationCollection Properties

[image]

PostSharp 2.0 Documentation
TypeSpecDeclarationCollection Properties
TypeSpecDeclarationCollection Class See Also Send Feedback

The TypeSpecDeclarationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

TypeSpecDeclarationCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


UnmanagedResourceCollection Class

UnmanagedResourceCollection Class
Members See Also Send Feedback
Collection of unmanaged resources (UnmanagedResource).

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class UnmanagedResourceCollection : Collection<UnmanagedResource>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' UnmanagedResource >)>)>
PostSharp.Sdk.CodeModel.Collections..::.UnmanagedResourceCollection

See Also

UnmanagedResourceCollection Members
PostSharp.Sdk.CodeModel.Collections Namespace


UnmanagedResourceCollection Members

[image]

PostSharp 2.0 Documentation
UnmanagedResourceCollection Members
UnmanagedResourceCollection Class Constructors See Also Send Feedback

The UnmanagedResourceCollection type exposes the following members.

Constructors

 | Name | Description
Public method | UnmanagedResourceCollection | Initializes a new instance of the UnmanagedResourceCollection class

See Also

UnmanagedResourceCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


UnmanagedResourceCollection Constructor

UnmanagedResourceCollection Constructor
UnmanagedResourceCollection Class See Also Send Feedback
Initializes a new instance of the UnmanagedResourceCollection class

Namespace: PostSharp.Sdk.CodeModel.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedResourceCollection()

See Also

UnmanagedResourceCollection Class
PostSharp.Sdk.CodeModel.Collections Namespace


PostSharp.Sdk.CodeModel.Helpers Namespace

PostSharp.Sdk.CodeModel.Helpers Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.Helpers namespace contains utility classes to make work with the PostSharp.Sdk.CodeModel easier.

Classes

 | Class | Description
Public class | DelegateBuilder | Helps to build a TypeDefDeclaration implementing a delegate.
Public class | DelegateSignature | Represents a delegate signature.
Public class | EnumHelper | Helps to work with enumerations.
Public class | GenericParameterReferenceFinder | Provides a method that enumerates generic arguments (i.e. references to generic parameters) in type of method signatures.
Public class | InterfaceHelper | Provides helper methods to work with interfaces.


DelegateBuilder Class

DelegateBuilder Class
Members See Also Send Feedback
Helps to build a TypeDefDeclaration implementing a delegate.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class DelegateBuilder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Helpers..::.DelegateBuilder

See Also

DelegateBuilder Members
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateBuilder Members

[image]

PostSharp 2.0 Documentation
DelegateBuilder Members
DelegateBuilder Class Methods See Also Send Feedback

The DelegateBuilder type exposes the following members.

Methods

Name | Description
BuildDelegate | Builds a TypeDefDeclaration implementing a delegate.

See Also

DelegateBuilder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateBuilder Methods

[image]

PostSharp 2.0 Documentation
DelegateBuilder Methods
DelegateBuilder Class See Also Send Feedback

The DelegateBuilder type exposes the following members.

Methods

Name | Description
BuildDelegate | Builds a TypeDefDeclaration implementing a delegate.

See Also

DelegateBuilder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


BuildDelegate Method

DelegateBuilder..::..BuildDelegate Method
DelegateBuilder Class See Also Send Feedback
Builds a TypeDefDeclaration implementing a delegate.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeDefDeclaration BuildDelegate(
    ITypeContainer typeContainer,
    string name,
    DelegateSignature delegateSignature
)

Parameters

typeContainer
Type: PostSharp.Sdk.CodeModel..::.ITypeContainer
Declaration to which the TypeDefDeclaration should be added.
name
Type: System..::.String
Type name.
delegateSignature
Type: PostSharp.Sdk.CodeModel.Helpers..::.DelegateSignature
Delegate signature.

Return Value

A TypeDefDeclaration implementing the delegate.

Remarks

It seems that Microsoft's runtime engine requires delegates to be derived from MulticastDelegate.

See Also

DelegateBuilder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateSignature Class

DelegateSignature Class
Members See Also Send Feedback
Represents a delegate signature.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DelegateSignature : Declaration,
    IEquatable<DelegateSignature>

Remarks

The types used to define a signature can be valid inside a different module than the one into which the delegate shall be generated. The DelegateBuilder utility translates types automatically.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.CodeModel.Helpers..::.DelegateSignature

See Also

DelegateSignature Members
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateSignature Members

[image]

PostSharp 2.0 Documentation
DelegateSignature Members
DelegateSignature Class Constructors Methods Properties See Also Send Feedback

The DelegateSignature type exposes the following members.

Constructors

 | Name | Description
Public method | DelegateSignature | Initializes a new DelegateSignature.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameters | Gets the list of generic parameters.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parameters | Gets the list of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ReturnType | Gets or sets the delegate return type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateSignature Constructor

DelegateSignature Constructor
DelegateSignature Class See Also Send Feedback
Initializes a new DelegateSignature.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DelegateSignature(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the signature should be valid.

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateSignature Methods

[image]

PostSharp 2.0 Documentation
DelegateSignature Methods
DelegateSignature Class See Also Send Feedback

The DelegateSignature type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | Equals | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
DelegateSignature..::..Equals Method
DelegateSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Public method | Equals(DelegateSignature) | Indicates whether the current object is equal to another object of the same type.

See Also

DelegateSignature Class
DelegateSignature Members
PostSharp.Sdk.CodeModel.Helpers Namespace


Equals Method (Object)

DelegateSignature..::..Equals Method (Object)
DelegateSignature Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

DelegateSignature Class
Equals Overload
PostSharp.Sdk.CodeModel.Helpers Namespace


Equals Method (DelegateSignature)

DelegateSignature..::..Equals Method (DelegateSignature)
DelegateSignature Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    DelegateSignature other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel.Helpers..::.DelegateSignature
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

DelegateSignature Class
Equals Overload
PostSharp.Sdk.CodeModel.Helpers Namespace


GetHashCode Method

DelegateSignature..::..GetHashCode Method
DelegateSignature Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A hash code for the current Object.

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


DelegateSignature Properties

[image]

PostSharp 2.0 Documentation
DelegateSignature Properties
DelegateSignature Class See Also Send Feedback

The DelegateSignature type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | GenericParameters | Gets the list of generic parameters.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parameters | Gets the list of parameters.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ReturnType | Gets or sets the delegate return type.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GenericParameters Property

DelegateSignature..::..GenericParameters Property
DelegateSignature Class See Also Send Feedback
Gets the list of generic parameters.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterDeclarationCollection GenericParameters { get; }

Remarks

Generic parameters present in this list may be owned by other entities. It is not necessary to clone them before adding it to this collection.

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


Parameters Property

DelegateSignature..::..Parameters Property
DelegateSignature Class See Also Send Feedback
Gets the list of parameters.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ParameterDeclarationCollection Parameters { get; }

Remarks

Parameters present in this list may be owned by other entities. It is not necessary to clone them before adding it to this collection.

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


ReturnType Property

DelegateSignature..::..ReturnType Property
DelegateSignature Class See Also Send Feedback
Gets or sets the delegate return type.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature ReturnType { get; set; }

See Also

DelegateSignature Class
PostSharp.Sdk.CodeModel.Helpers Namespace


EnumHelper Class

EnumHelper Class
Members See Also Send Feedback
Helps to work with enumerations.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class EnumHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Helpers..::.EnumHelper

See Also

EnumHelper Members
PostSharp.Sdk.CodeModel.Helpers Namespace


EnumHelper Members

[image]

PostSharp 2.0 Documentation
EnumHelper Members
EnumHelper Class Methods See Also Send Feedback

The EnumHelper type exposes the following members.

Methods

Name | Description
GetUnderlyingType | Gets the underlying type of an enumeration.

See Also

EnumHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


EnumHelper Methods

[image]

PostSharp 2.0 Documentation
EnumHelper Methods
EnumHelper Class See Also Send Feedback

The EnumHelper type exposes the following members.

Methods

Name | Description
GetUnderlyingType | Gets the underlying type of an enumeration.

See Also

EnumHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GetUnderlyingType Method

EnumHelper..::..GetUnderlyingType Method
EnumHelper Class See Also Send Feedback
Gets the underlying type of an enumeration.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IntrinsicTypeSignature GetUnderlyingType(
    IType type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.IType
A type derived from Enum.

Return Value

The underlying type of the enumeration.

See Also

EnumHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GenericParameterReferenceFinder Class

GenericParameterReferenceFinder Class
Members See Also Send Feedback
Provides a method that enumerates generic arguments (i.e. references to generic parameters) in type of method signatures.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericParameterReferenceFinder

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Helpers..::.GenericParameterReferenceFinder

See Also

GenericParameterReferenceFinder Members
PostSharp.Sdk.CodeModel.Helpers Namespace


GenericParameterReferenceFinder Members

[image]

PostSharp 2.0 Documentation
GenericParameterReferenceFinder Members
GenericParameterReferenceFinder Class Methods See Also Send Feedback

The GenericParameterReferenceFinder type exposes the following members.

Methods

Name | Description
GetGenericParameterReferenceEnumerator | Enumerates generic arguments (i.e. references to generic parameters) in type of method signatures.

See Also

GenericParameterReferenceFinder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GenericParameterReferenceFinder Methods

[image]

PostSharp 2.0 Documentation
GenericParameterReferenceFinder Methods
GenericParameterReferenceFinder Class See Also Send Feedback

The GenericParameterReferenceFinder type exposes the following members.

Methods

Name | Description
GetGenericParameterReferenceEnumerator | Enumerates generic arguments (i.e. references to generic parameters) in type of method signatures.

See Also

GenericParameterReferenceFinder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GetGenericParameterReferenceEnumerator Method

GenericParameterReferenceFinder..::..GetGenericParameterReferenceEnumerator Method
GenericParameterReferenceFinder Class See Also Send Feedback
Enumerates generic arguments (i.e. references to generic parameters) in type of method signatures.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<GenericParameterTypeSignature> GetGenericParameterReferenceEnumerator(
    IVisitable<ITypeSignature> visitable
)

Parameters

visitable
Type: PostSharp.Sdk.Collections..::.IVisitable <(Of <(<' ITypeSignature >)>)>
The signature to traverse.

Return Value

An enumerator over GenericParameterTypeSignature occurrences in visitable.

See Also

GenericParameterReferenceFinder Class
PostSharp.Sdk.CodeModel.Helpers Namespace


InterfaceHelper Class

InterfaceHelper Class
Members See Also Send Feedback
Provides helper methods to work with interfaces.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class InterfaceHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Helpers..::.InterfaceHelper

See Also

InterfaceHelper Members
PostSharp.Sdk.CodeModel.Helpers Namespace


InterfaceHelper Members

[image]

PostSharp 2.0 Documentation
InterfaceHelper Members
InterfaceHelper Class Methods See Also Send Feedback

The InterfaceHelper type exposes the following members.

Methods

Name | Description
GetAllImplementedInterfaces | Gets the set of all interfaces implemented by a given type.

See Also

InterfaceHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


InterfaceHelper Methods

[image]

PostSharp 2.0 Documentation
InterfaceHelper Methods
InterfaceHelper Class See Also Send Feedback

The InterfaceHelper type exposes the following members.

Methods

Name | Description
GetAllImplementedInterfaces | Gets the set of all interfaces implemented by a given type.

See Also

InterfaceHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


GetAllImplementedInterfaces Method

InterfaceHelper..::..GetAllImplementedInterfaces Method
InterfaceHelper Class See Also Send Feedback
Gets the set of all interfaces implemented by a given type.

Namespace: PostSharp.Sdk.CodeModel.Helpers
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Set<ITypeSignature> GetAllImplementedInterfaces(
    ITypeSignature type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type.

Return Value

The set of all interfaces implemented by type.

See Also

InterfaceHelper Class
PostSharp.Sdk.CodeModel.Helpers Namespace


PostSharp.Sdk.CodeModel.MarshalTypes Namespace

PostSharp.Sdk.CodeModel.MarshalTypes Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.MarshalTypes namespace defines classes representing P-Invoke types.

Classes

 | Class | Description
Public class | ArrayMarshalType | Represents the type of an unmanaged LPArray, i.e. a pointer to a standard C array.
Public class | CustomMarshallerMarshalType | Special MarshalType meaning that a custom marshaller should be used.
Public class | FixedArrayMarshalType | Represents the type of an unmanaged array with fixed number of elements, passed by value.
Public class | FixedStringMarshalType | Represents the type of an unmanaged string passed by value.
Public class | IntrinsicMarshalType | Represents the type of an intrinsic unmanaged scalar.
Public class | SafeArrayMarshalType | Represents the type of an unmanaged Safe Array.


ArrayMarshalType Class

ArrayMarshalType Class
Members See Also Send Feedback
Represents the type of an unmanaged LPArray, i.e. a pointer to a standard C array.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ArrayMarshalType : MarshalType

Remarks

The number of elements in the array is determined by the following formula:
  • If AdditionalSize = 0, the size is ArraySizeParameterIndex.
  • Otherwise, the size is @AdditionalSize + ArraySizeParameterIndex, where @AdditionalSize is the value of the parameter whose 0-based index is AdditionalSize-1.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.ArrayMarshalType

See Also

ArrayMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ArrayMarshalType Members

[image]

PostSharp 2.0 Documentation
ArrayMarshalType Members
ArrayMarshalType Class Constructors Fields Properties See Also Send Feedback

The ArrayMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | ArrayMarshalType | Initializes a new instance of ArrayMarshalType.

Fields

Name | Description
UnknownElementType | When applies to the ElementType property, means that the element type is not known.

Properties

 | Name | Description
Public property | AdditionalSize | Gets the index of the parameter containing the array size.
Public property | ArraySizeParameterIndex | Gets the fixed array size.
Public property | ElementType | Gets the type of elements.
Public property | SizeMultiplier | Gets the number by which the value of the parameter at index ArraySizeParameterIndex should be multiplied.

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ArrayMarshalType Constructor

ArrayMarshalType Constructor
ArrayMarshalType Class See Also Send Feedback
Initializes a new instance of ArrayMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArrayMarshalType(
    UnmanagedType elementType,
    int arraySizeParameterIndex,
    int additionalSize,
    int sizeMultiplier,
    int iidParameter
)

Parameters

elementType
Type: System.Runtime.InteropServices..::.UnmanagedType
Type of array elements.
arraySizeParameterIndex
Type: System..::.Int32
Fixed array size, or -1 if the size is not specified.
additionalSize
Type: System..::.Int32
0-based index of the parameter containing the additional number of array elements, or -1 is the array size is solely determined by arraySizeParameterIndex.
sizeMultiplier
Type: System..::.Int32
Number by which the value of the parameter at index arraySizeParameterIndex should be multiplied.
iidParameter
Type: System..::.Int32
Position of the parameter containing the type IID.

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ArrayMarshalType Fields

[image]

PostSharp 2.0 Documentation
ArrayMarshalType Fields
ArrayMarshalType Class See Also Send Feedback

The ArrayMarshalType type exposes the following members.

Fields

Name | Description
UnknownElementType | When applies to the ElementType property, means that the element type is not known.

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


UnknownElementType Field

ArrayMarshalType..::..UnknownElementType Field
ArrayMarshalType Class See Also Send Feedback
When applies to the ElementType property, means that the element type is not known.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const UnmanagedType UnknownElementType

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ArrayMarshalType Properties

[image]

PostSharp 2.0 Documentation
ArrayMarshalType Properties
ArrayMarshalType Class See Also Send Feedback

The ArrayMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalSize | Gets the index of the parameter containing the array size.
Public property | ArraySizeParameterIndex | Gets the fixed array size.
Public property | ElementType | Gets the type of elements.
Public property | SizeMultiplier | Gets the number by which the value of the parameter at index ArraySizeParameterIndex should be multiplied.

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


AdditionalSize Property

ArrayMarshalType..::..AdditionalSize Property
ArrayMarshalType Class See Also Send Feedback
Gets the index of the parameter containing the array size.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int AdditionalSize { get; }

Field Value

The 1-based index of the parameter containing the array size, or 0 if the array size is fixed and set to ArraySizeParameterIndex.

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ArraySizeParameterIndex Property

ArrayMarshalType..::..ArraySizeParameterIndex Property
ArrayMarshalType Class See Also Send Feedback
Gets the fixed array size.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ArraySizeParameterIndex { get; }

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ElementType Property

ArrayMarshalType..::..ElementType Property
ArrayMarshalType Class See Also Send Feedback
Gets the type of elements.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedType ElementType { get; }

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


SizeMultiplier Property

ArrayMarshalType..::..SizeMultiplier Property
ArrayMarshalType Class See Also Send Feedback
Gets the number by which the value of the parameter at index ArraySizeParameterIndex should be multiplied.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int SizeMultiplier { get; }

See Also

ArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


CustomMarshallerMarshalType Class

CustomMarshallerMarshalType Class
Members See Also Send Feedback
Special MarshalType meaning that a custom marshaller should be used.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomMarshallerMarshalType : MarshalType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.CustomMarshallerMarshalType

See Also

CustomMarshallerMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


CustomMarshallerMarshalType Members

[image]

PostSharp 2.0 Documentation
CustomMarshallerMarshalType Members
CustomMarshallerMarshalType Class Constructors Properties See Also Send Feedback

The CustomMarshallerMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | CustomMarshallerMarshalType | Initializes a new CustomMarshallerMarshalType.

Properties

 | Name | Description
Public property | Cookie | Gets the cookie.
Public property | Guid | Gets the custom marshaller GUID.
Public property | ManagedType | Gets the managed type name.
Public property | UnmanagedType | Gets the unmanaged type name.

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


CustomMarshallerMarshalType Constructor

CustomMarshallerMarshalType Constructor
CustomMarshallerMarshalType Class See Also Send Feedback
Initializes a new CustomMarshallerMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomMarshallerMarshalType(
    Guid guid,
    string unmanagedType,
    string managedType,
    string cookie
)

Parameters

guid
Type: System..::.Guid
GUID.
unmanagedType
Type: System..::.String
Unmanaged type name.
managedType
Type: System..::.String
Managed type name.
cookie
Type: System..::.String
Cookie.

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


CustomMarshallerMarshalType Properties

[image]

PostSharp 2.0 Documentation
CustomMarshallerMarshalType Properties
CustomMarshallerMarshalType Class See Also Send Feedback

The CustomMarshallerMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | Cookie | Gets the cookie.
Public property | Guid | Gets the custom marshaller GUID.
Public property | ManagedType | Gets the managed type name.
Public property | UnmanagedType | Gets the unmanaged type name.

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


Cookie Property

CustomMarshallerMarshalType..::..Cookie Property
CustomMarshallerMarshalType Class See Also Send Feedback
Gets the cookie.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Cookie { get; }

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


Guid Property

CustomMarshallerMarshalType..::..Guid Property
CustomMarshallerMarshalType Class See Also Send Feedback
Gets the custom marshaller GUID.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Guid Guid { get; }

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ManagedType Property

CustomMarshallerMarshalType..::..ManagedType Property
CustomMarshallerMarshalType Class See Also Send Feedback
Gets the managed type name.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string ManagedType { get; }

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


UnmanagedType Property

CustomMarshallerMarshalType..::..UnmanagedType Property
CustomMarshallerMarshalType Class See Also Send Feedback
Gets the unmanaged type name.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string UnmanagedType { get; }

See Also

CustomMarshallerMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedArrayMarshalType Class

FixedArrayMarshalType Class
Members See Also Send Feedback
Represents the type of an unmanaged array with fixed number of elements, passed by value.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FixedArrayMarshalType : MarshalType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.FixedArrayMarshalType

See Also

FixedArrayMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedArrayMarshalType Members

[image]

PostSharp 2.0 Documentation
FixedArrayMarshalType Members
FixedArrayMarshalType Class Constructors Properties See Also Send Feedback

The FixedArrayMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | FixedArrayMarshalType | Initializes a new FixedArrayMarshalType.

Properties

 | Name | Description
Public property | ElementNumber | Gets the number of elements in the array.
Public property | ElementType | Gets the type of array elements.
Public property | IIDParameterIndex | Gets the index of the parameter containing the IID of item types

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedArrayMarshalType Constructor

FixedArrayMarshalType Constructor
FixedArrayMarshalType Class See Also Send Feedback
Initializes a new FixedArrayMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FixedArrayMarshalType(
    UnmanagedType elementType,
    int elementNumber,
    int iidParameterIndex
)

Parameters

elementType
Type: System.Runtime.InteropServices..::.UnmanagedType
Type of array elements.
elementNumber
Type: System..::.Int32
Number of array elements.
iidParameterIndex
Type: System..::.Int32
Index of the parameter containing the IID of item types.

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedArrayMarshalType Properties

[image]

PostSharp 2.0 Documentation
FixedArrayMarshalType Properties
FixedArrayMarshalType Class See Also Send Feedback

The FixedArrayMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | ElementNumber | Gets the number of elements in the array.
Public property | ElementType | Gets the type of array elements.
Public property | IIDParameterIndex | Gets the index of the parameter containing the IID of item types

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ElementNumber Property

FixedArrayMarshalType..::..ElementNumber Property
FixedArrayMarshalType Class See Also Send Feedback
Gets the number of elements in the array.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ElementNumber { get; private set; }

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ElementType Property

FixedArrayMarshalType..::..ElementType Property
FixedArrayMarshalType Class See Also Send Feedback
Gets the type of array elements.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedType ElementType { get; private set; }

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IIDParameterIndex Property

FixedArrayMarshalType..::..IIDParameterIndex Property
FixedArrayMarshalType Class See Also Send Feedback
Gets the index of the parameter containing the IID of item types

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int IIDParameterIndex { get; private set; }

See Also

FixedArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedStringMarshalType Class

FixedStringMarshalType Class
Members See Also Send Feedback
Represents the type of an unmanaged string passed by value.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FixedStringMarshalType : MarshalType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.FixedStringMarshalType

See Also

FixedStringMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedStringMarshalType Members

[image]

PostSharp 2.0 Documentation
FixedStringMarshalType Members
FixedStringMarshalType Class Constructors Properties See Also Send Feedback

The FixedStringMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | FixedStringMarshalType | Initializes a new FixedStringMarshalType.

Properties

 | Name | Description
Public property | Size | Gets the string size.

See Also

FixedStringMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedStringMarshalType Constructor

FixedStringMarshalType Constructor
FixedStringMarshalType Class See Also Send Feedback
Initializes a new FixedStringMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FixedStringMarshalType(
    int size
)

Parameters

size
Type: System..::.Int32
Number of characters in the string.

See Also

FixedStringMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


FixedStringMarshalType Properties

[image]

PostSharp 2.0 Documentation
FixedStringMarshalType Properties
FixedStringMarshalType Class See Also Send Feedback

The FixedStringMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | Size | Gets the string size.

See Also

FixedStringMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


Size Property

FixedStringMarshalType..::..Size Property
FixedStringMarshalType Class See Also Send Feedback
Gets the string size.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Size { get; }

See Also

FixedStringMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Class

IntrinsicMarshalType Class
Members See Also Send Feedback
Represents the type of an intrinsic unmanaged scalar.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IntrinsicMarshalType : MarshalType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.IntrinsicMarshalType

See Also

IntrinsicMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Members

[image]

PostSharp 2.0 Documentation
IntrinsicMarshalType Members
IntrinsicMarshalType Class Constructors Properties See Also Send Feedback

The IntrinsicMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | IntrinsicMarshalType | Overloaded.

Properties

 | Name | Description
Public property | IIDParameterIndex | Gets the index of the parameter containing the IID of the type of current value.
Public property | Type | Gets the intrinsic type.

See Also

IntrinsicMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Constructor

[image]

PostSharp 2.0 Documentation
IntrinsicMarshalType Constructor
IntrinsicMarshalType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntrinsicMarshalType(UnmanagedType) | Initializes a new IntrinsicMarshalType.
Public method | IntrinsicMarshalType(UnmanagedType, Int32) | Initializes a new IntrinsicMarshalType and sets the IIDParameterIndex property.

See Also

IntrinsicMarshalType Class
IntrinsicMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Constructor (UnmanagedType)

IntrinsicMarshalType Constructor (UnmanagedType)
IntrinsicMarshalType Class See Also Send Feedback
Initializes a new IntrinsicMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicMarshalType(
    UnmanagedType type
)

Parameters

type
Type: System.Runtime.InteropServices..::.UnmanagedType
The intrinsic type.

See Also

IntrinsicMarshalType Class
IntrinsicMarshalType Overload
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Constructor (UnmanagedType, Int32)

IntrinsicMarshalType Constructor (UnmanagedType, Int32)
IntrinsicMarshalType Class See Also Send Feedback
Initializes a new IntrinsicMarshalType and sets the IIDParameterIndex property.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicMarshalType(
    UnmanagedType type,
    int iidParameterIndex
)

Parameters

type
Type: System.Runtime.InteropServices..::.UnmanagedType
The intrinsic type.
iidParameterIndex
Type: System..::.Int32
Index of the parameter containing the IID of the type of current value.

See Also

IntrinsicMarshalType Class
IntrinsicMarshalType Overload
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IntrinsicMarshalType Properties

[image]

PostSharp 2.0 Documentation
IntrinsicMarshalType Properties
IntrinsicMarshalType Class See Also Send Feedback

The IntrinsicMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | IIDParameterIndex | Gets the index of the parameter containing the IID of the type of current value.
Public property | Type | Gets the intrinsic type.

See Also

IntrinsicMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


IIDParameterIndex Property

IntrinsicMarshalType..::..IIDParameterIndex Property
IntrinsicMarshalType Class See Also Send Feedback
Gets the index of the parameter containing the IID of the type of current value.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int IIDParameterIndex { get; private set; }

See Also

IntrinsicMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


Type Property

IntrinsicMarshalType..::..Type Property
IntrinsicMarshalType Class See Also Send Feedback
Gets the intrinsic type.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnmanagedType Type { get; }

See Also

IntrinsicMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


SafeArrayMarshalType Class

SafeArrayMarshalType Class
Members See Also Send Feedback
Represents the type of an unmanaged Safe Array.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SafeArrayMarshalType : MarshalType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.MarshalType
PostSharp.Sdk.CodeModel.MarshalTypes..::.SafeArrayMarshalType

See Also

SafeArrayMarshalType Members
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


SafeArrayMarshalType Members

[image]

PostSharp 2.0 Documentation
SafeArrayMarshalType Members
SafeArrayMarshalType Class Constructors Properties See Also Send Feedback

The SafeArrayMarshalType type exposes the following members.

Constructors

 | Name | Description
Public method | SafeArrayMarshalType | Initializes a new SafeArrayMarshalType.

Properties

 | Name | Description
Public property | ElementType | Gets the type of array elements.

See Also

SafeArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


SafeArrayMarshalType Constructor

SafeArrayMarshalType Constructor
SafeArrayMarshalType Class See Also Send Feedback
Initializes a new SafeArrayMarshalType.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SafeArrayMarshalType(
    VarEnum elementType
)

Parameters

elementType
Type: System.Runtime.InteropServices..::.VarEnum
Type of array elements.

See Also

SafeArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


SafeArrayMarshalType Properties

[image]

PostSharp 2.0 Documentation
SafeArrayMarshalType Properties
SafeArrayMarshalType Class See Also Send Feedback

The SafeArrayMarshalType type exposes the following members.

Properties

 | Name | Description
Public property | ElementType | Gets the type of array elements.

See Also

SafeArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


ElementType Property

SafeArrayMarshalType..::..ElementType Property
SafeArrayMarshalType Class See Also Send Feedback
Gets the type of array elements.

Namespace: PostSharp.Sdk.CodeModel.MarshalTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public VarEnum ElementType { get; }

See Also

SafeArrayMarshalType Class
PostSharp.Sdk.CodeModel.MarshalTypes Namespace


PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace

PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.ReflectionWrapper namespace contains implementations of abstract types from System.Reflection (such as Type, MethodInfo, FieldInfo, ...) that wrap the PostSharp's internal representation of the assembly.

Classes

 | Class | Description
Public class | ReflectionWrapperUtility | Provides utility methods to work with reflection wrappers.

Interfaces

 | Interface | Description
Public interface | IReflectionWrapper<(Of <(?0>)>) | Defines common public semantics of all reflection wrappers.


IReflectionWrapper(?0) Interface

IReflectionWrapper<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
Defines common public semantics of all reflection wrappers.

Namespace: PostSharp.Sdk.CodeModel.ReflectionWrapper
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IReflectionWrapper<?0> : IReflectionWrapper

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.CodeModel.ReflectionWrapper.IReflectionWrapper`1"]

See Also

IReflectionWrapper<(Of <(?0>)>) Members
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


IReflectionWrapper(?0) Members

[image]

PostSharp 2.0 Documentation
IReflectionWrapper<(Of <(<'?0>)>)> Members
IReflectionWrapper<(Of <(?0>)>) Interface Properties See Also Send Feedback

The IReflectionWrapper<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element. (Inherited from IReflectionWrapper.)
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper. (Inherited from IReflectionWrapper.)
Public property | WrappedObject | Gets the underlying PostSharp.CodeModel object.

See Also

IReflectionWrapper<(Of <(?0>)>) Interface
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


IReflectionWrapper(?0) Properties

[image]

PostSharp 2.0 Documentation
IReflectionWrapper<(Of <(<'?0>)>)> Properties
IReflectionWrapper<(Of <(?0>)>) Interface See Also Send Feedback

The IReflectionWrapper<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssemblyName | Gets the name of the assembly declaring the current element. (Inherited from IReflectionWrapper.)
Public property | UnderlyingSystemObject | Gets the system object (Type, FieldInfo, MethodInfo, ConstructorInfo, ParameterInfo, ...) corresponding to the current wrapper. (Inherited from IReflectionWrapper.)
Public property | WrappedObject | Gets the underlying PostSharp.CodeModel object.

See Also

IReflectionWrapper<(Of <(?0>)>) Interface
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


WrappedObject Property

IReflectionWrapper<(Of <(<'?0>)>)>..::..WrappedObject Property
IReflectionWrapper<(Of <(?0>)>) Interface See Also Send Feedback
Gets the underlying PostSharp.CodeModel object.

Namespace: PostSharp.Sdk.CodeModel.ReflectionWrapper
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
?0 WrappedObject { get; }

See Also

IReflectionWrapper<(Of <(?0>)>) Interface
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


ReflectionWrapperUtility Class

ReflectionWrapperUtility Class
Members See Also Send Feedback
Provides utility methods to work with reflection wrappers.

Namespace: PostSharp.Sdk.CodeModel.ReflectionWrapper
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class ReflectionWrapperUtility

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.ReflectionWrapper..::.ReflectionWrapperUtility

See Also

ReflectionWrapperUtility Members
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


ReflectionWrapperUtility Members

[image]

PostSharp 2.0 Documentation
ReflectionWrapperUtility Members
ReflectionWrapperUtility Class Methods See Also Send Feedback

The ReflectionWrapperUtility type exposes the following members.

Methods

Name | Description
HideTypeFromAssembly | Marks a TypeDefDeclaration to that it won't be enumerated by the GetTypes()()() method of AssemblyWrapper.
RequiresReflectionWrapper | Determines whether an aspect requires reflection wrappers instead of system reflection objects.

See Also

ReflectionWrapperUtility Class
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


ReflectionWrapperUtility Methods

[image]

PostSharp 2.0 Documentation
ReflectionWrapperUtility Methods
ReflectionWrapperUtility Class See Also Send Feedback

The ReflectionWrapperUtility type exposes the following members.

Methods

Name | Description
HideTypeFromAssembly | Marks a TypeDefDeclaration to that it won't be enumerated by the GetTypes()()() method of AssemblyWrapper.
RequiresReflectionWrapper | Determines whether an aspect requires reflection wrappers instead of system reflection objects.

See Also

ReflectionWrapperUtility Class
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


HideTypeFromAssembly Method

ReflectionWrapperUtility..::..HideTypeFromAssembly Method
ReflectionWrapperUtility Class See Also Send Feedback
Marks a TypeDefDeclaration to that it won't be enumerated by the GetTypes()()() method of AssemblyWrapper.

Namespace: PostSharp.Sdk.CodeModel.ReflectionWrapper
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void HideTypeFromAssembly(
    TypeDefDeclaration typeDef
)

Parameters

typeDef
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Type to hide from reflection wrappers.

See Also

ReflectionWrapperUtility Class
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


RequiresReflectionWrapper Method

ReflectionWrapperUtility..::..RequiresReflectionWrapper Method
ReflectionWrapperUtility Class See Also Send Feedback
Determines whether an aspect requires reflection wrappers instead of system reflection objects.

Namespace: PostSharp.Sdk.CodeModel.ReflectionWrapper
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool RequiresReflectionWrapper(
    TypeDefDeclaration declaringType
)

Parameters

declaringType
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The aspect type.

Return Value

true if declaringType requires reflection wrappers, otherwise false.

See Also

ReflectionWrapperUtility Class
PostSharp.Sdk.CodeModel.ReflectionWrapper Namespace


PostSharp.Sdk.CodeModel.SerializationTypes Namespace

PostSharp.Sdk.CodeModel.SerializationTypes Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.SerializationTypes namespace contains classes that represent serialization types, i.e. types used to represent the value of custom attributes or security descriptors.

Classes

 | Class | Description
Public class | ArraySerializationType | Represents the serialization type of an array.
Public class | EnumerationSerializationType | Represents the serialization type of an enumeration.
Public class | IntrinsicSerializationType | Represents intrinsic serialization types (boolean, int32, int64, ...).
Public class | TaggedObjectSerializationType | Represents a tagged object serialization type, i.e. the type of a boxed value.
Public class | TypeSerializationType | Represents the serialization type of a type reference.


ArraySerializationType Class

ArraySerializationType Class
Members See Also Send Feedback
Represents the serialization type of an array.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ArraySerializationType : SerializationType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.ArraySerializationType

See Also

ArraySerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ArraySerializationType Members

[image]

PostSharp 2.0 Documentation
ArraySerializationType Members
ArraySerializationType Class Constructors Methods Properties See Also Send Feedback

The ArraySerializationType type exposes the following members.

Constructors

 | Name | Description
Public method | ArraySerializationType | Initializes a new ArraySerializationType.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

Properties

 | Name | Description
Public property | ElementType | Gets or sets the type of array elements.
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Overrides SerializationType..::.SystemType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ArraySerializationType Constructor

ArraySerializationType Constructor
ArraySerializationType Class See Also Send Feedback
Initializes a new ArraySerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArraySerializationType(
    SerializationType elementType
)

Parameters

elementType
Type: PostSharp.Sdk.CodeModel..::.SerializationType
Type of array elements.

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ArraySerializationType Methods

[image]

PostSharp 2.0 Documentation
ArraySerializationType Methods
ArraySerializationType Class See Also Send Feedback

The ArraySerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Translate Method

ArraySerializationType..::..Translate Method
ArraySerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateRuntimeValue Method

ArraySerializationType..::..ValidateRuntimeValue Method
ArraySerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateValue Method

ArraySerializationType..::..ValidateValue Method
ArraySerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ArraySerializationType Properties

[image]

PostSharp 2.0 Documentation
ArraySerializationType Properties
ArraySerializationType Class See Also Send Feedback

The ArraySerializationType type exposes the following members.

Properties

 | Name | Description
Public property | ElementType | Gets or sets the type of array elements.
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Overrides SerializationType..::.SystemType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ElementType Property

ArraySerializationType..::..ElementType Property
ArraySerializationType Class See Also Send Feedback
Gets or sets the type of array elements.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SerializationType ElementType { get; set; }

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


SystemType Property

ArraySerializationType..::..SystemType Property
ArraySerializationType Class See Also Send Feedback
Gets the system reflection type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type SystemType { get; }

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSignature Property

ArraySerializationType..::..TypeSignature Property
ArraySerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

ArraySerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationSerializationType Class

EnumerationSerializationType Class
Members See Also Send Feedback
Represents the serialization type of an enumeration.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class EnumerationSerializationType : SerializationType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.EnumerationSerializationType

See Also

EnumerationSerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationSerializationType Members

[image]

PostSharp 2.0 Documentation
EnumerationSerializationType Members
EnumerationSerializationType Class Constructors Methods Properties See Also Send Feedback

The EnumerationSerializationType type exposes the following members.

Constructors

 | Name | Description
Public method | EnumerationSerializationType | Initializes a new EnumerationSerializationType.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
Public method | GetIntrinsicSerializationType |
Public method | GetIntrinsicType |
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

Properties

 | Name | Description
Public property | EnumerationType | Gets or sets the runtime type of the enumeration.
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Overrides SerializationType..::.SystemType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationSerializationType Constructor

EnumerationSerializationType Constructor
EnumerationSerializationType Class See Also Send Feedback
Initializes a new EnumerationSerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public EnumerationSerializationType(
    INamedType enumerationType
)

Parameters

enumerationType
Type: PostSharp.Sdk.CodeModel..::.INamedType
Runtime type of the enumeration.

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationSerializationType Methods

[image]

PostSharp 2.0 Documentation
EnumerationSerializationType Methods
EnumerationSerializationType Class See Also Send Feedback

The EnumerationSerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
Public method | GetIntrinsicSerializationType |
Public method | GetIntrinsicType |
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


GetIntrinsicSerializationType Method

EnumerationSerializationType..::..GetIntrinsicSerializationType Method
EnumerationSerializationType Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.SerializationTypes.EnumerationSerializationType.GetIntrinsicSerializationType"]

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicSerializationType GetIntrinsicSerializationType()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.SerializationTypes.EnumerationSerializationType.GetIntrinsicSerializationType"]

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


GetIntrinsicType Method

EnumerationSerializationType..::..GetIntrinsicType Method
EnumerationSerializationType Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.SerializationTypes.EnumerationSerializationType.GetIntrinsicType"]

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicType GetIntrinsicType()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.SerializationTypes.EnumerationSerializationType.GetIntrinsicType"]

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Translate Method

EnumerationSerializationType..::..Translate Method
EnumerationSerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateRuntimeValue Method

EnumerationSerializationType..::..ValidateRuntimeValue Method
EnumerationSerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateValue Method

EnumerationSerializationType..::..ValidateValue Method
EnumerationSerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationSerializationType Properties

[image]

PostSharp 2.0 Documentation
EnumerationSerializationType Properties
EnumerationSerializationType Class See Also Send Feedback

The EnumerationSerializationType type exposes the following members.

Properties

 | Name | Description
Public property | EnumerationType | Gets or sets the runtime type of the enumeration.
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Overrides SerializationType..::.SystemType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


EnumerationType Property

EnumerationSerializationType..::..EnumerationType Property
EnumerationSerializationType Class See Also Send Feedback
Gets or sets the runtime type of the enumeration.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public INamedType EnumerationType { get; set; }

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


SystemType Property

EnumerationSerializationType..::..SystemType Property
EnumerationSerializationType Class See Also Send Feedback
Gets the system reflection type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type SystemType { get; }

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSignature Property

EnumerationSerializationType..::..TypeSignature Property
EnumerationSerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

EnumerationSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


IntrinsicSerializationType Class

IntrinsicSerializationType Class
Members See Also Send Feedback
Represents intrinsic serialization types (boolean, int32, int64, ...).

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IntrinsicSerializationType : SerializationType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.IntrinsicSerializationType

See Also

IntrinsicSerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


IntrinsicSerializationType Members

[image]

PostSharp 2.0 Documentation
IntrinsicSerializationType Members
IntrinsicSerializationType Class Methods Properties See Also Send Feedback

The IntrinsicSerializationType type exposes the following members.

Methods

 | Name | Description
 | CreateValue | Overloaded.
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets an instance IntrinsicSerializationType for the current module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | Type | Gets the IntrinsicType enumeration value.
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


IntrinsicSerializationType Methods

[image]

PostSharp 2.0 Documentation
IntrinsicSerializationType Methods
IntrinsicSerializationType Class See Also Send Feedback

The IntrinsicSerializationType type exposes the following members.

Methods

 | Name | Description
 | CreateValue | Overloaded.
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets an instance IntrinsicSerializationType for the current module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method

[image]

PostSharp 2.0 Documentation
IntrinsicSerializationType..::..CreateValue Method
IntrinsicSerializationType Class See Also Send Feedback

Overload List

Name | Description
CreateValue(ModuleDeclaration, Boolean) | Creates a SerializedValue representing a Boolean.
CreateValue(ModuleDeclaration, Byte) | Creates a SerializedValue representing a Boolean.
CreateValue(ModuleDeclaration, Char) | Creates a SerializedValue representing a Boolean.
CreateValue(ModuleDeclaration, Double) | Creates a SerializedValue representing a Double.
CreateValue(ModuleDeclaration, Int16) | Creates a SerializedValue representing a Int16.
CreateValue(ModuleDeclaration, Int32) | Creates a SerializedValue representing a Int32.
CreateValue(ModuleDeclaration, Int64) | Creates a SerializedValue representing a Int64.
CreateValue(ModuleDeclaration, SByte) | Creates a SerializedValue representing a SByte.
CreateValue(ModuleDeclaration, Single) | Creates a SerializedValue representing a Single.
CreateValue(ModuleDeclaration, String) | Creates a SerializedValue representing a String.
CreateValue(ModuleDeclaration, UInt16) | Creates a SerializedValue representing a UInt16.
CreateValue(ModuleDeclaration, UInt32) | Creates a SerializedValue representing a UInt32.
CreateValue(ModuleDeclaration, UInt64) | Creates a SerializedValue representing a UInt64.
CreateValue(ModuleDeclaration, IntrinsicType, Object) | Creates a SerializedValue representing an intrinsic type.

See Also

IntrinsicSerializationType Class
IntrinsicSerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Boolean)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Boolean)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Boolean.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    bool value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Boolean
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Byte)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Byte)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Boolean.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    byte value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Byte
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Char)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Char)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Boolean.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    char value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Char
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Double)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Double)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Double.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    double value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Double
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Int16)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Int16)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Int16.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    short value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Int16
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Int32)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Int32)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Int32.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    int value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Int32
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Int64)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Int64)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Int64.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    long value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Int64
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, SByte)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, SByte)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a SByte.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    sbyte value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.SByte
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, Single)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, Single)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a Single.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    float value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.Single
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, String)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, String)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a String.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    string value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.String
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, UInt16)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, UInt16)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a UInt16.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    ushort value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.UInt16
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, UInt32)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, UInt32)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a UInt32.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    uint value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.UInt32
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, UInt64)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, UInt64)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing a UInt64.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    ulong value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
value
Type: System..::.UInt64
Value.

Return Value

A SerializedValue encapsulating value in module.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


CreateValue Method (ModuleDeclaration, IntrinsicType, Object)

IntrinsicSerializationType..::..CreateValue Method (ModuleDeclaration, IntrinsicType, Object)
IntrinsicSerializationType Class See Also Send Feedback
Creates a SerializedValue representing an intrinsic type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SerializedValue CreateValue(
    ModuleDeclaration module,
    IntrinsicType type,
    Object value
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the SerializedValue should be valid.
type
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
Type of the intrinsic value.
value
Type: System..::.Object
A boxed value of type type.

Return Value

A SerializedValue of type type.

See Also

IntrinsicSerializationType Class
CreateValue Overload
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


GetInstance Method

IntrinsicSerializationType..::..GetInstance Method
IntrinsicSerializationType Class See Also Send Feedback
Gets an instance IntrinsicSerializationType for the current module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IntrinsicSerializationType GetInstance(
    ModuleDeclaration module,
    IntrinsicType type
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the instance should be valid.
type
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
Intrinsic type that should be represented by the instance.

Return Value

An IntrinsicSerializationType representing type, valid in module.

Remarks

User code should use the DeclarationCache. GetIntrinsicSerializationType(IntrinsicType) method instead.

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Translate Method

IntrinsicSerializationType..::..Translate Method
IntrinsicSerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateRuntimeValue Method

IntrinsicSerializationType..::..ValidateRuntimeValue Method
IntrinsicSerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateValue Method

IntrinsicSerializationType..::..ValidateValue Method
IntrinsicSerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


IntrinsicSerializationType Properties

[image]

PostSharp 2.0 Documentation
IntrinsicSerializationType Properties
IntrinsicSerializationType Class See Also Send Feedback

The IntrinsicSerializationType type exposes the following members.

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | Type | Gets the IntrinsicType enumeration value.
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Type Property

IntrinsicSerializationType..::..Type Property
IntrinsicSerializationType Class See Also Send Feedback
Gets the IntrinsicType enumeration value.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicType Type { get; }

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSignature Property

IntrinsicSerializationType..::..TypeSignature Property
IntrinsicSerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

IntrinsicSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TaggedObjectSerializationType Class

TaggedObjectSerializationType Class
Members See Also Send Feedback
Represents a tagged object serialization type, i.e. the type of a boxed value.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TaggedObjectSerializationType : SerializationType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.TaggedObjectSerializationType

See Also

TaggedObjectSerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TaggedObjectSerializationType Members

[image]

PostSharp 2.0 Documentation
TaggedObjectSerializationType Members
TaggedObjectSerializationType Class Methods Properties See Also Send Feedback

The TaggedObjectSerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets an instance of TaggedObjectSerializationType for a specific module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TaggedObjectSerializationType Methods

[image]

PostSharp 2.0 Documentation
TaggedObjectSerializationType Methods
TaggedObjectSerializationType Class See Also Send Feedback

The TaggedObjectSerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets an instance of TaggedObjectSerializationType for a specific module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


GetInstance Method

TaggedObjectSerializationType..::..GetInstance Method
TaggedObjectSerializationType Class See Also Send Feedback
Gets an instance of TaggedObjectSerializationType for a specific module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TaggedObjectSerializationType GetInstance(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module for which the instance should be valid.

Return Value

A TaggedObjectSerializationType.

Remarks

User code should use DeclarationCache.TaggedObjectSerializationType instead of this method.

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Translate Method

TaggedObjectSerializationType..::..Translate Method
TaggedObjectSerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateRuntimeValue Method

TaggedObjectSerializationType..::..ValidateRuntimeValue Method
TaggedObjectSerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateValue Method

TaggedObjectSerializationType..::..ValidateValue Method
TaggedObjectSerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TaggedObjectSerializationType Properties

[image]

PostSharp 2.0 Documentation
TaggedObjectSerializationType Properties
TaggedObjectSerializationType Class See Also Send Feedback

The TaggedObjectSerializationType type exposes the following members.

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSignature Property

TaggedObjectSerializationType..::..TypeSignature Property
TaggedObjectSerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

TaggedObjectSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSerializationType Class

TypeSerializationType Class
Members See Also Send Feedback
Represents the serialization type of a type reference.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeSerializationType : SerializationType

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.SerializationType
PostSharp.Sdk.CodeModel.SerializationTypes..::.TypeSerializationType

See Also

TypeSerializationType Members
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSerializationType Members

[image]

PostSharp 2.0 Documentation
TypeSerializationType Members
TypeSerializationType Class Methods Properties See Also Send Feedback

The TypeSerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets a TypeSerializationType for a given module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSerializationType Methods

[image]

PostSharp 2.0 Documentation
TypeSerializationType Methods
TypeSerializationType Class See Also Send Feedback

The TypeSerializationType type exposes the following members.

Methods

 | Name | Description
Public method | FromRuntimeValue | Converts a runtime value into a SerializedValue. (Inherited from SerializationType.)
 | GetInstance | Gets a TypeSerializationType for a given module.
Public method | Translate | Translates the current SerializationType so that it is valid in another module. (Overrides SerializationType..::.Translate(ModuleDeclaration).)
Public method | ValidateRuntimeValue | Ensures that a runtime value is compatible with the current type. (Overrides SerializationType..::.ValidateRuntimeValue(Object).)
Public method | ValidateValue | Ensures that a value is compatible with the current type. (Overrides SerializationType..::.ValidateValue(Object).)

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


GetInstance Method

TypeSerializationType..::..GetInstance Method
TypeSerializationType Class See Also Send Feedback
Gets a TypeSerializationType for a given module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeSerializationType GetInstance(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the instance should be valid.

Return Value

A TypeSerializationType value for this module.

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


Translate Method

TypeSerializationType..::..Translate Method
TypeSerializationType Class See Also Send Feedback
Translates the current SerializationType so that it is valid in another module.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override SerializationType Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module for which the SerializationType should be expressed.

Return Value

An instance of SerializationType expressed for the other module.

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateRuntimeValue Method

TypeSerializationType..::..ValidateRuntimeValue Method
TypeSerializationType Class See Also Send Feedback
Ensures that a runtime value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateRuntimeValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


ValidateValue Method

TypeSerializationType..::..ValidateValue Method
TypeSerializationType Class See Also Send Feedback
Ensures that a value is compatible with the current type.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void ValidateValue(
    Object value
)

Parameters

value
Type: System..::.Object
The value to validate.

Remarks

Implementations should raise an ArgumentException if the value is invalid.

When PostSharp.Sdk.dll is compiled without the ASSERT constant, implementations do not throw exceptions and this method is always successful.

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSerializationType Properties

[image]

PostSharp 2.0 Documentation
TypeSerializationType Properties
TypeSerializationType Class See Also Send Feedback

The TypeSerializationType type exposes the following members.

Properties

 | Name | Description
Public property | Module | Gets the module to which the current SerializationType belongs. (Inherited from SerializationType.)
Public property | SystemType | Gets the system reflection type corresponding to the current SerializationType. (Inherited from SerializationType.)
Public property | TypeSignature | Gets the runtime, deserialized type corresponding to the current SerializationType. (Overrides SerializationType..::.TypeSignature.)

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


TypeSignature Property

TypeSerializationType..::..TypeSignature Property
TypeSerializationType Class See Also Send Feedback
Gets the runtime, deserialized type corresponding to the current SerializationType.

Namespace: PostSharp.Sdk.CodeModel.SerializationTypes
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature TypeSignature { get; }

Return Value

Then runtime type that corresponds to the serialized type of the current SerializationType.

See Also

TypeSerializationType Class
PostSharp.Sdk.CodeModel.SerializationTypes Namespace


PostSharp.Sdk.CodeModel.TypeSignatures Namespace

PostSharp.Sdk.CodeModel.TypeSignatures Namespace
Send Feedback
The PostSharp.Sdk.CodeModel.TypeSignatures namespace contains classes that implement T:PostSharp.Sdk.CodeModel.ITypeSignature and can be used as, or as parts of, a type signature.

Classes

 | Class | Description
Public class | ArrayTypeSignature | Represents the type of an array.
Public class | BoxedTypeSignature | Represents the type of a boxed value.
Public class | CustomModifierTypeSignature | Represents a type modified by a custom modifier.
Public class | GenericParameterTypeSignature | Represents a reference to a generic parameter.
Public class | GenericTypeInstanceTypeSignature | Represents a generic type construction.
Public class | IntrinsicTypeSignature | Represents an intrinsic type.
Public class | MethodPointerTypeSignature | Represents the type of a method pointer.
Public class | PinnedTypeSignature | Represents the type of a pinned pointer.
Public class | PointerTypeSignature | Represents the type of a pointer (managed or unmanaged).

Structures

 | Structure | Description
Public structure | ArrayDimension | Specifies the bounds of a single dimension of an ArrayTypeSignature.
Public structure | CustomModifier | Represents a custom modifier, which are tags emitted by compilers that add some meaning to the modified type.


ArrayDimension Structure

ArrayDimension Structure
Members See Also Send Feedback
Specifies the bounds of a single dimension of an ArrayTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct ArrayDimension : IEquatable<ArrayDimension>

See Also

ArrayDimension Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Members

[image]

PostSharp 2.0 Documentation
ArrayDimension Members
ArrayDimension Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The ArrayDimension type exposes the following members.

Constructors

 | Name | Description
Public method | ArrayDimension | Initializes a new ArrayDimension.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Determines whether two instances are equal.
Inequality | Determines whether two instances are different.

Fields

Name | Description
Unlimited | When set to LowerBound or Size, specifies that the value is unbounded.

Properties

 | Name | Description
Public property | HasLowerBound | Determines whether the dimension has a lower bound.
Public property | HasSize | Determines whether the dimension has a limited number of elements.
Public property | LowerBound | Gets the lower bound.
Public property | Size | Gets the number of elements.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Constructor

ArrayDimension Constructor
ArrayDimension Structure See Also Send Feedback
Initializes a new ArrayDimension.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArrayDimension(
    int lowerBound,
    int size
)

Parameters

lowerBound
Type: System..::.Int32
Lower bound, or Unlimited.
size
Type: System..::.Int32
Number of elements, or Unlimited.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Fields

[image]

PostSharp 2.0 Documentation
ArrayDimension Fields
ArrayDimension Structure See Also Send Feedback

The ArrayDimension type exposes the following members.

Fields

Name | Description
Unlimited | When set to LowerBound or Size, specifies that the value is unbounded.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Unlimited Field

ArrayDimension..::..Unlimited Field
ArrayDimension Structure See Also Send Feedback
When set to LowerBound or Size, specifies that the value is unbounded.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const int Unlimited

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Methods

[image]

PostSharp 2.0 Documentation
ArrayDimension Methods
ArrayDimension Structure See Also Send Feedback

The ArrayDimension type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
ArrayDimension..::..Equals Method
ArrayDimension Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(ArrayDimension) | Indicates whether the current object is equal to another object of the same type.

See Also

ArrayDimension Structure
ArrayDimension Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Equals Method (Object)

ArrayDimension..::..Equals Method (Object)
ArrayDimension Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

ArrayDimension Structure
Equals Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Equals Method (ArrayDimension)

ArrayDimension..::..Equals Method (ArrayDimension)
ArrayDimension Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    ArrayDimension other
)

Parameters

other
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

ArrayDimension Structure
Equals Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetHashCode Method

ArrayDimension..::..GetHashCode Method
ArrayDimension Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Operators

[image]

PostSharp 2.0 Documentation
ArrayDimension Operators
ArrayDimension Structure See Also Send Feedback

The ArrayDimension type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances are equal.
Inequality | Determines whether two instances are different.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Equality Operator

ArrayDimension..::..Equality Operator
ArrayDimension Structure See Also Send Feedback
Determines whether two instances are equal.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    ArrayDimension left,
    ArrayDimension right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension
An ArrayDimension.
right
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension
An ArrayDimension.

Return Value

true if both instances are equal, otherwise false.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Inequality Operator

ArrayDimension..::..Inequality Operator
ArrayDimension Structure See Also Send Feedback
Determines whether two instances are different.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    ArrayDimension left,
    ArrayDimension right
)

Parameters

left
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension
An ArrayDimension.
right
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension
An ArrayDimension.

Return Value

true if both instances are different, otherwise false.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayDimension Properties

[image]

PostSharp 2.0 Documentation
ArrayDimension Properties
ArrayDimension Structure See Also Send Feedback

The ArrayDimension type exposes the following members.

Properties

 | Name | Description
Public property | HasLowerBound | Determines whether the dimension has a lower bound.
Public property | HasSize | Determines whether the dimension has a limited number of elements.
Public property | LowerBound | Gets the lower bound.
Public property | Size | Gets the number of elements.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


HasLowerBound Property

ArrayDimension..::..HasLowerBound Property
ArrayDimension Structure See Also Send Feedback
Determines whether the dimension has a lower bound.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasLowerBound { get; }

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


HasSize Property

ArrayDimension..::..HasSize Property
ArrayDimension Structure See Also Send Feedback
Determines whether the dimension has a limited number of elements.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool HasSize { get; }

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


LowerBound Property

ArrayDimension..::..LowerBound Property
ArrayDimension Structure See Also Send Feedback
Gets the lower bound.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int LowerBound { get; }

Remarks

A signed integer, or Unlimited so specify that this dimension has no lower bound.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Size Property

ArrayDimension..::..Size Property
ArrayDimension Structure See Also Send Feedback
Gets the number of elements.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Size { get; }

Remarks

A singed integer, or Unlimited to specify that this dimension can have an unlimited number of elements.

See Also

ArrayDimension Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Class

ArrayTypeSignature Class
Members See Also Send Feedback
Represents the type of an array.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ArrayTypeSignature : TypeSignature

Remarks

Arrays with a single dimension, no fixed size and zero lower bound are called Vectors. Normal arrays in C#, for instance, are vectors. Use the IsVector property to determine whether an ArrayTypeSignature is a vector.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayTypeSignature

See Also

ArrayTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Members

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature Members
ArrayTypeSignature Class Constructors Methods Properties See Also Send Feedback

The ArrayTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | ArrayTypeSignature | Overloaded.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetDimension | Gets a dimension given its index.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of array elements. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | IsVector | Determines whether the current array is a vector.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Rank | Gets the array rank (number of dimensions).

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Constructor

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature Constructor
ArrayTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ArrayTypeSignature(ITypeSignature) | Initializes a new ArrayTypeSignature with default dimensions ([0..]).
Public method | ArrayTypeSignature(ITypeSignature, array<ArrayDimension>[]()[]) | Initializes a new ArrayTypeSignature.

See Also

ArrayTypeSignature Class
ArrayTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Constructor (ITypeSignature)

ArrayTypeSignature Constructor (ITypeSignature)
ArrayTypeSignature Class See Also Send Feedback
Initializes a new ArrayTypeSignature with default dimensions ([0..]).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArrayTypeSignature(
    ITypeSignature innerType
)

Parameters

innerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of array elements.

See Also

ArrayTypeSignature Class
ArrayTypeSignature Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Constructor (ITypeSignature, ArrayDimension[])

ArrayTypeSignature Constructor (ITypeSignature, array<ArrayDimension>[]()[][])
ArrayTypeSignature Class See Also Send Feedback
Initializes a new ArrayTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArrayTypeSignature(
    ITypeSignature innerType,
    ArrayDimension[] dimensions
)

Parameters

innerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of array elements.
dimensions
Type: array< PostSharp.Sdk.CodeModel.TypeSignatures..::.ArrayDimension >[]()[][]
Array dimensions.

See Also

ArrayTypeSignature Class
ArrayTypeSignature Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Methods

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature Methods
ArrayTypeSignature Class See Also Send Feedback

The ArrayTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetDimension | Gets a dimension given its index.
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

ArrayTypeSignature..::..BelongsToClassification Method
ArrayTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

ArrayTypeSignature..::..ContainsGenericArguments Method
ArrayTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

ArrayTypeSignature..::..GetCanonicalHashCode Method
ArrayTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetDimension Method

ArrayTypeSignature..::..GetDimension Method
ArrayTypeSignature Class See Also Send Feedback
Gets a dimension given its index.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ArrayDimension GetDimension(
    int index
)

Parameters

index
Type: System..::.Int32
Dimension index.

Return Value

The dimension at index index.

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

ArrayTypeSignature..::..GetReflectionWrapper Method
ArrayTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

ArrayTypeSignature..::..GetSystemType Method
ArrayTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature..::..GetTypeDefinition Method
ArrayTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

ArrayTypeSignature Class
ArrayTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature..::..IsAssignableTo Method
ArrayTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

ArrayTypeSignature Class
ArrayTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

ArrayTypeSignature..::..MapGenericArguments Method
ArrayTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

ArrayTypeSignature..::..ToString Method
ArrayTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

ArrayTypeSignature..::..Translate Method
ArrayTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.ArrayTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.ArrayTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.ArrayTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

ArrayTypeSignature..::..WriteReflectionName Method
ArrayTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ArrayTypeSignature Properties

[image]

PostSharp 2.0 Documentation
ArrayTypeSignature Properties
ArrayTypeSignature Class See Also Send Feedback

The ArrayTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of array elements. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | IsVector | Determines whether the current array is a vector.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Rank | Gets the array rank (number of dimensions).

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

ArrayTypeSignature..::..ElementType Property
ArrayTypeSignature Class See Also Send Feedback
Gets the type of array elements.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsVector Property

ArrayTypeSignature..::..IsVector Property
ArrayTypeSignature Class See Also Send Feedback
Determines whether the current array is a vector.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsVector { get; }

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

ArrayTypeSignature..::..Module Property
ArrayTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Rank Property

ArrayTypeSignature..::..Rank Property
ArrayTypeSignature Class See Also Send Feedback
Gets the array rank (number of dimensions).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Rank { get; }

See Also

ArrayTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BoxedTypeSignature Class

BoxedTypeSignature Class
Members See Also Send Feedback
Represents the type of a boxed value.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class BoxedTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.BoxedTypeSignature

See Also

BoxedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BoxedTypeSignature Members

[image]

PostSharp 2.0 Documentation
BoxedTypeSignature Members
BoxedTypeSignature Class Constructors Methods Properties See Also Send Feedback

The BoxedTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | BoxedTypeSignature | Initializes a new BoxedTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of values being boxed. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BoxedTypeSignature Constructor

BoxedTypeSignature Constructor
BoxedTypeSignature Class See Also Send Feedback
Initializes a new BoxedTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BoxedTypeSignature(
    ITypeSignature innerType
)

Parameters

innerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type of values being boxed.

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BoxedTypeSignature Methods

[image]

PostSharp 2.0 Documentation
BoxedTypeSignature Methods
BoxedTypeSignature Class See Also Send Feedback

The BoxedTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

BoxedTypeSignature..::..BelongsToClassification Method
BoxedTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

BoxedTypeSignature..::..ContainsGenericArguments Method
BoxedTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

BoxedTypeSignature..::..GetCanonicalHashCode Method
BoxedTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

BoxedTypeSignature..::..GetReflectionWrapper Method
BoxedTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

BoxedTypeSignature..::..GetSystemType Method
BoxedTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
BoxedTypeSignature..::..GetTypeDefinition Method
BoxedTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

BoxedTypeSignature Class
BoxedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
BoxedTypeSignature..::..IsAssignableTo Method
BoxedTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

BoxedTypeSignature Class
BoxedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

BoxedTypeSignature..::..MapGenericArguments Method
BoxedTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

BoxedTypeSignature..::..ToString Method
BoxedTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

BoxedTypeSignature..::..Translate Method
BoxedTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.BoxedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.BoxedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.BoxedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

BoxedTypeSignature..::..WriteReflectionName Method
BoxedTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BoxedTypeSignature Properties

[image]

PostSharp 2.0 Documentation
BoxedTypeSignature Properties
BoxedTypeSignature Class See Also Send Feedback

The BoxedTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of values being boxed. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

BoxedTypeSignature..::..ElementType Property
BoxedTypeSignature Class See Also Send Feedback
Gets the type of values being boxed.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

BoxedTypeSignature..::..Module Property
BoxedTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

BoxedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifier Structure

CustomModifier Structure
Members See Also Send Feedback
Represents a custom modifier, which are tags emitted by compilers that add some meaning to the modified type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct CustomModifier

Remarks

A custom modifier modifies a type and gives a a different meaning. For instance, the IsConst means that the argument should not be changed. Custom modifiers are emitted by compilers.

See Also

CustomModifier Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifier Members

[image]

PostSharp 2.0 Documentation
CustomModifier Members
CustomModifier Structure Constructors Methods Properties See Also Send Feedback

The CustomModifier type exposes the following members.

Constructors

 | Name | Description
Public method | CustomModifier | Initializes a new CustomModifier.

Methods

 | Name | Description
Public method | Translate |

Properties

 | Name | Description
Public property | Required | Specifies whether the custom modifier is required.
Public property | Type | Gets or sets the type of the custom modifier.

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifier Constructor

CustomModifier Constructor
CustomModifier Structure See Also Send Feedback
Initializes a new CustomModifier.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomModifier(
    bool required,
    ITypeSignature type
)

Parameters

required
Type: System..::.Boolean
Whether the custom attribute is required.
type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the custom attribute.

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifier Methods

[image]

PostSharp 2.0 Documentation
CustomModifier Methods
CustomModifier Structure See Also Send Feedback

The CustomModifier type exposes the following members.

Methods

 | Name | Description
Public method | Translate |

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

CustomModifier..::..Translate Method
CustomModifier Structure See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifier.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomModifier Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifier.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifier.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifier Properties

[image]

PostSharp 2.0 Documentation
CustomModifier Properties
CustomModifier Structure See Also Send Feedback

The CustomModifier type exposes the following members.

Properties

 | Name | Description
Public property | Required | Specifies whether the custom modifier is required.
Public property | Type | Gets or sets the type of the custom modifier.

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Required Property

CustomModifier..::..Required Property
CustomModifier Structure See Also Send Feedback
Specifies whether the custom modifier is required.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Required { get; set; }

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Type Property

CustomModifier..::..Type Property
CustomModifier Structure See Also Send Feedback
Gets or sets the type of the custom modifier.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ITypeSignature Type { get; set; }

See Also

CustomModifier Structure
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifierTypeSignature Class

CustomModifierTypeSignature Class
Members See Also Send Feedback
Represents a type modified by a custom modifier.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CustomModifierTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.CustomModifierTypeSignature

See Also

CustomModifierTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifierTypeSignature Members

[image]

PostSharp 2.0 Documentation
CustomModifierTypeSignature Members
CustomModifierTypeSignature Class Constructors Methods Properties See Also Send Feedback

The CustomModifierTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | CustomModifierTypeSignature | Initializes a new CustomModifierTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the modified type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Modifier | Gets the custom modifier.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifierTypeSignature Constructor

CustomModifierTypeSignature Constructor
CustomModifierTypeSignature Class See Also Send Feedback
Initializes a new CustomModifierTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomModifierTypeSignature(
    CustomModifier customModifier,
    ITypeSignature innerType
)

Parameters

customModifier
Type: PostSharp.Sdk.CodeModel.TypeSignatures..::.CustomModifier
The custom modifier.
innerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The modified type.

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifierTypeSignature Methods

[image]

PostSharp 2.0 Documentation
CustomModifierTypeSignature Methods
CustomModifierTypeSignature Class See Also Send Feedback

The CustomModifierTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

CustomModifierTypeSignature..::..BelongsToClassification Method
CustomModifierTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

CustomModifierTypeSignature..::..ContainsGenericArguments Method
CustomModifierTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

CustomModifierTypeSignature..::..GetCanonicalHashCode Method
CustomModifierTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

CustomModifierTypeSignature..::..GetReflectionWrapper Method
CustomModifierTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

CustomModifierTypeSignature..::..GetSystemType Method
CustomModifierTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
CustomModifierTypeSignature..::..GetTypeDefinition Method
CustomModifierTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

CustomModifierTypeSignature Class
CustomModifierTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

CustomModifierTypeSignature..::..GetValueSize Method
CustomModifierTypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
CustomModifierTypeSignature..::..IsAssignableTo Method
CustomModifierTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

CustomModifierTypeSignature Class
CustomModifierTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

CustomModifierTypeSignature..::..MapGenericArguments Method
CustomModifierTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

CustomModifierTypeSignature..::..ToString Method
CustomModifierTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

CustomModifierTypeSignature..::..Translate Method
CustomModifierTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifierTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifierTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.CustomModifierTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Visit Method

CustomModifierTypeSignature..::..Visit Method
CustomModifierTypeSignature Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

CustomModifierTypeSignature..::..WriteReflectionName Method
CustomModifierTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


CustomModifierTypeSignature Properties

[image]

PostSharp 2.0 Documentation
CustomModifierTypeSignature Properties
CustomModifierTypeSignature Class See Also Send Feedback

The CustomModifierTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the modified type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Modifier | Gets the custom modifier.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

CustomModifierTypeSignature..::..ElementType Property
CustomModifierTypeSignature Class See Also Send Feedback
Gets the modified type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Modifier Property

CustomModifierTypeSignature..::..Modifier Property
CustomModifierTypeSignature Class See Also Send Feedback
Gets the custom modifier.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomModifier Modifier { get; }

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

CustomModifierTypeSignature..::..Module Property
CustomModifierTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

CustomModifierTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericParameterTypeSignature Class

GenericParameterTypeSignature Class
Members See Also Send Feedback
Represents a reference to a generic parameter.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericParameterTypeSignature : TypeSignature,
    IGenericParameter, ITypeSignature, IModuleElement, IVisitable<ITypeSignature>,
    IGeneric, IEquatable<ITypeSignature>, IWriteReflectionName

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.GenericParameterTypeSignature

See Also

GenericParameterTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericParameterTypeSignature Members

[image]

PostSharp 2.0 Documentation
GenericParameterTypeSignature Members
GenericParameterTypeSignature Class Methods Properties See Also Send Feedback

The GenericParameterTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
 | GetInstance | Gets a GenericParameterTypeSignature.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Kind | Gets the kind of generic parameter (type or method).
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Ordinal | Gets the generic parameter ordinal.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericParameterTypeSignature Methods

[image]

PostSharp 2.0 Documentation
GenericParameterTypeSignature Methods
GenericParameterTypeSignature Class See Also Send Feedback

The GenericParameterTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
 | GetInstance | Gets a GenericParameterTypeSignature.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Inherited from TypeSignature.)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Gets the name of a given declaration as it should be displayed to the user. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Returns the meaningful type out of a given type signature. Removes specified modifiers and resolves type references. (Uses default options.) (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration and returns a string that is compatible with the result of the ToString method of system reflection objects. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Overloaded. Gets the name of a given declaration, constructed using given options. (Defined by WriteReflectionNameExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a given runtime value. (Defined by TypeSignatureExtensions.)
Public Extension Method | [extension] | Determines whether a given type signature can be assigned a null value. (Defined by TypeSignatureExtensions.)

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

GenericParameterTypeSignature..::..BelongsToClassification Method
GenericParameterTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)
ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

GenericParameterTypeSignature..::..ContainsGenericArguments Method
GenericParameterTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()
ITypeSignature..::.ContainsGenericArguments()()()

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

GenericParameterTypeSignature..::..GetCanonicalHashCode Method
GenericParameterTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()
ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetInstance Method

GenericParameterTypeSignature..::..GetInstance Method
GenericParameterTypeSignature Class See Also Send Feedback
Gets a GenericParameterTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static GenericParameterTypeSignature GetInstance(
    ModuleDeclaration module,
    int ordinal,
    GenericParameterKind genericParameterKind
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module for which the instance is valid.
ordinal
Type: System..::.Int32
Ordinal.
genericParameterKind
Type: PostSharp.Sdk.CodeModel..::.GenericParameterKind
Kind of generic parameter (method or type).

Return Value

The requested GenericParameterTypeSignature.

Remarks

User code should call DeclarationCache.GetGenericParameter(Int32, GenericParameterKind) instead of this method.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

GenericParameterTypeSignature..::..GetReflectionWrapper Method
GenericParameterTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])
ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

GenericParameterTypeSignature..::..GetSystemType Method
GenericParameterTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])
ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
GenericParameterTypeSignature..::..GetTypeDefinition Method
GenericParameterTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

GenericParameterTypeSignature Class
GenericParameterTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
GenericParameterTypeSignature..::..IsAssignableTo Method
GenericParameterTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

GenericParameterTypeSignature Class
GenericParameterTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

GenericParameterTypeSignature..::..MapGenericArguments Method
GenericParameterTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)
ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

GenericParameterTypeSignature..::..ToString Method
GenericParameterTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

GenericParameterTypeSignature..::..Translate Method
GenericParameterTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericParameterTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericParameterTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericParameterTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

GenericParameterTypeSignature..::..WriteReflectionName Method
GenericParameterTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)
IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericParameterTypeSignature Properties

[image]

PostSharp 2.0 Documentation
GenericParameterTypeSignature Properties
GenericParameterTypeSignature Class See Also Send Feedback

The GenericParameterTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Kind | Gets the kind of generic parameter (type or method).
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Ordinal | Gets the generic parameter ordinal.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

GenericParameterTypeSignature..::..ElementType Property
GenericParameterTypeSignature Class See Also Send Feedback
Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

Remarks

A TypeSignature, or null if there is no textWriter type.

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Kind Property

GenericParameterTypeSignature..::..Kind Property
GenericParameterTypeSignature Class See Also Send Feedback
Gets the kind of generic parameter (type or method).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericParameterKind Kind { get; }

Implements

IGenericParameter..::.Kind

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

GenericParameterTypeSignature..::..Module Property
GenericParameterTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module
IModuleElement..::.Module

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Ordinal Property

GenericParameterTypeSignature..::..Ordinal Property
GenericParameterTypeSignature Class See Also Send Feedback
Gets the generic parameter ordinal.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; }

Implements

IGenericParameter..::.Ordinal

See Also

GenericParameterTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericTypeInstanceTypeSignature Class

GenericTypeInstanceTypeSignature Class
Members See Also Send Feedback
Represents a generic type construction.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GenericTypeInstanceTypeSignature : TypeSignature,
    IGenericInstance, IGeneric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.GenericTypeInstanceTypeSignature

See Also

GenericTypeInstanceTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericTypeInstanceTypeSignature Members

[image]

PostSharp 2.0 Documentation
GenericTypeInstanceTypeSignature Members
GenericTypeInstanceTypeSignature Class Constructors Methods Properties See Also Send Feedback

The GenericTypeInstanceTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | GenericTypeInstanceTypeSignature | Initializes a new GenericTypeInstanceTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Overrides TypeSignature..::.GetGenericContext(GenericContextOptions).)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ResolveGenericContext | Return the GenericMap valid inside the scope of this generic type specification.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the formal generic type. (Overrides TypeSignature..::.ElementType.)
Public property | GenericArguments | Gets the list of concrete generic arguments.
Public property | GenericDefinition | Gets the formal generic type.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Overrides TypeSignature..::.IsGenericInstance.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericTypeInstanceTypeSignature Constructor

GenericTypeInstanceTypeSignature Constructor
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Initializes a new GenericTypeInstanceTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericTypeInstanceTypeSignature(
    INamedType genericDeclaration,
    IList<ITypeSignature> genericArguments
)

Parameters

genericDeclaration
Type: PostSharp.Sdk.CodeModel..::.INamedType
The formal generic type.
genericArguments
Type: System.Collections.Generic..::.IList <(Of <(<' ITypeSignature >)>)>
List of concrete generic arguments.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericTypeInstanceTypeSignature Methods

[image]

PostSharp 2.0 Documentation
GenericTypeInstanceTypeSignature Methods
GenericTypeInstanceTypeSignature Class See Also Send Feedback

The GenericTypeInstanceTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Overrides TypeSignature..::.GetGenericContext(GenericContextOptions).)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ResolveGenericContext | Return the GenericMap valid inside the scope of this generic type specification.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

GenericTypeInstanceTypeSignature..::..BelongsToClassification Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

GenericTypeInstanceTypeSignature..::..ContainsGenericArguments Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

GenericTypeInstanceTypeSignature..::..GetCanonicalHashCode Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetGenericContext Method

GenericTypeInstanceTypeSignature..::..GetGenericContext Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the generic context inside the scope of the generic instance.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override GenericMap GetGenericContext(
    GenericContextOptions options
)

Parameters

options
Type: PostSharp.Sdk.CodeModel..::.GenericContextOptions

[Missing <param name="options"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.GetGenericContext(PostSharp.Sdk.CodeModel.GenericContextOptions)"]

Return Value

A GenericMap mapping ordinals either to GenericParameterDeclaration (in case of generic definition), either of the type signature associated to this ordinal (in the case of generic instance).

Implements

IGeneric..::.GetGenericContext(GenericContextOptions)
IGeneric..::.GetGenericContext(GenericContextOptions)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

GenericTypeInstanceTypeSignature..::..GetReflectionWrapper Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

GenericTypeInstanceTypeSignature..::..GetSystemType Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
GenericTypeInstanceTypeSignature..::..GetTypeDefinition Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

GenericTypeInstanceTypeSignature Class
GenericTypeInstanceTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

GenericTypeInstanceTypeSignature..::..GetValueSize Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.GetValueSize(PostSharp.Sdk.CodeModel.PlatformInfo)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo

[Missing <param name="platform"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.GetValueSize(PostSharp.Sdk.CodeModel.PlatformInfo)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.GetValueSize(PostSharp.Sdk.CodeModel.PlatformInfo)"]

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
GenericTypeInstanceTypeSignature..::..IsAssignableTo Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

GenericTypeInstanceTypeSignature Class
GenericTypeInstanceTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

GenericTypeInstanceTypeSignature..::..MapGenericArguments Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ResolveGenericContext Method

GenericTypeInstanceTypeSignature..::..ResolveGenericContext Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Return the GenericMap valid inside the scope of this generic type specification.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GenericMap ResolveGenericContext(
    GenericMap context
)

Parameters

context
Type: PostSharp.Sdk.CodeModel..::.GenericMap
The GenericMap valid outside the scope of the generic type definition.

Return Value

A GenericMap.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

GenericTypeInstanceTypeSignature..::..ToString Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

GenericTypeInstanceTypeSignature..::..Translate Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.GenericTypeInstanceTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Visit Method

GenericTypeInstanceTypeSignature..::..Visit Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

GenericTypeInstanceTypeSignature..::..WriteReflectionName Method
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericTypeInstanceTypeSignature Properties

[image]

PostSharp 2.0 Documentation
GenericTypeInstanceTypeSignature Properties
GenericTypeInstanceTypeSignature Class See Also Send Feedback

The GenericTypeInstanceTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the formal generic type. (Overrides TypeSignature..::.ElementType.)
Public property | GenericArguments | Gets the list of concrete generic arguments.
Public property | GenericDefinition | Gets the formal generic type.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Overrides TypeSignature..::.IsGenericInstance.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

GenericTypeInstanceTypeSignature..::..ElementType Property
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the formal generic type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericArguments Property

GenericTypeInstanceTypeSignature..::..GenericArguments Property
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the list of concrete generic arguments.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<ITypeSignature> GenericArguments { get; }

Field Value

A read-only list of TypeSignature.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GenericDefinition Property

GenericTypeInstanceTypeSignature..::..GenericDefinition Property
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the formal generic type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public INamedType GenericDefinition { get; }

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsGenericInstance Property

GenericTypeInstanceTypeSignature..::..IsGenericInstance Property
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool IsGenericInstance { get; }

Implements

IGeneric..::.IsGenericInstance
IGeneric..::.IsGenericInstance

Remarks

If the current property returns true, the semantics of IGenericInstance are meaningful for the current instance.

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

GenericTypeInstanceTypeSignature..::..Module Property
GenericTypeInstanceTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

GenericTypeInstanceTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IntrinsicTypeSignature Class

IntrinsicTypeSignature Class
Members See Also Send Feedback
Represents an intrinsic type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IntrinsicTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.IntrinsicTypeSignature

See Also

IntrinsicTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IntrinsicTypeSignature Members

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature Members
IntrinsicTypeSignature Class Methods Properties See Also Send Feedback

The IntrinsicTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
 | GetInstance | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
 | Is | Determines whether a type signature is a given intrinsic.
Public method | IsAssignableTo | Overloaded.
 | IsIntrinsic | Determines whether a Type is intrinsic.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
 | MapReflectionType | Gets the IntrinsicType corresponding to a Type.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IntrinsicType | Gets the intrinsic type.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IntrinsicTypeSignature Methods

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature Methods
IntrinsicTypeSignature Class See Also Send Feedback

The IntrinsicTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
 | GetInstance | Overloaded.
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
 | Is | Determines whether a type signature is a given intrinsic.
Public method | IsAssignableTo | Overloaded.
 | IsIntrinsic | Determines whether a Type is intrinsic.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
 | MapReflectionType | Gets the IntrinsicType corresponding to a Type.
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

IntrinsicTypeSignature..::..BelongsToClassification Method
IntrinsicTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

IntrinsicTypeSignature..::..ContainsGenericArguments Method
IntrinsicTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

IntrinsicTypeSignature..::..GetCanonicalHashCode Method
IntrinsicTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetInstance Method

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature..::..GetInstance Method
IntrinsicTypeSignature Class See Also Send Feedback

Overload List

Name | Description
GetInstance(Type, ModuleDeclaration) | Gets an IntrinsicTypeSignature instance given a reflection Type.
GetInstance(IntrinsicType, ModuleDeclaration) | Gets an instance of a IntrinsicTypeSignature for a given module.

See Also

IntrinsicTypeSignature Class
IntrinsicTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetInstance Method (Type, ModuleDeclaration)

IntrinsicTypeSignature..::..GetInstance Method (Type, ModuleDeclaration)
IntrinsicTypeSignature Class See Also Send Feedback
Gets an IntrinsicTypeSignature instance given a reflection Type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IntrinsicTypeSignature GetInstance(
    Type reflectionType,
    ModuleDeclaration module
)

Parameters

reflectionType
Type: System..::.Type
An intrinsic runtime Type.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module for which the instance should be valid.

Return Value

The IntrinsicTypeSignature corresponding to reflectionType.

Remarks

User code should use the method DeclarationCache.GetIntrinsic(Type) instead of this one.

See Also

IntrinsicTypeSignature Class
GetInstance Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetInstance Method (IntrinsicType, ModuleDeclaration)

IntrinsicTypeSignature..::..GetInstance Method (IntrinsicType, ModuleDeclaration)
IntrinsicTypeSignature Class See Also Send Feedback
Gets an instance of a IntrinsicTypeSignature for a given module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IntrinsicTypeSignature GetInstance(
    IntrinsicType intrinsic,
    ModuleDeclaration module
)

Parameters

intrinsic
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
IntrinsicType for which the type signature is required.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module in which the instance should be valid.

Return Value

An IntrinsicTypeSignature.

See Also

IntrinsicTypeSignature Class
GetInstance Overload
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

IntrinsicTypeSignature..::..GetReflectionWrapper Method
IntrinsicTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

IntrinsicTypeSignature..::..GetSystemType Method
IntrinsicTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature..::..GetTypeDefinition Method
IntrinsicTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

IntrinsicTypeSignature Class
IntrinsicTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

IntrinsicTypeSignature..::..GetValueSize Method
IntrinsicTypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Is Method

IntrinsicTypeSignature..::..Is Method
IntrinsicTypeSignature Class See Also Send Feedback
Determines whether a type signature is a given intrinsic.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Is(
    ITypeSignature typeSignature,
    IntrinsicType intrinsic
)

Parameters

typeSignature
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
A type signature.
intrinsic
Type: PostSharp.Sdk.CodeModel..::.IntrinsicType
An intrinsic.

Return Value

true if typeSignature is the given intrinsic, otherwise false.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature..::..IsAssignableTo Method
IntrinsicTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

IntrinsicTypeSignature Class
IntrinsicTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsIntrinsic Method

IntrinsicTypeSignature..::..IsIntrinsic Method
IntrinsicTypeSignature Class See Also Send Feedback
Determines whether a Type is intrinsic.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsIntrinsic(
    Type reflectionType
)

Parameters

reflectionType
Type: System..::.Type

[Missing <param name="reflectionType"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.IntrinsicTypeSignature.IsIntrinsic(System.Type)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.IntrinsicTypeSignature.IsIntrinsic(System.Type)"]

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

IntrinsicTypeSignature..::..MapGenericArguments Method
IntrinsicTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapReflectionType Method

IntrinsicTypeSignature..::..MapReflectionType Method
IntrinsicTypeSignature Class See Also Send Feedback
Gets the IntrinsicType corresponding to a Type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IntrinsicType MapReflectionType(
    Type reflectionType
)

Parameters

reflectionType
Type: System..::.Type
The Type to be mapped to an IntrinsicType.

Return Value

The IntrinsicType corresponding to reflectionType.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

IntrinsicTypeSignature..::..ToString Method
IntrinsicTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

IntrinsicTypeSignature..::..Translate Method
IntrinsicTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.IntrinsicTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.IntrinsicTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.IntrinsicTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

IntrinsicTypeSignature..::..WriteReflectionName Method
IntrinsicTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IntrinsicTypeSignature Properties

[image]

PostSharp 2.0 Documentation
IntrinsicTypeSignature Properties
IntrinsicTypeSignature Class See Also Send Feedback

The IntrinsicTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IntrinsicType | Gets the intrinsic type.
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

IntrinsicTypeSignature..::..ElementType Property
IntrinsicTypeSignature Class See Also Send Feedback
Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

Remarks

A TypeSignature, or null if there is no textWriter type.

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IntrinsicType Property

IntrinsicTypeSignature..::..IntrinsicType Property
IntrinsicTypeSignature Class See Also Send Feedback
Gets the intrinsic type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IntrinsicType IntrinsicType { get; }

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

IntrinsicTypeSignature..::..Module Property
IntrinsicTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

IntrinsicTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MethodPointerTypeSignature Class

MethodPointerTypeSignature Class
Members See Also Send Feedback
Represents the type of a method pointer.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodPointerTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.MethodPointerTypeSignature

See Also

MethodPointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MethodPointerTypeSignature Members

[image]

PostSharp 2.0 Documentation
MethodPointerTypeSignature Members
MethodPointerTypeSignature Class Constructors Methods Properties See Also Send Feedback

The MethodPointerTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | MethodPointerTypeSignature | Initializes a new MethodPointerTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Signature | Gets the signature of the method referenced by a pointer of the current type.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MethodPointerTypeSignature Constructor

MethodPointerTypeSignature Constructor
MethodPointerTypeSignature Class See Also Send Feedback
Initializes a new MethodPointerTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodPointerTypeSignature(
    MethodSignature method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodSignature
Signature of the method referenced by a pointer of this type.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MethodPointerTypeSignature Methods

[image]

PostSharp 2.0 Documentation
MethodPointerTypeSignature Methods
MethodPointerTypeSignature Class See Also Send Feedback

The MethodPointerTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Overrides TypeSignature..::.Visit(String, Visitor<(Of <(ITypeSignature>)>)).)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

MethodPointerTypeSignature..::..BelongsToClassification Method
MethodPointerTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

MethodPointerTypeSignature..::..ContainsGenericArguments Method
MethodPointerTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

MethodPointerTypeSignature..::..GetCanonicalHashCode Method
MethodPointerTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

MethodPointerTypeSignature..::..GetReflectionWrapper Method
MethodPointerTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

MethodPointerTypeSignature..::..GetSystemType Method
MethodPointerTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
MethodPointerTypeSignature..::..GetTypeDefinition Method
MethodPointerTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

MethodPointerTypeSignature Class
MethodPointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

MethodPointerTypeSignature..::..GetValueSize Method
MethodPointerTypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
MethodPointerTypeSignature..::..IsAssignableTo Method
MethodPointerTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

MethodPointerTypeSignature Class
MethodPointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

MethodPointerTypeSignature..::..MapGenericArguments Method
MethodPointerTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

MethodPointerTypeSignature..::..ToString Method
MethodPointerTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

MethodPointerTypeSignature..::..Translate Method
MethodPointerTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.MethodPointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.MethodPointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.MethodPointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Visit Method

MethodPointerTypeSignature..::..Visit Method
MethodPointerTypeSignature Class See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void Visit(
    string role,
    Visitor<ITypeSignature> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ITypeSignature >)>)>
Delegate that should be called when an item in the given role is found.

Implements

IVisitable<(Of <(?0>)>)..::.Visit(String, Visitor<(Of <(?0>)>))

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

MethodPointerTypeSignature..::..WriteReflectionName Method
MethodPointerTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MethodPointerTypeSignature Properties

[image]

PostSharp 2.0 Documentation
MethodPointerTypeSignature Properties
MethodPointerTypeSignature Class See Also Send Feedback

The MethodPointerTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)
Public property | Signature | Gets the signature of the method referenced by a pointer of the current type.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

MethodPointerTypeSignature..::..ElementType Property
MethodPointerTypeSignature Class See Also Send Feedback
Gets the textWriter TypeSignature, i.e. the next element of the chains of type signature element.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

Remarks

A TypeSignature, or null if there is no textWriter type.

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

MethodPointerTypeSignature..::..Module Property
MethodPointerTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Signature Property

MethodPointerTypeSignature..::..Signature Property
MethodPointerTypeSignature Class See Also Send Feedback
Gets the signature of the method referenced by a pointer of the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSignature Signature { get; }

See Also

MethodPointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PinnedTypeSignature Class

PinnedTypeSignature Class
Members See Also Send Feedback
Represents the type of a pinned pointer.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PinnedTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.PinnedTypeSignature

See Also

PinnedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PinnedTypeSignature Members

[image]

PostSharp 2.0 Documentation
PinnedTypeSignature Members
PinnedTypeSignature Class Constructors Methods Properties See Also Send Feedback

The PinnedTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | PinnedTypeSignature | Initializes a new PinnedTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the underlying pointer type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PinnedTypeSignature Constructor

PinnedTypeSignature Constructor
PinnedTypeSignature Class See Also Send Feedback
Initializes a new PinnedTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PinnedTypeSignature(
    ITypeSignature pointerType
)

Parameters

pointerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the underlying pointer.

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PinnedTypeSignature Methods

[image]

PostSharp 2.0 Documentation
PinnedTypeSignature Methods
PinnedTypeSignature Class See Also Send Feedback

The PinnedTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

PinnedTypeSignature..::..BelongsToClassification Method
PinnedTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

PinnedTypeSignature..::..ContainsGenericArguments Method
PinnedTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

PinnedTypeSignature..::..GetCanonicalHashCode Method
PinnedTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

PinnedTypeSignature..::..GetReflectionWrapper Method
PinnedTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

PinnedTypeSignature..::..GetSystemType Method
PinnedTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
PinnedTypeSignature..::..GetTypeDefinition Method
PinnedTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

PinnedTypeSignature Class
PinnedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

PinnedTypeSignature..::..GetValueSize Method
PinnedTypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
PinnedTypeSignature..::..IsAssignableTo Method
PinnedTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

PinnedTypeSignature Class
PinnedTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

PinnedTypeSignature..::..MapGenericArguments Method
PinnedTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

PinnedTypeSignature..::..ToString Method
PinnedTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

PinnedTypeSignature..::..Translate Method
PinnedTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PinnedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PinnedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PinnedTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

PinnedTypeSignature..::..WriteReflectionName Method
PinnedTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PinnedTypeSignature Properties

[image]

PostSharp 2.0 Documentation
PinnedTypeSignature Properties
PinnedTypeSignature Class See Also Send Feedback

The PinnedTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the underlying pointer type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

PinnedTypeSignature..::..ElementType Property
PinnedTypeSignature Class See Also Send Feedback
Gets the underlying pointer type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

PinnedTypeSignature..::..Module Property
PinnedTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

PinnedTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PointerTypeSignature Class

PointerTypeSignature Class
Members See Also Send Feedback
Represents the type of a pointer (managed or unmanaged).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PointerTypeSignature : TypeSignature

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.TypeSignature
PostSharp.Sdk.CodeModel.TypeSignatures..::.PointerTypeSignature

See Also

PointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PointerTypeSignature Members

[image]

PostSharp 2.0 Documentation
PointerTypeSignature Members
PointerTypeSignature Class Constructors Methods Properties See Also Send Feedback

The PointerTypeSignature type exposes the following members.

Constructors

 | Name | Description
Public method | PointerTypeSignature | Initializes a new PointerTypeSignature.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of the instance referenced to by pointers of this type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | IsManaged | Determines whether the pointer is managed.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PointerTypeSignature Constructor

PointerTypeSignature Constructor
PointerTypeSignature Class See Also Send Feedback
Initializes a new PointerTypeSignature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PointerTypeSignature(
    ITypeSignature innerType,
    bool managed
)

Parameters

innerType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type of the instance referenced to by the pointer.
managed
Type: System..::.Boolean
Determines whether the pointer is managed.

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PointerTypeSignature Methods

[image]

PostSharp 2.0 Documentation
PointerTypeSignature Methods
PointerTypeSignature Class See Also Send Feedback

The PointerTypeSignature type exposes the following members.

Methods

 | Name | Description
Public method | BelongsToClassification | Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate. (Overrides TypeSignature..::.BelongsToClassification(TypeClassifications).)
Public method | ContainsGenericArguments | Determines whether the type signature contains a generic argument. (Overrides TypeSignature..::.ContainsGenericArguments()()().)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from TypeSignature.)
Public method | GetCanonicalHashCode | Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code). (Overrides TypeSignature..::.GetCanonicalHashCode()()().)
Public method | GetGenericContext | Gets the generic context inside the scope of the generic instance. (Inherited from TypeSignature.)
Public method | GetReflectionWrapper | Gets a reflection Type that wraps the current type. (Overrides TypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetSystemType | Gets the system, runtime Type corresponding to the current type. (Overrides TypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[]).)
Public method | GetTypeDefinition | Overloaded.
Public method | GetValueSize | Gets the size of the value type. (Overrides TypeSignature..::.GetValueSize(PlatformInfo).)
Public method | IsAssignableTo | Overloaded.
Public method | MapGenericArguments | Resolves all generic arguments in the current type signature. (Overrides TypeSignature..::.MapGenericArguments(GenericMap).)
Public method | MatchesReference | Determines whether the current type signature matches a given type signature. (Inherited from TypeSignature.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Translate | (Overrides TypeSignature..::.Translate(ModuleDeclaration).)
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively. (Inherited from TypeSignature.)
Public method | WriteReflectionName | Writes the name of the current declaration to a StringBuilder. (Overrides TypeSignature..::.WriteReflectionName(StringBuilder, ReflectionNameOptions).)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


BelongsToClassification Method

PointerTypeSignature..::..BelongsToClassification Method
PointerTypeSignature Class See Also Send Feedback
Determines whether the type signature belongs to a given classification, i.e. whether it fulfills a given predicate.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override NullableBool BelongsToClassification(
    TypeClassifications typeClassification
)

Parameters

typeClassification
Type: PostSharp.Sdk.CodeModel..::.TypeClassifications
The classification (or predicate) (combination of bits are not allowed).

Return Value

True if the predicate is true, False if the predicate is false or Null if it cannot be determined.

Implements

ITypeSignature..::.BelongsToClassification(TypeClassifications)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ContainsGenericArguments Method

PointerTypeSignature..::..ContainsGenericArguments Method
PointerTypeSignature Class See Also Send Feedback
Determines whether the type signature contains a generic argument.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool ContainsGenericArguments()

Return Value

true if the type signature contains a generic argument, otherwise false.

Implements

ITypeSignature..::.ContainsGenericArguments()()()

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetCanonicalHashCode Method

PointerTypeSignature..::..GetCanonicalHashCode Method
PointerTypeSignature Class See Also Send Feedback
Gets a hash code that is invariant under type signature equality (i.e. if two types are equal under IEquatable<(Of <(T>)>), they have the same canonical has code).

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetCanonicalHashCode()

Return Value

A hash code that is invariant under type signature equality.

Implements

ITypeSignature..::.GetCanonicalHashCode()()()

Remarks

This method is of course useful to build dictionaries. The TypeComparer class uses this method.

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetReflectionWrapper Method

PointerTypeSignature..::..GetReflectionWrapper Method
PointerTypeSignature Class See Also Send Feedback
Gets a reflection Type that wraps the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetReflectionWrapper(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

A Type wrapping current type in the given generic context.

Implements

ITypeSignature..::.GetReflectionWrapper(array<Type>[]()[], array<Type>[]()[])

Remarks

This method returns a Type that is different from the system runtime type that is retrieved by GetSystemType(array<Type>[]()[], array<Type>[]()[]). This allows a have a System.Reflection representation of the current type even when it cannot be loaded in the Virtual Runtime Engine.

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetSystemType Method

PointerTypeSignature..::..GetSystemType Method
PointerTypeSignature Class See Also Send Feedback
Gets the system, runtime Type corresponding to the current type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Type GetSystemType(
    Type[] genericTypeArguments,
    Type[] genericMethodArguments
)

Parameters

genericTypeArguments
Type: array< System..::.Type >[]()[][]
Array of generic type arguments in the current context, or null if there is no generic type arguments in the current context.
genericMethodArguments
Type: array< System..::.Type >[]()[][]
Array of generic method arguments in the current context, or null if there is no generic type arguments in the current context.

Return Value

The system Type associated the current type in the given generic context.

Implements

ITypeSignature..::.GetSystemType(array<Type>[]()[], array<Type>[]()[])

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetTypeDefinition Method

[image]

PostSharp 2.0 Documentation
PointerTypeSignature..::..GetTypeDefinition Method
PointerTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTypeDefinition()()() | Finds in the current domain the TypeDefDeclaration corresponding to the current type and uses default BindingOptions. (Inherited from TypeSignature.)
Public method | GetTypeDefinition(BindingOptions) | Finds in the current domain the TypeDefDeclaration corresponding to the current type and specifies BindingOptions. (Inherited from TypeSignature.)

See Also

PointerTypeSignature Class
PointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


GetValueSize Method

PointerTypeSignature..::..GetValueSize Method
PointerTypeSignature Class See Also Send Feedback
Gets the size of the value type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetValueSize(
    PlatformInfo platform
)

Parameters

platform
Type: PostSharp.Sdk.CodeModel..::.PlatformInfo
Information about the target platform.

Return Value

The size of the value type in bytes, or -1 if the type is not a value type or has no fixed size.

Implements

ITypeSignature..::.GetValueSize(PlatformInfo)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsAssignableTo Method

[image]

PostSharp 2.0 Documentation
PointerTypeSignature..::..IsAssignableTo Method
PointerTypeSignature Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAssignableTo(ITypeSignature) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type). (Inherited from TypeSignature.)
Public method | IsAssignableTo(ITypeSignature, GenericMap) | Determines whether instances of the current type is assignable to locations of a specified type (i.e. whether the current type derives or implements this type) and specifies a GenericMap. (Inherited from TypeSignature.)

See Also

PointerTypeSignature Class
PointerTypeSignature Members
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


MapGenericArguments Method

PointerTypeSignature..::..MapGenericArguments Method
PointerTypeSignature Class See Also Send Feedback
Resolves all generic arguments in the current type signature.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature MapGenericArguments(
    GenericMap genericMap
)

Parameters

genericMap
Type: PostSharp.Sdk.CodeModel..::.GenericMap
Generic context in which generic arguments have to be resolved.

Return Value

A IType resolved against genericMap.

Implements

ITypeSignature..::.MapGenericArguments(GenericMap)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ToString Method

PointerTypeSignature..::..ToString Method
PointerTypeSignature Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Translate Method

PointerTypeSignature..::..Translate Method
PointerTypeSignature Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature Translate(
    ModuleDeclaration targetModule
)

Parameters

targetModule
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration

[Missing <param name="targetModule"/> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeModel.TypeSignatures.PointerTypeSignature.Translate(PostSharp.Sdk.CodeModel.ModuleDeclaration)"]

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


WriteReflectionName Method

PointerTypeSignature..::..WriteReflectionName Method
PointerTypeSignature Class See Also Send Feedback
Writes the name of the current declaration to a StringBuilder.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteReflectionName(
    StringBuilder stringBuilder,
    ReflectionNameOptions options
)

Parameters

stringBuilder
Type: System.Text..::.StringBuilder
A StringBuilder.
options
Type: PostSharp.Sdk.CodeModel..::.ReflectionNameOptions
Options influencing how the name is generated.

Implements

IWriteReflectionName..::.WriteReflectionName(StringBuilder, ReflectionNameOptions)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PointerTypeSignature Properties

[image]

PostSharp 2.0 Documentation
PointerTypeSignature Properties
PointerTypeSignature Class See Also Send Feedback

The PointerTypeSignature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyQualifiedName | (Inherited from TypeSignature.)
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from TypeSignature.)
Public property | ElementType | Gets the type of the instance referenced to by pointers of this type. (Overrides TypeSignature..::.ElementType.)
Public property | IsGenericInstance | Determines whether the current instance is a generic instance, i.e. whether it has been constructed from a generic definition. (Inherited from TypeSignature.)
Public property | IsManaged | Determines whether the pointer is managed.
Public property | Module | Gets the declaring module. (Overrides TypeSignature..::.Module.)
Public property | Name | (Inherited from TypeSignature.)

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


ElementType Property

PointerTypeSignature..::..ElementType Property
PointerTypeSignature Class See Also Send Feedback
Gets the type of the instance referenced to by pointers of this type.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ITypeSignature ElementType { get; }

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


IsManaged Property

PointerTypeSignature..::..IsManaged Property
PointerTypeSignature Class See Also Send Feedback
Determines whether the pointer is managed.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsManaged { get; }

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


Module Property

PointerTypeSignature..::..Module Property
PointerTypeSignature Class See Also Send Feedback
Gets the declaring module.

Namespace: PostSharp.Sdk.CodeModel.TypeSignatures
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Module { get; }

Implements

IModuleElement..::.Module

See Also

PointerTypeSignature Class
PostSharp.Sdk.CodeModel.TypeSignatures Namespace


PostSharp.Sdk.CodeWeaver Namespace

PostSharp.Sdk.CodeWeaver Namespace
Send Feedback
The PostSharp.Sdk.CodeWeaver namespace implements a low-level instruction weaver, able to modify the flow of MSIL instructions.

Classes

 | Class | Description
Public class | FieldEncapsulation | Information about the encapsulation of a FieldDefDeclaration into a PropertyDeclaration.
Public class | JoinPoint | A join point is a location in the code tree.
Public class | MethodBodyRestructurer | Restructures a method body so that the original code can be wrapped into a try...catch block.
Public class | Weaver | Weaves advices with main source code.
Public class | WeavingContext | Context of the current join point.
Public class | WeavingHelper | Provides methods that generate frequently used snippets of IL instructions.

Interfaces

 | Interface | Description
Public interface | IAdvice | An advice is a class that is able to produce some MSIL code.
Public interface | IBeforeStaticConstructorAdvice | Interface optionally implemented by advices on join points BeforeStaticConstructor, allowing to specify if the BeforeFieldInit class-level specifier is supported by this advice. An advice should return true if it only initializes static fields. The default, if the interface is not specified, is that this specifier is not specified.
Public interface | ITypedExceptionAdvice | Exposes a method that allows advices of join points AfterMethodBodyException to specify which exceptions should be caught.

Enumerations

 | Enumeration | Description
Public enumeration | ConstructorType | Determines whether the instance constructor calls a constructor its own class (this) or in the base class (base).
Public enumeration | JoinPointKinds | Kinds of join points.
Public enumeration | JoinPointPosition | Position of point points w.r.t. locations.
Public enumeration | MethodBodyRestructurerOptions | Options for the MethodBodyRestructurer class.


ConstructorType Enumeration

ConstructorType Enumeration
See Also Send Feedback
Determines whether the instance constructor calls a constructor its own class (this) or in the base class (base).

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum ConstructorType

Members

Member name | Value | Description
Default | 0 | Default: NotAnInstanceConstructor.
NotAnInstanceConstructor | 0 | The method is not an instance constructor.
CallBase | 1 | The constructor calls the base class.
CallThis | 2 | The constructor calls the current class.
CallNothing | 3 | The constructor does not call any base constructor (struct constructor).

See Also

PostSharp.Sdk.CodeWeaver Namespace


FieldEncapsulation Class

FieldEncapsulation Class
Members See Also Send Feedback
Information about the encapsulation of a FieldDefDeclaration into a PropertyDeclaration.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class FieldEncapsulation

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.FieldEncapsulation

See Also

FieldEncapsulation Members
PostSharp.Sdk.CodeWeaver Namespace


FieldEncapsulation Members

[image]

PostSharp 2.0 Documentation
FieldEncapsulation Members
FieldEncapsulation Class Properties Events See Also Send Feedback

The FieldEncapsulation type exposes the following members.

Properties

 | Name | Description
Public property | GetMethod | Gets the method implementing the Get semantic, or null if this semantic is not defined.
Public property | IsReadOnly | Determines whether the field is read-only.
Public property | Property | Gets the PropertyDeclaration encapsulating the field, or null if no property has been generated.
Public property | SetMethod | Gets the method implementing the Set semantic, or null if this semantic is not defined.

Events

 | Name | Description
Public event | Changed | Event raised when a property has changed.

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


FieldEncapsulation Properties

[image]

PostSharp 2.0 Documentation
FieldEncapsulation Properties
FieldEncapsulation Class See Also Send Feedback

The FieldEncapsulation type exposes the following members.

Properties

 | Name | Description
Public property | GetMethod | Gets the method implementing the Get semantic, or null if this semantic is not defined.
Public property | IsReadOnly | Determines whether the field is read-only.
Public property | Property | Gets the PropertyDeclaration encapsulating the field, or null if no property has been generated.
Public property | SetMethod | Gets the method implementing the Set semantic, or null if this semantic is not defined.

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


GetMethod Property

FieldEncapsulation..::..GetMethod Property
FieldEncapsulation Class See Also Send Feedback
Gets the method implementing the Get semantic, or null if this semantic is not defined.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration GetMethod { get; private set; }

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


IsReadOnly Property

FieldEncapsulation..::..IsReadOnly Property
FieldEncapsulation Class See Also Send Feedback
Determines whether the field is read-only.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; private set; }

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


Property Property

FieldEncapsulation..::..Property Property
FieldEncapsulation Class See Also Send Feedback
Gets the PropertyDeclaration encapsulating the field, or null if no property has been generated.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyDeclaration Property { get; internal set; }

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


SetMethod Property

FieldEncapsulation..::..SetMethod Property
FieldEncapsulation Class See Also Send Feedback
Gets the method implementing the Set semantic, or null if this semantic is not defined.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration SetMethod { get; private set; }

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


FieldEncapsulation Events

[image]

PostSharp 2.0 Documentation
FieldEncapsulation Events
FieldEncapsulation Class See Also Send Feedback

The FieldEncapsulation type exposes the following members.

Events

 | Name | Description
Public event | Changed | Event raised when a property has changed.

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


Changed Event

FieldEncapsulation..::..Changed Event
FieldEncapsulation Class See Also Send Feedback
Event raised when a property has changed.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler Changed

See Also

FieldEncapsulation Class
PostSharp.Sdk.CodeWeaver Namespace


IAdvice Interface

IAdvice Interface
Members See Also Send Feedback
An advice is a class that is able to produce some MSIL code.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAdvice

Remarks

The RequiresWeave(WeavingContext) method determine whether the Weave(WeavingContext, InstructionBlock) method should be called at a given join point.

See Also

IAdvice Members
PostSharp.Sdk.CodeWeaver Namespace


IAdvice Members

[image]

PostSharp 2.0 Documentation
IAdvice Members
IAdvice Interface Methods Properties See Also Send Feedback

The IAdvice type exposes the following members.

Methods

 | Name | Description
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point.
Public method | Weave | Weave the current advice into a given join point, i.e. inject code.

Properties

 | Name | Description
Public property | Priority | Gets the advice priority.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IAdvice Methods

[image]

PostSharp 2.0 Documentation
IAdvice Methods
IAdvice Interface See Also Send Feedback

The IAdvice type exposes the following members.

Methods

 | Name | Description
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point.
Public method | Weave | Weave the current advice into a given join point, i.e. inject code.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


RequiresWeave Method

IAdvice..::..RequiresWeave Method
IAdvice Interface See Also Send Feedback
Determines whether the current advice requires to be woven on a given join point.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool RequiresWeave(
    WeavingContext context
)

Parameters

context
Type: PostSharp.Sdk.CodeWeaver..::.WeavingContext
Weaving context.

Return Value

true if the Weave(WeavingContext, InstructionBlock) method should be called for this join point, otherwise false.

Remarks

It is theoretically possible for this method to return always false, because the Weave(WeavingContext, InstructionBlock) method is not obliged to emit any code. However, restructuring the method body to make weaving possible is expensive, so the RequiresWeave(WeavingContext) method should be designed in order to minimize the number of useless calls to the Weave(WeavingContext, InstructionBlock) method.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


Weave Method

IAdvice..::..Weave Method
IAdvice Interface See Also Send Feedback
Weave the current advice into a given join point, i.e. inject code.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Weave(
    WeavingContext context,
    InstructionBlock block
)

Parameters

context
Type: PostSharp.Sdk.CodeWeaver..::.WeavingContext
Context.
block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
Block where the code has to be injected.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IAdvice Properties

[image]

PostSharp 2.0 Documentation
IAdvice Properties
IAdvice Interface See Also Send Feedback

The IAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Priority | Gets the advice priority.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


Priority Property

IAdvice..::..Priority Property
IAdvice Interface See Also Send Feedback
Gets the advice priority.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int Priority { get; }

Remarks

This influences the order in which advices are applied to join points, in case that many advices are applied to the same join point. In join point of type before or instead of, advices are injected with direct order of priority. In join point of type after, advices are injected with inverse order of priority.

See Also

IAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IBeforeStaticConstructorAdvice Interface

IBeforeStaticConstructorAdvice Interface
Members See Also Send Feedback
Interface optionally implemented by advices on join points BeforeStaticConstructor, allowing to specify if the BeforeFieldInit class-level specifier is supported by this advice. An advice should return true if it only initializes static fields. The default, if the interface is not specified, is that this specifier is not specified.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IBeforeStaticConstructorAdvice : IAdvice

See Also

IBeforeStaticConstructorAdvice Members
PostSharp.Sdk.CodeWeaver Namespace


IBeforeStaticConstructorAdvice Members

[image]

PostSharp 2.0 Documentation
IBeforeStaticConstructorAdvice Members
IBeforeStaticConstructorAdvice Interface Methods Properties See Also Send Feedback

The IBeforeStaticConstructorAdvice type exposes the following members.

Methods

 | Name | Description
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point. (Inherited from IAdvice.)
Public method | Weave | Weave the current advice into a given join point, i.e. inject code. (Inherited from IAdvice.)

Properties

 | Name | Description
Public property | IsBeforeFieldInitSupported | Determines whether the advice is compatible with the BeforeFieldInit class-level specifier.
Public property | Priority | Gets the advice priority. (Inherited from IAdvice.)

See Also

IBeforeStaticConstructorAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IBeforeStaticConstructorAdvice Methods

[image]

PostSharp 2.0 Documentation
IBeforeStaticConstructorAdvice Methods
IBeforeStaticConstructorAdvice Interface See Also Send Feedback

The IBeforeStaticConstructorAdvice type exposes the following members.

Methods

 | Name | Description
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point. (Inherited from IAdvice.)
Public method | Weave | Weave the current advice into a given join point, i.e. inject code. (Inherited from IAdvice.)

See Also

IBeforeStaticConstructorAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IBeforeStaticConstructorAdvice Properties

[image]

PostSharp 2.0 Documentation
IBeforeStaticConstructorAdvice Properties
IBeforeStaticConstructorAdvice Interface See Also Send Feedback

The IBeforeStaticConstructorAdvice type exposes the following members.

Properties

 | Name | Description
Public property | IsBeforeFieldInitSupported | Determines whether the advice is compatible with the BeforeFieldInit class-level specifier.
Public property | Priority | Gets the advice priority. (Inherited from IAdvice.)

See Also

IBeforeStaticConstructorAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


IsBeforeFieldInitSupported Property

IBeforeStaticConstructorAdvice..::..IsBeforeFieldInitSupported Property
IBeforeStaticConstructorAdvice Interface See Also Send Feedback
Determines whether the advice is compatible with the BeforeFieldInit class-level specifier.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool IsBeforeFieldInitSupported { get; }

See Also

IBeforeStaticConstructorAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


ITypedExceptionAdvice Interface

ITypedExceptionAdvice Interface
Members See Also Send Feedback
Exposes a method that allows advices of join points AfterMethodBodyException to specify which exceptions should be caught.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ITypedExceptionAdvice : IAdvice

Remarks

If an advice is applied on a join point of type AfterMethodBodyException but does not implement this interface, all exceptions will be caught.

See Also

ITypedExceptionAdvice Members
PostSharp.Sdk.CodeWeaver Namespace


ITypedExceptionAdvice Members

[image]

PostSharp 2.0 Documentation
ITypedExceptionAdvice Members
ITypedExceptionAdvice Interface Methods Properties See Also Send Feedback

The ITypedExceptionAdvice type exposes the following members.

Methods

 | Name | Description
Public method | GetExceptionType | Gets the type of exceptions that should be caught for advices applied on join points of kind AfterMethodBodyException.
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point. (Inherited from IAdvice.)
Public method | Weave | Weave the current advice into a given join point, i.e. inject code. (Inherited from IAdvice.)

Properties

 | Name | Description
Public property | Priority | Gets the advice priority. (Inherited from IAdvice.)

See Also

ITypedExceptionAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


ITypedExceptionAdvice Methods

[image]

PostSharp 2.0 Documentation
ITypedExceptionAdvice Methods
ITypedExceptionAdvice Interface See Also Send Feedback

The ITypedExceptionAdvice type exposes the following members.

Methods

 | Name | Description
Public method | GetExceptionType | Gets the type of exceptions that should be caught for advices applied on join points of kind AfterMethodBodyException.
Public method | RequiresWeave | Determines whether the current advice requires to be woven on a given join point. (Inherited from IAdvice.)
Public method | Weave | Weave the current advice into a given join point, i.e. inject code. (Inherited from IAdvice.)

See Also

ITypedExceptionAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


GetExceptionType Method

ITypedExceptionAdvice..::..GetExceptionType Method
ITypedExceptionAdvice Interface See Also Send Feedback
Gets the type of exceptions that should be caught for advices applied on join points of kind AfterMethodBodyException.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ITypeSignature GetExceptionType(
    WeavingContext context
)

Parameters

context
Type: PostSharp.Sdk.CodeWeaver..::.WeavingContext
The weaving context.

Return Value

A Type (derived from Exception), or null if any Exception is to be caught.

See Also

ITypedExceptionAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


ITypedExceptionAdvice Properties

[image]

PostSharp 2.0 Documentation
ITypedExceptionAdvice Properties
ITypedExceptionAdvice Interface See Also Send Feedback

The ITypedExceptionAdvice type exposes the following members.

Properties

 | Name | Description
Public property | Priority | Gets the advice priority. (Inherited from IAdvice.)

See Also

ITypedExceptionAdvice Interface
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Class

JoinPoint Class
Members See Also Send Feedback
A join point is a location in the code tree.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class JoinPoint

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.JoinPoint

See Also

JoinPoint Members
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Members

[image]

PostSharp 2.0 Documentation
JoinPoint Members
JoinPoint Class Constructors Methods Properties See Also Send Feedback

The JoinPoint type exposes the following members.

Constructors

 | Name | Description
Public method | JoinPoint | Initializes a new instance of the JoinPoint class

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | ExceptionHandler | Current exception handler.
Public property | Instruction | Gets the current instruction.
Public property | JoinPointKind | Kind of join point.
Public property | Position | Current position w.r.t. the location (Before, InsteadOf, After).

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Constructor

JoinPoint Constructor
JoinPoint Class See Also Send Feedback
Initializes a new instance of the JoinPoint class

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public JoinPoint()

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Methods

[image]

PostSharp 2.0 Documentation
JoinPoint Methods
JoinPoint Class See Also Send Feedback

The JoinPoint type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


ToString Method

JoinPoint..::..ToString Method
JoinPoint Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Properties

[image]

PostSharp 2.0 Documentation
JoinPoint Properties
JoinPoint Class See Also Send Feedback

The JoinPoint type exposes the following members.

Properties

 | Name | Description
Public property | ExceptionHandler | Current exception handler.
Public property | Instruction | Gets the current instruction.
Public property | JoinPointKind | Kind of join point.
Public property | Position | Current position w.r.t. the location (Before, InsteadOf, After).

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


ExceptionHandler Property

JoinPoint..::..ExceptionHandler Property
JoinPoint Class See Also Send Feedback
Current exception handler.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler ExceptionHandler { get; internal set; }

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


Instruction Property

JoinPoint..::..Instruction Property
JoinPoint Class See Also Send Feedback
Gets the current instruction.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Instruction Instruction { get; internal set; }

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPointKind Property

JoinPoint..::..JoinPointKind Property
JoinPoint Class See Also Send Feedback
Kind of join point.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public JoinPointKinds JoinPointKind { get; internal set; }

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


Position Property

JoinPoint..::..Position Property
JoinPoint Class See Also Send Feedback
Current position w.r.t. the location (Before, InsteadOf, After).

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public JoinPointPosition Position { get; internal set; }

See Also

JoinPoint Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPointKinds Enumeration

JoinPointKinds Enumeration
See Also Send Feedback
Kinds of join points.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum JoinPointKinds

Members

Member name | Value | Description
None | 0 | Any.
BeforeMethodBody | 2 | Before the method body. This is a method-level advice.
AfterMethodBodyAlways | 4 | After the method body, in every case (exception or normal termination). This is a method-level advice.
AfterMethodBodySuccess | 2097152 | After the method body, in case of success. This is a method-level advice.
AfterMethodBodyException | 8 | After the method body, only in case of exception. This is a method-level advice.
BeforeGetField | 16 | Before getting a field. This is a method-level advice.
AfterGetField | 32 | After getting a field. This is a method-level advice.
InsteadOfGetField | 64 | Instead of getting a field. This is both a field-level and method-level advice.
BeforeSetField | 128 | Before setting a field. This is a method-level advice.
AfterSetField | 256 | After setting a field. This is a method-level advice.
InsteadOfSetField | 512 | Instead of setting a field. This is a method-level advice.
BeforeCall | 1024 | Before calling a method. This is a method-level advice.
AfterCall | 2048 | After calling a method. This is a method-level advice.
InsteadOfCall | 4096 | Instead of calling a method. This is a method-level advice.
BeforeGetArray | 8192 | Before getting an array element. This is a method-level advice.
AfterGetArray | 16384 | After getting an array element. This is a method-level advice.
InsteadOfGetArray | 32768 | Instead of getting an array element. This is a method-level advice.
BeforeSetArray | 65536 | Before setting an array element. This is a method-level advice.
AfterSetArray | 131072 | After setting an array element. This is a method-level advice.
InsteadOfSetArray | 262144 | Instead of setting an array element. This is a method-level advice.
BeforeThrow | 524288 | Before the throw or rethrow instruction. This is a method-level advice.
BeforeInstanceConstructor | 1 | In the real beginning of instance constructors, even before the this pointer is initialized. This is a method-level advice.
BeforeStaticConstructor | 1048576 | Before the class/static constructors (creates the class constructor if not yet present). This is a type-level advice.
AfterInstanceInitialization | 4194304 | Just after the this pointer has been initialized (in each constructor that calls the constructor of the base type). This is a type-level advice.
BeforeNewObject | 8388608 | Just before the newobj instruction.
InsteadOfNewObject | 16777216 | Instead of the newobj instruction.
AfterNewObject | 33554432 | Just before the newobj instruction.
BeforeGetFieldAddress | 67108864 | Just before the ldflda or ldsflda instruction.
AfterGetFieldAddress | 134217728 | Just after the ldflda or ldsflda instruction.
InsteadOfGetFieldAddress | 268435456 | Instead of the ldflda or ldsflda instruction.
BeforeLoadArgument | 536870912 | Just before the ldarg* instructions.
AfterLoadArgument | 1073741824 | Just after the ldarg* instructions.
InsteadOfLoadArgument | -2147483648 | Instead of the ldarg* instructions.
BeforeStoreArgument | 1 | Just before the starg* instructions.
AfterStoreArgument | 2 | Just after the starg* instructions.
InsteadOfStoreArgument | 4 | Instead of the starg* instructions.
BeforeLoadArgumentAddress | 8 | Just before the ldarga* instructions.
AfterLoadArgumentAddress | 16 | Just after the ldarga* instructions.
InsteadOfLoadArgumentAddress | 32 | Instead of the ldarga* instructions.

See Also

PostSharp.Sdk.CodeWeaver Namespace


JoinPointPosition Enumeration

JoinPointPosition Enumeration
See Also Send Feedback
Position of point points w.r.t. locations.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum JoinPointPosition

Members

Member name | Value | Description
Before | 0 | Before the location.
After | 1 | After the location.
InsteadOf | 2 | Instead of the current instruction.

See Also

PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurer Class

MethodBodyRestructurer Class
Members See Also Send Feedback
Restructures a method body so that the original code can be wrapped into a try...catch block.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MethodBodyRestructurer

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.MethodBodyRestructurer

See Also

MethodBodyRestructurer Members
PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurer Members

[image]

PostSharp 2.0 Documentation
MethodBodyRestructurer Members
MethodBodyRestructurer Class Constructors Methods Properties See Also Send Feedback

The MethodBodyRestructurer type exposes the following members.

Constructors

 | Name | Description
Public method | MethodBodyRestructurer | Initializes a new MethodBodyRestructurer.

Methods

 | Name | Description
Public method | Restructure | Proceeds with the method body restructuring process.

Properties

 | Name | Description
Public property | AfterInitializationBlock | Gets the block execute just after the instance is initialized.
Public property | ConstructorType | Gets the kind of constructor that was passed.
Public property | EntryBlock | Gets the entry block.
Public property | InitializationBlock | Gets the block initializing the object (in case the method is a constructor).
Public property | PrincipalBlock | Gets the block containing the original code, after the object has been initialized.
Public property | ReturnBranchTarget | Gets the InstructionSequence containing the ret instruction.
Public property | ReturnValueVariable | Gets the variable containing the return value in the exit block.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurer Constructor

MethodBodyRestructurer Constructor
MethodBodyRestructurer Class See Also Send Feedback
Initializes a new MethodBodyRestructurer.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodBodyRestructurer(
    MethodDefDeclaration method,
    MethodBodyRestructurerOptions options,
    WeavingHelper weavingHelper
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The method that will be restructured.
options
Type: PostSharp.Sdk.CodeWeaver..::.MethodBodyRestructurerOptions
Options.
weavingHelper
Type: PostSharp.Sdk.CodeWeaver..::.WeavingHelper
A WeavingHelper.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurer Methods

[image]

PostSharp 2.0 Documentation
MethodBodyRestructurer Methods
MethodBodyRestructurer Class See Also Send Feedback

The MethodBodyRestructurer type exposes the following members.

Methods

 | Name | Description
Public method | Restructure | Proceeds with the method body restructuring process.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


Restructure Method

MethodBodyRestructurer..::..Restructure Method
MethodBodyRestructurer Class See Also Send Feedback
Proceeds with the method body restructuring process.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Restructure(
    InstructionWriter writer
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurer Properties

[image]

PostSharp 2.0 Documentation
MethodBodyRestructurer Properties
MethodBodyRestructurer Class See Also Send Feedback

The MethodBodyRestructurer type exposes the following members.

Properties

 | Name | Description
Public property | AfterInitializationBlock | Gets the block execute just after the instance is initialized.
Public property | ConstructorType | Gets the kind of constructor that was passed.
Public property | EntryBlock | Gets the entry block.
Public property | InitializationBlock | Gets the block initializing the object (in case the method is a constructor).
Public property | PrincipalBlock | Gets the block containing the original code, after the object has been initialized.
Public property | ReturnBranchTarget | Gets the InstructionSequence containing the ret instruction.
Public property | ReturnValueVariable | Gets the variable containing the return value in the exit block.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


AfterInitializationBlock Property

MethodBodyRestructurer..::..AfterInitializationBlock Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the block execute just after the instance is initialized.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock AfterInitializationBlock { get; }

Field Value

An InstructionBlock, or null if the method is not a constructor.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


ConstructorType Property

MethodBodyRestructurer..::..ConstructorType Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the kind of constructor that was passed.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ConstructorType ConstructorType { get; }

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


EntryBlock Property

MethodBodyRestructurer..::..EntryBlock Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the entry block.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock EntryBlock { get; }

Remarks

The entry block is a block that will be executed before any other in the method.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


InitializationBlock Property

MethodBodyRestructurer..::..InitializationBlock Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the block initializing the object (in case the method is a constructor).

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock InitializationBlock { get; }

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


PrincipalBlock Property

MethodBodyRestructurer..::..PrincipalBlock Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the block containing the original code, after the object has been initialized.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock PrincipalBlock { get; }

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


ReturnBranchTarget Property

MethodBodyRestructurer..::..ReturnBranchTarget Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the InstructionSequence containing the ret instruction.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence ReturnBranchTarget { get; }

Remarks

This instruction sequence loads the value of ReturnValueVariable, then returns to the calling context. When some code in the protected block (PrincipalBlock) wants to return to the calling context, it cannot use directly the ret instruction but should first set the ReturnValueVariable variable (unless the method returns void), then use the leave instruction to the ReturnBranchTarget instruction sequence.

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


ReturnValueVariable Property

MethodBodyRestructurer..::..ReturnValueVariable Property
MethodBodyRestructurer Class See Also Send Feedback
Gets the variable containing the return value in the exit block.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol ReturnValueVariable { get; }

See Also

MethodBodyRestructurer Class
PostSharp.Sdk.CodeWeaver Namespace


MethodBodyRestructurerOptions Enumeration

MethodBodyRestructurerOptions Enumeration
See Also Send Feedback
Options for the MethodBodyRestructurer class.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum MethodBodyRestructurerOptions

Members

Member name | Value | Description
None | 0 | Default.
ChangeReturnInstructions | 1 | Change ret instructions into branching instructions.

See Also

PostSharp.Sdk.CodeWeaver Namespace


Weaver Class

Weaver Class
Members See Also Send Feedback
Weaves advices with main source code.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class Weaver : IDisposable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.Weaver

See Also

Weaver Members
PostSharp.Sdk.CodeWeaver Namespace


Weaver Members

[image]

PostSharp 2.0 Documentation
Weaver Members
Weaver Class Constructors Methods See Also Send Feedback

The Weaver type exposes the following members.

Constructors

 | Name | Description
Public method | Weaver | Initializes a new Weaver.

Methods

 | Name | Description
Public method | AddFieldLevelAdvice | Obsolete. Adds a field-level advice to the current Weaver.
Public method | AddMethodLevelAdvice | Adds a method-level advice to the current Weaver.
Public method | AddTypeLevelAdvice | Adds a type-level advice to the current Weaver.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EncapsulateField |
Public method | GeneratePropertyAroundField | Informs the weaver that a property should be generated around a field.
 | IgnoreMethod | Specifies that a method should be ignored (skipped) by the Weaver.
Public method | Weave | Weave the module to which the current Weaver is related using the current set of advices.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


Weaver Constructor

Weaver Constructor
Weaver Class See Also Send Feedback
Initializes a new Weaver.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Weaver(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
Project to which the new Weaver is assigned.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


Weaver Methods

[image]

PostSharp 2.0 Documentation
Weaver Methods
Weaver Class See Also Send Feedback

The Weaver type exposes the following members.

Methods

 | Name | Description
Public method | AddFieldLevelAdvice | Obsolete. Adds a field-level advice to the current Weaver.
Public method | AddMethodLevelAdvice | Adds a method-level advice to the current Weaver.
Public method | AddTypeLevelAdvice | Adds a type-level advice to the current Weaver.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EncapsulateField |
Public method | GeneratePropertyAroundField | Informs the weaver that a property should be generated around a field.
 | IgnoreMethod | Specifies that a method should be ignored (skipped) by the Weaver.
Public method | Weave | Weave the module to which the current Weaver is related using the current set of advices.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


AddFieldLevelAdvice Method

Weaver..::..AddFieldLevelAdvice Method
Weaver Class See Also Send Feedback
Adds a field-level advice to the current Weaver.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Use the EncapsulateField method.")]
public void AddFieldLevelAdvice(
    IAdvice advice,
    JoinPointKinds joinPointKinds,
    IEnumerable<IField> fields
)

Parameters

advice
Type: PostSharp.Sdk.CodeWeaver..::.IAdvice
An advice.
joinPointKinds
Type: PostSharp.Sdk.CodeWeaver..::.JoinPointKinds
The kinds of join points to which the advice applies.
fields
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' IField >)>)>
The set of fields to which the advice applies.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


AddMethodLevelAdvice Method

Weaver..::..AddMethodLevelAdvice Method
Weaver Class See Also Send Feedback
Adds a method-level advice to the current Weaver.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddMethodLevelAdvice(
    IAdvice advice,
    IEnumerable<MethodDefDeclaration> methods,
    JoinPointKinds joinPointKinds,
    IEnumerable<MetadataDeclaration> operands
)

Parameters

advice
Type: PostSharp.Sdk.CodeWeaver..::.IAdvice
An advice.
methods
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' MethodDefDeclaration >)>)>
The set of methods to which the advice applies, or null if the advice applies to all methods.
joinPointKinds
Type: PostSharp.Sdk.CodeWeaver..::.JoinPointKinds
The kinds of join points to which the advice applies.
operands
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' MetadataDeclaration >)>)>
The set of operands to which the advice applies, or null if the selected kinds of join points have no operand or if the advice applies to all operands.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


AddTypeLevelAdvice Method

Weaver..::..AddTypeLevelAdvice Method
Weaver Class See Also Send Feedback
Adds a type-level advice to the current Weaver.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddTypeLevelAdvice(
    IAdvice advice,
    JoinPointKinds joinPointKinds,
    IEnumerable<TypeDefDeclaration> types
)

Parameters

advice
Type: PostSharp.Sdk.CodeWeaver..::.IAdvice
An advice.
joinPointKinds
Type: PostSharp.Sdk.CodeWeaver..::.JoinPointKinds
The kinds of join points to which the advice applies.
types
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' TypeDefDeclaration >)>)>
The set of types to which the advice applies.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


Dispose Method

Weaver..::..Dispose Method
Weaver Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


EncapsulateField Method

Weaver..::..EncapsulateField Method
Weaver Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.CodeWeaver.Weaver.EncapsulateField(PostSharp.Sdk.CodeModel.FieldDefDeclaration,System.Boolean)"]

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public FieldEncapsulation EncapsulateField(
    FieldDefDeclaration field,
    bool changeToProperty
)

Parameters

field
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration

[Missing <param name="field"/> documentation for "M:PostSharp.Sdk.CodeWeaver.Weaver.EncapsulateField(PostSharp.Sdk.CodeModel.FieldDefDeclaration,System.Boolean)"]

changeToProperty
Type: System..::.Boolean

[Missing <param name="changeToProperty"/> documentation for "M:PostSharp.Sdk.CodeWeaver.Weaver.EncapsulateField(PostSharp.Sdk.CodeModel.FieldDefDeclaration,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.CodeWeaver.Weaver.EncapsulateField(PostSharp.Sdk.CodeModel.FieldDefDeclaration,System.Boolean)"]

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


GeneratePropertyAroundField Method

Weaver..::..GeneratePropertyAroundField Method
Weaver Class See Also Send Feedback
Informs the weaver that a property should be generated around a field.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void GeneratePropertyAroundField(
    FieldDefDeclaration fieldDef
)

Parameters

fieldDef
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
Field that should be wrapped by a property.

Remarks

If this property is set, the field is made private and renamed, and a property with the original name and visibility of the field is created.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


IgnoreMethod Method

Weaver..::..IgnoreMethod Method
Weaver Class See Also Send Feedback
Specifies that a method should be ignored (skipped) by the Weaver.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void IgnoreMethod(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A method.

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


Weave Method

Weaver..::..Weave Method
Weaver Class See Also Send Feedback
Weave the module to which the current Weaver is related using the current set of advices.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Weave()

See Also

Weaver Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingContext Class

WeavingContext Class
Members See Also Send Feedback
Context of the current join point.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class WeavingContext : IDisposable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.WeavingContext

See Also

WeavingContext Members
PostSharp.Sdk.CodeWeaver Namespace


WeavingContext Members

[image]

PostSharp 2.0 Documentation
WeavingContext Members
WeavingContext Class Methods Properties See Also Send Feedback

The WeavingContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Properties

 | Name | Description
Public property | ExceptionHandler | Gets the current exception handler.
Public property | InstructionBlock | Gets the current instruction block.
Public property | InstructionReader | Gets the InstructionReader located at the current instruction.
Public property | InstructionWriter | Gets an instance of InstructionWriter shared by all advices.
Public property | IsThisInitialized | Determines whether the this pointer is initialized.
Public property | JoinPoint | Gets the current join point.
Public property | LeaveBranchTarget | Gets the InstructionSequence containing the next (i.e. immediately outer) on-success handler in the chain.
Public property | Method | Gets the current method.
Public property | OnSuccessBranchTarget | Gets the InstructionSequence containing the current on-success handler in the chain.
Public property | ReturnValueVariable | Gets the variable containing at runtime the return value, in join points of type AfterMethodBodyAlways and AfterMethodBodyException
Public property | WeavingHelper | Gets a WeavingHelper, which provides utility functions typically used during weaving.

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingContext Methods

[image]

PostSharp 2.0 Documentation
WeavingContext Methods
WeavingContext Class See Also Send Feedback

The WeavingContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


Dispose Method

WeavingContext..::..Dispose Method
WeavingContext Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingContext Properties

[image]

PostSharp 2.0 Documentation
WeavingContext Properties
WeavingContext Class See Also Send Feedback

The WeavingContext type exposes the following members.

Properties

 | Name | Description
Public property | ExceptionHandler | Gets the current exception handler.
Public property | InstructionBlock | Gets the current instruction block.
Public property | InstructionReader | Gets the InstructionReader located at the current instruction.
Public property | InstructionWriter | Gets an instance of InstructionWriter shared by all advices.
Public property | IsThisInitialized | Determines whether the this pointer is initialized.
Public property | JoinPoint | Gets the current join point.
Public property | LeaveBranchTarget | Gets the InstructionSequence containing the next (i.e. immediately outer) on-success handler in the chain.
Public property | Method | Gets the current method.
Public property | OnSuccessBranchTarget | Gets the InstructionSequence containing the current on-success handler in the chain.
Public property | ReturnValueVariable | Gets the variable containing at runtime the return value, in join points of type AfterMethodBodyAlways and AfterMethodBodyException
Public property | WeavingHelper | Gets a WeavingHelper, which provides utility functions typically used during weaving.

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


ExceptionHandler Property

WeavingContext..::..ExceptionHandler Property
WeavingContext Class See Also Send Feedback
Gets the current exception handler.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExceptionHandler ExceptionHandler { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


InstructionBlock Property

WeavingContext..::..InstructionBlock Property
WeavingContext Class See Also Send Feedback
Gets the current instruction block.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionBlock InstructionBlock { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


InstructionReader Property

WeavingContext..::..InstructionReader Property
WeavingContext Class See Also Send Feedback
Gets the InstructionReader located at the current instruction.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionReader InstructionReader { get; internal set; }

Remarks

This property is exposed to implement some hardly recommendable workarounds. Prefer the JoinPoint.Instruction property to get the current instruction. You are supposed to leave the InstructionReader at the same position as you received it!

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


InstructionWriter Property

WeavingContext..::..InstructionWriter Property
WeavingContext Class See Also Send Feedback
Gets an instance of InstructionWriter shared by all advices.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionWriter InstructionWriter { get; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


IsThisInitialized Property

WeavingContext..::..IsThisInitialized Property
WeavingContext Class See Also Send Feedback
Determines whether the this pointer is initialized.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsThisInitialized { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


JoinPoint Property

WeavingContext..::..JoinPoint Property
WeavingContext Class See Also Send Feedback
Gets the current join point.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public JoinPoint JoinPoint { get; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


LeaveBranchTarget Property

WeavingContext..::..LeaveBranchTarget Property
WeavingContext Class See Also Send Feedback
Gets the InstructionSequence containing the next (i.e. immediately outer) on-success handler in the chain.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence LeaveBranchTarget { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace
WeavingContext..::.OnSuccessBranchTarget


Method Property

WeavingContext..::..Method Property
WeavingContext Class See Also Send Feedback
Gets the current method.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodDefDeclaration Method { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


OnSuccessBranchTarget Property

WeavingContext..::..OnSuccessBranchTarget Property
WeavingContext Class See Also Send Feedback
Gets the InstructionSequence containing the current on-success handler in the chain.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InstructionSequence OnSuccessBranchTarget { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace
WeavingContext..::.LeaveBranchTarget


ReturnValueVariable Property

WeavingContext..::..ReturnValueVariable Property
WeavingContext Class See Also Send Feedback
Gets the variable containing at runtime the return value, in join points of type AfterMethodBodyAlways and AfterMethodBodyException

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LocalVariableSymbol ReturnValueVariable { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingHelper Property

WeavingContext..::..WeavingHelper Property
WeavingContext Class See Also Send Feedback
Gets a WeavingHelper, which provides utility functions typically used during weaving.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WeavingHelper WeavingHelper { get; internal set; }

See Also

WeavingContext Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingHelper Class

WeavingHelper Class
Members See Also Send Feedback
Provides methods that generate frequently used snippets of IL instructions.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class WeavingHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeWeaver..::.WeavingHelper

See Also

WeavingHelper Members
PostSharp.Sdk.CodeWeaver Namespace


WeavingHelper Members

[image]

PostSharp 2.0 Documentation
WeavingHelper Members
WeavingHelper Class Constructors Methods See Also Send Feedback

The WeavingHelper type exposes the following members.

Constructors

 | Name | Description
Public method | WeavingHelper | Initializes a new WeavingHelper.

Methods

 | Name | Description
Public method | AddCompilerGeneratedAttribute | Builds a CustomAttributeDeclaration representing the CompilerGeneratedAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.
Public method | AddDebuggerNonUserCodeAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.
Public method | AddExceptionHandlers | Adds exception handlers to an InstructionBlock.
Public method | EmitCustomAttributeConstruction | Emits instructions that construct a custom attribute.
Public method | FromObject | Obsolete. Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.
Public method | GetCompilerGeneratedAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.
Public method | GetDebuggerNonUserCodeAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.
Public method | GetRuntimeType | Emits instruction that load a runtime type (Type) on the stack.
Public method | MakeArrayOfGenericMethodArguments | Emits instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given method.
Public method | MakeArrayOfGenericTypeArguments | Emit instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given type.
Public method | RedirectReturnInstructions | Transforms an InstructionBlock so that it can be protected and decorated with exception handlers. This method does not add the handlers in themselves.
Public method | ToObject | Obsolete. Emits MSIL instructions that cast an object of any type to an object (eventually boxed).
Public method | WriteLine | Emits instructions that write a line using WriteLine(String).

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingHelper Constructor

WeavingHelper Constructor
WeavingHelper Class See Also Send Feedback
Initializes a new WeavingHelper.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WeavingHelper(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module into which instructions shall be generated.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


WeavingHelper Methods

[image]

PostSharp 2.0 Documentation
WeavingHelper Methods
WeavingHelper Class See Also Send Feedback

The WeavingHelper type exposes the following members.

Methods

 | Name | Description
Public method | AddCompilerGeneratedAttribute | Builds a CustomAttributeDeclaration representing the CompilerGeneratedAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.
Public method | AddDebuggerNonUserCodeAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.
Public method | AddExceptionHandlers | Adds exception handlers to an InstructionBlock.
Public method | EmitCustomAttributeConstruction | Emits instructions that construct a custom attribute.
Public method | FromObject | Obsolete. Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.
Public method | GetCompilerGeneratedAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.
Public method | GetDebuggerNonUserCodeAttribute | Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.
Public method | GetRuntimeType | Emits instruction that load a runtime type (Type) on the stack.
Public method | MakeArrayOfGenericMethodArguments | Emits instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given method.
Public method | MakeArrayOfGenericTypeArguments | Emit instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given type.
Public method | RedirectReturnInstructions | Transforms an InstructionBlock so that it can be protected and decorated with exception handlers. This method does not add the handlers in themselves.
Public method | ToObject | Obsolete. Emits MSIL instructions that cast an object of any type to an object (eventually boxed).
Public method | WriteLine | Emits instructions that write a line using WriteLine(String).

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


AddCompilerGeneratedAttribute Method

WeavingHelper..::..AddCompilerGeneratedAttribute Method
WeavingHelper Class See Also Send Feedback
Builds a CustomAttributeDeclaration representing the CompilerGeneratedAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddCompilerGeneratedAttribute(
    CustomAttributeDeclarationCollection collection
)

Parameters

collection
Type: PostSharp.Sdk.CodeModel.Collections..::.CustomAttributeDeclarationCollection

[Missing <param name="collection"/> documentation for "M:PostSharp.Sdk.CodeWeaver.WeavingHelper.AddCompilerGeneratedAttribute(PostSharp.Sdk.CodeModel.Collections.CustomAttributeDeclarationCollection)"]

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


AddDebuggerNonUserCodeAttribute Method

WeavingHelper..::..AddDebuggerNonUserCodeAttribute Method
WeavingHelper Class See Also Send Feedback
Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute and adds it to a CustomAttributeDeclarationCollection.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddDebuggerNonUserCodeAttribute(
    CustomAttributeDeclarationCollection collection
)

Parameters

collection
Type: PostSharp.Sdk.CodeModel.Collections..::.CustomAttributeDeclarationCollection

[Missing <param name="collection"/> documentation for "M:PostSharp.Sdk.CodeWeaver.WeavingHelper.AddDebuggerNonUserCodeAttribute(PostSharp.Sdk.CodeModel.Collections.CustomAttributeDeclarationCollection)"]

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


AddExceptionHandlers Method

WeavingHelper..::..AddExceptionHandlers Method
WeavingHelper Class See Also Send Feedback
Adds exception handlers to an InstructionBlock.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddExceptionHandlers(
    InstructionWriter writer,
    InstructionBlock block,
    InstructionSequence leaveSequence,
    ITypeSignature[] catchExceptionTypes,
    bool includeFinallyBlock,
    out InstructionBlock protectedBlock,
    out InstructionBlock[] catchBlocks,
    out InstructionBlock finallyBlock
)

Parameters

writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An available InstructionWriter.
block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
The InstructionBlock to which handlers have to be added. This block should be safe for being nested in an exception handler (see the RedirectReturnInstructions(InstructionReader, InstructionWriter, InstructionBlock, InstructionSequence, LocalVariableSymbol, Boolean) method).
leaveSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
The branching target that should be used to jump out of the protected block (typically a sequence located just after this block).
catchExceptionTypes
Type: array< PostSharp.Sdk.CodeModel..::.ITypeSignature >[]()[][]
An array of types for which typed catch handlers should be generated, or null or an empty array if no catch handler should be generated.
includeFinallyBlock
Type: System..::.Boolean
true whether a finally handler should be added, otherwise false.
protectedBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock %
At output, an InstructionBlock containing the initial block and its handlers.
catchBlocks
Type: array< PostSharp.Sdk.CodeModel..::.InstructionBlock >[]()[][] %
At output, an array of blocks where the instructions of catch handler can be emitted. The leave instruction is already emitted, so user code should not do it a second time. null if no catch handler was requested.
finallyBlock
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock %
At output, an InstructionBlock where the instruction of the finally handler can be emitted. The endfinally instruction is already emitted, so user code should not do it a second time. null if no finally handler was requested.

Remarks

The method body is modified in such a way that the finally handler protects also the catch handlers. That is, if an exception is thrown from a catch handler, the finally handler will be invoked.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


EmitCustomAttributeConstruction Method

WeavingHelper..::..EmitCustomAttributeConstruction Method
WeavingHelper Class See Also Send Feedback
Emits instructions that construct a custom attribute.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EmitCustomAttributeConstruction(
    IAnnotationValue attribute,
    BaseInstructionWriter writer
)

Parameters

attribute
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
The custom attribute to construct.
writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
An BaseInstructionWriter.

Remarks

Stack transition: ... -> Ref(Of attribute.Constructor.DeclaringType), ... .

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


FromObject Method

WeavingHelper..::..FromObject Method
WeavingHelper Class See Also Send Feedback
Emits MSIL instructions that cast an object (of type Object) to a given type, performing unboxing when needed.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Replaced by InstructionWriter.EmitConvertFromObject")]
public void FromObject(
    ITypeSignature targetType,
    InstructionWriter writer
)

Parameters

targetType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type into which the object has to be converted.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
BaseInstructionWriter into which instructions have to be written.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


GetCompilerGeneratedAttribute Method

WeavingHelper..::..GetCompilerGeneratedAttribute Method
WeavingHelper Class See Also Send Feedback
Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration GetCompilerGeneratedAttribute()

Return Value

A new instance of CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


GetDebuggerNonUserCodeAttribute Method

WeavingHelper..::..GetDebuggerNonUserCodeAttribute Method
WeavingHelper Class See Also Send Feedback
Builds a CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CustomAttributeDeclaration GetDebuggerNonUserCodeAttribute()

Return Value

A new instance of CustomAttributeDeclaration representing the DebuggerNonUserCodeAttribute custom attribute.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


GetRuntimeType Method

WeavingHelper..::..GetRuntimeType Method
WeavingHelper Class See Also Send Feedback
Emits instruction that load a runtime type (Type) on the stack.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void GetRuntimeType(
    ITypeSignature type,
    BaseInstructionWriter writer
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
The type to load on the stack.
writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
An BaseInstructionWriter

Remarks

Stack transition: ... -> Ref(Of Type), ... .

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


MakeArrayOfGenericMethodArguments Method

WeavingHelper..::..MakeArrayOfGenericMethodArguments Method
WeavingHelper Class See Also Send Feedback
Emits instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given method.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MakeArrayOfGenericMethodArguments(
    MethodDefDeclaration method,
    InstructionWriter writer
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
Method for which generic arguments have to be read.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
InstructionWriter.

Remarks

Stack transition: ... -> array, ... .

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


MakeArrayOfGenericTypeArguments Method

WeavingHelper..::..MakeArrayOfGenericTypeArguments Method
WeavingHelper Class See Also Send Feedback
Emit instructions that create a new array of types (Type[]) and fills it with all generic arguments of a given type.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MakeArrayOfGenericTypeArguments(
    TypeDefDeclaration type,
    InstructionWriter writer
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Type for which generic arguments have to be read.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An InstructionWriter.

Remarks

Stack transition: ... -> array, ... .

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


RedirectReturnInstructions Method

WeavingHelper..::..RedirectReturnInstructions Method
WeavingHelper Class See Also Send Feedback
Transforms an InstructionBlock so that it can be protected and decorated with exception handlers. This method does not add the handlers in themselves.

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RedirectReturnInstructions(
    InstructionReader reader,
    InstructionWriter writer,
    InstructionBlock block,
    InstructionSequence returnSequence,
    LocalVariableSymbol returnValueVariable,
    bool useLeave
)

Parameters

reader
Type: PostSharp.Sdk.CodeModel..::.InstructionReader
An InstructionReader assigned to the method of the current InstructionBlock.
writer
Type: PostSharp.Sdk.CodeModel..::.InstructionWriter
An available InstructionWriter.
block
Type: PostSharp.Sdk.CodeModel..::.InstructionBlock
An InstructionBlock attached to a method.
returnSequence
Type: PostSharp.Sdk.CodeModel..::.InstructionSequence
An InstructionSequence located outside block, containing the instructions ldloc returnValueVariable; ret. true if leave instructions should be used instead of ret, false to use br instructions.
returnValueVariable
Type: PostSharp.Sdk.CodeModel..::.LocalVariableSymbol
A LocalVariableSymbol where the return value will be stored before the control will be directed to returnSequence.
useLeave
Type: System..::.Boolean

[Missing <param name="useLeave"/> documentation for "M:PostSharp.Sdk.CodeWeaver.WeavingHelper.RedirectReturnInstructions(PostSharp.Sdk.CodeModel.InstructionReader,PostSharp.Sdk.CodeModel.InstructionWriter,PostSharp.Sdk.CodeModel.InstructionBlock,PostSharp.Sdk.CodeModel.InstructionSequence,PostSharp.Sdk.CodeModel.LocalVariableSymbol,System.Boolean)"]

Remarks

The only branching instruction allowed to leave a protected block is the leave instruction. This method should change all branching instructions to leave.

The current implementation of the current method is only able to transform ret instructions, i.e. it assumes that all branch targets are internal to the block to protect.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


ToObject Method

WeavingHelper..::..ToObject Method
WeavingHelper Class See Also Send Feedback
Emits MSIL instructions that cast an object of any type to an object (eventually boxed).

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[ObsoleteAttribute("Replaced by InstructionWriter.EmitConvertToObject")]
public void ToObject(
    ITypeSignature originalType,
    BaseInstructionWriter writer
)

Parameters

originalType
Type: PostSharp.Sdk.CodeModel..::.ITypeSignature
Type to be converted.
writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
BaseInstructionWriter to which instructions have to be written.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


WriteLine Method

WeavingHelper..::..WriteLine Method
WeavingHelper Class See Also Send Feedback
Emits instructions that write a line using WriteLine(String).

Namespace: PostSharp.Sdk.CodeWeaver
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void WriteLine(
    string format,
    BaseInstructionWriter writer,
    params Object[] parameters
)

Parameters

format
Type: System..::.String
Formatting string.
writer
Type: PostSharp.Sdk.CodeModel..::.BaseInstructionWriter
An BaseInstructionWriter.
parameters
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

See Also

WeavingHelper Class
PostSharp.Sdk.CodeWeaver Namespace


PostSharp.Sdk.Collections Namespace

PostSharp.Sdk.Collections Namespace
Send Feedback
The PostSharp.Sdk.Collections defines abstract collection types.

Classes

 | Class | Description
Public class | AppendingSortedList<(Of <(?0, ?1>)>) | Sorted list optimized to situations when items are added in the right order (from the smallest to the greatest).
Public class | AppendingSortedListFactory<(Of <(?0, ?1>)>) | Factory of AppendingSortedList<(Of <(?0, ?1>)>).
Public class | CollectionDebuggerTypeProxy | Debugger viewer that presents any collection (ICollection) according to its semantics instead of its implementation, i.e. it displays the list of items exposed by the interface.
Public class | DictionaryFactory<(Of <(?0, ?1>)>) | Factory of Dictionary<(Of <(TKey, TValue>)>).
Public class | EmptyArray<(Of <(?0>)>) | Provides empty arrays of any type.
Public class | EmptyCollection<(Of <(?0>)>) | An empty and read-only collection.
Public class | EmptyEnumerator<(Of <(?0>)>) | An enumerator over an empty collection.
Public class | EnumerableWrapper<(Of <(?0>)>) | Wraps an IEnumerable<(Of <(T>)>) so that the object behind becoms inaccessible, that is, read-only.
Public class | EnumeratorEnlarger | Provides a method that casts a enumerator of a specific type into an enumerator of a more general type.
Public class | ExtensibleArray<(Of <(?0>)>) | Auto-extensible array composed of extends, with full thread safety and low lock retention.
Public class | Index<(Of <(?0, ?1>)>) | Dictionary of objects indexed by a property of these objects. The index is automatically updated when the key property changes.
Public class | IndexedCollection<(Of <(?0>)>) | Collection of objects indexed by many properties of these objects. The index is automatically updated when the key property changes.
Public class | IndexedCollectionFactory<(Of <(?0>)>) | Factory for IndexedCollection<(Of <(?0>)>).
Public class | IndexFactory<(Of <(?0, ?1>)>) | Factory for Index<(Of <(?0, ?1>)>).
Public class | ListFactory<(Of <(?0>)>) | Factory of List<(Of <(T>)>).
Public class | MarshalByRefCollection<(Of <(?0>)>) | Implementation of generic ICollection<(Of <(T>)>) marshalled by reference.
Public class | MarshalByRefDictionary<(Of <(?0, ?1>)>) | Implementation of generic IDictionary<(Of <(TKey, TValue>)>) marshalled by reference.
Public class | MarshalByRefEnumerator<(Of <(?0>)>) | Wraps an enumerator with a class derived from MarshalByRefObject, so that the enumerator can be used across application domain boundaries.
Public class | MarshalByRefList<(Of <(?0>)>) | Implementation of generic IList<(Of <(T>)>) marshaled by reference.
Public class | MultiDictionary<(Of <(?0, ?1>)>) | Associates many values to a single key.
Public class | MultiDictionaryFactory<(Of <(?0, ?1>)>) | Factory for MultiDictionary<(Of <(?0, ?1>)>).
Public class | NonNullableList<(Of <(?0>)>) | Wraps a list so that it is forbidden to add null items.
Public class | Set<(Of <(?0>)>) | Collection with uniqueness constraint and with read complexity in O(1).
Public class | SimpleLinkedListNode<(Of <(?0>)>) | Minimalist implementation of a one-direction linked list.
Public class | SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator | Enumerator for the class SimpleLinkedListNode<(Of <(?0>)>).
Public class | Singleton<(Of <(?0>)>) | Wraps a single value into a list. A singleton contains zero or one value.
Public class | SingletonEnumerator<(Of <(?0>)>) | Enumerator that returns a single value.
Public class | SortedDictionaryFactory<(Of <(?0, ?1>)>) | Factory of Dictionary<(Of <(TKey, TValue>)>).
Public class | SortedMultiDictionary<(Of <(?0, ?1>)>) | MultiDictionary<(Of <(?0, ?1>)>) where keys are ordered.
Public class | SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) | Factory for SortedMultiDictionary<(Of <(?0, ?1>)>).
Public class | StringSet | Set of strings.
Public class | UnionCollection<(Of <(?0>)>) | Wrapper that exposes the union of two collections as a single collection.

Structures

 | Structure | Description
Public structure | Pair<(Of <(?0, ?1>)>) | Typed pair of values.

Interfaces

 | Interface | Description
Public interface | ICollectionFactory<(Of <(?0>)>) | A collection factory creates instances of collections and allocates capacity.
Public interface | IDictionaryFactory<(Of <(?0, ?1>)>) | A dictionary factory creates instances of collections and allocates capacity.
Public interface | IIndex<(Of <(?0, ?1>)>) | Specifies the interface of an index.
Public interface | IListFactory<(Of <(?0>)>) | A list factory creates instances of lists and allocates capacity.
Public interface | IMultiDictionary<(Of <(?0, ?1>)>) | Specifies a dictionary possibly associating many items to a single key.
Public interface | INamed | Exposes a Name property.
Public interface | IPositioned | Exposes the Ordinal property.
Public interface | IPreAllocatedCollection<(Of <(?0>)>) | Extends the ICollection<(Of <(T>)>) interface by a method EnsureCapacity(Int32) allowing to increase the capacity of the collection.
Public interface | IVisitable<(Of <(?0>)>) | Defines the semantics of an object that can be visited.

Delegates

 | Delegate | Description
Public delegate | Visitor<(Of <(?0>)>) | Signature of the method that should be called by Visit(String, Visitor<(Of <(?0>)>)).

Enumerations

 | Enumeration | Description
Public enumeration | NodePosition | Relative position of nodes in a sequence.


AppendingSortedList(?0, ?1) Class

AppendingSortedList<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Sorted list optimized to situations when items are added in the right order (from the smallest to the greatest).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AppendingSortedList<?0, ?1> : IDictionary<?0, ?1>,
    ICollection<KeyValuePair<?0, ?1>>, IEnumerable<KeyValuePair<?0, ?1>>,
    IEnumerable
where ?0 : Object, IComparable<?0>, IEquatable<?0>
where ?1 : class

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.AppendingSortedList`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.AppendingSortedList`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.AppendingSortedList<(Of <(?0, ?1>)>)

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)> Members
AppendingSortedList<(Of <(?0, ?1>)>) Class Constructors Methods Properties See Also Send Feedback

The AppendingSortedList<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | AppendingSortedList<(Of <(?0, ?1>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.
Public method | CopyTo |
Public method | GetEnumerator |
Public method | Remove | Overloaded.
Public method | TryGetValue | Gets the value associated with the specified key.

Properties

 | Name | Description
Public property | Capacity | Gets the list capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection<(Of <(T>)>) containing the keys of the IDictionary<(Of <(TKey, TValue>)>).
Public property | Values | Gets an ICollection<(Of <(T>)>) containing the values in the IDictionary<(Of <(TKey, TValue>)>).

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Constructor

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)> Constructor
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendingSortedList<(Of <(?0, ?1>)>)(Boolean) | Initializes a new AppendingSortedList<(Of <(?0, ?1>)>) with default capacity.
Public method | AppendingSortedList<(Of <(?0, ?1>)>)(Int32, Boolean) | Initializes a new AppendingSortedList<(Of <(?0, ?1>)>) with given initial capacity.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
AppendingSortedList<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Constructor (Boolean)

AppendingSortedList<(Of <(<'?0, ?1>)>)> Constructor (Boolean)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new AppendingSortedList<(Of <(?0, ?1>)>) with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AppendingSortedList(
    bool allowDuplicates
)

Parameters

allowDuplicates
Type: System..::.Boolean

[Missing <param name="allowDuplicates"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.#ctor(System.Boolean)"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
AppendingSortedList<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Constructor (Int32, Boolean)

AppendingSortedList<(Of <(<'?0, ?1>)>)> Constructor (Int32, Boolean)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new AppendingSortedList<(Of <(?0, ?1>)>) with given initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AppendingSortedList(
    int capacity,
    bool allowDuplicates
)

Parameters

capacity
Type: System..::.Int32
capacity
allowDuplicates
Type: System..::.Boolean
true if the list allows duplicates, false if an exception should be thrown when one tries to add a duplicate to the list.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
AppendingSortedList<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)> Methods
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

The AppendingSortedList<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.
Public method | CopyTo |
Public method | GetEnumerator |
Public method | Remove | Overloaded.
Public method | TryGetValue | Gets the value associated with the specified key.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Add Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) |
Public method | Add(?0, ?1) | Adds an element with the provided key and value to the IDictionary<(Of <(TKey, TValue>)>).

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
AppendingSortedList<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Add Method (KeyValuePair(?0, ?1))

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Add Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


Add Method (?0, ?1)

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Add Method (?0, ?1)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds an element with the provided key and value to the IDictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 key,
    ?1 value
)

Parameters

key
Type: ?0
The object to use as the key of the element to add.
value
Type: ?1
The object to use as the value of the element to add.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Add(TKey, TValue)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.
System..::.ArgumentException | An element with the same key already exists in the IDictionary<(Of <(TKey, TValue>)>).
System..::.NotSupportedException | The IDictionary<(Of <(TKey, TValue>)>) is read-only.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


Clear Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Clear Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Contains Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


ContainsKey Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..ContainsKey Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsKey(
    ?0 key
)

Parameters

key
Type: ?0
The key to locate in the IDictionary<(Of <(TKey, TValue>)>).

Return Value

true if the IDictionary<(Of <(TKey, TValue>)>) contains an element with the key; otherwise, false.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..CopyTo Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    KeyValuePair<?0, ?1>[] array,
    int arrayIndex
)

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)> >[]()[][]

[Missing <param name="array"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

arrayIndex
Type: System..::.Int32

[Missing <param name="arrayIndex"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..GetEnumerator Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<KeyValuePair<?0, ?1>> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.GetEnumerator"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Remove Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(KeyValuePair<(Of <(?0, ?1>)>)) |
Public method | Remove(?0) | Removes the element with the specified key from the IDictionary<(Of <(TKey, TValue>)>).

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
AppendingSortedList<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Remove Method (KeyValuePair(?0, ?1))

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Remove Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.AppendingSortedList`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


Remove Method (?0)

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Remove Method (?0)
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes the element with the specified key from the IDictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 key
)

Parameters

key
Type: ?0
The key of the element to remove.

Return Value

true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionary<(Of <(TKey, TValue>)>).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Remove(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.
System..::.NotSupportedException | The IDictionary<(Of <(TKey, TValue>)>) is read-only.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


TryGetValue Method

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..TryGetValue Method
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the value associated with the specified key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool TryGetValue(
    ?0 key,
    out ?1 value
)

Parameters

key
Type: ?0
The key whose value to get.
value
Type: ?1 %
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

true if the object that implements IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key; otherwise, false.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue(TKey, TValue%)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AppendingSortedList(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
AppendingSortedList<(Of <(<'?0, ?1>)>)> Properties
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback

The AppendingSortedList<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets the list capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection<(Of <(T>)>) containing the keys of the IDictionary<(Of <(TKey, TValue>)>).
Public property | Values | Gets an ICollection<(Of <(T>)>) containing the values in the IDictionary<(Of <(TKey, TValue>)>).

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Capacity Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Capacity Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the list capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Capacity { get; set; }

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Count Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..IsReadOnly Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Item Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets or sets the element with the specified key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?1 Item[
    ?0 key
] { get; set; }

Parameters

key
Type: ?0
The key of the element to get or set.

Return Value

The element with the specified key.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Item[([(TKey])])

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.
System.Collections.Generic..::.KeyNotFoundException | The property is retrieved and key is not found.
System..::.NotSupportedException | The property is set and the IDictionary<(Of <(TKey, TValue>)>) is read-only.

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Keys Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Keys Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets an ICollection<(Of <(T>)>) containing the keys of the IDictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> Keys { get; }

Return Value

An ICollection<(Of <(T>)>) containing the keys of the object that implements IDictionary<(Of <(TKey, TValue>)>).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Keys

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Values Property

AppendingSortedList<(Of <(<'?0, ?1>)>)>..::..Values Property
AppendingSortedList<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets an ICollection<(Of <(T>)>) containing the values in the IDictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?1> Values { get; }

Return Value

An ICollection<(Of <(T>)>) containing the values in the object that implements IDictionary<(Of <(TKey, TValue>)>).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Values

See Also

AppendingSortedList<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AppendingSortedListFactory(?0, ?1) Class

AppendingSortedListFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory of AppendingSortedList<(Of <(?0, ?1>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AppendingSortedListFactory<?0, ?1> : IDictionaryFactory<?0, ?1>,
    ICollectionFactory<KeyValuePair<?0, ?1>>
where ?0 : Object, IComparable<?0>, IEquatable<?0>
where ?1 : class

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.AppendingSortedListFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.AppendingSortedListFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.AppendingSortedListFactory<(Of <(?0, ?1>)>)

See Also

AppendingSortedListFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


AppendingSortedListFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
AppendingSortedListFactory<(Of <(<'?0, ?1>)>)> Members
AppendingSortedListFactory<(Of <(?0, ?1>)>) Class Fields See Also Send Feedback

The AppendingSortedListFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
AllowDuplicatesInstance | An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that allows duplicates.
NoDuplicateInstance | An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that does not allow duplicates.

See Also

AppendingSortedListFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AppendingSortedListFactory(?0, ?1) Fields

[image]

PostSharp 2.0 Documentation
AppendingSortedListFactory<(Of <(<'?0, ?1>)>)> Fields
AppendingSortedListFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The AppendingSortedListFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
AllowDuplicatesInstance | An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that allows duplicates.
NoDuplicateInstance | An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that does not allow duplicates.

See Also

AppendingSortedListFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AllowDuplicatesInstance Field

AppendingSortedListFactory<(Of <(<'?0, ?1>)>)>..::..AllowDuplicatesInstance Field
AppendingSortedListFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that allows duplicates.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly AppendingSortedListFactory<?0, ?1> AllowDuplicatesInstance

See Also

AppendingSortedListFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


NoDuplicateInstance Field

AppendingSortedListFactory<(Of <(<'?0, ?1>)>)>..::..NoDuplicateInstance Field
AppendingSortedListFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
An instance of AppendingSortedListFactory<(Of <(?0, ?1>)>) that does not allow duplicates.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly AppendingSortedListFactory<?0, ?1> NoDuplicateInstance

See Also

AppendingSortedListFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CollectionDebuggerTypeProxy Class

CollectionDebuggerTypeProxy Class
Members See Also Send Feedback
Debugger viewer that presents any collection (ICollection) according to its semantics instead of its implementation, i.e. it displays the list of items exposed by the interface.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CollectionDebuggerTypeProxy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.CollectionDebuggerTypeProxy

See Also

CollectionDebuggerTypeProxy Members
PostSharp.Sdk.Collections Namespace


CollectionDebuggerTypeProxy Members

[image]

PostSharp 2.0 Documentation
CollectionDebuggerTypeProxy Members
CollectionDebuggerTypeProxy Class Constructors Properties See Also Send Feedback

The CollectionDebuggerTypeProxy type exposes the following members.

Constructors

 | Name | Description
Public method | CollectionDebuggerTypeProxy | Initializes a new CollectionDebuggerTypeProxy.

Properties

 | Name | Description
Public property | Count | Gets the number of elements in the collection.
Public property | Items | Gets the array of items.

See Also

CollectionDebuggerTypeProxy Class
PostSharp.Sdk.Collections Namespace


CollectionDebuggerTypeProxy Constructor

CollectionDebuggerTypeProxy Constructor
CollectionDebuggerTypeProxy Class See Also Send Feedback
Initializes a new CollectionDebuggerTypeProxy.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CollectionDebuggerTypeProxy(
    ICollection collection
)

Parameters

collection
Type: System.Collections..::.ICollection
The collection to be viewed.

See Also

CollectionDebuggerTypeProxy Class
PostSharp.Sdk.Collections Namespace


CollectionDebuggerTypeProxy Properties

[image]

PostSharp 2.0 Documentation
CollectionDebuggerTypeProxy Properties
CollectionDebuggerTypeProxy Class See Also Send Feedback

The CollectionDebuggerTypeProxy type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements in the collection.
Public property | Items | Gets the array of items.

See Also

CollectionDebuggerTypeProxy Class
PostSharp.Sdk.Collections Namespace


Count Property

CollectionDebuggerTypeProxy..::..Count Property
CollectionDebuggerTypeProxy Class See Also Send Feedback
Gets the number of elements in the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

See Also

CollectionDebuggerTypeProxy Class
PostSharp.Sdk.Collections Namespace


Items Property

CollectionDebuggerTypeProxy..::..Items Property
CollectionDebuggerTypeProxy Class See Also Send Feedback
Gets the array of items.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object[] Items { get; }

Remarks

This array is displayed as the content of the collection.

See Also

CollectionDebuggerTypeProxy Class
PostSharp.Sdk.Collections Namespace


DictionaryFactory(?0, ?1) Class

DictionaryFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory of Dictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DictionaryFactory<?0, ?1> : IDictionaryFactory<?0, ?1>,
    ICollectionFactory<KeyValuePair<?0, ?1>>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.DictionaryFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.DictionaryFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.DictionaryFactory<(Of <(?0, ?1>)>)

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


DictionaryFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)> Members
DictionaryFactory<(Of <(?0, ?1>)>) Class Constructors Methods Fields See Also Send Feedback

The DictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | DictionaryFactory<(Of <(?0, ?1>)>) | Initializes a new instance of the DictionaryFactory<(Of <(?0, ?1>)>) class

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

Fields

Name | Description
Default | Default instance (using the default equality comparer).

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


DictionaryFactory(?0, ?1) Constructor

DictionaryFactory<(Of <(<'?0, ?1>)>)> Constructor
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new instance of the DictionaryFactory<(Of <(?0, ?1>)>) class

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DictionaryFactory(
    IEqualityComparer<?0> comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <(<' ?0 >)>)>

[Missing <param name="comparer"/> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.#ctor(System.Collections.Generic.IEqualityComparer{`0})"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


DictionaryFactory(?0, ?1) Fields

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)> Fields
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The DictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
Default | Default instance (using the default equality comparer).

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Default Field

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..Default Field
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Default instance (using the default equality comparer).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly DictionaryFactory<?0, ?1> Default

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


DictionaryFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)> Methods
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() |
Public method | CreateCollection(Int32) |

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
DictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateCollection"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateCollection"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method (Int32)
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateCollection(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateCollection(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateCollection(System.Int32)"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDictionary()()() |
Public method | CreateDictionary(Int32) |

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
DictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateDictionary"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<?0, ?1> CreateDictionary()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateDictionary"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


CreateDictionary Method (Int32)

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method (Int32)
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateDictionary(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<?0, ?1> CreateDictionary(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateDictionary(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.CreateDictionary(System.Int32)"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

[image]

PostSharp 2.0 Documentation
DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureCapacity(ICollection<(Of <(KeyValuePair<(Of <(?0, ?1>)>)>)>), Int32) | Ensures that a collection has the given capacity.
Public method | EnsureCapacity(IDictionary<(Of <(?0, ?1>)>), Int32) |

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
DictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (ICollection(KeyValuePair(?0, ?1)), Int32)

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method (ICollection<(Of <(<'KeyValuePair<(Of <(<'?0, ?1>)>)>>)>)>, Int32)
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<KeyValuePair<?0, ?1>> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (IDictionary(?0, ?1), Int32)

DictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method (IDictionary<(Of <(<'?0, ?1>)>)>, Int32)
DictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    IDictionary<?0, ?1> dictionary,
    int capacity
)

Parameters

dictionary
Type: System.Collections.Generic..::.IDictionary <(Of <(<' ?0, ?1 >)>)>

[Missing <param name="dictionary"/> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.DictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

See Also

DictionaryFactory<(Of <(?0, ?1>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


EmptyArray(?0) Class

EmptyArray<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Provides empty arrays of any type.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class EmptyArray<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.EmptyArray`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.EmptyArray<(Of <(?0>)>)

See Also

EmptyArray<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


EmptyArray(?0) Members

[image]

PostSharp 2.0 Documentation
EmptyArray<(Of <(<'?0>)>)> Members
EmptyArray<(Of <(?0>)>) Class Methods See Also Send Feedback

The EmptyArray<(Of <(?0>)>) type exposes the following members.

Methods

Name | Description
GetInstance | Gets an empty array of type T[].

See Also

EmptyArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyArray(?0) Methods

[image]

PostSharp 2.0 Documentation
EmptyArray<(Of <(<'?0>)>)> Methods
EmptyArray<(Of <(?0>)>) Class See Also Send Feedback

The EmptyArray<(Of <(?0>)>) type exposes the following members.

Methods

Name | Description
GetInstance | Gets an empty array of type T[].

See Also

EmptyArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetInstance Method

EmptyArray<(Of <(<'?0>)>)>..::..GetInstance Method
EmptyArray<(Of <(?0>)>) Class See Also Send Feedback
Gets an empty array of type T[].

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ?0[] GetInstance()

Return Value

An empty array of type T[].

See Also

EmptyArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyCollection(?0) Class

EmptyCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
An empty and read-only collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class EmptyCollection<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.EmptyCollection`1"]

Remarks

This collection is useful when one has to return an empty collection and cannot return null.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.EmptyCollection<(Of <(?0>)>)

See Also

EmptyCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


EmptyCollection(?0) Members

[image]

PostSharp 2.0 Documentation
EmptyCollection<(Of <(<'?0>)>)> Members
EmptyCollection<(Of <(?0>)>) Class Methods See Also Send Feedback

The EmptyCollection<(Of <(?0>)>) type exposes the following members.

Methods

Name | Description
GetInstance | Gets an empty and read-only collection.

See Also

EmptyCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
EmptyCollection<(Of <(<'?0>)>)> Methods
EmptyCollection<(Of <(?0>)>) Class See Also Send Feedback

The EmptyCollection<(Of <(?0>)>) type exposes the following members.

Methods

Name | Description
GetInstance | Gets an empty and read-only collection.

See Also

EmptyCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetInstance Method

EmptyCollection<(Of <(<'?0>)>)>..::..GetInstance Method
EmptyCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets an empty and read-only collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ICollection<?0> GetInstance()

Return Value

An empty and read-only collection

See Also

EmptyCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyEnumerator(?0) Class

EmptyEnumerator<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
An enumerator over an empty collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class EmptyEnumerator<?0> : IEnumerator<?0>,
    IDisposable, IEnumerator

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.EmptyEnumerator`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.EmptyEnumerator<(Of <(?0>)>)

See Also

EmptyEnumerator<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


EmptyEnumerator(?0) Members

[image]

PostSharp 2.0 Documentation
EmptyEnumerator<(Of <(<'?0>)>)> Members
EmptyEnumerator<(Of <(?0>)>) Class Methods Properties See Also Send Feedback

The EmptyEnumerator<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | GetInstance | Get an enumerator over an empty collection.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyEnumerator(?0) Methods

[image]

PostSharp 2.0 Documentation
EmptyEnumerator<(Of <(<'?0>)>)> Methods
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The EmptyEnumerator<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | GetInstance | Get an enumerator over an empty collection.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Dispose Method

EmptyEnumerator<(Of <(<'?0>)>)>..::..Dispose Method
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetInstance Method

EmptyEnumerator<(Of <(<'?0>)>)>..::..GetInstance Method
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Get an enumerator over an empty collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<?0> GetInstance()

Return Value

An enumerator over an empty collection.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MoveNext Method

EmptyEnumerator<(Of <(<'?0>)>)>..::..MoveNext Method
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MoveNext()

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Reset Method

EmptyEnumerator<(Of <(<'?0>)>)>..::..Reset Method
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Reset()

Implements

IEnumerator..::.Reset()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EmptyEnumerator(?0) Properties

[image]

PostSharp 2.0 Documentation
EmptyEnumerator<(Of <(<'?0>)>)> Properties
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The EmptyEnumerator<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Current Property

EmptyEnumerator<(Of <(<'?0>)>)>..::..Current Property
EmptyEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Gets the element in the collection at the current position of the enumerator.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Current { get; }

Return Value

The element in the collection at the current position of the enumerator.

Implements

IEnumerator<(Of <(T>)>)..::.Current

See Also

EmptyEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EnumerableWrapper(?0) Class

EnumerableWrapper<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Wraps an IEnumerable<(Of <(T>)>) so that the object behind becoms inaccessible, that is, read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class EnumerableWrapper<?0> : IEnumerable<?0>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.EnumerableWrapper`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.EnumerableWrapper<(Of <(?0>)>)

See Also

EnumerableWrapper<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


EnumerableWrapper(?0) Members

[image]

PostSharp 2.0 Documentation
EnumerableWrapper<(Of <(<'?0>)>)> Members
EnumerableWrapper<(Of <(?0>)>) Class Methods See Also Send Feedback

The EnumerableWrapper<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator |
 | GetInstance | Wraps an enumerable into a read-only enumerable. The original enumerable becomes inaccessible.

See Also

EnumerableWrapper<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EnumerableWrapper(?0) Methods

[image]

PostSharp 2.0 Documentation
EnumerableWrapper<(Of <(<'?0>)>)> Methods
EnumerableWrapper<(Of <(?0>)>) Class See Also Send Feedback

The EnumerableWrapper<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator |
 | GetInstance | Wraps an enumerable into a read-only enumerable. The original enumerable becomes inaccessible.

See Also

EnumerableWrapper<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

EnumerableWrapper<(Of <(<'?0>)>)>..::..GetEnumerator Method
EnumerableWrapper<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.EnumerableWrapper`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.EnumerableWrapper`1.GetEnumerator"]

See Also

EnumerableWrapper<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetInstance Method

EnumerableWrapper<(Of <(<'?0>)>)>..::..GetInstance Method
EnumerableWrapper<(Of <(?0>)>) Class See Also Send Feedback
Wraps an enumerable into a read-only enumerable. The original enumerable becomes inaccessible.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerable<?0> GetInstance(
    IEnumerable<?0> inner
)

Parameters

inner
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' ?0 >)>)>
The inner enumerable.

Return Value

An equivalent enumerable.

Remarks

When PostSharp is compiled not compiled in debug mode, this method simply returns inner.

See Also

EnumerableWrapper<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


EnumeratorEnlarger Class

EnumeratorEnlarger Class
Members See Also Send Feedback
Provides a method that casts a enumerator of a specific type into an enumerator of a more general type.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class EnumeratorEnlarger

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.EnumeratorEnlarger

See Also

EnumeratorEnlarger Members
PostSharp.Sdk.Collections Namespace


EnumeratorEnlarger Members

[image]

PostSharp 2.0 Documentation
EnumeratorEnlarger Members
EnumeratorEnlarger Class Methods See Also Send Feedback

The EnumeratorEnlarger type exposes the following members.

Methods

Name | Description
EnlargeEnumerable<(Of <(TSource, TTarget>)>) | Casts an enumerable IEnumerable<(Of <(T>)>)<TSource> into IEnumerable<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.
EnlargeEnumerator<(Of <(TSource, TTarget>)>) | Casts an enumerator IEnumerator<(Of <(T>)>)<TSource> into IEnumerator<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.

See Also

EnumeratorEnlarger Class
PostSharp.Sdk.Collections Namespace


EnumeratorEnlarger Methods

[image]

PostSharp 2.0 Documentation
EnumeratorEnlarger Methods
EnumeratorEnlarger Class See Also Send Feedback

The EnumeratorEnlarger type exposes the following members.

Methods

Name | Description
EnlargeEnumerable<(Of <(TSource, TTarget>)>) | Casts an enumerable IEnumerable<(Of <(T>)>)<TSource> into IEnumerable<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.
EnlargeEnumerator<(Of <(TSource, TTarget>)>) | Casts an enumerator IEnumerator<(Of <(T>)>)<TSource> into IEnumerator<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.

See Also

EnumeratorEnlarger Class
PostSharp.Sdk.Collections Namespace


EnlargeEnumerable(TSource, TTarget) Method

EnumeratorEnlarger..::..EnlargeEnumerable<(Of <(<'TSource, TTarget>)>)> Method
EnumeratorEnlarger Class See Also Send Feedback
Casts an enumerable IEnumerable<(Of <(T>)>)<TSource> into IEnumerable<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerable<TTarget> EnlargeEnumerable<TSource, TTarget>(
    IEnumerable<TSource> sourceEnumerable
)
where TSource :

Parameters

sourceEnumerable
Type: System.Collections.Generic..::.IEnumerable <(Of <(<'TSource>)>)>
Enumerator to be enlarged.

Type Parameters

TSource
Origin type of enumerated items.
TTarget
Target type of enumerated items (should be derived from TSource).

Return Value

An IEnumerable<(Of <(T>)>)<TTarget> that maps sourceEnumerable.

See Also

EnumeratorEnlarger Class
PostSharp.Sdk.Collections Namespace


EnlargeEnumerator(TSource, TTarget) Method

EnumeratorEnlarger..::..EnlargeEnumerator<(Of <(<'TSource, TTarget>)>)> Method
EnumeratorEnlarger Class See Also Send Feedback
Casts an enumerator IEnumerator<(Of <(T>)>)<TSource> into IEnumerator<(Of <(T>)>)<TTarget>, where TTarget is derived from TSource.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<TTarget> EnlargeEnumerator<TSource, TTarget>(
    IEnumerator<TSource> sourceEnumerator
)
where TSource :

Parameters

sourceEnumerator
Type: System.Collections.Generic..::.IEnumerator <(Of <(<'TSource>)>)>
Enumerator to be enlarged.

Type Parameters

TSource
Origin type of enumerated items.
TTarget
Target type of enumerated items (should be derived from TSource).

Return Value

An IEnumerator<(Of <(T>)>)<TTarget> that maps sourceEnumerator.

See Also

EnumeratorEnlarger Class
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Class

ExtensibleArray<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Auto-extensible array composed of extends, with full thread safety and low lock retention.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class ExtensibleArray<?0> : IEnumerable<KeyValuePair<int, ?0>>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.ExtensibleArray`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.ExtensibleArray<(Of <(?0>)>)

See Also

ExtensibleArray<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Members

[image]

PostSharp 2.0 Documentation
ExtensibleArray<(Of <(<'?0>)>)> Members
ExtensibleArray<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The ExtensibleArray<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | ExtensibleArray<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.

Properties

 | Name | Description
Public property | Item | Gets or sets an array item.
Public property | UpperBound | Gives the array upper bound.

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Constructor

[image]

PostSharp 2.0 Documentation
ExtensibleArray<(Of <(<'?0>)>)> Constructor
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExtensibleArray<(Of <(?0>)>)(Int32) | Initializes a new ExtensibleArray<(Of <(?0>)>) with default extend size.
Public method | ExtensibleArray<(Of <(?0>)>)(Int32, Int32) | Initializes a new ExtensibleArray<(Of <(?0>)>) and specifies the size of extends and the initial capacity.

See Also

ExtensibleArray<(Of <(?0>)>) Class
ExtensibleArray<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Constructor (Int32)

ExtensibleArray<(Of <(<'?0>)>)> Constructor (Int32)
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new ExtensibleArray<(Of <(?0>)>) with default extend size.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExtensibleArray(
    int initialCapacity
)

Parameters

initialCapacity
Type: System..::.Int32
Initial array capacity.

See Also

ExtensibleArray<(Of <(?0>)>) Class
ExtensibleArray<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Constructor (Int32, Int32)

ExtensibleArray<(Of <(<'?0>)>)> Constructor (Int32, Int32)
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new ExtensibleArray<(Of <(?0>)>) and specifies the size of extends and the initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ExtensibleArray(
    int extendSize,
    int initialCapacity
)

Parameters

extendSize
Type: System..::.Int32
Size of extends.
initialCapacity
Type: System..::.Int32
Initial capacity (number of items, not extends).

See Also

ExtensibleArray<(Of <(?0>)>) Class
ExtensibleArray<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Methods

[image]

PostSharp 2.0 Documentation
ExtensibleArray<(Of <(<'?0>)>)> Methods
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback

The ExtensibleArray<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

ExtensibleArray<(Of <(<'?0>)>)>..::..GetEnumerator Method
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<KeyValuePair<int, ?0>> GetEnumerator()

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ExtensibleArray(?0) Properties

[image]

PostSharp 2.0 Documentation
ExtensibleArray<(Of <(<'?0>)>)> Properties
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback

The ExtensibleArray<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets an array item.
Public property | UpperBound | Gives the array upper bound.

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

ExtensibleArray<(Of <(<'?0>)>)>..::..Item Property
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback
Gets or sets an array item.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Item[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32
Index.

Return Value

The item at position index.

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


UpperBound Property

ExtensibleArray<(Of <(<'?0>)>)>..::..UpperBound Property
ExtensibleArray<(Of <(?0>)>) Class See Also Send Feedback
Gives the array upper bound.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int UpperBound { get; }

Remarks

The array is guaranteed to contain less than UpperBound items.

See Also

ExtensibleArray<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ICollectionFactory(?0) Interface

ICollectionFactory<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
A collection factory creates instances of collections and allocates capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface ICollectionFactory<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.ICollectionFactory`1"]

See Also

ICollectionFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


ICollectionFactory(?0) Members

[image]

PostSharp 2.0 Documentation
ICollectionFactory<(Of <(<'?0>)>)> Members
ICollectionFactory<(Of <(?0>)>) Interface Methods See Also Send Feedback

The ICollectionFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


ICollectionFactory(?0) Methods

[image]

PostSharp 2.0 Documentation
ICollectionFactory<(Of <(<'?0>)>)> Methods
ICollectionFactory<(Of <(?0>)>) Interface See Also Send Feedback

The ICollectionFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
ICollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
ICollectionFactory<(Of <(?0>)>) Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() | Creates a collection with default capacity.
Public method | CreateCollection(Int32) | Creates a collection with given capacity.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
ICollectionFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

ICollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
ICollectionFactory<(Of <(?0>)>) Interface See Also Send Feedback
Creates a collection with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ICollection<?0> CreateCollection()

Return Value

A collection.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

ICollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method (Int32)
ICollectionFactory<(Of <(?0>)>) Interface See Also Send Feedback
Creates a collection with given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ICollection<?0> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial collection capacity.

Return Value

A collection.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

ICollectionFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method
ICollectionFactory<(Of <(?0>)>) Interface See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void EnsureCapacity(
    ICollection<?0> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

See Also

ICollectionFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IDictionaryFactory(?0, ?1) Interface

IDictionaryFactory<(Of <(<'?0, ?1>)>)> Interface
Members See Also Send Feedback
A dictionary factory creates instances of collections and allocates capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IDictionaryFactory<?0, ?1> : ICollectionFactory<KeyValuePair<?0, ?1>>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IDictionaryFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.IDictionaryFactory`2"]

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


IDictionaryFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
IDictionaryFactory<(Of <(<'?0, ?1>)>)> Members
IDictionaryFactory<(Of <(?0, ?1>)>) Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


IDictionaryFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
IDictionaryFactory<(Of <(<'?0, ?1>)>)> Methods
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() | Creates a collection with default capacity. (Inherited from ICollectionFactory<(Of <(?0>)>).)
Public method | CreateCollection(Int32) | Creates a collection with given capacity. (Inherited from ICollectionFactory<(Of <(?0>)>).)

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
IDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

[image]

PostSharp 2.0 Documentation
IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDictionary()()() | Creates a dictionary with default capacity.
Public method | CreateDictionary(Int32) | Creates a dictionary with given capacity.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
IDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Creates a dictionary with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IDictionary<?0, ?1> CreateDictionary()

Return Value

A dictionary.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


CreateDictionary Method (Int32)

IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method (Int32)
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Creates a dictionary with given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IDictionary<?0, ?1> CreateDictionary(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial dictionary capacity.

Return Value

A dictionary.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

[image]

PostSharp 2.0 Documentation
IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureCapacity(ICollection<(Of <(?0>)>), Int32) | Ensures that a collection has the given capacity. (Inherited from ICollectionFactory<(Of <(?0>)>).)
Public method | EnsureCapacity(IDictionary<(Of <(?0, ?1>)>), Int32) | Ensures that a dictionary has the given capacity.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
IDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (IDictionary(?0, ?1), Int32)

IDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method (IDictionary<(Of <(<'?0, ?1>)>)>, Int32)
IDictionaryFactory<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Ensures that a dictionary has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void EnsureCapacity(
    IDictionary<?0, ?1> dictionary,
    int capacity
)

Parameters

dictionary
Type: System.Collections.Generic..::.IDictionary <(Of <(<' ?0, ?1 >)>)>
A dictionary.
capacity
Type: System..::.Int32
The required capacity.

See Also

IDictionaryFactory<(Of <(?0, ?1>)>) Interface
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


IIndex(?0, ?1) Interface

IIndex<(Of <(<'?0, ?1>)>)> Interface
Members See Also Send Feedback
Specifies the interface of an index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IIndex<?0, ?1> : ICollection<?1>,
    IEnumerable<?1>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IIndex`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.IIndex`2"]

Remarks

This interface has the advantage to specify the index without having to put constraint on generic type parameters. This eliminates many casting problems, for instance when defining the IndexedCollection<(Of <(?0>)>) class.

See Also

IIndex<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


IIndex(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
IIndex<(Of <(<'?0, ?1>)>)> Members
IIndex<(Of <(?0, ?1>)>) Interface Methods See Also Send Feedback

The IIndex<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetFirstValueByKey | Gets the first value associated to a given key.
Public method | GetValuesByKey | Gets the collection of values associated to a given key.
Public method | Remove | Removes an item from the index after its key has changed, by providing its old key.
Public method | TryGetFirstValueByKey | Tries to gets the first value associated to a given key.

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


IIndex(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
IIndex<(Of <(<'?0, ?1>)>)> Methods
IIndex<(Of <(?0, ?1>)>) Interface See Also Send Feedback

The IIndex<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | GetFirstValueByKey | Gets the first value associated to a given key.
Public method | GetValuesByKey | Gets the collection of values associated to a given key.
Public method | Remove | Removes an item from the index after its key has changed, by providing its old key.
Public method | TryGetFirstValueByKey | Tries to gets the first value associated to a given key.

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


GetFirstValueByKey Method

IIndex<(Of <(<'?0, ?1>)>)>..::..GetFirstValueByKey Method
IIndex<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Gets the first value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
?1 GetFirstValueByKey(
    ?0 key
)

Parameters

key
Type: ?0
The key.

Return Value

The value associated to key, or the default value of V if no value is associated to key.

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


GetValuesByKey Method

IIndex<(Of <(<'?0, ?1>)>)>..::..GetValuesByKey Method
IIndex<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Gets the collection of values associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<?1> GetValuesByKey(
    ?0 key
)

Parameters

key
Type: ?0
The key.

Return Value

The collection of values associated to key.

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


Remove Method

IIndex<(Of <(<'?0, ?1>)>)>..::..Remove Method
IIndex<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Removes an item from the index after its key has changed, by providing its old key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool Remove(
    ?1 item,
    ?0 oldKey
)

Parameters

item
Type: ?1
The item to be removed.
oldKey
Type: ?0
The old key, under which the item was previously registered.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.IIndex`2.Remove(`1,`0)"]

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


TryGetFirstValueByKey Method

IIndex<(Of <(<'?0, ?1>)>)>..::..TryGetFirstValueByKey Method
IIndex<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Tries to gets the first value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool TryGetFirstValueByKey(
    ?0 key,
    out ?1 value
)

Parameters

key
Type: ?0
The key.
value
Type: ?1 %
The value associated to key, or the default value of V if no value is associated to key.

Return Value

true if some value was found, otherwise false.

See Also

IIndex<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


IListFactory(?0) Interface

IListFactory<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
A list factory creates instances of lists and allocates capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IListFactory<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IListFactory`1"]

See Also

IListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


IListFactory(?0) Members

[image]

PostSharp 2.0 Documentation
IListFactory<(Of <(<'?0>)>)> Members
IListFactory<(Of <(?0>)>) Interface Methods See Also Send Feedback

The IListFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateList | Overloaded.
Public method | EnsureCapacity | Ensures that a list has the given capacity.

See Also

IListFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IListFactory(?0) Methods

[image]

PostSharp 2.0 Documentation
IListFactory<(Of <(<'?0>)>)> Methods
IListFactory<(Of <(?0>)>) Interface See Also Send Feedback

The IListFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateList | Overloaded.
Public method | EnsureCapacity | Ensures that a list has the given capacity.

See Also

IListFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


CreateList Method

[image]

PostSharp 2.0 Documentation
IListFactory<(Of <(<'?0>)>)>..::..CreateList Method
IListFactory<(Of <(?0>)>) Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateList()()() | Creates a list with default capacity.
Public method | CreateList(Int32) | Creates a list with given capacity.

See Also

IListFactory<(Of <(?0>)>) Interface
IListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


CreateList Method

IListFactory<(Of <(<'?0>)>)>..::..CreateList Method
IListFactory<(Of <(?0>)>) Interface See Also Send Feedback
Creates a list with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IList<?0> CreateList()

Return Value

A list.

See Also

IListFactory<(Of <(?0>)>) Interface
CreateList Overload
PostSharp.Sdk.Collections Namespace


CreateList Method (Int32)

IListFactory<(Of <(<'?0>)>)>..::..CreateList Method (Int32)
IListFactory<(Of <(?0>)>) Interface See Also Send Feedback
Creates a list with given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IList<?0> CreateList(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial list capacity.

Return Value

A collection.

See Also

IListFactory<(Of <(?0>)>) Interface
CreateList Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

IListFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method
IListFactory<(Of <(?0>)>) Interface See Also Send Feedback
Ensures that a list has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void EnsureCapacity(
    IList<?0> list,
    int capacity
)

Parameters

list
Type: System.Collections.Generic..::.IList <(Of <(<' ?0 >)>)>
A list.
capacity
Type: System..::.Int32
The required capacity.

See Also

IListFactory<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IMultiDictionary(?0, ?1) Interface

IMultiDictionary<(Of <(<'?0, ?1>)>)> Interface
Members See Also Send Feedback
Specifies a dictionary possibly associating many items to a single key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IMultiDictionary<?0, ?1> : ICollection<KeyValuePair<?0, ?1>>,
    IEnumerable<KeyValuePair<?0, ?1>>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IMultiDictionary`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.IMultiDictionary`2"]

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


IMultiDictionary(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
IMultiDictionary<(Of <(<'?0, ?1>)>)> Members
IMultiDictionary<(Of <(?0, ?1>)>) Interface Methods Properties See Also Send Feedback

The IMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a key-value pair in the dictionary.
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key.

Properties

 | Name | Description
Public property | Item | Gets the list of values associated with a given key.
Public property | Keys | Gets the collection of keys.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


IMultiDictionary(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
IMultiDictionary<(Of <(<'?0, ?1>)>)> Methods
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback

The IMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a key-value pair in the dictionary.
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


Add Method

IMultiDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Adds a key-value pair in the dictionary.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Add(
    ?0 key,
    ?1 value
)

Parameters

key
Type: ?0
Key.
value
Type: ?1
Value.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


ContainsKey Method

IMultiDictionary<(Of <(<'?0, ?1>)>)>..::..ContainsKey Method
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Determines whether the dictionary contains at least one value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
bool ContainsKey(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

true if the dictionary contains at least one value associated with key, otherwise false.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


IMultiDictionary(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
IMultiDictionary<(Of <(<'?0, ?1>)>)> Properties
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback

The IMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the list of values associated with a given key.
Public property | Keys | Gets the collection of keys.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


Item Property

IMultiDictionary<(Of <(<'?0, ?1>)>)>..::..Item Property
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Gets the list of values associated with a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerable<?1> Item[
    ?0 key
] { get; }

Parameters

key
Type: ?0
Key.

Return Value

The list of values associated with key.

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


Keys Property

IMultiDictionary<(Of <(<'?0, ?1>)>)>..::..Keys Property
IMultiDictionary<(Of <(?0, ?1>)>) Interface See Also Send Feedback
Gets the collection of keys.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
ICollection<?0> Keys { get; }

See Also

IMultiDictionary<(Of <(?0, ?1>)>) Interface
PostSharp.Sdk.Collections Namespace


INamed Interface

INamed Interface
Members See Also Send Feedback
Exposes a Name property.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface INamed

See Also

INamed Members
PostSharp.Sdk.Collections Namespace


INamed Members

[image]

PostSharp 2.0 Documentation
INamed Members
INamed Interface Properties See Also Send Feedback

The INamed type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the current object.

See Also

INamed Interface
PostSharp.Sdk.Collections Namespace


INamed Properties

[image]

PostSharp 2.0 Documentation
INamed Properties
INamed Interface See Also Send Feedback

The INamed type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the current object.

See Also

INamed Interface
PostSharp.Sdk.Collections Namespace


Name Property

INamed..::..Name Property
INamed Interface See Also Send Feedback
Gets the name of the current object.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
string Name { get; }

See Also

INamed Interface
PostSharp.Sdk.Collections Namespace


Index(?0, ?1) Class

Index<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Dictionary of objects indexed by a property of these objects. The index is automatically updated when the key property changes.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class Index<?0, ?1> : IIndex<?0, ?1>,
    ICollection<?1>, IEnumerable<?1>, IEnumerable
where ?1 : class

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.Index`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.Index`2"]

Remarks

If a collection of items should have many indexes (many indexed properties), it is preferable to use the IndexedCollection<(Of <(?0>)>) class.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.Index<(Of <(?0, ?1>)>)

See Also

Index<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Index(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
Index<(Of <(<'?0, ?1>)>)> Members
Index<(Of <(?0, ?1>)>) Class Constructors Methods Properties See Also Send Feedback

The Index<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Protected method | Index<(Of <(?0, ?1>)>) | Initializes a new Index<(Of <(?0, ?1>)>).

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Protected method | AssertNotDisposed | Throws an exception if the current instance has been disposed.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Overloaded.
Public method | GetEnumerator |
Public method | GetFirstValueByKey | Gets the first value associated to a given key.
Protected method | GetItemKey | Gets the key of an item.
Public method | GetValuesByKey | Gets the collection of values associated to a given key.
Protected method | NotifyKeyChanged | Notifies the current Index<(Of <(?0, ?1>)>) that the key of an item contained in the index has changed.
Public method | Remove | Overloaded.
Public method | TryGetFirstValueByKey | Tries to gets the first value associated to a given key.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Keys | Gets the collection of keys of the current index.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Index(?0, ?1) Constructor

Index<(Of <(<'?0, ?1>)>)> Constructor
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new Index<(Of <(?0, ?1>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Index(
    ICollectionFactory<KeyValuePair<?0, ?1>> collectionFactory
)

Parameters

collectionFactory
Type: PostSharp.Sdk.Collections..::.ICollectionFactory <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>
Factory of the underlying implementation of this index.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Index(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
Index<(Of <(<'?0, ?1>)>)> Methods
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback

The Index<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Protected method | AssertNotDisposed | Throws an exception if the current instance has been disposed.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Overloaded.
Public method | GetEnumerator |
Public method | GetFirstValueByKey | Gets the first value associated to a given key.
Protected method | GetItemKey | Gets the key of an item.
Public method | GetValuesByKey | Gets the collection of values associated to a given key.
Protected method | NotifyKeyChanged | Notifies the current Index<(Of <(?0, ?1>)>) that the key of an item contained in the index has changed.
Public method | Remove | Overloaded.
Public method | TryGetFirstValueByKey | Tries to gets the first value associated to a given key.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

Index<(Of <(<'?0, ?1>)>)>..::..Add Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?1 item
)

Parameters

item
Type: ?1
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


AssertNotDisposed Method

Index<(Of <(<'?0, ?1>)>)>..::..AssertNotDisposed Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Throws an exception if the current instance has been disposed.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AssertNotDisposed()

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

Index<(Of <(<'?0, ?1>)>)>..::..Clear Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

Index<(Of <(<'?0, ?1>)>)>..::..Contains Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?1 item
)

Parameters

item
Type: ?1
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

Index<(Of <(<'?0, ?1>)>)>..::..CopyTo Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?1[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?1 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
Index<(Of <(<'?0, ?1>)>)>..::..Dispose Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Releases all resources used by the Index<(Of <(?0, ?1>)>)
Protected method | Dispose(Boolean) | Disposes the current instance.

See Also

Index<(Of <(?0, ?1>)>) Class
Index<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Dispose Method

Index<(Of <(<'?0, ?1>)>)>..::..Dispose Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Releases all resources used by the Index<(Of <(?0, ?1>)>)

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

See Also

Index<(Of <(?0, ?1>)>) Class
Dispose Overload
PostSharp.Sdk.Collections Namespace


Dispose Method (Boolean)

Index<(Of <(<'?0, ?1>)>)>..::..Dispose Method (Boolean)
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Disposes the current instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if the method is called because of an explicit call of Dispose()()(), false if it is called inside the destructor.

See Also

Index<(Of <(?0, ?1>)>) Class
Dispose Overload
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

Index<(Of <(<'?0, ?1>)>)>..::..GetEnumerator Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.Index`2.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?1> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.Index`2.GetEnumerator"]

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetFirstValueByKey Method

Index<(Of <(<'?0, ?1>)>)>..::..GetFirstValueByKey Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the first value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?1 GetFirstValueByKey(
    ?0 key
)

Parameters

key
Type: ?0
The key.

Return Value

The value associated to key, or the default value of V if no value is associated to key.

Implements

IIndex<(Of <(?0, ?1>)>)..::.GetFirstValueByKey(?0)

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetItemKey Method

Index<(Of <(<'?0, ?1>)>)>..::..GetItemKey Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the key of an item.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract ?0 GetItemKey(
    ?1 value
)

Parameters

value
Type: ?1
Item.

Return Value

The key of value.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetValuesByKey Method

Index<(Of <(<'?0, ?1>)>)>..::..GetValuesByKey Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the collection of values associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerable<?1> GetValuesByKey(
    ?0 key
)

Parameters

key
Type: ?0
The key.

Return Value

The collection of values associated to key.

Implements

IIndex<(Of <(?0, ?1>)>)..::.GetValuesByKey(?0)

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


NotifyKeyChanged Method

Index<(Of <(<'?0, ?1>)>)>..::..NotifyKeyChanged Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Notifies the current Index<(Of <(?0, ?1>)>) that the key of an item contained in the index has changed.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void NotifyKeyChanged(
    ?0 oldKey,
    ?0 newKey,
    ?1 value
)

Parameters

oldKey
Type: ?0
Old key.
newKey
Type: ?0
New key.
value
Type: ?1
Item whose key has changed.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
Index<(Of <(<'?0, ?1>)>)>..::..Remove Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(?1) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | Remove(?1, ?0) | Removes an item from the index after its key has changed, by providing its old key.

See Also

Index<(Of <(?0, ?1>)>) Class
Index<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Remove Method (?1)

Index<(Of <(<'?0, ?1>)>)>..::..Remove Method (?1)
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?1 item
)

Parameters

item
Type: ?1
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Index<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


Remove Method (?1, ?0)

Index<(Of <(<'?0, ?1>)>)>..::..Remove Method (?1, ?0)
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes an item from the index after its key has changed, by providing its old key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?1 item,
    ?0 oldKey
)

Parameters

item
Type: ?1
The item to be removed.
oldKey
Type: ?0
The old key, under which the item was previously registered.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.Index`2.Remove(`1,`0)"]

Implements

IIndex<(Of <(?0, ?1>)>)..::.Remove(?1, ?0)

See Also

Index<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


TryGetFirstValueByKey Method

Index<(Of <(<'?0, ?1>)>)>..::..TryGetFirstValueByKey Method
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Tries to gets the first value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool TryGetFirstValueByKey(
    ?0 key,
    out ?1 value
)

Parameters

key
Type: ?0
The key.
value
Type: ?1 %
The value associated to key, or the default value of V if no value is associated to key.

Return Value

true if some value was found, otherwise false.

Implements

IIndex<(Of <(?0, ?1>)>)..::.TryGetFirstValueByKey(?0, ?1%)

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Index(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
Index<(Of <(<'?0, ?1>)>)> Properties
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback

The Index<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Keys | Gets the collection of keys of the current index.

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Capacity Property

Index<(Of <(<'?0, ?1>)>)>..::..Capacity Property
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets or sets the index capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Capacity { get; set; }

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

Index<(Of <(<'?0, ?1>)>)>..::..Count Property
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IsDisposed Property

Index<(Of <(<'?0, ?1>)>)>..::..IsDisposed Property
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

Index<(Of <(<'?0, ?1>)>)>..::..IsReadOnly Property
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Keys Property

Index<(Of <(<'?0, ?1>)>)>..::..Keys Property
Index<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the collection of keys of the current index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> Keys { get; }

See Also

Index<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollection(?0) Class

IndexedCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Collection of objects indexed by many properties of these objects. The index is automatically updated when the key property changes.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class IndexedCollection<?0> : IPreAllocatedCollection<?0>,
    ICollection<?0>, IEnumerable<?0>, IEnumerable, IDisposable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IndexedCollection`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.IndexedCollection<(Of <(?0>)>)
PostSharp.Sdk.CodeModel.Collections..::.MemberValuePairCollection
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfigurationDictionary

See Also

IndexedCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


IndexedCollection(?0) Members

[image]

PostSharp 2.0 Documentation
IndexedCollection<(Of <(<'?0>)>)> Members
IndexedCollection<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The IndexedCollection<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexedCollection<(Of <(?0>)>) | Initializes a new IndexedCollection<(Of <(?0>)>) with an initial capacity.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Overloaded.
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetEnumerator |
Protected method | GetOrderedValues | Gets all values in the collection ordered by an index known by its ordinal.
Protected method | GetValuesByKey<(Of <(K>)>) | Gets the collection of items whose a given property equals a given value. The property is known by the ordinal of its associated index.
Protected method | OnItemPropertyChanged<(Of <(K>)>) | Method invoked when an indexed property of an item of the current collection has changed.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Protected method | TryGetFirstValueByKey<(Of <(K>)>) | Tries to get the first item whose a given property equals a given value. The property is known by the ordinal of its associated index.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the collection has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollection(?0) Constructor

IndexedCollection<(Of <(<'?0>)>)> Constructor
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new IndexedCollection<(Of <(?0>)>) with an initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected IndexedCollection(
    ICollectionFactory<?0>[] indexFactories,
    int capacity
)

Parameters

indexFactories
Type: array< PostSharp.Sdk.Collections..::.ICollectionFactory <(Of <(<' ?0 >)>)> >[]()[][]
Array of factories for individual indexes.
capacity
Type: System..::.Int32
Initial capacity.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
IndexedCollection<(Of <(<'?0>)>)> Methods
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback

The IndexedCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Overloaded.
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetEnumerator |
Protected method | GetOrderedValues | Gets all values in the collection ordered by an index known by its ordinal.
Protected method | GetValuesByKey<(Of <(K>)>) | Gets the collection of items whose a given property equals a given value. The property is known by the ordinal of its associated index.
Protected method | OnItemPropertyChanged<(Of <(K>)>) | Method invoked when an indexed property of an item of the current collection has changed.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Protected method | TryGetFirstValueByKey<(Of <(K>)>) | Tries to get the first item whose a given property equals a given value. The property is known by the ordinal of its associated index.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

IndexedCollection<(Of <(<'?0>)>)>..::..Add Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

IndexedCollection<(Of <(<'?0>)>)>..::..Clear Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

IndexedCollection<(Of <(<'?0>)>)>..::..Contains Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

IndexedCollection<(Of <(<'?0>)>)>..::..CopyTo Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
IndexedCollection<(Of <(<'?0>)>)>..::..Dispose Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Disposes the current instance.

See Also

IndexedCollection<(Of <(?0>)>) Class
IndexedCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Dispose Method

IndexedCollection<(Of <(<'?0>)>)>..::..Dispose Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

IndexedCollection<(Of <(?0>)>) Class
Dispose Overload
PostSharp.Sdk.Collections Namespace


Dispose Method (Boolean)

IndexedCollection<(Of <(<'?0>)>)>..::..Dispose Method (Boolean)
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Disposes the current instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if the method is called because of an explicit call of Dispose()()(), false if it is called inside the destructor.

See Also

IndexedCollection<(Of <(?0>)>) Class
Dispose Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

IndexedCollection<(Of <(<'?0>)>)>..::..EnsureCapacity Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Ensures that the total capacity of the collection is at least of a given number.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Capacity.

Implements

IPreAllocatedCollection<(Of <(?0>)>)..::.EnsureCapacity(Int32)

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Finalize Method

IndexedCollection<(Of <(<'?0>)>)>..::..Finalize Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Destructor.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Finalize()

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

IndexedCollection<(Of <(<'?0>)>)>..::..GetEnumerator Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.IndexedCollection`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.IndexedCollection`1.GetEnumerator"]

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetOrderedValues Method

IndexedCollection<(Of <(<'?0>)>)>..::..GetOrderedValues Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets all values in the collection ordered by an index known by its ordinal.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected IEnumerable<?0> GetOrderedValues(
    int indexOrdinal
)

Parameters

indexOrdinal
Type: System..::.Int32
Index ordinal.

Return Value

An ordered collection of items of type T.

Remarks

This makes sense only if the implementation of the index of this property is an ordered dictionary.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetValuesByKey(K) Method

IndexedCollection<(Of <(<'?0>)>)>..::..GetValuesByKey<(Of <(<'K>)>)> Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the collection of items whose a given property equals a given value. The property is known by the ordinal of its associated index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected IEnumerable<?0> GetValuesByKey<K>(
    int indexOrdinal,
    K key
)

Parameters

indexOrdinal
Type: System..::.Int32
Ordinal of the index associated to this property.
key
Type: K
Value of the indexed property for which items have to be returned.

Type Parameters

K
Type of the indexed property.

Return Value

The collection of items whose property at position indexOrdinal equals key.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


OnItemPropertyChanged(K) Method

IndexedCollection<(Of <(<'?0>)>)>..::..OnItemPropertyChanged<(Of <(<'K>)>)> Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Method invoked when an indexed property of an item of the current collection has changed.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void OnItemPropertyChanged<K>(
    int indexOrdinal,
    ?0 item,
    K oldKey
)

Parameters

indexOrdinal
Type: System..::.Int32
Ordinal of the index corresponding to the property.
item
Type: ?0
Item.
oldKey
Type: K
Value of the indexed property before the change.

Type Parameters

K
Type of the indexed property.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

IndexedCollection<(Of <(<'?0>)>)>..::..Remove Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


TryGetFirstValueByKey(K) Method

IndexedCollection<(Of <(<'?0>)>)>..::..TryGetFirstValueByKey<(Of <(<'K>)>)> Method
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Tries to get the first item whose a given property equals a given value. The property is known by the ordinal of its associated index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected bool TryGetFirstValueByKey<K>(
    int indexOrdinal,
    K key,
    out ?0 value
)

Parameters

indexOrdinal
Type: System..::.Int32
Ordinal of the indexed property.
key
Type: K
Value of the indexed property for which the first item to be returned.
value
Type: ?0 %
Value of the first item whose property value is key.

Type Parameters

K
Type of the indexed property.

Return Value

true if at least one item corresponded to this criterion, otherwise false.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollection(?0) Properties

[image]

PostSharp 2.0 Documentation
IndexedCollection<(Of <(<'?0>)>)> Properties
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback

The IndexedCollection<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the collection has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Capacity Property

IndexedCollection<(Of <(<'?0>)>)>..::..Capacity Property
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets or sets the index capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Capacity { get; set; }

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

IndexedCollection<(Of <(<'?0>)>)>..::..Count Property
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsDisposed Property

IndexedCollection<(Of <(<'?0>)>)>..::..IsDisposed Property
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the collection has been disposed.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

IndexedCollection<(Of <(<'?0>)>)>..::..IsReadOnly Property
IndexedCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

IndexedCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollectionFactory(?0) Class

IndexedCollectionFactory<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Factory for IndexedCollection<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class IndexedCollectionFactory<?0> : ICollectionFactory<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IndexedCollectionFactory`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.IndexedCollectionFactory<(Of <(?0>)>)

See Also

IndexedCollectionFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


IndexedCollectionFactory(?0) Members

[image]

PostSharp 2.0 Documentation
IndexedCollectionFactory<(Of <(<'?0>)>)> Members
IndexedCollectionFactory<(Of <(?0>)>) Class Constructors Methods See Also Send Feedback

The IndexedCollectionFactory<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexedCollectionFactory<(Of <(?0>)>) | Initializes a new instance of the IndexedCollectionFactory<(Of <(?0>)>) class

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollectionFactory(?0) Constructor

IndexedCollectionFactory<(Of <(<'?0>)>)> Constructor
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new instance of the IndexedCollectionFactory<(Of <(?0>)>) class

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected IndexedCollectionFactory()

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexedCollectionFactory(?0) Methods

[image]

PostSharp 2.0 Documentation
IndexedCollectionFactory<(Of <(<'?0>)>)> Methods
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback

The IndexedCollectionFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
IndexedCollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() | Creates a collection with default capacity.
Protected method | CreateCollection(Int32) | Creates an IndexedCollection<(Of <(?0>)>).

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
IndexedCollectionFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

IndexedCollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback
Creates a collection with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual ICollection<?0> CreateCollection()

Return Value

A collection.

Implements

ICollectionFactory<(Of <(?0>)>)..::.CreateCollection()()()

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

IndexedCollectionFactory<(Of <(<'?0>)>)>..::..CreateCollection Method (Int32)
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback
Creates an IndexedCollection<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected abstract IndexedCollection<?0> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity of the collection.

Return Value

A new IndexedCollection<(Of <(?0>)>) with the given initial capacity.

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

IndexedCollectionFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method
IndexedCollectionFactory<(Of <(?0>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<?0> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

IndexedCollectionFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexFactory(?0, ?1) Class

IndexFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory for Index<(Of <(?0, ?1>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract class IndexFactory<?0, ?1> : ICollectionFactory<?1>
where ?1 : class

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IndexFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.IndexFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.IndexFactory<(Of <(?0, ?1>)>)

See Also

IndexFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


IndexFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
IndexFactory<(Of <(<'?0, ?1>)>)> Members
IndexFactory<(Of <(?0, ?1>)>) Class Constructors Methods See Also Send Feedback

The IndexFactory<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Protected method | IndexFactory<(Of <(?0, ?1>)>) | Initializes a new instance of the IndexFactory<(Of <(?0, ?1>)>) class

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IndexFactory(?0, ?1) Constructor

IndexFactory<(Of <(<'?0, ?1>)>)> Constructor
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new instance of the IndexFactory<(Of <(?0, ?1>)>) class

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected IndexFactory()

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IndexFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
IndexFactory<(Of <(<'?0, ?1>)>)> Methods
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The IndexFactory<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
IndexFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() | Creates a collection with default capacity.
Public method | CreateCollection(Int32) | Creates a collection with given capacity.

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
IndexFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

IndexFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Creates a collection with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ICollection<?1> CreateCollection()

Return Value

A collection.

Implements

ICollectionFactory<(Of <(?0>)>)..::.CreateCollection()()()

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

IndexFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method (Int32)
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Creates a collection with given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual ICollection<?1> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial collection capacity.

Return Value

A collection.

Implements

ICollectionFactory<(Of <(?0>)>)..::.CreateCollection(Int32)

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

IndexFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
IndexFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<?1> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?1 >)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

IndexFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IPositioned Interface

IPositioned Interface
Members See Also Send Feedback
Exposes the Ordinal property.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IPositioned

See Also

IPositioned Members
PostSharp.Sdk.Collections Namespace


IPositioned Members

[image]

PostSharp 2.0 Documentation
IPositioned Members
IPositioned Interface Properties See Also Send Feedback

The IPositioned type exposes the following members.

Properties

 | Name | Description
Public property | Ordinal | Position of the current item in its parent collection.

See Also

IPositioned Interface
PostSharp.Sdk.Collections Namespace


IPositioned Properties

[image]

PostSharp 2.0 Documentation
IPositioned Properties
IPositioned Interface See Also Send Feedback

The IPositioned type exposes the following members.

Properties

 | Name | Description
Public property | Ordinal | Position of the current item in its parent collection.

See Also

IPositioned Interface
PostSharp.Sdk.Collections Namespace


Ordinal Property

IPositioned..::..Ordinal Property
IPositioned Interface See Also Send Feedback
Position of the current item in its parent collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
int Ordinal { get; }

See Also

IPositioned Interface
PostSharp.Sdk.Collections Namespace


IPreAllocatedCollection(?0) Interface

IPreAllocatedCollection<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
Extends the ICollection<(Of <(T>)>) interface by a method EnsureCapacity(Int32) allowing to increase the capacity of the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IPreAllocatedCollection<?0> : ICollection<?0>,
    IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IPreAllocatedCollection`1"]

See Also

IPreAllocatedCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


IPreAllocatedCollection(?0) Members

[image]

PostSharp 2.0 Documentation
IPreAllocatedCollection<(Of <(<'?0>)>)> Members
IPreAllocatedCollection<(Of <(?0>)>) Interface Methods See Also Send Feedback

The IPreAllocatedCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number.

See Also

IPreAllocatedCollection<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IPreAllocatedCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
IPreAllocatedCollection<(Of <(<'?0>)>)> Methods
IPreAllocatedCollection<(Of <(?0>)>) Interface See Also Send Feedback

The IPreAllocatedCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number.

See Also

IPreAllocatedCollection<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

IPreAllocatedCollection<(Of <(<'?0>)>)>..::..EnsureCapacity Method
IPreAllocatedCollection<(Of <(?0>)>) Interface See Also Send Feedback
Ensures that the total capacity of the collection is at least of a given number.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void EnsureCapacity(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Capacity.

See Also

IPreAllocatedCollection<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IVisitable(?0) Interface

IVisitable<(Of <(<'?0>)>)> Interface
Members See Also Send Feedback
Defines the semantics of an object that can be visited.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IVisitable<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.IVisitable`1"]

See Also

IVisitable<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


IVisitable(?0) Members

[image]

PostSharp 2.0 Documentation
IVisitable<(Of <(<'?0>)>)> Members
IVisitable<(Of <(?0>)>) Interface Methods See Also Send Feedback

The IVisitable<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

See Also

IVisitable<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


IVisitable(?0) Methods

[image]

PostSharp 2.0 Documentation
IVisitable<(Of <(<'?0>)>)> Methods
IVisitable<(Of <(?0>)>) Interface See Also Send Feedback

The IVisitable<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Visit | Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

See Also

IVisitable<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


Visit Method

IVisitable<(Of <(<'?0>)>)>..::..Visit Method
IVisitable<(Of <(?0>)>) Interface See Also Send Feedback
Requires a callback method (named visitor) to be called for each item of a given role in the current object, recursively.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
void Visit(
    string role,
    Visitor<?0> visitor
)

Parameters

role
Type: System..::.String
Role of items to be visited, or null if all items of type T should be visited.
visitor
Type: PostSharp.Sdk.Collections..::.Visitor <(Of <(<' ?0 >)>)>
Delegate that should be called when an item in the given role is found.

See Also

IVisitable<(Of <(?0>)>) Interface
PostSharp.Sdk.Collections Namespace


ListFactory(?0) Class

ListFactory<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Factory of List<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ListFactory<?0> : IListFactory<?0>,
    ICollectionFactory<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.ListFactory`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.ListFactory<(Of <(?0>)>)

See Also

ListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


ListFactory(?0) Members

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)> Members
ListFactory<(Of <(?0>)>) Class Methods Fields See Also Send Feedback

The ListFactory<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateList | Overloaded.
Public method | EnsureCapacity | Overloaded.

Fields

Name | Description
Default | Singleton instance.

See Also

ListFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ListFactory(?0) Fields

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)> Fields
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

The ListFactory<(Of <(?0>)>) type exposes the following members.

Fields

Name | Description
Default | Singleton instance.

See Also

ListFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Default Field

ListFactory<(Of <(<'?0>)>)>..::..Default Field
ListFactory<(Of <(?0>)>) Class See Also Send Feedback
Singleton instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly ListFactory<?0> Default

See Also

ListFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ListFactory(?0) Methods

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)> Methods
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateList | Overloaded.
Public method | EnsureCapacity | Overloaded.

See Also

ListFactory<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() |
Public method | CreateCollection(Int32) |

See Also

ListFactory<(Of <(?0>)>) Class
ListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

ListFactory<(Of <(<'?0>)>)>..::..CreateCollection Method
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.ListFactory`1.CreateCollection"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> CreateCollection()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.ListFactory`1.CreateCollection"]

See Also

ListFactory<(Of <(?0>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

ListFactory<(Of <(<'?0>)>)>..::..CreateCollection Method (Int32)
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.ListFactory`1.CreateCollection(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.ListFactory`1.CreateCollection(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.ListFactory`1.CreateCollection(System.Int32)"]

See Also

ListFactory<(Of <(?0>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateList Method

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)>..::..CreateList Method
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateList()()() | Creates a list with default capacity.
Public method | CreateList(Int32) | Creates a list with given capacity.

See Also

ListFactory<(Of <(?0>)>) Class
ListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


CreateList Method

ListFactory<(Of <(<'?0>)>)>..::..CreateList Method
ListFactory<(Of <(?0>)>) Class See Also Send Feedback
Creates a list with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<?0> CreateList()

Return Value

A list.

Implements

IListFactory<(Of <(?0>)>)..::.CreateList()()()

See Also

ListFactory<(Of <(?0>)>) Class
CreateList Overload
PostSharp.Sdk.Collections Namespace


CreateList Method (Int32)

ListFactory<(Of <(<'?0>)>)>..::..CreateList Method (Int32)
ListFactory<(Of <(?0>)>) Class See Also Send Feedback
Creates a list with given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IList<?0> CreateList(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial list capacity.

Return Value

A collection.

Implements

IListFactory<(Of <(?0>)>)..::.CreateList(Int32)

See Also

ListFactory<(Of <(?0>)>) Class
CreateList Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

[image]

PostSharp 2.0 Documentation
ListFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method
ListFactory<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureCapacity(ICollection<(Of <(?0>)>), Int32) | Ensures that a collection has the given capacity.
Public method | EnsureCapacity(IList<(Of <(?0>)>), Int32) | Ensures that a list has the given capacity.

See Also

ListFactory<(Of <(?0>)>) Class
ListFactory<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (ICollection(?0), Int32)

ListFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method (ICollection<(Of <(<'?0>)>)>, Int32)
ListFactory<(Of <(?0>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<?0> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

ListFactory<(Of <(?0>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (IList(?0), Int32)

ListFactory<(Of <(<'?0>)>)>..::..EnsureCapacity Method (IList<(Of <(<'?0>)>)>, Int32)
ListFactory<(Of <(?0>)>) Class See Also Send Feedback
Ensures that a list has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    IList<?0> list,
    int capacity
)

Parameters

list
Type: System.Collections.Generic..::.IList <(Of <(<' ?0 >)>)>
A list.
capacity
Type: System..::.Int32
The required capacity.

Implements

IListFactory<(Of <(?0>)>)..::.EnsureCapacity(IList<(Of <(?0>)>), Int32)

See Also

ListFactory<(Of <(?0>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Class

MarshalByRefCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Implementation of generic ICollection<(Of <(T>)>) marshalled by reference.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class MarshalByRefCollection<?0> : MarshalByRefObject,
    ICollection<?0>, IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MarshalByRefCollection`1"]

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefCollection<(Of <(?0>)>)

See Also

MarshalByRefCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Members

[image]

PostSharp 2.0 Documentation
MarshalByRefCollection<(Of <(<'?0>)>)> Members
MarshalByRefCollection<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The MarshalByRefCollection<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MarshalByRefCollection<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Constructor

[image]

PostSharp 2.0 Documentation
MarshalByRefCollection<(Of <(<'?0>)>)> Constructor
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MarshalByRefCollection<(Of <(?0>)>)()()() | Initializes a new MarshalByRefCollection<(Of <(?0>)>) with a List<(Of <(T>)>) as the underlying implementation.
Public method | MarshalByRefCollection<(Of <(?0>)>)(ICollection<(Of <(?0>)>)) | Initializes a new MarshalByRefCollection<(Of <(?0>)>) and specifies the underlying implementation.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
MarshalByRefCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Constructor

MarshalByRefCollection<(Of <(<'?0>)>)> Constructor
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MarshalByRefCollection<(Of <(?0>)>) with a List<(Of <(T>)>) as the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefCollection()

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
MarshalByRefCollection<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Constructor (ICollection(?0))

MarshalByRefCollection<(Of <(<'?0>)>)> Constructor (ICollection<(Of <(<'?0>)>)>)
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MarshalByRefCollection<(Of <(?0>)>) and specifies the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefCollection(
    ICollection<?0> implementation
)

Parameters

implementation
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
The underlying implementation, or the collection to wrap.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
MarshalByRefCollection<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
MarshalByRefCollection<(Of <(<'?0>)>)> Methods
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..Add Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..Clear Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..Contains Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..CopyTo Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..GetEnumerator Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefCollection`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefCollection`1.GetEnumerator"]

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

MarshalByRefCollection<(Of <(<'?0>)>)>..::..Remove Method
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefCollection(?0) Properties

[image]

PostSharp 2.0 Documentation
MarshalByRefCollection<(Of <(<'?0>)>)> Properties
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefCollection<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

MarshalByRefCollection<(Of <(<'?0>)>)>..::..Count Property
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

MarshalByRefCollection<(Of <(<'?0>)>)>..::..IsReadOnly Property
MarshalByRefCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

MarshalByRefCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Class

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Implementation of generic IDictionary<(Of <(TKey, TValue>)>) marshalled by reference.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class MarshalByRefDictionary<?0, ?1> : MarshalByRefObject,
    IDictionary<?0, ?1>, ICollection<KeyValuePair<?0, ?1>>, IEnumerable<KeyValuePair<?0, ?1>>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MarshalByRefDictionary`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.MarshalByRefDictionary`2"]

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefDictionary<(Of <(?0, ?1>)>)
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfigurationDictionary
PostSharp.Sdk.Extensibility.Configuration..::.TaskTypeConfigurationDictionary

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Members
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class Constructors Methods Properties See Also Send Feedback

The MarshalByRefDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MarshalByRefDictionary<(Of <(?0, ?1>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | ContainsKey |
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Overloaded.
Public method | TryGetValue |

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |
Public property | Keys |
Public property | Values |

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Constructor

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Constructor
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MarshalByRefDictionary<(Of <(?0, ?1>)>)()()() | Initializes a new MarshalByRefDictionary<(Of <(?0, ?1>)>) with a Dictionary<(Of <(TKey, TValue>)>) as the underlying implementation.
Public method | MarshalByRefDictionary<(Of <(?0, ?1>)>)(IDictionary<(Of <(?0, ?1>)>)) | Initializes a new MarshalByRefDictionary<(Of <(?0, ?1>)>) and specifies the underlying implementation.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
MarshalByRefDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Constructor

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Constructor
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MarshalByRefDictionary<(Of <(?0, ?1>)>) with a Dictionary<(Of <(TKey, TValue>)>) as the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefDictionary()

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
MarshalByRefDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Constructor (IDictionary(?0, ?1))

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Constructor (IDictionary<(Of <(<'?0, ?1>)>)>)
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MarshalByRefDictionary<(Of <(?0, ?1>)>) and specifies the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefDictionary(
    IDictionary<?0, ?1> implementation
)

Parameters

implementation
Type: System.Collections.Generic..::.IDictionary <(Of <(<' ?0, ?1 >)>)>
The underlying implementation, or the collection to wrap.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
MarshalByRefDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Methods
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MarshalByRefDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | ContainsKey |
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Overloaded.
Public method | TryGetValue |

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) | Adds an item to the ICollection<(Of <(T>)>).
Public method | Add(?0, ?1) |

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
MarshalByRefDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Add Method (KeyValuePair(?0, ?1))

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


Add Method (?0, ?1)

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method (?0, ?1)
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Add(`0,`1)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 key,
    ?1 value
)

Parameters

key
Type: ?0

[Missing <param name="key"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Add(`0,`1)"]

value
Type: ?1

[Missing <param name="value"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Add(`0,`1)"]

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


Clear Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Clear Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Contains Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


ContainsKey Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..ContainsKey Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.ContainsKey(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsKey(
    ?0 key
)

Parameters

key
Type: ?0

[Missing <param name="key"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.ContainsKey(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.ContainsKey(`0)"]

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..CopyTo Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    KeyValuePair<?0, ?1>[] array,
    int arrayIndex
)

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)> >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..GetEnumerator Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<KeyValuePair<?0, ?1>> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.GetEnumerator"]

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(KeyValuePair<(Of <(?0, ?1>)>)) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | Remove(?0) |

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
MarshalByRefDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Remove Method (KeyValuePair(?0, ?1))

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


Remove Method (?0)

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method (?0)
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Remove(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 key
)

Parameters

key
Type: ?0

[Missing <param name="key"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Remove(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Remove(`0)"]

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


TryGetValue Method

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..TryGetValue Method
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.TryGetValue(`0,`1@)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool TryGetValue(
    ?0 key,
    out ?1 value
)

Parameters

key
Type: ?0

[Missing <param name="key"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.TryGetValue(`0,`1@)"]

value
Type: ?1 %

[Missing <param name="value"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.TryGetValue(`0,`1@)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.TryGetValue(`0,`1@)"]

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefDictionary(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
MarshalByRefDictionary<(Of <(<'?0, ?1>)>)> Properties
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MarshalByRefDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |
Public property | Keys |
Public property | Values |

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Count Property
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..IsReadOnly Property
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Item Property
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Item(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?1 Item[
    ?0 key
] { get; set; }

Parameters

key
Type: ?0

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Keys Property

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Keys Property
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Keys"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> Keys { get; }

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Values Property

MarshalByRefDictionary<(Of <(<'?0, ?1>)>)>..::..Values Property
MarshalByRefDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.MarshalByRefDictionary`2.Values"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?1> Values { get; }

See Also

MarshalByRefDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefEnumerator(?0) Class

MarshalByRefEnumerator<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Wraps an enumerator with a class derived from MarshalByRefObject, so that the enumerator can be used across application domain boundaries.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MarshalByRefEnumerator<?0> : MarshalByRefObject,
    IEnumerator<?0>, IDisposable, IEnumerator

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MarshalByRefEnumerator`1"]

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefEnumerator<(Of <(?0>)>)

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefEnumerator(?0) Members

[image]

PostSharp 2.0 Documentation
MarshalByRefEnumerator<(Of <(<'?0>)>)> Members
MarshalByRefEnumerator<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The MarshalByRefEnumerator<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MarshalByRefEnumerator<(Of <(?0>)>) | Initializes a new MarshalByRefEnumerator<(Of <(?0>)>).

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

 | Name | Description
Public property | Current |

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefEnumerator(?0) Constructor

MarshalByRefEnumerator<(Of <(<'?0>)>)> Constructor
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MarshalByRefEnumerator<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefEnumerator(
    IEnumerator<?0> enumerator
)

Parameters

enumerator
Type: System.Collections.Generic..::.IEnumerator <(Of <(<' ?0 >)>)>
Underlying enumerator.

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefEnumerator(?0) Methods

[image]

PostSharp 2.0 Documentation
MarshalByRefEnumerator<(Of <(<'?0>)>)> Methods
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefEnumerator<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Dispose Method

MarshalByRefEnumerator<(Of <(<'?0>)>)>..::..Dispose Method
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MoveNext Method

MarshalByRefEnumerator<(Of <(<'?0>)>)>..::..MoveNext Method
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MoveNext()

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Reset Method

MarshalByRefEnumerator<(Of <(<'?0>)>)>..::..Reset Method
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Reset()

Implements

IEnumerator..::.Reset()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefEnumerator(?0) Properties

[image]

PostSharp 2.0 Documentation
MarshalByRefEnumerator<(Of <(<'?0>)>)> Properties
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefEnumerator<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Current |

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Current Property

MarshalByRefEnumerator<(Of <(<'?0>)>)>..::..Current Property
MarshalByRefEnumerator<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.MarshalByRefEnumerator`1.Current"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Current { get; }

See Also

MarshalByRefEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Class

MarshalByRefList<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Implementation of generic IList<(Of <(T>)>) marshaled by reference.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class MarshalByRefList<?0> : MarshalByRefObject,
    IList<?0>, ICollection<?0>, IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MarshalByRefList`1"]

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList<(Of <(?0>)>)
PostSharp.Sdk.Extensibility.Configuration..::.DependencyConfigurationCollection
PostSharp.Sdk.Extensibility.Configuration..::.NameValuePairCollection
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfigurationCollection
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfigurationCollection
PostSharp.Sdk.Extensibility.Configuration..::.PropertyConfigurationCollection
PostSharp.Sdk.Extensibility.Configuration..::.SearchPathConfigurationCollection
PostSharp.Sdk.Extensibility.Configuration..::.UsingConfigurationCollection

See Also

MarshalByRefList<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Members

[image]

PostSharp 2.0 Documentation
MarshalByRefList<(Of <(<'?0>)>)> Members
MarshalByRefList<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The MarshalByRefList<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MarshalByRefList<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Constructor

[image]

PostSharp 2.0 Documentation
MarshalByRefList<(Of <(<'?0>)>)> Constructor
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MarshalByRefList<(Of <(?0>)>)()()() | Initializes a new MarshalByRefList<(Of <(?0>)>) with a List<(Of <(T>)>) as the underlying implementation.
Public method | MarshalByRefList<(Of <(?0>)>)(IList<(Of <(?0>)>)) | Initializes a new MarshalByRefList<(Of <(?0>)>) and specifies the underlying implementation.

See Also

MarshalByRefList<(Of <(?0>)>) Class
MarshalByRefList<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Constructor

MarshalByRefList<(Of <(<'?0>)>)> Constructor
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MarshalByRefList<(Of <(?0>)>) with a List<(Of <(T>)>) as the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefList()

See Also

MarshalByRefList<(Of <(?0>)>) Class
MarshalByRefList<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Constructor (IList(?0))

MarshalByRefList<(Of <(<'?0>)>)> Constructor (IList<(Of <(<'?0>)>)>)
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new MarshalByRefList<(Of <(?0>)>) and specifies the underlying implementation.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MarshalByRefList(
    IList<?0> implementation
)

Parameters

implementation
Type: System.Collections.Generic..::.IList <(Of <(<' ?0 >)>)>
The underlying implementation, or the collection to wrap.

See Also

MarshalByRefList<(Of <(?0>)>) Class
MarshalByRefList<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Methods

[image]

PostSharp 2.0 Documentation
MarshalByRefList<(Of <(<'?0>)>)> Methods
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefList<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

MarshalByRefList<(Of <(<'?0>)>)>..::..Add Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

MarshalByRefList<(Of <(<'?0>)>)>..::..Clear Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

MarshalByRefList<(Of <(<'?0>)>)>..::..Contains Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

MarshalByRefList<(Of <(<'?0>)>)>..::..CopyTo Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

MarshalByRefList<(Of <(<'?0>)>)>..::..GetEnumerator Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.GetEnumerator"]

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexOf Method

MarshalByRefList<(Of <(<'?0>)>)>..::..IndexOf Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.IndexOf(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int IndexOf(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.IndexOf(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.IndexOf(`0)"]

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Insert Method

MarshalByRefList<(Of <(<'?0>)>)>..::..Insert Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.Insert(System.Int32,`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Insert(
    int index,
    ?0 item
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.Insert(System.Int32,`0)"]

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.MarshalByRefList`1.Insert(System.Int32,`0)"]

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

MarshalByRefList<(Of <(<'?0>)>)>..::..Remove Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


RemoveAt Method

MarshalByRefList<(Of <(<'?0>)>)>..::..RemoveAt Method
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Removes the IList<(Of <(T>)>) item at the specified index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(T>)>).
System..::.NotSupportedException | The IList<(Of <(T>)>) is read-only.

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MarshalByRefList(?0) Properties

[image]

PostSharp 2.0 Documentation
MarshalByRefList<(Of <(<'?0>)>)> Properties
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

The MarshalByRefList<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

MarshalByRefList<(Of <(<'?0>)>)>..::..Count Property
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

MarshalByRefList<(Of <(<'?0>)>)>..::..IsReadOnly Property
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

MarshalByRefList<(Of <(<'?0>)>)>..::..Item Property
MarshalByRefList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.MarshalByRefList`1.Item(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Item[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32

See Also

MarshalByRefList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Class

MultiDictionary<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Associates many values to a single key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MultiDictionary<?0, ?1> : IMultiDictionary<?0, ?1>,
    ICollection<KeyValuePair<?0, ?1>>, IEnumerable<KeyValuePair<?0, ?1>>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MultiDictionary`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.MultiDictionary`2"]

Remarks

The default implementation of this MultiDictionary<(Of <(?0, ?1>)>) uses a Dictionary<(Of <(TKey, TValue>)>). However, it is possible to use other implementations by deriving this class and overriding the InternalCreateDictionary(Int32), InternalTryGetValue(UTP, MultiDictionary<(Of <(UTP, UTP>)>)%) methods. The underlying implementation can be accessed by derived classes thanks to the Implementation()()() property.

The creation of the underlying dictionary is defered to the first element addition. This allows to have empty dictionaries at relatively low cost.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.MultiDictionary<(Of <(?0, ?1>)>)
PostSharp.Sdk.Collections..::.SortedMultiDictionary<(Of <(?0, ?1>)>)

See Also

MultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)> Members
MultiDictionary<(Of <(?0, ?1>)>) Class Constructors Methods Properties See Also Send Feedback

The MultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MultiDictionary<(Of <(?0, ?1>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of values in the current dictionary.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetArrayByKey | Gets the array of values associated to a given key.
Public method | GetCountByKey | Gets the number of items registered under a given key.
Public method | GetEnumerator |
Public method | GetEnumeratorByKey | Gets an enumerator of values associated to a given key.
Public method | Merge | Merges a MultiDictionary<(Of <(?0, ?1>)>) into the current instance.
Public method | Remove | Overloaded.
Public method | RemoveAll | Removes all values associated to a given key.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the expected number of keys.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets the list of values associated with a given key.
Public property | Keys | Gets the collection of keys.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Constructor

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)> Constructor
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MultiDictionary<(Of <(?0, ?1>)>)()()() | Initializes a new MultiDictionary<(Of <(?0, ?1>)>) with default capacity.
Public method | MultiDictionary<(Of <(?0, ?1>)>)(Int32) | Initializes a new MultiDictionary<(Of <(?0, ?1>)>) and sets the initial capacity of the first-level dictionary (number of keys).
Public method | MultiDictionary<(Of <(?0, ?1>)>)(Int32, IEqualityComparer<(Of <(?0>)>)) | Initializes a new MultiDictionary<(Of <(?0, ?1>)>), sets the initial capacity of the first-level dictionary (number of keys) and gives a non-default comparer of equality of keys,

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Constructor

MultiDictionary<(Of <(<'?0, ?1>)>)> Constructor
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MultiDictionary<(Of <(?0, ?1>)>) with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MultiDictionary()

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Constructor (Int32)

MultiDictionary<(Of <(<'?0, ?1>)>)> Constructor (Int32)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MultiDictionary<(Of <(?0, ?1>)>) and sets the initial capacity of the first-level dictionary (number of keys).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MultiDictionary(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity of unique keys.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Constructor (Int32, IEqualityComparer(?0))

MultiDictionary<(Of <(<'?0, ?1>)>)> Constructor (Int32, IEqualityComparer<(Of <(<'?0>)>)>)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MultiDictionary<(Of <(?0, ?1>)>), sets the initial capacity of the first-level dictionary (number of keys) and gives a non-default comparer of equality of keys,

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MultiDictionary(
    int capacity,
    IEqualityComparer<?0> comparer
)

Parameters

capacity
Type: System..::.Int32
Initial capacity of unique keys.
comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <(<' ?0 >)>)>
Equality comparer for keys.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)> Methods
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of values in the current dictionary.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetArrayByKey | Gets the array of values associated to a given key.
Public method | GetCountByKey | Gets the number of items registered under a given key.
Public method | GetEnumerator |
Public method | GetEnumeratorByKey | Gets an enumerator of values associated to a given key.
Public method | Merge | Merges a MultiDictionary<(Of <(?0, ?1>)>) into the current instance.
Public method | Remove | Overloaded.
Public method | RemoveAll | Removes all values associated to a given key.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) | Adds an item to the ICollection<(Of <(T>)>).
Public method | Add(?0, ?1) | Adds a key-value pair in the dictionary.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Add Method (KeyValuePair(?0, ?1))

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


Add Method (?0, ?1)

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method (?0, ?1)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds a key-value pair in the dictionary.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 key,
    ?1 value
)

Parameters

key
Type: ?0
Key.
value
Type: ?1
Value.

Implements

IMultiDictionary<(Of <(?0, ?1>)>)..::.Add(?0, ?1)

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
Add Overload
PostSharp.Sdk.Collections Namespace


AddRange Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..AddRange Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Adds a collection of values in the current dictionary.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    ICollection<KeyValuePair<?0, ?1>> values
)

Parameters

values
Type: System.Collections.Generic..::.ICollection <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>
A collection of key-value pairs.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Clear Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Contains Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


ContainsKey Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..ContainsKey Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Determines whether the dictionary contains at least one value associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ContainsKey(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

true if the dictionary contains at least one value associated with key, otherwise false.

Implements

IMultiDictionary<(Of <(?0, ?1>)>)..::.ContainsKey(?0)

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..CopyTo Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    KeyValuePair<?0, ?1>[] array,
    int arrayIndex
)

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)> >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetArrayByKey Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..GetArrayByKey Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the array of values associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?1[] GetArrayByKey(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

The array of values associated to key.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetCountByKey Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..GetCountByKey Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the number of items registered under a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int GetCountByKey(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

The number of items registered under key.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..GetEnumerator Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<KeyValuePair<?0, ?1>> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.GetEnumerator"]

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumeratorByKey Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..GetEnumeratorByKey Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets an enumerator of values associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?1> GetEnumeratorByKey(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

Enumerator of values associated with key.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Merge Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Merge Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Merges a MultiDictionary<(Of <(?0, ?1>)>) into the current instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Merge(
    MultiDictionary<?0, ?1> values
)

Parameters

values
Type: PostSharp.Sdk.Collections..::.MultiDictionary <(Of <(<' ?0, ?1 >)>)>
Dictionary to be merged

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(KeyValuePair<(Of <(?0, ?1>)>)) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | Remove(?0, ?1) |

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
MultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Remove Method (KeyValuePair(?0, ?1))

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method (KeyValuePair<(Of <(<'?0, ?1>)>)>)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    KeyValuePair<?0, ?1> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <(<' ?0, ?1 >)>)>
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


Remove Method (?0, ?1)

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method (?0, ?1)
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.Remove(`0,`1)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 key,
    ?1 value
)

Parameters

key
Type: ?0

[Missing <param name="key"/> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.Remove(`0,`1)"]

value
Type: ?1

[Missing <param name="value"/> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.Remove(`0,`1)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MultiDictionary`2.Remove(`0,`1)"]

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
Remove Overload
PostSharp.Sdk.Collections Namespace


RemoveAll Method

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..RemoveAll Method
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Removes all values associated to a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RemoveAll(
    ?0 key
)

Parameters

key
Type: ?0
Key.

Return Value

true if at least one value was removed, otherwise false.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionary(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
MultiDictionary<(Of <(<'?0, ?1>)>)> Properties
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the expected number of keys.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item | Gets the list of values associated with a given key.
Public property | Keys | Gets the collection of keys.

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Capacity Property

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Capacity Property
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets or sets the expected number of keys.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Capacity { get; set; }

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Count Property
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..IsReadOnly Property
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Item Property
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the list of values associated with a given key.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerable<?1> Item[
    ?0 key
] { get; }

Parameters

key
Type: ?0
Key.

Return Value

The list of values associated with key.

Implements

IMultiDictionary<(Of <(?0, ?1>)>)..::.Item[([(?0])])

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Keys Property

MultiDictionary<(Of <(<'?0, ?1>)>)>..::..Keys Property
MultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Gets the collection of keys.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<?0> Keys { get; }

Implements

IMultiDictionary<(Of <(?0, ?1>)>)..::.Keys

See Also

MultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionaryFactory(?0, ?1) Class

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory for MultiDictionary<(Of <(?0, ?1>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MultiDictionaryFactory<?0, ?1> : ICollectionFactory<KeyValuePair<?0, ?1>>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.MultiDictionaryFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.MultiDictionaryFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.MultiDictionaryFactory<(Of <(?0, ?1>)>)

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


MultiDictionaryFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
MultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Members
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class Constructors Methods Fields See Also Send Feedback

The MultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | MultiDictionaryFactory<(Of <(?0, ?1>)>) | Initializes a new MultiDictionaryFactory<(Of <(?0, ?1>)>) and specifies the equality comparer.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

Fields

Name | Description
Default | Default instance, using the default equality comparer.

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionaryFactory(?0, ?1) Constructor

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Constructor
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new MultiDictionaryFactory<(Of <(?0, ?1>)>) and specifies the equality comparer.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MultiDictionaryFactory(
    IEqualityComparer<?0> comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <(<' ?0 >)>)>
Equality comparer.

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionaryFactory(?0, ?1) Fields

[image]

PostSharp 2.0 Documentation
MultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Fields
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
Default | Default instance, using the default equality comparer.

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Default Field

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..Default Field
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Default instance, using the default equality comparer.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly MultiDictionaryFactory<?0, ?1> Default

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


MultiDictionaryFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
MultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Methods
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The MultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity | Ensures that a collection has the given capacity.

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
MultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() |
Public method | CreateCollection(Int32) |

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
MultiDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MultiDictionaryFactory`2.CreateCollection"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MultiDictionaryFactory`2.CreateCollection"]

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method (Int32)
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.MultiDictionaryFactory`2.CreateCollection(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.MultiDictionaryFactory`2.CreateCollection(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.MultiDictionaryFactory`2.CreateCollection(System.Int32)"]

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

MultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
MultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<KeyValuePair<?0, ?1>> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

MultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


NodePosition Enumeration

NodePosition Enumeration
See Also Send Feedback
Relative position of nodes in a sequence.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum NodePosition

Members

Member name | Value | Description
Before | 0 | Before the reference node.
After | 1 | After the reference node.

See Also

PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Class

NonNullableList<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Wraps a list so that it is forbidden to add null items.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class NonNullableList<?0> : IList<?0>,
    ICollection<?0>, IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.NonNullableList`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.NonNullableList<(Of <(?0>)>)
PostSharp.Sdk.CodeModel..::.TypeSignatureCollection

See Also

NonNullableList<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Members

[image]

PostSharp 2.0 Documentation
NonNullableList<(Of <(<'?0>)>)> Members
NonNullableList<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The NonNullableList<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | NonNullableList<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | AddRange | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the capacity of the current list.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Constructor

[image]

PostSharp 2.0 Documentation
NonNullableList<(Of <(<'?0>)>)> Constructor
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NonNullableList<(Of <(?0>)>)()()() | Initializes a new NonNullableList<(Of <(?0>)>) with default capacity.
Public method | NonNullableList<(Of <(?0>)>)(ICollection<(Of <(?0>)>)) | Initializes a new NonNullableList<(Of <(?0>)>) and copies the content of an existing collection.
Public method | NonNullableList<(Of <(?0>)>)(Int32) | Initializes a new NonNullableList<(Of <(?0>)>) with given initial capacity.

See Also

NonNullableList<(Of <(?0>)>) Class
NonNullableList<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Constructor

NonNullableList<(Of <(<'?0>)>)> Constructor
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new NonNullableList<(Of <(?0>)>) with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NonNullableList()

See Also

NonNullableList<(Of <(?0>)>) Class
NonNullableList<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Constructor (ICollection(?0))

NonNullableList<(Of <(<'?0>)>)> Constructor (ICollection<(Of <(<'?0>)>)>)
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new NonNullableList<(Of <(?0>)>) and copies the content of an existing collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NonNullableList(
    ICollection<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
The collection to be copied.

See Also

NonNullableList<(Of <(?0>)>) Class
NonNullableList<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Constructor (Int32)

NonNullableList<(Of <(<'?0>)>)> Constructor (Int32)
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new NonNullableList<(Of <(?0>)>) with given initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NonNullableList(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity.

See Also

NonNullableList<(Of <(?0>)>) Class
NonNullableList<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Methods

[image]

PostSharp 2.0 Documentation
NonNullableList<(Of <(<'?0>)>)> Methods
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

The NonNullableList<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | AddRange | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

NonNullableList<(Of <(<'?0>)>)>..::..Add Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


AddRange Method

[image]

PostSharp 2.0 Documentation
NonNullableList<(Of <(<'?0>)>)>..::..AddRange Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(ICollection<(Of <(?0>)>)) | Adds a collection of items in the list.
Public method | AddRange(IEnumerable<(Of <(?0>)>)) | Adds a set of items to the current collection.

See Also

NonNullableList<(Of <(?0>)>) Class
NonNullableList<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


AddRange Method (ICollection(?0))

NonNullableList<(Of <(<'?0>)>)>..::..AddRange Method (ICollection<(Of <(<'?0>)>)>)
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Adds a collection of items in the list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    ICollection<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
The collection of items to be added.

See Also

NonNullableList<(Of <(?0>)>) Class
AddRange Overload
PostSharp.Sdk.Collections Namespace


AddRange Method (IEnumerable(?0))

NonNullableList<(Of <(<'?0>)>)>..::..AddRange Method (IEnumerable<(Of <(<'?0>)>)>)
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Adds a set of items to the current collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    IEnumerable<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' ?0 >)>)>
A set of items.

See Also

NonNullableList<(Of <(?0>)>) Class
AddRange Overload
PostSharp.Sdk.Collections Namespace


Clear Method

NonNullableList<(Of <(<'?0>)>)>..::..Clear Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

NonNullableList<(Of <(<'?0>)>)>..::..Contains Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

NonNullableList<(Of <(<'?0>)>)>..::..CopyTo Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

NonNullableList<(Of <(<'?0>)>)>..::..GetEnumerator Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.GetEnumerator"]

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexOf Method

NonNullableList<(Of <(<'?0>)>)>..::..IndexOf Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.IndexOf(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int IndexOf(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.IndexOf(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.IndexOf(`0)"]

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Insert Method

NonNullableList<(Of <(<'?0>)>)>..::..Insert Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.Insert(System.Int32,`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Insert(
    int index,
    ?0 item
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.Insert(System.Int32,`0)"]

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.NonNullableList`1.Insert(System.Int32,`0)"]

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

NonNullableList<(Of <(<'?0>)>)>..::..Remove Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


RemoveAt Method

NonNullableList<(Of <(<'?0>)>)>..::..RemoveAt Method
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Removes the IList<(Of <(T>)>) item at the specified index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(T>)>).
System..::.NotSupportedException | The IList<(Of <(T>)>) is read-only.

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


NonNullableList(?0) Properties

[image]

PostSharp 2.0 Documentation
NonNullableList<(Of <(<'?0>)>)> Properties
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

The NonNullableList<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the capacity of the current list.
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Capacity Property

NonNullableList<(Of <(<'?0>)>)>..::..Capacity Property
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Gets or sets the capacity of the current list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Capacity { get; set; }

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

NonNullableList<(Of <(<'?0>)>)>..::..Count Property
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

NonNullableList<(Of <(<'?0>)>)>..::..IsReadOnly Property
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

NonNullableList<(Of <(<'?0>)>)>..::..Item Property
NonNullableList<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.NonNullableList`1.Item(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Item[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32

See Also

NonNullableList<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Structure

Pair<(Of <(<'?0, ?1>)>)> Structure
Members See Also Send Feedback
Typed pair of values.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public struct Pair<?0, ?1> : IEquatable<Pair<?0, ?1>>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.Pair`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.Pair`2"]

See Also

Pair<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
Pair<(Of <(<'?0, ?1>)>)> Members
Pair<(Of <(?0, ?1>)>) Structure Constructors Methods Operators Properties See Also Send Feedback

The Pair<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | Pair<(Of <(?0, ?1>)>) | Initializes a new Pair<(Of <(?0, ?1>)>) of values.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Determines whether two instances are equal.
Inequality | Determines whether two instances are different.

Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Constructor

Pair<(Of <(<'?0, ?1>)>)> Constructor
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Initializes a new Pair<(Of <(?0, ?1>)>) of values.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Pair(
    ?0 first,
    ?1 second
)

Parameters

first
Type: ?0
First value.
second
Type: ?1
Second value.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
Pair<(Of <(<'?0, ?1>)>)> Methods
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback

The Pair<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Overloaded.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::.GetHashCode()()().)

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Equals Method

[image]

PostSharp 2.0 Documentation
Pair<(Of <(<'?0, ?1>)>)>..::..Equals Method
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueType..::.Equals(Object).)
Public method | Equals(Pair<(Of <(?0, ?1>)>)) | Indicates whether the current object is equal to another object of the same type.

See Also

Pair<(Of <(?0, ?1>)>) Structure
Pair<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Equals Method (Object)

Pair<(Of <(<'?0, ?1>)>)>..::..Equals Method (Object)
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Indicates whether this instance and a specified object are equal.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Pair<(Of <(?0, ?1>)>) Structure
Equals Overload
PostSharp.Sdk.Collections Namespace


Equals Method (Pair(?0, ?1))

Pair<(Of <(<'?0, ?1>)>)>..::..Equals Method (Pair<(Of <(<'?0, ?1>)>)>)
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Equals(
    Pair<?0, ?1> other
)

Parameters

other
Type: PostSharp.Sdk.Collections..::.Pair <(Of <(<' ?0, ?1 >)>)>
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

Pair<(Of <(?0, ?1>)>) Structure
Equals Overload
PostSharp.Sdk.Collections Namespace


GetHashCode Method

Pair<(Of <(<'?0, ?1>)>)>..::..GetHashCode Method
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Operators

[image]

PostSharp 2.0 Documentation
Pair<(Of <(<'?0, ?1>)>)> Operators
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback

The Pair<(Of <(?0, ?1>)>) type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances are equal.
Inequality | Determines whether two instances are different.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Equality Operator

Pair<(Of <(<'?0, ?1>)>)>..::..Equality Operator
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Determines whether two instances are equal.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator ==(
    Pair<?0, ?1> left,
    Pair<?0, ?1> right
)

Parameters

left
Type: PostSharp.Sdk.Collections..::.Pair <(Of <(<' ?0, ?1 >)>)>
A pair.
right
Type: PostSharp.Sdk.Collections..::.Pair <(Of <(<' ?0, ?1 >)>)>
AA pair.

Return Value

true if both instances are equal, otherwise false.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Inequality Operator

Pair<(Of <(<'?0, ?1>)>)>..::..Inequality Operator
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Determines whether two instances are different.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool operator !=(
    Pair<?0, ?1> left,
    Pair<?0, ?1> right
)

Parameters

left
Type: PostSharp.Sdk.Collections..::.Pair <(Of <(<' ?0, ?1 >)>)>
A pair.
right
Type: PostSharp.Sdk.Collections..::.Pair <(Of <(<' ?0, ?1 >)>)>
A pair.

Return Value

true if both instances are different, otherwise false.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Pair(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
Pair<(Of <(<'?0, ?1>)>)> Properties
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback

The Pair<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


First Property

Pair<(Of <(<'?0, ?1>)>)>..::..First Property
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Gets the first value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 First { get; }

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Second Property

Pair<(Of <(<'?0, ?1>)>)>..::..Second Property
Pair<(Of <(?0, ?1>)>) Structure See Also Send Feedback
Gets the second value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?1 Second { get; }

See Also

Pair<(Of <(?0, ?1>)>) Structure
PostSharp.Sdk.Collections Namespace


Set(?0) Class

Set<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Collection with uniqueness constraint and with read complexity in O(1).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class Set<?0> : ICollection<?0>, IEnumerable<?0>,
    IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.Set`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.Set<(Of <(?0>)>)
PostSharp.Sdk.Collections..::.StringSet

See Also

Set<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Set(?0) Members

[image]

PostSharp 2.0 Documentation
Set<(Of <(<'?0>)>)> Members
Set<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The Set<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | Set<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | AddIfAbsent | Adds an item to the set if this set does not yet contain this item.
Public method | AddRange | Adds a range of new items to the current set.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Protected method | CreateSiblingInstance | Creates a well-typed instance; used by for operations GetUnion(Set<(Of <(?0>)>)), GetIntersection(Set<(Of <(?0>)>)) and GetDifference(Set<(Of <(?0>)>)) to create the new set.
Public method | Difference | Removes a set of items from the current set.
Public method | GetDifference | Gets the difference of the current set with another.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetIntersection | Gets the intersection of the current set with another.
Public method | GetUnion | Gets the union of the current set with another.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | ToArray | Returns an array containing all items of the current set.
Public method | Union | Merge another collection in the current set.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Set(?0) Constructor

[image]

PostSharp 2.0 Documentation
Set<(Of <(<'?0>)>)> Constructor
Set<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set<(Of <(?0>)>)()()() | Initializes a new Set<(Of <(?0>)>) with default capacity.
Public method | Set<(Of <(?0>)>)(Int32) | Initializes a new Set<(Of <(?0>)>) and specifies the initial capacity.
Public method | Set<(Of <(?0>)>)(Int32, IEqualityComparer<(Of <(?0>)>)) | Initializes a new Set<(Of <(?0>)>) and specifies the initial capacity and the comparer.

See Also

Set<(Of <(?0>)>) Class
Set<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Set(?0) Constructor

Set<(Of <(<'?0>)>)> Constructor
Set<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new Set<(Of <(?0>)>) with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set()

See Also

Set<(Of <(?0>)>) Class
Set<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


Set(?0) Constructor (Int32)

Set<(Of <(<'?0>)>)> Constructor (Int32)
Set<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new Set<(Of <(?0>)>) and specifies the initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity.

See Also

Set<(Of <(?0>)>) Class
Set<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


Set(?0) Constructor (Int32, IEqualityComparer(?0))

Set<(Of <(<'?0>)>)> Constructor (Int32, IEqualityComparer<(Of <(<'?0>)>)>)
Set<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new Set<(Of <(?0>)>) and specifies the initial capacity and the comparer.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set(
    int capacity,
    IEqualityComparer<?0> comparer
)

Parameters

capacity
Type: System..::.Int32
Initial capacity.
comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <(<' ?0 >)>)>
Comparer.

See Also

Set<(Of <(?0>)>) Class
Set<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


Set(?0) Methods

[image]

PostSharp 2.0 Documentation
Set<(Of <(<'?0>)>)> Methods
Set<(Of <(?0>)>) Class See Also Send Feedback

The Set<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | AddIfAbsent | Adds an item to the set if this set does not yet contain this item.
Public method | AddRange | Adds a range of new items to the current set.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Protected method | CreateSiblingInstance | Creates a well-typed instance; used by for operations GetUnion(Set<(Of <(?0>)>)), GetIntersection(Set<(Of <(?0>)>)) and GetDifference(Set<(Of <(?0>)>)) to create the new set.
Public method | Difference | Removes a set of items from the current set.
Public method | GetDifference | Gets the difference of the current set with another.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetIntersection | Gets the intersection of the current set with another.
Public method | GetUnion | Gets the union of the current set with another.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | ToArray | Returns an array containing all items of the current set.
Public method | Union | Merge another collection in the current set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

Set<(Of <(<'?0>)>)>..::..Add Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


AddIfAbsent Method

Set<(Of <(<'?0>)>)>..::..AddIfAbsent Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the set if this set does not yet contain this item.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AddIfAbsent(
    ?0 item
)

Parameters

item
Type: ?0
The item to add.

Return Value

true if the item was added, or false if the item was already present.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


AddRange Method

Set<(Of <(<'?0>)>)>..::..AddRange Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Adds a range of new items to the current set.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    IEnumerable<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' ?0 >)>)>
Collection of items to be added. Any of these items can be already be a part of the collection.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

Set<(Of <(<'?0>)>)>..::..Clear Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

Set<(Of <(<'?0>)>)>..::..Contains Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

Set<(Of <(<'?0>)>)>..::..CopyTo Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CreateSiblingInstance Method

Set<(Of <(<'?0>)>)>..::..CreateSiblingInstance Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Creates a well-typed instance; used by for operations GetUnion(Set<(Of <(?0>)>)), GetIntersection(Set<(Of <(?0>)>)) and GetDifference(Set<(Of <(?0>)>)) to create the new set.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual Set<?0> CreateSiblingInstance(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Capacity of the new set.

Return Value

A new set of capacity capacity.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Difference Method

Set<(Of <(<'?0>)>)>..::..Difference Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Removes a set of items from the current set.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Difference(
    IEnumerable<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' ?0 >)>)>
Collection of items to be removed from the current set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetDifference Method

Set<(Of <(<'?0>)>)>..::..GetDifference Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Gets the difference of the current set with another.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<?0> GetDifference(
    Set<?0> set
)

Parameters

set
Type: PostSharp.Sdk.Collections..::.Set <(Of <(<' ?0 >)>)>
Second set.

Return Value

A new set which the difference between the current set and set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

Set<(Of <(<'?0>)>)>..::..GetEnumerator Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetIntersection Method

Set<(Of <(<'?0>)>)>..::..GetIntersection Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Gets the intersection of the current set with another.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<?0> GetIntersection(
    Set<?0> set
)

Parameters

set
Type: PostSharp.Sdk.Collections..::.Set <(Of <(<' ?0 >)>)>
Second set.

Return Value

A new set which the intersection between the current set and set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetUnion Method

Set<(Of <(<'?0>)>)>..::..GetUnion Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Gets the union of the current set with another.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<?0> GetUnion(
    Set<?0> set
)

Parameters

set
Type: PostSharp.Sdk.Collections..::.Set <(Of <(<' ?0 >)>)>
Second set.

Return Value

A new set which the union between the current set and set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

Set<(Of <(<'?0>)>)>..::..Remove Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


ToArray Method

Set<(Of <(<'?0>)>)>..::..ToArray Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Returns an array containing all items of the current set.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0[] ToArray()

Return Value

An array containing all items of the current set.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Union Method

Set<(Of <(<'?0>)>)>..::..Union Method
Set<(Of <(?0>)>) Class See Also Send Feedback
Merge another collection in the current set.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Union(
    IEnumerable<?0> items
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' ?0 >)>)>
Collection of items (eventually with duplicates or items already present in the current collection).

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Set(?0) Properties

[image]

PostSharp 2.0 Documentation
Set<(Of <(<'?0>)>)> Properties
Set<(Of <(?0>)>) Class See Also Send Feedback

The Set<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

Set<(Of <(<'?0>)>)>..::..Count Property
Set<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

Set<(Of <(<'?0>)>)>..::..IsReadOnly Property
Set<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

Set<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0) Class

SimpleLinkedListNode<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Minimalist implementation of a one-direction linked list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SimpleLinkedListNode<?0> : IEnumerable<?0>,
    IEnumerable, ICloneable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.SimpleLinkedListNode`1"]

Remarks

There is no node implementing the list. Everything is a node. When using the IEnumerable<(Of <(T>)>) interface, you get an enumeration of the current node and all the next nodes.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.SimpleLinkedListNode<(Of <(?0>)>)

See Also

SimpleLinkedListNode<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0) Members

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)> Members
SimpleLinkedListNode<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The SimpleLinkedListNode<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleLinkedListNode<(Of <(?0>)>) | Initializes a new node.

Methods

 | Name | Description
 | Append | Overloaded.
Public method | Clone | Clone the current node (but not the value).
 | GetEnumerator | Overloaded.
Public method | GetLast | Gets the last node in the list.
 | Insert | Inserts a value at the beginning of a list.
 | Remove | Finds a node in a list and removes it.

Properties

 | Name | Description
Public property | Next | Gets the next node.
Public property | Value | Gets or sets the node value.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0) Constructor

SimpleLinkedListNode<(Of <(<'?0>)>)> Constructor
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new node.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SimpleLinkedListNode(
    ?0 value,
    SimpleLinkedListNode<?0> next
)

Parameters

value
Type: ?0
Node value.
next
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)>
Next node.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0) Methods

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)> Methods
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback

The SimpleLinkedListNode<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
 | Append | Overloaded.
Public method | Clone | Clone the current node (but not the value).
 | GetEnumerator | Overloaded.
Public method | GetLast | Gets the last node in the list.
 | Insert | Inserts a value at the beginning of a list.
 | Remove | Finds a node in a list and removes it.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Append Method

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Append Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback

Overload List

Name | Description
Append(SimpleLinkedListNode<(Of <(?0>)>)%, SimpleLinkedListNode<(Of <(?0>)>)) | Appends a list at the end of another one.
Append(SimpleLinkedListNode<(Of <(?0>)>)%, ?0) | Appends a value at the end of a list.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
SimpleLinkedListNode<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Append Method (SimpleLinkedListNode(?0), SimpleLinkedListNode(?0))

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Append Method (SimpleLinkedListNode<(Of <(<'?0>)>)>%, SimpleLinkedListNode<(Of <(<'?0>)>)>)
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Appends a list at the end of another one.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Append(
    ref SimpleLinkedListNode<?0> node,
    SimpleLinkedListNode<?0> list
)

Parameters

node
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)> %
Reference of a node of the 'left' list. May safely be a reference to a null node.
list
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)>
Reference to the head of the 'right' list. May safely be a null node.

Remarks

The 'right' list (list) is cloned, so nodes are never shared between lists.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
Append Overload
PostSharp.Sdk.Collections Namespace


Append Method (SimpleLinkedListNode(?0), ?0)

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Append Method (SimpleLinkedListNode<(Of <(<'?0>)>)>%, ?0)
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Appends a value at the end of a list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Append(
    ref SimpleLinkedListNode<?0> node,
    ?0 value
)

Parameters

node
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)> %
Reference to a node of the list. May safely be a reference to a null node.
value
Type: ?0
Value.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
Append Overload
PostSharp.Sdk.Collections Namespace


Clone Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Clone Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Clone the current node (but not the value).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SimpleLinkedListNode<?0> Clone()

Return Value

A copy of the current node.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)>..::..GetEnumerator Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEnumerator()()() | Gets an enumerator for the current and following nodes.
 | GetEnumerator(SimpleLinkedListNode<(Of <(?0>)>)) | Gets an enumerator of the list starting at a given node.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
SimpleLinkedListNode<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..GetEnumerator Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Gets an enumerator for the current and following nodes.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

An enumerator.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
GetEnumerator Overload
PostSharp.Sdk.Collections Namespace


GetEnumerator Method (SimpleLinkedListNode(?0))

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..GetEnumerator Method (SimpleLinkedListNode<(Of <(<'?0>)>)>)
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Gets an enumerator of the list starting at a given node.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<?0> GetEnumerator(
    SimpleLinkedListNode<?0> node
)

Parameters

node
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)>
The first node of the list, or null.

Return Value

An enumerator for node and all following nodes.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
GetEnumerator Overload
PostSharp.Sdk.Collections Namespace


GetLast Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..GetLast Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Gets the last node in the list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SimpleLinkedListNode<?0> GetLast()

Return Value

The last node in the list.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Insert Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Insert Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Inserts a value at the beginning of a list.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Insert(
    ref SimpleLinkedListNode<?0> node,
    ?0 value
)

Parameters

node
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)> %
Reference to the head node. May safely be a reference to a null node.
value
Type: ?0
Value.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Remove Method
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Finds a node in a list and removes it.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Remove(
    ref SimpleLinkedListNode<?0> node,
    ?0 value
)

Parameters

node
Type: PostSharp.Sdk.Collections..::.SimpleLinkedListNode <(Of <(<' ?0 >)>)> %
Reference to the head node. May safely be a reference to a null node.
value
Type: ?0
The value to remove.

Return Value

true if the node was found and removed, otherwise false.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0) Properties

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)> Properties
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback

The SimpleLinkedListNode<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Next | Gets the next node.
Public property | Value | Gets or sets the node value.

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Next Property

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Next Property
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Gets the next node.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SimpleLinkedListNode<?0> Next { get; internal set; }

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Value Property

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Value Property
SimpleLinkedListNode<(Of <(?0>)>) Class See Also Send Feedback
Gets or sets the node value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Value { get; set; }

See Also

SimpleLinkedListNode<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0).Enumerator Class

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator Class
SimpleLinkedListNode<(Of <(?0>)>) Class Members See Also Send Feedback
Enumerator for the class SimpleLinkedListNode<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class Enumerator : IEnumerator<?0>,
    IDisposable, IEnumerator

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Members
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0).Enumerator Members

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator Members
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class Methods Properties See Also Send Feedback

Minimalist implementation of a one-direction linked list.

The SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator generic type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

 | Name | Description
Public property | Current |

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0).Enumerator Methods

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator Methods
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback

The SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator generic type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


Dispose Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator..::..Dispose Method
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


MoveNext Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator..::..MoveNext Method
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MoveNext()

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


Reset Method

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator..::..Reset Method
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Reset()

Implements

IEnumerator..::.Reset()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


SimpleLinkedListNode(?0).Enumerator Properties

[image]

PostSharp 2.0 Documentation
SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator Properties
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback

The SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator generic type exposes the following members.

Properties

 | Name | Description
Public property | Current |

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


Current Property

SimpleLinkedListNode<(Of <(<'?0>)>)>..::..Enumerator..::..Current Property
SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.SimpleLinkedListNode`1.Enumerator.Current"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Current { get; }

See Also

SimpleLinkedListNode<(Of <(?0>)>)..::.Enumerator Class
PostSharp.Sdk.Collections Namespace


Singleton(?0) Class

Singleton<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Wraps a single value into a list. A singleton contains zero or one value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class Singleton<?0> : IList<?0>,
    ICollection<?0>, IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.Singleton`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.Singleton<(Of <(?0>)>)

See Also

Singleton<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Singleton(?0) Members

[image]

PostSharp 2.0 Documentation
Singleton<(Of <(<'?0>)>)> Members
Singleton<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The Singleton<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | Singleton<(Of <(?0>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Singleton(?0) Constructor

[image]

PostSharp 2.0 Documentation
Singleton<(Of <(<'?0>)>)> Constructor
Singleton<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Singleton<(Of <(?0>)>)(?0) | Initializes a new read-only Singleton<(Of <(?0>)>) containing one element
Public method | Singleton<(Of <(?0>)>)(?0, Boolean) | Initializes a new Singleton<(Of <(?0>)>) containing one element and specifies whether the collection should be read-only.

See Also

Singleton<(Of <(?0>)>) Class
Singleton<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


Singleton(?0) Constructor (?0)

Singleton<(Of <(<'?0>)>)> Constructor (?0)
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new read-only Singleton<(Of <(?0>)>) containing one element

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Singleton(
    ?0 value
)

Parameters

value
Type: ?0
Value.

See Also

Singleton<(Of <(?0>)>) Class
Singleton<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


Singleton(?0) Constructor (?0, Boolean)

Singleton<(Of <(<'?0>)>)> Constructor (?0, Boolean)
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new Singleton<(Of <(?0>)>) containing one element and specifies whether the collection should be read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Singleton(
    ?0 value,
    bool readOnly
)

Parameters

value
Type: ?0
Initial value.
readOnly
Type: System..::.Boolean
true the singleton is read-only, false if the value can be removed or overwritten.

See Also

Singleton<(Of <(?0>)>) Class
Singleton<(Of <(?0>)>) Overload
PostSharp.Sdk.Collections Namespace


Singleton(?0) Methods

[image]

PostSharp 2.0 Documentation
Singleton<(Of <(<'?0>)>)> Methods
Singleton<(Of <(?0>)>) Class See Also Send Feedback

The Singleton<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

Singleton<(Of <(<'?0>)>)>..::..Add Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

Singleton<(Of <(<'?0>)>)>..::..Clear Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

Singleton<(Of <(<'?0>)>)>..::..Contains Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

Singleton<(Of <(<'?0>)>)>..::..CopyTo Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

Singleton<(Of <(<'?0>)>)>..::..GetEnumerator Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.GetEnumerator"]

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IndexOf Method

Singleton<(Of <(<'?0>)>)>..::..IndexOf Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.IndexOf(`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int IndexOf(
    ?0 item
)

Parameters

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.IndexOf(`0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.IndexOf(`0)"]

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Insert Method

Singleton<(Of <(<'?0>)>)>..::..Insert Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.Insert(System.Int32,`0)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Insert(
    int index,
    ?0 item
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.Insert(System.Int32,`0)"]

item
Type: ?0

[Missing <param name="item"/> documentation for "M:PostSharp.Sdk.Collections.Singleton`1.Insert(System.Int32,`0)"]

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

Singleton<(Of <(<'?0>)>)>..::..Remove Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


RemoveAt Method

Singleton<(Of <(<'?0>)>)>..::..RemoveAt Method
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Removes the IList<(Of <(T>)>) item at the specified index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to remove.

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is not a valid index in the IList<(Of <(T>)>).
System..::.NotSupportedException | The IList<(Of <(T>)>) is read-only.

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Singleton(?0) Properties

[image]

PostSharp 2.0 Documentation
Singleton<(Of <(<'?0>)>)> Properties
Singleton<(Of <(?0>)>) Class See Also Send Feedback

The Singleton<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.
Public property | Item |

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

Singleton<(Of <(<'?0>)>)>..::..Count Property
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

Singleton<(Of <(<'?0>)>)>..::..IsReadOnly Property
Singleton<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Item Property

Singleton<(Of <(<'?0>)>)>..::..Item Property
Singleton<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.Singleton`1.Item(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Item[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32

See Also

Singleton<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SingletonEnumerator(?0) Class

SingletonEnumerator<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Enumerator that returns a single value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SingletonEnumerator<?0> : IEnumerator<?0>,
    IDisposable, IEnumerator

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.SingletonEnumerator`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.SingletonEnumerator<(Of <(?0>)>)

See Also

SingletonEnumerator<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


SingletonEnumerator(?0) Members

[image]

PostSharp 2.0 Documentation
SingletonEnumerator<(Of <(<'?0>)>)> Members
SingletonEnumerator<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The SingletonEnumerator<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | SingletonEnumerator<(Of <(?0>)>) | Initializes a new SingletonEnumerator<(Of <(?0>)>)

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

 | Name | Description
Public property | Current |

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SingletonEnumerator(?0) Constructor

SingletonEnumerator<(Of <(<'?0>)>)> Constructor
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new SingletonEnumerator<(Of <(?0>)>)

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SingletonEnumerator(
    ?0 value
)

Parameters

value
Type: ?0
Value returned by the Current property.

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SingletonEnumerator(?0) Methods

[image]

PostSharp 2.0 Documentation
SingletonEnumerator<(Of <(<'?0>)>)> Methods
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The SingletonEnumerator<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Dispose Method

SingletonEnumerator<(Of <(<'?0>)>)>..::..Dispose Method
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


MoveNext Method

SingletonEnumerator<(Of <(<'?0>)>)>..::..MoveNext Method
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool MoveNext()

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Reset Method

SingletonEnumerator<(Of <(<'?0>)>)>..::..Reset Method
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Reset()

Implements

IEnumerator..::.Reset()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SingletonEnumerator(?0) Properties

[image]

PostSharp 2.0 Documentation
SingletonEnumerator<(Of <(<'?0>)>)> Properties
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback

The SingletonEnumerator<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Current |

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Current Property

SingletonEnumerator<(Of <(<'?0>)>)>..::..Current Property
SingletonEnumerator<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "P:PostSharp.Sdk.Collections.SingletonEnumerator`1.Current"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Current { get; }

See Also

SingletonEnumerator<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


SortedDictionaryFactory(?0, ?1) Class

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory of Dictionary<(Of <(TKey, TValue>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SortedDictionaryFactory<?0, ?1> : IDictionaryFactory<?0, ?1>,
    ICollectionFactory<KeyValuePair<?0, ?1>>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.SortedDictionaryFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.SortedDictionaryFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.SortedDictionaryFactory<(Of <(?0, ?1>)>)

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


SortedDictionaryFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)> Members
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class Constructors Methods Fields See Also Send Feedback

The SortedDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | SortedDictionaryFactory<(Of <(?0, ?1>)>) | Initializes a new instance of the SortedDictionaryFactory<(Of <(?0, ?1>)>) class

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

Fields

Name | Description
Default | Default instance (using the default equality comparer).

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedDictionaryFactory(?0, ?1) Constructor

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)> Constructor
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new instance of the SortedDictionaryFactory<(Of <(?0, ?1>)>) class

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SortedDictionaryFactory(
    IComparer<?0> comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IComparer <(Of <(<' ?0 >)>)>

[Missing <param name="comparer"/> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.#ctor(System.Collections.Generic.IComparer{`0})"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedDictionaryFactory(?0, ?1) Fields

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)> Fields
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The SortedDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
Default | Default instance (using the default equality comparer).

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Default Field

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..Default Field
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Default instance (using the default equality comparer).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly SortedDictionaryFactory<?0, ?1> Default

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedDictionaryFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)> Methods
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | CreateDictionary | Overloaded.
Public method | EnsureCapacity | Overloaded.

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() |
Public method | CreateCollection(Int32) |

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
SortedDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateCollection"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateCollection"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method (Int32)
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateCollection(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateCollection(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateCollection(System.Int32)"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDictionary()()() |
Public method | CreateDictionary(Int32) |

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
SortedDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateDictionary Method

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateDictionary"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<?0, ?1> CreateDictionary()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateDictionary"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


CreateDictionary Method (Int32)

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateDictionary Method (Int32)
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateDictionary(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<?0, ?1> CreateDictionary(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateDictionary(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.CreateDictionary(System.Int32)"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateDictionary Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

[image]

PostSharp 2.0 Documentation
SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsureCapacity(ICollection<(Of <(KeyValuePair<(Of <(?0, ?1>)>)>)>), Int32) | Ensures that a collection has the given capacity.
Public method | EnsureCapacity(IDictionary<(Of <(?0, ?1>)>), Int32) |

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
SortedDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (ICollection(KeyValuePair(?0, ?1)), Int32)

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method (ICollection<(Of <(<'KeyValuePair<(Of <(<'?0, ?1>)>)>>)>)>, Int32)
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Ensures that a collection has the given capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<KeyValuePair<?0, ?1>> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>
A collection.
capacity
Type: System..::.Int32
The required capacity.

Implements

ICollectionFactory<(Of <(?0>)>)..::.EnsureCapacity(ICollection<(Of <(?0>)>), Int32)

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method (IDictionary(?0, ?1), Int32)

SortedDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method (IDictionary<(Of <(<'?0, ?1>)>)>, Int32)
SortedDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    IDictionary<?0, ?1> dictionary,
    int capacity
)

Parameters

dictionary
Type: System.Collections.Generic..::.IDictionary <(Of <(<' ?0, ?1 >)>)>

[Missing <param name="dictionary"/> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.SortedDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.IDictionary{`0,`1},System.Int32)"]

See Also

SortedDictionaryFactory<(Of <(?0, ?1>)>) Class
EnsureCapacity Overload
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Class

SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
MultiDictionary<(Of <(?0, ?1>)>) where keys are ordered.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SortedMultiDictionary<?0, ?1> : MultiDictionary<?0, ?1>
where ?0 : Object, IComparable<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.SortedMultiDictionary`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.SortedMultiDictionary`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.MultiDictionary <(Of <(<'?0, ?1>)>)>
PostSharp.Sdk.Collections..::.SortedMultiDictionary<(Of <(?0, ?1>)>)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Members
SortedMultiDictionary<(Of <(?0, ?1>)>) Class Constructors Methods Properties See Also Send Feedback

The SortedMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | SortedMultiDictionary<(Of <(?0, ?1>)>) | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of values in the current dictionary. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetArrayByKey | Gets the array of values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetCountByKey | Gets the number of items registered under a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumeratorByKey | Gets an enumerator of values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Merge | Merges a MultiDictionary<(Of <(?0, ?1>)>) into the current instance. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Remove | Overloaded.
Public method | RemoveAll | Removes all values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the expected number of keys. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Item | Gets the list of values associated with a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | Gets the collection of keys. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Constructor

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Constructor
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortedMultiDictionary<(Of <(?0, ?1>)>)()()() | Initializes a new SortedMultiDictionary<(Of <(?0, ?1>)>) with default capacity.
Public method | SortedMultiDictionary<(Of <(?0, ?1>)>)(Int32) | Initializes a new SortedMultiDictionary<(Of <(?0, ?1>)>) and sets the initial capacity.

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
SortedMultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Constructor

SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Constructor
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new SortedMultiDictionary<(Of <(?0, ?1>)>) with default capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SortedMultiDictionary()

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
SortedMultiDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Constructor (Int32)

SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Constructor (Int32)
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback
Initializes a new SortedMultiDictionary<(Of <(?0, ?1>)>) and sets the initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SortedMultiDictionary(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity of unique keys.

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
SortedMultiDictionary<(Of <(?0, ?1>)>) Overload
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Methods
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The SortedMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of values in the current dictionary. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | Determines whether the dictionary contains at least one value associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetArrayByKey | Gets the array of values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetCountByKey | Gets the number of items registered under a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumeratorByKey | Gets an enumerator of values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Merge | Merges a MultiDictionary<(Of <(?0, ?1>)>) into the current instance. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Remove | Overloaded.
Public method | RemoveAll | Removes all values associated to a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)>..::..Add Method
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Add(?0, ?1) | Adds a key-value pair in the dictionary. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
SortedMultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


Remove Method

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)>..::..Remove Method
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(KeyValuePair<(Of <(?0, ?1>)>)) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public method | Remove(?0, ?1) | (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
SortedMultiDictionary<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


SortedMultiDictionary(?0, ?1) Properties

[image]

PostSharp 2.0 Documentation
SortedMultiDictionary<(Of <(<'?0, ?1>)>)> Properties
SortedMultiDictionary<(Of <(?0, ?1>)>) Class See Also Send Feedback

The SortedMultiDictionary<(Of <(?0, ?1>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the expected number of keys. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Item | Gets the list of values associated with a given key. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | Gets the collection of keys. (Inherited from MultiDictionary<(Of <(?0, ?1>)>).)

See Also

SortedMultiDictionary<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedMultiDictionaryFactory(?0, ?1) Class

SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Class
Members See Also Send Feedback
Factory for SortedMultiDictionary<(Of <(?0, ?1>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SortedMultiDictionaryFactory<?0, ?1> : ICollectionFactory<KeyValuePair<?0, ?1>>
where ?0 : Object, IComparable<?0>

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2"]

?1

[Missing <typeparam name="?1"/> documentation for "T:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.SortedMultiDictionaryFactory<(Of <(?0, ?1>)>)

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


SortedMultiDictionaryFactory(?0, ?1) Members

[image]

PostSharp 2.0 Documentation
SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Members
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class Methods Fields See Also Send Feedback

The SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity |

Fields

Name | Description
Default | Singleton instance.

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedMultiDictionaryFactory(?0, ?1) Fields

[image]

PostSharp 2.0 Documentation
SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Fields
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Fields

Name | Description
Default | Singleton instance.

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


Default Field

SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..Default Field
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback
Singleton instance.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static readonly SortedMultiDictionaryFactory<?0, ?1> Default

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


SortedMultiDictionaryFactory(?0, ?1) Methods

[image]

PostSharp 2.0 Documentation
SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)> Methods
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

The SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) type exposes the following members.

Methods

 | Name | Description
Public method | CreateCollection | Overloaded.
Public method | EnsureCapacity |

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


CreateCollection Method

[image]

PostSharp 2.0 Documentation
SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCollection()()() |
Public method | CreateCollection(Int32) |

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Members
PostSharp.Sdk.Collections Namespace


CreateCollection Method

SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.CreateCollection"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.CreateCollection"]

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


CreateCollection Method (Int32)

SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..CreateCollection Method (Int32)
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.CreateCollection(System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ICollection<KeyValuePair<?0, ?1>> CreateCollection(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.CreateCollection(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.CreateCollection(System.Int32)"]

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
CreateCollection Overload
PostSharp.Sdk.Collections Namespace


EnsureCapacity Method

SortedMultiDictionaryFactory<(Of <(<'?0, ?1>)>)>..::..EnsureCapacity Method
SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.ICollection{System.Collections.Generic.KeyValuePair{`0,`1}},System.Int32)"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EnsureCapacity(
    ICollection<KeyValuePair<?0, ?1>> collection,
    int capacity
)

Parameters

collection
Type: System.Collections.Generic..::.ICollection <(Of <(<' KeyValuePair <(Of <(<' ?0, ?1 >)>)>>)>)>

[Missing <param name="collection"/> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.ICollection{System.Collections.Generic.KeyValuePair{`0,`1}},System.Int32)"]

capacity
Type: System..::.Int32

[Missing <param name="capacity"/> documentation for "M:PostSharp.Sdk.Collections.SortedMultiDictionaryFactory`2.EnsureCapacity(System.Collections.Generic.ICollection{System.Collections.Generic.KeyValuePair{`0,`1}},System.Int32)"]

See Also

SortedMultiDictionaryFactory<(Of <(?0, ?1>)>) Class
PostSharp.Sdk.Collections Namespace


StringSet Class

StringSet Class
Members See Also Send Feedback
Set of strings.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class StringSet : Set<string>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.Set <(Of <(<' String >)>)>
PostSharp.Sdk.Collections..::.StringSet

See Also

StringSet Members
PostSharp.Sdk.Collections Namespace


StringSet Members

[image]

PostSharp 2.0 Documentation
StringSet Members
StringSet Class Constructors Methods Properties See Also Send Feedback

The StringSet type exposes the following members.

Constructors

 | Name | Description
Public method | StringSet | Overloaded.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | AddIfAbsent | Adds an item to the set if this set does not yet contain this item. (Inherited from Set<(Of <(?0>)>).)
Public method | AddRange | Adds a range of new items to the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from Set<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from Set<(Of <(?0>)>).)
Protected method | CreateSiblingInstance | Creates a well-typed instance; used by for operations GetUnion(Set<(Of <(?0>)>)), GetIntersection(Set<(Of <(?0>)>)) and GetDifference(Set<(Of <(?0>)>)) to create the new set. (Inherited from Set<(Of <(?0>)>).)
Public method | Difference | Removes a set of items from the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | GetDifference | Gets the difference of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Set<(Of <(?0>)>).)
Public method | GetIntersection | Gets the intersection of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | GetUnion | Gets the union of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | ToArray | Returns an array containing all items of the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | Union | Merge another collection in the current set. (Inherited from Set<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Set<(Of <(?0>)>).)

See Also

StringSet Class
PostSharp.Sdk.Collections Namespace


StringSet Constructor

[image]

PostSharp 2.0 Documentation
StringSet Constructor
StringSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringSet()()() | Initializes a new StringSet with default initial capacity.
Public method | StringSet(Int32) | Initializes a new StringSet and specifies the initial capacity.

See Also

StringSet Class
StringSet Members
PostSharp.Sdk.Collections Namespace


StringSet Constructor

StringSet Constructor
StringSet Class See Also Send Feedback
Initializes a new StringSet with default initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StringSet()

See Also

StringSet Class
StringSet Overload
PostSharp.Sdk.Collections Namespace


StringSet Constructor (Int32)

StringSet Constructor (Int32)
StringSet Class See Also Send Feedback
Initializes a new StringSet and specifies the initial capacity.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StringSet(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
Initial capacity.

See Also

StringSet Class
StringSet Overload
PostSharp.Sdk.Collections Namespace


StringSet Methods

[image]

PostSharp 2.0 Documentation
StringSet Methods
StringSet Class See Also Send Feedback

The StringSet type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | AddIfAbsent | Adds an item to the set if this set does not yet contain this item. (Inherited from Set<(Of <(?0>)>).)
Public method | AddRange | Adds a range of new items to the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from Set<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from Set<(Of <(?0>)>).)
Protected method | CreateSiblingInstance | Creates a well-typed instance; used by for operations GetUnion(Set<(Of <(?0>)>)), GetIntersection(Set<(Of <(?0>)>)) and GetDifference(Set<(Of <(?0>)>)) to create the new set. (Inherited from Set<(Of <(?0>)>).)
Public method | Difference | Removes a set of items from the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | GetDifference | Gets the difference of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Set<(Of <(?0>)>).)
Public method | GetIntersection | Gets the intersection of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | GetUnion | Gets the union of the current set with another. (Inherited from Set<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public method | ToArray | Returns an array containing all items of the current set. (Inherited from Set<(Of <(?0>)>).)
Public method | Union | Merge another collection in the current set. (Inherited from Set<(Of <(?0>)>).)

See Also

StringSet Class
PostSharp.Sdk.Collections Namespace


StringSet Properties

[image]

PostSharp 2.0 Documentation
StringSet Properties
StringSet Class See Also Send Feedback

The StringSet type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from Set<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from Set<(Of <(?0>)>).)

See Also

StringSet Class
PostSharp.Sdk.Collections Namespace


UnionCollection(?0) Class

UnionCollection<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Wrapper that exposes the union of two collections as a single collection.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class UnionCollection<?0> : ICollection<?0>,
    IEnumerable<?0>, IEnumerable

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.UnionCollection`1"]

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.UnionCollection<(Of <(?0>)>)

See Also

UnionCollection<(Of <(?0>)>) Members
PostSharp.Sdk.Collections Namespace


UnionCollection(?0) Members

[image]

PostSharp 2.0 Documentation
UnionCollection<(Of <(<'?0>)>)> Members
UnionCollection<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The UnionCollection<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | UnionCollection<(Of <(?0>)>) | Initializes a new UnionCollection<(Of <(?0>)>).

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


UnionCollection(?0) Constructor

UnionCollection<(Of <(<'?0>)>)> Constructor
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new UnionCollection<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UnionCollection(
    ICollection<?0> first,
    ICollection<?0> second
)

Parameters

first
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
A collection.
second
Type: System.Collections.Generic..::.ICollection <(Of <(<' ?0 >)>)>
A collection.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


UnionCollection(?0) Methods

[image]

PostSharp 2.0 Documentation
UnionCollection<(Of <(<'?0>)>)> Methods
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback

The UnionCollection<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>).
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>).
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | GetEnumerator |
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Add Method

UnionCollection<(Of <(<'?0>)>)>..::..Add Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Adds an item to the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    ?0 item
)

Parameters

item
Type: ?0
The object to add to the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Clear Method

UnionCollection<(Of <(<'?0>)>)>..::..Clear Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes all items from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Contains Method

UnionCollection<(Of <(<'?0>)>)>..::..Contains Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the ICollection<(Of <(T>)>) contains a specific value.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    ?0 item
)

Parameters

item
Type: ?0
The object to locate in the ICollection<(Of <(T>)>).

Return Value

true if item is found in the ICollection<(Of <(T>)>); otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


CopyTo Method

UnionCollection<(Of <(<'?0>)>)>..::..CopyTo Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    ?0[] array,
    int arrayIndex
)

Parameters

array
Type: array< ?0 >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


GetEnumerator Method

UnionCollection<(Of <(<'?0>)>)>..::..GetEnumerator Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Collections.UnionCollection`1.GetEnumerator"]

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<?0> GetEnumerator()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Collections.UnionCollection`1.GetEnumerator"]

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Remove Method

UnionCollection<(Of <(<'?0>)>)>..::..Remove Method
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    ?0 item
)

Parameters

item
Type: ?0
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


UnionCollection(?0) Properties

[image]

PostSharp 2.0 Documentation
UnionCollection<(Of <(<'?0>)>)> Properties
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback

The UnionCollection<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Count Property

UnionCollection<(Of <(<'?0>)>)>..::..Count Property
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


IsReadOnly Property

UnionCollection<(Of <(<'?0>)>)>..::..IsReadOnly Property
UnionCollection<(Of <(?0>)>) Class See Also Send Feedback
Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only.

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsReadOnly { get; }

Return Value

true if the ICollection<(Of <(T>)>) is read-only; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

UnionCollection<(Of <(?0>)>) Class
PostSharp.Sdk.Collections Namespace


Visitor(?0) Delegate

Visitor<(Of <(<'?0>)>)> Delegate
See Also Send Feedback
Signature of the method that should be called by Visit(String, Visitor<(Of <(?0>)>)).

Namespace: PostSharp.Sdk.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public delegate void Visitor<?0>(
    IVisitable<?0> owner,
    string role,
    ?0 item
)

Parameters

owner
Type: PostSharp.Sdk.Collections..::.IVisitable <(Of <(<'?0>)>)>
Object owning the visited item.
role
Type: System..::.String
Role of the visited item
item
Type: ?0
Visited item.

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Collections.Visitor`1"]

See Also

PostSharp.Sdk.Collections Namespace


PostSharp.Sdk.Extensibility Namespace

PostSharp.Sdk.Extensibility Namespace
Send Feedback
The PostSharp.Sdk.Extensibility namespace implements the platform infrastructure, i.e. the system of configuration, projects, and tasks.

Classes

 | Class | Description
Public class | AnnotationInstance | Represents a AnnotationValue that is applied to one and only one target element.
Public class | AnnotationValue | Represents a custom attribute value that is not declared inside a module, i.e. is not a MetadataDeclaration.
Public class | AssembleOptions | Options of the TargetPlatformAdapter.Assemble(ModuleDeclaration, AssembleOptions) method.
Public class | ConfigurablePropertyAttribute | Custom attribute that, then applied on a property of a class derived from Task, specifies that this property is configurable as an XML attribute in the XML project file.
Public class | MessageEventArgs | Arguments of the Message event.
Public class | MessageSinkAccessor | Gives access to a remove IMessageSink.
Public class | Messenger | Publish-subscribe channel for error messages (Message).
Public class | ModuleLoadDirectFromFileStrategy | Implementation of ModuleLoadStrategy that loads a module directly from disk, without using Reflection before.
Public class | ModuleLoadReflectionFromFileStrategy | Implementation of ModuleLoadStrategy loading the assembly by file location, using the Assembly.LoadFile method.
Public class | ModuleLoadReflectionFromNameStrategy | Implementation of ModuleLoadStrategy loading the assembly by name, using the Assembly.Load method.
Public class | ModuleLoadReflectionStrategy | Abstract implementation of ModuleLoadStrategy that first loads the assembly using reflection.
Public class | ModuleLoadStrategy | Abstract strategy determining how a module should be loaded (typically by name, ModuleLoadReflectionFromNameStrategy; or by file path, ModuleLoadReflectionFromFileStrategy).
Public class | Project | Contains the actual configuration of the application or project at a given time in the project loading process, i.e. with resolved properties and references.
Public class | PropertyCollection | Collection of properties.
Public class | RemotingAccessor<(Of <(?0>)>) | Automatically manages the lifetime of a remote object.
Public class | SharedAnnotationInstance | Implementation of IAnnotationInstance that allows the same custom attribute value to be applied to many target elements.
Public class | TagCollection | Collection of tags (see ITaggable). Used to pass tags from the host to the Domain and Project objects.
Public class | Task | Execution unit of a Project.
Public class | TaskCollection | Collection of tasks (Task).

Enumerations

 | Enumeration | Description
Public enumeration | DebugOption | Determines how debugging will be supported for the target module.
Public enumeration | TaskState | States of a Task.


AnnotationInstance Class

AnnotationInstance Class
Members See Also Send Feedback
Represents a AnnotationValue that is applied to one and only one target element.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AnnotationInstance : AnnotationValue,
    IAnnotationInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.AnnotationValue
PostSharp.Sdk.Extensibility..::.AnnotationInstance

See Also

AnnotationInstance Members
PostSharp.Sdk.Extensibility Namespace


AnnotationInstance Members

[image]

PostSharp 2.0 Documentation
AnnotationInstance Members
AnnotationInstance Class Constructors Methods Properties See Also Send Feedback

The AnnotationInstance type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationInstance | Initializes a new instance of the AnnotationInstance type.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from AnnotationValue.)
Public method | Translate | Translates the current annotation so that it is valid in another module. (Inherited from AnnotationValue.)

Properties

 | Name | Description
Public property | Constructor | Gets the constructor that was used to build the custom attribute. (Inherited from AnnotationValue.)
Public property | ConstructorArguments | Gets the collection of constructor arguments. (Inherited from AnnotationValue.)
Public property | IsDisposed | Determines whether the current instance has been disposed. (Inherited from AnnotationValue.)
Public property | NamedArguments | Gets the collection of named arguments. (Inherited from AnnotationValue.)
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


AnnotationInstance Constructor

AnnotationInstance Constructor
AnnotationInstance Class See Also Send Feedback
Initializes a new instance of the AnnotationInstance type.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AnnotationInstance(
    SymAspectUsage symAspectUsage,
    MetadataDeclaration targetElement,
    IMethod constructor
)

Parameters

symAspectUsage
Type: PostSharp.Sdk.WeavingSymbols..::.SymAspectUsage
The representation of this annotation instance in the symbol file.
targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Element on which the custom attribute applies.
constructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Custom attribute constructor.

Remarks

The constructor parameter should be set to a valid instance constructor. This rule is not enforced imperatively.

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


AnnotationInstance Methods

[image]

PostSharp 2.0 Documentation
AnnotationInstance Methods
AnnotationInstance Class See Also Send Feedback

The AnnotationInstance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from AnnotationValue.)
Public method | Translate | Translates the current annotation so that it is valid in another module. (Inherited from AnnotationValue.)

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


AnnotationInstance Properties

[image]

PostSharp 2.0 Documentation
AnnotationInstance Properties
AnnotationInstance Class See Also Send Feedback

The AnnotationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gets the constructor that was used to build the custom attribute. (Inherited from AnnotationValue.)
Public property | ConstructorArguments | Gets the collection of constructor arguments. (Inherited from AnnotationValue.)
Public property | IsDisposed | Determines whether the current instance has been disposed. (Inherited from AnnotationValue.)
Public property | NamedArguments | Gets the collection of named arguments. (Inherited from AnnotationValue.)
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


Symbol Property

AnnotationInstance..::..Symbol Property
AnnotationInstance Class See Also Send Feedback
Element of the symbol file representing the current aspect instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsage Symbol { get; }

Implements

IAnnotationInstance..::.Symbol

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


TargetElement Property

AnnotationInstance..::..TargetElement Property
AnnotationInstance Class See Also Send Feedback
Element on which the annotation value is applied.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; }

Implements

IAnnotationInstance..::.TargetElement

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


Value Property

AnnotationInstance..::..Value Property
AnnotationInstance Class See Also Send Feedback
Custom attribute value.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationValue Value { get; }

Implements

IAnnotationInstance..::.Value

See Also

AnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


AnnotationValue Class

AnnotationValue Class
Members See Also Send Feedback
Represents a custom attribute value that is not declared inside a module, i.e. is not a MetadataDeclaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class AnnotationValue : IAnnotationValue,
    IDisposable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.AnnotationValue
PostSharp.Sdk.Extensibility..::.AnnotationInstance

See Also

AnnotationValue Members
PostSharp.Sdk.Extensibility Namespace


AnnotationValue Members

[image]

PostSharp 2.0 Documentation
AnnotationValue Members
AnnotationValue Class Constructors Methods Properties See Also Send Feedback

The AnnotationValue type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationValue | Initializes a new instance of the CustomAttributeDeclaration type.

Methods

 | Name | Description
Protected method | AssertNotDisposed | Throws an exception if the current instance has been disposed.
Public method | Dispose | Overloaded.
 | FromObjectConstruction | Builds an AnnotationValue from an ObjectConstruction.
 | ToObjectConstruction | Converts an IAnnotationValue into an ObjectConstruction.
Public method | Translate | Translates the current annotation so that it is valid in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

Properties

 | Name | Description
Public property | Constructor | Gets the constructor that was used to build the custom attribute.
Public property | ConstructorArguments | Gets the collection of constructor arguments.
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | NamedArguments | Gets the collection of named arguments.

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


AnnotationValue Constructor

AnnotationValue Constructor
AnnotationValue Class See Also Send Feedback
Initializes a new instance of the CustomAttributeDeclaration type.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AnnotationValue(
    IMethod constructor
)

Parameters

constructor
Type: PostSharp.Sdk.CodeModel..::.IMethod
Custom attribute constructor.

Remarks

The constructor parameter should be set to a valid instance constructor. This rule is not enforced imperatively.

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


AnnotationValue Methods

[image]

PostSharp 2.0 Documentation
AnnotationValue Methods
AnnotationValue Class See Also Send Feedback

The AnnotationValue type exposes the following members.

Methods

 | Name | Description
Protected method | AssertNotDisposed | Throws an exception if the current instance has been disposed.
Public method | Dispose | Overloaded.
 | FromObjectConstruction | Builds an AnnotationValue from an ObjectConstruction.
 | ToObjectConstruction | Converts an IAnnotationValue into an ObjectConstruction.
Public method | Translate | Translates the current annotation so that it is valid in another module.

Extension Methods

 | Name | Description
Public Extension Method | [extension] | Overloaded. Construct the instance (typically an object derived from Attribute) represented a given IAnnotationValue. This overload uses reflection to locate the constructor, and does not work if the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as a generic argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Construct the instance represented by a given IAnnotationValue, given its type passed as an argument. This overload is safe even when the target framework is not .NET Framework. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to a string. (Defined by CustomAttributeHelper.)
Public Extension Method | [extension] | Overloaded. Renders a custom attribute value to an existing StringBuilder. (Defined by CustomAttributeHelper.)

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


AssertNotDisposed Method

AnnotationValue..::..AssertNotDisposed Method
AnnotationValue Class See Also Send Feedback
Throws an exception if the current instance has been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AssertNotDisposed()

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
AnnotationValue..::..Dispose Method
AnnotationValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance.

See Also

AnnotationValue Class
AnnotationValue Members
PostSharp.Sdk.Extensibility Namespace


Dispose Method

AnnotationValue..::..Dispose Method
AnnotationValue Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

AnnotationValue Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


Dispose Method (Boolean)

AnnotationValue..::..Dispose Method (Boolean)
AnnotationValue Class See Also Send Feedback
Disposes the resources hold by the current instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
disposing if the current method is called because an explicit call of Dispose()()(), or false if the method is called by the destructor.

See Also

AnnotationValue Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


FromObjectConstruction Method

AnnotationValue..::..FromObjectConstruction Method
AnnotationValue Class See Also Send Feedback
Builds an AnnotationValue from an ObjectConstruction.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AnnotationValue FromObjectConstruction(
    ObjectConstruction objectConstruction,
    ModuleDeclaration module
)

Parameters

objectConstruction
Type: PostSharp.Reflection..::.ObjectConstruction
An ObjectConstruction.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module for which the AnnotationValue should be built.

Return Value

A new AnnotationValue representing objectConstruction.

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


ToObjectConstruction Method

AnnotationValue..::..ToObjectConstruction Method
AnnotationValue Class See Also Send Feedback
Converts an IAnnotationValue into an ObjectConstruction.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ObjectConstruction ToObjectConstruction(
    IAnnotationValue annotationValue,
    bool useReflectionWrapper
)

Parameters

annotationValue
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
An IAnnotationValue.
useReflectionWrapper
Type: System..::.Boolean
true if reflection wrappers should be used instead of runtime reflection objects, otherwise false.

Return Value

The ObjectConstruction corresponding to annotationValue.

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


Translate Method

AnnotationValue..::..Translate Method
AnnotationValue Class See Also Send Feedback
Translates the current annotation so that it is valid in another module.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationValue Translate(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
The module into which the current IAnnotationValue should be translated.

Return Value

An IAnnotationValue valid in module.

Implements

IAnnotationValue..::.Translate(ModuleDeclaration)

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


AnnotationValue Properties

[image]

PostSharp 2.0 Documentation
AnnotationValue Properties
AnnotationValue Class See Also Send Feedback

The AnnotationValue type exposes the following members.

Properties

 | Name | Description
Public property | Constructor | Gets the constructor that was used to build the custom attribute.
Public property | ConstructorArguments | Gets the collection of constructor arguments.
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | NamedArguments | Gets the collection of named arguments.

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


Constructor Property

AnnotationValue..::..Constructor Property
AnnotationValue Class See Also Send Feedback
Gets the constructor that was used to build the custom attribute.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IMethod Constructor { get; }

Implements

IAnnotationValue..::.Constructor

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


ConstructorArguments Property

AnnotationValue..::..ConstructorArguments Property
AnnotationValue Class See Also Send Feedback
Gets the collection of constructor arguments.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection ConstructorArguments { get; }

Field Value

A collection of values (MemberValuePair) where MemberName is not significant.

Implements

IAnnotationValue..::.ConstructorArguments

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


IsDisposed Property

AnnotationValue..::..IsDisposed Property
AnnotationValue Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


NamedArguments Property

AnnotationValue..::..NamedArguments Property
AnnotationValue Class See Also Send Feedback
Gets the collection of named arguments.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MemberValuePairCollection NamedArguments { get; }

Field Value

A collection of member-value associations (MemberValuePair).

Implements

IAnnotationValue..::.NamedArguments

See Also

AnnotationValue Class
PostSharp.Sdk.Extensibility Namespace


AssembleOptions Class

AssembleOptions Class
Members See Also Send Feedback
Options of the TargetPlatformAdapter.Assemble(ModuleDeclaration, AssembleOptions) method.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AssembleOptions

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.AssembleOptions

See Also

AssembleOptions Members
PostSharp.Sdk.Extensibility Namespace


AssembleOptions Members

[image]

PostSharp 2.0 Documentation
AssembleOptions Members
AssembleOptions Class Constructors Properties See Also Send Feedback

The AssembleOptions type exposes the following members.

Constructors

 | Name | Description
Public method | AssembleOptions | Initializes a new AssembleOptions.

Properties

 | Name | Description
Public property | DebugOptions | Gets ot sets the debug options.
Public property | PrivateKeyLocation | If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.
Public property | SignAssembly | Determines whether the assembly should be signed using a digital key.
Public property | SourceFile | Gets or sets the path of the source file.
Public property | TargetFile | Gets or sets the path of the target file.
Public property | UnmanagedResourceFile | Gets or sets the path of the file containing unmanaged resources in .RES format.

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


AssembleOptions Constructor

AssembleOptions Constructor
AssembleOptions Class See Also Send Feedback
Initializes a new AssembleOptions.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssembleOptions(
    string sourceFile,
    string targetFile
)

Parameters

sourceFile
Type: System..::.String
Origin file.
targetFile
Type: System..::.String
Target file.

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


AssembleOptions Properties

[image]

PostSharp 2.0 Documentation
AssembleOptions Properties
AssembleOptions Class See Also Send Feedback

The AssembleOptions type exposes the following members.

Properties

 | Name | Description
Public property | DebugOptions | Gets ot sets the debug options.
Public property | PrivateKeyLocation | If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.
Public property | SignAssembly | Determines whether the assembly should be signed using a digital key.
Public property | SourceFile | Gets or sets the path of the source file.
Public property | TargetFile | Gets or sets the path of the target file.
Public property | UnmanagedResourceFile | Gets or sets the path of the file containing unmanaged resources in .RES format.

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


DebugOptions Property

AssembleOptions..::..DebugOptions Property
AssembleOptions Class See Also Send Feedback
Gets ot sets the debug options.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DebugOption DebugOptions { get; set; }

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


PrivateKeyLocation Property

AssembleOptions..::..PrivateKeyLocation Property
AssembleOptions Class See Also Send Feedback
If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PrivateKeyLocation { get; set; }

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


SignAssembly Property

AssembleOptions..::..SignAssembly Property
AssembleOptions Class See Also Send Feedback
Determines whether the assembly should be signed using a digital key.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool SignAssembly { get; set; }

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


SourceFile Property

AssembleOptions..::..SourceFile Property
AssembleOptions Class See Also Send Feedback
Gets or sets the path of the source file.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string SourceFile { get; set; }

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


TargetFile Property

AssembleOptions..::..TargetFile Property
AssembleOptions Class See Also Send Feedback
Gets or sets the path of the target file.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TargetFile { get; set; }

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


UnmanagedResourceFile Property

AssembleOptions..::..UnmanagedResourceFile Property
AssembleOptions Class See Also Send Feedback
Gets or sets the path of the file containing unmanaged resources in .RES format.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string UnmanagedResourceFile { get; set; }

Field Value

A complete file path, or null if the module does not contain unmanaged resources.

See Also

AssembleOptions Class
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Class

ConfigurablePropertyAttribute Class
Members See Also Send Feedback
Custom attribute that, then applied on a property of a class derived from Task, specifies that this property is configurable as an XML attribute in the XML project file.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ConfigurablePropertyAttribute : Attribute

Remarks

Configurable properties may be of one of the following types: enumeration, DateTime, or any type implementing IConvertible.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PostSharp.Sdk.Extensibility..::.ConfigurablePropertyAttribute

See Also

ConfigurablePropertyAttribute Members
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Members

[image]

PostSharp 2.0 Documentation
ConfigurablePropertyAttribute Members
ConfigurablePropertyAttribute Class Constructors Properties See Also Send Feedback

The ConfigurablePropertyAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurablePropertyAttribute | Overloaded.

Properties

 | Name | Description
Public property | Required | Determines whether the property is required.

See Also

ConfigurablePropertyAttribute Class
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Constructor

[image]

PostSharp 2.0 Documentation
ConfigurablePropertyAttribute Constructor
ConfigurablePropertyAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConfigurablePropertyAttribute()()() | Initializes a new ConfigurablePropertyAttribute, specifying that the property is not required.
Public method | ConfigurablePropertyAttribute(Boolean) | Initializes a new ConfigurablePropertyAttribute, and specifies whether the property is required or not.

See Also

ConfigurablePropertyAttribute Class
ConfigurablePropertyAttribute Members
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Constructor

ConfigurablePropertyAttribute Constructor
ConfigurablePropertyAttribute Class See Also Send Feedback
Initializes a new ConfigurablePropertyAttribute, specifying that the property is not required.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ConfigurablePropertyAttribute()

See Also

ConfigurablePropertyAttribute Class
ConfigurablePropertyAttribute Overload
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Constructor (Boolean)

ConfigurablePropertyAttribute Constructor (Boolean)
ConfigurablePropertyAttribute Class See Also Send Feedback
Initializes a new ConfigurablePropertyAttribute, and specifies whether the property is required or not.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ConfigurablePropertyAttribute(
    bool required
)

Parameters

required
Type: System..::.Boolean

[Missing <param name="required"/> documentation for "M:PostSharp.Sdk.Extensibility.ConfigurablePropertyAttribute.#ctor(System.Boolean)"]

See Also

ConfigurablePropertyAttribute Class
ConfigurablePropertyAttribute Overload
PostSharp.Sdk.Extensibility Namespace


ConfigurablePropertyAttribute Properties

[image]

PostSharp 2.0 Documentation
ConfigurablePropertyAttribute Properties
ConfigurablePropertyAttribute Class See Also Send Feedback

The ConfigurablePropertyAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Required | Determines whether the property is required.

See Also

ConfigurablePropertyAttribute Class
PostSharp.Sdk.Extensibility Namespace


Required Property

ConfigurablePropertyAttribute..::..Required Property
ConfigurablePropertyAttribute Class See Also Send Feedback
Determines whether the property is required.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Required { get; set; }

See Also

ConfigurablePropertyAttribute Class
PostSharp.Sdk.Extensibility Namespace


DebugOption Enumeration

DebugOption Enumeration
See Also Send Feedback
Determines how debugging will be supported for the target module.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum DebugOption

Members

Member name | Value | Description
Auto | 0 | Determines automatically (Pdb if the source module has debugging information, otherwise None.
Pdb | 1 | Create a PDB file.
None | 2 | No support for debugging.

See Also

PostSharp.Sdk.Extensibility Namespace


MessageEventArgs Class

MessageEventArgs Class
Members See Also Send Feedback
Arguments of the Message event.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MessageEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PostSharp.Sdk.Extensibility..::.MessageEventArgs

See Also

MessageEventArgs Members
PostSharp.Sdk.Extensibility Namespace


MessageEventArgs Members

[image]

PostSharp 2.0 Documentation
MessageEventArgs Members
MessageEventArgs Class Constructors Properties See Also Send Feedback

The MessageEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MessageEventArgs | Initializes a new MessageEventArgs.

Properties

 | Name | Description
Public property | Message | Gets the Message signaled by the event.

See Also

MessageEventArgs Class
PostSharp.Sdk.Extensibility Namespace


MessageEventArgs Constructor

MessageEventArgs Constructor
MessageEventArgs Class See Also Send Feedback
Initializes a new MessageEventArgs.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MessageEventArgs(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A Message.

See Also

MessageEventArgs Class
PostSharp.Sdk.Extensibility Namespace


MessageEventArgs Properties

[image]

PostSharp 2.0 Documentation
MessageEventArgs Properties
MessageEventArgs Class See Also Send Feedback

The MessageEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the Message signaled by the event.

See Also

MessageEventArgs Class
PostSharp.Sdk.Extensibility Namespace


Message Property

MessageEventArgs..::..Message Property
MessageEventArgs Class See Also Send Feedback
Gets the Message signaled by the event.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Message Message { get; }

See Also

MessageEventArgs Class
PostSharp.Sdk.Extensibility Namespace


MessageSinkAccessor Class

MessageSinkAccessor Class
Members See Also Send Feedback
Gives access to a remove IMessageSink.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MessageSinkAccessor : RemotingAccessor<IMessageSink>,
    IMessageSink

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.RemotingAccessor <(Of <(<' IMessageSink >)>)>
PostSharp.Sdk.Extensibility..::.MessageSinkAccessor

See Also

MessageSinkAccessor Members
PostSharp.Sdk.Extensibility Namespace


MessageSinkAccessor Members

[image]

PostSharp 2.0 Documentation
MessageSinkAccessor Members
MessageSinkAccessor Class Constructors Methods Properties See Also Send Feedback

The MessageSinkAccessor type exposes the following members.

Constructors

 | Name | Description
Public method | MessageSinkAccessor | Initializes a new MessageSinkAccessor

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | Write | Writes a message to the sink.

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public property | Value | Gets the remote object. (Inherited from RemotingAccessor<(Of <(?0>)>).)

See Also

MessageSinkAccessor Class
PostSharp.Sdk.Extensibility Namespace


MessageSinkAccessor Constructor

MessageSinkAccessor Constructor
MessageSinkAccessor Class See Also Send Feedback
Initializes a new MessageSinkAccessor

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MessageSinkAccessor(
    IMessageSink remoteSink,
    bool ownRemoteSink
)

Parameters

remoteSink
Type: PostSharp.Extensibility..::.IMessageSink
A message sink implementing MarshalByRefObject.
ownRemoteSink
Type: System..::.Boolean
true if remoteSink should be disposed when the accessor is disposed, otherwise false.

See Also

MessageSinkAccessor Class
PostSharp.Sdk.Extensibility Namespace


MessageSinkAccessor Methods

[image]

PostSharp 2.0 Documentation
MessageSinkAccessor Methods
MessageSinkAccessor Class See Also Send Feedback

The MessageSinkAccessor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public method | Write | Writes a message to the sink.

See Also

MessageSinkAccessor Class
PostSharp.Sdk.Extensibility Namespace


Write Method

MessageSinkAccessor..::..Write Method
MessageSinkAccessor Class See Also Send Feedback
Writes a message to the sink.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A message.

Implements

IMessageSink..::.Write(Message)

See Also

MessageSinkAccessor Class
PostSharp.Sdk.Extensibility Namespace


MessageSinkAccessor Properties

[image]

PostSharp 2.0 Documentation
MessageSinkAccessor Properties
MessageSinkAccessor Class See Also Send Feedback

The MessageSinkAccessor type exposes the following members.

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed. (Inherited from RemotingAccessor<(Of <(?0>)>).)
Public property | Value | Gets the remote object. (Inherited from RemotingAccessor<(Of <(?0>)>).)

See Also

MessageSinkAccessor Class
PostSharp.Sdk.Extensibility Namespace


Messenger Class

Messenger Class
Members See Also Send Feedback
Publish-subscribe channel for error messages (Message).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Messenger : MarshalByRefObject,
    IMessageSink, IDisposable

Remarks

Each thread has its own instance of the Messenger class. Message emitters should use the Write(Message) method, consumers should subscribe to the Message event or implement the IMessageSink interface and register it using the AddRemoteSink(IMessageSink, Boolean) method.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Messenger

See Also

Messenger Members
PostSharp.Sdk.Extensibility Namespace


Messenger Members

[image]

PostSharp 2.0 Documentation
Messenger Members
Messenger Class Constructors Methods Properties Events See Also Send Feedback

The Messenger type exposes the following members.

Constructors

 | Name | Description
Public method | Messenger | Initializes a new Messenger.

Methods

 | Name | Description
Public method | AddRemoteSink | Adds a remote message sink to the current Messenger.
Public method | DisableMessage | Disables a message given its identifier.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EscalateMessage | Escalates a message, given its identifier.
 | Initialize | Forces to initialize the static Messenger instance.
Public method | RemoveRemoteSink | Removes a remote message sink from the current Messenger.
Public method | Write | Emits a message.

Properties

 | Name | Description
 | Current | Gets the Messenger associated with the current thread.
Public property | ErrorCount | Gets the current number of emitted error messages.
Public property | FatalCount | Gets the number of emitted fatal error messages.
Public property | InfoCount | Gets the current number of emitted info messages.
Public property | MaxErrorCount | Gets or sets the maximal number of errors before a fatal error is emitted.
Public property | WarningCount | Gets the current number of emitted warning messages.

Events

 | Name | Description
Public event | Message | Event raised when a message is emitted.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Messenger Constructor

Messenger Constructor
Messenger Class See Also Send Feedback
Initializes a new Messenger.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Messenger()

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Messenger Methods

[image]

PostSharp 2.0 Documentation
Messenger Methods
Messenger Class See Also Send Feedback

The Messenger type exposes the following members.

Methods

 | Name | Description
Public method | AddRemoteSink | Adds a remote message sink to the current Messenger.
Public method | DisableMessage | Disables a message given its identifier.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EscalateMessage | Escalates a message, given its identifier.
 | Initialize | Forces to initialize the static Messenger instance.
Public method | RemoveRemoteSink | Removes a remote message sink from the current Messenger.
Public method | Write | Emits a message.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


AddRemoteSink Method

Messenger..::..AddRemoteSink Method
Messenger Class See Also Send Feedback
Adds a remote message sink to the current Messenger.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRemoteSink(
    IMessageSink sink,
    bool ownSink
)

Parameters

sink
Type: PostSharp.Extensibility..::.IMessageSink
A message sink that resides in another application domain.
ownSink
Type: System..::.Boolean
true if the current Messenger should dispose sink when the Messenger is disposed, otherwise false.

Remarks

All message sinks registered by this method shall be called when a message will be written into the current Messenger

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


DisableMessage Method

Messenger..::..DisableMessage Method
Messenger Class See Also Send Feedback
Disables a message given its identifier.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void DisableMessage(
    string messageId
)

Parameters

messageId
Type: System..::.String
Identifier of the message to be disabled.

Remarks

Disabling a message means ignoring it. You can disable only information and warning messages, not errors.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Dispose Method

Messenger..::..Dispose Method
Messenger Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


EscalateMessage Method

Messenger..::..EscalateMessage Method
Messenger Class See Also Send Feedback
Escalates a message, given its identifier.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void EscalateMessage(
    string messageId
)

Parameters

messageId
Type: System..::.String
Identifier of the message to be escalated.

Remarks

Disabling a message means changing its severity to Error.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Initialize Method

Messenger..::..Initialize Method
Messenger Class See Also Send Feedback
Forces to initialize the static Messenger instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Initialize()

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


RemoveRemoteSink Method

Messenger..::..RemoveRemoteSink Method
Messenger Class See Also Send Feedback
Removes a remote message sink from the current Messenger.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool RemoveRemoteSink(
    IMessageSink sink
)

Parameters

sink
Type: PostSharp.Extensibility..::.IMessageSink
A message sink that resides in another application domain.

Return Value

true if sink has been removed, otherwise false.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Write Method

Messenger..::..Write Method
Messenger Class See Also Send Feedback
Emits a message.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    Message message
)

Parameters

message
Type: PostSharp.Extensibility..::.Message
A Message.

Implements

IMessageSink..::.Write(Message)

Exceptions

Exception | Condition
PostSharp.Extensibility..::.MessageException | The message severity is Fatal.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Messenger Properties

[image]

PostSharp 2.0 Documentation
Messenger Properties
Messenger Class See Also Send Feedback

The Messenger type exposes the following members.

Properties

 | Name | Description
 | Current | Gets the Messenger associated with the current thread.
Public property | ErrorCount | Gets the current number of emitted error messages.
Public property | FatalCount | Gets the number of emitted fatal error messages.
Public property | InfoCount | Gets the current number of emitted info messages.
Public property | MaxErrorCount | Gets or sets the maximal number of errors before a fatal error is emitted.
Public property | WarningCount | Gets the current number of emitted warning messages.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Current Property

Messenger..::..Current Property
Messenger Class See Also Send Feedback
Gets the Messenger associated with the current thread.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Messenger Current { get; internal set; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


ErrorCount Property

Messenger..::..ErrorCount Property
Messenger Class See Also Send Feedback
Gets the current number of emitted error messages.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int ErrorCount { get; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


FatalCount Property

Messenger..::..FatalCount Property
Messenger Class See Also Send Feedback
Gets the number of emitted fatal error messages.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int FatalCount { get; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


InfoCount Property

Messenger..::..InfoCount Property
Messenger Class See Also Send Feedback
Gets the current number of emitted info messages.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int InfoCount { get; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


MaxErrorCount Property

Messenger..::..MaxErrorCount Property
Messenger Class See Also Send Feedback
Gets or sets the maximal number of errors before a fatal error is emitted.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int MaxErrorCount { get; set; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


WarningCount Property

Messenger..::..WarningCount Property
Messenger Class See Also Send Feedback
Gets the current number of emitted warning messages.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int WarningCount { get; }

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Messenger Events

[image]

PostSharp 2.0 Documentation
Messenger Events
Messenger Class See Also Send Feedback

The Messenger type exposes the following members.

Events

 | Name | Description
Public event | Message | Event raised when a message is emitted.

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


Message Event

Messenger..::..Message Event
Messenger Class See Also Send Feedback
Event raised when a message is emitted.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public event EventHandler<MessageEventArgs> Message

See Also

Messenger Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Class

ModuleLoadDirectFromFileStrategy Class
Members See Also Send Feedback
Implementation of ModuleLoadStrategy that loads a module directly from disk, without using Reflection before.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class ModuleLoadDirectFromFileStrategy : ModuleLoadStrategy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadDirectFromFileStrategy

See Also

ModuleLoadDirectFromFileStrategy Members
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Members

[image]

PostSharp 2.0 Documentation
ModuleLoadDirectFromFileStrategy Members
ModuleLoadDirectFromFileStrategy Class Constructors Methods Properties See Also Send Feedback

The ModuleLoadDirectFromFileStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleLoadDirectFromFileStrategy | Overloaded.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Overrides ModuleLoadStrategy..::.Load(Domain).)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Overrides ModuleLoadStrategy..::.LazyLoading.)

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Constructor

[image]

PostSharp 2.0 Documentation
ModuleLoadDirectFromFileStrategy Constructor
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ModuleLoadDirectFromFileStrategy(String) | Initializes a new ModuleLoadDirectFromFileStrategy that will not load the module using lazy loading.
Public method | ModuleLoadDirectFromFileStrategy(String, Boolean) | Initializes a new ModuleLoadDirectFromFileStrategy and specifies whether the module should be loaded using lazy loading.

See Also

ModuleLoadDirectFromFileStrategy Class
ModuleLoadDirectFromFileStrategy Members
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Constructor (String)

ModuleLoadDirectFromFileStrategy Constructor (String)
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback
Initializes a new ModuleLoadDirectFromFileStrategy that will not load the module using lazy loading.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleLoadDirectFromFileStrategy(
    string fileName
)

Parameters

fileName
Type: System..::.String
Full path of the module.

See Also

ModuleLoadDirectFromFileStrategy Class
ModuleLoadDirectFromFileStrategy Overload
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Constructor (String, Boolean)

ModuleLoadDirectFromFileStrategy Constructor (String, Boolean)
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback
Initializes a new ModuleLoadDirectFromFileStrategy and specifies whether the module should be loaded using lazy loading.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleLoadDirectFromFileStrategy(
    string fileName,
    bool lazyLoading
)

Parameters

fileName
Type: System..::.String
Full path of the module.
lazyLoading
Type: System..::.Boolean
true if the module should be loaded using lazy loading, otherwise false.

See Also

ModuleLoadDirectFromFileStrategy Class
ModuleLoadDirectFromFileStrategy Overload
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Methods

[image]

PostSharp 2.0 Documentation
ModuleLoadDirectFromFileStrategy Methods
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback

The ModuleLoadDirectFromFileStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Overrides ModuleLoadStrategy..::.Load(Domain).)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


Load Method

ModuleLoadDirectFromFileStrategy..::..Load Method
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback
Loads the assembly into the current AppDomain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Load(
    Domain domain
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain

[Missing <param name="domain"/> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadDirectFromFileStrategy.Load(PostSharp.Sdk.CodeModel.Domain)"]

Return Value

The loaded assembly.

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


Matches Method

ModuleLoadDirectFromFileStrategy..::..Matches Method
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback
Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Matches(
    Domain domain,
    IAssemblyName assemblyName
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
A Domain (used to evaluate binding policies).
assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

true if the current ModuleLoadStrategy matches assemblyName given the binding policies of domain, otherwise false.

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadDirectFromFileStrategy Properties

[image]

PostSharp 2.0 Documentation
ModuleLoadDirectFromFileStrategy Properties
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback

The ModuleLoadDirectFromFileStrategy type exposes the following members.

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Overrides ModuleLoadStrategy..::.LazyLoading.)

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


LazyLoading Property

ModuleLoadDirectFromFileStrategy..::..LazyLoading Property
ModuleLoadDirectFromFileStrategy Class See Also Send Feedback
Determines whether the module should be loaded lazily.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool LazyLoading { get; }

See Also

ModuleLoadDirectFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromFileStrategy Class

ModuleLoadReflectionFromFileStrategy Class
Members See Also Send Feedback
Implementation of ModuleLoadStrategy loading the assembly by file location, using the Assembly.LoadFile method.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class ModuleLoadReflectionFromFileStrategy : ModuleLoadReflectionStrategy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionFromFileStrategy

See Also

ModuleLoadReflectionFromFileStrategy Members
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromFileStrategy Members

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromFileStrategy Members
ModuleLoadReflectionFromFileStrategy Class Constructors Methods Properties See Also Send Feedback

The ModuleLoadReflectionFromFileStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleLoadReflectionFromFileStrategy | Initializes a new ModuleLoadReflectionFromFileStrategy.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Inherited from ModuleLoadReflectionStrategy.)
Public method | LoadAssembly | Loads the assembly using reflection. (Overrides ModuleLoadReflectionStrategy..::.LoadAssembly()()().)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | FileName | Gets the full physical path of the assembly.
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Inherited from ModuleLoadReflectionStrategy.)

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromFileStrategy Constructor

ModuleLoadReflectionFromFileStrategy Constructor
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback
Initializes a new ModuleLoadReflectionFromFileStrategy.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleLoadReflectionFromFileStrategy(
    string fileName
)

Parameters

fileName
Type: System..::.String
Full physical path of the assembly.

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromFileStrategy Methods

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromFileStrategy Methods
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback

The ModuleLoadReflectionFromFileStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Inherited from ModuleLoadReflectionStrategy.)
Public method | LoadAssembly | Loads the assembly using reflection. (Overrides ModuleLoadReflectionStrategy..::.LoadAssembly()()().)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


LoadAssembly Method

ModuleLoadReflectionFromFileStrategy..::..LoadAssembly Method
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback
Loads the assembly using reflection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Assembly LoadAssembly()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadReflectionFromFileStrategy.LoadAssembly"]

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


Matches Method

ModuleLoadReflectionFromFileStrategy..::..Matches Method
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback
Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Matches(
    Domain domain,
    IAssemblyName assemblyName
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
A Domain (used to evaluate binding policies).
assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

true if the current ModuleLoadStrategy matches assemblyName given the binding policies of domain, otherwise false.

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ToString Method

ModuleLoadReflectionFromFileStrategy..::..ToString Method
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromFileStrategy Properties

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromFileStrategy Properties
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback

The ModuleLoadReflectionFromFileStrategy type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets the full physical path of the assembly.
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Inherited from ModuleLoadReflectionStrategy.)

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


FileName Property

ModuleLoadReflectionFromFileStrategy..::..FileName Property
ModuleLoadReflectionFromFileStrategy Class See Also Send Feedback
Gets the full physical path of the assembly.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FileName { get; }

See Also

ModuleLoadReflectionFromFileStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromNameStrategy Class

ModuleLoadReflectionFromNameStrategy Class
Members See Also Send Feedback
Implementation of ModuleLoadStrategy loading the assembly by name, using the Assembly.Load method.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class ModuleLoadReflectionFromNameStrategy : ModuleLoadReflectionStrategy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionFromNameStrategy

See Also

ModuleLoadReflectionFromNameStrategy Members
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromNameStrategy Members

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromNameStrategy Members
ModuleLoadReflectionFromNameStrategy Class Constructors Methods Properties See Also Send Feedback

The ModuleLoadReflectionFromNameStrategy type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleLoadReflectionFromNameStrategy | Initializes a new ModuleLoadReflectionFromNameStrategy.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Inherited from ModuleLoadReflectionStrategy.)
Public method | LoadAssembly | Loads the assembly using reflection. (Overrides ModuleLoadReflectionStrategy..::.LoadAssembly()()().)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Inherited from ModuleLoadReflectionStrategy.)
Public property | Name | Gets the assembly name.

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromNameStrategy Constructor

ModuleLoadReflectionFromNameStrategy Constructor
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback
Initializes a new ModuleLoadReflectionFromNameStrategy.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleLoadReflectionFromNameStrategy(
    string name
)

Parameters

name
Type: System..::.String
Assembly name.

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromNameStrategy Methods

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromNameStrategy Methods
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback

The ModuleLoadReflectionFromNameStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Inherited from ModuleLoadReflectionStrategy.)
Public method | LoadAssembly | Loads the assembly using reflection. (Overrides ModuleLoadReflectionStrategy..::.LoadAssembly()()().)
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Overrides ModuleLoadStrategy..::.Matches(Domain, IAssemblyName).)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


LoadAssembly Method

ModuleLoadReflectionFromNameStrategy..::..LoadAssembly Method
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback
Loads the assembly using reflection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override Assembly LoadAssembly()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadReflectionFromNameStrategy.LoadAssembly"]

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


Matches Method

ModuleLoadReflectionFromNameStrategy..::..Matches Method
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback
Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Matches(
    Domain domain,
    IAssemblyName assemblyName
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
A Domain (used to evaluate binding policies).
assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

true if the current ModuleLoadStrategy matches assemblyName given the binding policies of domain, otherwise false.

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


ToString Method

ModuleLoadReflectionFromNameStrategy..::..ToString Method
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionFromNameStrategy Properties

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionFromNameStrategy Properties
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback

The ModuleLoadReflectionFromNameStrategy type exposes the following members.

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Inherited from ModuleLoadReflectionStrategy.)
Public property | Name | Gets the assembly name.

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


Name Property

ModuleLoadReflectionFromNameStrategy..::..Name Property
ModuleLoadReflectionFromNameStrategy Class See Also Send Feedback
Gets the assembly name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; }

See Also

ModuleLoadReflectionFromNameStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionStrategy Class

ModuleLoadReflectionStrategy Class
Members See Also Send Feedback
Abstract implementation of ModuleLoadStrategy that first loads the assembly using reflection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class ModuleLoadReflectionStrategy : ModuleLoadStrategy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionFromFileStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionFromNameStrategy

See Also

ModuleLoadReflectionStrategy Members
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionStrategy Members

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionStrategy Members
ModuleLoadReflectionStrategy Class Constructors Methods Properties See Also Send Feedback

The ModuleLoadReflectionStrategy type exposes the following members.

Constructors

 | Name | Description
Protected method | ModuleLoadReflectionStrategy | Initializes a new instance of the ModuleLoadReflectionStrategy class

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Overrides ModuleLoadStrategy..::.Load(Domain).)
Public method | LoadAssembly | Loads the assembly using reflection.
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Inherited from ModuleLoadStrategy.)

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Overrides ModuleLoadStrategy..::.LazyLoading.)

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionStrategy Constructor

ModuleLoadReflectionStrategy Constructor
ModuleLoadReflectionStrategy Class See Also Send Feedback
Initializes a new instance of the ModuleLoadReflectionStrategy class

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected ModuleLoadReflectionStrategy()

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionStrategy Methods

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionStrategy Methods
ModuleLoadReflectionStrategy Class See Also Send Feedback

The ModuleLoadReflectionStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain. (Overrides ModuleLoadStrategy..::.Load(Domain).)
Public method | LoadAssembly | Loads the assembly using reflection.
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain. (Inherited from ModuleLoadStrategy.)

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


Load Method

ModuleLoadReflectionStrategy..::..Load Method
ModuleLoadReflectionStrategy Class See Also Send Feedback
Loads the assembly into the current AppDomain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override ModuleDeclaration Load(
    Domain domain
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain

[Missing <param name="domain"/> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadReflectionStrategy.Load(PostSharp.Sdk.CodeModel.Domain)"]

Return Value

The loaded assembly.

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


LoadAssembly Method

ModuleLoadReflectionStrategy..::..LoadAssembly Method
ModuleLoadReflectionStrategy Class See Also Send Feedback
Loads the assembly using reflection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract Assembly LoadAssembly()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadReflectionStrategy.LoadAssembly"]

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadReflectionStrategy Properties

[image]

PostSharp 2.0 Documentation
ModuleLoadReflectionStrategy Properties
ModuleLoadReflectionStrategy Class See Also Send Feedback

The ModuleLoadReflectionStrategy type exposes the following members.

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily. (Overrides ModuleLoadStrategy..::.LazyLoading.)

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


LazyLoading Property

ModuleLoadReflectionStrategy..::..LazyLoading Property
ModuleLoadReflectionStrategy Class See Also Send Feedback
Determines whether the module should be loaded lazily.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool LazyLoading { get; }

See Also

ModuleLoadReflectionStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadStrategy Class

ModuleLoadStrategy Class
Members See Also Send Feedback
Abstract strategy determining how a module should be loaded (typically by name, ModuleLoadReflectionFromNameStrategy; or by file path, ModuleLoadReflectionFromFileStrategy).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class ModuleLoadStrategy

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadDirectFromFileStrategy
PostSharp.Sdk.Extensibility..::.ModuleLoadReflectionStrategy

See Also

ModuleLoadStrategy Members
PostSharp.Sdk.Extensibility Namespace
Assembly..::.LoadFrom(String, Evidence)
Assembly..::.Load(String, Evidence)


ModuleLoadStrategy Members

[image]

PostSharp 2.0 Documentation
ModuleLoadStrategy Members
ModuleLoadStrategy Class Constructors Methods Properties See Also Send Feedback

The ModuleLoadStrategy type exposes the following members.

Constructors

 | Name | Description
Protected method | ModuleLoadStrategy | Initializes a new instance of the ModuleLoadStrategy class

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain.
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily.

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadStrategy Constructor

ModuleLoadStrategy Constructor
ModuleLoadStrategy Class See Also Send Feedback
Initializes a new instance of the ModuleLoadStrategy class

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected ModuleLoadStrategy()

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadStrategy Methods

[image]

PostSharp 2.0 Documentation
ModuleLoadStrategy Methods
ModuleLoadStrategy Class See Also Send Feedback

The ModuleLoadStrategy type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the assembly into the current AppDomain.
Public method | Matches | Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


Load Method

ModuleLoadStrategy..::..Load Method
ModuleLoadStrategy Class See Also Send Feedback
Loads the assembly into the current AppDomain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract ModuleDeclaration Load(
    Domain domain
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain

[Missing <param name="domain"/> documentation for "M:PostSharp.Sdk.Extensibility.ModuleLoadStrategy.Load(PostSharp.Sdk.CodeModel.Domain)"]

Return Value

The loaded assembly.

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


Matches Method

ModuleLoadStrategy..::..Matches Method
ModuleLoadStrategy Class See Also Send Feedback
Determines whether the current ModuleLoadStrategy matches a given assembly name in a given Domain.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool Matches(
    Domain domain,
    IAssemblyName assemblyName
)

Parameters

domain
Type: PostSharp.Sdk.CodeModel..::.Domain
A Domain (used to evaluate binding policies).
assemblyName
Type: PostSharp.Reflection..::.IAssemblyName
An assembly name.

Return Value

true if the current ModuleLoadStrategy matches assemblyName given the binding policies of domain, otherwise false.

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


ModuleLoadStrategy Properties

[image]

PostSharp 2.0 Documentation
ModuleLoadStrategy Properties
ModuleLoadStrategy Class See Also Send Feedback

The ModuleLoadStrategy type exposes the following members.

Properties

 | Name | Description
Public property | LazyLoading | Determines whether the module should be loaded lazily.

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


LazyLoading Property

ModuleLoadStrategy..::..LazyLoading Property
ModuleLoadStrategy Class See Also Send Feedback
Determines whether the module should be loaded lazily.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public abstract bool LazyLoading { get; }

See Also

ModuleLoadStrategy Class
PostSharp.Sdk.Extensibility Namespace


Project Class

Project Class
Members See Also Send Feedback
Contains the actual configuration of the application or project at a given time in the project loading process, i.e. with resolved properties and references.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class Project : MarshalByRefObject,
    IDisposable, ITaggable, IProject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Project

See Also

Project Members
PostSharp.Sdk.Extensibility Namespace


Project Members

[image]

PostSharp 2.0 Documentation
Project Members
Project Class Methods Properties See Also Send Feedback

The Project type exposes the following members.

Methods

 | Name | Description
Public method | AddPath | Add a directory to the project search path.
Public method | AddPlugIn | Adds and load a plugin in the current project.
 | CreateInstance | Overloaded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Evaluate | Evaluates an expression.
Public method | Execute | Executes the current project.
Public method | ExecutePhase | Executes a single phase of the project.
Public method | GetFullPath | Gets the full path of a path that may be given either absolutely either relatively.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTargetAssembly | Gets the assembly being transformed.
Public method | SetTag | Set a tag to the current declaration.
 | ValidatePath | Writes a fatal error message is a given string is not a valid path string.

Properties

 | Name | Description
 | ApplicationConfiguration | Gets the application-level configuration.
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Module | Gets the target ModuleDeclaration in its current state.
 | Phases | Gets the collection of phases.
Public property | Platforms | Gets the directory of platforms indexed by name.
Public property | PlugIns | Gets the collection of plug-ins included at this point.
Public property | ProjectConfiguration | Gets the project configuration element.
Public property | Properties | Gets the collection of properties.
Public property | StrongNames | Gets the mappings between assembly friendly names and the corresponding strong names.
Public property | Tasks | Gets the collection of project tasks,
Public property | TaskTypes | Gets the directory of task types indexed by name.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Project Methods

[image]

PostSharp 2.0 Documentation
Project Methods
Project Class See Also Send Feedback

The Project type exposes the following members.

Methods

 | Name | Description
Public method | AddPath | Add a directory to the project search path.
Public method | AddPlugIn | Adds and load a plugin in the current project.
 | CreateInstance | Overloaded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Evaluate | Evaluates an expression.
Public method | Execute | Executes the current project.
Public method | ExecutePhase | Executes a single phase of the project.
Public method | GetFullPath | Gets the full path of a path that may be given either absolutely either relatively.
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | GetTargetAssembly | Gets the assembly being transformed.
Public method | SetTag | Set a tag to the current declaration.
 | ValidatePath | Writes a fatal error message is a given string is not a valid path string.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


AddPath Method

Project..::..AddPath Method
Project Class See Also Send Feedback
Add a directory to the project search path.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddPath(
    string path
)

Parameters

path
Type: System..::.String
A directory name.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


AddPlugIn Method

Project..::..AddPlugIn Method
Project Class See Also Send Feedback
Adds and load a plugin in the current project.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool AddPlugIn(
    string shortName
)

Parameters

shortName
Type: System..::.String
Name of the plug-in (without directory or extension)

Return Value

true if the plug-in was just added, false if it was already loaded.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


CreateInstance Method

[image]

PostSharp 2.0 Documentation
Project..::..CreateInstance Method
Project Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(String, ModuleDeclaration, PropertyCollection, TagCollection) | Creates a new Project and assigns it to a module has already been loaded as a ModuleDeclaration.
CreateInstance(String, Domain, ModuleLoadStrategy, PropertyCollection, TagCollection) | Creates a new Project instance and assigns it to a module that has not already been loaded.

See Also

Project Class
Project Members
PostSharp.Sdk.Extensibility Namespace


CreateInstance Method (String, ModuleDeclaration, PropertyCollection, TagCollection)

Project..::..CreateInstance Method (String, ModuleDeclaration, PropertyCollection, TagCollection)
Project Class See Also Send Feedback
Creates a new Project and assigns it to a module has already been loaded as a ModuleDeclaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Project CreateInstance(
    string projectFileName,
    ModuleDeclaration module,
    PropertyCollection properties,
    TagCollection tags
)

Parameters

projectFileName
Type: System..::.String
Location of the project file to be executed.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module that needs to be processed.
properties
Type: PostSharp.Sdk.Extensibility..::.PropertyCollection
Collection of properties for the project execution.
tags
Type: PostSharp.Sdk.Extensibility..::.TagCollection
Collection of tags to be applied to the project, or null if no tag has to be applied.

Return Value

true if the project was successful, otherwise false.

See Also

Project Class
CreateInstance Overload
PostSharp.Sdk.Extensibility Namespace


CreateInstance Method (String, Domain, ModuleLoadStrategy, PropertyCollection, TagCollection)

Project..::..CreateInstance Method (String, Domain, ModuleLoadStrategy, PropertyCollection, TagCollection)
Project Class See Also Send Feedback
Creates a new Project instance and assigns it to a module that has not already been loaded.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Project CreateInstance(
    string projectFileName,
    Domain domain,
    ModuleLoadStrategy moduleLoadStrategy,
    PropertyCollection properties,
    TagCollection tags
)

Parameters

projectFileName
Type: System..::.String
The location of the project file to be executed.
domain
Type: PostSharp.Sdk.CodeModel..::.Domain
The Domain into which the module has to be loaded.
moduleLoadStrategy
Type: PostSharp.Sdk.Extensibility..::.ModuleLoadStrategy
Specifies how the assembly should be loaded.
properties
Type: PostSharp.Sdk.Extensibility..::.PropertyCollection
Collection of properties for the project execution.
tags
Type: PostSharp.Sdk.Extensibility..::.TagCollection
Collection of tags to be applied to the project, or null if no tag has to be applied.

Return Value

true if the project was successful, otherwise false.

See Also

Project Class
CreateInstance Overload
PostSharp.Sdk.Extensibility Namespace


Dispose Method

Project..::..Dispose Method
Project Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Evaluate Method

Project..::..Evaluate Method
Project Class See Also Send Feedback
Evaluates an expression.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Evaluate(
    string expression
)

Parameters

expression
Type: System..::.String
An expression.

Return Value

The expression value.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Execute Method

Project..::..Execute Method
Project Class See Also Send Feedback
Executes the current project.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Execute()

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.Project.Execute"]

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


ExecutePhase Method

Project..::..ExecutePhase Method
Project Class See Also Send Feedback
Executes a single phase of the project.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ExecutePhase(
    string phase
)

Parameters

phase
Type: System..::.String
Name of the phase to be executed.

Return Value

true if the execution was successful, otherwise false.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


GetFullPath Method

Project..::..GetFullPath Method
Project Class See Also Send Feedback
Gets the full path of a path that may be given either absolutely either relatively.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string GetFullPath(
    string path
)

Parameters

path
Type: System..::.String
Path that may be given either absolutely, either relatively to the reference directory of the current project. This path may contain expressions.

Return Value

The full path corresponding to path, or null if path contained an expression that could not be resolved.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


GetTag Method

Project..::..GetTag Method
Project Class See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

Implements

ITaggable..::.GetTag(TagId)

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


GetTargetAssembly Method

Project..::..GetTargetAssembly Method
Project Class See Also Send Feedback
Gets the assembly being transformed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public _Assembly GetTargetAssembly(
    bool getWrapper
)

Parameters

getWrapper
Type: System..::.Boolean
true if a reflection wrapper should be returned, true if a system Assembly should be returned.

Return Value

The assembly being processed.

Implements

IProject..::.GetTargetAssembly(Boolean)

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


SetTag Method

Project..::..SetTag Method
Project Class See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

Implements

ITaggable..::.SetTag(TagId, Object)

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


ValidatePath Method

Project..::..ValidatePath Method
Project Class See Also Send Feedback
Writes a fatal error message is a given string is not a valid path string.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void ValidatePath(
    string path
)

Parameters

path
Type: System..::.String
A string.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Project Properties

[image]

PostSharp 2.0 Documentation
Project Properties
Project Class See Also Send Feedback

The Project type exposes the following members.

Properties

 | Name | Description
 | ApplicationConfiguration | Gets the application-level configuration.
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Module | Gets the target ModuleDeclaration in its current state.
 | Phases | Gets the collection of phases.
Public property | Platforms | Gets the directory of platforms indexed by name.
Public property | PlugIns | Gets the collection of plug-ins included at this point.
Public property | ProjectConfiguration | Gets the project configuration element.
Public property | Properties | Gets the collection of properties.
Public property | StrongNames | Gets the mappings between assembly friendly names and the corresponding strong names.
Public property | Tasks | Gets the collection of project tasks,
Public property | TaskTypes | Gets the directory of task types indexed by name.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


ApplicationConfiguration Property

Project..::..ApplicationConfiguration Property
Project Class See Also Send Feedback
Gets the application-level configuration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ApplicationConfiguration ApplicationConfiguration { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


IsDisposed Property

Project..::..IsDisposed Property
Project Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Module Property

Project..::..Module Property
Project Class See Also Send Feedback
Gets the target ModuleDeclaration in its current state.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleDeclaration Module { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Phases Property

Project..::..Phases Property
Project Class See Also Send Feedback
Gets the collection of phases.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static PhaseConfigurationDictionary Phases { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Platforms Property

Project..::..Platforms Property
Project Class See Also Send Feedback
Gets the directory of platforms indexed by name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlatformConfigurationDictionary Platforms { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


PlugIns Property

Project..::..PlugIns Property
Project Class See Also Send Feedback
Gets the collection of plug-ins included at this point.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public StringSet PlugIns { get; }

Remarks

This collection contains the full paths of loaded plug-ins. This is to avoid cycles in references.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


ProjectConfiguration Property

Project..::..ProjectConfiguration Property
Project Class See Also Send Feedback
Gets the project configuration element.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProjectConfiguration ProjectConfiguration { get; }

Field Value

A ProjectConfiguration, or null if no project has been loaded.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Properties Property

Project..::..Properties Property
Project Class See Also Send Feedback
Gets the collection of properties.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyCollection Properties { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


StrongNames Property

Project..::..StrongNames Property
Project Class See Also Send Feedback
Gets the mappings between assembly friendly names and the corresponding strong names.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IDictionary<string, AssemblyName> StrongNames { get; }

Remarks

This dictionary is used to automatically map short names to strong names in case a short name is found in a configuration file.

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


Tasks Property

Project..::..Tasks Property
Project Class See Also Send Feedback
Gets the collection of project tasks,

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskCollection Tasks { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


TaskTypes Property

Project..::..TaskTypes Property
Project Class See Also Send Feedback
Gets the directory of task types indexed by name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfigurationDictionary TaskTypes { get; }

See Also

Project Class
PostSharp.Sdk.Extensibility Namespace


PropertyCollection Class

PropertyCollection Class
Members See Also Send Feedback
Collection of properties.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PropertyCollection

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.PropertyCollection

See Also

PropertyCollection Members
PostSharp.Sdk.Extensibility Namespace


PropertyCollection Members

[image]

PostSharp 2.0 Documentation
PropertyCollection Members
PropertyCollection Class Constructors Methods Properties See Also Send Feedback

The PropertyCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyCollection | Initializes a new instance of the PropertyCollection class

Methods

 | Name | Description
Public method | Merge | Merge another collection of properties into the current collection.

Properties

 | Name | Description
Public property | Item | Gets or sets a property.

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


PropertyCollection Constructor

PropertyCollection Constructor
PropertyCollection Class See Also Send Feedback
Initializes a new instance of the PropertyCollection class

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyCollection()

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


PropertyCollection Methods

[image]

PostSharp 2.0 Documentation
PropertyCollection Methods
PropertyCollection Class See Also Send Feedback

The PropertyCollection type exposes the following members.

Methods

 | Name | Description
Public method | Merge | Merge another collection of properties into the current collection.

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


Merge Method

PropertyCollection..::..Merge Method
PropertyCollection Class See Also Send Feedback
Merge another collection of properties into the current collection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Merge(
    PropertyCollection properties
)

Parameters

properties
Type: PostSharp.Sdk.Extensibility..::.PropertyCollection
Another collection of properties.

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


PropertyCollection Properties

[image]

PostSharp 2.0 Documentation
PropertyCollection Properties
PropertyCollection Class See Also Send Feedback

The PropertyCollection type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets a property.

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


Item Property

PropertyCollection..::..Item Property
PropertyCollection Class See Also Send Feedback
Gets or sets a property.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Item[
    string key
] { get; set; }

Parameters

key
Type: System..::.String
Property name.

Return Value

The property value, or null if the property is not defined.

See Also

PropertyCollection Class
PostSharp.Sdk.Extensibility Namespace


RemotingAccessor(?0) Class

RemotingAccessor<(Of <(<'?0>)>)> Class
Members See Also Send Feedback
Automatically manages the lifetime of a remote object.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class RemotingAccessor<?0> : IDisposable
where ?0 : class

Type Parameters

?0

[Missing <typeparam name="?0"/> documentation for "T:PostSharp.Sdk.Extensibility.RemotingAccessor`1"]

Remarks

This type automates the use of ClientSponsor for remote objects. It starts sponsoring the remove object when the RemotingAccessor<(Of <(?0>)>) instance is created, and stops sponsoring when the RemotingAccessor<(Of <(?0>)>) is disposed or finalized. It helps implementing consistent remote sponsoring without effort.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.RemotingAccessor<(Of <(?0>)>)
PostSharp.Sdk.Extensibility..::.MessageSinkAccessor

See Also

RemotingAccessor<(Of <(?0>)>) Members
PostSharp.Sdk.Extensibility Namespace


RemotingAccessor(?0) Members

[image]

PostSharp 2.0 Documentation
RemotingAccessor<(Of <(<'?0>)>)> Members
RemotingAccessor<(Of <(?0>)>) Class Constructors Methods Properties See Also Send Feedback

The RemotingAccessor<(Of <(?0>)>) type exposes the following members.

Constructors

 | Name | Description
Public method | RemotingAccessor<(Of <(?0>)>) | Initializes a new RemotingAccessor<(Of <(?0>)>).

Methods

 | Name | Description
Protected method | AssertNotDisposed | Throws an exception if the current instance has already been disposed.
Public method | Dispose | Overloaded.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Value | Gets the remote object.

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


RemotingAccessor(?0) Constructor

RemotingAccessor<(Of <(<'?0>)>)> Constructor
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Initializes a new RemotingAccessor<(Of <(?0>)>).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public RemotingAccessor(
    ?0 remoteObject,
    bool ownsRemoteObject
)

Parameters

remoteObject
Type: ?0
An existing remote object (marshaled by reference).
ownsRemoteObject
Type: System..::.Boolean
true if the remote object should be disposed when the accessor is disposed, otherwise false.

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


RemotingAccessor(?0) Methods

[image]

PostSharp 2.0 Documentation
RemotingAccessor<(Of <(<'?0>)>)> Methods
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback

The RemotingAccessor<(Of <(?0>)>) type exposes the following members.

Methods

 | Name | Description
Protected method | AssertNotDisposed | Throws an exception if the current instance has already been disposed.
Public method | Dispose | Overloaded.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


AssertNotDisposed Method

RemotingAccessor<(Of <(<'?0>)>)>..::..AssertNotDisposed Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Throws an exception if the current instance has already been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected void AssertNotDisposed()

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
RemotingAccessor<(Of <(<'?0>)>)>..::..Dispose Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Disposes the current instance.

See Also

RemotingAccessor<(Of <(?0>)>) Class
RemotingAccessor<(Of <(?0>)>) Members
PostSharp.Sdk.Extensibility Namespace


Dispose Method

RemotingAccessor<(Of <(<'?0>)>)>..::..Dispose Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

RemotingAccessor<(Of <(?0>)>) Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


Dispose Method (Boolean)

RemotingAccessor<(Of <(<'?0>)>)>..::..Dispose Method (Boolean)
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Disposes the current instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
false if the method is called by the destructor, otherwise true.

See Also

RemotingAccessor<(Of <(?0>)>) Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


Finalize Method

RemotingAccessor<(Of <(<'?0>)>)>..::..Finalize Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Destructor.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Finalize()

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


GetHashCode Method

RemotingAccessor<(Of <(<'?0>)>)>..::..GetHashCode Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override int GetHashCode()

Return Value

A hash code for the current Object.

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


ToString Method

RemotingAccessor<(Of <(<'?0>)>)>..::..ToString Method
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


RemotingAccessor(?0) Properties

[image]

PostSharp 2.0 Documentation
RemotingAccessor<(Of <(<'?0>)>)> Properties
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback

The RemotingAccessor<(Of <(?0>)>) type exposes the following members.

Properties

 | Name | Description
Public property | IsDisposed | Determines whether the current instance has been disposed.
Public property | Value | Gets the remote object.

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


IsDisposed Property

RemotingAccessor<(Of <(<'?0>)>)>..::..IsDisposed Property
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Determines whether the current instance has been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


Value Property

RemotingAccessor<(Of <(<'?0>)>)>..::..Value Property
RemotingAccessor<(Of <(?0>)>) Class See Also Send Feedback
Gets the remote object.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ?0 Value { get; }

See Also

RemotingAccessor<(Of <(?0>)>) Class
PostSharp.Sdk.Extensibility Namespace


SharedAnnotationInstance Class

SharedAnnotationInstance Class
Members See Also Send Feedback
Implementation of IAnnotationInstance that allows the same custom attribute value to be applied to many target elements.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SharedAnnotationInstance : IAnnotationInstance

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.SharedAnnotationInstance

See Also

SharedAnnotationInstance Members
PostSharp.Sdk.Extensibility Namespace


SharedAnnotationInstance Members

[image]

PostSharp 2.0 Documentation
SharedAnnotationInstance Members
SharedAnnotationInstance Class Constructors Properties See Also Send Feedback

The SharedAnnotationInstance type exposes the following members.

Constructors

 | Name | Description
Public method | SharedAnnotationInstance | Initializes a new SharedAnnotationInstance.

Properties

 | Name | Description
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


SharedAnnotationInstance Constructor

SharedAnnotationInstance Constructor
SharedAnnotationInstance Class See Also Send Feedback
Initializes a new SharedAnnotationInstance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SharedAnnotationInstance(
    IAnnotationValue value,
    MetadataDeclaration targetElement,
    SymAspectUsage symAspectUsage
)

Parameters

value
Type: PostSharp.Sdk.CodeModel..::.IAnnotationValue
Custom attribute value.
targetElement
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Target element.
symAspectUsage
Type: PostSharp.Sdk.WeavingSymbols..::.SymAspectUsage
Representation of this annotation instance in the symbol file.

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


SharedAnnotationInstance Properties

[image]

PostSharp 2.0 Documentation
SharedAnnotationInstance Properties
SharedAnnotationInstance Class See Also Send Feedback

The SharedAnnotationInstance type exposes the following members.

Properties

 | Name | Description
Public property | Symbol | Element of the symbol file representing the current aspect instance.
Public property | TargetElement | Element on which the annotation value is applied.
Public property | Value | Custom attribute value.

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


Symbol Property

SharedAnnotationInstance..::..Symbol Property
SharedAnnotationInstance Class See Also Send Feedback
Element of the symbol file representing the current aspect instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsage Symbol { get; }

Implements

IAnnotationInstance..::.Symbol

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


TargetElement Property

SharedAnnotationInstance..::..TargetElement Property
SharedAnnotationInstance Class See Also Send Feedback
Element on which the annotation value is applied.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetElement { get; }

Implements

IAnnotationInstance..::.TargetElement

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


Value Property

SharedAnnotationInstance..::..Value Property
SharedAnnotationInstance Class See Also Send Feedback
Custom attribute value.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IAnnotationValue Value { get; }

Implements

IAnnotationInstance..::.Value

See Also

SharedAnnotationInstance Class
PostSharp.Sdk.Extensibility Namespace


TagCollection Class

TagCollection Class
Members See Also Send Feedback
Collection of tags (see ITaggable). Used to pass tags from the host to the Domain and Project objects.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class TagCollection : ITaggable

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility..::.TagCollection

See Also

TagCollection Members
PostSharp.Sdk.Extensibility Namespace


TagCollection Members

[image]

PostSharp 2.0 Documentation
TagCollection Members
TagCollection Class Constructors Methods See Also Send Feedback

The TagCollection type exposes the following members.

Constructors

 | Name | Description
Public method | TagCollection | Initializes a new instance of the TagCollection class

Methods

 | Name | Description
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | SetTag | Set a tag to the current declaration.

See Also

TagCollection Class
PostSharp.Sdk.Extensibility Namespace


TagCollection Constructor

TagCollection Constructor
TagCollection Class See Also Send Feedback
Initializes a new instance of the TagCollection class

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TagCollection()

See Also

TagCollection Class
PostSharp.Sdk.Extensibility Namespace


TagCollection Methods

[image]

PostSharp 2.0 Documentation
TagCollection Methods
TagCollection Class See Also Send Feedback

The TagCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetTag | Gets a tag associated with the current declaration.
Public method | SetTag | Set a tag to the current declaration.

See Also

TagCollection Class
PostSharp.Sdk.Extensibility Namespace


GetTag Method

TagCollection..::..GetTag Method
TagCollection Class See Also Send Feedback
Gets a tag associated with the current declaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Object GetTag(
    TagId tagId
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.

Return Value

An object, or null if no tag of type tagId is associated to the current declaration.

Implements

ITaggable..::.GetTag(TagId)

See Also

TagCollection Class
PostSharp.Sdk.Extensibility Namespace


SetTag Method

TagCollection..::..SetTag Method
TagCollection Class See Also Send Feedback
Set a tag to the current declaration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTag(
    TagId tagId,
    Object value
)

Parameters

tagId
Type: PostSharp.Sdk.CodeModel..::.TagId
Tag identifier.
value
Type: System..::.Object
Tag value.

Implements

ITaggable..::.SetTag(TagId, Object)

See Also

TagCollection Class
PostSharp.Sdk.Extensibility Namespace


Task Class

Task Class
Members See Also Send Feedback
Execution unit of a Project.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class Task : MarshalByRefObject,
    IDisposable, IPositioned, INamed

Remarks

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.AspectInfrastructure..::.AspectInfrastructureTask
PostSharp.Sdk.AspectWeaver..::.AspectWeaverPlugIn
PostSharp.Sdk.AspectWeaver..::.AspectWeaverTask
PostSharp.Sdk.Extensibility.Tasks..::.AnnotationRepositoryTask
PostSharp.Sdk.Extensibility.Tasks..::.AutoDetectTask
PostSharp.Sdk.Extensibility.Tasks..::.CompileTask
PostSharp.Sdk.Extensibility.Tasks..::.DisableMessagesTask
PostSharp.Sdk.Extensibility.Tasks..::.GlobalsTask
PostSharp.Sdk.Extensibility.Tasks..::.ImplementationBoundAttributesTask
PostSharp.Sdk.Extensibility.Tasks..::.IndexGenericInstancesTask
PostSharp.Sdk.Extensibility.Tasks..::.IndexTypeDefMemberRefsTask
PostSharp.Sdk.Extensibility.Tasks..::.IndexUsagesTask
PostSharp.Sdk.Extensibility.Tasks..::.ModuleAnnotationProvider
PostSharp.Sdk.Extensibility.Tasks..::.MulticastAttributeTask
PostSharp.Sdk.Extensibility.Tasks..::.RemoveTask
PostSharp.Sdk.Extensibility.Tasks..::.TypeHierarchyTask
PostSharp.Sdk.Extensibility.Tasks..::.VerifyTask
PostSharp.Sdk.WeavingSymbols..::.WriteWeavingSymbolsTask

See Also

Task Members
PostSharp.Sdk.Extensibility Namespace


Task Members

[image]

PostSharp 2.0 Documentation
Task Members
Task Class Constructors Methods Properties See Also Send Feedback

The Task type exposes the following members.

Constructors

 | Name | Description
Protected method | Task | Initializes a new instance of the Task class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element.
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Protected method | Initialize | Initializes the current task.
Public method | IsRequired | Determines whether the current task is required by another task in the project.
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled.
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task.
Public property | Project | Gets the Project to which the current task belongs.
Public property | State | Gets the state of the current task.
Public property | TaskName | Gets the task name.
Public property | TaskType | Gets the task type configuration.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Task Constructor

Task Constructor
Task Class See Also Send Feedback
Initializes a new instance of the Task class

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Task()

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Task Methods

[image]

PostSharp 2.0 Documentation
Task Methods
Task Class See Also Send Feedback

The Task type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element.
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task.
Protected method | Finalize | Destructor. (Overrides Object..::.Finalize()()().)
Protected method | Initialize | Initializes the current task.
Public method | IsRequired | Determines whether the current task is required by another task in the project.
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Deserialize Method

Task..::..Deserialize Method
Task Class See Also Send Feedback
Deserializes the current task from an XML element.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Deserialize(
    XmlElement xmlElement
)

Parameters

xmlElement
Type: System.Xml..::.XmlElement
The source XML element.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.Task.Deserialize(System.Xml.XmlElement)"]

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
Task..::..Dispose Method
Task Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance.

See Also

Task Class
Task Members
PostSharp.Sdk.Extensibility Namespace


Dispose Method

Task..::..Dispose Method
Task Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

Task Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


Dispose Method (Boolean)

Task..::..Dispose Method (Boolean)
Task Class See Also Send Feedback
Disposes the resources hold by the current instance.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
disposing if the current method is called because an explicit call of Dispose()()(), or false if the method is called by the destructor.

See Also

Task Class
Dispose Overload
PostSharp.Sdk.Extensibility Namespace


Execute Method

Task..::..Execute Method
Task Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Finalize Method

Task..::..Finalize Method
Task Class See Also Send Feedback
Destructor.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Finalize()

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Initialize Method

Task..::..Initialize Method
Task Class See Also Send Feedback
Initializes the current task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual void Initialize()

Remarks

In case that the task is deserialized from XML, this method is called after Deserialize(XmlElement).

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


IsRequired Method

Task..::..IsRequired Method
Task Class See Also Send Feedback
Determines whether the current task is required by another task in the project.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsRequired()

Return Value

true if the current task is required by another task in the project, otherwise false.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Validate Method

Task..::..Validate Method
Task Class See Also Send Feedback
Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected virtual bool Validate()

Return Value

true if the task configuration is valid, otherwise false.

Remarks

If the task configuration is invalid, the method implementation should additionally emit an error message.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Task Properties

[image]

PostSharp 2.0 Documentation
Task Properties
Task Class See Also Send Feedback

The Task type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled.
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task.
Public property | Project | Gets the Project to which the current task belongs.
Public property | State | Gets the state of the current task.
Public property | TaskName | Gets the task name.
Public property | TaskType | Gets the task type configuration.

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Disabled Property

Task..::..Disabled Property
Task Class See Also Send Feedback
Determines whether this task is disabled.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Disabled { get; set; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


ImplicitlyRequired Property

Task..::..ImplicitlyRequired Property
Task Class See Also Send Feedback
Indicates that this task was implicitly required by another task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ImplicitlyRequired { get; internal set; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


Project Property

Task..::..Project Property
Task Class See Also Send Feedback
Gets the Project to which the current task belongs.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Project Project { get; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


State Property

Task..::..State Property
Task Class See Also Send Feedback
Gets the state of the current task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskState State { get; internal set; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


TaskName Property

Task..::..TaskName Property
Task Class See Also Send Feedback
Gets the task name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TaskName { get; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


TaskType Property

Task..::..TaskType Property
Task Class See Also Send Feedback
Gets the task type configuration.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfiguration TaskType { get; }

See Also

Task Class
PostSharp.Sdk.Extensibility Namespace


TaskCollection Class

TaskCollection Class
Members See Also Send Feedback
Collection of tasks (Task).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class TaskCollection : MarshalByRefObject,
    ICollection<Task>, IEnumerable<Task>, IEnumerable,
    IDisposable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.TaskCollection

See Also

TaskCollection Members
PostSharp.Sdk.Extensibility Namespace


TaskCollection Members

[image]

PostSharp 2.0 Documentation
TaskCollection Members
TaskCollection Class Methods Properties See Also Send Feedback

The TaskCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a range of tasks, then resolve dependencies and sort.
Public method | Clear | Remove all items of th current collection.
Public method | Contains | Determines whether the current collection contains a given Task.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetInterfaces<(Of <(T>)>) | Enumerates all tasks implementing a given interface.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the collection has been disposed.
Public property | Item | Gets a Task given its type name.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


TaskCollection Methods

[image]

PostSharp 2.0 Documentation
TaskCollection Methods
TaskCollection Class See Also Send Feedback

The TaskCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a range of tasks, then resolve dependencies and sort.
Public method | Clear | Remove all items of th current collection.
Public method | Contains | Determines whether the current collection contains a given Task.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetInterfaces<(Of <(T>)>) | Enumerates all tasks implementing a given interface.
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Add Method

[image]

PostSharp 2.0 Documentation
TaskCollection..::..Add Method
TaskCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Adds to the current collection a new task given its name.
Public method | Add(Task) | Adds a Task to the collection.

See Also

TaskCollection Class
TaskCollection Members
PostSharp.Sdk.Extensibility Namespace


Add Method (String)

TaskCollection..::..Add Method (String)
TaskCollection Class See Also Send Feedback
Adds to the current collection a new task given its name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    string taskTypeName
)

Parameters

taskTypeName
Type: System..::.String
Name of the task type.

See Also

TaskCollection Class
Add Overload
PostSharp.Sdk.Extensibility Namespace


Add Method (Task)

TaskCollection..::..Add Method (Task)
TaskCollection Class See Also Send Feedback
Adds a Task to the collection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Add(
    Task item
)

Parameters

item
Type: PostSharp.Sdk.Extensibility..::.Task
A Task.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

Remarks

This method shall also add all tasks that are required by item.

See Also

TaskCollection Class
Add Overload
PostSharp.Sdk.Extensibility Namespace


AddRange Method

TaskCollection..::..AddRange Method
TaskCollection Class See Also Send Feedback
Adds a range of tasks, then resolve dependencies and sort.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddRange(
    IEnumerable<Task> tasks
)

Parameters

tasks
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Task >)>)>
A range of tasks.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Clear Method

TaskCollection..::..Clear Method
TaskCollection Class See Also Send Feedback
Remove all items of th current collection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Contains Method

TaskCollection..::..Contains Method
TaskCollection Class See Also Send Feedback
Determines whether the current collection contains a given Task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    Task item
)

Parameters

item
Type: PostSharp.Sdk.Extensibility..::.Task
A Task.

Return Value

true if this collection contains item, otherwise false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


CopyTo Method

TaskCollection..::..CopyTo Method
TaskCollection Class See Also Send Feedback
Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void CopyTo(
    Task[] array,
    int arrayIndex
)

Parameters

array
Type: array< PostSharp.Sdk.Extensibility..::.Task >[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(T>)>). The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is null.
System..::.ArgumentOutOfRangeException | arrayIndex is less than 0.
System..::.ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ICollection<(Of <(T>)>) is greater than the available space from arrayIndex to the end of the destination array. -or- Type T cannot be cast automatically to the type of the destination array.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Dispose Method

TaskCollection..::..Dispose Method
TaskCollection Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


GetEnumerator Method

TaskCollection..::..GetEnumerator Method
TaskCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<Task> GetEnumerator()

Return Value

A IEnumerator<(Of <(T>)>) that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


GetInterfaces(T) Method

TaskCollection..::..GetInterfaces<(Of <(<'T>)>)> Method
TaskCollection Class See Also Send Feedback
Enumerates all tasks implementing a given interface.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<T> GetInterfaces<T>()

Type Parameters

T
The interface that tasks have to implement.

Return Value

An enumerator returning all tasks implementing T.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Remove Method

TaskCollection..::..Remove Method
TaskCollection Class See Also Send Feedback
Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Remove(
    Task item
)

Parameters

item
Type: PostSharp.Sdk.Extensibility..::.Task
The object to remove from the ICollection<(Of <(T>)>).

Return Value

true if item was successfully removed from the ICollection<(Of <(T>)>); otherwise, false. This method also returns false if item is not found in the original ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

Exceptions

Exception | Condition
System..::.NotSupportedException | The ICollection<(Of <(T>)>) is read-only.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


TaskCollection Properties

[image]

PostSharp 2.0 Documentation
TaskCollection Properties
TaskCollection Class See Also Send Feedback

The TaskCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>).
Public property | IsDisposed | Determines whether the collection has been disposed.
Public property | Item | Gets a Task given its type name.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Count Property

TaskCollection..::..Count Property
TaskCollection Class See Also Send Feedback
Gets the number of elements contained in the ICollection<(Of <(T>)>).

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Count { get; }

Return Value

The number of elements contained in the ICollection<(Of <(T>)>).

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


IsDisposed Property

TaskCollection..::..IsDisposed Property
TaskCollection Class See Also Send Feedback
Determines whether the collection has been disposed.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsDisposed { get; }

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


Item Property

TaskCollection..::..Item Property
TaskCollection Class See Also Send Feedback
Gets a Task given its type name.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Task Item[
    string taskTypeName
] { get; }

Parameters

taskTypeName
Type: System..::.String
Name of the task type.

Return Value

A Task, or null if the task was not found.

See Also

TaskCollection Class
PostSharp.Sdk.Extensibility Namespace


TaskState Enumeration

TaskState Enumeration
See Also Send Feedback
States of a Task.

Namespace: PostSharp.Sdk.Extensibility
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum TaskState

Members

Member name | Value | Description
Queued | 0 | Queued. The task has not been executed.
Default | 0 | Default = Queued.
Executing | 1 | The task is being executed now.
Executed | 2 | The task has already been executed.

See Also

PostSharp.Sdk.Extensibility Namespace


PostSharp.Sdk.Extensibility.Configuration Namespace

PostSharp.Sdk.Extensibility.Configuration Namespace
Send Feedback
The PostSharp.Sdk.Extensibility.Configuration namespace contains classes representing the XML configuration files.

Classes

 | Class | Description
Public class | ApplicationConfiguration | Application-level configuration.
Public class | AssemblyBindingExternalConfiguration | Imported section of assembly redirection configuration
Public class | AssemblyBindingPolicySetConfiguration | Configuration of an set of assembly binding policies.
Public class | AssemblyIdentityConfiguration | Part of an DependentAssemblyConfigurationCollection. Identifies a set if assembly.
Public class | BaseConfiguration | Elements of configuration that are common to the application-level, plugin-level and project-level configuration.
Public class | BindingRedirectConfiguration | Specifies the new target of an assembly. Part of a DependentAssemblyConfiguration configuration element.
Public class | ConfigurationElement | Base class for all configuration elements.
Public class | DependencyConfiguration | Represents a dependency between task types.
Public class | DependencyConfigurationCollection | Collection of dependencies (DependencyConfiguration).
Public class | DependentAssembliesConfiguration | Section containing the configuration of assembly redirection.
Public class | DependentAssemblyConfiguration | Configures an assembly redirection policy.
Public class | DependentAssemblyConfigurationCollection | Collection of DependentAssemblyConfiguration.
Public class | ImportAssemblyBindingsConfiguration | Specifies that assembly redirection configuration should be imported from another XML file. Part of the DependentAssembliesConfiguration element.
Public class | ImportAssemblyBindingsConfigurationCollection | Collection of ImportAssemblyBindingsConfiguration.
Public class | NameValuePair | Simple name-value pair of strings.
Public class | NameValuePairCollection | Collection of name-value pairs (NameValuePair).
Public class | PhaseConfiguration | Post-compilation phase, which divides sequentially the post-compilation process and to which tasks belong.
Public class | PhaseConfigurationCollection | Collection of phases (PhaseConfiguration).
Public class | PhaseConfigurationDictionary | Collection of phases ordered by ordinal and accessible by name.
Public class | PlatformConfiguration | Configures a target platform.
Public class | PlatformConfigurationCollection | Collection of platform configurations (PlatformConfiguration).
Public class | PlatformConfigurationDictionary | Dictionary of platform configurations (PlatformConfiguration) by name.
Public class | PlugInConfiguration | Plug-in-level configuration.
Public class | ProjectConfiguration | Project-level configuration.
Public class | PropertyConfiguration | Specifies a property assignment.
Public class | PropertyConfigurationCollection | Collection of property definitions.
Public class | SearchPathConfiguration | Specifies that a directory should be included in the search path.
Public class | SearchPathConfigurationCollection | Collection of SearchPathConfiguration.
Public class | SourceConfiguration | Determines the source module.
Public class | TaskTypeConfiguration | Configures a task type.
Public class | TaskTypeConfigurationCollection | Collection of task type configurations (TaskTypeConfiguration).
Public class | TaskTypeConfigurationDictionary | Dictionary mapping the name of a TaskTypeConfiguration to its corresponding instance.
Public class | UsingConfiguration | Includes a plug-in in the current project.
Public class | UsingConfigurationCollection | Collection of UsingConfiguration.
Public class | XmlElementCollection | Collection of XML elements.

Enumerations

 | Enumeration | Description
Public enumeration | DependencyPosition | Enumerates the relative position of dependencies (Before or After).


ApplicationConfiguration Class

ApplicationConfiguration Class
Members See Also Send Feedback
Application-level configuration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class ApplicationConfiguration : BaseConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.ApplicationConfiguration

See Also

ApplicationConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


ApplicationConfiguration Members

[image]

PostSharp 2.0 Documentation
ApplicationConfiguration Members
ApplicationConfiguration Class Constructors Methods Properties See Also Send Feedback

The ApplicationConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationConfiguration | Initializes a new instance of the ApplicationConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Phases | Gets or sets the collection of phases (PhaseConfiguration) in the post-compilation process.
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

ApplicationConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ApplicationConfiguration Constructor

ApplicationConfiguration Constructor
ApplicationConfiguration Class See Also Send Feedback
Initializes a new instance of the ApplicationConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ApplicationConfiguration()

See Also

ApplicationConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ApplicationConfiguration Methods

[image]

PostSharp 2.0 Documentation
ApplicationConfiguration Methods
ApplicationConfiguration Class See Also Send Feedback

The ApplicationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

ApplicationConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ApplicationConfiguration Properties

[image]

PostSharp 2.0 Documentation
ApplicationConfiguration Properties
ApplicationConfiguration Class See Also Send Feedback

The ApplicationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Phases | Gets or sets the collection of phases (PhaseConfiguration) in the post-compilation process.
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

ApplicationConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Phases Property

ApplicationConfiguration..::..Phases Property
ApplicationConfiguration Class See Also Send Feedback
Gets or sets the collection of phases (PhaseConfiguration) in the post-compilation process.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PhaseConfigurationCollection Phases { get; set; }

See Also

ApplicationConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingExternalConfiguration Class

AssemblyBindingExternalConfiguration Class
Members See Also Send Feedback
Imported section of assembly redirection configuration

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class AssemblyBindingExternalConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.AssemblyBindingExternalConfiguration

See Also

AssemblyBindingExternalConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingExternalConfiguration Members

[image]

PostSharp 2.0 Documentation
AssemblyBindingExternalConfiguration Members
AssemblyBindingExternalConfiguration Class Constructors Properties See Also Send Feedback

The AssemblyBindingExternalConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyBindingExternalConfiguration | Initializes a new instance of the AssemblyBindingExternalConfiguration class

Properties

 | Name | Description
Public property | DependentAssemblies | Gets the collection of DependentAssemblyConfiguration configuration elements.

See Also

AssemblyBindingExternalConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingExternalConfiguration Constructor

AssemblyBindingExternalConfiguration Constructor
AssemblyBindingExternalConfiguration Class See Also Send Feedback
Initializes a new instance of the AssemblyBindingExternalConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingExternalConfiguration()

See Also

AssemblyBindingExternalConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingExternalConfiguration Properties

[image]

PostSharp 2.0 Documentation
AssemblyBindingExternalConfiguration Properties
AssemblyBindingExternalConfiguration Class See Also Send Feedback

The AssemblyBindingExternalConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | DependentAssemblies | Gets the collection of DependentAssemblyConfiguration configuration elements.

See Also

AssemblyBindingExternalConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblies Property

AssemblyBindingExternalConfiguration..::..DependentAssemblies Property
AssemblyBindingExternalConfiguration Class See Also Send Feedback
Gets the collection of DependentAssemblyConfiguration configuration elements.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssemblyConfigurationCollection DependentAssemblies { get; }

See Also

AssemblyBindingExternalConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingPolicySetConfiguration Class

AssemblyBindingPolicySetConfiguration Class
Members See Also Send Feedback
Configuration of an set of assembly binding policies.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class AssemblyBindingPolicySetConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.AssemblyBindingPolicySetConfiguration

See Also

AssemblyBindingPolicySetConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingPolicySetConfiguration Members

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicySetConfiguration Members
AssemblyBindingPolicySetConfiguration Class Constructors Properties See Also Send Feedback

The AssemblyBindingPolicySetConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyBindingPolicySetConfiguration | Initializes a new instance of the AssemblyBindingPolicySetConfiguration class

Properties

 | Name | Description
Public property | Name | Gets or sets the name of the set.
Public property | Policies | Gets or set the configuration of policies for normal binding.
Public property | ReflectionPolicies | Gets or sets the configuration of policies from reflection binding.

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingPolicySetConfiguration Constructor

AssemblyBindingPolicySetConfiguration Constructor
AssemblyBindingPolicySetConfiguration Class See Also Send Feedback
Initializes a new instance of the AssemblyBindingPolicySetConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingPolicySetConfiguration()

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingPolicySetConfiguration Properties

[image]

PostSharp 2.0 Documentation
AssemblyBindingPolicySetConfiguration Properties
AssemblyBindingPolicySetConfiguration Class See Also Send Feedback

The AssemblyBindingPolicySetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name of the set.
Public property | Policies | Gets or set the configuration of policies for normal binding.
Public property | ReflectionPolicies | Gets or sets the configuration of policies from reflection binding.

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

AssemblyBindingPolicySetConfiguration..::..Name Property
AssemblyBindingPolicySetConfiguration Class See Also Send Feedback
Gets or sets the name of the set.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Policies Property

AssemblyBindingPolicySetConfiguration..::..Policies Property
AssemblyBindingPolicySetConfiguration Class See Also Send Feedback
Gets or set the configuration of policies for normal binding.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssembliesConfiguration Policies { get; set; }

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ReflectionPolicies Property

AssemblyBindingPolicySetConfiguration..::..ReflectionPolicies Property
AssemblyBindingPolicySetConfiguration Class See Also Send Feedback
Gets or sets the configuration of policies from reflection binding.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssembliesConfiguration ReflectionPolicies { get; set; }

See Also

AssemblyBindingPolicySetConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyIdentityConfiguration Class

AssemblyIdentityConfiguration Class
Members See Also Send Feedback
Part of an DependentAssemblyConfigurationCollection. Identifies a set if assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class AssemblyIdentityConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.AssemblyIdentityConfiguration

See Also

AssemblyIdentityConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyIdentityConfiguration Members

[image]

PostSharp 2.0 Documentation
AssemblyIdentityConfiguration Members
AssemblyIdentityConfiguration Class Constructors Properties See Also Send Feedback

The AssemblyIdentityConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyIdentityConfiguration | Initializes a new instance of the AssemblyIdentityConfiguration class

Properties

 | Name | Description
Public property | Culture | Gets or sets the culture name of the matching assembly.
Public property | Name | Gets of sets short name of matching assemblies, or '*' to match all assemblies.
Public property | PublicKeyToken | Gets or sets the public key token of matching assemblies.

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyIdentityConfiguration Constructor

AssemblyIdentityConfiguration Constructor
AssemblyIdentityConfiguration Class See Also Send Feedback
Initializes a new instance of the AssemblyIdentityConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyIdentityConfiguration()

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyIdentityConfiguration Properties

[image]

PostSharp 2.0 Documentation
AssemblyIdentityConfiguration Properties
AssemblyIdentityConfiguration Class See Also Send Feedback

The AssemblyIdentityConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets or sets the culture name of the matching assembly.
Public property | Name | Gets of sets short name of matching assemblies, or '*' to match all assemblies.
Public property | PublicKeyToken | Gets or sets the public key token of matching assemblies.

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Culture Property

AssemblyIdentityConfiguration..::..Culture Property
AssemblyIdentityConfiguration Class See Also Send Feedback
Gets or sets the culture name of the matching assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Culture { get; set; }

Remarks

If this property is null, assemblies of any culture will match.

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

AssemblyIdentityConfiguration..::..Name Property
AssemblyIdentityConfiguration Class See Also Send Feedback
Gets of sets short name of matching assemblies, or '*' to match all assemblies.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PublicKeyToken Property

AssemblyIdentityConfiguration..::..PublicKeyToken Property
AssemblyIdentityConfiguration Class See Also Send Feedback
Gets or sets the public key token of matching assemblies.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PublicKeyToken { get; set; }

Remarks

If this property is null, any signed or unsigned assembly will match.

See Also

AssemblyIdentityConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BaseConfiguration Class

BaseConfiguration Class
Members See Also Send Feedback
Elements of configuration that are common to the application-level, plugin-level and project-level configuration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class BaseConfiguration : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.ApplicationConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.PlugInConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.ProjectConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.UsingConfiguration

See Also

BaseConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


BaseConfiguration Members

[image]

PostSharp 2.0 Documentation
BaseConfiguration Members
BaseConfiguration Class Constructors Methods Properties See Also Send Feedback

The BaseConfiguration type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseConfiguration | Initializes a new instance of the BaseConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies.
Public property | FileName | Gets or sets the name of the file declaring the current configuration.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file.
Public property | Properties | Gets or sets the collection of properties defined in the current file.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path.
Public property | StrongNames | Gets or sets the collection of strong names.
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file.
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BaseConfiguration Constructor

BaseConfiguration Constructor
BaseConfiguration Class See Also Send Feedback
Initializes a new instance of the BaseConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected BaseConfiguration()

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BaseConfiguration Methods

[image]

PostSharp 2.0 Documentation
BaseConfiguration Methods
BaseConfiguration Class See Also Send Feedback

The BaseConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BaseConfiguration Properties

[image]

PostSharp 2.0 Documentation
BaseConfiguration Properties
BaseConfiguration Class See Also Send Feedback

The BaseConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies.
Public property | FileName | Gets or sets the name of the file declaring the current configuration.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file.
Public property | Properties | Gets or sets the collection of properties defined in the current file.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path.
Public property | StrongNames | Gets or sets the collection of strong names.
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file.
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyBindingPolicySets Property

BaseConfiguration..::..AssemblyBindingPolicySets Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the section configuring assembly redirection policies.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyBindingPolicySetConfiguration[] AssemblyBindingPolicySets { get; set; }

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


FileName Property

BaseConfiguration..::..FileName Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the name of the file declaring the current configuration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FileName { get; set; }

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Platforms Property

BaseConfiguration..::..Platforms Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of platforms defined in the current file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlatformConfigurationCollection Platforms { get; set; }

Field Value

A collection of platforms (PlatformConfiguration).

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Properties Property

BaseConfiguration..::..Properties Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of properties defined in the current file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyConfigurationCollection Properties { get; set; }

Field Value

A collection of properties.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPath Property

BaseConfiguration..::..SearchPath Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of directories to be added to the search path.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SearchPathConfigurationCollection SearchPath { get; set; }

Field Value

A collection of directories given either absolutely either relatively to the declaring file.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


StrongNames Property

BaseConfiguration..::..StrongNames Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of strong names.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string[] StrongNames { get; set; }

Remarks

Strong names allow to automatically map short assembly names on strong assembly names, when short assembly names are provided in a configuration file.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypes Property

BaseConfiguration..::..TaskTypes Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of task types defined in the current file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfigurationCollection TaskTypes { get; set; }

Field Value

A collection of task types (TaskTypeConfiguration).

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsedPlugIns Property

BaseConfiguration..::..UsedPlugIns Property
BaseConfiguration Class See Also Send Feedback
Gets or sets the collection of plug-ins to be included in the project.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UsingConfigurationCollection UsedPlugIns { get; set; }

Field Value

A collection of plug-in configuration file names given either absolutely either relatively to the declaring file.

See Also

BaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BindingRedirectConfiguration Class

BindingRedirectConfiguration Class
Members See Also Send Feedback
Specifies the new target of an assembly. Part of a DependentAssemblyConfiguration configuration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class BindingRedirectConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.BindingRedirectConfiguration

See Also

BindingRedirectConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


BindingRedirectConfiguration Members

[image]

PostSharp 2.0 Documentation
BindingRedirectConfiguration Members
BindingRedirectConfiguration Class Constructors Properties See Also Send Feedback

The BindingRedirectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | BindingRedirectConfiguration | Initializes a new instance of the BindingRedirectConfiguration class

Properties

 | Name | Description
Public property | NewName | Gets or sets the name of the target assembly.
Public property | NewPublicKeyToken | Gets or sets the public key token of the target assembly.
Public property | NewVersion | Gets or sets the version of the target assembly.
Public property | OldVersion | Gets or sets the version that the version of the redirected assembly.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BindingRedirectConfiguration Constructor

BindingRedirectConfiguration Constructor
BindingRedirectConfiguration Class See Also Send Feedback
Initializes a new instance of the BindingRedirectConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BindingRedirectConfiguration()

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BindingRedirectConfiguration Properties

[image]

PostSharp 2.0 Documentation
BindingRedirectConfiguration Properties
BindingRedirectConfiguration Class See Also Send Feedback

The BindingRedirectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | NewName | Gets or sets the name of the target assembly.
Public property | NewPublicKeyToken | Gets or sets the public key token of the target assembly.
Public property | NewVersion | Gets or sets the version of the target assembly.
Public property | OldVersion | Gets or sets the version that the version of the redirected assembly.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NewName Property

BindingRedirectConfiguration..::..NewName Property
BindingRedirectConfiguration Class See Also Send Feedback
Gets or sets the name of the target assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string NewName { get; set; }

Remarks

If this property is null, the new name will be equal to the old one.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NewPublicKeyToken Property

BindingRedirectConfiguration..::..NewPublicKeyToken Property
BindingRedirectConfiguration Class See Also Send Feedback
Gets or sets the public key token of the target assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string NewPublicKeyToken { get; set; }

Remarks

If this property is null, the new public key token will be equal to the old one.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NewVersion Property

BindingRedirectConfiguration..::..NewVersion Property
BindingRedirectConfiguration Class See Also Send Feedback
Gets or sets the version of the target assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string NewVersion { get; set; }

Remarks

If this property is null, the new version will be equal to the old version.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


OldVersion Property

BindingRedirectConfiguration..::..OldVersion Property
BindingRedirectConfiguration Class See Also Send Feedback
Gets or sets the version that the version of the redirected assembly.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OldVersion { get; set; }

Remarks

If this property is null, all versions are matches. Otherwise, the version can be given in format 0.0.0.0 or in format 0.0.0.0-0.0.0.0.

See Also

BindingRedirectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ConfigurationElement Class

ConfigurationElement Class
Members See Also Send Feedback
Base class for all configuration elements.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class ConfigurationElement

Remarks

This class provides access to parent elements.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.DependencyConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.NameValuePair
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.PropertyConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.SourceConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.TaskTypeConfiguration

See Also

ConfigurationElement Members
PostSharp.Sdk.Extensibility.Configuration Namespace


ConfigurationElement Members

[image]

PostSharp 2.0 Documentation
ConfigurationElement Members
ConfigurationElement Class Methods Properties See Also Send Feedback

The ConfigurationElement type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element.

Properties

 | Name | Description
Public property | Parent | Gets the parent configuration element.
Public property | Root | Gets the root configuration element.

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ConfigurationElement Methods

[image]

PostSharp 2.0 Documentation
ConfigurationElement Methods
ConfigurationElement Class See Also Send Feedback

The ConfigurationElement type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element.

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Validate Method

ConfigurationElement..::..Validate Method
ConfigurationElement Class See Also Send Feedback
Validates the current configuration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual bool Validate()

Return Value

true if the current configuration element is valid, otherwise false.

Remarks

This method should writer errors (and warnings) to the current Messenger. It should validate child configuration elements recursively.

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ConfigurationElement Properties

[image]

PostSharp 2.0 Documentation
ConfigurationElement Properties
ConfigurationElement Class See Also Send Feedback

The ConfigurationElement type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets the parent configuration element.
Public property | Root | Gets the root configuration element.

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Parent Property

ConfigurationElement..::..Parent Property
ConfigurationElement Class See Also Send Feedback
Gets the parent configuration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ConfigurationElement Parent { get; internal set; }

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Root Property

ConfigurationElement..::..Root Property
ConfigurationElement Class See Also Send Feedback
Gets the root configuration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BaseConfiguration Root { get; }

See Also

ConfigurationElement Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfiguration Class

DependencyConfiguration Class
Members See Also Send Feedback
Represents a dependency between task types.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class DependencyConfiguration : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.DependencyConfiguration

See Also

DependencyConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfiguration Members

[image]

PostSharp 2.0 Documentation
DependencyConfiguration Members
DependencyConfiguration Class Constructors Methods Properties See Also Send Feedback

The DependencyConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | DependencyConfiguration | Initializes a new instance of the DependencyConfiguration class

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | OwnerTaskType | Gets the name of the task owning the current dependency.
Public property | Parent | Gets the parent task type (TaskTypeConfiguration).
Public property | Position | Gets or sets the position of the dependent task type (before or after the current task type).
Public property | PrecedingTaskType | Gets the name of the preceding task type in the current dependency.
Public property | Required | Indicates whether this dependency is required.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SucceedingTaskType | Gets the name of the succeeding task type in the current dependency.
Public property | TaskType | Gets or sets the name of the task type to which the declaring type task is dependent.

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfiguration Constructor

DependencyConfiguration Constructor
DependencyConfiguration Class See Also Send Feedback
Initializes a new instance of the DependencyConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependencyConfiguration()

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfiguration Methods

[image]

PostSharp 2.0 Documentation
DependencyConfiguration Methods
DependencyConfiguration Class See Also Send Feedback

The DependencyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ToString Method

DependencyConfiguration..::..ToString Method
DependencyConfiguration Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfiguration Properties

[image]

PostSharp 2.0 Documentation
DependencyConfiguration Properties
DependencyConfiguration Class See Also Send Feedback

The DependencyConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | OwnerTaskType | Gets the name of the task owning the current dependency.
Public property | Parent | Gets the parent task type (TaskTypeConfiguration).
Public property | Position | Gets or sets the position of the dependent task type (before or after the current task type).
Public property | PrecedingTaskType | Gets the name of the preceding task type in the current dependency.
Public property | Required | Indicates whether this dependency is required.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SucceedingTaskType | Gets the name of the succeeding task type in the current dependency.
Public property | TaskType | Gets or sets the name of the task type to which the declaring type task is dependent.

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


OwnerTaskType Property

DependencyConfiguration..::..OwnerTaskType Property
DependencyConfiguration Class See Also Send Feedback
Gets the name of the task owning the current dependency.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string OwnerTaskType { get; internal set; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Parent Property

DependencyConfiguration..::..Parent Property
DependencyConfiguration Class See Also Send Feedback
Gets the parent task type (TaskTypeConfiguration).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfiguration Parent { get; internal set; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Position Property

DependencyConfiguration..::..Position Property
DependencyConfiguration Class See Also Send Feedback
Gets or sets the position of the dependent task type (before or after the current task type).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependencyPosition Position { get; set; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PrecedingTaskType Property

DependencyConfiguration..::..PrecedingTaskType Property
DependencyConfiguration Class See Also Send Feedback
Gets the name of the preceding task type in the current dependency.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PrecedingTaskType { get; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Required Property

DependencyConfiguration..::..Required Property
DependencyConfiguration Class See Also Send Feedback
Indicates whether this dependency is required.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Required { get; set; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SucceedingTaskType Property

DependencyConfiguration..::..SucceedingTaskType Property
DependencyConfiguration Class See Also Send Feedback
Gets the name of the succeeding task type in the current dependency.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string SucceedingTaskType { get; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskType Property

DependencyConfiguration..::..TaskType Property
DependencyConfiguration Class See Also Send Feedback
Gets or sets the name of the task type to which the declaring type task is dependent.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TaskType { get; set; }

See Also

DependencyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfigurationCollection Class

DependencyConfigurationCollection Class
Members See Also Send Feedback
Collection of dependencies (DependencyConfiguration).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class DependencyConfigurationCollection : MarshalByRefList<DependencyConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' DependencyConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.DependencyConfigurationCollection

See Also

DependencyConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
DependencyConfigurationCollection Members
DependencyConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The DependencyConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DependencyConfigurationCollection | Initializes a new instance of the DependencyConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

DependencyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfigurationCollection Constructor

DependencyConfigurationCollection Constructor
DependencyConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the DependencyConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependencyConfigurationCollection()

See Also

DependencyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
DependencyConfigurationCollection Methods
DependencyConfigurationCollection Class See Also Send Feedback

The DependencyConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

DependencyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
DependencyConfigurationCollection Properties
DependencyConfigurationCollection Class See Also Send Feedback

The DependencyConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

DependencyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependencyPosition Enumeration

DependencyPosition Enumeration
See Also Send Feedback
Enumerates the relative position of dependencies (Before or After).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum DependencyPosition

Members

Member name | Value | Description
Default | 0 | Default = Before.
Before | 0 | Before.
After | 1 | After.

See Also

PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssembliesConfiguration Class

DependentAssembliesConfiguration Class
Members See Also Send Feedback
Section containing the configuration of assembly redirection.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class DependentAssembliesConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.DependentAssembliesConfiguration

See Also

DependentAssembliesConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssembliesConfiguration Members

[image]

PostSharp 2.0 Documentation
DependentAssembliesConfiguration Members
DependentAssembliesConfiguration Class Constructors Properties See Also Send Feedback

The DependentAssembliesConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | DependentAssembliesConfiguration | Initializes a new instance of the DependentAssembliesConfiguration class

Properties

 | Name | Description
Public property | DependentAssemblies | Gets the collection of assembly redirections.
Public property | ImportAssemblyBindings | Gets the collection of imports of assembly direction configurations.

See Also

DependentAssembliesConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssembliesConfiguration Constructor

DependentAssembliesConfiguration Constructor
DependentAssembliesConfiguration Class See Also Send Feedback
Initializes a new instance of the DependentAssembliesConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssembliesConfiguration()

See Also

DependentAssembliesConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssembliesConfiguration Properties

[image]

PostSharp 2.0 Documentation
DependentAssembliesConfiguration Properties
DependentAssembliesConfiguration Class See Also Send Feedback

The DependentAssembliesConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | DependentAssemblies | Gets the collection of assembly redirections.
Public property | ImportAssemblyBindings | Gets the collection of imports of assembly direction configurations.

See Also

DependentAssembliesConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblies Property

DependentAssembliesConfiguration..::..DependentAssemblies Property
DependentAssembliesConfiguration Class See Also Send Feedback
Gets the collection of assembly redirections.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssemblyConfigurationCollection DependentAssemblies { get; }

See Also

DependentAssembliesConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindings Property

DependentAssembliesConfiguration..::..ImportAssemblyBindings Property
DependentAssembliesConfiguration Class See Also Send Feedback
Gets the collection of imports of assembly direction configurations.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImportAssemblyBindingsConfigurationCollection ImportAssemblyBindings { get; }

See Also

DependentAssembliesConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfiguration Class

DependentAssemblyConfiguration Class
Members See Also Send Feedback
Configures an assembly redirection policy.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class DependentAssemblyConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.DependentAssemblyConfiguration

See Also

DependentAssemblyConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfiguration Members

[image]

PostSharp 2.0 Documentation
DependentAssemblyConfiguration Members
DependentAssemblyConfiguration Class Constructors Properties See Also Send Feedback

The DependentAssemblyConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | DependentAssemblyConfiguration | Initializes a new instance of the DependentAssemblyConfiguration class

Properties

 | Name | Description
Public property | AssemblyIdentity | Gets or sets the element identifying the source of the redirection.
Public property | BindingRedirect | Gets or sets the element identifying the target of the redirection.

See Also

DependentAssemblyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfiguration Constructor

DependentAssemblyConfiguration Constructor
DependentAssemblyConfiguration Class See Also Send Feedback
Initializes a new instance of the DependentAssemblyConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssemblyConfiguration()

See Also

DependentAssemblyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfiguration Properties

[image]

PostSharp 2.0 Documentation
DependentAssemblyConfiguration Properties
DependentAssemblyConfiguration Class See Also Send Feedback

The DependentAssemblyConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyIdentity | Gets or sets the element identifying the source of the redirection.
Public property | BindingRedirect | Gets or sets the element identifying the target of the redirection.

See Also

DependentAssemblyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


AssemblyIdentity Property

DependentAssemblyConfiguration..::..AssemblyIdentity Property
DependentAssemblyConfiguration Class See Also Send Feedback
Gets or sets the element identifying the source of the redirection.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AssemblyIdentityConfiguration AssemblyIdentity { get; set; }

See Also

DependentAssemblyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


BindingRedirect Property

DependentAssemblyConfiguration..::..BindingRedirect Property
DependentAssemblyConfiguration Class See Also Send Feedback
Gets or sets the element identifying the target of the redirection.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public BindingRedirectConfiguration BindingRedirect { get; set; }

See Also

DependentAssemblyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfigurationCollection Class

DependentAssemblyConfigurationCollection Class
Members See Also Send Feedback
Collection of DependentAssemblyConfiguration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class DependentAssemblyConfigurationCollection : Collection<DependentAssemblyConfiguration>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' DependentAssemblyConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.DependentAssemblyConfigurationCollection

See Also

DependentAssemblyConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
DependentAssemblyConfigurationCollection Members
DependentAssemblyConfigurationCollection Class Constructors See Also Send Feedback

The DependentAssemblyConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DependentAssemblyConfigurationCollection | Initializes a new instance of the DependentAssemblyConfigurationCollection class

See Also

DependentAssemblyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


DependentAssemblyConfigurationCollection Constructor

DependentAssemblyConfigurationCollection Constructor
DependentAssemblyConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the DependentAssemblyConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependentAssemblyConfigurationCollection()

See Also

DependentAssemblyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfiguration Class

ImportAssemblyBindingsConfiguration Class
Members See Also Send Feedback
Specifies that assembly redirection configuration should be imported from another XML file. Part of the DependentAssembliesConfiguration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class ImportAssemblyBindingsConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ImportAssemblyBindingsConfiguration

See Also

ImportAssemblyBindingsConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfiguration Members

[image]

PostSharp 2.0 Documentation
ImportAssemblyBindingsConfiguration Members
ImportAssemblyBindingsConfiguration Class Constructors Properties See Also Send Feedback

The ImportAssemblyBindingsConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ImportAssemblyBindingsConfiguration | Initializes a new instance of the ImportAssemblyBindingsConfiguration class

Properties

 | Name | Description
Public property | File | Gets or sets the path of the imported XML file.
Public property | Select | Gets or sets the XPath expression evaluating to a node of type AssemblyBindingExternalConfiguration.

See Also

ImportAssemblyBindingsConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfiguration Constructor

ImportAssemblyBindingsConfiguration Constructor
ImportAssemblyBindingsConfiguration Class See Also Send Feedback
Initializes a new instance of the ImportAssemblyBindingsConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImportAssemblyBindingsConfiguration()

See Also

ImportAssemblyBindingsConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfiguration Properties

[image]

PostSharp 2.0 Documentation
ImportAssemblyBindingsConfiguration Properties
ImportAssemblyBindingsConfiguration Class See Also Send Feedback

The ImportAssemblyBindingsConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | File | Gets or sets the path of the imported XML file.
Public property | Select | Gets or sets the XPath expression evaluating to a node of type AssemblyBindingExternalConfiguration.

See Also

ImportAssemblyBindingsConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


File Property

ImportAssemblyBindingsConfiguration..::..File Property
ImportAssemblyBindingsConfiguration Class See Also Send Feedback
Gets or sets the path of the imported XML file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string File { get; set; }

See Also

ImportAssemblyBindingsConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Select Property

ImportAssemblyBindingsConfiguration..::..Select Property
ImportAssemblyBindingsConfiguration Class See Also Send Feedback
Gets or sets the XPath expression evaluating to a node of type AssemblyBindingExternalConfiguration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Select { get; set; }

See Also

ImportAssemblyBindingsConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfigurationCollection Class

ImportAssemblyBindingsConfigurationCollection Class
Members See Also Send Feedback
Collection of ImportAssemblyBindingsConfiguration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class ImportAssemblyBindingsConfigurationCollection : Collection<ImportAssemblyBindingsConfiguration>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ImportAssemblyBindingsConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.ImportAssemblyBindingsConfigurationCollection

See Also

ImportAssemblyBindingsConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
ImportAssemblyBindingsConfigurationCollection Members
ImportAssemblyBindingsConfigurationCollection Class Constructors See Also Send Feedback

The ImportAssemblyBindingsConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ImportAssemblyBindingsConfigurationCollection | Initializes a new instance of the ImportAssemblyBindingsConfigurationCollection class

See Also

ImportAssemblyBindingsConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ImportAssemblyBindingsConfigurationCollection Constructor

ImportAssemblyBindingsConfigurationCollection Constructor
ImportAssemblyBindingsConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the ImportAssemblyBindingsConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImportAssemblyBindingsConfigurationCollection()

See Also

ImportAssemblyBindingsConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePair Class

NameValuePair Class
Members See Also Send Feedback
Simple name-value pair of strings.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class NameValuePair : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.NameValuePair

See Also

NameValuePair Members
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePair Members

[image]

PostSharp 2.0 Documentation
NameValuePair Members
NameValuePair Class Constructors Methods Properties See Also Send Feedback

The NameValuePair type exposes the following members.

Constructors

 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | Value | Gets or sets the value.

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePair Constructor

NameValuePair Constructor
NameValuePair Class See Also Send Feedback
Initializes a new instance of the NameValuePair class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NameValuePair()

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePair Methods

[image]

PostSharp 2.0 Documentation
NameValuePair Methods
NameValuePair Class See Also Send Feedback

The NameValuePair type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePair Properties

[image]

PostSharp 2.0 Documentation
NameValuePair Properties
NameValuePair Class See Also Send Feedback

The NameValuePair type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | Value | Gets or sets the value.

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

NameValuePair..::..Name Property
NameValuePair Class See Also Send Feedback
Gets or sets the name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Value Property

NameValuePair..::..Value Property
NameValuePair Class See Also Send Feedback
Gets or sets the value.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Value { get; set; }

See Also

NameValuePair Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePairCollection Class

NameValuePairCollection Class
Members See Also Send Feedback
Collection of name-value pairs (NameValuePair).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class NameValuePairCollection : MarshalByRefList<NameValuePair>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' NameValuePair >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.NameValuePairCollection

See Also

NameValuePairCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePairCollection Members

[image]

PostSharp 2.0 Documentation
NameValuePairCollection Members
NameValuePairCollection Class Constructors Methods Properties See Also Send Feedback

The NameValuePairCollection type exposes the following members.

Constructors

 | Name | Description
Public method | NameValuePairCollection | Initializes a new instance of the NameValuePairCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

NameValuePairCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePairCollection Constructor

NameValuePairCollection Constructor
NameValuePairCollection Class See Also Send Feedback
Initializes a new instance of the NameValuePairCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NameValuePairCollection()

See Also

NameValuePairCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePairCollection Methods

[image]

PostSharp 2.0 Documentation
NameValuePairCollection Methods
NameValuePairCollection Class See Also Send Feedback

The NameValuePairCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

NameValuePairCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


NameValuePairCollection Properties

[image]

PostSharp 2.0 Documentation
NameValuePairCollection Properties
NameValuePairCollection Class See Also Send Feedback

The NameValuePairCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

NameValuePairCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfiguration Class

PhaseConfiguration Class
Members See Also Send Feedback
Post-compilation phase, which divides sequentially the post-compilation process and to which tasks belong.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PhaseConfiguration : ConfigurationElement,
    INamed, IPositioned

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfiguration

See Also

PhaseConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfiguration Members

[image]

PostSharp 2.0 Documentation
PhaseConfiguration Members
PhaseConfiguration Class Constructors Methods Properties See Also Send Feedback

The PhaseConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseConfiguration | Initializes a new instance of the PhaseConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | Name | Gets or sets the phase name.
Public property | Ordinal | Gets or sets the phase ordinal.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfiguration Constructor

PhaseConfiguration Constructor
PhaseConfiguration Class See Also Send Feedback
Initializes a new instance of the PhaseConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PhaseConfiguration()

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfiguration Methods

[image]

PostSharp 2.0 Documentation
PhaseConfiguration Methods
PhaseConfiguration Class See Also Send Feedback

The PhaseConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfiguration Properties

[image]

PostSharp 2.0 Documentation
PhaseConfiguration Properties
PhaseConfiguration Class See Also Send Feedback

The PhaseConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the phase name.
Public property | Ordinal | Gets or sets the phase ordinal.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

PhaseConfiguration..::..Name Property
PhaseConfiguration Class See Also Send Feedback
Gets or sets the phase name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

Implements

INamed..::.Name

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Ordinal Property

PhaseConfiguration..::..Ordinal Property
PhaseConfiguration Class See Also Send Feedback
Gets or sets the phase ordinal.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; set; }

Implements

IPositioned..::.Ordinal

See Also

PhaseConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationCollection Class

PhaseConfigurationCollection Class
Members See Also Send Feedback
Collection of phases (PhaseConfiguration).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PhaseConfigurationCollection : MarshalByRefList<PhaseConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' PhaseConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfigurationCollection

See Also

PhaseConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
PhaseConfigurationCollection Members
PhaseConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The PhaseConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseConfigurationCollection | Initializes a new instance of the PhaseConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PhaseConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationCollection Constructor

PhaseConfigurationCollection Constructor
PhaseConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the PhaseConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PhaseConfigurationCollection()

See Also

PhaseConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
PhaseConfigurationCollection Methods
PhaseConfigurationCollection Class See Also Send Feedback

The PhaseConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PhaseConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
PhaseConfigurationCollection Properties
PhaseConfigurationCollection Class See Also Send Feedback

The PhaseConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PhaseConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationDictionary Class

PhaseConfigurationDictionary Class
Members See Also Send Feedback
Collection of phases ordered by ordinal and accessible by name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class PhaseConfigurationDictionary : IndexedCollection<PhaseConfiguration>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Collections..::.IndexedCollection <(Of <(<' PhaseConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.PhaseConfigurationDictionary

See Also

PhaseConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationDictionary Members

[image]

PostSharp 2.0 Documentation
PhaseConfigurationDictionary Members
PhaseConfigurationDictionary Class Methods Properties See Also Send Feedback

The PhaseConfigurationDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Contains | Overloaded.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the collection has been disposed. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Item | Gets a phase given its name.

See Also

PhaseConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationDictionary Methods

[image]

PostSharp 2.0 Documentation
PhaseConfigurationDictionary Methods
PhaseConfigurationDictionary Class See Also Send Feedback

The PhaseConfigurationDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Contains | Overloaded.
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Ensures that the total capacity of the collection is at least of a given number. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)

See Also

PhaseConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Contains Method

[image]

PostSharp 2.0 Documentation
PhaseConfigurationDictionary..::..Contains Method
PhaseConfigurationDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(?0) | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public method | Contains(String) | Determines whether there exists a phase of a given name.

See Also

PhaseConfigurationDictionary Class
PhaseConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


Contains Method (String)

PhaseConfigurationDictionary..::..Contains Method (String)
PhaseConfigurationDictionary Class See Also Send Feedback
Determines whether there exists a phase of a given name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Contains(
    string name
)

Parameters

name
Type: System..::.String
Phase name.

Return Value

true if there exists a phase named name,

Field Value

false otherwise.

See Also

PhaseConfigurationDictionary Class
Contains Overload
PostSharp.Sdk.Extensibility.Configuration Namespace


PhaseConfigurationDictionary Properties

[image]

PostSharp 2.0 Documentation
PhaseConfigurationDictionary Properties
PhaseConfigurationDictionary Class See Also Send Feedback

The PhaseConfigurationDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the index capacity. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the collection has been disposed. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from IndexedCollection<(Of <(?0>)>).)
Public property | Item | Gets a phase given its name.

See Also

PhaseConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Item Property

PhaseConfigurationDictionary..::..Item Property
PhaseConfigurationDictionary Class See Also Send Feedback
Gets a phase given its name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PhaseConfiguration Item[
    string name
] { get; }

Parameters

name
Type: System..::.String
Phase name.

Return Value

The phase named name, or null if no phase was found.

See Also

PhaseConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfiguration Class

PlatformConfiguration Class
Members See Also Send Feedback
Configures a target platform.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PlatformConfiguration : ConfigurationElement

Remarks

A target platform is primarily defined by an implementation class, and optionally by some parameters.

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfiguration

See Also

PlatformConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfiguration Members

[image]

PostSharp 2.0 Documentation
PlatformConfiguration Members
PlatformConfiguration Class Constructors Methods Properties See Also Send Feedback

The PlatformConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | PlatformConfiguration | Initializes a new instance of the PlatformConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | Implementation | Gets or sets the full name of the type implementing TargetPlatformAdapter.
Public property | Name | Gets or sets the platform name (primary identifier).
Public property | Parameters | Gets or sets the collection of platform parameters.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfiguration Constructor

PlatformConfiguration Constructor
PlatformConfiguration Class See Also Send Feedback
Initializes a new instance of the PlatformConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlatformConfiguration()

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfiguration Methods

[image]

PostSharp 2.0 Documentation
PlatformConfiguration Methods
PlatformConfiguration Class See Also Send Feedback

The PlatformConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfiguration Properties

[image]

PostSharp 2.0 Documentation
PlatformConfiguration Properties
PlatformConfiguration Class See Also Send Feedback

The PlatformConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Implementation | Gets or sets the full name of the type implementing TargetPlatformAdapter.
Public property | Name | Gets or sets the platform name (primary identifier).
Public property | Parameters | Gets or sets the collection of platform parameters.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Implementation Property

PlatformConfiguration..::..Implementation Property
PlatformConfiguration Class See Also Send Feedback
Gets or sets the full name of the type implementing TargetPlatformAdapter.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Implementation { get; set; }

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

PlatformConfiguration..::..Name Property
PlatformConfiguration Class See Also Send Feedback
Gets or sets the platform name (primary identifier).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Parameters Property

PlatformConfiguration..::..Parameters Property
PlatformConfiguration Class See Also Send Feedback
Gets or sets the collection of platform parameters.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NameValuePairCollection Parameters { get; set; }

Remarks

Parameters are passed to the implementation of TargetPlatformAdapter during instantiation.

See Also

PlatformConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationCollection Class

PlatformConfigurationCollection Class
Members See Also Send Feedback
Collection of platform configurations (PlatformConfiguration).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PlatformConfigurationCollection : MarshalByRefList<PlatformConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' PlatformConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfigurationCollection

See Also

PlatformConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
PlatformConfigurationCollection Members
PlatformConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The PlatformConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PlatformConfigurationCollection | Initializes a new instance of the PlatformConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PlatformConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationCollection Constructor

PlatformConfigurationCollection Constructor
PlatformConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the PlatformConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlatformConfigurationCollection()

See Also

PlatformConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
PlatformConfigurationCollection Methods
PlatformConfigurationCollection Class See Also Send Feedback

The PlatformConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PlatformConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
PlatformConfigurationCollection Properties
PlatformConfigurationCollection Class See Also Send Feedback

The PlatformConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PlatformConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationDictionary Class

PlatformConfigurationDictionary Class
Members See Also Send Feedback
Dictionary of platform configurations (PlatformConfiguration) by name.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PlatformConfigurationDictionary : MarshalByRefDictionary<string, PlatformConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefDictionary <(Of <(<' String, PlatformConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.PlatformConfigurationDictionary

See Also

PlatformConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationDictionary Members

[image]

PostSharp 2.0 Documentation
PlatformConfigurationDictionary Members
PlatformConfigurationDictionary Class Constructors Methods Properties See Also Send Feedback

The PlatformConfigurationDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | PlatformConfigurationDictionary | Initializes a new PlatformConfigurationDictionary.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | TryGetValue | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Item | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Values | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

PlatformConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationDictionary Constructor

PlatformConfigurationDictionary Constructor
PlatformConfigurationDictionary Class See Also Send Feedback
Initializes a new PlatformConfigurationDictionary.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlatformConfigurationDictionary()

See Also

PlatformConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationDictionary Methods

[image]

PostSharp 2.0 Documentation
PlatformConfigurationDictionary Methods
PlatformConfigurationDictionary Class See Also Send Feedback

The PlatformConfigurationDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | TryGetValue | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

PlatformConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Add Method

[image]

PostSharp 2.0 Documentation
PlatformConfigurationDictionary..::..Add Method
PlatformConfigurationDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Add(?0, ?1) | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

PlatformConfigurationDictionary Class
PlatformConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PlatformConfigurationDictionary Properties

[image]

PostSharp 2.0 Documentation
PlatformConfigurationDictionary Properties
PlatformConfigurationDictionary Class See Also Send Feedback

The PlatformConfigurationDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Item | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Values | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

PlatformConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInConfiguration Class

PlugInConfiguration Class
Members See Also Send Feedback
Plug-in-level configuration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PlugInConfiguration : BaseConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.PlugInConfiguration

See Also

PlugInConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInConfiguration Members

[image]

PostSharp 2.0 Documentation
PlugInConfiguration Members
PlugInConfiguration Class Constructors Methods Properties See Also Send Feedback

The PlugInConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | PlugInConfiguration | Initializes a new instance of the PlugInConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

PlugInConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInConfiguration Constructor

PlugInConfiguration Constructor
PlugInConfiguration Class See Also Send Feedback
Initializes a new instance of the PlugInConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PlugInConfiguration()

See Also

PlugInConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInConfiguration Methods

[image]

PostSharp 2.0 Documentation
PlugInConfiguration Methods
PlugInConfiguration Class See Also Send Feedback

The PlugInConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

PlugInConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInConfiguration Properties

[image]

PostSharp 2.0 Documentation
PlugInConfiguration Properties
PlugInConfiguration Class See Also Send Feedback

The PlugInConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

PlugInConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ProjectConfiguration Class

ProjectConfiguration Class
Members See Also Send Feedback
Project-level configuration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class ProjectConfiguration : BaseConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.ProjectConfiguration

See Also

ProjectConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


ProjectConfiguration Members

[image]

PostSharp 2.0 Documentation
ProjectConfiguration Members
ProjectConfiguration Class Constructors Methods Properties See Also Send Feedback

The ProjectConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectConfiguration | Initializes a new instance of the ProjectConfiguration class

Methods

 | Name | Description
 | LoadProject | Loads the project configuration from a file.
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TasksElement | Gets or sets the serialized collection of tasks.
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ProjectConfiguration Constructor

ProjectConfiguration Constructor
ProjectConfiguration Class See Also Send Feedback
Initializes a new instance of the ProjectConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ProjectConfiguration()

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ProjectConfiguration Methods

[image]

PostSharp 2.0 Documentation
ProjectConfiguration Methods
ProjectConfiguration Class See Also Send Feedback

The ProjectConfiguration type exposes the following members.

Methods

 | Name | Description
 | LoadProject | Loads the project configuration from a file.
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


LoadProject Method

ProjectConfiguration..::..LoadProject Method
ProjectConfiguration Class See Also Send Feedback
Loads the project configuration from a file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ProjectConfiguration LoadProject(
    string fileName
)

Parameters

fileName
Type: System..::.String
Complete location of the project file.

Return Value

A ProjectConfiguration resulting from the deserialization of the content of the file at fileName.

Remarks

Errors are logged to the Messenger attached to the current thread.

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


ProjectConfiguration Properties

[image]

PostSharp 2.0 Documentation
ProjectConfiguration Properties
ProjectConfiguration Class See Also Send Feedback

The ProjectConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TasksElement | Gets or sets the serialized collection of tasks.
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TasksElement Property

ProjectConfiguration..::..TasksElement Property
ProjectConfiguration Class See Also Send Feedback
Gets or sets the serialized collection of tasks.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public XmlElement TasksElement { get; set; }

See Also

ProjectConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfiguration Class

PropertyConfiguration Class
Members See Also Send Feedback
Specifies a property assignment.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PropertyConfiguration : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.PropertyConfiguration

See Also

PropertyConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfiguration Members

[image]

PostSharp 2.0 Documentation
PropertyConfiguration Members
PropertyConfiguration Class Constructors Methods Properties See Also Send Feedback

The PropertyConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyConfiguration | Initializes a new instance of the PropertyConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | Name | Gets or sets the property name (primary key).
Public property | Overwrite | Determines whether the property will be overwritten if it already exists.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | Value | Gets or sets the property value.

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfiguration Constructor

PropertyConfiguration Constructor
PropertyConfiguration Class See Also Send Feedback
Initializes a new instance of the PropertyConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyConfiguration()

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfiguration Methods

[image]

PostSharp 2.0 Documentation
PropertyConfiguration Methods
PropertyConfiguration Class See Also Send Feedback

The PropertyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfiguration Properties

[image]

PostSharp 2.0 Documentation
PropertyConfiguration Properties
PropertyConfiguration Class See Also Send Feedback

The PropertyConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the property name (primary key).
Public property | Overwrite | Determines whether the property will be overwritten if it already exists.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | Value | Gets or sets the property value.

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

PropertyConfiguration..::..Name Property
PropertyConfiguration Class See Also Send Feedback
Gets or sets the property name (primary key).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Overwrite Property

PropertyConfiguration..::..Overwrite Property
PropertyConfiguration Class See Also Send Feedback
Determines whether the property will be overwritten if it already exists.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool Overwrite { get; set; }

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Value Property

PropertyConfiguration..::..Value Property
PropertyConfiguration Class See Also Send Feedback
Gets or sets the property value.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Value { get; set; }

Field Value

An expression.

See Also

PropertyConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfigurationCollection Class

PropertyConfigurationCollection Class
Members See Also Send Feedback
Collection of property definitions.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class PropertyConfigurationCollection : MarshalByRefList<PropertyConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' PropertyConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.PropertyConfigurationCollection

See Also

PropertyConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
PropertyConfigurationCollection Members
PropertyConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The PropertyConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyConfigurationCollection | Initializes a new instance of the PropertyConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PropertyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfigurationCollection Constructor

PropertyConfigurationCollection Constructor
PropertyConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the PropertyConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public PropertyConfigurationCollection()

See Also

PropertyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
PropertyConfigurationCollection Methods
PropertyConfigurationCollection Class See Also Send Feedback

The PropertyConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PropertyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PropertyConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
PropertyConfigurationCollection Properties
PropertyConfigurationCollection Class See Also Send Feedback

The PropertyConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

PropertyConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfiguration Class

SearchPathConfiguration Class
Members See Also Send Feedback
Specifies that a directory should be included in the search path.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class SearchPathConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.SearchPathConfiguration

See Also

SearchPathConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfiguration Members

[image]

PostSharp 2.0 Documentation
SearchPathConfiguration Members
SearchPathConfiguration Class Constructors Properties See Also Send Feedback

The SearchPathConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | SearchPathConfiguration | Initializes a new instance of the SearchPathConfiguration class

Properties

 | Name | Description
Public property | Directory | Gets or sets the directory to be included in the search path.
Public property | File | Gets or sets the file to be included in the search path.

See Also

SearchPathConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfiguration Constructor

SearchPathConfiguration Constructor
SearchPathConfiguration Class See Also Send Feedback
Initializes a new instance of the SearchPathConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SearchPathConfiguration()

See Also

SearchPathConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfiguration Properties

[image]

PostSharp 2.0 Documentation
SearchPathConfiguration Properties
SearchPathConfiguration Class See Also Send Feedback

The SearchPathConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Directory | Gets or sets the directory to be included in the search path.
Public property | File | Gets or sets the file to be included in the search path.

See Also

SearchPathConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Directory Property

SearchPathConfiguration..::..Directory Property
SearchPathConfiguration Class See Also Send Feedback
Gets or sets the directory to be included in the search path.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Directory { get; set; }

See Also

SearchPathConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


File Property

SearchPathConfiguration..::..File Property
SearchPathConfiguration Class See Also Send Feedback
Gets or sets the file to be included in the search path.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string File { get; set; }

See Also

SearchPathConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfigurationCollection Class

SearchPathConfigurationCollection Class
Members See Also Send Feedback
Collection of SearchPathConfiguration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class SearchPathConfigurationCollection : MarshalByRefList<SearchPathConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' SearchPathConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.SearchPathConfigurationCollection

See Also

SearchPathConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
SearchPathConfigurationCollection Members
SearchPathConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The SearchPathConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SearchPathConfigurationCollection | Initializes a new instance of the SearchPathConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

SearchPathConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfigurationCollection Constructor

SearchPathConfigurationCollection Constructor
SearchPathConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the SearchPathConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SearchPathConfigurationCollection()

See Also

SearchPathConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
SearchPathConfigurationCollection Methods
SearchPathConfigurationCollection Class See Also Send Feedback

The SearchPathConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

SearchPathConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SearchPathConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
SearchPathConfigurationCollection Properties
SearchPathConfigurationCollection Class See Also Send Feedback

The SearchPathConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

SearchPathConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceConfiguration Class

SourceConfiguration Class
Members See Also Send Feedback
Determines the source module.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class SourceConfiguration : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.SourceConfiguration

See Also

SourceConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceConfiguration Members

[image]

PostSharp 2.0 Documentation
SourceConfiguration Members
SourceConfiguration Class Constructors Methods Properties See Also Send Feedback

The SourceConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | SourceConfiguration | Initializes a new instance of the SourceConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Overrides ConfigurationElement..::.Validate()()().)

Properties

 | Name | Description
Public property | FullPath | Gets the full path of the current project file.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SourceFile | Gets or sets the path of the source module.

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceConfiguration Constructor

SourceConfiguration Constructor
SourceConfiguration Class See Also Send Feedback
Initializes a new instance of the SourceConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SourceConfiguration()

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceConfiguration Methods

[image]

PostSharp 2.0 Documentation
SourceConfiguration Methods
SourceConfiguration Class See Also Send Feedback

The SourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Overrides ConfigurationElement..::.Validate()()().)

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Validate Method

SourceConfiguration..::..Validate Method
SourceConfiguration Class See Also Send Feedback
Validates the current configuration element.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Validate()

Return Value

true if the current configuration element is valid, otherwise false.

Remarks

This method should writer errors (and warnings) to the current Messenger. It should validate child configuration elements recursively.

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceConfiguration Properties

[image]

PostSharp 2.0 Documentation
SourceConfiguration Properties
SourceConfiguration Class See Also Send Feedback

The SourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | FullPath | Gets the full path of the current project file.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SourceFile | Gets or sets the path of the source module.

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


FullPath Property

SourceConfiguration..::..FullPath Property
SourceConfiguration Class See Also Send Feedback
Gets the full path of the current project file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FullPath { get; }

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


SourceFile Property

SourceConfiguration..::..SourceFile Property
SourceConfiguration Class See Also Send Feedback
Gets or sets the path of the source module.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string SourceFile { get; set; }

Field Value

An absolute file name, or a location relative to the declaring project file location.

See Also

SourceConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfiguration Class

TaskTypeConfiguration Class
Members See Also Send Feedback
Configures a task type.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class TaskTypeConfiguration : ConfigurationElement

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.TaskTypeConfiguration

See Also

TaskTypeConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfiguration Members

[image]

PostSharp 2.0 Documentation
TaskTypeConfiguration Members
TaskTypeConfiguration Class Constructors Methods Properties See Also Send Feedback

The TaskTypeConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | TaskTypeConfiguration | Initializes a new instance of the TaskTypeConfiguration class

Methods

 | Name | Description
Public method | CreateInstance | Creates a empty task instance of the current task type.
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | Dependencies | Gets or sets the collection of dependencies of this task type.
Public property | Implementation | Gets or sets the name of the type implementing the Task.
Public property | Name | Gets or sets the name of the XML element for this task type.
Public property | Parameters | Gets or sets the collection of task type parameters.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Phase | Gets the name of the base to which tasks of this type belong.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfiguration Constructor

TaskTypeConfiguration Constructor
TaskTypeConfiguration Class See Also Send Feedback
Initializes a new instance of the TaskTypeConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfiguration()

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfiguration Methods

[image]

PostSharp 2.0 Documentation
TaskTypeConfiguration Methods
TaskTypeConfiguration Class See Also Send Feedback

The TaskTypeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Creates a empty task instance of the current task type.
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


CreateInstance Method

TaskTypeConfiguration..::..CreateInstance Method
TaskTypeConfiguration Class See Also Send Feedback
Creates a empty task instance of the current task type.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Task CreateInstance(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
Actual configuration.

Return Value

A Task.

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfiguration Properties

[image]

PostSharp 2.0 Documentation
TaskTypeConfiguration Properties
TaskTypeConfiguration Class See Also Send Feedback

The TaskTypeConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Dependencies | Gets or sets the collection of dependencies of this task type.
Public property | Implementation | Gets or sets the name of the type implementing the Task.
Public property | Name | Gets or sets the name of the XML element for this task type.
Public property | Parameters | Gets or sets the collection of task type parameters.
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Phase | Gets the name of the base to which tasks of this type belong.
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Dependencies Property

TaskTypeConfiguration..::..Dependencies Property
TaskTypeConfiguration Class See Also Send Feedback
Gets or sets the collection of dependencies of this task type.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DependencyConfigurationCollection Dependencies { get; set; }

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Implementation Property

TaskTypeConfiguration..::..Implementation Property
TaskTypeConfiguration Class See Also Send Feedback
Gets or sets the name of the type implementing the Task.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Implementation { get; set; }

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Name Property

TaskTypeConfiguration..::..Name Property
TaskTypeConfiguration Class See Also Send Feedback
Gets or sets the name of the XML element for this task type.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; set; }

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Parameters Property

TaskTypeConfiguration..::..Parameters Property
TaskTypeConfiguration Class See Also Send Feedback
Gets or sets the collection of task type parameters.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public NameValuePairCollection Parameters { get; set; }

Remarks

Parameters can be used by the implementation of the Task type.

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Phase Property

TaskTypeConfiguration..::..Phase Property
TaskTypeConfiguration Class See Also Send Feedback
Gets the name of the base to which tasks of this type belong.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Phase { get; set; }

See Also

TaskTypeConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationCollection Class

TaskTypeConfigurationCollection Class
Members See Also Send Feedback
Collection of task type configurations (TaskTypeConfiguration).

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class TaskTypeConfigurationCollection : Collection<TaskTypeConfiguration>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' TaskTypeConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.TaskTypeConfigurationCollection

See Also

TaskTypeConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
TaskTypeConfigurationCollection Members
TaskTypeConfigurationCollection Class Constructors See Also Send Feedback

The TaskTypeConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | TaskTypeConfigurationCollection | Initializes a new instance of the TaskTypeConfigurationCollection class

See Also

TaskTypeConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationCollection Constructor

TaskTypeConfigurationCollection Constructor
TaskTypeConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the TaskTypeConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfigurationCollection()

See Also

TaskTypeConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationDictionary Class

TaskTypeConfigurationDictionary Class
Members See Also Send Feedback
Dictionary mapping the name of a TaskTypeConfiguration to its corresponding instance.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class TaskTypeConfigurationDictionary : MarshalByRefDictionary<string, TaskTypeConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefDictionary <(Of <(<' String, TaskTypeConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.TaskTypeConfigurationDictionary

See Also

TaskTypeConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationDictionary Members

[image]

PostSharp 2.0 Documentation
TaskTypeConfigurationDictionary Members
TaskTypeConfigurationDictionary Class Constructors Methods Properties See Also Send Feedback

The TaskTypeConfigurationDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | TaskTypeConfigurationDictionary | Initializes a new TaskTypeConfigurationDictionary.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | TryGetValue | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Item | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Values | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

TaskTypeConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationDictionary Constructor

TaskTypeConfigurationDictionary Constructor
TaskTypeConfigurationDictionary Class See Also Send Feedback
Initializes a new TaskTypeConfigurationDictionary.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TaskTypeConfigurationDictionary()

See Also

TaskTypeConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationDictionary Methods

[image]

PostSharp 2.0 Documentation
TaskTypeConfigurationDictionary Methods
TaskTypeConfigurationDictionary Class See Also Send Feedback

The TaskTypeConfigurationDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | ContainsKey | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | TryGetValue | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

TaskTypeConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


Add Method

[image]

PostSharp 2.0 Documentation
TaskTypeConfigurationDictionary..::..Add Method
TaskTypeConfigurationDictionary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(KeyValuePair<(Of <(?0, ?1>)>)) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public method | Add(?0, ?1) | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

TaskTypeConfigurationDictionary Class
TaskTypeConfigurationDictionary Members
PostSharp.Sdk.Extensibility.Configuration Namespace


TaskTypeConfigurationDictionary Properties

[image]

PostSharp 2.0 Documentation
TaskTypeConfigurationDictionary Properties
TaskTypeConfigurationDictionary Class See Also Send Feedback

The TaskTypeConfigurationDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Item | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Keys | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)
Public property | Values | (Inherited from MarshalByRefDictionary<(Of <(?0, ?1>)>).)

See Also

TaskTypeConfigurationDictionary Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfiguration Class

UsingConfiguration Class
Members See Also Send Feedback
Includes a plug-in in the current project.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class UsingConfiguration : BaseConfiguration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Configuration..::.ConfigurationElement
PostSharp.Sdk.Extensibility.Configuration..::.BaseConfiguration
PostSharp.Sdk.Extensibility.Configuration..::.UsingConfiguration

See Also

UsingConfiguration Members
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfiguration Members

[image]

PostSharp 2.0 Documentation
UsingConfiguration Members
UsingConfiguration Class Constructors Methods Properties See Also Send Feedback

The UsingConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | UsingConfiguration | Initializes a new instance of the UsingConfiguration class

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | PlugInFile | Gets or sets the path of the plug-in configuration file.
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

UsingConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfiguration Constructor

UsingConfiguration Constructor
UsingConfiguration Class See Also Send Feedback
Initializes a new instance of the UsingConfiguration class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UsingConfiguration()

See Also

UsingConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfiguration Methods

[image]

PostSharp 2.0 Documentation
UsingConfiguration Methods
UsingConfiguration Class See Also Send Feedback

The UsingConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Validates the current configuration element. (Inherited from ConfigurationElement.)

See Also

UsingConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfiguration Properties

[image]

PostSharp 2.0 Documentation
UsingConfiguration Properties
UsingConfiguration Class See Also Send Feedback

The UsingConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyBindingPolicySets | Gets or sets the section configuring assembly redirection policies. (Inherited from BaseConfiguration.)
Public property | FileName | Gets or sets the name of the file declaring the current configuration. (Inherited from BaseConfiguration.)
Public property | Parent | Gets the parent configuration element. (Inherited from ConfigurationElement.)
Public property | Platforms | Gets or sets the collection of platforms defined in the current file. (Inherited from BaseConfiguration.)
Public property | PlugInFile | Gets or sets the path of the plug-in configuration file.
Public property | Properties | Gets or sets the collection of properties defined in the current file. (Inherited from BaseConfiguration.)
Public property | Root | Gets the root configuration element. (Inherited from ConfigurationElement.)
Public property | SearchPath | Gets or sets the collection of directories to be added to the search path. (Inherited from BaseConfiguration.)
Public property | StrongNames | Gets or sets the collection of strong names. (Inherited from BaseConfiguration.)
Public property | TaskTypes | Gets or sets the collection of task types defined in the current file. (Inherited from BaseConfiguration.)
Public property | UsedPlugIns | Gets or sets the collection of plug-ins to be included in the project. (Inherited from BaseConfiguration.)

See Also

UsingConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PlugInFile Property

UsingConfiguration..::..PlugInFile Property
UsingConfiguration Class See Also Send Feedback
Gets or sets the path of the plug-in configuration file.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PlugInFile { get; set; }

See Also

UsingConfiguration Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfigurationCollection Class

UsingConfigurationCollection Class
Members See Also Send Feedback
Collection of UsingConfiguration.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class UsingConfigurationCollection : MarshalByRefList<UsingConfiguration>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Collections..::.MarshalByRefList <(Of <(<' UsingConfiguration >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.UsingConfigurationCollection

See Also

UsingConfigurationCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfigurationCollection Members

[image]

PostSharp 2.0 Documentation
UsingConfigurationCollection Members
UsingConfigurationCollection Class Constructors Methods Properties See Also Send Feedback

The UsingConfigurationCollection type exposes the following members.

Constructors

 | Name | Description
Public method | UsingConfigurationCollection | Initializes a new instance of the UsingConfigurationCollection class

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

UsingConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfigurationCollection Constructor

UsingConfigurationCollection Constructor
UsingConfigurationCollection Class See Also Send Feedback
Initializes a new instance of the UsingConfigurationCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public UsingConfigurationCollection()

See Also

UsingConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfigurationCollection Methods

[image]

PostSharp 2.0 Documentation
UsingConfigurationCollection Methods
UsingConfigurationCollection Class See Also Send Feedback

The UsingConfigurationCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | IndexOf | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Insert | (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public method | RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

UsingConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


UsingConfigurationCollection Properties

[image]

PostSharp 2.0 Documentation
UsingConfigurationCollection Properties
UsingConfigurationCollection Class See Also Send Feedback

The UsingConfigurationCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from MarshalByRefList<(Of <(?0>)>).)
Public property | Item | (Inherited from MarshalByRefList<(Of <(?0>)>).)

See Also

UsingConfigurationCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


XmlElementCollection Class

XmlElementCollection Class
Members See Also Send Feedback
Collection of XML elements.

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class XmlElementCollection : Collection<XmlElement>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' XmlElement >)>)>
PostSharp.Sdk.Extensibility.Configuration..::.XmlElementCollection

See Also

XmlElementCollection Members
PostSharp.Sdk.Extensibility.Configuration Namespace


XmlElementCollection Members

[image]

PostSharp 2.0 Documentation
XmlElementCollection Members
XmlElementCollection Class Constructors See Also Send Feedback

The XmlElementCollection type exposes the following members.

Constructors

 | Name | Description
Public method | XmlElementCollection | Initializes a new instance of the XmlElementCollection class

See Also

XmlElementCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


XmlElementCollection Constructor

XmlElementCollection Constructor
XmlElementCollection Class See Also Send Feedback
Initializes a new instance of the XmlElementCollection class

Namespace: PostSharp.Sdk.Extensibility.Configuration
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public XmlElementCollection()

See Also

XmlElementCollection Class
PostSharp.Sdk.Extensibility.Configuration Namespace


PostSharp.Sdk.Extensibility.Licensing Namespace

PostSharp.Sdk.Extensibility.Licensing Namespace
Send Feedback
The PostSharp.Sdk.Extensibility.Licensing namespace contains, well, the licensing subsystem of PostSharp, and you should probably not look at it unless you have criminal intentions or need to initialize the licensing system.

Classes

 | Class | Description
Public class | InvalidLicenseException | Exception thrown when an invalid license is provided.
Public class | LicenseManager | Manages PostSharp licenses.


InvalidLicenseException Class

InvalidLicenseException Class
Members See Also Send Feedback
Exception thrown when an invalid license is provided.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class InvalidLicenseException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PostSharp.Sdk.Extensibility.Licensing..::.InvalidLicenseException

See Also

InvalidLicenseException Members
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Members

[image]

PostSharp 2.0 Documentation
InvalidLicenseException Members
InvalidLicenseException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | InvalidLicenseException | Overloaded.

See Also

InvalidLicenseException Class
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Constructor

[image]

PostSharp 2.0 Documentation
InvalidLicenseException Constructor
InvalidLicenseException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidLicenseException()()() | Initializes a new InvalidLicenseException.
Public method | InvalidLicenseException(String) | Initializes a new InvalidLicenseException and sets the exception message.
Protected method | InvalidLicenseException(SerializationInfo, StreamingContext) | Deserialization constructor.
Public method | InvalidLicenseException(String, Exception) | Initializes a new InvalidLicenseException and sets the exception message and the inner exception.

See Also

InvalidLicenseException Class
InvalidLicenseException Members
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Constructor

InvalidLicenseException Constructor
InvalidLicenseException Class See Also Send Feedback
Initializes a new InvalidLicenseException.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidLicenseException()

See Also

InvalidLicenseException Class
InvalidLicenseException Overload
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Constructor (String)

InvalidLicenseException Constructor (String)
InvalidLicenseException Class See Also Send Feedback
Initializes a new InvalidLicenseException and sets the exception message.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidLicenseException(
    string message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

InvalidLicenseException Class
InvalidLicenseException Overload
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Constructor (SerializationInfo, StreamingContext)

InvalidLicenseException Constructor (SerializationInfo, StreamingContext)
InvalidLicenseException Class See Also Send Feedback
Deserialization constructor.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected InvalidLicenseException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Info.
context
Type: System.Runtime.Serialization..::.StreamingContext
Context.

See Also

InvalidLicenseException Class
InvalidLicenseException Overload
PostSharp.Sdk.Extensibility.Licensing Namespace


InvalidLicenseException Constructor (String, Exception)

InvalidLicenseException Constructor (String, Exception)
InvalidLicenseException Class See Also Send Feedback
Initializes a new InvalidLicenseException and sets the exception message and the inner exception.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public InvalidLicenseException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner exception.

See Also

InvalidLicenseException Class
InvalidLicenseException Overload
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseManager Class

LicenseManager Class
Members See Also Send Feedback
Manages PostSharp licenses.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class LicenseManager : MarshalByRefObject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility.Licensing..::.LicenseManager

See Also

LicenseManager Members
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseManager Members

[image]

PostSharp 2.0 Documentation
LicenseManager Members
LicenseManager Class Constructors Methods Fields See Also Send Feedback

The LicenseManager type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseManager | Initializes a new instance of the LicenseManager class

Methods

Name | Description
Initialize | Initializes the LicenseManager.

Fields

Name | Description
LicenseFileName | Name of the license file.

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseManager Constructor

LicenseManager Constructor
LicenseManager Class See Also Send Feedback
Initializes a new instance of the LicenseManager class

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public LicenseManager()

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseManager Fields

[image]

PostSharp 2.0 Documentation
LicenseManager Fields
LicenseManager Class See Also Send Feedback

The LicenseManager type exposes the following members.

Fields

Name | Description
LicenseFileName | Name of the license file.

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseFileName Field

LicenseManager..::..LicenseFileName Field
LicenseManager Class See Also Send Feedback
Name of the license file.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public const string LicenseFileName

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


LicenseManager Methods

[image]

PostSharp 2.0 Documentation
LicenseManager Methods
LicenseManager Class See Also Send Feedback

The LicenseManager type exposes the following members.

Methods

Name | Description
Initialize | Initializes the LicenseManager.

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


Initialize Method

LicenseManager..::..Initialize Method
LicenseManager Class See Also Send Feedback
Initializes the LicenseManager.

Namespace: PostSharp.Sdk.Extensibility.Licensing
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Initialize(
    string userLicenseKey
)

Parameters

userLicenseKey
Type: System..::.String
User license string.

Return Value

true if a license was successfully loaded, otherwise false.

See Also

LicenseManager Class
PostSharp.Sdk.Extensibility.Licensing Namespace


PostSharp.Sdk.Extensibility.Tasks Namespace

PostSharp.Sdk.Extensibility.Tasks Namespace
Send Feedback
The PostSharp.Sdk.Extensibility.Tasks namespace contains the basic tasks composing a typical PostSharp build process.

Classes

 | Class | Description
Public class | AnnotationRepositoryTask | Repository of custom attributes applying on a module. Custom attributes may come from different sources (sources would implement the IAnnotationProvider interface) and are indexed by type.
Public class | AutoDetectTask | Tasks that detects automatically other tasks required by the module on the base of custom attributes annotated with the RequirePostSharpAttribute custom attribute.
Public class | CompileTask | Task that compiles a module into MSIL or into binary form.
Public class | DisableMessagesTask | Tasks that detects DisablePostSharpMessageAttribute custom attributes and disable messages accordingly.
Public class | GlobalsTask | Performs the transformations required by the Post class.
Public class | ImplementationBoundAttributesTask | Determines whether a custom attribute is bound to its implementation, i.e. provides an index of instances of the ImplementationBoundAttributeAttribute custom attribute.
Public class | IndexGenericInstancesTask | Task that references generic instances as tags in generic definitions.
Public class | IndexTypeDefMemberRefsTask | Indexes all MemberRefs (MemberRefDeclaration) owned by a TypeDef (Type), and relate them to the corresponding FieldDefDeclaration or MethodDefDeclaration.
Public class | IndexUsagesTask | Tasks that references the uses of fields and methods by methods.
Public class | ModuleAnnotationProvider | Implementation of IAnnotationProvider that provides the custom attribute instances defined in the module (i.e. CustomAttributeDeclaration).
Public class | MulticastAttributesComparer | Provides methods that evaluate if a specific declaration match a value of MulticastAttributes.
Public class | MulticastAttributeTask | This task analyze instances of custom attributes derived from MulticastAttribute and propagate them on their target elements in the custom attribute dictionary (AnnotationRepositoryTask) of this module.
Public class | RemoveTask | Task that remove declarations from the module. Typically called immediately before compilation.
Public class | TypeHierarchyTask | Analysis that builds an inheritance tree of all types in the module.
Public class | VerifyTask | Executes PEVERIFY on the compilation output.

Interfaces

 | Interface | Description
Public interface | IAnnotationProvider | When implemented by a Task, provides custom attribute instances to the AnnotationRepositoryTask task.

Enumerations

 | Enumeration | Description
Public enumeration | IndexUsagesInstructions | Bit mask of instructions returned by GetUsesWithInstructions(MethodDefDeclaration).


AnnotationRepositoryTask Class

AnnotationRepositoryTask Class
Members See Also Send Feedback
Repository of custom attributes applying on a module. Custom attributes may come from different sources (sources would implement the IAnnotationProvider interface) and are indexed by type.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AnnotationRepositoryTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.AnnotationRepositoryTask

See Also

AnnotationRepositoryTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


AnnotationRepositoryTask Members

[image]

PostSharp 2.0 Documentation
AnnotationRepositoryTask Members
AnnotationRepositoryTask Class Constructors Methods Properties See Also Send Feedback

The AnnotationRepositoryTask type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationRepositoryTask | Initializes a new instance of the AnnotationRepositoryTask class

Methods

 | Name | Description
Public method | AddAnnotation | Adds a custom attribute instance to the current repository.
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetAnnotationsOfType | Overloaded.
Public method | GetAnnotationsOnTarget | Gets an enumerator of all annotations defined on a target (i.e. on a MetadataDeclaration).
 | GetTask | Finds the current task in a Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | RemoveAnnotation | Removes a custom attribute instance from the current repository.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AnnotationRepositoryTask Constructor

AnnotationRepositoryTask Constructor
AnnotationRepositoryTask Class See Also Send Feedback
Initializes a new instance of the AnnotationRepositoryTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AnnotationRepositoryTask()

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AnnotationRepositoryTask Methods

[image]

PostSharp 2.0 Documentation
AnnotationRepositoryTask Methods
AnnotationRepositoryTask Class See Also Send Feedback

The AnnotationRepositoryTask type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds a custom attribute instance to the current repository.
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetAnnotationsOfType | Overloaded.
Public method | GetAnnotationsOnTarget | Gets an enumerator of all annotations defined on a target (i.e. on a MetadataDeclaration).
 | GetTask | Finds the current task in a Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | RemoveAnnotation | Removes a custom attribute instance from the current repository.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AddAnnotation Method

AnnotationRepositoryTask..::..AddAnnotation Method
AnnotationRepositoryTask Class See Also Send Feedback
Adds a custom attribute instance to the current repository.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AddAnnotation(
    IAnnotationInstance instance
)

Parameters

instance
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
A new custom attribute instance.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

AnnotationRepositoryTask..::..Execute Method
AnnotationRepositoryTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotationsOfType Method

[image]

PostSharp 2.0 Documentation
AnnotationRepositoryTask..::..GetAnnotationsOfType Method
AnnotationRepositoryTask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAnnotationsOfType(Type, Boolean) | Gets all custom attribute instances of a given custom attribute class, given a base Type.
Public method | GetAnnotationsOfType(TypeDefDeclaration, Boolean) | Gets all custom attribute instances of a given custom attribute class, given a base TypeDefDeclaration.

See Also

AnnotationRepositoryTask Class
AnnotationRepositoryTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotationsOfType Method (Type, Boolean)

AnnotationRepositoryTask..::..GetAnnotationsOfType Method (Type, Boolean)
AnnotationRepositoryTask Class See Also Send Feedback
Gets all custom attribute instances of a given custom attribute class, given a base Type.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<IAnnotationInstance> GetAnnotationsOfType(
    Type type,
    bool inherited
)

Parameters

type
Type: System..::.Type
Base type of requested custom attribute instances.
inherited
Type: System..::.Boolean
Whether instances of types inherited from type are requested.

Return Value

An enumerator of the requested custom attribute instances.

See Also

AnnotationRepositoryTask Class
GetAnnotationsOfType Overload
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotationsOfType Method (TypeDefDeclaration, Boolean)

AnnotationRepositoryTask..::..GetAnnotationsOfType Method (TypeDefDeclaration, Boolean)
AnnotationRepositoryTask Class See Also Send Feedback
Gets all custom attribute instances of a given custom attribute class, given a base TypeDefDeclaration.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<IAnnotationInstance> GetAnnotationsOfType(
    TypeDefDeclaration type,
    bool inherited
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
Base type of requested custom attribute instances.
inherited
Type: System..::.Boolean
Whether instances of types inherited from type are requested.

Return Value

An enumerator of the requested custom attribute instances.

See Also

AnnotationRepositoryTask Class
GetAnnotationsOfType Overload
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotationsOnTarget Method

AnnotationRepositoryTask..::..GetAnnotationsOnTarget Method
AnnotationRepositoryTask Class See Also Send Feedback
Gets an enumerator of all annotations defined on a target (i.e. on a MetadataDeclaration).

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<IAnnotationInstance> GetAnnotationsOnTarget(
    MetadataDeclaration target
)

Parameters

target
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The declaration whose annotations have to be returned.

Return Value

An enumerator of all annotations defined on target.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetTask Method

AnnotationRepositoryTask..::..GetTask Method
AnnotationRepositoryTask Class See Also Send Feedback
Finds the current task in a Project.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static AnnotationRepositoryTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
A Project.

Return Value

The IndexGenericInstancesTask contained in the project, or null if this project does not contain the current task.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveAnnotation Method

AnnotationRepositoryTask..::..RemoveAnnotation Method
AnnotationRepositoryTask Class See Also Send Feedback
Removes a custom attribute instance from the current repository.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void RemoveAnnotation(
    IAnnotationInstance instance
)

Parameters

instance
Type: PostSharp.Sdk.CodeModel..::.IAnnotationInstance
The custom attribute instance to remove.

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AnnotationRepositoryTask Properties

[image]

PostSharp 2.0 Documentation
AnnotationRepositoryTask Properties
AnnotationRepositoryTask Class See Also Send Feedback

The AnnotationRepositoryTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AnnotationRepositoryTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AutoDetectTask Class

AutoDetectTask Class
Members See Also Send Feedback
Tasks that detects automatically other tasks required by the module on the base of custom attributes annotated with the RequirePostSharpAttribute custom attribute.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class AutoDetectTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.AutoDetectTask

See Also

AutoDetectTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


AutoDetectTask Members

[image]

PostSharp 2.0 Documentation
AutoDetectTask Members
AutoDetectTask Class Constructors Methods Properties See Also Send Feedback

The AutoDetectTask type exposes the following members.

Constructors

 | Name | Description
Public method | AutoDetectTask | Initializes a new instance of the AutoDetectTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AutoDetectTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AutoDetectTask Constructor

AutoDetectTask Constructor
AutoDetectTask Class See Also Send Feedback
Initializes a new instance of the AutoDetectTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public AutoDetectTask()

See Also

AutoDetectTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AutoDetectTask Methods

[image]

PostSharp 2.0 Documentation
AutoDetectTask Methods
AutoDetectTask Class See Also Send Feedback

The AutoDetectTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

AutoDetectTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

AutoDetectTask..::..Execute Method
AutoDetectTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

AutoDetectTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


AutoDetectTask Properties

[image]

PostSharp 2.0 Documentation
AutoDetectTask Properties
AutoDetectTask Class See Also Send Feedback

The AutoDetectTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

AutoDetectTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompileTask Class

CompileTask Class
Members See Also Send Feedback
Task that compiles a module into MSIL or into binary form.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class CompileTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.CompileTask

See Also

CompileTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


CompileTask Members

[image]

PostSharp 2.0 Documentation
CompileTask Members
CompileTask Class Constructors Methods Properties See Also Send Feedback

The CompileTask type exposes the following members.

Constructors

 | Name | Description
Public method | CompileTask | Initializes a new instance of the CompileTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | CleanIntermediate | Determines whether the intermediate directory should be cleaned after compilation.
Public property | Compatibility | Not really supported.
Public property | DebugOption | Determines how debugging will be supported for the target module.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | Encoding | Gets or sets the encoding of the intermediate MSIL file. It needs to be supported by ILASM.
Public property | ForbidSignAssembly | If true, the assembly will not be signed. This property overwrites the SignAssembly property and the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | IntermediateDirectory | Gets or sets the intermediate directory (where IL and resource files will be written).
Public property | PrivateKeyLocation | If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | SignAssembly | Determines whether the assembly should be signed using a digital key. If set to Default()()(), the task will look for the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TargetFile | Gets or sets the target location of the binary module.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompileTask Constructor

CompileTask Constructor
CompileTask Class See Also Send Feedback
Initializes a new instance of the CompileTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public CompileTask()

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompileTask Methods

[image]

PostSharp 2.0 Documentation
CompileTask Methods
CompileTask Class See Also Send Feedback

The CompileTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

CompileTask..::..Execute Method
CompileTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompileTask Properties

[image]

PostSharp 2.0 Documentation
CompileTask Properties
CompileTask Class See Also Send Feedback

The CompileTask type exposes the following members.

Properties

 | Name | Description
Public property | CleanIntermediate | Determines whether the intermediate directory should be cleaned after compilation.
Public property | Compatibility | Not really supported.
Public property | DebugOption | Determines how debugging will be supported for the target module.
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | Encoding | Gets or sets the encoding of the intermediate MSIL file. It needs to be supported by ILASM.
Public property | ForbidSignAssembly | If true, the assembly will not be signed. This property overwrites the SignAssembly property and the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | IntermediateDirectory | Gets or sets the intermediate directory (where IL and resource files will be written).
Public property | PrivateKeyLocation | If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | SignAssembly | Determines whether the assembly should be signed using a digital key. If set to Default()()(), the task will look for the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TargetFile | Gets or sets the target location of the binary module.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CleanIntermediate Property

CompileTask..::..CleanIntermediate Property
CompileTask Class See Also Send Feedback
Determines whether the intermediate directory should be cleaned after compilation.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CleanIntermediate { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Compatibility Property

CompileTask..::..Compatibility Property
CompileTask Class See Also Send Feedback
Not really supported.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Compatibility { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


DebugOption Property

CompileTask..::..DebugOption Property
CompileTask Class See Also Send Feedback
Determines how debugging will be supported for the target module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DebugOption DebugOption { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Encoding Property

CompileTask..::..Encoding Property
CompileTask Class See Also Send Feedback
Gets or sets the encoding of the intermediate MSIL file. It needs to be supported by ILASM.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Encoding { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ForbidSignAssembly Property

CompileTask..::..ForbidSignAssembly Property
CompileTask Class See Also Send Feedback
If true, the assembly will not be signed. This property overwrites the SignAssembly property and the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ForbidSignAssembly { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IntermediateDirectory Property

CompileTask..::..IntermediateDirectory Property
CompileTask Class See Also Send Feedback
Gets or sets the intermediate directory (where IL and resource files will be written).

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string IntermediateDirectory { get; set; }

Field Value

A directory path, or null to store intermediate files in a temporary directory.

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


PrivateKeyLocation Property

CompileTask..::..PrivateKeyLocation Property
CompileTask Class See Also Send Feedback
If SignAssembly is true, full path of the key file that should be used to sign the assembly. If the key should not be taken from a file, but from a key repository, this property should start with an '@' sign.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string PrivateKeyLocation { get; set; }

Remarks

The path may be given in the form {Reference Directory}|{Relative Path}. In this case, the relative path given in the right part of the string is resolved according to the reference directory given in the left part. If a full path is given in the right part, the reference directory is ignored.

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


SignAssembly Property

CompileTask..::..SignAssembly Property
CompileTask Class See Also Send Feedback
Determines whether the assembly should be signed using a digital key. If set to Default()()(), the task will look for the custom attributes AssemblyKeyFileAttribute and AssemblyKeyNameAttribute.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool SignAssembly { get; set; }

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


TargetFile Property

CompileTask..::..TargetFile Property
CompileTask Class See Also Send Feedback
Gets or sets the target location of the binary module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TargetFile { get; set; }

Field Value

The location of the target binary module (absolute or relative to the project file), or null if the IL code should not be assembled.

See Also

CompileTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


DisableMessagesTask Class

DisableMessagesTask Class
Members See Also Send Feedback
Tasks that detects DisablePostSharpMessageAttribute custom attributes and disable messages accordingly.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class DisableMessagesTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.DisableMessagesTask

See Also

DisableMessagesTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


DisableMessagesTask Members

[image]

PostSharp 2.0 Documentation
DisableMessagesTask Members
DisableMessagesTask Class Constructors Methods Properties See Also Send Feedback

The DisableMessagesTask type exposes the following members.

Constructors

 | Name | Description
Public method | DisableMessagesTask | Initializes a new instance of the DisableMessagesTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

DisableMessagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


DisableMessagesTask Constructor

DisableMessagesTask Constructor
DisableMessagesTask Class See Also Send Feedback
Initializes a new instance of the DisableMessagesTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DisableMessagesTask()

See Also

DisableMessagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


DisableMessagesTask Methods

[image]

PostSharp 2.0 Documentation
DisableMessagesTask Methods
DisableMessagesTask Class See Also Send Feedback

The DisableMessagesTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

DisableMessagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

DisableMessagesTask..::..Execute Method
DisableMessagesTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

DisableMessagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


DisableMessagesTask Properties

[image]

PostSharp 2.0 Documentation
DisableMessagesTask Properties
DisableMessagesTask Class See Also Send Feedback

The DisableMessagesTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

DisableMessagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GlobalsTask Class

GlobalsTask Class
Members See Also Send Feedback
Performs the transformations required by the Post class.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class GlobalsTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.GlobalsTask

See Also

GlobalsTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


GlobalsTask Members

[image]

PostSharp 2.0 Documentation
GlobalsTask Members
GlobalsTask Class Constructors Methods Properties See Also Send Feedback

The GlobalsTask type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalsTask | Initializes a new instance of the GlobalsTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | ProvideAdvices |

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GlobalsTask Constructor

GlobalsTask Constructor
GlobalsTask Class See Also Send Feedback
Initializes a new instance of the GlobalsTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public GlobalsTask()

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GlobalsTask Methods

[image]

PostSharp 2.0 Documentation
GlobalsTask Methods
GlobalsTask Class See Also Send Feedback

The GlobalsTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | ProvideAdvices |

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

GlobalsTask..::..Execute Method
GlobalsTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ProvideAdvices Method

GlobalsTask..::..ProvideAdvices Method
GlobalsTask Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.GlobalsTask.ProvideAdvices(PostSharp.Sdk.CodeWeaver.Weaver)"]

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void ProvideAdvices(
    Weaver codeWeaver
)

Parameters

codeWeaver
Type: PostSharp.Sdk.CodeWeaver..::.Weaver

[Missing <param name="codeWeaver"/> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.GlobalsTask.ProvideAdvices(PostSharp.Sdk.CodeWeaver.Weaver)"]

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GlobalsTask Properties

[image]

PostSharp 2.0 Documentation
GlobalsTask Properties
GlobalsTask Class See Also Send Feedback

The GlobalsTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

GlobalsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IAnnotationProvider Interface

IAnnotationProvider Interface
Members See Also Send Feedback
When implemented by a Task, provides custom attribute instances to the AnnotationRepositoryTask task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public interface IAnnotationProvider

See Also

IAnnotationProvider Members
PostSharp.Sdk.Extensibility.Tasks Namespace


IAnnotationProvider Members

[image]

PostSharp 2.0 Documentation
IAnnotationProvider Members
IAnnotationProvider Interface Methods See Also Send Feedback

The IAnnotationProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotations | Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.

See Also

IAnnotationProvider Interface
PostSharp.Sdk.Extensibility.Tasks Namespace


IAnnotationProvider Methods

[image]

PostSharp 2.0 Documentation
IAnnotationProvider Methods
IAnnotationProvider Interface See Also Send Feedback

The IAnnotationProvider type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotations | Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.

See Also

IAnnotationProvider Interface
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotations Method

IAnnotationProvider..::..GetAnnotations Method
IAnnotationProvider Interface See Also Send Feedback
Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
IEnumerator<IAnnotationInstance> GetAnnotations()

Return Value

An enumerator of custom attributes provided by the current task.

See Also

IAnnotationProvider Interface
PostSharp.Sdk.Extensibility.Tasks Namespace


ImplementationBoundAttributesTask Class

ImplementationBoundAttributesTask Class
Members See Also Send Feedback
Determines whether a custom attribute is bound to its implementation, i.e. provides an index of instances of the ImplementationBoundAttributeAttribute custom attribute.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ImplementationBoundAttributesTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.ImplementationBoundAttributesTask

See Also

ImplementationBoundAttributesTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


ImplementationBoundAttributesTask Members

[image]

PostSharp 2.0 Documentation
ImplementationBoundAttributesTask Members
ImplementationBoundAttributesTask Class Constructors Methods Properties See Also Send Feedback

The ImplementationBoundAttributesTask type exposes the following members.

Constructors

 | Name | Description
Public method | ImplementationBoundAttributesTask | Initializes a new instance of the ImplementationBoundAttributesTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetTask | Gets the ImplementationBoundAttributesTask task in a project.
Public method | IsImplementationBound | Determines whether a custom attribute of a given type is bound to the implementation of the semantic to which it was applied.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ImplementationBoundAttributesTask Constructor

ImplementationBoundAttributesTask Constructor
ImplementationBoundAttributesTask Class See Also Send Feedback
Initializes a new instance of the ImplementationBoundAttributesTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ImplementationBoundAttributesTask()

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ImplementationBoundAttributesTask Methods

[image]

PostSharp 2.0 Documentation
ImplementationBoundAttributesTask Methods
ImplementationBoundAttributesTask Class See Also Send Feedback

The ImplementationBoundAttributesTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetTask | Gets the ImplementationBoundAttributesTask task in a project.
Public method | IsImplementationBound | Determines whether a custom attribute of a given type is bound to the implementation of the semantic to which it was applied.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

ImplementationBoundAttributesTask..::..Execute Method
ImplementationBoundAttributesTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetTask Method

ImplementationBoundAttributesTask..::..GetTask Method
ImplementationBoundAttributesTask Class See Also Send Feedback
Gets the ImplementationBoundAttributesTask task in a project.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ImplementationBoundAttributesTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
Project.

Return Value

The ImplementationBoundAttributesTask if one was found in the project, or null otherwise.

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IsImplementationBound Method

ImplementationBoundAttributesTask..::..IsImplementationBound Method
ImplementationBoundAttributesTask Class See Also Send Feedback
Determines whether a custom attribute of a given type is bound to the implementation of the semantic to which it was applied.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool IsImplementationBound(
    IType attributeType
)

Parameters

attributeType
Type: PostSharp.Sdk.CodeModel..::.IType
Type of the custom attribute.

Return Value

true if custom attributes of type attributeType are bound to the implementation of the semantic to which they are applied, or false if these custom attributes should be moved to the semantic when semantics are split from implementations.

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ImplementationBoundAttributesTask Properties

[image]

PostSharp 2.0 Documentation
ImplementationBoundAttributesTask Properties
ImplementationBoundAttributesTask Class See Also Send Feedback

The ImplementationBoundAttributesTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

ImplementationBoundAttributesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexGenericInstancesTask Class

IndexGenericInstancesTask Class
Members See Also Send Feedback
Task that references generic instances as tags in generic definitions.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IndexGenericInstancesTask : Task

Remarks

This tasks creates the following back links:

Parent | Children
TypeDefDeclaration | TypeSpecDeclaration.
FieldDefDeclaration | FieldRefDeclaration whose declaring type is a TypeSpecDeclaration.
MethodDefDeclaration | MethodRefDeclaration whose declaring type is a TypeSpecDeclaration; MethodSpecDeclaration.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.IndexGenericInstancesTask

See Also

IndexGenericInstancesTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexGenericInstancesTask Members

[image]

PostSharp 2.0 Documentation
IndexGenericInstancesTask Members
IndexGenericInstancesTask Class Constructors Methods Properties See Also Send Feedback

The IndexGenericInstancesTask type exposes the following members.

Constructors

 | Name | Description
Public method | IndexGenericInstancesTask | Initializes a new instance of the IndexGenericInstancesTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetGenericInstances | Get the collection of generic instances of a given generic declaration.
 | GetTask | Finds the current task in a Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexGenericInstancesTask Constructor

IndexGenericInstancesTask Constructor
IndexGenericInstancesTask Class See Also Send Feedback
Initializes a new instance of the IndexGenericInstancesTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IndexGenericInstancesTask()

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexGenericInstancesTask Methods

[image]

PostSharp 2.0 Documentation
IndexGenericInstancesTask Methods
IndexGenericInstancesTask Class See Also Send Feedback

The IndexGenericInstancesTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetGenericInstances | Get the collection of generic instances of a given generic declaration.
 | GetTask | Finds the current task in a Project.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

IndexGenericInstancesTask..::..Execute Method
IndexGenericInstancesTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetGenericInstances Method

IndexGenericInstancesTask..::..GetGenericInstances Method
IndexGenericInstancesTask Class See Also Send Feedback
Get the collection of generic instances of a given generic declaration.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ICollection<MetadataDeclaration> GetGenericInstances(
    MetadataDeclaration item
)

Parameters

item
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
A generic declaration.

Return Value

The collection of generic instances of item, or null if item has no generic instance in the given module.

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetTask Method

IndexGenericInstancesTask..::..GetTask Method
IndexGenericInstancesTask Class See Also Send Feedback
Finds the current task in a Project.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IndexGenericInstancesTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
A Project.

Return Value

The IndexGenericInstancesTask contained in the project, or null if this project does not contain the current task.

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexGenericInstancesTask Properties

[image]

PostSharp 2.0 Documentation
IndexGenericInstancesTask Properties
IndexGenericInstancesTask Class See Also Send Feedback

The IndexGenericInstancesTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexGenericInstancesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefMemberRefsTask Class

IndexTypeDefMemberRefsTask Class
Members See Also Send Feedback
Indexes all MemberRefs (MemberRefDeclaration) owned by a TypeDef (Type), and relate them to the corresponding FieldDefDeclaration or MethodDefDeclaration.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IndexTypeDefMemberRefsTask : Task

Remarks

It is stupid, but some compilers use a FieldRefDeclaration or a MethodRefDeclaration inside the current module, although they could use a FieldDefDeclaration or a MethodDefDeclaration

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.IndexTypeDefMemberRefsTask

See Also

IndexTypeDefMemberRefsTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefMemberRefsTask Members

[image]

PostSharp 2.0 Documentation
IndexTypeDefMemberRefsTask Members
IndexTypeDefMemberRefsTask Class Constructors Methods Properties See Also Send Feedback

The IndexTypeDefMemberRefsTask type exposes the following members.

Constructors

 | Name | Description
Public method | IndexTypeDefMemberRefsTask | Initializes a new instance of the IndexTypeDefMemberRefsTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetReferences | Gets the collection of MemberRefs (MemberRefDeclaration) that are used to access a given FieldDefDeclaration or MethodDefDeclaration.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefMemberRefsTask Constructor

IndexTypeDefMemberRefsTask Constructor
IndexTypeDefMemberRefsTask Class See Also Send Feedback
Initializes a new instance of the IndexTypeDefMemberRefsTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IndexTypeDefMemberRefsTask()

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefMemberRefsTask Methods

[image]

PostSharp 2.0 Documentation
IndexTypeDefMemberRefsTask Methods
IndexTypeDefMemberRefsTask Class See Also Send Feedback

The IndexTypeDefMemberRefsTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetReferences | Gets the collection of MemberRefs (MemberRefDeclaration) that are used to access a given FieldDefDeclaration or MethodDefDeclaration.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

IndexTypeDefMemberRefsTask..::..Execute Method
IndexTypeDefMemberRefsTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetReferences Method

IndexTypeDefMemberRefsTask..::..GetReferences Method
IndexTypeDefMemberRefsTask Class See Also Send Feedback
Gets the collection of MemberRefs (MemberRefDeclaration) that are used to access a given FieldDefDeclaration or MethodDefDeclaration.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ICollection<MemberRefDeclaration> GetReferences(
    IMember member
)

Parameters

member
Type: PostSharp.Sdk.CodeModel..::.IMember
A FieldDefDeclaration or a MethodDefDeclaration.

Return Value

The collection of MemberRefDeclaration referencing member.

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefMemberRefsTask Properties

[image]

PostSharp 2.0 Documentation
IndexTypeDefMemberRefsTask Properties
IndexTypeDefMemberRefsTask Class See Also Send Feedback

The IndexTypeDefMemberRefsTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexTypeDefMemberRefsTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesInstructions Enumeration

IndexUsagesInstructions Enumeration
See Also Send Feedback
Bit mask of instructions returned by GetUsesWithInstructions(MethodDefDeclaration).

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[FlagsAttribute]
public enum IndexUsagesInstructions

Members

Member name | Value | Description
None | 0 | None.
Ldfld | 1 | Ldfld.
Stfld | 2 | Stfld.
Call | 4 | Call.
Callvirt | 8 | Callvirt.
Newobj | 16 | Newobj.
Ldflda | 32 | Ldflda.

See Also

PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesTask Class

IndexUsagesTask Class
Members See Also Send Feedback
Tasks that references the uses of fields and methods by methods.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class IndexUsagesTask : Task

Remarks

Note that this task only indexes references found in IL instructions, not in metadata tables.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.IndexUsagesTask

See Also

IndexUsagesTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesTask Members

[image]

PostSharp 2.0 Documentation
IndexUsagesTask Members
IndexUsagesTask Class Constructors Methods Properties See Also Send Feedback

The IndexUsagesTask type exposes the following members.

Constructors

 | Name | Description
Public method | IndexUsagesTask | Initializes a new instance of the IndexUsagesTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
 | Execute | Overloaded.
 | GetUsedBy | Gets the collection of methods that use a given declaration.
 | GetUses | Gets the collection of declarations (fields, methods, types) that are used by a method.
 | GetUsesWithInstructions | Gets the collection of declarations (fields, methods, types) that are used by a given method and, for each declaration, the set of instructions that has the declaration as operand.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
 | MoveMethodBody | Method to be called when the body of a method has been moved into another. This methods updates the indexes of uses-used by.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesTask Constructor

IndexUsagesTask Constructor
IndexUsagesTask Class See Also Send Feedback
Initializes a new instance of the IndexUsagesTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IndexUsagesTask()

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesTask Methods

[image]

PostSharp 2.0 Documentation
IndexUsagesTask Methods
IndexUsagesTask Class See Also Send Feedback

The IndexUsagesTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
 | Execute | Overloaded.
 | GetUsedBy | Gets the collection of methods that use a given declaration.
 | GetUses | Gets the collection of declarations (fields, methods, types) that are used by a method.
 | GetUsesWithInstructions | Gets the collection of declarations (fields, methods, types) that are used by a given method and, for each declaration, the set of instructions that has the declaration as operand.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
 | MoveMethodBody | Method to be called when the body of a method has been moved into another. This methods updates the indexes of uses-used by.

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

[image]

PostSharp 2.0 Documentation
IndexUsagesTask..::..Execute Method
IndexUsagesTask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute()()() | Execute the current Task. (Overrides Task..::.Execute()()().)
 | Execute(Project) |

See Also

IndexUsagesTask Class
IndexUsagesTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

IndexUsagesTask..::..Execute Method
IndexUsagesTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

IndexUsagesTask Class
Execute Overload
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method (Project)

IndexUsagesTask..::..Execute Method (Project)
IndexUsagesTask Class See Also Send Feedback

[Missing <summary> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.IndexUsagesTask.Execute(PostSharp.Sdk.Extensibility.Project)"]

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool Execute(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project

[Missing <param name="project"/> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.IndexUsagesTask.Execute(PostSharp.Sdk.Extensibility.Project)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.IndexUsagesTask.Execute(PostSharp.Sdk.Extensibility.Project)"]

See Also

IndexUsagesTask Class
Execute Overload
PostSharp.Sdk.Extensibility.Tasks Namespace


GetUsedBy Method

IndexUsagesTask..::..GetUsedBy Method
IndexUsagesTask Class See Also Send Feedback
Gets the collection of methods that use a given declaration.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ICollection<MethodDefDeclaration> GetUsedBy(
    MetadataDeclaration declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
A field, method or type.

Return Value

The collection of methods that use declaration.

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetUses Method

IndexUsagesTask..::..GetUses Method
IndexUsagesTask Class See Also Send Feedback
Gets the collection of declarations (fields, methods, types) that are used by a method.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static ICollection<MetadataDeclaration> GetUses(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A method.

Return Value

The collection of fields, methods and types used by method.

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetUsesWithInstructions Method

IndexUsagesTask..::..GetUsesWithInstructions Method
IndexUsagesTask Class See Also Send Feedback
Gets the collection of declarations (fields, methods, types) that are used by a given method and, for each declaration, the set of instructions that has the declaration as operand.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerable<KeyValuePair<MetadataDeclaration, IndexUsagesInstructions>> GetUsesWithInstructions(
    MethodDefDeclaration method
)

Parameters

method
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
A method.

Return Value

The collection of fields, methods and types used by method and corresponding bit masks of IndexUsagesInstructions.

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MoveMethodBody Method

IndexUsagesTask..::..MoveMethodBody Method
IndexUsagesTask Class See Also Send Feedback
Method to be called when the body of a method has been moved into another. This methods updates the indexes of uses-used by.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void MoveMethodBody(
    MethodDefDeclaration sourceMethod,
    MethodDefDeclaration targetMethod
)

Parameters

sourceMethod
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
Method to which the body previously belonged.
targetMethod
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
Method to which the body now belongs.

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexUsagesTask Properties

[image]

PostSharp 2.0 Documentation
IndexUsagesTask Properties
IndexUsagesTask Class See Also Send Feedback

The IndexUsagesTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

IndexUsagesTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ModuleAnnotationProvider Class

ModuleAnnotationProvider Class
Members See Also Send Feedback
Implementation of IAnnotationProvider that provides the custom attribute instances defined in the module (i.e. CustomAttributeDeclaration).

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class ModuleAnnotationProvider : Task,
    IAnnotationProvider

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.ModuleAnnotationProvider

See Also

ModuleAnnotationProvider Members
PostSharp.Sdk.Extensibility.Tasks Namespace


ModuleAnnotationProvider Members

[image]

PostSharp 2.0 Documentation
ModuleAnnotationProvider Members
ModuleAnnotationProvider Class Constructors Methods Properties See Also Send Feedback

The ModuleAnnotationProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleAnnotationProvider | Initializes a new instance of the ModuleAnnotationProvider class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetAnnotations | Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ModuleAnnotationProvider Constructor

ModuleAnnotationProvider Constructor
ModuleAnnotationProvider Class See Also Send Feedback
Initializes a new instance of the ModuleAnnotationProvider class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public ModuleAnnotationProvider()

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ModuleAnnotationProvider Methods

[image]

PostSharp 2.0 Documentation
ModuleAnnotationProvider Methods
ModuleAnnotationProvider Class See Also Send Feedback

The ModuleAnnotationProvider type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | GetAnnotations | Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

ModuleAnnotationProvider..::..Execute Method
ModuleAnnotationProvider Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetAnnotations Method

ModuleAnnotationProvider..::..GetAnnotations Method
ModuleAnnotationProvider Class See Also Send Feedback
Enumerates the custom attribute instances (IAnnotationInstance) provided by the current task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public IEnumerator<IAnnotationInstance> GetAnnotations()

Return Value

An enumerator of custom attributes provided by the current task.

Implements

IAnnotationProvider..::.GetAnnotations()()()

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ModuleAnnotationProvider Properties

[image]

PostSharp 2.0 Documentation
ModuleAnnotationProvider Properties
ModuleAnnotationProvider Class See Also Send Feedback

The ModuleAnnotationProvider type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

ModuleAnnotationProvider Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributesComparer Class

MulticastAttributesComparer Class
Members See Also Send Feedback
Provides methods that evaluate if a specific declaration match a value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class MulticastAttributesComparer

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Extensibility.Tasks..::.MulticastAttributesComparer

See Also

MulticastAttributesComparer Members
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributesComparer Members

[image]

PostSharp 2.0 Documentation
MulticastAttributesComparer Members
MulticastAttributesComparer Class Constructors Methods See Also Send Feedback

The MulticastAttributesComparer type exposes the following members.

Constructors

 | Name | Description
Public method | MulticastAttributesComparer | Initializes a new MulticastAttributesComparer.

Methods

 | Name | Description
Public method | CompareEventAttributes | Determines if a given event matches a given value of MulticastAttributes.
Public method | CompareFieldAttributes | Determines if a given field matches a given value of MulticastAttributes.
Public method | CompareMethodAttributes | Determines if a given method matches a given value of MulticastAttributes.
Public method | CompareParameterAttributes | Determines if a given parameter matches a given value of MulticastAttributes.
Public method | ComparePropertyAttributes | Determines if a given property matches a given value of MulticastAttributes.
Public method | CompareTypeAttributes | Determines if a given type matches a given value of MulticastAttributes.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributesComparer Constructor

MulticastAttributesComparer Constructor
MulticastAttributesComparer Class See Also Send Feedback
Initializes a new MulticastAttributesComparer.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributesComparer(
    ModuleDeclaration module
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
Module.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributesComparer Methods

[image]

PostSharp 2.0 Documentation
MulticastAttributesComparer Methods
MulticastAttributesComparer Class See Also Send Feedback

The MulticastAttributesComparer type exposes the following members.

Methods

 | Name | Description
Public method | CompareEventAttributes | Determines if a given event matches a given value of MulticastAttributes.
Public method | CompareFieldAttributes | Determines if a given field matches a given value of MulticastAttributes.
Public method | CompareMethodAttributes | Determines if a given method matches a given value of MulticastAttributes.
Public method | CompareParameterAttributes | Determines if a given parameter matches a given value of MulticastAttributes.
Public method | ComparePropertyAttributes | Determines if a given property matches a given value of MulticastAttributes.
Public method | CompareTypeAttributes | Determines if a given type matches a given value of MulticastAttributes.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompareEventAttributes Method

MulticastAttributesComparer..::..CompareEventAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given event matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CompareEventAttributes(
    MulticastAttributes acceptableAttributes,
    EventDeclaration candidateEvent
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable events.
candidateEvent
Type: PostSharp.Sdk.CodeModel..::.EventDeclaration
The candidate event.

Return Value

true if candidateEvent is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompareFieldAttributes Method

MulticastAttributesComparer..::..CompareFieldAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given field matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CompareFieldAttributes(
    MulticastAttributes acceptableAttributes,
    FieldDefDeclaration candidateField
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable fields.
candidateField
Type: PostSharp.Sdk.CodeModel..::.FieldDefDeclaration
The candidate field.

Return Value

true if candidateField is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompareMethodAttributes Method

MulticastAttributesComparer..::..CompareMethodAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given method matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CompareMethodAttributes(
    MulticastAttributes acceptableAttributes,
    MethodDefDeclaration candidateMethod
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable methods.
candidateMethod
Type: PostSharp.Sdk.CodeModel..::.MethodDefDeclaration
The candidate method.

Return Value

true if candidateMethod is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompareParameterAttributes Method

MulticastAttributesComparer..::..CompareParameterAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given parameter matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CompareParameterAttributes(
    MulticastAttributes acceptableAttributes,
    ParameterDeclaration candidateParameter
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable parameters.
candidateParameter
Type: PostSharp.Sdk.CodeModel..::.ParameterDeclaration
The candidate parameter.

Return Value

true if candidateParameter is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


ComparePropertyAttributes Method

MulticastAttributesComparer..::..ComparePropertyAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given property matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool ComparePropertyAttributes(
    MulticastAttributes acceptableAttributes,
    PropertyDeclaration candidateProperty
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable properties.
candidateProperty
Type: PostSharp.Sdk.CodeModel..::.PropertyDeclaration
The candidate property.

Return Value

true if candidateProperty is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


CompareTypeAttributes Method

MulticastAttributesComparer..::..CompareTypeAttributes Method
MulticastAttributesComparer Class See Also Send Feedback
Determines if a given type matches a given value of MulticastAttributes.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool CompareTypeAttributes(
    MulticastAttributes acceptableAttributes,
    TypeDefDeclaration candidateType
)

Parameters

acceptableAttributes
Type: PostSharp.Extensibility..::.MulticastAttributes
A value of MulticastAttributes specifying acceptable types.
candidateType
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The candidate type.

Return Value

true if candidateType is acceptable with respect to acceptableAttributes, otherwise false.

See Also

MulticastAttributesComparer Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributeTask Class

MulticastAttributeTask Class
Members See Also Send Feedback
This task analyze instances of custom attributes derived from MulticastAttribute and propagate them on their target elements in the custom attribute dictionary (AnnotationRepositoryTask) of this module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class MulticastAttributeTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.MulticastAttributeTask

See Also

MulticastAttributeTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributeTask Members

[image]

PostSharp 2.0 Documentation
MulticastAttributeTask Members
MulticastAttributeTask Class Constructors Methods Properties See Also Send Feedback

The MulticastAttributeTask type exposes the following members.

Constructors

 | Name | Description
Public method | MulticastAttributeTask | Initializes a new instance of the MulticastAttributeTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Overrides Task..::.Initialize()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributeTask Constructor

MulticastAttributeTask Constructor
MulticastAttributeTask Class See Also Send Feedback
Initializes a new instance of the MulticastAttributeTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MulticastAttributeTask()

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributeTask Methods

[image]

PostSharp 2.0 Documentation
MulticastAttributeTask Methods
MulticastAttributeTask Class See Also Send Feedback

The MulticastAttributeTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Overrides Task..::.Initialize()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
MulticastAttributeTask..::..Dispose Method
MulticastAttributeTask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance. (Inherited from Task.)

See Also

MulticastAttributeTask Class
MulticastAttributeTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

MulticastAttributeTask..::..Execute Method
MulticastAttributeTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Initialize Method

MulticastAttributeTask..::..Initialize Method
MulticastAttributeTask Class See Also Send Feedback
Initializes the current task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void Initialize()

Remarks

In case that the task is deserialized from XML, this method is called after Deserialize(XmlElement).

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MulticastAttributeTask Properties

[image]

PostSharp 2.0 Documentation
MulticastAttributeTask Properties
MulticastAttributeTask Class See Also Send Feedback

The MulticastAttributeTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

MulticastAttributeTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveTask Class

RemoveTask Class
Members See Also Send Feedback
Task that remove declarations from the module. Typically called immediately before compilation.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class RemoveTask : Task

Remarks

Declaration removal should be two-phased: first declarations should be marked for removal using the MarkForRemoval(IRemovable) method, then they are removed, typically immediately before compilation, during task execution.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.RemoveTask

See Also

RemoveTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveTask Members

[image]

PostSharp 2.0 Documentation
RemoveTask Members
RemoveTask Class Constructors Methods Properties See Also Send Feedback

The RemoveTask type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveTask | Initializes a new instance of the RemoveTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetTask | Finds the RemoveTask task instance in a Project.
 | IsMarkedForRemoval | Determines whether a declaration has been marked for removal.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | MarkForRemoval | Order a declaration to be removed later by this task.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveTask Constructor

RemoveTask Constructor
RemoveTask Class See Also Send Feedback
Initializes a new instance of the RemoveTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public RemoveTask()

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveTask Methods

[image]

PostSharp 2.0 Documentation
RemoveTask Methods
RemoveTask Class See Also Send Feedback

The RemoveTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
 | GetTask | Finds the RemoveTask task instance in a Project.
 | IsMarkedForRemoval | Determines whether a declaration has been marked for removal.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Public method | MarkForRemoval | Order a declaration to be removed later by this task.

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

RemoveTask..::..Execute Method
RemoveTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetTask Method

RemoveTask..::..GetTask Method
RemoveTask Class See Also Send Feedback
Finds the RemoveTask task instance in a Project.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static RemoveTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
The project.

Return Value

The RemoveTask task instance.

Exceptions

Exception | Condition
System..::.InvalidOperationException | The task Remove is not present in this project.

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IsMarkedForRemoval Method

RemoveTask..::..IsMarkedForRemoval Method
RemoveTask Class See Also Send Feedback
Determines whether a declaration has been marked for removal.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool IsMarkedForRemoval(
    IRemovable declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IRemovable
A declaration.

Return Value

true if declaration has been marked for removal, otherwise false.

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


MarkForRemoval Method

RemoveTask..::..MarkForRemoval Method
RemoveTask Class See Also Send Feedback
Order a declaration to be removed later by this task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void MarkForRemoval(
    IRemovable declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.IRemovable
The declaration that should be removed.

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


RemoveTask Properties

[image]

PostSharp 2.0 Documentation
RemoveTask Properties
RemoveTask Class See Also Send Feedback

The RemoveTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

RemoveTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


TypeHierarchyTask Class

TypeHierarchyTask Class
Members See Also Send Feedback
Analysis that builds an inheritance tree of all types in the module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class TypeHierarchyTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.TypeHierarchyTask

See Also

TypeHierarchyTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


TypeHierarchyTask Members

[image]

PostSharp 2.0 Documentation
TypeHierarchyTask Members
TypeHierarchyTask Class Constructors Methods Properties See Also Send Feedback

The TypeHierarchyTask type exposes the following members.

Constructors

 | Name | Description
Public method | TypeHierarchyTask | Initializes a new instance of the TypeHierarchyTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Inherited from Task.)
 | GetDerivedGenericTypeInstancesEnumerator | Gets an enumerator of derived types of a given a base TypeDefDeclaration. The enumerator returns generic type instances mapped in the context of the given base type.
 | GetDerivedTypesEnumerator | Gets an enumerator of derived types (TypeDefDeclaration), given a TypeDefDeclaration, with the possibility to include types defined outside the module.
 | GetTask | Finds the current task in a Project.
Public method | IndexAllTypeDefinitions | Indexes all TypeDefDeclaration in the current module.
Public method | IndexType | Inserts a given TypeDefDeclaration in the type hierarchy.
Public method | IndexTypeDefDeclarations | Inserts all type declarations (TypeDefDeclaration) in the type hierarchy.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


TypeHierarchyTask Constructor

TypeHierarchyTask Constructor
TypeHierarchyTask Class See Also Send Feedback
Initializes a new instance of the TypeHierarchyTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public TypeHierarchyTask()

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


TypeHierarchyTask Methods

[image]

PostSharp 2.0 Documentation
TypeHierarchyTask Methods
TypeHierarchyTask Class See Also Send Feedback

The TypeHierarchyTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Inherited from Task.)
 | GetDerivedGenericTypeInstancesEnumerator | Gets an enumerator of derived types of a given a base TypeDefDeclaration. The enumerator returns generic type instances mapped in the context of the given base type.
 | GetDerivedTypesEnumerator | Gets an enumerator of derived types (TypeDefDeclaration), given a TypeDefDeclaration, with the possibility to include types defined outside the module.
 | GetTask | Finds the current task in a Project.
Public method | IndexAllTypeDefinitions | Indexes all TypeDefDeclaration in the current module.
Public method | IndexType | Inserts a given TypeDefDeclaration in the type hierarchy.
Public method | IndexTypeDefDeclarations | Inserts all type declarations (TypeDefDeclaration) in the type hierarchy.
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetDerivedGenericTypeInstancesEnumerator Method

TypeHierarchyTask..::..GetDerivedGenericTypeInstancesEnumerator Method
TypeHierarchyTask Class See Also Send Feedback
Gets an enumerator of derived types of a given a base TypeDefDeclaration. The enumerator returns generic type instances mapped in the context of the given base type.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<ITypeSignature> GetDerivedGenericTypeInstancesEnumerator(
    TypeDefDeclaration baseType
)

Parameters

baseType
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The base type.

Return Value

An enumerator of types derived from baseType. Generic arguments of generic type instances are expressed in the context of baseType.

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetDerivedTypesEnumerator Method

TypeHierarchyTask..::..GetDerivedTypesEnumerator Method
TypeHierarchyTask Class See Also Send Feedback
Gets an enumerator of derived types (TypeDefDeclaration), given a TypeDefDeclaration, with the possibility to include types defined outside the module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static IEnumerator<TypeDefDeclaration> GetDerivedTypesEnumerator(
    TypeDefDeclaration baseType,
    bool deep,
    ModuleDeclaration module
)

Parameters

baseType
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration
The base type.
deep
Type: System..::.Boolean
Whether derived types of second and higher level should be returned. If false, only direct descendant of baseType shall be returned.
module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
If non-null, returns only types defined in this module. If null, returns all types.

Return Value

An enumerator of types derived from baseType.

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


GetTask Method

TypeHierarchyTask..::..GetTask Method
TypeHierarchyTask Class See Also Send Feedback
Finds the current task in a Project.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static TypeHierarchyTask GetTask(
    Project project
)

Parameters

project
Type: PostSharp.Sdk.Extensibility..::.Project
A Project.

Return Value

The IndexGenericInstancesTask contained in the project, or null if this project does not contain the current task.

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexAllTypeDefinitions Method

TypeHierarchyTask..::..IndexAllTypeDefinitions Method
TypeHierarchyTask Class See Also Send Feedback
Indexes all TypeDefDeclaration in the current module.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void IndexAllTypeDefinitions()

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexType Method

TypeHierarchyTask..::..IndexType Method
TypeHierarchyTask Class See Also Send Feedback
Inserts a given TypeDefDeclaration in the type hierarchy.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void IndexType(
    TypeDefDeclaration type
)

Parameters

type
Type: PostSharp.Sdk.CodeModel..::.TypeDefDeclaration

[Missing <param name="type"/> documentation for "M:PostSharp.Sdk.Extensibility.Tasks.TypeHierarchyTask.IndexType(PostSharp.Sdk.CodeModel.TypeDefDeclaration)"]

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


IndexTypeDefDeclarations Method

TypeHierarchyTask..::..IndexTypeDefDeclarations Method
TypeHierarchyTask Class See Also Send Feedback
Inserts all type declarations (TypeDefDeclaration) in the type hierarchy.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void IndexTypeDefDeclarations()

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


TypeHierarchyTask Properties

[image]

PostSharp 2.0 Documentation
TypeHierarchyTask Properties
TypeHierarchyTask Class See Also Send Feedback

The TypeHierarchyTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

TypeHierarchyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


VerifyTask Class

VerifyTask Class
Members See Also Send Feedback
Executes PEVERIFY on the compilation output.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class VerifyTask : Task

Remarks

This task is not very useful, because PEVERIFY needs dependencies to be in the same directory as the verified assemblies, which is typically not the case when PostSharp is executed. It is instead preferable to call PEVERIFY from the MSBuild task.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.Extensibility.Tasks..::.VerifyTask

See Also

VerifyTask Members
PostSharp.Sdk.Extensibility.Tasks Namespace


VerifyTask Members

[image]

PostSharp 2.0 Documentation
VerifyTask Members
VerifyTask Class Constructors Methods Properties See Also Send Feedback

The VerifyTask type exposes the following members.

Constructors

 | Name | Description
Public method | VerifyTask | Initializes a new instance of the VerifyTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

VerifyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


VerifyTask Constructor

VerifyTask Constructor
VerifyTask Class See Also Send Feedback
Initializes a new instance of the VerifyTask class

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public VerifyTask()

See Also

VerifyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


VerifyTask Methods

[image]

PostSharp 2.0 Documentation
VerifyTask Methods
VerifyTask Class See Also Send Feedback

The VerifyTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)

See Also

VerifyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


Execute Method

VerifyTask..::..Execute Method
VerifyTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.Extensibility.Tasks
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

VerifyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


VerifyTask Properties

[image]

PostSharp 2.0 Documentation
VerifyTask Properties
VerifyTask Class See Also Send Feedback

The VerifyTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)

See Also

VerifyTask Class
PostSharp.Sdk.Extensibility.Tasks Namespace


PostSharp.Sdk.User Namespace

PostSharp.Sdk.User Namespace
Send Feedback
The PostSharp.Sdk.User namespace contains classes that implement user interaction and CEIP.

Classes

 | Class | Description
Public class | Metric | Encapsulates a metric, i.e. anything that can be measured.
Public class | MetricCollection | Collection of metrics (Metric).
Public class | MetricDateTime | A Metric storing a DateTime value.
Public class | MetricDouble | A Metric storing a Double value.
Public class | MetricInt32 | A Metric storing an Int32 value.
Public class | MetricSet | A Metric storing a set of strings.
Public class | MetricString | A Metric storing a String value.


Metric Class

Metric Class
Members See Also Send Feedback
Encapsulates a metric, i.e. anything that can be measured.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public abstract class Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricDateTime
PostSharp.Sdk.User..::.MetricDouble
PostSharp.Sdk.User..::.MetricInt32
PostSharp.Sdk.User..::.MetricSet
PostSharp.Sdk.User..::.MetricString

See Also

Metric Members
PostSharp.Sdk.User Namespace


Metric Members

[image]

PostSharp 2.0 Documentation
Metric Members
Metric Class Constructors Methods Properties See Also Send Feedback

The Metric type exposes the following members.

Constructors

 | Name | Description
Protected method | Metric | Initializes a new Metric.

Methods

 | Name | Description
Public method | WriteValue | Writes the value of the current metric to a TextWriter.

Properties

 | Name | Description
Public property | Name | Gets the metric name.

See Also

Metric Class
PostSharp.Sdk.User Namespace


Metric Constructor

Metric Constructor
Metric Class See Also Send Feedback
Initializes a new Metric.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected Metric(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:PostSharp.Sdk.User.Metric.#ctor(System.String)"]

See Also

Metric Class
PostSharp.Sdk.User Namespace


Metric Methods

[image]

PostSharp 2.0 Documentation
Metric Methods
Metric Class See Also Send Feedback

The Metric type exposes the following members.

Methods

 | Name | Description
Public method | WriteValue | Writes the value of the current metric to a TextWriter.

See Also

Metric Class
PostSharp.Sdk.User Namespace


WriteValue Method

Metric..::..WriteValue Method
Metric Class See Also Send Feedback
Writes the value of the current metric to a TextWriter.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public virtual void WriteValue(
    TextWriter textWriter
)

Parameters

textWriter
Type: System.IO..::.TextWriter
A TextWriter.

See Also

Metric Class
PostSharp.Sdk.User Namespace


Metric Properties

[image]

PostSharp 2.0 Documentation
Metric Properties
Metric Class See Also Send Feedback

The Metric type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name.

See Also

Metric Class
PostSharp.Sdk.User Namespace


Name Property

Metric..::..Name Property
Metric Class See Also Send Feedback
Gets the metric name.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Name { get; private set; }

See Also

Metric Class
PostSharp.Sdk.User Namespace


MetricCollection Class

MetricCollection Class
Members See Also Send Feedback
Collection of metrics (Metric).

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MetricCollection : KeyedCollection<string, Metric>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Metric >)>)>
System.Collections.ObjectModel..::.KeyedCollection <(Of <(<' String, Metric >)>)>
PostSharp.Sdk.User..::.MetricCollection

See Also

MetricCollection Members
PostSharp.Sdk.User Namespace


MetricCollection Members

[image]

PostSharp 2.0 Documentation
MetricCollection Members
MetricCollection Class Constructors Methods See Also Send Feedback

The MetricCollection type exposes the following members.

Constructors

 | Name | Description
Public method | MetricCollection | Initializes a new instance of the MetricCollection class

Methods

 | Name | Description
Public method | Write | Writes the content of the current collection to a TextWriter.

See Also

MetricCollection Class
PostSharp.Sdk.User Namespace


MetricCollection Constructor

MetricCollection Constructor
MetricCollection Class See Also Send Feedback
Initializes a new instance of the MetricCollection class

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricCollection()

See Also

MetricCollection Class
PostSharp.Sdk.User Namespace


MetricCollection Methods

[image]

PostSharp 2.0 Documentation
MetricCollection Methods
MetricCollection Class See Also Send Feedback

The MetricCollection type exposes the following members.

Methods

 | Name | Description
Public method | Write | Writes the content of the current collection to a TextWriter.

See Also

MetricCollection Class
PostSharp.Sdk.User Namespace


Write Method

MetricCollection..::..Write Method
MetricCollection Class See Also Send Feedback
Writes the content of the current collection to a TextWriter.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Write(
    TextWriter writer
)

Parameters

writer
Type: System.IO..::.TextWriter
A TextWriter.

See Also

MetricCollection Class
PostSharp.Sdk.User Namespace


MetricDateTime Class

MetricDateTime Class
Members See Also Send Feedback
A Metric storing a DateTime value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public class MetricDateTime : Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricDateTime

See Also

MetricDateTime Members
PostSharp.Sdk.User Namespace


MetricDateTime Members

[image]

PostSharp 2.0 Documentation
MetricDateTime Members
MetricDateTime Class Constructors Methods Properties See Also Send Feedback

The MetricDateTime type exposes the following members.

Constructors

 | Name | Description
Public method | MetricDateTime | Overloaded.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricDateTime Class
PostSharp.Sdk.User Namespace


MetricDateTime Constructor

[image]

PostSharp 2.0 Documentation
MetricDateTime Constructor
MetricDateTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetricDateTime(String) | Initializes a new empty MetricDateTime.
Public method | MetricDateTime(String, DateTime) | Initializes a new MetricDateTime and sets its initial value.

See Also

MetricDateTime Class
MetricDateTime Members
PostSharp.Sdk.User Namespace


MetricDateTime Constructor (String)

MetricDateTime Constructor (String)
MetricDateTime Class See Also Send Feedback
Initializes a new empty MetricDateTime.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricDateTime(
    string name
)

Parameters

name
Type: System..::.String
Metric name.

See Also

MetricDateTime Class
MetricDateTime Overload
PostSharp.Sdk.User Namespace


MetricDateTime Constructor (String, DateTime)

MetricDateTime Constructor (String, DateTime)
MetricDateTime Class See Also Send Feedback
Initializes a new MetricDateTime and sets its initial value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricDateTime(
    string name,
    DateTime value
)

Parameters

name
Type: System..::.String
Metric name.
value
Type: System..::.DateTime
Metric value.

See Also

MetricDateTime Class
MetricDateTime Overload
PostSharp.Sdk.User Namespace


MetricDateTime Methods

[image]

PostSharp 2.0 Documentation
MetricDateTime Methods
MetricDateTime Class See Also Send Feedback

The MetricDateTime type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

See Also

MetricDateTime Class
PostSharp.Sdk.User Namespace


ToString Method

MetricDateTime..::..ToString Method
MetricDateTime Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MetricDateTime Class
PostSharp.Sdk.User Namespace


MetricDateTime Properties

[image]

PostSharp 2.0 Documentation
MetricDateTime Properties
MetricDateTime Class See Also Send Feedback

The MetricDateTime type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricDateTime Class
PostSharp.Sdk.User Namespace


Value Property

MetricDateTime..::..Value Property
MetricDateTime Class See Also Send Feedback
Gets or sets the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public DateTime Value { get; set; }

See Also

MetricDateTime Class
PostSharp.Sdk.User Namespace


MetricDouble Class

MetricDouble Class
Members See Also Send Feedback
A Metric storing a Double value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MetricDouble : Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricDouble

See Also

MetricDouble Members
PostSharp.Sdk.User Namespace


MetricDouble Members

[image]

PostSharp 2.0 Documentation
MetricDouble Members
MetricDouble Class Constructors Methods Properties See Also Send Feedback

The MetricDouble type exposes the following members.

Constructors

 | Name | Description
Public method | MetricDouble | Overloaded.

Methods

 | Name | Description
Public method | Increment | Increments the metric value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


MetricDouble Constructor

[image]

PostSharp 2.0 Documentation
MetricDouble Constructor
MetricDouble Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetricDouble(String) | Initializes a new empty MetricDouble.
Public method | MetricDouble(String, Double) | Initializes a new MetricDouble and sets its initial value.

See Also

MetricDouble Class
MetricDouble Members
PostSharp.Sdk.User Namespace


MetricDouble Constructor (String)

MetricDouble Constructor (String)
MetricDouble Class See Also Send Feedback
Initializes a new empty MetricDouble.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricDouble(
    string name
)

Parameters

name
Type: System..::.String
Metric name.

See Also

MetricDouble Class
MetricDouble Overload
PostSharp.Sdk.User Namespace


MetricDouble Constructor (String, Double)

MetricDouble Constructor (String, Double)
MetricDouble Class See Also Send Feedback
Initializes a new MetricDouble and sets its initial value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricDouble(
    string name,
    double value
)

Parameters

name
Type: System..::.String
Metric name.
value
Type: System..::.Double
Metric value.

See Also

MetricDouble Class
MetricDouble Overload
PostSharp.Sdk.User Namespace


MetricDouble Methods

[image]

PostSharp 2.0 Documentation
MetricDouble Methods
MetricDouble Class See Also Send Feedback

The MetricDouble type exposes the following members.

Methods

 | Name | Description
Public method | Increment | Increments the metric value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


Increment Method

MetricDouble..::..Increment Method
MetricDouble Class See Also Send Feedback
Increments the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Increment(
    double increment
)

Parameters

increment
Type: System..::.Double
Number of which the metric Value must be incremented.

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


ToString Method

MetricDouble..::..ToString Method
MetricDouble Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


MetricDouble Properties

[image]

PostSharp 2.0 Documentation
MetricDouble Properties
MetricDouble Class See Also Send Feedback

The MetricDouble type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


Value Property

MetricDouble..::..Value Property
MetricDouble Class See Also Send Feedback
Gets or sets the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public double Value { get; set; }

See Also

MetricDouble Class
PostSharp.Sdk.User Namespace


MetricInt32 Class

MetricInt32 Class
Members See Also Send Feedback
A Metric storing an Int32 value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MetricInt32 : Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricInt32

See Also

MetricInt32 Members
PostSharp.Sdk.User Namespace


MetricInt32 Members

[image]

PostSharp 2.0 Documentation
MetricInt32 Members
MetricInt32 Class Constructors Methods Properties See Also Send Feedback

The MetricInt32 type exposes the following members.

Constructors

 | Name | Description
Public method | MetricInt32 | Overloaded.

Methods

 | Name | Description
Public method | Increment | Increments the metric value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


MetricInt32 Constructor

[image]

PostSharp 2.0 Documentation
MetricInt32 Constructor
MetricInt32 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetricInt32(String) | Initializes a new empty MetricInt32.
Public method | MetricInt32(String, Int32) | Initializes a new MetricInt32 and sets its initial value.

See Also

MetricInt32 Class
MetricInt32 Members
PostSharp.Sdk.User Namespace


MetricInt32 Constructor (String)

MetricInt32 Constructor (String)
MetricInt32 Class See Also Send Feedback
Initializes a new empty MetricInt32.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricInt32(
    string name
)

Parameters

name
Type: System..::.String
Metric name.

See Also

MetricInt32 Class
MetricInt32 Overload
PostSharp.Sdk.User Namespace


MetricInt32 Constructor (String, Int32)

MetricInt32 Constructor (String, Int32)
MetricInt32 Class See Also Send Feedback
Initializes a new MetricInt32 and sets its initial value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricInt32(
    string name,
    int value
)

Parameters

name
Type: System..::.String
Metric name.
value
Type: System..::.Int32
Metric value.

See Also

MetricInt32 Class
MetricInt32 Overload
PostSharp.Sdk.User Namespace


MetricInt32 Methods

[image]

PostSharp 2.0 Documentation
MetricInt32 Methods
MetricInt32 Class See Also Send Feedback

The MetricInt32 type exposes the following members.

Methods

 | Name | Description
Public method | Increment | Increments the metric value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


Increment Method

MetricInt32..::..Increment Method
MetricInt32 Class See Also Send Feedback
Increments the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Increment(
    int increment
)

Parameters

increment
Type: System..::.Int32
Number of which the metric Value must be incremented.

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


ToString Method

MetricInt32..::..ToString Method
MetricInt32 Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


MetricInt32 Properties

[image]

PostSharp 2.0 Documentation
MetricInt32 Properties
MetricInt32 Class See Also Send Feedback

The MetricInt32 type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


Value Property

MetricInt32..::..Value Property
MetricInt32 Class See Also Send Feedback
Gets or sets the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Value { get; set; }

See Also

MetricInt32 Class
PostSharp.Sdk.User Namespace


MetricSet Class

MetricSet Class
Members See Also Send Feedback
A Metric storing a set of strings.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MetricSet : Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricSet

See Also

MetricSet Members
PostSharp.Sdk.User Namespace


MetricSet Members

[image]

PostSharp 2.0 Documentation
MetricSet Members
MetricSet Class Constructors Methods Properties See Also Send Feedback

The MetricSet type exposes the following members.

Constructors

 | Name | Description
Public method | MetricSet | Initializes a new MetricSet.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Overrides Metric..::.WriteValue(TextWriter).)

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Set | Gets the set of values.

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


MetricSet Constructor

MetricSet Constructor
MetricSet Class See Also Send Feedback
Initializes a new MetricSet.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricSet(
    string name
)

Parameters

name
Type: System..::.String
Metric name.

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


MetricSet Methods

[image]

PostSharp 2.0 Documentation
MetricSet Methods
MetricSet Class See Also Send Feedback

The MetricSet type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Overrides Metric..::.WriteValue(TextWriter).)

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


ToString Method

MetricSet..::..ToString Method
MetricSet Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


WriteValue Method

MetricSet..::..WriteValue Method
MetricSet Class See Also Send Feedback
Writes the value of the current metric to a TextWriter.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override void WriteValue(
    TextWriter textWriter
)

Parameters

textWriter
Type: System.IO..::.TextWriter
A TextWriter.

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


MetricSet Properties

[image]

PostSharp 2.0 Documentation
MetricSet Properties
MetricSet Class See Also Send Feedback

The MetricSet type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Set | Gets the set of values.

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


Set Property

MetricSet..::..Set Property
MetricSet Class See Also Send Feedback
Gets the set of values.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Set<string> Set { get; }

See Also

MetricSet Class
PostSharp.Sdk.User Namespace


MetricString Class

MetricString Class
Members See Also Send Feedback
A Metric storing a String value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
[SerializableAttribute]
public sealed class MetricString : Metric

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.User..::.Metric
PostSharp.Sdk.User..::.MetricString

See Also

MetricString Members
PostSharp.Sdk.User Namespace


MetricString Members

[image]

PostSharp 2.0 Documentation
MetricString Members
MetricString Class Constructors Methods Properties See Also Send Feedback

The MetricString type exposes the following members.

Constructors

 | Name | Description
Public method | MetricString | Overloaded.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricString Class
PostSharp.Sdk.User Namespace


MetricString Constructor

[image]

PostSharp 2.0 Documentation
MetricString Constructor
MetricString Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MetricString(String) | Initializes a new empty MetricString.
Public method | MetricString(String, String) | Initializes a new MetricString and sets its initial value.

See Also

MetricString Class
MetricString Members
PostSharp.Sdk.User Namespace


MetricString Constructor (String)

MetricString Constructor (String)
MetricString Class See Also Send Feedback
Initializes a new empty MetricString.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricString(
    string name
)

Parameters

name
Type: System..::.String
Metric name.

See Also

MetricString Class
MetricString Overload
PostSharp.Sdk.User Namespace


MetricString Constructor (String, String)

MetricString Constructor (String, String)
MetricString Class See Also Send Feedback
Initializes a new MetricString and sets its initial value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetricString(
    string name,
    string value
)

Parameters

name
Type: System..::.String
Metric name.
value
Type: System..::.String
Metric value.

See Also

MetricString Class
MetricString Overload
PostSharp.Sdk.User Namespace


MetricString Methods

[image]

PostSharp 2.0 Documentation
MetricString Methods
MetricString Class See Also Send Feedback

The MetricString type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::.ToString()()().)
Public method | WriteValue | Writes the value of the current metric to a TextWriter. (Inherited from Metric.)

See Also

MetricString Class
PostSharp.Sdk.User Namespace


ToString Method

MetricString..::..ToString Method
MetricString Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override string ToString()

Return Value

A String that represents the current Object.

See Also

MetricString Class
PostSharp.Sdk.User Namespace


MetricString Properties

[image]

PostSharp 2.0 Documentation
MetricString Properties
MetricString Class See Also Send Feedback

The MetricString type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the metric name. (Inherited from Metric.)
Public property | Value | Gets or sets the metric value.

See Also

MetricString Class
PostSharp.Sdk.User Namespace


Value Property

MetricString..::..Value Property
MetricString Class See Also Send Feedback
Gets or sets the metric value.

Namespace: PostSharp.Sdk.User
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Value { get; set; }

See Also

MetricString Class
PostSharp.Sdk.User Namespace


PostSharp.Sdk.Utilities Namespace

PostSharp.Sdk.Utilities Namespace
Send Feedback
The PostSharp.Sdk.Utilities namespace contains various utility classes.

Classes

 | Class | Description
Public class | DebuggerSpecialNames | Generates special names recognized by the debugger.
Public class | ExceptionContext | Maintains a stack of context information related to an exception. The catch block of an exception handler should call Push(String, array<Object>[]()[]) and rethrow the exception.
Public class | ExceptionHelper | Provides methods that retrieve exception messages from an embedded resource and throws an exception.
Public class | MsilWriterUtility | Provides methods that writes the MSIL code corresponding to an object to a TextWriter.

Enumerations

 | Enumeration | Description
Public enumeration | DebuggerSpecialDeclarationKind | Enumeration of kinds of debugger special names for declarations.
Public enumeration | DebuggerSpecialVariableKind | Enumeration of kinds of debugger special names for local variables.


DebuggerSpecialDeclarationKind Enumeration

DebuggerSpecialDeclarationKind Enumeration
See Also Send Feedback
Enumeration of kinds of debugger special names for declarations.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum DebuggerSpecialDeclarationKind

Members

Member name | Value | Description
IteratorState | 0 |
CurrentIteratorValue | 1 |
IteratorParameter | 2 |
HoistedThis | 3 |
HoistedLocal | 4 |
HoistedLocalOuterScope | 5 |
HoistedWrapperValue | 6 |
ClosureClassInstance | 7 |
CachedDelegateInstance | 8 |
IteratorInstance | 9 |
AnonymousMethod | 10 |
AnonymousMethodClosureClass | 11 |
IteratorClass | 12 |
FixedBufferStruct | 13 |
AnonymousType | 14 |
InitializerLocal | 15 |
QueryExpressionTemporary | 16 |
AnonymousTypeField | 17 |
AnonymousTypeTypeParameter | 18 |
AutomaticPropertyBackingField | 19 |
IteratorThreadId | 20 |
IteratorFinally | 21 |
FabricatedMethod | 22 |
DynamicContainerClass | 23 |
DynamicCallSite | 24 |
DynamicDelegate | 25 |
ComRefCallLocal | 26 |
LockTakenLocal | 27 |
Other | 28 |

See Also

PostSharp.Sdk.Utilities Namespace


DebuggerSpecialNames Class

DebuggerSpecialNames Class
Members See Also Send Feedback
Generates special names recognized by the debugger.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class DebuggerSpecialNames

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Utilities..::.DebuggerSpecialNames

See Also

DebuggerSpecialNames Members
PostSharp.Sdk.Utilities Namespace


DebuggerSpecialNames Members

[image]

PostSharp 2.0 Documentation
DebuggerSpecialNames Members
DebuggerSpecialNames Class Methods See Also Send Feedback

The DebuggerSpecialNames type exposes the following members.

Methods

Name | Description
GetDeclarationSpecialName | Generates a special debugger name for a declaration.
GetVariableSpecialName | Generates a special debugger name for a local variable.

See Also

DebuggerSpecialNames Class
PostSharp.Sdk.Utilities Namespace


DebuggerSpecialNames Methods

[image]

PostSharp 2.0 Documentation
DebuggerSpecialNames Methods
DebuggerSpecialNames Class See Also Send Feedback

The DebuggerSpecialNames type exposes the following members.

Methods

Name | Description
GetDeclarationSpecialName | Generates a special debugger name for a declaration.
GetVariableSpecialName | Generates a special debugger name for a local variable.

See Also

DebuggerSpecialNames Class
PostSharp.Sdk.Utilities Namespace


GetDeclarationSpecialName Method

DebuggerSpecialNames..::..GetDeclarationSpecialName Method
DebuggerSpecialNames Class See Also Send Feedback
Generates a special debugger name for a declaration.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetDeclarationSpecialName(
    string suffix,
    string displayName,
    DebuggerSpecialDeclarationKind kind
)

Parameters

suffix
Type: System..::.String
Suffix.
displayName
Type: System..::.String
Display name.
kind
Type: PostSharp.Sdk.Utilities..::.DebuggerSpecialDeclarationKind
Kind of member.

Return Value

The requested special debugger name.

See Also

DebuggerSpecialNames Class
PostSharp.Sdk.Utilities Namespace


GetVariableSpecialName Method

DebuggerSpecialNames..::..GetVariableSpecialName Method
DebuggerSpecialNames Class See Also Send Feedback
Generates a special debugger name for a local variable.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string GetVariableSpecialName(
    string suffix,
    DebuggerSpecialVariableKind kind
)

Parameters

suffix
Type: System..::.String
Suffix.
kind
Type: PostSharp.Sdk.Utilities..::.DebuggerSpecialVariableKind
Kind of member.

Return Value

The requested special debugger name.

See Also

DebuggerSpecialNames Class
PostSharp.Sdk.Utilities Namespace


DebuggerSpecialVariableKind Enumeration

DebuggerSpecialVariableKind Enumeration
See Also Send Feedback
Enumeration of kinds of debugger special names for local variables.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum DebuggerSpecialVariableKind

Members

Member name | Value | Description
ShortLived | 0 |
ReturnValue | 1 |
Lock | 2 |
Using | 3 |
Durable | 4 |
EnumeratorResult | 5 |
ForEachArrayStorage | 6 |
ForEachIndexStorage | 7 |

See Also

PostSharp.Sdk.Utilities Namespace


ExceptionContext Class

ExceptionContext Class
Members See Also Send Feedback
Maintains a stack of context information related to an exception. The catch block of an exception handler should call Push(String, array<Object>[]()[]) and rethrow the exception.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class ExceptionContext

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Utilities..::.ExceptionContext

See Also

ExceptionContext Members
PostSharp.Sdk.Utilities Namespace


ExceptionContext Members

[image]

PostSharp 2.0 Documentation
ExceptionContext Members
ExceptionContext Class Methods See Also Send Feedback

The ExceptionContext type exposes the following members.

Methods

Name | Description
Clear | Clear the context stack.
GetStack | Gets the messages on the stack.
Push | Pushes a new information message to the exception stack. This method is typically invoked from an exception handler, which rethrows the exception afterward.

See Also

ExceptionContext Class
PostSharp.Sdk.Utilities Namespace


ExceptionContext Methods

[image]

PostSharp 2.0 Documentation
ExceptionContext Methods
ExceptionContext Class See Also Send Feedback

The ExceptionContext type exposes the following members.

Methods

Name | Description
Clear | Clear the context stack.
GetStack | Gets the messages on the stack.
Push | Pushes a new information message to the exception stack. This method is typically invoked from an exception handler, which rethrows the exception afterward.

See Also

ExceptionContext Class
PostSharp.Sdk.Utilities Namespace


Clear Method

ExceptionContext..::..Clear Method
ExceptionContext Class See Also Send Feedback
Clear the context stack.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Clear()

See Also

ExceptionContext Class
PostSharp.Sdk.Utilities Namespace


GetStack Method

ExceptionContext..::..GetStack Method
ExceptionContext Class See Also Send Feedback
Gets the messages on the stack.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static string[] GetStack()

Return Value

An array containing the information messages currently on the stack.

See Also

ExceptionContext Class
PostSharp.Sdk.Utilities Namespace


Push Method

ExceptionContext..::..Push Method
ExceptionContext Class See Also Send Feedback
Pushes a new information message to the exception stack. This method is typically invoked from an exception handler, which rethrows the exception afterward.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Push(
    string format,
    params Object[] arguments
)

Parameters

format
Type: System..::.String
Format string.
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the format string.

See Also

ExceptionContext Class
PostSharp.Sdk.Utilities Namespace


ExceptionHelper Class

ExceptionHelper Class
Members See Also Send Feedback
Provides methods that retrieve exception messages from an embedded resource and throws an exception.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class ExceptionHelper

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Utilities..::.ExceptionHelper

See Also

ExceptionHelper Members
PostSharp.Sdk.Utilities Namespace


ExceptionHelper Members

[image]

PostSharp 2.0 Documentation
ExceptionHelper Members
ExceptionHelper Class Constructors Methods See Also Send Feedback

The ExceptionHelper type exposes the following members.

Constructors

 | Name | Description
Protected method | ExceptionHelper | Initializes a new ExceptionHelper.

Methods

 | Name | Description
Public method | Assert | Throws an AssertionFailedException if a condition is not fulfilled.
 | AssertArgumentNotEmptyOrNull | Throws an ArgumentNullException if a string reference is null or if the referenced string is empty.
 | AssertArgumentNotNull | Overloaded.
Public method | AssertValidArgument | Throws an ArgumentException if a condition is not fulfilled.
Public method | AssertValidOperation | Conditionally throws an InvalidOperationException (message with parameters).
 | Assume | Tells the static analyzer that the given condition is trusted to be true.
 | AssumeNotNull<(Of <(T>)>) | Tells the static analyzer that the given reference is trusted to be non-null.
 | AssumeNotNullExpression<(Of <(T>)>) | Tells the static analyzer that the given reference is trusted to be non-null.
Public method | CreateArgumentException | Creates an ArgumentException.
Public method | CreateAssemblyLoadException | Creates an BindingException.
Public method | CreateAssemblyLoadExceptionException | Creates an BindingException and includes an inner exception.
Public method | CreateAssertionFailedException | Creates an AssertionFailedException and reads the message from the resource manager.
Public method | CreateBindingException | Overloaded.
Public method | CreateFileNotFoundException | Creates an FileNotFoundException.
 | CreateInvalidEnumerationValueException | Creates an AssertionFailedException with a message telling that an enumeration contained an unexpected value.
Public method | CreateInvalidOperationException | Creates an InvalidOperationException.
 | ExecuteUserCode | Executes a given Action, catches exceptions and replace them by a fatal error message.
 | ExecuteUserCode<(Of <(T>)>) | Executes a given Func<(Of <(TResult>)>), catches exceptions and replace them by a fatal error message.
Protected method | GetMessage | Overloaded.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


ExceptionHelper Constructor

ExceptionHelper Constructor
ExceptionHelper Class See Also Send Feedback
Initializes a new ExceptionHelper.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected ExceptionHelper(
    ResourceManager resourceManager
)

Parameters

resourceManager
Type: System.Resources..::.ResourceManager
Resources containing message definitions.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


ExceptionHelper Methods

[image]

PostSharp 2.0 Documentation
ExceptionHelper Methods
ExceptionHelper Class See Also Send Feedback

The ExceptionHelper type exposes the following members.

Methods

 | Name | Description
Public method | Assert | Throws an AssertionFailedException if a condition is not fulfilled.
 | AssertArgumentNotEmptyOrNull | Throws an ArgumentNullException if a string reference is null or if the referenced string is empty.
 | AssertArgumentNotNull | Overloaded.
Public method | AssertValidArgument | Throws an ArgumentException if a condition is not fulfilled.
Public method | AssertValidOperation | Conditionally throws an InvalidOperationException (message with parameters).
 | Assume | Tells the static analyzer that the given condition is trusted to be true.
 | AssumeNotNull<(Of <(T>)>) | Tells the static analyzer that the given reference is trusted to be non-null.
 | AssumeNotNullExpression<(Of <(T>)>) | Tells the static analyzer that the given reference is trusted to be non-null.
Public method | CreateArgumentException | Creates an ArgumentException.
Public method | CreateAssemblyLoadException | Creates an BindingException.
Public method | CreateAssemblyLoadExceptionException | Creates an BindingException and includes an inner exception.
Public method | CreateAssertionFailedException | Creates an AssertionFailedException and reads the message from the resource manager.
Public method | CreateBindingException | Overloaded.
Public method | CreateFileNotFoundException | Creates an FileNotFoundException.
 | CreateInvalidEnumerationValueException | Creates an AssertionFailedException with a message telling that an enumeration contained an unexpected value.
Public method | CreateInvalidOperationException | Creates an InvalidOperationException.
 | ExecuteUserCode | Executes a given Action, catches exceptions and replace them by a fatal error message.
 | ExecuteUserCode<(Of <(T>)>) | Executes a given Func<(Of <(TResult>)>), catches exceptions and replace them by a fatal error message.
Protected method | GetMessage | Overloaded.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


Assert Method

ExceptionHelper..::..Assert Method
ExceptionHelper Class See Also Send Feedback
Throws an AssertionFailedException if a condition is not fulfilled.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void Assert(
    bool condition,
    string messageKey,
    params Object[] arguments
)

Parameters

condition
Type: System..::.Boolean
Condition. Should be true, otherwise an exception is thrown.
messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


AssertArgumentNotEmptyOrNull Method

ExceptionHelper..::..AssertArgumentNotEmptyOrNull Method
ExceptionHelper Class See Also Send Feedback
Throws an ArgumentNullException if a string reference is null or if the referenced string is empty.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AssertArgumentNotEmptyOrNull(
    string value,
    string parameterName
)

Parameters

value
Type: System..::.String
A string reference.
parameterName
Type: System..::.String
Parameter name.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


AssertArgumentNotNull Method

[image]

PostSharp 2.0 Documentation
ExceptionHelper..::..AssertArgumentNotNull Method
ExceptionHelper Class See Also Send Feedback

Overload List

Name | Description
AssertArgumentNotNull(Object, String) | Throws an ArgumentNullException if a reference is null.
AssertArgumentNotNull(Void*, String) | Throws an ArgumentNullException if a pointer is null.

See Also

ExceptionHelper Class
ExceptionHelper Members
PostSharp.Sdk.Utilities Namespace


AssertArgumentNotNull Method (Object, String)

ExceptionHelper..::..AssertArgumentNotNull Method (Object, String)
ExceptionHelper Class See Also Send Feedback
Throws an ArgumentNullException if a reference is null.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AssertArgumentNotNull(
    Object value,
    string parameterName
)

Parameters

value
Type: System..::.Object
An object reference.
parameterName
Type: System..::.String
Parameter name.

See Also

ExceptionHelper Class
AssertArgumentNotNull Overload
PostSharp.Sdk.Utilities Namespace


AssertArgumentNotNull Method (Void*, String)

ExceptionHelper..::..AssertArgumentNotNull Method (Void*, String)
ExceptionHelper Class See Also Send Feedback
Throws an ArgumentNullException if a pointer is null.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AssertArgumentNotNull(
    void* value,
    string parameterName
)

Parameters

value
Type: System..::.Void *
A pointer.
parameterName
Type: System..::.String
Parameter name.

See Also

ExceptionHelper Class
AssertArgumentNotNull Overload
PostSharp.Sdk.Utilities Namespace


AssertValidArgument Method

ExceptionHelper..::..AssertValidArgument Method
ExceptionHelper Class See Also Send Feedback
Throws an ArgumentException if a condition is not fulfilled.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AssertValidArgument(
    bool condition,
    string parameterName,
    string messageKey,
    params Object[] arguments
)

Parameters

condition
Type: System..::.Boolean
Condition. Should be true, otherwise an exception is thrown.
parameterName
Type: System..::.String
Name of the tested parameter.
messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


AssertValidOperation Method

ExceptionHelper..::..AssertValidOperation Method
ExceptionHelper Class See Also Send Feedback
Conditionally throws an InvalidOperationException (message with parameters).

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void AssertValidOperation(
    bool condition,
    string messageKey,
    params Object[] arguments
)

Parameters

condition
Type: System..::.Boolean
false to throw the exception, otherwise true.
messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


Assume Method

ExceptionHelper..::..Assume Method
ExceptionHelper Class See Also Send Feedback
Tells the static analyzer that the given condition is trusted to be true.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void Assume(
    bool condition
)

Parameters

condition
Type: System..::.Boolean
An condition.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


AssumeNotNull(T) Method

ExceptionHelper..::..AssumeNotNull<(Of <(<'T>)>)> Method
ExceptionHelper Class See Also Send Feedback
Tells the static analyzer that the given reference is trusted to be non-null.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void AssumeNotNull<T>(
    T value
)

Parameters

value
Type: T
An object reference.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.AssumeNotNull``1(``0)"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


AssumeNotNullExpression(T) Method

ExceptionHelper..::..AssumeNotNullExpression<(Of <(<'T>)>)> Method
ExceptionHelper Class See Also Send Feedback
Tells the static analyzer that the given reference is trusted to be non-null.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static T AssumeNotNullExpression<T>(
    T value
)

Parameters

value
Type: T
An object reference.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.AssumeNotNullExpression``1(``0)"]

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.AssumeNotNullExpression``1(``0)"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateArgumentException Method

ExceptionHelper..::..CreateArgumentException Method
ExceptionHelper Class See Also Send Feedback
Creates an ArgumentException.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateArgumentException(
    string parameterName,
    string messageKey,
    params Object[] arguments
)

Parameters

parameterName
Type: System..::.String
Name of the incorrect parameter.
messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateArgumentException(System.String,System.String,System.Object[])"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateAssemblyLoadException Method

ExceptionHelper..::..CreateAssemblyLoadException Method
ExceptionHelper Class See Also Send Feedback
Creates an BindingException.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateAssemblyLoadException(
    string messageKey,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateAssemblyLoadException(System.String,System.Object[])"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateAssemblyLoadExceptionException Method

ExceptionHelper..::..CreateAssemblyLoadExceptionException Method
ExceptionHelper Class See Also Send Feedback
Creates an BindingException and includes an inner exception.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateAssemblyLoadExceptionException(
    string messageKey,
    Exception innerException,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
innerException
Type: System..::.Exception
The exception that is wrapped by the new exception.
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateAssemblyLoadExceptionException(System.String,System.Exception,System.Object[])"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateAssertionFailedException Method

ExceptionHelper..::..CreateAssertionFailedException Method
ExceptionHelper Class See Also Send Feedback
Creates an AssertionFailedException and reads the message from the resource manager.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateAssertionFailedException(
    string messageKey,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

An AssertionFailedException.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateBindingException Method

[image]

PostSharp 2.0 Documentation
ExceptionHelper..::..CreateBindingException Method
ExceptionHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBindingException(String, array<Object>[]()[]) | Creates an BindingException.
Public method | CreateBindingException(String, Exception, array<Object>[]()[]) | Creates an BindingException and includes an inner exception.

See Also

ExceptionHelper Class
ExceptionHelper Members
PostSharp.Sdk.Utilities Namespace


CreateBindingException Method (String, Object[])

ExceptionHelper..::..CreateBindingException Method (String, array<Object>[]()[][])
ExceptionHelper Class See Also Send Feedback
Creates an BindingException.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateBindingException(
    string messageKey,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateBindingException(System.String,System.Object[])"]

See Also

ExceptionHelper Class
CreateBindingException Overload
PostSharp.Sdk.Utilities Namespace


CreateBindingException Method (String, Exception, Object[])

ExceptionHelper..::..CreateBindingException Method (String, Exception, array<Object>[]()[][])
ExceptionHelper Class See Also Send Feedback
Creates an BindingException and includes an inner exception.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateBindingException(
    string messageKey,
    Exception innerException,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
innerException
Type: System..::.Exception
The exception that is wrapped by the new exception.
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateBindingException(System.String,System.Exception,System.Object[])"]

See Also

ExceptionHelper Class
CreateBindingException Overload
PostSharp.Sdk.Utilities Namespace


CreateFileNotFoundException Method

ExceptionHelper..::..CreateFileNotFoundException Method
ExceptionHelper Class See Also Send Feedback
Creates an FileNotFoundException.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateFileNotFoundException(
    string fileName,
    string messageKey,
    params Object[] arguments
)

Parameters

fileName
Type: System..::.String
Path of the file that was not found.
messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateFileNotFoundException(System.String,System.String,System.Object[])"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateInvalidEnumerationValueException Method

ExceptionHelper..::..CreateInvalidEnumerationValueException Method
ExceptionHelper Class See Also Send Feedback
Creates an AssertionFailedException with a message telling that an enumeration contained an unexpected value.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static Exception CreateInvalidEnumerationValueException(
    Object value,
    string location
)

Parameters

value
Type: System..::.Object
Enumeration value.
location
Type: System..::.String
Name of the variable or field containing the enumeration value.

Return Value

An AssertionFailedException.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


CreateInvalidOperationException Method

ExceptionHelper..::..CreateInvalidOperationException Method
ExceptionHelper Class See Also Send Feedback
Creates an InvalidOperationException.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Exception CreateInvalidOperationException(
    string messageKey,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message. The message may contain arguments like {0}, {1}, ...
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

[Missing <returns> documentation for "M:PostSharp.Sdk.Utilities.ExceptionHelper.CreateInvalidOperationException(System.String,System.Object[])"]

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


ExecuteUserCode Method

ExceptionHelper..::..ExecuteUserCode Method
ExceptionHelper Class See Also Send Feedback
Executes a given Action, catches exceptions and replace them by a fatal error message.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void ExecuteUserCode(
    Action userCode,
    params Type[] acceptableExceptions
)

Parameters

userCode
Type: System..::.Action
A delegate executing user code.
acceptableExceptions
Type: array< System..::.Type >[]()[][]
Array of types of exceptions that should not be replaced by a fatal error message.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


ExecuteUserCode(T) Method

ExceptionHelper..::..ExecuteUserCode<(Of <(<'T>)>)> Method
ExceptionHelper Class See Also Send Feedback
Executes a given Func<(Of <(TResult>)>), catches exceptions and replace them by a fatal error message.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static T ExecuteUserCode<T>(
    Func<T> userCode,
    params Type[] acceptableExceptions
)

Parameters

userCode
Type: System..::.Func <(Of <(<'T>)>)>
A delegate executing user code.
acceptableExceptions
Type: array< System..::.Type >[]()[][]
Array of types of exceptions that should not be replaced by a fatal error message.

Type Parameters

T
Type of the return value of userCode.

Return Value

The return value of userCode.

See Also

ExceptionHelper Class
PostSharp.Sdk.Utilities Namespace


GetMessage Method

[image]

PostSharp 2.0 Documentation
ExceptionHelper..::..GetMessage Method
ExceptionHelper Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetMessage(String) | Gets an exception message.
Protected method | GetMessage(String, array<Object>[]()[]) | Gets an exception message from resources and format it using arguments.

See Also

ExceptionHelper Class
ExceptionHelper Members
PostSharp.Sdk.Utilities Namespace


GetMessage Method (String)

ExceptionHelper..::..GetMessage Method (String)
ExceptionHelper Class See Also Send Feedback
Gets an exception message.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected string GetMessage(
    string messageKey
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message.

Return Value

The message corresponding to messageKey. The text may be a formatting string containing parameters like {0}, {1}, ...

See Also

ExceptionHelper Class
GetMessage Overload
PostSharp.Sdk.Utilities Namespace


GetMessage Method (String, Object[])

ExceptionHelper..::..GetMessage Method (String, array<Object>[]()[][])
ExceptionHelper Class See Also Send Feedback
Gets an exception message from resources and format it using arguments.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected string GetMessage(
    string messageKey,
    params Object[] arguments
)

Parameters

messageKey
Type: System..::.String
Key of the resource string containing the message.
arguments
Type: array< System..::.Object >[]()[][]
Arguments of the formatting string.

Return Value

The message corresponding to messageKey formatted using arguments.

See Also

ExceptionHelper Class
GetMessage Overload
PostSharp.Sdk.Utilities Namespace


MsilWriterUtility Class

MsilWriterUtility Class
Members See Also Send Feedback
Provides methods that writes the MSIL code corresponding to an object to a TextWriter.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static class MsilWriterUtility

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.Utilities..::.MsilWriterUtility

See Also

MsilWriterUtility Members
PostSharp.Sdk.Utilities Namespace


MsilWriterUtility Members

[image]

PostSharp 2.0 Documentation
MsilWriterUtility Members
MsilWriterUtility Class Methods See Also Send Feedback

The MsilWriterUtility type exposes the following members.

Methods

Name | Description
CanWriteMsil | Determines whether it is possible to generate MSIL instructions for a given object.
WriteMsil | Writes the MSIL code corresponding to a given object.

See Also

MsilWriterUtility Class
PostSharp.Sdk.Utilities Namespace


MsilWriterUtility Methods

[image]

PostSharp 2.0 Documentation
MsilWriterUtility Methods
MsilWriterUtility Class See Also Send Feedback

The MsilWriterUtility type exposes the following members.

Methods

Name | Description
CanWriteMsil | Determines whether it is possible to generate MSIL instructions for a given object.
WriteMsil | Writes the MSIL code corresponding to a given object.

See Also

MsilWriterUtility Class
PostSharp.Sdk.Utilities Namespace


CanWriteMsil Method

MsilWriterUtility..::..CanWriteMsil Method
MsilWriterUtility Class See Also Send Feedback
Determines whether it is possible to generate MSIL instructions for a given object.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static bool CanWriteMsil(
    Object declaration
)

Parameters

declaration
Type: System..::.Object
An element of code.

Return Value

true if it is possible to call WriteMsil(Object, TextWriter) for this declaration, otherwise false.

See Also

MsilWriterUtility Class
PostSharp.Sdk.Utilities Namespace


WriteMsil Method

MsilWriterUtility..::..WriteMsil Method
MsilWriterUtility Class See Also Send Feedback
Writes the MSIL code corresponding to a given object.

Namespace: PostSharp.Sdk.Utilities
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static void WriteMsil(
    Object declaration,
    TextWriter writer
)

Parameters

declaration
Type: System..::.Object
An element of code.
writer
Type: System.IO..::.TextWriter
A TextWriter.

See Also

MsilWriterUtility Class
PostSharp.Sdk.Utilities Namespace


PostSharp.Sdk.WeavingSymbols Namespace

PostSharp.Sdk.WeavingSymbols Namespace
Send Feedback

[Missing <summary> documentation for "N:PostSharp.Sdk.WeavingSymbols"]

Classes

 | Class | Description
Public class | SymAspectClass | Represents an aspect class (typically, a type or a method) in a symbol document.
Public class | SymAspectInstance | Represents an aspect instance in a symbol file. This concept corresponds to AspectInstance.
Public class | SymAspectModule | Represents a symbol document, associated with a single ModuleDeclaration.
Public class | SymAspectOrigin | Represents a location in a source artifact.
Public class | SymAspectUsage | Represents an aspect usage in a symbol document. A SymAspectUsage corresponds to an instance of custom attribute, which in turn can be applied to multiple targets and generate multiple aspect instances (SymAspectInstance).
Public class | SymEvolution | Represents an evolution of a metadata element, for instance when a field is transformed into a property, or when a declaration is renamed.
Public class | SymJoinPoint | Represents a join point in a symbol document, i.e. the information that a declaration has been advised by another declaration, as a part of transformations provided by a SymAspectInstance.
Public class | WriteWeavingSymbolsTask | Task that writes the symbol file.

Enumerations

 | Enumeration | Description
Public enumeration | SymEvolutionKind | Kinds of evolutions represented by SymEvolution.


SymAspectClass Class

SymAspectClass Class
Members See Also Send Feedback
Represents an aspect class (typically, a type or a method) in a symbol document.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymAspectClass : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymAspectClass

See Also

SymAspectClass Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectClass Members

[image]

PostSharp 2.0 Documentation
SymAspectClass Members
SymAspectClass Class Constructors Methods Properties See Also Send Feedback

The SymAspectClass type exposes the following members.

Constructors

 | Name | Description
Public method | SymAspectClass | Initializes a new SymAspectClass.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)

Properties

 | Name | Description
Public property | ClassDeclaration | Gets the declaration (typically, type or method) represented by this SymAspectClass.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Usages | Gets the set of aspect usages in the current aspect class.

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectClass Constructor

SymAspectClass Constructor
SymAspectClass Class See Also Send Feedback
Initializes a new SymAspectClass.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectClass(
    MetadataDeclaration classDeclaration
)

Parameters

classDeclaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
The class (type or method, typically).

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectClass Methods

[image]

PostSharp 2.0 Documentation
SymAspectClass Methods
SymAspectClass Class See Also Send Feedback

The SymAspectClass type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectClass Properties

[image]

PostSharp 2.0 Documentation
SymAspectClass Properties
SymAspectClass Class See Also Send Feedback

The SymAspectClass type exposes the following members.

Properties

 | Name | Description
Public property | ClassDeclaration | Gets the declaration (typically, type or method) represented by this SymAspectClass.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Usages | Gets the set of aspect usages in the current aspect class.

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


ClassDeclaration Property

SymAspectClass..::..ClassDeclaration Property
SymAspectClass Class See Also Send Feedback
Gets the declaration (typically, type or method) represented by this SymAspectClass.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration ClassDeclaration { get; private set; }

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


Usages Property

SymAspectClass..::..Usages Property
SymAspectClass Class See Also Send Feedback
Gets the set of aspect usages in the current aspect class.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsageCollection Usages { get; }

See Also

SymAspectClass Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectInstance Class

SymAspectInstance Class
Members See Also Send Feedback
Represents an aspect instance in a symbol file. This concept corresponds to AspectInstance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SymAspectInstance : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymAspectInstance

See Also

SymAspectInstance Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectInstance Members

[image]

PostSharp 2.0 Documentation
SymAspectInstance Members
SymAspectInstance Class Constructors Methods Properties See Also Send Feedback

The SymAspectInstance type exposes the following members.

Constructors

 | Name | Description
Public method | SymAspectInstance | Initializes a new SymAspectInstance.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | JoinPoints | Gets the collection of join points affected by the current aspect instance.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentUsage | Gets the parent SymAspectUsage.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TargetDeclaration | Gets the declaration to which the aspect instance is applied.

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectInstance Constructor

SymAspectInstance Constructor
SymAspectInstance Class See Also Send Feedback
Initializes a new SymAspectInstance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectInstance(
    MetadataDeclaration targetDeclaration
)

Parameters

targetDeclaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration to which the aspect instance has been applied.

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectInstance Methods

[image]

PostSharp 2.0 Documentation
SymAspectInstance Methods
SymAspectInstance Class See Also Send Feedback

The SymAspectInstance type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectInstance Properties

[image]

PostSharp 2.0 Documentation
SymAspectInstance Properties
SymAspectInstance Class See Also Send Feedback

The SymAspectInstance type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | JoinPoints | Gets the collection of join points affected by the current aspect instance.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentUsage | Gets the parent SymAspectUsage.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | TargetDeclaration | Gets the declaration to which the aspect instance is applied.

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


JoinPoints Property

SymAspectInstance..::..JoinPoints Property
SymAspectInstance Class See Also Send Feedback
Gets the collection of join points affected by the current aspect instance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymJoinPointCollection JoinPoints { get; }

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


ParentUsage Property

SymAspectInstance..::..ParentUsage Property
SymAspectInstance Class See Also Send Feedback
Gets the parent SymAspectUsage.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsage ParentUsage { get; }

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


TargetDeclaration Property

SymAspectInstance..::..TargetDeclaration Property
SymAspectInstance Class See Also Send Feedback
Gets the declaration to which the aspect instance is applied.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration TargetDeclaration { get; private set; }

See Also

SymAspectInstance Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectModule Class

SymAspectModule Class
Members See Also Send Feedback
Represents a symbol document, associated with a single ModuleDeclaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymAspectModule : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymAspectModule

See Also

SymAspectModule Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectModule Members

[image]

PostSharp 2.0 Documentation
SymAspectModule Members
SymAspectModule Class Methods Properties See Also Send Feedback

The SymAspectModule type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
 | GetInstance | Gets the SymAspectModule associated to a ModuleDeclaration; create a new one if requested and necessary.

Properties

 | Name | Description
Public property | AspectClasses | Gets the collection of aspect classes (SymAspectClass) in the current module.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Evolutions | Gets the collection of evolutions (SymEvolutionCollection) in the current module.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectModule Methods

[image]

PostSharp 2.0 Documentation
SymAspectModule Methods
SymAspectModule Class See Also Send Feedback

The SymAspectModule type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
 | GetInstance | Gets the SymAspectModule associated to a ModuleDeclaration; create a new one if requested and necessary.

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


GetInstance Method

SymAspectModule..::..GetInstance Method
SymAspectModule Class See Also Send Feedback
Gets the SymAspectModule associated to a ModuleDeclaration; create a new one if requested and necessary.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public static SymAspectModule GetInstance(
    ModuleDeclaration module,
    bool create
)

Parameters

module
Type: PostSharp.Sdk.CodeModel..::.ModuleDeclaration
A ModuleDeclaration.
create
Type: System..::.Boolean
true if a new SymAspectModule should be returned if it does not exist yet, otherwise false.

Return Value

The SymAspectModule associated with module, or null if create is false and no SymAspectModule has previously been created for module.

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectModule Properties

[image]

PostSharp 2.0 Documentation
SymAspectModule Properties
SymAspectModule Class See Also Send Feedback

The SymAspectModule type exposes the following members.

Properties

 | Name | Description
Public property | AspectClasses | Gets the collection of aspect classes (SymAspectClass) in the current module.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Evolutions | Gets the collection of evolutions (SymEvolutionCollection) in the current module.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


AspectClasses Property

SymAspectModule..::..AspectClasses Property
SymAspectModule Class See Also Send Feedback
Gets the collection of aspect classes (SymAspectClass) in the current module.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectClassCollection AspectClasses { get; }

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


Evolutions Property

SymAspectModule..::..Evolutions Property
SymAspectModule Class See Also Send Feedback
Gets the collection of evolutions (SymEvolutionCollection) in the current module.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymEvolutionCollection Evolutions { get; }

See Also

SymAspectModule Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Class

SymAspectOrigin Class
Members See Also Send Feedback
Represents a location in a source artifact.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SymAspectOrigin

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.WeavingSymbols..::.SymAspectOrigin

See Also

SymAspectOrigin Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Members

[image]

PostSharp 2.0 Documentation
SymAspectOrigin Members
SymAspectOrigin Class Constructors Properties See Also Send Feedback

The SymAspectOrigin type exposes the following members.

Constructors

 | Name | Description
Public method | SymAspectOrigin | Overloaded.

Properties

 | Name | Description
Public property | Column | Gets the column number if available, otherwise null.
Public property | Declaration | Gets the MetadataDeclaration associated to the current SymAspectOrigin, or null if the current object is associated with a file.
Public property | FileName | Gets the full path of the file associated to the current SymAspectOrigin, or null if the current object is associated with a MetadataDeclaration.
Public property | Line | Gets the line number if available, otherwise null.

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Constructor

[image]

PostSharp 2.0 Documentation
SymAspectOrigin Constructor
SymAspectOrigin Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SymAspectOrigin(MetadataDeclaration) | Initializes a new SymAspectOrigin representing a MetadataDeclaration.
Public method | SymAspectOrigin(String, Int32, Int32) | Initializes a new SymAspectOrigin representing a location in a text file.

See Also

SymAspectOrigin Class
SymAspectOrigin Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Constructor (MetadataDeclaration)

SymAspectOrigin Constructor (MetadataDeclaration)
SymAspectOrigin Class See Also Send Feedback
Initializes a new SymAspectOrigin representing a MetadataDeclaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectOrigin(
    MetadataDeclaration declaration
)

Parameters

declaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
A MetadataDeclaration.

See Also

SymAspectOrigin Class
SymAspectOrigin Overload
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Constructor (String, Int32, Int32)

SymAspectOrigin Constructor (String, Int32, Int32)
SymAspectOrigin Class See Also Send Feedback
Initializes a new SymAspectOrigin representing a location in a text file.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectOrigin(
    string fileName,
    int line,
    int column
)

Parameters

fileName
Type: System..::.String
Full path of the text file.
line
Type: System..::.Int32
Line number in the text file.
column
Type: System..::.Int32
Column number in the text file.

See Also

SymAspectOrigin Class
SymAspectOrigin Overload
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectOrigin Properties

[image]

PostSharp 2.0 Documentation
SymAspectOrigin Properties
SymAspectOrigin Class See Also Send Feedback

The SymAspectOrigin type exposes the following members.

Properties

 | Name | Description
Public property | Column | Gets the column number if available, otherwise null.
Public property | Declaration | Gets the MetadataDeclaration associated to the current SymAspectOrigin, or null if the current object is associated with a file.
Public property | FileName | Gets the full path of the file associated to the current SymAspectOrigin, or null if the current object is associated with a MetadataDeclaration.
Public property | Line | Gets the line number if available, otherwise null.

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


Column Property

SymAspectOrigin..::..Column Property
SymAspectOrigin Class See Also Send Feedback
Gets the column number if available, otherwise null.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<int> Column { get; private set; }

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


Declaration Property

SymAspectOrigin..::..Declaration Property
SymAspectOrigin Class See Also Send Feedback
Gets the MetadataDeclaration associated to the current SymAspectOrigin, or null if the current object is associated with a file.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration Declaration { get; private set; }

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


FileName Property

SymAspectOrigin..::..FileName Property
SymAspectOrigin Class See Also Send Feedback
Gets the full path of the file associated to the current SymAspectOrigin, or null if the current object is associated with a MetadataDeclaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string FileName { get; private set; }

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


Line Property

SymAspectOrigin..::..Line Property
SymAspectOrigin Class See Also Send Feedback
Gets the line number if available, otherwise null.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public Nullable<int> Line { get; private set; }

See Also

SymAspectOrigin Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectUsage Class

SymAspectUsage Class
Members See Also Send Feedback
Represents an aspect usage in a symbol document. A SymAspectUsage corresponds to an instance of custom attribute, which in turn can be applied to multiple targets and generate multiple aspect instances (SymAspectInstance).

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SymAspectUsage : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymAspectUsage

See Also

SymAspectUsage Members
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectUsage Members

[image]

PostSharp 2.0 Documentation
SymAspectUsage Members
SymAspectUsage Class Constructors Methods Properties See Also Send Feedback

The SymAspectUsage type exposes the following members.

Constructors

 | Name | Description
Public method | SymAspectUsage | Initializes a new SymAspectUsage.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Instances | Gets the collection of targets to which the current SymAspectInstance is applied.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Origin | Gets the origin of the current SymAspectUsage, i.e. the location where it has been defined.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentClass | Gets the SymAspectClass of which the current SymAspectUsage is an instance.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Title | Gets or sets the human-readable title of the current SymAspectUsage.
Public property | Token | Gets the unique token of the current SymAspectUsage.

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectUsage Constructor

SymAspectUsage Constructor
SymAspectUsage Class See Also Send Feedback
Initializes a new SymAspectUsage.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectUsage(
    SymAspectOrigin origin,
    int token
)

Parameters

origin
Type: PostSharp.Sdk.WeavingSymbols..::.SymAspectOrigin
Origin, specifying how the aspect instance was created.
token
Type: System..::.Int32
A unique aspect instance token.

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectUsage Methods

[image]

PostSharp 2.0 Documentation
SymAspectUsage Methods
SymAspectUsage Class See Also Send Feedback

The SymAspectUsage type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


SymAspectUsage Properties

[image]

PostSharp 2.0 Documentation
SymAspectUsage Properties
SymAspectUsage Class See Also Send Feedback

The SymAspectUsage type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Instances | Gets the collection of targets to which the current SymAspectInstance is applied.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Origin | Gets the origin of the current SymAspectUsage, i.e. the location where it has been defined.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | ParentClass | Gets the SymAspectClass of which the current SymAspectUsage is an instance.
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Title | Gets or sets the human-readable title of the current SymAspectUsage.
Public property | Token | Gets the unique token of the current SymAspectUsage.

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


Instances Property

SymAspectUsage..::..Instances Property
SymAspectUsage Class See Also Send Feedback
Gets the collection of targets to which the current SymAspectInstance is applied.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectInstanceCollection Instances { get; }

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


Origin Property

SymAspectUsage..::..Origin Property
SymAspectUsage Class See Also Send Feedback
Gets the origin of the current SymAspectUsage, i.e. the location where it has been defined.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectOrigin Origin { get; private set; }

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


ParentClass Property

SymAspectUsage..::..ParentClass Property
SymAspectUsage Class See Also Send Feedback
Gets the SymAspectClass of which the current SymAspectUsage is an instance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectClass ParentClass { get; }

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


Title Property

SymAspectUsage..::..Title Property
SymAspectUsage Class See Also Send Feedback
Gets or sets the human-readable title of the current SymAspectUsage.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Title { get; set; }

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


Token Property

SymAspectUsage..::..Token Property
SymAspectUsage Class See Also Send Feedback
Gets the unique token of the current SymAspectUsage.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Token { get; private set; }

See Also

SymAspectUsage Class
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolution Class

SymEvolution Class
Members See Also Send Feedback
Represents an evolution of a metadata element, for instance when a field is transformed into a property, or when a declaration is renamed.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymEvolution : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymEvolution

See Also

SymEvolution Members
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolution Members

[image]

PostSharp 2.0 Documentation
SymEvolution Members
SymEvolution Class Constructors Methods Properties See Also Send Feedback

The SymEvolution type exposes the following members.

Constructors

 | Name | Description
Public method | SymEvolution | Initializes a new SymEvolution.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | SetTarget | Sets the target declaration.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Kind | Gets the kind of evolution.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Source | Gets the identity of the source declaration.
Public property | Target | Gets the identity of the target declaration.

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolution Constructor

SymEvolution Constructor
SymEvolution Class See Also Send Feedback
Initializes a new SymEvolution.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymEvolution(
    MetadataDeclaration source,
    SymEvolutionKind kind
)

Parameters

source
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Original declaration.
kind
Type: PostSharp.Sdk.WeavingSymbols..::.SymEvolutionKind
Kind of evolution.

Remarks

The constructor should be invoked before the transformation, and the method SetTarget(MetadataDeclaration) after the transformation.

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolution Methods

[image]

PostSharp 2.0 Documentation
SymEvolution Methods
SymEvolution Class See Also Send Feedback

The SymEvolution type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Public method | SetTarget | Sets the target declaration.

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


SetTarget Method

SymEvolution..::..SetTarget Method
SymEvolution Class See Also Send Feedback
Sets the target declaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public void SetTarget(
    MetadataDeclaration target
)

Parameters

target
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Target declaration.

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolution Properties

[image]

PostSharp 2.0 Documentation
SymEvolution Properties
SymEvolution Class See Also Send Feedback

The SymEvolution type exposes the following members.

Properties

 | Name | Description
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Kind | Gets the kind of evolution.
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Source | Gets the identity of the source declaration.
Public property | Target | Gets the identity of the target declaration.

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


Kind Property

SymEvolution..::..Kind Property
SymEvolution Class See Also Send Feedback
Gets the kind of evolution.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymEvolutionKind Kind { get; private set; }

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


Source Property

SymEvolution..::..Source Property
SymEvolution Class See Also Send Feedback
Gets the identity of the source declaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Source { get; private set; }

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


Target Property

SymEvolution..::..Target Property
SymEvolution Class See Also Send Feedback
Gets the identity of the target declaration.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Target { get; private set; }

See Also

SymEvolution Class
PostSharp.Sdk.WeavingSymbols Namespace


SymEvolutionKind Enumeration

SymEvolutionKind Enumeration
See Also Send Feedback
Kinds of evolutions represented by SymEvolution.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public enum SymEvolutionKind

Members

Member name | Value | Description
Renamed | 0 | The declaration has been renamed.
Wrapped | 1 | The declaration has been wrapped into another (typically, a field is wrapped into a property).

See Also

PostSharp.Sdk.WeavingSymbols Namespace


SymJoinPoint Class

SymJoinPoint Class
Members See Also Send Feedback
Represents a join point in a symbol document, i.e. the information that a declaration has been advised by another declaration, as a part of transformations provided by a SymAspectInstance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SymJoinPoint : Declaration

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel..::.Element
PostSharp.Sdk.CodeModel..::.Declaration
PostSharp.Sdk.WeavingSymbols..::.SymJoinPoint

See Also

SymJoinPoint Members
PostSharp.Sdk.WeavingSymbols Namespace


SymJoinPoint Members

[image]

PostSharp 2.0 Documentation
SymJoinPoint Members
SymJoinPoint Class Constructors Methods Properties See Also Send Feedback

The SymJoinPoint type exposes the following members.

Constructors

 | Name | Description
Public method | SymJoinPoint | Initializes a new SymJoinPoint.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

Properties

 | Name | Description
Public property | AdvisedDeclaration | Gets the declaration that has been advised.
Public property | AdvisingDeclaration | Gets the declaration (type or method, typically) that provided the transformation.
Public property | AspectInstance | Gets the parent SymAspectInstance.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Description | Gets or sets a human-readable description for the current SymJoinPoint.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Ordinal | Gets the ordinal of the current SymJoinPoint in the set of all advices on the join point.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Semantic | Gets the semantic of AdvisedDeclaration being advised.

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


SymJoinPoint Constructor

SymJoinPoint Constructor
SymJoinPoint Class See Also Send Feedback
Initializes a new SymJoinPoint.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymJoinPoint(
    MetadataDeclaration advisedDeclaration,
    MethodSemantics semantic,
    MetadataDeclaration advisingDeclaration,
    int ordinal
)

Parameters

advisedDeclaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration that has been advised.
semantic
Type: PostSharp.Sdk.CodeModel..::.MethodSemantics
Semantic of advisedDeclaration being advised.
advisingDeclaration
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Declaration (type or method, typically) that provided the transformation.
ordinal
Type: System..::.Int32
Ordinal of the current SymJoinPoint in the set of all advices on the join point.

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


SymJoinPoint Methods

[image]

PostSharp 2.0 Documentation
SymJoinPoint Methods
SymJoinPoint Class See Also Send Feedback

The SymJoinPoint type exposes the following members.

Methods

 | Name | Description
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of the current Element and all its children. (Inherited from Element.)
Protected method | NotifyChildPropertyChanged | Method invoked when a property of a child has been changed. (Inherited from Element.)
Protected method | OnPropertyChanged | Method invoked when a property of the current instance has been changed. (Inherited from Element.)

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


SymJoinPoint Properties

[image]

PostSharp 2.0 Documentation
SymJoinPoint Properties
SymJoinPoint Class See Also Send Feedback

The SymJoinPoint type exposes the following members.

Properties

 | Name | Description
Public property | AdvisedDeclaration | Gets the declaration that has been advised.
Public property | AdvisingDeclaration | Gets the declaration (type or method, typically) that provided the transformation.
Public property | AspectInstance | Gets the parent SymAspectInstance.
Public property | DeclaringAssembly | Gets the declaring assembly. (Inherited from Declaration.)
Public property | Description | Gets or sets a human-readable description for the current SymJoinPoint.
Public property | Domain | Gets the Domain to which the current element belong, or null if the current element is a stand-alone (detached) declaration. (Inherited from Element.)
Public property | Module | Gets the declaring module. (Inherited from Declaration.)
Public property | Ordinal | Gets the ordinal of the current SymJoinPoint in the set of all advices on the join point.
Public property | Parent | Gets the parent Element. (Inherited from Element.)
Public property | Role | Gets the role of the current Element in its parent. (Inherited from Element.)
Public property | Semantic | Gets the semantic of AdvisedDeclaration being advised.

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


AdvisedDeclaration Property

SymJoinPoint..::..AdvisedDeclaration Property
SymJoinPoint Class See Also Send Feedback
Gets the declaration that has been advised.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration AdvisedDeclaration { get; private set; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


AdvisingDeclaration Property

SymJoinPoint..::..AdvisingDeclaration Property
SymJoinPoint Class See Also Send Feedback
Gets the declaration (type or method, typically) that provided the transformation.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MetadataDeclaration AdvisingDeclaration { get; private set; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


AspectInstance Property

SymJoinPoint..::..AspectInstance Property
SymJoinPoint Class See Also Send Feedback
Gets the parent SymAspectInstance.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymAspectInstance AspectInstance { get; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


Description Property

SymJoinPoint..::..Description Property
SymJoinPoint Class See Also Send Feedback
Gets or sets a human-readable description for the current SymJoinPoint.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string Description { get; set; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


Ordinal Property

SymJoinPoint..::..Ordinal Property
SymJoinPoint Class See Also Send Feedback
Gets the ordinal of the current SymJoinPoint in the set of all advices on the join point.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public int Ordinal { get; private set; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


Semantic Property

SymJoinPoint..::..Semantic Property
SymJoinPoint Class See Also Send Feedback
Gets the semantic of AdvisedDeclaration being advised.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public MethodSemantics Semantic { get; private set; }

See Also

SymJoinPoint Class
PostSharp.Sdk.WeavingSymbols Namespace


WriteWeavingSymbolsTask Class

WriteWeavingSymbolsTask Class
Members See Also Send Feedback
Task that writes the symbol file.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class WriteWeavingSymbolsTask : Task

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PostSharp.Sdk.Extensibility..::.Task
PostSharp.Sdk.WeavingSymbols..::.WriteWeavingSymbolsTask

See Also

WriteWeavingSymbolsTask Members
PostSharp.Sdk.WeavingSymbols Namespace


WriteWeavingSymbolsTask Members

[image]

PostSharp 2.0 Documentation
WriteWeavingSymbolsTask Members
WriteWeavingSymbolsTask Class Constructors Methods Properties See Also Send Feedback

The WriteWeavingSymbolsTask type exposes the following members.

Constructors

 | Name | Description
Public method | WriteWeavingSymbolsTask | Initializes a new instance of the WriteWeavingSymbolsTask class

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Inherited from Task.)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TargetFile | Full path of the symbol file.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)
Public property | UseNameTable | Determines whether the a name table should be used.

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


WriteWeavingSymbolsTask Constructor

WriteWeavingSymbolsTask Constructor
WriteWeavingSymbolsTask Class See Also Send Feedback
Initializes a new instance of the WriteWeavingSymbolsTask class

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public WriteWeavingSymbolsTask()

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


WriteWeavingSymbolsTask Methods

[image]

PostSharp 2.0 Documentation
WriteWeavingSymbolsTask Methods
WriteWeavingSymbolsTask Class See Also Send Feedback

The WriteWeavingSymbolsTask type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Deserializes the current task from an XML element. (Inherited from Task.)
Public method | Dispose | Overloaded.
Public method | Execute | Execute the current Task. (Overrides Task..::.Execute()()().)
Protected method | Finalize | Destructor. (Inherited from Task.)
Protected method | Initialize | Initializes the current task. (Inherited from Task.)
Public method | IsRequired | Determines whether the current task is required by another task in the project. (Inherited from Task.)
Protected method | Validate | Determines whether the task configuration (deserialized from the attributes of the XML element representing the task instance) is valid. (Inherited from Task.)

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


Dispose Method

[image]

PostSharp 2.0 Documentation
WriteWeavingSymbolsTask..::..Dispose Method
WriteWeavingSymbolsTask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Task.)
Protected method | Dispose(Boolean) | Disposes the resources hold by the current instance. (Inherited from Task.)

See Also

WriteWeavingSymbolsTask Class
WriteWeavingSymbolsTask Members
PostSharp.Sdk.WeavingSymbols Namespace


Execute Method

WriteWeavingSymbolsTask..::..Execute Method
WriteWeavingSymbolsTask Class See Also Send Feedback
Execute the current Task.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public override bool Execute()

Return Value

true if the execution was successful, otherwise false.

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


WriteWeavingSymbolsTask Properties

[image]

PostSharp 2.0 Documentation
WriteWeavingSymbolsTask Properties
WriteWeavingSymbolsTask Class See Also Send Feedback

The WriteWeavingSymbolsTask type exposes the following members.

Properties

 | Name | Description
Public property | Disabled | Determines whether this task is disabled. (Inherited from Task.)
Public property | ImplicitlyRequired | Indicates that this task was implicitly required by another task. (Inherited from Task.)
Public property | Project | Gets the Project to which the current task belongs. (Inherited from Task.)
Public property | State | Gets the state of the current task. (Inherited from Task.)
Public property | TargetFile | Full path of the symbol file.
Public property | TaskName | Gets the task name. (Inherited from Task.)
Public property | TaskType | Gets the task type configuration. (Inherited from Task.)
Public property | UseNameTable | Determines whether the a name table should be used.

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


TargetFile Property

WriteWeavingSymbolsTask..::..TargetFile Property
WriteWeavingSymbolsTask Class See Also Send Feedback
Full path of the symbol file.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public string TargetFile { get; set; }

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


UseNameTable Property

WriteWeavingSymbolsTask..::..UseNameTable Property
WriteWeavingSymbolsTask Class See Also Send Feedback
Determines whether the a name table should be used.

Namespace: PostSharp.Sdk.WeavingSymbols
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public bool UseNameTable { get; set; }

See Also

WriteWeavingSymbolsTask Class
PostSharp.Sdk.WeavingSymbols Namespace


PostSharp.Sdk.WeavingSymbols.Collections Namespace

PostSharp.Sdk.WeavingSymbols.Collections Namespace
Send Feedback

[Missing <summary> documentation for "N:PostSharp.Sdk.WeavingSymbols.Collections"]

Classes

 | Class | Description
Public class | SymAspectClassCollection | Collection of SymAspectClass items.
Public class | SymAspectInstanceCollection | Collection of aspect instances (SymAspectInstance).
Public class | SymAspectUsageCollection | Collection of aspect usages (SymAspectUsage).
Public class | SymEvolutionCollection | Collection of evolutions (SymEvolution).
Public class | SymJoinPointCollection | Collection of join points (SymJoinPoint).


SymAspectClassCollection Class

SymAspectClassCollection Class
Members See Also Send Feedback
Collection of SymAspectClass items.

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymAspectClassCollection : ElementCollection<SymAspectClass>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' SymAspectClass >)>)>
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectClassCollection

See Also

SymAspectClassCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectClassCollection Members

[image]

PostSharp 2.0 Documentation
SymAspectClassCollection Members
SymAspectClassCollection Class Methods Properties See Also Send Feedback

The SymAspectClassCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectClassCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectClassCollection Methods

[image]

PostSharp 2.0 Documentation
SymAspectClassCollection Methods
SymAspectClassCollection Class See Also Send Feedback

The SymAspectClassCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectClassCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectClassCollection Properties

[image]

PostSharp 2.0 Documentation
SymAspectClassCollection Properties
SymAspectClassCollection Class See Also Send Feedback

The SymAspectClassCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectClassCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectInstanceCollection Class

SymAspectInstanceCollection Class
Members See Also Send Feedback
Collection of aspect instances (SymAspectInstance).

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymAspectInstanceCollection : ElementCollection<SymAspectInstance>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' SymAspectInstance >)>)>
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectInstanceCollection

See Also

SymAspectInstanceCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectInstanceCollection Members

[image]

PostSharp 2.0 Documentation
SymAspectInstanceCollection Members
SymAspectInstanceCollection Class Methods Properties See Also Send Feedback

The SymAspectInstanceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectInstanceCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectInstanceCollection Methods

[image]

PostSharp 2.0 Documentation
SymAspectInstanceCollection Methods
SymAspectInstanceCollection Class See Also Send Feedback

The SymAspectInstanceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectInstanceCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectInstanceCollection Properties

[image]

PostSharp 2.0 Documentation
SymAspectInstanceCollection Properties
SymAspectInstanceCollection Class See Also Send Feedback

The SymAspectInstanceCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectInstanceCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectUsageCollection Class

SymAspectUsageCollection Class
Members See Also Send Feedback
Collection of aspect usages (SymAspectUsage).

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public class SymAspectUsageCollection : ElementCollection<SymAspectUsage>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' SymAspectUsage >)>)>
PostSharp.Sdk.WeavingSymbols.Collections..::.SymAspectUsageCollection

See Also

SymAspectUsageCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectUsageCollection Members

[image]

PostSharp 2.0 Documentation
SymAspectUsageCollection Members
SymAspectUsageCollection Class Methods Properties See Also Send Feedback

The SymAspectUsageCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectUsageCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectUsageCollection Methods

[image]

PostSharp 2.0 Documentation
SymAspectUsageCollection Methods
SymAspectUsageCollection Class See Also Send Feedback

The SymAspectUsageCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | DoLazyLoading | Loads the content of the collection. (Overrides ElementCollection<(Of <(?0>)>)..::.DoLazyLoading()()().)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemAdding | Called before adding an item to the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected method | OnItemRemoved | Called before removing an item from the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectUsageCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


DoLazyLoading Method

SymAspectUsageCollection..::..DoLazyLoading Method
SymAspectUsageCollection Class See Also Send Feedback
Loads the content of the collection.

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override void DoLazyLoading()

See Also

SymAspectUsageCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymAspectUsageCollection Properties

[image]

PostSharp 2.0 Documentation
SymAspectUsageCollection Properties
SymAspectUsageCollection Class See Also Send Feedback

The SymAspectUsageCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Protected property | IsLazyLoadingSupported | Determines if the current collection supports lazy loading. (Overrides ElementCollection<(Of <(?0>)>)..::.IsLazyLoadingSupported.)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymAspectUsageCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


IsLazyLoadingSupported Property

SymAspectUsageCollection..::..IsLazyLoadingSupported Property
SymAspectUsageCollection Class See Also Send Feedback
Determines if the current collection supports lazy loading.

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
protected override bool IsLazyLoadingSupported { get; }

Remarks

If a collection supports lazy loading, the method DoLazyLoading()()() should be implemented; it will be called before any access to the collection.

This property is evaluated before the collection constructor is invoked. Therefore, it is considered as static for the collection class.

See Also

SymAspectUsageCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymEvolutionCollection Class

SymEvolutionCollection Class
Members See Also Send Feedback
Collection of evolutions (SymEvolution).

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymEvolutionCollection : ElementCollection<SymEvolution>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' SymEvolution >)>)>
PostSharp.Sdk.WeavingSymbols.Collections..::.SymEvolutionCollection

See Also

SymEvolutionCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymEvolutionCollection Members

[image]

PostSharp 2.0 Documentation
SymEvolutionCollection Members
SymEvolutionCollection Class Methods Properties See Also Send Feedback

The SymEvolutionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymEvolutionCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymEvolutionCollection Methods

[image]

PostSharp 2.0 Documentation
SymEvolutionCollection Methods
SymEvolutionCollection Class See Also Send Feedback

The SymEvolutionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymEvolutionCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


Add Method

[image]

PostSharp 2.0 Documentation
SymEvolutionCollection..::..Add Method
SymEvolutionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(?0) | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Add(MetadataDeclaration, SymEvolutionKind) | Adds a SymEvolution to the current collection.
Public method | Add(MetadataDeclaration, SymEvolutionKind, MetadataDeclaration) | Adds a SymEvolution to the current collection and specifies a target.

See Also

SymEvolutionCollection Class
SymEvolutionCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


Add Method (MetadataDeclaration, SymEvolutionKind)

SymEvolutionCollection..::..Add Method (MetadataDeclaration, SymEvolutionKind)
SymEvolutionCollection Class See Also Send Feedback
Adds a SymEvolution to the current collection.

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymEvolution Add(
    MetadataDeclaration source,
    SymEvolutionKind kind
)

Parameters

source
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Source declaration.
kind
Type: PostSharp.Sdk.WeavingSymbols..::.SymEvolutionKind
Kind of evolution.

Return Value

The newly created SymEvolution.

Remarks

The caller is expected to invoke SetTarget(MetadataDeclaration) after the transformation is completed.

See Also

SymEvolutionCollection Class
Add Overload
PostSharp.Sdk.WeavingSymbols.Collections Namespace


Add Method (MetadataDeclaration, SymEvolutionKind, MetadataDeclaration)

SymEvolutionCollection..::..Add Method (MetadataDeclaration, SymEvolutionKind, MetadataDeclaration)
SymEvolutionCollection Class See Also Send Feedback
Adds a SymEvolution to the current collection and specifies a target.

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public SymEvolution Add(
    MetadataDeclaration source,
    SymEvolutionKind kind,
    MetadataDeclaration target
)

Parameters

source
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Source declaration.
kind
Type: PostSharp.Sdk.WeavingSymbols..::.SymEvolutionKind
Kind of evolution.
target
Type: PostSharp.Sdk.CodeModel..::.MetadataDeclaration
Target declaration.

Return Value

The newly created SymEvolution.

See Also

SymEvolutionCollection Class
Add Overload
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymEvolutionCollection Properties

[image]

PostSharp 2.0 Documentation
SymEvolutionCollection Properties
SymEvolutionCollection Class See Also Send Feedback

The SymEvolutionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymEvolutionCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymJoinPointCollection Class

SymJoinPointCollection Class
Members See Also Send Feedback
Collection of join points (SymJoinPoint).

Namespace: PostSharp.Sdk.WeavingSymbols.Collections
Assembly: PostSharp.Sdk (in PostSharp.Sdk.dll) Version: 2.0.0.0 (2.0.7.1251)

Syntax

C#
public sealed class SymJoinPointCollection : ElementCollection<SymJoinPoint>

Inheritance Hierarchy

System..::.Object
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection
PostSharp.Sdk.CodeModel.Collections..::.ElementCollection <(Of <(<' SymJoinPoint >)>)>
PostSharp.Sdk.WeavingSymbols.Collections..::.SymJoinPointCollection

See Also

SymJoinPointCollection Members
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymJoinPointCollection Members

[image]

PostSharp 2.0 Documentation
SymJoinPointCollection Members
SymJoinPointCollection Class Methods Properties See Also Send Feedback

The SymJoinPointCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymJoinPointCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymJoinPointCollection Methods

[image]

PostSharp 2.0 Documentation
SymJoinPointCollection Methods
SymJoinPointCollection Class See Also Send Feedback

The SymJoinPointCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRange | Adds a collection of items to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | AddRangeCloned | Adds clones of items of a given collection to the current collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ClearCache | Clear the cache (typically mapping to System.Reflection or, if the current element is a reference, to the related definition) of all items of this collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Contains | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | CopyTo | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Dispose | Disposes the resources held by the current instance. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | EnsureCapacity | Allocates additional capacity in the collection. (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | GetEnumerator | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | Remove | (Inherited from ElementCollection<(Of <(?0>)>).)
Public method | ToArray | Converts the current collection into a typed array. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymJoinPointCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


SymJoinPointCollection Properties

[image]

PostSharp 2.0 Documentation
SymJoinPointCollection Properties
SymJoinPointCollection Class See Also Send Feedback

The SymJoinPointCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsDisposed | Determines whether the current collection has been disposed. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Owner | Gets the owner Element. (Inherited from ElementCollection<(Of <(?0>)>).)
Public property | Role | Gets the role of the current collection in the owner element. (Inherited from ElementCollection<(Of <(?0>)>).)

See Also

SymJoinPointCollection Class
PostSharp.Sdk.WeavingSymbols.Collections Namespace


Class Reference

Class Reference
Send Feedback
PostSharp is a build-time aspect weaver for Microsoft .NET.

Namespaces

Namespace | Description
PostSharp | The PostSharp namespace is the root namespace of PostSharp.
PostSharp.Aspects | The PostSharp.Aspects namespace provides the primitives of the PostSharp aspect-oriented framework, such as abstract aspect classes, aspect interfaces, and advise argument classes.
PostSharp.Aspects.Advices | The PostSharp.Aspects.Advices provides custom attributes that allow developing composite aspects with advices and pointcuts.
PostSharp.Aspects.Configuration | The PostSharp.Aspects.Configuration namespace contains classes and custom attributes configuring the aspects of the PostSharp.Aspects namespace.
PostSharp.Aspects.Dependencies | The PostSharp.Aspects.Dependencies namespace contains types and custom attributes that allow to define dependencies between aspects and advices, so that the aspect weaver behaves determistically even if the same element of code is the target of several aspects provided by multiple vendors.
PostSharp.Aspects.Serialization | The PostSharp.Aspects.Serialization namespace contains types taking care of the process of serializing aspects at build time and deserializing them at run time.
PostSharp.Extensibility | The PostSharp.Extensibility namespace defines the semantics of the attribute multicasting mechanism and exposes other types that allow user code to interact with the PostSharp,platform.
PostSharp.Hosting | The PostSharp.Hosting namespace contains the types that allow third-party code to host PostSharp, i.e. to initiate a post-compilation process.
PostSharp.MSBuild | The PostSharp.MSBuild namespace contains the MSBuild tasks for PostSharp.
PostSharp.Reflection | The PostSharp.Reflection namespace complements the System.Reflection namespace.
PostSharp.Reflection.GenericArgs | The PostSharp.Reflection.GenericArgs namespace contains classes that can be used instead of unbound generic type arguments.
PostSharp.Sdk | The PostSharp.Sdk namespace contains types that allow to extend PostSharp using low-level APIes.
PostSharp.Sdk.AspectInfrastructure | The PostSharp.Sdk.AspectInfrastructure namespace defines and implements an infrastructure that can be shared by all aspect frameworks. It makes minimal assumptions on the semantics of aspect frameworks (such as PostSharp.Aspects) that can be built on the top of it. The aspect infrastructure does not itself have a notion of aspect, advice or point cut; instead, it has a notion of transformation, transformation pipeline, and defines a framework to resolve dependencies between transformations.
PostSharp.Sdk.AspectInfrastructure.Dependencies | The PostSharp.Sdk.AspectInfrastructure.Dependencies namespace contains specific implementations of aspect dependencies.
PostSharp.Sdk.AspectInfrastructure.Events | The PostSharp.Sdk.AspectInfrastructure.Events namespace exposes the events raised by the aspect infrastructure.
PostSharp.Sdk.AspectWeaver | The PostSharp.Sdk.AspectWeaver namespace is an abstract implementation of the aspect framework defined in PostSharp.Aspects. The aspect framework defines the concepts of aspect, advice, and pointcut.
PostSharp.Sdk.AspectWeaver.AspectWeavers | The PostSharp.Sdk.AspectWeaver.AspectWeavers namespace provides specific implementations of the T:PostSharp.Sdk.AspectWeaver.AspectWeaver class from which user aspect weavers can be derived.
PostSharp.Sdk.AspectWeaver.Dependencies | The PostSharp.Sdk.AspectWeaver.AdviceWeavers namespace contains specific implementations of aspect dependencies.
PostSharp.Sdk.AspectWeaver.Transformations | The PostSharp.Sdk.AspectWeaver.Transformations namespace provides classes from which user-defined transformations can be derived.
PostSharp.Sdk.CodeModel | The PostSharp.Sdk.CodeModel namespace contains types that constitute the PostSharp's internal representation of an assembly.
PostSharp.Sdk.CodeModel.Binding | The PostSharp.Sdk.CodeModel.Binding namespace contains comparer classes several kinds of declarations.
PostSharp.Sdk.CodeModel.Collections | The PostSharp.Sdk.CodeModel.Collections namespaces contains collections of objects of the PostSharp.Sdk.CodeModel namespace.
PostSharp.Sdk.CodeModel.Helpers | The PostSharp.Sdk.CodeModel.Helpers namespace contains utility classes to make work with the PostSharp.Sdk.CodeModel easier.
PostSharp.Sdk.CodeModel.MarshalTypes | The PostSharp.Sdk.CodeModel.MarshalTypes namespace defines classes representing P-Invoke types.
PostSharp.Sdk.CodeModel.ReflectionWrapper | The PostSharp.Sdk.CodeModel.ReflectionWrapper namespace contains implementations of abstract types from System.Reflection (such as Type, MethodInfo, FieldInfo, ...) that wrap the PostSharp's internal representation of the assembly.
PostSharp.Sdk.CodeModel.SerializationTypes | The PostSharp.Sdk.CodeModel.SerializationTypes namespace contains classes that represent serialization types, i.e. types used to represent the value of custom attributes or security descriptors.
PostSharp.Sdk.CodeModel.TypeSignatures | The PostSharp.Sdk.CodeModel.TypeSignatures namespace contains classes that implement T:PostSharp.Sdk.CodeModel.ITypeSignature and can be used as, or as parts of, a type signature.
PostSharp.Sdk.CodeWeaver | The PostSharp.Sdk.CodeWeaver namespace implements a low-level instruction weaver, able to modify the flow of MSIL instructions.
PostSharp.Sdk.Collections | The PostSharp.Sdk.Collections defines abstract collection types.
PostSharp.Sdk.Extensibility | The PostSharp.Sdk.Extensibility namespace implements the platform infrastructure, i.e. the system of configuration, projects, and tasks.
PostSharp.Sdk.Extensibility.Configuration | The PostSharp.Sdk.Extensibility.Configuration namespace contains classes representing the XML configuration files.
PostSharp.Sdk.Extensibility.Licensing | The PostSharp.Sdk.Extensibility.Licensing namespace contains, well, the licensing subsystem of PostSharp, and you should probably not look at it unless you have criminal intentions or need to initialize the licensing system.
PostSharp.Sdk.Extensibility.Tasks | The PostSharp.Sdk.Extensibility.Tasks namespace contains the basic tasks composing a typical PostSharp build process.
PostSharp.Sdk.User | The PostSharp.Sdk.User namespace contains classes that implement user interaction and CEIP.
PostSharp.Sdk.Utilities | The PostSharp.Sdk.Utilities namespace contains various utility classes.
PostSharp.Sdk.WeavingSymbols |
PostSharp.Sdk.WeavingSymbols.Collections |